Show: Total No of Items:


WebZIP Tasks

Task Report:
Category:
Title:

Show: Items per page Total No of Items:
Status | Title | URL | File Type | Size | Last Modified | Download Result | Level | Referrer

© 2000 Spidersoft. All rights reserved.


Status,Title,URL,LocalFile,FileType,Size,LastModified,DownloadResult,Level,Referrer


WebZIP Task Summary

Last Run: |
Next Run: |
Total Files: |
Size: | bytes
Status: |
Pages
/ 		Media
/ 		Errors
/
Category:
Title:
URL:
Local URL:
Save-to Folder:

Download Method

The following file types will be downloaded:
.

Pages will be downloaded from: .
Media files will be downloaded from:
WebZIP will download pages deep from the start page.

© 2000 Spidersoft. All rights reserved.


TaskName,Category,StartPage,Title,URL,URLs,Description,Keywords,Status,Schedule,LastRun,NextRun,TotalBytes,TotalFiles,PagesDownloaded,PagesDownloadedPct,PagesQueued,PagesQueuedPct,PagesError,PagesErrorPct,PagesTotal,MediaDownloaded,MediaDownloadedPct,MediaQueued,MediaQueuedPct,MediaError,MediaErrorPct,MediaTotal,ErrorsTotal,LocalURL,Destination,ProfileName,FileTypes,PageLocation,MediaLocation,Depth,URLFilterInclude,URLFilterExclude,ConvertFollowedLinks,ConvertUnfollowedLinks,AggressiveParser
"Useful Mathematics","Programming\","C:\Program Files\WebZIP\Tasks\Programming\Useful Mathematics.wzt","Useful Mathematics","http://www.org2.com/jaap/puzzles/theory.htm","","","","Incomplete","","12/30/01 5:15:51 AM","","3170116","2035","312","85","47","13","9","2","368","168","10","1345","81","154","9","1667","163","D:\Useful Mathematics\www.org2.com\jaap\puzzles\theory.htm","D:\Useful Mathematics\","","All","0","2","-1","","","1","3"


Jaap's Puzzle Page

UPDATED 04/11/2001. Added the complete reproduction of David Singmasters Cubic Circular magazine. New Saturn, Gripple, and Ufo pages, as well as Computer Puzzling page. Added JavaScripts for Orbix, Port to Port, Triple Cross, and Instant Insanity. Added Burnside's Lemma to the Maths page. New solution to Magic Master Edition. Updated Topspin. Lights Out extended and revised.
UPDATED 30/07/2001. Added page about Instant Insanity. Also updated several texts slightly.
UPDATED 06/05/2001. Added BackSpin puzzle. Added JavaScript Rubik's Rings and 2x2x2 cube. Updated Rubik's Magic, Equator. Improved Square1 solver.
* = JavaScript simulation available
Rubik's Cube family:
Other moving piece puzzles:
Other interesting puzzles:

Tetrahedral:

  • Beachball
  • Diamond
  • Pyraminx / Tetraminx/ Meier-Halpern Pyramid
  • Skewb
  • Ultimate Skewb

Cubical / Octahedral:

  • Barrel/Octagon
  • Pocket Cube (2x2x2) * UPDATED
  • Rubik's Cube (3x3x3)
  • Rubik's Revenge (4x4x4)
  • Professor's Cube (5x5x5)
  • Octahedron
  • Pyramorphix

Dodecahedral / Icosahedral:

  • Alexander's Star
  • Dogic
  • Impossiball
  • Megaminx

Dihedral:

  • Domino
  • Masterball *

* = JavaScript simulation available
  • Bandaged Pyraminx
  • Bicube (Bandaged Cube)
  • Square One UPDATED
  • Billiards 9-ball puzzle *
  • 14-15 Puzzle *
  • Babylon Tower
  • Massage Ball *
  • Missing link *
  • Whip-It / 6 by 6 *
  • BackSpin / Loophole NEW
  • Brain ball *
  • Equator / Hungarian Globe UPDATED
  • Rubik's Fifteen
  • Gripple * NEW
  • It (Tsukuda's Square) *
  • Mozaika
  • Nintendo Billion Barrel *
  • Orb (Orb-It)
  • Port to Port * / Triple Cross * UPDATED
  • (Hockey) Puck
  • Roundy
  • Rubik's Rings * UPDATED
  • Saturn * NEW
  • Siamese Cubes
  • Topspin / No. Crunch * UPDATED
  • Rubik's Triamid
  • Tricky Disky
  • Turn'Push
  • Turnstile *
  • Ufo NEW
  • Rubik's Clock *
  • Rubik's Dice
  • Instant Insanity * NEW
  • Lights Out * UPDATED
  • Rubik's Magic / Master Edition / Create the Cube UPDATED
  • Orbix * UPDATED
  • Rubik's Maze
  • Spinout* / The Brain / Chinese Rings
  • Tantrix
  • Tower of Hanoi *

Further articles:

  • Computer Puzzling NEW
  • Cubic Circular NEW
  • Simple Ideas for further puzzles
  • Useful Mathematics UPDATED
  • Links Page
  • Guest Book

I have quite a large collection of puzzles (sequential movement puzzles), and have worked out solutions for all of them. Having typed out all those solutions, it seems logical to place them on the web, especially since for many of the lesser known puzzles there are no solutions on the internet, or the ones that exist are not easy to do. My solutions may not necessarily be better or easier, but I hope that they will be of use to some people out there. I have tried to make all the text understandable even if there were no pictures, so people with text browsers can also use the pages.

If you have any similar puzzles for sale that are not listed here, or have any comments about this site, please contact me at jaap@org2.com.

Hendrik Haak has very kindly given me permission to use his pictures of these puzzles. You can see these and many others at Hendrik Haaks' Puzzle Shop and Museum. Some other pictures are by Uwe Meffert, the man who invented the Pyraminx, and who manufactures and sells many excellent puzzles.

Home
Links
Guestbook

These pages are written by Jaap Scherphuis, © Copyright 1999-2001.
Some of these puzzles may be trademarked. This page is not derived from, associated with, or endorsed by the holders of such trademarks.
Send any comments or suggestions to jaap@org2.com.


Alexander's Star

Picture kindly supplied by Hendrik Haak

This puzzle is in the shape of a great dodecahedron, which is one of the Kepler-Poinsot polyhedra. As a puzzle it has 12 vertices which are the axes of rotation. There are 30 moving pieces which have two colours each. Each piece forms the edge between two vertices, and five such edges join at each vertex. The great dodecahedron has 12 pentagonal faces, but as these go through the interior of the solid, only part of each pentagon is visible from the outside. The visible part of a pentagon consists of a ring of five triangles. Each ring must be all of one colour, and rings on opposite sides of the puzzle must be the same colour.

This puzzle is equivalent to just the edges of the megaminx. There is however one minor difficulty with the star because only six colours are used and therefore each colour combination occurs twice.

It is not terribly difficult to solve, but this puzzle is infamously hard to twist. It was invented by Adam Alexander, a US mathematician.

The number of positions:
There are 30 pieces, with 2 orientations each, giving a maximum of 30!·230 positions. This limit is not reached because:

  • only even permutations of pieces are possible (2)
  • only and even number of flipped pieces are possible (2)
  • there are 15 pairs of indistinguishable pieces (215/2 since even number of swaps)
  • the orientation of the puzzle does not matter (60)
This leaves 29!·213 = 72,431,714,252,715,638,411,621,302,272,000,000 or 7.2·1034 positions. There are however 12 solved positions because there are 24 ways of arranging 5 colours around a star if you discount rotations, and two of those occur in each solution.

This puzzle is related to the Megaminx, as it is equivalent to solving only the edges of that puzzle.

Links to other useful pages:
Dennis Palaganas' page has a short solution.

Notation:
Let F, R, D be three adjacent vertices (Front, Right and Down), in other words, F, R, D are arranged clockwise at the vertices of a triangle of edges. Let U (Up) be the other vertex adjacent to both F and R, and let L (Left) be the other vertex adjacent to F and D. Clockwise 1/5 twists of a vertex are denoted by the appropriate letter, anti-clockwise 1/5 twists by F', R', L', D' or U'. In the solution below, the D vertex is usually still unsolved.

Solution:

  1. Solve everything except the five pieces around one last vertex.
    For this only two sequences are necessary. Suppose we want to place the correct piece between the F and R vertices. First find the piece on the puzzle (remember there are two possible pieces). Use any moves that don't destroy solved parts of the puzzle to place the piece somewhere on the D vertex. Then twist D and use one of the following sequences:
    DF->FR: R'D R
    DR->RF: F D'F'
    Make sure you use the correct one, otherwise the piece is put in upside down. If a piece is upside down in position, simply use either sequence to displace it and then place it correctly. These sequences only disturb the D vertex edges and the FR edge but nothing else.
  2. Position the edges of the final vertex.
    Rotate D to place as many edges as possible in their correct places. You might find that the edges are in an odd permutation. In this case you will have to swap any two identical pieces elsewhere on the puzzle and try solving it again.
    In this and the next phase, the vertices adjacent to D are in clockwise order: L, F, R, b, B.
    Hold the puzzle so that you can use one of the following:
    DR->DF->DL->DR: R  D   R'  D   R D'D' R'
    DR->DL->DF->DR: R  DD  R'  D'  R  D'  R'
    DR->DF->DB->DR: R  D   R'  DD  R  DD  R'
    DR->DB->DF->DR: R D'D' R' D'D' R  D'  R'
    DR-DB, DF-DL: R  D   R'  D   R  D'  R' DD  R  DD  R'
  3. Orient the edges of the final vertex.
    The edges are flipped in pairs. It is impossible to have only one edge upside down. Two similar sequences are used for this. Hold the puzzle so that the unsolved vertex is D, one edge to be flipped is DR, and the other is either at DL or DF:
    Flip DF, DR: R D' F D  F' D R' D'
    Flip DL, DR: R D' F DD F' D R' D'D'
    Repeat this if necessary.

Home
Links
Guestbook


Backspin / Loophole

The Backspin puzzle is by Binary Arts, but is also sold as Loophole under their XEX brandname. The body of the puzzle is a large circular disk, the two sides of which can rotate with respect to each other. Each side has areas in which balls of several colors can move about. There are three areas which run radially like spokes of a wheel from the edge to near the centre, and between them three curved areas along the disk edge. All these areas can hold at most three balls, so there is room for 6·3=18 balls on each side, or 36 balls in total. One ball is missing, creating a hole to which adjacent balls can be moved. A ball can move from one side of the disk to the other if the sides are rotated so that the hole and the ball are one in front of the other. Note that it is possible for a ball to move from a curved area to the outer position in a spoke on the other side, and vice versa.

Each area has a colour, and the aim is to place each coloured ball into the area of that same colour. The missing ball is from one of the curved areas. There are actually only 9 colours, not 12, since the colours of the spoke areas on one side are the same as the colours of the curved areas on the other, but this does not make it very much easier to solve.

Links to other useful pages:
Binary Arts homepage. Homepage of the manufacturer.

The number of positions:
I will not consider rotations of the sides as essentially different positions. There are 35 balls and a hole, which can be positioned in at most 36! ways. This upper limit is not reached because:

  • There are 6 identical balls of three of the colours. (6!3)
  • There are 3 identical balls of five of the colours. (3!5)
  • There are 2 identical balls of one of the colours. (2)
This leaves 36!/6!3/3!5/2 = 64,084,265,679,291,581,935,411,200,000 or about 6.4·1028 positions.

Solution:
This puzzle is not very hard to solve, once you do it in the correct order. I will not describe the solution in extreme detail, as that would only be confusing. The solution below is already difficult enough to put into words.

Phase 1: Solve the innermost balls.
Suppose for a moment that the hole lies in one of the straight 'spoke' areas, and the two sides are rotated so they lined up. If you look from the side, the hole and the five balls near it form a standard 2 by 3 rectangular sliding piece puzzle. Therefore, if you can solve a regular sliding tile puzzle (14/15 puzzle) then you should also be able solve the inner two balls of all the spokes with little trouble.

    You can solve all the innermost balls of the spokes as follows:
  1. Choose one of the innermost positions which does not yet have the correct ball in it.
  2. Find a ball that belongs at that position, i.e. any one of the correct colour.
  3. Move the ball into one of the spoke areas on the other side of the position you are solving, if it isn't already in such an area.
  4. Move the hole also into one of the two areas.
  5. Rotate the disks to bring the two areas containing the ball, its destination, and the hole together.
  6. Rearrange it so that the ball goes to the correct position.

    7. After solving all the innermost balls, they need not be disturbed at all when you then solve the middle balls of the spokes in the same manner.
Phase 2: Solve the outermost balls.
In this phase all remaining balls are solved, which are those in the curved areas, and ther outermost ones in the spokes. These all lie on a circle.
  1. Find out which colour ball belongs in the position where the hole is now. If there is a ball of that colour on the other side which is incorrectly positioned, then turn that side to bring it next to the hole and push it through into the correct position. Repeat this as often as possible.
  2. If in the previous step you cannot find an incorrectly positioned ball of the colour you want, then you would have to push through some other one. Below is a list of balls in order of preference:
    1. An incorrectly placed ball of the right colour (as mentioned in step a)
    2. An incorrectly placed ball of the wrong colour, but which belongs somewhere else on the side it is currently on.
    3. A correctly placed ball of the right colour.
    4. An incorrectly placed ball of the wrong colour, but which belongs somewhere else on the side that the hole is currently on.
    5. A correctly placed ball of the wrong colour.

Home
Links
Guestbook


Bicube / Bandaged Rubik's Cube

Picture kindly supplied by Uwe Meffert

The Bicube puzzle can be made from a standard Rubik's Cube by gluing pieces together. Seven of the corner pieces are glued to edges to make seven 2x1x1 movable pieces. The five remaining edges are glued to the face centres; one glued to two adjacent centres, and the others are glued one on each face.

Full description
Notation
Solution 1 (fast)
Solution 2 (for memorisation)
Mathematical diversion
Pretty patterns

Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He produces and sells many puzzles, including this one.

Full Description

The glued pieces make this puzzle very difficult because moves are very often blocked. It is a little like the Square One puzzle, in that the possible positions do not mathematically form a group. Nearly all other moving piece puzzles do form groups because they are in effect (isomorphic to subgroups of) permutation groups, usually generated by the simplest possible moves. On this puzzle not every move is possible at every moment so the face turns cannot be considered generators of a group.

From a computer search I found the following:
 | Configurations | Positions
0 | 1 | 1
1 | 9 | 9
2 | 24 | 24
3 | 54 | 54
4 | 83 | 102
5 | 91 | 168
6 | 64 | 296
7 | 58 | 583
8 | 28 | 996
9 | 16 | 1,817
10 | 6 | 3,196
11 | 3 | 5,739
12 | 3 | 9,785
13 |  | 17,075
14 |  | 29,279
15 |  | 48,552
16 |  | 77,828
17 |  | 115,384
18 |  | 155,444
19 |  | 179,617
20 |  | 172,952
21 |  | 133,159
22 |  | 82,486
23 |  | 43,199
24 |  | 19,613
25 |  | 7,781
26 |  | 2,833
27 |  | 747
28 |  | 81
Total | 440 | 1,108,800

There are 440 configurations, i.e. there are 440 positions if the colours of the pieces are ignored, and it takes at most 12 moves to get to the same configuration as the solved position (i.e. free corner at UFR, face centre edges at UL, RB, FD, LD). Once in this configuration only the seven glued pieces need to be swapped about in order to solve it.

Once in a given configuration, the positions in such a configuration do form a (permutation) group. It is generated by the application of move sequences that return the puzzle to the same configuration. It turns out that only even permutations of the glued corner/edge pieces can occur. The reason is quite subtle: Note that for a face to move, it must contain the unglued corner piece. Any sequence of moves that permutes the pieces, bringing them back to the same configuration must have an even number of quarter face turns to bring the free corner back to its original position, and therefore must be an even permutation on the seven glued corner pieces.

The number of positions:
There are 440 configurations, and in each of these the 7 glued pieces can have any even permutation. Therefore there are 440·7!/2 = 1,108,800 positions.

Notation:
The same notation is used as for the Rubik's cube. The letters U, D, L, R, F, B are used to denote the faces of the cube. The letters also denote a clockwise quarter turn of that face. A letter followed by a 2 or an apostrophe denotes a half turn and an anti-clockwise quarter turn respectively. A combination of letters can be used to denote a particular piece position on the cube, e.g. URF means the corner contained in the three adjacent faces U, R, and F.

Unlike the Rubik's Cube, this puzzle has a fixed orientation, i.e. it matters which way up you hold it. First find the edge piece that is glued to two face centres, and hold the puzzle so it is in the DB position. Now find out the colours of the unglued corner, wherever it is on the puzzle. If the colours match those of the F, U and R face centres then you are holding the puzzle correctly for the solutions below to work. If they match the F, U and L face centres then turn the puzzle over so that the the F and U faces swap places. If neither of the two cases above holds, then you have a puzzle that is glued differently, and the solutions below will not help you much.

In the solved position the U face edge is at UL, the R face edge is at RB, the F face edge is at FD, and the L face edge is at LD.

Solution 1:
This solution is mostly just a list of move sequences, one sequence for each possible way each piece needs to move. It is therefore not really suitable for memorisation, but it is relatively fast.
Before starting this solution you must understand the notation and make sure you are holding the puzzle as outlined there.

Phase 1: Bring the puzzle into the right configuration

    This is quite a complicated process, but the following steps will do this in a fairly direct manner.
  1. Use any moves to bring the free corner to the UFR position, though its orientation need not be correct.
  2. If the L edge is at LF then try doing U2 L U'. There are two cases where this does not work, and those can be brought to the initial configuration by doing either U'R' or R U followed by ULFU'F'U'.
  3. If the L edge is at LU then try doing F2 L' F. There are two cases where this does not work, and those can be brought to the initial configuration by doing either R F' or F R followed by F2 L'FUFU L'UR'.
  4. If the L edge is at LB then the following steps will twist it to LD:
    1. If the R edge is at RU then do either R U or F R.
    2. If the R edge is at RF then do either U'R' or R'F'.
    3. If the U edge is at UF then do U F.
    4. The L edge can now be usually be corrected by either UL'U2 or F2L'F.
    There is only case in which neither work, and that can be brought to the initial configuration by doing R'F'UF'L'U'.
  5. Now the U, R, and F edges can be put at UL, RB, FD by using the sequences U'R', R'F', F'U' and their inverses R U, F R and U F. This is quite easy since each sequence turns two adjacent faces in the same direction. First move any edges that are adjacent to the free corner, and then at most one of the sequences is needed to put them in position. There is one case (U and F edges at UR, FR) which can only be solved by using the left face, by the sequence UL'U'LFU2R'.
Phase 2: Place the LBD piece correctly
  1. Find the piece belonging at the LBD position.
  2. Do one of the following sequences:
    1. To move UFL->LBD, do U2 L U' F' L' U' F
    2. To move UBL->LBD, do U L F2 R' F' R U F' L' U2
    3. To move URB->LBD, do F' U L F R U2 L' U R'
    4. To move FRD->LBD, do F' U L F U L' U2
    5. To move FLD->LBD, do R U F' L F2 U F' L' U2 R'
    6. To move BRD->LBD, do R U F' U L F U L' U R'
Phase 3: Place the RDB piece correctly
  1. Find the piece belonging at the RDB position.
  2. Do one of the following sequences:
    1. To move UFL->RDB, do F R U F R' F2 U'
    2. To move UBL->RDB, do R U2 F U' R' F' U'
    3. To move URB->RDB, do U F2 R F' U' R' F'
    4. To move RFD->RDB, do U F R U F' U2 R'
    5. To move LFD->RDB, do R U F R U' R2 F'
Phase 4: Place the LFD piece correctly
  1. Find the piece belonging at the LFD position.
  2. Do one of the following sequences:
    1. To move UFL->LFD, do F' U L F2 R U' R' U F' L' U'
    2. To move UBL->LFD, do U L F2 R' F L' F2 R F' U'
    3. To move URB->LFD, do U2 L F' L2 U' L F U'
    4. To move RFD->LFD, do U F' L' U L2 F L' U2
Phase 5: Place the RFD piece correctly
  1. Find the piece belonging at the RFD position.
  2. If the piece lies at RUB position, then do either one of the two sequences in the next phase to move the top layer pieces around.
  3. Do one of the following sequences:
    1. To move UFL->RFD, do R U F R U' R' U F' L' U L U2 R'
    2. To move UBL->RFD, do R U2 L' U' L F U' R U R' F' U' R'
Phase 6: Place the top layer pieces correctly
  1. Find the piece belonging at the UBL position.
  2. Do one of the following sequences:
    1. To move UFL->UBL, do F' U L F' L' F2 R U' R'
    2. To move URB->UBL, do R U R' F2 L F L' U' F

Solution 2:
This solution is more suitable for memorisation. It only uses a few move sequences, but it takes much longer than the first method.
Before starting this solution you must understand the notation and make sure you are holding the puzzle as outlined there.

Further notation:
In this solution, we will use some new notation. Let C be a clockwise rotation of the whole puzzle about the URF corner. In other words the U face moves to R, the R face moves to F and the F face moves to U. Similarly, let A be an anti-clockwise rotation about URF. Note that this solution will also use turns of the D face, and this involves the movement of two layers rather than just one.

Phase 1: Bring the puzzle into the right configuration
See Solution 1.

Phase 2: Place the LBD piece correctly.

  1. Find the piece belonging at the LBD position. If it is already correct then go straight to the next phase.
  2. If it lies at FRD then do C ( F R U F R' F2 U' ) A.
  3. Repeat the sequence F R U F R' F2 U' until it lies at UBL.
  4. Do the sequence R D R' ( F R U F R' F2 U' ) R D' R'.
Phase 3: Place the FRD piece correctly.
  1. Find the piece belonging at the FRD position. If it is already correct then go straight to the next phase.
  2. Repeat the sequence F R U F R' F2 U' until it lies at FDL.
  3. Do the sequence A (F R U F R' F2 U' ) C.
Phase 4: Place the BRD piece correctly.
  1. Find the piece belonging at the BRD position. If it is already correct then go straight to the next phase.
  2. Repeat the sequence F R U F R' F2 U' until it is correctly at BRD.
Phase 5: Place the remaining pieces correctly
  1. Find the piece belonging at the FLD position. If it is already correct then go to step d.
  2. If the piece belonging at FLD is not at UBL, then repeat the sequence R U R' F2 L F L' U' F until it is.
  3. Do the following sequence to place the FLD piece in position:
    C (F R U F R' F2 U' ) C (U F2 R F' U' R' F' ) A (F R U F R' F2 U' ) A.
    Note that the middle part is the inverse of the usual sequence.
  4. Perform the sequence R U R' F2 L F L' U' F once or twice until the remaining three pieces are correct.

A mathematical diversion:
When I devised solution 2 I hoped that from phase 3 onwards the puzzle could be solved by only using turns of the F, R and U faces. This turns out not to be the case. After phase 2 there are 6!/2=360 possible positions left, but F, R and U turns generate only 60 of them.

There is a very neat proof of this. I'll just give the bare outline here. First consider the main sequence used in the solution. This can be performed in 3 orientations (that is what A and C are for) and also in reverse. This gives 6 basic move sequences. Any move sequence of the F/R/U faces can be built by combining these 6 basic ones. This is the trickiest but least interesting part of the proof so I'll skip it. These basic move sequences perform 5-cycles on the pieces of the puzzle, so it remains to be seen what positions are attainable by combining these 5-cycles. An easy way to show that these give no more than 60 positions is by looking at an icosahedron. Each pair of opposite corners of the icosahedron can be identified with a piece so that the 5-cycles correspond to rotations of the icosahedron. The icosahedron has only 60 different orientations so there can be no more than 60 positions generated by the 5-cycles.

Pretty patterns:

  1. (F R U F R' F2 U' )2 C (F R U F R' F2 U' )2
  2. F R U F' L' U' R U' L U2 R' U' R'
  3. U F2 R F2 L' U L U2 R' F R U F R' F2 U'

Home
Links
Guestbook


Bandaged Rubik's Cube / Siamese Cubes

Picture kindly supplied by Hendrik Haak

The Siamese Cubes, devised by Tony Fischer, consist of two cubes joined together along one edge so that they share three pieces amongst them. These shared pieces cannot move, and the pieces of the joined cubes cannot intermingle. The two halves can therefore be solved separately.

Each of the two cubes in a Siamese Cubes puzzle can be considered to be a bandaged cube, which is made from a standard Rubik's Cube by gluing the three pieces along one edge of the cube together, i.e. there is now one large 1x1x3 moving piece on the cube. If you can solve such a bandaged cube, then you can solve the Siamese cubes separately in the same way.

There is only one bandaged piece on the cube, so by keeping that piece fixed and moving the remainder (including the centres) the puzzle forms a group generated by face and slice turns.

This puzzle was first produced in 1983 by Ideal under the name Rubik's Mate.

Links to other useful pages:
Meffert's puzzles Mèffert produces and sells this puzzle, the Pyraminx, Megaminx, Skewb, and many others.

Notation:
The same notation is used as for the Rubik's cube. The letters U, D, L, R, F, B are used to denote the faces of the cube. The cube is held so that the bandaged piece lies along the bottom left edge, between the D and L faces. Only the R and U face can be turned. These letters also denote a clockwise quarter turn of that face. A letter followed by a 2 or an apostrophe denote a half turn and an anti-clockwise quarter turn respectively. A combination of letters can be used to denote a particular piece position on the cube, e.g. URF means the corner contained in the three adjacent faces U, R, and F. The middle slices will be denoted using lower case letters, r and u. Note that a slice turn does not move any corner pieces.

The number of positions:
The easiest way to calculate this is to first consider the centres fixed and the bandaged piece moving. There are 12 edges including the bandaged one which could have 12! permutations, and 2 orientations each. The 6 unglued corners could then have 6! permutations and 3 orientations each. This gives at most 12!·6!·212·36 positions. This limit is not reached because:

  • The total permutation must be even (2)
  • The number of flipped edges must be even (2)
  • The total corner twist is fixed (3)
  • If three corners are placed the other three are fixed too (6)
The last point is because the corners are moved only by turns of two adjacent faces. The two generator group on the cube is well known, and its action on the corners is as the PGL(2,5) group, of order 5!. For a good explanation, see David Singmaster's "Notes on Rubik's 'Magic Cube'". This leaves 12!·5!·210·35 = 14,302,911,135,744,000 positions.

Note that the puzzle becomes somewhat more difficult if the bandaged piece has no colours. It is then more difficult to find out where the pieces belong. Also, if the bandaged piece is upside down (or rather the other pieces are placed upside down w.r.t. the bandaged piece) then the puzzle cannot be solved because the number of flipped edges is odd, and the permutation of pieces is odd.

Solution:
Phase 1: Place the two D corners correctly

  1. Find the corner that belongs at DFR.
  2. Turn R or U to bring it to the URF position.
  3. Put it in place and in the correct orientation by one of the following:
    1. To move URF->DFR, do U'R2.
    2. To move RFU->DFR, do U'R'U'R2.
    3. To move FUR->DFR, do RUR'.
  4. Find the corner that belongs at DRB.
  5. If it lies incorrectly positioned at DRB then do R'U'RU2, otherwise turn U to bring it to the URF position.
  6. Put it in place and in the correct orientation by one of the following:
    1. To move URF->DRB, do U'R'URU2R'U'R.
    2. To move RFU->DRB, do UR'U2R
    3. To move FUR->DRB, do U'R'U'R.
Phase 2: Place the U corners correctly.
  1. Count how many of the U corners are correctly oriented w.r.t. to U face.
  2. If all 4 are twisted then put a corner needing a clockwise twist at the ULF position. If three are twisted then put the correctly twisted corner at the ULF position. If only two are twisted then put a corner needing an anti-clockwise twist at the ULF position.
  3. Do the sequence RUR'URU2R'.
  4. Repeat b and c until all corners are oriented properly.
  5. Turn U to put the corners in place.
Phase 3: Place the edges in their correct slices.
    There are three sets of edges, those in the r slice, those in the u slice, and the three edges in the other (immovable) slice. This phase places the pieces in their own slice, though not correctly oriented or positioned. It may move pieces that are correctly positioned already, but will keep them in their slice. The centres are ignored.
  1. Find a piece in the r slice that does not belong, and turn r to place it at the BD position.
  2. Find a second piece that belongs in the r slice but is not in that slice.
  3. If the second piece is in the u slice, then turn u to bring it to the FR position, and do RUr'U'R'.
  4. If the second piece is at UR then do Ur'U'.
  5. If the second piece is at DR then do R2Ur'U'R2.
  6. If the second piece is at UL then do U'r'U'rU2r'.
  7. Repeat a-f until the r slice has all its edges.
  8. Turn the puzzle over, so that the D and L faces are swapped, and repeat steps a-g until the new r slice is also correct.
Phase 4: Place the centres correct.
  1. If the U/D centres need to be swapped then do r2.
  2. If the U/D centres are not correct then turn u to bring the U centre to the front, and do r.
  3. Do u to place the remaining centres correct.
Phase 5: Place the r edges in position.
  1. To swap two adjacent edges in the r slice, turn r to bring them to the U face, do U2, and turn r to bring the centres back in position.
  2. Repeat step a as often as necessary until the slice is correct (ignoring the U corners).
  3. If the U corners need to be moved back into position, do R2U2R2U2R2.
Phase 6: Place the u edges in position.
  1. To swap two adjacent edges in the u slice, turn u to bring them to the R face, do R2, and turn u to bring the centres back in position.
  2. Repeat step a as often as necessary until the slice is correct (ignoring the R corners).
  3. If the R corners need to be moved back into position, then do the sequence U R2U2R2U2R2 U R2.
Phase 7: Place the remaining edges in position.
  1. If the remaining three edges are incorrectly positioned then there are only two possibilities.
    1. To move UL->UR->DR, do RUR2 U'R'U'R' U2RU.
    2. To move DR->UR->UL, do U'R'U2 RURU R2U'R'.
Phase 8: Orient the edges.
    All the sequences used below are conjugates of rUrUrUrU (which flips the pieces UL, FD, BU, BD) or combinations thereof. If you are proficient at cubing, you can probably solve this stage a lot quicker by using your own conjugates. Note that the edges are not solved individually, so a step may flip edges that are then solved in later steps.
  1. Consider the edges in the F/B slice (i.e. UL, UR, DR), and see which ones need to be flipped.
  2. Do the appropriate sequence below:
    1. To flip all three edges, do UR2r2 U'rU'rU'rU' r'R2U'.
    2. To flip UR, UL then do Ur2 UrUrUrU r'U'.
    3. To flip DR, UL then do R2Ur2 UrUrUrU r'U'R2.
    4. To flip only UL, then do rUrUrUrU.
    5. To flip only UR, then do rU'rU'rU'rU'.
    In all other cases, you need to turn over the puzzle so that the D and L faces are swapped and then you find yourself in one of the cases handled above.
  3. Count how many of the edges in the r and u slices still need to be flipped. If there are more flipped edges in the u slice then turn over the puzzle, so that the D and L faces are swapped.
  4. If all 8 edges need to be flipped then do the sequence R rU'rU'rU'rU' R. Now only 4 edges need to be flipped, which is explained below.
  5. If 4 edges in the r slice and 2 in the u slice need to be flipped, then turn u to bring an unflipped edge to FR and do R rU'rU'rU'rU' R'. Turn the u slice back into position. Now 4 edges need to be flipped, which is explained below.
  6. If only the 4 edges of the r slice need to be flipped then do the sequence U'rUr' UrUrUrU r2U'r'U.
  7. If 3 edges in each slice need to be flipped, then turn r and u to bring the unflipped edges at FU and FR and do R rU'rU'rU'rU' R'. Turn the u and the r slices back into position. Now 4 edges need to be flipped, which is explained below.
  8. If 3 edges in the r slice and one edge in the u slice need to be flipped, then turn r to bring the unflipped edge at FU, and u to bring the flipped edge to FR, and then do R rU'rU'rU'rU' R'. Turn the u and the r slices back into position.
  9. If 2 edges in each slice need to be flipped then turn r and u to bring unflipped edges to the FU and FR positions, and then do R rU'rU'rU'rU' R'. Turn the u and the r slices back into position. Now there are still 4 flipped edges, but there are three in one slice, and this case is explained above.
  10. If only two edges in the r slice need to be flipped, then turn r to bring a flipped edge to FU and do R rU'rU'rU'rU' R'. Turn the r slices back into position. Now 4 edges need to be flipped, which is explained above.
  11. If one edge in each slice need to be flipped, then turn r and u to bring the flipped edges at FU and FR and do R rU'rU'rU'rU' R'. Turn the u and the r slices back into position. Now 4 edges need to be flipped, which is explained above.

Home
Links
Guestbook


Bandaged Pyraminx

Picture kindly supplied by Norman Diamond

This puzzle is made from a standard pyraminx by gluing two of its edge pieces to one corner piece each. This is somewhat similar to how a bicube is made from a standard Rubik's cube.

This puzzle was given to me by Norman Diamond when he asked me to devise a solution to it.

The number of positions:
There are three types of pieces; the tips, corner pieces and edge pieces. There are 4 corner pieces which each have 3 possible orientations. If unrestricted this would give rise to 34 combinations. On the bandaged puzzle however, the two bandaged corners can be in any orientation but one, so this leaves only (32-1)·32 orientations. The 4 unbandaged edge pieces can be in any position given the same restrictions as the normal pyraminx, i.e. they must lie in an even permutation, and the total number of flipped pieces is even. This leaves a total of (32-1)·32·4!/2·24/2 = 6,912 positions ignoring the trivial corner tips.

If you include the trivial tips then this has to be multiplied by a further 34=81.

A quick computer search gives the following result (ignoring the tips):
Depth | # Positions
0 | 1
1 | 4
2 | 12
3 | 32
4 | 76
5 | 206
6 | 510
7 | 1,126
8 | 1,803
9 | 1,980
10 | 981
11 | 165
12 | 15
13 | 1
Total | 6,912
The antipode at distance 13 is the position with all 4 free edges flipped.

Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He invented and now produces and sells the Pyraminx amongst others.

Notation:
Hold the puzzle so that the tips on the two corner pieces which have an edge glued to them are pointing left and right, and the other two corner tips are pointing back and up. Clockwise 120 degree turns of these corners will be denoted by the letters L, R, B, U respectively. Anti-clockwise turns are denoted by an apostrophe, i.e. L', R', B', U'. The position of an edge piece can be specified by two letters, e.g. the edge in position LR is the piece lying directly between the L and R corners.

In the solved position, the edges which are glued to the L and R corner pieces lie in positions LB and RU respectively. Due to its symmetry this is true even when the puzzle is turned over so that the L and R corners are swapped.

Solution:
Phase 1: Solve the tips.

  1. Simply turn each tip so that it matches its corner piece.
Phase 2: Solve the bandaged corner pieces.
  1. Find out which colour is missing from the B corner piece. The face opposite (the URL face at the front) will eventually be that colour.
  2. Turn the L and R bandaged corner pieces to their correct orientations, i.e. showing the correct colour in the front face. The bandaged edges should lie at RU and LB.
Phase 3: Position the LR edge piece, in its correct orientation.
  1. Find the piece that belongs in the LR position (directly between the bandaged corners). Skip this step if it is already correctly positioned and oriented.
  2. If the edge lies at RB then do R', otherwise do R.
  3. Turn U to bring the edge to the UB position.
  4. Turn R back to its original position.
    The piece belonging at LR now lies at UB.
  5. If the colour of the front (ULR) face is showing on the right hand side (URB face) of the edge piece, then do RL'U'L'R'L', otherwise do RUR'. The edge should now match the adjacent L and R corner pieces.
Phase 4: Solve the unbandaged corner pieces
  1. To turn the U corner, do R'UR or R'U'R so that its colours match the L corner piece.
  2. To turn the B corner, do L'BL or L'B'L so that its colours match the R corner piece.
Phase 5: Position the remaining 3 edges.
  1. Find the edge piece belonging at the RB position.
  2. If it lies at UL, then do RURUR'UR'.
  3. If it lies at UB, then do RU'RU'R'U'R'.
  4. The other two edge pieces are automatically now correctly positioned.
Phase 6: Orient the 3 edges.
  1. To flip the RB and UB edges, do RUL'ULU'RU'R.
  2. To flip the RB and UL edges, do RUL'U'LU'RUR.
  3. To flip the UL and UB edges, do LBR'BRB'LB'L.

Home
Links
Guestbook


Barrel/Octagon

Picture kindly supplied by Hendrik Haak

This variation on the Rubik's cube is called the Magic Octagonal Prism, or just The Barrel or The Octagon. It is exactly the same except that the four vertical edges of the cube are truncated. The corner pieces of original cube now have only two colours and the four edge pieces in the middle layer have only one colour.

The differences make this puzzle a little confusing. It is possible to get to a position where it seems that two pieces need to be swapped or where one edge piece needs to be flipped, both of which are impossible on the original cube.

The number of positions:
There are 8 corner pieces with 3 orientations each, 12 edge pieces with 2 orientations each, giving a maximum of 8!·12!·38·212 positions. This limit is not reached because:

  • The total twist of the cubes is fixed (3)
  • The middle layer edge pieces show no orientation (24)
  • The colours of the vertical columns are equivalent (4!)
This leaves 8!·12!·37·28/4! = 450,541,700,775,936,000 or 4.5·1017 positions.

Solution:
Use any solution method for the Rubik's Cube to solve it as far as possible. If you need to flip one final edge, then simply flip that edge and one of the shaved (monochrome) edges.
If you need to swap two pieces then swap any two of the shaved columns. For example if the shaved columns are vertical, then RLD2R'L' will swap the DF and DB edges.

Some people prefer to hold the puzzle so that the last layer they solve is one with two shaved edges (e.g. the octagonal sides are at L and R). This way any final flips/swaps only involve pieces of the final layer.

Home
Links
Guestbook


Beachball Skewb

Picture kindly supplied by Uwe Mèffert

The Beachball Skewb is a sphere which is bisected 4 ways, by planes through the centre of the ball, which splits the surface of the ball up into 8 triangles and 6 squares. Each half of the puzzle has a triangle at its centre and can rotate 120 degrees in either direction. When solved, the surface of the ball is divided into four segments, one colour each, along two of the cutting planes.

The beachball uses the same mechanism as the Skewb, and can therefore be solved in much the same way, but as this puzzle is so much simpler it is better to have a faster solution that is specifically geared to it.

Note that turning one triangle has the same effect on the puzzle as turning the opposite triangle the other way. Therefore the puzzle can be solved by only using one of each pair of opposite triangles. Internally 4 of the triangles are fixed on axes, and the other 4 are moving pieces. Externally there is no visible difference between the two sets.

The number of positions:
There are 4 fixed triangles, 4 free triangles, and 6 squares giving a maximum of 6! 4! positions. This limit is not reached because

  • There are two pairs of identical squares (4)
  • The free triangles must have an even permutation (2)
This leaves 6!·3 = 2,160 positions.

A computer search gave the following result:
0 | 1
1 | 8
2 | 48
3 | 252
4 | 930
5 | 884
6 | 37
Total | 2,160
This shows that any position can be solved in at most 6 moves.

Links to other useful pages:
Meffert's puzzles Uwe Mèffert's pages. He produces and sells this puzzle, the Pyraminx, Megaminx, Skewb, and many others.

Solution:

Phase 1: Solve a small segment.

  1. First find out the colour of one of the small segments. Simply look at the squares, and find a colour of which there is only one square.
  2. If the square is not already adjacent to a triangle of the same colour, then do any move to make it so.
  3. Turn the half containing the square and its adjacent triangle so that the square lies between the two triangles of the same colour, thus completing the small segment.

Phase 2: Solve the second small segment

  1. Hold the puzzle so that the solved segment is vertical at the back. From now the only moves will be turns of the front left and front right halves because they do not move this solved segment. This restriction does mean the solution uses more moves, but it is much simpler.
  2. Find out the colour of the second small segment, i.e. the colour of which there is only one square left. This segment will be solved directly at the front, in the intersection of the two halves that can still turn.
  3. If the square is not already adjacent to a triangle of the same colour, then do any move to make it so.
  4. Turn the half containing the square and its adjacent triangle so that they do not lie in the intersection of the two ball halves.
  5. Turn the other half to join up the other triangle, and so form the second segment.
  6. Turn half containing the segment to bring it to the front.

Notation:
The final phase is easier to describe with a little bit of notation. Let L denote a clockwise 120 degree turn of the front left half of the ball, and let R be such a turn of the front right half. Anti-clockwise turns of those halves are denoted by L' and R'.

Phase 3: Solve the two large segments.

  1. Examine the two triangles in the left unsolved segment. If they are not the same colour, then do RLRLR'LR'. Note how this sequence swaps the two triangles of the front segment. That automatically causes two other triangles to be swapped as required.
  2. If all four remaining squares are incorrect, then do the sequence L'R'LRLRLRLR'L'.
  3. If two of the squares need to be swapped, then turn the whole ball so that the two small segments are still vertical at the front and back, and the left bottom square correctly matches the left triangles. There are two possibilities for the square belonging at the top left:
    1. If the square lies at the top right, do L'R'LRLR'.
    2. If the square lies at the bottom right, do RL'R'L'RL.
    Note that these are inverses of eachother.

Home
Links
Guestbook


Brainball

Picture kindly supplied by Hendrik Haak

Description of the Brain Ball
Notation
Solution
JavaScript version of the Brain Ball

Description:
This is a very difficult puzzle. It looks a bit like the planet Saturn, a ball with a ring around it. The ring consists of 13 numbered pieces, which are white on one side and yellow on the other. This ring can be rotated around the ball. There are two round caps which lie on opposite sides of the ball and which are bisected by the ring of pieces. One cap is 4 pieces wide, the other only 3. These two caps can rotate, which reorders the pieces of the ring. The caps are not independent, they can only rotate simultaneously. The aim is of course to restore the pieces to numerical order with a single colour on each side.

Links to other useful pages:
Brainball homepage. This good page is in German, and has move sequences, puzzles and a 10,000 DM prize contest.
Stelldinger's page is also in German, and has some further sequences (Choose Fun/Brainball).
Jenni's page, again German, has a fairly poor Java game.

The number of positions:
There are 13 pieces, with 2 orientations each, giving a maximum of 13! 213 positions. This limit is not reached because:

  • The total number of flips and swaps of pieces is even (2)
  • Rotation of the ring relative to the ball is not considered different (13)
This leaves 12!·212 = 1,961,990,553,600 or 1.9·1012 positions.

Notation:
This is the notation used on the Brainball homepage, and it is similar to my notation for the Square-1. Consider the ball to be fixed in place, with the ring moving around it. Clockwise turns of the ring are denoted by a number, indicating how many pieces the ring moves. Similarly negative numbers are used for anti-clockwise turns. A slash character (/) is use to denote a twist of the blue caps. I'll say a piece is in pole position if it lies in the middle of the small blue cap. In the last phase we will also have to specify the various positions the pieces can be in. The piece positions are lettered A to M starting clockwise from the pole position.

Solution:
The Brainball homepage recommends ordering the pieces first, and then orienting them correctly. I prefer to do the opposite, first getting them all one colour and then positioning them properly.

Phase 1: Make all pieces the same colour.

  1. If you can, do any move that makes more pieces of the desired colour.
  2. Repeat step a as often as possible, until only most pieces are of the right colour.
  3. For each remaining piece that needs to be flipped, put it in pole position and then use 2/-2/2/-2 which flips it.

Phase 2: Parity step
If the pieces are now in an odd permutation, then you will have to flip all the pieces. It is not easy to see whether it is an odd permutation, so you could just try to solve it as in the following phase, and if you are left with just two pieces that need to be swapped then you will have to come back to this phase. Alternatively you could cheat by marking the sides of the ball with the colour of the pieces before getting the puzzle mixed up.
If in an odd permutation then do /6/4/1/1/-2 to flip all the pieces. This sequence preserves the order of the 3 pieces on the small cap. If the piece order does not matter at all, then you can do /5/5/ instead.

Phase 3: Ordering the pieces.
The sequence 1/-1/6/-6/-6/-6/-1 cycles only pieces in positions A, B and C around: The piece in pole position moves to position B, the piece in position B moves to position C, and the piece in position C moves into pole position.

Theoretically you can simply use only this one sequences to solve the ball, but you may want to speed things up by looking up sequences in the table below. To solve the ball with this table, do the following steps:

  1. Rotate the ring to bring piece 1 in pole position, and then do -1.
  2. Find the piece 2, and note its current position.
  3. Look up the sequence in the table that moves a piece from that position to pole position, and do it.
  4. Do move -1.
  5. Repeat steps b-d for each of the pieces 3-12 to solve it. Make sure that the sequence you choose will not disturb the pieces that are already solved. Sometimes there are several alternative sequences in the table, so that you may be able to solve two pieces simultaneously.
Pieces unmoved | Moves ?->A | Moves ?->B | Sequence
8 | B | A | 5/6/6/1/6/6/-4
1 | B | C | 2/-4/3/-4/
10 | B | C | 1/6/6/6/-6/1/-1
9 | B | D | /5/-6/-6/6/1/
8 | B | E | -4/2/-6/6/6/5/4
7 | B | F | -5/2/-4/-4/-4/-6/5
6 | B | G | -5/6/6/3/-4/-4/-5
5 | B | H | -2/4/-3/4/-1
4 | B | I | -2/-3/-6/-2/-3/-5/-1
3 | B | J | /2/-1/-6/1/4/
2 | B | K | 6/1/6/1/-6/-2/-6
1 | B | L | -1/1/2/-4/-1/5/4
10 | C | A | 1/-1/6/-6/-6/-6/-1
9 | C | B | -6/-1/6/6/-6/-5/6
1 | C | D | -5/-1/-3/-1/6
1 | C | E | 1/-2/-4/3/-1/-5/-1
1 | C | F | 2/-1/-1/2/-1/-1/-2
5 | C | G | -6/-4/-4/-3/-4/1/6
4 | C | H | 4/1/3/1/6
4 | C | I | 4/-2/6/-4/-4/-6/6
1 | C | J | -5/2/1/-3/-2/-1/
2 | C | K | 6/-2/1/1/-4/-1/-3
1 | C | L | -1/-2/1/-2/1/4/1
9 | D | A | /-1/-6/6/6/-5/
9 | D | B | -6/5/6/-6/-6/1/6
8 | D | B | /5/6/6/-6/2/
2 | D | C | -3/4/1/-2/4/2/
1 | D | E | 1/5/-3/5/-1
1 | D | F | /-6/-6/-2/4/5/-1
5 | D | G | /2/-1/3/-1/-5/
3 | D | H | -3/5/-3/5/
4 | D | H | 3/1/4/6/-4/5/-3
2 | D | I | 3/1/1/-6/2/-5/-6
3 | D | J | -3/5/6/-4/-4/1/
1 | D | K | -2/-5/2/-3/2/2/6
1 | D | L | 1/-5/2/-3/-1/-2/-1
8 | E | A | -4/-5/-6/-6/6/-2/4
8 | E | B | /-2/6/-6/-6/-5/
4 | E | C | -4/-5/-2/6/2/-2/4
2 | E | D | 3/1/4/-1/-1/2/-6
1 | E | F | -6/1/3/1/5
5 | E | G | 6/-5/-1/3/-1/2/-6
2 | E | H | 3/-1/-3/-1/-6
4 | E | H | -4/-2/-1/4/-1/-2/4
3 | E | I | /-2/-4/-4/-1/2/3
1 | E | J | 2/-1/-2/-2/1/1/6
2 | E | K | -4/4/-4/2/-4/-2/4
1 | E | L | /-3/3/-1/-6/-2/5
1 | F | A | /4/-3/4/-2
7 | F | A | -5/6/4/4/4/-2/5
7 | F | B | /-2/4/4/4/6/
3 | F | C | 2/-4/-4/-2/6/-2/
3 | F | D | /-1/6/5/4/4/-2
1 | F | E | /4/-3/3/-3/-1/-5
5 | F | G | -1/1/-1/3/-1/-4/1
1 | F | H | -4/-4/3/-4/1
4 | F | H | 2/2/4/6/-4/4/-2
3 | F | I | -6/2/-1/-4/-4/-2/-4
3 | F | J | /2/-6/2/4/4/-2
1 | F | K | 1/-2/4/2/4/4/3
1 | F | L | -2/-2/1/-2/4/-4/2
6 | G | A | 5/4/4/-3/-6/-6/5
5 | G | B | 5/4/-3/4/5
6 | G | B | -3/-5/-3/3/-3/-5/3
2 | G | C | 5/-3/3/5/-6/5/4
3 | G | D | -2/-2/-2/3/1/-5/-1
4 | G | E | -4/5/5/-2/-5/-5/-1
2 | G | F | -1/1/1/-3/1/2/-5
4 | G | H | -2/1/3/1/-1
5 | G | H | /5/1/-3/1/-2/
4 | G | I | -2/-2/4/-6/6/4/-1
3 | G | J | -3/-2/-1/3/2/1/
2 | G | K | 6/5/-2/3/-2/-2/-6
1 | G | L | /-3/-6/1/6/2/-5
5 | H | A | 1/-4/3/-4/2
5 | H | B | -5/-4/3/-4/-5
5 | H | C | 1/-1/6/-6/4/6/2
5 | H | D | /5/4/6/-4/1/
5 | H | E | 6/-2/4/6/-4/-5/-6
5 | H | F | -5/2/-4/-4/6/6/-5
4 | H | G | 4/4/6/-6/4/-2/6
4 | H | I | 1/2/3/2/2
1 | H | I | -1/4/-3/4/4
3 | H | J | /5/1/4/1/4/
2 | H | K | -6/-1/-1/-4/2/-5/-4
1 | H | L | /-5/-5/-2/5/5/1
4 | I | A | /-6/-6/-5/-4/2/2
4 | I | B | /-6/-6/2/-4/-4/2
4 | I | C | -6/6/3/-6/-6/-1/-4
4 | I | D | 3/-2/-1/3/-1/-1/-3
4 | I | E | -4/5/-1/3/-1/5/4
4 | I | F | 2/-1/-1/3/-1/-2/-2
4 | I | G | -2/-2/-6/-1/3/-3/-1
4 | I | H | /-6/-6/5/4/-1/2
3 | I | J | /-1/1/-3/1/4/
2 | I | K | 6/1/-4/2/6/-1/-3
1 | I | L | 1/-2/-2/-4/1/2/1
3 | J | A | /-4/-1/6/1/-2/
3 | J | B | /2/4/4/4/2/
3 | J | C | -3/-6/-6/4/4/-2/
1 | J | D | /2/2/-3/-1/5/1
1 | J | E | 1/1/-3/-1/3/-2/-4
1 | J | F | 1/2/2/4/2/2/-6
3 | J | G | /-4/-1/6/4/2/3
3 | J | H | /-4/-4/-6/4/-2/
3 | J | I | /-1/3/-6/-6/5/3
1 | J | K | /2/2/-3/2/-5/4
1 | J | L | 4/-1/-2/4/1/-5/-4
2 | K | A | /1/-6/5/-6/-6/
2 | K | B | /-5/1/4/1/1/
2 | K | C | -4/1/1/4/-2/5/1
2 | K | D | -3/5/4/-2/-6/-6/
1 | K | E | 1/-2/-1/-3/2/-5/-1
2 | K | F | -4/-4/-1/6/1/-2/5
2 | K | G | 3/-5/4/3/4/-5/-3
2 | K | H | /-2/3/-5/3/-3/
2 | K | I | /-5/-5/-6/-5/-5/-3
1 | K | J | 1/-2/-1/1/-2/-1/-6
1 | K | L | /-5/-1/1/1/4/3
1 | L | A | /1/2/-4/2/-5/2
1 | L | B | /1/1/-2/1/1/
1 | L | C | 2/-4/-1/2/-4/-2/
1 | L | D | 2/-2/-2/-1/2/1/-6
1 | L | E | -2/-2/1/-2/1/4/-1
1 | L | F | /1/2/3/-1/-2/5
1 | L | G | 1/2/1/-1/2/1/4
1 | L | H | /1/-4/2/-4/1/2
1 | L | I | /1/1/1/2/2/3
1 | L | J | 2/-2/-1/1/-2/-1/-5
1 | L | K | -2/-1/-1/2/-1/-1/6
For example, if you have solved pieces 1, 2, and 3 then place them in positions K-M, so that piece 4 will have to be placed in pole position (A) to extend the solved block. Find pieces 4 and 5, and let's suppose they are at positions D and C respectively. Look through the table to find a sequence with D in the second column, and C in the third.
2 | D | C | -3/4/1/-2/4/2/
Unfortunately the only such sequence has 2 in the first column, meaning it will disturb the three solved pieces you already have. You will therefore have to choose another sequence, and be content with only solving piece 4 with it.
3 | D | H | -3/5/-3/5/
Of the sequences with at least 3 in the first column, and D in the second, this is the shortest, and therefore the best one to use.

If you end up with a position where you would have to swap the final two pieces, then you have to flip all the pieces round as explained in phase 2.

Appendix: Some other neat sequences.
The following sequences cycle three pieces around, without altering the orientations. All possible three-cycles are represented here, though you may have to turn over the puzzle and/or perform the inverse of the given sequence.
Pieces cycled | Sequence
A, B, C | 1/-1/6/-6/-6/-6/-1
A, B, D | /-1/-6/6/6/-5/
A, B, E | -4/5/-6/-6/6/-2/4
A, B, F | -5/6/4/4/4/-2/5
A, B, G | -2/-3/3/-4/3/-1/2
A, B, H | 1/-4/3/-4/2
A, C, E | /-5/1/4/4/4/3/5/
A, C, F | 1/-1/4/4/4/5/-1
A, C, G | 4/1/-3/3/-3/2/-4
A, C, H | -6/-1/-3/3/-3/4/6
A, D, G | -3/-5/-3/3/-3/-5/3
A, D, H | /5/-3/3/-3/-2/
A, D, I | 3/-5/4/4/4/-4/-3
A, E, I | -4/2/4/4/4/2/4
The following sequences flip pieces without moving them:
Piece positions flipped | Sequence
A | /5/-3/5/5/-3/5 (+turn over) /5/5/-5/-5/5/5 (+turn over)
A, B | 1/5/-6/2/-2/2/-2/2/4/-5/-1
A, C | /-2/2/-2/2/-2/2
A, D | 4/-6/2/-2/2/-2/2/4/-4
A, E | -3/1/2/-2/2/-2/2/-3/3
A, F | 3/-5/5/2/5/-5/-3
A, G | /5/-3/5/-3/5/-3/5/-5/6/-5
A, B, C | /1/-2/2/4/2/5/4/5/5/-4/2/5 (+turn over)
A, B, G | -1/3/-2/3/-3/5/-5/-2/-2/5/-4 (+turn over)
A, B, H | 2/1/5/3/-2/-1/1/-5/6/-2/-2 (+turn over)
A, C, E | 2/5/2/2/-3/2/-3/5/5/-1/-6 (+turn over)
A, C, F | /2/-5/-2/-2/-5/5/-3/3/-3/ (+turn over)
A, C, G | /5/-3/3/-5/5/2/2/5 (+turn over)
A, C, H | /5/2/2/5/-5/3/-3/5 (+turn over)
A, D, G | /-2/3/5/1/-1/5/-6/2/4/1 (+turn over)
A, D, H | /1/-1/-2/3/5/1/4/2/-6/5 (+turn over)
A, D, I | -2/-5/5/2/2/5/5/-3/5 (+turn over)
A, E, I | 1/1/2/-2/2/1/-5/5/-3/2/-2 (+turn over)
A, B, C, D | /-2/1/2/-2/2/-2/5/1/-5/5/2/5
A, B, C, E | /4/-5/5/2/5/-5/5/2/-2/2/-2/2
A, B, C, F | /-2/2/-2/4/5/-5/-2/-5/3/2
A, B, C, G | /3/2/5/-5/6/-2/-5/5/4/
A, B, C, H | /3/2/1/-4/5/-5/4/4/2/-6/4/
A, B, D, E | /-2/-1/2/-2/1/2/-2/1/-2/2/-1/2
A, B, D, F | /-2/1/2/-2/2/-4/-5/5/2/-5/5/
A, B, D, G | 4/5/-5/4/4/2/-6/-6/2/1/5
A, B, D, H | -5/2/2/6/5/2/5/6/2/-4/5
A, B, D, I | 2/2/5/-5/6/-2/-5/5/5
A, B, D, J | 1/-4/2/-2/2/6/5/2/-5/3/2
A, B, D, K | -3/2/1/3/-5/2/5/-5/-4/2/1
A, B, D, L | /2/-2/2/-2/4/5/-5/-2/-5/3
A, B, E, F | /-1/2/2/5/-5/-4/-5/5/2/2/-2/
A, B, E, G | 1/5/2/6/5/2/5/6/2/6/-1
A, B, E, H | 1/6/-1/4/1/5/2/-1/2/1/6
A, B, E, I | 3/5/-5/5/2/-6/5/-5/-2/1/-3
A, B, E, J | -3/1/2/-2/2/-4/-5/5/2/-5/6
A, B, E, K | /3/-2/2/-4/-5/5/2/-5/3/1/-1/
A, B, F, G | 2/-5/1/2/-2/2/-2/2/2/2/5/-5/-4
A, B, F, H | 2/-1/6/-6/1/2/-1/2/5/1/2
A, B, F, I | -4/6/2/5/-5/6/-2/-5/5/1/4
A, B, F, J | 1/-2/-2/-5/5/4/5/-5/-2/-2/2
A, B, G, H | 1/6/2/-1/1/5/6/2/-1/1/4
A, B, G, I | 2/6/-5/5/2/-6/5/-5/-4
A, C, E, G | /4/6/-2/6/6/-2/2/-4/-2/2
A, C, E, H | /-2/2/4/6/-2/6/6/-2/2/-4
A, C, E, I | 3/2/3/-5/5/2/5/3/-2/-5/2
A, C, F, H | 6/2/-2/2/6/5/2/5/
A, C, F, I | -2/5/2/-1/2/1/-6/6/-1/4/3
A, C, F, J | 3/2/-1/2/1/-6/6/-1/4/1/2
A, C, F, K | /-2/2/-2/2/6/5/2/5/-5/
A, C, G, I | /6/2/-2/2/6/5/2/5
A, C, G, J | -2/2/6/5/2/5/6/2/
A, D, G, J | /4/2/6/5/2/5/6/2/-6/

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Rubik's Clock

Picture kindly supplied by Hendrik Haak

Description of Rubik's Clock
Solution to the Clock
JavaScript simulation of the Clock

Links to other useful pages:
'Simplest Solution' page. A textbased solution.
Arlet Otten's page The solution from the rec.puzzles archive.
Chris Eggermont's page. A somewhat cumbersome mathematical solution.
Raymond Penner's page. A Java game simulating the Rubik's Clock.
Raymond Penner's page. His simple solution.

Description

This puzzle consists of a disk with 9 small clocks on each side arranged in a square. The four corner clocks can be twisted (the front and back corner clocks are connected). In between the clocks are four buttons. By pushing then up or down, the front or back clocks adjacent to it are connected to the corner clocks so that they will be turned when the corners are turned. The aim of the puzzle is to set all clocks to 12 o'clock.

The number of positions:
There are 14 independent clocks, with 12 settings each, giving 1214 = 1,283,918,464,548,864 positions.

This is the one of the few non-trivial puzzles I know in which the order that the moves are performed is unimportant (i.e. the puzzle positions form an Abelian group). This means that it is not necessary to do any particular move twice during the solution because we could change the order to do them one after the other, and therefore combine them into one move. Another puzzle of this kind is the Lights Out puzzle.

There are 16 positions that the buttons can be in, and in 14 of these we can turn a corner next to an up button or one next to a down button. In the other two cases all the buttons are the same. This means there are 30 possible moves that can be performed.

Suppose we choose 14 independent moves. Independent means here that the effect of any of the 14 moves cannot be replicated by using only the other 13. These 14 moves can then always solve the puzzle. For any position of the clocks this can be done by writing down 14 independent equations in 14 unknowns and solving them. The unknowns represent the how far you have to turn for each type of move. Each equation represents a clock; the left side is the amount the clock is turned by all the moves, the right side is the amount it has to turn to set it to twelve.

The theoretical solution above is in general not very easy for humans to perform, but is well suited for computers. By rewriting the equations in matrix form, and inverting the matrix, finding a solution becomes nothing more than a simply multiplying the (constant) inverse matrix by a vector representing the current position to be solved.

The solution for humans below does indeed use exactly 14 moves. By a suitable choice of 14 moves, and by doing them in an easy order there is virtually no mental effort needed at all. Sometimes fewer than 14 moves are needed, because a clock happened to end up in the correct setting. There are 30 possible moves, and with a fixed choice of 14 independent ones there are always positions that need all 14 moves. It would be interesting to know for sure whether there are positions for which no choice 13 of the 30 moves can solve it. This is by no means certain, but I do not believe this is the case here.

Solution:

Note that in this solution, you only turn corners which are next to buttons in the up position. This way none of the clocks on the reverse side move, except for the corner clocks.

  1. Push down the bottom two pins, push up the top two.
  2. Turn a top corner until the center clock matches the bottom middle.
  3. Rotate the whole puzzle a quarter turn clockwise.
  4. Repeat steps 1-3 three more times.
  5. Push up all pins.
  6. Turn any corner till the centre clock is 12.
  7. Turn over the puzzle, and repeat steps 1-4 for this side.
  8. Push down the top left pin, push the other three up.
  9. Turn one of the three corners till the centre clocks match the top left.
  10. Rotate the whole puzzle a quarter turn clockwise.
  11. Repeat steps 8-10 three more times.
  12. Repeat steps 5-6 for this side.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Computer Puzzling

On this page I will discuss some of the ideas involved in using computers to solve or analyse permutation puzzles. Along the way I will describe various algorithms or methods in pseudo code, which will make it easier to implement regardless of the programming language used.

Calculation of God's Algorithm
Reducing memory use, Indexing

Thistlethwaites algorithm

Tree searching
Iterative deepening
Pruning
Increasing speed, transition tables

Kociemba's Algorithm

Calculation of God's Algorithm

God's algorithm is the name for the method of solving a puzzle which always uses the fewest possible moves. There are a few puzzles for which this already completely known (e.g. Pyraminx, 2×2×2 cube, Skewb), but many puzzles have just too many possible positions to be able to calculate God's Algorithm for all possible positions. As the cost of memory and processing power comes down more and more, puzzles that were previously out of reach become possible. Yet there are many puzzles which have such astronomical numbers of positions that it is hard to imagine that they will ever be fully solved.

For any position, God's algorithm can give a move that brings the puzzle one step closer to being solved. It is essentially just a large database, in which a position can be looked up, and from which you can extract the move to perform. To fully solve a position, just keep looking up the current position and doing the move the database tells you to, and eventually the puzzle will be solved. To find God's algorithm you therefore have to generate such a database only once, after which it can be reused forever.

The database is generated in reverse, beginning with the starting positions, in the following manner:

  1. Make an empty database that is large enough to store all the data.
  2. Put the solved position (or positions) of the puzzle in the database. For all these solved positions perform the following step.
  3. For each of these positions, and each possible move do this:
    a. perform the move, and see what position is generated.
    b. If this position is not yet in the database, then store it together with the move that solves it (the inverse of the move that was just done).
  4. For each of the positions that have just been generated, repeat the previous step. If no new positions were generated, then the database is finished.

This is often called a 'breadth first' search. This means that it visits all positions at distance 1 before visiting all positions at distance 2, and so on.

Reducing memory use, Indexing

The database used can be huge. It is therefore essential to reduce the storage space needed per position. The most common way to do this is by indexing. By using indexing, the positions of the puzzle are not themselves stored, but are given by the index in the database or table. Suppose that you have found a way to associate with each position of the puzzle a unique number in the range 1 to N. You can then use a table with N entries, and the index in the table determines which puzzle position the data pertains to.

Another useful point is that you don't have to store the moves, but instead you can store only the distance from solved. The table still allows you to know what the best moves are in each position; simply try out all available moves and see if the new position is closer to being solved by looking it up in the table. Most puzzles can be solved in fewer than 256 moves, so you need no more than a single byte per puzzle position.

For very large puzzles, it might be necessary to use even less than a byte per position. If you know that the puzzle diameter is less than 15, you need only 4 bits to store the distance. In fact, you can go even further. Instead of storing the distance, store the distance modulo 3 (i.e. the remainder from division of the distance by 3). This is still enough to give God's algorithm, because it is still possible to check whether a move brings it a step closer to start or not. Note that 2 bits have 4 possible values, so while generating the table we can use the fourth value to indicate entries that have not yet been filled.

Many puzzles have symmetry. It may be possible to use such symmetry to reduce the size of the tables. For example if every position also has a mirror image position, and none of the positions themselves are mirror symmetric, then the table can be cut to half size. Similarly for rotational symmetries. Indexing this reduced set of positions may be a bit more tricky however.

Many puzzles are still too large to be fully calculated, even when only 2 bits per position are used. In such cases, it is only possible to calculate all positions which lie within a certain distance from solved. In that case you will have to store the positions that have been visited in the database. The techniques used for indexing are still useful, because they allow you to encode a position in a unique number (or list of numbers) which is easy to store and doesn't take up as many bits as most other ways of storing a position.

Click this link for more detailed pseudo code examples of database generation and indexing.

Thistlethwaite's algorithm

In the early 1980's Morwen B. Thistlethwaite came up with a very clever method of solving the Rubik's cube. It is clearly not (yet) possible to calculate God's algorithm for the whole cube, so he decided to split up the problem into 4 sub-problems, each of which are just like solving a simpler puzzle and which can be done using a table.

To achieve this he used a sequence of nested groups (see the Theory page). The whole cube group is generated by the moves {U, D, R, L, F, B}, and this is the first group G0 in the sequence. Successive groups restrict various moves to half turns only as follows:

    G0 = <U, D, R, L, F, B>
    G1 = <U, D, R2, L2, F, B>
    G2 = <U, D, R2, L2, F2, B2>
    G3 = <U2, D2, R2, L2, F2, B2>
    G4 = I

The first subproblem is how to use any moves to get a position which lies in G1, i.e. to get a position that can be solved using only {U, D, R2, L2, F, B}. From that new position, the second subproblem is how to use only those restricted moves to get to a position that can be solved by using only {U, D, R2, L2, F2, B2}. This continues, each stage uses fewer types of moves to reach a position that can be solve with even fewer. Eventually in the last stage it is solved.

Note how each stage can be considered a standalone puzzle in itself because the elements of Gi form a subgroup. This is different from the usual methods of solving a cube, because usually previously solved pieces have to be temporarily moved while solving later pieces. Here, any progress made during earlier stages remains intact throughout.

In the first stage, the orientation of the edges is solved. It is impossible to flip an edge piece once the R and L faces are restricted to half turns. Any position that has no edges flipped lies in G1 (because it can be shown that it can be solved using those restricted moves). Therefore the size of the lookup table for the first stage is only 211 = 2048. It can easily be generated by the same methods as for God's Algorithm. To solve a cube position with Thistlethwaite's algorithm, the first stage is solved simply by looking only at the flip of the edges and ingoring all else.

The other stages work exactly the same way, though they are not all quite so easy. You have to build some kind of index into the table, which only encapsulates those aspects of the cube which are solved at that stage.

Thistlethwaite's algorithm solves the cube in at most 7+10+13+15= 45 moves, with an average of 4.6+7.8+8.8+10.1= 31.3 moves.

Note that if you take a different shortest route through stage 1, the route through stage 2 may be shorter or longer than before. This in turn influences the length of stage 3 or 4. The only guarantee is that it will not exceed 45. Another interesting fact is that some positions in G3, the square group, can be solved in fewer moves when quarter turns are allowed.

Tree Searching

This is a method of solving a particular position by trying out all combinations of moves until it is solved. In a tree search of depth 1, every move is tried out from the scrambled position, to see if it becomes solved. If it doesn't, you know that it is more than 1 move away from start. Deeper searches can be done by recursion; for a search of depth n try out each single move followed by a tree search of depth n-1. In pseudo code it looks something like this:

function Treeseach( position p; depth d )
  if p is solved then
    Hooray!
  elseif d>0 then
    for each available move m
      treesearch( result of m applied to p; d-1 )
    endfor
  endif
endfunction

The biggest advantage of a tree search is that it needs very little memory to run as it has no databases or tables.

Iterative deepening

If you have a scrambled puzzle, and you are sure that its solution will be at most n moves, then a tree search of depth n will find it. If, unbeknownst to you, the position of the scrambled puzzle is actually only a few moves from solved, then the search may take much longer than necessary. It may have to search many positions at depth n before finding a shorter solution. Tree searches are called 'depth first' searches for this reason, as it reaches out to the maximum depth before visiting all positions that are closer by. Such a tree search might also find a long alternative solution instead of the short one you actually would want.

To overcome these problems, use iterative deepening. This simply means that you do a tree search of depth 1, then one of depth 2, and so on, until a solution is found. This gives a hybrid of a breadth-first and depth-first search. It does repeat some work each time, but overall it is quicker because deep searches take a long time. Furthermore it will always find the shortest possible solution. This algorithm is known by the abbreviation IDA.

Pruning

Tree searching is still slow. It would be much quicker if it doesn't need to search as deeply. Suppose we have done 5 moves so far in a depth 12 search. Only very few of the branches in any tree search reach a solution, so if we could somehow know that all branches that continue from this position are dead ends, i.e. that the current position cannot be solved within 7 moves, then we need not try any further.

A pruning table gives just this kind of information. For each position, it gives a lower bound on the number of moves needed to solve it. At first glance it seems that it is ridiculous because if you had such a table, you might as well have used it to store God's Algorithm. This is not the case as a pruning table does not have separate entries for each puzzle position. Each entry in a pruning table represents many puzzle positions. All these positions are further away from solved than the distance given by the table. A pruning table is calculated using exactly the same methods as were used for God's algorithm, except that instead only part of the position is used to index the database.

It is easiest to explain by giving an example. Consider the 2×2×2 Rubik's Cube. There are N1 = 7! possible piece permutations, and N2 = 36 possible piece orientations. When calculating God's algorithm, we would convert a puzzle position into a permutation number n1, an orientation number n2, and then use these as indices into a large two-dimensional table of N1 by N2. For pruning tables we could use one small table of size N1 for the permutation and one small table of size N2 for the orientation. These two tables contain the minimum values of the distances in the columns and rows of the God's Algorithm table.

If it takes 5 moves for example to solve only the orientations of the pieces, without even bothering about the permutations, then it will take at least that many to solve the position fully. At each step in the tree search you can check whether you still have enough moves left to solve the orientation, and similarly if there are enough moves left to solve the permutation. If so, then continue searching, but if not then you don't have to look any further from this position and have to backtrack and try something else.

This algorithm is sometimes given the name IDA*. The code for this algorithm is as follows:

  function IDA2 ( position p )
    for depth d from 0 to max
      Treesearch( p; d )
    endfor
  endfunction

  function Treeseach( position p; depth d )
    if d=0 then
      if p is solved then
        Hooray!
      endif
    elseif d>0 then
      if prune1[p]<=d and prune2[p]<=d then
        for each available move m
          treesearch( result of m applied to p; d-1 )
        endfor
      endif
    endif
  endfunction

In this example code I have assumed that there are two pruning tables, but it can obviously be changed for any number of them.

Increasing speed, Transition tables

The pruning tables improve the speed of a tree search significantly, more so if they are carefully chosen. It is best if every essential part of the puzzle position is used in some way in a pruning table, the pruning tables are as large as possible, and also independent of each other. Independent in this sense means that for any indices n1 and n2 into two pruning tables, there is some puzzle position that has those two indices.

One aspect that I have not clarified is the phrase 'available move' when performing a tree search. It is clearly undesirable to undo the move that has just been performed at the previous level of the tree. Often moves should not be repeated either because instead of doing on a Rubik's Cube for example R followed by R, we could have done R2 straight away. Simply put, any R, R2, or R' move should not be followed by R, R2, or R' because otherwise the search checks many positions several times. Also, since RL=LR we can also assume that R (or R2, R') never follows L (or L2, L'). Most puzzles have similar simple identities that can be checked.

Another significant way of speeding up the search is reducing the overhead at each node in the tree. At most nodes, the current position has to be looked up in pruning tables, changed by performing a move and then passed on to the next level of the tree search. To look up a position in the pruning tables, it needs to be converted to one or more index numbers. It is therefore best if that conversion is unnecessary because the current position is already given by such a set of indices. To do a move on a position given by a set of indices, you can use transition tables. These are tables that give the indices for the new position resulting from applying a move to the previous position.

Again an example is in order. On the 2×2×2 cube, each position is completely determined by the orientation of the pieces, and the permutation of the pieces. The position is therefore encoded in two indices. We can have a pruning table for each index as explained before. We also a transition table of size N1 × M, which gives the effect on the first index of any move. Here M is the number of possible moves. Similarly there is a transition table for the second index too, of size N2 × M.

A puzzle of which the positions are given by two indices can be searched by using the code below. Extending to more indices if necessary is trivial.

  function Treeseach( Index1 p1; Index2 p2; depth d )
    if d=0 then
      if position p1;p2 is solved then
        Hooray!
      endif
    elseif d>0 then
      if prune1[p1]<=d and prune2[p2]<=d then
        for each available move m
          treesearch( trans1[p1,m]; trans2[p2,m]; d-1 )
        endfor
      endif
    endif
  endfunction

In the above I have assumed that the transition tables give all possible moves. On the 2×2×2 cube this would mean that M=9, because the moves are {R, R2, R', F, F2, F', U, U2, U'} (and we consider piece BLD fixed). This is not necessary, as we only need to have M=3 to encode the transitions by moves {R, F, U} and the others can then be deduced by repeatedly applying the transition table. This can save on memory storage which can be better applied by having larger pruning tables.

Kociemba's Algorithm

All the discussion above assumes that you actually want to find the shortest solution. A tree search might take a long time even with good pruning tables. Herbert Kociemba managed to combine several ideas into a very effective new algorithm which will give good suboptimal solutions very quickly. It may well find an optimal solution fairly soon, but it can take a long time to actually prove it is optimal by trying out all shorter sequences.

The first idea was based on Thistlethwaite's work. Kociemba uses only two stages however. His first stage moves from G0 to G1 = <U, D, R2, L2, F2, B2>, and the second stage from G1 to G2 = I. Clearly these stages are too large to build a full table. Nevertheless, it is quite straightforward to make pruning tables and and use IDA* to solve each stage. Already this two-stage algorithm will clearly lead to some improvement on Thistlethwaite, because the first stage of this algorithm finds the shortest possible way of going through the first two parts of Thistlethwaite, and the second stage the shortest way to go through the last two parts. It is hard to quantify how much is gained because it is difficult to give an upper bound on the length of the two stages.

The second major idea was to continue searching after the first solution is found. As was noted with Thistlethwaite's algorithm, a different stage 1 solution may well have a better possible stage 2 solution. After one solution is found, other stage 1 solutions are tried to see if these give a better stage 2 and hence a better overall solution.

This is not the end of it though. Suppose we have found a solution of length 7+8, and all other the length 7 stage 1 solutions have been tried. By continuing the stage 1 IDA* even further, it tries to find solutions of length 8, followed by a stage 2 solution of at most 6 (so that the sum 8+6 is less than the solution we have so far). Eventually, as the stage 1 search depth increases, the length of allowed stage 2 solutions decreases until stage 1 has reached the length of the best solution found so far. This means that it is an optimal solution.

This algorithm is extremely effective. It very quickly finds solutions which are not far from being optimal.

Although Kociemba originally designed his algorithm for solving the normal Rubik's cube, it is possible to apply it to other puzzles. My Square-1 solver uses it for example, and I also once made a Siamese Cube solver. Any puzzle for which you can find a subgroup that makes the two stages roughly equal, and which is small enough to be calculated by IDA*, can have the Kociemba algorithm applied to it.

It may be possible to change this algorithm to use 3 or more stages, though it will be far less efficient in such cases. If however the search depths can be kept within reasonable bounds, it should work.

Home
Links
Guestbook


Indexing: pseudo-code examples

Indexing Orientations
With zero twist constraint

Indexing Permutations
With parity constraint

Indexing Combinations

Calculating tables

Indexing Orientations

If n pieces of a puzzle all have v possible orientations, then encode the orientation of each of these pieces as a number between 0 and v-1. Then n of such orientation values in an array or[1...n] can be encoded into a number between 0 and vn-1 as follows:

t=0
for i = 1 to n
  t = t * v
  t = t + or[i]
endfor
return t

To extract the individual orientations again from t < vn-1, use the following code:

for i = n to 1
  or[i] = t mod v
  t = t / v
endfor

Usually there is the constraint that the total twist is 0 modulo v, in other words the orientation of the last piece is dependent on the other n-1. In this case just do not encode the orientation of the last piece, which gives a number between 0 and vn-1-1:

t=0
for i = 1 to n-1
  t = t * v
  t = t + or[i]
endfor
return t

To extract the individual orientations again from t < vn-1-1, use the following code:

s=0
for i = n-1 to 1
  or[i] = t mod v
  s = s - or[i]
  if s < 0 then s = s + v
  t = t / v
endfor
or[n] = s

Indexing Permutations

If n pieces of a puzzle can be permuted amongst themselves then their permutation can be encoded in a number between 0 and n!-1. Use a fixed numbering for both the pieces and the positions: the n piece positions are numbered from 1 to n, and the pieces are also from 1 to n (usually so that piece 1 belongs at position 1 when solved, piece 2 at position 2 and so on, but this is not strictly necessary). The permutation is stored in an array pm[1...n]. A permutation can now be encoded as a number between 0 and n!-1 as follows:

t = 0;
for i = 1 to n-1
  for j = i+1 to n
    if pm[i] > pm[j] then t = t + 1
  endfor
  t = t * (n-i)
endfor
return t

Note that if all pieces are in position then it is encoded as 0. To extract the permutation again from a number t < n! use this:

pm[n]=1
for i = n-1 to 1
  pm[i] = 1 + (t mod (n-i+1))
  t = t / (n-i+1)
  for j = i+1 to n
    if pm[j] >= pm[i] then pm[j] = pm[j] + 1
  endfor
endfor

Often there is the constraint that the permutation must have even parity. This means that the position of the last two pieces is dependent on the other n-2. In this case just do not encode the position of the last two pieces, which gives a number between 0 and n!/2 - 1:

t = 0;
for i = 1 to n-2
  for j = i+1 to n
    if pm[i] > pm[j] then t = t + 1
  endfor
  t = t * (n-i)
endfor
return t

To extract the even permutation again from a number t < n!/2 use this:

pm[n] = 2
pm[n-1] = 1
s = 0
for i = n-2 to 1
  pm[i] = 1 + (t mod (n-i+1))
  s = s + pm[i]-1
  t = t / (n-i+1)
  for j = i+1 to n
    if pm[j] >= pm[i] then pm[j] = pm[j] + 1
  endfor
endfor
if s mod 2 = 1 then swap pm[n] , pm[n-1]

Indexing Combinations

If m pieces identical pieces of a puzzle can be in any of n positions, then there are n!/m!(n-m)! ways to do this. Use a fixed numbering for the positions, from 1 to n. The combination is stored in an array cm[1...n], where an array element is p if one of the pieces is there and some other value otherwise. A combination can now be encoded as a number between 0 and n! / ( m!(n-m)! ) -1 as follows:

t = 0
r = m
for i = n-1 to 0
  if cm[i+1] = p then
    t = t + comb(i,r)
    r = r - 1
  endif
next
return t

Here comb(i,r) equals i!/ ( r!*(i-r)! ). For speed, it is best to have a pre-calculated n by n table with the values for the various i and r. To extract the permutation again from a number t < n!/m!(n-m)! use this:

r = m
for i = n-1 to 0
  if t >= comb(i,r) then
    t = t - comb(i,r)
    cm[i+1] = p
    r = r - 1
  endif
endfor

Calculating tables

The pseudo-code below calculates God's algorithm for a puzzle, i.e. a table with the distances from start for all positions. It is assumed that a position can be converted to an index between 1 and N using the function pos2idx, and vice versa using the function idx2pos.

Fill table completely with -1.
table[ pos2idx(startposition) ] = 0
len = 0
loopbegin
  c = 0
  for p = 1 to N
    if table[p] = len then
      for each available move m
        q = pos2idx( m applied to idx2pos(p) )
        if table[q]=-1 then
          c=c+1
          table[q] = len+1
        endif
      endfor
    endif
  endfor
  len = len + 1
  print c "positions at distance" len
loop while c>0
Clearly it is faster if the expression pos2idx(m applied to idx2pos(p)) is calculated beforehand for all p and m, i.e. if a transition table is used. If a transition table would too much trouble to implement, or too large and p cannot be split into several indices each with its own small transition table, then it is certainly best to calculate idx2pos(p) outside the innermost for loop.
Note that the same method is used for calculating pruning tables. For God's algorithm we have a one on one relation between the numbers 1 to N, but for pruning tables this is no longer the case. Each number represents many puzzle positions, and pos2idx() converts all these to that number, and idx2pos generates any one of those positions which is used to represent them all. Thus we still have p = pos2idx(idx2pos(p)) for any number 1<=p<=N.

Back to Computing page

Home
Links
Guestbook


Mini Cube, the 2x2x2 Rubik's Cube

Picture kindly supplied by Stephen M. Caraco

  1. Description
  2. The number of positions
  3. JavaScript simulation
  4. Notation
  5. Solution 1
  6. Solution 2
  7. Nice patterns
Links to other useful pages:
Denny's Puzzle Pages A very nice graphical solution.
Matthew Monroe's Page Although a solution for the 3x3x3 cube, it is corners first, and thus applies to the pocket cube as well.
Philip Marshall's page A relatively short solution.
A Nerd Paradise by Blake has solutions for the various cubes, Pyraminx, Skewb and Square-1.

This puzzle is a smaller version of the Rubik's Cube. It goes under various names, such as Mini Cube and Pocket Cube. The puzzle is built from 8 smaller cubes, i.e. a 2x2x2 cube. Each face can rotate, which rearranges the 4 small cubes at that face. The six sides of the puzzle are coloured, so every small cube shows three colours.

This puzzle is equivalent to just the corners of the normal Rubik's cube. It is a little confusing though, because there are no face centres to use as a reference point.

A related puzzle is the pyramorphix, which is like the cube but where the orientation of four of the pieces does not matter.

The number of positions:
There are 8 pieces, with 3 orientations each, giving a maximum of 8!·38 positions. This limit is not reached because:

  • The total twist of the cubes is fixed (3)
  • the orientation of the puzzle does not matter (24)
This leaves 7!·36 = 3,674,160 positions.

Every position can be solved in at most 11 moves (if a half turn is also considered a single move). A few years ago I used a computer search to find God's Algorithm, i.e. the shortest solution for each position. Other people have done this also as far back as 1981, and the result is shown in the following table:
Moves | Positions
0 | 1
1 | 9
2 | 54
3 | 321
4 | 1,847
5 | 9,992
6 | 50,136
7 | 227,536
8 | 870,072
9 | 1,887,748
10 | 623,800
11 | 2,644
Total | 3,674,160

This number is relatively small, so a computer can very quickly search through all positions to find the shortest possible solution for any given position. If your browser supports layers/styles, (i.e. Netscape 4+, Explorer 5+) then you can play a Javascript version which includes such a solver. It takes a moment to load because it has to prepare some pruning tables for the search algorithm of the solver.

Click here for a Javascript Mini Cube

Notation:
Let the faces be denoted by the letters L, R, F, B, U and D (Left, Right Front, Back, Up and Down). Clockwise quarter turns of a face are denoted by the appropriate letter, anti-clockwise quarter turns by the letter with an apostrophe (i.e. L', R', F', B', U' or D'). Half turns are denoted by the letter followed by a 2 (i.e. L2, R2, F2, B2, U2 or D2).

Note that on this cube the moves LR' is simply a rotation of the whole cube. Similarly FB' or UD'. Therefore moving only three adjacent faces is enough to solve the cube. If we only use the F, R and D faces to solve it, then the UBL corner is never moved from its place, and the other pieces are simply placed so they line up with it. The first solution below will use all the faces because it is based on a solution for the normal Rubik's Cube.

Solution 1:
Phase 1: Solve the top layer.

  1. Decide which colour you want to place on the top face. Then hold the cube so that at least one piece already shows that colour on the top face. The remaining pieces on the top face will be placed relative to that piece.
  2. Find a piece in the D layer that belongs in the U layer. Rotate D so that the piece is below its destination and rotate the whole cube to get it to the front right. If all the U layer pieces are already in the top layer though some are wrongly placed then choose any D piece to displace any wrong piece from the U layer.
  3. Depending on its orientation, do one of the following:
    1. To move FRD->URF do FDF'
    2. To move RDF->URF do R'D'R
    3. To move DFR->URF do FD'F'R'D2R
  4. Repeat b-c until the top layer is done.
Phase 2: Place the bottom layer pieces, ignoring orientation.
  1. Rotate the D layer to get at least two pieces in the correct position, though they may be twisted.
  2. If necessary swap two pieces by using the following:
    1. To swap DFR, DBL do F'R'D'RDFD'
    2. To swap DFR, DFL do FDF'D'R'D'R
Phase 3: Twist the bottom layer pieces correctly.
  1. Do one of the following sequences to solve the remaining pieces. Clockwise twists are denoted by a +, anti-clockwise ones by a -.
    1. To twist DFL-, DBL+ | do R'D'R F' DR'DR D2F2
    2. To twist DFL+, DBL- | do F2D2 R'D'RD' F R'DR
    3. To twist DFL-, DBR+ | do R2D'R D2R'D2R D'R2D
    4. To twist DFR-, DRB-, DBL- | do R'D'RD' R'D2RD2
    5. To twist DFR+, DRB+, DBL+ | do D2R'D2R DR'DR
    6. To twist DFR-, DRB+, DBL-, DLF+ | do R2D2 R D2R2 D
    7. To twist DFR+, DRB-, DBL-, DLF+ | do RDF R2D2F2 DF'DR2
This solution takes at most 24+8+10=42 moves.

Solution 2:
This solution is loosely based on the Thistlewaite algorithm adapted for the 2x2x2 cube. It uses fewer moves than solution 1, but is far more complicated since it uses a large table of sequences.
Phase 1: Orient all pieces correctly.

  1. Choose the colours which will go on the top and bottom faces of the cube.
  2. Hold the cube so that at least three of the pieces show one of those two colours on the top and bottom faces.
  3. Examine which pieces need to be twisted and in which direction to make the top/bottom faces a mixture of the two chosen colours.
  4. The following table lists all possible sequences needed to fix the orientations. The left column shows the twist the pieces need, in the order ULB, UBR, URF, UFL, DBR, DRF, DFL, DLB, where a + means it needs a clockwise twist, a - an anti+clockwise twist.
    5. -0+00000 | FRU2R'F
-+000000 | R2URF'UF
+-000000 | RU2RU2R
0---0000 | R2U2F'RF
--++0000 | RF'R2F2UR
-+-+0000 | F2U2F
+000-000 | FU'RF
00+0-000 | R'FR'F
--00-000 | R'UR
0-0--000 | FRF
0-++-000 | R2U'F
0+-+-000 | FR2F
+-0+-000 | R2F2U'F
--+--000 | R'F2UR
++++-000 | RU'R'FR2F
0+0+-0-0 | R2F
0++0-0-0 | RUF2U'R
++00-0-0 | R'UR2FR
-0-+-0-0 | RFUR
+0---0-0 | FUR2F
0+---0-0 | R'F2R'F
0--+-0-0 | FRUF
00++--00 | R2U2F2UR
0+0+--00 | R'URU2R
0++0--00 | FR2F2RF
+0+0--00 | RU2FU'R
++00--00 | RUF2R2F
+0----00 | FRFU2R
0+----00 | R2FR2U'R
-+0---00 | FR2F'UR
-+-+--00 | R'F'U2F
0--+--00 | RUF'U'F
0-+---00 | FR2F'R
--0+--00 | R'U'RU2R
+--0--00 | RU2RU'R
--+0--00 | F2R'U2F'R
0+-0-+00 | F2R2F
-0+0-+00 | R'UR2U'R
-+00-+00 | R2F'U2F
+0-0-+00 | FU'R2U'R
0----+00 | FR2U'R
---0-+00 | RF'U2F
0-+0+-00 | R
+0-0+-00 | R'F'U'F
+-00+-00 | F2R'U2R
-0--+-00 | RF2UR
00+--0+0 | RF'RF2R
00-+-0+0 | FRFR
-0+0-0+0 | R2UF2R
+-00-0+0 | FR'U2RF
-00+-0+0 | R2U'R'F2R
--0--0+0 | R'U2F'R
---0-0+0 | F'RU2F
Phase 2: Put the pieces in position.
  1. Find a tetrad of pieces, i.e. 4 pieces which in the solved cube are not adjacent (i.e. any two of them have exactly 1 colour in common).
  2. Rotate U/D to get these pieces into one of the following patterns and do the sequence shown:
    UFL, ULB, DLF, DRB: R2UR2UF2
    UFL, ULB, UBR, DLF: R2UF2
    UFL, UBR, URF, DLF: F2U'F2
    UFL, UBR, DLF, DBR: R2U2F
    ULB, URF, DLF, DFR: F2
    This leaves the tetrad in the U layer, and the other tetrad in the D layer.
  3. Rotate U to get as many pieces from the U layer adjacent to matching pieces in the bottom layer, i.e. forming as many correct columns as possible.
  4. If there are 4 columns, then do UF2U2R2U; if there are 2 adjacent columns then holding the cube with those columns in the B face do the sequence F2U'F2U2R2UF2U; if there are 2 non-adjacent columns, then holding the cube with those columns at FR and BL do the sequence R2U2F2U.
  5. The cube can now be solved by using only half turns, and at most 4 are needed. This is trivial.
This solution takes at most 24 moves (not including cancellations between the steps in phase 2).

Nice patterns:

  1. U 4 horizontal flags (not mirror symmetric)
  2. U2 4 horizontal flags (mirror symmetric)
  3. F2 R2 F2 4 vertical flags
  4. U2 F2 R2 U2 Supertwist; 6 flags
  5. U F2 U2 R2 U 4 vertical flags, 2 checkerboards
  6. R2 F2 R2 U2 4 checkerboards
  7. R U2 R' F2 R U' R2 U F2 U' Cube in cube
  8. R F U' R2 U F' R U F2 R2 Cube in cube 2
  9. U R F2 U R F2 R U F' R 3-Cycle
  10. U R U' R2 U' R' F' U F2 R F' Column turn
  11. F' U R' F2 U' R F U R2 U R' Corner swap
  12. U F2 U' Zig-zag
  13. U' F2 U2 R2 U' F2 U2 R2 U' 2 Checkerboards, 4 L
The following patterns are symmetric, but don't look as nice.
  13. U R F2 U F2 R U' Triple swap.
  14. U' R2 F2 R' U2 F' R2 F2 U' Two 3-cycles
  15. F U2 R2 F2 U Supertwist 2
  16. F' R F2 U2 F' U' F U2 R2 U' Six twist
  17. F R' F U2 F R' U R' F2 U' Six twist
  18. F U' R' F2 U2 R2 U' F R' Four twist
  19. U R U2 F' U2 F2 U' F2 R' U' Four twist 2
  20. R2 F' R2 F2 R' F2 Four twist 3
  21. F2 U2 F' U2 F2 U' Four twist 4
  22. F U2 R' F2 R2 F' U2 R' Four twist 5
  23. F2 U R' F R U2 F' U R U2 R' Double corner swap
  24. U F2 U F' U F U' F U2 F 3-Twist

Home
Links
Guestbook


Rubik's Cube 3x3x3

Picture kindly supplied by Hendrik Haak

This is the puzzle that started it all. It is a cube which is built from smaller cubes, 3 to an edge, i.e. a 3x3x3 cube. The 9 pieces on each face can rotate, which rearranges the small cubes at that face. The six sides of the puzzle are coloured, so every corner piece shows three colours, every edge piece shows 2 colours, and every face centre only one.

Turning a face does not change the face centres (their twist is not a visible change of pattern) so these can be considered solved already, the other pieces have to be placed correctly around them.

The number of positions:
There are 8 corner pieces with 3 orientations each, 12 edge pieces with 2 orientations each, giving a maximum of 8!·12!·38·212 positions. This limit is not reached because:

  • The total twist of the cubes is fixed (3)
  • The total number of edge flips is even (2)
  • The pieces have an even permutation (2)
This leaves 8!·12!·37·210 = 43,252,003,274,489,856,000 or 4.3·1019 positions.

Links to other useful pages:
Rubik's homepage. The solution from the booklet, an easier new solution, and links to many others on the web.
Denny's Puzzle Pages. A very nice graphical solution.
A Nerd Paradise by Blake has solutions for the various cubes, Pyraminx, Skewb and Square-1.
Rob Brown's page. Rob's Rubix Repair, a program that gives the solving sequence after giving it the scrambled pattern.
Jiri Fridrich's page. A very fast layer algorithm.
Lars Petrus' page. A very fast and excellent method.
Hana Bizek and Josef Jelinek's page. All different types of solution of the cube.
Matthew Monroe's Page. A corners first solution.
Philip Marshall's page. An edges first solution.
Cyril Castella's page. A French solution.
Oxford computing lab. An old text based layer solution.
PuzzleSolver.com by Jake Olefsky has a layer method, with slight improvements leaving one column last during the first two layers.
Skip Lawson's page. Assumes you can solve the top layer, then graphically illustrates the middle layer, bottom corners and finally bottom edges.
Casey Cardwell's page. An illustrated layer algorithm.
Ola Rönnerup's page. Another layer algorithm.
Juergen Koeller's page. A layer solution, also available in German.
Ronald Bieber's page. A German solution.

There is little I can add to the massive amount written about the cube, both in books and on the internet. For completeness I will nevertheless give two solutions here. They are by no means fast, but are typical examples of cube solutions.

Notation:
Let the faces be denoted by the letters L, R, F, B, U and D (Left, Right Front, Back, Up and Down). Clockwise quarter turns of a face are denoted by the appropriate letter, anti-clockwise quarter turns by the letter with an apostrophe (i.e. L', R', F', B', U' or D'). Half turns are denoted by the letter followed by a 2 (i.e. L2, R2, F2, B2, U2 or D2).

Solution 1: In layers.
Phase 1: Solve the top layer edges.
This phase is straightforward, but I will nevertheless give a full description.

  1. Find an edge piece that belongs on the top face but which is not already there. If there are none, but they are not all positioned correctly, then give the side containing one of the incorrect ones a half turn.
  2. If that edge is in the bottom layer then rotate D to place the piece below its destination, and then hold the cube so that both the piece and its destination are in the front face.
    1. To move DF to UF, do F2.
    2. To move FD to UF, do U'F'RF.
    If instead that edge is in the middle layer then hold the cube so that the piece is at the front right, and do one of the following:
    1. To move RF to UF, do F'.
    2. To move RF to UR, do UF'U'.
    3. To move RF to UB, do U2F'U2.
    4. To move RF to UL, do U'F'U.
    5. To move FR to UR, do R.
    6. To move FR to UB, do URU'.
    7. To move FR to UL, do U2RU2.
    8. To move FR to UF, do U'RU.
With experience you can save many turns of the U face and choose the order in which you solve the edges so that this phase usually takes no more than 7 or 8 moves in total.

Phase 2: Solve the top corners.

  1. Find a corner piece in the bottom layer that belongs in the top layer. If there are none, and not all four are correct yet then hold the cube so that an incorrect corner is at UFR. If the colour of the face is at the front of the piece then do R'DR otherwise do R'D'R.
  2. Rotate D to place the corner piece below its destination, and hold the cube so that the piece and its destination are at the front right. Then do one of the following:
    1. To move FRD to URF, do FDF'.
    2. To move RDF to URF, do R'D'R.
    3. To move DFR to URF, do FD'F'R'D2R.
By solving corner pieces which don't show the U colour on the D face first, the longer b3 case is often avoided.

Phase 3: Solve the middle edges.

  1. Find an edge piece in the bottom layer that belongs in the middle layer. If there are none, and the middle layer is not correct then choose any of the bottom edges to displace a wrong piece in the middle layer. Hold the cube so that the destination of the edge is at the front right, and then rotate D to bring the edge piece at the front.
  2. Do one of the following to place the edge correctly.
    1. To move FD to FR, do D'R'DR DFD'F'.
    2. To move DF to FR, do D2FD'F' D'R'DR.
Phase 4: Position the bottom corners.
  1. Rotate D until at least two corners are positioned correctly, ignoring their orientations.
  2. If you need to swap two corners, then do one of the following:
    1. To swap DLF and DFR, do R'D'R FDF' R'DR D2.
    2. To swap DLF and DRB, do R'D'R FD2F' R'DR D.
Phase 5: Orient the bottom corners.
  1. If there are four twisted corners then hold cube so that a corner which is clockwise twisted at the front left (the D colour shows on the left of that corner).
    If there are three twisted corners then hold cube so that the corner which is not twisted at the front left (the D colour shows on the bottom of that corner).
    If there are two twisted corners then hold cube so that the corner which is anti-clockwise twisted at the front left (the D colour shows on the front of that corner).
  2. Perform R'D'RD'R'D2RD2.
  3. Repeat a-b if necessary until the corners are solved.
Phase 6: Position the bottom edges.
  1. Do one of the following:
    1. To swap DL-DR and DF-DB, do L2R2U2L2R2 D L2R2U2L2R2 D'
    2. To swap DF-DR and DL-DB, do R2L2 U F2R2L2B2R2L2 U' R2L2
    3. To cycle DR->DB->DL->DR, do L'RFLR' D2 L'RFLR'.
    4. To cycle DL->DB->DR->DL, do L'RF'LR' D2 L'RF'LR'.
You need not use sequences 1 and 2 since they can be solved by applying 3 or 4 twice.

Phase 7: Orient the bottom edges.

  1. Do one of the following:
    1. To flip DF, DR, do FU'DR2U2D2L D' L'D2U2R2D'UF' D.
    2. To flip DF, DB, do FU'DR2U2D2L D2 L'D2U2R2D'UF' D2.
    3. To flip all four edges, apply either of the above twice.

There are many similar solutions that solve the cube in layers. Many are a lot faster than this one. Speed can be improved in many ways:

  • Use more sequences for orienting the final corners, and in general use shorter sequences for phases 4-7.
  • Phase 2 and 3 can be combined, so that top corners and middle edges are first placed adjacent in the bottom layer and then slotted into position as a single unit. I generally use this method myself.
  • Phase 2 and 3 can be combined in a different way: First solve 3 top corners. Then place the three adjacent middle edges correctly, which uses shorter move sequences than above because of the unsolved corner. Each edge is done by turning U to place the unsolved corner above the edge destination, and then using three (or four) moves to place the edge. Once these are done, the final corner/edge is solved as described above.
  • Phase 4-7 can be combined in several different ways, nearly all of which involve memorising a large number of sequences.
    You could position all the bottom pieces correctly first (23 sequences), and then orient them (57 sequences). See the book 'Winning Ways Vol.2' by Berlekamp, Conway and Guy.
    You could do this in the opposite order too; orient them first (57 sequences) and then positioning them (23 sequences). See Jiri Fridrich's web page.
    You could solve the corners first (42 sequences) and then solve the edges (29 sequences).
    You could do this in the opposite order too; edges first (21 sequences) and then corners (86 sequences), but there are rather many sequences needed to do the corners in one step. You could however position (4) and orient (7) the corners in two steps (in either order) while leaving the edges untouched.
  • Another approach is that used by Lars Petrus on his web page. Instead of phases 1 and 2 he solves a 2x2x2 block, extends this to a 2x2x3 block and finally the top two layers except for one corner/middle edge. Then comes the best part. He now uses the unsolved column to orient the edges. He then solves the column, and solves the final layer like phases 4-6, except that all the sequences he uses do not change the edge orientations. As far as I know his method is the only fast solution that does not involve a large amount of memorisation. I mostly use his method to solve the cube's final layer.

Below is a corners first algorithm, i.e. all the corners are solved first, then the edges. Conceptually this is a good idea, since it can use slice moves (moves of a middle layer) which only involves edges. This kind of solution is relatively easy to understand and remember. They can be quite fast because of this, but they do generally use more moves than layer methods because turns of a slice are often counted as two moves.

Further notation:
The only slice moves in the following solution are moves of the middle layer, i.e. the layer between U and D. Let M denote a clockwise quarter turn of the middle layer when looking from above (the same direction as the move U).

Solution 2: Corners then edges.

Phase 1: Solve the corners.
Use any method you like. Use part of solution 1, or use the method for the mini cube. Afterwards the top and bottom centres should match their corners, but the centres in the middle layer need not match.

Phase 2: Solve the edges in the U/D layers.

  1. Find the edge piece that belongs at the front top. If it does not lie in the middle layer then rotate the whole cube around the U/D axis to bring it to the front face and do FM2F'.
  2. Hold the cube with the destination of the piece at the front top and turn M to bring the piece to the back right. Then do one of the following:
    1. To move BR to UF, do FMF'
    2. To move RB to UF, do F'M2F.
  3. Find the edge piece that belongs at the front bottom. If it already lies at the front bottom except upside down, then do F'M'F M' FM'F' to flip it around. If it does not lie in the middle layer and not at the bottom front then rotate the whole cube around the U/D axis to bring it to the front face and do FM2F'.
  4. Hold the cube with the destination of the piece at the front bottom and turn M to bring the piece to the back right. Then do one of the following:
    1. To move BR to DF, do F'M'F M F'M F
    2. To move RB to DF, do F'M'F M2 F M'F'
  5. Repeat a-d for each pair of edges in the U/D layers.

Phase 3: Solve the middle layer.

  1. Turn M to place the centres correct with respect to the U/D layers.
  2. Place the edges correct by doing one of the following:
    1. To swap FR-BL, FL-BR do M L2R2 M' L2R2.
    2. To swap FR-BR, FL-BL do R2 M2 R2 M2.
    3. To cycle FL->FR->BR->FL do R2 M' R2 M.
    4. To cycle FR->FL->BR->FR do M' R2 M R2.
  3. Orient the edges by doing one of the following:
    1. To flip FR and BR do RM'RM'RM'RM2 RM'RM'RM'R.
    2. To flip FL and BR do RM'RM'RM'RM RM'RM'RM'RM.
    3. To flip FR, FL, BR, BL do BUB' RM'RM'RM'RM' BU'B'.

There are not as many variations of the corners first algorithm as there were with the layers algorithm, but the speed of this algorithm can be improved in several ways.

  • Phase 2 can be speeded up simply by placing the edge belonging at UF in the FD position first, and when you next place the correct piece at FD, the first piece will be displaced and end up correctly at UF.
  • Another variation of phase 2 involves solving the edges singly instead of in pairs. Its basic idea is to rotate the layer opposite the destination to bring an unsolved edge to the front. This way you can solve 3 edges in each layer singly without disturbing solved edges. The final two edges are then placed as before.
  • Phase 3 can be done quicker by using shorter sequences, or by memorising sequences that place and flip edges at the same time. There are only 20 sequences needed for this.

The Thistlethwaite algorithm:

Finally, an explanation of the Thistlethwaite algorithm. This differs from layer algorithms and corners first algorithms in that it does not place pieces in their correct positions one by one. Instead it works on all the pieces at the same time, restricting them to fewer and fewer possibilities until there is only one possible position left for each piece and the cube is solved.

The way it does this is by first doing a few moves until a position arises that can be solved without using quarter turns of the L and R faces (though half turns of L and R are still needed). It then proceeds to do this by moving to a position that does not need quarter turns of the F, B faces either. After this a position is arrived at that does not need any quarter turns, and can hence be solved by half turns only, which it proceeds to do.

These four stages are quite complicated, since they use large look-up tables for all the positions at each stage. The table below shows the numbers involved:
Group | # positions | Factor
G0=<L, R, F, B, U, D> | 4.33*10^19 |  |
 |  | 2,048 | (2^11)
G1=<L2,R2,F, B, U, D> | 2.11*10^16 |  |
 |  | 1,082,565 | (12C4 *3^7)
G2=<L2,R2,F2,B2,U, D> | 1.95*10^10 |  |
 |  | 29,400 | ( 8C4^2 *2*3)
G3=<L2,R2,F2,B2,U2,D2> | 6.63*10^5 |  |
 |  | 663,552 | (4!^5/12)
G4=I | 1 |  |

Mathematically speaking, this is a sequence of nested groups, and each stage of the algorithm is simply a look-up table showing a solution for each element in the quotient coset space. The last column shows the order of these coset spaces, i.e. the size of the look-up tables used.

The first stage has a factor of 2,048=2^11. This corresponds to the fact that this stage fixes the orientation of the edges; it is impossible to flip edges if only half turns are allowed on the L, R faces, but otherwise the pieces can be put in any normal position with this restriction.

The second stage has a factor of 3^7 *12!/(8!4!). This corresponds to the fact that this stage fixes the orientation of the corners, and places the middle layer edges into their slice. It is fairly easy to see that if you are only allowed half turns on the sides together with any turns on the U, D faces, then the top and bottom faces will never have more than two colours, and the middle edge pieces will never leave their layer or be flipped. In fact, those restricted moves can solve any position under those conditions.

The third stage has a factor of [8!/(4!4!)]^2 *2*3. This corresponds to the fact that the edges in the U and D layers are placed in their correct slices, the corners are put into their correct tetrads, the parity of the edge permutation (and hence the corners too) is made even, and the total twist of each tetrad is fixed.

The final stage finally solves the cube.

The following table shows the number of moves each stage needs.
 | 1 | 2 | 3 | 4 | Total
Original algorithm: | 7 | 13 | 15 | 17 | 52
Improved algorithm: | 7 | 13 | 15 | 15 | 50
Best possible: | 7 | 10 | 13 | 15 | 45

To keep the size of the lookup tables down, Thistlethwaite used simplifying preliminary moves which is why the number of moves he needed is sometimes more than the best possible (the diameter of the quotient groups).

Home
Links
Guestbook


Rubik's Revenge / Master Cube / 4x4x4 Rubik's cube.

Picture kindly supplied by Hendrik Haak

This puzzle is a cube which is built from smaller cubes, 4 to an edge, i.e. a 4x4x4 cube. Each slice can rotate, which rearranges the small cubes on the surface of the puzzle. The six sides of the cube are coloured, so every corner piece shows three colours, every edge piece shows 2 colours, and every face centre only one.

Unlike the normal 3x3x3 Rubik's cube, turning a face does move the face centres. The centres therefore can not be immediately used as a fixed reference point.

The number of positions:
There are 8 corner pieces with 3 orientations each, 24 edge pieces with 2 orientations each, 24 centre pieces, giving a maximum of 8!·24!·24!·38·224 positions. This limit is not reached because:

  • The total twist of the corners is fixed (3)
  • The edge orientation is dependent on its position (224)
  • There are indistinguishable face centres (4!6)
  • The orientation of the puzzle does not matter (24)
This leaves 7!·24!·24!·36/4!6= 7,401,196,841,564,901,869,874,093,974,498,574,336,000,000,000 or 7.4·1045 positions.

Links to other useful pages:
Denny's Puzzle Pages A very nice graphical solution, top/bottom corners and centres then edges, followed by middle edges and centres.
Chris Hardwick's page. A solution that does centres, pairs up edges and then solves as for the 3x3x3 cube.
Dennis Palaganas' page. (problematic when viewed with Netscape)
Philip Marshall's page A solution that does centres, pairs up edges and then solves as for the 3x3x3 cube.
Oxford computing lab An old text based solution.

Like the normal cube, there are several types of solution. I will give three examples here, and mention some advantages or disadvantages of each.
Solution 1: Layer by layer.
Solution 2: Corners first.
Solution 3: Pairing up edges.

Notation:
Let the faces be denoted by the letters L, R, F, B, U and D (Left, Right Front, Back, Up and Down). Clockwise quarter turns of a face layer are denoted by the appropriate letter, anti-clockwise quarter turns by the letter with an apostrophe (i.e. L', R', F', B', U' or D'). Half turns are denoted by the letter followed by a 2 (i.e. L2, R2, F2, B2, U2 or D2). The above is the same notation as for the 3x3x3 cube. There is however a new type of move. The internal slices will be denoted by the lowercase letters l, r, f, b, u and d, and the type of move is shown in the same way as normal face moves. Note that these letters mean the slice only, so such a move will not disturb the corners of the cube.

Solution 1: In layers.

This is certainly not the best method, but it is how most people instinctively try to solve a cube. The reason it is not very good is that after the first layer, all further progress must disturb and restore that layer.

Phase 1: Solve the top layer centres.

  1. Find a face that has as many centre pieces of the same colour as possible, and hold that on top as the U face.
  2. Turn U to place a wrong centre piece at the bl position.
  3. Find a centre piece that belongs in the U face.
  4. If it does not lie in the D face then turn u or d so that the piece is on the front face. Turn F to place the piece in the dr position and do the sequence rUr'.
    If it lies in the D face then turn D to place the piece in the br position and do the sequence rU2r'.
Repeat the above process until all four top centre pieces are correct.

Phase 2: Solve the top corners.
The corners are solved before the edges because you are less likely to make a mistake in the colours of the sides that way. If you were to place the edges first and the colours of the sides were in the wrong order then the corners would not fit.
The corners are solved in the same way as on the normal cube layer method.

  1. Find a corner piece in the bottom layer that belongs in the top layer. If there are none, and fewer than three corners are in place in the top layer then hold the cube so that an incorrect corner is at UFR. If the colour of the face is at the front of the piece then do R'DR otherwise do R'D'R.
  2. If that edge is in the bottom layer then rotate D to place the piece below its destination, and hold the cube so that the piece and its destination are at the front right. Then do one of the following:
    1. To move FRD to URF, do FDF'.
    2. To move RDF to URF, do R'D'R.
    3. To move DFR to URF, do FD'F'R'D2R.
By solving corner pieces which don't show the U colour on the D face first, the longer b3 case is usually avoided.

Phase 3: Solve the top edges.

  1. Find an edge that belongs on the top face. Hold the cube so that its destination is at the top front.
  2. If the piece lies in the bottom face then turn D to bring it to the front, and then do one of the following:
    1. To move the FDr edge to the UFr position, do FdF'.
    2. To move the FDl edge to the UFr position, do BD2B' Fd2F'.
    3. To move the FDl edge to the UFl position, do F'd'F.
    4. To move the FDr edge to the UFl position, do B'D2B F'd2F.
  3. If the piece lies in the u or d slice then turn its slice to bring it to the back right and then do one of the following:
    1. To move the BRu edge to the UFl position, do FuF'.
    2. To move the BRd edge to the UFr position, do Fd'F'.
    3. To move the BRd edge to the UFl position, do F'd2F.
    4. To move the BRu edge to the UFr position, do F'u2F.
Phase 4: Solve the middle edges, both u and d slices.
  1. Find an edge piece in the bottom layer that belongs in one of the middle layers. If there are none, and the middle layer is not correct then choose any of the bottom edges to displace a wrong piece in a middle layer. You will have to hold the cube so that the destination of the edge is at the back left or right, depending on the sequence below, and then rotate D to bring the edge piece to the front.
  2. Do one of the following to place the edge correctly.
    1. To move the FDr edge to the BRd position, do r F'R2F r' F'R2F.
    2. To move the FDl edge to the BLd position, do l' FL2F' l FL2F'.
    3. To move the FDl edge to the BRu position, do l' F'R2F l F'R2F.
    4. To move the FDr edge to the BLu position, do r FL2F' r' FL2F'.
Phase 5: Place the centres.
  1. Find any centre that belongs in the D face, and hold the cube with that piece in the R face. Turn D to bring any incorrect centre piece to the fr position. Turn R to bring the piece to be placed at the db position. Then do the sequence rd'r'Drdr'D' and turn R back to normal.
    Repeat this until the D face is correct.
  2. The same method can also be used to correct the other centres. To swap a piece from the F face with a piece from the R face, use the sequence rf'r'Frfr'F' which moves the Fur piece to the R face, and the Rdf piece to the F face. This is the same sequence as a in a different orientation. You may have to turn the F and R faces first to get the pieces in position for the sequence to work, and turn the faces back afterwards in the opposite order.
Phase 6: Place the bottom corners.
  1. Rotate D until at least two corners are positioned correctly, ignoring their orientations.
  2. If you need to swap two corners, then do one of the following:
    1. To swap DLF and DFR, do R'D'R FDF' R'DR' D2.
    2. To swap DLF and DRB, do R'D'R FD2F' R'DR' D.
Phase 7: Orient the bottom corners.
  1. If there are four twisted corners then hold cube so that a corner which is clockwise twisted at the front left (the D colour shows on the left of that corner).
    If there are three twisted corners then hold cube so that the corner which is not twisted at the front left (the D colour shows on the bottom of that corner).
    If there are two twisted corners then hold cube so that the corner which is anti-clockwise twisted at the front left (the D colour shows on the front of that corner).
  2. Perform R'D'RD'R'D2RD2.
  3. Repeat a-b if necessary until the corners are solved.
Phase 8: Position the bottom edges.
  1. The following list has every possible combination of three edges on three different sides, and the given sequences cycle them around.
    1. To cycle DBr->DFr->DRf->DBr do r F'RF r' F'R'F
    2. To cycle DBr->DFr->DRb->DBr do BR'B' r' BRB' r
    3. To cycle DBl->DFl->DRb->DBl do l' F'RF l F'R'F
    4. To cycle DBl->DFl->DRf->DBl do BR'B' l BRB' l'
    5. To cycle DBr->DRf->DFl->DBr do B'L' f L'FL f' L'F'L LB
    6. To cycle DBr->DRb->DFl->DBr do B'L' RF'R' f' RFR' f LB
    7. To cycle DBl->DRb->DFr->DBl do B'L' b' L'FL b L'F'L LB
    8. To cycle DBl->DRf->DFr->DBl do B'L' RF'R' b RFR' b' LB
    To cycle the edges in the other way, either do the inverse of the given sequence, or do it twice.
    If you need to cycle three edges where two of them are adjacent, then simply use one of the sequences to put the other edge correctly in place which will disturb an edge on another face. You will then have a position with three edges on different faces that can be solved by on of the sequences on the list.
    To make two swaps, just cycle any three of them, and you will be left with only three pieces that again need to be cycled.
  2. You may find that you end up with two edges that need to be swapped. The reason that this is possible on this cube is that slice moves perform an odd permutation on the edges. By doing a single slice move, correcting the moved centres and cycling three of the edges back, a single edge swap has occurred. Face moves are even permutations on edges, so it is not possible to perform a single edge swap with only face moves.
    Here is such a sequence, which swaps DFr and DBr:
    1. FrBR2B'r'BR2B'F' r'U2D2l'U2D2r r2u2r2u2

Solution 2: Corners first method.

It is also possible to do a corners first method, i.e. corners, edges and finally centres. One advantage of this is that you will not hit the parity problem, see 8b above, where two edges need to be swapped. It was solved above by doing a slice move, cycling three of its edges, and solving the centres again. By doing the centres last this is not a big problem.

Phase 1: Solve the corners.
Use any method you like. Use part of solution 1, or use the method for the mini cube. Afterwards the top and bottom centres should match their corners, but the centres in the middle layer need not match.

Phase 2: Solve the edges in the U/D layers.

  1. Find the edge piece that belongs at UFl or UFr. If it does not lie in the middle layer then rotate the whole cube around the U/D axis to bring it to the front face and do FuF', or Fd'F' in the second case.
  2. Hold the cube with the destination of the piece at the front top and turn u or d to bring the piece to the back right. Then do one of the following:
    1. To move BRu to UFl, do FuF'.
    2. To move BRd to UFr, do Fd'F'.
    3. To move BRu to UFr, do F'u2F.
    4. To move BRd to UFl, do F'd2F.
  3. Find the edge piece that belongs at DFl or DFr. If it does not lie in the middle layer then rotate the whole cube around the U/D axis to bring it to the front face and do Fu2F', or Fd2F' in the second case.
  4. Hold the cube with the destination of the piece at the front bottom and turn u or d to bring the piece to the back right. Then do one of the following:
    1. To move BRu to DFl, do F' u'd F2 u'F'.
    2. To move BRd to DFr, do F' u'd F2 d F'.
    3. To move BRu to DFr, do F d' F2 u F.
    4. To move BRd to DFl, do F u F2 d'F.
  5. Repeat a-d for each pair of edges in the U/D layers.

Phase 3: Solve the middle layer edges.
In some ways this phase is similar to solving the corners of the Domino, except that an even number of turns of the sides are needed because the U/D layers must be conserved.

  1. Rotate d to place as many pieces correct as possible.
  2. Find an edge piece in the u layer that belongs in d, rotate the cube to put its destination at FRd, and rotate u to place that piece at FLu. Then to one of the following sequences:
    1. To move FLu->FRd->FLd->u layer, do uF2u'F2.
    2. To move FLu->FRf->u layer, do F2uF2uF2u'F2.
    If there is no d piece in the u layer then use and u piece to displace incorrect d pieces.
  3. Rotate u to place as any edges correct as possible. If two edges need to be swapped, then you can use one of the following:
    1. To swap FLu-BRu, do L2u2F2uF2u2L2uF2udF2d'
    2. To swap FLu-FRu, do R2du'R2d'R2uF2u'F2uR2u'

Phase 4: Solve the centres

  1. First we separate the centres into 3 sets, the F/B centres, L/R centres and U/D centres. These sets can be moved to their own pairs of faces by using the following sequences:
    1. To cycle Fur->Rub->Bur->Lub->Fur do r2ur2u'.
    2. To swap Fur-Rdf, do rf'r'Frfr'F'.
    These sequences do move other centres, but do not move others from the pair of faces where they belong.
    You may have to turn the cube, and turn some faces to get the pieces you want to move into position for the sequences to work, and turn the faces back afterwards in the opposite order.
  2. Hold the cube so that the F and B faces need to be solved. They will only contain F and B centres.
    If the faces each only have one piece wrong, then turn F so that the two wrong pieces are not in the same u/d layer but are in the same l/r layer.
    If the faces each have three pieces wrong, then turn F so that the two correct pieces are not in the same u/d layer but are in the same l/r layer.
    If the faces each have two pieces wrong, and they are not adjacent in either face, then turn F so that the wrong pieces lie in the same slices as those of the B face.
    If the faces each have two pieces wrong, and at least one pair is adjacent, then turn F and/or B so that the adjacent wrong pieces both lie in the u layer.
    Then do u2r2u2r2 and turn F and B back again if necessary.

Solution 3: Pairing up edges

There is one more type of algorithm for this cube and larger cubes. This involves putting the centres correct, pairing up edge pieces, and then solving it as if it were a normal 3x3x3 Rubik's cube. It is relatively simple, as only a few new sequences are needed.

Phase 1: Solve centres
To do this phase, you must know where the colours of the cube are supposed to be. If at any point you are unsure, look at the corner pieces to find out.

  1. Turn U to place a wrong centre piece at the bl position.
  2. Find a centre piece that belongs in the U face.
  3. If it does not lie in the D face then turn u and d together so that the piece is on the front face. Turn F to place the piece in the dr position and do the sequence rUr'.
    If it lies in the D face then turn D to place the piece in the br position and do the sequence rU2r'.
  4. Repeat a-c until all four top centre pieces are correct.
  5. Rotate the cube to place an unsolved face at u and do a-d again. Repeat until all the centres are solved.
Phase 2: Pair up the edges.
  1. Find any pair of edge pieces that have the same colours, but are not yet adjacent. Use any face moves (no slice moves) to place one at FDr and the other at FUl.
  2. Find the piece with colours matching FUr, and place it at FRd again using only face moves. If this is not possible, then put any unmatched piece there. If there are no unmatched pieces, it means that you have to swap FUr and FDr but not move anything else. The sequence U2rU2rU2rU2rU2rU2 will rearrange the edges so that you now have exactly three unmatched pairs again.
  3. Do rU'RUr'U'R'U.
  4. Repeat a-c until all pairs have been matched.
Phase 3: Solve the cube.
  1. Solve the cube as far as possible using any method for the 3x3x3 cube.
  2. There are two situations that can occur that are not possible on the normal Rubik's cube, viz. a flipped 'edge', or two swapped 'edges'. If you end up with two swapped corners because your method solves the corners last, then do a sequence that swaps two 'edges' and two corners, for example B2U'B'UB'R2FD'F'R2 which swaps DRB-DBL, and the DB-DL 'edges'.
    To solve the cube in these situations, you can use one of the following sequences:
    1. To swap DFr-DFl, do r2R2B2L' D2l'D2 rD2r'D2 F2r'F2 l LB2R2r2.
    2. To swap DFr-DBr, DFl-DBl, do B2r2 F'DR'FD' r2l2 DF'RD'F l2 B2.
    3. To swap DFr-DRf, DFl-DRb, do R'Br2 F'DR'FD' r2l2 DF'RD'F l2 B'R.
    Note that the last two sequences are based on a double edge flip of the normal Rubik's cube, as on the revenge these perform the required two swaps without disturbing centres.

Home
Links
Guestbook


Professor's Cube, the 5x5x5 Rubik's cube.

Picture kindly supplied by Hendrik Haak

This puzzle is a cube which is built from smaller cubes, 5 to an edge, i.e. a 5x5x5 cube. Each slice can rotate, which rearranges the small cubes on the surface of the puzzle. The six sides of the cube are coloured, so every corner piece shows three colours, every edge piece shows 2 colours, and every face centre only one.

Like the normal 3x3x3 Rubik's cube, each face has a centre piece which never moves from its spot, so these can be used as a fixed reference point, showing what colour each face should be.

The number of positions:
There are 8 corner pieces with 3 orientations each, 24 side edge pieces and 12 central edge pieces with 2 orientations each, 24 inside corner pieces, and 24 inside edge pieces, giving a maximum of 8!·24!3·12!·38·236 positions. This limit is not reached because:

  • The total twist of the corners is fixed (3)
  • The side edge orientation is dependent on its position (224 )
  • The number of central edge flips is even (2)
  • There are indistinguishable inside face pieces (4!12)
  • The permutation of corners and central edges is even (2)
This leaves 8!·24!3·12!·37·210/4!12= 282,870,942,277,741,856,536,180,333,107,150,328,293,127,731,985,672,134,721,536,000,000,000,000,000 or 2.8·1074 positions.

Links to other useful pages:
Meffert's page. The solution provided in its booklet.
Matthew Monroe's Page Solves centres, pairs up edges and solves as cube.
Dennis Palaganas' page Incomplete solution. (problematic when viewed in Netscape)

Like the normal cube, there are several types of solution. I will give some examples here, and point out the advantages and disadvantages of each.

Notation:
Let the faces be denoted by the letters L, R, F, B, U and D (Left, Right Front, Back, Up and Down). Clockwise quarter turns of a face layer are denoted by the appropriate letter, anti-clockwise quarter turns by the letter with an apostrophe (i.e. L', R', F', B', U' or D'). Half turns are denoted by the letter followed by a 2 (i.e. L2, R2, F2, B2, U2 or D2). The above is the same notation as for the 3x3x3 cube. There is however a new type of move. The internal slices will be denoted by the lowercase letters l, r, f, b, u and d, and the type of move is shown in the same way as normal face moves. Note that these letters mean the slice adjacent to the faces only, so such a move will not disturb the corners or the face centres of the cube. Occasionally we will want to rotate the central slice, the one parallel to the floor, between the u and d slices. This will be denoted by the letter m, where the direction of the move is as seen from above, so the moves m and u both move in the same direction.

I will not give a solution that solves this cube in layers (i.e. top centres, top corners/edges, middle centres/edges, bottom edges/corners). For a cube this size it is slow, and impractical compared to the other types of solution.

Solution 1: Corners first method.
Phase 1:Solve the top layer centres.

  1. First use slice moves to solve the inside edge pieces, i.e. form a small cross inside the U face. This is easy, so I will not elaborate.
  2. Turn U to place a wrong inside corner piece at the fr position.
  3. Find an inside corner piece that belongs in the U face.
  4. If it does not lie in the D face then turn u or d so that the piece is on the front face. Turn F to place the piece in the dr position and do the sequence d'r'dr. If it lies in the D face then turn D to place the piece in the fr position and do the sequence r'B'd2r
  5. Repeat b-d until all the top inside pieces are correct.
Phase 2: Solve the bottom layer centres.
  1. Find an inside edge piece that belongs on the bottom face. Hold the cube so that it lies in the front face and turn F to bring it to the u layer. Rotate D to put an incorrect inside edge to the r slice, and then do rFr' to replace it.
  2. Repeat a until all four inside edges of the D face are correct, i.e. it shows a small cross.
  3. Find an inside corner piece that belongs in the D face. Hold the cube so that it lies in the front face and turn F to bring it to the r and u slices. Rotate D to put an incorrect corner at the fr position, and do urB'uBr'.
  4. Repeat d until the bottom centre is finished.
Phase 3: Solve the corners.
Use any method you like. If you use a method for the mini cube, then turn the corners afterwards to match the top and bottom centres.

Phase 4: Solve the edges in the U/D layers.
Note that this phase is a combination of the corresponding phases in the solutions for the 3x3x3 and 4x4x4 cubes.

  1. Find one of the three edge pieces that belongs at UF. If it does not lie in the middle layer then rotate the whole cube around the U/D axis to bring it to the front face and do FuF', FmF' or Fd'F' where you use the sequence that move the slice containing the edge. It should now lie in the middle layer.
  2. Hold the cube with the destination of the piece at the front top and turn u, m or d to bring the piece to the back right. Then do one of the following:
    1. To move BRu to UFl, do FuF'.
    2. To move BR to UF, do FmF'.
    3. To move BRd to UFr, do Fd'F'.
    4. To move BRu to UFr, do F'u2F.
    5. To move RB to UF, do F'm2F.
    6. To move BRd to UFl, do F'd2F.
  3. Find the edge piece that belongs at DF, in the same slice as the piece that you just placed. If it is already in position but upside down, then do FmF'mF'mF to place it correctly. Note that the DFr and DFl pieces cannot be upside down. If it seems that way, then it is simply the other identically coloured piece that belongs there. If the piece you have found is in the bottom face then rotate the whole cube around the U/D axis to bring it to the front face and do Fu2F', Fm2F' or Fd2F' to bring it to a middle layer.
  4. Hold the cube with the destination of the piece at the front bottom and turn u, m or d to bring the piece to the back right. Then do one of the following:
    1. To move BRu to DFl, do F' u'd F2 u'F'.
    2. To move BRd to DFr, do F' u'd F2 d F'.
    3. To move BRu to DFr, do F d' F2 u F.
    4. To move BRd to DFl, do F u F2 d'F.
    5. To move BR to DF, do m' F m F2 m F.
    6. To move BR to DF, do F' m' F2 m'F.
  5. Repeat a-d for each pair of edges in the U/D layers.
Phase 5: Solve the middle layer edges.
Note that this phase is a combination of the corresponding phases in the solutions for the 3x3x3 and 4x4x4 cubes.
  1. Rotate d to place as many pieces correct as possible.
  2. Find an edge piece in the u layer that belongs in d, rotate the cube to put its destination at FRd, and rotate u to place the piece at FLu. Then to one of the following sequences:
    1. To move FLu->FRd->FLd->u layer, do uF2u'F2.
    2. To move FLu->FRd->u layer, do F2uF2uF2u'F2.
    If there is no d piece in the u layer then use and u piece to displace incorrect d pieces.
  3. Rotate u to place as any edges correct as possible. If two edges need to be swapped, then you can use one of the following:
    1. To swap FLu-BRu, do L2u2F2uF2u2L2uF2udF2d'
    2. To swap FLu-FRu, do R2du'R2d'R2uF2u'F2uR2u'
  4. Rotate m to place the centres correct.
  5. Place the m edges correct by doing one of the following:
    1. To swap FR-BL, FL-BR do m L2R2 m' L2R2.
    2. To swap FR-BR, FL-BL do R2 m2 R2 m2.
    3. To cycle FL->FR->BR->FL do R2 m' R2 m.
    4. To cycle FR->FL->BR->FR do m' R2 m R2.
  6. Orient the edges by doing one of the following:
    1. To flip FR and BR do RM'RM'RM'RM2 RM'RM'RM'R.
    2. To flip FL and BR do RM'RM'RM'RM RM'RM'RM'RM.
    3. To flip FR, FL, BR, BL do BUB' Rm'Rm'Rm'Rm' BU'B'.
Phase 6: Solve the inside corners
  1. First we separate the remaining inside corners into 2 sets, the F/B pieces and the L/R pieces. These sets can be moved to their own pairs of faces by using the following sequences:
    1. To cycle Fur->Rub->Bur->Lub->Fur do r2ur2u'.
    2. To swap Fur-Rdf, do rf'r'Frfr'F'.
    These sequences do move other centres, but do not move others from the pair of faces where they belong.
    You may have to turn the cube, and turn some faces to get the pieces you want to move into position for the sequences to work, and turn the faces back afterwards in the opposite order.
    Repeat until the pieces are separated.
  2. Hold the cube so that the F and B inside corners need to be solved.
    If only one inside corner is wrong on each of the two faces, then turn F so that the two wrong pieces are not in the same u/d layer but are in the same l/r layer.
    If the faces each have three inside corners wrong, then turn F so that the two correct pieces are not in the same u/d layer but are in the same l/r layer.
    If the faces each have two inside corners wrong, and they are not adjacent in either face, then turn F so that the wrong pieces lie in the same slices as those of the B face.
    If the faces each have two pieces wrong, and at least one pair is adjacent, then turn F and/or B so that the adjacent wrong pieces both lie in the u layer.
    Then do u2r2u2r2 and turn F and B back again if necessary.
    Repeat this also for the L/R faces.
Phase 7: Solve the inside edges.
For this phase we need a bit more notation. Let n denote the middle slice between l and r.
  1. First we separate the remaining inside edges into 2 sets, the F/B pieces and the L/R pieces. These sets can be moved to their own pairs of faces by using the following sequences:
    1. To cycle Fu->Ru->Bu->Lu->Fu do n2un2u'.
    2. To swap Fu-Ru,Fd-Rd, do Rm'B' u2n2u2n2 BmR'.
    3. To swap Fu-Ru, do Rm'd'B' u2n2u2n2 BdmR'.
    These sequences may move other inside edges, but do not move others from the pair of faces where they belong.
    You may have to turn the cube, and turn some faces to get the pieces you want to move into position for the sequences to work, and turn the faces back afterwards in the opposite order.
    Repeat this until the two sets are separated.
  2. Now solve the cube by using the following sequences:
    1. To swap Fu-Bu, Fd-Bd, do u2n2u2n2.
    2. To swap Fr-Br, Lb-Rb, do r2mr2m'.
    3. To swap Fu-Bu, do F'd2F u2n2u2n2 F'd2F

There is one more type of algorithm which is especially effective on this cube. It involves putting the centres correct, joining up edge pieces, and then solving it as if it were a normal 3x3x3 Rubik's cube. It is relatively simple, as only a few new sequences are needed.

Solution 2:
Phase 1:Solve centres.
The method below solves the F centres without disturbing any already solved faces. Simply repeat this for each of the faces.

  1. Find an inside edge that belongs on the F face. Hold the cube so that it lies on the L, R or B face. Turn that face to bring it to the u layer. Turn F so that an unsolved inside edge lies at the Fl position. Now do one of the following:
    1. For Lu->Fu, do u'Fu.
    2. For Bu->Fu, do u2Fu2.
    3. For Ru->Fu, do u Fu'.
  2. Repeat a to put all the inside edges of the F face correct.
  3. Find an inside corner that belongs on the F face. Hold the cube so that it lies on the L, R or B face. Turn that face to bring it to the top left corner of that face (i.e. at Lub, Bur or Ruf). Turn F so that an unsolved inside corner lies at the Fur position. Now do one of the following:
    1. For Lub->Fur, do u'R'u R'u'R2u.
    2. For Bur->Fur, do u2B'u2B'u2B2u2.
    3. For Ruf->Fur, do u'R'u R'u'R2u.
  4. Repeat c to put all the inside corners of the F face correct.
  5. Repeat a-d for each of the faces.
Phase 2: Join up the edges.
  1. Find any central edge piece and any other edge piece that has the same colours, but which are not yet adjacent. Use any face moves (no slice moves) to place them in the m and u layers respectively. Make sure that the central edge piece is oriented in such a way that a move of the u layer would line the two pieces up correctly.
  2. Use any face moves to place an unmatched edge piece at the FUr position. Give priority to those triplets where the FUr piece has the same colours as its adjacent central edge, but where the central edge is upside down. If you cannot find any other unmatched edge, then do the sequence R2uR2uR2uR2uR2uR2 and try again.
  3. Rotate u, and m to line the three edges up at the FR position.
  4. Do RU'R' and then turn u back so that the centres match again.
  5. Repeat a-d until all edges have been joined up into triples, or until you can no longer find three sets of triples that are not matched.
Phase 3: Solve the cube.
Solve the cube with face moves only, using any method for the 3x3x3 cube. This is always possible. The exceptional cases that occur with the 4x4x4 cube will not happen because the central edges have already forced the other edges to be in a solvable position.

Home
Links
Guestbook


Cubic Circular, Issue 1

The Cubic Circular magazine was written and produced by David Singmaster in the early Eighties. The first issue was a small 16 page pink booklet, of about 19.5 × 14cm. Later issues were on yellow paper and slightly larger at 21 × 14.5cm (A5 format). There were only 5 magazines published, of which 3 were double issues:

Issue 1: | 16 pages | Autumn 1981
Issue 2: | 16 pages | Spring 1982
Issue 3&4: | 36 pages | Spring&Summer 1982
Issue 5&6: | 28 pages | Autumn&Winter 1982
Issue 7&8: | 48 pages | Summer 1985

The first issue is reproduced below. I have tried to keep it as close to the original as possible, so I have kept the images in the same style, even though most pictures have been redrawn. A sheet with corrections was also included with this first issue, pertaining mostly to the article about Ernö Rubik, so I have inserted it at that point. I have occasionally inserted a comment or correction of my own, and to be clearly distinguishable from David's text my comments are in italics and in square brackets,
[like this - J ].

David Singmaster still has many copies of the Cubic Circular available, so I highly recommend acquiring them from him directly. David can be contacted via e-mail (zingmast@sbu.ac.uk) or at:

    David Singmaster
    87 Rodenhurst Road
    London, SW4 8AF
    United Kingdom

The text and original drawings are copyright © David Singmaster, reproduced with permission. Conversion to html and additional commentary by Jaap Scherphuis.

Home
Links
Guestbook

Cubic Circular Logo

CUBIC CIRCULAR

A quarterly newsletter for Rubik Cube addicts

Issue 1 Autumn 1981

CONTENTS |
Welcome, Advertisement and Introduction | 2
Ernö Rubik and his Cube | 3
Cube Variations | 5
Pyraminx - The Magic Tetrahedron | 10
Clubs | 12
Shortest Times and Competitions | 12
Funny Moves | 14
Errata to my Notes | 14
General Anecdotes | 15
Marital Anecdotes | 16

Published by David Singmaster Ltd., London, England. ISSN NO 0261-8362

2

WELCOME, ADVERTISEMENT AND INTRODUCTION

Welcome to the first issue of the CUBIC CIRCULAR. Let me begin by telling you my plans for the Circular. Primarily it will be a newsletter to distribute information on the Cube. However, there have been many new puzzles as a result of the enormous success of Rubik's Cube™, and the circular will discuss these as well.

There has been so much interest in such puzzles and other mathematical puzzles, that I have established a company to distribute them. I will use the Circular to announce interesting new products as they appear, both from ourselves and from other sources. We are always delighted to hear about new items for possible distribution and we maybe able to organise production of them. Samples, drawings, patent specifications, etc. will be gratefully received.

There has been a persistent demand for a newsletter like the Circular ever since the fifth edition of my "Notes of Rubik's 'Magic cube'" appeared in September 1980. As a consequence of the explosion of Cube mania at the beginning of 1981, I have been receiving letters at several times the rate at which I can read and reply to them. Included are manuscripts, books, computer programmes and computer printouts which can run to hundreds of pages and require weeks to study! Consequently my study is piled with unanswered correspondence and I would like to apologise to everyone who has written and hasn't yet had a reply. I am hoping that the Circular will contain the answers to some of the more standard questions and perhaps reduce the number of letters sent in by providing the answer. The Circular may also be usable as a standard response letter.

Because much recent material In my study has not yet been properly read and filed, I find myself sometimes remembering facts that I cannot relocate and so I am sometimes unable to give proper credit to the source of an idea or fact.

I am delighted to receive copies of articles on the cube or related material - but please be sure to put the date, name and place of publication on it. I would prefer an original version rather than a photocopy, if at all possible. I would appreciate it if you can include such details as the page number(s), transliteration and/or translation of the title and/or abstract of the content for articles not in English, French, German or Italian. Information on radio and TV items will also be appreciated - but again, please be as detailed as possible.

At present, I have enough material to fill several Circulars - indeed, I am presently preparing a bibliography which would fill several issues by itself! This issue contains rather less than I had intended - all technical material has been deferred. Nonetheless, I would be happy to receive short articles, news items, announcements, etc. for inclusion.

The Circular can be considered as further addenda to the fifth edition of my Notes which is now being published by Penguin. A Spanish translation of my Notes by Gilberto Torbeck is being published by Altalena Editores, Cochabamba 2, Madrid 16, Spain at 400 pesetas. A German translation by Suzanne Bischoff will soon be published by Springer-Verlag, Berlin & Heidelberg. A Dutch version is under way. We shall stock copies when they are available. References to the Notes will be in the form N5, NS3, meaning page 5 and page S-3 of the Notes. (In the American printing, pages i, ii became v, vi; pages S-1 to S-4 became 61 to 64, pages B-1 and B-2 were extended to 65 to 68 and I-1 to I-5 became 69-73). I will refer to page 2 of Circular 1 as C1-2, etc. I will use the notation of my Notes since it seems to be the most widely accepted of all notation. For typographic convenience, I will abbreviate 3×3×3 as 33, etc.

I had hoped this circular would appear in early October. Apologies for the delay. I will try to get the next circular done over Christmas.

3

ERNO RUBIK AND HIS CUBE

[Corrections to this article can be found at the end. - J ]

I have recently been informed by Cedric Smith that the symbol above the ö in Rubik's first name is not an umlaut (") but a mark indicating a long o. This symbol is not available on English typewriters and the attempt to produce it gives ö which is a little odd looking, but acceptable.

Ernö Rubik was born in Budapest in 1944 to an eminent Hungarian family. His father, Ernö Rubik Senior, was an aeronautical engineer who designed many gliders and was awarded the Kossuth Prize (Hungary's highest honour). Rubik first studied sculpture, matriculating from the Fine and Applied Arts Gymnasium in 1962 with a distinction in sculpture. He then shifted to architecture, obtaining a diploma from the Budapest Technical University in 1967. He then did a post-graduate diploma in interior architecture or architectural planning (the sources vary - perhaps it was a joint course or the English translations refer to the same subject?) at the Academy of Applied Arts. Upon completing this course in 1971, he was appointed a lecturer at the Academy and began teaching three-dimensional design among other subjects. He is now head of the studio for the study of form.

Rubik found that his students, even the post-graduates, had great difficulty with three-dimensional visualisation. Consequently he was thinking about various exercises for his students. Cutting a cube with various planes is a fairly standard exercise and leads to the well-known 23 and 33 arrays. Rubik has a life-long interest in mechanisms, undoubtedly assimilated from his father. While contemplating the 23 and 33 arrays about May of 1974, this interest led him to ask, "How can I make the faces move?" Within six weeks, he had a solution, first for the 23 and then for the 33 (which is much easier than the 23). It took him a month to solve the cube when he made his first model. He applied for a patent on 30 January 1975.

At the end of 1976, he approached Trial, the major toy distributor in Hungary, and they sent him to Politechnika Ipari Szövetkezet (i.e. Politechnika Co-operative), which made plastic chess sets and similar games. Gyula Nemcsók, the chairman and co-founder of Politechnika, recalls "When I took the Cube in my hand, excitement immediately seized me. I took it to our chief engineer, who likewise recognised the fantastic possibilities. We decided on the spot to obtain the necessary capital for production". (My translation from A. Havas, Der Zauberwürfel, Wochenpost 28:23 [5 Jun 81].) By late 1977, they could supply Trial. Trial made an initial order for 5,000 Magic Cubes (as they were initially named) and anticipated that advertising would be required to sell them. Instead they found that the problem was getting enough to meet demand. The Cube won a prize at the Budapest International Fair in 1978, which led to a number of foreign orders. In 1978, Hungarians were using the Cubes as hard currency which they could take or send abroad! Hungarian customs officials now ask departing people "How many Cubes have you got?" In 1979, the Cube received a prize from the Hungarian Ministry of Education and Culture. It received the Toy of the Year awards for 1980 in the UK and Germany.

At the end of 1979, Ideal Toy, a major US and international toy firm best known for introducing the teddy bear some years ago, took over the distribution for most of the western world. They planned to call it 'The Gordian Knot' but someone came up with the name 'Rubik's Cube'. I know no other toy named after its inventor - a unique tribute to a unique invention! Ideal wisely spent time and money in retooling the production lines. The resulting product is lighter, smoother in finish and much easier to turn. The original Hungarian production, like much of the unlicensed Taiwanese production, was so stiff that cubists developed 'Cubist's Thumb' or 'Rubik's Wrist'.)

The new version began to appear in mid-1980 and the resulting runaway success is now well chronicled. Ideal sold about 4½ million Cubes in 1980 and anticipated sales of about 10 million in 1981. Although figures are not yet known for 1981, I estimate they have sold perhaps 20 million so far. The Taiwanese are reported to have sold about three times as many! There are reports of a Munich shop Selling 800 Cubes in an hour and of a Wolverhampton (UK) shop selling 2000 in an hour. Market traders sold 1000 easily on Saturday. During the great Cube famine of early 1981 when Ideal's stocks were completely depleted and the Taiwanese knock-offs had not arrived, I heard of a second hand Cube market and offers of £15 for a Cube.

4

Rubik's name has become a household word in many languages and has been entered into the Oxford English Dictionary and the Brockhaus Lexicon. UK Customs even has a new category: Rubik's Cube and the like.

But what of Rubik himself? Early rumours said he was getting little royalties and he still does not have a telephone. However, Ideal pays him a royalty on the use of his name which has started arriving and recent reports describe him as the richest man in Hungary or the first communist millionaire (though the currency is not specified). He receives between 1 and 2p per cube from Ideal and is said to be receiving about $30,000 per month after taxes! He says it is just as well that he doesn't have a telephone.

The Cube is said to be Hungary's biggest single earner of foreign currency. With all the production sent to the West this Eastern Block is almost unobtainable in the Eastern Block Indeed an East German magazine has an article telling how to make your own Rubik Cube! Recent reports indicate it is available and widespread in Poland

Rubik, his wife Rozsa and his 3 year old daughter Anna live in a hilly suburb of Buda in a house he built with his own hands literally on top of his parent's house. His appearance is more Mediterranean than Central European. He is of medium height, thin, with small neat features. He has straight brown hair and smokes heavily. He reminds me a bit of Alain Delon or Gerard Philipe. He is initially reserved but opens out when the conversation gets into three dimensions. His conversation and manner are serious and intense. He often replies in a way which opens up more questions and thoughts to consider. He is one of the few people that I have met who immediately comes over as a genius.

Rubik consciously applied the fundamental principles of design when devising the Cube. In particular, he aimed to make each piece as simple and compact as possible. He believes form follows function. He is particularly pleased with the spring-loaded screws, which provide the dynamic tension to hold the cube together and to take up wear. We have discovered several earlier attempts to make Magic Cubes as well as several later independent designs. (Details will appear in a later circular). The measure of Rubik's success at simplifying the mechanism is that none of the other designs for the 33 has yet been produced.

Rubik has succinctly analysed the features of the Cube which made it unique among puzzles when it appeared.

A. The pieces stay together.

B. More than one piece moves at a time.

C. The pieces have orientation as well as position.

I have written a section on the Fascination of Rubik's Cube for Rubik's forthcoming book and have added some analysis of the more obvious points such as the three-dimensionality, the coloration and the complexity. A point which I have recently realised, is that the Cube has many subgoals - one can get pleasure out of simply doing one side or just the corners. Like any masterpiece in any field, everyone can find his own special aspects of the cube to fascinate him.

I have not yet been able to think of any previous puzzle with the three features Rubik has pointed out. Now we have many variations and many new puzzles based on these points. Perhaps we could now call them "Rubik's Rubric" for puzzle inventors.

CORRECTIONS - IMPORTANT

[This is a corrections sheet that was included in the magazine. - J ]

I gave a draft version of the Circular to Rubik on his recent visit to London. He has pointed out a number of errors. I am afraid I depended on some published reports which were erroneous. I am delighted to help set the record straight and must apologize for not checking more thoroughly.

The ő in Ernő is actually a long ö.

Ernő Rubik Senior is still alive.

Rubik's subject is best called interior architecture.

Rubik approached Politechnika directly, not via Trial, about March 1975; Gyula Nemcsók, the current president of Politechnika, was not president at that time and was not involved in the first meeting with Rubik. (The details of the Havas article seem to be all wrong.)

The 1975 prize from the Hungarian Ministry of Education and Culture was awarded to Rubik personally for all his work. The Cube was also Toy of the Year for 1980 in France.

The retooling of the production in 1980 was entirely suggested and carried out by the Hungarians. Ideal was not involved. The stiffness and other problems with the earlier Hungarian production were resolved in 1979.

Ideal's anticipation of 1981 sales has varied but the figure of 10 million was for the US alone.

Royalties on the use of Rubik's name have not ever been agreed. Ideal buys all cubes for Europe from Konsumex, the Hungarian export agency, and pays Konsumex a royalty on other cubes made under licence. Rubik receives some royalty in both cases, but the monetary values given are quite incorrect.

My contribution to Rubik's book has been used as the Foreword. In his book, Rubik describes how he invented the cube at much greater length and with much greater authority than I can do. The book will be available a month or two.

[This book eventually saw print in 1987 as "Rubik's Cubic Compendium" with articles written by Rubik, Singmaster, Tamás Varga, Gerzson Kéri, György Marx and Tamás Vekerdy. It is the third book in the Recreations in Mathematics series from Oxford University Press, ISBN 0-19-853202-4, and is mostly a translation from Hungarian of "A büvös kocka". See also C2-3, C7/8-3. - J ]

5

CUBE VARIATIONS

One of the marks of greatness which Rubik's Cube has demonstrated, is the ability to inspire imitations and variations in profusion. The two most obvious variations have been in the face patterns and in size. Most of the patterned cubes require one to solve the supergroup (N 18, 22, 45). Patterns include magic squares, fruit, suits, die patterns, chessmen, balls, O's and X's, and two types of Royal Wedding Cube - surely the ultimate, symbol of 1981! One of these has nine identical pictures of each face: Charles, Diana and flags of England, Scotland, Wales and the UK. The other is made in England and each face is a single nine part picture: Charles, Diana and four Union Jacks. With the latter, you can interchange the couple's hairdos or their ears! There are Cubes with the stickers modified into circles or octagons and with glittery, pastel or grainy colours. Some cubes have been used for advertising. Ideal is about to introduce a Calendar Cube with syllables, letters and numbers allowing you to set the day, date and month on one face This is an obvious executive toy which should keep the executive busy every morning.
[ see also C7/8-4. - J ].

Tamás Varga pointed out that one can modify the colour patterns on the Cube to get a number of simpler Cubes. I have made up a number of these, of which the following are the most interesting.

  1. All faces green - the Irish Cube (suggested by R. G. S. Hankin).
  2. 5 black faces, one white face - a Beginner's Cube.
  3. 3 yellow faces, 3 blue faces - with the yellows meeting at a corner.
    (This is the pattern that Varga's colleague Julienne Szendrei showed me.)
  4. 2 opposite faces of red, white and blue.
  5. Remove the centre stickers.
  6. Remove the centre and edge stickers. This simulates the 23.
  7. Remove the centre and corner stickers.
  8. Remove stickers so the remainder form patterns like on a die or domino (suggested by John Ergatoudis). One could also make such patterns using just white stickers on the black cube.
  9. Make an all white cube and trace a continuous circuit through all the 54 facelets. Finding such a circuit is a problem in itself. (Due to DBS based on a related picture in Deledicq & Touchard's book).

Several of these patterns have indistinguishable pieces, which makes them easier at first but can lead to complications later on. They are good tests of one's understanding of the Cube.

[ See also Sheperd's Cube in C7/8-7. - J ]

EXERCISE. How many ways are there to put 1,2,..., 6 colours on the six faces of a cube? The answer depends on whether you consider the actual colours as important or not and whether one allows reflections or not.

EXERCISE. Find all the circuits through the 54 facelets.

Some South African students have just suggested some further patterns: the South African Voters Cube - all white; the Bantustan Cube which starts with 5 black areas and one white area and winds up with one black area and 5 white areas; a six coloured 13, called the Total Apartheid Cube since the colours never get mixed.

A UK firm has produced a solid version of the Irish Cube called Rube Mick's Cube. A number of other colour patterns are shown in the March 1981 Scientific American and the October-November 1981 Jeux & Stratégie. In the latter, one version has all stickers diagonally split between black and white. One could also use nine colours - one of each on each face.

Stickers are now available to make each face a magic square on a gold background. This is much harder than the previous magic square version which had different coloured background. Dan Feldman sends a set of stickers from Israel but I'm not quite sure what one does with it. I have seen a Do-It-Yourself Cube Kit which you assemble, but it has ordinary stickers.

One can put one's own choice of pictures on a Cube. This requires careful cutting and gluing. The result should be protected with some artist's fixative, but one must be careful not to make the Cube stick together. Joe and Jamie Buhler put six playboy pictures on a Cube for 3-D Jackson. He took hours to do it because it was all pink! Daniel Minoli sent a pictorial cube with rather abstract pictures in only a few colours. He threatens to send one with a short story in small print!

6

A Cambridge student, whose name I have forgotten, made white stickers with the same letter along each edge so the letter could be read from each side as in the diagram. He then found 6 3 by 3 letter patterns so that each row, column and diagonal is an English 3-letter word in one direction or the other. This gives 48 different words, though he says there are 54 of them - perhaps some are words in both directions. Neil J. Rubenking suggests labelling the 26 cubelets (or cubies) with the letters of the alphabet, trying to spell as many 3-letter words as possible.

There have been several inquiries about Cubes for the blind. (I also had an inquiry about Cubes for the colour blind, but this has been solved by many of the patterned Cubes). Bernard Morin, the well-known blind French topologist, used Dymo-Tape to produce tactile labels. Rainer Seitz, the founder of the Rubik's Cube Club in Germany (of which more later), devised the simple technique of using a hot needle to create craters in the plastic, in the form of die patterns. One can do this oneself though it takes some practice to get the right size needle, to get the right heat and to make the holes neat. Seitz demonstrated this technique on German TV and about a thousand inquiries were received. He was subsequently proposed for an award for services to the disabled. Cubes of this type and another type with brass studs are now made in Germany and we can import them. James Dalgety, of Pentangle, says that some may be produced here but so far I have no confirmation of this proposal.
[ see also C7/8-4. - J ].

The variations in size are more straightforward. The standard Rubik's Cube is 57mm on a n edge. Ron Leary, of the Mechanical and Production Engineering shops at my Polytechnic, has produced some 114mm cubes in wood for demonstration purposes. I have recently seen that cubes of similar size are being made in Germany, but I have no details. Commercially, one can obtain cubes with edges: 52mm, 44mm, 38mm, 31 mm, 30mm, 27mm, 20mm. The smaller ones come with key chains or neck chains attached to the cube or its package.

A different kind of variation has appeared. 23 cubes have been produced in Japan. One type has Popeye characters on coloured labels and used Ishige's mechanism (N 37). My example works very well, but Dalgety says his doesn't work so well. I gather this is no longer being produced. Another 23 has a magnetic mechanism - each piece has a magnet in it which holds it to a central steel sphere. Unfortunately, rapid turning causes the pieces to come off. The outside of this version had all black labels with a silvery path through the facelets, The path crossings are labelled so you know which end is matched with which - leaving the labels off would have made a more interesting cube. Dalgety says that Ideal will be bringing in a 23 soon. Jerry Slocum tells me he has three other types from Japan. Wim Osterholt, a Dutch enthusiast, has made several types of 23 by hand and points out that the Rubik and Ishige mechanism are ends of a continuum of mechanisms. Dan Sleator, now at Bell Telephone, made a 23 while a graduate student at Stanford, which I saw in Summer 1980. His mechanism is like Rubik's, with one additional point not specified in Rubik's patent. The theory of the 23 is discussed in my Notes, especially N28, 29, 31. Solving it is quite easy, but there is one point where you can go astray if your algorithm for the 33 does the edges before the corners of the last layer.

7

Osterholt has built and patented a 43. He brought it to London and it worked quite nicely once we lubricated it with Holt's rubber and nylon lubricant. Rainer Seitz showed me some German patents or applications for 43 and 53. The 43 has 8 corners, 24 edges and 24 centres. If these are all distinguishable and their orientations are noticeable, then we have 8!·24!·24!·38·224·424 = 4.8 × 1077 constructible patterns. However, if we have each face a solid colour, then the edges occur in indistinguishable pairs and the centres in quadruples, while the centre orientations are unnoticeable. Thus we get only 8!·24!·24!·38·224 / 212·246 = 2.2 × 1051 distinct constructible patterns for the standard colouring. In the positions obtainable by layer turns, I have so far determined that: i) each position must be an even permutation of the corners and centres together; ii) the orientation of a corner is fixed by the orientation of the other seven corners; iii) the orientation of an edge or centre is determined by its location. This gives at most 8!·24!·24!·38 / 2·3 = 1.7 × 1055 patterns in the 43 supergroup. If we use a standard colouring with solid faces, then we get to divide this number by 212·246 as above, to give at most 2.2 × 1043 distinct patterns in the cube group.
[ See corrections at C2-8 and C3/4-15. - J ].
Osterholt showed me a process which appeared to exchange one pair of centres, though it is actually a 3-cycle with two centres indistinguishable. Consequently, it looks like all the above patterns are indeed achievable by first getting the centres correct, then the edges and corners by use of commutators of face layer turns.
[ See also C3/4 - 14-17. - J ].

Shape variations have also appeared. The simplest is a Truncated Cube, i.e. a Cube with the corners trimmed off to leave 8 small triangles which are coloured gold (Figure 1). The main Cube faces are thus octagons. The triangles are irrelevant so they can be coloured all different. If one truncates further so the triangles just meet, one has a Cubo-octahedron with 6 square faces and 8 triangular faces (see Figure 2 and the catalogue). This is sold as a Diamond Puzzler. The corner pieces retain bits of the main cube faces, so the triangles are still irrelevant, but they are coloured with 8 new colours. If one carries the truncation further until none of the Cube faces are left, one has an Octahedron which is dual to the cube. The 8 triangular faces are coloured with 8 colours. A face centre of the Cube is now a corner of the Octahedron, and has four colours on it. By adjusting the relative spacing of the Cube's bisecting planes so the edge pieces are no longer cubical, we can make it so that a corner of the Cube is now a triangular face centre of the Octahedron with only one colour on it. The edges of the two shapes correspond, but the colour pattern behaves differently on them (Figure 3). It is possible to simulate this Octahedron by colouring a Cube with eight colours in a pattern looking like a 23 superimposed on the 33 (See Figure 4 or Scientific American, March 1981, p.15, bottom right picture.) I call this a 'Dual' Magic Octahedron because the corners turn, rather than the faces. This has been patented by Josef Trajber of Vienna and shown to me by Rainer Seitz. Its solution is similar to the cube, but requires some new insights. It has 8!·12!·212·46 / 2·2·2 = 4.1 × 1019 = 40 50301 90700 29824 patterns. I don't know when this may be produced.
[ see C3/4-11. - J ]

Fig. 1 | Fig. 2
Fig. 1 | Fig. 2

8

Fig. 3 | Fig. 4
Fig. 3 | Fig. 4

Another shape variation, which is still essentially a Cube, is the Magic Ball. This is simply a rounded out Cube, approximately the circumsphere of a standard Cube, with diameter about 95mm. The face centres are nearly square areas, but the edges are long rectangular areas and the comers are large spherical triangular areas. The coloured stickers form large circular areas about each face centre, tangent to one another, leaving some black area on the corner faces - see the figure in the catalogue. Because you don't have the Cube's edges to align the eye or hand as you turn, the Ball is quite difficult to do. A 75mm version exists and miniature key chain versions of 31mm diameter exist. The latter have solidly coloured faces, forming 8 columns of three like coloured pieces, with the North and South Poles differently coloured or made to match one of the other 8 colours. There is also a Magic Globe! An amazing combination of Geography and Geometry! Now you can sort out the world! It comes complete with globe stand. At the time of writing these are not readily available in the UK.

MAGIC BALL | MAGIC GLOBE
Magic Ball | Magic Globe

More interesting are shape variations which are not quite the same as the Cube. The first of these was the Magic Octagonal Prism, which looks like a Cube with its four vertical edges trimmed (Figure 5 and the catalogue). This gives eight vertical faces of three facelets and two octagonal faces which are coloured with 10 colours altogether. The middle layer edge pieces now have only one outside face, which means that you cannot tell which way round they are. This makes the restoration easier at first, but harder overall since only half the ways of putting in these pieces are possible when the rest of the Prism is restored. (Compare with the comment of some of the patterned cubes). The colours of the vertical faces corresponding to the trimmed edges are not related to the other colours, so they may be rearranged, but again only half the ways are possible. In order to deal with these problems, one must develop two further tricks beyond those used to restore the Cube. (I will give a detailed solution in a later Circular). The Prism has only 1/8 of the distinct patterns of the cube, i.e. 5406 50040 93112 32000 patterns and 12 of these can be considered as START patterns. The Prism rapidly gets into non-convex shapes because it lacks cubical symmetry. There are miniature Prisms with edges 37mm, 34mm, 30mm.
[ or see my octagon page - J ]

9

MAGIC OCTAGONAL PRISM
Fig. 5
Fig. 5

An odder shape is a Cube which is octagonalised along two axes (Figure 6). Mine is labelled Million Space Shuttle on the two poles and I have heard it called a cushion or pillow.
[ see also C7/8-4. - J ].
I have also recently obtained a Cube which has had all its edges and corners trimmed to give 6 square centre faces, 12 rectangular edge faces and 8 triangular corner faces (Figure 7). If the rectangles were squares, this would be a Small Rhombi-cubo-octahedron! I will leave the detailed descriptions of these for a later Circular.
[ See also C3/4-11 and C7/8-5. - J ]

During a recent visit to Liverpool, Alexander Wall showed me an object he had created by taking half of an Octagonal Prism and half of a Cube-octahedron and putting them together. I suggest we call this a Chimerical Cube. Obviously there are slot of possibilities here since almost all the standard size cube variations have the same internal dimensions. We could even mix three or more kinds to produce the most amazing shapes!
[ See also C3/4-11. - J ]

I have recently put the catalogue of my cube collection onto a computer file, so it can be kept up to date easily. Copies can be obtained by writing me with a stamped addressed envelope or a mailing label and stamps or International Reply coupons appropriate for a 30gm or 1 oz letter.

I am delighted to receive samples of cubes, particularly those which I do not have. Several people have sent examples in the past which I have not had time to acknowledge. My thanks especially to Shiyusuke Nakamuraya who sent several samples from Japan which are not available in Europe. I would be grateful for examples of any ancillary material as well, especially the packaging, any enclosed leaflets and any advertising, posters, etc. which can be sent.

Fig. 6 | Fig. 7
Fig. 6 | Fig. 7

10

PYRAMINX - THE MAGIC TETRAHEDRON
[ see also C5/6-18/20, C7/8-18 and my pyraminx page. - J ]

All of the above described objects, except the 23, 43 and 53, are essentially variations on Rubik's basic idea. The first of the long awaited other shapes has just arrived as a Magic Tetrahedron called Pyraminx (or Pyramix). It is a tetrahedron trisected by planes parallel to each face (Figure 8). This gives 4 tetrahedral vertex pieces (V), 4 octahedral corner pieces (C) and 6 tetrahedral edge pieces (E). The Pyraminx rotates on each of the trisecting planes. It has a ball bearing action with detents to produce a smooth action and definite stopping. However, Pyraminx has no face centres, so it is not easy to see just how it works. Basically, it is a 'Dual' Magic Tetrahedron in that it is easier, although equivalent, to imagine the corners as turning rather than the faces. I denote the faces by F, R, L, D and the opposite corners by B, L, R, U. Part of the mystery of this pyramid is understanding how to orient oneself, so I will say no more about it now. The Pyraminx is much easier than the Cube and it has only 75582720 = 75,582,720 patterns, which can be reduced to 11,520 or even 960 patterns of interest. EXERCISE. Derive these numbers. Consequently, it will bring great joy to those who haven't been able to do the Cube. At the same time, it shows the basic techniques which apply to all such puzzles.

Fig. 8 Fig. 8

Pyraminx was invented about ten years ago by Uwe Mèffert, a Franco-German inventor of scientific instruments. At the time he was interested in pyramids and the mysterious powers they are reported to have. He found that running the point of a pyramid along the palm relaxed him. Hence he wanted to make some kind of pyramid for the hand and the Pyraminx was the result. It took him and his brother, a talented engineer, about two years to develop the mechanism. When they completed their wooden model, they put it away and thought no more about it. Mèffert only realised the potential of his idea after the great success of Rubik's Cube last year. He showed it to several people in the puzzle field, notably To m Werneck, and they were all enthusiastic, so he began to organise production this year.

Having seen the chaos in the Cube field, Mèffert has taken steps to protect Pyraminx by means of patent, registered designs, trademarks and copyright in every relevant country, especially in Taiwan and Korea which are not signatories of the international patent conventions. He is already successfully enforcing his rights in Taiwan, although a number of pirate versions of the pyramid have appeared in Europe, Australia and Canada, where he has also been taking legal action successfully. An interesting further factor in his favour is that he has used fluorescent orange PVC stickers for one face. This orange is a difficult dye to use and only one firm in Europe can produce the material without using lead salts. The Taiwanese versions are required to use Taiwanese produced material which contains about 5,300 parts per million of lead. The maximum amount of lead permitted under the UK Toy Safety Regulations in a paint film is 2,500 parts per million and other countries have similar or lower permitted amounts. The Regulations definitely refer to other types of coating besides paint, so we believe the local authorities may be able to seize infringing copies.
[ see also C2-4 - J ]
Incidentally, the Taiwanese 'knock-offs' are based on 21 examples stolen from Mèffert's display stand at the Tokyo Toy Fair in June. By August, the Taiwanese were advertising them for sale, complete with a defect that Mèffert had already corrected. The Taiwanese versions are made from much inferior plastic and poorly finished, but are not all that much cheaper than the original.

11

Mèffert has worked with an institution of the blind to produce a Pyraminx for the blind with textured surfaces which are readily distinguished. These have been specially coloured for the benefit of the partially sighted as well. Mèffert has developed two simpler versions and two more complex versions of the Pyraminx, the most complex being comparable to the Cube.

Kersten Meier, a computer scientist from Itzehoe, Germany, independently invented the Magic Tetrahedron in 1980. He told me about it by telephone at Christmas, 1980, but I imagine it looked like Figure 9 (I have recently learned that Peter Ruffhead, of Cambridge, applied for a registered design for a tetrahedral puzzle of this form on 31 March 1981, and Ian Roger James, of Potters Bar, applied for a patent which includes this design on 2 July 1981). But Meier said that he could turn one corner and this did not agree with the results of Andrew Taylor and of Uldis Celmins (N 29, 60). Subsequently, I extended and completed their results, obtaining the number of patterns on any magic polyhedron. However, I then learned about other face patterns from Rubik and later from a picture that Meier sent I did some of these, but didn't get back to the Magic Tetrahedron until I heard reports of it from Jan van de Craats and Tom Werneck in August and September.

Fig. 9 Fig. 9

I have recently found a letter from Meier giving a solution algorithm which takes at most 33 moves and has an average of 20.2 moves. My own method takes 50 moves, which can be reduced to 40 moves, at most. Mèffert reports a method that takes at most 38 moves and a newer method that takes at most 30. Nicolas Hammond has used a computer to study the 960 essential patterns and reports that any position is at most 21 moves from START. Further improvement will require studying a larger set of essential patterns.
[ See also C7/8-18. - J ]

Two books on the Pyraminx have already appeared in Germany - one by Tom Werneck (now published in English by Evans Publishers *) and one by Michael Mrowka and Wolfgang J. Weber (which may appear in English as well). Werneck's book is more popular and has lovely colour pictures of Mèffert, the production lines, diagrams, etc. But the Mrowka and Weber book is more interesting for mathematicians, etc., giving a considerably easier algorithm and more mathematical information. Mèffert is working with Professor R. F. Turner-Smith of the Chinese University of Hong Kong on a "Book of Pyramids" which will cover all the different Pyraminxes on both the popular and mathematical levels. This should be appearing early in 1982.

Mèffert has already adapted his principle to an octahedron. Rainer Seitz has shown me a number of German patents for other magic shapes and I think almost every variation has now been considered. Some of these have even reached prototype stage and I have seen some of these, but I don't know when any will become available. Rubik's Magic Domino (N34, 35) has been redesigned and should appear in 1982.

* Mastering the Magic Pyramid by Tom Werneck. Evans, £1.50 (please add 15p for postage if ordered from David Singmaster Ltd.)

12

CLUBS

Three national clubs have been formed.

Rubik's Cube Clube (Deutschland), Amselweg 12, D-6458 Rodenbach 2, Germany. (Founded by Rainer Seitz).

Rubik's Cube Club (Schweiz), CH-4600 Olten, Switzerland. (Apparently an offshoot of the previous club).

Japan Cubist Club, 3-D Daiichi Yazawa Building, 6-4-11 Roppongi, Minato-ku, Tokyo 106, Japan. (Established by Tsukuda, the Japanese agents of Ideal).

Two regional clubs have been established.

Rubik's Cube Club Hamburg, c/o Peter Kellerman, Stormarnerstrasse 1, D-2000 Hamburg 70, Germany.

Hasseltse Kubisten Federatie, do D. Durlinger, Genkersteenweg 179, B-3500 Hasselt, Belgium.

[ See also C5/6-8. - J ]

Three university-based clubs have been formed, at Bristol and Warwick in the UK and Stanford in the USA, but I do not have current addresses for them. Many schools have set up clubs, but I think there may be too many for us to record them in the Newsletter. Nonetheless, I would be pleased to receive details of any clubs at all and I will certainly list any national or regional clubs in future issues of the Circular.

SHORTEST TIMES AND COMPETITIONS

Single times for restoring a cube are not a good measure of ability, but it is amusing to record them as an indication of the fantastic speeds which have been achieved. In my Notes, the shortest known time was due to Nicolas Hammond, namely 36 seconds, Since then Hammond has achieved it in 28 seconds (and perhaps less by now) and did 37 seconds on BBC TV on 24 January 81. Nicolas is an upper sixth former (i.e. about 17 years old) at Nottingham High School (UK). In Harburg, Hamburg, Germany, a 16 year old boy, Ronald Brinkmann, solved his maths teachers cube overnight when the teacher finally gave up. Within a few months, he did 29 seconds on German TV and later reached 24 seconds. When asked for advice, Brinkmann replied, "Turn, turn, turn".

In Paris, Jérôme Jean-Charles, 25, has developed efficient ways of carrying out processes, achieving an average of 36 seconds, then 32 seconds, within a minimum of 21. He can do up to 180 moves per minute and can do (LF')63=I in 37 seconds. In Bootle, Liverpool, Michael Musker, 16, a student at Hillside High School, has been timed at 20 seconds and says he once did 14 seconds when no one was watching. In Australia, Geoff Harris, a 21 year old student at Griffith University claims he did a cube in 7 seconds! At this point, the problem of deciding whether the cube was really in a random position becomes apparent. Although any five or six moves effectively randomises the cube, some random positions are much closer to START than others and this varies depending on the algorithm used by the solver. Hence it is quite unreasonable to take single times. One should have several gos and the cubes ought to be identical patterns for each person. Even then, as in all sporting events, luck will still play some role.

Nicolas Hammond recently appeared on the Paul Daniels Magic Show and reports that Daniels does the world's fastest cube - he throws it in the air and it comes down restored!

After the first competitions in Hungary (N38), the next major competition was on 31 January 81 at the Imperial Hotel in Tokyo, sponsored by the Japan Cubist Club. There were 400 entries and 73 passed the qualifying round. The contest consisted of restoring three new cubes. The winner was a 16 year old schoolboy, Hideki Kitajima, with times of 62, 46, 49 seconds (average: 52 1/3 seconds). He won a new Datsun! Second prize was a Sony video tape recorder, and there were three further substantial prizes. Kitajima said the new cubes slowed him down - he usually does 25 to 30 seconds in his morning practice of 100 cubes.

13

Rainer Seitz organised a Guiness Book of Records bash in Munich on 6-13 March 81 at the Olympia Shopping Centre. The Centre is connected with the German publisher of the Guiness Book). The best times were 38 seconds, again due to new cubes, achieved by Ronald Brinkmann and Jury Fröschl, an 18 year old Munich boy.

Ideal has begun a world championship, though it hasn't yet received much attention in the UK, where the Daily Mirror is co-sponsoring it. Mal Davies (of whom more later) has kindly passed on the first four (of eight) regional results.

Edinburgh - Alex McNair, Edinburgh | 48.85 sec
Manchester - Edgar Whitley, Colwyn Bay | 39.98
York - Brian Storey, Sunderland | 41.76
Midlands - Nicolas Hammond, Nottingham | 35.38
Bristol - Julian Bush, Bristol | 52.09
Great Yarmouth - Julian Chilvers | 38.67
Southampton - Christopher Lennon, Portsmouth | 55.35
London (1st trial) -Ben Jones, St Nicholas-at-Wade | 46.12
(In third position was Debbie Wade, fastest girl at 49.57; and in the lead at lunch time with 61.71 sec was Benjamin Ealovega of Haslemere, Surrey, age 9, who says he won't subscribe to Cubic Circular unless this is mentioned!)

The rules allow a 15 second look at the Cube on a table. An automatic timer records the time from when it is picked up to when it is set down. Only one trial is allowed in the regionals, but there will be three trials at the final which will be on 12 December in London. New Cubes are used which are described as randomised by a computer and contestants pick one from a bin full. There will be a world championship in Monte Carlo next year.

The French national finals were held recently and Jérôme Jean-Charles won with a time of 25.6 seconds. The New England regional was won by a 9 year old boy named Jonathan Cheyer in 48.31 seconds.

The first Inter-school Rubik Cube Match was held on 15 October 81 between St Thomas Aquinas RC School and The Holy Child Jesus School in Birmingham. There were 16 students on each side. The fastest times were Anthony Shally (34 seconds) and John Bartlett (37 seconds). The organiser was Mal Davies, a teacher at the first school, who was filmed giving a lesson to his students and the TV station began the story that this was part of the regular curriculum! Davies wishes to make it clear that such lessons are extracurricular. He has started to teach an Adult Education class on the Cube! This takes three evenings and is held at the Brasshouse Centre, Birmingham.

The youngest solver of the cube appears to be Lars-Erik Andersen, 7, of Lørenskog, Norway. He does the cube regularly but cannot explain how. James Dalgety says an 8 year old in Hampshire has solved the cube. Tanya Shelton, 6, in Oxford, has learned how to do the cube from her father and is now much faster than he is.

Rainer Seitz reports that a boy in Germany does two cubes at once - one in each hand. Mal Davies reports that Richard Hodson, of Queen Mary's Grammar School, Walsall, can do a Cube one-handed in 89 seconds. John White, 19, a second year mathematics student at the University of Warwick can do the Cube behind his back with one look. He demonstrated this for Mal Davies, taking 10 minutes to study the Cube first. Unfortunately it came out with two pieces wrong, which he then corrected behind his back, in a total time of 154 seconds.

14

FUNNY MOVES

Jérôme Jean-Charles has devised the following technique for implementing (F2R2)3. Place your forefingers on the U sides of the UF and UR pieces with your thumbs on the D sides of the DF and DR pieces. Figure 10 shows the placing of the forefingers on the U face. One can now repeat F2R2 indefinitely without letting go! Jean-Charles also makes moves just flipping a corner piece with a finger, e.g. B is achieved by flicking the D face of the DRB piece with the forefinger.

Rainer Seitz makes a similar hold on the Cube, as shown in Figure 11. With this hold, one can repeat L2B4L4B4L4... continuously. Seitz calls this the Buddhist Prayer Wheel. Perhaps one should chant "Om Rubik om..." or "Hare Rubik, hare Rubik, hare Rubik, hare, hare" while doing it.

Chris Strain-Clark holds her Cube similarly at the points shown in Figure 12. By skilful slipping, one can carry out slice moves without appearing to have done anything at all. Pete Strain-Clark points out that the group of patterns achievable is not a subgroup of the Cube group because the orientation of the Cube is now important. Rather we have a subgroup of the 'oriented Cube group', which has 24N = 1.04 × 1021 elements.

Fig. 10 | Fig. 11 | Fig. 12
Fig. 10 | Fig. 11 | Fig. 12

ERRATA TO MY NOTES

The following are errata beyond the list of 23 Feb 1981, which were incorporated into the American edition. The items on pages 37, 43, 44, 45, 49 are given on the list of 1 Jul 1981 which is included in the Penguin edition. The items on pages 46 and 51 are corrections to previous errata.

Thanks to Frank Bernhart, Marston Conder, Sandy Frey, Jesper Gervaed & Torben Bisgaard, Nicolas Hammond, Colin Merton and Anneke Treep for finding some of these.

Page 21, Line 21. In the antislice notation, the second process is (FR)3U2.
Page 37, Line 5; Page 38, Line -2; Page 51, Line -14; Page I-3, Left, Line -6. Change Nicholas to Nicolas.
Page 43, Line -6. Change to: L'U'B'U2BLUFU2F'.
Page 44, Line -16. Change to: (MBT&KO - 9)
Page 45, Line -7. Delete: (See also .
Page 45, Line -3. Change to: (MBT - 14).
Page 45, Line -1. Change to:RaF2aR'a·U·RaF2aR'a·D'
Page 46, Line 30. ... only moves (A, C-)D- in ...
Page 49, Line -6. Insert:(UF, DL).
Page 50, Lines -15-14. The first non-obvious case is 88 which ... have 8 and 11 cycles...
Page 51, Line 26. Change the total to 355995.
Page 51, Line 31. Change to: 3389 45406 22394 = 3.39 × 1013.
Page 51, Line 32. ... about 7.84 10-7 ...

15

GENERAL ANECDOTES

Fred Warshofsky relates that a football game in Connecticut was delayed due to a missing player who was discovered playing with his Cube in the locker room. Someone told me of a UK court being disrupted by a Cube. Several people have told me that the Cube reduced the productivity of their department to zero. One in London and one in Washington pointed out that because they worked for government departments, one couldn't notice the difference. Paul Samet, head of the University College London Computer Centre, bought a copy of my Notes so he could get his staff back to work.

An Italian engineer in Nigeria, Vittorio Burgatto, won a Chinese dinner for two when the proprietor saw his Cube and said it looked easy! Robert Cole told me that two people followed him out of a waiting room into his train compartment when he was playing with his Cube. Fifteen minutes later one of them realised he was on the wrong train.

Ideals promotion of the cube in the US started with a party given by Zsa-Zsa Gabor in Hollywood on 5 May 80 (N37), followed by a New York do on 8 May 1980 with three generations of Gabors. In Hollywood, Solomon W. Golomb, the inventor (or at least the popularizer) of Polyominoes™, appeared as the mathematical half of the sponsorship. David Sibley was the mathematician on the East Coast. Miss Gabor managed to forget the name of the product at the Hollywood press conference.

English Cube-mania (Cubanoia?) began when Rubik appeared on Swap-Shop, a Saturday morning BBC TV children's programme on 24 January 81, along with Nicolas Hammond, who did the Cube in 37 seconds. They had several other bits on the cube in the preceding and succeeding weeks, and at later times. The competing show, in ITV, Tiswas, has just launched a 'Stamp out Cubes' campaign. Songs have been written about the Cube! "Mr. Rubik" by the Barron Knights is available in the UK on Epic EPC Al596. (See the catalogue).
[ see also C3/4-2. - J ]. There is an Australian song and a German one by a character called Krazy Kuno.

Rubik's Cube has become a household word - I have seen it used as a metaphor in political, educational and economic contexts as well as in numerous political and humorous cartoons. The first political cartoon was by Felix Mussil in Frankfurter Rundschau on 5 February 81, reprinted in Stuttgarter Zeitung and Der Spiegel. It showed a bemused Chancellor Schmidt with a Cube labelled Berlin, unemployment, etc. On 7 July, Garland did a cartoon in The Daily Telegraph showing Willie Whitelaw and Maggie Thatcher struggling with a Cube labelled racial violence, etc. On 6 September, I saw Reagan's Cube by Paul Conrad of the Los Angeles Times reprinted in The New York Times Weekly Review. It had 27 problems showing! A Mahood cartoon In Punch for 9 September shows The Russian Cube - an enormous cube being parachuted onto troops - "A variation of the Rubik Cube, this game is guaranteed to drive any enemy to distraction within minutes". Numerous other cartoons and even a poem have appeared.

Hamlet Cigars have used the Cube for two commercials. One shows my hands getting a Cube all correct, then it is turned to reveal a blue centre in the white face, whereupon It is dropped in disgust Another uses another pair of hands just to show increasing frustration with the wretched thing, then dropping it.

Several people have discovered their Cubes have moved when they left the house, the only people about were children or workmen who swore they hadn't touched it. Hence we have concluded that either there are poltergeists (which explanation I cannot accept) or the Cube must be able to move by itself. This led one correspondent to wonder if one could force theCube to surrender, he thought of starving it, but he couldn't work out what it ate. He then tried sensory deprivation - keeping it in its box in a dark drawer - but to no avail.

There is a definite mysteriousness about the Cube. There is a hotly denied rumour that one of John Conway's graduate students got his beard caught in a Cube and was slowly pulled into it despite his friends' efforts. It is thought that he will reappear when the Cube is returned to the same position it was in when he was first trapped, but no one noticed what it was. CCC (N 30), which is better denoted as C3, has commandeered all the computers in Cambridge to run through Cube patterns in hopes that the desired pattern will be recognisable, perhaps by the appearance of the missing cubist on the video screen. The German advertising for the Cube says 'Do not take hold of it - it will not let you go'. How prophetically true this is - or is it a warning subsequent to a similar Germany tragedy?

16

There has even been a Cubic Communion. The Reverend Richard Ames-Lewis conducted this at Edenbridge Parish Church on 25 October 81. When I first heard about this, I supposed that his parishioners needed holy help to restore their Cubes, but he says he used the Cube as an image of disorganised life which one is presenting for God's grace. Still, I'm sure some people were secretly hoping their Cubes would come back solved.

The mixture of religion and cubism may be an interesting development.
[ see also C5/6-22 - J ].
Solomon Golomb has devised an analogy between Cube corners and quarks, which he has extended into a complete Cubic cosmology. (More on this and on naked beauty or bare bottom in a later Circular).

A correspondent has recently written that the Cube has allowed him to come out of the closet, the mathematical closet, that is. In the past, when he told people he was a mathematician, they treated him like a social outcast. Now they ask how to do the Cube. Beautiful blondes come up to him in airports asking him to relieve their misery, etc.

So many books have come out on the Cube (details in a larger Circular) that Pan Books is about to publish 'Not Another Cube Book'.

"And he's at it all night too!"

MARITAL ANECDOTES

Rainer Seitz told me of a Cube-caused divorce case last March. He has kindly sent the report from Bild Zeitung, which is datelined Bottrop, Ruhr region, 27 Feb (1981). A 21 year old salesgirl was complaining that her husband no longer spoke to her, fled from visitors, never watched TV and no longer did anything in bed. Seitz volunteered to act as marriage counselor by teaching him how to do the Cube, but nothing came of it.

Seitz also reported that a woman with a large black eye came to a demonstration. Her husband had got two faces correct and she had disturbed it while he was at work She had been given two days to get it right again!

A later report comes from Kassel, "She dreams of sex, he only dreams of six sides". 'I have gone nearly mad, being woken up at six by that stupid klick-klack' complained Ilse K. (33) about her technician husband Otto K. (36). He replied that he bought the Cube as a present for her, because she didn't like flowers.

One a more positive note, Eric Pfisterer (the same one), a schoolteacher in Toronto, says that a girl he had known as a child, now grown up, came to Vienna with a Cube and promised to marry him if he solved it He did and she did! And they are living happily ever after.

In England, Pete Strain, a lecturer at the Open University and a world-class racing cubist with a best time of 21 seconds, met a girl, Chris Clark, at summer school and they found the Cube a mutual fascination. He promised to marry her when she got down to 60 seconds. She did and he did! (Actually she was already down to 70 seconds, so this wasn't so great a challenge as it seems). They are now Pete and Chris Strain-Clark Her two daughters also do the Cube and they are claiming a family record! I gave their name to some media people and they volunteered to do the cube underwater! This was filmed for Anglia TV but I gather all you could see was bubbles. They had facemasks but were holding their breath. Chris' face mask got flooded so she had to complete her cube by memory.

I mentioned the divorces and marriages in a talk I gave to the British Association on 4 September 1981. This got headlined as 'Cube Route to Divorce', etc. Next week Private Eye did a pseudo-Sun front page with "Exclusive - How 'That Cube' can improve your love life - Harvard Prof. Tells All".

© David Singmaster

Home
Links
Guestbook


Cubic Circular, Issue 2

The Cubic Circular magazine was written and produced by David Singmaster in the early Eighties. The first issue was a small 16 page pink booklet, of about 19.5 × 14cm. Later issues were on yellow paper and slightly larger at 21 × 14.5cm (A5 format). There were only 5 magazines published, of which 3 were double issues:

Issue 1: | 16 pages | Autumn 1981
Issue 2: | 16 pages | Spring 1982
Issue 3&4: | 36 pages | Spring&Summer 1982
Issue 5&6: | 28 pages | Autumn&Winter 1982
Issue 7&8: | 48 pages | Summer 1985

The second issue is reproduced below. I have tried to keep it as close to the original as possible, so I have kept the images in the same style, even though most pictures have been redrawn. I have occasionally inserted a comment or correction of my own, and to be clearly distinguishable from David's text my comments are in italics and in square brackets,
[like this - J ].

David Singmaster still has many copies of the Cubic Circular available, so I highly recommend acquiring them from him directly. David can be contacted via e-mail (zingmast@sbu.ac.uk) or at:

    David Singmaster
    87 Rodenhurst Road
    London, SW4 8AF
    United Kingdom

The text and original drawings are copyright © David Singmaster, reproduced with permission. Conversion to html and additional commentary by Jaap Scherphuis.

Home
Links
Guestbook

Cubic Circular Logo

CUBIC CIRCULAR

A quarterly newsletter for Rubik Cube addicts

Issue 2 Spring 1982

CONTENTS |
Introduction | 2
News | 2
New Books | 3
Newsletters | 3
Competitions, Times, etc. | 3
Lead Hazards ? | 4
Other Medical Anecdotes | 6
Technical Notes | 8
Sliding Piece Puzzles | 9

Published by David Singmaster Ltd., London, England. ISSN NO 0261-8362

2

INTRODUCTION

As usual, I am a bit behind with this. The last few months have been very hectic as David Singmaster Ltd. has gotten launched. We had a stand at the London Toy Fair, I went to the Nuremberg Toy Fair and Jane Nankivell went to the Paris Toy Fair. I counted about 50 new puzzles which will appear this year: A report on some of these will occupy most of this issue. There are many other new products which will have to wait for the next Circular.

I have spent a lot of time reorganizing my bibliography and my files of material. The bibliography now has some 900 items and runs to 35 pages. And I haven't had time to enter several hundred items which were kindly passed on by Ideal Toy's public relations firm, Porter, Le Vay & Rose. As a result, I haven't gotten very far into the 500 or 1000 letters on my desk, but I think I will be able to get to them soon... The technical material on the Cube is already enough to fill another Circular, so perhaps the next one will be a bit early. Meanwhile, don't despair if your pretty pattern or one-handed upside down record isn't mentioned in this issue.

As you will see from the supplementary catalogue enclosed, we have taken on a large number of new products. We intend to stock a large range for mail order and we will emphasise products which are not widely available. If you know of an interesting product, please tell us about it. We are looking out for a shop or warehouse with display area where you will be able to come and look around.

We are developing a great range of contacts in the puzzle industry and have begun to act as agents or manufacturers for several inventors. We can either arrange to manufacture on a small scale or pass on ideas to major producers such as Mèffert or Pentangle. At the moment, this is a new area of the business and we are feeling our way, but we would be delighted to hear ideas from any readers.

NEWS

Ernö Rubik was awarded the Order of Labour Gold Class by the Hungarian government in December.

Congratulations to Ernö and Rozsa Rubik on the birth of a son, Ernö III, on 26 December.

Rubik's Cube won the UK Toy of the Year award in January, the only product to win two years in a row. (Lego won two years in a row, but with two products.)

Rubik's Cube has even made the Times Crossword. On 19 Jan 82, clue 14 down was "Modern problem, to 23 colours on six sides (6,4)". Clue 23 across was "Act to stop official race-meetings (9)" with answer 'segregate'.

I had the pleasure of meeting the man who invented the name "Rubik's Cube" in December. Stewart Sims, senior vice-president for marketing and product development at Ideal Toy Corp. in New York, was the contact man for getting the cube for Ideal. Both Gordian Knot and Inca Gold had been suggested, but Sims didn't like them and Rubik's Cube came to him after a few days.

3

New Books

Alexander (Sandy) H. Frey, Jr., has adapted my Notes into a school/college level text for learning group theory and cube theory. This expands on the ideas covered in the Notes so as to bring the ideas within reach of more students at this level. It is titled "Handbook of Cubik Math" and is published by Endow Publishers (New Jersey). Lutterworth Press is distributing it in the UK. (I should have called this the 'Cubik Circular'.)

John Ewing and Czes Kośniowski have produced "Puzzle it Out - Cubes, Groups and Puzzles" which also presents the basics of group theory and applies them to several puzzles. It is about the same length as the Notes, going less deep but covering the basics in more detail. It falls about halfway between the Notes and the Handbook as regards level.

Rubik has edited a book "A Bűvös Kocka" which is being done in English by Penguin later this year. Rubik contributes a 19 page description of how he invented the Cube. The major chapter are by Tamás Varga and Gerzon Kéri, with contributions on physics from György Marx and on psychology from Tamás Vekerdy, and a foreword by myself.

[This book eventually saw print in 1987 as "Rubik's Cubic Compendium". It is the third book in the Recreations in Mathematics series from Oxford University Press (ISBN 0-19-853202-4). - J ]

Jack Eidswick has produced a Rubik's Cube Engagement Calendar for 1982. (Available for $6.95 from And Books, 702 South Michigan, South Bend, Indiana, 46618, USA.) This reveals that Rubik was born on 18 June 1937 and that the first working model of the Magic Cube was made by Rubik on 24 Oct 1973. Both of these are somewhat different than I have heard before. I believe Rubik was 37 last year which gives a birth year of 1944. Rubik said he invented in the late spring/early Summer of 1974, but he does not give any specific dates in his book and possibly he doesn't have the dates clearly in mind.

Newsletters

Rubik is starting a quarterly to be called "Rubik's - Logic and Fantasy Dimensions". It will be 52 pages, with colour, at $2.50 per issue or $9 per year from Lapkiadó Vállalat, Kereskedelmi Iroda, H-1906 Budapest, POB 023, Hungary. The first issue is planned for April. They may decide to use distributors in various countries
[ see also C3/4-3. - J ].

Ideal Toy Corp. is planning a Rubik's Cube Fan Club with a quarterly newsletter. However, I haven't yet seen details. (I think something got lost on my desk.)

Anneke Treep and Just van Rossum have beat us all by starting a newsletter (in Dutch) last August. It costs 9.50 Dfl per year from Anneke Treep, Folkert Postlaan 15, 1391 AV Abcoude, Holland. The first issue had 4 pages.

[ The NKC (Dutch Cubists Club) and their quarterly newsletter Cubism For Fun (CFF) are still going strong after 20 years. See their homepage for contact details. - J ]

Competitions, Times, etc.

Julian Chilvers, age 15, from Norwich, won the UK Championship on 12 December. He clocked 25.79 seconds, a world record, on his third and final trial. He also had the second best time, 28.36 seconds, on the second trial. He reports that he uses ordinary car grease as a lubricant. He does the corners first, then completes most of the top and bottom, then the middle. One contestant's cube flew apart. Another said he didn't like Vaseline as it ran out when his cube 'got hot'. How fast was he turning it?? One contestant had sweatbands on his arms, but he confessed it was mostly to frighten the opposition. Nial Ferguson, the Irish champion, was, at age 20, the oldest competitor. He wore gloves between trials to keep his hands warm.

4

The US Championship was done on a TV show "That's Incredible", recorded on 13 November and broadcast on 7 December. Minh Thai, a Vietnamese refugee, age 16, won in a time of 26.04 seconds. The first prize was $2000 plus the trip to the World Championships. Second place went to Jeffrey Varasano with a time of 28.96 seconds. Jeffrey holds the US record with a time of 24.67 seconds in the Eastern Regional Competition.

The World Championships have been announced for various times and places, but the most recent statement is that they will be in Budapest on 5 June.

In Germany or Hungary, there is a film of a four year old doing the cube in under 30 seconds: The film appears to be and is intact. Can you figure out how it was made? (Answer below.)
[ Actually, the answer is in C3/4-2. - J ].

The Los Angeles Times (1 Nov 81) reports on the western US Cube-A-Thon and on three year old Glenn Quackenbusch of Torrance, the youngest competitor. He nonchalantly solved a cube before the contest but was rather bedazzled by the cameras in the competition and failed to finish by the bell. "We didn't even teach him how to do it. He learned from watching his brother", said his father.
[ See C5/6-4 and C7/8-46. - J ]

Richard Hodson has improved his one-handed record to 82.51 seconds. I saw John White do the cube behind his back with only one look after he started. A 17-year old from the Midlands has been clocked at 24.56 seconds. His name is John Duffey.

Miscellany

Rubik's Cube has been placed in the design section of the Museum of Modern Art.

BCG's long awaited treatise "Winning Ways" has just appeared.

[ Berlekamp, Conway and Guy's "Winning Ways" is a 2-volume book. Chapter 24 of Volume 2 has a section on the Cube. It is printed by Academic Press, ISBN 01-12-091101-9 and 01-12-091102-7. - J ]

LEAD HAZARDS?

In C1-10, I reported that the genuine Pyraminx used special lead-free labels while the Taiwanese imitations used labels with a lead level higher than would be permitted for a 'paint film' under The Toys (Safety) Regulations 1974. These limit lead to 2500 parts per million (ppm) in the dry paint film and "'paint' includes lacquer, varnish and other similar substances". We wrote to all the Trading Standards Offices in the UK about this in the autumn. Despite considerable interest and some resulting media coverage in the Midlands, no Trading Standards Officer felt the phrase "other similar substances" could be stretched to cover plastic labels, although the Consumer Safety Unit which drafted the regulations indicated they would have included plastic labels if they had existed in 1974.

Recently, Bill Yoxall, Chief Trading Standards Officer for Southwark, has gone out and analysed all the colours on 9 different cubes and similar products, including Ideal Rubik Cubes from Hungary and Hong Kong, though he did not test a genuine Pyraminx. Wonderful Puzzler (Taiwan), Key Chain Magic Puzzle (Taiwan), Rubik's Cube (Hong Kong), Elliptical Puzzle (??), Rubik's Cube (Hungary), Diamond Puzzler (Taiwan) all had lead levels between 26,250 and 32,900 ppm in their yellow labels. All of these except the Rubik's Cube (Hong Kong) had between 6,700 and 9,800 ppm in their green labels. Elliptical Puzzle had 9,000 ppm in red labels, Wonderful Puzzler and The Pyramids (Taiwan) had 7,800 to 8,900 ppm in their orange labels. (The Pyramids uses gold labels instead of yellow. Diamond Puzzler is a pirate version of Mèffert's Pyraminx Octahedron.) The puzzles with no lead were Face Four (Hong Kong) and Mind Exerciser (Japan) which are Instant Insanity type puzzles. These results are given in a news release "Rubik Cubes Danger", Southwark Public Relations, Town Hall, Peckham Road, London SE5 8UB, 2pp., 4 March 1982.

5

At first glance, these lead levels are quite horrific and I am amazed that the Hungarian Rubik Cubes are as bad as the others. However, two questions immediately arise.

  1. Do children eat them?
  2. Is the lead in PVC labels locked into the plastic in such a way as to be inert?

A. Many people have said that they have seen cubes used as dummies (i.e. pacifiers) and that cubes are often left about where infants can chew on them. Several friends have shown me cubes which have been chewed by their infants. One person saw a child in a pram whose only word seemed to be 'Rubicube'! Still, the cube is not intended as a toy for children of this age.

B. At first I could get no answers to this question. I eventually got in touch with Professor Bryce-Smith of the Department of Chemistry at the University of Reading. He informed me that the Water Research Association had discovered that lead dissolved out of unplasticized PVC pipes into cold water and that a colleague had discovered that cadmium dissolved out of a popular child's plastic building block with saliva. (The manufacturers of the blocks promptly changed the composition of the plastic.)

The results of Southwark' s analyses show that the lead is used as a pigment rather than a PVC stabiliser. The PVC water pipes were probably uncoloured (I haven't seen the reports yet), but a chemist colleague tells me that lead stearate is often out in PVC soapy surface for release from moulds. This may explain problem of the water pipes, but the fact remains that at least one form of lead can dissolve out of the PVC.

Apparently, there are no other results, so we don't really know the answer to question B, but these results would certainly indicate that the same lead level as in paint film would be prudent for plastic.

My advice is -

Don't let infants chew on cubes or imitation pyramids:

I have since spoken to Mèffert who reaffirms that all his colours are lead-free and that they are checked to be below 10 ppm, a level which occurs in some tinned foods and below which it 15 difficult to test.

6

OTHER MEDICAL ANECDOTES

'Cubist's Thumb' is apparently the same as 'Disco Digit'. It has finally made it into the New England Journal of Medicine (mid Sept., 1981). Douglas Waugh, a Canadian doctor, got it in the same way as Dame Kathleen Ollerenshaw (N38). Though right-handed they hold the Cube firmly against the left palm with a corner pressing into the heel of the thumb. Dr. Waugh's doctor first diagnosed it as gout! But the true cause was soon revealed and Dr. Waugh attributes it to using a cheap Taiwanese Cube and prescribes a proper Rubik's Cube as a cure. Incidentally, Dame Kathleen is fully recovered from her operation and says that her doctor was most pleased to have her as a patient so he could learn how to do the Cube from her.

David Laine writes to New Scientist (14 May 81) that his 17 year old son gets fits and has twice passed out while doing the Cube! He is otherwise healthy. Brain strain??

On the positive side, Eric Pfisterer of Toronto (the same one) reports that the Cube has cured his Tennis Elbow. My tennis-playing friends thought this must be because he left off tennis for so long, but he replies that similar hand exercises are standard treatment for the condition.

My brother-in-law, John Rowland, reports the Cube helped him stop smoking! "I reach for a Cube instead of a cigarette." However, Karen Rowland says it makes her smoke more!

On 7 Jan 82, P. J. Voas wrote to the Guardian about strange afflictions and inquired "Can anyone suggest a medical name for the marks caused by sitting down heavily on a discarded Rubik's Cube?" Needless to say, several readers wrote to the rescue.
J.A. Norris: "contused cubum";
Malcolm Ferguson: "glutaeous Rubicus" or "Rubik's bum";
Martin Davis: "Arsickness". (He points out that cubes left on the floor can cause "Rubato".)
Robert Goodden: "fundamental rubikundity".

However, this doesn't compare in seriousness to sitting on a Pyraminx!! (Get the point!) Indeed, I don't really recommend you put the new Pyraminx key-chain in your pocket. You might do yourself an injury!

Rubik Cubes have been banned from Bath High School as a safety hazard. "They bump into each other and fall over objects while concentrating on the Cubes", said Headmistress Doris Chapman.

Two rather moving stories have been reported. I met a doctor at a record fair who said he worked in a teenage leukaemia ward where there was a pressing need to distract the teenage patients. He said the Cube was the best distraction he had ever had.

A mother wrote to the Daily Express that her 14 year old daughter, who is severely handicapped, has learned how to do the Cube - much to her delight and the amazement of the rest of the family. "It's the first thing she's ever been able to do that so many normal children can't."

7

I gave a Cube to a neighbour named John in the early days of the Cube. A few days later, the friend in the next flat reported that "They have taken poor John away. You know that Cube you gave him? Well, he's been awake ever since and this morning he just went 'Aargh' and we had to call the police. Please, could I have twenty more Cubes?"

Henry Ernest Dudeney, writing about the craze produced by Sam Loyd's 15 Puzzle in 1873, says: "And it has been stated, though doubtless it was a Yankee exaggeration, that some 1500 weak-minded persons in America alone were driven to insanity by it." My partner, Jane Nankivell, suggested the slogan that we use on our tee and sweat shirts: "Rubik's Cube Cures Sanity". Fortunately we have not yet heard of any real cases, though I have received a number of crank letters and phone calls.

There are rumours that American psychologists are using the Cube in aptitude testing. Fred Warshofsky reports that a Viennese psychiatrist gives cubes to his patients. They all do it, and the way they do it seems to have little psychological significance. However, about half lie about how long it took them to do it.

8

TECHNICAL NOTES

H. J. Kamack and T. R. Keane have sent a 43 page article on the Rubik tesseract, i.e. the 34 'Cube'. They allow each of the 8 3-dimensional faces to rotate as a solid in its own 3-dimensional space, so each face has 24 positions. Using a computer simulator, they found sufficient processes to generate all positions subject to some conservation laws. The laws are a bit too complex to explain here since one must introduce all the terminology for parts of a 4-dimemsional cube and for rotations in 3-space. If we note that a 34 has 81 pieces comprising 16 0-dimensional corners, 32 1-dimensional 'edges', 24 2-dimensional 'squares', 8 3-dimensional faces and 1 4-dimesional cube and that an i dimensional piece has 4-i outside 3-dimensional facets, then the following formula for N, the number of achievable patterns, will show the conservation laws to some extent.
N = (24!·32!·l6!)/4 · (224/2) · (632/2) · (1216/3) = 1 75677 28807 09135 84316 85260 79081 02505 96144 84630 14955 76514 77156 02173 32367 98970 16855 06002 74887 65008 23542 07129 60000 00000 00000 = 1.8 × 10120, which they describe as about the number of ways to play a game of chess. (The astute reader will wonder how this number was computed to 121 places. I have written a multi precision calculator routine for my Sinclair ZX81 and it only took about five minutes work to compute this. This is the largest example I have yet done.)
[ see also C5/6-3. - J ]

In the draft English version of his chapter for Rubik's book, G. Marx remarks that the cube has 12 positions after one move, 114 after two moves, 1068 after three and 10011 after four and he credits these numbers to Zoltán Kaufmann. After some contemplation, I realised that he was counting 90° moves, e.g. R2 is counted as two moves. By considering all 15 (= 42-1) moves on an axis and the number of 90° moves they use, I find that the number Sn ,of sequences of moves with obvious redundancy removed, satisfies: Sn = 8 Sn-1 + 12 Sn-2 + 8 Sn-3 + 2 Sn-4 for n>=5. For smaller n, the sum terminates at S0 (= 1) and its coefficient is multiplied by 3/2 since there is no previous move to be on a different axis from.
[ see also C7/8-9. - J ].
Letting Tn = S0 + S1 + S2 + ... + Sn, we get Tn > N first at n = 21, where S21 = 3.3 × 1020, T21 = 3.7 × 1020. We have Tn = 1.45 (9.37)n. The previous analysis (N34) gave Tn = 1.47 (13.35) n, with critical value n = 18. I find it remarkable that the critical value for 90° turns not much larger. The asymptotic results for T indicate that n turns of 90° or 180° are equivalent to about 1.155 90° turns.
[ see also C5/6-26 - J ]

The 43 are in production. Discussion with David Collins (who, with Daniel Smith, also devised a mechanism for the 43 has clarified the number of possible patterns. At line 14 of C1-7, the number of patterns in the 43 supergroup is divided by 247 when solid coloured faces are used. We cannot interchange the identical edge pieces because then they are both flipped and the result is not the same as before exchanging them. There is an extra factor of 24 because the lack of centres means we don't know which way is up. Thus we now set 8!·24!·24!·38 / 2·3·247 = 3 70059 84207 82450 93493 70469 87249 28716 80000 00000 = 3.7 × 1045.
[ see correction at C3/4-15. - J ].
Ideal is advertising 363 octillion, meaning 363 × 1048, which is probably 24·212 the number we have found. This would arise if they forgot the fact that there are no centres (as I did also) and did not notice the edge orientation properties. Indeed, their number is 1/6 of the number in line 8 on C1-7. Still compared to their results on the 33, this is a pretty good result.

9

SLIDING PIECE PUZZLES

The distant ancestor of all the sliding piece puzzles which are mow appearing is Sam Loyd's 15 Puzzle of 1873, which had 15 square pieces in a 42 frame. Three major types of puzzles have appeared since early 1981, which fill in the huge conceptual gap between the 15 Puzzle and Rubik's Cube. Surprisingly, they have appeared in the reverse of what I consider logical order. More recently, several new types of interlocking cycle puzzles and switchable cycle puzzles have appeared. In this essay, I will discuss these puzzles and give the number of patterns in each case. Many other puzzles are also appearing, but I will treat them in a later issue.
[ See also Uriblock in C7/8-19 and my 15 Puzzle page - J ]

4 × 4 and CROSSOVER

These are the most recent and I have only seen a sample of each. They have a 42 frame with concealed extra spaces at each end of each row and column, so there are 32 spaces in all. Each row and column has 5 pieces in it, which can be slid back and forth to expose two different groups of 4. The 4 × 4 puzzles from Tsukuda (Japan) have several columns locked together to complicate things and they come with three kinds of marking. Crossover, from Nintendo (Japan), has all rows and columns separately moveable, but the pieces and the glass covers are polarised so a piece changes from dark to light as it moves: One can make the square all dark or all light.
[ see also C5/6-7 and my 'It' puzzle page - J ]

The group structure here as with the 15 Puzzle, is somewhat concealed. One must consider just the positions where the rows and columns are slid to the same configuration one began at. Otherwise one cannot combine processes. To get all the rows and columns back, each must be slid back as often as forward. If we consider each slide as an action on all 32 positions, each one is a 6-cycle and an even number of these must be an even permutation of the 32 positions. When we put all the slides back, the 8 positions containing no piece are restored to their original places, so our move must be an even permutation of the 24 pieces. Thus there are 24! / 2 = 3102 24200 86661 97196 80000 patterns of the 24 pieces when they are all distinct. However, the 8 concealed pieces can be permuted in 8! / 2 ways which cannot be seen, so there are 24! / 8! = 15388 10520 17172 48000 visib1e patterns when the pieces are all distinct. If we consider the 28 = 256 ways the slides can be positioned, we get 39 39354 93163 96154 88000 patterns. With Crossover, each square can only be dark or light, so there are only 216 = 65536 visible patterns and considering the slide positions only gives 167 77216 patterns. At least in Crossover, we find that the commutator of a row and a column move is a 3-cycle and there is enough transitivity to get any 3-cycle by conjugation, so all the even permutations are achievable. (Exercise - check this.)

SLIDING CUBE PUZZLES

In 1892, W. W. Rouse Ball, in Mathematical recreations and Essays, remarks, after a discussion of the 15 Puzzle, "We can conceive also of a similar cubical puzzle, but we could not work it practically except by sections." Apparently no one tried to make one until Piet Hein came up with his elegant Bloxbox in 1973. This is 7 cubes in a 23 box and they are moved simply by tilting the box to let a cube slide into the blank space. Recently several people, including both Rubik and myself have reinvented this both in 23 and 33 versions. I have seen five types in production and two handmade versions as well as an example of Hein's which went out of production some time ago. A 23 comes from Sakura (Japan) with cubes having their outsides coloured in six colours and the inner faces all white.
[ For earlier reference see also C7/8-35. - J ].

10

The face colours can be seen edgewise which makes it much easier to tell where a piece belongs. A more substantial and 'handy' version is exported by Konsumex, the main Hungarian export agency and the exporters of the Cube. Their version is now available in the UK. Its cubes have slightly inset circles containing either red or blue colour. This makes it much more difficult to find out the colours on inner faces - one must manoeuvre the pieces to see what the hidden colours are. Further it is not clear what colour pattern one is supposed to achieve. The theory of these puzzles is the same as for the 15 Puzzle. To get the blank space back where it began, one must make an even number of exchanges, so one only gets the even permutations. The 23 thus has 7! / 2 = 2520 patterns with the blank in a particular spot and 8! / 2 = 20160 patterns all together. One can obtain a type of 6-X pattern but one cannot put all the outside faces to the inside.

A 33, called Puzzle Box, comes from K. W. Toys (Korea). It has letters on one side of the 26 pieces (convenient:) so one can spell words. The 3 puzzles present a new complexity - how do you move the pieces in the centres of the faces? Puzzle Box has holes in the faces and a push stick, though one can also hold the pieces by pressing fingers against the holes. A more elegant technique is to spin the cube, which sends pieces to the corners leaving a blank at the middle of an edge. The spinning technique can also move the piece in the centre of the cube with some ingenuity. (Exercise:) Again one just gets the even permutations if the blank returns to its origin, so there are 26! / 2 = 20 16457 30563 30281 77920 00000 patterns then and 27! / 2 = 544 44347 25209 17608 03840 00000 patterns all together. On the 33, a number of patterns like 6-Z, 6+ and 6-spot can be formed, but only one of the production forms makes these recognisable.

The second 33 that I saw in production is the Hungarian analogue of their 23. This resolves the problem of moving centres by gluing all the centres together to the cube centre! This takes a while to discover and it then determines the 'natural' pattern to achieve. But it takes quite a while and lots of concentration since the pieces are hard to recognise and to keep track of. Further the fixed centres mean you have to move things around 8-cycles. The last 33 in production is called Mad Marbles, from Lakeside (USA). It is modified with an internal column so there are only 24 positions. With grooves on this column, it is possible to use balls (= plastic marbles) instead of cubical pieces. The balls come in only three colours, so this is a pretty easy puzzle with 23!/8!·8!·7! = 31551 70590 patterns with the blank in place and 24!/8!·8!·7! = 7 57240 94160 patterns all together. Since the pieces have no sides, one could not distinguish some patterns except by the label on the box. If the box were the same on all sides, these numbers would have to be divided by about 8, but this is a non-trivial calculation.

CYLINDRICAL PUZZLES

These are essentially a 15 Puzzle wrapped around a cylinder and various versions were on the market last year. Because of gravity and for ease of handling, it is convenient to consider the cylinder as horizontal. Pieces can slide horizontally. The cylinder is sliced into a number of discs, which can rotate about the cylinder's axis. The simplest form, called Whippit (and numerous other names) had three discs containing six positions. (I will abbreviate this as 3 by 6.) Whippit has three pieces of five colours and two pieces of a sixth colour, together with one blank position. I usually consider the blank as a piece of the sixth colour for symmetry.
[ See also my Whippit page - J ]

11

The analysis of such puzzles is easiest when all the pieces are distinct and the discs are marked so one can recognise if they have returned to their original location. Then, just as in the 15 Puzzle, if the blank and the discs are returned to their original places, only the even permutations of the pieces are possible. Further, it is easy to construct a 3-cycle and there is sufficient transitivity so that all even permutations are achievable. However, the discs are usually unmarked, so we do not consider the disc positions. Thus we can make a single turn of a disc, which is a b-cycle. This is an odd permutation if and only if b is even. So if b is even, we can also get the odd permutations of the pieces. For a 3 by 6 puzzle with distinct pieces, we get 17! = 35568 74280 96000 patterns with the blank in place and 18! = 6 40237 37057 28000 patterns all together. With Whippit, the three pieces of each colour can be indistinguishably rearranged in 3! = 6 ways, so the number of distinguishable patterns is 18!/3!6 = 13 72250 88000. (This is multiplied by 3 if we distinguish the blank from the two pieces of the sixth colour, giving 41 16752 64000 patterns.)

The next versions of the puzzle to appear were 6 by 6 ones from the Far East and Hungary, then 4 by 4 and 5 by 5 ones also appeared. If all pieces of an a by b puzzle are distinct and the discs are unmarked, we have (ab)! patterns all together when b is even and half that many when b is odd. If we have a pieces of each of b colours, there are a!b indistinguishable ways to rearrange pieces. If some a > 1, then half of these are odd and unachievable when b is odd. In either case, we get (ab)!/a!b distinct achievable patterns. The relevant numbers are given.

16! = 2092 27898 88000
l6!/4! 4 = 630 63000
25!/2 = 77556 05021 66549 29920 00000
25!/5! 5 = 62336 07431 25120
36! = 7 19933 26789 90121 74679 99448 15083 52000 00000
36!/6! 6 =26701 77736 63714 92473 08800

There are also 72 versions of the 15 Puzzle available, having 49!/2 = 304 14093 20171 33780 43612 60816 60647 68844 37764 15689 60512 00000 00000 patterns.

Remarks on difficulty

Many people tend to equate the difficulty of a puzzle with the number of possibilities. But this is only true for puzzles of the same type. Even then, I feel the difficulty is not proportional to the number of patterns but to something like the logarithm of the number of patterns. If we have M moves at each step and N possibilities, then the estimated length of a solution method ought to be given by ML = N or L = log N/log M. Thus a puzzle of twice the difficulty has the square of the number of possibilities.

Another way to estimate difficulty is to determine the maximum number m of moves to effect a minimal change such as a 3-cycle or a 2-cycle. If there are n pieces, then mn is a measure of difficulty. I would expect m to increase with n, but not as fast as n. So our difficulty might be measured by n log n or n3/2. The first is about the same as our previous measure, since if N = n!, then log N ~ n log n by Stirling's approximation. For example, in an n by n puzzle, there are n2 pieces but the maximum number of moves required to produce an arbitrary 3-cycle is something like 6n. Thus we might expect a difficulty of 6n3 while the previous analysis gives something like 2n2 log n.

12

However, these analyses are only for puzzles of the same type. A 7 by 7 has many more patterns than Rubik's Cube, but it is vastly easier. There are several obvious ways in which the Cube is more difficult than the puzzles considered above.

  1. The pieces have orientation. This imparts an extra twist to the group structure, so we get a wreath product (N58-60).
  2. The pieces are of different types, but the types interact. This is why the group of the cube is a subgroup of a direct sum (N58-59).

(Rubik has pointed out A, but I find B is also relevant.)

It is hard to quantify these or other points so one must fall back on some personal measure such as how long it takes you to solve it.

Back to cylindrical Puzzles

Last year, a Hungarian 6 by 6 called Babylon Tower (or Tower of Babel) was popular in Germany and France and it is now appearing elsewhere via Ideal Toy. This has six balls of six colours, but they are gradated in intensity so all 36 are distinct. The blank space is obtained by pressing a ball into one of two spring-loaded spaces in the base. This was devised by Endre Pap - of whom more later.
[ See also my Babylon Tower page - J ]
6 by 6 versions of Whippit type with numbers instead of gradated colours also appeared. A 4 by 4 and a 5 by 5 came from Hungary but had an extra level with one position into which one ball could be pushed to give the working blank.
[ This is called the Varikon, see my Whippit page - J ]

Another 4 by 4, called Missing Link, was a popular product for Ideal in the US last year and is now coming to Europe, though the Taiwanese imitations have been here for some time. This has fifteen pieces of four colours with a chain link pattern which distinguishes the end pieces, while the middle two are identical. The extra feature is that the middle two discs are locked together. As with the Hungarian 33, this makes movements more complex, but all 16! Patterns are achievable. Because there are two identical pieces of each colour, there are 16! / 2!4 = 130 76743 68000 distinguishable patterns. (If the blank is distinguished from the other middle pieces, we multiply by 2 to get 261 53487 36000 patterns.)
[ See also my Missing Link page - J ]

But the most difficult of the cylindrical puzzles is the Ten Billion Barrel, invented by Gumpei Yokoi of the Japanese firm Nintendo. This is a mixture of the 4 × 4 puzzles and the cylinders. It is something like a 4 by 5 cylinder, but the two rotating discs contain two balls of each row. There are three extra positions at each end, three extra balls and a plunger which slides three rows back and forth by one position. To begin, we assume the balls are all distinct. If one doesn't turn the barrel end for end, then the plunger must operate an even number of times to get back to its original state and each disc turn is an even permutation, so each pattern is an even permutation of the 23 pieces.

Turning the barrel end for end and making a plunge also gives the original configuration and is an odd permutation. (Actually two blank positions are also exchanged.) Because of the complexity of these moves, it is not easy to see how to achieve all the even permutations, but it is possible, even with the two discs locked together! So we have either 23! / 2 = 129 26008 36944 24883 20000 or 23! = 258 52016 73888 49766 40000 patterns depending on whether we preserve the end or not. Ten Billion comes with 4 balls of five colours and 3 balls of a sixth colour. These can be permuted in 4!5·3! ways (divided by 2 if we keep to the even permutations), so there are 23!/(4!53!) = 54111 17561 85000 distinguishable patterns. (NOTE. The figure quoted in our catalogue has a misprint.) Despite having fewer patterns, most people find this puzzle harder to solve than the Cube, but it doesn't grip people as much because it is hard follow what is happening. Several authors have written about it, but most solutions tend to show you one 5-cycle and then leave you to get on with it. Trevor Hutton is preparing a detailed solution with pretty patterns and useful processes, etc.
[ See also my Ten Billion Barrel page - J ]

13

OTHER TYPES

Beyond the above types of sliding piece puzzles, a number of related types have begun to appear and may presage more of these types.

TRILLION

This is sort of a flat version of the Ten Billion and comes from Agatsuma (Japan). It has 17 positions arranged in a cross in a circular frame. At the centre, the 5 innermost pieces can be rotated (leaving the innermost piece fixed). Surrounding these, there is a rotatable ring containing two pieces of each cross arm and an outer ring contains one piece of each arm. One arm of the cross has a spring loaded plunger which slides the 9 pieces along by one place. The plunger then blocks the outer ring from turning. Since some ring turns are 4-cycles and one easily finds some pairs of 2-cycles, it is not hard to achieve all 17! = 35568 74280 96000 patterns when the pieces are distinct. I have just completed the solution and I find that the plunger and the middle ring generate a subgroup isomorphic to the rigid motions of an octahedron on its vertices (or a cube on its faces). Trillion comes with 4 pieces of 4 colours and one piece of a fifth colour, so there are only 17!/4!4 = 10720 71000 distinguishable patterns. Two of these are fairly natural: Rings - with odd piece at the centre and the rings having the colours shown on the puzzle; Cross - with the odd piece in the centre and the arms of solid colours.

INTERLOCKING CYCLE PUZZLES

All of the above puzzles have either blank positions or auxiliary positions. Rubik's Cube has no such blanks, so any sequence of moves can be combined with any other sequence. Thus the set of all patterns is the group of interest, rather than the set of patterns which leave the blanks or auxiliaries fixed. If one considers just two or three faces of the 33, e.g. <F,R> (N55-57) or <F, U, R>, then one has two or three interlocking 4-cycles which can be drawn on a plane as in the diagram. About a year ago, I began to contemplate planar puzzles with this structure, but I never got very far. I believe the analysis of sliding piece puzzles with one blank on a general graph has been done and will appear in Winning Ways (= BCG) which has just appeared (though I haven't seen one yet). I am not sure if this also does the interlocking cycle puzzles. [It does not. - J ] Dan Sleator, now at Bell Labs, pointed out to me a number of ways such puzzles can be built and several independent versions have now appeared.

14

HUNGARIAN RINGS

Hungarian Rings This idea is due to Endre Pap and three coworkers. The simplest version which is the only one that has yet appeared, has two intersecting rings of 20 balls (hence 38 all together). At the intersections, which are five balls apart, a ball can move with either ring. The puzzle seems quite simple. The commutator of the two ring moves is a pair of 3-cycles, but it takes some time and effort to find elementary processes such as a pair of 2-cycles, and a solution strategy. Since a ring turn is a 20-cycle, which is an odd permutation, one can get all 38! = 52302 26174 66601 11176 00072 24100 07429 12000 00000 patterns when the pieces are distinct. The puzzle comes with 10 balls of each of two colours and 9 balls of two other colours, so there are then 38!/(10!·10!·9!·9!) = 3 01625 69686 36903 99200 distinguishable patterns. With so many identical pieces, it is hard to keep track of the position of a ring. I wrote a computer simulation to make it easier! There are several suggested patterns in the instructions. The original pattern as solid coloured arcs as shown. The most difficult has two colours alternating on each ring. Dan Sleator tells me there is a 19th century patent on this idea, but the present exemplification has differences which may justify a new patent. I gather that several variations with more rings will appear. A different two ring version has been invented by Ivan Moscovitch, the noted Israeli inventor of puzzles. Perhaps we should call this a bicycle?

[ See also C5/6-9/10 and C7/8-19. - J ]

DISC CHESS, ROTASCOPE, Etc.

If one thinks about planar cycles with solid pieces instead of tails, there are many possible patterns, but the pieces start getting fiddly. Dan Sleator suggested the following, which may be produced by Mèffert. Consider the diagram of four circles. Each circle can rotate and this permutes the 12 'lens' pieces. The structure of commutators, etc. are easy to see here because of the planarity and one easily gets al 15! = 4790 01600 patterns. The even valency at the centre guarantees that no orientation changes occur. Mèffert's prototype has 6 circles in a 3 by 2 array, giving 17 pieces and 17! = 35568 74280 96000 patterns when all the pieces are distinct. But the prototype has 3 pieces of 3 colours and 2 pieces of 4 other colours, giving 17!/(3!3·2!4) = 10 29188 16000 distinct patterns. I am told of a game by Milton Bradley (?) called Turntables (?) which used the same mechanism. (There is no new thing under the sun!)
[ See also C5/6-6. - J ].

15

Rotascope Rotascope is an unsymmetric approach to a triangular version of the above. Here the pieces are not all the same, so rotation of one disc can block other rotations. The set of patterns is not a group - one must consider just the patterns with the centre (C) and the rims (R) fixed. Exercise 1. The rims cannot be permuted. Thus we get just permutations of the 9 shields (S) and a counting argument shows we only ever get the even permutations of these, i.e. 9!/2 = 1 81440 patterns. All these are achievable. Exercise 2. The shortest process leaving the rims and centre fixed is 8 moves long. Exercise 3. The centre cannot be twisted by itself.

Rotascope is the first of a series of similar puzzles invented a few years ago by a French inventor, Raoul Raba.
[ see also C5/6-6. - J ]
Interestingly, the same idea won first prize last year in a Hungarian puzzle Invention competition chaired by Rubik. Rubik says they are the same, but perhaps there is some difference?? Rotascope is being produced by Pentangle.

EQUATOR

Equator This is another Hungarian production exported by Konsumex. It has three interlocking cycles arranged as orthogonal great circles on a sphere. Each cycle has 12 square pieces, making 30 in all. These occur in 15 antipodal pairs. The pairs can be permuted in 15! ways and each pair can be inverted, giving 15!·215 = 42 84987 36906 24000 positional patterns. However the square pieces have four sides which can be distinguished. By carefully shifting a piece around three sides of a triangle, on can twist one piece. (Its antipode twists oppositely which satisfies the conservation law.) Hence there are 15! 215·415 = 4 60097 01534 74022 5458l 76000 patterns if the pieces and their sides are distinct. On the puzzle as a supplied, four sectors of the sphere are coloured say with A, B, C, D, with the colour boundaries along cycles. This gives 1 4-coloured pair, 10 2-coloured pairs, and 4 1-coloured pairs. (A 1-coloured pair has its two pieces each 1-coloured but of different colours, etc.) The 2-coloured pairs are of only two types: AB opposite CD and BC opposite DA. Likewise the 1-coloured pairs are of only two types: A opposite C and B opposite D. This gives 15!/(1!·5!·5!·2!·2!) · 215·411·14 = 3120 23258 02097 04960 distinct patterns.
[ See corrections in C5/6-10 and also my Equator page - J ]

Trevor Truran reports that Christiaan Freeling has also invented a puzzle of this type with 14 pieces in each groove, but he was unable to get anyone to produce it. Freeling's ball is shown above. Truran contemplates the puzzle with the hemispheres free to turn, which will lead into the next type of puzzle.
[ a mechanism was designed and patented by Rudi Destics, and he makes and sells this puzzle under the name Mozaika, see also my Mozaika page - J ]

16

SWITCHABLE CYCLE PUZZLES

This group of puzzles has several disjoint cycles but the cycles can be broken and rejoined in various ways.

ORB-IT

This is a sphere with 4 equally spaced horizontal grooves containing 8, 20, 20, 8 pieces. One half of the sphere rotates on a vertical plane in multiples of 45°. A 45° turn gives one 'swirl' cycle of 56 pieces and a 90° turn gives two 'tennis ball' cycles of 28 pieces. I find that the basic trick used in the Magic Domino (N35) will give a 3-cycle, so all 56! = 71099 85878 04863 45185 40456 47463 72494 97364 97978 88116 84586 87447 04000 00000 00000 patterns are achievable when the pieces are distinct. The puzzle comes with 8, 20, 20, 8 pieces of four colours, so there are 56!/(8!·20!·20!·8!) = 7388 87734 75012 11308 95230 51000 distinguishable patterns. The puzzle as a whole has 8 symmetries which gives about 1/8 as many distinguishable patterns, but this is a non-trivial calculation, best done by use of Burnside's Lemma and I have not done this. (The same applies to the next two puzzles.)

Orb-It was invented by Chris Wiggs, an English designer, and has been developed with Tom Kremer. They are producing it in the UK.
[ See also my Orb page - J ]

DIOGENES

This was invented by Hubert Petutschnig, an Austrian engineer. It is a 3 by 10 cylinder with no blank space. Instead half the cylinder slides back and forth into three positions. Thus the middle half-ring on one side may get matched with any half-ring on the other side. I haven't found any simple processes, but I expect it will have 30! = 265 25285 98121 91058 63630 814800 00000 patterns if the pieces are all distinct. It comes with 3 pieces of each of ten colours, so this gives 30! / 3!10 = 43867 97336 28584 44800 00000 patterns. The advertising refers to the larger number, which is a bit unreasonable.

VIP SPHERE

This is produced by Logitoy (Switzerland) based on Petutschnig's idea. It is a sphere with four horizontal layers with 8 pieces in each layer.

One half of the sphere turns on a vertical plane in multiples of 180°. The group is a subgroup of the Orb-It group. Since only 180° turns occur, the top and bottom levels never get mixed with the middle levels and the pieces are not interchangeable so this is clearly seen. One has 16!2 = 43 77631 36697 39505 25440 00000 patterns since all 32 pieces are distinct. (It has 8 colours with gradated intensities.)

[ This is commercially available with many possible designs, and is known as the Masterball puzzle. See my Masterball page - J ]

© David Singmaster

Home
Links
Guestbook


Cubic Circular, Issue 3 & 4

The Cubic Circular magazine was written and produced by David Singmaster in the early Eighties. The first issue was a small 16 page pink booklet, of about 19.5 × 14cm. Later issues were on yellow paper and slightly larger at 21 × 14.5cm (A5 format). There were only 5 magazines published, of which 3 were double issues:

Issue 1: | 16 pages | Autumn 1981
Issue 2: | 16 pages | Spring 1982
Issue 3&4: | 36 pages | Spring&Summer 1982
Issue 5&6: | 28 pages | Autumn&Winter 1982
Issue 7&8: | 48 pages | Summer 1985

The third issue is reproduced below. I have tried to keep it as close to the original as possible, so I have kept the images in the same style, even though most pictures have been redrawn. I have occasionally inserted a comment or correction of my own, and to be clearly distinguishable from David's text my comments are in italics and in square brackets,
[like this - J ].

David Singmaster still has many copies of the Cubic Circular available, so I highly recommend acquiring them from him directly. David can be contacted via e-mail (zingmast@sbu.ac.uk) or at:

    David Singmaster
    87 Rodenhurst Road
    London, SW4 8AF
    United Kingdom

The text and original drawings are copyright © David Singmaster, reproduced with permission. Conversion to html and additional commentary by Jaap Scherphuis.

Home
Links
Guestbook
Cubic Circular Logo

CUBIC CIRCULAR

A quarterly newsletter for Rubik Cube addicts

Issue 3 & 4 Spring & Summer 1982

CONTENTS |
Editor's Corner | 2
Songs | 2
Answer | 2
Cubic Quarterlies | 3
The First World Championship | 4
Cubic Cannabis | 7
New Cube Products | 8
A. Pryl - Fool! | 13
Rubik's Revenge - The 43 | 14
Winning Ways on the U Group | 17
The 53 | 18
The Magic Dodecahedron and Alexander's Star | 19
Magic Polyhedra | 21
Rubik Robots | 25
Pretty Patterns | 26
Orders of Elements | 34
The Magic Disc | 36
Comments on the U Group | 36

Published by David Singmaster Ltd., London, England. ISSN NO 0261-8362

2

EDITOR'S CORNER

When I started the Cubic Circular last year, I. intended to have 12 pages per issue and I wondered how I would fill them. As it turns out, material continues to arrive faster than I can deal with it or publish it, and two other magazines have started. The first two Circulars were already 16 pages and I have about 40 pages of type-script in front of me. Because of this and because the Spring issue is a bit late, we have decided to make this a DOUBLE ISSUE for Spring and Summer, i.e. issues number 3 & 4. Depending on how the material fits and on the printer, this issue will be 32 or 36 pages.

Hence this issue completes the first year of the Circular. The next issue will appear in the Autumn, probably in October or November. Because of the extra weight of larger issues, the need to employ technical assistance and the fact that circulation is still confined to a small circle of cubologists, we find the current subscription of £2.50 per year is not really covering our costs. Hence we must raise the subscription to £4.00 for the next year (or $8.00). This may be revised later but we will accept renewals now at this rate.

Do it faster!

SONGS

Mister Rubik, by the Barron Knights, (C1-15) is now on their LP "Twisting the knights Away". An English school group did a song of their own on TV while trying to restore their cubes at the same time. They didn't finish.

A Hungarian husband and wife, Bea Muszty and András Dobay, have made an English single called "Trick in the Middle" about Rubik's cube (Start Records SP5 70537) -

"Try to harmonize the colours of your life
Or the faces of the cube to be alike.
You can twist, twiddle and fiddle,
But the trick's in the middle of the cube."

Don Taylor has sent a photocopy of the cover of the Australian song. It's called "The Cube" by Mike Brady and the Cubettes. It has been done as a video clip with dancers.

Claude Shannon has composed "A Rubric on Rubik Cubics" to the tune of 'Ta! Ra! Ra! Boom De Ay!'. It has six verses of 8 lines with six 4 line choruses, and ten footnotes: It's a bit long to copy here, but perhaps I'll put it in a later Circular.
[ See C7/8-36. - J ]

ANSWER

The answer to the film question on C2-4 is that the film was run backwards!

3

CUBIC QUARTERLIES

The first issue of Rubik's Logic and Fantasy in Space has appeared (C2-3). It appears in several languages simultaneously. The price is now listed at $2.00 per issue. The contents are as follows: (Some of the information will be excerpted elsewhere.)

Introduction by Rubik
The Order of Disorder. This is an essay on entropy and the Cube.
Mr. Cube - Ernö Rubik - a sketch. This is an interview with Rubik, one of the best and most informative that I have seen.
Mister Rubik. Words of the song and a story about the Barron Knights (C1-15).
A world you can twist around, by Gerzson Keri. An essay on patterns - achievable, constructible and even unconstructible ones!
Letters to the editor.
From five thousand to fifteen millions. A report on Politechnika's production of the cube.
Student Olympics. A report on the International Mathematical Olympiad.
Geometrical Art - The Magic of Shapes. An essay on cubism and on cube images in art.
Cube Fans - Competitions and clubs ; Our London correspondent reports
Puzzles page
Around the World - press cuttings.
Reviews of "You can do the Cube" and of my Notes.
Toy-Business; Varikon. An article on Konsumex products, especially the Varikon barrel puzzles.
The Computer, my playmate. An essay on computer games.
Corner - a page of cartoons.

The first issue of Rubik's Cube Newsletter (from PO Box 72, Hollis, New York, 11423, USA for $5.00) appeared in May and has just arrived. It's 8 sides, printed on a single piece of paper and folded, in red and black. The contents are:

At the US National Championships
The Editor's Cubie
Upcoming Cube Clinics
Sneak Preview: 2 new Rubik's Puzzles
Cube Contest Kits
Cube Club Calendar
Membership Offer
Letters to the Editor
Local Clubs
Final Standings & Times
1981 Regional Cube-A-Thon Records and Results

The membership offer includes several new spinoffs: 'Keep on Cubin' tee shirts and badges, pencils, patches, a mobile!, neck ties and memo pads!

4

THE FIRST WORLD CHAMPIONSHIP

The first Rubik's Cube World Championship was held in Budapest on 5 June 1982. This was jointly sponsored by Politoys, Konsumex and Ideal. There were contestants from 19 countries. Minh Thai, the US champion, won with a time of 22.95 sec.

The competition was efficiently organized by Brian Cartmell, the public relations firm for Ideal (UK), so it had the same basic structure as the UK contest. The cubes were selected by Rubik from a special production run and competitors were given a sample to practice with. Competitors described them as pretty good. All had a standardized colour pattern with white opposite yellow, red opposite orange and blue opposite green (David Sibley calls this the 'plus and minus yellow pattern' since opposite faces differ by yellow.) and with blue, orange, yellow clockwise at a corner (spelling BOY). Rubik worked with some mathematicians to develop several patterns of similar complexity. (The contestants remarked that all the patterns seemed of equal difficulty.) Four sets of cubes were put in four of these patterns by Rubik and sealed in separate briefcases which were kept in a bank overnight and brought to the competition by the supervising lawyer. One case was opened and placed by the competitor's entrance. Each contestant picked one at random as he came on stage. (The competitors remained offstage until their turn came so they could not watch the previous attempts.) Each contestant had three attempts and the best time was taken. The fourth cube was used as an extra cube in case a cube came apart. In this event, the contestant got one extra trial. This happened seven times. The Finnish contestant's cube broke twice, so he lost one trial.

The contestant had fifteen seconds to examine the cube in his hand. It was then set down on a photoelectric base. The timing was then based on the time from picking up the cube to setting it down again in completed form.

There was a jury consisting of Rubik, myself, Georgina Tamás (Commercial Director, Konsumex), Peter Peacock (Marketing Director, Ideal (UK)), Rainer Seitz (Product Manager of Arxon and founder of the Rubik's Cube Club). Basically the jury was to guarantee fairness in the event of unexpected phenomena. Indeed the power for the TV and the display timer gave out in the middle of one trial. Fortunately the timing computers are battery powered and a valid time was obtained. One contestant started to do the cube during the study time - he was given an extra try. Once the display timer wouldn't reset after the study time and there was some delay, so the contestant was allowed a new examination period.

The order in the first round was determined by a drawing the previous night. On the following rounds, the slowest contestants went first. The logo of the contest was a cube with one corner replaced by a globe. The prizes were three examples of these which were plated in gold, silver and bronze, together with a number of elegant Hungarian handicrafts.

5

The Contestants

I give a summary about each contestant: Country. Name, age, home city, occupation, personal best time, winning time in national championship (labelled: won in ...). Comments.

Austria. Josef Trajber, 25, Vienna, computer programmer, 29 sec. Author of two books on the Cube. Inventor of an octahedron (C1-7/8)

Belgium. Luc van Laethem, 25, Kraainem (near Brussels), student, 17 sec. Did 100 Cubes in 54 minutes (32.4 sec average).

Bulgaria. Svilen Tenev, 18, Plovdiv, student of languages, 40 sec.

Canada. Duc Trinh, 14, Kitchener (Ontario), student, won in 26 sec. Originates from Viet Nam.

Czechoslovakia. Jiri Fridrich, 17, Ostrava-Poruba, student, won in 23.55 sec.

Finland. Jan Sandqvist, 21, Helsinki, advertising representative, 19 sec.

France. Jerome Jean-Charles, 26, Paris?, journalist, won in 25.60 sec.

Great Britain. Julian Chilvers, 15, Eaton (near Norwich), student, won British Isles Championship in 25.79 sec. He has done 44 cubes in 20 minutes (27.3 sec average!).

Holland. Guus Razoux Schultz, 17, ?, student, 18.50 sec.

Hungary. Zoltán Lábas, 26, Nyiregyhaza (near Budapest), student, 34.5 sec, won in 36.9 sec average.

Italy. Guiseppe Romeo, 16, Rome, student, won in 26 sec.

Japan. Ken'ichi Ueno, 18, Tomakomai (near Sapporo City), student, 22 sec, won in 42.30 sec.

Peru. Eduardo Valdiva Chacón, 21, Lima, student, 26.80 sec.

Poland. Piotr Serbenski, 17, Warsaw, student, 28.50 sec.

Portugal. Manuel Moura Galrinho, 24, Setubal, professor of philosophy, 25.80 sec.

Sweden. Lars Petrus, 21, Uppsala, student of technical physics at Uppsala University, won in 24 sec.

United States. Minh Thai, 16, Los Angeles, student, won in 26.06 sec. Seven days after buying a Cube in June 1981, he could do it in under two minutes. Came to US 3 years ago from Viet Nam, speaking no English.

6

West Germany. Ronald Brinkmann, 17, Hamburg, student, won in 19 sec.

Yugoslavia. József Borsos, ?, ?, student, won in 28 sec.

The average age was about 20 years, which was older than I expected. Jean-Charles and Lábas were the oldest.

Results

Best times are underlined. B indicates breakage resulting in one extra trial.

 | Round |  |  | Best |  | Ave.
Name (country) | 1 | 2 | 3 | time | Rank | time
Borsos (Yug) | 36.75 | 35.33 | 30.02 | 30.02 | 13 | 34.03
Brinkmann (BDR) | 34.80 | 30.59 | 32.32B | 30.59 | 14 | 32.57
Chacón (Per) | 34.91 | 29.62 | 30.01 | 29.62 | 11 | 31.51
Chilvers (GB) | 30.59 | 25.95 | 27.46 | 25.95 | 7 | 28.00
Fridrich (Cze) | 31.49 | 29.11 | 33.20 | 29.11 | 10 | 31.27
Galrinho (Por) | 40.74 | 48.67 | 37.11B | 37.11 | 16 | 42.17
Jean-Charles (Fra) | 27.87 | 31.18 | 25.06 | 25.06 | 6 | 28.04
Lábas (Hun) | 24.49 | 27.58 | 28.21B | 24.49 | 3 | 26.76
van Laethem (Bel) | 32.92 | 34.98 | 29.73 | 29.73 | 12 | 32.54
Petrus (Swe) | 35.42 | 33.11 | 24.57 | 24.57 | 4 | 31.03
Razoux Schultz (Hol) | 24.32 | 31.51 | 26.15 | 24.32 | 2 | 27.33
Romeo (Ita) | 34.23* | 41.75 | 28.11 | 28.11 | 9 | 34.70
Sandqvist (Fin) | 31.17B | B | 31.56 | 31.17 | 15 | 31.37
Serbenski (Pol) | 44.40 | 37.50 | 40.86 | 37.50 | 17 | 40.92
Tenev (Bul) | 51.88 | 47.29 | 47.35 | 47.29 | 18 | 48.84
Thai (USA) | 27.16B | 22.95 | 27.97 | 22.95 | 1 | 26.03
Trajber (Aus) | 50.16 | 54.93B | 58.99 | 50.16 | 19 | 54.69
Trinh (Can) | 37.44 | 26.63 | 36.09 | 26.63 | 8 | 33.39
Ueno (Jap) | 27.56 | 27.90 | 24.91 | 24.91 | 5 | 26.79

* Romeo's first cube broke three times but he reinserted the piece each time and carried on. Had he stopped, he would have been given an extra trial.

I have computed the average time for each contestant out of curiosity. The averages do not give results greatly different than the best time. Thai would have won on average as well as best time!

Championship Techniques

I asked all the contestants what algorithm they used. Borsos' algorithm was unclear to me. Brinkmann and Chilvers had two possible algorithms. The following descriptions assume doing the D face first, but this doesn't mean they hold it that way. I write DC for D corners, ME for middle edges, etc. The most popular method was to do DC, UC, U & D E, ME (C2-3). This was used by Brinkmann, Chacón, Chilvers, Jean-Charles, Labas, Sandqvist, Thai, Trinh, van Laethem. Ueno did DC, UC, ME, 3UE, rest.

7

The second most popular technique was Pierre Jullien's method of leaving a DC and the ME above it undone as working or parking spaces. Galrinho, Romeo and Tenev used this method. Brinkmann used a method DC, 3DE, 4UC, rest. Variants of the D, M, U layer method were used by Fridrich, Serbenski and Trajber. Chilvers did DC, DE, U, M. Razoux Schultz did DE, DC & ME together, U (see N32). Petrus does a 2 × 2 × 3 block then orients edges, then orients corners, then completes D & M and then U. (See N32-33.) He gets a 57 move average.

OTHER COMPETITIONS

The Hungarian Championship was held on 27 September 1981. A local elimination round gave 300 competitors and a second round on 20 September left 128, classified as under 15, 15 to 18, over 18, containing 58, 31 and 39 competitors. Three trials were made and the average time taken. The best five in each class then formed a three trials, average time, final. Zoltán Lábas won the over 18 class with an average of 37.1 sec and the final with 36.9 sec.

The Czech competition, held on 11 May, had three categories: children up to 10 years; women and girls; men and boys. In the semifinals they had seven trials and the middle five were averaged, but the finals were for best time out of three trials. Jiri Fridrich, 17, of Ostrava-Poruba, was first in the semifinals with an average of 32.24 seconds and in the finals with a best time of 23.55 seconds.

There have been a number of charity cube contests in the UK. These try to do as many cubes as possible in a given time, often 10 or 20 minutes. Dame Kathleen Ollerenshaw organized one in Manchester for the St. John Ambulance on 6 March. Mal Davies organized one in Birmingham for the English Schools Athletics Association on 15 May. At the first, Anthony Willetts did 29 cubes in 20 minutes. At the second, John Duffy and Anthony Willetts did 33 cubes in 20 minutes (36.4 sec average). I saw John White do a cube completely behind his back (136 sec). Richard Hodson improved his one-handed time to 77.50 sec., but Duncan Dicks, a 2nd year student at Warwick University, did 59.32 and 53.29 sec. Hendon School (outer London) had a contest for the Barnet Mayor's Appeal for research into Crohn's Disease.

Two London policemen, Tim Timoney and Barry Pullen, held a 24 hour cube marathon at Keddies in Romford to raise money for a five year old girl suffering from an inoperable brain tumour. They restored 1000 cubes in 22 hours 25 minutes and acquired severe cases of Cubist's Thumb. They raised over £2000 to send the girl and her mother to Lourdes and Disney World.
[ See also C5/6-2. - J ]

CUBIC CANNABIS

Rubik Cubes were banned at Wandsworth Prison, London, after one was found to be stuffed with cannabis!

8

NEW CUBE PRODUCTS

In C2, I discussed a number of new sliding block puzzles. Here I will discuss new cube type puzzles. Several of these are discussed elsewhere.

Ideal is bringing out a 'Rubik's Range' of cube products, apparently all selected and supervised by Rubik and some of which originated with Rubik. The 43 is part of this range. There is also a 23 with Ishige's mechanism called Rubik's Pocket Cube, and a 33 globe with a rather schematic map called Rubik's World. The Calendar Cube (C1-5) is also in the Range. This was devised by Marvin Silbermintz of Ideal in New York, and strikes me as one of the neatest variations. Because Wednesday is Mittwoch, it is possible to set two days at once on the German version. (Exercise: find all such pairs. This depends on the year!)
[ see also C7/8-4. - J ]

Rubik's Challenge is a 33 with holes for pegs in the facelets. Each player chooses a colour, puts a peg in a facelet of that colour and then gives a turn. The object to get three of your pegs in a row.

Rubik's Race is a 5 × 5 board with four pieces of 6 colours in it. A container of nine tiny cubes is shaken to produce a 3 × 3 pattern. The race is to slide the pieces on the board so as to get the 3 × 3 pattern in the middle.

Ideal is also bringing out the Popeye 23 (C1-6), made by Tsukuda (Japan) and Alexander's Star.

Konsumex, the Hungarian trading company which exports the Cube, has a number of other cube products produced by Politoys. Rubik's Mini Cube is a small 23 with only three colours and a mechanism which is a bit like Ishige's, but without an inner sphere. See below for schematic cross sections of both mechanisms. In both cases one corner is fixed to the centre.

Ishige's Mechanism | Rubik's Mini cube
Ishige's Mechanism | Rubik's Mini cube

9

There are several Taiwanese 23's with a different mechanism. I haven't taken one apart yet.
[ see also C5/6-5. - J ]
They come with two types of die pattern as well as Popeye and ordinary patterns. The Mini Cube has three pairs of adjacent faces with identical colours. It turns out that this allows two colour patterns, one of which is impossible to achieve!

The Magic Domino has been re-engineered and now has a much smoother action. It is also being made in a version with raised spots for the blind.

General Impex is the other Hungarian trading company which exports the Babylon Tower (C2-12), the Hungarian Rings (C2-14) and the Magic Dodecahedron. They displayed a 23 Magic Globe attributed to a Mr. Csillam.

Master Cubo with three coloured regions shown. Mondadori, the Italian distributor of the cube, is doing two variants. The Fifteen Cubo is a Magic Square Magic Cube with black numbers on gold labels. (See C1-5.) The Master Cubo has 12 colours which essentially colour the edges. Here the centre orientations are important but the edge orientations are not and there are 8!·38·12!·46/2·2·3 patterns, which is the same as on the ordinary cube!
[ See also C7/8-5. - J ]

Toni Obermaier, of the German sports equipment firm Togu, has applied for patents on a 23, a 43 and a 53. He has started production of a series of eight 23 with different colour patterns. The simplest has only two colours with four solidly coloured cubelets of each colour. Though advertised as having 70 patterns, there are just 7 when symmetries of the cube are considered. Any two patterns are at most two moves apart!
[ three moves actually. See also C7/8-5. - J ]
Obermaier describes this as suitable for preschoolers. Enumerating the patterns, considering the symmetries, is quite a tricky task for the different colour patterns. The mechanism is like Ishige's.

When I was in New York over Christmas, I found examples of cubes with flags, die patterns, animals and nudes (not to be confused with the other Boob Cube which only turns on one axis).

10

Ole Jacobsen sends an example of an idea of Jim Saxe and Dan Hoey. There are 6 cyclic arrangements of four colours. Take a blank cube and put four coloured spots in the corners of each facelet, so the 6 arrangements are each on one face. I find this cube makes you colour blind! A Korean variation of the cube uses thin (about 1 mm) plastic covers on the facelets rather than the PVC stickers. I saw these in the US being sold as the Deluxe Version of Rubik's Cube at $15.00.

Redmill's Cube, with three regions shown. Another variant is the Banana Puzzler which has six colours of bananas on white labels and the box says "This puzzler will drive you bananas". Peter Redmill sends a different type of edge colouring. He has each face split in half. The halves can be viewed as corresponding to edges. There is a way to colour the edges with four colours so the three colours of each edge are along three orthogonal intersecting edges, as shown.

John White, of Warwick University, has invented a non-trivial Irish Cube (C1-5). It has two colours arranged as shown. He has made a large number of other colour patterns.
[ see also C7/8-10. - J ]

Redmill's Cube, with three regions shown. Henry and Bruce Dan, of Atlanta, Georgia, have been making solid colour cubes by buying lots of ordinary cubes and peeling the labels. (They could have bought white or black cubes directly from Ideal!) The Taiwanese have sold a black cube as The Executive Polish Cube. "Its total lack of reason for being will keep you fascinated for several minutes, or, perhaps, only a few seconds ... try to solve the puzzle with your eyes closed ... work the puzzle in the dark."

11

In New York, I found the small rhombi-cubo-octahedron (C1-9) with three colours instead of ten. Recently I have seen the shape obtained by intersecting three octagonal prisms at right angles. This is a bit like the small rhombi-cube-octahedron, but the corner pieces are pyramids rather than being flat. I haven't yet discovered the name of this shape. It has twelve colours corresponding to the edges.
[ Truncated rhombic dodecahedron, see also C7/8-5. - J ].

Trajber's Octahedron (C1-7/8) has been produced in Taiwan, in two forms. The other form has the vertex pieces slightly truncated. Tsukuda (Japan) advertise a 2 cube-octahedron.

The range of cube related products is also amazing. Perhaps most intriguing are cube earrings! These are about 12.5 mm (1/2") on a side. One version doesn't turn at all. Another turns on one axis only. In New York, I saw hair slides (or barrettes) and a cube jig-saw puzzle.
[ see also C5/6-5. - J ].
In the UK are mugs ("It's a Mug's Game"!), a memo cube and a poster version of the solution. At least a dozen cubic tee-shirts are available, mostly in the US. Kit-Kat and Olympic Holidays used the Cube in bill-beard advertising. Hamlet Cigars has a Cube being restored, but it turns out to have a blue centre in the white face, so the user throws it away and lights up a cigar. The cube rotation is by me.

I have seen a number of chimerical cubes (C1-9). The simplest are obtained by taking one, two or three columns from an octagonal prism and putting them into an ordinary cube. See below for an example. Actually, I have just realised that one need net make them parallel and a rather odd shape is obtained with three orthogonal nonintersecting columns, as shown below.

12

Tony Fisher, of Ipswich, has made what I call Siamese Cubes. Take two ordinary cubes each with one column replaced by a column from an octagonal prism. Glue the cubes together along these columns. The pieces do not move from one cube to the other, so each cube behaves like an ordinary cube with one column glued together. Exercise: Consider any pattern on the cube, which has a column correctly lined up. Prove or disprove that the cube can be restored without breaking up the column.
[ see also C7/8-13, and my Siamese Cubes page - J ].

Fisher's Siamese Cubes
Fisher's Siamese Cubes

One could join two Cubes at a corner, using a piece from a truncated Cube, or crossways at an edge: I can't see any way to join two Cubes which allows mixing pieces.

Another chimera from Taiwan is a mixture of corners from a truncated Cube and edges from a cubo-octahedron.

Uwe Mèffert came to the London Toy Fair with about 30 new products, several of which will be appearing soon. The Magic Dodecahedron is mentioned elsewhere. The Pyraminx Star is a stellated and sparkly version of the Pyraminx. It is even easier to solve, but it makes a most handsome object.

The most interesting of Mèffert's products is the Pyraminx Cube, invented by Tony Durham, an English journalist. It is a cube which is bisected by the four planes through the centre and perpendicular to the diagonals. It rotates on each of the planes, a movement which people have difficulty in discovering. There are 6 faces and 8 corners. There is a dual structure which is an octahedron with 8 faces and 6 edges. I find
4!·4!·6!·38/2·2·24 = 283 43520 patterns for the cube and 4!·4!·6!·26/2·2·2·4! = 1 38240 patterns for the octahedral version. (We get 26 rather than 46 for the reasons explained under Magic Polyhedra.) The octahedral version was invented earlier by Rubik.

13

Pyraminx Cube | Magic Octahedron
Pyraminx Cube | Magic Octahedron

It is possible to make both the 6 four-sided pieces and the 8 three-sided pieces have recognizable orientation either by various colourings or by embedding the four axes into a less symmetric solid - Durham uses a dodecahedral shape. I get 4!·4!·6!·38·26/2·2·2·24 = 9069 92640 patterns in this case. However, I have just read over Durham's work on the number of patterns and he finds two further conservation rules which are quite interesting. I haven't had time to fully assimilate them, but they give two twist conservation laws for the cube and dodecahedron cases, yielding 1/9 of the results I have just given, namely, 31 49280 and 1007 76960. I will return to this one once the objects become available - no point in spoiling your fun completely.
[ see also C7/8-15. - J ]

A. PRYL - FOOL!

The Prague newspaper, Mlada Fronta, ran a story on 1 April about a school giving courses on the cube. The school's director was A. Pryl whose best time for the cube was 69 hours, 37 minutes, 58 seconds. The teachers were Frantisek Kubík, age 12, and Miloslav Kostečka, age 9. The Associated Press picked up the story and The International Herald Tribune (IHT) ran it, but they lost some of the points by christening A. Pryl as Antonin Pryl and omitting his time. When I read the IHT report it seemed quite genuine. Mlada Fronta ran the IHT article in English with Czech commentary, "Believe or Not Believe - We Have Caught a Whale". Mojmír Sob, who has kindly sent the details of this epic, points out that Pryl, Kubík and Kostecka are common Czech names, though the last two are also Czech words for a small cube.

14

RUBIK'S REVENGE - THE 43

The 43 is appearing. I have received an early sample via Rainer Seitz and it works pretty well. Ideal is advertising it as Rubik's Revenge in the US and UK and as Rubik's Master Cube in Germany, but has only made a few deliveries so far in the UK. It is 66 mm (about 2 5/8 ") on an edge and weighs about 240 gm (about 8 1/2 oz) which makes it about one-third denser than the ordinary cube (57 mm edge, weighing 120 gm).

The mechanism is basically a grooved sphere, but there are several points where it varies from designs I have seen. The centres are the only pieces hooked on to the sphere. The four centres of a face turn in a circular opening where two grooves meet. There is only one central groove in each direction for the slices to turn along, but these grooves are asymmetric so that one slice will turn with respect to the sphere, but the parallel slice carries the sphere with it. No piece is attached to the central sphere. The 43 will come apart in much the same way as the 33, but one must remove all the edges and corners of a face and spread out the centre pieces in order to disengage a centre piece. I don't know the source of this mechanism.

Three books on the 43 are about to appear from Minh Thai, Jerome Jean Charles and Tom Werneck. All of these have been written without a 43 in hand!

I received my 43 in Budapest and began to work on it on Saturday evening. Thinking that the methods of the 33 would solve the edges and corners, I put the centres right first. This is not too difficult. I then got the edge pieces in pairs, but stopped when I needed a single 3-cycle of edges. The next morning, while flying back to London, I saw how to do this and then put the edges and corners correct. However, I made a boo-boo later and then tried the same method and discovered I needed a single 2-cycle of edges! After applying a 3-cycle I wanted a 4-cycle and I had to leave it like this. I returned to it a few days later and saw how to form a 4-cycle, but this moved centres. Finally, I saw an easy method to 3-cycle centres only. So, my strategy is to get the edges correct first, then centres and corners, which are easily done, but everything takes some time. A layer by layer method is feasible, but the edges of the last layer will need some tricks. If the last layer is a face, it will be very awkward to get a 2-cycle of edges. Hence it may be best to do two opposite faces and then the slices between them.

Number of patterns

The number of patterns on the 43 has been considered by Herb Taylor, Solomon Golomb and David Kantor in Los Angeles.

15

Taylor and I have located an error in the argument at C2-8. The factor of 24 in the denominator arises since the 6 sets of 4 identical centres can be permuted in 24 ways each and the cube has 24 indistinguishable orientations. However since the parity of centre turns is the same as the parity of corner turns, only half of the 24 cases are possible. This is the same reasoning that gave the 2 in the denominator at C2-6 and was used several times on C2-9/12. Thus the correct (I hope!) answer is 8!·24!·24!·38/(3·247) = 7 40119 68415 64901 86987 40939 74498 57433 60000 00000 = 7.4 × 1045

Notation

4x4x4 Notation Kurt Endl has proposed a notation using A, B, C, D, 1, 2, 3, 4; I, II, III, IV to represent the levels in a 43. This has the advantage of being indefinitely expandable, but I prefer a notation which retains some mnemonic character like the B, L, U, D, F, B notation for the 43 . I find the following seems to be the most convenient for me. Label the 'slice' layer adjacent to each face by the lover case letter of that face. Thus the four levels from left to right are denoted L, l, r, R as shown in the diagram. Similarly we use U, u, d, D and F, f, b, B. Because we do not have centre pieces, one must be careful physically to remember which directions are which, or one can keep a corner fixed, as with the 23 (N53).

It is clear how the notation records moves, but we must adapt it a bit to label pieces and positions. We now have two FU edges and four F centres. So we shall now label each piece with three symbols, corresponding to the three levels it lies in. Each edge lies in two faces and a slice and each centre lies in a face and two slices. The pieces of the front face are shown.

16

4x4x4 Piece Notation Obviously, this notation is awkward to implement on computers which have only upper case. In such situations, one could use the next letter of the alphabet to represent a slice - e.g. L, N, S, P; U, V, E, D; F, G, C, B.

Some Sample Processes

I give a few sample processes to illustrate the notation and the way in which commutators give simple processes. I will leave you to build a strategy from these.

[F, R] = (FLU, FUR)+ (RDF, RBD)- (FUl, FRu, DRf) (FUr, FRd, DRb)

[[F, R], L] = (FLU, ULB, RFU)

[[F, R], 1] = (FUl, UBl, DRf)

[U, r] = (ULb, UBr, FUr, DFr, RUb) (Ulb, Urb, Urf, Frd, Fru)

[[F, r], L] = (FLu, ULb, RFu)

[[F, r], l] = (Flu, Ulb, Drb)

[[F,R],l] | [[F,r],L]
[[F,R],l] | [[F,r],L]

17

[[F, r], d'] = (Fru, Frd, Rbd)

[f,r] = (Luf, Urf, Frd) (Ruf, Drf, Brd)

[r,b] = (Fur, Ubr, Rbd) (Bur, Dbr, Lbd)

[[F,r],d'] | Half of [r,b]
[[F,r],d'] | Half of [r,b]

[[r,b] ,F] [[r, b], F] = (Fru, Flu, Rbd)

Let me fill in this space by remarking that the 43 exhibits the properties of both the 23 and the 33, if you move halves or just faces. Thus one can obtain a large number of patterns by using known patterns on the 33, together with certain variations from the 23. In particular, one can obtain the cube in a cube in a cube in a cube or quadruple cube pattern. It is not possible to get chessboards on all six faces. I don't know if you can get stripes on all faces??

WINNING WAYS ON THE U GROUP

Winning Ways (= BCG) has appeared as noted in C2-4. The BCS Tables (pp.808-809) have been revised and any U position can be restored in at most 29 moves (N49). David Seal has shown that most of the results are best possible. The hardest patterns are (A, B) (b, d) (in any orientation) and A+ C- a+ b+ c+ d+ requiring 13 and 16 moves.
[ see also C3/4-36, C5/6-2, and C7/8-8. - J ].

18

THE 53

Pierre Bouchard sends an article from Journal de Montréal about a 53 invented by Gaston Saint-Pierre, a 21-year old Quebec boy. The first prototype was in wood, 14 inches (about 35 cm) on a side. He has built a prototype in aluminium, about 7 cm on a side, which took 176 hours to make and weighs 2 pounds (about 1 kg). It has 99 pieces, presumably 98 (= 125 - 27) exterior pieces and one interior piece. He estimates that it has 1090 positions and it takes him 1 1/4 hours to restore. Quite a number of 53 designs and patents have appeared, but this is the first working one I have heard of.

5x5x5 Piece Types Let us work out a first guess as to the number of patterns on the 53. There are 6 kinds of pieces, indicated in the diagram: A = corners; B = edges; C = edge middles; D = inner corners; E = inner edges; F = centres. There are 8; 24; 12; 24; 24; 6 of these, but pieces B, C, E are asymmetric so their orientation is determined by their position. The constructible group thus has

8!·38·24!·12!·212·24!·24! = 123 96654 10985 74050 19981 53455 12384 81212 40682 69122 60338 23429 49382 61930 84194 48832 00000 00000 00000 = 1.24 × 1092 patterns.

Just as with the 33, the corners and edges have their total twist and flip conserved so we will divide by 3 and 2. There are two kinds of moves: faces and offset 'slices'. Each of these gives a number of 4-cycles of pieces as tabulated.

 | A | B | C | D | E
Face | 1 | 2 | 1 | 1 | 1
Slice | 0 | 1 | 0 | 2 | 1

Consequently the parity of the A, C and D movements must all be the same, which gives only 1/4 of the possible permutations of the positions. Now we also have 6 sets of four D end E pieces which can be permuted without changing the appearance (assuming the faces are uniformly coloured). However, the D pieces have the same parity as the A pieces, so only half of the permutations of the D pieces are possible. Using commutators of the form [X,[Y,Z]], just as on the 43, we can get 3-cycles of each type of piece, so we can get all the patterns permitted by the above conservations. Thus there are
8!·38·24!·12!·212·24!·24! / (3·2·4·246·246/2) = 28287 09422 77741 85653 61803 33107 15032 82931 27731 98567 21347 21536 00000 00000 00000 = 2.83 × 1074 patterns.

19

THE MAGIC DODECAHEDRON AND ALEXANDER'S STAR

The Magic Dodecahedron has been contemplated for some time. So far I have seen photos or models from: Ben Halpern (USA), Boris Horvat (Yugoslavia), Barry Lockwood (UK) and Miklós Kristóf (Hungary) while Kersten Meier (Germany) sent plans in early 1981. I have heard that Christoph Bandelow and Doctor Moll (Germany) have patents and that Mario Ouellette and Luc Robillard (Canada) have both found mechanisms. The Hungarian version 15 notable as being in production (being exported by General Impex) and as having the planes closer to the centre so each face has a star pattern.

Face patterns of the Dodecahedron

Uwe Mèffert has bought the Halpern and Meier rights, which were both filed on the same day about a month before Kristóf. However, there is an unresolved dispute over the extent of overlap in the designs.

The theory of the Magic Dodecahedron is discussed elsewhere.

A simpler version of the dodecahedron is due to Adam Alexander, a US mathematician. The shape is a great dodecahedron which is an icosahedron with its faces pushed in so the pentagonal pyramid about each vertex becomes a five-pointed star sitting on a plane and it can rotate on this plane (marked F).
[ see also C7/8-25/26. - J ]
One can view this as a Magic Dodecahedron without corners (or centres)
[ Compare C5/6 - 10 - J ].
Thus there are
30!/2 · 230/2 = 7 12032 72378 98958 11841 60204 98546 68800 00000 = 7.1 × 1040 patterns.

20

Alexander's Star The 'faces' of the star are the planes on which the rotations take place. They comprise five triangular areas, marked F above. Now the 12 faces fall into 6 pairs of parallel faces. Alexander makes the parallel faces have the same colour, giving just 6 colours. Hence there are two pieces of each of 15 types and the number of patterns must be divided by 215/2. There are 60 rigid motions of a dodecahedron (reflections are excluded) which form a group isomorphic to A5. (Exercise: Show you can inscribe 5 cubes in a dodecahedron so a symmetry of the dodecahedron is a permutation of these cubes.) The rigid motions are rotations of order 5, 3, 2 and it is readily checked that each of these can be obtained as an achievable position of the edges when centres are fixed. I.e. the spots group or the centres group (N46/47) is the whole group A5 of symmetries. Hence the effect of the centres being unseen is to divide the number of patterns by 60 and there are 30! · 214/60 = 72431 71425 27156 38411 62130 22720 00000 = 7.2 × 1029 patterns. The fact that the star has identical pieces means that one can produce an apparent 2-cycle! The arrangement of colours in the solved state is arbitrary, as can be seen by observing that two colours can be exchanged by 8 two-cycles and two flips, so this is an achievable process. There are 6! = 720 ways to assign the 6 colours to the 6 axes, but we get to divide by 60 to obtain 12 distinct START colour patterns. Alternatively, if we look at a white face, we can rotate to put blue in a standard direction, and then the remaining 4 colours can be in any order, which seems to give 24 START patterns. However looking at the opposite white face gives the mirror image arrangement of colours so there are only 12 START patterns.

21

MAGIC POLYHEDRA

For any polyhedron, or any planar graph, it is possible to imagine a magic version with pieces at the vertices and edges 50 that each face turns. I have reported the work of Andrew Taylor (N29) and Uldis Celmins (N60) on this. Here I outline the general result which subsumes both works. If we have vertices of different valencies, i.e. with different numbers of edges at them, then Andrew Taylor's idea (N29) is to imagine corner pieces with the least common multiple (LCM) of the corner valencies. E.g. if we have valencies 3 and 4, then corner pieces are 12-sided! See the diagram. One must then make some convention regarding what effect face measurements have on corners. This is not critical as long as the inverse of a move restores the pieces and the n-th power of an n-gonal face is the identity. For convenience, I assume that turning face A will carry sector 0 to sector 0, etc. That is, as we travel clockwise around the perimeter of A, the 0 sector is the one on the right as we leave each vertex. Alternatively, we say that turning face A carries its edges to its edges.

Now we have some conservation theorems.

Theorem 1. If every face has an odd number of vertices, then each face turn (and hence each achievable pattern) is an even permutation of corners and of edges. Otherwise each turn is an even permutation of the corners and edges together.

Theorem 2. Only an even number of edge pieces can be flipped.

Chris Rowley has given me a simple proof.

Consider all S edges. Each of these has two sides or facelets. Each face turn is an even permutation of the 2E facelets.

In order to deal with twists of corners, we must make some definitions following BCG and Neumann. In the initial START position, assign a principal direction to each piece and the same principal direction to its initial position. These directions correspond to some sector of the piece.

22

For a piece in any position, its twist is the difference between the principal direction of the piece and of the position that it is in. The twist is measured in units of 360°/v where v is the LCM of all the corner valencies v0, and we work (mod v). There is freedom to choose the sign of the twist, but we consider the orientation of the piece with respect to its position and measure clockwise to agree with the previous usage in the cycle representation. E.g. on the cube, we can take our principal directions as U and D. Then if UHF is at BRU, we have a twist of +1. The total twist of a position is the sum of all the twists (mod v). (Similar concepts hold for the edges, where v = 2.) The total twist at START is 0.

Theorem 3. The total twist of corners is 0 (mod v) for any face turn (and hence any achievable pattern). (A similar theorem holds for edges.)

Proof. Consider any face F and let its vertices be V1, V2, ..., Ve in clockwise order. Label the sectors at each Vi by 0, 1, ..., v-1 so that F carries the sector at Vi into the same sector at Vi+1 - e.g. as described above. Suppose the principal directions of the piece at Vi and of the position Vi are sectors pi and qi in our labelling. Then the twist at Vi is pi-qi and the contribution of these pieces to the total twist is Sum(pi-qi) (mod v).

23

Now F carries the piece at Vi to Vi+1 making the principal direction of the piece at Vi+1 be pi while the principal direction of the position Vi+1 remains qi+1. Thus the twist at Vi+1 is pi-qi+1 and the contribution to the total twist is Sum(p i-q i+1) (mod v), which is the same as the previous contribution. Since all other pieces are fixed by F, the total twist has been preserved, hence it always remains 0 (mod v).

I think the above is the clearest proof of theorem 3. I gather that Andrew Taylor's approach was similar. However Taylor did not try to show all the permitted patterns were achievable and thereby missed the next results, which are rather complex.

Theorem 4. If all V i are even, then no edges can be flipped.

Proof. Because of the assumption, it is possible to colour the faces with two colours so that adjacent faces have opposite colours. (Exercise - verify this.) Now each face turn preserves the colouring, so that the colouring is always preserved and this fixes the orientation of each edge piece.

The corresponding result for corners is a bit mere complex, but this argument works in simple cases, such as the octahedron. If we build a magic octahedron and two-colour it, it would always look the same.

Let kC = v/vC where vC is the valence of vertex C

and v = LCM{vC}. Let C and D be two adjacent vertices and set tCD = kC + kD. Let d be the greatest common divisor (GCD) of v with the set {tCD | C, D are adjacent vertices}

Theorem 5. A corner can only take on v/d of its possible positions.

The proof here is based on the same idea as Theorem 4. We cyclically colour the v sectors at vertex C with v/d copies of d colours. As we move the piece C about, we use it to define the colouring at other vertices. Verifying the consistency of this colouring is trickier than in Theorem 4 and is based on the fact that if F and G are two adjacent faces at vertex C (as shown), then FG, which brings C back to C via D, imparts a twist of -kC-kD to C. Since this is divisible by d, the colouring is preserved.

24

Example 1. The octahedron. Here all vC = 4, v = 4, all kC = 1 all tCD = 2, d = 2. The colouring is the same two-colouring mentioned above.

Example 2 Example 2. The infinite baby-blocks pattern. Here vC is alternately 3 and 6, v = 6, k is alternately 2 and 1, all tCD = 3, d = 3.

The second half of the theory is to show that all the patterns permitted by the conservation theorems can be achieved. This requires a moderate amount of calculation, the exclusion of a number of degenerate cases and the separate consideration of v >= 4, v = 3. The basic approach is to see that the Z and Y commutators have the same structure as they have on the cube, although the twists on the cycles are replaced by -kC-kD and kC+kD. For v > 4, we can use the commutators to build up pairs of corner 2-cycles and corner twists and then edge 3-cycles and pairs of edge flips. When v = 3, we combine the three Y commutators at a vertex as in Benson's process (N24&45) to get 3 twists and 2 flips, whence any twisting and flipping is obtained. Then we get 3-cycles of edges. Finally, we separately consider the tetrahedron and all other cases to see that even permutation of corners can be achieved.

I believe the arguments work if we assume

  1. the graph is connected;
  2. two faces meet in at most one edge or at most one vertex;
  3. all faces have at least three edges.

These conditions are certainly satisfied for a polyhedron.

Now we can write down the number of patterns for a graph of V vertices, E edges, v = LCM{vC}, d = GCD{v, tCD}, w= GCD{2, vC}, as
N = V! E! / (2 or 4) · (v/d)V-1 · (2/w)E-1
where 2 or 4 is 4 if all faces have an odd number of edges, 2 otherwise.

25

For the regular polyhedra of V vertices, E edges, valence v and e edges on each face, we have kC = 1, tC = 2, d = w = GCD(2, v).

 | V | E | v | e | 2 or 4 | d=w
Tetrahedron | 4 | 6 | 3 | 3 | 4 | 1
Cube | 8 | 12 | 3 | 4 | 2 | 1
Octahedron | 6 | 12 | 4 | 3 | 4 | 2
Dodecahedron | 20 | 30 | 3 | 5 | 4 | 1
Icosahedron | 12 | 30 | 5 | 3 | 4 | 1
Tetrahedron | N = (4! 6! / 4) 33 25 | = | 37 32480 |
Cube | N = (8! 12! / 2) 37 211 | = | N (on N12) |
Octahedron | N = (6! 12! / 4) 25 | = | 275 90492 16000 |
Dodecahedron | N = (20! 30! / 4) 319 229 | = | 1006 69616 55352 33471 22516 03231 36455 05168 68811 64110 19768 62720 00000 00000 | = 1.01 × 1068
Icosahedron | N = (12! 30! / 4) 511 229 | = | 83 26777 68427 04628 34605 13497 17691 92448 00000 00000 00000 00000 | = 8.33 × 1056

These results include both Taylor's and Celmin's results. However, the magic makers are more masterful than mere mathematicians. With different shapes it is easier to make magic with different styles of cutting. E.g. the Pyraminx has no centre pieces. This factors N by the number of patterns in which only the centres move, or the number of symmetries of the shape which are achievable patterns when the centres are ignored. Rubik and others have shapes where faces have no edge pieces and movement moves some centres as well as edges. Each of these gives rise to complications which will not be considered further here.

RUBIK ROBOTS

A group of students at the University of Illinois have built a robot called Robbie Rubik, to solve the cube. The pattern must be entered into the computer however, - it does not have a colour sensor. It only turns the top face - flippers and pistons turn the whole cube to bring the appropriate face to the top. The computer is apparently programmed with my algorithm - one of the students is holding a copy of my book in the photo.

Claude Shannon (of information theory fame) sent me an outline for a Rubik robot about the beginning of this year.

26

PRETTY PATTERNS

I intended to include this material in C2, but there was too much other material. I have several hundred, perhaps a thousand letters on my desk waiting to be read. Most of these contain patterns. However, I find that the same patterns are rediscovered often, so I am presenting what I have got so far in the hopes that it will answer some of the letters.

Sources

Several books have appeared which present a fair number of patterns. I haven't yet collated all these, but let me list the books.

M. Razid Black & Herb Taylor. Unscrambling the Cube. Zephyr Engineering Design, PO Box 1668, Burbank, California, 91507, USA. 40pp, 1980 (printed in 1981). (This includes Black's earlier booklet: Constructing Patterns on the Cube.)

Mal Davies (227 Belly Oak Road, Kings Norton, Birmingham, P30 1HP, UK). Pretty Patterns. 2pp, 1981.

Don Taylor & Leanne Rylands. Cube Games. Penguin (UK), Holt Rinehart & Winston (USA), Greenhouse (Australia). 54pp, 1981

French

A. Deledicq, J. C. Deledicq & J. B. Touchard. Le Cube - mode d'emploi. Editions CEDIC. 47pp, 1981.

André Warusfel. Réussir le Rubik's Cube. Editions Denoël. 190pp, 1981.

German

Christoph Bandelow. Einführung in die Cubologie. Vieweg. 144pp, 1981.
[ See also C7/8-4. - J ]

Josef Trajber. Der Würfel fur Fortgeschrittene. Falken Verlag. 144pp, 1981.

Tom Werneck. Der Zauberwürfel fur Könner. Heyne Verlag. 160pp, 1982.

Generalities

I will adapt the presentation of patterns to give both the number of moves (as before) and the number of quarter turns. E.g. 8,16q will mean 8 turns, but 16 quarter turns (i.e. 90° moves).

A. H. (Sandy) Frey has extended the notation to include moves of the whole cube, as follows. Consider making a R face turn. If we let go of the rest of the cube, then the whole cube turns with the R face. We denote this move by R. Don Taylor points out that this puts us into a larger group - the oriented group - which has 24N = 10 38048 07858 77565 44000 patterns and that processes which only appear to be commutators when we change coordinate systems (e.g. in the slice group) will now appear naturally as commutators. For example, the 6-spot RsFsUsRs is written RDR'D' = [R,D] in slice notation. This becomes [RsR', DsD'] in our new notation. That is, a slice move R (in slice coordinates) is equal to RsR' in our new notation. Some authors prefer to call RsR' the R slice move, viewing the slice as moved clockwise, rather than the R face. I will not use the notation very often, but there are situations where it is very useful. Whole cube moves do not count as turns since they are part of the process of moving from one turn to the next and do not take any extra time to execute.

27

Orbit names

Neil J Rubenking suggests names for the 12 orbits of the cube within the constructible group. I have changed Switch to Swap. Start, Flip, Plus, Minus, Swap, Flip Plus, ... , Flip Swap Minus.

Diagonal Patterns

William J. Blewitt asked if there was any pattern with diagonals on all six faces. John Butler sent an elegant example in a Twist orbit (i.e. in Plus or Minus). Consider alternate vertices of the cube. These are the vertices of a regular tetrahedron whose six edges are diagonals of the six cube faces. Imagine this tetrahedron rotated by 120° about a main diagonal of the cube. This pattern is readily obtained by the corner 3-cycle on N25, followed by a 6-spot and then a corner twist.

2x2 diagonal I posed Blewitt's question in an article and John O. Kiltinen of Northern Michigan University has sent a solution. His argument is based entirely on the corners so it is most easily expressed in terms of the 23 On the 23, a diagonal face has the shown pattern, which is also a chessboard pattern. Then Kiltinen's result is that there is no 6-diagonal pattern on the 23.

Proof. Take URF as fixed. Consider the UBL position, which would have to have a U face in its U direction, assuming that such a pattern exists. If UBR is at UBL, then the piece at DRB must have two R facelets. Similarly, UFL cannot be at UBL, so we must have UBL at UBL. Likewise, DRB must be at DRB and DLF must be at DLF. So the four corners URF, UBL, DRB, DLF must be a correct tetrahedron of pieces.

By the same argument, the other four corners are a correct tetrahedron of pieces, but the two tetrahedra are not correct with respect to each other. Taking the first tetrahedron as fixed, we need only consider the group S4 of 24 permutations of the other corners, which correspond to the rigid motions (including reflections) of the second tetrahedron. The reflections can be excluded at once since they reverse the colours on the corner pieces. So we have just the group A4 of 12 even permutations, which correspond to the rotations of the tetrahedron. One of these is the identity I. Eight of these are 3-cycles corresponding to rotations about a cube diagonal and involve a twist of a corner, so are impossible. The other three are pairs of 2-cycles corresponding to rotations about a 'midline' of the tetrahedron, which is a face to face axis of the cube. This leaves two edges of the tetrahedron in place and hence leaves two faces of the cube of one colour. These are the zig-zag patterns which have four diagonal faces.

(The beginning of the argument is Kiltinen's. I have brought in the consideration of S4 and A4 which allows us to deduce that the only 'generalised diagonal' patterns (i.e. 6-diagonal patterns where a = b can occur) are START and Zig-Zag. This also shows that one cannot get 6 chessboards on the 43.)

28

Two-face Patterns

Michael Holroyd points out that his 2-X on N53 is more efficient than the one on N47. This 2-X was also discovered by G. Kéri and Charles Marks and other variations come from Kevin Lewis and Ross & Karl Anderson.

2-X | F2L2F2L2R2F2L2B2 | (M. Holroyd & WK - 8, 16q; N8,47,53)
 | R2F2sR2·B2Rs2B2 | (K. Lewis - 8, 16q; N8,47,53)
 | R2F2L2B2F2R2F2B2 | (R. & K. Anderson - 8, 16q; N8,47,53)

The last is Crossbars (N48) followed by Fs2 end is a conjugate of Holroyd's method.

Four-face Patterns

There are two 4+ patterns. One rotates the corners 180° about a face axis, which I take as UD (N48), and the other rotates by 900 about the UD axis and I take the clockwise form.

4+ (180°) | R2sU2R2s·F2sD2Fs2 | (H. & K. Anderson - 10, 20q; N11,21,33,35,47,48)
 | UaFaUa2FaUaRa2 | (A. Treep - 12, 16q; N11,21,33,35,47,48)
4+ (90°) | Rs2U2Fs2D . Rs2D2Fs2U' | (V. Toth & L. Varga - 12, 22q; N48)
H pattern | T pattern | U pattern
H | T | U

The H face pattern is the same as the I face pattern seen sideways. H faces are easily obtained from processes like (UF,UB)(DF,DB), but these yield 4-H patterns corresponding to 180° rotations. We also get 4-H patterns from 4+ patterns by a slice move.

4-H (180°) | = 4+ (180°)·Us2
 | Rs2U2Rs2·Fs2D2Fs2·Us2 | (GK, DBS & WK - 12, 24q )
 | (This is a conjugate of two uses of the second process in 5.8-D on N45.)
4-H (90°) | = 4+ (90°)·U's
 | Rs2U2Fs2DRs2D2Fs2U2D | (GK - 13,24q)
[ Slightly shorter is Rs2D2Fs2DFs2D2Rs2D' (12,22q) - J ]

29

There are several 4-T patterns and the two obvious ones can be converted to 4-U patterns by a U turn (though the Us are upside down).

4-U (180°) | RaU2Ra'·FaU2Fa' | (DBS - 10,12q; N49)
4-T (180°) | RaU2Ra'·FaU2Fa'·U2 | (E. Fuss - 11,14q)
Edgar Fuss calls the upside down 4-U a 'Temple' and it does look like a temple or table with doors in the centre of each face. The 4-T can be viewed as a Temple with its pillars in the centre of each face rather than at the corners. Fuss gives a friend's method for 90° versions of these and two shorter methods have been received.
4-U (90°) | ([R,U]U)7 | (? - 28, 28q)
 | FaU'Fa'URaURa'U'FaUFa'U'·U2 | (H. Walker - 19,20q)
 | RUs'B'D'BUsR'DLFRUsF'L'B' | (B. G. Jones - 18,18q)
[ Shortest is RF'L'U2B'D'RBU2LUF' (12,14q) - J ]
David B. Shapiro sends a different 4-T arrangement which has the T's sideways with the crosspieces adjacent. I have reduced this from 28 moves to 8 moves.
4-T (sideways) | L2FR2Us2L2BR2 | (D. B. Shapiro & DBS - 8,14q)
There is also a sideways version of 4-U.
4-U (sideways) | UsR2UsF2 | (A. Treep - 6,8q)
The 4-X pattern is easily obtained from 4-bar followed by Us2
4-X | (R2F2L2)2Us2 | (R. & K. Anderson, GK & WK - 8,16q; N47, 48)
 | RaUa2RaU2Ra2U2 | (A. Treep - 10,16q; N47,48)
Frank O'Hara sends a shorter 4-Z and K. P. Furness sends a 4-2L pattern which is the slice 4-flip (N31, 35, 36, 45, 47) followed by Fa.
4-S | FaRa'FaRaFa'Ra | (F. O'Hara - 12,12q; N11,21,47)
4-2L | Fs2LF2UsR2BRs2F'L2Us'B2R'Fa | (K. P. Furness - 18,24q)
[ Shorter is F2RD'L2BU'RBF'U'LB'D2RU' (15,18q) - J ].
Six-face Patterns
One can get Hs or Is on all six faces in several ways. The most symmetric is to have the bars mutually orthogonal. Someone suggested this 6-H pattern be called the Irish cube (i.e. the H-block!).
6-H | RaFaRaFa2RaFaRa | (A. Treep - 14, 16q)
[ Using half turns only U2B2R2D2U2R2F2U2 (8,16q) - J ].
Several people have sent 6-T patterns. Interestingly, these all give the same asymmetrical arrangement. Exercise. Is there any other 6-T pattern?
6-T | (LsF2) 2 (D2B2) 3 | (R. Ager - 12, 20q)
 | LsF2LsD2F2U2B2U2 | (F. Schmidt - 10, 16q)
[ Shorter is LsU2B2LsB2U2 (8,12q) - J ].

Miroslav Goljan and Jiri Fridrich have analysed the 6-U patterns and found 10 types. I have their processes for 6 types, one of which is Pretzel's, for which Richard Walker has a shorter version. Since these patterns are easier to describe as though the centres move and the corners are fixed, I will do so. E.g. (F,U) means the F and U centres are exchanged. Note that any pattern is even on centres and edges together (N46-47). This representation must be treated carefully!

30

a) | R'D'B'D2FaRa D2Ra'F'DRFs'DaRs2Da' | = (F B)(R,D)(U,L)LU+RD+(FD,BD) | (22, 26q)
[ Shortest is FR2Fs2L'DFRs2B'U'L'F' (13,18q) - J ].
b) | R'B'RsF'R'U'RFRs'BLB2Rs'U' | = (F,R)(L,B)(U,D)(UF,DF,UR)(UL,UB) | (22,26q)
[ Shortest is D2LsB'L2UsB2R'U2BsL2 (13,18q) - J ].
c) | R'B'RsF'R'DsBRBs'LFD2Bs'L2 | = (F,L)(R,B)(U,D)(UF,UL)(UR,DB,UB) | (18,20q)
[ Shortest is F2DFsL'F2L2UsB'LsU' (13,16q) - J ].
d) | LDBsR'FL'F'DsRFR'D' | = (F,U,R)(B,D,L)(UF,RU)+ (DB,LB)+ | (14,14q)
[ Shortest is RF'DsR'FsDLsBD' (12,12q) - J ].
e) | DaLFD'FLFUFs'L'F'D'B'DF'L'U2FsRsDs | = (F,D,R)(B,U,L)(FR,DR,DF)+ (LB,LU,BU)+ | (25,26q)
[ Shortest is U'B2L'DsFRaBDBUsR'U' (15,16q) - J ].
f) | Rs·U'F(UF)2(U'F')2·Rs'·RsFsUsRs = Rs·U'F(UF)2U'F'U'B'UsRs | = (F,R,U)(B,L,D)(FL,RD,UB) | (R. Walker - 16,16q; N49)
[ Shortest is UsF'URsB'UFUsR' (12,12q) - J ].

The last three can be formed by moving the edges and then applying a 6-spot.

There is a possible 6-bar pattern obtained by applying Rs to the 4-bar, but the bars are not all orthogonal as described at N28, 47.
6-bar RaU2Ra2U2R2 (A. Treep - 7,12q)

More interestingly, Ross end Karl Anderson suggest R2F2L2R2F2Us2L2Us2 [ or B2D2Fs2Rs2U2F2 (8,16q) - J ] which almost gives the impossible 6-bar and if you hold it with your thumb and forefinger covering the F and B centres, then it looks like the impossible 6-bar.

Kate Fried has found a 6-flip.
6-flip (LFL'U)5 = UL+UB+UR+UF+FR+FD+ (K. Fried - 20,20q)
Conjugating this with F changes FD+ to FL+ and then the non-flipped edges are in the same configuration as the flipped ones.

Pinwheel (CW) Mel Perry and Charles Marks send a new face pattern as shown. Marks calls this 'pinwheel' and I called it 'spiral'. The pinwheel comes in two orientations. Let us call the depicted one 'clockwise' and its reflection 'anticlockwise'. Perry's pattern has 4 pinwheels in one direction and 2, on opposite faces, in the other direction, Marks has 5 pinwheels in one direction. Neither has a simple pattern-producing process.

[ Try these sequences:
4-2 RaU'Fa'DsFa'Rs2URa (14,16q)
5-1 FaU2L2F'D'R2L'F'D'RFUsF2BLD (18,22q)
3-3 R2BD2FaUaLFLsFsL'UL2FL2 (18,22q)
3-3 D2R2B2U2R2FD2F2LFaR'D'FR2F2DF'U' (19,28q) - J ]

31

Exercises. Can we get 6 pinwheels in the same direction or 3 in each direction? Are there patterns with a = c, b = d ?
[ The answers are no, yes, no. -J ]

David Sibley provides a process for producing tri-coloured faces.

S = S(U,R,F) = R'FD2F'D·L2·D'FD2F'R = (FUR,FLU)(BRU,BUL)(UR,LU)(LF,LB)

This exchanges the UR and LU columns and also (LF,LB). Applying this twice he obtains a Tricolours where three faces use the same three colours in parallel columns. If we use the mono-column-flip (N31,48), C = C(R,F,D) = R2FDR2D'R, we can get the same pattern.

Tricolours (Sibley) | = S(U,R,F)·D·S(D,R,B)·U2D | (D. Sibley - 25,32q)
 | = C(R,D,B)U2C(R,D,B)-1 · C(F,U,L)D2C(F,U,L)-1 · UFs2U2Fs2U | (D. Benson & DBS - 33,48q)

You may find these easier to carry out if I write them as (SDR2)2UD2 and RCB2C'·FR2CB2C'·FRs2F2Rs2F

Joe Nemeth also found this pattern, but by a longer process.

[ Shorter is D'BLsBsL'D2Fa'UL2FsU2R'U' (17,20q) - J ]

Some Diagonal Patterns

Charles Marks send a number of patterns which led me to study ways of combining the processes of Ahrens (N29) and Walker (N48) which twist corner 'pyramids', i.e. a corner and its three adjacent edges considered as a unit. These give a number of diagonal face patterns which I name as follows.

Diagonal Tricolour | Stairs | Latin Square | Quincolour
Diagonal Tricolour | Stairs | Latin Square | Quincolour

A = A(U,R,F) = URF+(FU,UR,RF)UFL- = [R',F][U,F'][U',R]

twists the URF pyramid clockwise and the adjacent corner UFL anticlockwise.

W = W(U,R,F) = URF+(FU,UR,RF)DFR- ULB+(BU,UL,LF)DBL- = RaURa'·Fa'UFa

twists the URF and ULB pyramids clockwise and the adjacent corners DFR and DBL anticlockwise.

Note that W = FR A R2 A RF'.

32

AU2F'LA'L' is a stage toward the Double-cube pattern (N28,29,48) and is a 6-stairs pattern.
[ Shortest is FD2BRB'L'FD'L2F2RF'R'F2L'F' (16,20q) - J ]

AUR'A' gives one diagonal tricolour, four stairs and a plain face (C. Marks)
[ or RF2L'UBU'F2U'B'RFULF'R2 (15,18q) - J ].
Applying RU'(RaFa) 3 to this gives 5-diagonal tricolours with one plain face (C. Marks - 36,36q)
[ or DRF2U'FDB'RU2BR'DsL'BD' (16,18q) - J ].
This was the first case I saw of a 5:1 distribution of face patterns. Usually one gets 3:3, 4:2 or 2:2:2, although the first stage has 4:1:1 and Marks' Pinwheel is also a 5:1 (but came later). Marks says that when he first made this, a friend picked it up and said "So you've got one face correct".

WFU'AUF' followed by DBL-DFR+ gives three diagonal tricolours with their diagonals radiating from UFL and three stairs with their bulk at DRF (C. Marks).

[W, Fa'UFa UR2] = RaURa'Fa'U2FaU · Fa'D'FaRaD'Ra' · U'Fa'U'Fa (C. Marks - 27,28q)
[ or U'R2U2B2D'R2F2U'R'F'U2L'BsL2RFUa' (19,26q) - J ]
gives 6-diagonal tricolours, a pattern which is mentioned in passing on N29,48.

While considering the above pattern, I discovered a new 6-2L pattern. In this one, all corners are in place, merely twisted, and no uprights adjacent.

6-2L WF2W (DBS - 20,20q)
[ or UaFaRa'Fa'RaUa (12,12q) - J ]

(Note that 2L patterns are Pinwheels with a = b, c = d. This pattern has 6 anticlockwise 2Ls while the earlier 6-2L had 4 anticlockwise 2Ls.)

Marks says he can get two Latin square faces and the other four close to it. Exercise. Is there any 6-Latin square pattern?
[ The answer is no. - J ]

John O. Kiltinen sends a pattern consisting of 6-quincolours obtained by twisting the corners of the 4 pyramids which are twisted in 6-diagonal tricolours. This can be achieved by DWD'F2DW'D' (24,24q)
[ or DB2R'B2RaU'L2BsL2DRa'F2RF2U' (18,24q) - J ].
If one twists the corners in the opposite ways, one gets the tricolour patterns which are quincolour with a = c = e.

The pattern given by (FLU,UBR,RDF)(FU,UR,RF)(FL,UB,RD)(FD,UL,RB)
[ e.g. LUL2FUB2D'RsFaDR'B (14,16q) - J ]
takes the three pyramids at FLU, UBR, RDF and rotates them as a unit 120° clockwise about the FUR-BLD axis. This is a single pyramid twist away from Butler's impossible tetrahedron.

Miscellaneous Patterns

The Double-cube pattern (N28,29,48) can obviously be modified to a Triple-cube by twisting the corners at the ends of the rotation axis. The faces can now all have two or three colours. I can produce either of these in 32 moves by following Walker's process (N48) with a conjugate of the U corner process +0-0.
[ or try these:
F2D'R2D'L'U'RsBUsBLF2LU2 (16,20q)
U'L2F2D'L'DU2RU'R'U2R2UF'L'UR' (17,22q) - J ].

David B. Shapiro sends a 'Flat meson' which consists of the two 23 at URF and ULB rotated 180° about the UD axis. Turned over, it looks like a Temple with two corner pillars or a two-legged table. It can be viewed as (UBR,UFL)(BR,FL) followed by D2, so it could be easily obtained from the U process (A,C)(a,c).
[ F2LD2B2R2B2L'D2R2F2R'D2R2 (13,24q) - J ].

Anneke Treep sends an odd but attractive pattern which she calls Skein. Form UFR+DBL-UF+FR+RU+DB+BL+LD+ and then apply the 6-spot FsUsRsFs. (Picture on next page.)
[ DR2U'B2UF2U'BsLFRsB2R2U'F2R2U' (19,26q) - J ].

Pretty Random Patterns

A number of people seem more interested in disorder than order. There are several different criteria that have been used to measure disorder. Let us consider the number of facelets of each colour on a face and write down these numbers in decreasing order. We can have 900000, 810000, 720000, 711000, ...

33

Anneke Treep's Skein We abbreviate these as 9 (= 905), 81, 72, 712 , .... The complete list of these 'partitions of 9 into at most 6 parts' is: 9, 81, 72, 712, 63, 621, 613, 54, 531, 522, 5212, 514, 421, 432, 4312, 4221, 4213, 415, 33, 3221, 3213, 323, 32212, 3214, 2413, 2313. Of these, only 415, 3214, 2313 have all six colours.

David C. Maxwell and K. P. Furness both send FaRaFaRa2 which gives six colours on each face - four 2313and two 3213 - which is perhaps not the most random distribution. Moreover, no two facelets of the same colour have a common edge, so this is a proper colouring of the 54 facelets as a map. Brian Martin sends (RsUs)2 which is a proper map colouring with six 4221 faces.

Charles Marks obtains six colours on each face without moving the edges: twist all the U corners + and all the D corners - (e.g. by using the U corner process ++-- on the F and B faces); apply Zig-zag (RaFa)3; exchange U and D edges with a 2X pattern.
[ D'FRU2L2F2D2RBL'B2F'D2L2F'R'U' (17,24q) - J ].

Brian Martin gets six 2313 faces by: 12-flip; diagonal exchange of corners exchanging F & B (i.e. (FUR,BLD)(FLU,BDR)(FDL,BRU)(FRD,BUL)); then FLU-FRD-BRU+BLD+.
[ RaU2R'DB'U'R2B2LUR2B2U'2LB'R'FU' (19, 24q) - J ].
This is also a proper map colouring. Indeed no two facelets of the same colour meet at an edge or a corner, so it is a 'strong' map colouring. In fact, any two cochromatic facelets on a face are separated by a knight's move (16 times) or are diagonal corners (2 times). Frank Carey finds that (UL,LB,DL,RB)(UR,LF,DR,RF) UF+UB+DF+DB+ gives a strong map colouring.

[ See also C7/8-8. - J ]

Entropy of a Pattern

George Marx and his colleagues in Budapest have used the Cube as a model for the physical concept of entropy, which is a measure of disorder and is the logarithm of the number of states of a given type. That is, the more common a type is, the greater its entropy, and the most common types are generally those with the least structure, i.e. the maximum disorder.

A simple example is to consider each of the 9 facelets of a face as being equally likely to have each of the 6 colours, giving 69= 100 77696 equally likely patterns. (This ignores the effects of the other faces.) If there are Ci facelets of colour i, then there are 9!/C1! ... C6! ways to distribute the 9 facelets in this colour pattern. However, we shall just consider the 'partition' of 9 given by the Ci, so we want to count all the different ways the Ci can be rearranged - i.e. we consider all the possible reassignments of colours. If there are Nj values of Ci which are equal to j, then there are 6! / N0!...N9! distributions of the Ci for a particular partition. For example, if we take the partition 712 , then the corresponding distributions (or ordered partitions) are 711000, 710100, 710010, 710001, ..., 000117. Here N0 = 3, N1 = 2, ..., N7 = 1 and there are

6! / 3!2!0!0!0!1! = 60 distributions corresponding to the partition 712 (=71203). Each of these distributions occurs 9! / 7!1!l!0!0!0! = 72 times as a distribution of facelets, so we have 72.60 = 4320 patterns for this partition. Straightforward calculations show that the most common partition is 32212 which has 27 21600 patterns of the 69, which is about 27% of them.

34

For the 23, the partitions of one face are 4, 31, 22, 212, 14 and they have 6, 120, 90, 720, 360 patterns respectively. On the 43 there are 136 partitions of 16 into at most 6 parts. Exercise. Calculate the number of patterns for each partition of a face on the 43.

Some Pretty Patterns in Other Orbits

The pattern of Walker's Snake (N49) followed by (FL,RB) has the appearance of the unique type of circuit along edges through all the vertices of a cube. The pattern is reminiscent of the curve on a tennis ball or a baseball. Such circuits are called Hamiltonian and so I call this the Hamiltonian circuit or Tennis ball pattern. It is in the Swap orbit. The Worm and the Snake are the only types of Hamiltonian circuits through the faces of a cube, or, equivalently, through the vertices of an octahedron. Zig-zag can be viewed as such a circuit along the edges of a tetrahedron, and is the only type of such circuit.

Edgar Fuss gives a Swap Double-cube pattern. Imagine the ordinary Double-cube (about the FUR-BLD axis) and then rotate the two 23 180° about the LF-RB axis.

(2+1)² Ray Ager tried to construct patterns with (2+1)2 faces, with a = d, b = c. He can get it on four faces, with two 81 faces, by U2R2U2R2U2B2R2U2. I have found a version with a = d on six faces arranged to show (2+1)3. The pattern is (FU,LU,BU)+ (RU,RB,RD)+ (FR,FD,FL)+ (FLU,LBU)+ (UBR,BDR)+ (FRD,FDL)+ which is in Swap-Flip. Exercises. Is there any achievable (2+1)3? Is there any constructible (2+1)3 with b = c (and a = d)? The name of this face pattern derives from its being a geometric representation of (2+1)2 = 2·2 + 2·1 + 1·2 + 1·1.

ORDERS OF ELEMENTS

Several people have found that there are just 73 possible orders of elements (N50/50). Jesper C. Gerved and Torben Maack Bisgaard, of Copenhagen, have computed the number of elements of each order as shown in their Table 4 on the adjoining page. I find that the average order is 122 and the median is 67.3. In ascending frequency of appearance, the orders are:

1, 11, 2, 3, 5, 7, 22, 4, 55 & 110, 80, 15, 33, 14, 21, 1260, 9, 35, 10, 280, 28, 315, 44, 99, 720, 112, 6, 16, 495 & 330, 140, 105, 504, 840, 336, 63, 8, 70, 231 & 462, 630, 66; 240, 126, 18, 360, 132, 56, 252, 144, 42, 198, 48, 420, 168, 40, 210, 72, 84, 90, 120 30, 12, 180, 36, 24, 60.

About 10.6% of the positions have order 60.

35

Order | Number of elements | Order | Number of elements
1 | 1 | 77 | 187 23810 94133 76000
2 | 17 09115 49183 | 80 | 13 34938 37266 94400
3 | 3389 45406 22394 | 84 | 1697 72581 86780 67200
4 | 4 34695 70301 44256 | 90 | 1925 06905 16173 83168
5 | 13352 81725 14624 | 99 | 104 36790 91359 74400
6 | 140 62105 92987 55526 | 105 | 232 82441 94233 54880
7 | 15324 55171 48800 | 110 | 4 85432 13551 61600
8 | 294 99863 89819 39200 | 112 | 128 72620 02216 96000
9 | 55 33375 23984 28896 | 120 | 1947 04401 14631 47520
10 | 65 25089 78363 52192 | 126 | 425 69635 22238 87360
11 | 4 45906 94400 | 132 | 637 12967 78549 60000
12 | 2330 23282 74555 54048 | 140 | 223 12541 37176 06400
14 | 23 29837 43830 21440 | 144 | 714 19202 93781 50400
15 | 14 38547 13332 09856 | 154 | 187 23810 94133 76000
16 | 150 73188 62708 73600 | 165 | 213 59013 96271 10400
18 | 520 62284 91581 24832 | 168 | 1050 26923 92665 08800
20 | 198 73224 56649 27744 | 180 | 2453 88900 57383 11680
21 | 39 33715 15593 33120 | 198 | 759 70129 20827 90400
22 | 92708 51272 70400 | 210 | 1339 23273 20469 50400
24 | 3293 93251 97962 44480 | 231 | 374 47621 88267 52000
28 | 97 41976 09076 73600 | 240 | 407 15620 36641 79200
30 | 2033 28420 89667 40224 | 252 | 689 87708 04473 85600
33 | 15 87401 96622 33600 | 280 | 68 65397 34515 71200
35 | 65 52621 89125 63200 | 315 | 99 30987 96525 15840
36 | 3186 20259 79731 76320 | 330 | 213 59013 96271 10400
40 | 1136 25838 02544 12800 | 336 | 257 45240 04433 92000
42 | 737 19977 68310 97600 | 360 | 571 01988 89093 52960
44 | 100 12037 79502 08000 | 420 | 961 15562 83219 96800
45 | 197 32944 16597 27104 | 462 | 374 47621 88267 52000
48 | 911 49764 74103 80800 | 495 | 174 75556 87858 17600
55 | 4 85432 13551 61600 | 504 | 238 38185 22624 00000
56 | 671 20530 68464 12800 | 630 | 395 38014 01624 16640
60 | 4601 52469 28929 25952 | 720 | 120 14445 35402 49600
63 | 264 37143 37053 08160 | 840 | 240 28890 70804 99200
66 | 404 05117 52503 29600 | 990 | 174 75556 87858 17600
70 | 353 49083 42737 30560 | 1260 | 51 49048 00886 78400
72 | 1681 09266 03396 71040 |  |

Table 4. The number of elements of each possible order in the group Go

36

THE MAGIC DISC

Magic Disc In N51/52, I discussed planar versions of the Magic Cube. During my recent visit to Budapest, Tibor Szentiványi gave me a Magic Disc which is a different kind of planar magic cube. It comprises a circular disc divided into two halves (A and B) surrounded by a ring of 6 pieces (1 to 6). The outer ring rotates with respect to the inner ring. Further, when aligned as shown, the right half of the disc can be turned over, exposing the reverse sides B', 1', 2', 3' as shown. The two sides have pictures of dogs in blue and brown and they are not easy to keep track of. If we hold it with A up, there are only 1152 distinct patterns and these readily reduce to 96. I find the diameter of the reduced Cayley graph is 7 and there are nine antipodes. Despite the simplicity of the problem, it is not trivial to produce an algorithm nor to determine just what patterns are possible. If the outer ring of the disc has only 4 parts, then there are 48 patterns which reduce to 6, where the Cayley graph is a 6-cycle. The case with 2n parts, for n≠3, is quite different to the 6 part case.

[ An 8 segment magic disc is still available as the Saturn puzzle by Mag-Nif. A 12 segment magic disc is also commercially available and is called the Hockey Puck. These are indeed very different to the 6 segment version. See also my Hockey Puck page. - J ]

COMMENTS ON THE U GROUP

Guus Razoux Schultz has a method for the U group (N49) in at most 26 moves. Jerome Jean-Charles conjectures its diameter is 19q.
[ See also C3/4-17, C5/6-2 and C7/8-8. - J ]

© David Singmaster

Home
Links
Guestbook


Cubic Circular, Issue 5 & 6

The Cubic Circular magazine was written and produced by David Singmaster in the early Eighties. The first issue was a small 16 page pink booklet, of about 19.5 × 14cm. Later issues were on yellow paper and slightly larger at 21 × 14.5cm (A5 format). There were only 5 magazines published, of which 3 were double issues:

Issue 1: | 16 pages | Autumn 1981
Issue 2: | 16 pages | Spring 1982
Issue 3&4: | 36 pages | Spring&Summer 1982
Issue 5&6: | 28 pages | Autumn&Winter 1982
Issue 7&8: | 48 pages | Summer 1985

The double issue 5/6 is reproduced below. I have tried to keep it as close to the original as possible, so I have kept the images in the same style, even though most pictures have been redrawn. I have occasionally inserted a comment or correction of my own, and to be clearly distinguishable from David's text my comments are in italics and in square brackets,
[like this - J ].

David Singmaster still has many copies of the Cubic Circular available, so I highly recommend acquiring them from him directly. David can be contacted via e-mail (zingmast@sbu.ac.uk) or at:

    David Singmaster
    87 Rodenhurst Road
    London, SW4 8AF
    United Kingdom

The text and original drawings are copyright © David Singmaster, reproduced with permission. Conversion to html and additional commentary by Jaap Scherphuis.

Home
Links
Guestbook
Cubic Circular Logo

CUBIC CIRCULAR

A quarterly newsletter for Rubik Cube addicts

Issue 5 & 6
Autumn & Winter 1982

ANOTHER DOUBLE ISSUE

CONTENTS |
Editor's Corner | 2
More on the U Group | 2
Cubathons | 2
The n-Dimentional Cube Solved | 3
Miscellany | 4
New Cube Products | 5
Tsukuda's Square | 7
More Clubs | 8
Generalized Hungarian Rings | 9
The Incredi-Ball (or Impossiball) | 10
Going Ape over the Cube | 10
Some Geometric Puzzles |
A. Eight Cube Rings | 11
B. Twelve Tetrahedra Rings | 13
C. Cubic Snakes | 14
Some Notes on the 43 | 15
Pyraminx | 18
Cubism and Religion | 22
Prehistory of the Cube | 23
Local Maxima | 24
The Trials of the Cube | 25
A Czech Check Problem | 25
God's Algorithms | 26
First Day Cover | 28
Block of 4 Stamps | 28

Published by David Singmaster, 87 Rodenhurst Road, London, SW4 8AF, UK
ISBN No. 0261-8362. All material © 1982 by David Singmaster.

2

EDITOR' S CORNER

IMPORTANT NOTICE: Due to retrenchment at David Singmaster Ltd., I am now running the Cubic Circular personally. All future correspondence should be addressed to CUBIC CIRCULAR, 87 RODENHURST ROAD, LONDON, SW4 8AF, UK. Subscription cheques should be made out to David Singmaster. Subscribe now - give a gift subscription for Christmas: Subscription rate for the second year is £4 or $8. Back issues of Volume 1 available for £3 or $6.

From July, Peter Light has been assisting me in dealing with the mass of accumulated correspondence. By now, almost everyone will have had some reply to their letters - some of which are eighteen months old! We have not had time to digest everything and there are a number of letters (e.g. in other languages) which he has not been able to deal with. We hope everything will be cleared away by the new year:

Let me urge correspondents to send stamped addressed envelopes (or at least a mailing label and a reply coupon): Also, please make sure your name and address and the date is on the contents as well as the envelope - envelopes do get separated from their contents and contents sometimes get filed in different ways.

Peter has also been testing the various computer programs which have been sent in.

Some of this Circular has been typed with 1 1/2 spacing instead of single spacing. This gives about 25% fever lines per page but is more readable. What do you think?

I would be delighted to receive contributions in the form of short articles for the Circular.

On page 3, I mention the Rubik's Cube stamps from Hungary. I have arranged to print these on the back page and the following has been transferred from there to make room for it.

MORE ON THE U GROUP (N49, C3/4-17,36)

Nicolas Hammond has a method for the U group in at most 21 moves.
[ See also C7/8-8. - J ]

J.F. Jarvis (96 Forrest Ave., Fair Haven, New Jersey, 07701, USA) has an inventory of U processes and would like to hear from anyone interested in compiling a directory with him. (Mr. Jarvis, meet Mr. Hammond - Mr, Hammond, meet Mr. Jarvis!)

CUBATHONS

In the 24 hour Cubathon of PCs Timoney and Pullen (C3/4-7), they completed 1043 Cubes in 24 hours. That's 21.73 cubes per man-hour, or an average of 2.76 min or 2 min 45.7 sec per cube.

Cardiff Students Rag 1982 had a Cubathon in which two students solved 2000 Cubes in 36 hours. That's 27.78 cubes per man-hour or an average of 2.16 min or 2 min 9.6 sec per cube.

3

The n-DIMENSIONAL CUBE SOLVED

Joe Buhler, Brad (3D) Jackson and Dave Sibley have drafted their work on the n-dimensional Rubik Cube. Like Keane and Kamack (C2-8), they allow orientation preserving movements of the n-1 dimensional facets of the n cube. The constructible group is a direct product of the appropriate wreath products

where Nd = 2n-d n! / d!(n-d)! is the number of d-dimensional faces of an n-cube, but when d = 0, we take An-d instead of Sn-d. They find several conversation laws which yield

Where [An:An'] = 3 for n=3, 4 and is otherwise 1. It is not clear how the expression works for n=2.

4

MISCELLANY

Several readers have been confused by expressions involving commutators. Recall that (N30,41) [A,B] = ABA'B'. Hence
[A,B]-1 = (ABA'B')-1 = BAB'A' = [B,A]!! Thus we have
[A,[B,C]] = A·[B,C]·A'·[B,C]' = A·[B,C]·A'·[C,B] = A·BCB'C'·A'·CBC'B', and
[A,[B,C]]' = [[B,C],A] = [B,C]·A·[C,B]·A' = BCB'C'·ACBC'B'·A'.

I forgot to mention that the First World Championship in Budapest was commemorated by a special 2-forint stamp, with First Day Covers, etc. If space and reproduction permit, I'll try to include a picture on the back page.

Several readers assert that WD40 and other aerosol spray lubricants can dissolve the central spindle!

The handbook of Cubik Math, by A. H. (Sandy) Frey and myself, is now available in the UK and Europe from Lutterworth Press. The UK list price is £5.95. I will be happy to dispatch copies to the UK and Europe for $6.50, including post and packing. The book has been well reviewed.
"A book that will delight enthusiasts"
"The solution in Chapter 3 is ... intelligent and breathtaking in its simplicity."

An article in Science 82 reports a 19 year old autistic child who doesn't speak but solved his first cube in 40 seconds!

An Auckland (New Zealand) paper reported a solution time of 5.51 seconds!

A French engineer, Alex Renault, at the firm AKR, has built a 'Rubik Robot with video colour detector which takes about 15 seconds per turn.

A cubical question was set on a UK entrance exam: "Exam Paper for Awards and Entrances in the College of the University of Cambridge - Paper 871, Physics & Maths, 23 Nov 1981". Question 12 asks how many ways one can reassemble a cube when cut into 27 cubies and one wants the colours outside, and what is the probability of getting the U face all blue.

Arthur P. Cracknell reports that the Cube proved an exception to a well known scientific law. The law is that no-one comes to lectures on the last afternoon of a conference. The exception was a lecture by Hans Zassenhaus at a colloquium on group theoretic methods in physics at the University of Kent, which was the last and most attended lecture of the colloquium.

At C2-4, I reported that 3 year old Glenn Quackenbush could do the Cube. His father writes that he can 'only' do several patterns - still that's not bad for a 3 year old.
[ See also C7/8-46. - J ]

5

NEW CUBE PRODUCTS

I have been kindly sent cubes with five fruits and Chex (a US cereal box top offer) and with Pac Man symbols. Several full-face patterns have appeared: animals, butterflies, copulating couples: In Italy, I found several interesting Ideas: Football Cubo - with full-face colours of six leading football (= soccer) clubs; Caricatur Cubo - with full-face caricatures of six Italian political party leaders; Italian Political Cube - with symbols of the six major parties (It can't get any more confused than Italian politics. Perhaps it's used for predicting Italian election results!); Souvenir di Venezia - with five full Venetian scenes and the motto on the sixth face. (I saw a ample of a scenic cube in Nuremberg, but this is the first I've seen on sale.) Neil C. Rubenking sends a cube with four colours forming pyramids about four alternate corners. He also sends a slightly melted cube, transfixed by a large brass screw, mounted on a wood base with a brass plate: "SCREW IT". In Holland, the all black cube (C3/4-10) is called the Belgian Cube.

The unnamed shape mentioned on C3/4-11 is a truncated rhombic dodecahedron. I have examined a Taiwanese 23 (C3/4-9) and its mechanism is similar to Rubik's 23 patent. That is, it is a 33 with its corners concealing the edges and centres. It differs from Rubik's method in details, but it is still a very complex design.

Jorg Brown, age 13, of Fort Collins, Colorado, has designed (but not built) a 53.

Edward Hordern has made a 33 into a 53 by gluing extra pieces on 3 sides. This causes the 42 faces to rotate eccentrically about one of the centre pieces. It is quite difficult to get back into shape!
[ Idea due to Nob Yoshigahara, see C7/8-9. - J ]

Cube Mates (Cinderella Co., P C Box 265, Sykesville, Maryland, 21784, USA) is a set of 54 lettered stickers to put on your cube to play word games. Every letter and * (a wild card) occurs at least once and the following more often - 2 times: D, G, H, P, S; 3 times: B, E, R, T; 4 times: I, L, O; 6 times: A. The instructions describe several games.

Ideal has produced a Puzzle Poster in the US showing about 2,000 cubes - one of which is wrong: They are also marketing a Jigsaw with all the pieces the same shape, but which assemble into a pattern in just one way: (cf. C3/4-11) The second issue of their Rubik's Cube Newsletter has appeared. I haven't yet seen the second issue of Rubik's (the Hungarian magazine), but I have just heard of it.

Cubical shoelaces have come from the USA. Solomon W. Golomb sports seeing cubical duvet covers in Amsterdam.

Although I have not yet seen examples, Mèffert has offered to send a catalogue of his products and to supply them by mail order. His address is Pricewell (Far East) Ltd., P.O. Box 31008, Causeway Bay, Hong Kong. The October issue of Omni shows a Magic Dodecahedron, called Megaminx (C3/4-19), a Pyraminx Cube (C3/4 - 12/13), and the Impossi-Ball (also called Incredi-Ball and described elsewhere in this issue). Some other products are mentioned. The offer to supply was made to Omni readers.

6

An article in La Recherche last December is partly by Raoul Raba inventor of the Rotascope (C2-14/15). Several variants are described. The flattened cube is three rings which behave like three faces of a cube - but each face has six corners and six edges. (A two-ring version of this was devised by Doug Engel of Colorado).
[ See also the 'Turnstile' puzzle page - J ]
Two spherical versions are shown, along with cubical equivalents. These look very like Durham's Pyraminx Cube (C3/4-12/13), but it's not clear just how they move. Raba also shows that the Rotascope can be viewed as a cube with some pieces glued together as shown.
[ See also the 'bicube/bandaged cube' puzzle page - J ]

Ruth Roufberg has tracked down the earlier version of these puzzles (C2-14/15). It was a 1971 Parker Brothers game called Orion with a 52 array of rotating discs, each containing lenses (as on C2-14)

Linear Aesthetic Systems, P O Box 23, West Cornwall, Connecticut, 06796, USA, have programs to display and simulate cubes up through 73.

Diane Turnbull reports seeing a 'Cubies' chair at Heal's (Tottenham Court Road, London). It has a plastic frame which holds small coloured cubes which you can take out and rearrange.

Van C. Wedgwood sends his "The Idiot's solution to the Rubiks Cube" which consists of a set of coloured labels. It costs $2.00 from PO Box 9261, Denver, Colorado, 80221, USA. (This reminds me of what someone called the 'chemical solution' to the Cube - use some solvent to dissolve the glue of the sticky labels and then reglue them!)

Early reports from Russia and China regarded the Cube as a symbol of Western decadence. Izvestia reporter Melor Sturua said: "Some assert that the Rubik Cube reflects the philosophy of the Reagan Administration - to build and destroy aimlessly in a futile search for a solution to the world situation. Others see Americans' efforts to solve the puzzle as the desire to escape from a disordered life." A report from China criticised be Cube as a time-waster and said that a boy had allowed a batch of buns to burn in the oven while he was distracted by a Cube.

However, a more recent report in Trud reveals that the Russians have succumbed to Cubitis. They will produce their own products -the Muldavian Pyramid and the Nikitin Cube - early next year!

7

TSUKUDA'S SQUARE

I mentioned this briefly at C2-9. I have had a chance to study Edward Hordern's example and I can describe it in more detail.

My previous description was incorrect due to having seen it only briefly and in conjunction with a Crossover.

The puzzle is a 42 board with pieces numbered 1 to 16. Each horizontal row can be slid one place to the right, bringing in an empty space on the left and concealing the piece on the right as In Figure 1 which shows the effect of sliding row 2. The three columns on the right can be slid down together by one place as shown in Figure 2.

FIGURE 1

FIGURE 2

All the slides are spring loaded to return to the original positions. Let us denote the right slide of row n by n, its left slide by n', the down slide of columns 2, 3, 4 by V (for vertical and its up slide by V'. When V has been made, row 1 is obstructed and slides 1 and 1' cannot be made.

8

As with other sliding piece puzzles, we have two levels of group structure. If we include 8 extra pieces along the bottom and right edges, we can view each move as a 5-cycle on this set of 24 pieces but the set of patterns is not a group. We get a group structure on the 16 numbered pieces by considering the patterns in which each extra piece is restored, i.e. each slide is returned to its initial position. Since this requires an even number of moves for each slide, each such pattern is an even permutation of the 16 pieces. A sequence of moves is in the group if and only if:

  1. it has as many 1's as 1s, ..., V's as Vs;
  2. b) the 1s and 1's, ..., alternate, in this order, in the sequence;
  3. c) 1 and 1' do not occur when there is an uncancelled V.

Commutators of moves are obvious processes with these properties, but they are messy. To investigate them, I wrote a simulation program on my Sinclair ZX81. This yields the following:

[2,V] = 2V2'V' = (2, 5, 6, 7, 8, 4, 3)

[23,V] = 23V2'3'V' = (2, 5, 9, 10, 11, 12, 8, 4, 3) etc. (Note that 2'3' = 3'2'.) and

[1,[2,V]] = (1, 2) (4,8)

The last result was not quite expected since 1 and [2,V] overlap in 3 places. But 1 sends

1 à 2 à 3 à 4 à

and [2,V] sends

à 8 à 4 à 3 à 2 à 5

so some of the interaction cancels in the middle, leaving only the 2 2-cycles at the ends of the overlap. In fact, this always happens when we take a commutator of two cycles that overlap in a sequence of positions.

From (1,2)(4,8), it is easy to obtain (4, 8, 12) and (3, 4, 8). It is easy to put whatever pieces are desired into locations 1 and 2. Then it is easy to get any piece in rows 2, 3, 4 into position 8 without affecting row 1. Thus we can achieve all the 3-cycles (3, 4, n) , n > 4, and so we can get any even permutation of the 16 pieces.

Added in Press. This puzzle is being distributed in the UK as "It".
[ See also my 'It' puzzle page - J ]

MORE CLUBS (Cont. from C1-12)

The Nederlanse Kubisten Club (NKC) has been established by Anneke Treep and others (address in C2-3).

[ The NKC (Dutch Cubists Club) and their quarterly newsletter Cubism For Fun (CFF) are still going strong after 20 years. See their homepage for contact details. - J ]

There is a Hungarian Rubik Cube Club with rooms in the Kossuth Club, Budapest.

Georges Helm has founded the Rubik's Cube Club Luxemburg at 76 Bomecht, L-4936 Bascharage, Luxemburg.

9

GENERALIZED HUNGARIAN RINGS

The Hungarian Rings, described at C2-14, have a nice generalisation. Suppose we have left and right rings with m and n balls with the intersection being a and b balls apart on these rings. Then there are N = m + n - 2 balls all together and we consider them as all distinct. Let G(m, n, a, b) be the group of achievable positions. Let L, R denote clockwise rotations of the left (right) ring. Philippe Paclet [Jeux et Stratégie 16 (Aug-Sep 82) 30-32] asserted that G(m, n, a, b) always contains AN the group of all even permutations of the N balls.

I have shown that this is not true. There is an infinite class of exceptions and one special case.

I. G(4, 4, 1, 1) is the same as the cube group <F,R> acting on the 6 corners it affects. In N55/57, this group is discussed and shown to be isomorphic to S5 - the group of permutations of 5 objects.

II. G(2a, 2b, a, b) is the antipodal case. Here the balls fall into antipodal pairs which cannot be separated. There are N/2 = a + b - 1 antipodal pairs and we can view the rings as an a-cycle and a b-cycle of these pairs. Thus it is easy to get any even permutation of pairs. Pairs may also be inverted, e.g. [La, R] inverts two pairs.

We can view G as a group of actions on the set of a + b - 1 oriented pairs, i.e. as a subgroup of the wreath product Z2 wr Sa+b-1

  1. If a and b are odd, we get only even permutations of pairs. But La inverts an odd number of pairs, so any number can be inverted. So G = Z2 wr Aa+b-1.
  2. If a and b are of opposite parity, we get G = Z2 wr Sa+b-1.
  3. If a and b are both even, we can only invert an even number pairs. The easiest method is to use Rowley's proof (N3/4-21). Both L and R are odd permutations of pairs and are odd permutations of the individual pieces. So if all pairs are in place, only an even number of them can be inverted. Hence G is the subgroup of Z2 wr Sa+b-1 in which the parity of orientation changes is the same as the parity of the permutation of pairs

Cases A and C give 2a+b-1 (a+b-1)!/2 patterns. Case B gives 2a+b-1 (a+b-1)!. In all cases other than mentioned in I and II, does contain AN and = SN if m or n is even; = AN otherwise.

In case you haven't yet solved your Hungarian Rings, here' s hint. Consider [La,Rb], which is [L5, R5] in the commercial version. This is equivalent to [F, R] on corners of a cube.

[ See also C7/8-19 and my Rubik's Rings puzzle page - J .]

10

The argument used in Case II-C above shows that I was wrong in C2-15 in asserting that each antipodal pair on the Equator could be inverted. Thus there are 15! 215/2 = 21 42493 68453 12000 permutations of the pieces, 15! 215 415/2 = 2 30048 50767 37011 27290 88000 patterns when all four orientations of each pair are distinct. (Pentangle is now importing a version with a map of the world on it which has this many patterns.) The number of patterns on the Equator is half the number at C2-15, line -6, namely 1560 11629 01048 52480.

THE INCREDI-BALL (or ImpossiBall)

This is described in Scientific American (July 1982) and Omni (October 1982). It consists of 20 spherical triangles (i.e. a spherical icosahedron) with a springy mechanism which allows a 'face' of five triangles about a vertex to rotate. There are coloured circles about each vertex. A little thought shows the triangles are equivalent to the corners of a Magic Dodecahedron, so there are
20!/2 320/3 /60 = 2 35639 02142 42189 66794 24000 distinct positions where the denominator of 60 corresponds to the dodecahedron having no centres. (Compare with C3/4-20.)

One version of the Incredi-Ball uses only six colours, like Alexander's Star. The fact that each triangle has three colours completely fixes the relationship of the colours, so the last discussion on C3/4-20 does not apply. But the ten pairs of antipodal pieces can be evenly exchanged in 210/2 ways, giving
(20!/2)·(320/3) / (210/2 · 60) = 460 23246 37191 77669 52000 distinguishable patterns.

[ Incorrect: Antipodal pieces are mirror images, so not identical. Hence there are (20!/2)·(320/3) / 60 = 2 35639 02142 42189 66794 24000 positions. - J ]

It is also possible to remove one piece and have an icosahedral sliding piece puzzle.

[ See also my ImpossiBall puzzle page - J .]

GOING APE OVER THE CUBE

UK TV viewers will be familiar with the Brooke Bond tea advertisements featuring chimpanzees who pour tea, ride bicycles, move pianos, etc. Researchers into behaviour wondered if there was any instinctual component in playing with the cube and so gave some cubes to the chimps. Five year old Louis, the bicycle rider, mixed up his cube and then twiddled aimlessly and bemusedly. Four year old Jill was fascinated by the red squares, but then got angry with the cube and tried to eat it. The baby chimp, Charlotte took hers apart. The chimps' owner, Molly Badnam, reported "The chimps were clearly enthralled, playing with the cubes for long periods each day. However, I regret to say that they showed no promise and only became more and more exasperated. For the sake of their health, I was forced to abandon the experiment". Sounds terribly human!

11

SOME GEOMETRIC PUZZLES

A. EIGHT CUBE RINGS

Over the years there have been a number of 'fiddlies' based on hinging together 8 cubes along edges so that they will fold into a 23. The best known of these has its 8 cubes joined in a ring as shown in the diagram. The cubes are shown from above. Some of the vertical faces where cubes meet have hinges joining their edges as indicated by the letters. When the front and back pairs of cubes are folded up, we have a 23. The folding can be continued through three more steps to give another 23. But then all the cubes are inverted so their previous outsides are inside and vice versa This fiddly has been known long enough that origamists can make the whole thing from a single strip of paper. (There are also a number of other hingings. If the R and L are changed to L and R and the back D is changed to B and the front D is changed to F, the result can be folded into a cube in four ways with a tricky move required to get between two sets of two ways.)

This year, a variation of the first idea above has been a popular seller 'under the name of The Shinsei Mystery (or Twin Comet) in England. Each of the eight cubes is split into two congruent halves, with the halves meeting along the hinged edges. Each half is separately hinged. The result is two rings of 8 half-cubes. When joined the two rings fold together and lock like an 8-cube ring But the two rings can be separated and each ring folds in the same way. Each ring can be folded into an interior form and an exterior form, both with cubical symmetry. The exterior form is a cube with an interior hole congruent to the interior form. (Added later: It is called Starburst in the US.)

Manufacturers assert that the idea is due to Naoki Yoshimoto, a Japanese artist. I have found it depicted in two Japanese books, attributed to Yoshimoto and giving a date of 1972. However the idea is

12

shown in eight forms in a 1973 article "Flexicubes - Reversible Cube Shapes" by the Dutch puzzle inventor Jan Slothouber (J. Recreational Math. 6:l (Winter 1973) 39-46). He gives several examples where the two halves are not congruent, giving rise to some interesting shapes.

The halving used by Yoshimoto is also given by Slothouber. Consider the cube divided into 6 square pyramids, based on the faces with the apices at the cube centre. Three of these meeting at a corner are a half-cube congruent to the other half. The interior form is a star-like solid which rejoices in the name of the stellated rhombic dodecahedron. Each point of the star is a rhombic pyramid on a face of the rhombic dodecahedron. The shape is fairly well known because a popular assembly puzzle forms this shape from 6 pieces. (There are two versions - one with different pieces, including a key piece and the other with 6 identical pieces which is more interesting.)

Slothouber gives two other divisions into congruent halves.

1. Imagine each cube again cut into a 23 and take 4 of the small cubes comprising a 'pyramid' at a corner. 2 Cut each cube in half by a plane perpendicular to a main diagonal. The interior forms of these are shown in the figure. The second is a truncated octahedron - though Slothouber calls it a cuboctahedron.

An amusing sidelight is that an early Taiwanese copier of the Shinsei Mystery clearly misunderstood the idea and produced a version with only one of the of the rings of half-cubes, thereby losing 50% of the interest of the object. (The truncated octahedral form was independently devised in New York last year. I've unfortunately mislaid my notes, but I believe that It was done by two people, one of whom is Alton Bader. The first form is in production by the Japanese Asahi Corp. (and several Taiwanese firms).

13

B. TWELVE TETRAHEDRA RINGS

If one divides one of the six face-based pyramids of a cube in half by a diagonal plane through the apex and two diagonal corners of the base, then we get two tetrahedra which are mirror images. These can be hinged in various ways to make a ring of 12 tetrahedra which flexes on various ways.

Bart Phillips makes an elegant wooden version called "Flexicube", which allows you to invert the six pyramids, making an exterior form which is a rhombic dodecahedron with a cubical hole inside, the size of the original cube. There is no way to put another cube in the interior and make them flex together.
[ see C7/8-5 for a picture of the rhombic dodecahedron. - J ]

One can view the cuts of the six pyramids as made by three diagonal planes of the cube which meet at a corner. The result is symmetric about the main diagonal of the cube through this corner. Six of the hinges are on this diagonal and six are along cube edges, forming a skew hexagon.

A second version of this fiddly, called Kaleido Puzzle or Kaleidoform, was sent from Taiwan. It is also available as a Corgi toy and via other importers. It has the same pieces in the same arrangement, but the hinges are all along the cube edges. It is trickier to flex and it took me some tome to realise that it could be inverted into a rhombic dodecahedron. It makes a lot of patterns including half a solid rhombic dodecahedron. I have only one copy of the ring but one version comes with two rings. One can combine two so they will flex together but only in a limited way and not like the Shinsei Mystery. I don't know if any hinging will allow the two rings to flex together through an inversion.

A third variation of this idea, called the Shinsei Miracle, starts by cutting each of the 6 face-based pyramids in quarters. This is the sane as cutting the cube by all six diagonal planes as shown. These are divided into two congruent groups of twelve which are hinged alternately along cube edges and along midlines (i.e. lines from a face centre through the cube centre). Each half makes some nice shapes and there are some ways to make the two rings flex together but they don't have the interaction of the Mystery. It is possible to use both rings to make a rhombic dodecahedron with a cubical hole.

14

C. CUBIC SNAKES

About two years ago, Diane Turnbull brought me an example of a 'folding cube'. It consists of 27 cubes strung together with elastic. The cubes have holes which go from a face centre to a face centre, either directly opposite a straight piece) or adjacent (a bend piece) as shown. The object is to fold it into a cube. For a particular arrangement of straight and bend pieces it takes about half an hour to check all possibilities. The example brought to me has only one solution as a 33 and no solution as a 3 × 9 rectangle. It struck me that it might be possible to have all bend pieces. However, I have shown that one must have at least two and at most eleven straights among the 25 interior pieces. (The end pieces cannot be classified as straight or bend since the string doesn't continue.)

This led me to consider making other versions of the puzzle. I've recently thought that a good name for these would be "cubic snakes". One way to make your own is to use Multilink blocks which are plastic cubes with one circular projection and five circular holes on the faces. These snap together and rotate, but do not hold together well. At Nuremberg, in February, I saw a better version of the idea developed by Antal Kelle for General Impex. This had a more sophisticated snap mechanism with two states: loose (for turning) and firm. I don't know if it is being produced.

This year, I have also seen three elastic versions made for Jeux Descartes, the French puzzle distributors. These have 36, 64 and 125 pieces, the first two being formed in a ring. All pieces are bends. Forming the 36 into a 3 × 3 × 4 is a bit tricky. I haven't yet made the 125 into a 5 - it looks like it will take some time!

Exercise. Find all the circuits through the 27 cells of a 33. Classify them by the sequence of straight and bend pieces. Are there any sequences which form a cube in many different ways?

15

SOME NOTES ON THE 43

A Strategy for the 43

  1. Do two opposite face centres, say L and R.
  2. Pair up and place the F, D, B edge pairs on the L and R faces.
  3. Put D corners in place. (Perhaps combine steps 2 and 3.)
  4. Pair up FD edges and store in UR, say. Pair up BD edges. Put FD and BD edge pairs in place.
  5. Check the parity of the U corners. If in odd parity, apply U.
  6. Use the moves like [[R,U], l'] = (URb, UBl, FUl) to 3-cycle U edges to get UR and UL edge pairs correct.
  7. Examine (carefully!) the parity of the four edge pieces at UF and UB. If in odd parity, apply r2D2l'D2r2, which 4-cycles these edges (and moves some F, U, B centres). (Since the D centres are not affected by this or later moves, one can try to get some (or all) D centres correct at step 4.)
  8. Use the moves of step 6 to get all edge pieces together.
  9. If you've done the parity at step 7 correctly, you may have to flip an even number of edge pairs, which can be done as on the 3 × 3 × 3. If you find you have to flip an odd number of pairs, you didn't examine the parity closely enough. Flipping a single edge pair requires exchanging them, which is an odd permutation. Return to step 7 if you need to do this.
  10. Place the U corners by use of 3 × 3 × 3 moves.
  11. Use moves like [[r, b], U] =(Fur, Ubr, Ubl) to 3-cycle centres into place.

Useful moves

The trickiest step in restoring the 43 is getting the edges into correct parity, as done in step 7 (cf. step 9). Because this requires making a slice move, I put off getting the other centres correct until after this step.

It is possible to exchange a single pair of edges as follows:

r2D2l'D2r2 · r2D'R2 · [[R, U], l'] · R2Dr2
= r2D2l'DR'UR'U'l'URU'lRDr2
= (UBl,UBr)(Ful,Ubl,Bdl,Ufr)(Fdl,Ufl,Bul,Ubr)

Jeffrey Adams' book gives

l2D2[u, F'] D2l2·LUL'u'LU'L' = (UFl,FUr) times a 6-cycle and a 4-cycle of centres on four faces, The centres are not as easy to correct as in my version.

Applying r2U2r (u2r2l2)2 r'U2r2 will correct the F and B centres in my process, leaving a 180° rotation of U centres, which can be corrected by a standard 33 supergroup move.

You may find it convenient to have a 2-cycle of edge pairs.

r2D2l2D2r2 = (UFl, UBr) (UFr, UBl) (Ufl, Ubr) (Ufr, Ubl) (Ful, Bdl) (Fdl, Bul).

Applying r2U2r (l2u2d2)2 r'U2r2 corrects all the centres.

Other strategies

After writing the above, I decided it was time to study other methods. I mentioned Jeffrey Adams' book, called "How to Solve Rubik's Revenge" which I have only seen briefly. He uses the same notation that I use - describing it as a natural extension of my 33 notation. I didn't have time to work through his method, but he does all corners, then U edges, M edges, D edges and then centres.

16

Jerome Jean-Charles' "Solving Rubik's Revenge" aims to be suitable even for those who haven't yet done the 33. The notation is minimal and the directions of moves are not consistent. But he presents everything in pictures, so the notation is not important.

Jean-Charles' strategy is as follows.

  1. Put all corners in place.
  2. Use standard edge moves to place 6 U edges in 3 U edge pairs and then all D edges. (The missing U edges serve as 'parking places'.
  3. Place last U edges.
    (Here he uses F'u'Fu'F'u2F = (FRu, Ufr, BLu, RBu, LFu) + movement of centres. This is actually a 33 move. If necessary he flips the pair after getting them in place by Fu'dF'u'dF'u'dF, though many other 33 moves could be used.)
  4. Place u edges. (This uses fairly easy moves.)
  5. Place d edges. (Here his 'magic move' is
    R'dR'F2Rd'R'F2R2d' = (FRd, Lfd) (Fur, Bdr, Rfd, Fdl) (Ful, Bdl, Rbd, Frd).
  6. Place centres. (As in my Step 11.)

The key to the simplicity of Jean-Charles' strategy is that step 1 solves the corner parity and step 4 makes the edge parity correct (at the end). Leaving all centres till last gives a lot of freedom to move the edges. I suspect one could adapt the strategy to place some centres at the beginning. Michael Mrowka and Wolfgang J. Weber do the whole D face, then U corners, U edges, M edges, centres. (More strategies in a later issue.)

Evisceration

Peter Lees has pointed out a duality which I have studied in the different context of Noughts and Crosses (= Tic Tac Toe) on the 44 board. In our notation, this has a very simple form: exchange upper and lower case letters throughout an expression. Thus the dual of the corner URF is an invisible central piece urf and the dual of the edge URf is the centre Fur. This mapping arises in Noughts and Crosses because it reserves all the lines of four in a row.) It turns the 43 inside out - hence the name 'evisceration'. The dual of the move R is r.

Then we have a Principle of Duality: The dual of a sequence of moves has the same effect on the dual pieces.

This allows us to transfer knowledge from 33 moves to 43 moves as illustrated by the following. On the 33, (F2R2)3 = (FU, FD) (RU, RD). On the 43, (F2R2)3 = (FUl, FDr) (FUr, FDl) (RUf, RDb) (RUb, RDf) (Ful, Fdr) (Fur, Fdl) (Ruf, Rdf) (Rub, Rdf)

Let a 'column' be an intersection of two planes or layers, such as the Fl column. Then (F2R2)3 is a pair of exchanges of columns: (Fl, Fr) (Rf, Rb) where the columns get inverted. Thus
(f2r2)3 = (fuL, fdR) (fuR, fdL) (ruF, rdB) (ruB, rdF) (fUL, fDR) (fUR, fDL) (rUF, rDB) (rUB, rDF) which is a pair of exchanges of columns: (fL, fR) (rF, rB).

17

Processes which affect corner columns on the 33 lead to dual processes which affect central columns on the 43. E.g. U2R2L2U2R2L2 exchanges corner columns (UR, UL) (DR, DL) on the 33, so u2r212u2r2l2 exchanges central columns (ur, ul) (dr, dl), which gives a 2-spot pattern! The presence of the 2-spot means we can create many of the impossible 33 patterns on the 43.

Another useful process shown to me by Trevor Hutton, is based on the 33 process (F2R2)2 which is a 3-cycle of corner columns: (FL, FR, BR), so the 43 process (f2r2)2 is a 3-cycle of central columns (fl, fr, br). Two of these yield the 2-spot by (r2u2)2 (b2r2)2.

Note that the part of a 33 process which affects corners vanishes in the 43 dual process. We can also use duality in just one or two directions, especially if we are looking at square moves. With non-square moves, it doesn't work! - compare [F,R] with [F,r].

Special Subgroups

Many patterns have already come in the post, but here I will only mention some special subgroups with patterns.

If we only make moves like Rr (=R2 say?), we obviously are simulating a 23. Less obviously, moves like Rl' (=Ri for interleaved?) also simulate 23, but in 8 copies! The squared interleaved moves generate a number of elegant patterns of stripes and bars, notably Ri2Fi2Ui2Ri2 which has 6 orthogonal 4-stripe patterns.

If we only make face moves, we are simulating a 33 with fat slices. But since we can produce a single exchange of centres and of edge pairs and we can invert a single edge pair, we can construct all the impossible 33 patterns except those involving a twist of a single corner. Also, we can obtain any permutation of the centres, though only 24 of these have the colours in the correct relationship.

God's Algorithm on the 43

There are 44 = 256 possible moves along an axis, e.g. LalbrcRd where 0 <= a, b, c, d <= 4. These include four cases where a = b = c = d. If we hold one layer fixed, say L, then we have 64 moves, including I. It is not yet clear just many 'moves' a move takes. For example, r really requires two hand moves - Rr followed by R' - while Rr and even Rrl' could be counted as a single move. The number of positions achievable after n axial moves is at most

Tn = 1 + 192 + l92·128 + ... + 192·128n-1 = (192·128n - 65) / 127.

This exceeds the N on C3/4-15, namely 7.4 × 1045, when n = 22. Guessing about two hand turns or three quarter turns per axial move, this gives about 44 hand moves or 66 quarter turns as a minimum for God's Algorithm.
[ See also C7/8-9. - J ]

18

PYRAMINX

Several writers have sent letters on the Pyraminx. Most have pointed out that the method in Werneck's book is not very efficient and that the English edition did not include the pictures of Mèffert and the production line mentioned in C1-11, nor the material on other puzzles in the German.

Notation. Consider the Pyraminx on a table with a face toward you. The four corners are denoted L, R, B, U and the four faces are denoted F, R, L, D as shown in the top view. Vertex pieces (V in the diagram) are denoted l, r, b, u and corner pieces (C in the diagram) are denoted L, R, B, U. Edge pieces (E in the diagram) are denoted by pairs of faces, thus: FR, RL, LF, FD, RD, LD. Moves will be considered as rotations of a corner with its associated vertex and edges. E.g. the move U is shown in the diagram. Its cycle representation will be written (FR, LF, RL) Uu where U means a 120° clockwise twist of the U corner and U' will denote its opposite, etc. (Kersten Meier uses F, R, L, U for his corners - i.e. he looks at an edge rather than at a face.)

Solutions. For me, the simplest solution is to restore the vertices and corners and then use:
(FR,RD,DL) = RBR'B' = [R,B];
(FR,RD BR) = RB'R'B = [R,B'];
FR+RB+ = [R,B'] [U' ,B];
to restore and flip edges.

Several solutions and many patterns have been sent in. Thanks to James Allwright, Angus Lavery, Lawrence Cuthbert, Bill McKeeman, Martin Milner, and Tino and Daniel Delbourgo (ages 10 and 12). David Peter has an easy algorithm in at most 37 moves and a fast algorithm in at most 28 moves, available from him at 50p at Wentworth College, University of York, York YO1 5DD, UK. Another 28 move solution is given by Benjamin L. Schwartz in Journal of Recreational Mathematics 15:1 (1982-83) 31-38.

19

The Delbourgos' "How To Tackle the Tetrahedron" is available from them at 15 Willowdene Avenue, Sandy Bay, Hobart, 7005, Tasmania, Australia. Nicolas Hammond has sent some of his computer results which he asserts solve all those edge only processes which use at most 9 moves.

There is no method to just flip a pair of edges in less than 8 moves, but Werneck and Meier give:
FR+RB+Uu = B'U'R'URBU.

The Groups of the Pyraminx. The constructible group (where we allow just the edges to be removed) has 34·34·6!·26 = 3023 30880 patterns. The conservation rules are that each move is an even permutation of edges and of edge faces. Hence we can only get an even permutation of pieces and an even number of flips. All such patterns are readily achieved, so the Pyraminx group has 34·34·6!·26 / 2·2 = 755 82720 patterns.

Since the corners and vertices can be moved independently of the edges, the constructible group is the direct product (N59) Z34 × Z34 × (Z2 wr S6). The Pyraminx group is the subgroup of index 4 (N39) obtained by restricting Z2 wr S6 to even permutations of position where the 'total flip' is 0 (mod 2).

God's Algorithm. The Pyraminx has 8 corner moves. After turning a corner, we have 6 turns available at other corners. So the number of patterns after n moves is at most Tn = 1 + 8 + 8·6 + 8·62 + ... + 8·6n-1 = (8·6n - 3)/5. These are the patterns where the vertices are not turned, so we are interested to know when Tn exceeds 34·6!·26 / 2·2 = 933120. The values of Tn are as follows.

n | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
Tn | 1 | 9 | 57 | 345 | 2073 | 12441 | 74649 | 447897 | 2687385

Hence God's algorithm must be at least 8 moves Long. Hammond's work (C1-11) shows it is at most 13 moves long. (Add four moves if we consider vertices as well.)
[ See also C7/8-19. - J ]

Pyraminx Patterns. Werneck's book gives a selection of patterns, but most of these can be done in fewer moves. Ronald Turner-Smith "The Amazing Pyraminx" gives more patterns than any other book. Though he does not always give the best solution, he usually states what the least moves known is. Some patterns have better solutions in the Pyramaths appendix.

20

We abbreviate sources as follows.
TDD - Tino & Daniel Delbourgo "How to Tackle the Tetrahedron"
NJH - Nicolas J Hammond
KM - Kersten Meier "The Small Magic Tetrahedron"
DP - David Peter
DBS - Myself
T-S - Ronald Turner-Smith "The Amazing Pyraminx"
WK - Well known
TW - Tom Werneck "Mastering the Magic pyramid"

Jewel (T-S & TW) or Twist
 | Uu = (URUR')2 | (T-S & WK - 8)
Joseph's Coat (T-S) or Till's Windmill (TW) or 4-Jewels or 4-Twist
 | RrLlBbUu = (R'L')5 (U'B')5 | (T-S - 20)
(T-S asserts 16 moves is possible.) Each half of this is a 2-twist.
[ In 10 moves: UBR'U'BRLU'R'L - J ]
Queen's Jewel Box (T-S) or Fabian's Windmill (TW) or 4-twist
 | is the above followed by r'l'b'u' to give RLBU.
Doors (T-S) or Holy Temple Gates (TW) or 3-V (TDD)
 | (FD, RD, LD) = RL'R'L'B'L'B | (T-S & WK - 7)
Cat's Paws (T-S) or Fire-Red Cat's Paw (TW) or Adjacent 2-flip
 | FR+FL+ = [R, U'] [R', L] | (T-S & WK - 8)
Gates at Gizeh (T-S) or 4-V (TDD) or Opposite 2-flip
 | LR+FD+ = L'U'LU'RUR'U | (NJH & KM - 8)
This puts a door or V pattern on all four faces. There is another such pattern mentioned without solution in T-S:
 | (FD, FL, RD) = R [U,L']R' | (DBS - 6)
The square of this is another such pattern.
4-flip
 | FR+RL+LF+FD+ = L'U'LU'RBUB'UR' | (NJH & KM - 10)
The configuration of edges FL, FD, RD, LR is a central square and its symmetries give interesting patterns.
Sun and Moon (T-S) or Square 4-flip
 | FL+FD+RD+LR+ = BR'U'RU'BLUL'UB | (KM & DBS - 11)
[ In 10 moves: U'L'RUL'RB'L'RB - J ]
King's Treasure Chest (T-S) or Tutankamen's Treasure Chest or 6-flip
 | FR+RL+LF+FD+RD+LD+ = (UR'L)3 | (T-S - 9)
Cleopatra's Needle (T-S & TW)
 | (FD, LD, RD) Uu = U'RU'R'LU'L'BU'B'RU'R' | (T-S & TW - 13)
[ In 9 moves: BR'UB'R'LR'L' - J ]
Chariot (T-S) or Wagon Wheel (TW) or 3-wheeler
 | (FR, RL, LF)(FD, RD, LD) = RUR'URUL'R'L'B'L'B | (DP - 12)
This rotates the edges 120° anticlockwise about the vertical axis.
[ In 9 moves: RL'RBUB'RLU' - J ]
Chariots of Egypt (T-S) or 4-wheeler
 | FR+DL+(FL, RD)(FD, RL) = LBR'U'·BLU'R'·LBR'U' | (DBS - 12)
This rotates the edges as a unit 180° about the midline joining FR and DL. If one views the moves as moves of faces, rather than corners, this is [R, L]3 which exchanges two pairs of corners!
[ In 9 moves: UBUL'RB'ULR' - J ]

21

Priest's Pattern (T-S) or Whirlwind (TW). Let us call this face pattern a clockwise spiral and its mirror image an anticlockwise spiral. Four anticlockwise spiral faces correspond to a 6-flip and 4-clockwise-jewels:

FR+ FL+ FD+ LR+ LD+ RD+ Uu Rr Ll Bb = LRBL'RL'R'L'UB'LBL' (DP - 13)
[ In 11 moves: BU'L'B'R'U'BLRLR - J ]

TDD give a long pattern with 3 clockwise and one anticlockwise spiral which I have simplified to:

FR+RL+LF+(FD, DR, LD)+ U'u'R'r'B'b'L'l' = B'R'BL'B'U' (TDD & DBS - 6)

The face pattern shown is variously called spade (as in cards), palm (tree) or fish.

The next pattern is called Doubles (T-S). We can get 4-Doubles in two ways.

(FR, FD, LF, RL, DR) | = ? | (T-S asserts it can be done in 7)
[ In 7 moves: BU'B'U'L'U'L - J ]
(FR, DL)(FL, DR) | = [R, B][L, U][R, B] | (DBS - 12)
[ In 7 moves: BRB'RU'RU' - J ]

The latter is 180° rotation of the central square about the axis LR-FD.

2-Doubles or 2 plain & 2 cat's eyes (T-S)
(FR, LR)(FD, LD) = R'BR'BRBR'BRBR'BR' (T-S & DBS - 13)
[ In 9 moves: RBRB'R'B'RBR - J ]

This is a reflection of the central square in a bisecting plane through the UL edge of the tetrahedron.

T-S calls this a (left) Nile Temple. I think it's clearly a (left) Sphinx. He gives a method for 3 right Sphinxes and one left one. Can you get 4 rights?

22

T-S calls this a 3-Sceptre face. He believes it is impossible to get four 3-Sceptres??

There are a number of other patterns in T-S and TW but they aren't as interesting as the above.

CUBISM AND RELIGION (Cont. from C1-16)

Neil J. Rubenking writes from a Zen Center in California, and he sounds like a serious Buddhist. He has produced a set of stickers which converts a cube into a "Buddha's Cube". Each corner has a single noun three times and each edge has a single verb twice. The resulting sentences across and down express truths of various schools of Buddhism. The corner nouns are: Buddha, delusion, emptiness, enlightenment, existence, Nirvana, the self, suffering. The edge verbs are: abides in, conceals, contains, deceives, destroys, hinders, is, is not, knows, liberates, produces, reveals. This gives a total of 672 possible sentences and any configuration of the cube has 12 at a time. Problem for the masochistic - is there a set of 56 cubes on which the 672 sentences occur once each. The centre stickers are "OM MANI PADME HUM", which makes it a genuine Prayer Wheel. He has made a more complex version for a Zen teacher with 24 words on the corner facelets and 24 words on the edge facelets.

Corner triples:

Buddha | ignorance | the self | concentration
Dharma | delusion | sentient beings | wisdom
Sangha | wrong views | existence | mindfulness
joy | emptiness | enlightenment | Nirvana
equanimity | impermanence | liberation | no-self
compassion | suffering | the way | true suchness

Edge pairs:

is | conceals | destroys | liberates
is not | reveals | produces | hinders
deceives | joins | abides in | saves
knows | parts from | contains | ignores
penetrates | frees | sees | completes
obstructs | binds | surpasses | scatters

Ian Williams sends an article from Aquarian Arrow by Lionel Snell entitled "Notes towards the deployment of the Hungarian Magic Tube as a system of divination".

"It is a portable permutable set ... smaller than the Rider Traveller's Tarot." He allocates the following meanings to the three axes:

23

"Up, down = WILL (cf. the upright rod or phallic symbol of will)

Left, right = THINKING (cf. the "weighing up" motion of the balance)

Front, back = FEELING (cf. a reaching forward and a shrinking back towards yourself)"

He finds the cube more harmonious to Libran aesthetic sensibilities when he recoloured his cube so

F = green, B = red, R = yellow, L = blue, U = white, D = brown (presumably a dark orange?).

He finds planetary and other associations with the colours - e.g. F = green, Venus, attraction ... !

PREHISTORY OF THE CUBE

As a result of the enormous publicity generated by the Cube, a number of independent inventions of the idea have surfaced.

The first French book on the cube (Le Cube Hongrois by André Deledicq and Jean-Baptiste Touchard) reports: "In fact, Inspector General Semah says he played with a similar cube (but in wood) in 1920 in Istanbul, then about 1935 in Marseilles (with a cube of five white faces and one green face)." Touchard says he went to see Semah, who is now an old man, but who seemed to recognise the cube as an old friend. In view of the Middle Eastern tradition of puzzle rings and the Far Eastern tradition of puzzle boxes and other wooden puzzles, I think there is some probability that a wooden cube might have been made by some craftsman, The cost of wooden cubes would have been prohibitive and only a few (one?) would have been made. I would be delighted if anyone can find more evidence of such a cube.

In 1960, a mathematics teacher named Gustafson, in Fresno, California, invented the 23 Magic Sphere, but only conceptually at first. One of his students, Dick Walton, reports that his class discussed the mathematics and possible mechanisms at length. Gustafson eventually proposed having a central sphere with grooves. I have been told that Gustafson obtained a patent on this, but I have not yet tracked it down.
[ See C7/8-47. - J ]

Larry D. Nichols, of Arlington, Massachusetts, filed for a US patent for "Pattern forming puzzle and method with pieces rotatable in groups" on 4 March 1970. This was granted as Patent no. 3,655,201 on 11 April 1972. This is for a 23 with a magnetic mechanism The concept of a magic cube is clear. However the magnetic mechanism works by separating the cube in half, then turning and putting the halves back together. If you try to rotate a half, magnetic repulsion pushes the halves apart. This is achieved by putting three small bar magnets on the inner faces of each cubelet as shown. So the mechanism is not at all like Rubik's. In particular, one can cheat too easily by disassembling the cube.

24

However, Nichols refers to other shapes and sizes, and "engagement by mechanical rather than magnetic means, as for example by using a pop-in snap linkage, or a tongue-in-groove arrangement". Nichols' company, which holds the patent rights, has written to Ideal claiming prior invention. Ideal feels that the cube does not infringe Nichols' patent. Nichols company has recently filed suit for $60,000,000!

The New York Times reports that Nichols' firm, Moleculon Research Corp., did try to market Nichols' idea in 1969 but wouldn't divulge the secrets until the patent came through. It was rejected by all the firms approached, including Ideal, generally because of the secrecy.

I hesitate to predict the outcome. Though Nichols has the concept, his claim (quoted above) must be stretched rather far to cover Rubik's mechanism and Gustafson's patent would seem to pre-empt Nichols. However, a large US law firm has taken the Nichols case on a contingency fee basis - i.e. they only get paid if they win! Gustafson has apparently stated that a cubical version did not occur to him.

Frank Fox of Bletchley, Bucks, filed for a UK patent on an "Amusement Device" on 9 April 1970 and this was published as UK patent 1,344,259 on l6 January 1974. This was for a 33 in spherical shape, using tongue and groove linking to hold the 26 exterior pieces together, leaving the centre hollow. Fox thought to use this as a kind of board for noughts and crosses (= tic tac toe), though he mentions use of 26 colours and the use of letters and numbers.

LOCAL MAXIMA

Consider the Cayley graph of the Cube group. We say a position P is a local maximum if it is further away from I than any of its 12 neighbours - i.e. PR, PR', PL, PL',... The 12-flip is a local maximum. Let P be any process which produces the 12-flip. Consider the last move of this process, say it is R. Since the pattern is symmetric with respect to the rigid motions of the cube and a mirror image of the process will give the same effect, we can transform P into processes which end with R', L, L', ... Any neighbour of P is thus obtained from some transform of P with the last move omitted, hence is obtained in one move less than P itself. There is no other pattern which is symmetric under all the rigid motions of the cube, but there may be a pattern with less symmetry which can be obtained by several processes of the same length such that we can obtain the pattern with any move at the end. Such a pattern will also be a local maximum.
[ See also C7/8-8. - J ]

25

THE TRIALS OF THE CUBE

Ideal Toys and Politoys (the new name of Politechnika commenced legal action against the Taiwanese 'knock off' cubes early in 1981. The first case to reach court was against Dallas Print Transfers and Dallas Marketing, two London distribution firms run by Alec Yuen. After many postponements, this case began on 25 January and lasted twelve days! There were two grounds - infringement of copyright and 'passing off'. UK copyright law is nearly unique in extending to working or production drawings. Copying of a three dimensional object made from the drawings infringes on the copyright in them. 'Passing off' means selling an imitation product which is so similar to an established original as to mislead the public. The defendants first claimed that the drawings produced were not the basis of the copied cube. This was due to the fact that Politoys first sent the drawings for the pre-1980 cube rather than those for the later production which was the basis for the copied cubes. Once the correct drawings were produced and the draughtsman, Miss H. Czák, made it clear that she had made both sets of drawings, then the infringement of copyright was established and the judgment upheld this. I thought 'passing off' was also clear, but Ideal was held not to have established that they had created a brand image, due to the pre-1980 sales and the lack of image promotion. Damages have not yet been assessed and Dallas is appealing the judgment. However, I have recently heard that the whole Dallas operation has gone bankrupt.

Cases have taken place in Holland and the US. In Holland the case went through several hearings and I am unclear as to the final outcome. In the US, Ideal has obtained several injunctions and is attempting to block the importation of pirate cubes.

I have heard from a student doing a law thesis on the cube. She has offered to write a summary for the Circular.

A CZECH CHECK PROBLEM

The Czech weekly, Mladý Svet (Young World), poses as an exercise the problem of having each face with 8 facelets of one colour. The other facelet is a second colour but can be at the centre or an edge or a corner. If all are at the centre, we have 6-spot; if all are at edges, we can get it easily as (UL, FD, RD); if all are at corners, we can get it easily as URF+BLD-. However, there may be other ways of getting these effects and one might have different places for the odd coloured facelets - or can one?

26

GOD'S ALGORITHMS

In C2-8, I discussed an improved lower bound for God's algorithm. I have since realised that the argument can be refined a bit. Recall that Sn is the number of sequences of n 90° moves with the obvious redundancies excluded. Previously I totaled Tn = S0 + S1 + ... + Sn until Tn > N. But each 90° move is an odd permutation of the corners and of the edges, so U2m = U2m+1 = S0 + S2 + ... + S2m is the number of sequences which give even permutations on corners and on edges while V2m+1 = V2m+2 = S1 + S3 + ... + S2m+1 is the number of sequences giving odd permutations on corners and edges. Both these sums must be >= N/2 = 2.16 × 1019. It turns out that

S20 = 3.56 × 1019, T20 = 3.98 × 1019, U20 = 3.60 × 1019,

S21 = 3.33 × 1020, T21 = 3.73 × 1020, V21 = 3.37 × 1020,

so that the refinement gives no gain, although I thought at first it would.

However, if we consider the supergroup, we want Tn, Un and Vn >= 2048·N/2 = 4.43 × 1022. Here T24 = 3.07 × 1023, U24 = 2.78 × 1023, V24 = 2.96 × 1022, so we do need to go one step further to get U25 = 2.60 × 1024 and God's algorithm for the supergroup has length > 25, instead of 24.

Herb Taylor has passed on some further results.

The 23 square group was observed to have 24 patterns, diameter 4 and 5 antipodes at N53/54. Taylor points out that the Cayley graph can be drawn on a torus with 12 hexagonal faces. The number Nd of positions at distance d from a position is given by

d | 0 | 1 | 2 | 3 | 4
Nd | 1 | 3 | 6 | 9 | 5

According to Joe Buhler, via Herb Taylor, three different programs have found the diameter of the 23 is 11. One of these was circulated as a UNIX news item. It took over 51 hours of computer time. Don Knuth, the well-known Stanford computer scientist, gave the problem to a graduate class, but wanted R2 to be counted as two turns, etc. Buhler recollects that this gives diameter 14 and says that this was done by Joan Feigenbaum or Richard Anderson. (Several people have suggested that we write 14q when we mean quarter or 90° turns. This seems useful.) The UNIX news item gives the following table for Nd.

27

d | Nd
1 | 9
2 | 54
3 | 321
4 | 1847
5 | 9992
6 | 50136
7 | 2 27536
8 | 8 70072
9 | 18 87748
10 | 6 23800
11 | 2644

Using simple counting, as at N26 and 60, one sees that some positions require at least 9 moves. There are no obvious redundancies to account for (we are keeping one corner fixed), so I expected a diameter less than 15. An antipode of START is

FRFRF D2FD'FD2R2 = (UFL, RBD, LDB, UBR, FUR, DLF, FRD)

One of the groups who did the 23 went on to the 33 square group. They get diameter 15 which confirms Thistlethwaite's conjecture (N39) and hence reduces his algorithm to at most 50 moves. The numbers Nd are as follows

d | Nd
1 | 6
2 | 27
3 | 120
4 | 519
5 | 1932
6 | 6484
7 | 20310
8 | 55034
9 | 1 13892
10 | 1 78495
11 | 1 79196
12 | 89728
13 | 16176
14 | 1488
15 | 144

The fact that these diameters are small leads me to believe that the length of God's algorithm will be about 22. However, it seems unlikely that there will be a unique antipode. The UNIX news item concludes "I just thought of a lovely way to get the answer for the 3 ×3 × 3 cube, but the margins on this news item are a little bit too small for me to include it."

The UNIX news item is a rather faint copy, but further examination shows that it comes from duke!chico!esquire!

Frank O'Hara has found the diameter of the antislice group is 8 antislice moves. (N54)

© David Singmaster

28

Home
Links
Guestbook


Cubic Circular, Issue 7 & 8

The Cubic Circular magazine was written and produced by David Singmaster in the early Eighties. The first issue was a small 16 page pink booklet, of about 19.5 × 14cm. Later issues were on yellow paper and slightly larger at 21 × 14.5cm (A5 format). There were only 5 magazines published, of which 3 were double issues:

Issue 1: | 16 pages | Autumn 1981
Issue 2: | 16 pages | Spring 1982
Issue 3&4: | 36 pages | Spring&Summer 1982
Issue 5&6: | 28 pages | Autumn&Winter 1982
Issue 7&8: | 48 pages | Summer 1985

The final issue is reproduced below. I have tried to keep it as close to the original as possible, so I have kept the images in the same style, even though most pictures have been redrawn. I have occasionally inserted a comment or correction of my own, and to be clearly distinguishable from David's text my comments are in italics and in square brackets,
[like this - J ].

David Singmaster still has many copies of the Cubic Circular available, so I highly recommend acquiring them from him directly. David can be contacted via e-mail (zingmast@sbu.ac.uk) or at:

    David Singmaster
    87 Rodenhurst Road
    London, SW4 8AF
    United Kingdom

The text and original drawings are copyright © David Singmaster, reproduced with permission. Conversion to html and additional commentary by Jaap Scherphuis.

Home
Links
Guestbook
Cubic Circular Logo

CUBIC CIRCULAR

A quarterly newsletter for Rubik Cube addicts

Issues 7 & 8

Summer 1985

THE LAST CUBIC CIRCULAR - SPECIAL TRIPLE SIZE ISSUE

CONTENTS

page |
2 | Editor's Corner, Oxford Series in Recreational Mathematics
3 | Sources in Recreational Mathematics. Centre for Mathematical Recreations and Puzzles. Puzzling Announcements.
4 | New Cube Products.
6 | Rainbow Patterns.
7 | Shepherd's Bloody Cube.
8 | More on the U Group. More on Local Maxima. Some Pretty Random Patterns.
9 | Some Comments about the 43. A 34 Simulator.
10 | The Theory of the n3.
12 | The 53.
13 | Rubik's Mate - The Siamese Cubes.
14 | Geometry of the 63 and 73.
15 | The Skewb or Pyraminx Cube.
18 | God's Algorithm for the Pyraminx,
19 | Uriblock. More on the Hungarian Rings.
20 | Some Notes on Polyhedra.
24 | Regular Polyhedra,
25 | Kepler-Poinsot Polyhedra.
26 | Honeycombs.
27 | Semi-regular Polyhedra.
28 | Archimedean Polyhedra.
30 | Archimedean Tessellations.
31 | Uniform Polyhedra. Regular-faced Polyhedra.
32 | Tessellations and Tilings.
34 | Addendum.
35 | Sliding Cube Puzzles.
36 | A Rubric on Rubik Cubics. By Claude Shannon.
39 | The XL-25.
43 | Curious Cubic Correspondence.
45 | A 43 Competition. 1000DM in Prizes. A Cubic Sick Joke.
46 | Rubik's Foundation. Youngest Cubist? Cubic Mail Box. Rubik Cubik Magik. A Novel Appearance.
47 | The History and Further Trials of the Cube. A Rumour.
48 | Some Pyraminx Variations. A Mad Comment.

Published by David Singmaster, 87 Rodenhurst Road, London, SW4 8AF, UK.
ISSN No, 0261-8362, All material © 1985 by David Singmaster.

2

EDITOR'S CORNER

SURPRISE, SURPRISE! I bet you'd all given up on me by now!

I have had numerous letters asking when this would appear. Frankly, I haven't had the foggiest idea most of the time. I feel I owe you all a few words of explanation.

I first started typing sections of this in Autumn 1983, when I prepared the long section on polyhedra for my geometry class. Since then I have been meaning to get around to it every few months. Unfortunately I had a massive overdose of cubism in 1982-83. David Singmaster Ltd. was closed down, and I lost a fair amount of money -more than I had made previously. This led to prolonged tax negotiations. Also I was still receiving more post than I could deal with. Indeed there is still a pile about a foot (30cm) high that I haven't got around to, as well as about 18 inches (45cm) of Xeroxes of articles that I haven't looked at yet. In addition, I was teaching several extra courses in 1983-84, including the geometry course which was being taught for the first time. I also spent a lot of time helping to rewrite a Department submission that had been rejected. I have also started on some other projects which have taken up much of my time. I will describe these below as they should be of interest.

Fortunately, I was promoted to a Readership (= Research Professorship), the first in my Faculty, as of September 1984 and this is giving me more time to get caught up. I have worked in spurts over the past year - some of you will have had answers to letters from 1983! I have spent this summer working very hard at getting caught up. I have nearly read all my unread back journals and have nearly got through all the unanswered letters on my desk, etc. If you haven't yet had an answer, hold on!

In a week, I am going to City College of New York for the Autumn term. I will not have completed answering all my post by then, but I'll probably do some more before then. If you haven't had an answer by about the time you get this, I will get to your letter when I return in January. Meanwhile, my apologies for the delay or non-response to your letters and the delay in compiling this Circular.

THE FUTURE. I don't plan to produce any more Circulars. However, I will eventually prepare an Index and I have a bibliography on the Cube which requires considerable additions, even though it already runs 70 pages. If and when I get around to producing these, I will circulate the present subscription list and let you know what they will cost. (The bibliography will need several pounds just for postage, unless I reduce and double-side it.)

OXFORD SERIES IN RECREATIONAL MATHEMATICS

Anthony Watkinson, mathematics editor at Oxford University Press, asked me to edit a series in recreational mathematics. (Anthony was formerly with Academic Press, where he edited 'Winning Ways'.) We have embarked on this series. One book was already in hand and put into the series. Another has just appeared, two are ready to go into production and several others are being written. The first books in the series are the following.

Hugh ApSimon. Mathematical Byways in Ayling, Beeling and Ceiling. October, 1984. This is a collection of simple but difficult problems, e.g. find the smallest rectangle of wrapping paper required to cover a box.

3

John Beasley. The Ins and Outs of Peg Solitaire. August, 1985. This is the first book on the subject in nearly a century and will be the standard work for about that long!

Ernö Rubik, et al. Rubik's Cubic Compendium. Spring, 1986? This is the book mentioned in C1-4 and C2-3. I have just finished an additional chapter summarising the later history of the Cube. (Title not yet fixed.)

Edward Hordern. Sliding Piece Puzzles. Summer, 1986? This will describe some 250 puzzles of this type which began with Loyd's 15 Puzzle. (Title not yet fixed.)

We are hoping to produce a translation of Wilhelm Ahrens' 'Mathematische Unterhaltungen und Spiele' (1910-1918), which is the most scholarly of all books on recreational mathematics and extremely difficult to obtain.

Sources in Recreational Mathematics - see below for a discussion of this project.

The above gives some indication of the kind of books we are looking for. If you have any suggestions, please write to me.

SOURCES IN RECREATIONAL MATHEMATICS

As a possible took for my series, I started to compile original sources of classical recreational problems. It has become apparent that the first step is to prepare an annotated bibliography of the source material. I have begun doing so and have put it on a computer file. It is now 95 pages long, with about 200 subjects with information listed chronologically for each subject. I have also found a good many problems and have compiled a 17 page file of queries and problems on this material. I also have a draft article which outlines the project and some of the material. I would be delighted to hear from anyone interested in this project.

CENTRE FOR MATHEMATICAL RECREATIONS AND PUZZLES

A few years ago, I thought that a puzzle museum ought to exist. I had some general ideas on this and then I discovered that Ivan Moscovich, the well known Israeli puzzle inventor, had been the founder of the Israeli Museum of Science and Technology and was interested in a puzzle museum also. We have been discussing this now for two years. I wrote out a preliminary version of our ideas in Spring 1984, but I have not yet had time to pursue it vigorously.

PUZZLING ANNOUNCEMENTS

An exhibition based on Jerry Slocum's puzzle collection will be at the Los Angeles Craft and Folk Art Museum from 20 Nov 1985 to 30 Jan 1986. I believe it will then travel to New York.

If you are interested in wooden puzzles, then you are probably familiar with Stewart T. Coffin's puzzles. In fact, many of them have also been made in plastic by firms such as Mag-Nif, Tenyo and the Museum of Modern Art. He has just produced a new edition of his book 'Puzzle-Craft'. This is 100 pages of how to make his puzzles in wood. It costs only $12. Write to him at 79 Old Sudbury Road, Lincoln, Massachusetts, 01773, USA. If you live outside the USA and Canada, I'd suggest adding a few $ for postage. He will only accept $ money orders, $ cheques drawn on a New York bank or $ cash.

[ This book is available for download in Adobe pdf format from John Rausch's Puzzle world. - J ].

There are only two distributors/retailers that I know of who are puzzle specialists.

Rainer Bathke, Village Games, 53A Court Nope Road, London, NW3, UK.

Dietmar Hartung, Arndtstr. 13, 0-1000 Berlin 61, Germany.

(Bathke has a weekend shop at Camden Lock in London.)

[ Rainer Bathke and his wife still manage the Village Games shop, which is at 65 West Yard, Camden Lock, London. - J ]

4

There are two especially active cubists.

Christoph Bandelow, Haarholzer Str. 13, D-46314 Bochum-Stiepel, Germany. Bandelow is the author of 'Einführung in die Cubologie', Vieweg, Braunschweig, 1981 (C3/4-26). This was expanded into English as 'Inside Rubik's Cube and Beyond' , Birkhäuser, Boston, 1982. It is one of the most comprehensive books on the cube.

Georges Helm, 76 Bomecht, L-4936 Bascharage, Luxemburg. Helm is the Rubik's Cube Club of Luxemburg which appears to be the only club still in existence! He has compiled a name index for Circulars 1 - 6.

NEW CUBE PRODUCTS

Cubes for the blind (C1-6) were made commercially in Germany. One type had metal studs, another had 1 to 6 raised spots formed by a hot rod applied to the faces. Bandelow has shown me some with raised molded plastic shapes. Metal studded 23 and 43 were also made.

Bandelow says cubes with pastel colours are being made in China, but I don't recall that he had one. He did however give me a solution book in Chinese!

Wim Osterholt has kindly sent a number of registered designs from Germany. Gerhard Josten, no. 81 03 943, published 25 Jun 1981, has an icosahedral puzzle, of the same concept as the Impossi-ball, but with the supporting pillars reaching outside to give a knobby appearance. Walter Moll, 81 Ok 382, 30 Jul 1981, is the earliest design for the magic dodecahedron, preceding the Hungarian application by a few weeks. Gerhard Josten, 81 06 197, 10 Sep 1981, shows an icosidodecahedron! Gebrüder Obermaier, 81 08 498, 24 Sep 1981, shows a 53, Toni Obermaier kindly sent me the drawings for this. It is a quite different mechanism from Udo Krell's version that Mèffert has produced. Obermaier's is all tongue and groove. Franz-Josef Decker, 81 11 356, 26 Nov 1981, is a general magic polyhedron.

I have recently seen Calendar Cubes (C1-5, C3/4-8) from Italy and Japan. The Japanese is essentially an English language Calendar Cube simplified so that there is room to put pictures of some pop star on the other facelets.

Twisted octagonal prism When I was in Poland in 1983, I accidentally found a shop with four shapes of cube that I have never seen elsewhere. These were labelled Original Toys, Poland. The first was the twisted octagonal prism shown on the right. This has two areas interlocked like the halves of a tennis ball or baseball. These two areas are solidly coloured giving a peculiar two-coloured object. I have shaded one of the areas in the figure.

The second Polish Cube was a pointed 'cushion'. Consider the 'cushion' shown at C1-9. Put square pyramids on the top and bottom face centres, so the eloping sides come up to a point. This is four-coloured in four segments going from the top to the bottom. A colour covers an upper and a lower sloping triangle and the middle row in between.

The rhombic dodecahedron is the dual of the cube-octahedron. It has been described at C5/6-13, but I give a figure on the next page.

5

Rhombic Dodecahedron It has twelve rhombic faces whose acute angles meet at four fold vertices and whose obtuse angles meet at three fold vertices. The rhombuses correspond to the edges of a cube or octahedron, The rhombic dodecahedron is the shape obtained by trimming a cube to octagonal cross sections along all three axes, then peaking all the face centres to square pyramids. Alternatively, if you take a geometric cube and cut it by 45° planes along all edges, the result is the rhombic dodecahedron. The third Polish Cube was a proper rhombic dodecahedron, with 12 colours. I find this a most elegant shape. It is actually equivalent to Mondadori's Master Cube (C3/4-9) but the structure is clearer on the Polish version.

The fourth unique Polish Cube was a truncation of the rhombic dodecahedron. Since the rhombic dodecahedron has two types of vertices, there are three kinds of truncation - at the four fold vertices, at the three fold vertices and at both. The first gives the truncated rhombic dodecahedron described at C3/4-11 and C5/6-5, which is twelve-coloured. The kind gives the Polish truncated rhombic dodecahedron. This was strangely six-coloured. Looking at the figure above, you can see three orthogonal great-circular bands on the solid. I have shaded one of the four regions that form such a band. In the Polish object, two of these bands were solidly coloured and the other four regions were joined with the triangles and given four colours. The third kind of truncation of the rhombic dodecahedron gives the small rhombi-cuboctahedron (C1-9) and these were also available in Poland, but are also widely available elsewhere.

Stella Octangula The East German firm VEB Spielvaren, in Pfaffschwende, is currently producing a series of four variations on the 23. The simplest is just an octahedron formed by truncating the corners of the 23, Each face has three coloured spots, one at each corner, so this is really the same as the six-colouring of the cube. If one puts regular tetrahedra on all eight faces of the octahedron, the result is the Stella Octangula discovered by Kepler. One can view it as two large interpenetrating tetrahedra or as one large tetrahedron with small tetrahedra on the centre of each face. It is four coloured in accordance with this last description - a large face and the small tetrahedron on it are of one colour,

If one puts tetrahedra on just four of the faces of the octahedron, the result is a large tetrahedron which rotates on its midplanes. These are the plane which bisect four of the edges of the tetrahedron cutting the tetrahedron in a square cross-section. The tetrahedron is naturally four-coloured. It changes shape as it turns giving rise to some seven different shapes. These correspond to the seven different patterns on the 23 of Obermaier described on C3/4-9.

[ This is currently manufactured by Mèffert as the Pyramorphix. See also my Pyramorphix page. - J ]

6

2x2x2 Tetrahedron / Pyramorphix This 2 × 2 × 2 tetrahedron was invented by several people, including Rubik and Barry Lockwood of Rochdale.

The last of the East German versions is again a simple idea. Start with an ordinary 2 × 2 × 2 cube and trim four parallel edges to leave a square prism. This also changes shape as it turns. It comes with just two colours - four pieces are solidly red and four are solidly yellow. One of the easy standard shapes is the house shown and the puzzle is called Trick Haus.

Trickhaus Trickhaus

Rainbow pattern RAINBOW PATTERNS

Peter J. Kelly sends a 'rainbow' pattern where he gets six parallel stripes of all six colours appearing on two adjacent faces. (We are considering a six-colour rainbow!) I have found the pattern shown, which is an achievable pattern though I found it by construction from a disassembled cube. I haven't found a process for it. Any two adjacent side faces give a six colour rainbow.
[ try this: D U' B2 D U L' D2 B2 F L2 F2 U2 F' U2 F2 - J ]

7

SHEPHERD'S BLOODY CUBE

In C1-5, I mentioned that one can make interesting cube variations by removing some of the stickers. Removing just the centres gives a cube which is particularly perplexing. Half the times one tries to restore it in a pattern that has a 4-cycle of the centres, but this is not visible because the centre stickers are missing. However, such a pattern is impossible and one finds that it requires an odd permutation of the edges to complete it. This is done by a slice move which also gives the desired odd permutation of centres.

Shepherd's Cube A more interesting variant has recently been given to me by Alistair Shepherd. He is a haematologist with the Blood Transfusion Service in Liverpool, which produces a small circular sticker showing two adjacent hearts, He has replaced all the coloured stickers on a cube with these, in such a way that each face has all the stickers oriented in the same way. A view is shown in the adjacent figure, where the direction of the hearts is shown by the arrows. Opposite faces have opposite orientations.

I find this to be perhaps the subtlest cube variation that I have seen, in that its complexity is much greater than its initial appearance. At first, it looks like an Irish Cube, i.e. one where all configurations look the same, since all the stickers are the same. But then one sees that orientations matter, e.g. an B turn produces the next figure.

I then thought there were eight types of corner cube, but further thoughts and careful inspection show that there are just four types of corner and four types of edge. This is most easily seen since the first figure is symmetric under 120° rotation about the URF corner axis. The 4 corner types contain 1, 3, 3, 1 corners, while the 4 edge types all contain 3 edges. Thus there are (3!)2(3!)4/2 . 32/3 = 69984 ways to move the pieces without changing the appearance. The denominator 2 occurs since both edges and corners must have the same parity of permutation and the 32/3 factor gives the indistinguishable twists of the two unique corners.

Additionally, one can multiply this by 24 movements of the centres, since an odd permutation of the centres can be compensated for by an odd permutation of indistinguishable edges and by twisting centres with a total centres twist of 0. This gives 16 79616 positions of the cube having the same appearance. Dividing this into 24N gives 61802 70243 84000 distinguishable patterns.

The above pattern led me to ask: how many ways can one put 6 arrows on the faces of a cube? A priori, there are 46 = 4096 ways, but each of these can be viewed in 24 ways. Further, some patterns are the same from different points of view. Answering this problem thus requires the use of Burnside's Lemma and I find 192 distinct patterns (or 112 if we also consider reflections as equivalent). Many of these have no symmetry and hence a cube with such a pattern

8

of arrows would be both easier and harder to solve - easier because there are fewer confusions and harder because there are fewer distinct ways to make it look right. Even so, there may be pieces which are indistinguishable. Indeed, there are only 10 distinct ways to put arrows on the stickers of an edge piece, so we will necessarily have some edge pieces looking the same. There are 24 ways of putting arrows on the stickers of a corner piece. This leads us to whole set of problems and possible puzzles which I don't want to go into, but if anyone makes up examples, I'd appreciate examples (and some royalties for Alistair Shepherd).

MORE ON THE U GROUP

John F. Jarvis (C5/6-2), at Bell Labs, Holmdel, New Jersey, 07733, USA, has sent me a copy of his 'A set of processes for generating all single face permutations of Rubik's Cube' which gives an extensive, though not complete, analysis of the U group (N49, C3/4-17,36, C5/6-2). Six patterns still require 19 moves. Georges Helm told me that Anneke Treep, Guus Razoux Schultz and friends had it down to 16 moves, but they may be counting differently. Looking again, I see that Jarvis counts 180° turns as one move, so I don't see how Treep & Schultz could be doing so much better. Perhaps there is some mistake somewhere in my remembrance?? Bandelow says that Jarvis's results have been improved and only two patterns remain at 19 moves.

Jarvis applies the following four transformations to a process to get equivalent processes.

  1. a) Take the inverse of the process.
  2. b) Reflect the process in the plane between the R and L faces. This interchanges all R and L symbols and takes the inverse of each turn in the process.
  3. c) Turn the whole cube by I, U, U2, U3.
  4. d) Turn the top face by I, U, U2,U3

This gives 2·2·4·4 = 64 equivalent processes in general. If these were always distinct, there would be 62208/64 = 972 different classes of equivalent processes to consider. It is not true that these are always all distinct and hence there are 1212 different classes that must be considered.

MORE ON LOCAL MAXIMA

Douglas Hofstadter has sent a note by Dan Hoey and Jim Saxe which studies local maxima in some detail (C5/6-24). By analysis of the group of symmetries of the cube and its possible subgroups, they identify 71 positions which are local maxima.

SOME PRETTY RANDOM PATTERNS

Cecil Smith sends several pretty random patterns (C3/4-32/33). He has six colours on each face and I believe he has the same pattern on each face, though he asserts this clearly only for the first of the following face patterns.

a | b | a
c | d | e
f | a | f

a | b | a
c | d | e
f | b | f

a | b | a
c | d | c
f | e | f

9

SOME COMMENTS ABOUT THE 43

The eccentric 43 made from a 33 which I described on C5/6-5 is due to Nob Yoshigahara. He also made a 23 into a 33 in the same way.

Alistair Shepherd sends a shortish edge 2-cycle.

(Ll)2BrB'U2Br'B'U2B2r'B2(Ll)2 = (UFr,FUl)(Urb,Dlb,Drf,Fld) (Urf,Dlf,Drb,Flu)

Christoph Bandelow sends the following.

r2UbU'F2Ub'UrU2F2r2 = (UFr,FUI)(Ubr,Fdl,Ufl,Fur)(Ubl,Fdr,Ufr,Ful)

In both cases, the two 14-cycles of centres can be viewed as one 4-cycle of pairs of centres.

Ronald Fletterman, Finkenweg 4, D-3501 Niestetal - 2, Germany, has produced several booklets in English on the 33,43,53, the Siamese cubes and on the <U, R> group. His 43 algorithm proceeds: D centres, edges, corners; d edges; u edges; d centres; u centres; U corners in position, then oriented; U centres; U edges. He gives tables of standard processes, but the simplest process for (UFr,FUl) takes 23 moves and is due to Bandelow.

r2 ·(D2l)2Dl'r'd2lrD'l'r'd2·B2rB2l'B2lB2'·r2 = (UFr,FUl)

His shortest edge swap is for (UFl,BUl) and takes 21 moves.

Rudolf Werz sends a solution doing centres, then edges, then corners. Getting the last edges right without disturbing the centres takes some work. But he has an elegant 3-cycle of edges and of corners.

RrUR'U'R'r'FRF' = (RUB,BUL,UFL)(RUb,BUl,UFl)

This can be viewed as a 3-cycle of corner-edge pairs and all the pieces are in the U face!

After some thinking about C5/6-17, it now seems clear that the number of hand moves in making an axial move La1brcRd on the 4 is the number of consecutive inequalities in the sequence a, b, 4-c, 4-d. That is, it is the number of internal planes on which turning occurs. Thus L, Ll, L'l'r all take one move; LR, r take two moves; l'r2R takes three moves. This number is not affected by turning the whole cube, so we need only consider the 64 cases where a = 0. Of these, 1 has no hand moves, 9 have 1 hand move, 27 have 2 hand moves and 27 have 3 hand moves. So the number, Sn of positions achievable after n hand moves is at most 18 Sn-1 + 54 Sn-2 + 54 Sn-3 for n > 3. For n <= 3, the sum terminates at S0 (= 1) and the coefficient of S0 is multiplied by 3/2 since there is no previous turn to be on a different axis from. (Cf. N34, C2-8, C5/6-17.) Then the sum Tn = S0 + S1 + ... + Sn is asymptotic to 1.39 (20.73)n. This value first exceeds N = 7.4 × 1045 for n = 35, so God's Algorithm must be at least this long.

A 34 SIMULATOR

William J. Shlaer, 2007 Southeast 96th Court, Vancouver, Washington, 98664, USA, sends a 34 simulator for the IBM-PC with colour monitor. He has an outline algorithm for restoring the 34 which took him several hours and 2757 moves!

10

THE THEORY OF THE n3

Several people have asked me about the n3 and the number of patterns on it. A recent letter from Carsten Butz has led me to the following analysis. It turns out that an extra conservation law comes into play for n > 5.

NxNxN cube First, one needs further notation. The following is rather ad-hoc for this particular problem and may not be optimal for other problems. We adopt a numerical coordinate system for cubelets. The cubelet (x, y, z) will be in layer x from the R face (so the R face has x = 1), layer y from the F face and layer z from the U face. Then (1, 1, 1) or (111) or 111 denotes the RFU corner which is in the centre of our usual diagram. The case n = 6 is shown on the right with cubelet 111 marked out. I will denote turns as R1, R2, R3, ... meaning to turn the layer x = 1, 2, 3... 90° clockwise as viewed from the R face. Now let a = n+1-a denote the complement of a. Note that 111 is the mirror image of 111 in the midplane of the cube which is parallel to the R face, i.e. the plane given by x = (n+1)/2. On the 33, 111 is LUF.

Consider now the cubelet 123, whose R facelet is marked with X in the diagram. This can be moved by the turns R1, F2, and U3. Examining the effects of these, we see that

R1 : 123 -> 132 -> 123 -> 132 -> 123 ...; F2: 123 -> 321 -> 123 -> 321 -> 123 ...;

U3: 123 -> 213 -> 123 -> 213 -> 123 ...

We see that any 90° turn gives an interchange of the two values corresponding to the other two directions and a complementation of the value corresponding to the next direction. E.g.

F is a turn in the plane y = 2, so the values in the x and z components are interchanged and the value in the z component is complemented. This leads to a new

CONSERVATION LAW. A piece abc can be moved to a position a'b'c' if and only if a'b'c' is a permutation of abc or of abc or ... or of abc and the parity of this permutation is the same as the parity of the number of complementations.

The argument above established the 'only if' part of this law. The 'if' part is readily seen as it is easy to move the piece onto any face and then into any of the four possible positions on that face. The law shows that a piece can only move to 24 positions at most, while one might have expected 48 positions for a piece like 123. But the law prevents 123 from moving to 132. In fact, a given facelet can move to exactly 24 positions, but for a corner facelet, these lie on just 8 pieces, while for edges and centres, these lie on 24 distinct pieces. (See later.) This phenomenon does not appear on the smaller n because they do not have a centre piece which is asymmetric in the way that 123 is. However Chris Rowley points out that a simpler form of this phenomenon already appears on the 3 and the 4 if one marks them unsymmetrically as indicated on the next page. Each face is given the same appearance, and then the asymmetrical pattern is preserved by any movement of the faces. In fact, this is the principle of White's Irish Cube (C3/4-10) and of the fact that one cannot flip an edge in place on the 43.

Now we can determine the number of patterns on the n For convenience, we begin with the even case: n = 2m. Then we have the following types of pieces.

11

Patterns showing asymmetric conservation
Corners: | 1 type of 8 pieces.
Edges: | m-1 types of 24 pieces.
Centres: | (2m-2)2/4 =(m-1)2 types of 24 pieces. (Of these, m-1 types are diagonal and the others are non-diagonal.)

A priori, the corners have 8!·38 arrangements and the other pieces have (24!)m-1·(24!)(m-1)² = (24!)m²-m arrangements. (Here, we have used the fact, discovered on the 43, that edge orientation is determined by position. I.e. we do not have a factor analogous to the 212 which appears on the 33.) We can easily see that we can divide by factors of 3 (conservation of total corner twist), of 24 (direct symmetries of the cube) and of (4!)6(m-2)² (rearrangements within the 6(m-1)2 groups of 4 indistinguishable centres - if we have solidly coloured faces). But we must examine parity conservation rules to see if there are further divisors.

Consider any 90° turn of an outer layer, e.g. B1. This gives a 4-cycle of corners, a pair of 4-cycles on each type of edge and a 4-cycle on each type of centre. Any turn of an inner layer gives a 4-cycle on one type of edge, a pair of 4-cycles on one type of diagonal centre and a 4-cycle on each of 2m-4 types of non-diagonal centre. From this, we see that all types of diagonal centre must have the same parity as the corners, while all types of non-diagonal centre must have the same parity as the total of the corner parity and all the edge parities. Hence all the (m-1)2 types of centre have their parity determined by the corners and edges. Further since we can readily form 3-cycles of each type of piece, twist two corners and adjust the parities of the corners and edges, we see that we have 8!·38·(24!)m²-m / 3·24·2(m-1)² achievable patterns when the centre pieces are distinguishable. If the faces are solidly coloured, then our divisor of (4!)6(m-1)² must also be divided by 2(m-1)² since each of the (m-1)2 types of 24 centres can be rearranged only in half of the (4!)6 ways which preserve the colouring. Thus there are 8!·38·(24!)m²-m / 3·24·(4!)6(m-1)² achievable patterns when the faces are solidly coloured. For m = 3, n = 6, the first number is 1.31 × 10148 and the second number is 1.57 × 10116 (I have computed these in full, but I don't think anyone except me is sufficiently interested in them.)

Now we consider the odd case: n = 2m + 1. This gives us an extra type of edge consisting of just 12 pieces. (On the previous page, I see I said that an edge facelet could move to 24 facelets, lying on 24 distinct pieces. This fails here - when n is odd, there is one type of edge facelet whose 24 equivalents lie on just 12 distinct pieces.) We also have m-1 extra types of centre having 24 pieces (which we will call central centres) and 6 extra Centres, which we will assume to remain fixed. Our a priori number is now 8!·38·(24!)m-1·12!·212·(24!)(m-1)²·(24!)m-1·46, where the 46 corresponds to turning Centres.

12

A 90° turn of an outer layer gives a 4-cycle of corners, a pair of 4-cycles on each type of non-central edge, a 4-cycle on central edges, a 4-cycle on each type of centre except the Centre and a 90° turn of a Centre. Any 90° turn of an inner layer (excluding the central layer since we are keeping the Centres fixed) gives a 4-cycle on one type of non-central edge, a pair of 4-cycles on one type of diagonal centre and a 4-cycle on 2m-3 types of types of non-diagonal centres. From this, we see that the following types must be in the same parity as the corners:
the central edges; all m-1 types of diagonal centres; the number of 90° turns of Centres. All the (m-1)2 types of non-diagonal centres have the same parity as the sum of the parities of the corners and non-central edges.

So far, this gives divisors of 2, 2, 2m-1 and 2(m-1)². We also have the usual divisors of 3 and 2 to allow for the conservation of the total twist of corners and edges. Again it is easy to find 3-cycles of each type of piece, twist two corners or edges and adjust parities of corners and edges. So there are 8!·38·(24!)m²-1 ·12!·212·46/3·2·2·2·2m²-m achievable patterns when all the centres and Centres are distinguishable (including rotation of the Centres). If the faces are solidly coloured, we can divide this by (4!)6(m²-m)·46/2m²-m·2. This gives us 8!·38·(24!)m²-1·12!··212 / 3·2·2·(4!)6(m²-m) achievable patterns when the faces are solidly coloured. For m = 3, 2m + 1 = 7, the first number is 3.04 × 10211 and the second number is 1.95 × 10160 (Again, I have computed these in full.)

You may like to verify that the formulae are correct for n = 2, 3, 4 and 5. The formulae for solidly coloured faces agree with those sent by Butz.

Christoph Bandelow and Rudolf Werz have both obtained the same results.

THE 53

Several designs for the 53 were proposed. The design of Udo Krell, of Hamburg, was produced by Mèffert in Hong Kong. This was marketed in 1983 in Germany as "Rubik's Wahn" (Wahn = delusion or illusion) at about 40DM and in Japan. It is 70mm (2 3/4 in) on an edge and weighs 290g (10 1/2 oz). It moves remarkably well. The mechanism is a 33 whose pieces have grown out to the boundary of the 53 space and then the extra pieces are fitted in between. It is not recommended to take it apart - I managed to do so and was then quite uncertain whether I would ever get it back together. The pieces have quite small parts yet I have not heard of any breaking. I have seen one of the diagonal centre pieces get twisted. The main problem I have found is that the stickers are a bit small and hence easily come off. If one puts the 53 loose into a bag of papers, etc., one discovers a sticker has come off somewhere and has to search every bit of paper to find the missing sticker Hence I now keep it in its own plastic bag. The solution of the 53 is actually no more complex than for the 43, as can be seen from the preceding discussion. It just takes much longer. However, one must take greater care in keeping the cube squared up and this may be slowing one down more than just the greater number of moves. I think that racing the 53 is likely to be a bit hazardous to the pieces.

Although the 53 presents no new problems for solution, there are some nice patterns which can be obtained on it and which cannot be obtained on the 43, e.g. six chessboards or 6-x patterns.

Christoph Bandelow has recently bought the remainder of the German 53 stock and you can buy examples from him.

13

RUBIK'S MATE - THE SIAMESE CUBES

In C3/4-12, I described the Siamese Cubes devised by Tony Fisher. In 1983, Ideal produced this same idea as Rubik's Mate. Initially one hopes that the pieces can move from one cube to another, but a little contemplation shows that each part is separate from the other and that each half behaves like an ordinary 33 with the three pieces along one edge held together. One can easily simulate this by using some heavy tape along an edge. I will refer to this as the rigid edge. Below I analyse the group and describe some methods of solving such a cube.

[ See also my Siamese Cubes page. - J ]

ANALYSIS

1) One easily determines where the rigid edge belongs. On Rubik's Mate, you cannot see the edge piece in the middle of the rigid edge, so one must use elimination. The ends of the rigid edge are visible and determine its orientation. It is then easy to put the rigid edge in place correctly.

2) The four edges adjacent to the rigid edge can be readily put in place correctly.

3) At this point, we have a correct 2 × 2 × 3 block along the rigid edge. If we hold the cube with the rigid edge as the LB edge, we have only the pieces in the F and B faces to consider. In my discussion of the group <F,R> (N55/57), it is shown that <F,R> contains all permutations of these edge pieces, so we can get all the edges in place using just F and R moves.

4) However, we actually have more moves available. If we hold the cube so the rigid edge is FD, then the first flip in Section 5.8.A (iii) of my Notes (N44), namely a+b+ (= UB+UR+) = B'U2B2UB'U'B'U2FRBR'F', can be applied to flip two edges. Since part 3) above shows that the edges can be moved arbitrarily, it follows that we can flip any even number of edges.

5) Now consider the corners. If we hold the rigid edge as LB, then we can only turn F, R, B, L. As far as the corners are concerned, B is the same as F and L is the same as R. So any sequence of turns of our cube has the same effect on edges as a sequence of F and B turns where F and R are defined with respect to the rigid edge at LB. We know that the action of <F,R> on corners is isomorphic to S5 which has 5! = 120 patterns, half of which are even. We also know that we can obtain the even patterns by use of just F and R moves. Further, we know that we can obtain any permissible twisting by use of F and R moves.

Hence, if the rigid edge is in place, we have

N1 = 11! 5!/2 · 36/3 · 211/2 = N/(12·8·7·6·32·2) = 59595 46306 56000 patterns. (Here N is the number on the normal cube (N12).) If we let the rigid edge take up any of its possible 24 places, then we have

N2 = 24 N1 = N/(8·7·6·32) = 14 30291 11357 414000 positions.

On Rubik's Mate, we have two independent parts, each having this many patterns, so there are

N22 = 204 57326 69569 89719 99443 35360 00000 patterns on the whole thing.

This analysis shows that my question on C3/4-12: can a cube with a column correctly lined up be restored without breaking up the column? is answered: no. For the 6 other corners can be in any one of the six cosets of the action of <F,R> and only one of these cosets can be restored. Thus, if we scramble the cube at random, line up one column and then rigidify it, we have only a 1/6 chance of being able to restore it. This shows up in the 6 occurring in the denominator of N - the rest of the denominator corresponds to fixing two corners by an edge in a column, but the 6 is an extra factor.

14

Having determined the group, it is possible to solve the problem in many other ways. Though I haven't tried it often, I think the following strategy may be easier.

1) & 2) as above.

3) Place corners 1 and 2 correctly (where the corner numbering is in Figure 5.10, p. 56 of my Notes). Then the remaining corners can be put in position by turning R.

4) Orient the corners. Since edges are not important yet, we can use simpler moves than those on N57. Recall that P3 = P22 = [F, R]2 = FRF'R'FRF'R'. Then the following are useful:

(P3R)3R2 = 5-6+;
(P3R')3R2 = 3-4+;
[P3, R] = 3+4+6+;
[P3, R'] = 3-5-6-.

5) Move edges into place. The Varga-Fried move and my P1 (= F2R2)3 can both be used in many conjugates, but not all conjugations are easily accomplished. One can also form the commutator of P2 = [F, R] with the slice RRs': [P2, RRS'] = (UR, FD, RD). This can be used to get a 3-cycle in the R face simply by conjugating with F. This 3-cycle does not preserve orientations of pieces so skilful use of it can correct orientations while placing edges.

6) If necessary, flip edges by the method of 4) in the first method.

GEOMETRY OF THE 63 and 73

Now that a 53 has been made, people often ask about 63, etc. I was told that these were impossible as the corners would fall off as face turned. However, upon checking, this does not actually happen until n = 7, If we assume the cubies have edge 2, then the distance from the face-centre O to the edge of the cube is n and the distance from O to the inner corner P of a corner piece is x = (n-2)&;√2. So the corner will fall off as it turns if x > n, i.e. (n-2)√2 > n. This easily gives n > 2√2/(√2 - 1) = 4 + 2√2 = 6.8+. So a 63 is technically possible with cubical cubies, but a 73 is not. One can get around this by making the outer layers thicker than the inner layers, as with Trajber's octahedron (C1-7/8), but I don't know that anyone has done it.

The amount of overlap left as the face turns is the difference n - x. Simple computation of (n-x)/2√2 gives a measure of how much of the cubie diagonal remains on the face. The values of this ratio are given below.

n= | 2 | 3 | 4 | 5 | 6 | 7
(n-x)/2√2 = | .707 | .561 | .414 | .268 | .121 | -.025

So we see that the 63 overlaps by only about 1/8 of its diagonal. This seems too small for practicality since the pieces at the edge of the face must have some thickness.

15

THE SKEWB OR PYRAMINX CUBE

I described this in C3/4-12/13. It has been discussed by Douglas Hofstadter in Scientific American, July 1982, and he suggested the name Skewb. Mèffert has produced the moulds for it and has made up small numbers of it. I find it very intriguing. My analysis now confirms Tony Durham's number of patterns given on C3/4-13.

Skewb As usual, we first need some notation. We refer to the eight corners as URF, etc. and the six centres as U, R, F, D, L, B. Since a move is most easily described as the turning of a corner, it is convenient to have simple names for the corners. I use the numbers 1 to 8 as shown in the adjacent figure. (Corner 7 is the hidden LDB corner.) Then the move 1 means the turn of the half cube centred on corner 1 by 120° clockwise, as viewed from the outside. I also use 1+, 1- for the action of a move when corner 1 is rotated in its place.

Now we note that the 8 corners form two tetrads. 1,3,6,8 and 2,4,5,7. It is not possible to move a corner from one tetrad to the other. Further, each move is a 3-cycle on one tetrad and a twist on the other. If we only turn corners in tetrad 1,3,6,8, then this tetrad remains fixed in space - its only movement is possible twisting of its corners in their places. Then this tetrad determines the Skewb's spatial orientation and we can recover the spatial orientation from the pattern on the Skewb, Caution. If we mix turns from both tetrads, then the pattern does not determine the spatial orientation. There are 12 rigid motions of the Skewb which rearrange tetrad 1,3,6,8 and there are 24 such motions if we allow the tetrads to be interchanged - but we usually don't. Some patterns are easier to describe after reorienting the Skewb and I will use R, U, for turns of the whole Skewb (C3/4-26). A pleasant example was shown to me by Mèffert: 143214321R'U = (F, L, B, U) (R, D). Note that each 90° turn of the whole Skewb interchanges its tetrads.

Let us explore some basic moves. If we are looking at just two corners, there are only two useful cases. 1,2 and 1,3. Their commutators are as follows.

 |  |  | moves
1. | [1, 2] | = 4+1+2-6- (F, U) (R, B) | (4)
2. | [1, 2]2 | = 4-1-2+6+ | (8)
3. | [1, 2]3 | = (F, U) (R, B) | (12)
 | [ In 8 moves: [2, 5] [2', 4'] - J ]
4. | [1, 2']3 | = (F, B) (R, U) | (12)
 | [ In 8 moves: 2 [5, 2] [4', 2'] 2' - J ]
5. | [1', 2']3 | = (F, R) (U, B) | (12)
 | [ In 8 moves: [5, 2] [4', 2'] - J ]
6. | [1, 3] | = (LUF, FRD)+ (UBR, BLD)- (U, B, F) | (4)
7. | [1, 3]2 | = 4+5+2-7- | (8)
8. | [1, 3]3 | = (FLU, FRD) (BRU, BLD) | (12)

16

These are already a rich set of moves - we have a pair of corner 2-cycles, a 4-twist and several pairs of centre 2-cycles. It is not hard to see that these are already sufficient to restore the Skewb, but restoration is much easier if we find a few more moves first.

9. | [1, 3][6, 8] | = (F, U, D) | (8)
10. | 1.[1, 3][6, 8]·1' | = (R, F, D) | (9)
11. | 6'·[1, 2]3·6 | = (U, F) (B, D) | (14)
 | [ In 9 moves: 7' [4, 5] [4', 7'] 7 - J ]
12. | 5·[1, 2]3·5' | = (U, D) (F, B) | (14)
 | [ In 8 moves: 7 4' 5 4' 7' 5 4' 5 - J ]
13. | 143214321R'U | = (F, L, B, U) (R, D) | (9)

Skewb To restore the Skewb, we can proceed as follows.

Stage 1. Select a tetrad and twist its corners so the tetrad is correct, e.g. as shown in the figure.

Stage 2. We need a:

Theorem. If the tetrad 1, 3, 6, 8 is correct, then the tetrad 2,4,5,7 is either correct or in a pair of 2-cycles.

Proof. The group of rigid motions of the tetrad 2,4,5,7 is A4, the group of even permutations of four elements. This is easily seen to be generated by the 3-cycles (2,5,4), (2,4,7), (2,7,5) and (4,5,7), corresponding to the clockwise corner turns 1, 3, 6, 8, respectively. (Cf. N10.) Let T denote the total number of clockwise corner turns in achieving a particular permutation of the tetrad 2,4,5,7. E.g. 16'132 would have T = 1 - 1 + 1 + 2 = 3. Since the cube of a turn is the identity, we must consider T (mod 3) and we call this the twist of the permutation. Note that this is both the number of 3-cycles used to form the permutation and the sum of the twists of the corners in 1,3,6,8. Direct calculation verifies that the product of two permutations has the sum of their twists. In group theory, we say that the mapping from permutations to twists is a homomorphism from A4 onto Z3. Now if 1,3,6,8 is correct, then its corners have no twist, so the permutation of 2,4,5,7 must be a product of T 3-cycles, where T is 0 (mod 3). The only such permutations are then checked to be I and the three pairs of 2-cycles.

This proof is really too computational to be enlightening. The subgroup where T is 0 (mod 3) is isomorphic to Z22 (N59) and is called the Klein-4-group. It is the smallest non-cyclic group and is the group of symmetries of a rectangle, hence is a subgroup of the symmetries of a square. I have not seen the above geometric description of Z2 in A4 before though it is well known that Z22 is an important subgroup of A4. (Indeed it is the only normal subgroup and its presence is why it is possible to solve an equation of the fourth degree by radicals.) One can get a more geometric perspective on this result by considering the three edge to edge axes of a tetrahedron. (These are the face to face axes of the Skewb if one takes a tetrad as our tetrahedron.) These axes are permuted among themselves by A4 acting on the tetrahedron.

17

Assuming that our axes are directed, so that we can see which end is which, A4 can reverse some of the axes in place. The actions which leave the axes in place, though possibly inverted, form our subgroup Z22. The amount of twist T corresponds to the amount of cyclic rotation of the three axes. We can only reverse 0 or 2 since even permutations of our tetrad correspond to even permutations of our six axis ends. In fact, this description of A4 is the same as the group of centres on Rubik's Cube (N46/47). Our subgroup Z2 corresponds to the three 4-spot patterns and I.

However we see our Theorem, it immediately implies that we can turn the Skewb so that formula 6 above will put the second tetrad in place.

Stage 3. From the proof of our Theorem, we see that the total twist of the corners in 2, 4, 5, 7 must be the same as the number of 3-cycles in the permutation of 1, 3, 6, 8. But 1, 3, 6, 8 has been put right, so then the total twist of 2, 4, 5, 7 must be 0 (mod 3).

We now have four cases. In each case, all the possible arrangements are equivalent by movements of the whole cube.

Case 1. No twists needed - do nothing.

Case 2. Two twists required, one + and one -.

14. [[1, 2], 6] = 2-5+ (R, B, D) (10)

Case 3. Three twists required, all the same.

15. (13)3 = 2-5-7- (U, L, R, B, F) (6)

Case 4. Four twists required, two + and two -. Use formula 7 of the list above.

Stage 4, We now have only to put the centres right and these are in an even permutation since any corner turn or any movement of the whole Skewb has the same parity of corner permutation as of centre permutation. It is not hard to see that formula 3 on our list is sufficient to restore the centres, but formulae 5, 6 and 9-13 greatly simplify the process.

Case 1. Any 3-cycle can be done in <=9 moves by use of 9 and 10.

Case 2. Any pair of 2-cycles can be done in <=14 moves by 3, 4, 5, 11, 12.

Case 3. Any 5-cycle (A, B, C, D, E) is a product of two 3-cycles (A, B, C)(A, D, E), so it can be done in <=18 moves by two uses of case 1.

Case 4. Any (4-cycle and 2-cycle) can be done in <=13 moves by conjugating formula 13 by at most two moves.

Case 5. Any pair of 3-cycles can be done in <=18 moves by two uses of case 1.

Thus we can always restore the Skewb in at most 4 + 14 + 10 + 18 = 36 moves, I suspect this can be reduced considerably - my first attempt had 60 moves and I only discovered formulae 9 & 10 today and they reduced stage 4 by 10 moves.

We now see exactly how many patterns are possible, namely [image] = 31 149280, as given by Tony Durham. This is based on the actual restoration process and one may prefer a different expression as [image]. That is, the centres can be in any permutation and each tetrad can have its corners in any even permutation and twisted so the total twist is 0 (mod 3), but the whole cube has 24 equivalent placements.

18

It was the 3s in the denominator which I missed before - and the above doesn't make them quite clear. The 4!/2 refers to the even permutations in one tetrad and the corresponding 34 refers to the corner twists in the other tetrad. The Theorem of stage 2 shows that there is an interaction between these so that only 1/3 of the combined possibilities are achieved. So perhaps a better expression is [image]. Incidentally, the odd permutations of the centres correspond to movements of the whole cube which interchange the tetrads. If we do not allow the tetrads to be interchanged, then both the 6! and the 24 are divided by 2.

If we imagine one tetrad held in place, then our only moves are about its corners. E.g. if we consider 1, 3, 6, 8 as held in place, then we only consider the moves 1, 3, 6, 8 and their inverses. Then there are at most 1 + 8 + 8·6 + 8·62 + ... + 8·6n positions after n moves.

This is (8·6n - 3)/5 and this does not exceed 31 149280 until n = 9. That is, God's Algorithm must be at least 9 moves in diameter.

One might say that the Skewb is easily solvable - after all, we have a solution in at most 36 moves already and it will probably come down. But it is much less easy than this would indicate. It is very hard to keep track of movements since each move disrupts so much. I think it would be quite difficult to restore the Skewb after 3 random moves. Any false move usually is difficult to recover from. It takes a good eye and some practice to use a tetrad for orientation. It is a first class puzzle and I send my compliments to the inventor, Tony Durham.

In my Notes (N38), Kate Fried is reported as being able to invert up to 7 random moves from START on the 33. So 8 moves generally is enough to thoroughly randomise a 33. She reports that 4 moves are enough to randomise a Skewb.

GOD'S ALGORITHM FOR THE PYRAMINX

Douglas Hofstadter reports that John Francis (USA), Lothar Teichert (Germany) and Louis P. A. Bobichaud (Canada) have each found God's Algorithm for the Pyraminx. The four trivial vertex moves are ignored. The number Nd of positions at distance d from START is given in the table below. The average distance from START is 7.8.

d | Nd
0 | 1
1 | 8
2 | 48
3 | 288
4 | 172
5 | 9896
6 | 51808
7 | 2 20111
8 | 4 80467
9 | 1 66276
10 | 2457
11 | 32

19

URIBLOCK

Dane Uri, of Bologna, has devised a different form of the 4 × 4 puzzles (C2-9, C5/6-7/8). This has a 4 × 4 field with each row and column able to slide by one square. However, there are only four pieces to a line, so that sliding a line introduces a rigid part of the slide at one end, making the perpendicular slide at that end now immovable. When the 4 × 4 field is in place, the rows and columns are able to slide, but in alternate directions. Thus the top row can go to the right, the second row can go to the left, the third row can go to the right, the fourth row can go to the left. It is convenient that the alternation of pattern is the same no matter which side is up, i.e. the left hand column can slide up. If the alternation is the other way in the second direction, then the corners do not all behave the same; instead there are three types of corner depending on whether none, one or two of the slides affecting it carry the corner out of the field. This would make the puzzle even harder.

The blockage of movement and the alternation of slides makes it not at all obvious how to solve the general puzzle. A little work shows that one can form a 3-cycle in the central 2 × 2 area and there is sufficient transitivity so that all even permutations seem to be readily achievable. As with all puzzles of this nature, only the even permutations are possible. If all the pieces are distinct, this gives us 16!/2 = 1046 13949 44000 patterns. In the actual puzzle, there are only four colours of piece, and four of each colour. This gives [image] = 630 63000 patterns. The packaging says 63 millions of combinations, so that, for once, the right number is given! My thanks to Dane Uri for sending an example via David Lister. Pentangle is distributing the Uriblock in the UK.

PS. The 2 × 2 Uriblock doesn't do anything, but the 3 × 3 Uriblock is solvable - i.e. any even permutation of the 9 squares is achievable. For the 3 × 3, we necessarily have that the alternation cannot be the same no matter which side is up and there are three types of corner.

MORE ON THE HUNGARIAN RINGS

I discussed the Hungarian Rings in C2-14 and their generalisation at C5/6-9/10. I have now seen the 19th century patent.

William Churchill, of Detroit, obtained US Patent 507,215 on 24 Oct 1893 for a Puzzle, which is conceptually identical to the Hungarian Rings. He permits various sizes of ring, but his drawing shows two rings of 22 pieces, with the intersections being 6 pieces apart on both rings. I.e. this is G(22, 22, 6, 6). His version has simple grooves, so that the pieces can be removed. Removal of one piece gives a sliding piece puzzle. He states the following problem for the puzzle with all pieces in. Start with 20 pieces of each of two colours and two pieces of a third colour. Put the two pieces at the intersections, 20 pieces of one colour in the rest of one ring and the 20 pieces of the other colour in the other ring. By clockwise rotations only, exchange the colours in the rings, leaving the intersections of the third colour. Churchill asserts it can be done in 340 moves!

My paper on the generalised Hungarian Rings groups has appeared in the Bulletin of the Institute of Mathematics and Its Applications 20:9/10 (Sep/Oct 1984) 137-139.

A G(6, 6, 2, 2) version called Rotos is made in East Germany.

[ Rubik's Rings is G(18,18,6,6) and has only three colours. See my Rubik's Rings page. - J ]

20

SOME NOTES ON POLYHEDRA

One or the few products which caught my eye at the 1983 London Toy Fair was a new type of plastic piece for building polyhedra. This led me to the study of certain types of polyhedra. Then this summer, at the International Congress of Mathematicians at Warsaw, I saw a display of a recently discovered class of polyhedra which I have investigated further. These notes cover two topics: pieces for building polyhedra and classes of polyhedra.

You may have seen some of the different ways of joining pieces. The most common method for cardboard pieces is the use of 'ears' along the edges as shown in Figures 1 - 3. The ears are folded and then joined by a rubber band over them. This idea was patented by Fred Bassetti, an architect from Portland, Oregon, sometime in the 1960s. I still have a set given to me then and called Flexagons and containing the regular n-gons for n 3, 4, 5, 6, with edge length of 90mm. These were available, in lighter card and different colours, from Book-Lab Inc., 1449 37th St., NY, NY, 11218, but they had stopped production by 1980. A nice booklet by Bassetti and two others, entitled 'Math Projects: Polyhedral Shapes' , was also available.

FIGURE 2 | FIGURE 3

Invicta Plastics (Oadby, Leicester, UK), best known for Mastermind, produced a large kit called Polyshapes, based on the same principle and apparently under license since some pictures are the same as in 'Math Projects' . They used heavy white card and an edge length of 70mm. The kit includes regular n-gons for n = 3, 4, 5, 6, 8, 10 and 70 by 140 mm rectangles and 70, 113, 113 mm isosceles triangles (with angles of 72°, 72° and 36°), (The Flexagons had different colours or patterns for each shape. Book-Lab kindly sent some samples when I wrote them. These were all blue and all orange - I don't know if they were mixed in their kits. The Invicta are all white.) Invicta supplies a set of 26 work cards by H. Shaw.

21

I have seen a number of other methods of joining cardboard polygons, using tabs and slots, but I do not find them easy to use - either they come apart too easily or they don't come apart at all. Joining plastic pieces along a hinged edge is not as easy and I had only noted one attempt to do this before this year, though there may have been others I didn't know about. The object I had first seen was the Happy Cubes made by the US firm of Mag-Nif and unfortunately not available in the UK. This had eight cubes joined in a chain by the edge connection shown at the right1 Figure 14. Unfortunately, the plastic was a bit soft and the outer parts of the hinge were too rigid, so that the balls which fit in the sockets soon wore down and the puzzle would fall apart when you picked it up.

More recently, I have seen the Tri Logic of Mag-Nif. This has 24 triangles in plastic with hinges as shown on the right, Figure 5. Each edge has two of the hinges, one male part and one female part on each aide of the edge. I haven't had mine long enough to see how sturdy it is. It does have the obvious disadvantage that they have tried to bring the edges to a real meeting point and this produces an extremely sharp point at each vertex.

Another version of idea is Clixi, produced by ESA Creative Learning, Harlow, UK. Their joint is shown on the right, Figure 6. Again each edge has two of the hinges, with one of each sex on each side. Clixi also provides squares, pentagons, circles and some cross pieces. The squares (at least) have joints moulded into the inside so that one can attach a piece to the interior of the square. This, and the circles and cross pieces, make this a much more general construction kit than the other kits described here. A 140 page booklet, 'Exploring Mathematics with 'Clixi', comes with it and is obviously aimed at 8-12 year olds. The corners are better rounded than in Tri Logic, but the pieces are supplied in moulded sheets and do not detach cleanly.

The version that I saw at the Toy Fair this year seems to be definitely the nicest that I have seen. The hinge was devised by Edward Harvey and the pieces are being produced by Polydron UK, Unit 12, Staveley Way, Brixworth Industrial Estate, Brixworth, Northampton-shire, NN6 9EU, UK. The hinge is shown at right, Figure 7. Because of the intricacy, I have drawn only one side of the hinge. The other aide is identical, just turned over. The pieces are thick and come in four primary colours with a smooth finish. The corners are neatly rounded.

22

At first, only equilateral triangles were produced, but squares became available in 1984. Since the pieces are thick, they are not cheap - a box of 60 retails at about £8.00. But bulk orders for educational use should be considerably cheaper and I think this will be a major market for the pieces, especially when other shapes become available. They seem ideal for classroom use. Polydron kindly sent me a bag of pieces to try out and I certainly find them the most pleasant to handle of all the types described.

In all of the hinges described, some flexibility must be designed in so that the ball and socket joint can be made of hard plastic which will not wear down. But this means that there is no give at the joint and go some give must be designed in elsewhere, again to prevent the joint wearing down. Mag-Nif's Happy Cubes failed to provide flexibility so the balls and sockets just ground each other down. All the other hinges have some sort of thin parts which bend and spring back as the pieces are snapped together or taken apart.

Once one has a kit of snap-together triangles, one wonders what one can build with them. In fact there are many such shapes and they have been called 'deltahedra', since an equilateral triangle looks like the Greek capital letter delta - Δ. Surprisingly, these have not been studied until quite recently - most authors cite a 1947 paper. But first we must note that one must make some restriction since it is easy to build infinitely many deltahedra - simply replace a face by a triangular pyramid on that face. This process can be repeated indefinitely. One can also build pleated tubes of arbitrary length. Most of the deltahedra constructed are non-convex, so we might ask for the convex ones. H. Freudenthal and B. L. van der Waerden, two eminent Dutch mathematicians, published 'Over een bewering van Euclides (On an assertion of Euclid)' in Simon Stevin 25 (1946/147) 115-121. They showed that there are just 8 convex deltahedra. It was later discovered that O. Rausenberger had found the same result in 'Konvexe pseudoreguläre Polyeder' in Zeitschr. fur math. und naturwiss. Unterricht 46 (1915) 135-142. The only English exposition I know of is in A. Beck, M. Bleicher & D. Crowe, 'Excursions in Mathematics', Worth, NY, 1969. A brief description is given in

H. Behnke, et al., 'Fundamentals of Mathematics', vol. 2, pp. 268-271, MIT Press, 1974. See next page for drawings.

Five of the deltahedra are fairly obvious. I, III, VIII are the regular tetrahedron, octahedron and icosahedron. II, III, IV are the triangular, square and pentagonal bipyramids. If we look at the icosahedron, VIII, we can imagine removing the top and bottom pentagonal pyramids and replacing them with pentagons. This gives what we call the pentagonal antiprism. In general, an n-gonal antiprism has two parallel n-gons, one turned by 360°/2n with respect to the other and the space in between filled by 2n equilateral triangles. The octahedron, III, is the triangular antiprism. VII and VIII are the square and pentagonal anti-prisms, with their n-gonal faces replaced by pyramids. (If you try this with the octahedron, the triangular faces pair off into rhombuses and you get a rhombic parallelepiped.) VI is obtained from VII by replacing one of the square pyramids with two triangles. This can also be obtained by starting with a triangular prism and replacing each square face by a square pyramid. V is obtained from VI by replacing one of these square pyramids by two triangles. (Repeating the process gives the pentagonal bipyramid, then the octahedron, then the triangular bipyramid, then the tetrahedron!)

23

THE CONVEX DELTAHEDRA

24

The work of Freudenthal and van der Waerden was inspired by reading Euclid, XIII, 18, which asserts (in Heath's translation) that there are only five figures which are "contained by equilateral and equiangular figures equal to one another". Euclid doesn't contemplate non-convex or infinite polyhedra, but the 5 non-regular convex deltahedra certainly still fit Euclid's definition. There are no other cases, since squares and pentagons can only fit with three at each vertex and thereby only give the regular polyhedra

Euclid intended to consider polyhedra whose symmetry group was transitive on vertices, edges and faces. That is, each vertex (or edge or face) can be carried into any other by some symmetry of the solid. Otherwise stated, all vertices, edges and faces appear the same. For a non-regular deltahedron such as the triangular bipyramid (II), some vertices have 3 edges while some have 4, so they are not all the same. Some edges join pairs of 3-fold vertices while others join a 3-fold and a 4-fold vertex, so they are not all the same. But all the faces are the same However, the faces are not all the same on V, VI or VII. By relaxing the criteria that Euclid intended, we can extend the family of regular polyhedra in several ways. Below, I outline several of these ways. The interested reader can find fuller details in the following.

H. Behnke, et al. Fundamentals of Mathematics. Vol. II - Geometry. MIT Press, 1974.
H. S. M. Coxeter. Regular Polytopes. 2nd ed. Macmillan, 1963.
H. M. Cundy & A. S. Rollett. Mathematical Models. 2nd ed., Oxford Univ. Press, 1961.
L. Lines. Solid Geometry. Dover, 1965
M. J. Wenninger. Polyhedron Models. Cambridge Univ. Press, 1971.

A. REGULAR POLYHEDRA

First, let us review the regular or Platonic polyhedra and lattices. The basic argument for these and most other polyhedra is that the sum of the angles at each vertex must be less than 2π (= 360°). (Equality leads to another type of figure - the plane lattices or tessellations.) The angle at the corner of a regular p-gon is (p-2)π/p. If we have q p-gons at a vertex, then we must have q(p-2)π/p <= 2π. This gives pq - 2q <= 2p, hence pq -2q - 2p <= 0, hence pq - 2q - 2p + 4 <= 4, i.e.

(*) (p - 2)(q - 2) <= 4.

For a convex polyhedron with V vertices, E edges and F faces, we also have Euler's formula. V - E + F = 2. For a regular polyhedron with p, q as above, we have pF = qV = 2E, since pF and qV both count all the edges twice over - pF counts them from each side, while qE counts them from each end. Hence (2/q - 1 + 2/p)E = 2, or (2p + 2q - pq)E = 2pq and E = 2pq/(2p+2q-pq). The fact that this denominator must be >= 0 is just (*) again.

There are not many solutions of (*), if we remember that p, q >= 3.

p | q | V | E | F
3 | 3 | 14 | 6 | 4 | Tetrahedron
3 | 4 | 6 | 12 | 8 | Octahedron
4 | 3 | 8 | 12 | 6 | Cube
3 | 5 | 12 | 30 | 20 | Icosahedron
5 | 3 | 20 | 30 | 12 | Dodecahedron
3 | 6 | - | - | - | Triangular lattice
6 | 3 | - | - | - | Hexagonal lattice
4 | 4 | - | - | - | Square lattice

25

I have drawn bits of the triangular and hexagonal lattices to the right since these are the least familiar of the above solutions. These figures are often denoted by the Schläfli symbol {p, q}. The figure {p, q) is dual to the figure {q, p} in that the roles of vertices and faces are interchanged. E.g. the octahedron has 6 vertices and 8 faces, while its dual, the cube, has 8 vertices and 6 faces. The easiest way to construct a dual is to take new vertices at the centres of the old faces and join these if the corresponding old faces are adjacent. I have bracketed the dual pairs in the table on the preceding page. Note that (3,3) and {4,4} are self-dual.

The regular polyhedra have all vertices, edges and faces the same and they are finite and convex. Removing finiteness in one way gives the regular tessellations or lattices.

B. KEPLER-POINSOT POLYHEDRA

pentagram If we remove the condition that our figure is convex, we obtain Is further polyhedra called the Kepler-Poinsot polyhedra. The great dodecahedron is just the shape of Alexander's Star (C3/4-19/20) - it has five pentagons meeting at each vertex in a pentagram pattern, as shown at the right. The great icosahedron has five triangles meeting at each vertex in a pentagram pattern. These were discovered by Poinsot in 1809. The duals of these are polyhedra whose faces are pentagrams. The small stellated dodecahedron has five faces at each vertex in a pentagonal pattern and looks like a dodecahedron with pentagonal pyramids on each face. The great stellated dodecahedron is actually a stellation of the great dodecahedron and looks like each of the triangular hollows of the great dodecahedron has been filled out to a pyramid. These were discovered by Kepler (in his De Harmonice Mundi, 1609, a work better known for the first appearance of Kepler's Third Law), and were rediscovered by Poinsot. The great icosahedron and the great stellated dodecahedron were rediscovered by Schläfli in 1901, but he did not believe the other two could exist because they do not satisfy Euler's formula, even when adjusted to make the first two satisfy it! It is possible to demonstrate that there are no further examples of this family of polyhedra, but the proof takes some work. See Coxeter, Chapter VI. The pentagram is conveniently denoted by 5/2, where the 2 denotes the connection from a vertex to the one that is two away. In general, the various star-polygons are denoted by rational numbers and one of the approaches to showing there are no further polyhedra in this class depends on seeing that there are no further rational solutions of a certain trigonometric relationship. Coxeter's first approach is to see that a regular polyhedron in our present extended sense has a symmetry group which is the same as the symmetry group of a Platonic regular polyhedron and this depends on some careful analysis of three-dimensional symmetry groups. Once this is established, one has only to examine the various stellatings of the dodecahedron to find all the possible cases.

26

Great Dodecahedron GREAT DODECAHEDRON | Great Icosahedron GREAT ICOSAHEDRON
Great Stellated Dodecahedron GREAT STELLATED DODECAHEDRON | Great Stellated Icosahedron GREAT STELLATED ICOSAHEDRON
p | q | V | E | F
5/2 | 5 | 12 | 30 | 12 | Great dodecahedron
5 | 5/2 | 12 | 30 | 12 | Small stellated dodecahedron
5/2 | 3 | 12 | 30 | 20 | Great icosahedron
3 | 5/2 | 20 | 30 | 12 | Great stellated dodecahedron

C. HONEYCOMBS

If we remove the conditions of both finiteness and convexity) we can get infinite 'honeycombs'. For example, consider all the faces of the regular cubical lattice. By removing half of these faces, like the black squares on a chessboard, along each plane, one can get an arrangement which divides space into two congruent halves, sometimes called sponges. If one thinks of the basic unit as 2 × 2 × 2 box of 8 cells, indefinitely repeated, then one half consists of a cube and its three neighbours, forming a 'pyramid' at a corner (as described in C5/6-12), repeated indefinitely. Many other patterns are possible, by using different sizes and halvings of units and by using other space filling polyhedra, such as the rhombic dodecahedron or the truncated octahedron, These get quite complex and Coxeter has written a booklet on them: 'Twisted Honeycombs', Amer. Math. Soc., 1970.

27

D. SEMI-REGULAR POLYHEDRA

Let us reinstate our assumptions that our polyhedra are convex and finite, but remove the assumption that all faces are the same, only requiring that all vertices and edges are the same, and that the faces are regular polygons. Then there are only two types of face - one on each side of each edge - and they must alternate about each vertex. Since the sum of the angles at each vertex must be C 2s, we find just three possibilities. Let the polygons be p1 and p2-gons. A little consideration of the possibilities shows that we must have 4 polygons at each vertex and hence (p1-2)/p1 + (p2-2)/p2 <= 1. Our three cases, beyond the Platonic cases, are then given by the table.

P1 | P2 | V | E | F1 | F2
3 | 14 | 12 | 24 | 8 | 6 | Cuboctahedron (C1-7)
3 | 5 | 30 | 60 | 20 | 12 | Icosidodecahedron
3 | 6 | - | - | - | - | Lattice of triangles and hexagons

Each of these is a mixture of two dual figures and can be viewed several ways. If we start with a cube and truncate its corners more and more until the triangles formed at the corners just touch, then we have the cuboctahedron. Truncating further leads to the octahedron. We can also truncate the octahedron to get the cuboctahedron and then the cube. We can see that the vertices of the cuboctahedron correspond to the edges of the cube (or octahedron) while the faces correspond to the faces and the vertices of the cube (or octahedron). We have p1F1 = p2F2 = E. The icosidodecahedron is similarly the truncation of the dodecahedron or the icosahedron. The lattice of triangles and hexagons, shown on the right, can be viewed as a truncation of {3,6} or {6,3}, but it may be easier to see by taking the triangular or hexagonal lattice and placing new vertices in the centre of each edge and joining the vertices of adjacent edges, where adjacent means having a common vertex and a common face. These figures were certainly known to the Greeks. Archimedes, in a lost account, ascribes the cuboctahedron to Plato, and Archimedes describes the icosidodecahedron.

The duals of these figures are less obvious. They are figures with all faces and edges being the same and the vertices are regular. This means that the pattern of faces at a vertex forms a regular polygon. These are less easy to see and hence have not been investigated as much. The faces are all rhombuses, but with different angles. The polyhedral ones are the rhombic dodecahedron and the rhombic triacontahedron. The rhombic dodecahedron is described in C5/6-12/14, but sketchily
[ and shown on page 5. - J ].
The rhombic triacontahedron, with 30 faces, can be obtained as a die. Both of these are attributed to Kepler, but there is an article: F. Lindemann, Zur Geschichte der Polyeder und der Zahlzeichen, Sitzungsberichte der math.-phys. Classe k. b. Akademie der Wissenschaften zu München 26 (1896) 625-783 & 9 plates, which describes an antique rhombic triacontahedron. He thinks it may date from about the middle of the Byzantine era. The dual of the lattice, shown on the right, is a famous optical illusion and a common patchwork quilt pattern called 'baby blocks'.

28

E. ARCHIMEDEAN POLYHEDRA

If we remove the assumption that all edges are the same, but still ask for regular faces, there are still only a few possibilities for the angles at each vertex. There are two infinite families of such polyhedra - the prisms Πn and the antiprisms An. There are just 13 more such polyhedra, though two types have right- and left-handed forms. These were known to Archimedes, according to a lost account which was summarised by Pappus. To classify these, we represent the pattern of polygons around a vertex by simply listing them in order and abbreviating repetitions by use of powers. E.g. the vertex pattern of a cube is 444 or 43, while the vertex pattern of a cuboctahedron is 3434 or (34)2.

Number | Vertex pattern | V | E | F1,F2,F3 | F
I | 42n | 2n | 3n | n,2 | n+2 | n-prism, Πn
II | 362 | 12 | 18 | 4,4 | 8 | Truncated tetrahedron
III | 462 | 24 | 36 | 6,8 | 14 | Truncated octahedron
IV | 562 | 60 | 90 | 12,20 | 32 | Truncated icosahedron
V | 382 | 24 | 36 | 8,6 | 14 | Truncated cube
VI | 3.102 | 60 | 90 | 20,12 | 32 | Truncated dodecahedron
VII | (34)2 | 12 | 24 | 8,6 | 14 | Cuboctahedron
VIII | (35)2 | 30 | 60 | 20,12 | 32 | Icosidodecahedron
IX | 33n | 2n | 4n | 2n,2 | 2n+2 | n-antiprism, An
X | 343 | 24 | 48 | 8,18 | 26 | (Small) Rhombicuboctahedron
XI | 344 | 24 | 60 | 32,6 | 38 | Snub cube
XII | 345 | 60 | 150 | 80,12 | 92 | Snub dodecahedron
XIII | 468 | 48 | 72 | 12,8,6 | 26 | Great rhombicuboctahedron
XIV | 4.6.10 | 120 | 180 | 30,20,12 | 62 | Great rhombicosidodecahedron
XV | 3454 | 60 | 120 | 20,30,12 | 62 | (Small) rhombicosidodecahedron

The two great rhombi-s can be viewed as truncations of the corresponding polyhedra, but the natural truncation leads to rectangular faces, as with the object shown at C1-9. But adjusting the truncation a bit, one gets square faces. There is a pseudo-Archimedean polyhedron obtained by rotating one 'face' (in the Rubik Cube sense) of the rhombicuboctahedron (X) by 45°, i.e. an eighth turn. Each vertex then has the same pattern, but they are not all the same on the polyhedron as a whole.

29

THE ARCHIMEDEAN POLYHEDRA

30

The dual Archimedean polyhedra have all their faces the same, but they are not regular. Consequently, few of these are well known. We have seen the duals of the semiregular polyhedra in the previous section. The dual of a prism is a bipyramid. The dual of an antiprism is a trapezohedron.

F. ARCHIMEDEAN TESELLATIONS

If we make the sum or the angles at each vertex now be 2π, we have the planar tessellation analogues of the Archimedean polyhedra. It turns out there are just 8 of them, having the following vertex patterns.
3342, 32434, (36)2, 346, 3.122, 482, 4.6.12, 3464.
346 has right- and left-handed forms. (36)2 is semi-regular.

3342 | 32434 | (36)2
346 | 3·122 | 482
4·6·12 | 3464

31

G. UNIFORM POLYHEDRA

If we drop the assumption of convexity from the concept of Archimedean polyhedron, we have the concept of polyhedra with all vertices the same, and with all faces regular, but possibly star-polygons. These are called uniform polyhedra. The Platonic and Archimedean polyhedra are the convex uniform polyhedra. In general, a non-convex uniform polyhedron looks like an ordinary polyhedron with some bits missing. The simplest example consists of the three square cross-sections of an octahedron, with half of the octahedral faces filled in. Then each vertex has two squares and two triangles. The result is a most peculiar polygon - it only has one side!

The uniform polyhedra have been discovered by a number of people over the last century: Badoureau (1881), Hess (1878), Pitsch (1881), Coxeter and Miller (1930-1932), M. S. & H. C. Longuet-Higgins (1942-1944), Lesarve and Mercier (1947). These results are all presented in:

H. S. M. Coxeter, M. S. Longuet-Higgins & J. C. P. Miller. Uniform polyhedra. Philos. Trans. Roy. Soc. 246A (1954) 401-450. Their end result is that there are at least 53 uniform polyhedra, beyond the 5 Platonic, 13 Archimedean, 14 Kepler-Poinsot and the prisms and anti-prisms. They say: 'it is the authors' belief that the enumeration is complete, although a rigorous proof has still to be given'. Wenninger's book, cited earlier, shows how to construct all 75 of these, where this number excludes Πn, n != 4, and An, n > 3. (Π4, the cube, and A3 the octahedron, fall into the 75 in other ways.)

H. REGULAR-FACED POLYHEDRA

The most recent of the generalisations of the regular polyhedra is the removal of all symmetry to ask: what convex polyhedra can be formed with regular polygonal faces? This has only been resolved in the 1960s. I heard something about it from Dick Hess in 1983 , but my knowledge of it derives from a marvellous exhibition by Professor S. Zych of Bialystock at the International Congress of Mathematicians in Warsaw, summer, 1983. Following on Zych's information, I have found the basic papers. These are;

Norman W. Johnson. Convex polyhedra with regular faces. Canad. J Math. 18 (1966) 169-200. (Johnson also produced an identically titled set of lecture notes at Carleton College, 1961).

Viktor A. Zalgaller. Convex polyhedra with regular faces. Seminars in Mathematics, V. A. Steklov Mathematical Institute, Leningrad, vol. 2, (1967) - in Russian. English translation: Consultants Bureau, NY, 1969, 95pp.

The regular-faced polyhedra are:
the prisms Πn, n >= 3;
the antiprisms An, n >= 3;
the 5 regular, Platonic, polyhedra;
the 13 Archimedean polyhedra;
92 others.

A regular-faced polyhedron is simple if it cannot be cut into two such polyhedra. Otherwise it is composite. For example, an octahedron can be cut into two square pyramids. Note that Π6 can be cut into 6 Π3's, but is still simple. Johnson had obtained the above described polyhedra, but without complete proof. Zalgaller furnished the proof and introduced the notions of simplicity and compositeness. Zalgeller found that the simple regular-faced polyhedra are:

the prisms Πn, n >= 3;
the antiprisms An, n >= 4;
28 others.

32

The tetrahedron and dodecahedron are among the 28; the cube is Π4 and is simple; the octahedron (= A3) and the icosahedron are composite. The larger two irregular deltahedra (VII and VI) are composite, but V is simple. Zalgaller gives names to all these polyhedra: V is the snub disphenoid, VI is the triaugmented triangular prism, VII is the elongated square dipyramid.

An early result in this field by Branko Grünbaum and Johnson is that, except for prisms and antiprisms, the only n-gons that can occur are for n = 3, 4, 5, 6, 8, 10. Consequently these can all be built if you have enough or the Invicta Polyshapes kits. Professor Zych had a display of all these. Interestingly, he used hand cut pieces of coloured fibreglass exactly in the pattern of the eared polygons that started off this whole essay!

I. TESSELLATIONS AND TILINGS

We have already seen the 11 Archimedean tessellations in A (the 3 regular ones) and G (the 8 others). These are apparently due to Kepler. There are 10 further ways one can place regular n-gons around a vertex

in the plane: 32.4.12, 3.4.3.12, 3262, 3426, 3.7.14, 3.8.24, 3.9.18, 3.10.15, 4.5.20, 52.10. There are four cases where the same polygons can be arranged in different ways: 3342 - 32434, 32.4.12 - 3.4.3.12, 3262 - (36)2, 3426 - 3464. In all but the second case, it is possible to combine vertices of both orders to get non-Archimedean tilings of the whole plane. In the latter two cases, all the tilings are obtainable from the Archimedean ones by shifting part of the pattern. In the first case, the possible tilings are not all known.

On a sphere, the Archimedean tessellations are just the projections of the Platonic and Archimedean polyhedra, but there are a number of subdivisions of these which have some sort of regularity. For example, if one subdivides the pentagons of a dodecahedron into 10 triangles by drawing rays from the centre to the vertices and midpoints of sides, then one gets a spherical tessellation into 120 triangles. The symmetry group of the dodecahedron is precisely transitive on these triangles in the sense that there is a unique symmetry carrying a given triangle onto another one.

Our approach to finding these polyhedra and tessellations was by use of angles. It is possible to use Euler's formula for polyhedra and thereby show that they have their combinatorial structure determined. For tessellations, Euler's formula does not apply. But if one examines a finite region of expanding size, then one can get a limiting form of Euler's formula. This can be used to show that the Archimedean tessellations have their combinatorial structure determined. In both cases, it is a happy accident that these structures can be formed with regular polygons.

Let us now consider removing the criterion of building these structures with regular polygons. For example, consider a brick or a tiling by rectangles. Then the only condition we are imposing is that the symmetry group acts transitively on vertices. The symmetry group of such an object will be a subgroup of the symmetries when all the faces are regular. Using an appropriate definition of 'same type', it is a finite, though tedious, task to determine all the different types of polyhedra or tessellations. It is probably easier to consider the dual problem, which considers polyhedra or tessellations in which the symmetry group acts transitively on the faces or tiles. I do not know if this task has been done for polyhedra.

33

It has recently been carried out for tessellations by B. Grünbaum and G. C. Shephard. (See their survey papers. Tiling with congruent tiles. Bull. Amer. Math. Soc. 3 (1980) 951-973. Tilings by regular polygons. Math. Mag. 50 (1977) 227-2147.) They say a tiling is isohedral if its symmetry group acts transitively on the tiles. In particular, all tiles must be congruent. By examining the duals of the 11 Archimedean tessellations, they find that there are 81 types of isohedral tilings. (The tiles need not even be polygons!) They do not describe the duals of these, but it seems apparent that one can form some sort of duals, which would be tilings whose symmetries are transitive on vertices. Interestingly, the sphere has 8 infinite families and 53 other types of isohedral tilings on the sphere.

Grünbaum and Shepherd have also studied tilings with a single shape of tile, but where the symmetries are not transitive on the tiles. There are tiles which tile the plane or space, but which have no isohedral tilings. Indeed, there are convex pentagons with this property.

Any triangle or quadrilateral tiles the plane isohedrally. (Exercise: show this.) There are just 3 types of convex hexagon which tile the plane and there are no convex p-gons, for p >= 7. At present, there are 13 known types of convex pentagon which tile, though some are not 'edge to edge'. There have been several claims to a complete list in the past, but no one presently claims the list is complete. (See D. M. Schattschneider. Tiling the plane with congruent pentagons. Math. Mag. 51 (1978) 29-44 for the history and diagrams.)

It is often asserted that there are only a few space-filling solids. These are sometimes even listed: cube, hexagonal prism, rhombic dodecahedron, elongated dodecahedron (obtained from the rhombic dodecahedron by stretching along a diameter through two 4-fold vertices), truncated octahedron. But these are the parallelohedra, i.e. the convex polyhedra which fill space entirely by translations. No one knows all the space filling solids, even if we exclude the prisms over the tilings of the plane. In the first cited Grünbaum and Shephard paper, many peculiar space filling shapes are shown and described, including 14 types of convex polyhedra with 38 faces.

In C above, I described, rather vaguely, the idea of a honeycomb. Technically, Coxeter uses honeycomb for the filling of space by polyhedra and the infinite polyhedra obtained by considering some of their faces are called sponges. Coxeter showed there are three regular sponges: {4, 6}, {6, 4}, {6, 6}, using the Schläfli symbol in an obvious way. The first comes from the cubical lattice as I described in C. The second comprises the hexagons in the filling of space with truncated octahedra. I have not yet been able to see what the last one looks like. Aha! I've just tried again and I managed to find out what this is. Consider the truncated tetrahedron, which has 4 hexagonal and 4 triangular faces. This does not fill space, but if we also use tetrahedra which fit the triangular faces, then we can pack four truncated tetrahedra around each tetrahedron, face to face with it, then we can pack another six truncated tetrahedra edge to edge with the original tetrahedron and this leaves four gaps at the vertices which we fill with four of the small tetrahedra. The faces of the pieces fall into planes where the hexagons and triangles form the semi-regular tessellation described in B above. In a sense, this is the best possible packing of space with tetrahedra - it can't be done properly, but if we let the tetrahedra overlap at corners, then we have this packing, where the small tetrahedra are the overlaps of the main tetrahedra. The packing of space by truncated octahedra can be viewed similarly as a packing by octahedra which overlap in little octahedra. In this case, one can truncate the octahedra regularly to eliminate all overlaps. In the tetrahedral case, this cannot be done, but we can truncate three corners of the tetrahedron to obtain a shape which fills space. There is another way to fill space that is suggested by these ways. Take an octahedron and add two tetrahedra on adjacent faces of it. The result looks a bit like a fish and copies of it can be joined nose to tail to produce a rhombic prism stretching to infinity. These can be packed side by side to fill space.

34

ADDENDUM

I have recently attended the 1984 London Toy Fair and visited the Polydron stand. They have been doing well. They have improved the finish on their pieces and have started making squares. They will provide en educational kit of 100 triangles for £11.50, including postage and VAT.

A new type of piece was on display. This is called Model Eight and their address is: Model 8, Ltd., Unit 14, Little Marcle Road, Ledbury, Herefords., HR8 2DS.

The mechanism is quite intricate and fits together in two basic ways. The first diagram on the right shows the basic shape of the piece, although the actual pieces are hollow in the middle. The projecting teeth have cylindrical rods or hollows on them which provide the axis of rotation. There are two types of edge: male with rods projecting from the teeth and female with hollows in the teeth. These are shown in the diagrams below. Because of the alternating nature of the teeth, a male and a female can be joined in two ways.

The more natural is the join of the first diagram on the left with the second one. Then the pieces can rotate about the cylindrical axis. The less obvious join is of the first diagram with the third one. Then the teeth overlap and form a rigid joint.

An extra feature is that four pieces can be joined along an edge!

35

However, joining edges in the second way requires keeping the two pieces in one plane. Otherwise the rods can snap off rather easily.

I find joining the pieces is somewhat fiddly. The pieces are only about half the edge length of the Polydron pieces (32.5mm versus 70mm). Further, the arrangement of male and female edges must vary on the pieces. Triangles have two edges of one sex and one of the other and you need both types to build anything. As I recall, there are also two types of squares, one with the two male edges adjacent and one with them opposite. Only triangles and squares are available so far.

The makers advertise Model 8 'from six years' but I do not think primary children will find them very pleasing, though the makers show some complex objects made by 8 to 10 year olds. I don't think it will compete with Polydron for primary use, but it could have use for older children and adults. Since it is smaller and hollow, it should be much cheaper. Being hollow gives the constructions a linear rather than a solid appearance which can be more pleasing for some objects. If pentagons, hexagons, octagons, decagons and dodecagons are produced, the smaller size of Model 8 and the cheaper price may become dominant considerations for serious model builders.

SLIDING CUBE PUZZLES

On C2-9/10, I discussed sliding cube puzzles and cited Rouse Ball (1892). I have found an even earlier reference. P. G. Tait, in a Note on the Theory of the "15 Puzzle" (Proc. Roy. Soc. Edinburgh 10 (1878-1880) 664-665) says: "The principle above stated is, of course, easily applicable to the conceivable, but scarcely realisable, case of a rectangular arrangement of equal cubes with one vacant space."

The Japanese firm of Kawada is making and marketing a very nice seven cube version in a Piet Hein range. They are also doing a new version of his Soma Cube. This has solid versions of the domino, both trominoes and 4 of the tetrominoes as shown below. These total 24 cubes and the puzzle comes on a 3 × 3 base with a pillar up through the centre.

36

A RUBRIC ON RUBIK CUBICS1

By Claude E. Shannon

[Readers may remember that I referred to this song in C3/4-2. Shannon has sent an amended version. This song is probably unique in musical history in having 15 footnotes for only 6 verses. I have inserted the footnotes after each verse, except for the first, which is a footnote to the title and comes just below. I have corrected a few errors , indicated by use of square brackets.]

1. When T. S. Eliot published 'The Waste Land" in 1922 with a wealth of footnotes, there was considerable commotion among the critics - should a work of art stand on its own feet or refer to such weighty tomes as The Golden Bough. The ambiguity, obscurity and even prurience of modern poetry are also under attack. We intend this to be clean as a hound's tooth, crystal clear, sensible as a dictionary, and with footnotes galore.

First off, this may be either read as a poem or, better, sung to "Ta! Ra! Ra! Boom De Ay!" (with an eight bar chorus). The verses should be sung solo, in a slightly bitter sardonic manner, a la Noel Coward or Bea Lillie; the choruses, in contrast, a joyous rousing salute to the cube.

Once puzzledom was laissez faire
With rebus, crosswords, solitaire.
Comes now the Rubik Magic Cube
For Ph. D. or country rube.
This fiendish clever engineer
Entrapped the music of the sphere.
It's sphere on sphere in all 3 D -
A kinematic symphony!

Ta! Ra! Ra: Boom De Ay!
One thousand bucks a day.
That's Rubik's cubic pay.
He drives a Chevrolet.2

2. A little poetic license here - the Wall Street Journal, Sept. 23, 1981, reports Rubik as receiving $30,000. a month from cubic royalties, but driving a "run-down rattling Polski Fiat". This would neither scan nor rhyme as well as Chevrolet.

Forty-three quintillion plus3
Problems Rubik posed for us.
Numbers of this awesome kind
Boggle even Sagan's mind.4
Some chaps pry their cubes apart
Then reassemble to the "start"
Not cricket! a rude game's afoot
And up with which we will not put!

Ta! Ra! Ra! Boom De Ay!
Cu-bies in disarray?
First twist them that-a-way,
Then turn them this-a-way.

3. There are 8! 12!/2 38/3 212/2 = 43252 00327 44898 56000 possible arrangements of the cube.

4. It would take billions and billions of "billions and billions" for forty-three quintillion plus.

37

Respect your cube and keep it clean.
Lube your cube with Vaseline.
Beware the dreaded cuber's thumb,
The callused hand and fingers numb.5
No borrower nor lender be.
Rude folk might switch two tabs on thee,
The most unkindest switch of all,
Into insolubility.6
In-sol-u-bility.
The cruellest place to be.7
However you persist
Solutions don't exist.

5. While not as debilitating as weaver's bottom or hooker's elbow, cuber's thumb can be both painful and frustrating. For more on these occupational ailments see recent issues of "The New England Journal of Medicine".

6. A friend of mine, Pete, an expert cuber, told me of encountering a friend Bill at a hobby shop. Bill gave Pete his cube, saying that he had been working for days without success. After a few minutes, Pete turned it into a position where he could see that two tabs had been interchanged.

Pete: Bill, somebody has switched two tabs on your cube.
Bill: That's impossible. I've always carried it, or left it in my apartment, and nobody has keys to get in there.
Pete: Nobody?
Bill: That's right, nobody. Just me and my girlfriend.

7. Especially in April.

While most folk watch the idiot tube
Cubemeisters spin the Rubik cube.
Minh Thai's the champ - he's fast as sin.
Minh solves his cube in half a min.8
John Conway leads a Cambridge pack
And solves his cube behind his back.9
Singmaster wrote THE BOOK - first rank;
Now cubes while riding to the Bank.10
Here now a heavyweight
Programming potentate:
Software sophisticate:
Morwen B. Thistlethvaite!11

8. Minh Thai, World Speed Champion, in a public demonstration solved six scrambled cubes, each in less that 30 seconds.

9, Actually, he peeks a little. John Conway, the great Cambridge combinatorialist, in addition to his tour de force blindfold cubing has, with his colleagues, contributed much to Rubik cube theory.

10. Singmaster, David. Notes on Rubik's Magic Cube, now in its sixth edition. [Fifth edition, but who's counting!]

11. A pioneer in programming computers to solve the cube. His program solves the cube in 52 or fewer moves.

38

Eschewing this dull 3 D space
Joe Buhler cubes in hyperspace.12
All hail Dame Kathleen Ollerenshaw,
A mayor with fast cubic draw,13
Is cubing just a crashing bore?
Let Talken's robot do this chore.14
God moves in geodesic ways
And solves His cube in twenty plays.15
Cubemeisters one and all,
Their cubes find final rest
Bronzed in the Hall of Fame
In lovely Budapest.

12. Group theorist Buhler and his colleagues have developed a theory of higher dimensional cubes.

13. Renaissance woman, sometime mayor of Manchester, recreational mathematician, expert cubist and discoverer or the cubist thumb syndrome and its relation to the fetlock problem in horses.

14. In October 1981 the writer foresaw the need for a cubing machine and sketched the design of a pair of mechanical hands to be connected to a computer and manipulate a cube. In the summer of 1982 a crack team of one M.I.T. student was assembled. Late in July the hands were making their first fumbling attempts to hold and manipulate a cube, when we received a crushing newspaper clipping from a friend. It seems that Dan Talken had assembled a crack team of Southern Illinois University students and beat us to the punch. My friend wrote one word across the clipping: "scooped!"

15. Or so Singmaster finds it tempting to conjecture.

The battle's joined in steely grip;
Man's mind against computer chip,
With theorems wrought by Conway's eight
'Gainst programs writ by Thistlethwaite.
Can multi-billion neuron brains
Beat multi-megabyte machines?
The thrust of this theistic schism -
To ferret out God's algorism!

CODA:
He (hooked on cubing) with great enthusiasm:

Ta! Ra! Ba! Boom De Ay!
Men's schemes gang aft agley.
Let's cube our life away.

She: Long pause (having been here before):

-----------------------OY VAY!

I had the pleasure of meeting Shannon this summer when he came to visit when he was in England.

39

THE XL-25

At the London Toy Fair in 1983, Vulcan Electronics (previously known as the importer of the Hungarian Rings (C2-12 & C5/6-9/10)) displayed a new Hungarian electronic puzzle which has an interesting mathematical theory. The XL25 has a 5 × 5 (henceforth denoted 52 in our usual convention) array of buttons with lights behind them so the buttons appear either dark or lit up, starting with all buttons off, pressing a button lights up a pattern of squares. A second press of the same button turns off the same squares. If you press two buttons, both their patterns light up, except that any square which lies in both patterns is first lit up and then turned off. That is, a press of a button reverses all the lights in its pattern. We can phrase this a different way. Each light is affected by a certain pattern of buttons. If these buttons have been pressed an odd number of times, the light will be on, otherwise it is off.

The XL25 has a choice of two patterns as shown on the right. The cross is five squares in the shape of a cross or +, affected by its central square. The knight is 9 squares comprising the button pressed and the 8 squares which are a knight's move away from it. If one is near an edge of the puzzle, the parts of the pattern which go over the edge are lost - they do not re-enter on the opposite side.

[ The puzzle with the cross pattern has become popular in the version manufactured by Tiger Electronics, and which is called 'Lights Out'. See my Lights Out page. - J ]

After some contemplation, the following structure becomes apparent. Consider the 25 squares as a list or vector of 25 values, where each value is either 0 (for off) or 1 (for on). A particular state of lights is thus a list or vector of 25 0s or 1s. The effect of pressing a button is also such a list and its effect on a given state is the sum of these two vectors, where we mean that we add the corresponding entries and this sum is done (mod 2) which means that 1+1 = 0. (This means that we are just doing the addition of odds and evens: even + even a even corresponds to 0 + 0 = 0; odd + even = odd corresponds to 1 + 0 = 1; odd + odd = even corresponds to 1 + 1 = 0.) The effect of pressing a set of buttons is then the sum of the effects of their individual effects.

This structure is precisely the multiplication of a matrix times a vector, where the arithmetic is done (mod 2) as just described. We now formalise this.

A play of the game is a 25-vector x = (x1, x2, ..., x25) where:
xi=1 if the i-th button is pressed (or is pressed an odd number of times);
xi=0 if the i-th button is not pressed (or is pressed an even number of times).

The state of the game is another 25-vector b, where:
bi=1 if the i-th light is on; bi = 0 if the i-th light is off.

Consider the effect of playing the j-th button when all lights are off. This produces a state which is a 25-vector, which is best considered as a column rather than a row, but it is too difficult to type columns, so I will say the state is (a1j, a2j, ..., a25,j) where aij = 1 if the j-th button affects the i-th light; = 0 otherwise. Then the pattern or state b produced by the play x, starting from the all off state is given by bi. = ∑j=1 aij xj (mod 2 as always). If we consider b and x as column vectors and let A be the matrix whose i,j entry is ai,j then this is the matrix product: b = Ax. I write this out in full below.

40

If x is played from some initial state c, then the result is b = Ax + c. The general problem of the XL25 is: given that you are in state c and want to get to state b, what must you play? This now can be phrased as; given c and b, find x such that b = Ax + c, i.e. such that Ax = b-c. This is the same as getting to the pattern b-c from the initial pattern of all offs. Thus we only need to consider starting from this pattern, which we denote by 0 = (0, 0, ... , 0).

Solving Ax = b is one of the classic techniques of mathematics and there are many methods available, of which the simplest is direct step by step elimination. However, this takes a lot of work (something like 5000 operations), so I wrote a program to do it on my Sinclair ZX81.

Knight pattern. For 22 up through 52, the matrix A is invertible and one can write down A such that AA-1 is the identity, so that Ax = b if and only if x = A-1b. Thus each b has a unique x which produces it. For example, for the 52, one can light the whole board from 0 in 17 moves, pressing all the buttons except the 8 which are adjacent to the corners. If one applies this to a pattern, the result is to form the complement of the pattern.

In fact, there are only 6 types of single location on a 52 (just as there are only six types of piece on a 53 - see C3/4-19). If we number the board as shown at the right, these are the locations 1, 2, 3, 7, 8, 13. Single squares of each type are lit by the following sets of buttons:
1 - 1,2,5,6,8,9,12,17,20,21,24 (11 moves)
2 - 1,4,6,9,10,11,12,13,15,16,17,18,20,23,24,25 (16 moves)
3 - 3,6,7,9,10,11,15,16,20,21,24 (11 moves)
7 - 2,3,4,5,6,7,10,11,14,16,18,21,22 (13 moves)
8 - 1,5,6,8,10,17,19,22,24 (9 moves)
13 - 2,4,6,10,13,16,20,22,24 (9 moves)

I illustrate the last pattern on the right. This has the remarkable feature that to light the central square, we press it and then press the other 8 squares that it lights up! These diagrams allow you to solve any problem. However, do not use them to light up one square at a time -this would use 313 moves to light up the whole board instead of the 17 described above. Instead, you should superimpose the diagrams for the squares which need to be lit and only press those buttons which occur an odd number of times.

41

Since each pattern has a unique play which produces it, there are 225 = 335 54432 patterns and the average number of moves per play is 25/2 = 12 1/2.

Cross pattern. The behaviour for this pattern turns out to be more interesting. For the 22 and 32 boards, the matrix A is invertible. But on the 42 and 52 boards, it is not. The degree of invertibility for an n by n matrix A is the rank of A, which is n if and only if A is invertible. The rank is the number of independent rows of A and we denote it by r. Then n-r is the number of conditions which each vector Ax must satisfy, and Ax = b is solvable if and only if b satisfies these n-r conditions, and then the solutions form a set of dimension n-r, which in our situation means a set of 2n-r elements.

For the 42 board, the matrix has rank 12 and no single square can be lit!

For the 52, the matrix has rank 23. A vector b can be of the form Ax if and only if it satisfies ∑bidi = 0, where d is one of the following to vectors, d, e:
d = (01110 10101 11011 10101 01110)
e = (10101 10101 00000 10101 10101).
From this we see that only the points i where di = ei = 0 can be obtained as singly lit squares - namely 7, 9, 13, 17, 19. There are 223 = 83 88608 patterns which can be obtained from 0 (or from any given starting point) and each obtainable pattern has 22 = 4 solutions.

Although we cannot invert the full 25 by 25 matrix A, one can obtain a pseudo-inverse of it. Our two dependence relations expressed by d and e can be viewed as determining the values of squares 24 and 25 in terms of the values of the first 23 squares. If these conditions are satisfied, we need only consider the first 23 entries of a vector and the corresponding 23 by 23 matrix. This is invertible and applying its inverse to the first 23 entries of b yields a solution x using only the first 23 buttons. If b satisfies our two conditions, then its last two entries must agree with the last two entries of Ax, where x has been extended to 25 entries by adding two 0 entries at the end. If one wants to get the same pattern, using buttons 24 and/or 25, one adds d and/or e to x. (This last result is not true for any matrix A - it depends on A being a symmetric matrix, as it is in our problems.)

From d and e, we can see that lighting just square 1 of the first 23 requires us to also light square 25. This is because d1 = 0, e1 = 1.

Similarly, square 2 implies we must light square 24, while square 3 requires 24 and 25. Let us classify the squares according to which configuration of di and ei or of 24 and 25 they involve.

Case | di | ei | 24 | 25 | Squares
0 | 0 | 0 | 0 | 0 | 7, 9, 13, 17, 19
1 | 0 | 1 | 0 | 1 | 1, 5, 21, 25
2 | 1 | 0 | 1 | 0 | 2, 4, 11, 12, 14, 15, 22, 24
3 | 1 | 1 | 1 | 1 | 3, 6, 8, 10, 16, 18, 20, 23

These groups are shown on the board at the right. We now examine the effects of single buttons on these groups. Because of symmetry, there are just 9 types of button to consider 1, 2, 3, 6, 7, 8, 11, 12, 13. We denote the effect on groups 0, 1, 2, 3 by a quadruple a0, a1, a2, a3, where ai = 1 if an odd number of group i squares are affected; = 0 otherwise. Then the effects are as follows.

42

Buttons | Effect
1 | 0, 1, 1, 1
2, 6 | 1, 1, 1, 1
3, 11 | 0, 0, 0, 0
7, 8, 12, 13 | 1, 0, 0, 0

Hence we see that the effect of one button is always of the form a, b, b, b, so the effect of any play must also be of this form. Thus any obtainable pattern (starting from 2) must have the parities of the numbers of lights in groups 1, 2, 3 all equal. Thus only 1/4 of the possible patterns can be achieved. This gives us an elementary approach to the conditions obtained from the analysis of the matrix A, but it doesn't show that all the permissible patterns can actually be achieved, which the pseudo-inverse does show.

Robert Stein, the proprietor of Vulcan Electronics, kindly sent my comments on to the inventor, Laszlo Meero. Meero replied that he had obtained similar results, but not using the pseudo-inverse. As we have seen, each achievable state using the cross has four solutions. Meero has shown that each such state can be achieved in at most 15 moves.

Meero also considers the general problems of n buttons with each button affecting some lights. As before, we set up an n by n matrix A with aij = 1 if the j-th button affects the i-th light; = 0 otherwise. Meero says that A is solvable if we can turn on all lights, starting from 0, i.e. all lights off. He has shown that if A is symmetric (aij = aji) and reflexive (aii = 1), then A is solvable. I managed to prove this also, but I have not tried to verify the following results.

Meero has studied the cross pattern problem on the n2 board and he finds that A is invertible for the following:

n = 1, 2, 3, 6, 7, 8, 10, 12, 13, 15, 18, 20, 21, 22, 25, 26, 27, 28, 31, 36, 37, 38, 40, 42, 43, 45, 46, 48, 51, 52, 55, 56, 57, 58, 60, 63, 66, 68, 70, 72, 73, 75, 76, 78, 80, 81, 82, 85, 86, 87, 88, 90, 91, 93, 96, 97, 100. (57 values up through 100.)

These do not exhibit an obvious pattern! He has shown that A is invertible infinitely often and is non-invertible infinitely often and that the non-invertible cases have positive lower density. (I.e. the number of them up through x is bigger than some positive multiple of x for all large x.) A friend of Meero has studied fixed points in the same problem. A fixed point x is a play which lights up just the buttons of x, i.e. it is a solution of x = Ax. He finds that there are 2n of these. (The phrasing isn't clear if there may be more.) He also studies anti-fixed points, which are plays which light up the complement of the buttons pressed. For n even, there are 2n of these, while for n odd, there are none.

The knight pattern on the n2 has an invertible matrix if n != 6, 7, 8 (mod 9). (I.e. if n is not of the form 9a + 6, 7, 8.) I find this an intriguing assertion and I have not yet seen why this should hold. Meero says the 72 is a hard problem. Meero has also studied buttons with three states, but his description is too sketchy to reproduce here. Buttons with four states will lead to interesting ? complications since the arithmetic (mod 4) no longer has division and so the standard methods for solving matrices break down and must be replaced by more complex methods.

Clearly there are some interesting questions generated by this puzzle and some of the results sent by Meero are quite intriguing. Are there patterns such that A is invertible for all n? (Obviously the one button per light patterns are always invertible, but are pretty trivial.) What happens if we think of our board as toroidal - i.e. if a play goes off an edge, it comes back in the opposite edge?

43

CURIOUS CUBIC CORRESPONDENCE

I have received a number of amusing letters. I reproduce them below, but the names have been deleted to protect the innocent!

Dear Sirs(o):
I am inquiring into the cube. I'm find my mistakes to be in the adaptation "of the cube" to the primary purpose of which it should have achieved. Please respect.

(This one came from Florida and was addressed to my Department.)

Dear Sir
I was a full time Ph.D. Student in Computer Science until I discovered the "Magic Cube" (please include my name in the list of possible candidates for your television advertisement) which has converted me to a full time Student in Group Theory (a subject I very much hated in my under-graduate days) and part time Student in Computer Science.
To ease our suffering (another two Ph.D. Students who have also become part timers) please send us 3 copies of ...

Dear Sir,
My name is .. . and I live in (Italy). Some time ago I bought the excitant puzzle invented of the now famous engineer Ernö Rubik; I am talking about the cube wich from several time is doing to become insane the west. Is for avoid of be involved in the exasperated multitude who I write it, and I enclose 3 U. 5. dollars for receive his book: "Notes on the Magic Cube". I thank you in advance for your collaboration and I beg you to accept my more friendly regards.

Dear Mr Singmaster,
Recently a friend of mine acquired a Magic Cube through ... from you. Since I first played with the cube I have become a nervous wreck, failed my finals and torn out a large proportion of my hair. They say it is because I did Physics that I haven't cracked the problem yet - but I'll show them I'm not that stupid. The trouble is, our term will soon be ending (a fortnight in fact) and then I'll be cubeless.
Please would you help to keep up your record and not only ruin my degree but also get me the sack from my new job. I'll tell you something else - I'm a sadist - so I would appreciate it if you would help to ruin two other lives, those of my brother and a friend.
You can do all this by sending me three Magic Cubes ...

Mr. David Singmaster
I am any one more many amateur to the "Rubik's Cube", of whom frigthen me his utility for Maths. I am studying Maths.
Thoug, still I haven't some deeps acquaintances about "cube" I pretend to profite the best of his possibilitys.
Then, I would like acquire yours "NOTES ON RUBIK' MAGIC CUBE" and, I am sure, they will be for me very usefuls.
I secure you my cooperation in all that think can be of your interest.
I will await your notices with impatience. Thank you very much.

Mr Singmaster,
My name is ... I am a student of .., at ... I read in our newspaper a text about yours book "NOTES ON RUBICS MAGIC CUBE". I am very interested on it as a long time (about 18 months) I tried and successed to make it well. I can do it (cube) for a one till two minutes. I know a several systems. In our newspapers I found many texts about magic cube, but I didn't learn any new thing from them.
I would like to read your book in originale because I can't bye it in Yugoslavia. Translate of your book is not done yet, and it wouldn't be soon. So, I would like to have your book, and I beg you to send me one copy of it. if you can't send me a book, please send me some texts about magic cube.
I am sorry of my bad English but I think that you will understand this letter.
Thanks in advice.

44

One of the shortest letters received was the following.

Thank-you David
Thank-you David
Thank-you David

Sir:
Here is your dollar extra ...
I strongly suggest you apply for sainthood - your notes have finally made me the cube's master and not the other way around: I Thank you.

The well known science fiction writer Arthur C. Clarke wrote from Sri Lanka, asking for a copy of the Notes, which was duly sent. He sent a card of acknowledgement.

Dear Cubemeister Singmaster,
Thanks for the booklet, I hope to spread the plague in Sri Lanka as soon as I get back.
Meanwhile I wonder what the record time is for the coward's way out, with screwdriver...

William W. Erdis, of County Antrim, couched his request in verse.

Dear Sir,
Oh please your book you must send
This Cube I've got has me round the bend,
I can do face's and crosses.
But all side faces has me at losses.
At the top of the page my address you'll see,
I will be ever so grateful
If you will send to me.
THE NOTES ON RUBIC'S MAGIC CUBE

(Mr. Erdis's typing is a bit erratic - the end of the fourth line is at lost,es which might also be rendered at loss, yes ??)

The following letter is perhaps the most startling and amazing that I received. Among other things it was dated 30 November 1981 and we received it on the 14 November 1981! Part was written in red ink and some parts were doubly written in red and blue. I will underline the red material and enclose the double coloured material in *s.

APPLICATION.
I AM IN TROUBLE

Dear Sir, David.
Your RUBIK'S MAGIC CUBE how it has surprise many people only God knows.
Is that when I read the book and I esplaned to them. About 200 people was'ent believe it at all, only 2 people believe it. *I also believe it.* I am a young boy of 20 years. How I told people.

45

I went to our Chief here, and told him what I have read, and said I'd like people also to hear it, and he gave me a Note. I finish only *30 minuts*, When I finished, the chief called the people. After meeting they told me this: Young boy, you have waist our time and so write to David Singmaster and ask him Rubik's Magic Cube. IF he gave it to you then it's true story but IF he did'nt gave it to you, please you'll be in prison. They have given me only 4 (FOUR) months. If four months, I did'nt have I will be in trouble. Please because of your wonderfull thing am in trouble.
Sir, all the thing I have said to you. Give me, to show them, so that I will set Free they are worry me too much mm! mm! mm!
Thank you for your co-opration and attention I remain
Yours faithful

(The author's writing is occasionally hard to decipher, but I think I've managed. Needless to say, I sent him a copy of the book and a letter and some other material, but it was not clear to me if his people did not believe in the existence of the cube or in the solution method. I never had a reply - I hope he's all right!)

A 43 COMPETITION

I have only heard of one Rubik's Revenge (= 43) Competition. This was organised by the Daily Star, a UK newspaper, on 25 June 1983. Julian Chilvers, the UK Rubik's Cube Champion, was best with a time of 119 sec. He won a Ford Fiesta 950 painted all over with cubes. Unfortunately, he's too young to drive and so he sold it.

1000DM IN PRIZES

In his German book, Christoph Bandelow offered 1000DM (= £263 = $368) in prizes for the best process for forming the Superfliptwist pattern. This has all edges flipped in place and all corners twisted in place, with adjacent corners having opposite twists. Thus the corners with positive twist form a regular tetrahedron. The winning solution came from Rainer aus dem Spring of Oberhausen.

UFs2Rs2U'.L'U2Fs'L2U'F'B'U2L'FsRs'F2B (22)

The contest was dropped from the English edition, but Bandelow has said he will give some prize for any improvement on this. This is thought to be a likely candidate for a most difficult position to achieve. I cannot readily see if this is a local maximum in Hoey and Saxe's theory, and I cannot see that my argument on C5/6-24 works. Wait, I think it does work - the symmetries which preserve the tetrahedron of positively twisted corners is certainly enough to take any face to any other, and the mirror image of the pattern is again itself, so we also get all the inverses of faces. So the argument is the same as for the 12-flip and the superfliptwist should be a local maximum.

[ Whether you count a half turn as a single move or as two, the sequence URF'BU'D'FU'DFLF'L'URDFURL found by Mike Reid is the shortest possible at 20 moves. - J ]

A CUBIC SICK JOKE

What goes 'Click-click - have I done it?'
A blind man doing the Rubik Cube.

From: Michael Kilgarriff. Oh No! Not Another 1000 Jokes for Kids. Ward Lock, London, 1983.

46

RUBIK'S FOUNDATION

Hungarian Exporter 33:9 (Sep 1983) 7-8 gives the moat detailed account of the founding of the Rubik Innovation Foundation. Rubik has contributed 7 million forints to establish a foundation to assist Hungarians in 'the practical realization of innovative ideas'. Since the forint is a controlled currency, it is a bit difficult to translate it into western amounts, but I recall rates of about 70 forints to the pound a few years ago. (I've just rung the Hungarian Embassy and they say it is currently 62 forints to the pound.

YOUNGEST CUBIST?

M. Antony, of Cochin, India, reports that his daughter, then 5 years, 1 month and 11 days old, can do the cube from any position in under three minutes. This is certainly the youngest genuine solver that I know of. (But compare C2-4 and C5/6-4.)

CUBIC MAIL BOX

Michael van der Riet has built a cubical post box in front of his house in Bellville, South Africa.

RUBIK CUBIK MAGIK

Magicians may be interested in a book with this title, by Kennedy Smith, published by Kanda Publications, Falkirk, 1982. It gives Ii magic tricks using the Cube as a prop. You will probably have to get it at a magic shop - I got mine at Davenport's, Charing Cross Underground Arcade, London.

A NOVEL APPEARANCE

Alastair Shepherd has found a novel entitled "Rubik's Cube". It is by Leela Dutt and was published by Gee & Son, Ltd., Denbigh, Clwyd, Wales, 1984. The back cover blurb says it's about Cruise missiles in South Wales - "like the squares on Rubik's cube, the pattern gets muddled". On p. 13, we find the following passage.

"... Oh, by the way - she gave him one of those Rubik's cubes yesterday."
"What's that? Oh, I know, my kids used to have one."
"You don't see them about so much now, but there was quite a craze for them in the early eighties - do you remember? My two were too small to do it."
"Yes, I remember. I could never work out what you were supposed to do with the darn thing."
"It was lovely when he first brought it home - all smooth and shiny, with all the colours in the right place. Just right. The trouble is, as soon as you give it a few twists, it all gets muddled up and you can't get back to where you were."
"I always thought they were rather boring. I suppose you have to have that sort of mind...."

47

THE HISTORY AND FURTHER TRIALS OF THE CUBE

In C5/6-23/24, I discussed the prehistory of the cube. I have now seen William G. Gustafson's US Patent 3,081,089 of 12 March 1963 for a 'Manipulatable Toy'. This is a spherical 23.The construction is basically a grooved sphere, with pieces sliding on it. However, his first version is unsymmetric in that the spherical-triangular pieces have a lip only at one corner. The eight lips meet in fours at two antipodal groove crossings and reach in under the groove edges to provide the holding mechanism. It is difficult to see that this does give a fully moveable cube or sphere. It does seem that this is a rather loose mechanism and he gives a second, symmetric, version where each piece has lips at all three corners. Gustafson's pieces do not abut edge to edge - one can see the interior sphere between any two adjacent pieces. Consequently one can relate the exterior pattern to the inner sphere and this gives 24 times as many overall patterns as for an ordinary 23. Interestingly, he does not attach any piece to the central sphere - instead he has detents to let you align the pieces with the grooves on the central sphere. It may be that the need to do this required the interior sphere to be visible.

The suit described in C5/6-23/24 went to trial in late January 1984 in Wilmington, Delaware. Jerry Slocum, the world's leading puzzle collector, was an expert witness for Moleculon for four days of the nine days of the trial. In his opinion, the cubical shape with coloured faces was a major advance over Gustafson's patent. Gustafsen has admitted that he had not realised the puzzle aspects of his device. Further, Slocum's study of the patent and puzzle literature revealed no other 'prior art' for this sort of puzzle. Although it now seems obvious to go from the sphere to the cube, neither Gustafson nor anyone else had done so prior to Nichols. Consequently the court ruled, on 2 October 1984, that Nichols' patent was valid and that Ideal (since taken over by CBS) had infringed on that patent.

However, the story is not yet over. The court must assess what damages to award to Moleculon. There is no doubt that Nichols did not have an effective mechanism. His magnets make it too easy to cheat. This may have been a factor in the universal rejection of his device by the toy trade when Moleculon tried to sell it in the early 1970s. a have also heard that Gustafson tried to market his sphere and was rejected by 80 companies.) All parties are agreed that Rubik's invention was independent. I cannot see that anyone can doubt that Rubik's mechanism represents a major improvement over Nichols' patent and hence it deserves the major credit for the success of the Rubik Cube. In view of this, I would predict that the court will award only a small fraction of the damages sought.

As I have said, the mechanism is the most wonderful part of the Cube. I, and most other people, will continue to acknowledge this by continuing to call it Rubik's Cube.

A RUMOUR

Douglas Hofstadter told me about two years ago that he had heard a rumour that a Princeton undergraduate had shown that God's Algorithm for the 33 had maximum length 26. However, I've heard nothing more of it, so it seems unlikely.

[ This rumour reached the Cube-Lovers mailing list in July 1984, but no one was ever able to confirm it. - J ]

48

SOME PYRAMINX VARIATIONS

Mèffert made an octahedral version of the Pyraminx, but only in sample quantities. It is shown of the lower left. Several other versions appeared, even in Poland!

The first truncated Pyraminx was a crude version made in Canada by Rubin's Toy Company.
[ It is now generally known as Tetraminx, and is manufactured by Mèffert. - J ]
The second version looks like a sphere cut by three tangent circles. It came from Taiwan. The truncated octahedron also came from Taiwan. It is a pleasant shape, especially when sitting on a hexagonal face.

A MAD COMMENT

The UK edition of Mad Magazine for November 1984 ha a cartoon showing a Boob Cube (C3/4-9) in a feature on 'Simple Games and Pastimes for the School Drop-Out.' The cartoon is labelled somewhat obscurely 'Two-colour Rubik Cubes'.

© David Singmaster

Home
Links
Guestbook


Skewb Diamond

Picture kindly supplied by Uwe Mèffert

The Skewb Diamond is an octahedron which is bisected 4 ways, by planes inbetween and parallel to two opposite faces. Any face can be turned through 120 degrees in either direction, moving exactly half the puzzle. The puzzle consists of 8 triangular face centre pieces and 6 corner pieces.

The Skewb Diamond is closely related to the Halpern-Meier Pyramid (see Pyraminx) and the Skewb, which also have 4 axes of rotation. The six corner pieces of the Diamond correspond to the 6 edge pieces of the pyramid. The 8 face pieces of the Diamond correspond to the corners and faces of the pyramid, except that on the Diamond none of the face orientations are visible. Similarly, the six corner pieces of the Diamond also correspond to the 6 face pieces of the Skewb except that orientations are visible, and the 8 face pieces of the Diamond correspond to the corners of the Skewb but without visible orientations.

My solutions for the Skewb will also solve the Diamond. The solution below is slightly faster however.

Note that turning one face has the same effect on the puzzle as turning the opposite face the other way. Therefore the puzzle can be solved by only using one of each pair of opposite faces. Internally 4 of the face centres are fixed on axes, and the other 4 are moving pieces. Externally there is no visible difference between the two sets. In the solution below we will use only one of these sets and call these the fixed face centres, and the other faces are called the free face centres. This internal mechanism not only makes clear that the two sets of face centres cannot be mixed together, it also shows the corners have only two orientations.

The number of positions:
There are 4 fixed faces, 4 free faces, and 6 corner pieces with 2 orientations giving a maximum of 6!·4!·26 positions. This limit is not reached because

  • The corners must have an even permutation (2)
  • The free faces must have an even permutation, and hence form a tetrad (2)
  • The number of twisted corners must be even (2)
This leaves 6!·4!·26/8 = 138,240 positions.

A computer search gave the following result:
0 | 1
1 | 8
2 | 48
3 | 288
4 | 1,632
5 | 8,568
6 | 36,114
7 | 74,799
8 | 16,547
9 | 220
10 | 15
Total | 138,240
This shows that any position can be solved in at most 10 moves.

Links to other useful pages:
Meffert's puzzles Uwe Mèffert's pages has a solution here. Mèffert produces and sells this puzzle, the Pyraminx, Megaminx, Skewb, and many others.

Notation:
Hold the Diamond with one face at the front with one corner pointing upwards. The set of 4 fixed faces that you will use in solving the puzzle lie on the down, left and right sides (adjacent to the front face) and the back side (opposite to the front). You will only turn these four faces, not the others, and the fixed centres of these faces show which colours these faces should have. Denote 120 degree clockwise turns of the faces by L, R, D and B. Anti-clockwise turns are denoted L', R', D' and B'. Any corner can be specified by two letters, e.g. DR is the corner where the down and right faces meet. The 4 free face centres can similarly be specified by 3 letters.

Solution:

Phase 1: Place the three top corners correctly.

  1. Find a corner piece in the D layer which belongs in the top layer. If there are no such pieces, then choose any corner in the D layer to use to displace an incorrectly placed corner from the top layer.
  2. Rotate the whole puzzle so that the corner piece belongs (or is to displace the corner piece) at the LR position (the top front corner).
  3. Turn D to put the corner piece at the back (at DB).
  4. Do one of the following to place the piece in the correct position, with the correct orientation:
    1. To move DB to LR, do R'D'R.
    2. To move DB to RL, do LDL'.
    If you choose the wrong one, you can use R'BD'RL' to flip the LR position in place. This is also useful if in step a you only have flipped corners in the top layer.

Phase 2: Place the other three corners correctly.

  1. Rotate D to put its corners in position, though they may have the wrong orientation.
  2. If some corners in the D layer need to be twisted around, turn the puzzle around the D axis so that the corners to be twisted lie at the front of the puzzle (at DR, DL to be precise). Then do DL'BRB'L. The corners should now be correct.

Phase 3: Place the free face centres correctly.

  1. If one of the face centres is already correctly positioned, then hold the Diamond so that the correct centre lies in the top face. The other three centres need to be cycled around, and this is done by performing the sequence LR'L'R'LR'L'R' to move them anti-clockwise around D, or RLRL'RLRL' to move them clockwise.
  2. If none of the free face centres are correct then hold the diamond so that the top and front centres need to be swapped around and do RDRDRB'L'B'L'B'.

Home
Links
Guestbook


Dogic

Picture kindly supplied by Hendrik Haak

This beautiful puzzle has the shape if a regular icosahedron. Its 20 triangular faces are divided into 4 regular triangles. There are two types of moves: Twisting the 5 complete faces meeting to a vertex (face twist), or the 5 small triangles at a vertex (tip twist).

When the puzzle is solved, each vertex has 5 triangles of the same colour. The central traingles of each face have three colours, and these should match the adjacent triangles.

I have taken mine apart to see how it worked, and found that it is made of an amazing number of parts. There are 60 vertex triangles, 20 central triangles each with 3 inlaid coloured parts, 60 internal pieces to keep the vertex triangles together, 30 internal pieces to keep the central triangles together, a central piece with twelve axes each with two rotating parts and a screw. This gives an incredible 267 pieces (or 194 moving parts)

The number of positions:
There are 60 tip pieces and 20 centres with 3 orientations, giving a maximum of 60!·20!·320 positions. This limit is not reached because:

  • only even permutations of centres are possible (2)
  • the total twist of the centres is fixed (3)
  • some tip pieces are indistinguishable (5!12 )
  • the orientation of the puzzle does not matter (60)
This leaves 59!·20!·319 /2 /5!12 = 21,991,107,793,244,335,592,538,616,581,443,187,569,604,232,889,165,919,156,829,382,848,981,603,083,878,400,000 = 2.1·1082 positions.

Despite its apparent complexity, the solution is not very difficult.

Solution:
Phase 1: Solve tips to correct the faces.

  1. Choose any tip triangle that is not adjacent to a correctly coloured centre piece. Say the tip has colour A, and it's centre has colour B. Use any face twists necessary to place a face next to it at the same vertex which has tip colour B, and centre colour C. Similarly put faces next to that with colours C and D, D and E, and finally if possible E and A.
    If there is no incorrect tip with the colours E and A, the final tip at the vertex may have only one of the colours, or even none but then it should be a tip that is not already matched correctly.
  2. Now twist the tip, matching the colours.
  3. Repeat the above as often as necessary, until there are no incorrect tips left.

A few hints:
1. Use faces which have 2 or 3 unmatched tips before using those with only 1.
2. The colours A-E above need not be all different. For example, if you end up with only two unmatched tips, places them at a tip with 3 matched pieces of one of the colours.

Phase 2: Solve faces.
This phase is exactly equivalent to the solving of the Impossiball. See there for the details.

Home
Links
Guestbook


Domino

Picture kindly supplied by Hendrik Haak

This is like a 2x3x3 Rubik's cube. The side which are 2x3 can obviously only do half turns. The top and bottom layer have different colours, and the pieces are simply numbered 1-9 with dots.

The number of positions:
There are 8 corners and 8 edges, giving a maximum of 8!·8! positions. This limit is not reached because the orientation of the puzzle does not matter. This leaves 8!·8!/4 = 406,425,600 positions.

Notation:
Let the 4 sides be denoted by L, R, F, B (left, right, front, back), and the top and bottom by U and D (up, down). Clockwise quarter turns are U and D, half turns U2 and D2, and anti-clockwise turns U' and D'. Sometimes a sequence in brackets is followed by a 2 or 3, indicating that the sequence as a whole is to be repeated two or three times.

Links to other useful pages:
Cyril Castella's page. A French solution.
The Twisty Megasite shows a domino mechanism that Wayne will try to make.

Solution:
Phase 1: Solve the top layer corners.

  1. UFL - If not in the U layer, turn a side to get it there and hold the domino so that it is in the correct corner.
  2. UFR - If in U layer but not correct then do B to put it in D layer. Rotate D until it is at DBR and then do R.
  3. UBR - If in U layer but not correct then do B to put it in D layer. Rotate D until it is at DBL and then do B.
  4. UBL - If not correct then rotate D until it is at DBL and do BDBD'B.
Phase 2: Solve the bottom layer corners.
  1. Use one of the following:
    1. Swap DBL and DBR. Do D(RURU')2 FRU2.
    2. Swap DFL and DBR. Do RD2FD(FD2FD)2.
Phase 3: Move the edge pieces to their correct layer.
  1. Turn U/D to get a position where you can use one of the following:
    1. Swap DL-UR. Do R(D2F)3R.
    2. Swap UF-DF and UR-DR. Do (FR)3.
    3. Swap UF-DF and UB-DB. Do FRLBRL.
Phase 4: Solve the edge pieces of the bottom layer.
  1. Rotate the whole domino to get to a position where you can use one of the following:
    1. Swap DF-DR. Do FUFU2RFU2FRUF.
    2. Swap DF-DB. Do (D2 R)3.
    3. Swap DF-DB, DL-DR. Do FRLBU FRLBD'.
    4. Swap DF-DR, DL-DB. Do FBD FRLBRL D'BF.
    5. Cycle DL->DF->DR->DL. Do FD'(FRD2R)2 DF.
    6. Cycle DL->DB->DR->DF->DL. Do RLB FBU FRL BL D2RD2R.
    7. Cycle DL->DF->DB->DR->DL. Do RDFBDFD' FB D'RD2 .
Phase 5: Solve the top layer edges.
  1. Turn over the domino.
  2. Repeat phase 4.

Home
Links
Guestbook


Equator

Pictures kindly supplied by Hendrik Haak

This sliding-piece puzzle is a ball with three intersecting rings of moving pieces which divide the ball into eights. There are 12 square shaped pieces each ring, making 30 pieces in all because there are 6 places where the rings intersect. There is no space so the pieces do not move singly. Instead, all 12 pieces of a ring are shifted as one.

Note that the pieces come in inseparable antipodal pairs; pieces on opposite sides of the puzzle will always stay that way. Solving a piece on one side will automatically solve the piece on the other.

There are two versions of this puzzle, which differ only in the colour scheme. The Hungarian Globe simply has a map of the earth on it, like a proper globe. The Equator version has a simple colour scheme. Four quarters of the puzzle have a different colour. Thus the pieces at the poles have 4 colours, the pieces on the vertical rings have two, the remaining pieces only one. The solution below should work with any version of the puzzle.

The number of positions:
Let's consider the Hungarian Globe first. There are 15 pairs of pieces, which can be placed in a position in 8 ways, giving a maximum of 15!·815 positions. This limit is not reached because:

  • No pair can be twisted a quarter turn in isolation (2)
  • The parity of the tile permutation is the same as the parity of the tile pair permutation (2)
This leaves 15!·815/4 = 11,502,425,383,685,056,364,544,000 or about 1.1·1025 positions. Note that the second constraint arises from the fact that moving a ring one tile is an odd permutation on the 12 tiles and also an odd permutation on the 6 tile pairs. This means it is impossible for example to swap two antipodal tiles without moving anything else (though on the Equator puzzle that situation does occur because that has identical tile pairs).

The Equator is simpler. Here the limit of 15!·815 is not reached because:

  • Four pairs are monochrome so orientation does not matter (44)
  • There are several indistinguishable pairs (2!·2!·5!·5!)
This leaves 15!/(2!·2!·5!·5!) · 811·24 = 3,120,232,580,209,704,960 or 3.1·1018 positions.

This solution below should work with all colour schemes.

Notation:
The Hungarian Globe will naturally be held with the North pole on top. On the Equator puzzle the 4-coloured pieces are considered to be the poles, so it is held so that the 4 top triangles have different colours. The equatorial ring and one of the vertical rings intersect on the front and the back of the puzzle.
The equatorial ring is moved Left or Right, denoted by L and R. The vertical ring going through the front goes Up or Down, denoted by U and D, while the other one goes Clockwise or Anti-clockwise, denoted by C and A. These letters are followed by a number indicating how many squares to move, so R3 means rotating the equator to the right a quarter turn.

Solution:
Phase 1: Solve the front vertical ring (except pole/equator pieces).

  1. First find a piece that is to be placed on the front vertical ring (a two-coloured piece on the Equator puzzle). If the piece lies on the other vertical ring, then turn it (C or A) to the equator.
  2. Hold the puzzle so that the destination of the piece is one of the two places between the front and the top (north pole). Turn the equator (L or R) until the piece is at the front.
  3. There are 8 possibilities, depending on the orientation of the piece, and whether it is to move up one or two squares.
    Twist needed | Up 1 square | Up 2 squares
    None | R1 D1 L1 U1 | R1 D2 L1 U2
    Clockwise | L3 U2 C3 D2 | L3 U1 C3 D1
    Half turn | R1 U5 R5 D5 | R1 U4 R5 D4
    Anti-clockwise | R3 U2 A3 D2 | R3 U1 A3 D1
  4. Repeat steps a-d until the ring is solved.
Phase 2: Solve the other vertical ring.
This is done exactly the same way as the first vertical ring. Rotate the whole puzzle left or right a quarter turn, and repeat Phase 1. Afterwards the first ring will not have been disturbed except that it may have been rotated by a quarter or a half turn. Simply re-align it when you have solved the second ring.

Phase 3: Solve the poles.

  1. If the North and South pole pieces are already at the pole positions but not correctly oriented, then bring them to the equator by D3 R1 U3.
  2. Rotate the equator to bring the North pole piece to the front.
  3. Now place it on the pole by using a method similar to phase 1:
    Twist needed
    None | R1 D3 L1 U3
    Clockwise | A3 L3 C3
    Half turn | R1 U3 R5 D3
    Anti-clockwise | C3 R3 A3

Phase 4: Orient (most of) the equatorial pieces.
In this phase the actual position of the pieces on the equator is ignored.

  1. If possible, find any two pieces on the equator (which are NOT an antipodal pair and) which are not in the correct orientation and both need to be twisted the same amount. Note that on the Equator puzzle, you can choose a monochrome piece as one of the two pieces if necessary.
  2. Turn the equator to bring one of the two twisted pieces to the front.
  3. Do one of the following sequences to twist the pieces:
    Clockwise | U3 R3 C3 R? L3 A3 L3 D3
    Half turn | U6 R? D6
    Anti-clockwise | U3 L3 A3 R? R3 C3 R3 D3
    The ? stands for any amount that puts the second piece to be twisted at the front.
  4. Repeat steps a-c as often as possible.
  5. On the Equator puzzle, all pieces will now be correctly oriented because of the monochrome pieces. On the Hungarian Globe you may still be left with one antipodal pair that needs a half turn. To rectify this, use the first or third sequence above to twist the pair a quarter turn, together with any other pair. You now have two pairs which need a quarter turn, so you can again use the first or third sequence to twist those two pairs correctly.
    Alternatively, turn the tile to the front and do the sequence:
    C3 D3 A3 U3 L3 U3 R3 C3 D3 A3 L3 A3 R3 C3
    Note that this does not disturb any other pieces.
Phase 5: Position the equatorial pieces.
The phase is actually quite easy, but hard to explain.
  1. The tile at the front will be used as a reference point, and one by one matching tiles will be placed alongside it until (most of) the equatorial ring is solved. Call this front tile, tile f.
  2. Find the tile belonging to the right of the front tile. Call this tile r.
  3. Turn the equator to bring r to the front, and do U1 to lift it out of the equator.
  4. Turn the equator to bring f to the front, and do L1 D1. This brings down tile r next to tile f, so that they match. The tile below the front will be incorrect, but that will be corrected later.
  5. You will now essentially keep repeating steps a-d, lifting up pieces up from one place and dropping them elsewhere in the equator, at the correct position relative to the previously moved tiles. Continue until the equator is (nearly) solved.
  6. If it is not solved, then only one antipodal pair on the equator is incorrect, as well as the tile just below the front and its antipode. Examine that tile below the front, find the position in the equator where it should be and turn that to the front. The following simple sequence should now solve the puzzle:
    R1 U1 R1 D1 R1 U1 R1 D1 R1 U1 R1 D1.
    Note how each tile on the equator is removed and placed back one tile further.

Home
Links
Guestbook


14-15 puzzle / Boss puzzle

1 | 2 | 3 | 4
5 | 6 | 7 | 8
9 | 10 | 11 | 12
13 | 15 | 14 |

The standard sliding piece puzzle is often called the 15-puzzle. It consists of a square tray containing 15 square tiles and one open space in a 4x4 arrangement. The tiles are usually numbered 1 to 15, or have some kind of picture on them. Any tile lying next to the space can slide into it, and so the tiles can be mixed up. The aim is to get them back in order; either so that the picture is restored, or so that the numbers are in numerical order from left to right, top to bottom, with the space at the bottom right.

This puzzle is often attributed to Sam Lloyd. This is not entirely true. He did not invent the puzzle, but he did invent the 14-15 puzzle, the variation in which the tiles numbered 14 and 15 are swapped, with all other tiles in place. In the 1870's he offered a $1000 prize for whoever could solve this. He knew however that this puzzle could not possibly be solved. Suppose the inside of the tray containing the tiles has a checkerboard pattern. Sliding a single tile will then always change the colour visible in the space. Any sequence of moves that brings the space back to where it started will therefore have an even number of moves. A single move can be considered to be a swap between the space and the tile, and an even number of moves is therefore an even permutation. A single swap of the tiles 14 and 15 is an odd permutation and hence not possible.

A very neat variation of the puzzle has a single letter on each tile, which when solved says 'RATE YOUR MIND PAL'. The first two words have different colours from the last two words. Here the 14-15 swap is possible, i.e. you can start with 'RATE YOUR MIND PLA' and solve it. The reason is that there are two identical tiles, the R's in the first two words, which can be swapped too. Making two swaps is an even permutation and therefore possible. Some puzzles which have a picture on them are also designed so that they have two identical tiles.
R | A | T | E
Y | O | U | R
M | I | N | D
P | A | L |

The puzzle is usually a 4x4 square, with 15 square tiles. It could also be made with different dimensions, say a 5x5 square or 3x7 rectangle. This does not make the puzzle much more difficult.

The number of positions:
The standard version has 15 pieces and a gap, giving a maximum of 16! positions. This limit is not reached because the permutation must be even or odd depending on the position of the gap. There are therefore 16!/2 = 10,461,394,944,000 positions, or 15!/2 = 653,837,184,000 positions with the space in one particular spot.

Links to other useful pages:
Dozens of pages have similar versions of this puzzle, so only a small selection of more unusual links is given here.
Cut-the-knot has a Java version of the game here as well as some history of it.
Harry Broeders' page has a Java and a downloadable Windows version which have a built-in solver, and can have different sizes or designs. Also a page with some history.
Puzzle World has an article on how many moves it takes to solve the puzzle.
David Singmaster's large list of references.

Solution:
This solution will work on all sizes.

Phase 1: Solve the top row.
You will solve the row from left to right.

  1. Find the next tile you want to place in position in the top row.
  2. If it is not the last tile of the row, it is fairly easy to place correctly, simply keep the following points in mind:
    1. Never disturb any previously placed pieces.
    2. To move the tile in a certain direction, move the other tiles around until the space is next to your tile on the side you want to move it to. Then you can move the tile.
  3. If the last tile is not already in position, bring it to the position directly below its correct spot, with the space directly below that. Then move tiles in the following directions: Down, down, right, up, left, up, right, down, down, left, up. This should place the piece in position. Note it does temporarily disturb the previously placed tile.

Phase 2: Solve the rest of the puzzle

  1. Use the technique in phase 1 to solve each row in turn, until there are only two rows left.
  2. Rotate the puzzle a quarter turn to the right. The left column of the two rows becomes the top row now.
  3. Use the technique in phase 1 to solve each row in turn, until there are only two rows left. This means there is only a 2x2 square left to solve.
  4. Move the pieces in the remaining 2x2 square around until one piece is positioned correctly, and the space is in the correct spot. The other two tiles should automatically be correctly positioned as well.
  5. If there are two tiles that need to be swapped, then this cannot be done unless two other tiles are swapped as well. If there are two identical tiles somewhere in the puzzle, then you will have to swap them and solve the rest again.

If you wish to solve a puzzle so that the blank space ends up in a position other than the bottom right corner, then you can still use the same method. Whenever the next unsolved row should have the blank space in it, then turn the puzzle upside down so you can start solving the remaining area from the other end. Eventually the remaining unsolved area is still reduced to a 2x2 square, but this time that does not lie in the bottom right corner.

There are quicker ways to solve the last two tiles of a row. One good way is first to place the last tile in the position of the next-to-last one, and then place the next-to-last tile in position (which displaces the last tile to its proper place).

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Gripple

Picture kindly supplied by Hendrik Haak

This simple puzzle has numbered and coloured pieces arranged in a 4×4 square. There are 5 knobs on the back of the puzzle with which you can rearrange the pieces. Turning a knob will cause a 2×2 sub-square of pieces to rotate. You can turn the four centre pieces, or the 4 pieces at each corner. The aim is of course to unscramble the pieces, restoring the starting position.

The original version of Gripple was marketed by M-Squared Inc. in 1989. There are 4 colours, with four pieces of each. In the solved position, the four pieces of a colour are together in a 2x2 square. Its pieces are numbered 1 to 16 in the obvious manner. There is also a Russian version, but here the pieces of each colour are numbered 1 to 4.

Links to other useful pages:
Java gripple (without numbers) with built-in solver.

The number of positions:
There are 16 pieces, so these can be arranged in at most 16! ways, and all these can in fact be reached. The orientation of the pieces is completely determined by their position, so there are 16! = 20,922,789,888,000 possible positions. Note however that there is more than one solution, as the puzzle can be solved in any of the four orientations, so there are 4 solutions. Furthermore in the Russian version, the 4 colours can be arranged in 4! ways in the solution, which means that is has 4·4! = 96 solutions.

Notation:
In the solution below I will only need to use a notation for the top left corner square and the middle square. Call a clockwise twist (when looking at the front of the puzzle) of the top left corner C, a half turn is then C2, and a counter-clockwise turn is C3. Similarly moves of the middle square are called M, M2, and M3.

Solution:

Phase 1: Solve the three edge pieces of the top left square.

  1. First solve the top left corner piece as follows:
    1. Find the piece belonging at the top left corner of the top left square.
    2. If it is not somewhere in the middle square, then you can always make a single move to bring it to the middle.
    3. Turn the middle square to bring the piece into the top left square.
    4. Turn the top left square to put the piece into position at the top left.
  2. Now solve the top right piece of the top left square as follows:
    1. Find the piece belonging at the top right corner of the top left square.
    2. If it lies at the bottom left of the top left square then C3 M C2 M3 C3 will solve it.
    3. If it is not somewhere in the middle square, then you can always make a single move to bring it to the middle.
    4. Turn the middle square to bring the piece into the bottom right square.
    5. Do C M2 C3 to put the piece into position.
  3. Finally solve the bottom left piece of the top left square as follows:
    1. Find the piece belonging at the bottom left corner of the top left square.
    2. If it is not somewhere in the middle square, then you can always make a single move to bring it to the middle.
    3. Turn the middle square to bring the piece into the bottom right square.
    4. Do C M2 C3 to put the piece into position.

Phase 2: Solve all the other edge pieces.
The edge pieces of the other corners can be solved in the same way. You can simply turn the whole puzzle so that an unsolved corner is at the top left and go through phase 1 to solve it. Do this for each corner.

Phase 3: Solve the centre.

  1. Turn the centre so that at least two of its pieces are correct.
  2. To swap two adjacent pieces in the center, hold the puzzle so that the two pieces to be swapped are at the top of the centre square, and do C M2 C3 M3 C M3 C3 M3.
  3. To swap two non-adjacent pieces in the center, hold the puzzle so that the two pieces to be swapped are at the top left and bottom right of the centre square, and then do M C M3 C3 M C M C3 M C M3 C3 M. Alternatively you can simply perform the sequence in step b above to swap any two adjacent middle pieces, and then you will find that you have to swap two other adjacent ones to solve it.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Jaap's Puzzle Page Guestbook

Please Add to this page here.

Press Reload on your browser if you do not see any new messages added since your last visit.

Excellent site. Some math related to permutations and designs made with cubes can be found at my website, http://m759.freeservers.com .
Steve Cullinane <m759@post.harvard.edu>
- Wednesday, December 19, 2001 at 00:22:19 (GMT)
i need help with my cube. my cube only has 3 sides with stickers on it. and it is scrambles at the moment. and i can't place more stickers on it until i get the 3 sides that have stickers done. and all the solutions you have. require me to have all sides with stickers. i was told that there is a way to do it by doing four moves repeativly. if that is possable or somebody knows another way to help lease e-mail me. thanx
Confused <ajax_669@hotmail.com>
- Tuesday, December 11, 2001 at 03:48:31 (GMT)
Jaap, an excellent site. I can't believe that I had not come across it before. I bought an Orb-It today and came across you while looking for other references. Visit it me sometime.
Martin H. Watson <via website>
- Wednesday, December 05, 2001 at 14:44:57 (GMT)
Hi - how funny to stumble across this great site when doing a Google search for my name, and finding my name in the first issue of the Cubic Circular. I remember vividly still being in the lead at lunch time at that competition 20 years ago! I can now only do one layer - very sad. Thanks for the fun memories. Benjamin Ealovega
Benjamin Ealovega <ben@benjaminealovega.com>
- Monday, December 03, 2001 at 16:52:35 (GMT)
Hi Jaap:
I am trying to make a Super Magic like the picture you have on your Magic page supplied by Corneliu Zavadovschi, but I don't have a solution for it.
Do you have one? Thanks.
P.S. Thank you very much for all the work you have done for us puzzlers.
Tony.
Anthony Caveda <tonycaveda@netscape.net>
- Thursday, November 29, 2001 at 13:57:15 (GMT)
Thanks for putting up this page. I looked at several other pages but the explanations are not so good, yours on the contrary take the person step by step and lead to the final solution.
Jorge Jaramillo <kingeorge@hotmail.com>
- Wednesday, November 28, 2001 at 19:56:58 (GMT)
I thank the lord for this page! I looked all over the internet to try to find chinese rings and this is the only place I found them. The date is the 27 of November and if you get this or anyone sees this before December 5 I need some more information on chinese rings because I have to do a report on it in front of my geometry class. Please help me and I thank you for giving me this much.
Kate Adkins <Mipadkins@aol.com>
- Tuesday, November 27, 2001 at 21:28:29 (GMT)
hello. I've really enjoyed your puzzle pages and solutions and used some of your pages as "reviews" of what to add to my puzzle collection. Following your suggestion, I created a stella octangula out of two pyromorphixes. I'm stuck. I need help orienting the last three tips. How about a solution for the "Star of David"?!!?
Jeremiah Sibley <Miahluvdd@aol.com>
- Saturday, November 17, 2001 at 04:14:57 (GMT)
I am trying to find a pyramix, and missing link.
I had these puzzles in the 1980's and now I want
them back!!
ROBYN <queenli19@yahoo.com>
- Friday, November 09, 2001 at 18:18:32 (GMT)
This is really...a genius, work of art. I do not know where to start to explain how amazing this is.
veronica <partiegrrl@hotmail.com>
- Thursday, November 08, 2001 at 07:13:40 (GMT)
Just my kind of website. Thanks for putting all this stuff together Jaap. Jaap's Puzzle Page rules!
Luis F Lupian <lupiansa@uiuc.edu>
- Thursday, November 01, 2001 at 16:30:14 (GMT)
Excellent site. Thanks
Manga
- Thursday, November 01, 2001 at 01:40:53 (GMT)
Please see my note on adjusting tension of 3x3x3 @ "chat"!
James N. Koppel <jamenkop@hotmail.com>
- Thursday, November 01, 2001 at 00:22:50 (GMT)
does anyone know how to type in the different puzzles e.g #12
for the lights out 2000
as i don't understand page 10 in the instrction booklet.

MEL <goody2shoes2uk@yahoo.com>
- Sunday, October 28, 2001 at 23:07:19 (GMT)
Good~!!!
Korean boy <butiloveu@hanamil.net>
- Wednesday, October 10, 2001 at 06:41:32 (BST)
Thanks a lot!

È¤½Ã ÃµÀç??
Korean boy <butiloveu@hanmail.net>
- Wednesday, October 10, 2001 at 06:40:21 (BST)
How much can I pay you to make me a "Super Magic?"
I have cold hard American Dollars for you.

-Jon Palmer
mazzterpiece@yahoo.com
Jon Palmer <mazzterpiece@yahoo.com>
- Friday, September 28, 2001 at 23:05:59 (BST)
Many thanks for your work.
I really appreciate all the math part.
I think that everybody feel better when things are explained.

JIMMI <jm@yahoo.fr>
- Thursday, September 27, 2001 at 10:57:23 (BST)
This site is awesome. Did you compile all of this yourself by actually playing these puzzles?

Do you know of any games that can be played by combining 2 or more Tantrix discovery (10pc) sets? I would love to buys a 56 pc set, but no stores near me carry them. Perhaps I will order one online.

Thanks,
John
John Raggio <raggio@optonline.net>
- Monday, September 24, 2001 at 03:45:44 (BST)
Hi Jaap,

I've enjoyed your puzzle site or years now -- are you planning to reinstate the downloadable version with some of your more recent updates added? The site is delightful, but it is incredibly convenient to have your text on hand without having to go online.

Thanks for all of your marvelous efforts,

- Peter
Peter Harle <harle@macalester.edu>
- Sunday, September 09, 2001 at 06:41:28 (BST)
The Version 2.0 Beta of Cube Explorer is available! Maybe you would like to take a look at it at
http://home.t-online.de/home/kociemba/cube.htm
best regards
H. Kociemba
Herbert Kociemba <kociemba@t-online.de>
- Saturday, August 18, 2001 at 22:30:30 (BST)
Hola al que lo lee, me gustarìa comprar el 4*4*4 o 5*5*5 , o algun otro, prfavor escribanme.
matias <matias_sa@latinmail.com>
- Sunday, August 05, 2001 at 14:59:44 (BST)
I also have been looking for these puzzles for years how can i purchase the whip it and the missing link puzzles. Please help. Much appreciation.
CARLA <carlasewell@hotmail.com>
- Friday, August 03, 2001 at 01:13:54 (BST)
Phase 4 step b1 should read: To swap DLF and DFR, do R'D'R FDF' R'DR D2. You have a ' on the last R on the site. Otherwise, OUTSTANDING site! It has rekindled my high school obsession with mastering the cube!

[ Thanks Jim, It's been fixed! -Jaap]

James diGriz <jamesdegriz@hotmail.com>
- Wednesday, July 25, 2001 at 07:06:47 (BST)
I have been looking forever to replace my magic puzzles!! Do you know where I can purchase these? please HELP!
Thanks!!!
Flip <flipstash@home.com>
- Monday, July 09, 2001 at 08:13:03 (BST)
Have you a solution to the 25 tile Rubik's Tangle. This one is really difficult - or am I missing something simple?
Ron Schwinn <ronsnormas@cs.com>
- Monday, June 18, 2001 at 05:44:49 (BST)
wow!!!!!!! your site is excellent! the "possible other puzzles" section is very thorough and fascinating; it is a real "page-turner"!!!!! I want to suggest a link for you to post. http://www.tux.org/~bagleyd/puzzles.html DAVID BAGLEY has put together a package of his FREE windows-based programs including a cube simulator that allows at least as high as 10x10x10 to run flawlessly on my old 486 -66mhz-24 mbRAM machine as well as pyramids, octahedra,dino, skewb,etc. all with the ability to increase/decrease "layers" and change from face turning to corner turning modes where applicable. These program allows you to save the current state of your cube (including all the moves done to get to that state) to a file called xxxxx.dat(can be renamed to allow for multiple save states) and reload it later to continue where you left off. worked great for my first-ever effort to solve 9x9x9,which took several half-hour sessions to finally complete(which I then saved to the ".dat" file,and which ,when reloaded, plays an impressive little "movie" as the simulator displays every single state the cube was in from start to finish in rapid-fire succession) The download is small and the functionality is UNSURPASSED !!!! BY FAR THE BEST SOFTWARE SIMULATION I'VE YET TO USE AND I BELIEVE BY FAR THE BEST SOFTWARE SIMULATION OUT THERE!!!! (DEBATABLE, I'M SURE) DID I MENTION IT'S FREE??? Try it, you'll love it. thanks. sincerely, J.P.Gizzi (j_gizzi@yahoo.com)
JOHN P. GIZZI <j_gizzi@yahoo.com>
- Saturday, June 16, 2001 at 14:36:11 (BST)
Hi again , sorry my message should read German puzzle shop (one of your links)
thanks
Mark
mark <mind-games@lineone.net>
- Wednesday, June 13, 2001 at 15:03:51 (BST)
Do you have a list of manufacturers of puzzles or wholesalers . I have two
puzzle shops and am always on the look out for new puzzles . I already have the
main ones like binary arts , pentangle , lagoon , . The german puzzle has lots of puzzle's which are new to me . Please can you or anybody help
Thanks
Mark
mark <mind-games@lineone.net>
- Wednesday, June 13, 2001 at 15:01:49 (BST)
Please, put one picture or diagram in your Ultimate Skewb Notation. I really can´t understand what you mean in that notation. Thanks
Fabio Couto d´Alambert <fcdalambert@globo.com>
- Saturday, June 09, 2001 at 00:20:30 (BST)
Incredible site! I am in awe of you people who can do the cube puzzles and do the coding for putting this stuff out on the web. And you do it for FREE, I bet! Amazing. I have been monitoring your emails regarding speed solving, and I stand in awe! I recall when I could solve the 3x3x3 cube in under 3 minutes. I thought that I was hot stuff then! I have some original duplicate puzzles from the 1980s if anyone is interested. Please feel free to contact me. Your puzzle and web expertise make me feel like an insect!
Joey Butler <jbutler_490@yahoo.com>
- Thursday, May 31, 2001 at 17:02:26 (BST)
Do you know where to buy a 12 colored Megaminx?
Darren <djgrew75@hotmail.com>
- Sunday, May 27, 2001 at 04:26:39 (BST)
Your page is awesome, it just needs more information on the
puzzle and the creator!
Erica Nancekivell <erica_152@hotmail.com>
- Monday, May 07, 2001 at 14:35:40 (BST)
Hello, Jaap,

What a terrific resource this website is! I am a frequent visitor.

Perhaps you can recommend a source of historical information. I am trying to
figure out who designed and who manufactured some of the early variants of
Rubik's cube, specifically the cubo-octahedron, the octagonal prism, the
truncated cube, the pillow cube, and the magic octahedron. It would be
interesting to know if Erno Rubik was involved with any of these, or if his
famous invention sparked the creativity of other puzzle designers. We know
how Rubik's puzzle inspired Mr. Meffert. What about these other puzzles?

Thanks.
Carter <ctarrer@ec.rr.com>
- Sunday, May 06, 2001 at 13:29:55 (BST)
I just discovered your page today! Thank you for including me on your links page (how did you find my website?). As an HTML novice, I'm not sure why my web page is hard to view in Netscape... but I'm open to suggestions.

Thank you greatly for your solution to Create the Cube. That is the only puzzle of mine which I haven't solved yet, so I am looking forward to having the time to utilize your solution. Keep up the good work!
Dennis Palaganas <dpalaganas@erols.com>
- Monday, April 16, 2001 at 18:13:18 (BST)
Where can I find information about how can I make (physically) Rubik's cubes (2x2x2,3x3x3) and others from the Rubik's familly? There exists informations about their mechanism on the net?
Please email me at hypersorin@email.ro
Thanks.
Sorin <hypersorin@email.ro>
- Tuesday, April 10, 2001 at 11:33:25 (BST)
Hi Jaap

I have a big problem. For my Birthday I got a Masterball (rainbow). I just wanted to try to turn the segments, but sudenly I couldn't turn back and I would like to have my masterball like before I started to turn. CAn you halp me to solve it? The colors are like that now:

row at Northpole:

yellow, violett, dark blue, light green, violett, lighte blue, orange, red

upper row in the middle:

yellow, violett, light blue, orange, dark green, violett, red, dark blue

lower row in the middle:

yellow, light green, dark blue, light blue, orange, light green, dark green, red

row at the southpole:

yellow, light green, dark blue, dark green, light blue, orange, red, dark green

Or is there a possibility to put these colors in that following in your example and trainingstation at your homepage? Please help me. Thank you

Yours Sincerely Neela
Neela <littleangel5481@hotmail.com>
- Sunday, April 08, 2001 at 09:16:10 (BST)
Hello Jaap. You have a great site, and I admire your work. The motive of this message, however, is about the problems I faced when I tried to follow your solutions to Ultimate Skewb, both that in the Meffert´s booklet and that in this site. I stopped at section 2 of the booklet; beyond that it became impossible to follow it. Many steps are not clear or it is supposed that the reader already know what to do. And then I tried this site´s solution, but I couldn´t understand even the notation you used to refer to the puzzle parts.
I would like to know if you can help me (and probably many other people with faced the same problems).
Thanks
Fabio Couto d´Alambert <fcdalambert@globo.com>
- Tuesday, April 03, 2001 at 12:02:01 (BST)
Hello Jaap,

You have a great website. I really love the Rubiks Magic and I saw a competition on the TV a few years ago and someone was trying to break the world record for going from the three rings separated to the three rings linked. I think they did it in just over two seconds and I am SO sure that I managed to do it in just under two seconds! The only trouble was I broke my Rubiks Magic trying to get faster and faster. This was a very long time ago and haven't been able to get another one since then. Any ideas where I can get one? I am in the UK.
Gary <garito100@hotmail.com>
- Monday, April 02, 2001 at 21:02:49 (BST)
Just thanking you again for your kind answers to my e-mails on Square1. I really enjoy your very good pages.
Elias Hernandez Capdevila <ehcM@amena.com>
- Saturday, March 31, 2001 at 10:23:31 (BST)
Hi Jaap. Great page. The stuff on the tantrix unsolved puzzles really
interests me, since Paul Martinsen and I were the first to find a solution
(with a computer) to the longest lines puzzle.
I have since proved to my satisfaction that the shape used (as seen on
the mathpuzzle.com site) is the best possible, but still can't find a nice
way to prive the largest loops puzzle.
If you are interested, I could send you a postscript file of my proof that
the shape is the best possible.
Cheers,
Jamie
Jamie Sneddon <j.sneddon@auckland.ac.nz>
- Sunday, January 07, 2001 at 21:31:34 (GMT)
I wrote a paper on Rubik's Magic Puzzle some years ago in which I showed that Rubik had made what appears to be a mistake in the design. I hope to put it on our website sometime.
Also my daughter designed a very hard puzzle which we called Rubik's Revenge. This was done on the NES and was the 32nd final puzzle in "Dudes with Attitude". I think we stil have some of those.
These days I work on Word Puzzles and games including our popular "WordZap" which has sold 1.3 million copies and was recently ZDNet game of the day (check WordZap.com).
Michael Crick <mica@crick.com>
- Tuesday, December 26, 2000 at 00:54:06 (GMT)
Very nice site. It helped me to find better solutions for Orbix and Lights Out. Thanks a lot.

Thomas
Thomas W. de Boer <t.w.de.boer@bdk.rug.nl>
- Friday, December 01, 2000 at 08:25:35 (GMT)
Append /interests/puzzles/4Cube/Nteract4/ to my homepage for access to my 4D Rubiks pocket cube.
John Bailey <jmb184@frontiernet.net>
- Wednesday, November 29, 2000 at 21:13:53 (GMT)
I once demonstrated the Rubiks Magic on a TV show many years ago. I now have 2 children and would love to get hold of one again. If you have the firts version (black) and are willing to sell it to me please get in contact.

THanks for your time,

Mark
Mark Futcher <markf@virgin.net>
- Thursday, November 16, 2000 at 01:32:35 (GMT)
Helemaal vol bewondering voor je kunststuk, mij hedenmiddag getoond door vader Jan,

Veel groeten,

Jacques
Peper <jacques.e.peper@planet.nl>
- Saturday, October 21, 2000 at 14:42:42 (BST)
Dear jaap--

Thanks a lot for your response to my rubiks.com post re: the
impossibility of a double edge swap on a 3x3x3. I suspected as
much very strongly, but am thankful for your confirmation!

jamenkop
James N. Koppel <jamenkop@hotmail.com>
- Wednesday, October 18, 2000 at 17:40:23 (BST)
Great site! You inspired me to dig out some of my old puzzles that had been collecting dust for the last several years. Some, like Alexander's Star, I had given up on before I'd figured out how to solve them. I already knew how to solve the Megaminx, so when you pointed out the fact that Alexander's Star was essentially just the Megaminx edges, I was off and running on my own. Why didn't I see that before? I did, however make the connection with the Impossiball on my own a few months ago.

Thanks again.............Scott
Scott Whitaker <swhit@rollanet.org>
- Monday, October 16, 2000 at 20:08:45 (BST)
Hello Jaap,

Just wanted you to know that there is another way to make the cube shape,
which causes less strain on the wires. I also have the "Create the Cube" puzzle,
and if you would like any info on it (pictures, etc), I can send that info.
I have solved it before, and I'm exploring the possibility of writing a
solution for it. Write me back if you want/need any info. Thanks, Jeff
Jeff B. <bondjd@hotmail.com>
- Saturday, August 05, 2000 at 21:49:27 (BST)
Hi Jaap,

Cool site. Maybe you can take a look at my Rubiks-cube-solver and in case you like it give me a link?
Johan de Ruiter <jdrsoft@worldonline.nl>
- Thursday, August 03, 2000 at 12:23:30 (BST)
Thanks for a great page. Your Square-1 solution was excellent!
Ray Eddington <raye@morinda.com>
- Wednesday, July 26, 2000 at 18:43:53 (BST)
This page is really cool. I just looked at your Square 1 solution and it is a lot better than the ones that were out there a few years ago.

I wrote a quick program to solve the Billiards 9-ball puzzle before I came to your page, and it looks like we must have written very similar programs. :)

David

David Barr <davidbarr@iname.com>
- Monday, July 03, 2000 at 09:40:28 (BST)
Dear Jaap,

As a lover of puzzles, I have mastered many that are on your list. This one puzzle (turnstile) has been baffling me for almost 18 months!!! Thanks. It will be such a relief to finally be free of the nagging feeling at the back of my consciousness.
Jill <cnjsmith@mediaone.net>
- Friday, June 09, 2000 at 03:05:12 (BST)
Dear Jaap
I have been hunting for a solution to the Magic Master edition for 5 years. God bless the internet. Although I now feel disappointed it was so straight forward!!!

Thanks

Claire
Claire <vorlina@aol.com>
- Wednesday, May 24, 2000 at 13:48:36 (BST)
Hi Jaap,

You did an impressive job!
I really like your home page, and visit it frequently.

Thanks,

Ron

Ron <rvb@chello.nl>
- Monday, May 01, 2000 at 19:27:20 (BST)
Welcome!
If you have any comments on my web pages, you can leave a message here.
Thanks!
Jaap Scherphuis <jaap@org2.com>
- Monday, March 13, 2000 at 23:27:38 (GMT)

Home
Links
Guestbook


Jaap's Puzzle Page Guestbook - Add a Message.

Fill in the boxes to add to the guestbook. Please be sure to enter your name, email address, your Homepage address (if you have one), and of course your message.

Your Name:

Your E-Mail Address:

Your Homepage URL (if applicable):

Your message:

Press here to return to the Guestbook without adding message.

This page is based on a Script by Matt Wright from Matt's Script Archive.

Home
Links
Guestbook


Tower of Hanoi

This puzzle consists of three pegs, and a stack of circular disks of differing sizes, each of which can be threaded onto a peg. At the start, the disks are all in order on the first peg, from the largest disk at the bottom to the smallest disk at the top. You are only allowed to move one disk at a time from one peg to another, and at no time may a disk be placed on top a smaller disk. The aim of the puzzle is to move all the disks from the first peg to the third. The puzzle can be solved with any number of disks, but it takes longer with more disks.

Links to other useful pages:
Miroslav Kolar's page has an amazing number of links so I don't need to list any other pages here. He even has proofs of the rules of thumb used below.

This puzzle was invented by the French mathematician Edouard Lucas in 1883. The description included with the puzzle when it was originally sold called it a simplified version of a mythical 'Tower of Brahma' in a temple in the Indian city of Benares. This tower consisted of 64 disks of gold, which had to be moved to another position by priests. The legend went that before they complete the task, the temple would crumble into dust and the world would vanish in a clap of thunder.

The number of possible positions:
If the disks are placed on the pegs one by one, starting with the largest one, then there are always three choices when placing a disk. Any legal position can be constructed in this manner. There are therefore 3N positions for N disks. At each position (except when all the disks are on one peg) there are 3 possible moves, one which brings you closer to the start, one which brings you closer to the end, and one which bring you closer to having all disks on the middle peg.

Solution:
The puzzle can be solved by a recursive algorithm. To move a stack of N disks from one peg to another, simply follow the following steps:

  1. Move the top N-1 disks of the stack aside, on the spare peg.
  2. Move disk N in position on the other peg.
  3. Move the stack of N-1 disks on top of disk N.
This method works because this reduces the puzzle of N disks to a puzzle of only N-1 disks. That in turn is reduced to a puzzle of N-2 disks, and so on until the puzzle is reduced to moving a stack containing only 1 disk, which is easy. This algorithm has exactly 2N-1 moves, because from the steps above it is easily seen that Length(N)=2Length(N-1)+1, and Length(1)=1, and the result then follows by induction. This solution is also minimal, in other words there is no shorter way to solve it, because every solution for N disks must reach the intermediate position with the top N-1 disks on the spare peg.

The recursive algorithm works very well, but in practice there are several rules of thumb which can guide you:

  • Every other move is a move of the smallest disk, i.e. the small disk is moved on move number 1, 3, 5, ... ,2N-1.
  • The smallest disk visits each peg in turn, and is never moved back to the peg it came from on its previous move. In fact this is true of all disks (except for the largest), but it is more obvious with the smallest one since it is moved so often.
  • On a move not involving the small disk (i.e. moves 2, 4, 6, ...) there is only one possible move choice.
  • If the disks are numbered, then an even disk is never placed on top of an even disk, and an odd one never on top of another odd one.
  • If there is an even number of disks then the first move takes the small disk to the second peg, with an odd number of disks the first move is to the third peg. This can be seen as an extension of the odd/even rule above; the bases of the pegs are also considered odd or even in such a way that the start and end positions follow the odd/even rule, and then the first move can be deduced.

There are 3N possible positions, and 2N positions are encountered while solving the puzzle directly using the methods above. All the other 3N-2N positions break the odd/even rules by having two disks of the same parity on top of each other (or the largest disk on the middle peg). The odd/even rule always rules out one of the three available moves, so that you can only go forwards to the end or back to the beginning.

If you stop in the middle of solving and forget what your last move was, then you may find yourself reversing previous moves and ending up back at the beginning. The rules of thumb also do not help you when you encounter one of the 3N-2N positions that do not lie on the direct route between the start and the end. In these cases the correct move can be deduced as follows:

  1. You want to move the stack of N disks to the third peg. You therefore want to put disk N on the third peg first.
  2. If the disk is in position, then the aim is to put all the smaller disks on top of it. If not, then the aim is to put all the smaller disks on the other peg.
  3. Repeat the above for this smaller stack of disks.
This is best illustrated by example:
A | B | C
Here we want to move disk 4 from peg B to peg C. This means that we need all the smaller disks to be on peg A, so we must move disk 3 from peg C to peg A first. For this we need all disks smaller than 3 to be on peg B. Disk 2 is already on peg B, but disk 1 is not so this has to be moved to peg B. The correct move is therefore disk 1 from A to B.
Similarly if we want to move back to start, to move disk 4 from B to A means that disk 3 and smaller must be on peg C. Disk 3 is already on C, so we must put disk 2 on C next. Disk 1 does not obstruct this, so the correct move is disk 2 from B to C.
If we wanted all the disks on peg B instead, then the correct move would be move disk 1 from A to C. Note that this move does break the odd/even rule (disk 1 move on top of disk 3), but that is only because the position itself already breaks that rule (disk 2 lies on disk 4).

An interesting pattern emerges if you map out all possible positions in a graph, with lines connecting two positions that differ by a single move. The graph will resemble of Sierpinski's gasket; the more disks, the more closely its graph approximates the gasket's fractal triangular shape. The solution is the path along the edge of the triangle, from one corner to the other.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Ideas for other puzzles

Below I will try to classify the various puzzles which are closely related to the Rubik's Cube. By doing this, I not only list which puzzles have been made, but more importantly which puzzles have not. Some of these might be developed, or at least give a few ideas for producing new rotational puzzles. I will make several assumptions:

  • All axes of rotation used in the puzzle have the same order. This disqualifies the Domino for example because its sides have order 2 while the top and bottom faces have order 4.
  • The puzzles have a fully symmetrical shape (i.e. for any two axes of rotation the puzzle has a symmetry that moves one axis to the position of the other). Actually this condition implies the first one as well.
  • All axes go through the centre of the puzzle.

There are three obvious symmetry groups for these puzzles; tetrahedral, cubical/octahedral, and icosa/dodecahedral symmetry. In each case the axes can go through all the corners, all the faces, or all the edges of the associated Platonic solid. I will assume only one such set of axes is used. It might be possible to combine for example corner and face turns in a single puzzle, but I won't consider such puzzles here, only those with all axis types the same. Neither will I discuss other symmetry groups such as dihedral ones, again because not all axes are the same.

Note that in the text below I will consider an axis to end at the centre, so that a Rubik's cube has 6 axes (one for each face) rather than only 3.

Puzzles with 4 axes of rotation, i.e. the faces or corners of a tetrahedron.
These can mostly be made by using the Skewb/Pyraminx mechanism, the 4-armed spider.

  1. Tetrahedron

    2. Two variations already exist.
    The standard tetrahedral puzzle is the Pyraminx, a tetrahedron with three pieces to an edge. The corners are fixed on axes. The tips are trivial as they do not interact with other pieces.
    The Halpern-Meier Tetrahedron is outwardly like the Pyraminx except that it has no trivial tips and the main cuts are deeper (w.r.t. the corners) giving face centres which move around the puzzle. I suspect that the mechanism has the faces fixed on the axes and that the corners are actually the moving pieces.
    If the main cuts are instead slightly shallower than the pyraminx then centre pieces also appear but these do not move, and therefore might as well be fixed to the central mechanism too. This puzzle has never been produced as far as I know.
    It is theoretically possible to make a tetrahedron with more pieces to an edge. A size 4 Pyraminx can be made by using the Skewb as a basis. The four free corners of the Skewb become the face centres, the six faces of the skewb are built up to become the octahedral edge pieces, the four fixed corners have built on them an octahedral vertex piece and tip, both of which can rotate w.r.t. the underlying skewb. Between the octahedral edge and vertex pieces are 12 new edge pieces.
    The only potential difficulty with this model that the 12 edge pieces would seem to fall off when a size 3 vertex is turned. This is not a problem however since the edges only do this on one side, so they can have a deeper reaching lopsided tongue inside a groove. This puzzle would have 6!·24·34·12!/2 = 2.2·1014 positions, ignoring the tips.
    A tetrahedron of size 5 however would not be possible with this type of mechanism without using layers of differing widths because the central edge pieces would have to be able to overhang on either side.
  2. Cube

    3. The only cube-shaped puzzle which is based around a 4-armed spider is the skewb. This puzzle has essentially 8 axes of rotation since the cuts go exactly through the centre of the cube.
    Note however that the similar mechanism could also produce a skewb with off centre cuts which does have only tetrahedral symmetry.
  3. Octahedron

    4. The octahedron is the dual of the cube so the same ideas apply in this case. The Skewb Diamond, the only mass produced puzzle in this category, has essentially 8 axes just as with the skewb above.
    An off centre version is again possible, and Tony Fisher makes them (Fisher's Octaminx). It is based on the pyraminx mechanism as four of the faces have no centre pieces.
    By using shallower cuts, all the faces have centre pieces, but as with the tetrahedron they do not move at all so might as well be fixed to the puzzle centre.
  4. Dodecahedron

    5. This puzzle now being produced under the name Ultimate Skewb by Uwe Mèffert. It has also at one time been called the Pyraminx Ball. Its mechanism is exactly that of the skewb, and can be solved in the same way except that the orientation of all the pieces matter. This puzzle is more confusing than an ordinary skewb where the faces are marked, because the strange angles make it easy to lose your way. With six colours, each piece also has a mirror image on the other side, and the face pieces are easily confused. On the normal skewb, a tetrad of corners are turned so that their colours match, i.e. matching colours are put next to each other. On this puzzle, such matching colours are on opposite faces, and must therefore point away from each other.
    With the above puzzle the cuts are through the centre. Shallower cuts are also possible, for example by using the Pyraminx mechanism instead to give a puzzle which has 4 large turning corners and 6 free moving pieces made from two triangles.
  5. Icosahedron

    6. Since this is the dual of the dodecahedron, a skewb mechanism can be embedded in exactly the same way. Tony Fisher has made these.
  6. Other shapes

    7. A Rhombic Dodecahedron makes for quite a pleasing puzzle. Halfway through a turn (i.e. 60 degrees) the surfaces line up and form trapezoids. This puzzle is confusing for much the same reasons as the regular dodecahedron skewb.

Puzzles with 6 axes of rotation, i.e. the faces of a cube, corners of an octahedron or even edges of a tetrahedron.
The standard mechanism for these is the 6-armed spider as used in the Rubik's Cube, though other mechanisms are often needed with puzzles which have deep cuts.

  1. Tetrahedron

    2. A tetrahedron does not have cube symmetry, so if we embed a cube mechanism inside it will change shape unless only half turns are allowed.
    One variation already exists, the Pyramorphix. It is a tetrahedron with two pieces to an edge, and as such is based on a 2x2x2 Rubik's cube mechanism. The only difference between them is that this time the orientations of four of the pieces do not matter.
    A version with three pieces to an edge would be an interesting one. It would be like a Rubik's cube with four corners missing, but where orientation of the face centres matter, and only half turns are allowed.
  2. Cube

    3. This leads to the standard cubes of various sizes.
  3. Octahedron

    4. One version based on a 2x2x2 cube would have one piece to an edge and cuts through the middle of the puzzle. You could make one of these by combining two Pyramorphixes (the pocket-size ones can easily be taken apart with a small screwdriver). This gives a puzzle with four colours, and only 8!/24/24 = 105 distinct patterns.
    A larger version with 2 pieces to an edge would make a nicer puzzle. It would be an octahedral version of Dogic (which is icosahedral). The Dogic mechanism could possibly be adapted, even though the cuts go through the centre of this puzzle. It would have 8! 24! / 3!8 /24 = 6.2·1020 positions, but would be easier to solve than that figure suggests.
    Versions with three pieces to a side do exist, however none of them have a cut through the exact centre of the puzzle. Instead they are based on the standard 3x3x3 cube mechanism, and only allow tips of size 1 or 2 to turn. Ignoring the tips, these are just like the Rubik's cube without corners but where the orientations of the face centres matters. See the octahedron page.
    Trajber's Octahedron is similar to the octahedron above, in the same way that the Halpern-Meier pyramid relates to the Pyraminx; it has no trivial tips, and the main cuts are slightly deeper. It therefore has face centres which correspond to the corners of the underlying cube mechanism.
  4. Dodecahedron / Icosahedron

    5. The dodecahedron and icosahedron do not have cube symmetry, so if we embed a cube mechanism, they will change shape unless only half turns are allowed. Embedding the 2x2x2 or a 3x3x3 cube mechanisms would make nice looking puzzles, but they would not be particularly interesting to solve.
  5. Other shapes

    6. It is well worth embedding a 2x2x2 mechanism inside the rhombic dodecahedron. Each piece has only one face in common with any adjacent piece. If only six colours are used (opposite faces the same colour) this leads to a very tricky puzzle. Given one edge of a piece, there are three pieces that seem to fit. Only one will lead to the correct solution.
    If a 3x3x3 mechanism is embedded inside a rhombic dodecahedron another fairly nice puzzle results. It is like the cube except that orientations of edges do not matter, but that of the centre pieces does.
    A 4x4x4 mechanism cannot be used with all the layers of the same width, because the edges and corners would drop off, but a different mechanism could be used similar to the octahedron above.
    A Stella Octangula can be made by combining two Pyramorphixes (actually both the octahedron above and stella could be made from two). This gives a puzzle based on a 2x2x2 cube but made of two intersecting tetrahedra. If it has four colours then there are only 8! 37 /24 /24 = 229,635 distinct patterns. Using eight colours results in a puzzle which has as many positions as the 2x2x2 cube, but a bit more difficult. It is possible to have a position where only one piece seems to be twisted. In fact, the other three corners with the same colours then need to be swapped around. This puzzle will probably be produced by Mèffert under the name of Star of David.
    A stella octangula with 4 pieces along each diagonal edge could theoretically have a 3x3x3 cube mechanism embedded in it, with the middle layers twice as thick as the outer ones. This has the interesting property that the edge pieces of the underlying cube correspond to two seemingly separate parts of the surface.
    A stella octangula with 4 pieces along each diagonal edge could also move like a proper 4x4x4 cube. The mechanism would be very difficult, since the corners will overhang during turning. It would behave like a Rubik's Revenge with the face centres marked and edge pieces which come in indistinguishable triplets. There will not be a parity problem when solving this puzzle.

Puzzles with 8 axes of rotation, i.e. the corners of a cube or faces of an octahedron.
The standard mechanism for this would be the 8-armed spider, but in deep-cut puzzles like the Skewb a 4-armed spider is used.

  1. Cube

    2. There are two versions available. The best known one is the Skewb, which has cuts exactly through the centre of the cube.
    The Dino Cube is a cube with 8 cuts, going diagonally through three adjacent face centres. This gives a cube with only 12 edge pieces and no others visible on the surface. It gets its name from the fact that they usually have pictures of dinosaurs on the sides. I do not have one, but it is most likely to be based on an 8-armed spider mechanism, i.e. a stella octangula with the edges held between each adjacent pair of rotating tips with a tongue/groove system. This is much like a simple version of the Alexander Star.
    Consider a cube which on the outside looks like a combination of both the above puzzles, i.e. each face is cut along its diagonals, and has diagonal cuts connecting the edge midpoints. It seems nearly impossible to me to find a simple mechanism that allows both skewb and dino moves. However the same outward shape could also be produced by a dino cube where each tip has two layers. A mechanism for this is possible even though the edges will overhang (see above) but it may need to be quite accurately made to stop it being too loose. This puzzle would have 12!/2 12!/2 12!/2 /24 = 5.7·1023 positions.
  2. Octahedron

    3. One octahedral puzzle where the faces turn is the Skewb Diamond. It has a skewb mechanism, and has cuts through the centre of the puzzle, and there are two pieces along each edge.
    Apparently Uwe Mèffert has designed a mechanism for a face-turning octahedron with three pieces to an edge. I suspect it is based around an 8-armed spider, where the tips (invisible from the outside) hold the 12 edges together (like a dino-cube) and these in turn hold the corner pieces, and all of these then hold the other face pieces.
    If the 8 cuts are shallower, i.e. the face layers are less thick, then the puzzle will have 8 triangular face centres, which are simply the tips of the 8 axes in the mechanism.
  3. Dodecahedron / Icosahedron

    4. A dodecahedron and Icosahedron do not have octahedral symmetry, so any such puzzle will change its shape.
  4. Other shapes

    5. The Skewb mechanism could be embedded in the Stella Octangula to make a nice looking puzzle, but this does not add much interest to solving it. Embedding the Dino-cube mechanism gives a trivial puzzle.
    The shape does however suggest a much more interesting puzzle. Starting with a size 4 tetrahedron (see above), it is possible to add on size 2 tetrahedra on each of the faces to build a stella octangula. It seems possible (but somewhat tricky) to adjust the mechanism outlined before to allow this puzzle to work.
    This puzzle would have 12!/2·12!/2·38 = 3.8·1020 positions, ignoring the tips.
    The Rhombic Dodecahedron skewb was discussed before. Cutting the Rhombic Dodecahedron like a dino-cube produces not only the 12 'edges' (now these are face centres) but also 24 edge pieces and 6 corner pieces. A mechanism for this puzzle is fairly straightforward and would be worth making.

Puzzles with 12 axes of rotation, around the edges of the cube or octahedron.
As far as I know, no such puzzles have been made, and no mechanisms are known for them.

Puzzles with 12 axes of rotation, i.e. faces of dodecahedron or corners of an icosahedron.
A 12-armed spider is the basis for most of these puzzles.

  1. Dodecahedron

    2. The standard version is the Megaminx. In this the cuts are shallow and meet each other at or near the middle of the edges which results in a puzzle where each face has a fixed face centre and 5 edge and 5 corner pieces.
    An interesting thing happens when deeper cuts are used. If the cut of a face goes through the centres of the adjacent faces, you get the Pyraminx Crystal, designed by Mèffert. Each face has no face centre, 5 edge pieces, 5 corner pieces, but if it is turned, the 5 adjacent edges turn with it. As far as I know this puzzle never made it into production.
    Deeper cuts will result in puzzles for which the mechanism is likely to be complicated. It has face centres which move around the puzzle. In puzzles with octahedral symmetry (e.g. Skewb) this is less of a problem because these could be built around its tetrahedral symmetry (hence the Skewb has a 4-armed spider instead of an 8-armed one). It would be fascinating however to have a dodecahedral analogue of the Skewb, i.e. a dodecahedron which is cut exactly through the centre parallel to each of its 6 pairs of opposite faces. This would be a very difficult puzzle to solve.
    Having more than one cut per face will produce far too many pieces to be made into a good puzzle, though you could have a differently shaped puzzle by not including all the pieces.
  2. Icosahedron

    3. The most common puzzle of this type is the Impossiball. Although it is actually shaped like a sphere, it is basically an icosahedron where every cap of 5 faces rotates about the corner.
    It would be straightforward to make a puzzle with a shallower cut, which goes through the centre of the triangular faces. A second cut could be added to create tips, and it then looks just like an icosahedral version of the pyraminx. It would not be much more difficult to solve than the pyraminx however, as no new techniques would be needed.
    Another way to make two cuts at each vertex is to do the first cut as in the Impossiball, and the second through the midpoints of the edges, and this produces the excellent Dogic puzzle. Its mechanism has an amazing number of moving parts.

Puzzles with 20 axes of rotation, i.e. corners of a dodecahedron or faces of an icosahedron.
A 20-armed spider could be the basis for these puzzles.

  1. Dodecahedron

    2. This would be a dodecahedron where the corners rotate. As far as I know no such puzzle has been produced.
    The most obvious case would have the cut of a corner going through the three adjacent corners. This puzzle is the equivalent of the Dino-cube. The main difference is that it has fixed face centres, and there is also a corner piece between the edges.
    Having deeper cuts produces a puzzle with moving corners (which are the centres of rotation) and a complicated mechanism would be needed.
    Having two cuts (first as above, second through edge midpoints) will produce a puzzle which needs a very intricate mechanism. Generally having more than one cut per face will produce too many pieces to be made into a good puzzle, though you could have a differently shaped puzzle by not including all the pieces.
  2. Icosahedron

    3. This would be an icosahedron where the faces rotate. Unfortunately this leads to too many pieces to make a good puzzle, though you could have a differently shaped puzzle by not including all the pieces.

Puzzles with 30 axes of rotation, around the edges of the dodecahedron or icosahedron.
As far as I know, no such puzzles have been made, and no mechanisms are known for them.

Home
Links
Guestbook


Impossiball

Picture kindly supplied by Hendrik Haak

This puzzle, also called the Incredi-ball, is a ball with 20 curved triangular pieces like an icosahedron. Each cap of 5 triangles rotates around a vertex. The vertices are coloured so that the pieces have three colours each. It is equivalent to a megaminx with only corners and no edges or centres.

The Impossiball has only 6 colours, since opposite vertices are given the same colour. Therefore each piece has a mirror image on the other side of the solved ball.

By lifting out any single piece, the Impossiball also becomes a sliding piece puzzle.

The number of positions:
There are 20 pieces, with 3 orientations, giving a maximum of 20!·320 positions. This limit is not reached because:

  • only even permutations of the pieces are possible (2)
  • the total twist of the pieces is fixed (3)
  • the orientation of the puzzle does not matter (60)
This leaves 19!·318/2 = 23,563,902,142,421,896,679,424,000 or 2.4·1025 positions.
Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He produces and sells many puzzles, including the orbix.
Meffert's page Contains the solution provided in its booklet.

Notation:
Let F, R, D be three adjacent vertices (Front, Right and Down), in other words, F, R, D are vertices arranged clockwise around a piece. Let U (Up) be the other vertex adjacent to both F and R, and let L (Left) be the other vertex adjacent to F and D. Clockwise 1/5 twists of a face are denoted by the appropriate letter, anti-clockwise 1/5 twists by F', R', L', D' or U'. In the solution below, the pieces around the D vertex are usually still unsolved.

Solution:
Phase 1: Solve all but one vertex.

  1. Select any vertex to solve first, and any colour to place there.
  2. Find a piece belonging at the vertex which is not yet there. If there are no such pieces, and the vertex is not solved then displace an incorrectly placed piece at the vertex by choosing any unsolved piece. Hold the ball so that the piece belongs at URF, and such that D is unsolved.
  3. Use any moves that do not disturb already solved pieces to place the piece at DFR.
  4. Put the piece in place by using one of the following:
    1. RDF->URF: R'D'R
    2. FRD->URF: FDF'
    3. DFR->URF: R'DR FD'D'F'
    These sequences only disturb the D vertex pieces, but nothing else except for the URF corner.
  5. Repeat a-d to solve all the pieces at the vertex. Be careful not place mirror image pieces together by mistake.
  6. Repeat the above for successive adjacent vertices until all but the final vertex is solved.
Phase 2: Position the final pieces around their vertex.
In this and the next phase, the vertices adjacent to the unsolved D vertex are in clockwise order: L, F, R, b, B.
  1. Rotate D to place as many of its pieces in position as possible.
  2. Hold the puzzle so that one of the following sequences will position the pieces correctly.
    1. DFR->DLF->DBL->DFR: RUR' D RU'R' D RUR' D'D'RU'R'
    2. DFR->DBL->DLF->DFR: RUR' DD RU'R' D' RUR' D' RU'R'
    3. DFR->DLF->DbB->DFR: RUR' D RU'R' DD RUR' DD RU'R'
    4. DFR->DbB->DLF->DFR: RUR' D'D'RU'R' D'D'RUR' D' RU'R'
    5. DFR-DbB, DLF-DBL: RUR' D RU'R' D RUR' D' RU'R' DD RUR' DD RU'R'
Phase 3: Orient the final pieces.
  1. Find a piece that needs to be twisted anti-clockwise and hold the puzzle so that it is at DFR.
  2. Find a piece that needs to be twisted clockwise, and do one of these sequences to solve it.
    1. DFR->RDF, DLF->LFD: RU'R'F'U'F D F'UFRUR' D'
    2. DFR->RDF, DBL->BLD: RU'R'F'U'F DD F'UFRUR' D'D'
    3. DFR->RDF, DbB->bBD: RU'R'F'U'F D'D' F'UFRUR' DD
    4. DFR->RDF, DFb->FbD: RU'R'F'U'F D' F'UFRUR' D
    3. To turn three corners in the same direction, just turn any two of them using the above, and then there will be only two unsolved corners, and one of the above sequences will solve them.

Home
Links
Guestbook


404 Page Not Found

Page not found

The page you requested was not found on this web server. This could be for a variety of reasons, including:
  • You followed a broken or out-of-date link.
  • You entered the URL for the page incorrectly.
  • The page no longer exists.
If you followed a broken link, please inform the owner of the referring page.

If you have any queries about this error, please e-mail webmaster@org2.com.

Back to www.org2.com homepage

[ Powered by Zeus Web Server ]


Instant Insanity

Picture kindly supplied by Corneliu Zavadovschi

Instant Insanity is a puzzle consisting of four seperate cubes. Each side of a cube has a single colour. There are four colours. The aim of the puzzle is to put the cubes on top of one another in a tower such that each side is a mix of all four colours. The colours of the other faces (hidden inside the tower or top/bottom) do not matter.

The picture shows a Hungarian version (Buvos golyok) which uses a frame containing balls with spots on them instead of separate cubes.

The puzzle became popular in the 1960's when it was produced by Parker Brothers, but it is actually much older. It was first made around 1900 and was then called 'The Great Tantalizer'.

As far as I know, nearly all versions of the puzzle that have been produced are essentially the same. They all have the following cubes, though possibly with slightly different colours (for example white instead of yellow), or some of the pieces in mirror image.
1. | B |  |
R | R | R | G
 | Y |  |
2. | R |  |
G | Y | G | B
 | B |  |
3. | R |  |
B | G | R | Y
 | Y |  |
4. | G |  |
B | R | Y | G
 | Y |  |
This standard version has a unique solution. James East told me about a version called "Watch It!"which has clocks on the sides of the cubes instead of colours. Instead of red faces it has clocks showing 2 o'clock, yellow becomes 4 o'clock, green is 8 o'clock, and blue is 10 o'clock. The aim of this puzzle is for the sides to add up to 24 hours. This can be be solved by having each side show all different clocks, since 10+8+4+2=24. It does however have ten more solutions, since the 24 can also be reached by 10+10+2+2 or 8+8+4+4.

The number of positions:
The cubes can be stacked in any order, each cube has 24 orientations, giving a maximum of 4!·244 positions. This limit is not reached because

  • The solved puzzle as a whole has 8 orientations (8)
  • The order of the cubes does not really matter to the solution (4!)
This leaves only 244/8 = 41,472 distinct positions.
Links to other useful pages:
Ivars Peterson's MathTrek has much the same info as this page.
Kadon Enterprises Inc. has reissued the puzzle.
Courtney Farren's page has the blurb from the Parker Brothers' box.

Solution:
Here is the unique solution to the standard version described above. As mentioned above, the cubes can be in any order. The cube with three red faces is easiest to recognize, so start with that one. The other cubes can also be recognised by the colours which occur more than once.
 | R |  |
B | R | Y | G
 | R |  |
 | G |  |
R | Y | B | B
 | G |  |
 | R |  |
Y | B | G | R
 | Y |  |
 | Y |  |
G | G | R | Y
 | B |  |
There is a neat method for solving this puzzle. It shows that there is no other solution, and works for any version of the puzzle.

  1. Number the cubes. I will use the numbering shown at the top of the page.
  2. You will next build a graph. Draw four points, arranged in a square which will represent the four colours.
  3. Take the first cube. There are three pairs of opposite faces. For each pair, draw a line between the points of those two colours, and mark it with the number 1 to show it comes from the first cube. Note that if two opposite faces have the same colour, then you will draw a loop from the point of that colour back to itself.
  4. Repeat this for the other three cubes, but now marking the lines with the appropriate numbers 2,3 and 4.
  5. With the standard version this results in the following graph:
  6. Now find two loops in this graph, such that each loop visits all four colours once, and uses lines with each number once. The two loops may not use the same lines.
  7. In this example, you can find the loops:
    R - 1 - G - 4 - Y - 2 - B - 3 - R
    R - 4 - G - 3 - Y - 1 - B - 2 - R
    One loop will solve the front and back, the other the right and left sides.
  8. Take cube 1, and see where it occurs in the loops. Cube 1 connects R-G and Y-B, so place the cube with Red at the front (Green at the back) and Yellow on the right (Blue on the left).
  9. Do exactly the same for the other cubes, and you will then have a solution when they are stacked together.
Actually, it might be possible (or necessary) to solve a set of opposite sides with several loops instead of one. In the example we needed a 4-cycle for each set of opposite sides, but two 2-cycles, or a 3-cycle with a single loop can work as well. Together they will still have to use all 4 colours and all four cubes. It is fairly easy to see that the graph above does not have such solutions, and that the solution shown here is unique.

With the JavaScript simulation below you can colour your own cubes and find all their solutions.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


"It" / 4x4 / Tsukuda's Square

Description of the "It" puzzle
Solution to the puzzle
JavaScript simulation of the puzzle

"It", also known as 4x4 or Tsukuda's Square, is a very difficult type of sliding piece puzzle. It consists of 16 tiles in a 4x4 square. On the left of each row is a plunger, which pushes that row one tile to the right. At the top is a large plunger which pushes the three rightmost columns down one tile. Springs push back the plungers as soon as they are released. If the top plunger is pushed in, the first row plunger can no longer move.

"It" is closely related to Rubik's Fifteen, but much more difficult because it has fewer plungers.

The number of positions:
There are 16 pieces, and hence a maximum of 16! positions (where the plungers are not pushed in). This limit is not reached since only even permutations are possible. Hence there are 16!/2 = 10,461,394,944,000 = 1.0·1013 positions.

Solution to the "It" puzzle

Notation:
Let T mean the pushing in of the top plunger, and let t mean releasing it. Similarly, let A, B, C, D denote the side plungers from top to bottom, with a capital letter meaning pushing it in and a small letter releasing it.

Solution:
Throughout the solution we need the following move sequences which cycle round 7 of the 8 tiles of the top two rows:
1a. Cycle all but top left tile clockwise: | TBtb
1b. Cycle all but top left tile anti-clockwise: | BTbt
2a. Cycle all but top right tile clockwise: | ATBtba
2b. Cycle all but top right tile anti-clockwise: | ABTbta
These sequences can also be performed on any other pair of adjacent rows.

Phase 1: Solve the first tile of the top row.

  1. Find tile 1.
  2. If it lies somewhere in the bottom row then apply 1a on the bottom row (i.e. TDtd) until it is in the third row.
  3. If it lies somewhere in the third row then apply 1a on the third row (i.e. TCtc) until it is in the second row.
  4. Apply 1a or 1b until tile 1 lies at the left of row 2.
  5. Apply 2a to place the tile correctly.
Note that the method used in b-c above to bring up a tile to the desired row will be used whenever necessary in later phases without further explanation.

Phase 2: Solve the rest of the top row.
In this phase we will use 1a to successively place tile 4, 3 and 2 at the second position of the first row.

  1. Tile 4: Bring up tile 4 to the top rows if necessary. Then use 1a or 1b until it lies at (1,2), i.e. in row 1 column 2.
  2. Tile 3: If it lies in the top row, then perform 1a until it is in the second row, do 1a on the second/third rows to bring it down further, and perform 1b until tile 4 is back in column 2.
    Use 1b on the second/third row until it is in column 2.
    Use 2b on the second/third row to bring it to column 1.
    Use 1a on the first/second row to bring it to row 1, column 2, displacing tile 4 to column 3.
  3. Tile 2: A similar method as for tile 3 is used:
    If it lies in the top row, then perform 1a until it is in the second row, do 1a on the second/third rows to bring it down further, and perform 1b until tile 3 is back in column 2.
    Use 1b on the second/third row until it is to column 2.
    Use 2b on the second/third row to bring it to column 1.
    Use 1a on the first/second row to bring it to row 1, column 2, displacing tile 3 to column 3.
Phase 3: Solve the second row.
This is done using exactly the same method as the first row.

Phase 4: Solve tiles 15 and 16.

  1. Do any of 1a/1b/2a/2b until tile 16 lies in column 4, row 3.
  2. Do 2a or 2b until tile 15 lies in column 4, row 4.
  3. Do 1a, and tiles 15 and 16 will be placed correctly.
Phase 5: Solve tile 13.
    Depending on its position, do one of the following:
    Row 3, column 1: Do 1a, 2b.
    Row 3, column 2: Do 1b three times, 2a twice.
    Row 3, column 3: Do 2b twice, 1a three times, 2b once.
    Row 3, column 4: Do 2a twice, 1a twice, 2a twice.
    Row 4, column 1: Do nothing.
    Row 4, column 2: Do 1a twice, 2b twice.
The final phase below uses three new sequences:
3a. Do 1b three times, 2a twice, 1a twice, 2b twice.
[Swaps pieces (3,1)-(3,2) and (3,3)-(4,2).]
3b. Do 1b three times, 2b three times, 1b once, 2b once.
[Swaps pieces (3,1)-(3,3) and (3,2)-(4,2).]
3c. Do 1b once, 2a once, 1b twice.
[Swaps pieces (3,2)-(3,3) and (3,1)-(4,2).]
These sequences do not move the tile at row 3 column 4, and make two swaps amongst the remaining four unsolved tiles.

Phase 4: Solve the remaining tiles.
It is always possible to get one of the positions in the table below (or if you're lucky even to solve it) by doing one of the sequences 3a-c. Then do the sequence shown in the table.
If this places tile 12 correctly, then you can now solve it by applying one of 3a-c.
If tile 12 was correctly placed before, then the sequence from the table will have moved it out, and you will have to repeat this phase once more to solve the puzzle.

 14 10 11  9    11  9 14 10    10 14  9 11
    12             12             12

 14 10  9 12    14  9 11 12     9 11 10 14
    11             10             12
 Perform TCtc, 3a, CTct.

 10 12 11  9     9 12 14 10    14 12  9 11    11 12 10 14
    14             11             10              9

 10 11  9 12    10 14 11 12     9 14 10 12     9 11 14 12
    14              9             11             10
 Perform TCtc, 3b, CTct.

 11 10 12  9    14  9 12 10     9 14 12 11
    14             11             10

 11  9 10 12    11 10 14 12    10 11 12 14
    14              9              9
 Perform TCtc, 3c, CTct.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Babylon Tower

Picture kindly supplied by Hendrik Haak

The Babylon Tower, sometimes called the Ivor Tower, is a sliding piece puzzle which consists of several discs stacked up into a tower, and they can rotate about a central axle. There are 6 such discs. Along the side of the tower are six columns of small balls in a pieces, in six colours. The colours in each column range from bright in the lower disc to pale in the top one. The bottom disc has a spring allowing one of two opposite balls to be pushed in, creating a gap. The balls can then slide up or down their groove from one disc to another because of the gap. By rotating the discs, the balls and the gap are moved around to the other columns.

Other related puzzles are the Whip-It Tower, and Missing Link.

The number of positions:
There are 36 balls and a gap which gives a maximum of 37! positions. However the colours are equivalent, meaning that it does not matter which colour goes in which column. This gives 37! / 6! = 19,116,323,737,814,368,119,883,304,974,417,920,000,000 or 1.9·1040 positions.

Solution 1:
It can be solved in layers, disc by disc from the bottom up starting with the brightest colours. Start by pushing in one of the balls to create a gap.

Phase 1: How to solve a disc.

  1. Find a ball that belongs in the disc but which is not in the correct position.
  2. If the ball is in the disc already, just in the wrong place then move it to the layer above:
    1. Shift balls down to get the gap in one of the discs above the ball.
    2. Rotate discs to place the gap above the ball in the same column.
    3. Shift the ball up.
    4. Rotate the ball to a different column and drop another ball in the gap.
  3. If the ball does not lie one layer immediately above the disc being solved then:
    1. Rotate a disc to place the gap in a different column to the ball.
    2. Shift the column up/down to get the gap in the disc below the ball.
    3. Rotate discs to place the gap beneath the ball.
    4. Shift the ball down.
    Repeat until the piece lies in the layer immediately above the disc being solved.
  4. Place the piece correctly as follows:
    1. Rotate discs to place the piece in a different column than its destination, and the gap in the destination column.
    2. Shift the column up/down to get the gap in the disc below the piece.
    3. Rotate discs to place the gap beneath the piece.
    4. Shift the piece down.
    Note the similarity to step b.
  5. Repeat a-d above until the whole disc is solved.
The method above can solve any of the layers of the tower, except for the top one. There are a few minor differences when solving the first layer because of the spring mechanism that creates the gap. First push in one ball to create the gap. Solve the ball on the other side. Then pull out the first ball and push in the solved one. Now continue the method as above.

Phase 2: Solve all but top disc.
Repeat phase 1 with the remaining discs until everything except the last disc is solved.

Phase 3: Solve top disc.

  1. If the permutation of the balls and the gap (where the gap belongs in the column of the pushed-in ball) is odd, then rotate the disc one step, i.e. 1/6 of a turn.
  2. Rotate the top disc an even number of steps (i.e. 1/3 turn) to put as many pieces correct as possible.
  3. To solve the remaining balls, the following sequences will come in handy.
    Let a and A denote the top balls of one column, b and B those of another column etc., and let Z be top ball of the column with the gap. The following diagrams show how certain positions can be solved:

      B A   BaA   Ba   Bab    ab  Aab  A b  ABb  AB
      abZ    bZ   AbZ  A Z   ABZ   BZ  aBZ  a Z  abZ

      BCA   BCAa   CAa  cCAa  c Aa  cBAa  cB a  cBCa   BCa  ABCa  ABC
      abcZ   bcZ  BbcZ  Bb Z  BbCZ   bCZ  AbCZ  Ab Z  AbcZ   bcZ  abcZ
    Both of these cycle three things in the top disc, the first cycles two balls and the gap, the second three balls. Note that the relevant columns need not be adjacent nor in the order as shown here. Simply mentally name the columns a, b, Z (and c) and move the balls between these columns as shown above wherever they may physically be on the puzzle.
    From step a, the balls have an even permutation, so these 3-cycles suffice to solve it. If you end up with exactly two balls swapped (or only a ball and the gap swapped) then it was an odd permutation so go back to step a to rectify it.

Solution 2:
It can also be solved in columns.

Phase 1: Place each colour into a column.
This phase is virtually the same as solving the Whippit puzzle.

  1. Decide which colours the columns will have. To speed things up, you could rotate some discs to partly solve some columns already.
  2. Push in a ball to create a gap.
  3. Look at the column containing the gap, and determine which colour the column has.
  4. Find a piece of the required colour in a different column. If there are none, and the columns are not yet one colour each then find any piece on the puzzle that is incorrect.
  5. Slide pieces in the column up or down until the gap is in a layer next to the layer that contains the piece.
  6. Rotate the layer with the gap until it lies above or below the piece.
  7. Slide the piece up or down into the gap.
  8. Rotate the layer back to its original position, which brings the piece into the column as required.
  9. Repeat steps b-g until the puzzle is solved. At some point you should also let out the pushed in ball, and push in the ball on the other side. Do this any time that the bottom two balls of the column on the other side have been solved.
Note that in practice it is quicker to move not just the one layer, but all the layers above/below it as well.

Phase 2: Order each colour, except for top two layers.

  1. There now follows a method of moving a ball up two layers, passing over two balls which drop down one layer. This is a 3-cycle.
    First create a gap in any other column.
  2. Bring the gap to the layer above the ball to move.
  3. Use the method of phase 1 to bring the ball to the position of the gap. (Rotate the gap above the ball, move ball up, rotate disc back again.)
  4. Bring the gap to the layer above the ball to move.
  5. Again insert the ball into the position where the gap is.
  6. Use steps b-e to place the correct 4 balls in the bottom 4 positions of the column. Note that the top two balls may now either be correct, or they need to be swapped.
  7. Now get rid of the gap by releasing the pushed in ball.
  8. Solve each column in the same way.

Phase 3: Swap the top two balls of any columns that need it.

  1. If there is an odd number of columns that need their top balls swapped, then turn the top layer 60 degrees (i.e. one step) and go back to phase 1. It will not take long to fix this problem since the bottom 4 layers need not be disturbed.
  2. If there are two or more columns that need swaps, then choose any two of them, and create a gap in a third column.
  3. Do the sequence shown in the following diagrams.

      ab   abA  a A  aBA  aB   aBb   Bb  ABb  AB
      ABZ   BZ  bBZ  b Z  bAZ   AZ  aAZ  a Z  abZ
    Note that the relevant columns need not be adjacent nor in the order shown in these diagrams. Simply mentally name the columns a, b, and Z and move the balls between these columns as shown above wherever they may physically be on the puzzle.
  4. Repeat steps b-c until the puzzle is solved.

Home
Links
Guestbook


Lights Out

Description of Lights Out (Classic)
Quiet patterns
Number of positions
Solution for Lights Out
JavaScript Lights Out
Using the minimal number of moves

The underlying mathematical theory

Lights Out 2000
Quiet patterns
Number of positions
Solution for Lights Out 2000
JavaScript Lights Out 2000

Lights Out Cube
Quiet patterns
Number of positions
Solution for Lights Out Cube
JavaScript Lights Out Cube

Further variants of the game
Lights Out Deluxe
Other variants
JavaScript Lights Out Variants

Links to other useful pages:
Tiger Toys, the manufacturers of the game has a Lights Out 2000 page. The Lights Out manuals are also available in Adobe pdf format.
Matthew Baker's Lights Out page has lots of good info about the puzzle and its many variants.
Ken's page. The Lights Out Fan Club.
Rik's Handheld game museum has a picture of Vulcan's XL25, the first commercial version of the game.
Gareth Richards' page has a Java version of the Lights-Out Cube.
David Guichard's page. A simple Java version of the game.
Al Geist's page Another Java version of the game.

Description:
This electronic puzzle by Tiger Toys consists of a 5×5 grid of buttons which also have lights in them. By pressing a button, its light and those of the (non-diagonally) adjacent buttons will change (switch on if it was off, and vice versa). Given a pattern of lights, you have to switch them all off by pressing the correct buttons. Not only that, but you have to do it in as few moves as possible.

This is the one of the few non-trivial puzzles I know in which the order that the moves are performed is unimportant (i.e. the puzzle positions form an Abelian group). This means that it is not necessary to press any button more than once during the solution because we could change the order of the moves so that repetitions occur together. Since pressing a button twice will not change anything, a button need only be pressed at most once.
Another puzzle of this kind is the Rubik's Clock puzzle, or the Orbix puzzle (type 1).

The first electronic version of this game was called the XL-25, was produced by Vulcan Electronics in 1983, and it was invented by László Mérõ. It not only could play the now standard game where each button changes a cross of lights, but also played a variant where each button changes its own light and those lights which are a chess knight's move away. An even older electronic game called Merlin was played on a 3x3 grid but its moves were slightly different.

Quiet patterns:
Actually we only need to use 23 of the 25 buttons to solve any position. To show this, we can use the following 'quiet' patterns, button patterns which when pressed will leave the lights unchanged.
X | X | X
X | X | X
X | X | X
X | X | X

X | X | X | X
X | X | X | X
X | X | X | X

 | X | X | X |
X |  | X |  | X
X | X |  | X | X
X |  | X |  | X
 | X | X | X |

Note the pattern on the right is simply a combination of the other two. These quiet patterns can be used to decrease the number of moves in a solution, but more of this later.

Using these patterns, we can see why we need never press the first two buttons. Instead of pressing them, we can use the following button patterns to get the same effect:
 | X | X
X | X | X
X | X | X
X | X | X

 |  | X | X |
X |  | X |  | X
X | X |  | X | X
X |  | X |  | X
 | X | X | X |

The number of positions:

From the above it follows that there are at most 223 positions (because there are only 223 button patterns which can solve it). As there are no further quiet patterns, all these button patterns have different effects on the lights. Therefore there are 223 = 8,388,608 possible light patterns attainable.

It is actually easy to test if a position can be solved. Look at the first quiet pattern, and consider the lights marked there. Any of the 25 button presses will change an even number of the marked lights. Therefore, the only solvable patterns have an even number of the marked lights switched on. The same holds for the second pattern. If both these sets of lights have an even number of them lit, then the pattern is solvable.

The table below shows how many positions there are for each number of buttons pressed. There is no position that needs more than 15 button presses to solve. Where before the quiet patterns were used so as not to press the first two buttons, now the quiet patterns are used to minimise the total number of moves.
# Buttons | # Positions
0 | 1
1 | 25
2 | 300
3 | 2,300
4 | 12,650
5 | 53,130
6 | 176,176
7 | 467,104
8 | 982,335
9 | 1,596,279
10 | 1,935,294
11 | 1,684,446
12 | 1,004,934
13 | 383,670
14 | 82,614
15 | 7,350
Total | 8,388,608

Solution of Lights Out (Classic):
Number the rows 1-5, the columns A-E.

  1. For each light on row 1, press the button beneath it on row 2 to turn the light off. This way row 1 is completely unlit.
  2. Repeat step a for rows 2-4, so that now you only have lights on row 5. This is usually called 'chasing the lights'.
  3. If the light at A5 is on, press D1 and E1.
    If the light at B5 is on, press B1 and E1.
    If the light at C5 is on, press D1.
  4. Repeat steps a-b, chasing the lights down and it will be magically solved.
This method will not solve the puzzle in the shortest possible way, but it is very simple.

If your browser has JavaScript, then you can play the standard Lights Out game:

JavaScript Lights Out (Classic)

Solving in the minimal number of moves:

To solve a puzzle in the minimal number of moves, first use steps a-c above to find out which buttons should be pressed in the top row. Restart the puzzle, and begin by pressing those top row buttons and chase the lights down. If this did not solve it in the minimal number of moves, then you should try to combine your solution with each of the three quiet patterns. One of these will give a minimal solution.

An example:
Look at the patterns below. Suppose you have the light pattern on the left. Chasing the lights produces the next light pattern. From the algorithm above, you know that if you pushed B1 and D1 first (E1 cancels) then you would have solved it. If you solve the first pattern again using this fact, then you will have used the button pattern shown. This uses 14 moves. If you combine this with the first quiet pattern, you get a worse solution (16 moves), with the second quiet pattern you get a 10 move solution, but with the third and final quiet pattern you get the optimal 8 move solution shown.
Light pattern After chasing First solution Optimal solution
 | X |  | X |
 | X | X | X | X
X | X |  | X | X
X | X | X | X | X
X | X | X | X | X

X | X | X | X

 | X |  | X |
X |  |  |  | X
X | X | X | X |
 |  | X | X | X
 | X |  | X | X

 | X |  |
 | X |  |
 | X |  | X
X |  | X |
 | X |  | X

The built-in puzzle problems can be solved using the above method, or you can simply look up the solution on this page.

The underlying mathematical theory

A good reference for the mathematics is Issue 7/8 of Cubic Circular (David Singmaster, Summer 1985) which has an analysis of the XL-25, and much of the information below is based on that.

Consider the lights as a list (or vector) of 25 values, 0 if the light is off, or 1 if the light is on. Thus any position can be written as such a vector of 25 noughts and ones. The effect of a button press (or several presses) can also be written as a list of 25 bits; 0 of a light does not change, and 1 if a light changes because of the button pattern. If you apply a button pattern to a particular position, then the result is described by a vector which is the sum of the two vectors modulo 2. This means that the result for a particular light is computed by adding the corresponding entries in the two vectors, and that if we have two ones then the result of 1+1 should be 0 (a light which is on, and is changed by a button pattern, will be off afterwards). You might also consider this an 'exclusive Or' operation on a 25 bit word.

Summation is commutative, in other words it doesn't matter in which order we add things up. This means that it also doesn't matter in which order vectors are added up, and therefore the effect of several button presses is simply the sum of their individual effects in any order. Such summation of vectors can be written as a matrix multiplication.

Lets work out the matrix algebra explicitly:
Let A be a matrix where aij is 1 if button j changes light i, or 0 otherwise.
Let p be starting position vector, i.e. pi is 1 if light i is on at the start, 0 otherwise.
Let x be the button pattern we press, i.e. xj is 1 if we press button j, or 0 if not.
Let r be the end position vector, i.e. ri is 1 if light i should be on at the end, 0 otherwise.

The state of light i afterwards is then given by its state at the beginning, plus the effects of all the button presses have on it. Algebraically this is

    ri = pi + Sumj aijxj
or in matrix form:
    r = p + A x
    or
    A x = r - p = c
Here c=r-p is the difference between the start and end position, or in other words the pattern of lights that have to be changed. Normally we know A and c (we know what the buttons do, and which lights we want to change), and want to find out x (the buttons we have to press to do it). This essentially boils down to solving 25 equations in 25 unknowns, which is a lot of work to do by hand, each time you want to solve the puzzle. If however we can invert the matrix A, we get:
    x = A-1 c
This makes it a lot simpler; to solve any position, all we have to do is plug in the numbers, and out comes the button pattern we need. Each light pattern will directly give a unique button pattern needed to solve it.

Lets call the entries of the A-1 matrix bij, and examine them more closely. Suppose we try to only change light k, so ck=1 and all other ci=0. This isolates one column of the matrix:

    xj = Sumi bij ci = bkj
This means that the columns of A-1 are the button patterns that change each light individually. Calculating A-1 from A is straightforward, and can be found in any linear algebra book.

Unfortunately not every matrix A that occurs in this context is invertible. This happens when it is not possible to find a button pattern for each light that changes only that light and no others. In other words, the lights are not all independent from each other. The rank m of a matrix A is the number of rows that are independent from each other. In the standard game, the rank of A is m=23, because the effect of two moves can be simulated by using the other 23 buttons.

All is not lost when A is not invertible. Instead of using all the lights, and all the buttons, we use only the independent buttons, and their lights. In the normal game we therefore no longer use the 25×25 matrix A, but a 23×23 matrix which is invertible.

There are however practical reasons for using the full matrix A. For a start, we don't know beforehand what the rank is of matrix A, and only find this out when trying to calculate its inverse. Furthermore, the pseudo-inverse B we get in that case has as a sub-matrix the inverse of the smaller matrix, together with columns containing (generators of) the quiet button patterns.

Note that if you want to analyse a game by hand, these matrices are all far too large. In the standard game, it is easier to use the fact that you can chase the lights. Press a button on the top row, chase the lights down, and see the effect on the bottom row. This way there are 5 possible button presses (the top row) with their effect on 5 lights (the bottom row). This leads to a much smaller matrix, only 5×5 on the standard game.

The inventor, László Mérõ, has examined whether matrix A is invertible or not for all square board sizes up to 100×100. It is invertible in the cases 1-3, 6-8, 10, 12, 13, 15, 18, 20-22, 25-28, 31, 36-38, 40, 42, 43, 45, 46, 48, 51, 52, 55-58, 60, 63, 66, 68, 70, 72, 73, 75, 76, 78, 80-82, 85-88, 90, 91, 93, 96, 97, 100. There is no obvious pattern.

There are some interesting patterns for which the affected lights are exactly the same as the buttons pressed. This means that:

    x = A x
    or
    (A - I) x = 0
where I is the identity matrix. Such patterns are eigenvectors of the matrix. These are actually found more easily by just playing the game. Press any button on the top row, and chase the lights down in such a way that the each row has just those lights on in the buttons that were pressed. You will find that the last row also has that property, so the pattern you created is such an 'eigenpattern'. Since this works with any single button press in the top row, it will also work with any combination of buttons on the top row. There are therefore 2n such patterns on an n×n board.

Most variations of the Lights Out game have a symmetric matrix (i.e. aij = aji) which means that if pressing one light changes a second light, then pressing that second light will also change the first. The solvability check that was mentioned in the section above on the classic game works in any symmetric lights out variation. Pressing the buttons of a quiet pattern will by definition change each light an even number of times so that in the end nothing has changed. Therefore each light is affected by an even number of the buttons in the pattern. By symmetry, every button will affect an even number of lights in the quiet pattern. A solvable position must have an even number of lights switched on in each quiet pattern arrangement for it to be possible to bring this number down to zero. All solvable light patterns will certainly satisfy these parity restrictions, and by counting how many patterns pass this test, it can be shown that only solvable patterns qualify and no others.

Lights out games usually have a matrix which is also reflexive (i.e. aii = 1), or in other words pressing a light will always change its own state. These reflexive symmetric games have the nice property that it is always possible to solve the pattern with all lights on.

Theorem:
Every reflexive, symmetric Lights Out game is solvable, i.e. it is possible to switch all the lights off when starting with all the lights on.

In Cubic Circular it says that Laszlo has proved this result, but the proof below is my own. To prove the theorem, I will need to prove a simpler result first.

Lemma:
In a symmetric Lights Out game with an odd number of buttons, there is always some button that affects an even number of other lights. This can also be stated in an equivalent way which is easier to understand: At a gathering of an odd number of people, there is always someone who shakes hands an even number of times.

Proof of lemma:
Suppose there are n people at the gathering, with n odd. Let mi be the number of times that person i shakes hands. The total number of handshakes must therefore be (m1+m2+...+mn)/2, because each handshake has two people taking part. This is a proper integer only if the sum is even, which can only mean that not all mi can be odd. Therefore at least one person shakes hands an even number of times.

Proof of theorem:
If there were unsolvable ones, then there would have to be one with the smallest possible number of lights, say n. In other words, any game with n-1 buttons is solvable, but we have a particular game with n buttons that is not.

For any light/button i, the other n-1 buttons and lights form a smaller game and are therefore solvable. Changing those n-1 lights will however not change light i because we have assumed this game was unsolvable. We can therefore find n patterns which each change everything except for a single light.

Suppose we perform these n patterns which each change all but one light. Every light will now have changed n-1 times. If n were even, this would mean that every light has changed state which would make our game solvable. Therefore our unsolvable game must have n odd.

Suppose there were some button pattern we could press which changes the state of an odd number of lights. For each light that was changed, perform the pattern which changes everything except that light. Now every light will have changed an odd number of times, which again would make the game solvable. Therefore all button patterns in an unsolvable game change an even number of lights.

So far I have proved that the smallest unsolvable symmetric game must have an odd number of lights/buttons, and that every button pattern changes an even number of lights. However, if the game is reflexive, then from the previous lemma there must be some button which changes an odd number of lights (itself and an even number of others). Therefore there can be no unsolvable reflexive symmetric Lights Out game.
Q.E.D.

Corollary:
Every quiet pattern in a symmetric reflexive game has an even number of buttons. This follows directly from the solvability check of the position with all lights on.

There is also a short algebraic proof of this corollary. If A is a reflexive symmetric matrix, then modulo 2 we get

    xT A x = xT I x = xTx
because all cross terms occur twice and hence cancel modulo 2. If x is a quiet pattern, i.e. Ax=0, then
    xTx = xT A x = xT 0 = 0
which means that x must use an even number of buttons. This alternative proof heavily relies on the fact that we are working modulo 2. The first longer proof does not, and that therefore also applies with minor modification to the Lights Out 2000 below which uses modulo 3 arithmetic..

Lights Out 2000

Description of Lights Out 2000:
This version is very similar to the classic version, i.e. a 5×5 grid of buttons with lights which you have to switch off in as few moves as possible. The difference lies in the fact that now the lights are not just on or off, but has 3 states - off, red, or green. When a button is pressed the same lights change as before, but now they go from off to red to green and then off again.

If you buy only one Lights-Out game, I would recommend this one, because not only does it do this 3-state puzzle, it also incorporates the classic Lights Out puzzle above, and has an action game and a 2 player game as well. In fact, this has replaced the classic Lights Out, and is now being sold without the 2000 tag.

The mathematics of the 3-state puzzle is much the same. The move order is unimportant, and pressing a button three times has no effect, so no button has to be pressed more than twice to solve any position. All the mathematics works the same way, except that the arithmetic is done modulo 3 instead of modulo 2. The proofs in the mathematics section above still hold.

Quiet patterns:
This puzzle also has five types of quiet patterns: (grey means press once, black twice)
1 |  |  | 2
2 | 2 | 1 | 1
1 | 2 | 1 | 2
1 | 1 | 2 | 2
 | 2 | 1 |
1 |  | 1 |  |
2 | 1 | 2 | 2 |
2 | 1 |  | 2 | 1
1 | 2 | 1 | 1 |
1 | 1 | 2 | 2 | 1

 | 1 | 2 | 2 | 2
2 |  | 1 |  | 2
1 | 2 |  | 1 | 2
1 |  | 2 |  | 1
1 | 1 | 1 | 2 |
1 | 2 | 1
2 | 1 | 2
1 | 2 | 1
2 | 1 | 2

1 | 1 | 2 | 2
1 | 1 | 2 | 2
2 | 2 | 1 | 1
2 | 2 | 1 | 1

These patterns can occur in any orientation, in mirror image, or with the colours swapped. Together with the trivial quiet pattern (no buttons pressed at all) this leads to 27=33 quiet patterns. This suggests that this time there are three buttons that need never be used.

The number of positions:
Three buttons need never be used to solve the puzzle, so 22 buttons are enough. Each button can be pressed up to two times, giving a total of 322 = 31,381,059,609 positions for the lights.

The built-in puzzles need between 5 and 24 moves to solve, and this seems to imply that any position can be solved in at most 24 moves. I have now verified this by calculating the table below, which shows the number of possible positions for each number of buttons pressed.
# Buttons | # Positions
0 | 1
1 | 25
2 | 325
3 | 2,900
4 | 19,850
5 | 110,630
6 | 520,948
7 | 2,125,078
8 | 7,644,164
9 | 24,561,916
10 | 71,147,752
11 | 186,876,765
12 | 446,015,084
13 | 964,537,892
14 | 1,872,111,656
15 | 3,203,446,007
16 | 4,709,112,417
17 | 5,767,439,109
18 | 5,710,406,148
19 | 4,433,675,458
20 | 2,590,026,921
21 | 1,073,252,214
22 | 279,734,731
23 | 36,143,633
24 | 2,147,985
Total | 31,381,059,609
The first 7 entries were first calculated by hand, but the remaining ones were counted by computer. Note that two of the patterns with 6 button presses have the same effect on the lights as two others (because of the fourth quiet pattern in its 4 orientations), so the number of positions at level 6 is two less than the 520950 you would otherwise expect.

Solution to Lights Out 2000:

  1. For each light on row 1, press the button beneath it on row 2 once or twice to turn the light off. This way row 1 is completely unlit.
  2. Repeat step a for rows 2-4, so that now you only have lights on row 5. This is usually called 'chasing the lights'.
  3. If the light at A5 is red then press B1 twice, if it is green press it once.
    If the light at B5 is red then press A1 and B1 twice, if it is green press them once.
  4. Repeat steps a-b, chasing the lights down and it will be magically solved.
To get a minimal solution, the same method can be used as for the classic version, except that there are now 26 quiet positions to check.

The built-in puzzle problems can be solved using the above method, or you can simply look up the solution on this page.

If your browser has JavaScript, then you can play the Lights Out 2000 game:

JavaScript Lights Out 2000.

Lights Out Cube

This version is like the classic Lights Out (all lights are either on or off) except that it is played on a 3×3×3 cube. Whereas the classic Lights Out has edges, the cube does not, so each light always has 4 neighbours, and every button press changes exactly 5 lights. This interesting variant can be solved using similar methods, except that light chasing is very different and much more complicated.

Quiet patterns:
The cube has 26 = 64 quiet patterns. This is a lot, but this is partly because the cube has more symmetry than a square. There are actually 8 types of quiet pattern, which can be applied in several orientations. They are shown below. By applying the first of these patterns in several orientations, you can also generate the other 7 patterns.
X
X
X | X
X | X

X | X | X
 | X |
X | X
X | X

X | X | X
 | X |
X
X
X | X
X | X

X | X
X | X

X | X
X | X

X | X
X | X

X | X |
X |  | X
 | X | X
X
X
X
X
X
X
X
X
 | X | X
X |  | X
X | X |
 | X |
X |  | X
 | X |
X | X | X
X |  | X
X | X | X

X | X | X
X |  | X
X | X | X

X | X | X
X |  | X
X | X | X

X | X | X
X |  | X
X | X | X

 | X |
X |  | X
 | X |
X |
X | X
 | X

X |
X | X
 | X

X | X |
 | X | X

 | X
X | X
X |
 | X | X
X | X |
 | X
X | X
X |
X | X
X | X
X | X

X | X | X
 | X |
X | X
X | X

X | X | X
 | X |
X | X
X | X

X | X
X | X
X | X

 | X
X |
X | X |
X |  | X
X | X |
X | X |
X |  | X
X | X |
 | X | X
X |  | X
 | X | X

 | X | X
X |  | X
 | X | X

X |
 | X

 | X |
X |  | X
 | X |
 | X |
X |  | X
 | X |
 | X |
X |  | X
 | X |
 | X |
X |  | X
 | X |
 | X |
X |  | X
 | X |
 | X |
X |  | X
 | X |

The number of positions:
There are 26 quiet patterns, which means that the 54 buttons do not generate 254 patterns, but 254-6 = 248 = 281,474,976,710,656 positions. The manual incorrectly calls this 'over 200 quadrillion', as it is a mere 281 trillion.

The table below shows the number of possible positions for each number of buttons pressed. It shows that no positions need more than 29 moves to solve.
# Buttons | # Positions
0 | 1
1 | 54
2 | 1,431
3 | 24,804
4 | 316,251
5 | 3,162,510
6 | 25,827,165
7 | 177,100,560
8 | 1,040,446,486
9 | 5,317,168,916
10 | 23,913,642,226
11 | 95,457,369,144
12 | 339,930,538,185
13 | 1,080,757,481,134
14 | 3,053,070,032,511
15 | 7,576,816,216,796
16 | 16,233,040,500,987
17 | 29,396,466,092,822
18 | 44,029,343,202,869
19 | 53,442,675,203,992
20 | 51,578,158,468,634
21 | 38,836,356,522,788
22 | 22,350,616,115,974
23 | 9,607,958,387,296
24 | 3,013,785,631,536
25 | 680,837,208,384
26 | 113,169,453,024
27 | 14,576,836,608
28 | 1,391,192,064
29 | 89,579,520
total | 281,474,976,710,656

Solution to the Lights Out Cube:
1 | 2 | 3
4 | 5 | 6
7 | 8 | 9

10 | 11 | 12
22 | 23 | 24
34 | 35 | 36

13 | 14 | 15
25 | 26 | 27
37 | 38 | 39

16 | 17 | 18
28 | 29 | 30
40 | 41 | 42

19 | 20 | 21
31 | 32 | 33
43 | 44 | 45

46 | 47 | 48
49 | 50 | 51
52 | 53 | 54

  1. Number the buttons/lights as shown above (which is different to the numbering in the manual).
  2. First you must simplify the position by chasing the lights:
    If 5 is lit, then press it to switch it off.
    If 1, 2 or 3 are lit, then press the buttons below them, i.e. 21, 20, or 19, to switch them off.
    If 7, 8 or 9 are lit, then press the buttons below them, i.e. 13, 14, or 15, to switch them off.
    If 4 or 6 are lit, then press the buttons below them, i.e. 11 or 17, to switch them off.
    If any of 10-21 are lit, then press the buttons below them, i.e. 22-33 to switch them off.
    If any of 22-33 are lit, then press the buttons below them, i.e. 34-45 to switch them off.
    If 35 or 41 are lit, then press the buttons below them, i.e. 49 or 51, to switch them off.
    If 37, 38, or 39 are lit, then press the bottoms below them, i.e. 46, 47, or 48, to switch them off.
    If 43, 44, or 45 are lit, then press the bottoms below them, i.e. 54, 53, or 52, to switch them off.
    If 50 is lit, then press it to switch it off.
  3. There are now only lights on in the bottom face or at 34, 36, 40, 42.

    4. If 40 is lit, then press the buttons 3 and 4.
    If 36 is lit, then press the buttons 4 and 16.
    If 46 is lit, then press the buttons 16 and 10.
    If 34 is lit, then press the buttons 10 and 1.
    If 47 is lit, then press the buttons 4.
    If 49 is lit, then press the buttons 2, 12 and 16.
  4. Repeat step b, chasing the lights down and it will be magically solved.

If your browser has JavaScript, then you can play the Lights Out Cube game:

JavaScript Lights Out Cube.

Further variants

Lights Out Deluxe
There are a few other variations of the classic Lights Out game possible. The most obvious change you can make is the board size. It can of course be played on a square or rectangular board of any size. The basic solving strategy does not change, although each board size will have its own quiet patterns (or possibly none at all).

The 6×6 version was manufactured by Tiger and sold as the Lights Out Deluxe. On this version you could also play the game with a different kind of move. Pressing a button now changes the lights in a diagonal cross pattern, i.e. pressing a button changes its own light and the diagonally neighbouring ones. The effect of a move is thus like a × intead of a +. There are no quiet patterns for either of these move types on this board size, so there are always 236 = 68,719,476,736 possible positions.

Solution for Lights Out Deluxe (move type +):
Number the rows 1-6, the columns A-F.

  1. For each light on row 1, press the button beneath it on row 2 to turn the light off. This way row 1 is completely unlit.
  2. Repeat step a for rows 2-5, so that now you only have lights on row 6.
  3. If the light at A6 is on, press A1 and C1.
    If the light at B6 is on, press D1.
    If the light at C6 is on, press A1 and E1.
    If the light at D6 is on, press B1 and F1.
    If the light at E6 is on, press C1.
    If the light at F6 is on, press D1 and F1.
  4. Repeat steps a-b, chasing the lights down and it will be magically solved.
As there are no quiet patterns on this board size, this solution will always use the minimal number of moves.

Solution for Lights Out Deluxe (move type ×):
Number the rows 1-6, the columns A-F.

  1. Press a combination of buttons on row 2 such that the lights on row 1 are switched off. This seems tricky, but is quite easy once you know how. First switch off lights A1, C1, E1 from left to right as follows:
    1. If A1 is on then press B2.
    2. If C1 is on then press D2.
    3. If E1 is on then press F2.
    Next switch off lights A2, A4, A6 from right to left as follows:
    1. If F1 is on then press E2.
    2. If D1 is on then press C2.
    3. If B1 is on then press A2.
    Now row 1 is completely unlit.
  2. Repeat step a for rows 2-5, so that now you only have lights on row 6.
  3. If the light at A6 is on, press F1.
    If the light at B6 is on, press E1.
    If the light at C6 is on, press D1.
    If the light at D6 is on, press C1.
    If the light at E6 is on, press B1.
    If the light at F6 is on, press A1.
    Note how the button pattern to press on the top row is the mirror image of the light pattern on the bottom row.
  4. Repeat steps a-b, chasing the lights down and it will be magically solved.
For this move type there are again no quiet patterns, so this solution will always use the minimal number of moves.

Other variations:

Instead of changing the shape of the board, the type of move could also be changed, for example instead of (or as well as) the lights horizontally / vertically adjacent changing, those diagonally adjacent could change too. Maybe the button you press does not itself change. All these variants will produce a different puzzle.

The behaviour at the edges of the board can be changed too. The columns of buttons on the left and right sides could be considered to be adjacent, i.e. as if the board were curved around into a cylinder. If the top and bottom sides are also considered adjacent, the board is in effect a torus. On this board it is more difficult to chase lights effectively because you will not end up with a single row of lights but two rows of lights. The 4×4 version was made commercially as a the Lights Out Keychain.

If your browser has JavaScript, then you can play many Lights Out variants by clicking the link below. The board can be any size from 3×3 to 10×10, can be a rectangle, cylinder or torus, and the move shape can be changed too. It is a little slow however when you change the board size or move type, because it has to find the new move matrix and invert it, as explained in the mathematics section above.

JavaScript Lights Out Variants.

Home
Links
Guestbook


Lights Out Solutions

Below is a table with the solutions to the 50 built-in puzzles of the classic Lights-Out game. Only the top row button presses are given. To use the table, just look up the row for the particular puzzle you are solving, and press the given combination of buttons on the top row. Then 'chase the lights' down the board, i.e. solve each row in turn by pressing the buttons directly beneath each of the lights. The final row should automatically be solved after the row above it is off. The solution shown here is not always unique.
Set 1 Set 2
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
X |  |  |  | X
 | X |  | X |
 | X |  |  | X
 | X |  | X |
 | X |  |  |
 |  | X |  |
X |  | X | X | X
 |  | X | X |
 |  | X |  |
X |  |  |  | X
 |  | X | X |
 | X |  | X | X
X |  |  |  | X
 |  |  | X |
 |  | X |  |
 |  | X |  |
 |  | X | X |
 | X |  |  | X
 | X |  |  | X
X |  |  |  | X

 | X |  |  | X
 | X |  |  | X
 | X |  |  | X
X | X |  |  |
X | X |  |  |
 |  | X | X | X
 |  | X |  |
 |  |  | X |
 |  | X |  |
 | X |  |  | X
 | X |  |  | X
 |  | X |  |
 | X |  |  | X
 |  | X |  |
 | X |  |  | X
 | X |  |  | X
 | X |  |  | X
X | X |  |  |
X |  |  |  |
 | X |  |  | X
X | X |  |  |
X | X |  |  |
 | X |  |  | X
X | X |  |  |

Below is a table with the solutions to the 100 built-in puzzles of the Lights-Out 2000 game. Only the top row button presses are given, just as in the table above. Grey means press once, black twice.
Set 1 Set 2 Set 3 Set 4
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
2 |  |  |  |
 | 2 |  |  |
 | 1 |  |  |
 |  | 1 |  |
2 |  | 1 |  | 2
 | 2 |  | 2 |
 | 1 |  | 1 |
 |  | 2 |  |
 | 2 |  |  |
 | 2 |  |  |
 | 1 |  | 1 |
1 | 2 | 1 |  |
1 |  | 1 |  | 1
 |  | 1 |  |
 | 1 |  | 1 |
 | 1 | 1 |  |
 | 1 | 2 |  |
 | 2 |  |  |
 |  |  |  | 2
 |  | 1 |  |
 |  | 1 |  |
 |  | 2 |  |
 | 1 | 1 |  | 1
 |  | 2 |  |
 | 2 |  | 2 |
 |  | 2 |  |
 |  |  | 1 | 1
2 | 1 |  |  |
1 |  | 2 |  | 1
2 |  | 1 |  | 2
 |  |  | 1 | 1
 | 1 | 2 |  |
2 |  | 1 |  | 1
 | 1 |  |  | 2
 |  |  |  | 2

 | 1 | 1 |  | 2
1 | 1 |  |  | 2
 |  | 2 |  |
1 | 2 |  | 1 | 2
1 | 1 |  | 1 |
1 |  |  | 1 | 2
2 | 1 |  |  |
2 |  |  |  |
2 |  | 2 | 2 |
1 | 2 |  |  |
 | 2 |  | 2 | 2
 |  | 2 |  |
 | 1 | 1 |  | 2
 | 1 | 1 |  |
 |  | 2 |  |
1 |  |  |  |
 | 1 | 2 |  |
2 | 1 | 2 |  |
1 |  | 1 |  |
2 |  |  | 1 | 1
 | 1 |  |  |
2 |  |  |  |
 | 2 | 2 |  |
1 |  |  |  |
 |  | 1 | 2 | 1
1 | 1 |  |  |
 | 2 | 2 |  | 1
 | 2 |  |  |
2 |  |  |  |
1 | 1 | 1 |  |
1 |  | 1 | 1 | 1
1 |  |  | 2 |
 | 2 |  |  |
2 | 2 |  |  |
 | 1 |  |  |
 |  |  | 1 |
1 | 1 | 1 |  |
 | 2 |  |  |
 |  |  | 2 | 1
2 | 2 |  |  |
1 |  |  | 2 | 1
 |  |  | 1 |
1 | 1 |  |  |
 | 2 | 1 |  |
 | 1 | 1 |  |
 |  |  | 1 |

Home
Links
Guestbook


Rubik's Magic

Picture kindly supplied by Hendrik Haak

Rubik's Magic
How the tiles hinge
3 useful transformations of the 2x4 rectangle
Getting back to the starting position
The shape changing transform
The number of positions
Solution
One more transform
Create the Cube puzzle
Solution to Create the Cube
Making the cube
Master Edition of Rubik's Magic
Solution to the Master Edition
Flat shapes

Links to other useful pages:
Juergen Koeller's page. A solution, also available in German. Now has all possible symmetric shapes.
Chris Eggermont's page. A list of shapes you can try to make.
Chris Eggermont's page. A solution to the Master Edition.
Richard's Rubik's Magic page. A solution to the normal Magic, with (very) large images of each step so slow to load.
How to solve Rubik's Magic by TeeJay Wallace. A slightly unusual graphical solution. Part of the strange Swing-machine online humourous magazine.
Javier Santos' page. A Spanish solution.
Arlet Otten's page. A description from the rec.puzzles archive of the shape changing transformation (See number 4 below).
Twisty Megasite. This has some pages about restringing the magic, or even making a larger version of the puzzle.
Wei Huang's image shows another way to get a cube shape (see also my method below)
Ronald Bieber's page has a textual solution to Rubik's Magic in German.

Rubik's Magic
This amazing puzzle consists of 8 tiles arranged in a 2x4 rectangle. They are connected to each other by wires that run in diagonal grooves on the tiles alternatively under and over them. If two of the tiles lie on top of each other, the wires allow them to be unfolded in two perpendicular directions provided connections to the other tiles do not restrict the movements. The kind of wire arrangement can also be found in certain wallets which can be opened in two different directions because of the ribbons connecting the two halves.

On one side of the tiles is a picture of three separate rings. On the other side is a mixed up picture of three linked rings. The aim is to link the rings by unscrambling this other side. When solved, its shape is a 3x3 square with one corner missing.

The original version of Rubik's Magic is black with rainbow coloured rings, and was made by Matchbox in the mid-eighties. Rubik has recently released it again, this time manufactured by Oddzon, but now it is red with yellow rings. In 1987 there was also a Master Edition which has 2x6 silver coloured tiles and has 5 rings on each side, but there the rings must be unlinked. One quite rare version of Rubik's Magic was 'Create the Cube', in which the 8 tiles where coloured differently, and the aim was to make the cube shape so that the colours matched.

How the tiles hinge.
Each tile is connected to exactly two others. For the moment lets just consider two connected tiles in isolation. Fold one on top of the other. There will now always be two ways the top one can be unfolded; either back the same way, or in a direction perpendicular to that. Which way this second folding direction goes depends on the wires, but it will always be at 90 degrees with the first folding direction. Of course the folding may not be possible due to the constraints imposed by the other tiles of the puzzle. Suppose that you have two tiles on top of one another, and that the top tile could folds downwards or rightwards. If you manage to fold the top tile downwards and swing it underneath the other tile, then it will now fold leftwards instead. This is always true; if a tile is folded around, its other folding direction changes to the opposite direction.

3 useful transformations of the 2x4 rectangle:

  1. Fold it into 1x4 rectangle, and pull it apart to get one long loop of pieces. If you do not get a loop, then go back and fold the 2x4 rectangle over in the other direction to get the 1x4 rectangle. Fold the loop flat at any point and open it up to get back to the rectangle shape.
  2. Fold the 2x4 rectangle up in zigzag fashion to a block. Now peel off one tile from the top half and turn it over onto the bottom half. If this is not possible, then go back and fold the 2x4 rectangle up in the other direction and try again. Fold the tile on the other side of the bottom half up to the top half. Now unfold the puzzle back to the rectangle shape.
  3. Fold the two leftmost tiles and the two rightmost tiles of the 2x4 rectangle onto the central tiles like a cupboard to get a thick square shape. Unfold the other 4 tiles in a similar way but up and down to get back to the rectangle shape and turn it over. Again, if it does not work, then you have folded in the wrong direction.

Getting back to the starting position
Once you have a rectangle shape, these three transforms can always get the puzzle back to its starting position. There is a fairly simply way to do this. First you must realise that the 8 tiles always remain in the same order around the loop. If you number them 1-8 going clockwise around the rectangle in the starting position, then every other position will also have them in 1-8 order, starting from wherever tile 1 is, and going either clockwise or anti-clockwise around the rectangle.

To get from any rectangle to the initial position, simply follow these steps:

  1. If the pieces all seem to need a quarter turn, then do transform 3.
  2. If the pieces all seem to need a half turn to line them up with the adjacent pieces in the loop (i.e. the 4 top pieces do not match each other, and neither do the bottom 4), then do transforms 3, 2 and 3 again.
  3. If the top and bottom halves are upside down, then do transform 1 where you shift only one piece along the loop.
  4. Use transform 2 once or twice to shift the top/bottom pieces to their own halves.

The shape changing transform
There is one more transform needed to solve the puzzle. This transform changes the shape from 2x4 to 3x3 with one corner missing, i.e. from a rectangle to a V shape.

  4. Hold the top right tile and fold it (and also the tile below it) left to the centre of the rectangle. Fold the tile down (if this is not possible then the first fold went the wrong way as usual), then fold it left, fold it upwards, fold it right, and finally fold it upwards.
Note that only three tiles are moved by transform 4. Learn to do both the mirror image and the inverse of this transform.

The number of positions:
There are obviously an infinite number of three dimensional shapes, but the number of flat patterns is limited. From the above it is clear that in the 2x4 rectangle:

  • Any tile can be in the top left corner. (8)
  • The tiles must all be in the same orientation, but any orientation is possible. (4)
  • The tiles can be in 1-8 or 8-1 order. (2)
This leaves 8·4·2=64 possibilities. However the rectangle can be rotated 180 degrees, and those positions have been counted as different. Therefore there are only 32 different possible rectangles.
A similar argument shows there are 64 possible V shapes. This gives 96 possible flat positions. Note that no other flat shapes are possible. In particular it is impossible to construct a 3x3 square with its centre missing. See the discussion below on the possible flat shapes of the Master Edition for the reason why.

Solution:
To go from the starting position to the solved position, then you can follow the following steps:

  1. Do transform 3, and turn over the puzzle to the side which you are solving.
  2. There are three tiles that match up. Use transform 1 to shift these three tiles one tile along to the other corner on that side.
  3. You now have 5 correct tiles. Use transform 4 to move the three incorrect ones, and the puzzle will be solved.

One more transform
There is an odd transform that performs steps a and b in one go. It looks very neat, and if you want to solve very quickly will work well. However, it does put more strain on the wires than the other transforms used so far, so make sure you do it accurately. It is difficult to describe, so I will have to number the tiles from 1 to 8, clockwise from the top left. Thus tile 5 is the bottom right corner.

  5. Hold tile 5 in your right hand. For more speed, instead of holding it with the thumb at the front, turn your right hand palm up and put the thumb at the back. The left hand holds tile 8 normally. Fold the right 4 tiles (3-6) to the left. Lift tiles 5 and 6 up a little and rotate 5 around its inside corner to the right under tiles 2 and 3. As you move it around to the back, tile 3 hinges down. Keep moving 5 around and up the back until it ends up behind 2. With your right thumb flip tile 2 (and tile 3 below it) to the left onto tile 1 and 8. At the same time your left fingers move tiles 6 and 7 back and to the right behind 5. The left hand now folds the 4 rear tiles back and up to make the 4x2 rectangle. Meanwhile the right hand moves down to the corner to start transform 4 as in step c.
I did not find this transform myself, but once saw someone solve Rubik's Magic on TV using it. There is a small difference between the old and new versions of Magic. The new version has the front printed upside down compared to the back, so that before or after you do transform 5 you have to turn the puzzle around. If you want to solve it quickly you must therefore start with the copyright and logo along the top of the rectangle.

Create the Cube puzzle

Pictures kindly supplied by Jeff Bond

This puzzle is mechanically exactly the same as the normal version of Rubik's Magic, the only difference is in the design on the two sides. Each corner of each tile is coloured using one of four colours (blue, yellow, red, and green), and each tile uses all four colours on both sides. The aim of this puzzle is to turn it into a cube which is balanced on an edge on top of a stand made from two tiles. This must of course be done in such a way that the colours of adjacent tiles match (except for the underside of the 2 tiles it stands on).

If you have a normal Rubik's magic, you can convert it to the Create the Cube puzzle, either by sticking on some coloured labels (avoiding the grooves of course), or if you are patient you can undo the wire loops (do not cut them, just stretch them over the nearest corner), insert new paper squares and then refit the wires.

Solution to Create the Cube
If you examine the two sides of the puzzle, you will notice that on one side, the front, all the tiles have the same colour combination (yellow, green, red and blue going clockwise around the tiles edge). In the starting position the front tiles will be oriented the same way.
On the back side of the puzzle the colour combinations of the tiles mostly differ. This side will eventually become the outside of the cube when it is solved.

There are in fact two solutions to this puzzle. First the puzzle has to be brought to one of two correct rectangular positions, and then the rectangle has to be changed into the cube shape. Follow the following steps to get one of the correct rectangular positions.

  1. Turn the puzzle over, so that the side with the differing colour combinations is facing you.
  2. Find the two identical tiles that show the colour combination YGBR looking clockwise around the tiles' edge. The two tiles will be diametrically opposite each other.
  3. The two tiles should be in the top right and bottom left corners (when holding the rectangle horizontally, i.e. it is 4 wide and 2 high). If not, then do transform 2 to bring the two tiles to those positions.
  4. There is another pair of identical tiles (YRBG). These should be adjacent to the bottom left corner. If not, then rotate the puzzle through 180 degrees.
  5. If the colour in the bottom left corner is blue or yellow, then do transform 3, and start again at step a.
  6. Look at the point where the four tiles on the left meet. They should all show the same colour there (red or green). If not, then do transform 3, transform 2, and then transform 3 again, and go back to step b.
  7. You should now have one of the two correct patterns. You can swap between the two patterns by using transform 1, shifting the top row one tile to the right. To turn this into a cube, follow the steps in the following section.

Making the cube shape
One of the most elusive shapes for the Rubik's Magic is the cube. Six tiles form the cube shape and it stands on one edge on top of the other two tiles. There are actually three possible cube configurations, plus their mirror images. I will show all three methods here, but only the first method actually solves the Create the Cube puzzle provided you start from one of the two positions mentioned above.

  1. Start from the 2x4 rectangle shape. If you are using a standard magic, hold it with the linked rings side on top. Fold two leftmost tiles up on top of the adjacent two.
  2. Fold the 2x3 in half upwards, which places the two previously folded tiles inside, stacked together.
  3. Open up the stacked tiles to form a 6-tiled loop, with two tiles stuck to the side of it, looking a bit like a fish shape. If this does not happen, and the stacked tiles can only fold up or downwards, then go back to the starting position, turn the puzzle over and try again.
  4. Arrange the 6-tile loop into a 1x2 rectangular open box, with the extra tiles separated and folded against the long side of the box.
  5. Fold the two extra tiles up, until they form a lid for the box.
  6. Push this lid through into the inside of the box until it lies flat against the side. This is somewhat stressful for the wires, so be careful.
  7. Stretch the box flat, which stacks together the lid tiles inside.
  8. Fold one tile from the stacked end to the middle. On the Create the Cube puzzle you must fold the rear tile to the left, not the front tile. The two newly visible tile sides should have matching colours.
  9. Fold open the puzzle into a 2x3 rectangle. The corner tile on the top right has an extra tile stacked on top of it, as does an adjacent tile.
  10. Keeping the middle pair of stacked tiles together, open the other pair of stacked tiles to form a kind of square tube.
  11. Open the remaining stacked tiles so that they hinge at one end of the tube, and the puzzle will strangely fold up into a cube shape with a handle of two stacked tiles.
  12. Separate the two tiles in the handle to make a 2x1 stand for the cube, and set the puzzle down on them.
The following method is much more stressful on the wires, but it is the most straightforward way to reach the other two possible cube configurations. The second of these configurations is very similar to the one above. If performed on the Create the Cube puzzle, it can make the cube shape with the matching colours on the inside of the cube!
  1. From the rectangle shape, do transform 4.
  2. Continue the final movement of the transform above, bringing the flap of two tiles right round to the back of the other tiles. Then turn over the puzzle.
  3. You now have a 2x3 rectangle. The middle tile on one side has an extra tile on top of it, as does an adjacent corner. Keeping the middle pair together, open the other pair to form a square tube.
  4. Open the remaining stacked tiles so that they hinge at one end of the tube, and the puzzle will strangely fold up into a cube shape with a handle of two stacked tiles.
  5. You can open up the handle to form a basket shape at this point.
  6. Fold the basket handle back again so you get a cube with a handle of two stacked tiles, and fold the two tiles of the handle onto the side of the cube that is made from the third tile of the basket handle. This is where the wires begin to feel the strain, because the inner two tiles of the stack have to squeeze between those forming the sides of the cube.
  7. Fold the two tiles on the inside of the stack through the inside of the cube onto the inside of another tile, to make another stack of three.
  8. Fold the two tiles on the outside of the stack out to form a 1x2 stand, and place the puzzle down onto it.
  9. To reach the other cube configuration, fold the platform tiles together. One of the two tiles together with one of the cube's sides can fold open to give an open box with three tiles around the rim. Now fold the other tile to close the box, and open out the remaining two tiles as a stand.

Master Edition of Rubik's Magic

Picture kindly supplied by Hendrik Haak

This puzzle is a lot more interesting than the normal version. After playing with the small one you soon find that the same shapes come back again and again. The large version has a much larger number of shapes and possibilities.

Most of the ideas from the small version transfer to this puzzle too. Transforms 1, 2 and 4 are exactly the same here. Transform 3 is different, but it has an analogue:

  3. Fold the two leftmost tiles and the two rightmost tiles of the 2x6 rectangle forward and onto the adjacent tiles like a cupboard. Unfold the other 8 tiles at the back in a similar way but upwards and downwards to get a large square shape. As usual if it does not work, then do the first folds in the other direction. Fold the left and right sides of the square backwards behind the other 4 tiles. Finally fold those 4 tiles up and down to get a 6x2 rectangle.
As you can see it is just like before, except that it the folding has to be done twice before the rectangle re-emerges.

Given a rectangle shape, the starting position can be reached using exactly the same method as before.

Transform 5 does not immediately transfer to this puzzle. If performed on the rectangle as a whole it changes its shape to an S, as if transform 4 has been performed to either side. This is not particularly useful. However, if it is performed on the right 2x4 tiles of the 2x6 rectangle, it has the effect of transforming the puzzle to an L shape, i.e. three adjoined 2x2 squares. If transform 4 is then performed on each leg of the L, the zigzag shape is produced that we need for the solution.

Solution 1:

  1. Hold the rectangle with the Rubik signature at the bottom right. Perform transform 2, shifting the pieces in the top row one tile to the left.
  2. Turn over the puzzle. There should be 4 tiles which match each other, with three wrong tiles on the left side and five wrong ones on the right.
  3. Now you will perform a sequence that is in effect the mirror image of transform 5 on the right hand side. In the following description the tiles are numbered 1-12 clockwise from the top left as usual.
    1. Fold the right 2 tiles (6-7) forwards on top of tiles 5, 8.
    2. Fold the right block of 4 tiles (5-8) backwards behind 4 and 9.
    3. Fold 8, 9 forwards to the left on top of 10.
    4. Fold 5, 6 backwards down behind 7.
    5. Fold 7, 8 forwards up onto 3 and 4.
    6. Fold 8, 9 forwards to the right on top of 6 and 7.
    7. Fold 4, 5 backwards to the left behind 3 and 10.
    8. Fold 4-7 backwards up to make an L shape.
  4. Now perform transform 4 on each of the legs of the L to make a zigzag shape.

Solution 2:
This solution uses a different shape changing transform, which was given to me by Courtney Farren.

  1. Hold the rectangle with the Rubik signature at the bottom right. Perform transform 1, shifting the pieces in the top row one tile to the right. When the loop is opened up again into a rectangle, the rows will have been swapped so that the signature tile has moved to the top row next to the top right corner.
  2. Now you will perform a shape changing transform. In the following description the tiles are numbered 1-12 clockwise from the top left as usual.
    1. Fold the right 2 tiles (6-7) forwards on top of tiles 5, 8, and the left 2 tiles (1,12) forwards on top of tiles 2, 11.
    2. Fold tile 1 down on top of 12, and 6 down on top of 7.
    3. Fold tiles 1-2 right on top of 3 and 10, and 5-6 left on top of 4 and 9.
    4. Unfold 3, 4 upwards, to make an inverted T shape.
    5. Separate tiles 8-11 from the rest, forming a loop. Shift the loop one tile to the left so that 7 goes behind 6 and 8-10 behind 11-12,1.
    6. Unfold 7-10 downwards to form the L shape.
  3. Now perform transform 4 on each of the legs of the L to make a zigzag shape.

Flat shapes
It is interesting to find out which flat shapes can be made with this puzzle. Obviously the pieces must be made from a loop of tiles, so each tile must be connected to exactly two other tiles. There is a further constraint, which for example prohibits the normal sized magic to form a 3x3 square with a hole in the middle.

Suppose you have the puzzle in a flat shape. Number the tiles of the loop with the number 1-8 or 1-12. For all the odd numbered tiles, count the number of right turns the loop makes at those tiles, and subtract the number of left turns. Do the same for all the even numbered tiles. These two numbers must be equal for the pattern to be possible, and for it to be a flat closed loop they must both be two (or minus two if you numbered them anti-clockwise) because you need 4 quarter turns to go full circle.

It is fairly easy to see why this condition exists. It is true for the initial position of the puzzle. Every time two adjacent tiles move their connection from one edge to another, the condition still holds. Therefore it must be true for every possible shape. (Note that for this reasoning to offer a valid proof, the condition should be extended and formalised so that it does not depend on the puzzle being a flat shape and can handle positions with tiles that are folded onto each other, but this can be done.)

For example, consider the solved position of the Master Edition.
12 | 1 |  |
11 | 2 | 3 |
10 | 9 | 4 | 5
 | 8 | 7 | 6

With the odd numbered tiles there are right turns at 1, 3, 5 and a left turn at 9, so there are two more right turns than left.
With the even numbered tiles there are right turns at 6, 8, 10, 12 and left turns at 2, 4 so there are again two more right turns than left.

With this constraint, there are only 15 possible flat patterns left, and they can all be constructed. It makes a good exercise to try to construct them all.
X | X | X | X | X | X
X | X | X | X | X | X

X | X | X | X | X
X | X | X | X | X
 |  |  | X | X

X | X | X | X | X
X | X | X | X | X
 |  | X | X |
X | X | X | X |
X | X | X | X | X
 |  | X | X | X

X | X | X | X | X
X |  |  | X | X
X | X | X | X |
X | X | X | X
X | X | X | X
X | X | X | X

X | X |  |
X | X | X | X
X | X | X | X
 |  | X | X

X | X |  |
X | X | X | X
X | X | X | X
X | X |  |
X | X |  |
X | X | X | X
X | X | X | X
 | X | X |
X | X |  |
X | X |  |
X | X | X | X
X | X | X | X
 | X | X |
X | X | X | X
X | X | X | X
 | X | X |
X | X | X | X
X |  |  | X
X |  |  | X
X | X | X | X

X | X | X |
X |  | X | X
X |  | X | X
X | X | X |
X | X | X |
X |  | X |
X |  | X | X
X | X | X | X

X | X |  |
X | X | X |
X | X | X | X
 | X | X | X

An interesting consequence of the constraint above is that even with larger versions of the puzzle, its flat shapes can never enclose an odd area. In other words, if the flat shape has holes then their total area is the same as an even number of tiles.

Larger versions of Rubik's Magic do exist, but they have not been very widely produced. The picture below shows one from Poland, and it does not seem to be endorsed by Rubik.

Picture kindly supplied by Corneliu Zavadovschi

It is possible to make such a 'Super Magic' yourself by recombining two normal Rubik's Magics. This is quite difficult, and not for the faint-hearted. I made one myself by connecting one old magic (black) and one new magic (red). The red magic is on the left, and the black magic on the right, with the copyright messages of both of them along the bottom. By connecting them this way, the reverse is still solvable, making two sets of 3 linked rings. You can of course connect two magics of the same type but then one has to be upside down, i.e. with the copyright message along the top edge (red magics: copyright along top right and bottom left; black magics: copyright along top left and bottom right). Note that in this starting position, the middle 4 tiles match on the reverse side as well as the front. Of course, if you replace the design then none of the above is relevant.

If you choose to make a Super Magic, then you should be aware of the following tips.

  • Never cut any of the wires holding the tiles together. They can be removed and replaced without breaking them, by levering a wire over the corner of a tile.
  • The wires consist of loops. A loop is long enough only to traverse 3 tiles.
  • Four wire loops are used for holding 3 tiles together. One pair of loops runs along one groove, the other pair along the other groove.
  • Each wire runs in a groove, alternating between over and under a tile, zig-zagging between the edges like a reflecting beam of light.
  • If the tiles of a normal magic are numbered 1-8, then four loops connect tiles 1-3, four connect tiles 3-5, another four connect 5-7, and the final four loops connect 7, 8 and 1. Two normal magics have just enough loops to build one Super Magic.
  • It is easiest to build the puzzle in loop shape (see transform 1), because then all the wire loops have exactly the same pattern.
  • The metal bits which turn the wire into loops should be placed in a regular manner, for example on the sides of all odd numbered tiles only.

      Home
      Links
      Guestbook


Massage Ball

Picture kindly supplied by Hendrik Haak

The official name of this puzzle is the OTTO WU 7-Color Magic Puzzle. It consists of a ball with six grooves running from pole to pole. In its solved position each track contains 5 sliding pieces of one colour, one of the poles has a single piece of a seventh colour, and the other pole has a gap. The pieces can slide into the gap, and so get mixed up.

Unfortunately the sliding pieces are hexagonal instead of round, so they can be difficult to move as they often get caught when moving from a pole into one of the six tracks. The leaflet that comes with the puzzle maintains that because each tile has little bumps on them and thus massages the palms of your hands, it will stimulate their meridian points and therefore be good for the health of your whole body. It also claims that the rainbow colours and in particular the single green tile symbolise nature and so promotes the importance of environmentalism awareness.

The number of positions:
There are 6·5+1=31 pieces and a gap, giving a maximum of 32! positions. This limit is not reached because:

  • There are six sets of five of indistinguishable pieces (5!6)
  • The six main colours are equivalent (6!)
  • The pole piece may be at either pole (2)
This leaves 32!/(2·6!·5!6) = 61,195,822,841,187,530,496 = 6.1·1019 positions.
Links to other useful pages:
Ottu Wu Corporation. Homepage of the Taiwanese manufacturer. Only contains a picture, and address and phone number.

Solution:
Hold the puzzle so that the tracks run up and down, meeting at the top at the North pole, and at the bottom at the South pole. The North pole will generally be empty, and the South pole will have a piece in it. Moves on the puzzle will always be a movement of one track upwards, taking with it the South pole piece, and then a move of another track downwards with the North pole piece.

Phase 1: Solve 4 of the tracks.

  1. Choose a track you want to solve, and the colour you want to use there.
  2. Find a piece of that colour in another track.
  3. Move the piece to the South pole as follows:
    1. Move any unsolved track upwards.
    2. Move the track with the piece downwards.
    3. Repeat 1-2 until the piece lies at the South pole.
  4. Move the track you are solving upwards, and any unsolved track down. This has placed the piece onto the right track.
  5. Repeat steps b-d until the track you have chosen is solved.
  6. Repeat steps a-d until four tracks have been solved.

Phase 2: Solve the South pole.
Move the solitary green piece to the South pole. See step 1c.

Phase 3: Solve the last 2 tracks.
Lets call the two unsolved tracks A and B, and one of the solved tracks C.

  1. Find a piece in track A and a piece in track B that need to be swapped.
  2. If there are at least 5 pieces above the two that need to be swapped, then do:
    1. Move C up, A down, until the piece in A lies next to the South pole.
    2. Move C up, B down, until the piece in B lies next to the South pole.
    3. Move C up, B down; C up, A down; B up, C down; A up, C down. This step swaps the two pieces. It also swaps the top two pieces of track C, but that is not visible.
    4. Move B up, C down, until track B has no more pieces from track C.
    5. Move A up, C down, until track A has no more pieces from track C.
  3. If there are between 1 and 4 pieces above the two that need to be swapped, then
    1. Move A up, C down, until the piece in A lies next to the North pole.
    2. Move B up, C down, until the piece in B lies next to the North pole.
    3. Move B up; C down, A up; B down, C up; A down.
    4. Move C up, B down, until track B has no more pieces from track C.
    5. Move C up, A down, until track A has no more pieces from track C.
    Note that you can also do this same sequence by moving C up, turning the puzzle upside down and doing the sequence b1-5. Afterwards, turn the puzzle back and move C down again.
  4. If there are no pieces above the two to be swapped, i.e. you want to swap the top pieces of tracks A and B, then
    1. Move A up, B down, which puts the two pieces at the top of track B.
    2. Move A up, C down, A up, C down, which puts two identical pieces next to the South pole in tracks A and C.
    3. Move B up, C down; B up, A down; C up, B down; A up, B down. This is essentially the same sequence as step b3.
    4. Move C up, A down, C up, A down.
    5. Move B up, A down.

Extra's:

  1. To swap all pieces from tracks A and B, simply move A up and B down until they are swapped. This also moves the green piece to the other pole.
  2. To swap A and B without moving the green piece, follow these steps, where C is any solved track:
    1. Move C up, to put aside the green piece.
    2. Move A down, B up until all the A and B pieces have swapped. The South pole now has a C piece on it.
    3. Move C up, A down, B up, A down, B up. You now have identical pieces at the top of A and B, and want to swap the bottom two pieces of C.
    4. Move C down, B up, C down, A up, B down, C up, A down, C up. This is similar to steps 3.b3 and 3.c3.
    5. Move B down, A up, B down, A up, C down.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Masterball

Picture kindly supplied by Hendrik Haak

This nice puzzle is consists of a ball which is sliced up like an orange into 8 segments, and the whole is also divided horizontally into 4 bands. In other words, it is like a globe with 8 lines of longitude and 3 lines of latitude.

There are two types of move: A half turn of half the ball along any of the lines of longitude, called a slice move, or a 1/8 turn of one of the 4 bands.

On the standard puzzle, the Rainbow Master (sometimes known as the 'geomaster'), each of the 8 segments has a different colour. Other designs have pictures on them. Below I will give one solution for the Rainbow Master, and then an extended solution that will solve any masterball.

The number of positions:
There are 16 polar pieces and 16 middle pieces, giving a maximum of 16!2 positions. All of these positions are attainable. This gives 16!2 = 437,763,136,697,395,052,544,000,000 or 4.4·1026 positions.

On the Rainbow Master the pieces come in identical pairs, so then the number of positions becomes 16!2/216 = 6,679,735,362,203,904,000,000 or 6.6·1021 positions.

Links to other useful pages:
Masterball homepage. Contains a solution for the rainbow master.
David Joyner's page. Some move sequences and patterns.
David Joyner's page. Formalization of the group of the puzzle.
Cyril Castella's page. A French solution.

There are two move sequences that we will use repeatedly throughout the solutions. Hold the puzzle with one segment directly in front, facing you.
  1. The first sequence is used to pair up pieces in the middle bands, or in the polar caps. Suppose in any band/cap the piece at the front and the piece at the back actually belong in the same segment in the solved puzzle.
    Then do the following:
    1. Move the band/cap to the right.
    2. Twist the right side of the ball (along the line to the right of the front segment).
    3. Move the band/cap to the left.
    This leaves the two pieces in the same segment without separating other such pairs. Note that this sequence can be used on middle bands, or on the caps.

  2. The second sequence swaps a pair of pieces in one segment with a pair in another segment. It is mainly used to line up the pieces in the polar caps with those of the middle bands. The pairs that are swapped also turn over, so it can also used for orienting them.
    To swap the middle band pieces in the front segment with those of the back segment, do the following:
    1. Move the top band to the right.
    2. Twist the right side of the ball (along the line to the right of the front segment).
    3. Move the top band back to the left.
    4. Move the bottom band to the right.
    5. Twist the right side of the ball.
    6. Move the bottom band back to the left.
    This sequence can of course also be used on the caps instead of the middle bands.

Solution for Rainbow Master:
Phase 1: Pair up the pieces in the middle bands.

  1. Find any two pieces in the middle bands that have the same colour.
  2. Use any slice moves you need to places them in opposite segments.
  3. If they are now in the same band, then do sequence a to pair them up. If they do not lie in the same band, then try to find another pair of pieces to pair up.
  4. If you have done stepa a-c as often as possible but cannot pair up all the middle band pieces, then use some slice moves to place an unmatched pair in the front segment, and a matched pair at the back segment, and do sequence b. You will now find that the unmatched pair can be solved using steps a-c above.
Phase 2: Pair up the pieces in the polar caps.
This is essentially the same as phase 1, except that you of course turn the caps instead of the bands when doing the move sequences.

Phase 3: Align the pairs in the middle bands and the caps to build segments.

  1. Find any pair of middle band pieces and pair of cap pieces that belong together in one segment.
  2. Use any slice moves to put them in opposite segments.
  3. Now do sequence b to put them all in a finished segment.
  4. Repeat steps a-c above to solve all the segments.
Phase 4: Put the segments in order.
In this final phase, only slice moves are needed. To describe the move sequences we need a notation for the moves, and for the different positions of the segments. Number the segment positions 1 to 8, where the front is position 1, the segment to its right position 2, and so on.

Name the possible slice moves A to D. A is the slice move we have used before, along the line between positions 1 and 2 (and which swaps the segment at 2 with 5, and also 3 with 4). B is the slice move along the line between positions 2 and 3, and so on.
Note that this phase is similar to solving the Hockey Puck Puzzle.

  1. The segment at position 1 is assumed to be correct. The other segments will be placed correctly alongside it.
  2. Find the segment that belongs in position 2 and note its position. Do the appropriate sequence below:
    3: ABA
    4: BA
    5: A
    6: CA
    7: DCA
    8: DA
  3. Find the segment that belongs in position 3 and note its position. Do the appropriate sequence below:
    4: BCB
    5: CB
    6: B
    7: DB
    8: DCB
  4. Find the segment that belongs in position 4 and note its position. Do the appropriate sequence below:
    5: CDC
    6: DC
    7: C
    8: DCDC
  5. Find the segments that belongs in positions 5 and 6 and note their positions. Do the appropriate sequence below:
    5,6: -
    5,7: CBCBDCDB
    5,8: BDCDBCBC
    6,5: BCDBDCB
    6,7: BABACBCA
    6,8: BCDCDCBC
    7,5: ACBCABAB
    7,6: BCBCBDBC
    7,8: BCBDBCBD
    8,5: CBCDCDCB
    8,6: CBDBCBCB
    8,7: D
  6. To swap the segments at 7 and 8 then do ABCDCDCA and turn over the ball.
A nice pattern for the Rainbow Master:
From the solved state, rotate the bottom layers of the ball by 180 degrees, and perform ADCDCBC.

Solution for any Masterball:
Phase 1: Pair up the pieces in the middle bands.
This is the same as phase 1 of the Rainbow solution.

Phase 2: Orient middle band pairs.

  1. Put the middle band pairs in the correct order (ignoring orientation), by using the same methods as in the final phase of the Rainbow solution.
  2. Count how many of the middle band pairs are upside down.
  3. If this is an odd number then move one of the middle bands once in any direction and go back to phase 1 to pair them up properly. The next time you return here there will be an even number of reversed pairs. Note that your puzzle may have a pair that looks identical whichever way up it is. If so, consider it to be in such a orientation that there are an even number of pairs upside down, so that you don't have to go back to phase 1.
  4. If an even number of pairs are upside down, then remember which pairs of pieces they are. Use any slice moves to place one such pair in the front segment and one such pair at the back, and do sequence b. Repeat this for all the pairs that were upside down before. If you were to place the segments in the right order again, they would now automatically end up in the right orientation. This is not necessary right now, but it may be a good idea to do this anyway to check if the orientations are correct.
Phase 3: Pair up the pieces in the polar caps.
This is identical to phase 2. of the Rainbow solution.

Phase 4: Align the pairs in the middle bands and the caps to build segments.

  1. Find any pair of middle band pieces and pair of cap pieces that belong together in one segment.
  2. Use any slice moves to put them in opposite segments.
  3. Assuming the orientation of both pairs of pieces matter, check whether the polar cap pieces are upside down relative to the middle band pieces on the other side. If not, go back to step a to try another set of pieces. If no set of pieces can be placed in the correct orientation, then ignore the orientation for now as we can fix it later.
  4. Now do sequence b ON THE POLAR CAPS to put them all in a finished segment. The reason you must use b on the caps and not on the bands is that the middle band pair was already correctly oriented in phase 2.
  5. Repeat the above to solve all the segments apart from the orientation of a few of the cap pairs.
  6. Count how many segments have the cap pieces upside down. If there is an odd number of such segments then rotate one of the polar caps once in any direction and go back to phase 3 again. The next time you reach this point, there will automatically be an even number of reversed cap pairs. Note that if your puzzle has a segment where the caps are indistinguishable, then you can assume its orientation is such that an even number of segments are wrong.
  7. To reverse the caps of any two segments, then you can use sequence b four times to solve them. If A and B are the two incorrect segments, and C is any other, then use sequence b to swap the caps of A and B, B and C, C and A, and finally C and B. Repeat this until all the segments are correct. As this is a rather tedious procedure, it is best to try to place as many of the cap pairs correctly straightaway in step c.
Phase 5: Put the segments in order.
This is the same as phase 4 of the Rainbow solution.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+.

Home
Links
Guestbook


Megaminx

Picture kindly supplied by Hendrik Haak

This is a variant of the Rubik's cube, in the shape of a dodecahedron. It is a very logical progression from the cube to the dodecahedron, as can be seen from the fact that the mechanism is virtually the same, and that many people invented it simultaneously. To quote from Cubic Circular, Issue 3&4, (David Singmaster, Spring&Summer 1982):

"The Magic Dodecahedron has been contemplated for some time. So far I have seen photos or models from: Ben Halpern (USA), Boris Horvat (Yugoslavia), Barry Lockwood (UK) and Miklós Kristóf (Hungary), while Kersten Meier (Germany) sent plans in early 1981. I have heard that Christoph Bandelow and Doctor Moll (Germany) have patents and that Mario Ouellette and Luc Robillard (Canada) have both found mechanisms. The Hungarian version is notable as being in production ... and as having planes closer to the centre so each face has a star pattern."

"Uwe Mèffert has bought the Halpern and Meier rights, which were both filed on the same day about a month before Kristóf. However there is an unresolved dispute over the extent of overlap in designs."

There are several versions that have been made. The standard megaminx has either 6 colours or 12 colours. The face layers are fairly thin, so the edge pieces have some width to them. A version called the Supernova was made, which has 12 colours and thicker face layers which meet exactly at the middle of an edge. Related puzzles are Alexander's Star, which is equivalent to a megaminx without corners or centres, and the Impossiball, which is equivalent to a megaminx without edges or centres.

The number of positions:
There are 30 edge pieces with 2 orientations each, and 20 corner pieces with 3 orientations, giving a maximum of 30!·20!·230·320 positions. This limit is not reached because:

  • only even permutations of edges are possible (2)
  • only even permutations of corners are possible (2)
  • only and even number of flipped edges are possible (2)
  • the total twist of the corners is fixed (3)
This leaves 30!·20!·227·319 = 100,669,616,553,523,347,122,516,032,313,645,505,168,688,116,411,019,768,627,200,000,000,000 or 1.0·1068 positions.

If only 6 colours are used, giving 15 pairs of indistinguishable pieces, then this number has to be divided by 214 (not 215 since only an even number of swaps are possible) which gives 6,144,385,775,971,883,979,645,753,925,393,402,415,081,061,792,664,780,800,000,000,000 or 6.1·1063 positions. Despite these huge numbers, the puzzle is no harder than the Rubik's cube.

Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He produces and sells many puzzles, including the megaminx.
Meffert's pages The solution as provided in its booklet.
'Simplest Solutions' page A text based solution.
Mark Longridge's page Some move sequences, and some nice spot patterns.
David Joyner's Page A proof by one of his students, formalizing the permutation group of the puzzle and proving the assertions I used above to calculate its size.
David Joyner's Page A catalogue of moves that can be used to solve the puzzle.

Notation:
Let F, R, D be three adjacent faces (Front, Right and Down), in other words, F, R, D are faces arranged clockwise around a vertex. Let U (Up) be the other face adjacent to both F and R, and let L (Left) be the other face adjacent to F and D. Clockwise 1/5 twists of a face are denoted by the appropriate letter, anti-clockwise 1/5 twists by F', R', L', D' or U'. In the solution below, the D face is usually still unsolved.

Solution:
If you can solve the top and middle layer of the Rubik's cube, then you can use the same techniques on the megaminx to solve everything but the final layer.
Phase 1: Solve all but final face

  1. Solve the edge pieces of one face. This is easy to do and need not be explained in detail. Let that face be the U face.
  2. Solve the corners of the U face as follows:
    1. Find a corner that belongs on the U face.
    2. Hold the puzzle so that the corner belongs at URF, and that face D is unsolved.
    3. Use any turns that do not disturb already solved pieces to place the corner at RDF.
    4. Use one of the following sequences to place the corner:
    RDF->URF: R'D'R
    FRD->URF: FDF'
    DFR->URF: R'DR FD'D'F'
    These sequences only disturb the FR edge piece and the D layer, but nothing else except for the corner.
    5. Repeat 1-4 till done. If necessary you may need to use this method to displace an incorrectly placed piece
  3. Place all yet unsolved edges adjacent to the solved corners. This is similar to placing the corners, except that you use the following sequences to place them:
    DR->FR: DFD'F' D' R'DR
    FD->FR: D'R'DR D FD'F'
    These sequences only disturb the D layer, but nothing else except for the edge.
  4. Repeat steps b-c to solve each adjacent face in turn, until only one unsolved face is left.
Phase 2: Orient the edges of the final face.
The edges are flipped in pairs. It is impossible to have only one edge upside down.
  1. Hold the puzzle so that the unsolved face is D, one edge to be flipped is at DR, and another is either at DL or DF.
  2. Do one of the following sequences to flips the edges:
    To flip DF, DR, do R D F D' F' R'
    To flip DL, DR, do R F D F' D' R'
  3. Repeat the above if necessary.
In the phases below, the faces adjacent to the D face are in clockwise order: L, F, R, b, B.

Phase 3: Position the edges of the final face.

  1. Rotate D to place as many edges as possible in their correct places. If, like Alexander's Star, your megaminx has only 6 colours, you might find that the edges are in an odd permutation. In this case you will have to swap any two identical edges elsewhere on the puzzle and try solving it again.
  2. Hold the puzzle so that you can use one of the following sequences to solve it:
    1. DR->DF->DL->DR: R D R' D R D'D' R'
    2. DR->DL->DF->DR: R DD R' D' R D' R'
    3. DR->DF->DB->DR: R D R' DD R DD R'
    4. DR->DB->DF->DR: R D'D' R' D'D' R D' R'
    5. DR-DB, DF-DL: R D R' D R D' R' DD R DD R'
Phase 4: Position the final corners.
  1. Hold the puzzle so that you can use one of the following sequences to solve it:
    1. DFR->DLF->DBL->DFR: RUR' D RU'R' D RUR' D'D'RU'R'
    2. DFR->DBL->DLF->DFR: RUR' DD RU'R' D' RUR' D' RU'R'
    3. DFR->DLF->DbB->DFR: RUR' D RU'R' DD RUR' DD RU'R'
    4. DFR->DbB->DLF->DFR: RUR' D'D'RU'R' D'D'RUR' D' RU'R'
    5. DFR-DbB, DLF-DBL: RUR' D RU'R' D RUR' D' RU'R' DD RUR' DD RU'R'
    Note the similarity between these sequences and those of phase 3.
Phase 5: Orient the final corners.
  1. Hold the puzzle so that the DFR corner needs to be twisted anti-clockwise. If there is no such corner, then put a different twisted corner there.
  2. To turn DFR anti-clockwise, and another clockwise, do one of these:
    1. DFR->RDF, DLF->LFD: RU'R'F'U'F D F'UFRUR' D'
    2. DFR->RDF, DBL->BLD: RU'R'F'U'F DD F'UFRUR' D'D'
    3. DFR->RDF, DbB->bBD: RU'R'F'U'F D'D' F'UFRUR' DD
    4. DFR->RDF, DFb->FbD: RU'R'F'U'F D' F'UFRUR' D
  3. Repeat the above until all corners are correct.

Home
Links
Guestbook


Missing Link

Picture kindly supplied by Hendrik Haak

This puzzle consists of a square tower of four layers. On the sides are sliding tiles, and each side depicts a chain in different colour. One chain, the white one, is made of only three tiles, so that there is a gap. The tiles can slide up and down into the gap. The top and the bottom layer can rotate so that the pieces from different chains are mixed up.

This puzzle is closely related to the Puzzle Tower/Whip-It and the Ivory Tower/Babylon Tower.

The number of positions:
There are 15 pieces and a gap, giving a maximum of 16! positions. This limit is not reached because:

  • There are three pairs of indistinguishable pieces (23)
  • The colours are equivalent (4!)
This leaves 16!/(4!·23) = 108,972,864,000 positions.

Solution:
The method below solves it column by column. This is not actually the method I generally use, but this was somewhat easier to describe in detail. I solve the Missing Link by moving the pieces into their correct half, top or bottom, and then solving each half separately. This is much quicker than the column method.

Phase 1: Solve one column A column can be solved by sliding the tiles of the chain one by one into the column from the top.

  1. Choose the column you want to solve, and which colour chain you want to put there. You must not choose white, but one of the other chains with four tiles.
  2. Find the bottom tile of the chain. Manoeuvre it to the second row of the column you are solving.
  3. Find one of the middle tiles of the chain. If it lies directly below the previous tile (i.e. third row of the column being solved) then choose the other middle tile instead.
  4. Manoeuvre it to the top of the puzzle, without disturbing any previously solved tiles.
  5. Move tiles upwards so that the gap is on the third row. Move the tile at the bottom of the column being solved up into the gap, and move down the column, pulling down the middle piece from the top row onto it.
  6. Repeat steps c-e for the other middle tile of the column. All but the top tile of the chain has now been solved.
  7. Find the top tile of the chain. Manoeuvre it to the top row, and put it at the top of the column.

Phase 2: Solve the second column
A similar method to phase 1 can be used to build the second column. A few changes are necessary because the first column must not be disturbed.

  1. Choose the column you want to solve, and which colour chain you want to put there. The column should be next to the previously solved one.
  2. Find the bottom tile of the chain. Manoeuvre it to the second row of the column you are solving.
  3. Find one of the middle tiles of the chain. If it lies directly below the previous tile (i.e. third row of the column being solved) then choose the other middle tile instead.
  4. Manoeuvre it to the second row of the puzzle, with the gap next to it in the second row of the other unsolved column. Do all of this without disturbing any previously solved tiles. Move the tile at the top of the column being solved into the gap, and then put the correct tile in its place at the top of the column being solved.
  5. Move tiles upwards so that the gap is on the third row. Move the tile at the bottom of the column being solved up into the gap, and move down the column, pulling down the middle piece from the top row onto it.
  6. Repeat steps c-e for the other middle tile of the column. All but the top tile of the chain has now been solved.
  7. Find the top tile of the chain. Manoeuvre it to the top row, and put it at the top of the column in the same way as step d.

Phase 3: Solve the remaining two columns.
The last two chains can be solved without sliding any of the tiles in the other two chains. The tiles in the last two chains can move around in a loop, either clockwise (left column up, right column down) or anti-clockwise (right column up, left column down). This loop consists of only 5 tiles; one tile in the top row and one tile in the bottom row can stay in place. Once you are familiar with this, the last chains are not very hard to solve.

  1. The steps below will solve the two remaining columns with the white chain in the right column. If you want to have the white chain in the left column then turn the puzzle upside down first.
  2. Solve the bottom tile of the left column. This is very easy. From now on this tile will never be moved.
  3. Loop the tiles until the white middle tile is in the top row. Leave the tile there, and loop the 5 remaining tiles until the bottom white tile lies in the second row of the right column, and the gap is next to it in the second row of the left column. Now loop the tiles to bring the bottom and middle tiles into position.
  4. If the top white tile lies in the third row of the left column, then move the loop clockwise, to bring the tile into the top half. Rearrange the three tiles in the top half, and move the loop anticlockwise, back into position.
  5. The top white tile must now lie somewhere in the top half, and the three tiles in the top half can be rearranged to solve the white chain completely, with the gap above it in the right column.
  6. If the left column is not yet solved, then loop the tiles clockwise, so that the two middle tiles and the top tile lie in the top half of the puzzle. Rearrange the three tiles so that the top tile lies at the top left, and the gap in the top right. Loop the tiles anti-clockwise, leaving the top tile in place, and the puzzle will be solved.

Note: About the parity problem.
This puzzle has a parity problem just like any other with square sliding tiles. It is impossible to swap two tiles without moving any other tiles to a different position. This puzzle has identical tiles, so two pieces can be swapped if two identical tiles are swapped also. In the solution above the parity problem was not really visible because two identical tiles were solved last. Another way to solve the problem is by turning the top or bottom layers a quarter turn, and re-solve the tiles that were moved. The turn is a 4-cycle, which is an odd permutation, and so this is another way to swap two tiles. This method is also used in the Babylon Tower.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Mozaika

Picture kindly supplied by Hendrik Haak

This cleverly designed puzzle is in effect a combination of the Equator puzzle and the Rubik's Cube. It is a ball with three intersecting rings of moving pieces which divide the remaining surface of the ball into eight triangles. There are 12 square tiles each ring, making 30 pieces in all because there are 6 places where the rings intersect. There is no space so the pieces do not move singly. Instead, all 12 pieces of a ring can be shifted as one just like the Equator puzzle. Furthermore, a cap consisting of 4 of the triangles and the tiles between them can rotate.

There are various colour schemes for the Mozaika puzzle. The most difficult version, the Offset, has 8 colours; each octant of the ball has its own colour. Therefore the 6 tiles which lie at the crossings (the intersections of the rings) have 4 colours, all other tiles have two colours, and the triangles have only one. Other patterns include the Quad, which is coloured just like the Equator, or the Half which simply has two differently coloured hemispheres. Note that the patterns can also have some colours duplicated to make it easier. I will only discuss the 8-colour version.

Links to other useful pages:
Mozaika homepage. Mozaika is manufactured and sold by Rudi Destics (J & R Destics Co.) and can be ordered direct from this homepage.

The number of positions:
There are 30 tiles and 8 triangles. The tiles all have 4 possible orientations, which gives a maximum of 8!·30!·430 positions. This limit is not reached because:

  • The orientation of the whole puzzle does not matter (24)
  • There are 12 indistinguishable tile pairs (212)
  • The permutation parity of the triangles equals the parity of the number of tiles that need a quarter turn (2)
This leaves 8!·30!·430/(24·213) = 62,716,115,731,979,958,427,000,055,726,386,372,096,819,200,000,000 or 6.2·1049 positions.

Notation:
A similar notation as the cube will be used. Hold the puzzle so that the rings intersect at the front, back, left and right. Denote these 6 crossings by the letters F, B, L, R, U and D. A clockwise quarter turn of the cap around such a crossing is simply denoted by the relevant letter. Half turns and anti-clockwise quarter turns are denoted by the relevant letter followed by a 2 or an apostrophe (') respectively. A clockwise move of a ring of tiles is denoted by a lower case letter indicating its adjacent cap, followed by a number indicating the number of tiles to move the ring along. For example u1 means rotate the ring around the equator westwards one tile, and d1 means rotate the equator ring eastwards one tile.
The positions of tiles can be denoted by a combination of letters: The crossing points by a single letter (e.g. F for the front crossing point), the other tiles by two letters (e.g. FD, FL, FU, FR for the 4 tile positions adjacent to the front crossing point; don't confuse FU with UF etc.).

Solution:
Phase 1: Place 4-coloured tiles in position
In this phase the tiles with 4 colours will be placed in position at the intersections of the rings of tiles. Their orientation is not important yet. Note that when the 4-coloured tiles are correctly positioned, each should have 2 colours in common with the 4 nearest 4-coloured tiles, and none with the tile on the opposite side.

  1. Move any ring to place one of the 4-coloured tiles at a crossing point. This tile is considered to be correctly placed.
  2. A second 4-coloured tile can usually be placed in position by twisting the ring that does not contain the first tile.
  3. The remaining 4-coloured tiles can be put in position as follows:
    1. Find a 4-coloured tile that is not in its correct position.
    2. If it lies at a crossing point, then hold the puzzle so that the piece is at the front and do b1 u1 F d1 f1.
    3. Turn any caps to bring the 4-coloured tile next to the crossing point where it belongs.
    4. Hold the puzzle so that the crossing point is at the front, and the 4-coloured tile below it (at FD) and do b1 u1 F d1 f1.
    5. Repeat the above steps for each remaining 4-coloured tile.
Phase 2: Orient the 2-coloured tiles.
In this phase each 2-coloured tile is given a quarter turn if necessary so that the line dividing its colours runs along the ring it's in rather than across it. In other words, one of its colours is adjacent to one triangle, the other colour is adjacent to another triangle.
  1. Find a tile that needs a quarter turn.
  2. Hold the puzzle so that the tile lies at position FD.
  3. Do the sequence r1 d3 R u3 l1.
  4. Repeat steps a-c until no more tiles need twisting.

    5. Note that it may be quicker at first to twist 4 tiles at a time as follows:
    1. Use any cap moves to bring tiles that need twisting at the positions FD, BU, FL, BR. Note that these are two antipodal pairs.
    2. Do the sequence d2 r1 u1 l1 u1
    Similar sequences can be used to twist any two antipodal pairs.
Phase 3: Pair up the 2-coloured tiles.
In this phase each pair of indistinguishable 2-coloured tiles will be brought next to each other, preferably in the same orientation.
  1. Find any pair of identical 2-coloured tiles which are not yet next to each other. It is best to find a pair which are in the same orientation with respect to the adjacent crossing tile (i.e. if you hold the puzzle with one of the tiles at position FD, you will have the same colour on the right hand side as when you hold the other tile at FD.)
  2. Hold the puzzle so that one of the tiles lies at FD.
  3. Use any cap turns necessary to keep the FD tile in place and move the other tile to the UB position (i.e. adjacent to the BU position which is exactly opposite the FD tile)
  4. Do the sequence r1 u6 l1 to bring them together. (Note that this will move the 4-coloured tiles around but that will be fixed in the next phase if necessary).
  5. Repeat steps a-d until all 2-coloured edges are in pairs.
Phase 4: Solve the 4-coloured tiles.
The previous phase may have disturbed the 4-coloured tiles, so that will be fixed now.
  1. Turn the U and R caps so that the 4-coloured tiles at U and R are in the correct orientation relative to each other (i.e. the two colours they have in common are nearest to each other).
  2. Turn the D and L caps to orient their 4-coloured tiles.
  3. Try to orient the F and B tiles by turning the F and B caps. This may not be possible, and then the F and B tiles need to be swapped. This can be fixed by the sequence:
    u1 r1 u1 l1 u1 r1 u1 l1 u2 r1 d5 l1
Phase 5: Position nearly all the pieces
The puzzle can now be nearly solved just like the Rubik's cube. Each triangle corresponds to a corner of the cube (though without visible orientation), each pair of 2-coloured tiles corresponds to an edge piece of the cube, and the 4-coloured pieces are the face centres. Nearly any method to solve the cube can be applied now, but it must be borne in mind that the centres have visible orientation now. There are several points to remember:
  1. You will probably have tile pairs which are not oriented properly with respect to each other. Treat these like any other proper edge pair. Note however that the orientation of this pair treated as a single 'edge' is not visible.
  2. You may find that two edges (tile pairs) need to be swapped in the end, which does not occur on a normal cube. This will be fixed in the next phase.
  3. You may find that one edge (tile pair) needs to be flipped in the end, which does not occur on a normal cube. This will be fixed in the next phase. Note however that you might flip such a 'single edge' in combination with a tile pair that are not oriented properly with respect to each other. This can usually get rid of any apparently single flipped 'edges'.
  4. If you use an edges first method, or a layer method in which the final layer is solved edges first, then in the end you may find you have two corners (triangles) which need to be swapped. In this case swap two edges and solve the corners again.
  5. Layer methods and edges first methods can be easily adapted so that the orientations of most face centres will be correct. Nevertheless you will probably need to fix the orientation of some centres, and this can be done with the following sequences:
    To turn the F tile 180 degrees, do R L F2 R' L' F twice.
    To turn the R tile clockwise 90 degrees, and the U tile anti-clockwise 90 degrees, do l3 u3 r3 U l3 d3 r3 U'.
Phase 6: Fix remaining problems
Now you may still need to swap two pairs of tiles, and will almost certainly need to orient a few of the 2-coloured tiles.
  1. The FD/DF tile pair can be swapped with the BU/UB pair by the sequence r1 u6 r1 u6 l2. Note that any tile pairs can be swapped with this sequence, for example:
    To swap the FD/DF pair with the FU/UF pair, do U2 r1 u6 r1 u6 l2 U2.
    To swap the FD/DF pair with the FR/RF pair, do R2 B r1 u6 r1 u6 l2 B' R2.
  2. The FD tile can be flipped by the sequence
    r1 R L F2 R' L' F R L F2 R' L' F l1
    All tiles that need to be flipped can be corrected in this way. Note that if you have a single 'flipped edge' from the previous phase, then you can flip the two tiles separately.

    3. Compare this sequence with the sequence used in the previous phase to rotate the F tile 180 degrees.

Home
Links
Guestbook


Billiards 9-Ball Puzzle

This puzzle consists of 10 numbered beads which slide along tracks. The track has the shape of a circle with one diameter. The circle can hold 9 beads, the diameter two, and as there are only 10 beads there is a single gap. There are an odd number of beads in the outer circle, so the diameter track leads from a single bead at the top down to a pair of beads at the bottom, and it therefore splits near the bottom. The beads are coloured like pool balls, numbered 1 to 9 in different colours, and one white ball. In the solved position, the white ball (and the gap) is in the centre, and the other balls are in order around the circle, from 1 at the bottom left to 9 at the bottom right.

Links to other useful pages:
Binary Arts homepage. Homepage of the manufacturer.

The number of positions:
If we count only those positions with the gap in the middle, then there are 10 pieces which can be any order, giving 10! = 3,628,800 positions. All of these permutations are possible.

Notation:
There are 3 loops in the puzzle; the left half, the right half, and the complete circle. Denote these by L, R, and C. A clockwise shift of all the beads in a loop is indicated by the relevant letter, and an anti-clockwise shift by the letter followed by an apostrophe, i.e. by L', R' and C'.

I performed a computer search for this puzzle. The following table shows how many positions there are for each number of moves from the solved position. A move is single shift of one of the three loops in any direction.
Moves | # Positions
0 | 1
1 | 6
2 | 24
3 | 91
4 | 329
5 | 1,169
6 | 3,992
7 | 13,122
8 | 41,437
9 | 124,205
10 | 343,276
11 | 811,477
12 | 1,328,627
13 | 882,408
14 | 78,441
15 | 195
Total | 3,628,800

Solution:
Hold the puzzle with the middle track vertical and its split end at the bottom.

Phase 1: Solve pieces 1-4.

  1. Do any moves to bring piece 1 to the left of the top position, i.e. the position where 4 will be when solved.
  2. If piece 2 does not lie in the right loop, then do L' until it lies in the middle, and do C until 1 is back at position 4.
  3. Rotate R to bring piece 2 to the top position, and then do L'. You now have pieces 1 and 2 in positions 3 and 4.
  4. Piece 3 is solved in much the same way as piece 2: If piece 3 does not lie in the right loop, then do L' until it lies in the middle, and do C until 1 and 2 are back at positions 3 and 4.
  5. Rotate R to bring piece 3 to the top position, and then do L'. You now have pieces 1, 2 and 3 in positions 2, 3 and 4.
  6. Piece 4 is solved in much the same way as pieces 2 and 3: If piece 4 does not lie in the right loop, then do L' until it lies in the middle, and do C until 1-3 are back at positions 2-4.
  7. Rotate R to bring piece 4 to the top position, and then do L'. You now have pieces 1 to 4 in their correct positions.

Phase 2: Solve remaining pieces

  1. Rotate R to put as many of the remaining pieces in position as possible.
  2. If the middle piece is not white, then find out where it should be and consider the piece in that position. Otherwise consider any incorrectly placed piece.
  3. Do C or C' until that piece lies at position 7.
  4. Do sequence LCLRCRCRCLCR' to swap that piece with the middle one.
  5. Do C or C' until pieces 1 to 4 are back in position.
  6. Repeat b-e until the puzzle is solved.

Nice sequences:
RR L'L' RR L'L' RR: Reverses the order of the outer circle, e.g. changes from 1-9 to 9-1 and vice versa.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Nintendo Ten Billion Barrel

Description of the puzzle
Notation used in the solutions
Solution 1 (layers)
Solution 2 (columns)
Javascript simulation of the puzzle

Description:
This extremely difficult puzzle was made by Nintendo in 1980 before they limited themselves to game computers. The Ten Billion Barrel is sometimes called the Billion barrel, 1010, or the Nintendo Tumbler Puzzle. It was invented by Gumpei Yokoi.

The puzzle has 23 coloured balls arranged in five columns spaced evenly around the sides of the barrel. The barrel itself has six rows. Two (non-adjecent) columns have only 4 balls, which lie in the middle four rows. The other three columns have 5 balls, and the extra balls either lie all in the top row or all in the bottom row. The black central core can move up or down, and that moves those three columns along with it. The middle four rows lie in two discs, which can rotate. By rotating a disc, the balls in the two rows it contains are moved around to the other columns. The aim is to place four balls of the same colour in each of the five columns, with the three black balls filling up the top of the longer columns.

Although this puzzle looks similar to the Ivory Tower, the Whip-It and the Missing Link, those puzzles have a gap so you can move pieces individually. The Nintendo barrel only allows you to move no fewer than 10 balls at a time which makes it extremely difficult.

In the far east it has been produced again recently. The small bit of paper supplied with it has the following amusing Japanglish text, quoted verbatim:
Cylindric Revolving Puzzler of good quality and fine appearance, provides educational value and also suit for decoration and giveaway in business. It holds colored beads in red, orange, yellow, green, blue, black etc, which present you 10 billion combinations. Cylindric Revolving Puzzler original type is laid three black bead at buttom, the second layer holds 4 same color bead in a row and spread 5 different rows arranged clockwise in the roder of blue, green, yellow, orange, red.
Mix the beads up, then here you start the game! 		It may firstly beat your brains quite a bit. Yet you may try to arrange for a row at beginning, then two, three rows to four, four rows. You will finally grasp secret from this challenge and be in enchanted with it.

The number of positions:
There are 23 balls which gives a maximum of 23! positions. This limit is not reached because:

  • the pieces of each colour are indistinguishable (3!·4!5)
  • the colours are equivalent (5!)
This last factor comes about because it does not matter which colour goes in which column. This leaves 23! / (3!·4!5 5!) = 4,509,264,634,875 or 4.5·1012 positions. This far exceeds the 10 billion figure on the packaging.

If all the balls were different then, according to David Singmaster (in Cubic Circular Issue 2) all 23!/2 even permutations of the balls are achievable, even if the two discs are locked together. By turning the puzzle upside down, all odd permutations can also be achieved.

Links to other useful pages:
Steve Martin's page has a partial solution to the puzzle.
This page has a very sketchy solution.

Notation:
The central core of the barrel will be assumed to be in its upwards position, the way it is when the puzzle is put down. The letters T and B will be used for moves which rotate one of the the two discs, the Top or Bottom one. If the core is up, then Tl or Bl mean moving a disc one step to the left (clockwise when viewed from above), whereas two steps (i.e. 2/5 of full circle) will be shown as Tll or Bll. Similarly right turns are Tr, Br, Trr, Brr. If these same moves are performed while the centre core is pushed down, then small letters are used, e.g. tl, tll, trr, tr, and bl, bll, brr, br.

As said before, normally the central core will be held in the up position. The rows are counted from the bottom up, so the bottom row is called the first row, and the top row which has only three balls is the fifth row. The puzzle is always held in such a way that the two short columns are at the front left and right. One of the three long columns is directly in front, and the two adjacent ones at the back. Lets label the columns too from A to E; the back left column is column A, the front column is C, the back right column is E. The position of each ball can then be described easily, for example C5 is the ball at the top of the front column.

Solution 1:
This solution will solve the Nintendo barrel row by row. It is based on the solution by James G. Nourse in "Simple Solutions to Cubic Puzzles".

In the first two phases the bottom two rows will be solved. There are a few useful sequences that move balls from row to row, without disturbing the bottom two rows. For example, tr Tl, moves C5 to C4, and C4 to C3. If you look carefully, you will see that you can use very similar sequences (that do not involve turning the bottom disc) to move any ball in rows 4 or 5 down to row 3.

One other useful move sequence is:
Double Swap: bll Tll brr (Trr).
This sequence swaps B2 and B3, and also A3 and C3. The last move in the sequence is usually not necessary because we will only use it when building the first two rows. You can use it to lift a ball from row 2 up to row 3 in column B, and vice versa, to drop a ball from row 3 to row 2. Of course, if you need to lift a ball in another column from row 2, then you can turn the bottom disc to bring it to column B, do the double swap, and return the bottom disc to its original position.

Phase 1: Solve the first (bottom) row.

  1. Consider which colours you want in each column. If you do not care which order the columns are in, and the first row already has all five different colours, then you can skip this phase completely.
  2. Turn the bottom disc so that A1 has a non-black ball. Consider that ball to be the correct colour for column A. Remember that when you have solved the puzzle, you can always move the two discs around to bring that colour to any other column anyway. Let a to e denote the colours that the columns A to E will eventually have, i.e. ball A1 already has colour a.
  3. Do Br, to bring the first ball to B1.
  4. Bring a ball of colour e to B2 as follows:
    1. Find a ball in row 3 of colour e. If there is none on row 3, then you can bring one to row 3 using the methods discussed above.
    2. Turn the top disc to bring the ball to B3.
    3. Do the double swap to bring it to B2.
  5. Do Brr, bringing the first two balls to D1 and D2.
  6. Bring a ball of colour c to B2, in the exact same way as before.
  7. Do Br bl. This puts the three balls in positions E1, D1 and B1.
  8. Bring a ball of colour b to B2, just as before.
  9. Do Bll.
  10. Bring a ball of colour d to B2, as before.
  11. Do Bll bl. The bottom row should now be correct.

Phase 2: Solve the second row.

  1. Turn the bottom row until B1 and B2 have different colours.
  2. Find a piece of the same colour as B1, and bring it to B2, using the exact same method as was used in the first phase.
  3. Repeat steps a and b until the bottom two rows are saved.

Phase 3: Solve the third row.

  1. Turn the top disc to match as many of the balls in the third row with those on the second row.
  2. Find a column where the third row has the wrong colour ball. Turn both discs to bring that column to the front, to column C.
  3. Find a ball that belongs at C3. There are 12 possible positions it could be in. Do the relevant sequence below:
    A3: tll Tll tll Trr tr Tr tll Tl tll
    B3: Tl tl Tll tll Tl trr Trr trr
    D3: Tr tr Trr trr Tr tll Tll tll
    E3: trr Trr trr Tll tl Tl trr Tr trr
    A4: tr Trr trr Trr tr Trr trr Trr tr
    B4: trr Tl tl Tll tr Tll tll
    C4: trr Tr trr Trr tr Tl trr Tr trr
    D4: tll Tr tr Trr tl Trr trr
    E4: tl Tll tll Tll tl Tll tll Tll tl
    A5: Trr tr Tll tll Tll tll Tr tr Tll
    C5: tll Tll tr Tll tl Tl trr
    E5: Tll tl Trr trr Trr trr Tl tl Trr
  4. Repeat steps b and c until the third row is correct.

Phase 4: Solve the fifth row.
Repeat the 3 steps below until all black balls are in the top row.

  1. If A5 is not black, then turn both discs so that a column containing a black ball is in column D. To move the black ball from D4 to the top row, do the sequence:
    tll Tr tr Tll tr Tr tr Tll tll
    The black ball will not necessarily go to position A5, but it will go in the top row.
  2. If C5 is not black, then turn both discs so that a column containing a black ball is in column B. To move the black ball from B4 to the top row, do the sequence:
    tll Tll tr Tr tr Tll tr Tr tll
    The black ball will not necessarily go to position C5, but it will go in the top row.
  3. If E5 is not black, then turn both discs so that a column containing a black ball is in column B. To move the black ball from B4 to the top row, do the sequence:
    trr Tl tl Trr tl Tl tl Trr trr
    The black ball will not necessarily go to position E5, but it will go in the top row.

Phase 5: Solve the fourth row.

  1. Only the fourth row is left, and this can be solved quite easily by swapping the balls around. Find two balls on the fourth row which when swapped will put at least one of them in the correct column.
  2. Turn both discs to bring the two columns to column C and one of A or B.
  3. To swap B4 and C4, do:
    trr Tl tl Trr tl brr Tl trr Trr bll Trr
    To swap A4 and C4, do:
    tr Tl Bl bll Tll brr Tll tl Br

Solution 2:
This solution will mostly solve the Nintendo barrel in columns.

Phase 1: Solve the black balls (the top row).

  1. If A5 is not black then turn the discs to bring a black ball in column A, and repeat Br Tr bl tl until it is at A5.
  2. If C5 is not black then turn the discs to bring a black ball in column C. Alternate the sequences Tr tl and Tl tr until it is at C5. Note that the first sequence moves A5 to E5, and the second moves it back again. If the first black ball ends up at E5 when C5 is solved, then do tll to prepare for the next step.
  3. If E5 is not black then turn the discs to bring it to column D. Alternate the sequences trr brr Tll Bll and tll bll Trr Brr until it is at D4. Note that the first sequence moves A5, C5 to C5, E5 and the second moves them back again. If the black balls are now at A5, C5, D4 then do trr to solve them. If on the other hand they are at C5, E5, D4 then they can be solved by Tll tll.

Phase 2: Solve the columns.

  1. Decide what colour you want each of the columns to be. Turn the discs to bring as many balls as possible into their correct columns.
  2. Find a ball that is in the wrong column. Find the column it should be, and find a ball in that column that is also wrong (preferably belonging in the first column). These two balls will be swapped.
  3. Turn both discs together so that the two balls lie in column C and column A or B.
  4. To swap the two balls, do the relevant sequence below:
    A1, C1: Bll br Tll br Trr Bl br Tll br Tr
    A2, C1: Tll Brr brr Bl bll Brr br Bll br
    A3, C1: Bl bll Bl brr Tll bll Br brr Tr
    A4, C1: tr Tll br Bl Tll br Br bl Tl tl
    B1, C1: Bl brr Br bll Br Tr bll Br brr Bl
    B2, C1: Trr Bll br Tl Bl bl Tr bll Tr bl
    B3, C1: Tll br Tll Bl br Br bl Tl
    B4, C1: Tr tr Trr br Tll Bl br Br tl bl Tl
    A1, C2: bl Trr bl Bl Tll bl Trr bl
    A2, C2: Br bl tl Tll bll Trr tr bll Bl
    A3, C2: Bl brr Tr bl Tll bl
    A4, C2: Bl tr br Tr br Tl tl bll Br
    B1, C2: Trr brr Bl bll Bl brr Bll bl Tr
    B2, C2: Bl bll Tl brr Br bll Tr brr
    B3, C2: Bll bl Br Trr bl Bl Tr br
    B4, C2: Bl Tl tr Tll bll Trr tl Tll brr Trr
    A1, C3: Br Tll bll Bl brr Trr bll Br brr Bl
    A2, C3: Bll Trr bll Tl br Trr br
    A3, C3: bll Tll brr Trr
    A4, C3: Trr tl Tll brr Trr tr bll Tll
    B1, C3: Br Tll bl Trr Br bl Bl br Bl
    B2, C3: Trr tll Trr bll Tll trr brr Tll
    B3, C3: Trr bl Trr brr Tll bl Tll
    B4, C3: Tll tl Trr bll Tll tr brr Trr
    A1, C4: Bll tl brr Tll Br bll Trr tr brr Bl bll Brr
    A2, C4: Trr Bll tl bl Tl bl Tr tr brr Bl
    A3, C4: tr Trr Brr bll Tll tl brr Bll
    A4, C4: Tl Bll tll bll Tl tll brr Tll Bll tl
    B1, C4: Br tl Tll bl Trr Br bl Bl tr br Bl
    B2, C4: tl Tll bll Trr tr Tll brr Trr
    B3, C4: Tll Br tr brr Tll bll Trr Brr tl
    B4, C4: Tl tll Tr tl Tll tl Tll tll Trr tr
    Note that these sequences will mix up each column, but only the two chosen balls will move to a different column.
  5. Repeat steps b-d until all the columns are solved.

Other sequences

  1. Column swaps: (Calculated by Mike Godfrey)
    Swap A,C: br Bl br Bl bll tr Tr brr Tl brr Bll bl tl
    Swap B,D: Tr bll tl Trr bll Bl Tll bl Tr br b1 Tl bl tr Tl
    Swap B,E: Tr br Br bl Brr bll tr Tl bl Brr Tr brr tl Brr Tl
    Swap A,B: trr Bll Tl bl Tl tll Tr trr Tll brr Br bll Trr bll Tl
    Swap B,C: Br bll Tr bll trr Tr tll Brr Tr bll Brr Tl br Tll trr Tll
    Swap A,E: tr Bl Tr bl Tl brr Br brr tll Tl bl Tr tr Bl

Pretty patterns:

  1. Spiral:
    bll Tr bll Tr bl Bl Tl br Bl
  2. Zig Zag:
    Do Spiral followed by Brr.
  3. Flag:
    bll Trr Brr tll brr Trr tl br Trr Bl tr br Tr Br brr
  4. Topsy Turvy (is similar when turned over).
    Tr tll Tr tr Tl tl Tr tr Tll

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Octahedron / Christoph's Jewel

Jaap's Puzzle Page

Octahedron

Picture kindly supplied by Hendrik Haak

This is a regular octahedron, of which each triangular face is divided into 9 identical smaller triangles, three to a side. A move consist of rotating a vertex; either just a tip (one triangle to a side) or a larger part (two triangles to a side). Christoph's Jewel is essentially the same puzzle except that the tips are missing, much like the Tetraminx is a Pyraminx without tips.

It is equivalent to a Rubik's cube puzzle without corners, but with the face centres marked to show their orientations. If you understand the solution for the Pyraminx, then you can probably solve much of this puzzle too, because it acts very similar.

The number of positions:
There are 6 vertex pieces with 4 orientations, 12 edge pieces with 2 orientations giving a maximum of 12!·212·64 positions. This limit is not reached because:

  • Only half the vertex orientations are possible given a certain edge position because a quarter turn is an odd permutation (2)
  • Only and even number of flipped pieces are possible (2)
This leaves 12!·210·46 = 2,009,078,326,888,000 or 2.0·1015 positions.
If you include the trivial vertex tips then this has to be multiplied by a further 46.

Links to other useful pages:
'Simplest Solutions' page A text based solution.

Notation:
The vertices are denoted by the letters L, R, F, B, U, D (Left, Right, Front, Back, Up and Down). Clockwise quarter turns are denoted by the appropriate letter, ant-clockwise turns by the letter followed by an apostrophe (e.g. L' means turn the Left vertex 90 degrees anti-clockwise), and half turns by the letter followed by a 2 (e.g.. F2 means turn Front 180 degrees). Since the vertex tips are solved independently from the rest of the puzzle (see phase 1 below) this notation is not applied to tip moves but only to the larger moves.

Solution:
Phase 1: Solve tips.

  1. Rotate the tips on each vertex to match the adjacent vertex pieces.
Phase 2: Solve vertex pieces.
  1. Rotate the F, B, L, R and U vertices so that their vertex pieces match, and only the edge pieces have the wrong colour. The D vertex will be done later.
Phase 3: Place the U edges correctly.
  1. First find any edge that belongs next to the U vertex.
  2. If the edge is not at the D vertex, then put it there by using this sequence:
    Move FR->DF: Do R'D'R.
    This moves the edge between the F and R vertices to a position between the D and F vertices.
  3. Hold the puzzle so that the edge belongs at the front, i.e. at FU.
  4. Rotate D to place the piece at the front, i.e. at DF.
  5. Use one of the following sequences to place the edge in its correct position:
    To move FD->FU do D F2 D' F2.
    To move DF->FU do D F' L D2 L' F.
  6. Repeat the above until all U edges are at the U vertex. Note that if all U edges are at the U vertex but they are not all correctly positioned, then you can bring one down to the D vertex by using one of the above sequences to displace a U edge.
Phase 4: Place middle edges correctly.
  1. Find a middle layer edge that lies at the D vertex.
  2. Hold the puzzle so that the edge belongs at FR.
  3. Rotate D to bring the edge to the DF position.
  4. Place the edge piece by using one of the following:
    To move FD->FR, do R' D R.
    To move DF->FR, do D L D' L'.
  5. Repeat the above until all middle edges are correct. Note that if a middle edge is incorrectly positioned, it can be brought down to the D vertex by using one of the above sequences to displace it.
Phase 5: Solve D vertex piece.
  1. Rotate D until the vertex piece matches the others. Now only the four D edge pieces remain unsolved.
Phase 6: Place D edges in position.
  1. Hold the puzzle so that one of the following sequences will place the remaining edges in the correct position:
    1. To move DR->DF->DL->DR, do R' D R D R' D2 R
    2. To move DR->DL->DF->DR, do R' D2 R D' R' D' R.
    3. To move DR-DL, DF-DB, do R' D2 R D2 R' D R D2 R' D2 R D'
    4. To move DR-DF, DL-DB, do R' D R D' R' D2 R D R' D' R D2
Phase 7: Orient the D edges.
  1. Hold the puzzle so that one of the following sequences will solve the puzzle completely:
    1. To flip DR, DF, do R D' F D F' D R' D'
    2. To flip DR, DL, do R D' F D2 F' D R' D2
    3. To flip DR, DL, DF, DB, use b or c to flip them two at a time.

Home
Links
Guestbook


The Orb

Jaap's Puzzle Page

The Orb (Orb-It)

Picture kindly supplied by Hendrik Haak

This fascinating puzzle is called Orb in the USA and Orb-It in the UK. The puzzle consists of a ball with two small rings of beads near the poles, and two larger rings parallel to and near the equator. The four rings have different colours. The bead rings rotate around the ball. The ball itself is divided vertically into two halves. By rotating one half the rings of beads become either one long spiral, or two loops (looking a bit like a tennis ball). In the solution below the spiral position is never used.

The beads in the polar rings are blue or yellow. The remaining beads are red or green.

It might be interesting to quote from the afterword of the Rubik's Cubic Compendium [p213] written by David Singmaster.

A further type of closely related puzzle is what I call the 'switchable cycle' puzzles. Here one has several disjoint cycles of pieces with some mechanism for splitting the cycles. The best known example was the Orb-It (UK) or Orb (US), which had four parallel tracks on a sphere. One hemisphere could be turned to eight positions with respect to the other, causing the half-tracks to join up in several different ways. This was marketed in both Europe and the United States. Another version, called VIP-Sphere or Logi-Sphere, allowed the hemisphere to have just two relative positions. It was marketed in Germany.
In Issue 2 of Cubic Circular (Spring 1982), David Singmaster says it was invented by Chris Wiggs and developed with Tom Kremer. The tiny booklet that comes with my puzzle however states it was invented by Chris Wiggs and Chris Taylor, and calls it the Orbs Puzzle.

The number of positions:
There are 8 beads in each of the polar rings and 20 in the equatorial ones, which gives: 56! / (8!220!2) = 73,888,773,475,012,113,089,523,051,000 or 7.4·1028 positions. This considers rotations of the rings as the different positions, and does not include the other loop shapes.

Solution:
Phase 1: Separate the polar/equatorial beads. In this phase the blue/yellow beads are placed in the polar rings, and the red/green beads are therefore displaced to the equatorial rings.

  1. Suppose there is a red/green bead in each of the polar rings, and a blue/yellow bead in each of the middle rings. Then rotate the rings to place those four beads at the following positions:
    1. Top ring: at the front, immediately to the left of the seam dividing the two halves of the orb.
    2. Second ring: at the front, immediately to the right of the seam.
    3. Third ring: at the back, next to the seam in the right hand half of the orb.
    4. Bottom ring: at the back, next to the seam in the left hand half of the orb.
  2. Rotate the right hand side a quarter turn in either direction, to create the position with two loops.
  3. Slide the beads in the right hand loop anti-clockwise so that the four beads cross over the seam.
  4. Rotate the right hand side back again.
  5. Repeat the above as often as possible.
  6. If you now have a position with 4 or more odd-coloured beads but they are not spread over all 4 rings, then rotate any rings with more than one odd bead so that they occur on both halves of the puzzle and any rings with a single odd bead so that it lies in the left hand side. Follow this with a half turn of one side of the puzzle to spread the odd beads over all the rings. Now go back to steps a-d.
  7. If you have a position with only 2 odd-coloured beads, then use the method in a-d above to place only one of them correctly. This will disturb three other beads, leaving you with 4 odd-coloured beads which can be solved as above.
Note that the above method doesn't just work with a single bead in each ring. It works just as well with a pair of adjacent beads in each ring, or even three of four.

Phase 2: Separate red and green, and similarly blue and yellow.

  1. Find an incorrectly placed bead in each of the equatorial rings.
  2. Place the incorrect beads as follows:
    1. First ring: At the front, to the left of the seam.
    2. Second ring: At the front, to the right of the seam.
  3. Rotate the right hand side through 180 degrees.
  4. Shift the first ring to the right, so that both beads cross the seam.
  5. Rotate the right hand side back 180 degrees.
  6. Repeat the above till the equatorial rings are correct.
  7. Repeat the above for the polar rings.
Note that the above moves don't just work with a single bead in each ring. It works just as well with a pair of adjacent beads in each ring, or even three or more.

Home
Links
Guestbook


Orbix

Picture kindly supplied by Uwe Meffert

This electronic puzzle consists of a ball with 12 large buttons on it, arranged symmetrically like the faces of a dodecahedron. Each button has a light in it as well. It is very similar to the Lights Out puzzle, in that by pressing the buttons the pattern of lights changes. The aim is to switch on all the lights.

There are 4 types of game play, which have very different ways of solving. These will be discussed separately below. By pressing and holding down two buttons at the same time you control the following aspects of the puzzle:

  • Two opposite buttons: Switches the Orbix on and off.
  • Two adjacent buttons: Switches between the 4 types of gameplay. The lights will flash between 1 and 4 times to show which type.
  • Two other buttons: Switches the sound on or off.

Description and solution to game type 1
Description and solution to game type 2
Description and solution to game type 3
Description and solution to game type 4

If your browser supports it, you can play with the orbix by clicking this link:

Javascript Orbix Puzzle

Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He produces and sells this puzzle, the Pyraminx, Megaminx, Skewb, and many others. Meffert's page also contains some move sequences for game type 1-3.
David Joyner's page. Some of the maths behind the type 1 puzzle.
David Joyner's page. A page with some hints.

Type 1:
If you press any button, the 5 adjacent lights will change; switch on if they were off and vice versa.

This is a very simple type of game. Like Lights Out and Rubik's Clock, this is one of the few puzzles in which the order that the moves are performed is unimportant (i.e. the puzzle positions form an Abelian group). This means that it is not necessary to press any button more than once during the solution because we could change the order of the moves so that repetitions occur together. Since pressing a button twice will not change anything, a button need only be pressed at most once.

There are 12 lights, and each light can be switched on independently from all the others. There are therefore 212 = 4,096 positions, and at most 12 button presses are needed to solve it. Of course many of the positions are similar because rotations/reflections of the whole puzzle have not been taken into account.
Depth | Positions | Rot | Rot+Refl
0 | 1 | 1 | 1
1 | 12 | 1 | 1
2 | 66 | 3 | 3
3 | 220 | 5 | 5
4 | 495 | 12 | 10
5 | 792 | 14 | 12
6 | 924 | 24 | 18
7 | 792 | 14 | 12
8 | 495 | 12 | 10
9 | 220 | 5 | 5
10 | 66 | 3 | 3
11 | 12 | 1 | 1
12 | 1 | 1 | 1
Total | 4096 | 96 | 82

The table shows the number of positions there are for each number of moves. In this case the numbers are simply the binomial coefficients, because of the nature of an Abelian group i.e. because the move order does not matter. The third column shows the number of positions if rotations are taken into account, the last if both rotations and reflections are taken into account.

Solution:
Simply press a button if an even number of the adjacent buttons are lit. Repeat this until the puzzle is solved.

Type 2:
This type of game play is the same as type 1, except that only lit buttons can be pressed. Pressing an unlit button has no effect on the lights. A simple computer search shows that 2079 positions are attainable, and that it can always be solved in at most 10 button presses.
0 | 1
1 | 12
2 | 36
3 | 80
4 | 185
5 | 300
6 | 475
7 | 480
8 | 312
9 | 152
10 | 51
Total | 2079

Solution:
This is solved in a similar manner as before, except that you just press lit buttons. Simply press any lit button which has an even number of lit neighbours. Repeat this until the puzzle is solved. There are however 5 types of position which has no lit buttons with an even number of lit neighbours and these should be avoided if you want to use the minimum number of moves. These are:

  1. There are 4 lights on; two adjacent lights and the two on the exact opposite side of the puzzle. Just press any light and continue. This is exactly 10 presses from being solved.
  2. There are 6 lights on; all the lights in one hemisphere are lit, the other half is unlit. Just press any light except for the central one, and continue. This is exactly 8 presses from being solved.
  3. There are 6 lights on; three adjacent lights (in a triangle), plus three lights which are adjacent to only one of the other three. Just press any light and continue. This is exactly 8 presses from being solved.
  4. There are 4 lights on; two separate sets of adjacent lights. Note that this time (unlike case 1 above) one pair does not lie exactly opposite the other. Just press one of the lights for which the button exactly opposite is lit, and continue. This is exactly 6 presses from being solved.
  5. There are 8 lights on; two adjacent buttons are unlit and the two on the exact opposite side of the puzzle are also unlit. Just press any light that lies adjacent to both sets of unlit buttons and continue. This is exactly 6 presses from being solved.

Type 3:
With this type of game play only unlit buttons can be pressed, and then all buttons EXCEPT the adjacent ones change. Pressing a lit button has no effect on the lights. A simple computer search shows that all positions are attainable, and that it can always be solved in at most 12 button presses.
0 | 1
1 | 12
2 | 30
3 | 140
4 | 291
5 | 440
6 | 660
7 | 792
8 | 727
9 | 572
10 | 302
11 | 92
12 | 37
Total | 4096

Solution:
Solving this is very similar to type 2, except that now you only press unlit buttons, and the number of lit neighbours must be alternately odd and even. I do not know of an easy way to determine what the parity of your first move should be, odd or even. Simply choose any first move, and from then on alternate the parity. If you have done 12 moves and still have not solved it, then you must have started wrong. You may also come upon a position where there are no moves of the parity you are looking for.

Generally, in any position that is an odd number of moves from being solved, the next button pressed should have an odd number of lit neighbours. Similarly, positions an even number of moves from solved usually have an even next move. If there are moves of the right parity, then they will always be good moves. There are however a few exceptional positions where there are no moves of the correct parity. In all these cases, any single move of the wrong parity is good, and then just continue as if that move were the correct parity. These cases are:

  1. There are 2 lights on; two on exactly opposite sides of the puzzle. This is exactly 4 presses from being solved.
  2. There are 6 lights on; two adjacent lights are on, all those adjacent to either of these are off, and the remaining 4 are on. This is exactly 4 presses from being solved.
  3. There are 8 lights on; three adjacent buttons (in a triangle) are off, and one on the opposite side of the puzzle is also off. This is exactly 6 presses from being solved.
  4. There are 6 lights on; three adjacent buttons (in a triangle) are off, and the three on the exact opposite side of the puzzle is also off. This is exactly 8 presses from being solved.
  5. There are 10 lights on; two non-adjacent non-opposite buttons are off. This is exactly 8 presses from being solved.
  6. There are 6 lights on; a ring of 5 lights are on, and the one non- adjacent light is also on. This is exactly 10 presses from being solved.
  7. There are 6 lights on; three adjacent lights are on, and the three buttons adjacent to two of the first three are also on (these six form a large triangle). This is exactly 10 presses from being solved.
  8. There are 10 lights on; two opposite lights are off. This is exactly 12 presses from being solved.

A way to solve the puzzle in relatively few moves is therefore like this:

  1. Find any unlit button, and check whether it has an even or odd number of lit neighbouring buttons.
  2. Press the button.
  3. If the last move was even, then find any unlit button which has an odd number of lit neighbours, and if the last move was odd then find any unlit button which has an even number of lit neighbours.
  4. Press the button.
  5. Repeat c-d, until:
    1. You have solved it.
    2. You have done 12 or more moves. You must have chosen the wrong parity to start with, so do a move of the same parity as the last one and go back the steps c-d to try again.
    3. You are in a position that is not one of those listed above, but has no move of the parity you are looking for. You must have chosen the wrong parity to start with, so do a move of the same parity as the last one and go back to steps c-d to try again.
    4. You are in a position that is one of those listed above. Do any move, and go back to steps c-d to continue, keeping in mind that the next move will need to be odd.

Type 4:
With this type of game play only lit buttons can be pressed. If the button opposite the pressed one is on then the effect is as type 1/2, i.e. the adjacent 5 lights change. If the button opposite the pressed one is off, then all buttons except the pressed one change. Pressing an unlit button has no effect.
0 | 1
1 | 24
2 | 30
3 | 12
4 | 180
5 | 492
6 | 735
7 | 1460
8 | 1101
9 | 60
Total | 4095

This shows that all positions can be solved in at most nine moves, except of course the position with no buttons lit which is impossible.

Solution:
The following method is not the fastest, but it will solve the puzzle fairly quickly.

  1. If fewer than half the buttons are lit, then press any lit button which has an unlit button opposite. Now at least half the buttons are lit.
  2. If there is any lit button with a lit button opposite, and with fewer than 3 lit neighbours then press it. This increases the number of lights that are on further.
  3. Repeat step b as long as possible.
  4. If all the unlit buttons have a lit button on the opposite side of the puzzle, then each of the unlit ones can be solved by pressing its opposite twice, and then the button itself once.
  5. There are only 3 cases remaining that are not solved this way:
    1. Two adjacent buttons and their opposites are off. Find the two buttons that are next to both the adjacent unlit buttons. Press them, and go back to step b.
    2. One unlit button and its opposite are unlit. Press any button adjacent to an unlit one to light it up, then press the originally unlit button itself, and go back to step b.
    3. Two adjacent unlit buttons, and one unlit button opposite. Press the lit button opposite one of the unlit buttons, and go back to step b.

Home
Links
Guestbook


Port to Port

Jaap's Puzzle Page

Port to Port / Triple Cross

Picture kindly supplied by Hendrik Haak

Description
Port to Port Solution
Triple Cross Solution

Links to other useful pages:
Binary Arts homepage. Homepage of the manufacturer.
David Barr's page has a complete solution to Triple Cross.
TripleCross Pain Chamber describes Mark Wagner's efforts to write a computer program that searches for Triple Cross solutions.

Description

These two puzzles have the same shape and mechanics, but have different designs. They have 18 tiles, which are moved by various plungers. The main area consists of a 2x7 rectangle and this can be moved one tile to the left or to the right (i.e. there are 3 positions; left, right and centre). There are also two small plungers which each hold a 3x2 rectangle of tiles, 4 of which are common to the main area. These plungers are connected so that if one is pushed upwards, the other is pushed downwards and vice versa.

The Port to Port puzzle is the easiest of the two. Three of its tiles form a ship, and the aim is to move them from one side of the puzzle to the other. The other tiles are not important (four have a little boat on them, two form the Binary Arts logo, the rest are blank).

Triple cross is much more difficult because more tiles take part. Four tiles in a 2x2 square have one large circle on them. There are also three identical tiles with a horizontal line on them which should go together in any order in a 1x3 rectangle. As in Port to Port, there are two tiles with the Binary Arts logo. The start position has the circle on the far right, the line on the top left, the left plunger is pushed down and its bottom two tiles contain the logo. The aim is to restore these parts after the puzzle has been mixed, though it is not clear to me whether they are supposed to be in the exact same positions mentioned above.

These are tricky puzzles, because there are only a few possible moves and each one moves many tiles. Even Port to Port's ship is a little tricky to put together again once it has been broken up.

Port to Port

The number of positions:
All even permutations of the tiles are possible, but only the tiles that have part of the design on them matter. In Port to Port, only the three ship tiles matter, and these can be in 18·17·16 different positions. The plungers can only be in two different positions as I will only count positions with the main area centralised. Therefore there are only 2·18·17·16 = 9,792 positions.
Note that of these positions, there are 4 with the ship on one side and 4 with the ship on the other. Despite this low number, it is certainly not trivial. If you include the logo tiles, there are 2·18·17·16·15·14 = 2,056,320 positions.

I used computer searches to analyse the puzzles and to find good move sequences to use in the solutions. Ignoring the logo, there are no positions more than 33 moves away from being docked anywhere, 39 moves from being docked at the left side, 42 moves from being docked at the top left with the left plunger down, or 45 moves from being docked at the top left with the left plunger up.

If your browser supports JavaScript, you can play Port to Port by clicking this link:

JavaScript Port to Port Puzzle

Notation:
Let R and L denote moving the central area right and left respectively, and let / denote a movement of the plungers.

Solution to Port 2 Port:
There are 4 positions with the ship docked at the left port, and 4 with the ship in the right port. Therefore are 16 ways of crossing, but through symmetry there are only 6 essentially different ways. The following table shows all of the left to right crossings. The position of the ship and that of the plunger at that side is given. The shortest sequence is 29 moves.
Ship | Plunger | Sequence | Ship | Plunger
top | down | R/LL/R/L/R/R/L/L/R/R/L/R/LL/R (29) | top | down
top | up | /L/RR/L/L/R/R/LL/R/L/RR/L/R/L/ (30) | top | down
bottom | up | L/R/R/LL/R/L/RR/L/R/L/L/R/R/LL/R (32) | top | down
bottom | down | L/R/R/L/L/RR/L/R/LL/R/L/RR/L/R/L/ (33) | top | down
bottom | down | R/L/L/R/R/L/R/LL/RR/L/R/LL/R/R/LL/RR/L/ (39) | bottom | down
top | up | R/LL/RR/LL/R/R/L/R/LL/R/R/L/R/LL/R/R/L/L/R (42) | bottom | down

Here are the 4 essentially different ways to re-dock at the same port, i.e. keep the ship on the same side but change its position or the position of the plungers. The table below lists all these for a ship on the right hand side. The position of the ship and that of the plunger at that side is given.
Ship | Plunger | Sequence | Ship | Plunger
top | up | R/L/L/RR/L/L/R/ (15) | top | down
bottom | up | R/LL/RR/L/L/R/R/L/R/LL/R/ (25) | top | down
top | up | R/LL/R/R/LL/RR/L/L/R/R/L/ (25) | bottom | down
bottom | down | L/RR/L/L/R/R/L/R/L/R/LL/R/ (26) | top | down

There now follows a general method of moving/reassembling the ship in Port to Port. Denote each of the 18 tile positions by letters as shown in the following diagram.
 |  |  |  | Q | R |
A | B | C | D | E | F | G
H | I | J | K | L | M | N
 | O | P |
The steps below will move the ship to the left, and reassemble it there. Start with the left plunger pushed down, and the main area centralised.

  1. If there is a ship tile in the right hand side, then
    1. Repeat sequence /L/R or its inverse L/R/ until positions D, E and K are empty, and there is a ship tile at Q, R, F, L or M.
    2. Repeat sequence /R/L or its inverse R/L/ until a ship tile lies at position D.
  2. Repeat step a until no ship tiles remain on the right hand side.
  3. Repeat sequence /L/R or its inverse L/R/ until positions D, K are empty.
  4. Consider the left and middle tiles of the ship. Repeat sequence /R/L or its inverse R/L/ until one of them lies at A, and the other does not lie at J.
  5. Repeat sequence /L/R or its inverse L/R/ until the left/middle tiles of the ship lie at A and B in either order.
  6. If the right tile of the ship lies at L then
    1. If the left tile of the ship lies at A then do /L/R/R/LL/R/R/L.
    2. If the middle tile of the ship lies at A then do L/R/R/LL/R/R/L.
  7. Do /R/L to leave the left/middle ship tiles at A and H.
  8. If the middle tile of the ship lies at A then
    1. If the right tile of the ship lies at J then do /R/L/R/L/L/RR/L/ to solve it.
    2. Otherwise repeat sequence L/R/ or /L/R till the right tile lies at position B and then do R/L/.
  9. If the left tile of the ship lies at A then
    1. If the right tile of the ship lies at J then do R/L/R/L/L/RR/L/ to solve it.
    2. Otherwise repeat sequence L/R/ or /L/R till the right tile lies at position O and then do /R/L/.

If you desperately want to recombine the logo tiles, then one method follows below. This assumes the ship lies at the top left, with the left plunger pushed down. The logo will be constructed at the bottom of the left plunger.

  1. Find the 'Binary' tile. To place it at O, do the relevant sequence in this list:
    D. R/LL/R/L/RR/L/L/R/L/R/R/LL/R/R/LL/RR/L
    E. /R/L/L/R/R/LL/R/R/LL/R/R/LL/R/R/L/R/L/
    F. /R/LL/RR/L/L/RR/L/R/LL/R/R/L
    G. R/L/L/R/L/RR/L/R/LL/R/L/RR/LL/RR/LL/R/
    H. /L/RR/LL/R/R/L/R/L
    I. L/RR/L/R/LL/RR/L/R/LL/RR/LL/R/
    J. R/L/R/LL/RR/LL/R/L/RR/L/R/LL/R
    K. /R/LL/R/L/RR/L/R/L/L/R/L/R/L/R/R/L
    L. L/RR/L/L/RR/L/L/RR/L/L/RR/L/
    M. L/RR/L/R/LL/R/R/L/R/L/R/L/
    N. R/L/L/RR/L/R/LL/R/R/LL/RR/L/
    P. R/LL/RR/LL/R/R/L/R/L/R/L
    Q. R/L/R/L/L/R/R/LL/RR/LL/RR/L/R/L/R/L/L/R/
    R. /L/RR/L/R/LL/RR/LL/RR/L/R/L/R/L/L/R/
  2. Find the 'Arts' tile. To place it at P, do the relevant sequence in this list:
    D. R/LL/R/R/L/R/L/R/LL/R/R/L/R/L/R/L/L/RR/L
    E. /R/LL/RR/LL/RR/LL/RR/LL/RR/L/R/LL/R/R/LL/R
    F. /L/R/R/LL/RR/L/L/RR/L/L/RR/L/L/RR/L/R/L/L/R/
    G. L/RR/L/l/R/L/R/L/RR/LL/RR/LL/R/R/L/R/L/L/R
    H. /L/RR/LL/R/R/L/L/RR/LL/R/R/LL/RR/LL/R/
    I. R/LL/R/R/L/R/L/R/L/L/RR/L/R/L/R/L/L/RR/L
    J. /R/L/R/L/R/LL/RR/LL/RR/L/R/L
    K. R/LL/RR/LL/RR/LL/RR/L/R/LL/R
    L. /R/L/R/LL/R/R/LL/RR/LL/R/R/L
    M. L/RR/L/R/LL/RR/LL/RR/LL/RR/L
    N. R/L/L/RR/L/R/L/L/RR/L/L/RR/LL/RR/L/L/RR/LL/R
    Q. R/L/L/RR/LL/RR/L/L/R/R/LL/RR/LL/RR/L/R/L
    R. L/R/R/L/L/RR/L/L/R/L/RR/L/R/L/R/LL/R/L/R/R/L

Triple Cross

Picture kindly supplied by Hendrik Haak

The number of positions:
All even permutations of the tiles are possible, but only the tiles that have part of the design on them matter. In triple Cross, there are 9 viz. the 4 circle tiles, the 3 line tiles and the 2 logo tiles. These can be in 18!/(18-9)! positions. The three line tiles are indistinguishable so that leaves 18!/(18-9)!/3! different positions. I will only count positions with the main area centralised. The plungers can therefore be in two positions, which means the total number of positions for the puzzle is 2·18!/(18-9)!/3! = 5,881,075,200 positions.

If your browser supports JavaScript, you can play Triple Cross by clicking this link:

JavaScript Triple Cross Puzzle

Notation:
Let R and L denote moving the central area right and left respectively, and let / denote a movement of the plungers.
Denote each of the 18 tile positions by letters as shown in the following diagram.
 |  |  |  | Q | R |
A | B | C | D | E | F | G
H | I | J | K | L | M | N
 | O | P |

Solution to Triple Cross:
This solution was constructed by using computer searches to find sequences that move specific tiles without moving others. This means it is mostly just lists of sequences without any visible underlying strategy. If anyone has a more transparent method, I would like to know about it.
Start with the left plunger pushed down, and the main area centralised.

Phase 1: Solve the circle.

  1. If there is a circle tile in the left hand side, then
    1. Repeat sequence /R/L or its inverse R/L/ until positions D, J and K have no circle tiles, and there is a circle tile at B, C, I, O or P.
    2. Repeat sequence /L/R or its inverse L/R/ until a circle tile lies at position K.
  2. Repeat step a until no circle tiles remain on the left hand side.
  3. Repeat sequence /R/L or its inverse R/L/ until positions D, K have no circle tiles. This might not be possible if both G and N have no circle tiles, so in that case first do /R/L or R/L/ until there is a circle tile at M but none at K, do /L/R, and then repeat this step.
  4. Consider the top right tile of the circle. If it lies at F then do the sequence R/L/L/R/L/R/R/LL/R, and repeat sequence /R/L or its inverse R/L/ until positions D, K have no circle tiles. Otherwise do /L/R or L/R/ till the top right tile is in position at G.
  5. Now consider the bottom right tile of the circle. If it is not in position at N then do the relevant sequence below:
    E. L/RR/LL/R/R/L/R/L/L/R/
    F. /R/L/L/R/L/R/R/LL/R/
    L. /R/LL/R/R/L/R/L/R/LL/R
    M. L/R/R/LL/R
    Q. /R/L/R/L/L/RR/L/L/R/L/R/
    R. R/LL/R/R/L/R/L/L/RR/LL/R
  6. Repeat sequence /R/L or its inverse R/L/ until there is a circle tile at M but none at D, K or L.
  7. If the bottom left circle tile is (correctly) positioned at M, then place the final circle piece using the relevant sequence the list below.
    E. /L/RR/L/R/LL/RR/LL/R/L/RR/LL/RR/L/R/L/
    Q. L/RR/LL/RR/LL/R/L/RR/LL/R/L/RR/L/L/R
    R. /L/R/L/R/R/LL/R/L/RR/L/L/R
    If the other circle tile lies at M, then one of the sequences below, depending on the position of the bottom left circle tile.
    E. L/R/L/R/L/RR/LL/RR/LL/R/L/R/R/L/
    F. /L/R/L/R/R/LL/R/L/RR/L/L/RR/L/
    Q. L/R/L/R/R/L/R/L/L/R/L/RR/L/L/R
    R. /R/L/R/LL/RR/LL/RR/L/L/R/L/R/L/R

Phase 2: Solve the line.

  1. Find a line piece that does not lie at position A, B or C.
  2. If C has no line piece, then do the relevant sequence below:
    D. /L/R/R/LL/R/R/LL/R/R/LL/R/R/L/
    E. L/R/R/LL/R/R/LL/R/R/LL/R/R/L
    H. L/RR/LL/R/R/LL/R/L/R/R/LL/R/R/LL/RR/LL/R/R/L
    I. /R/L/R/L/L/RR/L/L/R/L/RR/LL/R/R/LL/RR/L/L/R/R/LL/R
    J. R/L/L/R/R/L/L/R/R/L/L/R/R/L/L/R/
    K. /R/L/L/R/L/R/R/LL/RR/L/L/R/L/R/R/LL/R/
    L. /L/RR/L/L/R/L/R/R/LL/RR/L/L/R/L/R/R/L/
    O. /L/R/L/RR/LL/RR/L/L/R/R/LL/RR/L/L/R/R/LL/RR/LL/R
    P. /R/LL/R/L/R/R/LL/RR/L/L/R/L/R/R/LL/RR/L/R/L/
    Q. /L/R/R/L/L/R/R/L/L/R/R/L/L/R/R/L
    R. R/LL/R/R/L/L/R/R/L/L/R/R/L/L/R/R/L/R/L
  3. Otherwise, if B has no line piece, then do the relevant sequence below:
    D. R/L/R/L/L/R/R/L/L/R/R/L/L/R/R/L/L/RR/L
    E. L/RR/L/L/R/L/RR/L/L/RR/L/L/RR/L/L/RR/LL/R/R/LL/R
    H. L/R/L/R/R/L/L/R/L/RR/L/R/L/L/R/L/R/L/R/R/L/R/L
    I. R/L/R/L/R/LL/R/R/L/R/L/L/R/R/L/R/L/L/RR/L/R/L/
    J. /L/RR/L/L/R/R/L/L/R/R/L/L/R/R/L/L/R/L/R/
    K. /L/R/L/R/R/LL/R/R/LL/R/R/L/R/L/L/R/R/L/L/R/R/L
    L. L/R/L/R/R/L/R/L/L/R/L/RR/L/L/R/R/L
    O. R/L/L/R/R/LL/R/L/R/R/L/R/L/L/R/L/R
    P. L/R/R/LL/R/R/LL/R/R/L/R/LL/R/R/LL/R/R/LL/R/R/L/R/L
    Q. /L/R/L/R/L/R/R/L/R/L/L/R/L/R/L/R/R/L/L/R/R/L
    R. /L/R/L/R/R/L/L/R/R/L/L/R/R/L/L/R/R/LL/R/
  4. Otherwise, if A has no line piece, then do the relevant sequence below:
    D. R/LL/R/L/R/R/LL/RR/LL/R/R/L/L/R/R/LL/RR/L/L/R/L/R/R/LL/R
    E. L/RR/L/R/L/L/RR/LL/R/L/RR/LL/R/R/L/R/LL/R/L/R/
    H. /L/RR/LL/RR/L/L/RR/L/L/R/L/RR/L/L/RR/LL/RR/L
    I. R/LL/R/R/L/R/LL/R/R/LL/R/L/RR/L/L/RR/L/R/L/L/R
    J. /R/L/R/LL/R/L/R/R/L/L/R/R/L/L/R/R/L/L/R/R/LL/RR/L/
    K. /R/LL/RR/L/L/R/L/R/R/LL/RR/L/R/LL/RR/LL/R/L/R/L/R/
    L. R/L/L/R/R/L/L/R/L/R/L/R/R/L/R/L/L/R/L/R/L/R/
    O. L/R/R/L/R/L/L/R/L/R/R/L/R/L/L/RR/L/L/R/L/R/R/L
    P. /R/L/R/LL/R/R/L/R/L/L/R/R/L/R/L/L/RR/L/R/L/R/L
    Q. /R/L/L/R/L/RR/L/L/RR/LL/RR/LL/RR/LL/RR/L/R/LL/R/L/R/
    R. R/LL/RR/LL/R/R/LL/R/L/R/R/LL/R/R/LL/RR/LL/R/
  5. Repeat the above till all three line pieces are at A, B or C.

Phase 3: Solve the logo.

  1. Find the 'Binary' logo tile, and do the relevant sequence below to place it at position O.
    D. L/RR/L/L/R/L/R/R/L/L/R/R/L/L/R/R/L/L/R/R/LL/R/R/LL/R
    E. L/RR/L/R/L/R/LL/RR/L/L/R/L/RR/L/R/L/L/RR/L/L/R/L/R/L/R/R/L
    H. /R/LL/RR/L/R/L/L/RR/L/R/LL/R/R/L/R/LL/R/R/LL/R/L/R
    I. /R/LL/RR/LL/RR/L/L/R/L/R/R/LL/RR/L/L/R/L/R/L/RR/L/
    J. /R/L/L/R/R/LL/RR/L/L/R/L/R/R/LL/RR/L/L/RR/L/
    K. /R/LL/R/R/LL/RR/L/L/R/L/R/R/LL/RR/L/L/R/R/L/
    L. /R/L/R/L/L/RR/L/L/R/R/L/L/R/R/L/L/R/R/L/L/R/L/R/R/L/R/L/
    P. L/R/R/L/L/R/R/L/L/R/L/RR/L/L/R/L/R/R/LL/RR/L/L/RR/L/
    Q. /L/RR/LL/R/R/L/R/LL/R/L/RR/L/L/R/L/R/L/RR/L/L/R/L/R/R/LL/R/R/L
    R. /R/LL/R/L/R/L/R/R/LL/RR/L/L/R/L/R/R/LL/RR/LL/RR/L/
  2. Find the 'Arts' logo tile, and do the relevant sequence below to place it at position P.
    D. L/RR/L/L/R/L/RR/LL/RR/LL/RR/LL/RR/LL/RR/L/L/R/R/LL/R
    E. /L/RR/L/L/R/L/R/R/LL/R/L/R/R/L/L/R/R/L/R/L/L/RR/L/L/R/
    H. /L/R/R/LL/R/R/L/R/L/L/R/R/L/L/R/L/RR/L/L/R/L/R/R/LL/R/
    I. L/RR/L/L/R/R/LL/RR/LL/RR/LL/RR/LL/RR/LL/R/L/R/R/LL/R
    J. /R/L/L/R/R/L/L/R/R/L/L/R/R/L/L/R
    K. /L/R/R/L/R/L/L/R/R/L/L/R/R/L/L/R/R/L/L/RR/L/L/R/
    L. L/R/R/L/L/R/R/L/L/R/R/L/L/R/R/L/
    Q. R/L/L/RR/L/L/R/L/R/R/L/L/R/R/L/L/R/R/L/L/R/R/LL/R/R/LL/R/R/L
    R. L/RR/LL/RR/LL/R/L/R/L/RR/L/L/RR/L/L/RR/L/L/RR/LL/R/L/RR/LL/RR/LL/R

Home
Links
Guestbook


Puck

Picture kindly supplied by Hendrik Haak

The puck is a puzzle in the shape of a hockey puck, i.e. a thick disk. In the centre are two semicircular parts, and around these are 12 segment pieces. The center can rotate with respect to the segments, and one of its halves can be given a 180 degree turn to change the order of the segments.

There are several puck designs, ranging from a Canadian flag to simply the numbers 1 to 12.

The number of positions:
There are 12 segments giving a maximum of 12! positions relative to the centre. The orientation of the pieces is not important since it depends totally on their position. Assuming the centre has distinguishing marks then it has 2·2 possible orientations, giving a total of 4·12! positions. Given an edge position not all of the centre orientations are possible because each half twist is an odd permutation. This leaves 12!·2 = 958,003,200 positions. If rotations of the centre are not considered different, then there are only 11!·2 = 79,833,600 positions.

Links to other useful pages:
David Joyner's page Has a short description of a cumbersome solution.
Hockeypuck homepage Shows some of the different styles available.

Notation:
Consider the 12 segments numbered like a clock face, 12 at the top. We will leave piece 12 fixed, and solve the remaining segments anti- clockwise, from 11 to 1. Therefore hold the puzzle so that the piece at the top is correct. If your puzzle has four blank pieces (e.g. Canadian Puck) then it is best to choose piece 12 so that the blank pieces will end up at positions 1-4.
Piece 12 will never move, so are only 6 possible moves:

  1. Turn over segments 1-6.
  2. Turn over segments 2-7.
  3. Turn over segments 3-8.
  4. Turn over segments 4-9.
  5. Turn over segments 5-10.
  6. Turn over segments 6-11.
You will have to rotate the centre of the puck first to accomplish a move.

I have used a computer to calculate God's algorithm for the puzzle, ignoring the centre pieces completely, and with either all 6 possible moves or restricted to fewer moves. The relevant numbers where the centre orientation is not ignored can easily be deduced from this.
Distance | Moves a-c | Moves a-d | Moves a-e | Moves a-f
0 | 1 | 1 | 1 | 1
1 | 3 | 4 | 5 | 6
2 | 6 | 12 | 20 | 30
3 | 12 | 35 | 78 | 147
4 | 23 | 100 | 297 | 708
5 | 44 | 286 | 1,130 | 3,408
6 | 80 | 792 | 4,225 | 16,177
7 | 142 | 2,135 | 15,472 | 75,384
8 | 247 | 5,557 | 54,143 | 334,836
9 | 411 | 13,783 | 178,274 | 1,400,827
10 | 662 | 31,202 | 508,805 | 5,019,071
11 | 1,019 | 61,125 | 1,062,164 | 12,427,541
12 | 1,481 | 93,383 | 1,195,536 | 14,323,585
13 | 2,059 | 93,939 | 557,174 | 6,051,014
14 | 2,745 | 49,867 | 51,373 | 263,992
15 | 3,465 | 10,108 | 103 | 73
16 | 4,126 | 526
17 | 4,633 | 25
18 | 4,913
19 | 4,777
20 | 4,163
21 | 3,079
22 | 1,612
23 | 488
24 | 94
25 | 25
26 | 6
27 | 3
28 | 1
Total | 8! = 40,320 | 9! = 362,880 | 10! = 3,628,800 | 11! = 39,916,800

Solution:

Segment 12: This is already correct.

Segment 11:

    Find the piece that belongs in position 11.
    If it is at 11, go to the next step obviously.
    Otherwise do any move(s) to bring the piece to position 6, and then do move f to put it at 11.

Segments 10-7:

    These can be solved in a similar way to piece 11, with the proviso that you must not do any move that destroys any part of what you have done already. Just see what the last move is that you would need to use to put the piece in position, and then do any moves you need to bring the piece to the correct spot for that move to work. I will not explain further as it is easy.

Segment 6:

    Find the piece that belongs in position 6. Then do the relevant sequence below:
    6. Do nothing since it is already correct.
    5. ceacae
    4. dbcdcd
    3. adbcdcd
    2. dcdcbd
    1. a

Parity step:

    If half the centre is reversed then do 'ceacaea' and repeat step 6. If the two sides of the centre pieces have no distinguishing marks, then you must do this step if the position of the remaining pieces is an odd permutation. If you do not know what this is, you can just try to solve it and go back to this step if the final two pieces need to be swapped around.

Segment 5:

    Find the piece that belongs in position 5. Then do the relevant sequence below.
    5. Do nothing since it is already correct.
    4. eadcdeae
    3. cabcbc
    2. cebcdcec
    1. cbcbac

The Canadian puck is now done, except possibly for the centre. Go to the final step below.

Segment 4:

    Find the piece that belongs in position 4. Then do the relevant sequence below.
    4. Do nothing since it is already correct.
    3. dfcbabfd
    2. bdbcbadb
    1. bdabcbdb

Segment 3:

    Find the piece that belongs in position 3. Then do the relevant sequence below.
    3. Do nothing since it is already correct.
    2. dbdab dbdab
    1. badbd badbd

Segments 1,2:

    The last two pieces should automatically be correct. If not, then you have done the parity step wrong. Go back and do the sequence given there, then try again.

Centre:

    If all the pieces 1 to 12 are correct, it is impossible at this point for only one half of the centre to be reversed. On the Canadian puck it is possible however, since some pieces are indistinguishable. To twist half the centre in that case you will have to go back to the parity step above, do the sequence and continue from there.
    Having both halves of the centre reversed is always possible, and this can be avoided by making sure the correct half is turned on your final move in the steps above. If you have to correct it anyway, twist one half, rotate the centre 180 degrees and twist one half again.
    Finally rotate the centre to its correct position if necessary.

Home
Links
Guestbook


Jaap's Links to other puzzle pages

There are many puzzle pages about. Many of my pages have links to sites relevant to that particular puzzle. On this page I have drawn together the most important of them, together with some more general links, in no particular order. Some links belong in several sections and so are included more than once.

Pages which are in BOLD, have a link back to these pages.

Official Puzzle Homepages
Other places to buy puzzles
Solution pages
Speed cubing
Cube Theory
Cube Art
Pages with programs to download
Pages with scripts or Java programs
Message boards
Musea, galleries and collections
Other neat puzzle pages not listed above
Pages that are not mainly about mechanical puzzles

Home
Links
Guestbook

Official Puzzle Homepages:
Meffert's puzzles Uwe Meffert's homepage. He produces and sells many puzzles, including Pyraminx, Megaminx, Pyramorphix, Skewb, Orbix and others. This site also has solutions for some.
Rubik's homepage. The official homepage sells Rubik's puzzles and has links to several cube solutions on the web.
Masterball homepage. You can buy a masterball here. It also has a solution for the rainbow masterball.
Hockeypuck homepage. This only shows the different styles available.
Tantrix homepage is very nice as it has Java puzzles, and allows you to play in the online Tantrix game tournaments.
Tricky Disky homepage has a rather silly intro sequence.
Binary Arts are the makers of such puzzles as Topspin, Turnstile, Spinout, Nineball, Port to Port and others.
Mozaika homepage. A nice puzzle that is a cross between Equator and a cube can be ordered from here.
Tiger Toys, the manufacturers of many electronic games including Lights Out.
Mag-Nif, the manufacturer of The Brain, Saturn and other puzzles.
The Brainball homepage is in German, but has move sequences and puzzles.

Other places to buy puzzles:
Hendrik Haak's Shop. Excellent range of puzzles, and a really nice page too. Based in Germany.
Spieletobs also sells a few puzzles (like Brainball), but is in German.
Arabesk sell many puzzles and interesting or amusing playthings.
Bits and Pieces sell many puzzles. No Rubik-type puzzles though, but lots of others such as puzzle rings and disassembly puzzles.
Kadon Enterprises Inc. sells Instant Insanity, make and sell polyominoes and many other neat puzzles.
PuzzleMan (Viktor Genel) has lots of beautifully well-made wooden assembly/disassembly puzzles for sale, as well as a shareware puzzle game to download.

Solution pages:
Twisty Megasite. This is a nice page dealing with building puzzles from plastic resin, and also has a 3x3x3 cube solution which explains a method to solve middle layer edges together with the top layer corners in pairs. This page also has a highly recommended message forum.
Courtney McFarren's Site has solutions to the cube, skewb, square 1, Rubik's Magic (both sizes) amongst others, and lots of other interesting and funny stuff.
Cubic Puzzles - The SIMPLEST Solutions. A text based page with solutions for the Skewb, Pyraminx, NxNxN Cubes, Megaminx, Octahedron and Rubik's Clock.
Josef Jelinek and Hana Bizek's Page. Contains examples of various types of cube solving algorithms. Also pictures of cube art, interesting patterned objects built from many cubes.
Denny's Puzzle Pages. Solutions for Pyraminx and various cube sizes, and has a link to his Virtual Puzzle Museum which shows many versions of the cube and other puzzles.
Philip Marshall's Cube Page has a solutions for size 2, 3, 4 and 5 cubes, as well as the megaminx. His cube solution solves edges first, and then the corners and is relatively simple.
Matthew Monroe's page. Nice illustrated solutions for cube, professor's cube, square-one and Pyraminx.
PuzzleSolver by Jake Olefsky has nice solutions for the cube, minicube, the pyraminx, and the Brain. Also has neat impossible objects, and a message board
Anzu's Puzzle Solution Page has solutions to the pyraminx and all cube sizes.
Jacob Davenport's page. He has a text based 5x5x5 cube solution here.
Chris Eggermont's Twisted Mind Games. The highlights of this page are the solution to Rubik's Magic Master Edition, and the pages on how to get the Square-1 Puzzle into cube shape.
Chris Hardwick's Page. This page has solutions for the cube and the Rubik's Revenge. There is also The Unofficial World Records Page here where you can log your best times.
Luciani's Page is a nice looking French site with a solution.
World of Rubik's by Bruno Jarno. A French page, which has a bit of just about everything about the Rubik's cube.
Christophe Goudey's Cube Page has lots of fascinating stuff about the cube, and an excellent links page.
Dennis Palaganas' page has solutions for Alexander's Star, Turnstile, Rubik's Revenge, 5x5x5 Cube, and Skewb.
Juergen Koeller's page. A solution to the cube and rubik's magic amongst many other things, also available in German.
Steve Martin's page has a solution to Nintendo's Ten Billion Barrel puzzle.
A Nerd Paradise by Blake has solutions for the various cubes, Pyraminx, Skewb and Square-1.
Ryan Kagin's "How to solve the cube" has a layer solution.
R. Hoffman's site has a one-page solution.
Ronald Bieber's page is in German, and has a cube solution of the layer type, and also a Rubik's Magic page.
Elías Hernández Capdevila's page is in Spanish, and has solutions to Square 1 and the 5x5x5 cube.
Cubo Magico, a Spanish page with a corners first solution of the cube.
Another Spanish cube solution.
Yet another Spanish cube site.

Speed cubing:
Lars Petrus' page. A great set of pages that show you how to solve the cube fast without having to memorise 100 sequences. Also available in Italian.
Jessica 'Jiri' Fridrich's page. A very fast layer algorithm for the cube.
Dan Knights' page. Speed cubing, lubrication, avoiding injury, blindfold cubing, amusing quotes.
Chris Hardwick's page has his speedsolving methods here.
Stiff_hands' website is all about speedcubing, blindfold cubing, and lots more.
SpeedCubing.com has good lists of sequences for speedsolving the cube, similar to Jiri's, and a Java program that can searches for useful sequences.
Speedsolving Rubik's Cube Club. A message board, part of Yahoo's Clubs.
Jess Bonde's page has videos of various people speedsolving the cube as well as videos of good move sequences.
Chris Brown's page has a Speedcubing Glossary, and a cube timer.
Peter Jansen's page has conatins all the excellent sequences he uses (including rotations of the whole cube, or turns of two layers simultaneously), some with video.

Cube Theory:
Prof. David Joyner's Homepage. His section on permutation puzzles has a lot of interesting maths, but much of it is too complicated for the non-mathematician.
Cube-Lovers Archive. Contains all posts on the Cube-Lovers mailing list. The list seems to have died, and I hope that one day it will start up again.
Martin Schoenert's page has the cube-lovers archive in html form, though only 1980-1996.
Mark Longridge's Domain of the Cube has a few good text pages with cube theory, a large list of patterns, and a neat selection of links.
How to Solve Almost Any Rubik-like Puzzle. A short explanation of the concepts of conjugation and commutation.
Glenn Rhoads' Fun Page. Has lots of fun stuff, including a few for the cube including Solve ANY Rubik's type puzzle, a very short text explaining a general algorithm to solve many puzzles.
Introduction to Group Theory ends with a section on the Rubik's cube.

Cube Art:
Kristin Wunderlich and Jacob Davenport's page has some wonderful cube art here. It has a few patterns on a single 5x5x5 cube, and many mosaic patterns using a large array of cubes. Kristin also makes cubes with other designs here.
Josef Jelinek and Hana Bizek's Page. Hana has pictures of cube art on her page. These are mainly large cubes made from many smaller ones.
Zarf's Page also has cubes with different designs here.
Philip K's Puzzle Page has cubes with Escher designs.

Pages with programs to download:
Cube Explorer Page. This program by Herbert Kociemba produces move sequences for any cube pattern. It finds a reasonably short sequence in about two seconds, and given a few more minutes will nearly always produce a sequence of less than 20 moves.
Mike Reid's optimal solver can do a very fast and deep search for solutions (uncompiled C source only).
Jozef Jelinek's page has a (C source only) program that searches for optimal solutions, with the possibility of ignoring parts of the cube.
Puzzler by Noel Dillabough is a great Windows program that simulates many puzzles.
Superliminal has an excellent simulation of a 4-d rubik's cube, i.e. a 3x3x3x3 cube.
Rubik's Hypercube is another 4-d Rubik's Cube.
Larry's Cube Corner gives us the excellent Hungarian HexaHedron simulator.
Rubik's Kube, a Linux program based on Karl Hornell's Rubik Unbound Java Cube.
Cellosoft have a Rubik's Rings game for Windows. Looks nice, but it requires a Pentium and 2Mb disk space which is a bit much for such a simple game.
Japanese page, with a megaminx program amongst others.
Ishihama Yoshiaki's page, has lots of puzzles and simulations.
PuzzleMan (Viktor Genel) has a fascinating shareware puzzle game to download, like a cross between a sliding puzzle and Rubik's Magic.

Pages with scripts or Java programs:
Karl Hornell's Rubik Unbound. The most used Java cube on the net, and it has become the standard on which others are judged. With source.
Jozef Jelinek's page has a gorgeous Java Cube. Excellent program, with source.
Dan Knights' Java cube is now on the official Rubik's homepage. It is a beautiful 3x3x3 cube with edit and playback facility. Unfortunately the built-in solver is disabled - you are expected to pay for it!
Ron's Cube Solver from SpeedCubing.com can search for useful sequences, using only some moves or ignoring some pieces.
Rubik's Cuboid. Any size cuboid (including unequal sides), with undo facility. With source.
Rubik's Cube Disassembled is a Java cube which can not only turn, but also 'explode' to show the inside. This page also has pretty patterns.
Raymond Penner's Page. There are neat Java programs here for Rubik's Fifteen and Rubik's Clock amongst others.
Wedran's cube solver. It allows you to edit a cube and then it shows you the moves to solve it, using a corners first method of about 120 moves on average.
David Byrden's Twisty puzzles. A page with Java versions of many puzzles, including all platonic solids.
Rob's Rubix Repair. An interesting page which solves the cube for you. It works on all browsers that support tables with coloured cells, there is no need for Java. Unfortunately it uses a lot of moves to solve it. With source.
Michael Schubart's cube. 3x3x3 cube with views of other faces. With source.
David Barr's cube. Any cube size. Cube shown in a way that might be confusing to some.
Yuh-Jye (Michael) Chang's cube. Any cube size. Built-in solver just undoes previous moves.
Song Li's cube. 3x3x3 cube only. With source. Built-in solver just undoes previous moves.
Gid's cube. Simple graphical 3x3x3 cube. It is a script so will work on all graphical browsers even without Java.
Bob Breid's page has a Javascript Rubik's Cube.
Ishihama Yoshiaki's page, has lots of Java puzzles and simulations here, amongst which a 4d rubik's cube, and several very original 3d puzzles.
Crépeau-Nguyen's ultimate solver. Java programs that look up God's algorithm for the pocket cube, domino, pyraminx and all skewb puzzles.

Message boards:
Speedsolving Rubik's Cube Club. Highly active speedcubing club founded by Chris Hardwick. Part of Yahoo's Clubs.
RubiKlub is a French message board founded by Bruno Jarno. Part of Yahoo France Clubs.
Twisty Megasite forum. Excellent forum, with a good community.
Rubik's Online Forum from Rubik's own official site.
Meffert's Puzzle Board changed board provider a while ago and has become a little quiet.
PuzzleSolver's message board.

Musea, galleries and collections:
Hendrik Haak's Puzzle Museum. Large number of fascinating puzzles. Many of the pictures on this site are from here.
Virtual Puzzle Museum shows a huge number of different versions of the cube and other puzzles.
Cubeworld. A page with nice pictures of many Rubik puzzles, but little else.
Kevin Moore's page, has a nice page with pictures and descriptions of various puzzles.
Maarten Vermaak's page has descriptions and pictures of all Rubik's puzzles, even the rare ones, as well as many others.
Japanese site with pictures of various puzzles, but actually most notable for the neat hit counter.
Another Japanese site with a picture gallery.
Japanese page with many sub pages with pictures of puzzles, some quite rare. Most relevant are page 1 and page 2.
Japanese site with many pictures of puzzles and their packaging.
Peter Knoppers' Puzzle Collection consists mostly of assembly puzzles.
John Finch's page has a his Rubik's collection here.
Chosi's homepage has huge collection here but few pictures of them unfortunately.
Thomas' site has pictures of a good variety of puzzles. In German.

Other neat puzzle pages not listed above:
Joshua Bell's page has a very interesting info on the patents of puzzles like the Rubik's Cube.
Mike Reid's page has a lot of rubik's cube information and links.
Matthew Baker's Lights Out page has lots of good info about the Lights Out game and its variants, including the cube version.
Cubism For Fun is the newsletter of the Dutch Cube Club, which is still going strong after more than 20 years.
Directory of Mechanical Puzzle Collectors. A page with links to other collectors.
Tim and Shelley Rueger's page is about the Rubik's Cube Perpetual Calendar.
The Lego MindStorms Page has a Lego robot that can solve the cube here.
Rubik's Cube World Records lists some amazing world records.
Gaétan Guimond's page is in French (and some English), and shows his TV exploits as well as his corners first solving method.
Jin "Time Traveller" Kim's page has the Puzzle FAQ.
Chris and Kori's page. A nice page with descriptions of several kinds of puzzles.
Georges Helm's Page. Has a list of cube resources.
Hong Chen's Page has pictures and video of the cube and of a puzzleball.
Javier Santos' page. A Spanish page with some interesting puzzles, including a solution to Rubik's Magic.
J. Brown's Page describes a Lego Robot to solve the cube.

Pages that are not mainly about sequential movement puzzles:
Puzzle World, by John Rausch, is the portal site for assembly/disassembly puzzles as well as sliding piece puzzles. Also has Stewart Coffin's books available to download.
PuzzleMan has lots of wooden assembly/disassembly puzzles for sale.
The Mind Sports Organisation Worldwide. Board games, card games, puzzles, Computer Programming contest, and much more.
Creative Puzzles a neat page that hosts the Alt.Brain.Teasers Archive and has Java games too.
Arlet Otten's page containing the rec.puzzles archive.
Ed Pegg's Mathpuzzle page has lots of difficult but often fascinating mathematical puzzles.

I found many of these links by using Google:

Google

When you're finished with these, you can take a look at a page about my other hobby:
Organiser II Homepage Link Image.
or visit my father's page: Jan Scherphuis which includes my family tree and pictures of my parents house.

Home
Links
Guestbook


Pyraminx / Tetraminx

Pictures kindly supplied by Hendrik Haak

The standard Pyraminx is a regular tetrahedron, of which each triangular face is divided into 9 identical smaller triangles, three to a side. A move consist of rotating a sub-tetrahedron around a vertex; either just a tip or a larger tetrahedron (two triangles to a side). Each face has one colour, so the edge pieces have two colours, while the tips and the adjacent vertex pieces have three colours each.

The Pyraminx was invented by Uwe Mèffert in about 1971, but he only started producing it when the Cube Craze hit, and after he had carefully secured patents in most relevant countries, in particular Taiwan and Korea which haven't signed international patent treaties.

There several similar puzzles. The Tetraminx is a snub tetrahedron, which is the same as a Pyraminx but without the tips, also produced by Mèffert (though the first ones were crude versions made by Rubin's Toy Co. from Canada). A similar puzzle not pictured here was produced in Taiwan, and has a more rounded shape, with circular faces (like a sphere with 4 caps cut off). The most interesting variation was invented independently, and is nowadays called the Halpern-Meier Pyramid. It is cut differently than the pyraminx; the sub-pyramids are larger so that each face has a centre piece. Mechanically, it is those faces which are fixed to the centre, whereas in the pyraminx it is the corners which are on axes.

The number of positions:
There are 4 vertex pieces with 3 orientations, 6 edge pieces with 2 orientations giving a maximum of 6!·26·34 positions. This limit is not reached because:

  • only and even number of flipped pieces are possible (2)
  • only and even permutations of edges are possible (2)
This leaves 6!·24·34 = 933,120 positions.

If you include the trivial vertex tips then this has to be multiplied by a further 34=81. The Halpern-Meier pyramid instead has only 4 times as many positions.

This puzzle is closely related to the Skewb which also has four axes of rotation. The vertices and the face centres (if present) of the pyramid correspond to the corners of the Skewb, and the edges to the square faces of the Skewb.

A computer search gives the following result (ignoring the tips):
Depth | Pyraminx | H-M Pyramid
0 | 1 | 1
1 | 8 | 8
2 | 48 | 48
3 | 288 | 288
4 | 1,728 | 1,728
5 | 9,896 | 10,128
6 | 51,808 | 57,780
7 | 220,111 | 305,483
8 | 480,467 | 1,239,266
9 | 166,276 | 1,879,631
10 | 2,457 | 237,320
11 | 32 | 778
12 |  | 21
Total | 933,120 | 3,732,480
This shows that any pyraminx position can be solved in at most 11 moves, or 12 for the Halpern-Meier Pyramid. See the Ultimate Skewb page for tables of all the skewb-related puzzles.

Links to other useful pages:
Meffert's puzzles Uwe Mèffert's pages. He invented and now produces and sells the Pyraminx amongst others.
Meffert's page. Contains the solution provided in the pyraminx booklet.
Meffert's page. Contains the solution provided in the tetraminx booklet.
'Simplest Solutions' page. A text based solution.
Cyril Castella's page. A French solution.
Matthew Monroe's page. A nice illustrated solution.
Oxford Computing lab. A short text based solution.
Chris Eggermont's page. A few useful move sequences which are enough to solve it.
A Nerd Paradise by Blake has solutions for the various cubes, Pyraminx, Skewb and Square-1.

Notation:
Hold the tetrahedron so that the vertices point left, right, down and back. Denote these by L, R, D and B. Anti-clockwise turns are denoted L', R', D' and B'. The faces are denoted F, U, L and R (front, up, left, right) so that edge pieces can be easily described by a combination of two of those letters.

Solution:
Phase 1: Solve the tips

  1. Simply rotate each tip to match its adjacent vertex piece.
Phase 2: Solve the U vertices.
  1. Look at vertex D and find out which colour is not present.
  2. Rotate the three other vertices so that the colour is on the top face. Now the whole top layer is correct apart from the edge pieces.
Phase 3: Solve the U edges.
  1. Find an edge at the D vertex which belongs in the U face.
  2. Hold the puzzle so that the edge belongs at the FU position.
  3. Rotate D to bring the piece to the front so that the side which has the same colour as the U face is not in the front face.
  4. Use one of the following sequences to place the piece correctly:
    1. To move FR->FU, do LD'L'.
    2. To move FL->FU, do R'DR.
  5. Repeat the above until the top face is correct. If necessary, you can use one of the above sequences to displace any incorrectly placed pieces.
Phase 4: Solve the D vertex piece.
  1. Simply rotate D to make its corner match the others.
Phase 5: Solve the D edges.
  1. There are now only a few possibilities left. Hold the puzzle so that one of the following sequences will solve the puzzle completely:
    1. To move FR->LF->RL->FR, do R'DRDR'DR.
    2. To move FR->RL->LF->FR, do R'D'RD'R'D'R.
    3. To move FR->RF, FL->LF, do DRD'LD'L'DR'.
    4. To move FR->FL->LR->FR, do RLDL'D'R'.
    5. To move FR->LR->FL->FR, do RDLD'L'R'.
Phase 6: Solve face centres, for the Halpern-Meier pyramid only.
  1. To swap the F-U and L-R centres do R'D'RD R'D'RD R'D'RD.

Home
Links
Guestbook


Pyramorphix

Picture kindly supplied by Hendrik Haak

This puzzle is a small regular tetrahedron where each face is divided into 4 smaller triangles. This puzzle is related to the 2x2x2 Rubik's Cube; it is like a cube where the pieces forming one tetrad are flat and have one colour, the other tetrad forms the vertices of the tetrahedron and have 3 colours each. This puzzle does not maintain the same shape, making it somewhat confusing to solve.

Another way to see this puzzle is as a small octahedron, on which the four faces meeting at a vertex can rotate about that vertex. Four of the faces of the octahedron have tips stuck on them, the other faces are just flat.

According to Issue 7/8 of Cubic Circular (David Singmaster, Summer 1985) this puzzle was invented by several people, including Rubik and Barry Lockwood of Rochdale (UK).

The number of positions:
There are 8 pieces, 3 orientations each, giving a maximum of 8!·38 positions. This limit is not reached because:

  • The orientations of the flat pieces are not visible (34)
  • the orientation of the puzzle does not matter (24)
This leaves 7!·33 = 136,080 positions.

Every position can be solved in at most 9 moves (if a half turn is also considered a single move). Recently I used a computer search to find God's Algorithm, i.e. the shortest solution for each position, and the result is shown in the following table:
Moves | Positions | Local Maxima
0 | 1 | 0
1 | 9 | 0
2 | 54 | 0
3 | 321 | 2
4 | 1,835 | 25
5 | 9,716 | 224
6 | 39,536 | 11,383
7 | 68,424 | 56,944
8 | 16,120 | 16,056
9 | 64 | 64
Total | 136,080 |

Although any solution for the 2x2x2 cube will work here, I will give a better solution that uses the peculiarities of this puzzle.

Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He produces and sells the Pyramorphix amongst many other puzzles.
Meffert's page Contains the solution provided in its booklet.

Notation:
The same notation as the cube will used. The octahedral centre of the puzzle is considered fixed in space, and its vertices are denoted by the letters L, R, F, B, U and D (Left, Right Front, Back, Up and Down). Clockwise quarter turns of a face are denoted by the appropriate letter, anti-clockwise quarter turns by the letter with an apostrophe (i.e. L', R', F', B', U' or D'). Half turns are denoted by the letter followed by a 2 (i.e. L2, R2, F2, B2, U2 or D2).

Note like the 2x2x2 cube, the moves LR' perform a rotation of the whole puzzle. Similarly FB' or UD'. Therefore moving only three adjacent faces is enough to solve it. If we only use the F, R and U faces to solve it, then the DBL corner is never moved from its place, and the other pieces are simply placed so they line up with it. The solution below will mostly use this method.

Solution:
Phase 1: Get it in shape.
There are only 6 possible wrong shapes that can occur, and the pyramid shape can always be reached in at most 3 moves. This is quite easy to do, so there is no need to give details.

Phase 2: Get the tips correctly positioned.

  1. Hold the puzzle so that one tip is at the DBL position. This piece is from now on considered to be correctly positioned and oriented.
  2. Examine the other tips to see if they are in position relative to it.
  3. If only two tips need to be swapped, a single half turn move will do this.
  4. If all three tips are wrong, then swap any two of them first with a half turn and then one further swap will position them all correctly.
Phase 3: Get the tips correctly oriented
  1. From the previous phase the tip at DBL is correctly oriented. Examine the other three tips to see if they need a clockwise twist (+) or an anti-clockwise one (-).
  2. Look the combination up in the following table and do the appropriate move sequence. Note that you will probably have to hold the puzzle in a different orientation so make sure you still have a correctly oriented piece at the DBL corner.
    1. To twist DFR+ do R'UR2FU'
    2. To twist DFR- do UF'R2U'R
    3. To twist DFR-, UBR+ do R'F'UR'UF
    4. To twist DFR-, UBR- do U2FR2F2R'
    5. To twist DFR+, UBR+ do RF2R2F'U2
    6. To twist DFR-, UBR-, UFL- do FUF2RF'R2
    7. To twist DFR+, UBR+, UFL+ do R2FR'F2U'F'
    8. To twist DFR+, UBR-, UFL- do UF'UF'UF'
    9. To twist DFR-, UBR+, UFL+ do FU'FU'FU'
Phase 4: Put the other pieces in position
  1. Only the face centres have to be positioned now. This can be done in one step by using one of the following sequences:
    1. To swap DFL-UFR, do R2F2U2FR2U'R2F.
    2. To swap DFL-UFR and UBL-DBR, do F2R2U2R2.
    3. To cycle the three faces DFL->DBR->UBL->DFL, do RU'FRFR2FU2.
    4. To cycle the three faces DFL->UBL->DBR->DFL, do U2F'R2F'R'F'UR'.
    5. To cycle all four faces DFL->UFR->DBR->UBL->DFL, do UR2F'R2U'.
This solution takes at most 3+2+6+8=19 moves, or even 18 because of a possible cancellation between phases 1 and 2. This is quite low for such a puzzle. It could be extended to a solution for the 2x2x2 cube, by using a phase 5 which orients the 4 remaining pieces (which takes at most 8 moves).

If you have two spare pocket pyramorphix puzzles, you might want to take them apart and reassemble them with all the corner pieces on one puzzle and all the face pieces on the other. You now have two new puzzles, an octahedron and a stella octangula. It is a good idea to give them a different colour scheme.

Octahedron:
If you have four colours, two faces of each colour, then this is a really easy puzzle. There are only 8!/2^4/24 = 105 essentially different positions.

Stella Octangula:
This puzzle would be most interesting with 8 colours. It is then possible to end in a seemingly impossible position where one tip is twisted. In fact, it is the other three pieces of that tetrad which need to be swapped around. This puzzle has as many positions as the 2x2x2 cube, but there are four positions which can be considered solved. Uwe Mèffert might produce this puzzle in the future under the name Star of David, but if that is so, I do not know what colour scheme it will have.

Home
Links
Guestbook


Rubik's Rings / Hungarian Rings

This puzzle consists of two intersecting rings made up of a number of coloured balls. The rings of balls intersect at two places, so they share two of the balls. Each ring of balls can be turned, so the balls can be mixed.

The Rubik's Rings version has 34 balls of three colours. The intersections divide each ring into sections; there are 5 balls on the inner sections between the two intersection points, and an outer section with 11 balls. In its solved state the 11 blue, 11 red, 12 yellow balls are arranged so that the outer sections are red or blue, and the inner sections and intersections are yellow.

The Hungarian rings puzzle has 38 balls of four colours, intersections which lie 5 apart (i.e. 4 balls in between them). Two colours have 9 balls (yellow and blue) and two colours have 10 balls (black, red). When solved, the balls of each colour must form a continuous row.

Rubik's Rings has the two rings intersecting at an angle, making a 3-dimensional shape. This allows for a neat ratchet system to stop the balls from moving unintentionally.

It might be interesting to quote from the afterword of the Rubik's Cubic Compendium [p212] here. It has a picture of the hungarian rings and the following text by David Singmaster:

Closer to Rubik's Magic Cube are 'interlocking cycle' puzzles where several rings of pieces cross eachother. Endre Pap, a Hungarian engineer, invented a flat version with two rings which was marketed as the Hungarian Rings. The idea was not entirely new, as there is an 1893 patent for it.

The number of positions of Rubik's Rings:
There are 34 balls, which can be arranged in at most 34! ways. This limit is not reached because:

  • The yellow balls are indistinguishable (12!)
  • The red balls are indistinguishable (11!)
  • The blue balls are indistinguishable (11!)
  • The red and blue balls are equivalent (2)
The last point is because the puzzle can be solved both with red or with blue on the left hand side. The total number of positions is therefore 34!/(2·11!·11!·12!) = 193,413,243,572,640.

The number of positions of Hungarian Rings:
There are 38 balls, which can be arranged in at most 38! ways. This limit is not reached because:

  • The yellow balls are indistinguishable (9!)
  • The blue balls are indistinguishable (9!)
  • The red balls are indistinguishable (10!)
  • The black balls are indistinguishable (10!)
  • The yellow and blue balls are equivalent (2)
  • The red and black balls are equivalent (2)
The total number of positions is therefore 38!/(2·9!·10!)2 = 75,406,424,215,922,599,800. Note however that (even when taking into account the colour equivalences) there are still 8 possible solutions.

If your browser supports it, you can click on the links below to see a Javascript version of either of these puzzles.

Javascript Rubik's Rings Puzzle

Javascript Hungarian Rings Puzzle

Solution to Rubik's Rings:
This solution is different to the one in the booklet supplied with the puzzle. I think this solution is quicker. It is also more intuitive and therefore easier to remember.

Phase 1: Solve the yellow balls (the inner area)
In this phase all the yellow balls will be placed in position, in the inner sections of the rings including the intersection points.

  1. First construct a row of 5 yellow balls in the left ring. This is quite easy to do as follows:
    1. Find a yellow ball in the ring on the right that does not lie at an intersection.
    2. Rotate the left ring to bring whatever row of yellow balls you already have into the outer section of the ring, but adjacent to the intersection point nearest your chosen yellow ball.
    3. Turn the right ring to bring the yellow ball to the intersection, joining it up with the row of balls in the left ring.
    Repeat this process until you have a row of 5.
  2. Turn the puzzle upside down so that the row of 5 balls is in the right ring.
  3. Now we will put the 7 remaining yellow balls in a row in the left ring. Nearly the same method can be used as in step a, as long as we make sure that the row of 5 remains in the outer section if the right ring and so takes no part in the action. It is however possible that while building your row of 7, all the remaining loose yellow balls also lie in the left ring so that you get stuck at step a1 above. In this case move the left ring so that the yellow row is still in the outer section, but one of the loose yellow balls lies at an intersection point. You can now move the right ring a little and continue with step a2.
  4. You now have a row of 5 and a row of 7 yellow balls. First make sure both rows are away from the intersection points, next turn the right ring to put the row of 5 in place between the intersection points, and finally turn the left ring to put the row of 7 in place.
Phase 2: Separate the red/blue balls.
In this phase the red and blue colours are separated, thus solving the puzzle. Before you start this phase however, you have to decide which colours the outer sections should be. It is usually best simply to find out which colour dominates a section, red or blue, and then consider that to be the colour it is to be when solved. Balls of the wrong colour in each ring will be called simply 'wrong balls', and balls of the correct colour in each ring 'correct balls'. This phase will attempt to swap a wrong ball on the left with a wrong ball on the right, and thus make them correct.
Instead of clockwise or counter-clockwise turns, I will use the terms 'inwards' and 'outwards' turns. An inwards turn of a ring brings some balls from the outer section of the ring inwards towards the top intersection point. In other words, an inwards turn of the left ring will be clockwise but an inwards turn of the right ring will be counter-clockwise. Outwards turns are the opposite of inwards turns.
  1. If there is a wrong ball in the top half of each ring, then the following sequence will correct them:
    1. Turn the right ring inwards to bring a correct ball to the top intersection.
    2. Turn the left ring inwards to bring the left wrong ball to the top intersection.
    3. Turn the right ring to bring the right wrong ball to the top intersection.
    4. Turn the left ring back (outwards) into position.
    5. Turn the right ring back (outwards) into position.
    Note how at the bottom intersection there will always be a yellow ball, so no changes occur there.
  2. Repeat step a as often as you can. Note that as it stands, the wrong ball in the right hand ring can even be in the exact middle of the outer section (6 balls away from the intersection) and the sequence will still work, but the left wrong ball must be above the middle. If the left ball is in the middle and the right hand one is not, then you can use the same sequence but with left and right interchanged in each of the steps a1 to a5.
  3. If there are wrong balls in the lower halves of both rings then turn the puzzle upside down and go back to step a to correct them.
  4. If there are wrong balls in the top half of one ring, and in the bottom half of another, then this can be solved by bringing one wrong ball to the middle, and going back to step a to correct it. To bring a wrong ball in the top half to the middle, do the following sequence:
    1. Turn the ring with the wrong ball 6 steps inwards, bringing the ball that was in the middle to the top intersection.
    2. Turn the other ring inwards till a correct ball lies at the top intersection.
    3. Turn the first ring outwards till the wrong ball lies at the top intersection.
    4. Turn the other ring back (outwards) into position.
    5. Turn the first ring back (outwards) into position.
  5. The only case that can not be handled by the previous steps is when there are only two wrong balls, both in the middle. This can be solved by the folowing sequence:
    1. Turn one ring inwards 6 steps.
    2. Turn the other ring inwards 6 steps.
    3. Turn the first ring outwards 6 steps.
    4. Turn the other ring outwards 6 steps.

Note: Very often you can run various instances of the sequence in phase 2 step a together. The first turn brings a correct ball to the top intersection, and from then on each turn brings a wrong ball to the intersection. You must take care not to turn too far outwards, as the bottom intersection must always have a yellow ball. When you have no wrong balls within reach, turn the rings back to their original positions. This will speed up the process considerably.

Solution to the Hungarian Rings:

Phase 1: Solve one outer colour
In this phase all ten balls of one colour, for example black, will be placed together in the outer sections of one of the rings.

  1. Find a black ball in the ring on the right that does not lie at an intersection. If there are none, then go to step e below.
  2. Rotate the left ring to bring whatever row of black balls you already have into the outer section of the ring, but adjacent to the intersection point nearest your chosen black ball.
  3. Turn the right ring to bring the black ball to the intersection, joining it up with the row of black balls in the left ring.
  4. Repeat steps a-c until you have a row with all 10 black balls.
  5. It sometimes happens in step a that all the remaining loose black balls also lie in the left ring so that you get stuck at step a above. In this case move the left ring that the black row is still in the outer section, but one of the loose black balls lies at an intersection point. You can now move the right ring a little and continue with step b.

Phase 2: Solve the other outer colour
In this phase all the balls of the second colour with ten balls, for example red, will be placed together in the outer section of the other ring.

  1. Turn over the puzzle so that the bblack balls you solved in phase 1 are now in the outer section of the right ring.
  2. Solve the red balls in the left outer section using the exact same method as phase 1.
Phase 3: Solve the remaining two colours.
In this phase the yellow and blue colours are separated, thus solving the puzzle.
  1. Turn the left ring so that its previously solved outer section (red or black) is adjacent to the top intersection. Also turn the right ring to bring its previously solved outer section down until it is next to the bottom intersection. Decide which ring should get which colour. I assume that the blue balls will all belong all be in the left ring, and the yellow balls in the right ring. Of course, you can solve them the other way around, but the description is easier if it is limited to one case.
  2. Below I will give a sequence of moves which swap two balls. Using this to solve all the yellow/blue balls can be a bit slow, so if you see any way to solve some of them with a few moves (moves which never bring a red or black ball into an intersection) then by all means do so.
  3. Find a yellow ball and a blue ball which you want to swap. The yellow ball will be on the left ring, and the blue one on the right ring.
  4. If the yellow ball in the left ring lies below the bottom intersection, then the two balls can be swapped using the following sequence:
    1. Turn the right ring until the ball you want to swap lies at the top right, with four balls between it and the top intersection.
    2. Turn the left ring until the ball you want to swap lies at the top left, again with four balls between it and the top intersection.
    Note that the two intersections should now be the same colour.
    3. Turn the left ring 5 steps clockwise (the left ball to swap is now at the top intersection).
    4. Turn the right ring 5 steps anti-clockwise (the two balls to swap are now at the intersections).
    5. Turn the left ring 5 steps anti-clockwise.
    6. Turn the right ring 5 steps clockwise.
    Note that steps 3-6 swapped the two balls, but also swapped the two balls at the intersections but since they had the same colour this is not noticable.
    7. Turn the left ring back to its original position, with its outer section next to the top intersection.
    8. Turn the right ring back to its original position, with its outer section next to the bottom intersection.
  5. The above worked only if the ball to be swapped from the left ring was below the bottom intersection. If the ball in the right ring lies between the intersections, we can use nearly the same method except that we bring the balls to the top in the opposite order:
    1. Turn the left ring until the ball you want to swap lies at the top left, with four balls between it and the top intersection.
    2. Turn the right ring until the ball you want to swap lies at the top right, again with four balls between it and the top intersection.
    Note that the two intersections should now be the same colour.
    3-6. Exactly the same as steps d3-6 above.
    7. Turn the right ring back to its original position, with its outer section next to the bottom intersection.
    8. Turn the left ring back to its original position, with its outer section next to the top intersection.
  6. If either the ball to swap on the left ring lies between the intersections, or the ball to swap on the right ball lies above the top intersection, then turn the puzzle around. You can then use one of the sequences above.
  7. The only case that is not covered by the above sequences is the case where you want to swap the two balls at the intersections. This case can usually be avoided by solving the intersections as soon as possible with swaps involving the other balls. If however these are the only two balls left to be swapped, then you will have to disturb a few solved balls first. For example, turn right ring anti-clockwise, left ring anti-clockwise, right ring clockwise to original position, left ring clockwise to original position. You now have 4 balls which are wrong, of which only one is at an intersection, and so it can be solved using two swaps.

Home
Links
Guestbook


Roundy

Picture kindly supplied by Hendrik Haak

This is a simple but odd little puzzle. It consists of three semicircles which are hinged together. Each pair of semicircles can be held flat forming a round face, so there are three such faces with a single colour each. Around the edge of each face is a ring four pieces which can rotate around the face. The pieces have two colours, because they have two sides which belong to different faces. There are 6 pieces altogether, in three pairs of identical pieces.

The number of positions:
There are 6 pieces, with 2 orientations each, giving a maximum of 6!·26 positions. This limit is not reached because:

  • only and even number of flipped pieces are possible (2)
  • there are 3 pairs of indistinguishable pieces (23)
This leaves 6!·22 = 2,880 positions.

This puzzle has the lowest number of positions of all the puzzles in my collection, and yet it is certainly not trivial. None of the positions need more than 7 moves to solve:
Moves | Position
0 | 1
1 | 9
2 | 54
3 | 261
4 | 919
5 | 1246
6 | 378
7 | 12
Total | 2880

Notation:
Denote the three faces by L, R, and F, meaning left, right and front. Moves are denoted by the letter of the face involved. Quarter turns clockwise just use the letter, half turns are denoted by a the letter followed by a 2 (e.g. L2, R2, F2) and anti-clockwise turns by the letter with an apostrophe (e.g. L', R', F').

Solution:
Phase 1: Solve one semi-circle.

  1. Place any two identical pieces adjacent to each other, matching their colours. In virtually all cases there is a single turn that accomplishes this.
  2. Move this pair onto the correct semi-circle.
Phase 2: Place two of the remaining pieces
  1. Turn the puzzle so that the remaining 4 pieces are on the front face.
  2. Turn F so that the bottom 2 pieces are in the correct position, except that they might need to be flipped.
Phase 3: Solve the final face
  1. If all four pieces are in the correct position, but they need to be flipped, then do one of the following:
    1. To flip the two right pieces, do FR2LR2F.
    2. To flip the two top pieces, do L'F'L'R'L.
    3. To flip the top right and bottom left pieces, do LRLFL'.
    4. To flip the top left and bottom right pieces, do L'R'L'F'L.
    5. To flip all four pieces, do L2R2L2F2.
  2. If the top two pieces need to be swapped, and some pieces need to be flipped, then note those pieces which are showing the wrong colour on the front face, and do one of the following:
    1. No wrong colours. Do LR'L'FL'R'.
    2. Top left and top right. Do L2RL2.
    3. Top right and bottom right. Do FR2LR2
    4. Bottom right and bottom right. Do L2R'L2F2.
    5. Top left and bottom left. Do F'R2LR2.
    6. Top right and bottom left. Do RLF'RF.
    7. Top left and bottom right. Do RL'RF'R.
    8. All four show wrong color. Do L2R'L'F'RL.

Home
Links
Guestbook


Rubik's Dice

Picture kindly supplied by Hendrik Haak

Rubik's Dice is consists of a hollow cube with holes where the pips of a die would be (plus a few smaller holes). Inside are 7 square white metal plates which have red dots painted on them. These plates can be manipulated so that they stick to the insides of the cube, which is helped by the magnets built into the sides. The aim is to do this in such a way that none of the holes show a red spot, just white ones.

The number of positions:
There are 7 plates of which 6 are used to cover the sides of the die. Each plate has two sides and can be placed in 4 orientations. This gives a total of 7!·86 = 1,321,205,760 positions with 6 filled sides of which only one shows no red dots.

Solution:
Below is a table showing the plates. Each plate has a small number printed in the corner which can be used to identify it. This is shown on the left of the table. The plates are shown in white (.) and red (X) and grey (O). The grey parts show which parts of the plates are visible in the solved position. This solution is unique. This is easy to see if the sides are solved in descending order, from 6 to 1, when there is only one remaining possibility for each side. Note how side 1 of each plate used shows the same pattern as side 2 of the plate used to solve the next lower number.
Number | Side 1 |  |  | Side 2 |  |  | Die number solved
78 | . | X | . | O | o | O | 6
 | X | . | X | O | . | O
 | . | . | . | O | X | O
65 | . | . | . | O | X | O | 5
 | X | X | X | X | O | X
 | . | X | . | O | o | O
34 | X | X | . | O | X | O | 4
 | X | . | . | o | X | X
 | . | . | . | O | X | O
58 | X | . | . | o | . | O | 3
 | . | X | . | . | O | X
 | . | . | . | O | X | X
12 | . | . | X | O | . | o | 2
 | . | . | . | . | X | .
 | X | . | X | X | . | O
14 | X | . | X | X | . | o | 1
 | . | X | . | . | O | .
 | . | . | . | X | . | X
47 | . | . | . | . | . | . | None
 | . | X | . | . | X | .
 | X | . | X | X | . | X

Home
Links
Guestbook


Rubik's Fifteen

Picture kindly supplied by Hendrik Haak

Rubik's Fifteen is a type of sliding piece puzzle. It consists of 17 tiles in a 5x5 square. On the middle three columns there are levers which can move the 4 tiles in a column up or down one square. On the middle three rows there is one large lever that moves the 3x4 tiles left or right. On the top and bottom row there are also levers, but these will only work if there are 4 tiles in the row, i.e. only if all the column levers are up does the top row lever work, only if they are all down does the bottom row lever work.

The 15 tiles are numbered 1-15 in Roman numerals, one has an asterisk, one is black. The aim is to build a 4x4 square of the numbers in order.

On the back of the puzzle is a window showing the middle 3x3 square of tiles. The back of the 15 numbered tiles have the same numbers as the front, the other two tiles have a zero on the back. As a separate puzzle you can make a magic square on the back. It is clearly impossible to this if the front is solved, but if you can solve the front the same method suffices to solve the back.

A related but much more difficult puzzle is 'It'. Rubik's Fifteen is easier, because it has more levers and therefore less restrictive movement of the tiles.

Links to other useful pages:
Raymond Penner's page A Java simulation of the puzzle.

Notation:
Let M mean the pushing right of the large main lever, and let m mean pushing it back to the left. Similarly, let A, B, C denote the column levers from left to right, with a capital letter meaning pushing it down and a small letter pushing it up. The top row lever is T and t for right and left, and the bottom row D and d.

Solution:
Phase 1: Solve the black tile.

    The solution given here will solve the 4x4 square on the top four rows. The black tile is therefore on the bottom row, at either the left or the right side. Unfortunately it is only possible to solve the puzzle in one of those cases; in the other you are left with two swapped tiles which is impossible to solve in any other way.

    When you bought the puzzle it was probably in a solved position with the black piece on the left hand side, so unless the puzzle has been opened and the tiles rearranged the black tile has to go on the left.

    It is also possible to solve the puzzle on the bottom 4 rows, and in that case the black piece has to go on the same side in the top row, the top left.

    To place the black piece on the left, follow this method:

  1. Push ABCD to get the bottom lever to the right.
  2. Push all the other levers to the right and up, i.e. abcMT.
  3. In the unlikely case that the black tile is in the bottom right, then do the sequence MABCdabc to bring it out, followed by mABCdabcM to get the bottom lever to the left again.
  4. If the black tile lies in the top row column 5, then do tCmcMt.
  5. If it lies in column 5 (under lever C) then do mCMc (or CmcM) until it lies in column 4.
  6. If it lies in column 4 (under lever B) then do mBMb (or BmbM) until it lies in column 3.
  7. If it lies in column 3 (under lever A) then do mAMa (or AmaM) until it lies in column 2.
  8. Remember the method used here to move a tile from column to column. It will be used often, and will not be explained again.
  9. Now the black piece is in column 2, use AmaM until it lies in row 4.
  10. Then do ABCmdabcM to place the black piece in position.
From this point on the D lever is never used, and the other levers will generally be kept pushed up and to the right.

Phase 2: Solve column A.
The first column is solved by slotting in the tiles I, V, IX and XIII one by one from the bottom until the column is correct.

  1. Find piece I.
  2. Bring it to column A, and if necessary do AmaM until it lies in row 4.
  3. Find piece V. If it already lies in column A then do mAMa till it is in column B, then do mBMb, and do AmaM until I is back in row 4.
  4. Bring V to column B, do BmbM till it is row 4, and do mAMa to slot it into column A.
  5. Find piece IX. If it already lies in column A then do mAMa till it is in column B, then do mBMb, and do AmaM until V is back in row 4.
  6. Bring IX to column B, do BmbM till it is row 4, and do mAMa to slot it into column A.
  7. Find piece XIII. If it already lies in column A then do mAMa till it is in column B, then do mBMb, and do AmaM until IX is back in row 4.
  8. Bring IX to column B, do BmbM till it is row 4, and do mAMa to slot it into column A.
The A column should now correctly read I, V, IX, XIII from top to bottom.

Phase 3: Solve column B.
This is done in exactly the same way as column A, by slotting the tiles II, VI, X, XIV into it from below.

Phase 4: Solve the final two columns.

    The sequence CmcM or its inverse mCMc rotate around in a loop all the tiles in the two columns except for the top right tile. To solve the two columns we will rotate the loop, and use T (and t) to swap one of the tiles in the loop with the other one. This is repeated, each time replacing one of the tiles in the loop with the spare one until the loop contains the pieces in the order III, VIII, XII, *, XV, XI, VII clockwise from the top. The column have then been solved. If in phase 1 the black tile was placed correctly this method will need an even number of swaps, so the top lever will automatically end up correct, with tile IV at the top right.

    Lets call the tile that is not part of the loop the spare tile. If the top lever has been pushed to the right then the spare tile is the one in the top right hand corner. If the top lever has been pushed to the left, then the spare tile is the tile at the top of column B.

    In more detail, the method is as follows:

  1. If the spare tile is III then move the top lever. Otherwise repeat CmcM until tile III is at the top of column C.
  2. If the spare tile is IV and the puzzle is not solved then find an incorrect tile, repeat CmcM until that tile is at the top of column C, move the top lever, and repeat CmcM to bring III to the top of column C.
  3. If the spare tile is not III or IV, then look it up in this list:
    VII, 6
    VIII, 1
    XI, 5
    XII, 2
    XV, 4
    *, 3
    Repeat the sequence CmcM as many times as shown in the list, move the top lever, and repeat CmcM until III lies at the top of column C.
  4. Repeat this phase until the puzzle has been solved.

If you want to put a magic square on the back, here is a list of all possible magic squares you can have:

5  0  7
6  4  2
1  8  3

7  0  8
6  5  4
2  10 3

6  0  9
8  5  2
1 10  4

10 0  11
8  7  6
3  14 4

7  0  11
10 6  2
1  12 5

9  0  12
10 7  4
2  14 5

8  0  13
12 7  2
1  14 6

These can be rotated, reflected, and you can add something to all nine numbers as long as the result does not have any number larger than 15.

Home
Links
Guestbook


Rubik's Maze

Picture kindly supplied by Corneliu Zavadovschi.

Rubik's Maze consists of 6 cubes. They are connected like one long string in such a way that any face of a cube can be placed in any orientation onto any face of an adjacent cube. On the surface of the cubes is a pattern of thick black lines, separated by thin yellow ones. The aim is to place the cubes in a 2x3 rectangle in such a way that the black lines on the outside of the puzzle join up in a single long loop.

The number of positions:
If the cubes are numbered 1 to 6 in order, then the only restriction on the placement of the cubes in a rectangle is that cubes 1 and 2 must be adjacent, as must 2 and 3, 3 and 4 etc. This leaves only 4 distinct ways to put the 6 cubes into a 2x3 rectangle. Each cube has 24 possible orientations, giving a total of 4·246 = 764,411,904 rectangular positions of which four positions are solutions.

Links to other useful pages:
Raymond Penner's page, also available here. Has the solution, and also a VRML object simulation for it.

Notation:
In the text below the cubes are numbered 1 to 6, where 1 is the cube which has a loop on the surface around one corner.

Hints for finding a solution:

  1. Examine the lines on each cube and examine the number of dead ends. The edges where the dead ends occur cannot become an edge of the 2x3 block.
  2. The dead ends of cube 6 restrict it so much that it must be one of the central cubes in the 2x3 block, which leaves only one way of arranging the cubes, viz. cubes 3 and 6 in the middle and the others at the corners.
  3. The dead ends on the surface of cube 4 determine which sides are hidden, therefore leaving it only two orientations.
  4. One of the orientations of cube 4 make it impossible to place cube 5 correctly, so cube 4 is then solved.
  5. Now cubes 3, 2, 1, 5 and 6 can be solved in that order, because they only have one possibility left that does not cause a dead end with the already solved cubes. Actually cubes 3 and 1 have two possibilities but the faces on the outside of the 2x3 block are the same.

Solution:
 |  |  | . | . | . | . | . | . | . | X | .
 |  |  | X | X | X | X | X | X | X | X | .
 |  |  | . | . | . | . | . | . | . | . | .
. | X | . | 4 | . | . | 3 | . | . | 2 | . | . | . | . | .
. | X | X | X | X | . | . | X | X | X | X | . | . | X | X
. | . | . | . | X | . | . | X | . | . | X | . | . | X | .
. | . | . | 5 | X | . | 6 | X | . | 1 | X | . | . | X | .
X | X | . | . | X | . | . | X | . | . | X | X | X | X | .
. | X | . | . | X | . | . | X | . | . | . | . | . | . | .
 |  |  | . | X | . | . | X | . | . | . | . |
 |  |  | X | X | . | . | X | X | X | X | .
 |  |  | . | . | . | . | . | . | . | X | .
 |  |  | . | . | . | . | . | . | . | X | .
 |  |  | X | X | . | . | X | X | X | X | .
 |  |  | . | X | . | . | X | . | . | . | .
 |  |  | . | X | . | . | X | . | . | . | .
 |  |  | . | X | X | X | X | . | . | X | X
 |  |  | . | . | . | . | . | . | . | X | .
 Rubik's Maze, solved
Rubik's Maze, solved
Pictures kindly supplied by Corneliu Zavadovschi.

Home
Links
Guestbook


Saturn

Picture kindly supplied by Hendrik Haak

The Saturn is a puzzle manufactured by Mag-Nif, and it does indeed look like the planet Saturn. It is a ball with a flat ring around it which consists of eight numbered pieces. The ball is split in half so that you can turn one half through 180 degrees so as to turn over three adjacent ring segments. The ring as a whole can rotate about the ball so that you can choose which segments are affected by twisting half the ball. The pieces in the ring are numbered 1 to 8, and are the same on both sides.

The Saturn outwardly looks very similar to the Brainball. It is like a simplified Hockey Puck, though solving the puzzle is actually very similar to TopSpin and identical to rearranging the segments on a Masterball.

The number of positions:
The 8 pieces can be arranged in 8! = 40320 ways, but if we consider positions which differ only by a rotation of the ring as identical, then there are only 7! = 5040 positions. All these positions are attainable, but there are actually two solved positions - pieces in order 1 to 8, or in order 8 to 1.

The puzzle is little more subtle than the previous paragraph shows. By twisting one half and then the other, the puzzle is in fact turned over. This means that you can solve the puzzle by only twisting the half that does not contain piece 1. As each twist is an even permutation, only even permutations are attainable so then there are only 7!/2 = 2520 positions whereas the other half can be reached only by turning over the whole puzzle. This means that if you never twist the half containing piece 1, then only one solution can be reached. Looking at the puzzle this way means it has 2520 positions with 1 solution instead of 5040 positions with 2 solutions. The table below shows how many twists those 2520 positions take to solve.
0 | 1
1 | 4
2 | 12
3 | 34
4 | 96
5 | 264
6 | 617
7 | 904
8 | 572
9 | 16
Total | 2520

Links to other useful pages:
Mag-Nif. The homepage of the manufacturer.

Solution:

Pieces 1-4: The first pieces are rather easy.

  1. Consider piece 1 to be correctly positioned. All the other pieces will be arranged around it to reach the solved position.
  2. Do any moves (not involving piece 1) to place piece 2 diagonally opposite piece 1.
  3. A single move will now place piece 2 correctly next to piece 1.
  4. Do any moves (not involving pieces 1-2) to place piece 3 diagonally opposite piece 2.
  5. A single move will now place piece 3 correctly next to piece 2.
  6. Do any moves (not involving pieces 1-3) to place piece 4 diagonally opposite piece 3.
  7. A single move will now place piece 4 correctly next to piece 3.

Notation:
Below I will use a bit of notation. I will assume that you will hold the central ball in place and shift the ring around it. Only one half of the ball will then be twisted and the other half is held in place. The letters C and A will denote a clockwise and an anti-clockwise turn of the ring, shifting everything along by one piece. A twist of one half of the ball is denoted by a slash /.

Pieces 5-8:

  1. If twisting the half containing pieces 5-8 puts more of them in place, especially piece 5 or 8, then do so.
  2. It is possible to swap two adjacent pieces. Twist the ring to bring the two pieces you want to swap in the middle of the half that you hold in place (i.e. opposite the half that you would twist with a / move). Now do the sequence:
    C /A/A/ CC /A/A/A/A/
  3. By repeatedly swapping adjacent pieces with the move sequence above, the final pieces can be put in place. It is always possible to solve it using at most 3 swaps.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Skewb

Picture kindly supplied by Hendrik Haak

The skewb is a cube where you don't turn the faces, but instead turn exactly half the cube around the corners. The cube is bisected 4 ways, perpendicular to each of the 4 main diagonals. It therefore consists of 8 corner pieces and 6 square face pieces.

This puzzle was invented by Tony Durham. When Uwe Mèffert originally started to produce it, it was called the Pyraminx Cube, but Douglas Hofstadter coined the name Skewb in his column in the Scientific American (July 1982). This column is reprinted in his book MetaMagical Themas.

The skewb is closely related to the Pyraminx, which also has 4 axes of rotation. The six edge pieces of the pyraminx correspond to the 6 square faces of the skewb, and the four corner pieces (without the tips) correspond to four of the corners of the skewb. On the Halpern-Meier pyramid the 4 centers correspond to the other 4 skewb corners except that rotation of the centres is not visible. Note that the solutions below will only use turns of 4 non-adjacent of the corners of the skewb, i.e. four which correspond to the corners of the pyraminx.

The skewb also comes in other forms, like the Creative Puzzleball, Mickey's Challenge, and several other spherical ones. The Skewb Diamond is an octahedral version, and the Ultimate Skewb a dodecahedral one. All these puzzles have essentially the same pieces, which differ only in their colouring. Sometimes there are identical pieces, or the orientation of some pieces are visible on one puzzle but not on another variant. The solutions below are designed for the standard skewb, in which the orientation of the faces does not matter. If you have a skewb variant where the face orientation does matter, like some of the puzzleball variants, then the solution to the Ultimate Skewb will be more appropriate.

The Beachball, Diamond and Ultimate Skewb have separate pages devoted to them.

The number of positions of the standard Skewb:
There are 4 fixed corners with 3 orientations, 4 free corners with 3 orientations and 6 face pieces giving a maximum of 6!·4!·38 positions. This limit is not reached because

  • The total twist of the corners is fixed (3)
  • The faces must have an even permutation (2)
  • The free corners must have an even permutation, and hence form a tetrad (2)
  • The orientations of the fixed corners and the position of one of the free corners will determine the positions of the other three (3)
Another way of describing the last condition is that the relative position of the two tetrads also defines a kind of twist, which must be equal to the twist of the fixed tetrad. This leaves 6!·4!·36/4 = 3,149,280 positions.

Every position can be solved in at most 11 moves. Several years ago I used a computer search to find God's Algorithm, i.e. the shortest solution for each position. Other people have done this also, and the result is shown in the following table:
Moves | Positions
0 | 1
1 | 8
2 | 48
3 | 288
4 | 1,728
5 | 10,248
6 | 59,304
7 | 315,198
8 | 1,225,483
9 | 1,455,856
10 | 81,028
11 | 90
Total | 3,149,280

Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He produces the Skewb and many variants of it.
Meffert's page. Contains the solution provided in the Skewb booklet.
Meffert's page. Contains the solution provided in the Creative Puzzleball booklet.
David Joyner's page. A catalogue of move sequences.
David Joyner's page. Proof formalizing the Skewb group. It proves the assumptions I used above to calculate its size.
'Simplest Solutions' page. A text based solution.
Cato Tveit's Page. Another text based solution.
Cyril Castella's page. A french solution.
A Nerd Paradise by Blake has solutions for the various cubes, Pyraminx, Skewb and Square-1.

Notation:
Hold the skewb so that one tetrad of the corners point left, right, down and back. You will only turn these corners, not the others. Note that a move at any of these corners leaves the other three fixed. Denote clockwise moves at the corners by L, R, D and B. Anti-clockwise turns are denoted L', R', D' and B'. Any face can be specified by two letters, e.g. DR is the face between the down and right corners. The other 4 corners can similarly be specified by 3 letters.

There now follow 3 different solutions. The first solution below closely follows that of the pyraminx.

Solution 1:
3 top corners | 3
3 top faces | 14
bottom corner | 1
3 bottom faces | 6
4 free corners | 13
total: | 37 moves
Phase 1: Solve 3 top corners

    Rotate L, R, and B so that the colours of the corners match.
Phase 2: Solve 3 top faces
  1. Find a face piece at the D corner which does not belong there.
  2. Hold the puzzle so that the face belongs at the front, the LR position.
  3. Rotate D to bring the piece to the front right, in the RD position.
  4. Do LD'L' to put it in place.
  5. Repeat the above until all three top faces are correct. If necessary, you can use the same sequence to displace incorrectly placed faces.
Phase 3: Solve the D corner.
  1. Simply rotate D to make its corner match the others.
Phase 4: Solve the D faces.
  1. There are now only three possibilities left for the last 3 faces. They are either solved, or need to be cycled around the D corner in either direction. To move them, do the appropriate sequence:
    1. Anti-clockwise: RLDL'D'R'
    2. Clockwise: RDLD'L'R'
Phase 5: Solve the final 4 corners.
  1. If the corners are positioned correctly, but only need to be oriented properly, then the following sequences can be used. You will probably need to rotate the whole puzzle to get into one of these positions:
    1. LRD->DLR, RBD->DRB, BLD->DBL: B' RD'R'D BD' L'R'L'RL' D
    2. LRD->RDL, RBD->BDR, BLD->LDB: D' LR'LRL DB' D'RDR' B
    3. BLD->DBL, RBD->BDR: LDL'D' R B'D'BD R'
    4. LRD->DLR, RBD->BDR, BLD->LDB, LRB->RBL: D' LR'LRL DB' D'RDR' B
  2. If the corners are not in the correct position, then one of the following sequences will do:
    e. DLR->BRL->DLR, LDB->RBD->LDB: DR'D' L'D'LD R D'L'DL
    f. DLR->LBR->RDL, LDB->DRB->DBL: DL' D'RDR' L RD'R'
    g. DLR->RLB->LRD, LDB->BDR->BLD: B'LD'L'D B D'LDL'
    h. DLR->BRL->DLR, LDB->DRB->LDB: DR'L'B'LRDLBL'D
    i. DLR->LBR->RDL, LDB->RBD->DBL: R D R'LRL' D' LR'L'
    j. DLR->LBR->RDL, LDB->BDR->DBL: L'R'L B' L'RLR' B R
    k. DLR->LBR->LRD, LDB->BDR->BLD: L RD'R'D L' D'RDR'
    l. DLR->LBR->RDL, LDB->DRB->LDB: L'R'DRL BRD'R'B'
    m. DLR->LBR->RDL, LDB->BDR->LDB: LDBL R' L'B'D'L' R

Solution 2:
3 top corners | 3
3 top faces | 12
top corner | 6
bottom corner | 1
bottom layer | 10
total: | 32 moves
Phases 1-2:

    See solution 1.
Phase 3: Place the top corner correct.
  1. Find the piece belonging in the top corner.
  2. If it is in place but incorrectly oriented, then do one of the following:
    1. BRL->LBR: LD'L' R'D'R
    2. RLB->LBR: R'DR LDL'
  3. If the top corner piece is not in place then turn D to bring it to the
        LRD position, and do one of the following:
1.  LRD->LBR:   B' L'D'LD B
2.  LRD->RLB:   B' D'L'DL B
3.  LRD->BRL:   B  RDR'D' B'
Phase 4: Solve the D corner.
  1. Simply rotate D to make its corner match the others.
Phase 5: Solve the bottom layer.
There are three categories, depending on the position of the faces.
  1. If the final three faces are correctly positioned, then do one of the following:
    1. DBL->LDB DRB->RBD: B'DBD' L' RD'R'D L
    2. DBL->BLD DRB->BDR: L' D'RDR' L DB'D'B
    3. DBL->BLD DRB->RBD LRD->RDL: R'L'D R'L'D R'L'D
    4. DBL->LDB DRB->BDR LRD->DLR: LRD' LRD' LRD'
  2. If the final 3 faces need a clockwise twist around D, then do one of the following:
    1. Corners are correct: RL' BDB'D' RLR
    2. DBL->LDB DRB->RBD: R'D'RD RL'R'L
    3. DBL->BLD DRB->BDR: RL'R'L DLD'L'
    4. DBL->BLD DRB->RBD LRD->RDL: B'LBL RD' RL'RL' D
    5. DBL->LDB DRB->BDR LRD->DLR: R'LR' B'L' RD'RD B
  3. If the final 3 faces need an anti-clockwise twist around D, then do one of the following:
    1. Corners are correct: L'R B'D'BD L'RL'
    2. DBL->LDB DRB->RBD: LDL'D' L'RLR'
    3. DBL->BLD DRB->BDR: L'RLR' D'R'DR
    4. DBL->BLD DRB->RBD LRD->RDL: B' D'R'DR' LBRL'R
    5. DBL->LDB DRB->BDR LRD->DLR: BR'B'R' L'DL'RL'RD'

Solution 3:
3 top corners | 3
top corner | 5
bottom corner | 1
3 bottom corners | 6
6 faces | 18
total: | 32 moves
Phase 1:

    See solution 1.
Phase 2: Solve the top corner
  1. Find the piece belonging in the top corner.
  2. If it is in place but incorrectly oriented, then do one of the following:
    1. BRL->LBR: RDRDR
    2. RLB->LBR: R'D'R'D'R'
  3. If the top corner piece is not in place then turn D to bring it to the
        LRD position, and do one of the following:
1.  LRD->LBR:   R'D'R
2.  LRD->RLB:   D'RD'R'
3.  LRD->BRL:   LDL'
Phase 3: Solve the D corner.
  1. Simply rotate D to make its corner match the others. On the Pyraminx Diamond the orientation of the 'corner' (actually triangular face) is not visible, so then you must turn D so that the three remaining free 'corners' are all correctly positioned.
Phase 4: Orient the bottom corners.
  1. If two corners need to be twisted, then hold the puzzle so that the corners are at the DBL and DBR positions. Do one of the following:
    1. DBL->LDB DRB->RBD: LR'L' D'RD
    2. DBL->BLD DRB->BDR: D'R'D LRL'
  2. If all three corners need to be twisted then do one of the following:
    1. Clockwise: R'L'R'L'R'L'
    2. Anti-clockwise: LRLRLR
Phase 5: Position the faces
  1. Here is a list of sequences that move the faces about. They either swap two pairs of faces, of cycle three faces. You can solve any face position by applying at most two of these.
    1. DL-LR DR-DB: D'R'DR DLD'L'
    2. DL-DB DR-LR: R'D'RDLDL'D'
    3. DL-DR DB-LR: D' R'D'RD LDL'
    4. DR->BL->LR->DR: R'D'RD B'L'BL
    5 DL->DR->LR->DL: R' D'L'DL B'R'BR'

Home
Links
Guestbook


Spinout / The Brain / Chinese Rings puzzle

Picture kindly supplied by Hendrik Haak

This page is about three closely related puzzles:

Spinout, by Binary Arts, is a simple puzzle consisting of a long flat plastic rectangle inside a grey cover. The piece could simply slide out if it were not for 7 oddly shaped knobs. If all the knobs are turned horizontal it will slide, but a knob can only be turned if the one to its right is vertical and any others further to the right are horizontal. This puzzle is now sold with a new design where the knobs have little elephant figures on them.

The Brain, by Mag-Nif, consists of a tower of eight transparent disks that can rotate about their centres. The disks have slots in them and there are eight upright black rods going through the stack. The rods have two positions, in or out, and the aim is to move all the rods out. The rods are numbered 1 to 8, and a rod can only move if the rod with the next lower number is out and the further lower rods are in.

The Chinese rings puzzle is a row of rings, each affixed to a base with a rod. Each ring encloses the rod of the next ring in the row. A long loop of wire goes through all the rings and around all the rods. A ring can only be released from or placed back on the loop if the next ring is on the loop but all other rings further down are already off.

Links to other useful pages:
PuzzleSolver by Jake Olefsky has a short text about the Brain puzzle.
Binary Arts homepage. Homepage of the manufacturer of Spinout.
Mag-Nif homepage. Homepage of the manufacturer of The Brain.

All three puzzles above have the same basic solution, which is based on the (standard) binary Gray code. In essence a binary Gray code is a list of all binary numbers of a certain length in such an order that any two adjacent numbers in the list differ only by one digit. This obviously corresponds to the puzzles, where each knob/rod/ring has two positions and you can only move one at a time.

All these puzzles are quite simple. In any position there are at most two possible moves, the equivalent of going up or down the list of Gray code numbers. If you never take back a move, you will always go on until you reach the end/beginning of the list. Unfortunately the actual puzzle might only be solved at the other end of the list, and you will have to go all the way back.

With the Chinese Rings and Spinout you have two choices for your first move, either ring/knob 1 or 2. If there are an even number of rings/knobs, then you must begin with the even ring/knob i.e. number 2, if there are an odd number of rings/knobs (the standard spinout has 7) then begin with the odd one i.e. number 1.

If you begin with the wrong move, you end with the position where all but the last ring/knob is off the loop/horizontal. You must then go all the way back to the beginning, and then do twice as many moves again to solve the puzzle.

With the Brain you only have one first move, so it is easy to solve. Once in the solved position there are two choices for the next move if you want to bring it back to the initial position. Since there are an even number of rods, your next move then must be rod 2.

Suppose you find one of these puzzle in an intermediate position, and want to determine which of the two moves you need to solve it from there. The way to deduce this is best shown by a few examples.

Suppose the rods 1-8 of the Brain are In/Out/Out/In/Out/Out/In/In. If you want to solve it, then you would want the most difficult rod to move, rod 8, to be moved out. To do this, you must have rod 7 in and 1-6 out. Rods 5-7 are already in that position, but 4 is not so that has to be moved first. To move rod 4 you must have rod 3 in and 1-2 out, so rod 3 must be moved first. Therefore we need rod 2 in and rod 1 out. To move rod 2 in, we must have rod 1 in. This is already the case, so we can move rod 2 to get closer to the solution.

A similar argument would work if we wanted to get back to the starting position, all rods in. In that case we must move rod 6 in; to do that we need rod 5 in first; for that we need 4 in and 1-3 out; hence we must move rod 1.

On spinout we could make the same kind of argument. The knobs are numbered 1-7 where 1 is the rightmost one, i.e. the one that can always be moved. Suppose they are all horizontal except 2,5,7. To move 7 horizontal we need 6 to be vertical. To move 6 we need 5 vertical and 1-4 horizontal. Therefore we need to move 2 horizontal and to do that 1 must be moved vertical first.

This argument also shows why we must turn knob 1 first in the starting position where all 7 knobs are vertical. Knob 7 must be moved, so 5 must be moved horizontal first, and for that 3 must be moved and horizontal and to do that 1 must be moved.

If your browser supports it, you can click on the link below to see a Javascript version of the Spinout puzzle.

Javascript Spinout Puzzle

Home
Links
Guestbook


(Back to) Square One

Picture kindly supplied by Hendrik Haak

Description of the Square One Puzzle
Solution:
1. Getting into cube shape
Method 1
Method 2
Notation
A short note about odd permutations
2. Placing the corners
3. Placing the edges
Corner processes

Links to other useful pages:
Chris Eggermont's page. A good general text about the puzzle, with a list of shapes for solving phase 1.
Chris and Kori's page. This also has a set of pages with puzzle shapes.
Matthew Monroe's page. He has illustrated Andrew Arensberger's partial solution making it much easier. It still does not deal with odd permutations.
The rec.puzzles archive has an awkward solution here.
A Nerd Paradise by Blake has solutions for the various cubes, Pyraminx, Skewb and Square-1.

Description:
This puzzle is a cube consisting of three layers. The top and bottom layers are cut like a pie in 8 pieces; 4 edge pieces and 4 corner pieces, 30 and 60 degrees wide respectively. The top and bottom layers can rotate. The middle layer is cut in only two halves along one of the lines of the other layers. If there are no corner pieces in the way, you can twist half the cube 180 degrees so that pieces from the top and bottom layers mingle.

The puzzle is unique in that the two types of pieces intermingle. The edge and corner pieces can freely move between the two outer layers. Of course, the puzzle will not necessarily be a cube shape if the pieces are mixed. The puzzle has six colours, each face has a single colour similar to the Rubik's cube.

The number of positions:
There are three categories of puzzle shapes.

  1. Both layers have 4 edges and 4 corners each.
  2. One layer has 3 corners, 6 edges, the other 5 corners 2 edges.
  3. One layer has 2 corners, 8 edges, the other 6 corners and no edges.
There are 1, 3, 10, 10 and 5 layer shapes with 6, 5, 4, 3 and 2 corners. This means there are 5·1+10·3+10·10+3·10+1·5 = 170 shapes for the top and bottom layers. The middle layer has two shapes (half of it is assumed to be fixed). This means that there seem to be 170·2·8!·8! = 552,738,816,000 positions if we disregard rotations of the layers. Some layer shapes however have symmetry, and these have been counted too many times this way.

To take account of the symmetries we can simply count the number of layer shapes differently. Instead of the numbers 1, 3, 10, 10, 5 we use the numbers 2, 36, 105, 112, 54, which are the number of shapes if we consider rotations different (e.g. a square counts as 3 because it has three possible orientations). By the same method as before we then get 19305·2·8!·8! or 62,768,369,664,000 positions. To exclude layer rotations, divide by 122 to get a total of 435,891,456,000 distinct positions.

It is interesting to note that this number is exactly 15!/3. In fact, even for the generalised version with 2n pieces in each layer, a similarly simple formula holds, viz. 4(4n-1)!/3n. If anyone knows of a direct way to derive this, please let me know.

If instead we wish to count only all those positions where there are no corner pieces in the way of twisting the halves, then we can use the same method but counting only all the different ways each shape can be split into two halves, e.g. a square counts as 2 this time. The numbers to plug in are now 1, 12, 46, 62, and 37 which gives a total of 3678·2·8!·8! = 11,958,666,854,300 twistable positions.

To help solve this puzzle I have written a computer program that searches for solutions for a particular position. It is similar in style to Kociemba's algorithm for the Rubik's cube, as it solves it in two stages. In the first stage it makes a cube with an even permutation of pieces, and the second stage solves it. With some simple look-up tables the search is speeded up. This program has helped me improve some of the move sequences in my previous solution method, and helped me find many others. From the results I suspect that God's algorithm uses at most about 12 twists of the right (or left) hand side, or about 30 moves in total.

Click here to download the Square-1 solver, Version 3, for DOS/Windows.
Updated 27/05/2001: The program now allows a choice of metric.

Solution:
Phase 1: Getting the cube shape.

    First you must get the puzzle into cube shape. This takes at most 7 twists (ignoring the centre layer shape), and the shortest method is simply using a table to look up the moves since there are only 90 different possible puzzle shapes. Such tables can be found elsewhere on the web, and are not particularly enlightening. Instead I will expand two far more interesting ideas. The second method is much easier, but the first method shows an underlying mathematical constraint that I find quite surprising.

    Method 1:
    This is a method found in the rec.puzzles archive.
    There are 10 shapes with 4 edges (e), 4 corners (c) that a layer can have. Looking clockwise around the layer, they are:
    cececece: | Square | 0
cceecece: | Right Fist | 1
cceeccee: | Barrel | 2
cceceece: | Kite | 2
ccececee: | Left Fist | 3
ccecceee: | Mushroom | 0
ccceeece: | Right Paw | 3
ccceecee: | Shield | 0
ccceceee: | Left Paw | 1
cccceeee: | Scallop | 2
    If you are in a position with two of these shapes, look up the numbers associated with them in the list above and add them to get a number. Whatever move you do that keeps 4 corners in each layer, the number arrived at will not change (modulo 4). In particular if the number is not 0 (or 4) you cannot get it into a cube shape without first moving to a position that does not have 4 corners on each side. You then have to move back to a position with 4 corners in each layer and that does have a 0 or 4 sum.

    If you do get a 0 (or 4) sum then the following list shows you how far away you are from the cube shape:

              Square-Square      0
          Kite-Kite          1

Barrel-Barrel      2    L.Fist-R.Fist      2
Shield-Shield      3    L.Paw-R.Paw        3
Scallop-Scallop    3    Barrel-Kite        3
Mushroom-Mushroom  3    Square-Shield      3
Barrel-Scallop     4    Square-Mushroom    3
                        Kite-Scallop       3
                        R.Fist-R.Paw       4
                        L.Paw-L.Fist       4
                        Mushroom-Shield    4

    The above should give you enough information to eventually get two squares. If the middle layer is not square, a single twist can make it so, though this is not yet necessary.

    Method 2: Pairing the edges
    I am indebted to Robert Richter for the following method of restoring the square 1 puzzle to cube form.

    The main idea is to combine all the edge pieces into adjacent pairs of edges. Once this has been done, it is easy to bring all four pairs together and from there get the cube shape. The great advantage of having only pairs of edges is that they take exactly the same amount of room as corner pieces. Each layer therefore will consist of six parts of equal size (corners and/or edge pairs) which can be moved around without obstruction.

    I'll explain below in more detail how to make edge pairs, but before I do it is important to be able to distinguish between edge pairs and single edges. This is usually really obvious, but sometimes when there are an odd number of edges together in a group it is not immediately clear which of them is the single edge and which ones form the pairs. A simple way to determine this is to remember that the single edge is always one of those at the outside of the group, never one in the middle. Often one of those outside edges cannot be moved because the seam that separates if from the others does not extend all the way through the layer. As it cannot be separated, it must form a pair with the one next to it, and the edge at the other end of the group is the single one. If both edges can be moved then either one of them (but not both) can be considered to be single.

    Another way to determine the single edges is by seeing how close the layer is to being made of six equal sized parts. There are several shape types:

    1. The layer is square, and obviously there are 4 single edges in this case.
    2. The layer does divide into 6 equal sized parts. Here all edges (if any) already occur in pairs.
    3. The layer has 4 of the 6 equal parts, but the rest consists of two edges with a corner between them. Those two edges are the single ones.
    4. Half the layer consists of 3 equal parts, and the rest consists of two edges with two corners between them. Again those two edges are single.
    Sometimes a layer is ambiguous, because it belongs to both cases 3 and 4 above. In particular, the layer shape CCECEEEEE can be split as EE-EE-C-C-ECE, or as C-EE-EE-ECCE. We will use this ambiguity later on.

    So, the first thing to do to move towards the cube shape is to pair up the edge pieces. Getting three pairs is fairly easy, in fact, in more than half the configurations there are already three pairs. In nearly all other cases there will be unpaired edges in both layers. It is then possible to bring an unpaired edge in the top layer to the front to the left of the seam, and an unpaired edge in the bottom layer to the back to the right of the seam so that a single twist brings the two edges together and does not split any already paired edges. This process can be repeated if necessary until you have at least three edge pairings. There is one special case you should be aware of, where all unpaired edges are in a single layer which only occurs when it is a square shape. In this case simply do any twist (that does not split any pairs in the other layer) to spread the unpaired edges to both layers and then continue the process outlined above to bring them together.

    You will now have at least 3 pairs of edges. There are now three possibilities left:

    1. You already have 4 pairs of edges. It is now a simple matter to bring these pairs together to form a large group of 8 adjacent edges.
    2. You have two unpaired edges which are 150 degrees apart, i.e. they are separated by two corner pieces. Turn the layer with these two edges so that they both lie on the left hand side of the seam. I prefer to have them at the bottom left so I turn over the puzzle if they are on top. You next use only turns of the top layer and twists of the right hand side to move the three edge pairs together in a large group of 6 edges in the top layer. Often this is easy. The trickiest case is when the bottom right half consists of an edge pair between two corners. This pair cannot be immediately placed next to another edge pair, so you will have to twist it to the top and bring an edge pair to the bottom so that it lies next to the seam. Just be patient and make sure not to turn the bottom layer or to break up the edge pairs. Once you have the large group of 6 edges you can place them next to the two single edges to make a group of 8 edges together.
    3. You have two single edges that are 90 degrees apart, i.e. they are separated by exactly one corner piece. Turn the layer with these two edges so that they both lie on the same side of the seam, and turn the puzzle so that they are in the left half of the bottom layer. Using only turns of the top layer and twists of the right half of the puzzle bring (at least) two of the edge pairs together in the top layer to make a group of 4 (or 6) adjacent edges. It is now always possible to bring the single edges and the group of 4 together in one layer to make the layer shape CCECEEEEE (or its mirror image CCEEEEECE), and this leaves (or moves) the remaining edge pair to the other layer. Because of the ambiguity of the edge pairings in this shape, you can consider the two edges on either side of the two adjacent corners to be the unpaired ones instead. This can therefore be solved as in case 2 above.
      [Note: You could use the ambiguity of the CEEECCEEE layer shape instead but this it is slower to solve because its edge pairs are separated, and you need to put all three edge pairs together in case 2.]

    At this point all eight edges are together in one layer. To get to the cube shape split the group in two, making both layers into the scallop shape (CCCCEEEE). Now split each set of edges in two again to get both layers into the barrel shape (CCEECCEE). Split one barrel between a pair of corners and the other between a pair of edges, to get both layers into the kite shape (CECEECEC). If you split these between their edge pairs you form two squares.

Notation:
From now on we need a notation for the moves. Hold the puzzle with the 'square 1' text on the left, so that the cut in the middle layer goes from the front left to the back right. Let the faces be denoted by L, R, F, B, U and D (left, right, front, back, up, down). Positions of edge pieces can be denoted by two letters, positions of corners by 3. Turns of the top and bottom layers are denoted by a pair of numbers (n,m). They are the multiple of 30 degrees that the top/bottom layers are to turn respectively. A 3 means clockwise 90 degrees, 1 means 30 degrees (i.e. one edge along) and negative numbers mean anti-clockwise turns. A twist of the right hand side of the puzzle is denoted by a /.

A short note about odd permutations:
Now that the puzzle is a cube shape, it is tempting to think that it can now be solved without changing shape. Many of the sequences used below indeed keep the top and bottom layers square. Each shape preserving move swaps two pairs of corners and two pairs of edges. This is an even number of swaps, so this is an even permutation. No combinations of even permutations can possibly be an odd permutation so any position that needs an odd number of swaps to solve it, cannot be solved without changing shape. The quickest way to perform an odd permutation is to go to the scallop-scallop shape (3 twists), swap three corners from one layer with three from the other (1 twist), and return to the cube shape (3 twists) which takes 7 twists in total.

Phase 2: The corner pieces.
In this phase, every twist will keep the layers square.

  1. Find the piece that should be at UFL. If it is in the bottom layer, then bring it to the top with a twist, (keeping the U,D layers square by turning either layer slightly before twisting). Then turn the top to place it correctly.
  2. Find the piece that should be at UBL. If it is incorrectly placed in the top layer, then bring it to the bottom with a twist. Then turn the bottom to place it at DFR. Now do (4,0)/(-4,0)
  3. Find the piece that should be at UBR. If it is incorrectly placed in the top layer, then bring it to the bottom with a twist. Then turn the bottom to place it at DFR. Now do the twist (1,0)/(-1,0).
  4. Find the piece that should be at UFR. If it is not in place then turn the bottom to place it at DFR. Now do the sequence (1,0)/(0,-3)/(0,3)/(-1,0).
  5. Rotate the bottom layer to place at least 2 corners are correct. If you need to swap two corners, then you can use the following two sequences:
    1. Swap DFR-DBR: (1,0)/(0,-3)/(3,0)/(-3,0)/(-3,3)/(-3,0)/(2,0)
    2. Swap DFL-DBR: (1,0)/(3,3)/(0,3)/(3,3)/(0,3)/(3,3)/(-1,-3)
    It is possible to perform the second (diagonal) swap by using the first (adjacent) swap twice.
Phase 3: Place the edge pieces in their correct layer.
    Rotate the top/bottom layers to bring it to a position where one of the following sequences will place the edges in the correct layer. There is no need to memorise all of these. If you know only one of the sequences 8 to 13, you can use it repeatedly until the edges are in the correct layer.
    1. | Swap DF-UF, DR-UR, DB-UB, DL-UL | (3,2)/(1,1)/(-3,3)/(-1,-1)/(0,-5) | [4*|13*]
    2. | Swap DF-UF, DB-UB | (0,5)/(1,1)/(-1,6) | [2*|7*]
    3. | Swap DF-UB, DB-UF | (0,-1)/(1,1)/(-1,0) | [2*|6*]
    4. | Swap DR-UR, DB-UB | (0,2)/(0,3)/(1,1)/(-1,-4)/(0,-2) | [4*|11*]
    5. Swap DR-UB, DB-UR (0,2)/(0,3)/(1,-5)/(-1,5)/(0,3)/(0,-2)
    /(0,3)/(0,-4)/(1,1)/(-1,3)/(0,-3)/     		[5*|13*]
    [6|13*]
    6. | Swap DB-UB, DR-UF | /(-3,0)/(0,5)/(6,1)/(0,3)/(-5,0)/(-1,6) | [6*|14*]
    7. | Swap DB-UF, DR-UB | (1,0)/(0,5)/(0,-3)/(-1,6)/(0,-5)/(0,3)/(0,6) | [6*|14*]
    8. | Swap DR-UF, UR-UB | (1,0)/(0,-3)/(-1,2)/(1,1)/(0,-3)/(0,3)/(-1,0) | [6*|15*]
    9. | Swap DR-UR, UF-UB | (1,0)/(0,-3)/(-1,-4)/(1,1)/(0,3)/(0,3)/(-1,0) | [6*|15*]
    10. | Swap DR-UB, UF-UR | (0,-1)/(0,3)/(0,-3)/(1,1)/(-1,2)/(0,-3)/(0,1) | [6*|15*]
    11. | Cycle UF->UR->DR | (-5,-3)/(5,0)/(0,3)/(-5,0)/(5,0)/(0,-3)/(0,3) | [6*|14*]
    12. | Cycle UF->UB->DR | (1,0)/(-1,0)/(0,3)/(-5,0)/(5,0)/(0,-3)/(1,0)/(5,0) | [7*|15*]
    13. | Swap UF-DF | (0,-3)/(0,3)/(1,0)/(2,-2)/(4,0)/(4,0)/(-4,4)/(0,1)/(0,3)/(-3,-1)/(1,-2)/(-1,0) | [11*|27]
Phase 4: Place the edge pieces in each layer correctly.
    Rotate the top/bottom layers to bring it to a position where one of the following sequences will place the edges correctly. There is no need to memorise all of the sequences, as only a few of the single layer swaps will be sufficient. Alternatively any odd permutation together with sequences a4 and a5 will do.
  1. The following sequences perform swaps in both layers:
    1. | Swap UF-UB, UR-UL, DF-DB, DR-DL | (1,0)/(2,-4)/(1,1)/(2,2)/(-5,1)/(5,0) | [5*|15*]
    2. | Swap UF-UL, UR-UB, DF-DL, DR-DB | (0,2)/(-3,0)/(1,1)/(3,-3)/(-1,-1)/(0,3)/(0,-2) | [6*|16*]
    3. | Swap UF-UB, UR-UL, DF-DL, DR-DB | /(3,3)/(0,3)/(1,-5)/(4,-2)/(4,1)/(3,3)/ | [7*|18*]
    4. | Swap UF-UB, DF-DB | (1,0)/(5,-1)/(-5,1)/(5,0) | [3*|9*]
    5. | Swap UR-UB, DR-DB | (0,2)/(0,-3)/(1,1)/(-1,2)/(0,-2) | [4*|11*]
    6. | Swap UF-UB, DR-DB | (1,0)/(0,-1)/(0,-3)/(5,0)/(-5,0)/(0,3)/(0,1)/(5,0) | [7*|15*]
    7. | Swap UF-UB, UL-UR, DF-DB | /(3,3)/(0,-3)/(3,3)/(0,-2)/(-2,4)/(2,-4)/(0,-1)/(3,3)/(0,3) | [9*|23*]
  2. The following sequences move top layer edges only:
    1. | Swap UF-UB, UR-UL | /(3,-3)/(3,-3)/(0,1)/(-3,3)/(-3,3)/(-1,0) | [6*|16*]
    2. | Swap UF-UL, UR-UB | /(3,3)/(0,3)/(1,1)/(-1,-4)/(-3,-3)/ | [6*|15*]
    3. Cycle UF->UB->UR (1,0)/(-1,2)/(-5,1)/(0,3)/(-3,0)/(5,2)/(-5,4)/(-4,0)
    (-3,0)/(3,0)/(1,0)/(0,-3)/(-1,0)/(-3,0)/(1,0)/(0,3)/(2,0)     		[7*|19]
    [8|17*]
    4. | Swap UF-UB | /(3,3)/(3,2)/(-4,2)/(-2,4)/(-2,0)/(-4,2)/(-5,1)/(3,0)/(3,3)/(0,-3) | [10*|27]
    5. Swap UF-UR (3,0)/(3,0)/(1,2)/(-2,3)/(-2,3)/(-2,5)/(4,0)/(0,1)/(3,5)/(-3,0)/(2,3)/(-2,4)/(5,3)
    /(3,0)/(1,0)/(-2,0)/(2,-1)/(0,-2)/(-4,0)/(-5,0)/(-4,0)/(-1,0)/(-3,0)/(-3,2)/(-2,1)/(-1,0)     		[12|33]
    [13|29]
    6. | Cycle UF->UR->UB->UL | /(3,3)/(1,0)/(-2,-2)/(2,0)/(2,2)/(-1,0)/(-3,-3)/(0,2)/(-2,-2)/(-1,0) | [10*|25]
    7. | Cycle UB->UF->UR->UL | /(3,0)/(1,0)/(-2,-2)/(4,0)/(0,4)/(3,-4)/(-1,0)/(0,-3)/(4,0)/(-1,2)/(-3,4) | [11*|26]
Phase 5: The central layer.
  1. If the middle layer is not a square, then the following sequence will correct it by reversing its right hand side:
    /(6,0)/(6,0)/(6,0)
Addendum:
    Here are some further sequences that are not included in the algorithm above. The ones in this first section move only corner pieces instead of edges, in a similar way to phases 3 and 4 above. You could use these to solve the edges first and then the corners.
  1. The following move corners from one layer to the other.
    1. Swap UFR-DFR, UBR-DBR, UBL-DBL, UFL-DFL: (4,0)/(2,2)/(-3,3)/(-2,-2)/(-1,-3) [4*|13*]
    2. Swap UFL-DFL, UBR-DBR: (4,0)/(2,2)/(6,-2) [2*|7*]
    3. Swap UFL-DBR, UBR-DFL: (0,2)/(-2,-2)/(2,0) [2*|6*]
    4. Swap UFL-DFL, UFR-DFR: (1,0)/(3,0)/(2,2)/(-5,-2)/(-1,0) [4*|11*]
    5. Swap UFL-DFR, UFR-DFL: (1,0)/(3,0)/(-4,2)/(4,-2)/(3,0)/(-1,0) [5*|13*], or /(3,0)/(-5,0)/(2,2)/(3,-2)/(-3,0)/ [6|13*]
    6. Swap UFL-DFL, UBR-DFR: /(3,0)/(0,-4)/(6,-2)/(0,-3)/(4,0)/(2,6) [6*|14*]
    7. Swap UFL-DFR, UBR-DFL: (0,6)/(0,3)/(0,-4)/(4,0)/(-3,0)/(6,-2)/(2,0) [6*|14*]
    8. Swap UFR-UBR, UFL-DFR: (0,2)/(0,-3)/(-2,1)/(2,2)/(0,-3)/(0,3)/(0,-2) [6*|15*]
    9. Swap UFL-UBR, UFR-DFR: (0,2)/(0,-3)/(-2,-5)/(2,2)/(0,3)/(0,3)/(0,-2) [6*|15*]
    10. Swap UFL-UFR, UBR-DFR: (-2,0)/(0,3)/(0,-3)/(2,2)/(-2,1)/(0,-3)/(2,0) [6*|15*]
    11. Cycle UFL->UFR->DFR: (4,5)/(3,0)/(-4,0)/(0,4)/(0,-3)/(0,-4)/(0,-5) [6*|14*]
    12. Cycle UFL->UBR->DFR: (-2,0)/(2,0)/(0,-3)/(4,0)/(-4,0)/(0,3)/(-2,0)/(-4,0) [7*|15*]
    13. Swap UFR-DFR: /(3,3)/(-1,0)/(2,-2)/(0,-1)/(0,3)/(-2,-1)/(2,0)/(-1,-2)/(-3,0)/ [10*|23*]
  2. The following move corners within both layers.
    1. Swap UFR-UBL, UFL-UBR, DFR-DBL, DFL-DBR: (1,0)/(-1,5)/(3,3)/(1,1)/(-3,3)/(5,0) [5*|15*]
    2. Swap UFR-UFL, UBL-UBR, DFR-DFL, DBL-DBR: (1,0)/(0,-3)/(2,2)/(-3,3)/(-2,-2)/(3,0)/(-1,0) [6*|16*]
    3. Swap UFL-UBR, DFL-DBR: (0,5)/(-2,4)/(2,-4)/(0,1) [3*|9*]
    4. Swap UFL-UFR, DFL-DFR: (1,0)/(-3,0)/(2,2)/(1,-2)/(-1,0) [4*|11*]
    5. Swap UFL-UBR, DFL-DFR: (4,0)/(0,2)/(0,3)/(-4,0)/(4,0)/(0,-3)/(0,-2)/(2,0) [7*|15*]
    6. Swap UFL-UBR, UFR-UBL, DFL-DBR: /(3,3)/(1,2)/(2,-4)/(4,-2)/(-2,-1)/(3,3)/ [7*|19*]
  3. The following move corners in the top layer only.
    1. Swap UFL-UBR, UFR-UBL: /(3,-3)/(3,-3)/(0,-2)/(-3,3)/(-3,3)/(2,0) [6*|16*]
    2. Swap UFL-UFR, UBR-UBL: /(3,3)/(-5,-2)/(2,2)/(3,0)/(-3,-3)/ [6*|15*]
    3. Cycle UFL->UBR->UFR: (1,0)/(0,3)/(2,0)/(-3,0)/(-2,0)/(0,-3)/(2,0)/(3,0)/(-3,0) [8*|17*]
    4. Swap UFL-UBR: /(3,3)/(3,0)/(-4,2)/(-2,4)/(6,2)/(-4,2)/(-2,4)/(-5,0)/(-3,-3)/ [10*|26], or /(-3,0)/(0,-3)/(2,0)/(0,2)/(-2,0)/(4,0)/(0,-2)/(0,2)/(-4,1)/(3,0)/ [11|22*]
    5. Swap UFL-UFR: /(3,3)/(1,4)/(0,4)/(10,4)/(8,2)/(2,0)/(10,4)/(4,1)/(3,3)/ [10*|26], or /(0,3)/(1,2)/(0,-4)/(2,-2)/(0,-4)/(0,-4)/(0,4)/(0,-4)/(-3,0)/(0,-3)/ [11|23*]
    6. Cycle UFL->UBL->UBR->UFR: /(3,3)/(-1,0)/(-2,-2)/(2,0)/(2,2)/(0,-2)/(2,2)/(-1,0)/(-3,-3)/ [10*|24*]
    These sequences move corner and edge pieces in one layer simultaneously. With the sequences above that move only edges or only corners in one layer, all 34 possibilities are accounted for. You could use these to solve the puzzle by first getting all the pieces to the correct layer, before rearranging the layers.
  1. The following swap the diagonally opposite corners UFL and UBR, as well as the U layer edges as shown:
    1. B-L: /(3,0)/(3,3)/(3,0)/(-5,0)/(0,3)/(3,3)/(0,3)/(-4,0) [8*|18*]
    2. B-R: (1,0)/(3,0)/(-4,-1)/(0,-3)/(3,0)/(1,-2)/(0,3)/(0,3)/(-4,-1)/(0,4) [9|22]
    3. L-R: (1,0)/(3,3)/(3,0)/(3,3)/(3,0)/(3,3)/(-4,0) [6*|16*]
    4. F-B: (3,0)/(3,3)/(3,0)/(3,3)/(3,0)/(3,3)/ [6*|15*]
    5. R->B->F: /(0,-3)/(3,-1)/(1,0)/(4,0)/(0,-4)/(2,-1)/(0,-1)/(-3,-5)/(3,0)/(0,5)/(0,-3)/(0,1) [12|27]
    6. R->L->F: /(3,-3)/(0,-3)/(-1,4)/(-4,0)/(0,4)/(4,0)/(4,0)/(-4,0)/(0,1)/(0,3)/(0,6) [11|24]
    7. B-L, F-R: (0,-1)/(-5,0)/(3,3)/(4,-1)/(0,4)/(2,2)/(4,0)/(1,-4)/(3,3)/(5,0)/(0,1) [10*|26]
    8. L-F, B-R: (1,0)/(0,5)/(3,3)/(-2,-1)/(4,0)/(0,2)/(2,0)/(0,4)/(1,-4)/(3,3)/(0,-5)/(5,0) [11|27]
  2. The following swap the adjacent corners UBL and UBR, as well as the U layer edges as shown:
    9. R-F: (1,0)/(3,3)/(-4,-1)/(1,4)/(0,-3)/(0,-3)/(3,0)/(0,-3)/(-4,0) [8*|20*]
    10. B-R: /(-3,3)/(3,0)/(0,-3)/(0,3)/(0,-3)/(3,0) [6*|13*]
    11. L-B: (1,0)/(-3,3)/(3,0)/(0,-3)/(0,3)/(0,-3)/(2,0) [6*|14*]
    12. F-L: /(-3,-3)/(4,1)/(-4,-1)/(0,3)/(3,0)/(-3,0)/(3,0)/(3,0) [8*|19]
    13. L-R: (0,-1)/(1,1)/(3,0)/(-3,0)/(-1,-4)/(3,0)/(-3,0)/(-2,4)/(3,0)/(2,0) [9|22]
    14. F-B: (3,0)/(3,0)/(3,3)/(3,0)/(4,0)/(0,3)/(3,3)/(0,3)/(2,0) [8*|19*]
    15. R->L->F: /(0,-3)/(-2,0)/(-3,-1)/(-1,2)/(0,-4)/(0,4)/(1,-4)/(0,3)/(0,-5)/(0,3)/(3,0)/(5,0) [12|27]
    16. B->F->R: /(0,3)/(3,0)/(0,2)/(0,2)/(0,-4)/(0,4)/(1,-1)/(0,-3)/(0,3)/(2,0)/(-3,3)/(3,1) [12|27]
    17. L->R->B: /(3,0)/(0,2)/(0,-3)/(3,0)/(2,0)/(0,4)/(0,4)/(-4,0)/(-1,0)/(-3,0)/(-3,-4)/(0,4) [12|25]
    18. F->B->L: /(3,0)/(1,0)/(-2,0)/(0,5)/(0,-1)/(4,0)/(0,2)/(-4,1)/(0,1)/(0,5)/(-3,0)/(-1,1) [12|26]
    19. F-L, B-R: /(3,3)/(0,3)/(1,-1)/(-2,0)/(0,2)/(0,-4)/(2,0)/(-2,0)/(1,0)/(-3,-3)/ [11|24*]
    20. F-R, B-L: (3,0)/(3,3)/(0,3)/(1,5)/(-2,4)/(-4,2)/(2,0)/(-2,4)/(4,1)/(3,3)/(-3,0) [10*|28]
    21. L-R, F-B: (4,0)/(2,0)/(3,3)/(1,0)/(4,0)/(0,-4)/(0,-4)/(4,0)/(1,0)/(-3,-3)/(1,3)/(2,0) [11|26]
    22. F->R->L->B: (-3,0)/(-3,0)/(3,3)/(3,0)/(1,-2)/(-1,2)/(-3,-3)/ [7*|18*]
    23. F->L->R->B: (4,0)/(-3,0)/(3,3)/(3,0)/(2,-1)/(-2,1)/(-3,-3)/(-1,0) [7*|19] or /(-3,3)/(3,-3)/(1,0)/(0,3)/(0,-3)/(0,3)/(0,-3)/(2,0) [8|18*]
    And finally:
  1. To swap top and bottom layers, do /(6,6)/(-1,1) [4*|6*]

Home
Links
Guestbook


Tantrix

Original Tantrix Puzzle (Crazy Tantrix)
Hints on solving a loop puzzle
About the background of this page
The Super 5 Puzzles
Three Pyramid Puzzles
My own puzzles
The Rock
Unsolved(?) puzzles

Solution to Original Puzzle
Solutions to Super 5 puzzles
Solutions to the Pyramid Puzzles
Solutions to my own puzzles
Solutions to the Rock

Links to other useful pages:
Tantrix homepage. A very nice page including a Java puzzle game, and it also allows you to play the Tantrix Strategy Game with other people.
Tantrix UK Order it here if you are in the UK. Very fast delivery.
Mathpuzzle.com has a page about path tiles, and it has solutions to the 'unsolved' puzzles.
Tantrix Gossip Page by AlexKid and Zazza.
Glenn Rhoads' Fun Page. Has amongst many other things the Tantrix Rules and strategy taken from the manual for the game.

Original Tantrix Puzzle (Crazy Tantrix)
The original version of Tantrix is a puzzle consisting of 10 hexagonal tiles. Each tile has three lines, one red, one blue and one yellow, which go from one side to another. The aim is to tile the pieces (without leaving holes) to make a single loop using all the parts of one colour and such that the edges of all adjacent tiles match colours. Any colour loop is possible.

If we use the letters B, R, and Y for the colours (red/blue/yellow), then a tile can be described by a list of six such letters which denote the colour at each of the edges clockwise around the tile.

In the original puzzle there are four shapes of tile used:
1. Three sharp bends or 'corners':
BBRRYY tile BBRRYY (30)
2. A straight and two corners:
BBRYYR tile BBRYYR (32) | BBYRRY tile BBYRRY (31)
3. A straight and two shallow bends:
BRYBYR tile BRYBYR (36) | RBYRYB tile RBYRYB (35) | YBRYRB tile YBRYRB (34)
4. A corner and two bends:
BBRYRY tile BBRYRY (41) | BBYRYR tile BBYRYR (42) | YYBRBR tile YYBRBR (37) | YYRBRB tile YYRBRB (38)

Note that four more tiles are possible but not included in the set: YYRRBB (3 corners but mirror image of the above), BRRBYY (straight blue and two corners), RRBYBY and RRYBYB (red corner and two bends).

Therefore there are only 14 possible tiles with these three colours, because the type of tile with three straight (e.g. YRBYRB) is not used. With an extra colour (green) there are 4·14=56 possible tiles. Such a full set is available, and allows for many other puzzles as well as a clever multiplayer strategy game. The numbers in brackets are the numbers of the tiles using the standard 1-56 numbering that Tantrix uses.

Note that the original Tantrix puzzle may have a different colour combination than that above. For a present I received second set of 10 Tantrix pieces, but these used green instead of yellow. Other than that they are exactly the same. It is possible to combine the two sets, to make a larger puzzle. Below for example is a solution for a large red loop. A blue loop is more difficult, and I leave that to you.

Hints on finding a solution to any loop puzzle:
Before you read on, please be aware that these hints will make it quite easy and may spoil your enjoyment of the puzzle.

  1. First decide which colour you are going to make the loop from. If you are doing the original puzzle, any colour can be solved. The Super 5 puzzles Junior/Student/Master (see below) only allow one colour to be looped. It is not hard to decide which colour to use. For example, if a colour has an odd number of bends it cannot be looped. Similarly if two colours cross an odd number of times, neither colour can be looped.
  2. A good strategy is to make a loop of your chosen colour, completely ignoring the other colours. Then swap pairs of pieces that leave the loop intact but fix the other lines so that the colours match up.
  3. In my first original puzzle, yellow crosses with blue on only two tiles. Therefore when making a blue loop, a yellow line must enter and leave the loop using the two crossing tiles available. Similarly, a yellow loop must have a blue line entering and leaving using those two tiles.
  4. Every tile which lies mostly inside a blue/yellow loop will also have to have the yellow/blue line going over the tile.
  5. When making a blue/yellow loop, use hints 3 and 4 above to plot how you want the yellow/blue line to run. Note that the crossing over the straight edge is fixed because there is only on straight part, but the crossing over the bend can be placed elsewhere on the loop. Use swaps to place the line along the path you plotted. The rest of the tiles inside the loop will then match up.
  6. Once the loop and its insides are correct, make swaps of tiles which lie mostly outside the loop to correct any faults until all tiles match up.
  7. If you make a red loop, there are four yellow and four blue crossings. In this case choose one of the two colours, and plot two lines that go into and out of the loop, and that together go through every tile that lies mostly inside the loop.

About the background of this page
The background image used on this page consists of a repeated pattern using the ten tiles of the Original Puzzle. It was quite difficult to find a ten-tile shape that can be tiled easily. I do not believe that there is such a shape that tiles the plane with only translations, and that only shapes that need rotations as well are possible. What makes it harder is that the background image must be rectangular. In the end I plumped for a shape that combined with an upside down copy of itself forms a 4 by 5 diamond. By making sure its edges were such that the diamond could be tiled in a regular rectangular manner, the eventual background image would remain fairly small. I found several solutions, but this one is the only one I found that has infinitely long lines of all three colours, and only one loop. I did not find any with only loops or only lines that use ten tiles, but have not done an exhaustive search.
I did find a very nice 9-tile shape (3x3 diamond) that tiles the plane (without rotations) and has only loops, and another that has only lines. The trouble with these however is that they do not tile in a rectangular way, so the background image would have to be quite large and contain many copies if this shape (18 in fact), or be skewed in some way. The tiling patterns are shown below. Click on them to see the large rectangular tile that would be needed for a background.

The Super 5 Puzzles
I have recently acquired the full set of 56 tiles. In the booklet several puzzles are given. The full set can be separated into 5 separate sets, which are called the 'Super 5' puzzles. They are called Junior, Student, Professor, Master, and Genius. These are sold separately as well.

In the Junior, Student and Master puzzles the aim is to make a loop of one colour, just like the Original puzzle. Of course, the loop must include all the tiles with that colour, and the tiles may not enclose a hole. In the Professor puzzle the aim is to make two simultaneous loops. Again each loop must use all the tiles of that colour. Tiles which have both chosen colours must therefore be incorporated in both loops. The Genius puzzle is extremely difficult, as now you must make two lines instead of loops. The restrictions that loops impose do not apply to this puzzle. It has two solutions (red/blue, red/yellow), and it took me about a week to find both solutions.

Junior

BBRRYY (30)
BBYYRR (29)
BBYYGG (15)

BBRYYR (32)

BGYBYG (22)

BBRYRY (41)
GGBYBY (25)
GGYBYB (26)
RRYBYB (40)
YYBGBG (23) 		Student

BBGGRR (43)
GGRRYY (1)

GGBRRB (47)

BGRBRG (50)
GRYGYR (7)
RBGRGB (49)

GGBRBR (51)
GGRYRY (11)
RRGBGB (54)
RRGYGY (13) 		Master

GGYYRR (2)

BBGRRG (45)
BBYGGY (17)
RRGYYG (4)

RGYRYG (8)
YGRYRG (6)

BBGYGY (27)
GGRBRB (52)
GGYRYR (12)
RRBGBG (53)
YYGBGB (24)
YYRGRG (9) 		Professor

BBGGYY (16)

BBRGGR (46)
GGRYYR (5)
RRBYYB (33)

GBRGRB (48)
GBYGYB (21)
YBGYGB (20)

BBRGRG (55)
BBYGYG (28)
RRBYBY (39)
RRYGYG (14)
YYGRGR (10) 		Genius

BBRRGG (44)

BBGYYG (18)
BBYRRY (31)
GGBYYB (19)
GGYRRY (3)

BRYBYR (36)
RBYRYB (35)
YBRYRB (34)

BBGRGR (56)
BBYRYR (42)
YYBRBR (37)
YYRBRB (38)

Solutions to Super 5 puzzles

Three Pyramid Puzzles
Three puzzles that are mentioned in the booklet of the Tantrix game use 15 tiles, and they all have solutions in a pyramid shape, i.e. a size 5 triangle. In puzzle 1 you have to make a red loop, in puzzle 2 two loops using any two colours (like the Professor puzzle), and in puzzle 3 two lines of any two colours (like the Genius puzzle). Puzzle 3 is extremely hard to solve. The tiles to use are listed below:

Puzzle 1
Make a red loop.

GGRRYY (1)
BBYYRR (29)

GGRYYR (5)
BBYRRY (31)
BBRYYR (32)
RRBYYB (33)

YGRYRG (6)
RBYRYB (35)

YYRGRG (10)
YYGRGR (9)
GGYRYR (12)
RRYGYG (14)
YYRBRB (38)
RRYBYB (40)
BBRYRY (41) 		Puzzle 2
Make two loops.

GGYYRR (2)
BBGGYY (16)
BBGGRR (43)
BBRRGG (44)

GGYRRY (3)
GGRYYR (5)
BBYRRY (31)
BBRYYR (32)
BBRGGR (46)

GGRYRY (11)
GGYRYR (12)
RRGYGY (13)
RRYGYG (14)
BBRYRY (41)
BBYRYR (42) 		Puzzle 3
Make two lines.

GGYYRR (2)
BBGGYY (16)

BBYGGY (17)
BBGYYG (18)
BBRYYR (32)

GBYGYB (21)
BGYBYG (22)
YBRYRB (34)
GBRGRB (48)

GGYRYR (12)
RRGYGY (13)
YYBGBG (23)
YYGBGB (24)
BBGYGY (27)
GGBRBR (51)

Solutions to the Pyramid Puzzles

My own puzzles

  • The Master puzzle above has many solutions. I found about 30 solutions in one evening. The loop in a solution has both convex and concave parts. Usually three tiles are involved in the concave parts (the 'dents' if you like). As far as I know there is only solution in which only two tiles are part of the concave sections of the loop. Find it.
  • The unsolved line problem can also be done using only three colours. In other words, using the 14 tiles with only three of the colours make a shape with the longest three lines. Only the longest line of each colour counts, and the aim is to make the sum of the three lengths as large as possible. The highest possible total length is 32, and I have two solutions to it.
  • From the full set, take the 12 pieces which have a straight line and two bends. Try to make a triangle with sides of length 5 but with its tips missing. In other words, the shape with rows of lengths 2,3,4,3.
  • Do the same as the previous puzzle, but with the 12 pieces which have a straight line and two corners.

  • Take the 8 pieces which have 3 bends, and any single piece with a corner and two bends (e.g. RRBYBY). Try to make any shape containing 5 circles.

Solutions to my own puzzles

The Rock:
The Rock is a three-dimensional version of Tantrix. It has the shape of a truncated octahedron, which has 8 hexagonal faces and 6 square faces. There are hexagonal and square tantrix tiles which attach to these faces, and the aim is of course to place all these tiles so that all the coloured lines match up. This means that each colour will be one or more loops on the surface of the rock. Instead of taking the tiles off completely and trying to solve it, it is also possible just to rotate the tiles in place which makes for an easier puzzle.
The tiles are as follows:
Hexagonal tiles:
BBYRYR, BBRYRY, YYBRBR; BRYBYR, RBYRYB; RBBRYY, BRRBYY; BBRRYY
Square tiles:
BRBR, BYBY. RYRY, BBRR, BBYY, RRYY
This puzzle has only 5 solutions.

Solutions to the Rock

Unsolved(?) Puzzles:
There are two unsolved puzzles, using all 56 tiles. The first is to find an arrangement with the four longest lines, one of each colour. Only the longest line of each colour counts, and the best is the one with the longest total length. The current record according to the tantrix homepage is 146=40+37+35+34. Note that since all possible tiles are in the set, any solution can be rearranged such that the colours are swapped around.

It can be proved that 146 is the maximum attainable.
Sketch of proof: Consider an arrangement with 4 lines of total length 146. A line of length n uses n tiles, and therefore involves 2*n tile sides. Of these, 2*n-2 sides are internal, and 2 sides are the endpoints. The 4 lines will therefore use 2*146-8=284 internal sides of tiles. The 56 tiles have 5*56=336 sides all together, leaving 336-284=52 sides along the outside of the arrangement. Longer lines would leave fewer external sides. The size 5 regular hexagon with one edge shaved (i.e. a hexagon with sides 5, 5, 5, 4, 6 and 4) is the shape with the smallest possible perimeter, namely 52. Therefore the lines cannot be longer than 146.
The difficult step is proving that the hexagon shape has the smallest perimeter. I have proved this, in a long and tedious manner as follows: first show that the best shape is nearly convex, i.e. has at most one tile with one external edge. Then write the number of tiles in each row in a list, and show that with the best shape the list will look something like this: 7, 8, 9, 10, 9, 8, 5, i.e. first strictly increasing then decreasing and with successive differences equal to 1 except possibly for the last one. This leaves only a relatively small number of possibilities, and of these the sequence 6, 7, 8, 9, 10, 9, 8, 7, 6, 5 is the best.

The second unsolved puzzle is to find the arrangement with the four longest loops. The current record is 136=38+35+33+30.

It can probably be proved that 136 is the maximum attainable.
Sketch of proof:Any shape with 56 tiles must have some tiles with an odd number of external sides, because they cannot be arranged in a triangle (tiles with 4 external edges are at a 60 degree corner, with 2 external edges along a straight side of the arrangement). Each tile with an odd number of external sides must have at least one line connecting to an internal with an external side. Thus any such odd corner will be the start of a line leading into the arrangement, wasting internal sides which are better used for forming loops. The best shape is therefore one with a small perimeter, but which has few odd corners and has its odd corners close together.
Consider a size 10 triangle with one extra tile added anywhere on its side. This has perimeter 62, and its two odd corners are adjacent so these waste only 2 internal sides. This leaves 336-64=272 internal sides for a total loop length of 272/2=136. Any other shape with more odd corners that is more convex will have a smaller perimeter but all the internal sides gained are wasted on the lines between the odd corners. No other shapes have more available internal sides.
Again the difficulty is proving that this shape is the best. I have not properly proved this.

Solutions to Original Puzzle
Here are three solutions of the original Tantrix puzzle, one of each colour. There are dozens of possibilities for each, so these are only examples.

Original Blue Solution Original Yellow Solution Original Red Solution

Here is a solution for a large red loop with two sets combined. A blue loop is a little more difficult, and I leave that to you.
Double Original Red Solution

Solutions to the Super 5 Puzzles:
While the professor and Genius solutions are essentially unique, the others have other solutions than those given here.

Junior loop puzzle. Only a blue loop is possible. Junior Solution | Student loop puzzle. Only a green loop is possible. Student Solution | Master loop puzzle. Only a green loop is possible. Master Solution
Professor double loop puzzle. Only a blue/yellow loops are possible. Professor Solution | Genius double line puzzle. The red/yellow solution: Genius Red/Yellow Solution | Genius double line puzzle. The red/blue solution: Genius Red/Blue Solution

Solutions to the pyramid puzzles:

Pyramid Puzzle 1.
Red loop.
Pyramid 1 Solution 		Pyramid Puzzle 2.
Red/Yellow loops.
Pyramid 2 Solution 		Pyramid Puzzle 3.
Red/Blue lines.
Pyramid 3 Solution

Solutions to my own puzzles:

Master Puzzle Loop with only two concave pieces Master solution 2 | Three line puzzle Total length= 9+11+12=32 Three lines solution 1 | Three lines solution 2
Straight + Bends Striaght+Bends | Straight + Corners Striaght+Corners | Five Rings Five Rings

Solutions to the Rock:

Rock Solution 1 Rock Solution 2 Rock Solution 3 Rock Solution 4 Rock Solution 5

Home
Links
Guestbook


Useful Mathematics

On this page I will try to explain some mathematics that applies to the cube, mostly group theory. Along the way we will see how this theory can be used to find a solution to the Rubik's Cube or in fact nearly any other permutation puzzle.

Permutations
The parity of a permutation
Disjoint cycle notation
The Order of a permutation

Groups
Conjugation
Commutation
Size of the group
Subgroups
Centre
Supergroup

Metrics

God's Algorithm

Burnside's Lemma

Permutations

Suppose you have the list of numbers 1,2,3,4,5,6,7,8. A permutation of these numbers is simply another list of these numbers in any order, for example 4,2,6,1,3,5,8,7. Every number on the list must be used exactly once.

At first sight this is not related to the cube, but suppose you write down the corner pieces of the cube in a list. Any move on the cube then mixes the corner pieces, and therefore corresponds to a new list with the same corner pieces in a different order. Any move (or move sequence) is therefore a permutation of the corner pieces. Of course, the same can be said of the twelve edge pieces.

By examining what permutations can do, we can therefore examine how the pieces of the cube move. The numbers in our list which we permute are not really important. What is important is how they move. Usually a permutation uses numbers, but these number can represent any items, for example the moving pieces of the cube, or any other objects that can be rearranged. A permutation therefore embodies only the movement of the items.

There are many different ways to write down a permutation. A common way is to write the original list of numbers on one line, and the new list directly below it on another line. For the list of numbers above, we get

1 2 3 4 5 6 7 8
4 2 6 1 3 5 8 7

To make this more visual, we can make a line diagram by drawing straight lines between the lists to show exactly how each item on the list moves.
permutation 1

In this example the lines cross 8 times, so we can say that 8 is its crossing number.

An important aspect of permutations is that they can be combined. On the cube for example one sequence of moves can be followed by another. In other words, the pieces are rearranged in one way, and from that new position they are rearranged in another way. Suppose we combine the permutation above with the following permutation:
permutation 2

Only the movement is important, so even though this second permutation is also written using the numbers 1 to 8, when we combine them, we only look at the lines, i.e. at what movement the permutation indicates. To combine them, we draw the line diagrams one below the other and follow the lines:
permutations 1 and 2

By straightening the lines we get:
permutation 3

Lets look at the crossing numbers of these permutations. The first two have crossing numbers 8 and 15. The combined drawing therefore has 15+8=23 crosses but when the lines are straightened, we get a crossing number of 11. If you think of the lines as loose threads, and that you physically untangle them, you will see that each time you uncross two threads, the number of crossings always decreases by 2. When you untangle all the threads, the number of crossings then decreases by a multiple of 2. Therefore, although the final permutation's crossing number is not simply the sum, it will have the same parity as that sum (i.e. will also be even or also be odd). Lets call a permutation odd if its crossing number is odd, and even if its crossing number is even. This is the parity of the permutation.

It is now easy to see that when combining permutations, their parities follow the same rules as numbers: odd+odd=even, even+even=even, odd+even=odd and even+odd=odd.

On the Rubik's Cube, a single quarter turn of a face is an even permutation. To see this, number the corners of the face 1-4 and the edges 5-8. A quarter turn is then represented by the permutation 2,3,4,1,6,7,8,5 which has crossing number 6 if you draw it. Combining even permutations will always give another even permutation, so only even permutations of the pieces of the Rubik's Cube are possible. This shows that it is impossible to swap two pieces (edges or corners) without moving anything else.

Disjoint Cycle Notation

A different but very useful notation for permutations is disjoint cycle notation. In this notation, the first permutation we used becomes (14)(356)(78). This means that 1 moves to the position that 4 was in, and 4 moves to the position that 1 was in. Piece 3 moves to the position that 5 was in, 5 moves to where 6 was, and 6 moves to where 3 used to be. Pieces 7 and 8 swap places just like pieces 1 and 4. Piece 2 does not move because it is not mentioned, although you could state so explicitly by including the 2 like this (14)(2)(356)(78).

Each bracketed part of this is called a cycle. (14) and (78) are 2-cycles, and (356) is a 3-cycle. These cycles are called disjoint because they use different numbers, and so act on different pieces. It is easy to see that the parity of a 2-cycle is odd, and that of a 3-cycle is even. The combined permutation (14)(356)(78) is therefore odd+even+odd=even. In general the parity is an n-cycle will be the parity of n-1 for any number n.

The order of a permutation

The order of a permutation is the number of times it has to be performed before the pieces are back to their initial positions. This is where cycle notation is very useful. A 2-cycle is a single swap, so if this is performed twice then the pieces are back where they started. A 2-cycle therefore has order 2. Similarly, a 3-cycle will have order 3, and an n-cycle order n. Now lets consider a permutation like (14)(356)(78) which is composed of several cycles. If it is performed twice, or in fact any even number of times then the 2-cycles will disappear. If it is performed three times or any multiple of three, then the 3-cycle will disappear. If it is performed 6 times, which is a multiple of both 2 and 3 then all the cycles disappear and this permutation therefore has order 6. In general, the order of a permutation is the lowest common multiple of the lengths of the disjoint cycles.

Lets see how this applies to the cube. Consider the move sequence FR. If we look at how this moves the pieces, we see that the UFL corner moves to position RUB, piece RUB moves to position RBD, and so on. In cycle notation this permutation is as follows: (UFL,RUB,RBD,RDF,DLF)(UF,RU,RB,RD,RF,DF,LF) This is a 5-cycle of corners and a 7-cycle of edges. Its order is therefore 35, which means that if you constantly repeat the moves FR on the cube, you will have to do it 35 times before the pieces come back to their original positions. If you try this out on a solved cube you will see that although this is true, the cube is not restored because some corners are twisted. We have only looked at the location of the pieces, and not their orientation.

Groups

The collection of all possible permutations of n items form a group. A group is simply a collection of things which satisfy various conditions, which I will list below. We use these conditions implicitly whenever we use permutations, so it is best to state them explicitly now:

  1. Any two elements of the group can be combined, and this results in another element of the group. As you have seen, two permutations can be combined by performing one after the other, and this will always result in a permutation. If P and Q are permutations, then PQ will mean the permutation resulting from performing first P and then Q.
  2. There is an identity, i.e. an element I in the group such that for any element P in the group we have PI=IP=P. In a permutation group the element I is simply that permutation that does not move anything.
  3. Every element has an inverse, i.e. if P is an element of the group then there is an element Q in the group such that PQ=QP=I. If you mirror the line diagram of a permutation vertically, you get the line diagram of its inverse. A permutation in cycle notation can be inverted just by writing each cycle in reverse. The inverse of permutation P is denoted by P-1, or by P'. On puzzles, you can do the inverse of a move sequence just by undoing the moves in reverse order, i.e. taking back the moves you did.
  4. The multiplication is associative, i.e. if P, Q and R are elements of the group, then (PQ)R=P(QR). With permutations this is obviously true.

If a group is commutative, i.e. we have PQ=QP for any P, Q in the group then it is called an Abelian group. This phenomenon occurs in the Lights Out puzzle and the Rubik's Clock, and makes these puzzles much simpler because the order in which the moves are performed does not matter. Generally permutation groups occurring in puzzles are not Abelian.

All possible movements of the pieces on the Rubik's cube also form a group, the Cube Group. At first sight this is not a simple permutation group because the orientation of the pieces matters, but you could consider it a permutation group of the 48 moving facelets instead of the 20 moving pieces. On a pedantic note, it is technically incorrect to say that the positions of the Rubik's cube form a group. A position is reached from the solved cube by moving the pieces in some way, and it is those movements that form the group because movements can be combined. On the standard Rubik's Cube this is not a very important distinction, but on other puzzles like the 4x4x4 Cube it is. That puzzle has centre pieces which look the same, and so there are positions which are indistinguishable from each other. Thus different permutations seem to correspond to the same position, or permutations which seem to do nothing in one position will change things in another.

Conjugation

If P and Q are elements of a group, then the conjugate of Q by P is the element PQP'. This is one of the most useful concepts for solving a puzzle like the cube. Lets illustrate this with an example on the Rubik's Cube. Suppose you know that the move sequence Q = R'LF2RL'U2 cycles three edges around, viz. (UB,UF,DF) but that you want to cycle 3 other edges of the cube, for example (UR,UF,UL). We would know how to cycle them if they where placed at UB, UF and DF, so we simply put them there, for example by doing the sequence P = F2U. This sequence moves other pieces as well, but that does not matter. So after we put them in position with P, cycled them with Q, we put everything back by doing P'. The relevant edges have been cycled as we wanted them to, and any other pieces that were moved by P are put back by P'. Therefore PQP'= F2U R'LF2RL'UF2 cycles just the edges (UR,UF,UL).

As you can see from this example, if you have a sequence that performs a certain task on a particular pieces of the puzzle, conjugation will allow you to perform the same task on any other similar pieces of the puzzle instead. So, if you can flip two edge pieces then you can flip any two of them, or if you can twist two corners then you can twist any two of them, and so on.

Commutation

Conjugation allowed you to apply a specific sequence more generally, but you still need to find that specific sequence to begin with. That is where commutation is useful. If P and Q are elements of a group, then PQP'Q' is called a commutator. If P and Q commute (for example they are disjoint, like the moves R and L on the cube) then PQP'Q'=QPP'Q'=QIQ'=QQ'=I. The commutator can be seen as an indication of whether P and Q commute, and by how much. If P and Q are nearly disjoint, then the commutator will move fairly little, and is therefore often performs a useful function when solving a puzzle.

The simplest commutator on the cube uses single face moves for P and Q, for example FRF'R'. This cycles three edges (FU,FR,UR), and two pairs of corners (FLU,RUB) and (FUR,FRD). Note that corner FLU moves to RUB, which in turn moves to UFL. This is twisted anti-clockwise compared to the original position FLU, so if we perform this cycle twice, these two pieces will be back to their original positions but will both be twisted anti- clockwise. The other corner 2-cycle of FRF'R' twists clockwise. We could adapt cycle notation to show this as follows:
FRF'R' = (FLU,RUB)- (FUR,FRD)+ (FU,FR,UR)
Doing this twice, we get:
(FRF'R')2 = (FLU)- (RUB)- (FUR)+ (FRD)+ (FU,UR,FR)
Doing this three times, we get:
(FRF'R')3 = (FLU,UBR) (FUR,FRD)

Theoretically these moves and their conjugates are enough to perform any even permutation on the corners, and any even permutation on the edges. Any single quarter turn of a face is an odd permutation on both corners and edges, so just using what we have so far we could position all the pieces of the Cube. What remains is just to orient them.

Commutation works best when P and Q are nearly disjoint. Therefore lets choose Q to be a turn of the U face, and P so that it affects only a single piece in the U face. An extremely useful choice is the monotwist P = R'DRFDF'. This twists one corner (URF)+ and does not affect anything else in the U layer. The bottom half of the cube is messed up but that does not matter. We now have the following very useful sequences:
PUP'U' = R'DRFDF'UFD'F'R'D'RU' = (URF)+ (UBR)-
PU2P'U2 = R'DRFDF'U2FD'F'R'D'RU2 = (URF)+ (ULB)-
PU'P'U = R'DRFDF'U'FD'F'R'D'RU = (URF)+ (UFL)-
You can now twist any two corners on the cube.

Other good choices for P are the monoflip P = FUD'L2U2D2RU = (FU)+, which will allow you to flip any edges on the cube, and P = R'DR which gives you a simple 3-cycle of corners.

It is also productive to let Q be a move of a middle slice, for example Rm. If we let P = F2, which is a monoswap of edges (DF,UF) in that slice, then we get a 3-cycle of edges F2RmF2Rm' = (DB,DF,UF) and the 4-H pattern F2Rm2F2Rm2 = (DF,UF)(DB,UB). If P = Fm we get the 6-spot pattern, P=Fm2 gives the 4-spot pattern and P = FU'RF'U is a neat monoflip (FU)+.

Size of the group

You may have noticed that when you use a commutator for twisting corners, you will always twist two corners in opposite directions. Commutators can also only flip pairs of edges. It turns out that this is enough to solve the cube because it is impossible for a single piece to be turned.

Every corner piece has one facelet that belongs in the U or the D face. For a corner which has been moved anywhere on the cube, lets define its twist as follows:

  • Its twist is 0 if its U/D facelet is in the U or D face.
  • Its twist is +1 if the piece has been turned clockwise from the 0 twist orientation.
  • Its twist is -1 if the piece has been turned anti-clockwise from the 0 twist orientation.
Twisting a corner clockwise will increase its twist by one. We have to work modulo 3 however, because 3 twists is the same as no twist at all. Similarly anti-clockwise twisting decreases the twist by one modulo 3.

If you turn the U or the D face, the twist of the corner pieces do not change. If you turn any other face a quarter turn, then the twist of two of the corner pieces increases, and the twist of the other two corners decreases. In any case the total twist of all the corners does not change modulo 3. In the starting position the cube has total twist 0, and this therefore remains 0 however mixed up the cube gets. This shows that it is impossible to twist a single corner in isolation, and that if you twist only two corners then they must go in opposite directions.

A very similar method can be used on the edges; define the flip of an edge as 0 or 1 (modulo 2) and show that the total flip is 0, which means that no edge can be flipped in isolation. Another way is by looking at the permutations of the edge facelets. A quarter turn of a face is an even permutation of the facelets (two 4-cycles) so only even permutations are possible. A single edge flip is an odd permutation and hence not possible.

We can now calculate the size of the group (the number of permutations in the cube group), and hence the number of different positions that the cube can reach. Suppose we have taken the cube apart and are trying to assemble it again. When we fill the first edge position, there are 12 edge pieces we can choose from. When placing the next edge there are 11 pieces to choose from, and so on. This means that there are 12! = 12·11·10·9·8·7·6·5·4·3·2·1 combined choices we can make. The first 11 edges we place can be either flipped or not, but the last one's orientation is determined by the others. The edges can therefore be placed in 12!·211 different ways.

Similar reasoning shows the corners can be placed in 8!·37 ways. This does not however take into account that the piece permutation must be even, and we should take care of this when placing the last two corners. Hence there are only 8!·37/2 ways they can be placed after the edges have been done.

The total number of positions is then 12!·211·8!·37/2 = 4.3·1019. From the discussion about conjugation and commutation you can deduce that all of these positions can indeed be reached (and solved). Note that if you put the cube together at random without watching out for the constraints then there are 12!·212·8!·38 possibilities. This is 12 times as many as there are reachable positions, so you would have only 1 in 12 chance of the cube being solvable.

Subgroups

The Rubik's cube group is generated by the moves {F, B, R, L, U, D}, because by definition any movement of the pieces is done by moving the faces one at a time. Suppose instead that from a solved cube you only do half turns, i.e. you only use the moves {F2, B2, R2, L2, U2, D2}. Clearly this does not generate the whole cube group; for a start each face of the cube never has more than two colours. Nevertheless, the permutations these moves generate do form a group because any two permutations made from half turns will combine to give another permutation made from half turns. This group is usually called the Square Group.

The Square group is called a subgroup of the Cube Group, because it is a subset of it and is a group in its own right. There are many pretty patterns in the square group, and no doubt you already know some of them. The 4-spot pattern for example can be made by R2L2U2R2B2R2L2F2L2U2, which is 10 half turns. It can be reached in fewer turns if you allow the cube to temporarily leave the square group by using quarter turns. The 4-spot can be reached in 8 turns by R2L2UD'F2B2UD'.

There are other interesting subgroups of the Cube Group, for example the slice group (generated by all slice moves: FB', RL', UD'), the antislice group (generated by all antislice moves: FB, RL, UD), and many others.

It is a strange fact that you only need 5 faces to solve the cube. In other words, {F, B, R, L, U} generates the whole Cube Group. This is obvious once you realise that the sequence P = R2L2U2R2B2R2L2F2L2U2, which does the 4-spot, moves all the pieces from the D layer to the U layer in the same relative positions without turning the D layer, so that PUP' has the same effect as D. The same reasoning shows that the whole square group is also generated by just 5 faces.

Centre

One particular subgroup that is fascinating is the centre of the Cube Group. The centre of a group consists of all elements which commute with everything, i.e. if C lies in the centre, then CP=PC for all elements P in the group. Since CP=PC means that PCP'=C, the element C does not change under any conjugation. The only way for this to be true is if it does not move any piece from its place. Also, if C twists one corner, then by conjugation it must twist all corners in the same direction which is not possible on the cube. Similarly, if it flips one edge then it must flip all of them, and this is possible on the cube. The only elements in the centre are therefore the identity I and the Superflip which flips all 12 edges.

The superflip can be done by the sequence: [(RmU)4 RcDc]3. This rather cryptic sequence will need a little explanation. The notation Rm is used to denote a move of the middle slice adjacent to the R face in clockwise direction if you look at it from the R side. You have to do RmU four times. Now you have to do RcDc which are rotations of the whole cube in the same directions as the moves R and D (these two cube rotations together are the equivalent of a rotation about the UFL corner). Now you have to repeat everything you have done so far twice more (3 times all together).

The fact that the Superflip commutes with everything can be used for some impressive tricks. Suppose you apparently mix the cube up, but actually perform the Superflip (S). You hand the cube to someone and ask them to do one or two random moves (P) and then hand it to you behind your back. You have not seen which moves he did, nor which way up the cube is handed to you, and yet you seem to solve it behind your back. Simply perform the Superflip again, and bring it out to the front while you say that you are nearly finished. The cube will only need one or two moves to be solved which can be done instantly by sight. This works because SPS = SSP = IP = P so you only need to undo the few random moves that the cube was given.

The wonderfully clever magician Jerry Sadowitz came up with the following idea based on this. You show two Rubik's Cubes, both of which are mixed up differently. You ask someone to mix the cubes further, as long as every move that is performed on one is also performed on the other. You do not see these moves, and yet when you are handed either one of these cubes behind your back, then without even seeing the other cube you can mix yours so that it is the same as the other one. You should be able to figure out how this works now.

Supergroup

On the Rubik's Cube the centre pieces of each face do not change position, but they do rotate. On a normal cube this is not visible, but there are cubes with pictures or other designs on them where the orientation of the face centres does matter. Each quarter turn is an odd permutation on the corners of the cube (and also odd on the edges), so it is impossible for a face centre to move a quarter turn without any other pieces moving. It is possible however for a single centre to do a half turn in isolation, or for two centres to do a quarter turn without other pieces moving. The group of all permutations of a cube with visible centres is called the supergroup. It is 46/2 = 2048 times as large as the normal cube group.

By using commutators it is not very hard to move centres. For example let P be the 6-spot pattern (e.g. RmFmRm'Fm') and Q a face turn (e.g. U). The result is then a sequence which turns one face centre clockwise, and an adjacent face centre in the opposite direction. The sequence RL'FB'UD'R'U'DF'BR'LU which turns centres U and R' is derived that way. For opposite faces you could use the 4-spot instead, and this gives RL'F2B2RL'URL'F2B2RL'D' which turns U and D' centres. A short sequence for a half turn of a face centre is more difficult to find. Let P be the sequence RLU2R'L'U2. This swaps one pair of opposite corners and one pair of opposite edges in the U layer. Commuting it with U therefore gives you a sequence which has the same effect as U2 on the corners and edges, but which does not move the U centre. Follow it with U2 and you have only moved the U centre. Thus (RLU2R'L'U)2 will move the centre U2.

Metrics

It would be nice if we could measure how far away a cube is from being solved. If we could do this perfectly, we would be able to solve the cube in the quickest possible way simply by doing any move that brings it closer to the solved position. This quickest way is usually called God's Algorithm. It is of course not so simple to measure distances on the cube. In mathematics, a measure of some kind of distance between two points is called a metric. A metric D is a function which should satisfy a few fairly obvious conditions:

  1. D(a,b)>=0, or any distance is positive or 0.
  2. D(a,b)=D(b,a), or the distance from a to b is the same as from b to a.
  3. D(a,b)=0 if and only if b=a, or distances between differing points are always non-zero, and the distance from one point to itself is always zero.
  4. D(a,b)+D(b,c)>=D(a,c), also called the triangle inequality, means that if you go from a to c, the distance can only get longer if you detour via b.

On a cube, a reasonable metric would be the minimal number of moves to get from on position to the other. You can check that the conditions above are true, provided that the inverse of a single move is also considered a single move.

There are however several different opinions as to what constitutes a single move. Some people prefer the Quarter Turn Metric (QTM), i.e. only a quarter turn (in either direction) of a face is considered a single move, while other people use the Half Turn Metric (HTM) in which half turns are also considered to be a single move (this is also called the Face Turn Metric, and is often denoted by q+h). For example the Pons Asinorum or the 6X pattern reached by the sequence U2D2F2B2R2L2 is 12 moves from start in QTM but 6 moves in HTM. Some people even consider a slice move as a single move, and in this Slice Move Metric (SMM) the Pons would be only 3 moves from start.

The example of the 6X pattern above works only because it is known that it cannot be reached by a shorter route in any of the metrics used here. To prove this for the QTM, consider that each of the 12 edges needs 4 quarter turns to get into position, each move only moves 4 edges, and so you need at least 12 moves to reach/solve the 6X position.

Generally if you look at a move sequence, counting the number of moves in the sequence will only give you an upper bound for its distance from start. There may well be a shorter, more direct sequence. You can even prove this obvious result by using the triangle inequality.

God's Algorithm

God's Algorithm is the solving algorithm that always solves the puzzle in the fewest number of moves. At the moment this algorithm is not known for the Rubik's Cube, but for several smaller puzzles like the Skewb, the Pyraminx, the Diamond, and the 2x2x2 Cube it is known.

It is usually calculated by computer as follows:

  1. Set up a large array with entries for every possible position of the puzzle.
  2. Mark the solved position (or positions) as being at distance 0.
  3. If all positions of distance <=L are known, then those at distance L+1 can be found like this: For each position at distance L, try all possible moves. If an unknown position is reached, then that must be at distance L+1.
  4. Repeat step 3 until all positions have known distance.

This method requires a lot of memory, at least 2 bits for each possible position, so it is not practical for the Rubik's Cube and is not likely to be in the near future.

We can however find some simple lower bounds. Suppose we begin from a solved cube, and try to count how many positions that can be reached in a certain number of moves (HTM). There are 6·3=18 choices for the first move. We can assume we don't move the same face twice in succession, so there are 5·3=15 choices for the second move, and the same for each subsequent one. The total number of positions that can be reached in n moves is therefore at most
1+18+18·15+18·152+18·153+....+18·15n-1
This is of course an overestimate, because many positions can be reached in several ways. This number first exceeds the total number of positions the cube has when n=17, so there are positions which need at least 17 moves to solve. A better counting argument that takes into account that RL=LR etc gives n=18.

If we use the QTM, then the same argument gives as an upper bound on the number of positions reachable after n moves:
1+12+12·11+12·112+12·113+....+12·11n-1
Here we get n=19, but this can be much improved because it does not take into account that no more than 2 consecutive quarter turns of the same face is ever done. The best calculations show that some positions require at least 21 quarter turns.

These lower bounds have been improved upon, mostly by computer searches, by showing that certain positions need more moves to be solved. The superflip for example has been shown to need at least 20 moves in HTM, or at least 24 moves in QTM. The position reached by combining the 4-spot pattern and the superflip needs at least 26 moves in QTM.

Every algorithm that can solve the cube will take longer than God's algorithm, and therefore we have upper bounds for God's algorithm too. The best known solving algorithms take 29 moves in HTM or 42 moves in QTM. These methods involve large computer databases and are not practical for humans.

Thus God's algorithm will have a maximum length between 26 and 42 in QTM, or 24 and 29 in HTM.

Burnside's Lemma

Burnside's Lemma is also called the Pólya-Burnside Lemma, or the Cauchy-Frobenius Lemma. It can be used for counting the number of positions of a puzzle when some of them are considered to be equal due to the fact that the puzzle is symmetric in some way. I have hardly used this on my pages at all, though in some cases I could and should have. Let me first give a simple example where it can be used.

Suppose you have a square, and each of the sides is coloured either red or blue. How many of such distinct squares are there? Here it is easy to just count them; all sides the same colour (red or blue), 3 sides of one colour and 1 of the other (again two possibilities), 2 sides of one colour and 2 of the other (adjacent or opposing). There are therefore 6 such squares.

In more difficult cases there are too many to just count them like that. You could then calculate how many there might be (here we would get 16 because each of the 4 sides has 2 possibilities, red or blue), and then see which of these are symmetric and how many times too often they have been counted. Burnside's Lemma actually does something like this.

The lemma states in mathematical terms that if G is a finite group acting on a finite set X, then the number of orbits under this action is given by taking the average number of the fixed points. In our example, the set X is simply all possible squares ignoring symmetries (i.e. all 16), the group G is all different ways we can rotate/reflect the squares, and each orbit is a complete set of squares which are the same under rotation/reflection. The number of orbits, which is what the Lemma calculates, is therefore the number of distinct squares when rotation/reflection is taken into account.

Let's calculate it now. First we must find all the symmetries of the square, i.e. all ways of rotating or reflecting it. These are:

  1. Rotation through 90 degrees.
  2. Rotation through 180 degrees.
  3. Rotation through 270 degrees.
  4. Reflection through the horizontal midline.
  5. Reflection through the vertical midline.
  6. Reflection through one diagonal.
  7. Reflection through the other diagonal.
  8. The identity.

We must include the identity (rotation through 0 degrees if you like) because we need to use the whole group of symmetries, and groups always have an identity element. Note that the pairs A and C are similar, as are D and E, and also F and G.

Now we have to count the number of 'fixed points' that each symmetry has, in other words how many of the 16 possible squares remain unchanged by each symmetry. A square can only remain the same under a 90 degree rotation if all its sides have the same colour. Therefore symmetry A has exactly two 'fixed points', and so does symmetry C.

Symmetry B has 4 'fixed points', because we must have opposite sides of the square the same colour, and each pair of opposite sides can be either colour. Note that this also includes the squares of one colour that we had with symmetry A and C. Symmetry D and E also have 4 'fixed points', F and G have 8, and finally H has 16 because all squares remain the same if you do nothing to it.

The average of these 8 numbers is therefore (2+4+2+4+4+8+8+16)/8 = 6, as we expected.

Let's now try to apply the Lemma to a real puzzle. It could be applied to count the number of shapes of the Pyramorphix, but they are much easier to count by hand. Instead, lets count the number of distinct patterns on an Orbix puzzle. This is much like the earlier example, but now we have a dodecahedron with coloured faces instead of a square with coloured sides.

To make things a bit easier we will only look at rotations, so patterns that are mirror images of each other will still be considered different. There are four types of rotational symmetries:

  1. Rotations around a face by a multiple of 1/5 of a turn.
  2. Rotations around a corner by a multiple of 1/3 of a turn.
  3. Rotations around an edge by a 1/2 of a turn.
  4. The identity.

There are 6 axes through the faces, so 6 axes about which rotation A can take place. Note that a 2/5 turn will keep the same patterns unchanged as a 1/5 turn, because doing it three times give a 3*2/5 = 6/5 turn which has the same effect. Therefore all 6*4 = 24 type A rotations keep the same positions fixed. Under such a rotation, the faces move in two 5-cycles, and two 1-cycles. Each cycle must be all the same colour, so there are 24=16 fixed points for these rotations. Similarly the 20 B rotations have 24 fixed points, the 15 C rotations have 26, and finally the identity has 212 fixed points.

The sum is therefore (24·24 + 20·24 + 15·26 + 212) / (24+20+15+1) = 96. There are 96 distinct orbix positions (if mirror images are counted as well).

If you do the same thing for all mirror symmetries (easiest to use a point reflection through the centre of the dodecahedron followed by any normal rotation) then you get the result (24·24 + 20·24 + 15·26 + 212 + 24·22 + 20·22 + 15·28 + 26) / 120 = 82.
This means there are 82 positions if mirror images are considered the same, and therefore there are 96-82 = 14 pairs of positions that are mirror images of eachother.

Home
Links
Guestbook


Topspin

Picture kindly supplied by Hendrik Haak

The Topspin puzzle is by Binary Arts, but is also sold as No. Crunch under their XEX brandname. It consists of 20 numbered round pieces in one long loop. You can slide all the pieces of the loop along. There is also a turntable in the loop which can rotate any four adjacent pieces so that they will be in reverse order. This in effect swaps two adjacent pieces and the two pieces on either side of them. The aim is of course to place the pieces in numerical order. There also exists a larger version with more pieces and a larger turntable.

The number of positions:
There are 20 distinct pieces, which can therefore be put in at most 20! possible positions. All these are attainable, so there are 20!=2,432,902,008,176,640,000 distinct positions. If rotations of the loop are considered to be the same, then there are only 19!=121,645,100,408,832,000 positions.

Links to other useful pages:
Binary Arts homepage. Homepage of the manufacturer.

Solution:
Phase 1: Place pieces 1-16.

    This is very easy. Simply find the next piece to solve and do any move that brings it closer to the solved part of the loop, but which does not move any already solved pieces. Then bring it to a position such that there are three pieces between it and the solved part and then a single turn will append it.
Phase 2: Place pieces 17-20.
First I will show a method with few moves but which I find hard to memorise. Afterwards I will show the method given in the leaflet that comes with the puzzle which is easy to remember but takes more moves.
  1. Turn the four unsolved pieces if necessary, so that as many pieces as possible are solved. If the same number of pieces is solved either way, then turn it so that piece 17 is as close to piece 16 as possible.
  2. If exactly two pieces need to be swapped, or their position is
    ...,16,19,17,20,18,1,2,...
    which needs 3 swaps to solve it, then the position is an odd permutation. Since a turn is an even permutation this can not be immediately solved. Actually all the pieces that have been solved so far are in the wrong position, and all need to be moved an odd number of places along the loop. The easiest way to do this by repeatedly turning and shifting the loop one step anti-clockwise, until all the solved pieces have been moved (i.e. 16 times).
  3. To cycle 3 pieces around, simply follow the moves shown in the table below.
    14 | 15 | 16 | 19 | 17 | 18 | 20
    14 | 17 | 19 | 16 | 15 | 18 | 20
    16 | 19 | 17 | 14 | 15 | 18 | 20
    16 | 15 | 14 | 17 | 19 | 18 | 20
    17 | 14 | 15 | 16 | 19 | 18 | 20
    17 | 14 | 18 | 19 | 16 | 15 | 20
    17 | 16 | 19 | 18 | 14 | 15 | 20
    17 | 16 | 15 | 14 | 18 | 19 | 20
    14 | 15 | 16 | 17 | 18 | 19 | 20
    14 | 15 | 16 | 17 | 20 | 18 | 19
    14 | 15 | 18 | 20 | 17 | 16 | 19
    14 | 17 | 20 | 18 | 15 | 16 | 19
    14 | 17 | 16 | 15 | 18 | 20 | 19
    14 | 18 | 15 | 16 | 17 | 20 | 19
    14 | 18 | 15 | 19 | 20 | 17 | 16
    14 | 18 | 17 | 20 | 19 | 15 | 16
    14 | 18 | 17 | 16 | 15 | 19 | 20
    14 | 15 | 16 | 17 | 18 | 19 | 20
    14 | 15 | 16 | 18 | 19 | 17 | 20
    18 | 16 | 15 | 14 | 19 | 17 | 20
    18 | 16 | 17 | 19 | 14 | 15 | 20
    18 | 14 | 19 | 17 | 16 | 15 | 20
    18 | 14 | 15 | 16 | 17 | 19 | 20
    16 | 15 | 14 | 18 | 17 | 19 | 20
    16 | 17 | 18 | 14 | 15 | 19 | 20
    14 | 18 | 17 | 16 | 15 | 19 | 20
    14 | 15 | 16 | 17 | 18 | 19 | 20
    14 | 15 | 16 | 17 | 19 | 20 | 18
    14 | 19 | 17 | 16 | 15 | 20 | 18
    14 | 19 | 17 | 18 | 20 | 15 | 16
    14 | 19 | 15 | 20 | 18 | 17 | 16
    14 | 19 | 15 | 16 | 17 | 18 | 20
    14 | 17 | 16 | 15 | 19 | 18 | 20
    14 | 17 | 18 | 19 | 15 | 16 | 20
    14 | 15 | 19 | 18 | 17 | 16 | 20
    14 | 15 | 16 | 17 | 18 | 19 | 20
    To make two swaps of adjacent pieces, then follow this sequence:
    15 | 16 | 18 | 17 | 20 | 19
    17 | 18 | 16 | 15 | 20 | 19
    17 | 20 | 15 | 16 | 18 | 19
    16 | 15 | 20 | 17 | 18 | 19
    16 | 15 | 19 | 18 | 17 | 20
    18 | 19 | 15 | 16 | 17 | 20
    18 | 17 | 16 | 15 | 19 | 20
    15 | 16 | 17 | 18 | 19 | 20
Phase 2b: Place the last few pieces - alternative method.
  1. The sequence below moves one piece along the ring, but doesn't change the order of any other pieces.
    20 | 16 | 17 | 18 | 19
    18 | 17 | 16 | 20 | 19
    18 | 19 | 20 | 16 | 17
    16 | 20 | 19 | 18 | 17
    16 | 17 | 18 | 19 | 20
  2. The sequence above shifts a piece along, jumping over three other pieces. If you keep shifting a single piece all the way around the loop once or twice, it will eventually visit every possible position (because there are 19 other pieces which are jumped over 3 at a time, and the numbers 19 and 3 are co-prime). This way each piece can be individually positioned where you want it.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Whip-It/Puzzle Tower

Pictures kindly supplied by Hendrik Haak

This sliding piece puzzle consists of several discs stacked up into a tower, and they can rotate about a central axle. There are usually 3 such discs (called the Whip-It puzzle, or Puzzle 6) but 6 discs is also quite common in cheaper knock-offs. Along the side of the tower are six columns of sliding pieces, in six colours. The pieces can slide up or down from one disc to another because one of the white pieces is missing leaving a gap. By rotating the discs, the pieces and the gap are moved around to the other columns.

This puzzle is the simplest in a family of related puzzles which includes the Ivory Tower, and Missing Link.

The number of positions:
On the 6 layer version there are 36 pieces if we include the space as a piece, which gives a maximum of 36! positions. This limit is not reached because:

  • the pieces of each colour are indistinguishable (6!5·5!)
  • the colours are equivalent (6!)
This last factor comes about because it does not matter which colour goes in which column. This leaves 36!/6!6 /5! = 22,251,481,138,642,910,394,240 or 2.2·1022 positions.

The 3 layer version has 18!/3!5/2!/6! = 571,771,200 positions.

Solution:
The tower can be solved layers, disc by disc from the bottom up, but it is just as easy to solve column by column. The latter is much easier to describe, so that is the method used here.

  1. Decide which colours the columns will have. To speed things up, you could rotate some discs to partly solve some columns already.
  2. Look at the column containing the gap, and determine which colour the column has.
  3. Find a piece of the required colour in a different column. If there are none (i.e. the gap is in the completed white column, and the puzzle is not yet solved) then find any piece on the puzzle that is incorrect.
  4. Slide pieces in the column up or down until the gap is in a layer next to the layer that contains the piece.
  5. Rotate the layer with the gap until it lies above or below the piece.
  6. Slide the piece up or down into the gap.
  7. Rotate the layer back to its original position, which brings the piece into the column as required.
  8. Repeat steps b-g until the puzzle is solved.
Note that in practice it is quicker to move not just the one layer, but all the layers above/below it as well.

Your browser does not have Javascript 1.1 capabilities. You need Netscape 3+ or MSIE 4+ to see the puzzle simulation.

Home
Links
Guestbook


Rubik's Triamid

Picture kindly supplied by Hendrik Haak

This puzzle is a triangular pyramid of 10 odd shaped coloured pieces (actually they are truncated rhombic dodecahedra) which are held together using 4 small cubical connectors. A move consists of pulling off a small pyramid of 4 pieces, and replacing it in any orientation.

The pieces have 4 faces (3 adjacent faces of the rhombic dodecahedron) which have one of four colours. For any pair of colours there is a piece with two faces of each colour. There are 6 such pieces. The other 4 pieces have three colours, so they all have one colour missing and one colour repeated on two faces. No two of them have the same missing colour, and no two of them have the same colour repeated.

In the solved position, Each side of the pyramid has a single colour. Therefore the 4 tri-coloured pieces should go in the corners, and the other 6 on the edges.

If you restrict the moves to those which don't move a corner piece from its place, then this puzzle mimics the Pyraminx.

Number of positions:
There are 10 pieces which might be arranged in 10! ways, and they each have 12 possible orientations. This gives a maximum of 10!·1210 positions. This limit is not reached because:

  • The pieces must have an even permutation (2)
  • The facelets must have an even permutation. (2)
  • The orientation of the puzzle doesn't matter (12)
This leaves 10!·1210 / 48 = 4,680,952,735,334,400 positions.
It should also be noted that there are actually 2·45 = 2048 solved positions, because the 6 middle pieces each have 4 ways they can be placed correctly, but they are restricted slightly by the second condition above.
Links to other useful pages:
Rubik's page. Has some hints for solving it.

Solution:
The moves of this puzzle are very hard to describe accurately, and I can think of no good notation for it, so this solution may be hard to follow.

Phase 1: Place the corner pieces in position.
This phase is easy, as we do not worry about the orientation of the pieces yet.

  1. First find a corner piece, i.e. a piece with three colours.
  2. Make any move that doesn't move any previously placed corners, and which brings it to a corner that has no corner piece yet. The only time when this is not immediately possible is when three corners have been placed and the fourth one lies between them. Then twisting a suitable pyramid will move the piece adjacent to its destination, and it can then be put in position as normal.
  3. Repeat the above for all four corners
Phase 2: Twist the corner pieces correct.
  1. First all corners must be twisted to show three colours, so find any corners that only show two colours and do the steps below.
  2. Let A be a pyramid of which its corner piece shows only two colours, and let B be any other pyramid. The following moves will twist the tip of A to hide one of its repeated colours. Note that the pyramids A and B have one piece in commom, which I'll call the intersection.
  3. Move pyramid A to bring its corner piece into pyramid B, i.e. to the intersection.
  4. Move B to so that the piece at the intersection is turned so that one of its faces with the repeated colour is placed inside pyramid A.
  5. Move A to place its corner piece back in position, now showing all three colours.
  6. Move B to place its corner piece back.
  7. Repeat steps b-f above till all corners show three colours.
  8. Choose one of the colours, and find the three corners with that colour.
  9. Turn the three corners to bring that colour to the same face of the puzzle.
  10. Examine the pieces to see which if them need their two remaining colours swapped to match the others. Each of those corners simply need to be moved so that the other of its two faces with the same colour is on the inside of the puzzle. The same method as we used before will work again:
  11. Let A be a tip with a corner piece which has to be mirrored, and let B be any adjacent tip.
  12. Move pyramid A to bring its corner piece to the intersection of A and B, such that the second face of the piece's repeated colour does not lie inside pyramid B.
  13. Move B so that the repeated colour is placed inside pyramid A.
  14. Move A to place its corner piece back in position.
  15. Move B to place its corner piece back.
  16. Repeat the above for other corners if necessary until all the corners match up.
Phase 3: Place the edge pieces in position. In this phase the orientations of the edge pieces are ignored, so the only moves that are needed are rotations, i.e. moves just like the Pyraminx.
  1. Find an incorrect piece (piece 1), a second incorrect piece (piece 2) which is in the place that piece 1 should be, and finally a third incorrect piece which is in the place that piece 2 should be.
  2. If these three pieces all lie in the same pyramid, A, then let B be any adjacent pyramid and do the following:
    1. Turn B clockwise (cw), A anti-clockwise (acw), B acw, A acw, B cw, A acw, B acw.
    2. The moves above will have moved the three pieces around. If they moved in the wrong direction then repeat the sequence again to fix them.
  3. If the three pieces do not lie in the same pyramid, then there are two pyramids that each contain a pair of them. Let A and B be those two pyramids. Let c be the piece that lies in both A and B, b the other piece in B and a the other piece in A.
    The following sequence moves a to b, b to c and c to a:
    1. Move B to place b correctly in the place of c.
    2. Move A to put a at c (if possible correctly twisted in relation to the B pyramid).
    3. Move B back to its original position.
    4. Finally move A back.
  4. With the two sequences above you can move all the pieces into the correct position, except possibly for the final two pieces. If you find that two pieces need to be swapped but that the remaining ones are in position then you will have to solve the puzzle with the whole pattern in mirror image. This basically means you will have to swap two of the corner pieces, and solve the whole puzzle again from phase 2.
Phase 4: Twist the edge pieces correct.
  1. Find any edge piece that only shows one colour.
  2. If there is an adjacent edge that is incorrect then use that as the second piece in the sequence below, otherwise use any correctly placed adjacent edge.
  3. Let A be the pyramid containing both pieces, and let B be the other pyramid containing the SECOND piece.
    1. Move B to place this second piece correctly twisted in position.
    2. Rotate A to bring the first piece into pyramid B.
    3. Move B back into position.
    4. Finally turn A back.
  4. Repeat the above until there are no edge pieces with only one colour showing.
  5. Find any edge piece that is upside down (i.e. its two colours need to be swapped).
  6. Let A and B be the pyramids that the piece belongs to.
    1. Move A so that the piece stays in position but still shows two colours.
    2. Move B so that it again shows two colours.
    3. Move A back into correct position (piece now shows one colour).
    4. Finally move B back.
  7. Repeat the above until all pieces are correct.

Home
Links
Guestbook


Tricky Disky

Picture kindly supplied by Hendrik Haak

This is a disk made of two layers which can rotate with respect to each other. On the edge there are 4 groups of 4 coloured pieces. Each group is arranged in a circle with two pieces in the top layer, two in the bottom. When the top layer is rotated, the top two pieces of each group are carried along with it to the next group. Each group can be twisted, cyclically permuting its pieces.

The number of positions:
There are 16 pieces, giving a maximum of 16! positions. All these positions are attainable, so there are 16! = 20,922,789,888,000 positions.

Links to other pages:
Tricky Disky official homepage A silly intro, but not much real content.

Notation:
F : Clockwise quarter twist of the group at the front.
F' : Anti-clockwise quarter twist of the front group.
F2 : Half twist of the front group.
B B' B2 : As above, but pertaining to the back group, the group opposite the front.
T T' T2 : Turns of the top layer.

Solution:
Phase 1: Solve 3 pairs of pieces in the top half.

  1. Find the piece that is to go the front group at the top right.
  2. If in the bottom layer, then turn the bottom to get it to the front group.
  3. If in the top layer, then turn the top to get it to the front group, do F2 and turn the top layer back again.
  4. Twist F to put the piece at the top LEFT of the front group.
  5. Find the piece that is to go the front group at the top left.
  6. If it is at the front, top right, then swap the two pieces with the sequence FTF'T'F2RFR'F'.
  7. If it is elsewhere in the top layer, then turn the top to get it to the front group, twist F to put it at the bottom left, turn T back and then finally do F to put the pieces correct.
  8. If in the bottom layer, then turn the bottom to get it to the front group. If it is at the bottom right of the front group, then do TFT'F, if at the bottom left, then simply do F.
  9. The top front pair is now correct. Do T, and then repeat all the above twice more.
Phase 2: Solve 3 pairs in the bottom half.
  1. Turn over the disk so that the solved pairs are at the bottom, on the left, right and back.
  2. Use the same method as phase 1 to solve 3 pairs from the top half. When finished, everything but the front group is solved.
Phase 3: Solve the final group.
  1. Rotate the front group, so that at most only two pieces need to be swapped.
  2. If you need to swap the top two pieces, then do the following moves: F T2 F B' T2 F T2 F' T2 B T2 F' T2
  3. If you need to swap the bottom two pieces, just turn the disk over and do the above sequence.
  4. If you need to swap two other adjacent pieces, then turn F to bring them to the top layer, do the sequence above, and turn F again to put the group into its correct position.
  5. If you need to swap two pieces diagonally, do a quarter turn such that you get a position where both the top pair and bottom pair should be swapped. Then do this sequence: T2 F B T2 B T2 F B T2 B T2 F B T2

Home
Links
Guestbook


Turn'Push

This sliding piece puzzle has 13 pieces which form two intersecting disks. One disk can only do half turns, while the other disk can also do quarter turns. There are two piece shapes; seven triangular ones, and six which are teardrop shaped. Each disk has four of each.

The most interesting fact of this puzzle is that it occurs on the Rubik's cube (and the domino). If you scramble the cube using only the moves U and R2, then the corners of the top and right faces correspond to the teardrops, and the edges to the triangular pieces. A brief discussion of the subgroup can be found in David Singmaster's "Notes on Rubik's 'Magic Cube'", fifth edition, page 57.

A related puzzle is Turnstile by Binary Arts.

I got this puzzle as an advertising freebee, and on the back it has the title of the puzzle (TURN'PUSH ®) and Lotica Patent no. 9503633.

The number of positions:
The top and bottom triangle of one disk - the one that only does half turns - can swap but cannot mix with the other triangles. The pieces therefore fall into three separate groups, of 6, 5, and 2 pieces. This leads to a maximum of 6!·5!·2! = 172,800 positions. This limit is not reached because:

  • The position of three teardrop pieces, determines that of the other three (6)
  • The permutation of pieces must be even (2)
This leaves only 6!·5!/6 = 14,400 positions. For an explanation of the first restriction above, see Singmaster's notes, page 55-57.

A computer search gave the following result:
0 | 1
1 | 4
2 | 6
3 | 12
4 | 18
5 | 36
6 | 53
7 | 100
8 | 144
9 | 252
10 | 364
11 | 644
12 | 898
13 | 1,504
14 | 1,934
15 | 2,544
16 | 2,662
17 | 1,988
18 | 1,111
19 | 116
20 | 9
Total | 14,400
This shows that any position can be solved in at most 20 moves.

Notation:
Hold the puzzle so that the disk that can only do half turns is on the right. The letters L and R will denote the two discs. One clockwise quarter turn of the left disk is L, a half turn is L2, and an anticlockwise turn is L3. The right disk can only do half turns, so then I will use R instead of R2 for a right half turn.

Solution:

  1. Find the triangle that belongs on the far right, and put it into the correct position. This is easy; just bring it to the overlap of the disks, and then turn the right disk.
  2. Find the teardrop that belongs at the top right. If it lies at the bottom right then do R L2 R L3 R L3 R first. To move the teardrop from the left disk to the correct position, then turn it to the bottom left position, and do R L2 R L R L R.
  3. Find the teardrop that belongs at the bottom right. If it lies somewhere on the left disk, then turn it to the top left position, and do R L2 R L3 R L3 R.
  4. Turn the left disk so that all its teardrop pieces are correct. Note that this is always possible because when one is correct, the last three will automatically be in their correct positions too.
  5. Find a triangle on the left disk that is incorrect, and find the position where it belongs. Swapping the two triangles involved will then solve at least one of them. To swap two adjacent triangles of the left disk, turn it to bring them to the top and right of the disk, do R L3 R L R L2 R L2 R L R L R, and then turn the left disk back into its original position. To swap two opposing triangles, turn the disk so that they are at the top and bottom, do R L2 R L2 R L2, and turn the left disk to the correct position.
  6. Repeat step e until the puzzle is solved. Note that the last two triangles of the right disk will automatically be solved.

Home
Links
Guestbook


Turnstile

Picture kindly supplied by Hendrik Haak

This puzzle consists of two overlapping circular disks. Each disk has 12 pieces, 6 are triangular ('corners'), 6 rectangular ('edges') alternating along the rim of the disk around a hexagonal centre. The pieces have curved sides. The disks have three pieces in common, two corners and one edge, so there are altogether 10 corners and 11 edges. Each disk can be rotated. A rotation should be a multiple of 60 degrees since only then can the other disk move again.

There are 5 bright colours used for the corners, a pair of each colour. There is one edge of each of those colours, and the remaining 6 edges are grey. The aim is to put together all pieces of the each colour. The only way to do this is by forming coloured 'lozenges' of two adjacent corners and the edge between them. These lozenges are separated from each other by the grey edges.

Links to other useful pages:
Binary Arts homepage. Homepage of the manufacturer. Puzzles.com is sponsored by Binary Arts, and it contains a solution here.

The number of positions:
There are 10 corners and 11 edges, so there are at most 11!·10! positions. This limit is not reached because:

  1. The corners occur in 5 identical pairs (25)
  2. There are 6 indistinguishable grey edges (6!)
This leaves (11!·10!) / (6!·25) = 6,286,896,000 positions.

Notation:
Let a clockwise 60 degree rotation of the left disk be denoted by L. Rotations of 120, 180, 240, 300 degrees are then denoted by L2, L3, L4 and L5. Note that L5 can also be considered an anti-clockwise 60 degree turn, and is therefore also denoted by L'. Turns of the right disk are denoted in the same way, but using the letter R.

Solution:
Phase 1: Pair up the corners.

  1. First place two corners of the same colour next to each other. This is very easy. If there is not already a pair, turning only one of the disks is nearly always sufficient.
  2. Rotate the pair to the overlapping region, and then do L2 to place them at the bottom left of the left disk.
  3. Find the corner matching the colour of the upper left corner. If it does not lie at the top of the left disk (i.e. it is not yet paired up) then it must lie in the right disk. Turn the right disk to bring it to the top and do L R' L'. The left disk must now have two corner pairs.
  4. If the right disk has one or more pairs then rotate it to bring a pair to the overlapping region, otherwise rotate it so that its top and bottom corners have the same colour.
  5. Only 4 possibilities remain for the corners other than the three pairs position.
    1. If there are two pairs on the right disk then do R' L R L R.
    2. If there is one pair on the right disk then do R3 L4 R3 L2 R.
    3. If each pair of corners lie on the opposite sides of the disk then do L2 R2 L2 R2 L.
    4. Otherwise do R2 L2 R3 L' R L.

Phase 2: Place the edges correct.

  1. Find a coloured edge which is in a spot where a grey edge belongs (i.e. it does not lie between a matched pair of corners).
  2. Find the corner pair of the same colour as the edge.
  3. The following steps should bring the corners to the overlapping region and the edge adjacent to it.
    1. If the edge and its corners lie in the same disk then rotate it to bring the corners to the overlapping region. If the edge is not yet adjacent to the corners then rotate the other disk 120 degrees and go to step 2.
    2. If the edge and its corners lie in different disks and are not in the overlapping region then rotate the edge to a position adjacent to the overlap and then turn the other disk to place the corners in the overlap.
  4. The edge can now be placed between the corners by using one of the following four similar sequences TWICE. Which one you need depends on the position of the edge piece:
    1. Edge is at top left: R'L R L'
    2. Edge is at top right: L R'L'R
    3. Edge is at bottom left: R L'R'L
    4. Edge is at bottom right: L'R L R'
  5. Repeat step a-d for all the edges. If all the grey edges are correct but the coloured ones are not, then you can use the procedure above to insert a grey edge in an incorrectly coloured 'lozenge' to free up a coloured edge for step a.

Phase 3: Place the lozenges correct.

  1. This whole phase uses only 120 degree turns of the discs, so that the lozenges will not broken be up at all. First put the correct lozenge in bottom left position which is trivial.
  2. Find the lozenge belonging at the top left position. If it is not yet in position then rotate it to the top right, and do L2 R4 L4.
  3. Rotate the right disc to bring the correct lozenge to the overlapping region.
  4. If the final two colours are not correct then perform the sequence
    L R L' R L R4 L'.
    to swap the corners and then solve the remaining edge as in phase 2 by using:
    R2 L R' L' R L R' L' R.

If your browser supports it, you can click on the link below to see a Javascript version of the Turnstile puzzle.

Javascript Turnstile Puzzle

Home
Links
Guestbook


Ufo

Picture kindly supplied by Hendrik Haak

There are several puzzles called Ufo. This one consists of a disc which is split into two layers which can rotate about the central axis. Spaced evenly along the rim of the disc are 3 spheres of different colours. These are split into octants, so that when the layers of the disc are turned, one half of each sphere travels with each layer. The spheres can also rotate in two halves about an axis along the disc edge. Although this puzzle is hard to describe, it is fairly easy to solve.

Links to other useful pages:
Meffert's puzzles Uwe Mèffert retails this puzzle, which is manufactured by Netblock.

The number of positions:
There are 24 pieces, 8 of each colour. They can therefore be arranged in at most 24!/8!3=9,465,511,770 ways. This limit is not reached because:

  • The pieces in the left halves and the right halves of the balls never intermingle.
  • The orientation of the puzzle itself is unimportant.
The first restriction means that there are at most 12!2/4!6 = 1,200,622,500 possible positions. The second restriction means that the real number of positions is about 1/6th of that number because the puzzle can be held in 6 different ways (due to the three-fold symmetry around the center, and because it can be turned over). As some positions are themselves symmetric, the exact number can best be calculated with Burnside's Lemma, and this gives 200,121,075 positions.

Terminology:
Hold the puzzle so that one ball is at the front, nearest you, with the other balls further away on the left and right. The four nearest pieces of the front ball will be individually called the top-left, top-right, bottom-left and bottom-right piece. The other 4 pieces of the front ball won't be named separately. The outside pieces of the other two balls will also be described in the same way, for example the "top-right piece of the left ball" etc.

Solution:

Phase 1: Solve one ball.
In this phase the front ball will be solved. I will assume you will make it red, thought you could of course solve a different colour first.

  1. Find any unsolved red piece.
  2. Turn it so that it lies in the bottom front of its ball.
  3. Rotate the bottom disc layer to bring the piece to the front ball, at either the left of the right.
  4. Turn the piece up so that lies at the top left of top right.
  5. Repeat steps a-d three more times, so that the top half of the front ball is completely red. You may have to be a little selective in your choice of pieces, since you want to do the steps twice for the left half and twice for the right half of the ball.
  6. Rotate the top layer to the left or right, to put the four solved red pieces out of the way.
  7. Repeat steps a-e, so that you build up a second red half ball from the 4 remaining red pieces.
  8. Give the front ball a half turn, bringing the red pieces to the bottom half.
  9. Rotate the layers to bring all the red pieces together in a single ball.
Phase 2: Solve the other two balls.
Solving one of the remaining balls will obviously also solve the other one. I will assume you will solve the green ball next. This phase is very similar to phase 1, except that care must be taken not to disturb the red pieces (apart from layer turns). Hold the puzzle so that the red ball is at the back left, and an unsolved ball in front.
  1. Find any green piece in the back right ball.
  2. Turn it so that it lies in the bottom front of its ball.
  3. Rotate the bottom disc layer to bring the piece to the front ball, at either the left of the right.
  4. Turn the piece up so that lies at the top left of top right.
  5. Rotate the bottom layer back to the right (which reassembles the red ball).
  6. Repeat steps a-e until the top half of the front ball is completely green.
  7. Turn over the puzzle, and again hold the red ball at the back left. The bottom half of the back right ball is green.
  8. Turn the back right ball so that the solved green pieces are in the top half.
  9. Repeat steps a-e, so that you build up a second green half ball from the 4 remaining green pieces.
  10. Now bring the two green halves together as follows:
    1. Rotate the bottom layer to the left.
    2. Turn the front ball to bring its green half to the bottom layer.
    3. Rotate the bottom layer to the right, and the puzzle is solved.

Home
Links
Guestbook


Ultimate Skewb / Puzzleball

Pictures kindly supplied by Hendrik Haak

The puzzle is a variant on the skewb which has a dodecahedral shape. A cube can be embedded in a regular dodecahedron so that its corners coincide with eight of the corners of the dodecahedron. This puzzle can be considered to be a regular skewb cube which has been extended into a doedecahedron in the same way. It has 8 triangular corner pieces, and 6 square roof-like face pieces. The puzzle usually has only 6 colours, and opposite (parallel) faces have the same colour. When Meffert first made some of these, it was called the Pyraminx Ball.

This puzzle differs from the most other skewb variants because here the orientation of all the pieces is visible. It is therefore the most difficult skewb variant. On the regular skewb face orientation is not visible, whereas on the diamond the orientation of the triangular pieces is not visible. Some puzzleball puzzles also have visible orientations on most pieces, and they may be solved in the same manner as the ultimate skewb.

The number of positions:
There are 4 fixed corners with 3 orientations, 4 free corners with 3 orientations and 6 face pieces with 2 orientations, giving a maximum of 6!·4!·38·25 positions. This limit is not reached because:

  • The total twist of the corners is fixed (3)
  • The number of flipped faces is even (2)
  • The faces must have an even permutation (2)
  • The free corners must have an even permutation, and hence form a tetrad (2)
  • The orientations of the fixed corners and the position of one of the free corners will determine the positions of the other three (3)
This leaves 6!·4!·36·23 = 100,776,960 positions.

Every position can be solved in at most 14 moves. Thanh Vinh Nguyen has recently calculated God's Algorithm, i.e. the shortest solution for each position. Many thanks to Thanh and Claude Crépeau for sharing these results. In the table below I have placed the results for all the skewb variants together for comparison.
Moves | Beachball | Diamond | Pyraminx | Skewb | M-H Pyramid | Ultimate Skewb
0 | 1 | 1 | 1 | 1 | 1 | 1
1 | 8 | 8 | 8 | 8 | 8 | 8
2 | 48 | 48 | 48 | 48 | 48 | 48
3 | 252 | 288 | 288 | 288 | 288 | 288
4 | 930 | 1,632 | 1,728 | 1,728 | 1,728 | 1,728
5 | 884 | 8,568 | 9,896 | 10,248 | 10,128 | 10,248
6 | 37 | 36,114 | 51,808 | 59,304 | 57,780 | 59,976
7 |  | 74,799 | 220,111 | 315,198 | 305,483 | 346,740
8 |  | 16,547 | 480,467 | 1,225,483 | 1,239,266 | 1,958,850
9 |  | 220 | 166,276 | 1,455,856 | 1,879,631 | 10,297,604
10 |  | 15 | 2,457 | 81,028 | 237,320 | 39,466,215
11 |  |  | 32 | 90 | 778 | 46,217,578
12 |  |  |  |  | 21 | 2,417,060
13 |  |  |  |  |  | 615
14 |  |  |  |  |  | 1
Total | 2,160 | 138,240 | 933,120 | 3,149,280 | 3,732,480 | 100,776,960
The single antipode on the ultimate skewb is the superflip, the position with all six faces flipped but otherwise correct.

Links to other useful pages:
Meffert's puzzles Uwe Meffert's pages. He produces the Pyraminx, the Skewb and many variants of it.
Meffert's page. Contains the solution provided in the booklet for the standard Skewb.
Meffert's page. Contains the solution provided in the Creative Puzzleball booklet.
Meffert's page. Contains the solution provided in the Ultimate Skewb booklet.
David Joyner's page. A catalogue of move sequences.
David Joyner's page. Proof formalizing the Skewb group. It proves the assumptions I used above to calculate its size.

Notation:
Note that the corners fall in two classes; four left-handed and four right-handed ones. You will only turn one of these classes, so that these will be considered fixed in space while the other 4 free corners move about. Hold the puzzle so that the tetrad of fixed corners point left, right, down and back. Denote clockwise moves at the corners by L, R, D and B. Anti-clockwise turns are denoted L', R', D' and B'. Any face can be specified by two letters, e.g. DR is the face between the down and right fixed corners. The other 4 corners can similarly be specified by 3 letters.

There now follow 2 different solutions. The first solution below closely follows that of the pyraminx.

Solution 1:
3 top corners | 3
3 top faces | 14
bottom corner | 1
3 bottom faces | 8
4 free corners | 13
total: | 39 moves
Phase 1: Solve 3 top corners

    Rotate L, R, and B so that their orientation is correct. On the Ultimate Skewb these corners do not have any sides in common, but as opposite faces of the solved puzzle usually have the same colour, then the three corners can be turned so that their matching colours are on opposite faces.
Phase 2: Solve 3 top faces
  1. Find a face piece at the D corner which does not belong there.
  2. Hold the puzzle so that the belongs at the LR position.
  3. Rotate D to bring the piece to the back so that it is in the RD or BD position.
  4. Use one of the following sequences to place the piece correctly:
    1. Move BD->LR: Do LDL'.
    2. Move DB->LR: Do R'DR.
  5. Repeat the above until all three top faces are correct. If necessary, you can use one of the above sequences to displace incorrectly placed faces from the top layer.
Phase 3: Solve the D corner.
  1. Simply rotate D to orient its corner correctly. See the remarks in Phase 1. If you are solving a puzzle ball and the D triangle has no visible orientation, then rotate D so that either all 4 free moving corners are correctly positioned, or such that none of them are (If there are identical free corners then keep in mind that they may be considered to be swapped).
Phase 4: Solve the D faces.
  1. There are now only a few possibilities for the last 3 faces left:
    1. To cycle RD->LD->BD->RD: Do: R'DRDR'DR.
    2. To cycle RD->BD->LD->RD: Do: R'D'RD'R'D'R.
    3. To flip RD->DR, LD->DL: DRD'LD'L'DR'.
    4. To cycle RD->DL->DB->RD: RLDL'D'R'
    5. To cycle RD->DB->DL->RD: RDLD'L'R'
Phase 5: Solve the final 4 corners.
  1. If the corners are positioned correctly, but only need to be oriented properly, then the following sequences can be used. You will probably need to rotate the whole puzzle to get into one of these positions:
    1. LRD->DLR, RBD->DRB, BLD->DBL: B' RD'R'D BD' L'R'L'RL' D
    2. LRD->RDL, RBD->BDR, BLD->LDB: D' LR'LRL DB' D'RDR' B
    3. BLD->DBL, RBD->BDR: LDL'D' R B'D'BD R'
    4. LRD->DLR, RBD->BDR, BLD->LDB, LRB->RBL: D' LR'LRL DB' D'RDR' B
  2. If the corners are not in the correct position, then one of the following sequences will do:
    e. DLR->BRL->DLR, LDB->RBD->LDB: DR'D' L'D'LD R D'L'DL
    f. DLR->LBR->RDL, LDB->DRB->DBL: DL' D'RDR' L RD'R'
    g. DLR->RLB->LRD, LDB->BDR->BLD: B'LD'L'D B D'LDL'
    h. DLR->BRL->DLR, LDB->DRB->LDB: DR'L'B'LRDLBL'D
    i. DLR->LBR->RDL, LDB->RBD->DBL: R D R'LRL' D' LR'L'
    j. DLR->LBR->RDL, LDB->BDR->DBL: L'R'L B' L'RLR' B R
    k. DLR->LBR->LRD, LDB->BDR->BLD: L RD'R'D L' D'RDR'
    l. DLR->LBR->RDL, LDB->DRB->LDB: L'R'DRL BRD'R'B'
    m. DLR->LBR->RDL, LDB->BDR->LDB: LDBL R' L'B'D'L' R

Solution 2: Phase 1:

    Do any standard Skewb solution. This solves everything except the face orientations.
Phase 2: Orient the faces.
  1. Do one of the following sequences to flip the faces correctly:
    1. Flip DL, DR: B'LB D'R'DR BL'B' RDR'D'
    2. Flip DB, LR: DBL B'R'BR D'L'B' LRL'R'
    3. Flip DL, DR, DB, LR: B' D'RD' L'B'R DB'D LR
    4. Flip DL, DR, BL, BR: DRD B' RD'LD'R'D B' DR'DB'L'
    5. Flip DL, DR, DB, LR, BL, BR: DRD' L'B DRD' L DB'DL'RDL

Home
Links
Guestbook


Index of /jaap/puzzles/images/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
backgrnd/                       29 Aug 01 12:03         4.0Kb
bicube/                         29 Aug 01 12:03         4.0Kb
brainbll/                       29 Aug 01 12:03         4.0Kb
buttons/                         4 Nov 01 19:27         4.0Kb
clock/                          29 Aug 01 12:03         4.0Kb
cube/                            4 Nov 01 19:28         4.0Kb
cubic/                           4 Nov 01 19:31         4.0Kb
diamond/                        29 Aug 01 12:03         4.0Kb
equator/                        29 Aug 01 12:03         4.0Kb
fifteen/                        29 Aug 01 12:03         4.0Kb
gripple/                         4 Nov 01 19:32         4.0Kb
hanoi/                          29 Aug 01 12:03         4.0Kb
ideas/                          29 Aug 01 12:03         4.0Kb
insanity/                        4 Nov 01 19:33         4.0Kb
iqball/                          4 Nov 01 19:33         4.0Kb
it/                             29 Aug 01 12:03         4.0Kb
lights/                         29 Aug 01 12:03         4.0Kb
magic/                           4 Nov 01 19:36         4.0Kb
massage/                        29 Aug 01 12:03         4.0Kb
master/                         29 Aug 01 12:03         4.0Kb
missing/                        29 Aug 01 12:03         4.0Kb
nineball/                       29 Aug 01 12:03         4.0Kb
nintendo/                       29 Aug 01 12:03         4.0Kb
orbix/                           4 Nov 01 19:38         4.0Kb
pento/                          29 Aug 01 12:03         4.0Kb
port/                            4 Nov 01 19:39         4.0Kb
preview/                         4 Nov 01 19:41         4.0Kb
rubring/                        29 Aug 01 12:03         4.0Kb
saturn/                          4 Nov 01 19:41         4.0Kb
skewb/                          29 Aug 01 12:03         4.0Kb
spinout/                        29 Aug 01 12:03         4.0Kb
square1/                        29 Aug 01 12:03         4.0Kb
symmetry/                       29 Aug 01 12:03         4.0Kb
tantrix/                        29 Aug 01 12:03         4.0Kb
theory/                         29 Aug 01 12:03         4.0Kb
topspin/                        29 Aug 01 12:03         4.0Kb
tower/                          29 Aug 01 12:03         4.0Kb
turnstile/                      29 Aug 01 12:03         4.0Kb
alexstar.jpg                    28 Sep 99 13:13        23.9Kb
backspin.jpg                     6 May 01 12:28         9.4Kb
bandpyra.jpg                     5 Jul 00 14:24        11.4Kb
beachbll.jpg                    10 Mar 00 15:46         4.0Kb
bicube.jpg                      19 Mar 00 13:59         5.6Kb
brain.jpg                       21 Mar 00 13:48         9.0Kb
brainbll.jpg                    18 Mar 00 01:50         6.4Kb
chinring.jpg                    21 Mar 00 19:23         5.2Kb
cube2.jpg                        6 May 01 12:28         8.1Kb
cube3.jpg                       28 Sep 99 13:14        23.7Kb
cube5.jpg                       28 Sep 99 13:14        20.8Kb
diamond.jpg                      8 Mar 00 16:39         8.5Kb
disky.jpg                       28 Sep 99 13:14        17.3Kb
dogic.jpg                       28 Sep 99 13:14        15.1Kb
dogic2.gif                       6 May 01 12:28         5.0Kb
equator.jpg                     30 Jul 01 21:48        10.5Kb
equator2.jpg                    18 Aug 00 15:50         9.2Kb
google.gif                      24 Dec 01 13:33         3.8Kb
gripple.jpg                      4 Nov 01 19:45         8.3Kb
gripple2.jpg                     4 Nov 01 19:45         8.0Kb
halpern.jpg                     28 Sep 99 13:14        23.6Kb
hungring.jpg                     4 Nov 01 19:45         9.7Kb
impossib.jpg                    18 Aug 00 15:51        10.7Kb
insanity.jpg                    30 Jul 01 21:48        11.8Kb
iqball.jpg                       4 Nov 01 19:45         5.4Kb
it.jpg                          18 Aug 00 15:51         7.1Kb
ivory.jpg                       18 Aug 00 15:51         6.7Kb
lo2000b.jpg                     17 Oct 00 21:11        11.9Kb
logo.gif                         1 Apr 00 11:50         1.5Kb
logo2.gif                        1 Jun 00 18:33         1.6Kb
magiccrb.jpg                    18 Aug 00 18:04        17.2Kb
magiccrf.jpg                    18 Aug 00 18:04        16.4Kb
magicsup.jpg                     6 May 01 12:28        12.8Kb
massage.jpg                     28 Sep 99 13:14        23.4Kb
master.jpg                      28 Sep 99 13:13        21.5Kb
megaminx.jpg                    18 Aug 00 15:51        15.7Kb
misslink.jpg                    18 Aug 00 15:51         6.6Kb
mozaika.jpg                     15 Apr 00 14:33         8.0Kb
nineball.jpg                     8 Mar 00 15:39         6.4Kb
nintendo.jpg                    13 Nov 00 21:23        13.2Kb
octagon.jpg                     18 Aug 00 15:51         8.7Kb
octahedr.jpg                    18 Aug 00 15:51        10.5Kb
octaskew.jpg                    28 Sep 99 13:14        23.9Kb
orb.jpg                         18 Aug 00 15:51        11.6Kb
orbix.jpg                       10 Mar 00 17:48         9.7Kb
org2home.gif                    24 Dec 01 13:33         6.3Kb
port.jpg                        28 Feb 00 19:43        13.2Kb
puck.jpg                        28 Sep 99 13:13        14.0Kb
puck2.jpg                        9 Sep 00 15:08         7.4Kb
pyraminx.jpg                    18 Aug 00 15:51         9.4Kb
pyramor2.jpg                    28 Sep 99 13:14        32.2Kb
pyramorf.jpg                    28 Sep 99 13:14        25.0Kb
revenge.jpg                     18 Aug 00 15:51        11.7Kb
roundy.jpg                      28 Sep 99 13:14        15.6Kb
rubclock.jpg                    18 Aug 00 15:51        11.4Kb
rubdice.jpg                     18 Aug 00 15:51         7.2Kb
rubdom.jpg                      18 Aug 00 15:51        15.9Kb
rubfift.jpg                     18 Aug 00 15:51         9.0Kb
rubmag1.jpg                     18 Aug 00 15:51        19.4Kb
rubmag2.jpg                     18 Aug 00 15:51        25.8Kb
rubmaze.jpg                      6 May 01 12:29        10.3Kb
rubmaze1.jpg                     6 May 01 12:29        10.7Kb
rubmaze2.jpg                     6 May 01 12:29         8.3Kb
rubring.jpg                      5 May 00 19:46        10.4Kb
saturn.jpg                       4 Nov 01 19:47        14.4Kb
shells.jpg                      30 Jul 01 21:49        36.4Kb
siamese.jpg                     29 Oct 99 16:27        23.5Kb
skewb.jpg                       18 Aug 00 15:51         9.7Kb
spinout.jpg                     18 Aug 00 15:51         5.5Kb
square1.jpg                     28 Sep 99 13:14        21.9Kb
tetramin.jpg                    18 Aug 00 15:51        14.6Kb
topspin.jpg                     28 Sep 99 13:14        12.0Kb
tower.jpg                       28 Sep 99 13:14        21.5Kb
triamid.jpg                     18 Aug 00 15:51        34.8Kb
triamid2.jpg                     6 May 01 12:30        10.4Kb
triple.jpg                      28 Feb 00 19:43         7.9Kb
turnpush.jpg                    19 Dec 00 21:35         9.3Kb
turnstil.jpg                     7 Nov 99 10:13        12.7Kb
ufo.jpg                          4 Nov 01 19:47         7.4Kb
ultimat1.jpg                    13 Sep 00 12:36        12.4Kb
ultimat2.jpg                    13 Sep 00 12:36         8.2Kb
whippit.jpg                     28 Sep 99 13:13        10.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
whippit.jpg                     28 Sep 99 13:13        10.0Kb
ultimat2.jpg                    13 Sep 00 12:36         8.2Kb
ultimat1.jpg                    13 Sep 00 12:36        12.4Kb
ufo.jpg                          4 Nov 01 19:47         7.4Kb
turnstil.jpg                     7 Nov 99 10:13        12.7Kb
turnpush.jpg                    19 Dec 00 21:35         9.3Kb
triple.jpg                      28 Feb 00 19:43         7.9Kb
triamid2.jpg                     6 May 01 12:30        10.4Kb
triamid.jpg                     18 Aug 00 15:51        34.8Kb
tower.jpg                       28 Sep 99 13:14        21.5Kb
topspin.jpg                     28 Sep 99 13:14        12.0Kb
tetramin.jpg                    18 Aug 00 15:51        14.6Kb
square1.jpg                     28 Sep 99 13:14        21.9Kb
spinout.jpg                     18 Aug 00 15:51         5.5Kb
skewb.jpg                       18 Aug 00 15:51         9.7Kb
siamese.jpg                     29 Oct 99 16:27        23.5Kb
shells.jpg                      30 Jul 01 21:49        36.4Kb
saturn.jpg                       4 Nov 01 19:47        14.4Kb
rubring.jpg                      5 May 00 19:46        10.4Kb
rubmaze2.jpg                     6 May 01 12:29         8.3Kb
rubmaze1.jpg                     6 May 01 12:29        10.7Kb
rubmaze.jpg                      6 May 01 12:29        10.3Kb
rubmag2.jpg                     18 Aug 00 15:51        25.8Kb
rubmag1.jpg                     18 Aug 00 15:51        19.4Kb
rubfift.jpg                     18 Aug 00 15:51         9.0Kb
rubdom.jpg                      18 Aug 00 15:51        15.9Kb
rubdice.jpg                     18 Aug 00 15:51         7.2Kb
rubclock.jpg                    18 Aug 00 15:51        11.4Kb
roundy.jpg                      28 Sep 99 13:14        15.6Kb
revenge.jpg                     18 Aug 00 15:51        11.7Kb
pyramorf.jpg                    28 Sep 99 13:14        25.0Kb
pyramor2.jpg                    28 Sep 99 13:14        32.2Kb
pyraminx.jpg                    18 Aug 00 15:51         9.4Kb
puck2.jpg                        9 Sep 00 15:08         7.4Kb
puck.jpg                        28 Sep 99 13:13        14.0Kb
port.jpg                        28 Feb 00 19:43        13.2Kb
org2home.gif                    24 Dec 01 13:33         6.3Kb
orbix.jpg                       10 Mar 00 17:48         9.7Kb
orb.jpg                         18 Aug 00 15:51        11.6Kb
octaskew.jpg                    28 Sep 99 13:14        23.9Kb
octahedr.jpg                    18 Aug 00 15:51        10.5Kb
octagon.jpg                     18 Aug 00 15:51         8.7Kb
nintendo.jpg                    13 Nov 00 21:23        13.2Kb
nineball.jpg                     8 Mar 00 15:39         6.4Kb
mozaika.jpg                     15 Apr 00 14:33         8.0Kb
misslink.jpg                    18 Aug 00 15:51         6.6Kb
megaminx.jpg                    18 Aug 00 15:51        15.7Kb
master.jpg                      28 Sep 99 13:13        21.5Kb
massage.jpg                     28 Sep 99 13:14        23.4Kb
magicsup.jpg                     6 May 01 12:28        12.8Kb
magiccrf.jpg                    18 Aug 00 18:04        16.4Kb
magiccrb.jpg                    18 Aug 00 18:04        17.2Kb
logo2.gif                        1 Jun 00 18:33         1.6Kb
logo.gif                         1 Apr 00 11:50         1.5Kb
lo2000b.jpg                     17 Oct 00 21:11        11.9Kb
ivory.jpg                       18 Aug 00 15:51         6.7Kb
it.jpg                          18 Aug 00 15:51         7.1Kb
iqball.jpg                       4 Nov 01 19:45         5.4Kb
insanity.jpg                    30 Jul 01 21:48        11.8Kb
impossib.jpg                    18 Aug 00 15:51        10.7Kb
hungring.jpg                     4 Nov 01 19:45         9.7Kb
halpern.jpg                     28 Sep 99 13:14        23.6Kb
gripple2.jpg                     4 Nov 01 19:45         8.0Kb
gripple.jpg                      4 Nov 01 19:45         8.3Kb
google.gif                      24 Dec 01 13:33         3.8Kb
equator2.jpg                    18 Aug 00 15:50         9.2Kb
equator.jpg                     30 Jul 01 21:48        10.5Kb
dogic2.gif                       6 May 01 12:28         5.0Kb
dogic.jpg                       28 Sep 99 13:14        15.1Kb
disky.jpg                       28 Sep 99 13:14        17.3Kb
diamond.jpg                      8 Mar 00 16:39         8.5Kb
cube5.jpg                       28 Sep 99 13:14        20.8Kb
cube3.jpg                       28 Sep 99 13:14        23.7Kb
cube2.jpg                        6 May 01 12:28         8.1Kb
chinring.jpg                    21 Mar 00 19:23         5.2Kb
brainbll.jpg                    18 Mar 00 01:50         6.4Kb
brain.jpg                       21 Mar 00 13:48         9.0Kb
bicube.jpg                      19 Mar 00 13:59         5.6Kb
beachbll.jpg                    10 Mar 00 15:46         4.0Kb
bandpyra.jpg                     5 Jul 00 14:24        11.4Kb
backspin.jpg                     6 May 01 12:28         9.4Kb
alexstar.jpg                    28 Sep 99 13:13        23.9Kb
turnstile/                      29 Aug 01 12:03         4.0Kb
tower/                          29 Aug 01 12:03         4.0Kb
topspin/                        29 Aug 01 12:03         4.0Kb
theory/                         29 Aug 01 12:03         4.0Kb
tantrix/                        29 Aug 01 12:03         4.0Kb
symmetry/                       29 Aug 01 12:03         4.0Kb
square1/                        29 Aug 01 12:03         4.0Kb
spinout/                        29 Aug 01 12:03         4.0Kb
skewb/                          29 Aug 01 12:03         4.0Kb
saturn/                          4 Nov 01 19:41         4.0Kb
rubring/                        29 Aug 01 12:03         4.0Kb
preview/                         4 Nov 01 19:41         4.0Kb
port/                            4 Nov 01 19:39         4.0Kb
pento/                          29 Aug 01 12:03         4.0Kb
orbix/                           4 Nov 01 19:38         4.0Kb
nintendo/                       29 Aug 01 12:03         4.0Kb
nineball/                       29 Aug 01 12:03         4.0Kb
missing/                        29 Aug 01 12:03         4.0Kb
master/                         29 Aug 01 12:03         4.0Kb
massage/                        29 Aug 01 12:03         4.0Kb
magic/                           4 Nov 01 19:36         4.0Kb
lights/                         29 Aug 01 12:03         4.0Kb
it/                             29 Aug 01 12:03         4.0Kb
iqball/                          4 Nov 01 19:33         4.0Kb
insanity/                        4 Nov 01 19:33         4.0Kb
ideas/                          29 Aug 01 12:03         4.0Kb
hanoi/                          29 Aug 01 12:03         4.0Kb
gripple/                         4 Nov 01 19:32         4.0Kb
fifteen/                        29 Aug 01 12:03         4.0Kb
equator/                        29 Aug 01 12:03         4.0Kb
diamond/                        29 Aug 01 12:03         4.0Kb
cubic/                           4 Nov 01 19:31         4.0Kb
cube/                            4 Nov 01 19:28         4.0Kb
clock/                          29 Aug 01 12:03         4.0Kb
buttons/                         4 Nov 01 19:27         4.0Kb
brainbll/                       29 Aug 01 12:03         4.0Kb
bicube/                         29 Aug 01 12:03         4.0Kb
backgrnd/                       29 Aug 01 12:03         4.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
backgrnd/                       29 Aug 01 12:03         4.0Kb
bicube/                         29 Aug 01 12:03         4.0Kb
brainbll/                       29 Aug 01 12:03         4.0Kb
buttons/                         4 Nov 01 19:27         4.0Kb
clock/                          29 Aug 01 12:03         4.0Kb
cube/                            4 Nov 01 19:28         4.0Kb
cubic/                           4 Nov 01 19:31         4.0Kb
diamond/                        29 Aug 01 12:03         4.0Kb
equator/                        29 Aug 01 12:03         4.0Kb
fifteen/                        29 Aug 01 12:03         4.0Kb
gripple/                         4 Nov 01 19:32         4.0Kb
hanoi/                          29 Aug 01 12:03         4.0Kb
ideas/                          29 Aug 01 12:03         4.0Kb
insanity/                        4 Nov 01 19:33         4.0Kb
iqball/                          4 Nov 01 19:33         4.0Kb
it/                             29 Aug 01 12:03         4.0Kb
lights/                         29 Aug 01 12:03         4.0Kb
magic/                           4 Nov 01 19:36         4.0Kb
massage/                        29 Aug 01 12:03         4.0Kb
master/                         29 Aug 01 12:03         4.0Kb
missing/                        29 Aug 01 12:03         4.0Kb
nineball/                       29 Aug 01 12:03         4.0Kb
nintendo/                       29 Aug 01 12:03         4.0Kb
orbix/                           4 Nov 01 19:38         4.0Kb
pento/                          29 Aug 01 12:03         4.0Kb
port/                            4 Nov 01 19:39         4.0Kb
preview/                         4 Nov 01 19:41         4.0Kb
rubring/                        29 Aug 01 12:03         4.0Kb
saturn/                          4 Nov 01 19:41         4.0Kb
skewb/                          29 Aug 01 12:03         4.0Kb
spinout/                        29 Aug 01 12:03         4.0Kb
square1/                        29 Aug 01 12:03         4.0Kb
symmetry/                       29 Aug 01 12:03         4.0Kb
tantrix/                        29 Aug 01 12:03         4.0Kb
theory/                         29 Aug 01 12:03         4.0Kb
topspin/                        29 Aug 01 12:03         4.0Kb
tower/                          29 Aug 01 12:03         4.0Kb
turnstile/                      29 Aug 01 12:03         4.0Kb
logo.gif                         1 Apr 00 11:50         1.5Kb
logo2.gif                        1 Jun 00 18:33         1.6Kb
google.gif                      24 Dec 01 13:33         3.8Kb
beachbll.jpg                    10 Mar 00 15:46         4.0Kb
dogic2.gif                       6 May 01 12:28         5.0Kb
chinring.jpg                    21 Mar 00 19:23         5.2Kb
iqball.jpg                       4 Nov 01 19:45         5.4Kb
spinout.jpg                     18 Aug 00 15:51         5.5Kb
bicube.jpg                      19 Mar 00 13:59         5.6Kb
org2home.gif                    24 Dec 01 13:33         6.3Kb
brainbll.jpg                    18 Mar 00 01:50         6.4Kb
nineball.jpg                     8 Mar 00 15:39         6.4Kb
misslink.jpg                    18 Aug 00 15:51         6.6Kb
ivory.jpg                       18 Aug 00 15:51         6.7Kb
it.jpg                          18 Aug 00 15:51         7.1Kb
rubdice.jpg                     18 Aug 00 15:51         7.2Kb
puck2.jpg                        9 Sep 00 15:08         7.4Kb
ufo.jpg                          4 Nov 01 19:47         7.4Kb
triple.jpg                      28 Feb 00 19:43         7.9Kb
mozaika.jpg                     15 Apr 00 14:33         8.0Kb
gripple2.jpg                     4 Nov 01 19:45         8.0Kb
cube2.jpg                        6 May 01 12:28         8.1Kb
ultimat2.jpg                    13 Sep 00 12:36         8.2Kb
gripple.jpg                      4 Nov 01 19:45         8.3Kb
rubmaze2.jpg                     6 May 01 12:29         8.3Kb
diamond.jpg                      8 Mar 00 16:39         8.5Kb
octagon.jpg                     18 Aug 00 15:51         8.7Kb
rubfift.jpg                     18 Aug 00 15:51         9.0Kb
brain.jpg                       21 Mar 00 13:48         9.0Kb
equator2.jpg                    18 Aug 00 15:50         9.2Kb
turnpush.jpg                    19 Dec 00 21:35         9.3Kb
pyraminx.jpg                    18 Aug 00 15:51         9.4Kb
backspin.jpg                     6 May 01 12:28         9.4Kb
hungring.jpg                     4 Nov 01 19:45         9.7Kb
orbix.jpg                       10 Mar 00 17:48         9.7Kb
skewb.jpg                       18 Aug 00 15:51         9.7Kb
whippit.jpg                     28 Sep 99 13:13        10.0Kb
rubmaze.jpg                      6 May 01 12:29        10.3Kb
rubring.jpg                      5 May 00 19:46        10.4Kb
triamid2.jpg                     6 May 01 12:30        10.4Kb
equator.jpg                     30 Jul 01 21:48        10.5Kb
octahedr.jpg                    18 Aug 00 15:51        10.5Kb
rubmaze1.jpg                     6 May 01 12:29        10.7Kb
impossib.jpg                    18 Aug 00 15:51        10.7Kb
bandpyra.jpg                     5 Jul 00 14:24        11.4Kb
rubclock.jpg                    18 Aug 00 15:51        11.4Kb
orb.jpg                         18 Aug 00 15:51        11.6Kb
revenge.jpg                     18 Aug 00 15:51        11.7Kb
insanity.jpg                    30 Jul 01 21:48        11.8Kb
lo2000b.jpg                     17 Oct 00 21:11        11.9Kb
topspin.jpg                     28 Sep 99 13:14        12.0Kb
ultimat1.jpg                    13 Sep 00 12:36        12.4Kb
turnstil.jpg                     7 Nov 99 10:13        12.7Kb
magicsup.jpg                     6 May 01 12:28        12.8Kb
nintendo.jpg                    13 Nov 00 21:23        13.2Kb
port.jpg                        28 Feb 00 19:43        13.2Kb
puck.jpg                        28 Sep 99 13:13        14.0Kb
saturn.jpg                       4 Nov 01 19:47        14.4Kb
tetramin.jpg                    18 Aug 00 15:51        14.6Kb
dogic.jpg                       28 Sep 99 13:14        15.1Kb
roundy.jpg                      28 Sep 99 13:14        15.6Kb
megaminx.jpg                    18 Aug 00 15:51        15.7Kb
rubdom.jpg                      18 Aug 00 15:51        15.9Kb
magiccrf.jpg                    18 Aug 00 18:04        16.4Kb
magiccrb.jpg                    18 Aug 00 18:04        17.2Kb
disky.jpg                       28 Sep 99 13:14        17.3Kb
rubmag1.jpg                     18 Aug 00 15:51        19.4Kb
cube5.jpg                       28 Sep 99 13:14        20.8Kb
tower.jpg                       28 Sep 99 13:14        21.5Kb
master.jpg                      28 Sep 99 13:13        21.5Kb
square1.jpg                     28 Sep 99 13:14        21.9Kb
massage.jpg                     28 Sep 99 13:14        23.4Kb
siamese.jpg                     29 Oct 99 16:27        23.5Kb
halpern.jpg                     28 Sep 99 13:14        23.6Kb
cube3.jpg                       28 Sep 99 13:14        23.7Kb
octaskew.jpg                    28 Sep 99 13:14        23.9Kb
alexstar.jpg                    28 Sep 99 13:13        23.9Kb
pyramorf.jpg                    28 Sep 99 13:14        25.0Kb
rubmag2.jpg                     18 Aug 00 15:51        25.8Kb
pyramor2.jpg                    28 Sep 99 13:14        32.2Kb
triamid.jpg                     18 Aug 00 15:51        34.8Kb
shells.jpg                      30 Jul 01 21:49        36.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
shells.jpg                      30 Jul 01 21:49        36.4Kb
triamid.jpg                     18 Aug 00 15:51        34.8Kb
pyramor2.jpg                    28 Sep 99 13:14        32.2Kb
rubmag2.jpg                     18 Aug 00 15:51        25.8Kb
pyramorf.jpg                    28 Sep 99 13:14        25.0Kb
alexstar.jpg                    28 Sep 99 13:13        23.9Kb
octaskew.jpg                    28 Sep 99 13:14        23.9Kb
cube3.jpg                       28 Sep 99 13:14        23.7Kb
halpern.jpg                     28 Sep 99 13:14        23.6Kb
siamese.jpg                     29 Oct 99 16:27        23.5Kb
massage.jpg                     28 Sep 99 13:14        23.4Kb
square1.jpg                     28 Sep 99 13:14        21.9Kb
master.jpg                      28 Sep 99 13:13        21.5Kb
tower.jpg                       28 Sep 99 13:14        21.5Kb
cube5.jpg                       28 Sep 99 13:14        20.8Kb
rubmag1.jpg                     18 Aug 00 15:51        19.4Kb
disky.jpg                       28 Sep 99 13:14        17.3Kb
magiccrb.jpg                    18 Aug 00 18:04        17.2Kb
magiccrf.jpg                    18 Aug 00 18:04        16.4Kb
rubdom.jpg                      18 Aug 00 15:51        15.9Kb
megaminx.jpg                    18 Aug 00 15:51        15.7Kb
roundy.jpg                      28 Sep 99 13:14        15.6Kb
dogic.jpg                       28 Sep 99 13:14        15.1Kb
tetramin.jpg                    18 Aug 00 15:51        14.6Kb
saturn.jpg                       4 Nov 01 19:47        14.4Kb
puck.jpg                        28 Sep 99 13:13        14.0Kb
port.jpg                        28 Feb 00 19:43        13.2Kb
nintendo.jpg                    13 Nov 00 21:23        13.2Kb
magicsup.jpg                     6 May 01 12:28        12.8Kb
turnstil.jpg                     7 Nov 99 10:13        12.7Kb
ultimat1.jpg                    13 Sep 00 12:36        12.4Kb
topspin.jpg                     28 Sep 99 13:14        12.0Kb
lo2000b.jpg                     17 Oct 00 21:11        11.9Kb
insanity.jpg                    30 Jul 01 21:48        11.8Kb
revenge.jpg                     18 Aug 00 15:51        11.7Kb
orb.jpg                         18 Aug 00 15:51        11.6Kb
rubclock.jpg                    18 Aug 00 15:51        11.4Kb
bandpyra.jpg                     5 Jul 00 14:24        11.4Kb
impossib.jpg                    18 Aug 00 15:51        10.7Kb
rubmaze1.jpg                     6 May 01 12:29        10.7Kb
octahedr.jpg                    18 Aug 00 15:51        10.5Kb
equator.jpg                     30 Jul 01 21:48        10.5Kb
triamid2.jpg                     6 May 01 12:30        10.4Kb
rubring.jpg                      5 May 00 19:46        10.4Kb
rubmaze.jpg                      6 May 01 12:29        10.3Kb
whippit.jpg                     28 Sep 99 13:13        10.0Kb
skewb.jpg                       18 Aug 00 15:51         9.7Kb
orbix.jpg                       10 Mar 00 17:48         9.7Kb
hungring.jpg                     4 Nov 01 19:45         9.7Kb
backspin.jpg                     6 May 01 12:28         9.4Kb
pyraminx.jpg                    18 Aug 00 15:51         9.4Kb
turnpush.jpg                    19 Dec 00 21:35         9.3Kb
equator2.jpg                    18 Aug 00 15:50         9.2Kb
brain.jpg                       21 Mar 00 13:48         9.0Kb
rubfift.jpg                     18 Aug 00 15:51         9.0Kb
octagon.jpg                     18 Aug 00 15:51         8.7Kb
diamond.jpg                      8 Mar 00 16:39         8.5Kb
rubmaze2.jpg                     6 May 01 12:29         8.3Kb
gripple.jpg                      4 Nov 01 19:45         8.3Kb
ultimat2.jpg                    13 Sep 00 12:36         8.2Kb
cube2.jpg                        6 May 01 12:28         8.1Kb
gripple2.jpg                     4 Nov 01 19:45         8.0Kb
mozaika.jpg                     15 Apr 00 14:33         8.0Kb
triple.jpg                      28 Feb 00 19:43         7.9Kb
ufo.jpg                          4 Nov 01 19:47         7.4Kb
puck2.jpg                        9 Sep 00 15:08         7.4Kb
rubdice.jpg                     18 Aug 00 15:51         7.2Kb
it.jpg                          18 Aug 00 15:51         7.1Kb
ivory.jpg                       18 Aug 00 15:51         6.7Kb
misslink.jpg                    18 Aug 00 15:51         6.6Kb
nineball.jpg                     8 Mar 00 15:39         6.4Kb
brainbll.jpg                    18 Mar 00 01:50         6.4Kb
org2home.gif                    24 Dec 01 13:33         6.3Kb
bicube.jpg                      19 Mar 00 13:59         5.6Kb
spinout.jpg                     18 Aug 00 15:51         5.5Kb
iqball.jpg                       4 Nov 01 19:45         5.4Kb
chinring.jpg                    21 Mar 00 19:23         5.2Kb
dogic2.gif                       6 May 01 12:28         5.0Kb
beachbll.jpg                    10 Mar 00 15:46         4.0Kb
google.gif                      24 Dec 01 13:33         3.8Kb
logo2.gif                        1 Jun 00 18:33         1.6Kb
logo.gif                         1 Apr 00 11:50         1.5Kb
turnstile/                      29 Aug 01 12:03         4.0Kb
tower/                          29 Aug 01 12:03         4.0Kb
topspin/                        29 Aug 01 12:03         4.0Kb
theory/                         29 Aug 01 12:03         4.0Kb
tantrix/                        29 Aug 01 12:03         4.0Kb
symmetry/                       29 Aug 01 12:03         4.0Kb
square1/                        29 Aug 01 12:03         4.0Kb
spinout/                        29 Aug 01 12:03         4.0Kb
skewb/                          29 Aug 01 12:03         4.0Kb
saturn/                          4 Nov 01 19:41         4.0Kb
rubring/                        29 Aug 01 12:03         4.0Kb
preview/                         4 Nov 01 19:41         4.0Kb
port/                            4 Nov 01 19:39         4.0Kb
pento/                          29 Aug 01 12:03         4.0Kb
orbix/                           4 Nov 01 19:38         4.0Kb
nintendo/                       29 Aug 01 12:03         4.0Kb
nineball/                       29 Aug 01 12:03         4.0Kb
missing/                        29 Aug 01 12:03         4.0Kb
master/                         29 Aug 01 12:03         4.0Kb
massage/                        29 Aug 01 12:03         4.0Kb
magic/                           4 Nov 01 19:36         4.0Kb
lights/                         29 Aug 01 12:03         4.0Kb
it/                             29 Aug 01 12:03         4.0Kb
iqball/                          4 Nov 01 19:33         4.0Kb
insanity/                        4 Nov 01 19:33         4.0Kb
ideas/                          29 Aug 01 12:03         4.0Kb
hanoi/                          29 Aug 01 12:03         4.0Kb
gripple/                         4 Nov 01 19:32         4.0Kb
fifteen/                        29 Aug 01 12:03         4.0Kb
equator/                        29 Aug 01 12:03         4.0Kb
diamond/                        29 Aug 01 12:03         4.0Kb
cubic/                           4 Nov 01 19:31         4.0Kb
cube/                            4 Nov 01 19:28         4.0Kb
clock/                          29 Aug 01 12:03         4.0Kb
buttons/                         4 Nov 01 19:27         4.0Kb
brainbll/                       29 Aug 01 12:03         4.0Kb
bicube/                         29 Aug 01 12:03         4.0Kb
backgrnd/                       29 Aug 01 12:03         4.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
alexstar.jpg                    28 Sep 99 13:13        23.9Kb
whippit.jpg                     28 Sep 99 13:13        10.0Kb
puck.jpg                        28 Sep 99 13:13        14.0Kb
master.jpg                      28 Sep 99 13:13        21.5Kb
massage.jpg                     28 Sep 99 13:14        23.4Kb
octaskew.jpg                    28 Sep 99 13:14        23.9Kb
tower.jpg                       28 Sep 99 13:14        21.5Kb
roundy.jpg                      28 Sep 99 13:14        15.6Kb
halpern.jpg                     28 Sep 99 13:14        23.6Kb
pyramorf.jpg                    28 Sep 99 13:14        25.0Kb
cube5.jpg                       28 Sep 99 13:14        20.8Kb
cube3.jpg                       28 Sep 99 13:14        23.7Kb
topspin.jpg                     28 Sep 99 13:14        12.0Kb
dogic.jpg                       28 Sep 99 13:14        15.1Kb
disky.jpg                       28 Sep 99 13:14        17.3Kb
pyramor2.jpg                    28 Sep 99 13:14        32.2Kb
square1.jpg                     28 Sep 99 13:14        21.9Kb
siamese.jpg                     29 Oct 99 16:27        23.5Kb
turnstil.jpg                     7 Nov 99 10:13        12.7Kb
triple.jpg                      28 Feb 00 19:43         7.9Kb
port.jpg                        28 Feb 00 19:43        13.2Kb
nineball.jpg                     8 Mar 00 15:39         6.4Kb
diamond.jpg                      8 Mar 00 16:39         8.5Kb
beachbll.jpg                    10 Mar 00 15:46         4.0Kb
orbix.jpg                       10 Mar 00 17:48         9.7Kb
brainbll.jpg                    18 Mar 00 01:50         6.4Kb
bicube.jpg                      19 Mar 00 13:59         5.6Kb
brain.jpg                       21 Mar 00 13:48         9.0Kb
chinring.jpg                    21 Mar 00 19:23         5.2Kb
logo.gif                         1 Apr 00 11:50         1.5Kb
mozaika.jpg                     15 Apr 00 14:33         8.0Kb
rubring.jpg                      5 May 00 19:46        10.4Kb
logo2.gif                        1 Jun 00 18:33         1.6Kb
bandpyra.jpg                     5 Jul 00 14:24        11.4Kb
equator2.jpg                    18 Aug 00 15:50         9.2Kb
impossib.jpg                    18 Aug 00 15:51        10.7Kb
it.jpg                          18 Aug 00 15:51         7.1Kb
ivory.jpg                       18 Aug 00 15:51         6.7Kb
megaminx.jpg                    18 Aug 00 15:51        15.7Kb
misslink.jpg                    18 Aug 00 15:51         6.6Kb
octagon.jpg                     18 Aug 00 15:51         8.7Kb
octahedr.jpg                    18 Aug 00 15:51        10.5Kb
orb.jpg                         18 Aug 00 15:51        11.6Kb
pyraminx.jpg                    18 Aug 00 15:51         9.4Kb
revenge.jpg                     18 Aug 00 15:51        11.7Kb
rubclock.jpg                    18 Aug 00 15:51        11.4Kb
rubdice.jpg                     18 Aug 00 15:51         7.2Kb
rubdom.jpg                      18 Aug 00 15:51        15.9Kb
rubfift.jpg                     18 Aug 00 15:51         9.0Kb
rubmag1.jpg                     18 Aug 00 15:51        19.4Kb
rubmag2.jpg                     18 Aug 00 15:51        25.8Kb
skewb.jpg                       18 Aug 00 15:51         9.7Kb
spinout.jpg                     18 Aug 00 15:51         5.5Kb
tetramin.jpg                    18 Aug 00 15:51        14.6Kb
triamid.jpg                     18 Aug 00 15:51        34.8Kb
magiccrb.jpg                    18 Aug 00 18:04        17.2Kb
magiccrf.jpg                    18 Aug 00 18:04        16.4Kb
puck2.jpg                        9 Sep 00 15:08         7.4Kb
ultimat1.jpg                    13 Sep 00 12:36        12.4Kb
ultimat2.jpg                    13 Sep 00 12:36         8.2Kb
lo2000b.jpg                     17 Oct 00 21:11        11.9Kb
nintendo.jpg                    13 Nov 00 21:23        13.2Kb
turnpush.jpg                    19 Dec 00 21:35         9.3Kb
backspin.jpg                     6 May 01 12:28         9.4Kb
cube2.jpg                        6 May 01 12:28         8.1Kb
dogic2.gif                       6 May 01 12:28         5.0Kb
magicsup.jpg                     6 May 01 12:28        12.8Kb
rubmaze.jpg                      6 May 01 12:29        10.3Kb
rubmaze1.jpg                     6 May 01 12:29        10.7Kb
rubmaze2.jpg                     6 May 01 12:29         8.3Kb
triamid2.jpg                     6 May 01 12:30        10.4Kb
equator.jpg                     30 Jul 01 21:48        10.5Kb
insanity.jpg                    30 Jul 01 21:48        11.8Kb
shells.jpg                      30 Jul 01 21:49        36.4Kb
clock/                          29 Aug 01 12:03         4.0Kb
it/                             29 Aug 01 12:03         4.0Kb
tower/                          29 Aug 01 12:03         4.0Kb
backgrnd/                       29 Aug 01 12:03         4.0Kb
bicube/                         29 Aug 01 12:03         4.0Kb
topspin/                        29 Aug 01 12:03         4.0Kb
brainbll/                       29 Aug 01 12:03         4.0Kb
diamond/                        29 Aug 01 12:03         4.0Kb
fifteen/                        29 Aug 01 12:03         4.0Kb
hanoi/                          29 Aug 01 12:03         4.0Kb
ideas/                          29 Aug 01 12:03         4.0Kb
lights/                         29 Aug 01 12:03         4.0Kb
massage/                        29 Aug 01 12:03         4.0Kb
master/                         29 Aug 01 12:03         4.0Kb
missing/                        29 Aug 01 12:03         4.0Kb
skewb/                          29 Aug 01 12:03         4.0Kb
square1/                        29 Aug 01 12:03         4.0Kb
theory/                         29 Aug 01 12:03         4.0Kb
nineball/                       29 Aug 01 12:03         4.0Kb
nintendo/                       29 Aug 01 12:03         4.0Kb
spinout/                        29 Aug 01 12:03         4.0Kb
symmetry/                       29 Aug 01 12:03         4.0Kb
tantrix/                        29 Aug 01 12:03         4.0Kb
equator/                        29 Aug 01 12:03         4.0Kb
pento/                          29 Aug 01 12:03         4.0Kb
rubring/                        29 Aug 01 12:03         4.0Kb
turnstile/                      29 Aug 01 12:03         4.0Kb
buttons/                         4 Nov 01 19:27         4.0Kb
cube/                            4 Nov 01 19:28         4.0Kb
cubic/                           4 Nov 01 19:31         4.0Kb
gripple/                         4 Nov 01 19:32         4.0Kb
insanity/                        4 Nov 01 19:33         4.0Kb
iqball/                          4 Nov 01 19:33         4.0Kb
magic/                           4 Nov 01 19:36         4.0Kb
orbix/                           4 Nov 01 19:38         4.0Kb
port/                            4 Nov 01 19:39         4.0Kb
preview/                         4 Nov 01 19:41         4.0Kb
saturn/                          4 Nov 01 19:41         4.0Kb
gripple.jpg                      4 Nov 01 19:45         8.3Kb
gripple2.jpg                     4 Nov 01 19:45         8.0Kb
hungring.jpg                     4 Nov 01 19:45         9.7Kb
iqball.jpg                       4 Nov 01 19:45         5.4Kb
saturn.jpg                       4 Nov 01 19:47        14.4Kb
ufo.jpg                          4 Nov 01 19:47         7.4Kb
google.gif                      24 Dec 01 13:33         3.8Kb
org2home.gif                    24 Dec 01 13:33         6.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
org2home.gif                    24 Dec 01 13:33         6.3Kb
google.gif                      24 Dec 01 13:33         3.8Kb
ufo.jpg                          4 Nov 01 19:47         7.4Kb
saturn.jpg                       4 Nov 01 19:47        14.4Kb
iqball.jpg                       4 Nov 01 19:45         5.4Kb
hungring.jpg                     4 Nov 01 19:45         9.7Kb
gripple2.jpg                     4 Nov 01 19:45         8.0Kb
gripple.jpg                      4 Nov 01 19:45         8.3Kb
saturn/                          4 Nov 01 19:41         4.0Kb
preview/                         4 Nov 01 19:41         4.0Kb
port/                            4 Nov 01 19:39         4.0Kb
orbix/                           4 Nov 01 19:38         4.0Kb
magic/                           4 Nov 01 19:36         4.0Kb
iqball/                          4 Nov 01 19:33         4.0Kb
insanity/                        4 Nov 01 19:33         4.0Kb
gripple/                         4 Nov 01 19:32         4.0Kb
cubic/                           4 Nov 01 19:31         4.0Kb
cube/                            4 Nov 01 19:28         4.0Kb
buttons/                         4 Nov 01 19:27         4.0Kb
turnstile/                      29 Aug 01 12:03         4.0Kb
rubring/                        29 Aug 01 12:03         4.0Kb
pento/                          29 Aug 01 12:03         4.0Kb
equator/                        29 Aug 01 12:03         4.0Kb
tantrix/                        29 Aug 01 12:03         4.0Kb
symmetry/                       29 Aug 01 12:03         4.0Kb
spinout/                        29 Aug 01 12:03         4.0Kb
nintendo/                       29 Aug 01 12:03         4.0Kb
nineball/                       29 Aug 01 12:03         4.0Kb
theory/                         29 Aug 01 12:03         4.0Kb
square1/                        29 Aug 01 12:03         4.0Kb
skewb/                          29 Aug 01 12:03         4.0Kb
missing/                        29 Aug 01 12:03         4.0Kb
master/                         29 Aug 01 12:03         4.0Kb
massage/                        29 Aug 01 12:03         4.0Kb
lights/                         29 Aug 01 12:03         4.0Kb
ideas/                          29 Aug 01 12:03         4.0Kb
hanoi/                          29 Aug 01 12:03         4.0Kb
fifteen/                        29 Aug 01 12:03         4.0Kb
diamond/                        29 Aug 01 12:03         4.0Kb
brainbll/                       29 Aug 01 12:03         4.0Kb
topspin/                        29 Aug 01 12:03         4.0Kb
bicube/                         29 Aug 01 12:03         4.0Kb
backgrnd/                       29 Aug 01 12:03         4.0Kb
tower/                          29 Aug 01 12:03         4.0Kb
it/                             29 Aug 01 12:03         4.0Kb
clock/                          29 Aug 01 12:03         4.0Kb
shells.jpg                      30 Jul 01 21:49        36.4Kb
insanity.jpg                    30 Jul 01 21:48        11.8Kb
equator.jpg                     30 Jul 01 21:48        10.5Kb
triamid2.jpg                     6 May 01 12:30        10.4Kb
rubmaze2.jpg                     6 May 01 12:29         8.3Kb
rubmaze1.jpg                     6 May 01 12:29        10.7Kb
rubmaze.jpg                      6 May 01 12:29        10.3Kb
magicsup.jpg                     6 May 01 12:28        12.8Kb
dogic2.gif                       6 May 01 12:28         5.0Kb
cube2.jpg                        6 May 01 12:28         8.1Kb
backspin.jpg                     6 May 01 12:28         9.4Kb
turnpush.jpg                    19 Dec 00 21:35         9.3Kb
nintendo.jpg                    13 Nov 00 21:23        13.2Kb
lo2000b.jpg                     17 Oct 00 21:11        11.9Kb
ultimat2.jpg                    13 Sep 00 12:36         8.2Kb
ultimat1.jpg                    13 Sep 00 12:36        12.4Kb
puck2.jpg                        9 Sep 00 15:08         7.4Kb
magiccrf.jpg                    18 Aug 00 18:04        16.4Kb
magiccrb.jpg                    18 Aug 00 18:04        17.2Kb
triamid.jpg                     18 Aug 00 15:51        34.8Kb
tetramin.jpg                    18 Aug 00 15:51        14.6Kb
spinout.jpg                     18 Aug 00 15:51         5.5Kb
skewb.jpg                       18 Aug 00 15:51         9.7Kb
rubmag2.jpg                     18 Aug 00 15:51        25.8Kb
rubmag1.jpg                     18 Aug 00 15:51        19.4Kb
rubfift.jpg                     18 Aug 00 15:51         9.0Kb
rubdom.jpg                      18 Aug 00 15:51        15.9Kb
rubdice.jpg                     18 Aug 00 15:51         7.2Kb
rubclock.jpg                    18 Aug 00 15:51        11.4Kb
revenge.jpg                     18 Aug 00 15:51        11.7Kb
pyraminx.jpg                    18 Aug 00 15:51         9.4Kb
orb.jpg                         18 Aug 00 15:51        11.6Kb
octahedr.jpg                    18 Aug 00 15:51        10.5Kb
octagon.jpg                     18 Aug 00 15:51         8.7Kb
misslink.jpg                    18 Aug 00 15:51         6.6Kb
megaminx.jpg                    18 Aug 00 15:51        15.7Kb
ivory.jpg                       18 Aug 00 15:51         6.7Kb
it.jpg                          18 Aug 00 15:51         7.1Kb
impossib.jpg                    18 Aug 00 15:51        10.7Kb
equator2.jpg                    18 Aug 00 15:50         9.2Kb
bandpyra.jpg                     5 Jul 00 14:24        11.4Kb
logo2.gif                        1 Jun 00 18:33         1.6Kb
rubring.jpg                      5 May 00 19:46        10.4Kb
mozaika.jpg                     15 Apr 00 14:33         8.0Kb
logo.gif                         1 Apr 00 11:50         1.5Kb
chinring.jpg                    21 Mar 00 19:23         5.2Kb
brain.jpg                       21 Mar 00 13:48         9.0Kb
bicube.jpg                      19 Mar 00 13:59         5.6Kb
brainbll.jpg                    18 Mar 00 01:50         6.4Kb
orbix.jpg                       10 Mar 00 17:48         9.7Kb
beachbll.jpg                    10 Mar 00 15:46         4.0Kb
diamond.jpg                      8 Mar 00 16:39         8.5Kb
nineball.jpg                     8 Mar 00 15:39         6.4Kb
port.jpg                        28 Feb 00 19:43        13.2Kb
triple.jpg                      28 Feb 00 19:43         7.9Kb
turnstil.jpg                     7 Nov 99 10:13        12.7Kb
siamese.jpg                     29 Oct 99 16:27        23.5Kb
square1.jpg                     28 Sep 99 13:14        21.9Kb
pyramor2.jpg                    28 Sep 99 13:14        32.2Kb
disky.jpg                       28 Sep 99 13:14        17.3Kb
dogic.jpg                       28 Sep 99 13:14        15.1Kb
topspin.jpg                     28 Sep 99 13:14        12.0Kb
cube3.jpg                       28 Sep 99 13:14        23.7Kb
cube5.jpg                       28 Sep 99 13:14        20.8Kb
pyramorf.jpg                    28 Sep 99 13:14        25.0Kb
halpern.jpg                     28 Sep 99 13:14        23.6Kb
roundy.jpg                      28 Sep 99 13:14        15.6Kb
tower.jpg                       28 Sep 99 13:14        21.5Kb
octaskew.jpg                    28 Sep 99 13:14        23.9Kb
massage.jpg                     28 Sep 99 13:14        23.4Kb
master.jpg                      28 Sep 99 13:13        21.5Kb
puck.jpg                        28 Sep 99 13:13        14.0Kb
whippit.jpg                     28 Sep 99 13:13        10.0Kb
alexstar.jpg                    28 Sep 99 13:13        23.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/backgrnd/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
cubeback.gif                    18 Aug 00 15:46         0.9Kb
octaback.gif                    18 Aug 00 15:46         1.0Kb
skewback.gif                    18 Aug 00 15:46         0.9Kb
sq1back.gif                     18 Aug 00 15:46         0.8Kb
tantback.gif                    18 Aug 00 15:46         3.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/backgrnd/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
tantback.gif                    18 Aug 00 15:46         3.8Kb
sq1back.gif                     18 Aug 00 15:46         0.8Kb
skewback.gif                    18 Aug 00 15:46         0.9Kb
octaback.gif                    18 Aug 00 15:46         1.0Kb
cubeback.gif                    18 Aug 00 15:46         0.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/backgrnd/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
sq1back.gif                     18 Aug 00 15:46         0.8Kb
skewback.gif                    18 Aug 00 15:46         0.9Kb
cubeback.gif                    18 Aug 00 15:46         0.9Kb
octaback.gif                    18 Aug 00 15:46         1.0Kb
tantback.gif                    18 Aug 00 15:46         3.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/backgrnd/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
tantback.gif                    18 Aug 00 15:46         3.8Kb
octaback.gif                    18 Aug 00 15:46         1.0Kb
cubeback.gif                    18 Aug 00 15:46         0.9Kb
skewback.gif                    18 Aug 00 15:46         0.9Kb
sq1back.gif                     18 Aug 00 15:46         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/backgrnd/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
cubeback.gif                    18 Aug 00 15:46         0.9Kb
octaback.gif                    18 Aug 00 15:46         1.0Kb
skewback.gif                    18 Aug 00 15:46         0.9Kb
sq1back.gif                     18 Aug 00 15:46         0.8Kb
tantback.gif                    18 Aug 00 15:46         3.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/backgrnd/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
tantback.gif                    18 Aug 00 15:46         3.8Kb
sq1back.gif                     18 Aug 00 15:46         0.8Kb
skewback.gif                    18 Aug 00 15:46         0.9Kb
octaback.gif                    18 Aug 00 15:46         1.0Kb
cubeback.gif                    18 Aug 00 15:46         0.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/bicube/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
bicube2.gif                     30 Mar 00 18:57         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/bicube/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
bicube2.gif                     30 Mar 00 18:57         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/bicube/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
bicube2.gif                     30 Mar 00 18:57         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/bicube/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
bicube2.gif                     30 Mar 00 18:57         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/bicube/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
bicube2.gif                     30 Mar 00 18:57         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/bicube/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
bicube2.gif                     30 Mar 00 18:57         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/brainbll/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
bb01w.gif                       30 Mar 00 19:11         0.1Kb
bb01y.gif                       30 Mar 00 19:11         0.1Kb
bb02w.gif                       30 Mar 00 19:11         0.1Kb
bb02y.gif                       30 Mar 00 19:11         0.1Kb
bb03w.gif                       30 Mar 00 19:11         0.1Kb
bb03y.gif                       30 Mar 00 19:11         0.1Kb
bb04w.gif                       30 Mar 00 19:11         0.1Kb
bb04y.gif                       30 Mar 00 19:11         0.1Kb
bb05w.gif                       30 Mar 00 19:11         0.1Kb
bb05y.gif                       30 Mar 00 19:11         0.1Kb
bb06w.gif                       30 Mar 00 19:11         0.1Kb
bb06y.gif                       30 Mar 00 19:11         0.1Kb
bb07w.gif                       30 Mar 00 19:15         0.1Kb
bb07y.gif                       30 Mar 00 19:15         0.1Kb
bb08w.gif                       30 Mar 00 19:15         0.1Kb
bb08y.gif                       30 Mar 00 19:15         0.1Kb
bb09w.gif                       30 Mar 00 19:18         0.1Kb
bb09y.gif                       30 Mar 00 19:18         0.1Kb
bb10w.gif                       30 Mar 00 19:18         0.1Kb
bb10y.gif                       30 Mar 00 19:18         0.1Kb
bb11w.gif                       30 Mar 00 19:20         0.1Kb
bb11y.gif                       30 Mar 00 19:20         0.1Kb
bb12w.gif                       30 Mar 00 19:20         0.1Kb
bb12y.gif                       30 Mar 00 19:20         0.1Kb
bb13w.gif                       30 Mar 00 19:20         0.1Kb
bb13y.gif                       30 Mar 00 19:20         0.1Kb
bbedit.gif                      30 Mar 00 19:23         0.1Kb
puzzlink.htm                    30 Jul 01 20:01        24.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/brainbll/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
puzzlink.htm                    30 Jul 01 20:01        24.0Kb
bbedit.gif                      30 Mar 00 19:23         0.1Kb
bb13y.gif                       30 Mar 00 19:20         0.1Kb
bb13w.gif                       30 Mar 00 19:20         0.1Kb
bb12y.gif                       30 Mar 00 19:20         0.1Kb
bb12w.gif                       30 Mar 00 19:20         0.1Kb
bb11y.gif                       30 Mar 00 19:20         0.1Kb
bb11w.gif                       30 Mar 00 19:20         0.1Kb
bb10y.gif                       30 Mar 00 19:18         0.1Kb
bb10w.gif                       30 Mar 00 19:18         0.1Kb
bb09y.gif                       30 Mar 00 19:18         0.1Kb
bb09w.gif                       30 Mar 00 19:18         0.1Kb
bb08y.gif                       30 Mar 00 19:15         0.1Kb
bb08w.gif                       30 Mar 00 19:15         0.1Kb
bb07y.gif                       30 Mar 00 19:15         0.1Kb
bb07w.gif                       30 Mar 00 19:15         0.1Kb
bb06y.gif                       30 Mar 00 19:11         0.1Kb
bb06w.gif                       30 Mar 00 19:11         0.1Kb
bb05y.gif                       30 Mar 00 19:11         0.1Kb
bb05w.gif                       30 Mar 00 19:11         0.1Kb
bb04y.gif                       30 Mar 00 19:11         0.1Kb
bb04w.gif                       30 Mar 00 19:11         0.1Kb
bb03y.gif                       30 Mar 00 19:11         0.1Kb
bb03w.gif                       30 Mar 00 19:11         0.1Kb
bb02y.gif                       30 Mar 00 19:11         0.1Kb
bb02w.gif                       30 Mar 00 19:11         0.1Kb
bb01y.gif                       30 Mar 00 19:11         0.1Kb
bb01w.gif                       30 Mar 00 19:11         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/brainbll/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
bb01w.gif                       30 Mar 00 19:11         0.1Kb
bb01y.gif                       30 Mar 00 19:11         0.1Kb
bbedit.gif                      30 Mar 00 19:23         0.1Kb
bb05w.gif                       30 Mar 00 19:11         0.1Kb
bb05y.gif                       30 Mar 00 19:11         0.1Kb
bb07w.gif                       30 Mar 00 19:15         0.1Kb
bb07y.gif                       30 Mar 00 19:15         0.1Kb
bb02w.gif                       30 Mar 00 19:11         0.1Kb
bb02y.gif                       30 Mar 00 19:11         0.1Kb
bb04w.gif                       30 Mar 00 19:11         0.1Kb
bb04y.gif                       30 Mar 00 19:11         0.1Kb
bb06w.gif                       30 Mar 00 19:11         0.1Kb
bb06y.gif                       30 Mar 00 19:11         0.1Kb
bb08w.gif                       30 Mar 00 19:15         0.1Kb
bb08y.gif                       30 Mar 00 19:15         0.1Kb
bb09w.gif                       30 Mar 00 19:18         0.1Kb
bb09y.gif                       30 Mar 00 19:18         0.1Kb
bb03w.gif                       30 Mar 00 19:11         0.1Kb
bb03y.gif                       30 Mar 00 19:11         0.1Kb
bb11w.gif                       30 Mar 00 19:20         0.1Kb
bb11y.gif                       30 Mar 00 19:20         0.1Kb
bb13w.gif                       30 Mar 00 19:20         0.1Kb
bb13y.gif                       30 Mar 00 19:20         0.1Kb
bb10w.gif                       30 Mar 00 19:18         0.1Kb
bb10y.gif                       30 Mar 00 19:18         0.1Kb
bb12w.gif                       30 Mar 00 19:20         0.1Kb
bb12y.gif                       30 Mar 00 19:20         0.1Kb
puzzlink.htm                    30 Jul 01 20:01        24.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/brainbll/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
puzzlink.htm                    30 Jul 01 20:01        24.0Kb
bb12y.gif                       30 Mar 00 19:20         0.1Kb
bb12w.gif                       30 Mar 00 19:20         0.1Kb
bb10y.gif                       30 Mar 00 19:18         0.1Kb
bb10w.gif                       30 Mar 00 19:18         0.1Kb
bb13y.gif                       30 Mar 00 19:20         0.1Kb
bb13w.gif                       30 Mar 00 19:20         0.1Kb
bb11y.gif                       30 Mar 00 19:20         0.1Kb
bb11w.gif                       30 Mar 00 19:20         0.1Kb
bb03y.gif                       30 Mar 00 19:11         0.1Kb
bb03w.gif                       30 Mar 00 19:11         0.1Kb
bb09y.gif                       30 Mar 00 19:18         0.1Kb
bb09w.gif                       30 Mar 00 19:18         0.1Kb
bb08y.gif                       30 Mar 00 19:15         0.1Kb
bb08w.gif                       30 Mar 00 19:15         0.1Kb
bb06y.gif                       30 Mar 00 19:11         0.1Kb
bb06w.gif                       30 Mar 00 19:11         0.1Kb
bb04y.gif                       30 Mar 00 19:11         0.1Kb
bb04w.gif                       30 Mar 00 19:11         0.1Kb
bb02y.gif                       30 Mar 00 19:11         0.1Kb
bb02w.gif                       30 Mar 00 19:11         0.1Kb
bb07y.gif                       30 Mar 00 19:15         0.1Kb
bb07w.gif                       30 Mar 00 19:15         0.1Kb
bb05y.gif                       30 Mar 00 19:11         0.1Kb
bb05w.gif                       30 Mar 00 19:11         0.1Kb
bbedit.gif                      30 Mar 00 19:23         0.1Kb
bb01y.gif                       30 Mar 00 19:11         0.1Kb
bb01w.gif                       30 Mar 00 19:11         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/brainbll/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
bb01w.gif                       30 Mar 00 19:11         0.1Kb
bb01y.gif                       30 Mar 00 19:11         0.1Kb
bb02w.gif                       30 Mar 00 19:11         0.1Kb
bb02y.gif                       30 Mar 00 19:11         0.1Kb
bb03w.gif                       30 Mar 00 19:11         0.1Kb
bb03y.gif                       30 Mar 00 19:11         0.1Kb
bb04w.gif                       30 Mar 00 19:11         0.1Kb
bb04y.gif                       30 Mar 00 19:11         0.1Kb
bb05w.gif                       30 Mar 00 19:11         0.1Kb
bb05y.gif                       30 Mar 00 19:11         0.1Kb
bb06w.gif                       30 Mar 00 19:11         0.1Kb
bb06y.gif                       30 Mar 00 19:11         0.1Kb
bb07w.gif                       30 Mar 00 19:15         0.1Kb
bb07y.gif                       30 Mar 00 19:15         0.1Kb
bb08w.gif                       30 Mar 00 19:15         0.1Kb
bb08y.gif                       30 Mar 00 19:15         0.1Kb
bb09w.gif                       30 Mar 00 19:18         0.1Kb
bb09y.gif                       30 Mar 00 19:18         0.1Kb
bb10w.gif                       30 Mar 00 19:18         0.1Kb
bb10y.gif                       30 Mar 00 19:18         0.1Kb
bb11w.gif                       30 Mar 00 19:20         0.1Kb
bb11y.gif                       30 Mar 00 19:20         0.1Kb
bb12w.gif                       30 Mar 00 19:20         0.1Kb
bb12y.gif                       30 Mar 00 19:20         0.1Kb
bb13w.gif                       30 Mar 00 19:20         0.1Kb
bb13y.gif                       30 Mar 00 19:20         0.1Kb
bbedit.gif                      30 Mar 00 19:23         0.1Kb
puzzlink.htm                    30 Jul 01 20:01        24.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/brainbll/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
puzzlink.htm                    30 Jul 01 20:01        24.0Kb
bbedit.gif                      30 Mar 00 19:23         0.1Kb
bb13y.gif                       30 Mar 00 19:20         0.1Kb
bb13w.gif                       30 Mar 00 19:20         0.1Kb
bb12y.gif                       30 Mar 00 19:20         0.1Kb
bb12w.gif                       30 Mar 00 19:20         0.1Kb
bb11y.gif                       30 Mar 00 19:20         0.1Kb
bb11w.gif                       30 Mar 00 19:20         0.1Kb
bb10y.gif                       30 Mar 00 19:18         0.1Kb
bb10w.gif                       30 Mar 00 19:18         0.1Kb
bb09y.gif                       30 Mar 00 19:18         0.1Kb
bb09w.gif                       30 Mar 00 19:18         0.1Kb
bb08y.gif                       30 Mar 00 19:15         0.1Kb
bb08w.gif                       30 Mar 00 19:15         0.1Kb
bb07y.gif                       30 Mar 00 19:15         0.1Kb
bb07w.gif                       30 Mar 00 19:15         0.1Kb
bb06y.gif                       30 Mar 00 19:11         0.1Kb
bb06w.gif                       30 Mar 00 19:11         0.1Kb
bb05y.gif                       30 Mar 00 19:11         0.1Kb
bb05w.gif                       30 Mar 00 19:11         0.1Kb
bb04y.gif                       30 Mar 00 19:11         0.1Kb
bb04w.gif                       30 Mar 00 19:11         0.1Kb
bb03y.gif                       30 Mar 00 19:11         0.1Kb
bb03w.gif                       30 Mar 00 19:11         0.1Kb
bb02y.gif                       30 Mar 00 19:11         0.1Kb
bb02w.gif                       30 Mar 00 19:11         0.1Kb
bb01y.gif                       30 Mar 00 19:11         0.1Kb
bb01w.gif                       30 Mar 00 19:11         0.1Kb
_____________________________________________________________


Jaap's Links to other puzzle pages

There are many puzzle pages about. Many of my pages have links to sites relevant to that particular puzzle. On this page I have drawn together the most important of them, together with some more general links, in no particular order.

Pages which are in BOLD, have a link back to these pages.

    Official Puzzle Homepages
    Other places to buy puzzles
    Solution pages
    Speed cubing
    Cube Theory
    Cube Art
    Pages with programs to download
    Pages with scripts or Java programs
    Message boards
    Musea, galleries and collections
    Other neat puzzle pages not listed above
    Pages that are not mainly about mechanical puzzles

Home
Links
Guestbook

Official Puzzle Homepages:
Meffert's puzzles Uwe Meffert's pages. He produces and sells many puzzles, including Pyraminx, Megaminx, Pyramorphix, Skewb, Orbix and others. This site also has solutions for some.
Rubik's homepage. The official homepage sells Rubik's puzzles and has links to several cube solutions on the web.
Masterball Homepage. You can buy a masterball here. It also has a solution for the rainbow masterball.
Hockeypuck homepage. This only shows the different styles available.
Tantrix Homepage. A very nice page including a Java puzzle game.
Tricky Disky Homepage. Has a rather silly intro sequence. They are asking for fast solvers, so maybe I should memorise my solution and have a go.
Binary Arts Homepage. Makers of such puzzles as Topspin, Turnstile, Spinout, Nineball, Port to Port and others.
Mozaika Homepage. A nice puzzle that is a cross between Equator and a cube.
Tiger Toys, the manufacturers of many electronic games including Lights Out.
The Brainball homepage is in German, but has move sequences and puzzles.

Other places to buy puzzles:
Hendrik Haak's Shop. Excellent range of puzzles, and a really nice page too.

Solution pages:
Twisty Megasite. This is a nice page dealing with building puzzles from plastic resin, and also has a 3x3x3 cube solution which explains a method to solve middle layer edges together with the top layer corners in pairs. This page also has a highly recommended message forum.
Cubic Puzzles - The SIMPLEST Solutions. A text based page with solutions for the Skewb, Pyraminx, NxNxN Cubes, Megaminx, Octahedron and Rubik's Clock.
Josef Jelinek and Hana Bizek's Page. Contains examples of various types of cube solving algorithms. Also pictures of cube art, interesting patterned objects built from many cubes.
Denny's Puzzle Pages. Solutions for Pyraminx and various cube sizes, and has a link to his Virtual Puzzle Museum which shows many versions of the cube and other puzzles.
Philip Marshall's Cube Page has a solutions for size 2, 3, and 4 cubes. His cube solution solves edges first, and then the corners and is relatively simple.
Matthew Monroe's page. Nice illustrated solutions for cube, professor's cube, square-one and Pyraminx.
PuzzleSolver by Jake Olefsky has nice solutions for the cube, minicube, the pyraminx, and the Brain. Also has neat impossible objects, and a message board
Jacob Davenport's page. He has a text based 5x5x5 cube solution here.
Chris Eggermont's Twisted Mind Games. The highlights of this page are the solution to Rubik's Magic Master Edition, and the pages on how to get the Square-1 Puzzle into cube shape.
Chris Hardwick's Page. This page has solutions for the cube and the Rubik's Revenge. There is also The Unofficial World Records Page here where you can log your best times.
Luciani's Page is a nice looking French site with a solution.
World of Rubik's by Bruno Jarno. A French page, which has a bit of just about everything about the Rubik's cube.
Dennis Palaganas' page. Solutions for Alexander's Star, and Rubik's Revenge. Viewing with netscape may be problematic.
Javier Santos' page. A Spanish page with some interesting puzzles, including a solution to Rubik's Magic.
Juergen Koeller's page. A solution to the cube and rubik's magic amongst many other things, also available in German.
Steve Martin's page has a solution to Nintendo's Ten Billion Barrel puzzle.
A Nerd Paradise by Blake has solutions for the various cubes, Pyraminx, Skewb and Square-1.
Ryan Kagin's "How to solve the cube" has a layer solution.
"So you want to do the Cube" by Skip Lawson.
R. Hoffman's site has a one-page solution.
Ronald Bieber's page is in German, and has a cube solution of the layer type, and also a Rubik's Magic page.
Cubo Magico, a Spanish page with a corners first solution.
Another Spanish solution.
Yet another Spanish site.

Speed cubing:
Lars Petrus' page. A great set of pages that show you how to solve the cube fast without having to memorise 100 sequences. Also available in Spanish.
Jiri Fridrich's page. A very fast layer algorithm for the cube.
Dan Knights' page. Speed cubing, lubrication, avoiding injury, blindfold cubing, amusing quotes. Also a Java cube with built-in solver.
SpeedCubing.com has good lists of sequences for speedsolving the cube, similar to Jiri's, and a Java program that can searches for useful sequences.
Speedsolving Rubik's Cube Club. A message board, part of Yahoo's Clubs.
Bernard Helmtetter's page has all possible top layer algorithms you may ever need.

Cube Theory:
Prof. David Joyner's Homepage. His section on permutation puzzles has a lot of interesting maths, but much of it is too complicated for the non-mathematician.
Cube-Lovers Archive. Contains all posts on the Cube-Lovers mailing list. To join, send a message to cube-lovers-request@ai.mit.edu.
Martin Schoenert's page has the cube-lovers archive in html form, though only 1980-1996.
Mark Longridge's Domain of the Cube. This page has a few good text pages with cube theory, a large list of patterns, and a neat selection of links.
How to Solve Almost Any Rubik-like Puzzle. A short explanation of the concepts of conjugation and commutation.
Glenn Rhoads' Fun Page. Has lots of fun stuff, including a few for the cube including Solve ANY Rubik's type puzzle, a very short text explaining a general algorithm to solve many puzzles.
Introduction to Group Theory endswith a section on the Rubik's cube.

Cube Art:
Kristin Wunderlich and Jacob Davenport's page has some wonderful cube art here. It has a few patterns on a single 5x5x5 cube, and many mosaic patterns using a large array of cubes. Kristin also makes cubes with other designs here.
Josef Jelinek and Hana Bizek's Page. Hana has pictures of cube art on her page. These are mainly large cubes made from many smaller ones.
Zarf's Page also has cubes with different designs here.
Philip K's Puzzle Page has cubes with Escher designs.

Pages with programs to download:
Cube Explorer Page. This program by Herbert Kociemba produces move sequences for any cube pattern. It finds a reasonably short sequence in about two seconds, and given a few more minutes will nearly always produce a sequence of less than 20 moves.
Mike Reid's optimal solver can do a very fast and deep search for solutions (uncompiled C source only).
Jozef Jelinek's page has a (C source only) program that searches for optimal solutions, with the possibility of ignoring parts of the cube.
Puzzler by Noel Dillabough is a great Windows program that simulates many puzzles. He has also written a Java Puzzler.
Superliminal has an excellent simulation of a 4-d rubik's cube, i.e. a 3x3x3x3 cube.
Rubik's Hypercube is another 4-d Rubik's Cube.
Larry's Cube Corner gives us the excellent Hungarian HexaHedron simulator.
Rubik's Kube, a Linux program based on Karl Hornell's Rubik Unbound Java Cube.
Cellosoft have a Rubik's Rings game for Windows. Looks nice, but requires a Pentium and 2Mb disk space!
Japanese page, with a megaminx program amongst others.

Pages with scripts or Java programs:
Java Puzzler by Noel Dillabough is the Java version of some of the puzzles in his Puzzler Windows program.
Karl Hornell's Rubik Unbound. The most used Java cube on the net, and it has become the standard on which others are judged. With source.
Jozef Jelinek's page has a gorgeous Java Cube. Excellent program, with source.
Dan Knights' cube. Beautiful 3x3x3 cube with edit and playback facility, and built-in solver.
Ron’s Cube Solver from SpeedCubing.com can search for useful sequences, using only some moves or ignoring some pieces.
Rubik's Cuboid. Any size cuboid (including unequal sides), with undo facility. With source.
Rubik’s Cube Disassembled is a Java cube which can not only turn, but also 'explode' to show the inside. This page also has pretty patterns.
Raymond Penner's Page. There are neat Java programs here for Rubik's Fifteen and Rubik's Clock amongst others.
Wedran's cube solver. It allows you to edit a cube and then it shows you the moves to solve it, using a corners first method of about 120 moves on average.
David Byrden's Twisty puzzles. A page with Java versions of many puzzles, including all platonic solids.
Rob's Rubix Repair. An interesting page which solves the cube for you. It works on all browsers that support tables with coloured cells, there is no need for Java. Unfortunately it uses a lot of moves to solve it. With source.
Michael Schubart's cube. 3x3x3 cube with views of other faces. With source.
David Barr's cube. Any cube size. Cube shown in a way that might be confusing to some.
Yuh-Jye (Michael) Chang's cube. Any cube size. Built-in solver just undoes previous moves.
Song Li's cube. 3x3x3 cube only. With source. Built-in solver just undoes previous moves.
Gid's cube. Simple graphical 3x3x3 cube. It is a script so will work on all graphical browsers even without Java.
Bob Breid's page has a Javascript Rubik's Cube.

Message boards:
Speedsolving Rubik's Cube Club. Highly active, part of Yahoo's Clubs.
Twisty Megasite forum. Excellent forum, with a good community, though fairly quiet recently.
Meffert's Puzzle Board.
PuzzleSolver's message board
Rubik's Online Forum from Rubik's own official site. They recently changed board provider and lost all old messages, so it is fairly empty.

Musea, galleries and collections:
Hendrik Haak's Puzzle Museum. Large number of fascinating puzzles. Many of the pictures on this site are from here.
Virtual Puzzle Museum shows a huge number of different versions of the cube and other puzzles.
Cubeworld. A page with nice pictures of many Rubik puzzles, but little else.
Kevin Moore's page, has a nice page with pictures and descriptions of various puzzles.
Japanese site with pictures of various puzzles, but actually most notable for the neat hit counter.
Another Japanese site with a picture gallery.
Japanese page with many sub pages with pictures of puzzles, some quite rare. Most relevant are page 1 and page 2.

Other neat puzzle pages not listed above:
Mike Reid's page has a lot of rubik's cube information and links.
Rubik's Cube World Records lists some amazing world records.
Directory of Mechanical Puzzle Collectors. A page with links to other collectors.
Jin "Time Traveller" Kim's page has the Puzzle FAQ.
Chris and Kori's page. A nice page with descriptions of several kinds of puzzles.
Georges Helm's Page. Has a list of cube resources.
Matthew Baker's Lights Out page has lots of good info about the Lights Out game and its variants, including the cube version.

Pages that are not mainly about mechanical puzzles:
The Mind Sports Organisation Worldwide. Board games, card games, puzzles, Computer Programming contest, and much more.
Creative Puzzles a neat page that hosts the Alt.Brain.Teasers Archive and has Java games too.
Arlet Otten's page containing the rec.puzzles archive.
Ed Pegg's Mathpuzzle page has lots of difficult but often fascinating mathematical puzzles.

I found these links mostly by using Google:

Google

When you're finished with these, you can take a look at a page about my other hobby:
Organiser II Homepage Link Image.
or visit my father's page: Jan Scherphuis which includes my family tree and pictures of my parents house.

Home
Links
Guestbook


Index of /jaap/puzzles/images/buttons/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
back.gif                        20 Jun 00 11:09         0.1Kb
blank.gif                       20 Jun 00 10:52         0.0Kb
down.gif                         1 Jun 00 18:32         0.1Kb
edit.gif                        30 Mar 00 19:33         0.1Kb
edit2.gif                       30 Mar 00 19:33         0.2Kb
favicon.ico                      6 May 01 12:22         1.1Kb
ff.gif                          20 Jun 00 11:09         0.1Kb
ff2.gif                          7 Aug 00 16:53         0.1Kb
flip.gif                         6 May 01 12:22         0.2Kb
help.gif                        17 Oct 00 21:11         0.2Kb
horiz.gif                        6 May 01 12:22         0.2Kb
left.gif                         1 Jun 00 18:32         0.1Kb
meffert.gif                      6 Mar 00 14:03         0.9Kb
mix.gif                         30 Mar 00 19:35         0.2Kb
mode1.gif                        4 Nov 01 19:27         0.2Kb
mode2.gif                        4 Nov 01 19:27         0.2Kb
mode3.gif                        4 Nov 01 19:27         0.2Kb
mode4.gif                        4 Nov 01 19:27         0.2Kb
pause.gif                        6 May 01 12:22         0.2Kb
play.gif                        20 Jun 00 11:09         0.1Kb
reset.gif                       30 Mar 00 19:36         0.2Kb
rew.gif                         20 Jun 00 11:09         0.1Kb
rew2.gif                         7 Aug 00 16:53         0.1Kb
right.gif                        1 Jun 00 18:32         0.1Kb
solve.gif                       30 Mar 00 19:38         0.2Kb
solve2.gif                      30 Mar 00 19:38         0.2Kb
turn.gif                         1 Jan 01 19:35         0.2Kb
up.gif                           1 Jun 00 18:32         0.1Kb
vertic.gif                       6 May 01 12:22         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/buttons/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
vertic.gif                       6 May 01 12:22         0.2Kb
up.gif                           1 Jun 00 18:32         0.1Kb
turn.gif                         1 Jan 01 19:35         0.2Kb
solve2.gif                      30 Mar 00 19:38         0.2Kb
solve.gif                       30 Mar 00 19:38         0.2Kb
right.gif                        1 Jun 00 18:32         0.1Kb
rew2.gif                         7 Aug 00 16:53         0.1Kb
rew.gif                         20 Jun 00 11:09         0.1Kb
reset.gif                       30 Mar 00 19:36         0.2Kb
play.gif                        20 Jun 00 11:09         0.1Kb
pause.gif                        6 May 01 12:22         0.2Kb
mode4.gif                        4 Nov 01 19:27         0.2Kb
mode3.gif                        4 Nov 01 19:27         0.2Kb
mode2.gif                        4 Nov 01 19:27         0.2Kb
mode1.gif                        4 Nov 01 19:27         0.2Kb
mix.gif                         30 Mar 00 19:35         0.2Kb
meffert.gif                      6 Mar 00 14:03         0.9Kb
left.gif                         1 Jun 00 18:32         0.1Kb
horiz.gif                        6 May 01 12:22         0.2Kb
help.gif                        17 Oct 00 21:11         0.2Kb
flip.gif                         6 May 01 12:22         0.2Kb
ff2.gif                          7 Aug 00 16:53         0.1Kb
ff.gif                          20 Jun 00 11:09         0.1Kb
favicon.ico                      6 May 01 12:22         1.1Kb
edit2.gif                       30 Mar 00 19:33         0.2Kb
edit.gif                        30 Mar 00 19:33         0.1Kb
down.gif                         1 Jun 00 18:32         0.1Kb
blank.gif                       20 Jun 00 10:52         0.0Kb
back.gif                        20 Jun 00 11:09         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/buttons/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
blank.gif                       20 Jun 00 10:52         0.0Kb
left.gif                         1 Jun 00 18:32         0.1Kb
right.gif                        1 Jun 00 18:32         0.1Kb
back.gif                        20 Jun 00 11:09         0.1Kb
play.gif                        20 Jun 00 11:09         0.1Kb
up.gif                           1 Jun 00 18:32         0.1Kb
down.gif                         1 Jun 00 18:32         0.1Kb
rew.gif                         20 Jun 00 11:09         0.1Kb
ff.gif                          20 Jun 00 11:09         0.1Kb
ff2.gif                          7 Aug 00 16:53         0.1Kb
rew2.gif                         7 Aug 00 16:53         0.1Kb
edit.gif                        30 Mar 00 19:33         0.1Kb
mix.gif                         30 Mar 00 19:35         0.2Kb
edit2.gif                       30 Mar 00 19:33         0.2Kb
vertic.gif                       6 May 01 12:22         0.2Kb
reset.gif                       30 Mar 00 19:36         0.2Kb
solve.gif                       30 Mar 00 19:38         0.2Kb
horiz.gif                        6 May 01 12:22         0.2Kb
flip.gif                         6 May 01 12:22         0.2Kb
pause.gif                        6 May 01 12:22         0.2Kb
solve2.gif                      30 Mar 00 19:38         0.2Kb
help.gif                        17 Oct 00 21:11         0.2Kb
turn.gif                         1 Jan 01 19:35         0.2Kb
mode4.gif                        4 Nov 01 19:27         0.2Kb
mode1.gif                        4 Nov 01 19:27         0.2Kb
mode2.gif                        4 Nov 01 19:27         0.2Kb
mode3.gif                        4 Nov 01 19:27         0.2Kb
meffert.gif                      6 Mar 00 14:03         0.9Kb
favicon.ico                      6 May 01 12:22         1.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/buttons/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
favicon.ico                      6 May 01 12:22         1.1Kb
meffert.gif                      6 Mar 00 14:03         0.9Kb
mode3.gif                        4 Nov 01 19:27         0.2Kb
mode2.gif                        4 Nov 01 19:27         0.2Kb
mode1.gif                        4 Nov 01 19:27         0.2Kb
mode4.gif                        4 Nov 01 19:27         0.2Kb
turn.gif                         1 Jan 01 19:35         0.2Kb
help.gif                        17 Oct 00 21:11         0.2Kb
solve2.gif                      30 Mar 00 19:38         0.2Kb
pause.gif                        6 May 01 12:22         0.2Kb
flip.gif                         6 May 01 12:22         0.2Kb
horiz.gif                        6 May 01 12:22         0.2Kb
solve.gif                       30 Mar 00 19:38         0.2Kb
reset.gif                       30 Mar 00 19:36         0.2Kb
vertic.gif                       6 May 01 12:22         0.2Kb
edit2.gif                       30 Mar 00 19:33         0.2Kb
mix.gif                         30 Mar 00 19:35         0.2Kb
edit.gif                        30 Mar 00 19:33         0.1Kb
rew2.gif                         7 Aug 00 16:53         0.1Kb
ff2.gif                          7 Aug 00 16:53         0.1Kb
ff.gif                          20 Jun 00 11:09         0.1Kb
rew.gif                         20 Jun 00 11:09         0.1Kb
down.gif                         1 Jun 00 18:32         0.1Kb
up.gif                           1 Jun 00 18:32         0.1Kb
play.gif                        20 Jun 00 11:09         0.1Kb
back.gif                        20 Jun 00 11:09         0.1Kb
right.gif                        1 Jun 00 18:32         0.1Kb
left.gif                         1 Jun 00 18:32         0.1Kb
blank.gif                       20 Jun 00 10:52         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/buttons/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
meffert.gif                      6 Mar 00 14:03         0.9Kb
edit2.gif                       30 Mar 00 19:33         0.2Kb
edit.gif                        30 Mar 00 19:33         0.1Kb
mix.gif                         30 Mar 00 19:35         0.2Kb
reset.gif                       30 Mar 00 19:36         0.2Kb
solve.gif                       30 Mar 00 19:38         0.2Kb
solve2.gif                      30 Mar 00 19:38         0.2Kb
down.gif                         1 Jun 00 18:32         0.1Kb
left.gif                         1 Jun 00 18:32         0.1Kb
right.gif                        1 Jun 00 18:32         0.1Kb
up.gif                           1 Jun 00 18:32         0.1Kb
blank.gif                       20 Jun 00 10:52         0.0Kb
play.gif                        20 Jun 00 11:09         0.1Kb
rew.gif                         20 Jun 00 11:09         0.1Kb
back.gif                        20 Jun 00 11:09         0.1Kb
ff.gif                          20 Jun 00 11:09         0.1Kb
ff2.gif                          7 Aug 00 16:53         0.1Kb
rew2.gif                         7 Aug 00 16:53         0.1Kb
help.gif                        17 Oct 00 21:11         0.2Kb
turn.gif                         1 Jan 01 19:35         0.2Kb
favicon.ico                      6 May 01 12:22         1.1Kb
flip.gif                         6 May 01 12:22         0.2Kb
horiz.gif                        6 May 01 12:22         0.2Kb
pause.gif                        6 May 01 12:22         0.2Kb
vertic.gif                       6 May 01 12:22         0.2Kb
mode1.gif                        4 Nov 01 19:27         0.2Kb
mode2.gif                        4 Nov 01 19:27         0.2Kb
mode3.gif                        4 Nov 01 19:27         0.2Kb
mode4.gif                        4 Nov 01 19:27         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/buttons/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
mode4.gif                        4 Nov 01 19:27         0.2Kb
mode3.gif                        4 Nov 01 19:27         0.2Kb
mode2.gif                        4 Nov 01 19:27         0.2Kb
mode1.gif                        4 Nov 01 19:27         0.2Kb
vertic.gif                       6 May 01 12:22         0.2Kb
pause.gif                        6 May 01 12:22         0.2Kb
horiz.gif                        6 May 01 12:22         0.2Kb
flip.gif                         6 May 01 12:22         0.2Kb
favicon.ico                      6 May 01 12:22         1.1Kb
turn.gif                         1 Jan 01 19:35         0.2Kb
help.gif                        17 Oct 00 21:11         0.2Kb
rew2.gif                         7 Aug 00 16:53         0.1Kb
ff2.gif                          7 Aug 00 16:53         0.1Kb
ff.gif                          20 Jun 00 11:09         0.1Kb
back.gif                        20 Jun 00 11:09         0.1Kb
rew.gif                         20 Jun 00 11:09         0.1Kb
play.gif                        20 Jun 00 11:09         0.1Kb
blank.gif                       20 Jun 00 10:52         0.0Kb
up.gif                           1 Jun 00 18:32         0.1Kb
right.gif                        1 Jun 00 18:32         0.1Kb
left.gif                         1 Jun 00 18:32         0.1Kb
down.gif                         1 Jun 00 18:32         0.1Kb
solve2.gif                      30 Mar 00 19:38         0.2Kb
solve.gif                       30 Mar 00 19:38         0.2Kb
reset.gif                       30 Mar 00 19:36         0.2Kb
mix.gif                         30 Mar 00 19:35         0.2Kb
edit.gif                        30 Mar 00 19:33         0.1Kb
edit2.gif                       30 Mar 00 19:33         0.2Kb
meffert.gif                      6 Mar 00 14:03         0.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/clock/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
rc01b.gif                       16 Feb 00 19:30         0.3Kb
rc01bx.gif                      16 Feb 00 19:30         0.3Kb
rc01f.gif                       16 Feb 00 19:30         0.3Kb
rc01fx.gif                      16 Feb 00 19:30         0.3Kb
rc02b.gif                       16 Feb 00 19:30         0.3Kb
rc02bx.gif                      16 Feb 00 19:30         0.3Kb
rc02f.gif                       16 Feb 00 19:30         0.3Kb
rc02fx.gif                      16 Feb 00 19:30         0.3Kb
rc03b.gif                       16 Feb 00 19:30         0.3Kb
rc03bx.gif                      16 Feb 00 19:30         0.3Kb
rc03f.gif                       16 Feb 00 19:30         0.3Kb
rc03fx.gif                      16 Feb 00 19:30         0.3Kb
rc04b.gif                       16 Feb 00 19:30         0.3Kb
rc04bx.gif                      16 Feb 00 19:30         0.3Kb
rc04f.gif                       16 Feb 00 19:30         0.3Kb
rc04fx.gif                      16 Feb 00 19:30         0.3Kb
rc05b.gif                       16 Feb 00 19:30         0.3Kb
rc05bx.gif                      16 Feb 00 19:30         0.3Kb
rc05f.gif                       16 Feb 00 19:30         0.3Kb
rc05fx.gif                      16 Feb 00 19:30         0.3Kb
rc06b.gif                       16 Feb 00 19:30         0.3Kb
rc06bx.gif                      16 Feb 00 19:30         0.3Kb
rc06f.gif                       16 Feb 00 19:30         0.3Kb
rc06fx.gif                      16 Feb 00 19:30         0.3Kb
rc07b.gif                       16 Feb 00 19:30         0.3Kb
rc07bx.gif                      16 Feb 00 19:30         0.3Kb
rc07f.gif                       16 Feb 00 19:30         0.3Kb
rc07fx.gif                      16 Feb 00 19:30         0.3Kb
rc08b.gif                       16 Feb 00 19:30         0.3Kb
rc08bx.gif                      16 Feb 00 19:30         0.3Kb
rc08f.gif                       16 Feb 00 19:30         0.3Kb
rc08fx.gif                      16 Feb 00 19:30         0.3Kb
rc09b.gif                       16 Feb 00 19:30         0.3Kb
rc09bx.gif                      16 Feb 00 19:30         0.3Kb
rc09f.gif                       16 Feb 00 19:30         0.3Kb
rc09fx.gif                      16 Feb 00 19:30         0.3Kb
rc10b.gif                       16 Feb 00 19:30         0.3Kb
rc10bx.gif                      16 Feb 00 19:30         0.3Kb
rc10f.gif                       16 Feb 00 19:30         0.3Kb
rc10fx.gif                      16 Feb 00 19:30         0.3Kb
rc11b.gif                       16 Feb 00 19:30         0.3Kb
rc11bx.gif                      16 Feb 00 19:30         0.3Kb
rc11f.gif                       16 Feb 00 19:30         0.3Kb
rc11fx.gif                      16 Feb 00 19:30         0.3Kb
rc12b.gif                       16 Feb 00 19:30         0.3Kb
rc12bx.gif                      16 Feb 00 19:30         0.3Kb
rc12f.gif                       16 Feb 00 19:30         0.3Kb
rc12fx.gif                      16 Feb 00 19:30         0.3Kb
rcborbd.gif                     16 Feb 00 19:30         0.4Kb
rcborbl.gif                     16 Feb 00 19:30         0.5Kb
rcborbr.gif                     16 Feb 00 19:30         0.6Kb
rcborbu.gif                     16 Feb 00 19:30         0.4Kb
rcborfd.gif                     16 Feb 00 19:30         0.4Kb
rcborfl.gif                     16 Feb 00 19:31         0.5Kb
rcborfr.gif                     16 Feb 00 19:31         0.6Kb
rcborfu.gif                     16 Feb 00 19:31         0.4Kb
rcib.gif                        16 Feb 00 19:31         0.1Kb
rcif.gif                        16 Feb 00 19:31         0.1Kb
rcmidbh.gif                     16 Feb 00 19:31         0.2Kb
rcmidbv.gif                     16 Feb 00 19:31         0.2Kb
rcmidfh.gif                     16 Feb 00 19:31         0.2Kb
rcmidfv.gif                     16 Feb 00 19:31         0.2Kb
rcob.gif                        16 Feb 00 19:31         0.1Kb
rcof.gif                        16 Feb 00 19:31         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/clock/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
rcof.gif                        16 Feb 00 19:31         0.1Kb
rcob.gif                        16 Feb 00 19:31         0.1Kb
rcmidfv.gif                     16 Feb 00 19:31         0.2Kb
rcmidfh.gif                     16 Feb 00 19:31         0.2Kb
rcmidbv.gif                     16 Feb 00 19:31         0.2Kb
rcmidbh.gif                     16 Feb 00 19:31         0.2Kb
rcif.gif                        16 Feb 00 19:31         0.1Kb
rcib.gif                        16 Feb 00 19:31         0.1Kb
rcborfu.gif                     16 Feb 00 19:31         0.4Kb
rcborfr.gif                     16 Feb 00 19:31         0.6Kb
rcborfl.gif                     16 Feb 00 19:31         0.5Kb
rcborfd.gif                     16 Feb 00 19:30         0.4Kb
rcborbu.gif                     16 Feb 00 19:30         0.4Kb
rcborbr.gif                     16 Feb 00 19:30         0.6Kb
rcborbl.gif                     16 Feb 00 19:30         0.5Kb
rcborbd.gif                     16 Feb 00 19:30         0.4Kb
rc12fx.gif                      16 Feb 00 19:30         0.3Kb
rc12f.gif                       16 Feb 00 19:30         0.3Kb
rc12bx.gif                      16 Feb 00 19:30         0.3Kb
rc12b.gif                       16 Feb 00 19:30         0.3Kb
rc11fx.gif                      16 Feb 00 19:30         0.3Kb
rc11f.gif                       16 Feb 00 19:30         0.3Kb
rc11bx.gif                      16 Feb 00 19:30         0.3Kb
rc11b.gif                       16 Feb 00 19:30         0.3Kb
rc10fx.gif                      16 Feb 00 19:30         0.3Kb
rc10f.gif                       16 Feb 00 19:30         0.3Kb
rc10bx.gif                      16 Feb 00 19:30         0.3Kb
rc10b.gif                       16 Feb 00 19:30         0.3Kb
rc09fx.gif                      16 Feb 00 19:30         0.3Kb
rc09f.gif                       16 Feb 00 19:30         0.3Kb
rc09bx.gif                      16 Feb 00 19:30         0.3Kb
rc09b.gif                       16 Feb 00 19:30         0.3Kb
rc08fx.gif                      16 Feb 00 19:30         0.3Kb
rc08f.gif                       16 Feb 00 19:30         0.3Kb
rc08bx.gif                      16 Feb 00 19:30         0.3Kb
rc08b.gif                       16 Feb 00 19:30         0.3Kb
rc07fx.gif                      16 Feb 00 19:30         0.3Kb
rc07f.gif                       16 Feb 00 19:30         0.3Kb
rc07bx.gif                      16 Feb 00 19:30         0.3Kb
rc07b.gif                       16 Feb 00 19:30         0.3Kb
rc06fx.gif                      16 Feb 00 19:30         0.3Kb
rc06f.gif                       16 Feb 00 19:30         0.3Kb
rc06bx.gif                      16 Feb 00 19:30         0.3Kb
rc06b.gif                       16 Feb 00 19:30         0.3Kb
rc05fx.gif                      16 Feb 00 19:30         0.3Kb
rc05f.gif                       16 Feb 00 19:30         0.3Kb
rc05bx.gif                      16 Feb 00 19:30         0.3Kb
rc05b.gif                       16 Feb 00 19:30         0.3Kb
rc04fx.gif                      16 Feb 00 19:30         0.3Kb
rc04f.gif                       16 Feb 00 19:30         0.3Kb
rc04bx.gif                      16 Feb 00 19:30         0.3Kb
rc04b.gif                       16 Feb 00 19:30         0.3Kb
rc03fx.gif                      16 Feb 00 19:30         0.3Kb
rc03f.gif                       16 Feb 00 19:30         0.3Kb
rc03bx.gif                      16 Feb 00 19:30         0.3Kb
rc03b.gif                       16 Feb 00 19:30         0.3Kb
rc02fx.gif                      16 Feb 00 19:30         0.3Kb
rc02f.gif                       16 Feb 00 19:30         0.3Kb
rc02bx.gif                      16 Feb 00 19:30         0.3Kb
rc02b.gif                       16 Feb 00 19:30         0.3Kb
rc01fx.gif                      16 Feb 00 19:30         0.3Kb
rc01f.gif                       16 Feb 00 19:30         0.3Kb
rc01bx.gif                      16 Feb 00 19:30         0.3Kb
rc01b.gif                       16 Feb 00 19:30         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/clock/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
rcob.gif                        16 Feb 00 19:31         0.1Kb
rcof.gif                        16 Feb 00 19:31         0.1Kb
rcib.gif                        16 Feb 00 19:31         0.1Kb
rcif.gif                        16 Feb 00 19:31         0.1Kb
rcmidbh.gif                     16 Feb 00 19:31         0.2Kb
rcmidfh.gif                     16 Feb 00 19:31         0.2Kb
rcmidbv.gif                     16 Feb 00 19:31         0.2Kb
rcmidfv.gif                     16 Feb 00 19:31         0.2Kb
rc09b.gif                       16 Feb 00 19:30         0.3Kb
rc09bx.gif                      16 Feb 00 19:30         0.3Kb
rc09f.gif                       16 Feb 00 19:30         0.3Kb
rc09fx.gif                      16 Feb 00 19:30         0.3Kb
rc10b.gif                       16 Feb 00 19:30         0.3Kb
rc10bx.gif                      16 Feb 00 19:30         0.3Kb
rc02f.gif                       16 Feb 00 19:30         0.3Kb
rc02fx.gif                      16 Feb 00 19:30         0.3Kb
rc03b.gif                       16 Feb 00 19:30         0.3Kb
rc03bx.gif                      16 Feb 00 19:30         0.3Kb
rc03f.gif                       16 Feb 00 19:30         0.3Kb
rc03fx.gif                      16 Feb 00 19:30         0.3Kb
rc07b.gif                       16 Feb 00 19:30         0.3Kb
rc07bx.gif                      16 Feb 00 19:30         0.3Kb
rc07f.gif                       16 Feb 00 19:30         0.3Kb
rc07fx.gif                      16 Feb 00 19:30         0.3Kb
rc10f.gif                       16 Feb 00 19:30         0.3Kb
rc10fx.gif                      16 Feb 00 19:30         0.3Kb
rc05b.gif                       16 Feb 00 19:30         0.3Kb
rc05bx.gif                      16 Feb 00 19:30         0.3Kb
rc08b.gif                       16 Feb 00 19:30         0.3Kb
rc08bx.gif                      16 Feb 00 19:30         0.3Kb
rc02b.gif                       16 Feb 00 19:30         0.3Kb
rc02bx.gif                      16 Feb 00 19:30         0.3Kb
rc04b.gif                       16 Feb 00 19:30         0.3Kb
rc04bx.gif                      16 Feb 00 19:30         0.3Kb
rc08f.gif                       16 Feb 00 19:30         0.3Kb
rc08fx.gif                      16 Feb 00 19:30         0.3Kb
rc12b.gif                       16 Feb 00 19:30         0.3Kb
rc12bx.gif                      16 Feb 00 19:30         0.3Kb
rc12f.gif                       16 Feb 00 19:30         0.3Kb
rc12fx.gif                      16 Feb 00 19:30         0.3Kb
rc01b.gif                       16 Feb 00 19:30         0.3Kb
rc01bx.gif                      16 Feb 00 19:30         0.3Kb
rc04f.gif                       16 Feb 00 19:30         0.3Kb
rc04fx.gif                      16 Feb 00 19:30         0.3Kb
rc05f.gif                       16 Feb 00 19:30         0.3Kb
rc05fx.gif                      16 Feb 00 19:30         0.3Kb
rc06b.gif                       16 Feb 00 19:30         0.3Kb
rc06bx.gif                      16 Feb 00 19:30         0.3Kb
rc06f.gif                       16 Feb 00 19:30         0.3Kb
rc06fx.gif                      16 Feb 00 19:30         0.3Kb
rc11b.gif                       16 Feb 00 19:30         0.3Kb
rc11bx.gif                      16 Feb 00 19:30         0.3Kb
rc11f.gif                       16 Feb 00 19:30         0.3Kb
rc11fx.gif                      16 Feb 00 19:30         0.3Kb
rc01f.gif                       16 Feb 00 19:30         0.3Kb
rc01fx.gif                      16 Feb 00 19:30         0.3Kb
rcborbd.gif                     16 Feb 00 19:30         0.4Kb
rcborfd.gif                     16 Feb 00 19:30         0.4Kb
rcborbu.gif                     16 Feb 00 19:30         0.4Kb
rcborfu.gif                     16 Feb 00 19:31         0.4Kb
rcborbl.gif                     16 Feb 00 19:30         0.5Kb
rcborfl.gif                     16 Feb 00 19:31         0.5Kb
rcborbr.gif                     16 Feb 00 19:30         0.6Kb
rcborfr.gif                     16 Feb 00 19:31         0.6Kb
_____________________________________________________________


Index of /jaap/puzzles/images/clock/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
rcborfr.gif                     16 Feb 00 19:31         0.6Kb
rcborbr.gif                     16 Feb 00 19:30         0.6Kb
rcborfl.gif                     16 Feb 00 19:31         0.5Kb
rcborbl.gif                     16 Feb 00 19:30         0.5Kb
rcborfu.gif                     16 Feb 00 19:31         0.4Kb
rcborbu.gif                     16 Feb 00 19:30         0.4Kb
rcborfd.gif                     16 Feb 00 19:30         0.4Kb
rcborbd.gif                     16 Feb 00 19:30         0.4Kb
rc01fx.gif                      16 Feb 00 19:30         0.3Kb
rc01f.gif                       16 Feb 00 19:30         0.3Kb
rc11fx.gif                      16 Feb 00 19:30         0.3Kb
rc11f.gif                       16 Feb 00 19:30         0.3Kb
rc11bx.gif                      16 Feb 00 19:30         0.3Kb
rc11b.gif                       16 Feb 00 19:30         0.3Kb
rc06fx.gif                      16 Feb 00 19:30         0.3Kb
rc06f.gif                       16 Feb 00 19:30         0.3Kb
rc06bx.gif                      16 Feb 00 19:30         0.3Kb
rc06b.gif                       16 Feb 00 19:30         0.3Kb
rc05fx.gif                      16 Feb 00 19:30         0.3Kb
rc05f.gif                       16 Feb 00 19:30         0.3Kb
rc04fx.gif                      16 Feb 00 19:30         0.3Kb
rc04f.gif                       16 Feb 00 19:30         0.3Kb
rc01bx.gif                      16 Feb 00 19:30         0.3Kb
rc01b.gif                       16 Feb 00 19:30         0.3Kb
rc12fx.gif                      16 Feb 00 19:30         0.3Kb
rc12f.gif                       16 Feb 00 19:30         0.3Kb
rc12bx.gif                      16 Feb 00 19:30         0.3Kb
rc12b.gif                       16 Feb 00 19:30         0.3Kb
rc08fx.gif                      16 Feb 00 19:30         0.3Kb
rc08f.gif                       16 Feb 00 19:30         0.3Kb
rc04bx.gif                      16 Feb 00 19:30         0.3Kb
rc04b.gif                       16 Feb 00 19:30         0.3Kb
rc02bx.gif                      16 Feb 00 19:30         0.3Kb
rc02b.gif                       16 Feb 00 19:30         0.3Kb
rc08bx.gif                      16 Feb 00 19:30         0.3Kb
rc08b.gif                       16 Feb 00 19:30         0.3Kb
rc05bx.gif                      16 Feb 00 19:30         0.3Kb
rc05b.gif                       16 Feb 00 19:30         0.3Kb
rc10fx.gif                      16 Feb 00 19:30         0.3Kb
rc10f.gif                       16 Feb 00 19:30         0.3Kb
rc07fx.gif                      16 Feb 00 19:30         0.3Kb
rc07f.gif                       16 Feb 00 19:30         0.3Kb
rc07bx.gif                      16 Feb 00 19:30         0.3Kb
rc07b.gif                       16 Feb 00 19:30         0.3Kb
rc03fx.gif                      16 Feb 00 19:30         0.3Kb
rc03f.gif                       16 Feb 00 19:30         0.3Kb
rc03bx.gif                      16 Feb 00 19:30         0.3Kb
rc03b.gif                       16 Feb 00 19:30         0.3Kb
rc02fx.gif                      16 Feb 00 19:30         0.3Kb
rc02f.gif                       16 Feb 00 19:30         0.3Kb
rc10bx.gif                      16 Feb 00 19:30         0.3Kb
rc10b.gif                       16 Feb 00 19:30         0.3Kb
rc09fx.gif                      16 Feb 00 19:30         0.3Kb
rc09f.gif                       16 Feb 00 19:30         0.3Kb
rc09bx.gif                      16 Feb 00 19:30         0.3Kb
rc09b.gif                       16 Feb 00 19:30         0.3Kb
rcmidfv.gif                     16 Feb 00 19:31         0.2Kb
rcmidbv.gif                     16 Feb 00 19:31         0.2Kb
rcmidfh.gif                     16 Feb 00 19:31         0.2Kb
rcmidbh.gif                     16 Feb 00 19:31         0.2Kb
rcif.gif                        16 Feb 00 19:31         0.1Kb
rcib.gif                        16 Feb 00 19:31         0.1Kb
rcof.gif                        16 Feb 00 19:31         0.1Kb
rcob.gif                        16 Feb 00 19:31         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/clock/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
rc01b.gif                       16 Feb 00 19:30         0.3Kb
rc01bx.gif                      16 Feb 00 19:30         0.3Kb
rc01f.gif                       16 Feb 00 19:30         0.3Kb
rc01fx.gif                      16 Feb 00 19:30         0.3Kb
rc02b.gif                       16 Feb 00 19:30         0.3Kb
rc02bx.gif                      16 Feb 00 19:30         0.3Kb
rc02f.gif                       16 Feb 00 19:30         0.3Kb
rc02fx.gif                      16 Feb 00 19:30         0.3Kb
rc03b.gif                       16 Feb 00 19:30         0.3Kb
rc03bx.gif                      16 Feb 00 19:30         0.3Kb
rc03f.gif                       16 Feb 00 19:30         0.3Kb
rc03fx.gif                      16 Feb 00 19:30         0.3Kb
rc04b.gif                       16 Feb 00 19:30         0.3Kb
rc04bx.gif                      16 Feb 00 19:30         0.3Kb
rc04f.gif                       16 Feb 00 19:30         0.3Kb
rc04fx.gif                      16 Feb 00 19:30         0.3Kb
rc05b.gif                       16 Feb 00 19:30         0.3Kb
rc05bx.gif                      16 Feb 00 19:30         0.3Kb
rc05f.gif                       16 Feb 00 19:30         0.3Kb
rc05fx.gif                      16 Feb 00 19:30         0.3Kb
rc06b.gif                       16 Feb 00 19:30         0.3Kb
rc06bx.gif                      16 Feb 00 19:30         0.3Kb
rc06f.gif                       16 Feb 00 19:30         0.3Kb
rc06fx.gif                      16 Feb 00 19:30         0.3Kb
rc07b.gif                       16 Feb 00 19:30         0.3Kb
rc07bx.gif                      16 Feb 00 19:30         0.3Kb
rc07f.gif                       16 Feb 00 19:30         0.3Kb
rc07fx.gif                      16 Feb 00 19:30         0.3Kb
rc08b.gif                       16 Feb 00 19:30         0.3Kb
rc08bx.gif                      16 Feb 00 19:30         0.3Kb
rc08f.gif                       16 Feb 00 19:30         0.3Kb
rc08fx.gif                      16 Feb 00 19:30         0.3Kb
rc09b.gif                       16 Feb 00 19:30         0.3Kb
rc09bx.gif                      16 Feb 00 19:30         0.3Kb
rc09f.gif                       16 Feb 00 19:30         0.3Kb
rc09fx.gif                      16 Feb 00 19:30         0.3Kb
rc10b.gif                       16 Feb 00 19:30         0.3Kb
rc10bx.gif                      16 Feb 00 19:30         0.3Kb
rc10f.gif                       16 Feb 00 19:30         0.3Kb
rc10fx.gif                      16 Feb 00 19:30         0.3Kb
rc11b.gif                       16 Feb 00 19:30         0.3Kb
rc11bx.gif                      16 Feb 00 19:30         0.3Kb
rc11f.gif                       16 Feb 00 19:30         0.3Kb
rc11fx.gif                      16 Feb 00 19:30         0.3Kb
rc12b.gif                       16 Feb 00 19:30         0.3Kb
rc12bx.gif                      16 Feb 00 19:30         0.3Kb
rc12f.gif                       16 Feb 00 19:30         0.3Kb
rc12fx.gif                      16 Feb 00 19:30         0.3Kb
rcborbd.gif                     16 Feb 00 19:30         0.4Kb
rcborbl.gif                     16 Feb 00 19:30         0.5Kb
rcborbr.gif                     16 Feb 00 19:30         0.6Kb
rcborbu.gif                     16 Feb 00 19:30         0.4Kb
rcborfd.gif                     16 Feb 00 19:30         0.4Kb
rcborfl.gif                     16 Feb 00 19:31         0.5Kb
rcborfr.gif                     16 Feb 00 19:31         0.6Kb
rcborfu.gif                     16 Feb 00 19:31         0.4Kb
rcib.gif                        16 Feb 00 19:31         0.1Kb
rcif.gif                        16 Feb 00 19:31         0.1Kb
rcmidbh.gif                     16 Feb 00 19:31         0.2Kb
rcmidbv.gif                     16 Feb 00 19:31         0.2Kb
rcmidfh.gif                     16 Feb 00 19:31         0.2Kb
rcmidfv.gif                     16 Feb 00 19:31         0.2Kb
rcob.gif                        16 Feb 00 19:31         0.1Kb
rcof.gif                        16 Feb 00 19:31         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/clock/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
rcof.gif                        16 Feb 00 19:31         0.1Kb
rcob.gif                        16 Feb 00 19:31         0.1Kb
rcmidfv.gif                     16 Feb 00 19:31         0.2Kb
rcmidfh.gif                     16 Feb 00 19:31         0.2Kb
rcmidbv.gif                     16 Feb 00 19:31         0.2Kb
rcmidbh.gif                     16 Feb 00 19:31         0.2Kb
rcif.gif                        16 Feb 00 19:31         0.1Kb
rcib.gif                        16 Feb 00 19:31         0.1Kb
rcborfu.gif                     16 Feb 00 19:31         0.4Kb
rcborfr.gif                     16 Feb 00 19:31         0.6Kb
rcborfl.gif                     16 Feb 00 19:31         0.5Kb
rcborfd.gif                     16 Feb 00 19:30         0.4Kb
rcborbu.gif                     16 Feb 00 19:30         0.4Kb
rcborbr.gif                     16 Feb 00 19:30         0.6Kb
rcborbl.gif                     16 Feb 00 19:30         0.5Kb
rcborbd.gif                     16 Feb 00 19:30         0.4Kb
rc12fx.gif                      16 Feb 00 19:30         0.3Kb
rc12f.gif                       16 Feb 00 19:30         0.3Kb
rc12bx.gif                      16 Feb 00 19:30         0.3Kb
rc12b.gif                       16 Feb 00 19:30         0.3Kb
rc11fx.gif                      16 Feb 00 19:30         0.3Kb
rc11f.gif                       16 Feb 00 19:30         0.3Kb
rc11bx.gif                      16 Feb 00 19:30         0.3Kb
rc11b.gif                       16 Feb 00 19:30         0.3Kb
rc10fx.gif                      16 Feb 00 19:30         0.3Kb
rc10f.gif                       16 Feb 00 19:30         0.3Kb
rc10bx.gif                      16 Feb 00 19:30         0.3Kb
rc10b.gif                       16 Feb 00 19:30         0.3Kb
rc09fx.gif                      16 Feb 00 19:30         0.3Kb
rc09f.gif                       16 Feb 00 19:30         0.3Kb
rc09bx.gif                      16 Feb 00 19:30         0.3Kb
rc09b.gif                       16 Feb 00 19:30         0.3Kb
rc08fx.gif                      16 Feb 00 19:30         0.3Kb
rc08f.gif                       16 Feb 00 19:30         0.3Kb
rc08bx.gif                      16 Feb 00 19:30         0.3Kb
rc08b.gif                       16 Feb 00 19:30         0.3Kb
rc07fx.gif                      16 Feb 00 19:30         0.3Kb
rc07f.gif                       16 Feb 00 19:30         0.3Kb
rc07bx.gif                      16 Feb 00 19:30         0.3Kb
rc07b.gif                       16 Feb 00 19:30         0.3Kb
rc06fx.gif                      16 Feb 00 19:30         0.3Kb
rc06f.gif                       16 Feb 00 19:30         0.3Kb
rc06bx.gif                      16 Feb 00 19:30         0.3Kb
rc06b.gif                       16 Feb 00 19:30         0.3Kb
rc05fx.gif                      16 Feb 00 19:30         0.3Kb
rc05f.gif                       16 Feb 00 19:30         0.3Kb
rc05bx.gif                      16 Feb 00 19:30         0.3Kb
rc05b.gif                       16 Feb 00 19:30         0.3Kb
rc04fx.gif                      16 Feb 00 19:30         0.3Kb
rc04f.gif                       16 Feb 00 19:30         0.3Kb
rc04bx.gif                      16 Feb 00 19:30         0.3Kb
rc04b.gif                       16 Feb 00 19:30         0.3Kb
rc03fx.gif                      16 Feb 00 19:30         0.3Kb
rc03f.gif                       16 Feb 00 19:30         0.3Kb
rc03bx.gif                      16 Feb 00 19:30         0.3Kb
rc03b.gif                       16 Feb 00 19:30         0.3Kb
rc02fx.gif                      16 Feb 00 19:30         0.3Kb
rc02f.gif                       16 Feb 00 19:30         0.3Kb
rc02bx.gif                      16 Feb 00 19:30         0.3Kb
rc02b.gif                       16 Feb 00 19:30         0.3Kb
rc01fx.gif                      16 Feb 00 19:30         0.3Kb
rc01f.gif                       16 Feb 00 19:30         0.3Kb
rc01bx.gif                      16 Feb 00 19:30         0.3Kb
rc01b.gif                       16 Feb 00 19:30         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cube/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
lblank.gif                       3 Aug 00 15:52         0.2Kb
lblue.gif                        3 Aug 00 15:52         0.2Kb
lgreen.gif                       3 Aug 00 15:52         0.2Kb
lorange.gif                      3 Aug 00 15:52         0.2Kb
lred.gif                         3 Aug 00 15:52         0.2Kb
lwhite.gif                       6 May 01 12:56         0.2Kb
lyellow.gif                      3 Aug 00 15:52         0.2Kb
rblank.gif                       3 Aug 00 15:53         0.2Kb
rblue.gif                        3 Aug 00 15:53         0.2Kb
rgreen.gif                       3 Aug 00 15:53         0.2Kb
rorange.gif                      3 Aug 00 15:53         0.2Kb
rred.gif                         3 Aug 00 15:53         0.2Kb
rwhite.gif                       6 May 01 12:56         0.2Kb
ryellow.gif                      3 Aug 00 15:53         0.2Kb
ublank.gif                       3 Aug 00 15:53         0.2Kb
ublue.gif                        3 Aug 00 15:53         0.2Kb
ugreen.gif                       3 Aug 00 15:54         0.2Kb
uorange.gif                      3 Aug 00 15:54         0.2Kb
ured.gif                         3 Aug 00 15:54         0.2Kb
uwhite.gif                       6 May 01 12:56         0.2Kb
uyellow.gif                      3 Aug 00 15:54         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cube/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
uyellow.gif                      3 Aug 00 15:54         0.2Kb
uwhite.gif                       6 May 01 12:56         0.2Kb
ured.gif                         3 Aug 00 15:54         0.2Kb
uorange.gif                      3 Aug 00 15:54         0.2Kb
ugreen.gif                       3 Aug 00 15:54         0.2Kb
ublue.gif                        3 Aug 00 15:53         0.2Kb
ublank.gif                       3 Aug 00 15:53         0.2Kb
ryellow.gif                      3 Aug 00 15:53         0.2Kb
rwhite.gif                       6 May 01 12:56         0.2Kb
rred.gif                         3 Aug 00 15:53         0.2Kb
rorange.gif                      3 Aug 00 15:53         0.2Kb
rgreen.gif                       3 Aug 00 15:53         0.2Kb
rblue.gif                        3 Aug 00 15:53         0.2Kb
rblank.gif                       3 Aug 00 15:53         0.2Kb
lyellow.gif                      3 Aug 00 15:52         0.2Kb
lwhite.gif                       6 May 01 12:56         0.2Kb
lred.gif                         3 Aug 00 15:52         0.2Kb
lorange.gif                      3 Aug 00 15:52         0.2Kb
lgreen.gif                       3 Aug 00 15:52         0.2Kb
lblue.gif                        3 Aug 00 15:52         0.2Kb
lblank.gif                       3 Aug 00 15:52         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cube/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
ublank.gif                       3 Aug 00 15:53         0.2Kb
ublue.gif                        3 Aug 00 15:53         0.2Kb
ugreen.gif                       3 Aug 00 15:54         0.2Kb
uorange.gif                      3 Aug 00 15:54         0.2Kb
ured.gif                         3 Aug 00 15:54         0.2Kb
uwhite.gif                       6 May 01 12:56         0.2Kb
uyellow.gif                      3 Aug 00 15:54         0.2Kb
lblank.gif                       3 Aug 00 15:52         0.2Kb
lblue.gif                        3 Aug 00 15:52         0.2Kb
lgreen.gif                       3 Aug 00 15:52         0.2Kb
lorange.gif                      3 Aug 00 15:52         0.2Kb
lred.gif                         3 Aug 00 15:52         0.2Kb
lwhite.gif                       6 May 01 12:56         0.2Kb
lyellow.gif                      3 Aug 00 15:52         0.2Kb
rblank.gif                       3 Aug 00 15:53         0.2Kb
rblue.gif                        3 Aug 00 15:53         0.2Kb
rgreen.gif                       3 Aug 00 15:53         0.2Kb
rorange.gif                      3 Aug 00 15:53         0.2Kb
rred.gif                         3 Aug 00 15:53         0.2Kb
rwhite.gif                       6 May 01 12:56         0.2Kb
ryellow.gif                      3 Aug 00 15:53         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cube/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
ryellow.gif                      3 Aug 00 15:53         0.2Kb
rwhite.gif                       6 May 01 12:56         0.2Kb
rred.gif                         3 Aug 00 15:53         0.2Kb
rorange.gif                      3 Aug 00 15:53         0.2Kb
rgreen.gif                       3 Aug 00 15:53         0.2Kb
rblue.gif                        3 Aug 00 15:53         0.2Kb
rblank.gif                       3 Aug 00 15:53         0.2Kb
lyellow.gif                      3 Aug 00 15:52         0.2Kb
lwhite.gif                       6 May 01 12:56         0.2Kb
lred.gif                         3 Aug 00 15:52         0.2Kb
lorange.gif                      3 Aug 00 15:52         0.2Kb
lgreen.gif                       3 Aug 00 15:52         0.2Kb
lblue.gif                        3 Aug 00 15:52         0.2Kb
lblank.gif                       3 Aug 00 15:52         0.2Kb
uyellow.gif                      3 Aug 00 15:54         0.2Kb
uwhite.gif                       6 May 01 12:56         0.2Kb
ured.gif                         3 Aug 00 15:54         0.2Kb
uorange.gif                      3 Aug 00 15:54         0.2Kb
ugreen.gif                       3 Aug 00 15:54         0.2Kb
ublue.gif                        3 Aug 00 15:53         0.2Kb
ublank.gif                       3 Aug 00 15:53         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cube/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
lblank.gif                       3 Aug 00 15:52         0.2Kb
lblue.gif                        3 Aug 00 15:52         0.2Kb
lgreen.gif                       3 Aug 00 15:52         0.2Kb
lorange.gif                      3 Aug 00 15:52         0.2Kb
lred.gif                         3 Aug 00 15:52         0.2Kb
lyellow.gif                      3 Aug 00 15:52         0.2Kb
rblank.gif                       3 Aug 00 15:53         0.2Kb
rblue.gif                        3 Aug 00 15:53         0.2Kb
rgreen.gif                       3 Aug 00 15:53         0.2Kb
rorange.gif                      3 Aug 00 15:53         0.2Kb
rred.gif                         3 Aug 00 15:53         0.2Kb
ryellow.gif                      3 Aug 00 15:53         0.2Kb
ublank.gif                       3 Aug 00 15:53         0.2Kb
ublue.gif                        3 Aug 00 15:53         0.2Kb
ugreen.gif                       3 Aug 00 15:54         0.2Kb
uorange.gif                      3 Aug 00 15:54         0.2Kb
ured.gif                         3 Aug 00 15:54         0.2Kb
uyellow.gif                      3 Aug 00 15:54         0.2Kb
lwhite.gif                       6 May 01 12:56         0.2Kb
rwhite.gif                       6 May 01 12:56         0.2Kb
uwhite.gif                       6 May 01 12:56         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cube/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
uwhite.gif                       6 May 01 12:56         0.2Kb
rwhite.gif                       6 May 01 12:56         0.2Kb
lwhite.gif                       6 May 01 12:56         0.2Kb
uyellow.gif                      3 Aug 00 15:54         0.2Kb
ured.gif                         3 Aug 00 15:54         0.2Kb
uorange.gif                      3 Aug 00 15:54         0.2Kb
ugreen.gif                       3 Aug 00 15:54         0.2Kb
ublue.gif                        3 Aug 00 15:53         0.2Kb
ublank.gif                       3 Aug 00 15:53         0.2Kb
ryellow.gif                      3 Aug 00 15:53         0.2Kb
rred.gif                         3 Aug 00 15:53         0.2Kb
rorange.gif                      3 Aug 00 15:53         0.2Kb
rgreen.gif                       3 Aug 00 15:53         0.2Kb
rblue.gif                        3 Aug 00 15:53         0.2Kb
rblank.gif                       3 Aug 00 15:53         0.2Kb
lyellow.gif                      3 Aug 00 15:52         0.2Kb
lred.gif                         3 Aug 00 15:52         0.2Kb
lorange.gif                      3 Aug 00 15:52         0.2Kb
lgreen.gif                       3 Aug 00 15:52         0.2Kb
lblue.gif                        3 Aug 00 15:52         0.2Kb
lblank.gif                       3 Aug 00 15:52         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cubic/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
cub1-00.gif                      4 Nov 01 19:28         0.3Kb
cub1-01.gif                      4 Nov 01 19:28         1.0Kb
cub1-02.gif                      4 Nov 01 19:28         1.0Kb
cub1-03.gif                      4 Nov 01 19:28         0.9Kb
cub1-04.gif                      4 Nov 01 19:28         1.2Kb
cub1-04b.gif                     4 Nov 01 19:28         1.0Kb
cub1-04c.gif                     4 Nov 01 19:28         1.6Kb
cub1-05.gif                      4 Nov 01 19:28         1.1Kb
cub1-06.gif                      4 Nov 01 19:28         0.9Kb
cub1-07.gif                      4 Nov 01 19:28         0.7Kb
cub1-08.gif                      4 Nov 01 19:28         1.0Kb
cub1-09.gif                      4 Nov 01 19:28         0.9Kb
cub1-10.gif                      4 Nov 01 19:28         0.5Kb
cub1-11.gif                      4 Nov 01 19:28         0.5Kb
cub1-12.gif                      4 Nov 01 19:28         0.4Kb
cub1-13.gif                      4 Nov 01 19:28         3.4Kb
cub2-01.gif                      4 Nov 01 19:28         0.7Kb
cub2-02.gif                      4 Nov 01 19:28         2.3Kb
cub2-03.gif                      4 Nov 01 19:28         1.4Kb
cub2-04.gif                      4 Nov 01 19:28         1.1Kb
cub2-05.gif                      4 Nov 01 19:28         1.4Kb
cub3-01.gif                      4 Nov 01 19:28         1.0Kb
cub3-02.gif                      4 Nov 01 19:28         0.8Kb
cub3-03.gif                      4 Nov 01 19:28         1.8Kb
cub3-04.gif                      4 Nov 01 19:28         1.7Kb
cub3-05.gif                      4 Nov 01 19:29         1.4Kb
cub3-06.gif                      4 Nov 01 19:29         0.9Kb
cub3-07.gif                      4 Nov 01 19:29         0.8Kb
cub3-08.gif                      4 Nov 01 19:29         1.7Kb
cub3-09.gif                      4 Nov 01 19:29         0.9Kb
cub3-10.gif                      4 Nov 01 19:29         0.8Kb
cub3-11.gif                      4 Nov 01 19:29         2.0Kb
cub3-12.gif                      4 Nov 01 19:29         1.8Kb
cub3-13.gif                      4 Nov 01 19:29         2.0Kb
cub3-14.gif                      4 Nov 01 19:29         1.9Kb
cub3-15.gif                      4 Nov 01 19:29         1.8Kb
cub3-16.gif                      4 Nov 01 19:29         1.9Kb
cub3-17.gif                      4 Nov 01 19:29         2.0Kb
cub3-18.gif                      4 Nov 01 19:29         1.0Kb
cub3-19.gif                      4 Nov 01 19:29         0.5Kb
cub3-20.gif                      4 Nov 01 19:29         0.5Kb
cub3-21.gif                      4 Nov 01 19:29         0.7Kb
cub3-22.gif                      4 Nov 01 19:29         1.0Kb
cub3-23.gif                      4 Nov 01 19:29         0.8Kb
cub3-24.gif                      4 Nov 01 19:29         1.6Kb
cub3-25.gif                      4 Nov 01 19:29         0.4Kb
cub3-26.gif                      4 Nov 01 19:29         1.1Kb
cub3-27.gif                      4 Nov 01 19:29         0.4Kb
cub3-28.gif                      4 Nov 01 19:29         0.7Kb
cub3-29.gif                      4 Nov 01 19:29         0.7Kb
cub3-30.gif                      4 Nov 01 19:29         0.7Kb
cub3-31.gif                      4 Nov 01 19:29         0.7Kb
cub3-32.gif                      4 Nov 01 19:29         0.7Kb
cub3-33.gif                      4 Nov 01 19:29         0.7Kb
cub3-34.gif                      4 Nov 01 19:29         0.7Kb
cub3-35.gif                      4 Nov 01 19:29         0.7Kb
cub3-36.gif                      4 Nov 01 19:29         1.3Kb
cub3-37.gif                      4 Nov 01 19:29         0.7Kb
cub3-38.gif                      4 Nov 01 19:29         2.2Kb
cub3-39.gif                      4 Nov 01 19:29         1.1Kb
cub5-01.gif                      4 Nov 01 19:29         0.3Kb
cub5-02.gif                      4 Nov 01 19:29         0.6Kb
cub5-03.gif                      4 Nov 01 19:29         2.8Kb
cub5-05.gif                      4 Nov 01 19:29         0.6Kb
cub5-06.gif                      4 Nov 01 19:29         0.7Kb
cub5-07.gif                      4 Nov 01 19:29         0.7Kb
cub5-08.gif                      4 Nov 01 19:29         0.1Kb
cub5-09.gif                      4 Nov 01 19:29         0.9Kb
cub5-10.gif                      4 Nov 01 19:29         0.9Kb
cub5-11.gif                      4 Nov 01 19:29         0.7Kb
cub5-12.gif                      4 Nov 01 19:29         0.7Kb
cub5-13.gif                      4 Nov 01 19:29         0.9Kb
cub5-14.gif                      4 Nov 01 19:29         0.8Kb
cub5-15.gif                      4 Nov 01 19:29         0.3Kb
cub5-16.gif                      4 Nov 01 19:29         0.9Kb
cub5-17.gif                      4 Nov 01 19:29         1.0Kb
cub5-18.gif                      4 Nov 01 19:29         1.2Kb
cub5-19.gif                      4 Nov 01 19:29         1.1Kb
cub5-20.gif                      4 Nov 01 19:29         1.1Kb
cub5-21.gif                      4 Nov 01 19:30         1.0Kb
cub5-22.gif                      4 Nov 01 19:30         1.1Kb
cub5-23.gif                      4 Nov 01 19:30         1.0Kb
cub5-24.gif                      4 Nov 01 19:30         1.0Kb
cub5-25.jpg                      4 Nov 01 19:30        61.8Kb
cub7-01.gif                      4 Nov 01 19:30         1.1Kb
cub7-02.gif                      4 Nov 01 19:30         1.5Kb
cub7-03.gif                      4 Nov 01 19:30         0.5Kb
cub7-04.gif                      4 Nov 01 19:30         1.1Kb
cub7-05.gif                      4 Nov 01 19:30         0.7Kb
cub7-06.gif                      4 Nov 01 19:30         0.8Kb
cub7-07.gif                      4 Nov 01 19:30         2.2Kb
cub7-08.gif                      4 Nov 01 19:30         2.5Kb
cub7-09.gif                      4 Nov 01 19:30         0.8Kb
cub7-10.gif                      4 Nov 01 19:30         0.6Kb
cub7-11.gif                      4 Nov 01 19:30         0.7Kb
cub7-12.gif                      4 Nov 01 19:30         0.9Kb
cub7-13.gif                      4 Nov 01 19:30         1.2Kb
cub7-14.gif                      4 Nov 01 19:30         1.3Kb
cub7-15.gif                      4 Nov 01 19:30         0.2Kb
cub7-16.gif                      4 Nov 01 19:30         0.4Kb
cub7-17.gif                      4 Nov 01 19:30         0.4Kb
cub7-18.gif                      4 Nov 01 19:30         0.2Kb
cub7-19.gif                      4 Nov 01 19:30         1.3Kb
cub7-20.gif                      4 Nov 01 19:30         1.4Kb
cub7-21.gif                      4 Nov 01 19:30         3.1Kb
cub7-22.gif                      4 Nov 01 19:30         0.6Kb
cub7-23.gif                      4 Nov 01 19:30         0.5Kb
cub7-24.gif                      4 Nov 01 19:30         0.5Kb
cub7-25.gif                      4 Nov 01 19:30         0.5Kb
cub7-26.gif                      4 Nov 01 19:30         0.8Kb
cub7-27.gif                      4 Nov 01 19:30         1.8Kb
cub7-28.gif                      4 Nov 01 19:30         1.2Kb
cub7-29.gif                      4 Nov 01 19:30         1.0Kb
cub7-30.gif                      4 Nov 01 19:30         1.6Kb
cub7-31.gif                      4 Nov 01 19:30         1.6Kb
cub7-32.gif                      4 Nov 01 19:31         1.7Kb
cub7-33.gif                      4 Nov 01 19:31         2.3Kb
cub7-34.gif                      4 Nov 01 19:31         1.9Kb
cub7-35.gif                      4 Nov 01 19:31         0.4Kb
cub7-36.gif                      4 Nov 01 19:31         2.1Kb
cub7-37.gif                      4 Nov 01 19:31         2.1Kb
cub7-38.gif                      4 Nov 01 19:31         1.8Kb
cub7-39.gif                      4 Nov 01 19:31         2.4Kb
cub7-40.gif                      4 Nov 01 19:31         1.0Kb
cub7-41.gif                      4 Nov 01 19:31         0.7Kb
cub7-42.gif                      4 Nov 01 19:31         0.8Kb
cub7-43.gif                      4 Nov 01 19:31         0.8Kb
cub7-44.gif                      4 Nov 01 19:31         1.0Kb
cub7-45.gif                      4 Nov 01 19:31         1.3Kb
cub7-46.gif                      4 Nov 01 19:31         1.0Kb
cub7-47.gif                      4 Nov 01 19:31         1.1Kb
cub7-48.gif                      4 Nov 01 19:31         0.8Kb
cub7-49.gif                      4 Nov 01 19:31         1.2Kb
cub7-50.gif                      4 Nov 01 19:31         0.9Kb
cub7-51.gif                      4 Nov 01 19:31         1.2Kb
cub7-52.gif                      4 Nov 01 19:31         1.2Kb
cub7-53.gif                      4 Nov 01 19:31         1.6Kb
cub7-54.gif                      4 Nov 01 19:31         1.2Kb
cub7-55.gif                      4 Nov 01 19:31         1.4Kb
cub7-56.gif                      4 Nov 01 19:31         1.4Kb
cub7-57.gif                      4 Nov 01 19:31         0.7Kb
cub7-58.gif                      4 Nov 01 19:31         1.2Kb
cub7-59.gif                      4 Nov 01 19:31         0.9Kb
cub7-60.gif                      4 Nov 01 19:31         1.0Kb
cub7-61.gif                      4 Nov 01 19:31         0.5Kb
cub7-62.gif                      4 Nov 01 19:31         0.6Kb
cub7-63.gif                      4 Nov 01 19:31         0.7Kb
cub7-64.gif                      4 Nov 01 19:31         1.1Kb
cub7-65.gif                      4 Nov 01 19:31         0.9Kb
cub7-66.gif                      4 Nov 01 19:31         1.2Kb
cub7-67.gif                      4 Nov 01 19:31         0.1Kb
cub7-68.gif                      4 Nov 01 19:31         0.1Kb
cub7-69.gif                      4 Nov 01 19:31         0.2Kb
cub7-70.gif                      4 Nov 01 19:31         0.2Kb
cub7-71.gif                      4 Nov 01 19:31         0.2Kb
cub7-72.gif                      4 Nov 01 19:31         0.2Kb
cub7-73.gif                      4 Nov 01 19:31         0.2Kb
cub7-74.gif                      4 Nov 01 19:31         0.7Kb
cub7-75.gif                      4 Nov 01 19:31         1.5Kb
cub7-76.gif                      4 Nov 01 19:31         1.5Kb
cub7-77.gif                      4 Nov 01 19:31         1.3Kb
cub7-78.gif                      4 Nov 01 19:31         0.5Kb
cub7-79.gif                      4 Nov 01 19:31         3.0Kb
cublogo.gif                      4 Nov 01 19:31         1.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cubic/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
cublogo.gif                      4 Nov 01 19:31         1.5Kb
cub7-79.gif                      4 Nov 01 19:31         3.0Kb
cub7-78.gif                      4 Nov 01 19:31         0.5Kb
cub7-77.gif                      4 Nov 01 19:31         1.3Kb
cub7-76.gif                      4 Nov 01 19:31         1.5Kb
cub7-75.gif                      4 Nov 01 19:31         1.5Kb
cub7-74.gif                      4 Nov 01 19:31         0.7Kb
cub7-73.gif                      4 Nov 01 19:31         0.2Kb
cub7-72.gif                      4 Nov 01 19:31         0.2Kb
cub7-71.gif                      4 Nov 01 19:31         0.2Kb
cub7-70.gif                      4 Nov 01 19:31         0.2Kb
cub7-69.gif                      4 Nov 01 19:31         0.2Kb
cub7-68.gif                      4 Nov 01 19:31         0.1Kb
cub7-67.gif                      4 Nov 01 19:31         0.1Kb
cub7-66.gif                      4 Nov 01 19:31         1.2Kb
cub7-65.gif                      4 Nov 01 19:31         0.9Kb
cub7-64.gif                      4 Nov 01 19:31         1.1Kb
cub7-63.gif                      4 Nov 01 19:31         0.7Kb
cub7-62.gif                      4 Nov 01 19:31         0.6Kb
cub7-61.gif                      4 Nov 01 19:31         0.5Kb
cub7-60.gif                      4 Nov 01 19:31         1.0Kb
cub7-59.gif                      4 Nov 01 19:31         0.9Kb
cub7-58.gif                      4 Nov 01 19:31         1.2Kb
cub7-57.gif                      4 Nov 01 19:31         0.7Kb
cub7-56.gif                      4 Nov 01 19:31         1.4Kb
cub7-55.gif                      4 Nov 01 19:31         1.4Kb
cub7-54.gif                      4 Nov 01 19:31         1.2Kb
cub7-53.gif                      4 Nov 01 19:31         1.6Kb
cub7-52.gif                      4 Nov 01 19:31         1.2Kb
cub7-51.gif                      4 Nov 01 19:31         1.2Kb
cub7-50.gif                      4 Nov 01 19:31         0.9Kb
cub7-49.gif                      4 Nov 01 19:31         1.2Kb
cub7-48.gif                      4 Nov 01 19:31         0.8Kb
cub7-47.gif                      4 Nov 01 19:31         1.1Kb
cub7-46.gif                      4 Nov 01 19:31         1.0Kb
cub7-45.gif                      4 Nov 01 19:31         1.3Kb
cub7-44.gif                      4 Nov 01 19:31         1.0Kb
cub7-43.gif                      4 Nov 01 19:31         0.8Kb
cub7-42.gif                      4 Nov 01 19:31         0.8Kb
cub7-41.gif                      4 Nov 01 19:31         0.7Kb
cub7-40.gif                      4 Nov 01 19:31         1.0Kb
cub7-39.gif                      4 Nov 01 19:31         2.4Kb
cub7-38.gif                      4 Nov 01 19:31         1.8Kb
cub7-37.gif                      4 Nov 01 19:31         2.1Kb
cub7-36.gif                      4 Nov 01 19:31         2.1Kb
cub7-35.gif                      4 Nov 01 19:31         0.4Kb
cub7-34.gif                      4 Nov 01 19:31         1.9Kb
cub7-33.gif                      4 Nov 01 19:31         2.3Kb
cub7-32.gif                      4 Nov 01 19:31         1.7Kb
cub7-31.gif                      4 Nov 01 19:30         1.6Kb
cub7-30.gif                      4 Nov 01 19:30         1.6Kb
cub7-29.gif                      4 Nov 01 19:30         1.0Kb
cub7-28.gif                      4 Nov 01 19:30         1.2Kb
cub7-27.gif                      4 Nov 01 19:30         1.8Kb
cub7-26.gif                      4 Nov 01 19:30         0.8Kb
cub7-25.gif                      4 Nov 01 19:30         0.5Kb
cub7-24.gif                      4 Nov 01 19:30         0.5Kb
cub7-23.gif                      4 Nov 01 19:30         0.5Kb
cub7-22.gif                      4 Nov 01 19:30         0.6Kb
cub7-21.gif                      4 Nov 01 19:30         3.1Kb
cub7-20.gif                      4 Nov 01 19:30         1.4Kb
cub7-19.gif                      4 Nov 01 19:30         1.3Kb
cub7-18.gif                      4 Nov 01 19:30         0.2Kb
cub7-17.gif                      4 Nov 01 19:30         0.4Kb
cub7-16.gif                      4 Nov 01 19:30         0.4Kb
cub7-15.gif                      4 Nov 01 19:30         0.2Kb
cub7-14.gif                      4 Nov 01 19:30         1.3Kb
cub7-13.gif                      4 Nov 01 19:30         1.2Kb
cub7-12.gif                      4 Nov 01 19:30         0.9Kb
cub7-11.gif                      4 Nov 01 19:30         0.7Kb
cub7-10.gif                      4 Nov 01 19:30         0.6Kb
cub7-09.gif                      4 Nov 01 19:30         0.8Kb
cub7-08.gif                      4 Nov 01 19:30         2.5Kb
cub7-07.gif                      4 Nov 01 19:30         2.2Kb
cub7-06.gif                      4 Nov 01 19:30         0.8Kb
cub7-05.gif                      4 Nov 01 19:30         0.7Kb
cub7-04.gif                      4 Nov 01 19:30         1.1Kb
cub7-03.gif                      4 Nov 01 19:30         0.5Kb
cub7-02.gif                      4 Nov 01 19:30         1.5Kb
cub7-01.gif                      4 Nov 01 19:30         1.1Kb
cub5-25.jpg                      4 Nov 01 19:30        61.8Kb
cub5-24.gif                      4 Nov 01 19:30         1.0Kb
cub5-23.gif                      4 Nov 01 19:30         1.0Kb
cub5-22.gif                      4 Nov 01 19:30         1.1Kb
cub5-21.gif                      4 Nov 01 19:30         1.0Kb
cub5-20.gif                      4 Nov 01 19:29         1.1Kb
cub5-19.gif                      4 Nov 01 19:29         1.1Kb
cub5-18.gif                      4 Nov 01 19:29         1.2Kb
cub5-17.gif                      4 Nov 01 19:29         1.0Kb
cub5-16.gif                      4 Nov 01 19:29         0.9Kb
cub5-15.gif                      4 Nov 01 19:29         0.3Kb
cub5-14.gif                      4 Nov 01 19:29         0.8Kb
cub5-13.gif                      4 Nov 01 19:29         0.9Kb
cub5-12.gif                      4 Nov 01 19:29         0.7Kb
cub5-11.gif                      4 Nov 01 19:29         0.7Kb
cub5-10.gif                      4 Nov 01 19:29         0.9Kb
cub5-09.gif                      4 Nov 01 19:29         0.9Kb
cub5-08.gif                      4 Nov 01 19:29         0.1Kb
cub5-07.gif                      4 Nov 01 19:29         0.7Kb
cub5-06.gif                      4 Nov 01 19:29         0.7Kb
cub5-05.gif                      4 Nov 01 19:29         0.6Kb
cub5-03.gif                      4 Nov 01 19:29         2.8Kb
cub5-02.gif                      4 Nov 01 19:29         0.6Kb
cub5-01.gif                      4 Nov 01 19:29         0.3Kb
cub3-39.gif                      4 Nov 01 19:29         1.1Kb
cub3-38.gif                      4 Nov 01 19:29         2.2Kb
cub3-37.gif                      4 Nov 01 19:29         0.7Kb
cub3-36.gif                      4 Nov 01 19:29         1.3Kb
cub3-35.gif                      4 Nov 01 19:29         0.7Kb
cub3-34.gif                      4 Nov 01 19:29         0.7Kb
cub3-33.gif                      4 Nov 01 19:29         0.7Kb
cub3-32.gif                      4 Nov 01 19:29         0.7Kb
cub3-31.gif                      4 Nov 01 19:29         0.7Kb
cub3-30.gif                      4 Nov 01 19:29         0.7Kb
cub3-29.gif                      4 Nov 01 19:29         0.7Kb
cub3-28.gif                      4 Nov 01 19:29         0.7Kb
cub3-27.gif                      4 Nov 01 19:29         0.4Kb
cub3-26.gif                      4 Nov 01 19:29         1.1Kb
cub3-25.gif                      4 Nov 01 19:29         0.4Kb
cub3-24.gif                      4 Nov 01 19:29         1.6Kb
cub3-23.gif                      4 Nov 01 19:29         0.8Kb
cub3-22.gif                      4 Nov 01 19:29         1.0Kb
cub3-21.gif                      4 Nov 01 19:29         0.7Kb
cub3-20.gif                      4 Nov 01 19:29         0.5Kb
cub3-19.gif                      4 Nov 01 19:29         0.5Kb
cub3-18.gif                      4 Nov 01 19:29         1.0Kb
cub3-17.gif                      4 Nov 01 19:29         2.0Kb
cub3-16.gif                      4 Nov 01 19:29         1.9Kb
cub3-15.gif                      4 Nov 01 19:29         1.8Kb
cub3-14.gif                      4 Nov 01 19:29         1.9Kb
cub3-13.gif                      4 Nov 01 19:29         2.0Kb
cub3-12.gif                      4 Nov 01 19:29         1.8Kb
cub3-11.gif                      4 Nov 01 19:29         2.0Kb
cub3-10.gif                      4 Nov 01 19:29         0.8Kb
cub3-09.gif                      4 Nov 01 19:29         0.9Kb
cub3-08.gif                      4 Nov 01 19:29         1.7Kb
cub3-07.gif                      4 Nov 01 19:29         0.8Kb
cub3-06.gif                      4 Nov 01 19:29         0.9Kb
cub3-05.gif                      4 Nov 01 19:29         1.4Kb
cub3-04.gif                      4 Nov 01 19:28         1.7Kb
cub3-03.gif                      4 Nov 01 19:28         1.8Kb
cub3-02.gif                      4 Nov 01 19:28         0.8Kb
cub3-01.gif                      4 Nov 01 19:28         1.0Kb
cub2-05.gif                      4 Nov 01 19:28         1.4Kb
cub2-04.gif                      4 Nov 01 19:28         1.1Kb
cub2-03.gif                      4 Nov 01 19:28         1.4Kb
cub2-02.gif                      4 Nov 01 19:28         2.3Kb
cub2-01.gif                      4 Nov 01 19:28         0.7Kb
cub1-13.gif                      4 Nov 01 19:28         3.4Kb
cub1-12.gif                      4 Nov 01 19:28         0.4Kb
cub1-11.gif                      4 Nov 01 19:28         0.5Kb
cub1-10.gif                      4 Nov 01 19:28         0.5Kb
cub1-09.gif                      4 Nov 01 19:28         0.9Kb
cub1-08.gif                      4 Nov 01 19:28         1.0Kb
cub1-07.gif                      4 Nov 01 19:28         0.7Kb
cub1-06.gif                      4 Nov 01 19:28         0.9Kb
cub1-05.gif                      4 Nov 01 19:28         1.1Kb
cub1-04c.gif                     4 Nov 01 19:28         1.6Kb
cub1-04b.gif                     4 Nov 01 19:28         1.0Kb
cub1-04.gif                      4 Nov 01 19:28         1.2Kb
cub1-03.gif                      4 Nov 01 19:28         0.9Kb
cub1-02.gif                      4 Nov 01 19:28         1.0Kb
cub1-01.gif                      4 Nov 01 19:28         1.0Kb
cub1-00.gif                      4 Nov 01 19:28         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cubic/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
cub5-08.gif                      4 Nov 01 19:29         0.1Kb
cub7-67.gif                      4 Nov 01 19:31         0.1Kb
cub7-68.gif                      4 Nov 01 19:31         0.1Kb
cub7-69.gif                      4 Nov 01 19:31         0.2Kb
cub7-71.gif                      4 Nov 01 19:31         0.2Kb
cub7-73.gif                      4 Nov 01 19:31         0.2Kb
cub7-70.gif                      4 Nov 01 19:31         0.2Kb
cub7-72.gif                      4 Nov 01 19:31         0.2Kb
cub7-15.gif                      4 Nov 01 19:30         0.2Kb
cub7-18.gif                      4 Nov 01 19:30         0.2Kb
cub5-01.gif                      4 Nov 01 19:29         0.3Kb
cub1-00.gif                      4 Nov 01 19:28         0.3Kb
cub5-15.gif                      4 Nov 01 19:29         0.3Kb
cub3-27.gif                      4 Nov 01 19:29         0.4Kb
cub7-16.gif                      4 Nov 01 19:30         0.4Kb
cub7-17.gif                      4 Nov 01 19:30         0.4Kb
cub7-35.gif                      4 Nov 01 19:31         0.4Kb
cub3-25.gif                      4 Nov 01 19:29         0.4Kb
cub1-12.gif                      4 Nov 01 19:28         0.4Kb
cub1-10.gif                      4 Nov 01 19:28         0.5Kb
cub1-11.gif                      4 Nov 01 19:28         0.5Kb
cub7-24.gif                      4 Nov 01 19:30         0.5Kb
cub3-20.gif                      4 Nov 01 19:29         0.5Kb
cub3-19.gif                      4 Nov 01 19:29         0.5Kb
cub7-78.gif                      4 Nov 01 19:31         0.5Kb
cub7-03.gif                      4 Nov 01 19:30         0.5Kb
cub7-23.gif                      4 Nov 01 19:30         0.5Kb
cub7-25.gif                      4 Nov 01 19:30         0.5Kb
cub7-61.gif                      4 Nov 01 19:31         0.5Kb
cub7-22.gif                      4 Nov 01 19:30         0.6Kb
cub7-10.gif                      4 Nov 01 19:30         0.6Kb
cub5-02.gif                      4 Nov 01 19:29         0.6Kb
cub7-62.gif                      4 Nov 01 19:31         0.6Kb
cub5-05.gif                      4 Nov 01 19:29         0.6Kb
cub3-21.gif                      4 Nov 01 19:29         0.7Kb
cub5-07.gif                      4 Nov 01 19:29         0.7Kb
cub1-07.gif                      4 Nov 01 19:28         0.7Kb
cub3-32.gif                      4 Nov 01 19:29         0.7Kb
cub5-12.gif                      4 Nov 01 19:29         0.7Kb
cub3-34.gif                      4 Nov 01 19:29         0.7Kb
cub7-11.gif                      4 Nov 01 19:30         0.7Kb
cub3-35.gif                      4 Nov 01 19:29         0.7Kb
cub7-41.gif                      4 Nov 01 19:31         0.7Kb
cub3-31.gif                      4 Nov 01 19:29         0.7Kb
cub3-37.gif                      4 Nov 01 19:29         0.7Kb
cub3-28.gif                      4 Nov 01 19:29         0.7Kb
cub3-30.gif                      4 Nov 01 19:29         0.7Kb
cub3-33.gif                      4 Nov 01 19:29         0.7Kb
cub7-74.gif                      4 Nov 01 19:31         0.7Kb
cub3-29.gif                      4 Nov 01 19:29         0.7Kb
cub7-57.gif                      4 Nov 01 19:31         0.7Kb
cub2-01.gif                      4 Nov 01 19:28         0.7Kb
cub5-06.gif                      4 Nov 01 19:29         0.7Kb
cub5-11.gif                      4 Nov 01 19:29         0.7Kb
cub7-05.gif                      4 Nov 01 19:30         0.7Kb
cub7-63.gif                      4 Nov 01 19:31         0.7Kb
cub7-42.gif                      4 Nov 01 19:31         0.8Kb
cub3-10.gif                      4 Nov 01 19:29         0.8Kb
cub5-14.gif                      4 Nov 01 19:29         0.8Kb
cub3-02.gif                      4 Nov 01 19:28         0.8Kb
cub7-06.gif                      4 Nov 01 19:30         0.8Kb
cub3-23.gif                      4 Nov 01 19:29         0.8Kb
cub7-48.gif                      4 Nov 01 19:31         0.8Kb
cub7-26.gif                      4 Nov 01 19:30         0.8Kb
cub3-07.gif                      4 Nov 01 19:29         0.8Kb
cub7-09.gif                      4 Nov 01 19:30         0.8Kb
cub7-43.gif                      4 Nov 01 19:31         0.8Kb
cub7-50.gif                      4 Nov 01 19:31         0.9Kb
cub5-13.gif                      4 Nov 01 19:29         0.9Kb
cub5-16.gif                      4 Nov 01 19:29         0.9Kb
cub7-12.gif                      4 Nov 01 19:30         0.9Kb
cub5-10.gif                      4 Nov 01 19:29         0.9Kb
cub3-06.gif                      4 Nov 01 19:29         0.9Kb
cub5-09.gif                      4 Nov 01 19:29         0.9Kb
cub7-59.gif                      4 Nov 01 19:31         0.9Kb
cub1-09.gif                      4 Nov 01 19:28         0.9Kb
cub1-03.gif                      4 Nov 01 19:28         0.9Kb
cub7-65.gif                      4 Nov 01 19:31         0.9Kb
cub3-09.gif                      4 Nov 01 19:29         0.9Kb
cub1-06.gif                      4 Nov 01 19:28         0.9Kb
cub7-60.gif                      4 Nov 01 19:31         1.0Kb
cub1-02.gif                      4 Nov 01 19:28         1.0Kb
cub7-40.gif                      4 Nov 01 19:31         1.0Kb
cub7-46.gif                      4 Nov 01 19:31         1.0Kb
cub5-23.gif                      4 Nov 01 19:30         1.0Kb
cub1-08.gif                      4 Nov 01 19:28         1.0Kb
cub5-17.gif                      4 Nov 01 19:29         1.0Kb
cub5-21.gif                      4 Nov 01 19:30         1.0Kb
cub5-24.gif                      4 Nov 01 19:30         1.0Kb
cub7-44.gif                      4 Nov 01 19:31         1.0Kb
cub1-04b.gif                     4 Nov 01 19:28         1.0Kb
cub3-18.gif                      4 Nov 01 19:29         1.0Kb
cub3-01.gif                      4 Nov 01 19:28         1.0Kb
cub7-29.gif                      4 Nov 01 19:30         1.0Kb
cub1-01.gif                      4 Nov 01 19:28         1.0Kb
cub3-22.gif                      4 Nov 01 19:29         1.0Kb
cub7-01.gif                      4 Nov 01 19:30         1.1Kb
cub5-19.gif                      4 Nov 01 19:29         1.1Kb
cub5-20.gif                      4 Nov 01 19:29         1.1Kb
cub3-26.gif                      4 Nov 01 19:29         1.1Kb
cub7-04.gif                      4 Nov 01 19:30         1.1Kb
cub7-64.gif                      4 Nov 01 19:31         1.1Kb
cub2-04.gif                      4 Nov 01 19:28         1.1Kb
cub5-22.gif                      4 Nov 01 19:30         1.1Kb
cub1-05.gif                      4 Nov 01 19:28         1.1Kb
cub3-39.gif                      4 Nov 01 19:29         1.1Kb
cub7-47.gif                      4 Nov 01 19:31         1.1Kb
cub7-51.gif                      4 Nov 01 19:31         1.2Kb
cub7-54.gif                      4 Nov 01 19:31         1.2Kb
cub7-28.gif                      4 Nov 01 19:30         1.2Kb
cub7-58.gif                      4 Nov 01 19:31         1.2Kb
cub7-49.gif                      4 Nov 01 19:31         1.2Kb
cub7-66.gif                      4 Nov 01 19:31         1.2Kb
cub5-18.gif                      4 Nov 01 19:29         1.2Kb
cub1-04.gif                      4 Nov 01 19:28         1.2Kb
cub7-52.gif                      4 Nov 01 19:31         1.2Kb
cub7-13.gif                      4 Nov 01 19:30         1.2Kb
cub7-19.gif                      4 Nov 01 19:30         1.3Kb
cub7-45.gif                      4 Nov 01 19:31         1.3Kb
cub3-36.gif                      4 Nov 01 19:29         1.3Kb
cub7-14.gif                      4 Nov 01 19:30         1.3Kb
cub7-77.gif                      4 Nov 01 19:31         1.3Kb
cub7-55.gif                      4 Nov 01 19:31         1.4Kb
cub2-05.gif                      4 Nov 01 19:28         1.4Kb
cub3-05.gif                      4 Nov 01 19:29         1.4Kb
cub2-03.gif                      4 Nov 01 19:28         1.4Kb
cub7-20.gif                      4 Nov 01 19:30         1.4Kb
cub7-56.gif                      4 Nov 01 19:31         1.4Kb
cublogo.gif                      4 Nov 01 19:31         1.5Kb
cub7-02.gif                      4 Nov 01 19:30         1.5Kb
cub7-75.gif                      4 Nov 01 19:31         1.5Kb
cub7-76.gif                      4 Nov 01 19:31         1.5Kb
cub7-53.gif                      4 Nov 01 19:31         1.6Kb
cub3-24.gif                      4 Nov 01 19:29         1.6Kb
cub7-31.gif                      4 Nov 01 19:30         1.6Kb
cub7-30.gif                      4 Nov 01 19:30         1.6Kb
cub1-04c.gif                     4 Nov 01 19:28         1.6Kb
cub7-32.gif                      4 Nov 01 19:31         1.7Kb
cub3-04.gif                      4 Nov 01 19:28         1.7Kb
cub3-08.gif                      4 Nov 01 19:29         1.7Kb
cub3-12.gif                      4 Nov 01 19:29         1.8Kb
cub7-27.gif                      4 Nov 01 19:30         1.8Kb
cub3-03.gif                      4 Nov 01 19:28         1.8Kb
cub7-38.gif                      4 Nov 01 19:31         1.8Kb
cub3-15.gif                      4 Nov 01 19:29         1.8Kb
cub3-16.gif                      4 Nov 01 19:29         1.9Kb
cub7-34.gif                      4 Nov 01 19:31         1.9Kb
cub3-14.gif                      4 Nov 01 19:29         1.9Kb
cub3-17.gif                      4 Nov 01 19:29         2.0Kb
cub3-13.gif                      4 Nov 01 19:29         2.0Kb
cub3-11.gif                      4 Nov 01 19:29         2.0Kb
cub7-37.gif                      4 Nov 01 19:31         2.1Kb
cub7-36.gif                      4 Nov 01 19:31         2.1Kb
cub7-07.gif                      4 Nov 01 19:30         2.2Kb
cub3-38.gif                      4 Nov 01 19:29         2.2Kb
cub2-02.gif                      4 Nov 01 19:28         2.3Kb
cub7-33.gif                      4 Nov 01 19:31         2.3Kb
cub7-39.gif                      4 Nov 01 19:31         2.4Kb
cub7-08.gif                      4 Nov 01 19:30         2.5Kb
cub5-03.gif                      4 Nov 01 19:29         2.8Kb
cub7-79.gif                      4 Nov 01 19:31         3.0Kb
cub7-21.gif                      4 Nov 01 19:30         3.1Kb
cub1-13.gif                      4 Nov 01 19:28         3.4Kb
cub5-25.jpg                      4 Nov 01 19:30        61.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cubic/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
cub1-00.gif                      4 Nov 01 19:28         0.3Kb
cub1-01.gif                      4 Nov 01 19:28         1.0Kb
cub1-02.gif                      4 Nov 01 19:28         1.0Kb
cub1-03.gif                      4 Nov 01 19:28         0.9Kb
cub1-04.gif                      4 Nov 01 19:28         1.2Kb
cub1-04b.gif                     4 Nov 01 19:28         1.0Kb
cub1-04c.gif                     4 Nov 01 19:28         1.6Kb
cub1-05.gif                      4 Nov 01 19:28         1.1Kb
cub1-06.gif                      4 Nov 01 19:28         0.9Kb
cub1-07.gif                      4 Nov 01 19:28         0.7Kb
cub1-08.gif                      4 Nov 01 19:28         1.0Kb
cub1-09.gif                      4 Nov 01 19:28         0.9Kb
cub1-10.gif                      4 Nov 01 19:28         0.5Kb
cub1-11.gif                      4 Nov 01 19:28         0.5Kb
cub1-12.gif                      4 Nov 01 19:28         0.4Kb
cub1-13.gif                      4 Nov 01 19:28         3.4Kb
cub2-01.gif                      4 Nov 01 19:28         0.7Kb
cub2-02.gif                      4 Nov 01 19:28         2.3Kb
cub2-03.gif                      4 Nov 01 19:28         1.4Kb
cub2-04.gif                      4 Nov 01 19:28         1.1Kb
cub2-05.gif                      4 Nov 01 19:28         1.4Kb
cub3-01.gif                      4 Nov 01 19:28         1.0Kb
cub3-02.gif                      4 Nov 01 19:28         0.8Kb
cub3-03.gif                      4 Nov 01 19:28         1.8Kb
cub3-04.gif                      4 Nov 01 19:28         1.7Kb
cub3-05.gif                      4 Nov 01 19:29         1.4Kb
cub3-06.gif                      4 Nov 01 19:29         0.9Kb
cub3-07.gif                      4 Nov 01 19:29         0.8Kb
cub3-08.gif                      4 Nov 01 19:29         1.7Kb
cub3-09.gif                      4 Nov 01 19:29         0.9Kb
cub3-10.gif                      4 Nov 01 19:29         0.8Kb
cub3-11.gif                      4 Nov 01 19:29         2.0Kb
cub3-12.gif                      4 Nov 01 19:29         1.8Kb
cub3-13.gif                      4 Nov 01 19:29         2.0Kb
cub3-14.gif                      4 Nov 01 19:29         1.9Kb
cub3-15.gif                      4 Nov 01 19:29         1.8Kb
cub3-16.gif                      4 Nov 01 19:29         1.9Kb
cub3-17.gif                      4 Nov 01 19:29         2.0Kb
cub3-18.gif                      4 Nov 01 19:29         1.0Kb
cub3-19.gif                      4 Nov 01 19:29         0.5Kb
cub3-20.gif                      4 Nov 01 19:29         0.5Kb
cub3-21.gif                      4 Nov 01 19:29         0.7Kb
cub3-22.gif                      4 Nov 01 19:29         1.0Kb
cub3-23.gif                      4 Nov 01 19:29         0.8Kb
cub3-24.gif                      4 Nov 01 19:29         1.6Kb
cub3-25.gif                      4 Nov 01 19:29         0.4Kb
cub3-26.gif                      4 Nov 01 19:29         1.1Kb
cub3-27.gif                      4 Nov 01 19:29         0.4Kb
cub3-28.gif                      4 Nov 01 19:29         0.7Kb
cub3-29.gif                      4 Nov 01 19:29         0.7Kb
cub3-30.gif                      4 Nov 01 19:29         0.7Kb
cub3-31.gif                      4 Nov 01 19:29         0.7Kb
cub3-32.gif                      4 Nov 01 19:29         0.7Kb
cub3-33.gif                      4 Nov 01 19:29         0.7Kb
cub3-34.gif                      4 Nov 01 19:29         0.7Kb
cub3-35.gif                      4 Nov 01 19:29         0.7Kb
cub3-36.gif                      4 Nov 01 19:29         1.3Kb
cub3-37.gif                      4 Nov 01 19:29         0.7Kb
cub3-38.gif                      4 Nov 01 19:29         2.2Kb
cub3-39.gif                      4 Nov 01 19:29         1.1Kb
cub5-01.gif                      4 Nov 01 19:29         0.3Kb
cub5-02.gif                      4 Nov 01 19:29         0.6Kb
cub5-03.gif                      4 Nov 01 19:29         2.8Kb
cub5-05.gif                      4 Nov 01 19:29         0.6Kb
cub5-06.gif                      4 Nov 01 19:29         0.7Kb
cub5-07.gif                      4 Nov 01 19:29         0.7Kb
cub5-08.gif                      4 Nov 01 19:29         0.1Kb
cub5-09.gif                      4 Nov 01 19:29         0.9Kb
cub5-10.gif                      4 Nov 01 19:29         0.9Kb
cub5-11.gif                      4 Nov 01 19:29         0.7Kb
cub5-12.gif                      4 Nov 01 19:29         0.7Kb
cub5-13.gif                      4 Nov 01 19:29         0.9Kb
cub5-14.gif                      4 Nov 01 19:29         0.8Kb
cub5-15.gif                      4 Nov 01 19:29         0.3Kb
cub5-16.gif                      4 Nov 01 19:29         0.9Kb
cub5-17.gif                      4 Nov 01 19:29         1.0Kb
cub5-18.gif                      4 Nov 01 19:29         1.2Kb
cub5-19.gif                      4 Nov 01 19:29         1.1Kb
cub5-20.gif                      4 Nov 01 19:29         1.1Kb
cub5-21.gif                      4 Nov 01 19:30         1.0Kb
cub5-22.gif                      4 Nov 01 19:30         1.1Kb
cub5-23.gif                      4 Nov 01 19:30         1.0Kb
cub5-24.gif                      4 Nov 01 19:30         1.0Kb
cub5-25.jpg                      4 Nov 01 19:30        61.8Kb
cub7-01.gif                      4 Nov 01 19:30         1.1Kb
cub7-02.gif                      4 Nov 01 19:30         1.5Kb
cub7-03.gif                      4 Nov 01 19:30         0.5Kb
cub7-04.gif                      4 Nov 01 19:30         1.1Kb
cub7-05.gif                      4 Nov 01 19:30         0.7Kb
cub7-06.gif                      4 Nov 01 19:30         0.8Kb
cub7-07.gif                      4 Nov 01 19:30         2.2Kb
cub7-08.gif                      4 Nov 01 19:30         2.5Kb
cub7-09.gif                      4 Nov 01 19:30         0.8Kb
cub7-10.gif                      4 Nov 01 19:30         0.6Kb
cub7-11.gif                      4 Nov 01 19:30         0.7Kb
cub7-12.gif                      4 Nov 01 19:30         0.9Kb
cub7-13.gif                      4 Nov 01 19:30         1.2Kb
cub7-14.gif                      4 Nov 01 19:30         1.3Kb
cub7-15.gif                      4 Nov 01 19:30         0.2Kb
cub7-16.gif                      4 Nov 01 19:30         0.4Kb
cub7-17.gif                      4 Nov 01 19:30         0.4Kb
cub7-18.gif                      4 Nov 01 19:30         0.2Kb
cub7-19.gif                      4 Nov 01 19:30         1.3Kb
cub7-20.gif                      4 Nov 01 19:30         1.4Kb
cub7-21.gif                      4 Nov 01 19:30         3.1Kb
cub7-22.gif                      4 Nov 01 19:30         0.6Kb
cub7-23.gif                      4 Nov 01 19:30         0.5Kb
cub7-24.gif                      4 Nov 01 19:30         0.5Kb
cub7-25.gif                      4 Nov 01 19:30         0.5Kb
cub7-26.gif                      4 Nov 01 19:30         0.8Kb
cub7-27.gif                      4 Nov 01 19:30         1.8Kb
cub7-28.gif                      4 Nov 01 19:30         1.2Kb
cub7-29.gif                      4 Nov 01 19:30         1.0Kb
cub7-30.gif                      4 Nov 01 19:30         1.6Kb
cub7-31.gif                      4 Nov 01 19:30         1.6Kb
cub7-32.gif                      4 Nov 01 19:31         1.7Kb
cub7-33.gif                      4 Nov 01 19:31         2.3Kb
cub7-34.gif                      4 Nov 01 19:31         1.9Kb
cub7-35.gif                      4 Nov 01 19:31         0.4Kb
cub7-36.gif                      4 Nov 01 19:31         2.1Kb
cub7-37.gif                      4 Nov 01 19:31         2.1Kb
cub7-38.gif                      4 Nov 01 19:31         1.8Kb
cub7-39.gif                      4 Nov 01 19:31         2.4Kb
cub7-40.gif                      4 Nov 01 19:31         1.0Kb
cub7-41.gif                      4 Nov 01 19:31         0.7Kb
cub7-42.gif                      4 Nov 01 19:31         0.8Kb
cub7-43.gif                      4 Nov 01 19:31         0.8Kb
cub7-44.gif                      4 Nov 01 19:31         1.0Kb
cub7-45.gif                      4 Nov 01 19:31         1.3Kb
cub7-46.gif                      4 Nov 01 19:31         1.0Kb
cub7-47.gif                      4 Nov 01 19:31         1.1Kb
cub7-48.gif                      4 Nov 01 19:31         0.8Kb
cub7-49.gif                      4 Nov 01 19:31         1.2Kb
cub7-50.gif                      4 Nov 01 19:31         0.9Kb
cub7-51.gif                      4 Nov 01 19:31         1.2Kb
cub7-52.gif                      4 Nov 01 19:31         1.2Kb
cub7-53.gif                      4 Nov 01 19:31         1.6Kb
cub7-54.gif                      4 Nov 01 19:31         1.2Kb
cub7-55.gif                      4 Nov 01 19:31         1.4Kb
cub7-56.gif                      4 Nov 01 19:31         1.4Kb
cub7-57.gif                      4 Nov 01 19:31         0.7Kb
cub7-58.gif                      4 Nov 01 19:31         1.2Kb
cub7-59.gif                      4 Nov 01 19:31         0.9Kb
cub7-60.gif                      4 Nov 01 19:31         1.0Kb
cub7-61.gif                      4 Nov 01 19:31         0.5Kb
cub7-62.gif                      4 Nov 01 19:31         0.6Kb
cub7-63.gif                      4 Nov 01 19:31         0.7Kb
cub7-64.gif                      4 Nov 01 19:31         1.1Kb
cub7-65.gif                      4 Nov 01 19:31         0.9Kb
cub7-66.gif                      4 Nov 01 19:31         1.2Kb
cub7-67.gif                      4 Nov 01 19:31         0.1Kb
cub7-68.gif                      4 Nov 01 19:31         0.1Kb
cub7-69.gif                      4 Nov 01 19:31         0.2Kb
cub7-70.gif                      4 Nov 01 19:31         0.2Kb
cub7-71.gif                      4 Nov 01 19:31         0.2Kb
cub7-72.gif                      4 Nov 01 19:31         0.2Kb
cub7-73.gif                      4 Nov 01 19:31         0.2Kb
cub7-74.gif                      4 Nov 01 19:31         0.7Kb
cub7-75.gif                      4 Nov 01 19:31         1.5Kb
cub7-76.gif                      4 Nov 01 19:31         1.5Kb
cub7-77.gif                      4 Nov 01 19:31         1.3Kb
cub7-78.gif                      4 Nov 01 19:31         0.5Kb
cub7-79.gif                      4 Nov 01 19:31         3.0Kb
cublogo.gif                      4 Nov 01 19:31         1.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/cubic/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
cublogo.gif                      4 Nov 01 19:31         1.5Kb
cub7-79.gif                      4 Nov 01 19:31         3.0Kb
cub7-78.gif                      4 Nov 01 19:31         0.5Kb
cub7-77.gif                      4 Nov 01 19:31         1.3Kb
cub7-76.gif                      4 Nov 01 19:31         1.5Kb
cub7-75.gif                      4 Nov 01 19:31         1.5Kb
cub7-74.gif                      4 Nov 01 19:31         0.7Kb
cub7-73.gif                      4 Nov 01 19:31         0.2Kb
cub7-72.gif                      4 Nov 01 19:31         0.2Kb
cub7-71.gif                      4 Nov 01 19:31         0.2Kb
cub7-70.gif                      4 Nov 01 19:31         0.2Kb
cub7-69.gif                      4 Nov 01 19:31         0.2Kb
cub7-68.gif                      4 Nov 01 19:31         0.1Kb
cub7-67.gif                      4 Nov 01 19:31         0.1Kb
cub7-66.gif                      4 Nov 01 19:31         1.2Kb
cub7-65.gif                      4 Nov 01 19:31         0.9Kb
cub7-64.gif                      4 Nov 01 19:31         1.1Kb
cub7-63.gif                      4 Nov 01 19:31         0.7Kb
cub7-62.gif                      4 Nov 01 19:31         0.6Kb
cub7-61.gif                      4 Nov 01 19:31         0.5Kb
cub7-60.gif                      4 Nov 01 19:31         1.0Kb
cub7-59.gif                      4 Nov 01 19:31         0.9Kb
cub7-58.gif                      4 Nov 01 19:31         1.2Kb
cub7-57.gif                      4 Nov 01 19:31         0.7Kb
cub7-56.gif                      4 Nov 01 19:31         1.4Kb
cub7-55.gif                      4 Nov 01 19:31         1.4Kb
cub7-54.gif                      4 Nov 01 19:31         1.2Kb
cub7-53.gif                      4 Nov 01 19:31         1.6Kb
cub7-52.gif                      4 Nov 01 19:31         1.2Kb
cub7-51.gif                      4 Nov 01 19:31         1.2Kb
cub7-50.gif                      4 Nov 01 19:31         0.9Kb
cub7-49.gif                      4 Nov 01 19:31         1.2Kb
cub7-48.gif                      4 Nov 01 19:31         0.8Kb
cub7-47.gif                      4 Nov 01 19:31         1.1Kb
cub7-46.gif                      4 Nov 01 19:31         1.0Kb
cub7-45.gif                      4 Nov 01 19:31         1.3Kb
cub7-44.gif                      4 Nov 01 19:31         1.0Kb
cub7-43.gif                      4 Nov 01 19:31         0.8Kb
cub7-42.gif                      4 Nov 01 19:31         0.8Kb
cub7-41.gif                      4 Nov 01 19:31         0.7Kb
cub7-40.gif                      4 Nov 01 19:31         1.0Kb
cub7-39.gif                      4 Nov 01 19:31         2.4Kb
cub7-38.gif                      4 Nov 01 19:31         1.8Kb
cub7-37.gif                      4 Nov 01 19:31         2.1Kb
cub7-36.gif                      4 Nov 01 19:31         2.1Kb
cub7-35.gif                      4 Nov 01 19:31         0.4Kb
cub7-34.gif                      4 Nov 01 19:31         1.9Kb
cub7-33.gif                      4 Nov 01 19:31         2.3Kb
cub7-32.gif                      4 Nov 01 19:31         1.7Kb
cub7-31.gif                      4 Nov 01 19:30         1.6Kb
cub7-30.gif                      4 Nov 01 19:30         1.6Kb
cub7-29.gif                      4 Nov 01 19:30         1.0Kb
cub7-28.gif                      4 Nov 01 19:30         1.2Kb
cub7-27.gif                      4 Nov 01 19:30         1.8Kb
cub7-26.gif                      4 Nov 01 19:30         0.8Kb
cub7-25.gif                      4 Nov 01 19:30         0.5Kb
cub7-24.gif                      4 Nov 01 19:30         0.5Kb
cub7-23.gif                      4 Nov 01 19:30         0.5Kb
cub7-22.gif                      4 Nov 01 19:30         0.6Kb
cub7-21.gif                      4 Nov 01 19:30         3.1Kb
cub7-20.gif                      4 Nov 01 19:30         1.4Kb
cub7-19.gif                      4 Nov 01 19:30         1.3Kb
cub7-18.gif                      4 Nov 01 19:30         0.2Kb
cub7-17.gif                      4 Nov


Index of /jaap/puzzles/images/diamond/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
octa.gif                        25 May 00 15:19         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/diamond/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
octa.gif                        25 May 00 15:19         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/diamond/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
octa.gif                        25 May 00 15:19         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/diamond/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
octa.gif                        25 May 00 15:19         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/equator/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
equator.gif                      6 May 01 12:23         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/equator/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
equator.gif                      6 May 01 12:23         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/equator/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
equator.gif                      6 May 01 12:23         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/equator/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
equator.gif                      6 May 01 12:23         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/fifteen/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
fift0l.gif                       1 Jun 00 18:54         0.1Kb
fift0r.gif                       1 Jun 00 18:54         0.1Kb
fift1l.gif                       1 Jun 00 18:54         0.1Kb
fift1r.gif                       1 Jun 00 18:54         0.1Kb
fift2l.gif                       1 Jun 00 18:54         0.1Kb
fift2r.gif                       1 Jun 00 18:54         0.1Kb
fift3l.gif                       1 Jun 00 18:54         0.1Kb
fift3r.gif                       1 Jun 00 18:54         0.1Kb
fift4l.gif                       1 Jun 00 18:54         0.1Kb
fift4r.gif                       1 Jun 00 18:54         0.1Kb
fift5l.gif                       1 Jun 00 18:54         0.1Kb
fift5r.gif                       1 Jun 00 18:54         0.1Kb
fift6l.gif                       1 Jun 00 18:54         0.1Kb
fift6r.gif                       1 Jun 00 18:54         0.1Kb
fift7l.gif                       1 Jun 00 18:54         0.1Kb
fift7r.gif                       1 Jun 00 18:54         0.1Kb
fift8l.gif                       1 Jun 00 18:54         0.1Kb
fift8r.gif                       1 Jun 00 18:54         0.1Kb
fift9l.gif                       1 Jun 00 18:54         0.1Kb
fift9r.gif                       1 Jun 00 18:54         0.1Kb
fiftbl.gif                       1 Jun 00 18:54         0.1Kb
fiftbr.gif                       1 Jun 00 18:54         0.1Kb
fiftnone.gif                     1 Jun 00 17:41         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/fifteen/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
fiftnone.gif                     1 Jun 00 17:41         0.0Kb
fiftbr.gif                       1 Jun 00 18:54         0.1Kb
fiftbl.gif                       1 Jun 00 18:54         0.1Kb
fift9r.gif                       1 Jun 00 18:54         0.1Kb
fift9l.gif                       1 Jun 00 18:54         0.1Kb
fift8r.gif                       1 Jun 00 18:54         0.1Kb
fift8l.gif                       1 Jun 00 18:54         0.1Kb
fift7r.gif                       1 Jun 00 18:54         0.1Kb
fift7l.gif                       1 Jun 00 18:54         0.1Kb
fift6r.gif                       1 Jun 00 18:54         0.1Kb
fift6l.gif                       1 Jun 00 18:54         0.1Kb
fift5r.gif                       1 Jun 00 18:54         0.1Kb
fift5l.gif                       1 Jun 00 18:54         0.1Kb
fift4r.gif                       1 Jun 00 18:54         0.1Kb
fift4l.gif                       1 Jun 00 18:54         0.1Kb
fift3r.gif                       1 Jun 00 18:54         0.1Kb
fift3l.gif                       1 Jun 00 18:54         0.1Kb
fift2r.gif                       1 Jun 00 18:54         0.1Kb
fift2l.gif                       1 Jun 00 18:54         0.1Kb
fift1r.gif                       1 Jun 00 18:54         0.1Kb
fift1l.gif                       1 Jun 00 18:54         0.1Kb
fift0r.gif                       1 Jun 00 18:54         0.1Kb
fift0l.gif                       1 Jun 00 18:54         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/fifteen/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
fiftnone.gif                     1 Jun 00 17:41         0.0Kb
fift0l.gif                       1 Jun 00 18:54         0.1Kb
fiftbl.gif                       1 Jun 00 18:54         0.1Kb
fiftbr.gif                       1 Jun 00 18:54         0.1Kb
fift4l.gif                       1 Jun 00 18:54         0.1Kb
fift7l.gif                       1 Jun 00 18:54         0.1Kb
fift0r.gif                       1 Jun 00 18:54         0.1Kb
fift1l.gif                       1 Jun 00 18:54         0.1Kb
fift4r.gif                       1 Jun 00 18:54         0.1Kb
fift5r.gif                       1 Jun 00 18:54         0.1Kb
fift6r.gif                       1 Jun 00 18:54         0.1Kb
fift1r.gif                       1 Jun 00 18:54         0.1Kb
fift3l.gif                       1 Jun 00 18:54         0.1Kb
fift5l.gif                       1 Jun 00 18:54         0.1Kb
fift6l.gif                       1 Jun 00 18:54         0.1Kb
fift7r.gif                       1 Jun 00 18:54         0.1Kb
fift8r.gif                       1 Jun 00 18:54         0.1Kb
fift9l.gif                       1 Jun 00 18:54         0.1Kb
fift2l.gif                       1 Jun 00 18:54         0.1Kb
fift2r.gif                       1 Jun 00 18:54         0.1Kb
fift3r.gif                       1 Jun 00 18:54         0.1Kb
fift8l.gif                       1 Jun 00 18:54         0.1Kb
fift9r.gif                       1 Jun 00 18:54         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/fifteen/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
fift9r.gif                       1 Jun 00 18:54         0.1Kb
fift8l.gif                       1 Jun 00 18:54         0.1Kb
fift3r.gif                       1 Jun 00 18:54         0.1Kb
fift2r.gif                       1 Jun 00 18:54         0.1Kb
fift2l.gif                       1 Jun 00 18:54         0.1Kb
fift9l.gif                       1 Jun 00 18:54         0.1Kb
fift8r.gif                       1 Jun 00 18:54         0.1Kb
fift7r.gif                       1 Jun 00 18:54         0.1Kb
fift6l.gif                       1 Jun 00 18:54         0.1Kb
fift5l.gif                       1 Jun 00 18:54         0.1Kb
fift3l.gif                       1 Jun 00 18:54         0.1Kb
fift1r.gif                       1 Jun 00 18:54         0.1Kb
fift6r.gif                       1 Jun 00 18:54         0.1Kb
fift5r.gif                       1 Jun 00 18:54         0.1Kb
fift4r.gif                       1 Jun 00 18:54         0.1Kb
fift1l.gif                       1 Jun 00 18:54         0.1Kb
fift0r.gif                       1 Jun 00 18:54         0.1Kb
fift7l.gif                       1 Jun 00 18:54         0.1Kb
fift4l.gif                       1 Jun 00 18:54         0.1Kb
fiftbr.gif                       1 Jun 00 18:54         0.1Kb
fiftbl.gif                       1 Jun 00 18:54         0.1Kb
fift0l.gif                       1 Jun 00 18:54         0.1Kb
fiftnone.gif                     1 Jun 00 17:41         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/fifteen/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
fiftnone.gif                     1 Jun 00 17:41         0.0Kb
fift0l.gif                       1 Jun 00 18:54         0.1Kb
fift0r.gif                       1 Jun 00 18:54         0.1Kb
fift1l.gif                       1 Jun 00 18:54         0.1Kb
fift1r.gif                       1 Jun 00 18:54         0.1Kb
fift2l.gif                       1 Jun 00 18:54         0.1Kb
fift2r.gif                       1 Jun 00 18:54         0.1Kb
fift3l.gif                       1 Jun 00 18:54         0.1Kb
fift3r.gif                       1 Jun 00 18:54         0.1Kb
fift4l.gif                       1 Jun 00 18:54         0.1Kb
fift4r.gif                       1 Jun 00 18:54         0.1Kb
fift5l.gif                       1 Jun 00 18:54         0.1Kb
fift5r.gif                       1 Jun 00 18:54         0.1Kb
fift6l.gif                       1 Jun 00 18:54         0.1Kb
fift6r.gif                       1 Jun 00 18:54         0.1Kb
fift7l.gif                       1 Jun 00 18:54         0.1Kb
fift7r.gif                       1 Jun 00 18:54         0.1Kb
fift8l.gif                       1 Jun 00 18:54         0.1Kb
fift8r.gif                       1 Jun 00 18:54         0.1Kb
fift9l.gif                       1 Jun 00 18:54         0.1Kb
fift9r.gif                       1 Jun 00 18:54         0.1Kb
fiftbl.gif                       1 Jun 00 18:54         0.1Kb
fiftbr.gif                       1 Jun 00 18:54         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/fifteen/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
fiftbr.gif                       1 Jun 00 18:54         0.1Kb
fiftbl.gif                       1 Jun 00 18:54         0.1Kb
fift9r.gif                       1 Jun 00 18:54         0.1Kb
fift9l.gif                       1 Jun 00 18:54         0.1Kb
fift8r.gif                       1 Jun 00 18:54         0.1Kb
fift8l.gif                       1 Jun 00 18:54         0.1Kb
fift7r.gif                       1 Jun 00 18:54         0.1Kb
fift7l.gif                       1 Jun 00 18:54         0.1Kb
fift6r.gif                       1 Jun 00 18:54         0.1Kb
fift6l.gif                       1 Jun 00 18:54         0.1Kb
fift5r.gif                       1 Jun 00 18:54         0.1Kb
fift5l.gif                       1 Jun 00 18:54         0.1Kb
fift4r.gif                       1 Jun 00 18:54         0.1Kb
fift4l.gif                       1 Jun 00 18:54         0.1Kb
fift3r.gif                       1 Jun 00 18:54         0.1Kb
fift3l.gif                       1 Jun 00 18:54         0.1Kb
fift2r.gif                       1 Jun 00 18:54         0.1Kb
fift2l.gif                       1 Jun 00 18:54         0.1Kb
fift1r.gif                       1 Jun 00 18:54         0.1Kb
fift1l.gif                       1 Jun 00 18:54         0.1Kb
fift0r.gif                       1 Jun 00 18:54         0.1Kb
fift0l.gif                       1 Jun 00 18:54         0.1Kb
fiftnone.gif                     1 Jun 00 17:41         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/gripple/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
blank.gif                        4 Nov 01 19:32         0.2Kb
green1.gif                       4 Nov 01 19:32         0.3Kb
green2.gif                       4 Nov 01 19:32         0.3Kb
green3.gif                       4 Nov 01 19:32         0.3Kb
green4.gif                       4 Nov 01 19:32         0.3Kb
red1.gif                         4 Nov 01 19:32         0.3Kb
red2.gif                         4 Nov 01 19:32         0.3Kb
red3.gif                         4 Nov 01 19:32         0.3Kb
red4.gif                         4 Nov 01 19:32         0.3Kb
white1.gif                       4 Nov 01 19:32         0.3Kb
white2.gif                       4 Nov 01 19:32         0.3Kb
white3.gif                       4 Nov 01 19:32         0.3Kb
white4.gif                       4 Nov 01 19:32         0.3Kb
yellow1.gif                      4 Nov 01 19:32         0.3Kb
yellow2.gif                      4 Nov 01 19:32         0.3Kb
yellow3.gif                      4 Nov 01 19:32         0.3Kb
yellow4.gif                      4 Nov 01 19:32         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/gripple/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
yellow4.gif                      4 Nov 01 19:32         0.3Kb
yellow3.gif                      4 Nov 01 19:32         0.3Kb
yellow2.gif                      4 Nov 01 19:32         0.3Kb
yellow1.gif                      4 Nov 01 19:32         0.3Kb
white4.gif                       4 Nov 01 19:32         0.3Kb
white3.gif                       4 Nov 01 19:32         0.3Kb
white2.gif                       4 Nov 01 19:32         0.3Kb
white1.gif                       4 Nov 01 19:32         0.3Kb
red4.gif                         4 Nov 01 19:32         0.3Kb
red3.gif                         4 Nov 01 19:32         0.3Kb
red2.gif                         4 Nov 01 19:32         0.3Kb
red1.gif                         4 Nov 01 19:32         0.3Kb
green4.gif                       4 Nov 01 19:32         0.3Kb
green3.gif                       4 Nov 01 19:32         0.3Kb
green2.gif                       4 Nov 01 19:32         0.3Kb
green1.gif                       4 Nov 01 19:32         0.3Kb
blank.gif                        4 Nov 01 19:32         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/gripple/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
blank.gif                        4 Nov 01 19:32         0.2Kb
green1.gif                       4 Nov 01 19:32         0.3Kb
red1.gif                         4 Nov 01 19:32         0.3Kb
white1.gif                       4 Nov 01 19:32         0.3Kb
yellow1.gif                      4 Nov 01 19:32         0.3Kb
green2.gif                       4 Nov 01 19:32         0.3Kb
red2.gif                         4 Nov 01 19:32         0.3Kb
white2.gif                       4 Nov 01 19:32         0.3Kb
yellow2.gif                      4 Nov 01 19:32         0.3Kb
green3.gif                       4 Nov 01 19:32         0.3Kb
green4.gif                       4 Nov 01 19:32         0.3Kb
red3.gif                         4 Nov 01 19:32         0.3Kb
red4.gif                         4 Nov 01 19:32         0.3Kb
white3.gif                       4 Nov 01 19:32         0.3Kb
white4.gif                       4 Nov 01 19:32         0.3Kb
yellow3.gif                      4 Nov 01 19:32         0.3Kb
yellow4.gif                      4 Nov 01 19:32         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/gripple/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
yellow4.gif                      4 Nov 01 19:32         0.3Kb
yellow3.gif                      4 Nov 01 19:32         0.3Kb
white4.gif                       4 Nov 01 19:32         0.3Kb
white3.gif                       4 Nov 01 19:32         0.3Kb
red4.gif                         4 Nov 01 19:32         0.3Kb
red3.gif                         4 Nov 01 19:32         0.3Kb
green4.gif                       4 Nov 01 19:32         0.3Kb
green3.gif                       4 Nov 01 19:32         0.3Kb
yellow2.gif                      4 Nov 01 19:32         0.3Kb
white2.gif                       4 Nov 01 19:32         0.3Kb
red2.gif                         4 Nov 01 19:32         0.3Kb
green2.gif                       4 Nov 01 19:32         0.3Kb
yellow1.gif                      4 Nov 01 19:32         0.3Kb
white1.gif                       4 Nov 01 19:32         0.3Kb
red1.gif                         4 Nov 01 19:32         0.3Kb
green1.gif                       4 Nov 01 19:32         0.3Kb
blank.gif                        4 Nov 01 19:32         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/gripple/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
blank.gif                        4 Nov 01 19:32         0.2Kb
green1.gif                       4 Nov 01 19:32         0.3Kb
green2.gif                       4 Nov 01 19:32         0.3Kb
green3.gif                       4 Nov 01 19:32         0.3Kb
green4.gif                       4 Nov 01 19:32         0.3Kb
red1.gif                         4 Nov 01 19:32         0.3Kb
red2.gif                         4 Nov 01 19:32         0.3Kb
red3.gif                         4 Nov 01 19:32         0.3Kb
red4.gif                         4 Nov 01 19:32         0.3Kb
white1.gif                       4 Nov 01 19:32         0.3Kb
white2.gif                       4 Nov 01 19:32         0.3Kb
white3.gif                       4 Nov 01 19:32         0.3Kb
white4.gif                       4 Nov 01 19:32         0.3Kb
yellow1.gif                      4 Nov 01 19:32         0.3Kb
yellow2.gif                      4 Nov 01 19:32         0.3Kb
yellow3.gif                      4 Nov 01 19:32         0.3Kb
yellow4.gif                      4 Nov 01 19:32         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/gripple/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
yellow4.gif                      4 Nov 01 19:32         0.3Kb
yellow3.gif                      4 Nov 01 19:32         0.3Kb
yellow2.gif                      4 Nov 01 19:32         0.3Kb
yellow1.gif                      4 Nov 01 19:32         0.3Kb
white4.gif                       4 Nov 01 19:32         0.3Kb
white3.gif                       4 Nov 01 19:32         0.3Kb
white2.gif                       4 Nov 01 19:32         0.3Kb
white1.gif                       4 Nov 01 19:32         0.3Kb
red4.gif                         4 Nov 01 19:32         0.3Kb
red3.gif                         4 Nov 01 19:32         0.3Kb
red2.gif                         4 Nov 01 19:32         0.3Kb
red1.gif                         4 Nov 01 19:32         0.3Kb
green4.gif                       4 Nov 01 19:32         0.3Kb
green3.gif                       4 Nov 01 19:32         0.3Kb
green2.gif                       4 Nov 01 19:32         0.3Kb
green1.gif                       4 Nov 01 19:32         0.3Kb
blank.gif                        4 Nov 01 19:32         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/hanoi/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
hn0.gif                         20 Jun 00 11:09         0.1Kb
hn1.gif                         20 Jun 00 11:09         0.1Kb
hn2.gif                         20 Jun 00 11:09         0.1Kb
hn3.gif                         20 Jun 00 11:09         0.2Kb
hn4.gif                         20 Jun 00 11:09         0.2Kb
hn5.gif                         20 Jun 00 11:09         0.2Kb
hn6.gif                         20 Jun 00 11:09         0.2Kb
hn7.gif                         20 Jun 00 11:09         0.2Kb
hn8.gif                         20 Jun 00 11:09         0.2Kb
hn9.gif                         20 Jun 00 11:09         0.2Kb
hnbt.gif                        20 Jun 00 11:09         0.1Kb
hnbt2.gif                       20 Jun 00 11:09         0.1Kb
hntp.gif                        20 Jun 00 11:09         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/hanoi/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
hntp.gif                        20 Jun 00 11:09         0.1Kb
hnbt2.gif                       20 Jun 00 11:09         0.1Kb
hnbt.gif                        20 Jun 00 11:09         0.1Kb
hn9.gif                         20 Jun 00 11:09         0.2Kb
hn8.gif                         20 Jun 00 11:09         0.2Kb
hn7.gif                         20 Jun 00 11:09         0.2Kb
hn6.gif                         20 Jun 00 11:09         0.2Kb
hn5.gif                         20 Jun 00 11:09         0.2Kb
hn4.gif                         20 Jun 00 11:09         0.2Kb
hn3.gif                         20 Jun 00 11:09         0.2Kb
hn2.gif                         20 Jun 00 11:09         0.1Kb
hn1.gif                         20 Jun 00 11:09         0.1Kb
hn0.gif                         20 Jun 00 11:09         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/hanoi/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
hntp.gif                        20 Jun 00 11:09         0.1Kb
hn0.gif                         20 Jun 00 11:09         0.1Kb
hnbt.gif                        20 Jun 00 11:09         0.1Kb
hn1.gif                         20 Jun 00 11:09         0.1Kb
hn2.gif                         20 Jun 00 11:09         0.1Kb
hnbt2.gif                       20 Jun 00 11:09         0.1Kb
hn3.gif                         20 Jun 00 11:09         0.2Kb
hn7.gif                         20 Jun 00 11:09         0.2Kb
hn4.gif                         20 Jun 00 11:09         0.2Kb
hn5.gif                         20 Jun 00 11:09         0.2Kb
hn6.gif                         20 Jun 00 11:09         0.2Kb
hn9.gif                         20 Jun 00 11:09         0.2Kb
hn8.gif                         20 Jun 00 11:09         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/hanoi/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
hn8.gif                         20 Jun 00 11:09         0.2Kb
hn9.gif                         20 Jun 00 11:09         0.2Kb
hn6.gif                         20 Jun 00 11:09         0.2Kb
hn5.gif                         20 Jun 00 11:09         0.2Kb
hn4.gif                         20 Jun 00 11:09         0.2Kb
hn7.gif                         20 Jun 00 11:09         0.2Kb
hn3.gif                         20 Jun 00 11:09         0.2Kb
hnbt2.gif                       20 Jun 00 11:09         0.1Kb
hn2.gif                         20 Jun 00 11:09         0.1Kb
hn1.gif                         20 Jun 00 11:09         0.1Kb
hnbt.gif                        20 Jun 00 11:09         0.1Kb
hn0.gif                         20 Jun 00 11:09         0.1Kb
hntp.gif                        20 Jun 00 11:09         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/hanoi/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
hn0.gif                         20 Jun 00 11:09         0.1Kb
hn1.gif                         20 Jun 00 11:09         0.1Kb
hn2.gif                         20 Jun 00 11:09         0.1Kb
hn3.gif                         20 Jun 00 11:09         0.2Kb
hn4.gif                         20 Jun 00 11:09         0.2Kb
hn5.gif                         20 Jun 00 11:09         0.2Kb
hn6.gif                         20 Jun 00 11:09         0.2Kb
hn7.gif                         20 Jun 00 11:09         0.2Kb
hn8.gif                         20 Jun 00 11:09         0.2Kb
hn9.gif                         20 Jun 00 11:09         0.2Kb
hnbt.gif                        20 Jun 00 11:09         0.1Kb
hnbt2.gif                       20 Jun 00 11:09         0.1Kb
hntp.gif                        20 Jun 00 11:09         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/hanoi/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
hntp.gif                        20 Jun 00 11:09         0.1Kb
hnbt2.gif                       20 Jun 00 11:09         0.1Kb
hnbt.gif                        20 Jun 00 11:09         0.1Kb
hn9.gif                         20 Jun 00 11:09         0.2Kb
hn8.gif                         20 Jun 00 11:09         0.2Kb
hn7.gif                         20 Jun 00 11:09         0.2Kb
hn6.gif                         20 Jun 00 11:09         0.2Kb
hn5.gif                         20 Jun 00 11:09         0.2Kb
hn4.gif                         20 Jun 00 11:09         0.2Kb
hn3.gif                         20 Jun 00 11:09         0.2Kb
hn2.gif                         20 Jun 00 11:09         0.1Kb
hn1.gif                         20 Jun 00 11:09         0.1Kb
hn0.gif                         20 Jun 00 11:09         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/ideas/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
dinocub2.gif                    18 May 00 17:37         0.4Kb
dinocube.gif                    18 May 00 17:36         0.4Kb
dodecrys.gif                    18 May 00 17:38         0.8Kb
dodeminx.gif                    18 May 00 17:35         0.6Kb
dodeskew.gif                    18 May 00 17:35         0.7Kb
megaminx.gif                    18 May 00 17:37         0.8Kb
octa.gif                        18 May 00 17:36         0.3Kb
octaface.gif                    18 May 00 17:37         0.5Kb
octafish.gif                    18 May 00 17:35         0.4Kb
octaminx.gif                    18 May 00 17:36         0.5Kb
octaoffc.gif                    18 May 00 17:35         0.4Kb
octaskew.gif                    18 May 00 17:36         0.4Kb
octatraj.gif                    18 May 00 17:36         0.4Kb
pyram.gif                       18 May 00 17:33         0.4Kb
pyram4.gif                      18 May 00 17:34         0.3Kb
pyramorf.gif                    18 May 00 17:35         0.3Kb
skewb.gif                       18 May 00 17:34         0.4Kb
skewboff.gif                    18 May 00 17:34         0.4Kb
stella.gif                      18 May 00 17:36         0.4Kb
stella4.gif                     18 May 00 17:37         0.4Kb
tetrhm.gif                      18 May 00 17:33         0.3Kb
tetroffc.gif                    18 May 00 17:34         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/ideas/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
tetroffc.gif                    18 May 00 17:34         0.3Kb
tetrhm.gif                      18 May 00 17:33         0.3Kb
stella4.gif                     18 May 00 17:37         0.4Kb
stella.gif                      18 May 00 17:36         0.4Kb
skewboff.gif                    18 May 00 17:34         0.4Kb
skewb.gif                       18 May 00 17:34         0.4Kb
pyramorf.gif                    18 May 00 17:35         0.3Kb
pyram4.gif                      18 May 00 17:34         0.3Kb
pyram.gif                       18 May 00 17:33         0.4Kb
octatraj.gif                    18 May 00 17:36         0.4Kb
octaskew.gif                    18 May 00 17:36         0.4Kb
octaoffc.gif                    18 May 00 17:35         0.4Kb
octaminx.gif                    18 May 00 17:36         0.5Kb
octafish.gif                    18 May 00 17:35         0.4Kb
octaface.gif                    18 May 00 17:37         0.5Kb
octa.gif                        18 May 00 17:36         0.3Kb
megaminx.gif                    18 May 00 17:37         0.8Kb
dodeskew.gif                    18 May 00 17:35         0.7Kb
dodeminx.gif                    18 May 00 17:35         0.6Kb
dodecrys.gif                    18 May 00 17:38         0.8Kb
dinocube.gif                    18 May 00 17:36         0.4Kb
dinocub2.gif                    18 May 00 17:37         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/ideas/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
tetroffc.gif                    18 May 00 17:34         0.3Kb
pyramorf.gif                    18 May 00 17:35         0.3Kb
tetrhm.gif                      18 May 00 17:33         0.3Kb
pyram4.gif                      18 May 00 17:34         0.3Kb
octa.gif                        18 May 00 17:36         0.3Kb
pyram.gif                       18 May 00 17:33         0.4Kb
stella.gif                      18 May 00 17:36         0.4Kb
skewb.gif                       18 May 00 17:34         0.4Kb
dinocube.gif                    18 May 00 17:36         0.4Kb
skewboff.gif                    18 May 00 17:34         0.4Kb
octafish.gif                    18 May 00 17:35         0.4Kb
octaoffc.gif                    18 May 00 17:35         0.4Kb
stella4.gif                     18 May 00 17:37         0.4Kb
octaskew.gif                    18 May 00 17:36         0.4Kb
octatraj.gif                    18 May 00 17:36         0.4Kb
dinocub2.gif                    18 May 00 17:37         0.4Kb
octaminx.gif                    18 May 00 17:36         0.5Kb
octaface.gif                    18 May 00 17:37         0.5Kb
dodeminx.gif                    18 May 00 17:35         0.6Kb
dodeskew.gif                    18 May 00 17:35         0.7Kb
megaminx.gif                    18 May 00 17:37         0.8Kb
dodecrys.gif                    18 May 00 17:38         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/ideas/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
pyram.gif                       18 May 00 17:33         0.4Kb
tetrhm.gif                      18 May 00 17:33         0.3Kb
tetroffc.gif                    18 May 00 17:34         0.3Kb
pyram4.gif                      18 May 00 17:34         0.3Kb
skewb.gif                       18 May 00 17:34         0.4Kb
skewboff.gif                    18 May 00 17:34         0.4Kb
octafish.gif                    18 May 00 17:35         0.4Kb
octaoffc.gif                    18 May 00 17:35         0.4Kb
dodeskew.gif                    18 May 00 17:35         0.7Kb
dodeminx.gif                    18 May 00 17:35         0.6Kb
pyramorf.gif                    18 May 00 17:35         0.3Kb
octa.gif                        18 May 00 17:36         0.3Kb
octaskew.gif                    18 May 00 17:36         0.4Kb
octaminx.gif                    18 May 00 17:36         0.5Kb
octatraj.gif                    18 May 00 17:36         0.4Kb
stella.gif                      18 May 00 17:36         0.4Kb
dinocube.gif                    18 May 00 17:36         0.4Kb
dinocub2.gif                    18 May 00 17:37         0.4Kb
octaface.gif                    18 May 00 17:37         0.5Kb
stella4.gif                     18 May 00 17:37         0.4Kb
megaminx.gif                    18 May 00 17:37         0.8Kb
dodecrys.gif                    18 May 00 17:38         0.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/insanity/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
blue.gif                         4 Nov 01 19:33         0.0Kb
graph1.gif                       4 Nov 01 19:33         1.1Kb
green.gif                        4 Nov 01 19:33         0.0Kb
grey.gif                         4 Nov 01 19:33         0.0Kb
red.gif                          4 Nov 01 19:33         0.0Kb
yellow.gif                       4 Nov 01 19:33         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/insanity/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
yellow.gif                       4 Nov 01 19:33         0.0Kb
red.gif                          4 Nov 01 19:33         0.0Kb
grey.gif                         4 Nov 01 19:33         0.0Kb
green.gif                        4 Nov 01 19:33         0.0Kb
graph1.gif                       4 Nov 01 19:33         1.1Kb
blue.gif                         4 Nov 01 19:33         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/insanity/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
blue.gif                         4 Nov 01 19:33         0.0Kb
green.gif                        4 Nov 01 19:33         0.0Kb
grey.gif                         4 Nov 01 19:33         0.0Kb
red.gif                          4 Nov 01 19:33         0.0Kb
yellow.gif                       4 Nov 01 19:33         0.0Kb
graph1.gif                       4 Nov 01 19:33         1.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/insanity/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
graph1.gif                       4 Nov 01 19:33         1.1Kb
yellow.gif                       4 Nov 01 19:33         0.0Kb
red.gif                          4 Nov 01 19:33         0.0Kb
grey.gif                         4 Nov 01 19:33         0.0Kb
green.gif                        4 Nov 01 19:33         0.0Kb
blue.gif                         4 Nov 01 19:33         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/insanity/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
blue.gif                         4 Nov 01 19:33         0.0Kb
graph1.gif                       4 Nov 01 19:33         1.1Kb
green.gif                        4 Nov 01 19:33         0.0Kb
grey.gif                         4 Nov 01 19:33         0.0Kb
red.gif                          4 Nov 01 19:33         0.0Kb
yellow.gif                       4 Nov 01 19:33         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/insanity/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
yellow.gif                       4 Nov 01 19:33         0.0Kb
red.gif                          4 Nov 01 19:33         0.0Kb
grey.gif                         4 Nov 01 19:33         0.0Kb
green.gif                        4 Nov 01 19:33         0.0Kb
graph1.gif                       4 Nov 01 19:33         1.1Kb
blue.gif                         4 Nov 01 19:33         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/iqball/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
iqball.gif                       4 Nov 01 19:33         1.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/iqball/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
iqball.gif                       4 Nov 01 19:33         1.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/iqball/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
iqball.gif                       4 Nov 01 19:33         1.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/iqball/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
iqball.gif                       4 Nov 01 19:33         1.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/it/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
it01.gif                        30 Mar 00 19:48         0.1Kb
it02.gif                        30 Mar 00 19:48         0.1Kb
it03.gif                        30 Mar 00 19:48         0.1Kb
it04.gif                        30 Mar 00 19:48         0.1Kb
it05.gif                        30 Mar 00 19:50         0.1Kb
it06.gif                        30 Mar 00 19:50         0.1Kb
it07.gif                        30 Mar 00 19:51         0.1Kb
it08.gif                        30 Mar 00 19:51         0.1Kb
it09.gif                        30 Mar 00 19:55         0.1Kb
it0a.gif                        30 Mar 00 19:55         0.1Kb
it0b.gif                        30 Mar 00 19:55         0.1Kb
it0c.gif                        30 Mar 00 19:55         0.1Kb
it0d.gif                        30 Mar 00 19:55         0.1Kb
it0e.gif                        30 Mar 00 19:55         0.1Kb
it10.gif                        30 Mar 00 20:01         0.1Kb
it11.gif                        30 Mar 00 20:01         0.1Kb
it12.gif                        30 Mar 00 20:01         0.1Kb
it13.gif                        30 Mar 00 20:01         0.1Kb
it14.gif                        30 Mar 00 20:01         0.1Kb
it15.gif                        30 Mar 00 20:01         0.1Kb
it16.gif                        30 Mar 00 20:01         0.1Kb
itbordd.gif                     30 Mar 00 20:04         0.1Kb
itbordl.gif                     30 Mar 00 20:07         0.3Kb
itbordr.gif                     30 Mar 00 20:08         0.3Kb
itbordu.gif                     30 Mar 00 20:04         0.1Kb
itleft.gif                      30 Mar 00 20:13         0.1Kb
itleft2.gif                     30 Mar 00 20:13         0.1Kb
ittop.gif                       30 Mar 00 20:14         0.1Kb
ittop2.gif                      30 Mar 00 20:14         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/it/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
ittop2.gif                      30 Mar 00 20:14         0.1Kb
ittop.gif                       30 Mar 00 20:14         0.1Kb
itleft2.gif                     30 Mar 00 20:13         0.1Kb
itleft.gif                      30 Mar 00 20:13         0.1Kb
itbordu.gif                     30 Mar 00 20:04         0.1Kb
itbordr.gif                     30 Mar 00 20:08         0.3Kb
itbordl.gif                     30 Mar 00 20:07         0.3Kb
itbordd.gif                     30 Mar 00 20:04         0.1Kb
it16.gif                        30 Mar 00 20:01         0.1Kb
it15.gif                        30 Mar 00 20:01         0.1Kb
it14.gif                        30 Mar 00 20:01         0.1Kb
it13.gif                        30 Mar 00 20:01         0.1Kb
it12.gif                        30 Mar 00 20:01         0.1Kb
it11.gif                        30 Mar 00 20:01         0.1Kb
it10.gif                        30 Mar 00 20:01         0.1Kb
it0e.gif                        30 Mar 00 19:55         0.1Kb
it0d.gif                        30 Mar 00 19:55         0.1Kb
it0c.gif                        30 Mar 00 19:55         0.1Kb
it0b.gif                        30 Mar 00 19:55         0.1Kb
it0a.gif                        30 Mar 00 19:55         0.1Kb
it09.gif                        30 Mar 00 19:55         0.1Kb
it08.gif                        30 Mar 00 19:51         0.1Kb
it07.gif                        30 Mar 00 19:51         0.1Kb
it06.gif                        30 Mar 00 19:50         0.1Kb
it05.gif                        30 Mar 00 19:50         0.1Kb
it04.gif                        30 Mar 00 19:48         0.1Kb
it03.gif                        30 Mar 00 19:48         0.1Kb
it02.gif                        30 Mar 00 19:48         0.1Kb
it01.gif                        30 Mar 00 19:48         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/it/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
it0c.gif                        30 Mar 00 19:55         0.1Kb
itleft.gif                      30 Mar 00 20:13         0.1Kb
itleft2.gif                     30 Mar 00 20:13         0.1Kb
it0a.gif                        30 Mar 00 19:55         0.1Kb
it0d.gif                        30 Mar 00 19:55         0.1Kb
it0b.gif                        30 Mar 00 19:55         0.1Kb
it0e.gif                        30 Mar 00 19:55         0.1Kb
it01.gif                        30 Mar 00 19:48         0.1Kb
it06.gif                        30 Mar 00 19:50         0.1Kb
itbordu.gif                     30 Mar 00 20:04         0.1Kb
it02.gif                        30 Mar 00 19:48         0.1Kb
it03.gif                        30 Mar 00 19:48         0.1Kb
it04.gif                        30 Mar 00 19:48         0.1Kb
it05.gif                        30 Mar 00 19:50         0.1Kb
it07.gif                        30 Mar 00 19:51         0.1Kb
it08.gif                        30 Mar 00 19:51         0.1Kb
it09.gif                        30 Mar 00 19:55         0.1Kb
it11.gif                        30 Mar 00 20:01         0.1Kb
it12.gif                        30 Mar 00 20:01         0.1Kb
it15.gif                        30 Mar 00 20:01         0.1Kb
it16.gif                        30 Mar 00 20:01         0.1Kb
it10.gif                        30 Mar 00 20:01         0.1Kb
it13.gif                        30 Mar 00 20:01         0.1Kb
it14.gif                        30 Mar 00 20:01         0.1Kb
ittop.gif                       30 Mar 00 20:14         0.1Kb
ittop2.gif                      30 Mar 00 20:14         0.1Kb
itbordd.gif                     30 Mar 00 20:04         0.1Kb
itbordl.gif                     30 Mar 00 20:07         0.3Kb
itbordr.gif                     30 Mar 00 20:08         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/it/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
itbordr.gif                     30 Mar 00 20:08         0.3Kb
itbordl.gif                     30 Mar 00 20:07         0.3Kb
itbordd.gif                     30 Mar 00 20:04         0.1Kb
ittop2.gif                      30 Mar 00 20:14         0.1Kb
ittop.gif                       30 Mar 00 20:14         0.1Kb
it14.gif                        30 Mar 00 20:01         0.1Kb
it13.gif                        30 Mar 00 20:01         0.1Kb
it10.gif                        30 Mar 00 20:01         0.1Kb
it16.gif                        30 Mar 00 20:01         0.1Kb
it15.gif                        30 Mar 00 20:01         0.1Kb
it12.gif                        30 Mar 00 20:01         0.1Kb
it11.gif                        30 Mar 00 20:01         0.1Kb
it09.gif                        30 Mar 00 19:55         0.1Kb
it08.gif                        30 Mar 00 19:51         0.1Kb
it07.gif                        30 Mar 00 19:51         0.1Kb
it05.gif                        30 Mar 00 19:50         0.1Kb
it04.gif                        30 Mar 00 19:48         0.1Kb
it03.gif                        30 Mar 00 19:48         0.1Kb
it02.gif                        30 Mar 00 19:48         0.1Kb
itbordu.gif                     30 Mar 00 20:04         0.1Kb
it06.gif                        30 Mar 00 19:50         0.1Kb
it01.gif                        30 Mar 00 19:48         0.1Kb
it0e.gif                        30 Mar 00 19:55         0.1Kb
it0b.gif                        30 Mar 00 19:55         0.1Kb
it0d.gif                        30 Mar 00 19:55         0.1Kb
it0a.gif                        30 Mar 00 19:55         0.1Kb
itleft2.gif                     30 Mar 00 20:13         0.1Kb
itleft.gif                      30 Mar 00 20:13         0.1Kb
it0c.gif                        30 Mar 00 19:55         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/it/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
it01.gif                        30 Mar 00 19:48         0.1Kb
it02.gif                        30 Mar 00 19:48         0.1Kb
it03.gif                        30 Mar 00 19:48         0.1Kb
it04.gif                        30 Mar 00 19:48         0.1Kb
it05.gif                        30 Mar 00 19:50         0.1Kb
it06.gif                        30 Mar 00 19:50         0.1Kb
it07.gif                        30 Mar 00 19:51         0.1Kb
it08.gif                        30 Mar 00 19:51         0.1Kb
it09.gif                        30 Mar 00 19:55         0.1Kb
it0a.gif                        30 Mar 00 19:55         0.1Kb
it0b.gif                        30 Mar 00 19:55         0.1Kb
it0c.gif                        30 Mar 00 19:55         0.1Kb
it0d.gif                        30 Mar 00 19:55         0.1Kb
it0e.gif                        30 Mar 00 19:55         0.1Kb
it10.gif                        30 Mar 00 20:01         0.1Kb
it11.gif                        30 Mar 00 20:01         0.1Kb
it12.gif                        30 Mar 00 20:01         0.1Kb
it13.gif                        30 Mar 00 20:01         0.1Kb
it14.gif                        30 Mar 00 20:01         0.1Kb
it15.gif                        30 Mar 00 20:01         0.1Kb
it16.gif                        30 Mar 00 20:01         0.1Kb
itbordd.gif                     30 Mar 00 20:04         0.1Kb
itbordu.gif                     30 Mar 00 20:04         0.1Kb
itbordl.gif                     30 Mar 00 20:07         0.3Kb
itbordr.gif                     30 Mar 00 20:08         0.3Kb
itleft.gif                      30 Mar 00 20:13         0.1Kb
itleft2.gif                     30 Mar 00 20:13         0.1Kb
ittop.gif                       30 Mar 00 20:14         0.1Kb
ittop2.gif                      30 Mar 00 20:14         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/it/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
ittop2.gif                      30 Mar 00 20:14         0.1Kb
ittop.gif                       30 Mar 00 20:14         0.1Kb
itleft2.gif                     30 Mar 00 20:13         0.1Kb
itleft.gif                      30 Mar 00 20:13         0.1Kb
itbordr.gif                     30 Mar 00 20:08         0.3Kb
itbordl.gif                     30 Mar 00 20:07         0.3Kb
itbordu.gif                     30 Mar 00 20:04         0.1Kb
itbordd.gif                     30 Mar 00 20:04         0.1Kb
it16.gif                        30 Mar 00 20:01         0.1Kb
it15.gif                        30 Mar 00 20:01         0.1Kb
it14.gif                        30 Mar 00 20:01         0.1Kb
it13.gif                        30 Mar 00 20:01         0.1Kb
it12.gif                        30 Mar 00 20:01         0.1Kb
it11.gif                        30 Mar 00 20:01         0.1Kb
it10.gif                        30 Mar 00 20:01         0.1Kb
it0e.gif                        30 Mar 00 19:55         0.1Kb
it0d.gif                        30 Mar 00 19:55         0.1Kb
it0c.gif                        30 Mar 00 19:55         0.1Kb
it0b.gif                        30 Mar 00 19:55         0.1Kb
it0a.gif                        30 Mar 00 19:55         0.1Kb
it09.gif                        30 Mar 00 19:55         0.1Kb
it08.gif                        30 Mar 00 19:51         0.1Kb
it07.gif                        30 Mar 00 19:51         0.1Kb
it06.gif                        30 Mar 00 19:50         0.1Kb
it05.gif                        30 Mar 00 19:50         0.1Kb
it04.gif                        30 Mar 00 19:48         0.1Kb
it03.gif                        30 Mar 00 19:48         0.1Kb
it02.gif                        30 Mar 00 19:48         0.1Kb
it01.gif                        30 Mar 00 19:48         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/lights/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
lo0.gif                          4 Nov 01 19:34         0.2Kb
lo00.gif                         4 Nov 01 19:34         0.2Kb
lo01.gif                         4 Nov 01 19:34         0.2Kb
lo02.gif                         4 Nov 01 19:34         0.2Kb
lo1.gif                          4 Nov 01 19:34         0.2Kb
lo10.gif                         4 Nov 01 19:34         0.2Kb
lo11.gif                         4 Nov 01 19:34         0.2Kb
lo12.gif                         4 Nov 01 19:34         0.2Kb
lo2.gif                          4 Nov 01 19:34         0.2Kb
lo20.gif                         4 Nov 01 19:34         0.2Kb
lo21.gif                         4 Nov 01 19:34         0.2Kb
lo22.gif                         4 Nov 01 19:34         0.2Kb
lox.gif                          4 Nov 01 19:34         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/lights/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
lox.gif                          4 Nov 01 19:34         0.1Kb
lo22.gif                         4 Nov 01 19:34         0.2Kb
lo21.gif                         4 Nov 01 19:34         0.2Kb
lo20.gif                         4 Nov 01 19:34         0.2Kb
lo2.gif                          4 Nov 01 19:34         0.2Kb
lo12.gif                         4 Nov 01 19:34         0.2Kb
lo11.gif                         4 Nov 01 19:34         0.2Kb
lo10.gif                         4 Nov 01 19:34         0.2Kb
lo1.gif                          4 Nov 01 19:34         0.2Kb
lo02.gif                         4 Nov 01 19:34         0.2Kb
lo01.gif                         4 Nov 01 19:34         0.2Kb
lo00.gif                         4 Nov 01 19:34         0.2Kb
lo0.gif                          4 Nov 01 19:34         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/lights/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
lox.gif                          4 Nov 01 19:34         0.1Kb
lo1.gif                          4 Nov 01 19:34         0.2Kb
lo2.gif                          4 Nov 01 19:34         0.2Kb
lo10.gif                         4 Nov 01 19:34         0.2Kb
lo11.gif                         4 Nov 01 19:34         0.2Kb
lo12.gif                         4 Nov 01 19:34         0.2Kb
lo21.gif                         4 Nov 01 19:34         0.2Kb
lo22.gif                         4 Nov 01 19:34         0.2Kb
lo00.gif                         4 Nov 01 19:34         0.2Kb
lo01.gif                         4 Nov 01 19:34         0.2Kb
lo02.gif                         4 Nov 01 19:34         0.2Kb
lo20.gif                         4 Nov 01 19:34         0.2Kb
lo0.gif                          4 Nov 01 19:34         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/lights/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
lo0.gif                          4 Nov 01 19:34         0.2Kb
lo20.gif                         4 Nov 01 19:34         0.2Kb
lo02.gif                         4 Nov 01 19:34         0.2Kb
lo01.gif                         4 Nov 01 19:34         0.2Kb
lo00.gif                         4 Nov 01 19:34         0.2Kb
lo22.gif                         4 Nov 01 19:34         0.2Kb
lo21.gif                         4 Nov 01 19:34         0.2Kb
lo12.gif                         4 Nov 01 19:34         0.2Kb
lo11.gif                         4 Nov 01 19:34         0.2Kb
lo10.gif                         4 Nov 01 19:34         0.2Kb
lo2.gif                          4 Nov 01 19:34         0.2Kb
lo1.gif                          4 Nov 01 19:34         0.2Kb
lox.gif                          4 Nov 01 19:34         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/lights/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
lo0.gif                          4 Nov 01 19:34         0.2Kb
lo00.gif                         4 Nov 01 19:34         0.2Kb
lo01.gif                         4 Nov 01 19:34         0.2Kb
lo02.gif                         4 Nov 01 19:34         0.2Kb
lo1.gif                          4 Nov 01 19:34         0.2Kb
lo10.gif                         4 Nov 01 19:34         0.2Kb
lo11.gif                         4 Nov 01 19:34         0.2Kb
lo12.gif                         4 Nov 01 19:34         0.2Kb
lo2.gif                          4 Nov 01 19:34         0.2Kb
lo20.gif                         4 Nov 01 19:34         0.2Kb
lo21.gif                         4 Nov 01 19:34         0.2Kb
lo22.gif                         4 Nov 01 19:34         0.2Kb
lox.gif                          4 Nov 01 19:34         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/lights/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
lox.gif                          4 Nov 01 19:34         0.1Kb
lo22.gif                         4 Nov 01 19:34         0.2Kb
lo21.gif                         4 Nov 01 19:34         0.2Kb
lo20.gif                         4 Nov 01 19:34         0.2Kb
lo2.gif                          4 Nov 01 19:34         0.2Kb
lo12.gif                         4 Nov 01 19:34         0.2Kb
lo11.gif                         4 Nov 01 19:34         0.2Kb
lo10.gif                         4 Nov 01 19:34         0.2Kb
lo1.gif                          4 Nov 01 19:34         0.2Kb
lo02.gif                         4 Nov 01 19:34         0.2Kb
lo01.gif                         4 Nov 01 19:34         0.2Kb
lo00.gif                         4 Nov 01 19:34         0.2Kb
lo0.gif                          4 Nov 01 19:34         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/magic/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
creapat1.gif                     4 Nov 01 19:34         0.6Kb
creapat2.gif                     4 Nov 01 19:35         0.6Kb
cub1a.gif                        4 Nov 01 19:35         0.3Kb
cub1b.gif                        4 Nov 01 19:35         0.2Kb
cub1c.gif                        4 Nov 01 19:35         0.2Kb
cub1d.gif                        4 Nov 01 19:35         0.2Kb
cub1e.gif                        4 Nov 01 19:35         0.2Kb
cub1f.gif                        4 Nov 01 19:35         0.3Kb
cub1g.gif                        4 Nov 01 19:35         0.3Kb
cub1h.gif                        4 Nov 01 19:35         0.2Kb
cub1i.gif                        4 Nov 01 19:35         0.3Kb
cub1j.gif                        4 Nov 01 19:35         0.2Kb
cub1k.gif                        4 Nov 01 19:35         0.2Kb
cub1l.gif                        4 Nov 01 19:35         0.2Kb
cub1m.gif                        4 Nov 01 19:35         0.2Kb
cub1n.gif                        4 Nov 01 19:35         0.2Kb
cub1o.gif                        4 Nov 01 19:35         0.2Kb
cub1p.gif                        4 Nov 01 19:35         0.3Kb
cub1q.gif                        4 Nov 01 19:35         0.3Kb
cub1r.gif                        4 Nov 01 19:35         0.2Kb
cub1s.gif                        4 Nov 01 19:35         0.2Kb
cub2a.gif                        4 Nov 01 19:35         0.2Kb
cub2b.gif                        4 Nov 01 19:35         0.2Kb
cub2c.gif                        4 Nov 01 19:35         0.2Kb
cub2d.gif                        4 Nov 01 19:35         0.2Kb
mag0.gif                         4 Nov 01 19:35         0.2Kb
mag0b.gif                        4 Nov 01 19:35         0.3Kb
mag1a.gif                        4 Nov 01 19:35         0.2Kb
mag1b.gif                        4 Nov 01 19:35         0.2Kb
mag1c.gif                        4 Nov 01 19:35         0.3Kb
mag1d.gif                        4 Nov 01 19:35         0.3Kb
mag2a.gif                        4 Nov 01 19:35         0.3Kb
mag2b.gif                        4 Nov 01 19:35         0.2Kb
mag2c.gif                        4 Nov 01 19:35         0.2Kb
mag2d.gif                        4 Nov 01 19:35         0.2Kb
mag2e.gif                        4 Nov 01 19:35         0.2Kb
mag2f.gif                        4 Nov 01 19:35         0.3Kb
mag3a.gif                        4 Nov 01 19:35         0.3Kb
mag3b.gif                        4 Nov 01 19:35         0.2Kb
mag3c.gif                        4 Nov 01 19:35         0.3Kb
mag4a.gif                        4 Nov 01 19:35         0.3Kb
mag4b.gif                        4 Nov 01 19:35         0.2Kb
mag4c.gif                        4 Nov 01 19:35         0.3Kb
mag4d.gif                        4 Nov 01 19:35         0.3Kb
mag4e.gif                        4 Nov 01 19:35         0.3Kb
mag4f.gif                        4 Nov 01 19:35         0.2Kb
mag4g.gif                        4 Nov 01 19:35         0.2Kb
mag4h.gif                        4 Nov 01 19:35         0.2Kb
mag4i.gif                        4 Nov 01 19:35         0.3Kb
mag4j.gif                        4 Nov 01 19:35         0.2Kb
mag4k.gif                        4 Nov 01 19:35         0.3Kb
mag4l.gif                        4 Nov 01 19:35         0.3Kb
mag5a.gif                        4 Nov 01 19:35         0.3Kb
mag5b.gif                        4 Nov 01 19:35         0.3Kb
mag5d.gif                        4 Nov 01 19:35         0.3Kb
mag5e.gif                        4 Nov 01 19:35         0.2Kb
mast0.gif                        4 Nov 01 19:35         0.3Kb
mast0b.gif                       4 Nov 01 19:35         0.4Kb
mast3a.gif                       4 Nov 01 19:35         0.4Kb
mast3b.gif                       4 Nov 01 19:35         0.3Kb
mast3c.gif                       4 Nov 01 19:35         0.4Kb
mast3d.gif                       4 Nov 01 19:36         0.4Kb
mast3e.gif                       4 Nov 01 19:36         0.4Kb
mast3f.gif                       4 Nov 01 19:36         0.3Kb
mast3g.gif                       4 Nov 01 19:36         0.3Kb
mast5a.gif                       4 Nov 01 19:36         0.3Kb
mast5b.gif                       4 Nov 01 19:36         0.3Kb
mast5c.gif                       4 Nov 01 19:36         0.3Kb
mast5d.gif                       4 Nov 01 19:36         0.3Kb
mast5e.gif                       4 Nov 01 19:36         0.3Kb
mast5f.gif                       4 Nov 01 19:36         0.3Kb
mast5g.gif                       4 Nov 01 19:36         0.3Kb
mast5h.gif                       4 Nov 01 19:36         0.3Kb
mast5i.gif                       4 Nov 01 19:36         0.3Kb
mast5j.gif                       4 Nov 01 19:36         0.3Kb
mast5k.gif                       4 Nov 01 19:36         0.4Kb
mast5l.gif                       4 Nov 01 19:36         0.3Kb
mast5m.gif                       4 Nov 01 19:36         0.3Kb
mast5n.gif                       4 Nov 01 19:36         0.3Kb
mast5o.gif                       4 Nov 01 19:36         0.3Kb
mast5p.gif                       4 Nov 01 19:36         0.3Kb
mast6a.gif                       4 Nov 01 19:36         0.3Kb
mast6b.gif                       4 Nov 01 19:36         0.3Kb
mast6c.gif                       4 Nov 01 19:36         0.4Kb
mast6d.gif                       4 Nov 01 19:36         0.2Kb
mast6e.gif                       4 Nov 01 19:36         0.2Kb
mast6f.gif                       4 Nov 01 19:36         0.3Kb
mast6g.gif                       4 Nov 01 19:36         0.4Kb
mast6h.gif                       4 Nov 01 19:36         0.3Kb
mast6i.gif                       4 Nov 01 19:36         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/magic/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
mast6i.gif                       4 Nov 01 19:36         0.4Kb
mast6h.gif                       4 Nov 01 19:36         0.3Kb
mast6g.gif                       4 Nov 01 19:36         0.4Kb
mast6f.gif                       4 Nov 01 19:36         0.3Kb
mast6e.gif                       4 Nov 01 19:36         0.2Kb
mast6d.gif                       4 Nov 01 19:36         0.2Kb
mast6c.gif                       4 Nov 01 19:36         0.4Kb
mast6b.gif                       4 Nov 01 19:36         0.3Kb
mast6a.gif                       4 Nov 01 19:36         0.3Kb
mast5p.gif                       4 Nov 01 19:36         0.3Kb
mast5o.gif                       4 Nov 01 19:36         0.3Kb
mast5n.gif                       4 Nov 01 19:36         0.3Kb
mast5m.gif                       4 Nov 01 19:36         0.3Kb
mast5l.gif                       4 Nov 01 19:36         0.3Kb
mast5k.gif                       4 Nov 01 19:36         0.4Kb
mast5j.gif                       4 Nov 01 19:36         0.3Kb
mast5i.gif                       4 Nov 01 19:36         0.3Kb
mast5h.gif                       4 Nov 01 19:36         0.3Kb
mast5g.gif                       4 Nov 01 19:36         0.3Kb
mast5f.gif                       4 Nov 01 19:36         0.3Kb
mast5e.gif                       4 Nov 01 19:36         0.3Kb
mast5d.gif                       4 Nov 01 19:36         0.3Kb
mast5c.gif                       4 Nov 01 19:36         0.3Kb
mast5b.gif                       4 Nov 01 19:36         0.3Kb
mast5a.gif                       4 Nov 01 19:36         0.3Kb
mast3g.gif                       4 Nov 01 19:36         0.3Kb
mast3f.gif                       4 Nov 01 19:36         0.3Kb
mast3e.gif                       4 Nov 01 19:36         0.4Kb
mast3d.gif                       4 Nov 01 19:36         0.4Kb
mast3c.gif                       4 Nov 01 19:35         0.4Kb
mast3b.gif                       4 Nov 01 19:35         0.3Kb
mast3a.gif                       4 Nov 01 19:35         0.4Kb
mast0b.gif                       4 Nov 01 19:35         0.4Kb
mast0.gif                        4 Nov 01 19:35         0.3Kb
mag5e.gif                        4 Nov 01 19:35         0.2Kb
mag5d.gif                        4 Nov 01 19:35         0.3Kb
mag5b.gif                        4 Nov 01 19:35         0.3Kb
mag5a.gif                        4 Nov 01 19:35         0.3Kb
mag4l.gif                        4 Nov 01 19:35         0.3Kb
mag4k.gif                        4 Nov 01 19:35         0.3Kb
mag4j.gif                        4 Nov 01 19:35         0.2Kb
mag4i.gif                        4 Nov 01 19:35         0.3Kb
mag4h.gif                        4 Nov 01 19:35         0.2Kb
mag4g.gif                        4 Nov 01 19:35         0.2Kb
mag4f.gif                        4 Nov 01 19:35         0.2Kb
mag4e.gif                        4 Nov 01 19:35         0.3Kb
mag4d.gif                        4 Nov 01 19:35         0.3Kb
mag4c.gif                        4 Nov 01 19:35         0.3Kb
mag4b.gif                        4 Nov 01 19:35         0.2Kb
mag4a.gif                        4 Nov 01 19:35         0.3Kb
mag3c.gif                        4 Nov 01 19:35         0.3Kb
mag3b.gif                        4 Nov 01 19:35         0.2Kb
mag3a.gif                        4 Nov 01 19:35         0.3Kb
mag2f.gif                        4 Nov 01 19:35         0.3Kb
mag2e.gif                        4 Nov 01 19:35         0.2Kb
mag2d.gif                        4 Nov 01 19:35         0.2Kb
mag2c.gif                        4 Nov 01 19:35         0.2Kb
mag2b.gif                        4 Nov 01 19:35         0.2Kb
mag2a.gif                        4 Nov 01 19:35         0.3Kb
mag1d.gif                        4 Nov 01 19:35         0.3Kb
mag1c.gif                        4 Nov 01 19:35         0.3Kb
mag1b.gif                        4 Nov 01 19:35         0.2Kb
mag1a.gif                        4 Nov 01 19:35         0.2Kb
mag0b.gif                        4 Nov 01 19:35         0.3Kb
mag0.gif                         4 Nov 01 19:35         0.2Kb
cub2d.gif                        4 Nov 01 19:35         0.2Kb
cub2c.gif                        4 Nov 01 19:35         0.2Kb
cub2b.gif                        4 Nov 01 19:35         0.2Kb
cub2a.gif                        4 Nov 01 19:35         0.2Kb
cub1s.gif                        4 Nov 01 19:35         0.2Kb
cub1r.gif                        4 Nov 01 19:35         0.2Kb
cub1q.gif                        4 Nov 01 19:35         0.3Kb
cub1p.gif                        4 Nov 01 19:35         0.3Kb
cub1o.gif                        4 Nov 01 19:35         0.2Kb
cub1n.gif                        4 Nov 01 19:35         0.2Kb
cub1m.gif                        4 Nov 01 19:35         0.2Kb
cub1l.gif                        4 Nov 01 19:35         0.2Kb
cub1k.gif                        4 Nov 01 19:35         0.2Kb
cub1j.gif                        4 Nov 01 19:35         0.2Kb
cub1i.gif                        4 Nov 01 19:35         0.3Kb
cub1h.gif                        4 Nov 01 19:35         0.2Kb
cub1g.gif                        4 Nov 01 19:35         0.3Kb
cub1f.gif                        4 Nov 01 19:35         0.3Kb
cub1e.gif                        4 Nov 01 19:35         0.2Kb
cub1d.gif                        4 Nov 01 19:35         0.2Kb
cub1c.gif                        4 Nov 01 19:35         0.2Kb
cub1b.gif                        4 Nov 01 19:35         0.2Kb
cub1a.gif                        4 Nov 01 19:35         0.3Kb
creapat2.gif                     4 Nov 01 19:35         0.6Kb
creapat1.gif                     4 Nov 01 19:34         0.6Kb
_____________________________________________________________


Index of /jaap/puzzles/images/magic/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
cub1n.gif                        4 Nov 01 19:35         0.2Kb
mag1a.gif                        4 Nov 01 19:35         0.2Kb
cub1m.gif                        4 Nov 01 19:35         0.2Kb
cub1c.gif                        4 Nov 01 19:35         0.2Kb
mag1b.gif                        4 Nov 01 19:35         0.2Kb
cub2a.gif                        4 Nov 01 19:35         0.2Kb
cub2b.gif                        4 Nov 01 19:35         0.2Kb
mag2b.gif                        4 Nov 01 19:35         0.2Kb
cub1d.gif                        4 Nov 01 19:35         0.2Kb
mag3b.gif                        4 Nov 01 19:35         0.2Kb
cub1k.gif                        4 Nov 01 19:35         0.2Kb
cub1r.gif                        4 Nov 01 19:35         0.2Kb
cub1j.gif                        4 Nov 01 19:35         0.2Kb
mag2d.gif                        4 Nov 01 19:35         0.2Kb
cub1o.gif                        4 Nov 01 19:35         0.2Kb
mag4j.gif                        4 Nov 01 19:35         0.2Kb
cub2c.gif                        4 Nov 01 19:35         0.2Kb
mag2c.gif                        4 Nov 01 19:35         0.2Kb
mag4f.gif                        4 Nov 01 19:35         0.2Kb
cub2d.gif                        4 Nov 01 19:35         0.2Kb
mag5e.gif                        4 Nov 01 19:35         0.2Kb
mag0.gif                         4 Nov 01 19:35         0.2Kb
cub1b.gif                        4 Nov 01 19:35         0.2Kb
cub1s.gif                        4 Nov 01 19:35         0.2Kb
mag4h.gif                        4 Nov 01 19:35         0.2Kb
mag2e.gif                        4 Nov 01 19:35         0.2Kb
cub1h.gif                        4 Nov 01 19:35         0.2Kb
cub1l.gif                        4 Nov 01 19:35         0.2Kb
mag4b.gif                        4 Nov 01 19:35         0.2Kb
mag4g.gif                        4 Nov 01 19:35         0.2Kb
cub1e.gif                        4 Nov 01 19:35         0.2Kb
mast6d.gif                       4 Nov 01 19:36         0.2Kb
mast6e.gif                       4 Nov 01 19:36         0.2Kb
mag3c.gif                        4 Nov 01 19:35         0.3Kb
mag4d.gif                        4 Nov 01 19:35         0.3Kb
mag4c.gif                        4 Nov 01 19:35         0.3Kb
mast5h.gif                       4 Nov 01 19:36         0.3Kb
cub1i.gif                        4 Nov 01 19:35         0.3Kb
mast5j.gif                       4 Nov 01 19:36         0.3Kb
mag4l.gif                        4 Nov 01 19:35         0.3Kb
mast5n.gif                       4 Nov 01 19:36         0.3Kb
mag5d.gif                        4 Nov 01 19:35         0.3Kb
cub1f.gif                        4 Nov 01 19:35         0.3Kb
mast3b.gif                       4 Nov 01 19:35         0.3Kb
mag1d.gif                        4 Nov 01 19:35         0.3Kb
mast6b.gif                       4 Nov 01 19:36         0.3Kb
mag4k.gif                        4 Nov 01 19:35         0.3Kb
mag0b.gif                        4 Nov 01 19:35         0.3Kb
mag1c.gif                        4 Nov 01 19:35         0.3Kb
mag4a.gif                        4 Nov 01 19:35         0.3Kb
mast5d.gif                       4 Nov 01 19:36         0.3Kb
mag5b.gif                        4 Nov 01 19:35         0.3Kb
mast0.gif                        4 Nov 01 19:35         0.3Kb
mast5i.gif                       4 Nov 01 19:36         0.3Kb
mast5b.gif                       4 Nov 01 19:36         0.3Kb
mag4i.gif                        4 Nov 01 19:35         0.3Kb
mast5o.gif                       4 Nov 01 19:36         0.3Kb
mast6f.gif                       4 Nov 01 19:36         0.3Kb
mast6a.gif                       4 Nov 01 19:36         0.3Kb
mast5l.gif                       4 Nov 01 19:36         0.3Kb
cub1a.gif                        4 Nov 01 19:35         0.3Kb
mag3a.gif                        4 Nov 01 19:35         0.3Kb
cub1p.gif                        4 Nov 01 19:35         0.3Kb
cub1q.gif                        4 Nov 01 19:35         0.3Kb
mast5g.gif                       4 Nov 01 19:36         0.3Kb
mag4e.gif                        4 Nov 01 19:35         0.3Kb
mast6h.gif                       4 Nov 01 19:36         0.3Kb
cub1g.gif                        4 Nov 01 19:35         0.3Kb
mag5a.gif                        4 Nov 01 19:35         0.3Kb
mast3f.gif                       4 Nov 01 19:36         0.3Kb
mag2a.gif                        4 Nov 01 19:35         0.3Kb
mast5f.gif                       4 Nov 01 19:36         0.3Kb
mast5e.gif                       4 Nov 01 19:36         0.3Kb
mag2f.gif                        4 Nov 01 19:35         0.3Kb
mast5a.gif                       4 Nov 01 19:36         0.3Kb
mast5m.gif                       4 Nov 01 19:36         0.3Kb
mast3g.gif                       4 Nov 01 19:36         0.3Kb
mast5c.gif                       4 Nov 01 19:36         0.3Kb
mast5p.gif                       4 Nov 01 19:36         0.3Kb
mast5k.gif                       4 Nov 01 19:36         0.4Kb
mast3c.gif                       4 Nov 01 19:35         0.4Kb
mast3a.gif                       4 Nov 01 19:35         0.4Kb
mast6g.gif                       4 Nov 01 19:36         0.4Kb
mast3d.gif                       4 Nov 01 19:36         0.4Kb
mast0b.gif                       4 Nov 01 19:35         0.4Kb
mast6i.gif                       4 Nov 01 19:36         0.4Kb
mast6c.gif                       4 Nov 01 19:36         0.4Kb
mast3e.gif                       4 Nov 01 19:36         0.4Kb
creapat1.gif                     4 Nov 01 19:34         0.6Kb
creapat2.gif                     4 Nov 01 19:35         0.6Kb
_____________________________________________________________


Index of /jaap/puzzles/images/magic/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
creapat1.gif                     4 Nov 01 19:34         0.6Kb
creapat2.gif                     4 Nov 01 19:35         0.6Kb
cub1a.gif                        4 Nov 01 19:35         0.3Kb
cub1b.gif                        4 Nov 01 19:35         0.2Kb
cub1c.gif                        4 Nov 01 19:35         0.2Kb
cub1d.gif                        4 Nov 01 19:35         0.2Kb
cub1e.gif                        4 Nov 01 19:35         0.2Kb
cub1f.gif                        4 Nov 01 19:35         0.3Kb
cub1g.gif                        4 Nov 01 19:35         0.3Kb
cub1h.gif                        4 Nov 01 19:35         0.2Kb
cub1i.gif                        4 Nov 01 19:35         0.3Kb
cub1j.gif                        4 Nov 01 19:35         0.2Kb
cub1k.gif                        4 Nov 01 19:35         0.2Kb
cub1l.gif                        4 Nov 01 19:35         0.2Kb
cub1m.gif                        4 Nov 01 19:35         0.2Kb
cub1n.gif                        4 Nov 01 19:35         0.2Kb
cub1o.gif                        4 Nov 01 19:35         0.2Kb
cub1p.gif                        4 Nov 01 19:35         0.3Kb
cub1q.gif                        4 Nov 01 19:35         0.3Kb
cub1r.gif                        4 Nov 01 19:35         0.2Kb
cub1s.gif                        4 Nov 01 19:35         0.2Kb
cub2a.gif                        4 Nov 01 19:35         0.2Kb
cub2b.gif                        4 Nov 01 19:35         0.2Kb
cub2c.gif                        4 Nov 01 19:35         0.2Kb
cub2d.gif                        4 Nov 01 19:35         0.2Kb
mag0.gif                         4 Nov 01 19:35         0.2Kb
mag0b.gif                        4 Nov 01 19:35         0.3Kb
mag1a.gif                        4 Nov 01 19:35         0.2Kb
mag1b.gif                        4 Nov 01 19:35         0.2Kb
mag1c.gif                        4 Nov 01 19:35         0.3Kb
mag1d.gif                        4 Nov 01 19:35         0.3Kb
mag2a.gif                        4 Nov 01 19:35         0.3Kb
mag2b.gif                        4 Nov 01 19:35         0.2Kb
mag2c.gif                        4 Nov 01 19:35         0.2Kb
mag2d.gif                        4 Nov 01 19:35         0.2Kb
mag2e.gif                        4 Nov 01 19:35         0.2Kb
mag2f.gif                        4 Nov 01 19:35         0.3Kb
mag3a.gif                        4 Nov 01 19:35         0.3Kb
mag3b.gif                        4 Nov 01 19:35         0.2Kb
mag3c.gif                        4 Nov 01 19:35         0.3Kb
mag4a.gif                        4 Nov 01 19:35         0.3Kb
mag4b.gif                        4 Nov 01 19:35         0.2Kb
mag4c.gif                        4 Nov 01 19:35         0.3Kb
mag4d.gif                        4 Nov 01 19:35         0.3Kb
mag4e.gif                        4 Nov 01 19:35         0.3Kb
mag4f.gif                        4 Nov 01 19:35         0.2Kb
mag4g.gif                        4 Nov 01 19:35         0.2Kb
mag4h.gif                        4 Nov 01 19:35         0.2Kb
mag4i.gif                        4 Nov 01 19:35         0.3Kb
mag4j.gif                        4 Nov 01 19:35         0.2Kb
mag4k.gif                        4 Nov 01 19:35         0.3Kb
mag4l.gif                        4 Nov 01 19:35         0.3Kb
mag5a.gif                        4 Nov 01 19:35         0.3Kb
mag5b.gif                        4 Nov 01 19:35         0.3Kb
mag5d.gif                        4 Nov 01 19:35         0.3Kb
mag5e.gif                        4 Nov 01 19:35         0.2Kb
mast0.gif                        4 Nov 01 19:35         0.3Kb
mast0b.gif                       4 Nov 01 19:35         0.4Kb
mast3a.gif                       4 Nov 01 19:35         0.4Kb
mast3b.gif                       4 Nov 01 19:35         0.3Kb
mast3c.gif                       4 Nov 01 19:35         0.4Kb
mast3d.gif                       4 Nov 01 19:36         0.4Kb
mast3e.gif                       4 Nov 01 19:36         0.4Kb
mast3f.gif                       4 Nov 01 19:36         0.3Kb
mast3g.gif                       4 Nov 01 19:36         0.3Kb
mast5a.gif                       4 Nov 01 19:36         0.3Kb
mast5b.gif                       4 Nov 01 19:36         0.3Kb
mast5c.gif                       4 Nov 01 19:36         0.3Kb
mast5d.gif                       4 Nov 01 19:36         0.3Kb
mast5e.gif                       4 Nov 01 19:36         0.3Kb
mast5f.gif                       4 Nov 01 19:36         0.3Kb
mast5g.gif                       4 Nov 01 19:36         0.3Kb
mast5h.gif                       4 Nov 01 19:36         0.3Kb
mast5i.gif                       4 Nov 01 19:36         0.3Kb
mast5j.gif                       4 Nov 01 19:36         0.3Kb
mast5k.gif                       4 Nov 01 19:36         0.4Kb
mast5l.gif                       4 Nov 01 19:36         0.3Kb
mast5m.gif                       4 Nov 01 19:36         0.3Kb
mast5n.gif                       4 Nov 01 19:36         0.3Kb
mast5o.gif                       4 Nov 01 19:36         0.3Kb
mast5p.gif                       4 Nov 01 19:36         0.3Kb
mast6a.gif                       4 Nov 01 19:36         0.3Kb
mast6b.gif                       4 Nov 01 19:36         0.3Kb
mast6c.gif                       4 Nov 01 19:36         0.4Kb
mast6d.gif                       4 Nov 01 19:36         0.2Kb
mast6e.gif                       4 Nov 01 19:36         0.2Kb
mast6f.gif                       4 Nov 01 19:36         0.3Kb
mast6g.gif                       4 Nov 01 19:36         0.4Kb
mast6h.gif                       4 Nov 01 19:36         0.3Kb
mast6i.gif                       4 Nov 01 19:36         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/massage/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
msblank.gif                      7 Jun 00 14:54         0.0Kb
msblue.gif                       7 Jun 00 15:06         0.2Kb
mscyan.gif                       7 Jun 00 15:06         0.2Kb
msgreen.gif                      7 Jun 00 15:06         0.2Kb
msorange.gif                     7 Jun 00 15:06         0.2Kb
mspurple.gif                     7 Jun 00 15:06         0.2Kb
msred.gif                        7 Jun 00 15:06         0.2Kb
msyellow.gif                     7 Jun 00 15:06         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/massage/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
msyellow.gif                     7 Jun 00 15:06         0.2Kb
msred.gif                        7 Jun 00 15:06         0.2Kb
mspurple.gif                     7 Jun 00 15:06         0.2Kb
msorange.gif                     7 Jun 00 15:06         0.2Kb
msgreen.gif                      7 Jun 00 15:06         0.2Kb
mscyan.gif                       7 Jun 00 15:06         0.2Kb
msblue.gif                       7 Jun 00 15:06         0.2Kb
msblank.gif                      7 Jun 00 14:54         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/massage/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
msblank.gif                      7 Jun 00 14:54         0.0Kb
msblue.gif                       7 Jun 00 15:06         0.2Kb
mscyan.gif                       7 Jun 00 15:06         0.2Kb
msgreen.gif                      7 Jun 00 15:06         0.2Kb
msorange.gif                     7 Jun 00 15:06         0.2Kb
mspurple.gif                     7 Jun 00 15:06         0.2Kb
msred.gif                        7 Jun 00 15:06         0.2Kb
msyellow.gif                     7 Jun 00 15:06         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/massage/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
msyellow.gif                     7 Jun 00 15:06         0.2Kb
msred.gif                        7 Jun 00 15:06         0.2Kb
mspurple.gif                     7 Jun 00 15:06         0.2Kb
msorange.gif                     7 Jun 00 15:06         0.2Kb
msgreen.gif                      7 Jun 00 15:06         0.2Kb
mscyan.gif                       7 Jun 00 15:06         0.2Kb
msblue.gif                       7 Jun 00 15:06         0.2Kb
msblank.gif                      7 Jun 00 14:54         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/massage/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
msblank.gif                      7 Jun 00 14:54         0.0Kb
msblue.gif                       7 Jun 00 15:06         0.2Kb
mscyan.gif                       7 Jun 00 15:06         0.2Kb
msgreen.gif                      7 Jun 00 15:06         0.2Kb
msorange.gif                     7 Jun 00 15:06         0.2Kb
mspurple.gif                     7 Jun 00 15:06         0.2Kb
msred.gif                        7 Jun 00 15:06         0.2Kb
msyellow.gif                     7 Jun 00 15:06         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/massage/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
msyellow.gif                     7 Jun 00 15:06         0.2Kb
msred.gif                        7 Jun 00 15:06         0.2Kb
mspurple.gif                     7 Jun 00 15:06         0.2Kb
msorange.gif                     7 Jun 00 15:06         0.2Kb
msgreen.gif                      7 Jun 00 15:06         0.2Kb
mscyan.gif                       7 Jun 00 15:06         0.2Kb
msblue.gif                       7 Jun 00 15:06         0.2Kb
msblank.gif                      7 Jun 00 14:54         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/master/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
left.gif                        25 Aug 00 13:52         0.1Kb
m0a.gif                         25 Aug 00 13:52         0.1Kb
m0b.gif                         25 Aug 00 13:52         0.1Kb
m0c.gif                         25 Aug 00 13:52         0.1Kb
m0d.gif                         25 Aug 00 13:52         0.1Kb
m1a.gif                         25 Aug 00 13:52         0.1Kb
m1b.gif                         25 Aug 00 13:52         0.1Kb
m1c.gif                         25 Aug 00 13:52         0.1Kb
m1d.gif                         25 Aug 00 13:52         0.1Kb
m2a.gif                         25 Aug 00 13:52         0.1Kb
m2b.gif                         25 Aug 00 13:52         0.1Kb
m2c.gif                         25 Aug 00 13:52         0.1Kb
m2d.gif                         25 Aug 00 13:52         0.1Kb
m3a.gif                         25 Aug 00 13:52         0.1Kb
m3b.gif                         25 Aug 00 13:52         0.1Kb
m3c.gif                         25 Aug 00 13:52         0.1Kb
m3d.gif                         25 Aug 00 13:52         0.1Kb
m4a.gif                         25 Aug 00 13:52         0.1Kb
m4b.gif                         25 Aug 00 13:52         0.1Kb
m4c.gif                         25 Aug 00 13:52         0.1Kb
m4d.gif                         25 Aug 00 13:52         0.1Kb
m5a.gif                         25 Aug 00 13:52         0.1Kb
m5b.gif                         25 Aug 00 13:52         0.1Kb
m5c.gif                         25 Aug 00 13:52         0.1Kb
m5d.gif                         25 Aug 00 13:52         0.1Kb
m6a.gif                         25 Aug 00 13:52         0.1Kb
m6b.gif                         25 Aug 00 13:52         0.1Kb
m6c.gif                         25 Aug 00 13:52         0.1Kb
m6d.gif                         25 Aug 00 13:52         0.1Kb
m7a.gif                         25 Aug 00 13:52         0.1Kb
m7b.gif                         25 Aug 00 13:52         0.1Kb
m7c.gif                         25 Aug 00 13:52         0.1Kb
m7d.gif                         25 Aug 00 13:52         0.1Kb
m8a.gif                         25 Aug 00 13:52         0.1Kb
m8b.gif                         25 Aug 00 13:52         0.1Kb
m8c.gif                         25 Aug 00 13:52         0.1Kb
m8d.gif                         25 Aug 00 13:52         0.1Kb
master1.gif                      1 Jan 01 19:33         1.3Kb
master2.gif                      1 Jan 01 19:33         2.5Kb
master3.gif                      1 Jan 01 19:33         1.8Kb
master4.gif                      1 Jan 01 19:33         0.5Kb
right.gif                       25 Aug 00 13:52         0.1Kb
turnl.gif                       25 Aug 00 13:52         0.1Kb
turnr.gif                       25 Aug 00 13:52         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/master/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
turnr.gif                       25 Aug 00 13:52         0.1Kb
turnl.gif                       25 Aug 00 13:52         0.1Kb
right.gif                       25 Aug 00 13:52         0.1Kb
master4.gif                      1 Jan 01 19:33         0.5Kb
master3.gif                      1 Jan 01 19:33         1.8Kb
master2.gif                      1 Jan 01 19:33         2.5Kb
master1.gif                      1 Jan 01 19:33         1.3Kb
m8d.gif                         25 Aug 00 13:52         0.1Kb
m8c.gif                         25 Aug 00 13:52         0.1Kb
m8b.gif                         25 Aug 00 13:52         0.1Kb
m8a.gif                         25 Aug 00 13:52         0.1Kb
m7d.gif                         25 Aug 00 13:52         0.1Kb
m7c.gif                         25 Aug 00 13:52         0.1Kb
m7b.gif                         25 Aug 00 13:52         0.1Kb
m7a.gif                         25 Aug 00 13:52         0.1Kb
m6d.gif                         25 Aug 00 13:52         0.1Kb
m6c.gif                         25 Aug 00 13:52         0.1Kb
m6b.gif                         25 Aug 00 13:52         0.1Kb
m6a.gif                         25 Aug 00 13:52         0.1Kb
m5d.gif                         25 Aug 00 13:52         0.1Kb
m5c.gif                         25 Aug 00 13:52         0.1Kb
m5b.gif                         25 Aug 00 13:52         0.1Kb
m5a.gif                         25 Aug 00 13:52         0.1Kb
m4d.gif                         25 Aug 00 13:52         0.1Kb
m4c.gif                         25 Aug 00 13:52         0.1Kb
m4b.gif                         25 Aug 00 13:52         0.1Kb
m4a.gif                         25 Aug 00 13:52         0.1Kb
m3d.gif                         25 Aug 00 13:52         0.1Kb
m3c.gif                         25 Aug 00 13:52         0.1Kb
m3b.gif                         25 Aug 00 13:52         0.1Kb
m3a.gif                         25 Aug 00 13:52         0.1Kb
m2d.gif                         25 Aug 00 13:52         0.1Kb
m2c.gif                         25 Aug 00 13:52         0.1Kb
m2b.gif                         25 Aug 00 13:52         0.1Kb
m2a.gif                         25 Aug 00 13:52         0.1Kb
m1d.gif                         25 Aug 00 13:52         0.1Kb
m1c.gif                         25 Aug 00 13:52         0.1Kb
m1b.gif                         25 Aug 00 13:52         0.1Kb
m1a.gif                         25 Aug 00 13:52         0.1Kb
m0d.gif                         25 Aug 00 13:52         0.1Kb
m0c.gif                         25 Aug 00 13:52         0.1Kb
m0b.gif                         25 Aug 00 13:52         0.1Kb
m0a.gif                         25 Aug 00 13:52         0.1Kb
left.gif                        25 Aug 00 13:52         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/master/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
m0c.gif                         25 Aug 00 13:52         0.1Kb
m1c.gif                         25 Aug 00 13:52         0.1Kb
m2c.gif                         25 Aug 00 13:52         0.1Kb
m3c.gif                         25 Aug 00 13:52         0.1Kb
m4c.gif                         25 Aug 00 13:52         0.1Kb
m5c.gif                         25 Aug 00 13:52         0.1Kb
m6c.gif                         25 Aug 00 13:52         0.1Kb
m7c.gif                         25 Aug 00 13:52         0.1Kb
m8c.gif                         25 Aug 00 13:52         0.1Kb
turnl.gif                       25 Aug 00 13:52         0.1Kb
turnr.gif                       25 Aug 00 13:52         0.1Kb
m0b.gif                         25 Aug 00 13:52         0.1Kb
m1b.gif                         25 Aug 00 13:52         0.1Kb
m2b.gif                         25 Aug 00 13:52         0.1Kb
m3b.gif                         25 Aug 00 13:52         0.1Kb
m4b.gif                         25 Aug 00 13:52         0.1Kb
m5b.gif                         25 Aug 00 13:52         0.1Kb
m6b.gif                         25 Aug 00 13:52         0.1Kb
m7b.gif                         25 Aug 00 13:52         0.1Kb
m8b.gif                         25 Aug 00 13:52         0.1Kb
right.gif                       25 Aug 00 13:52         0.1Kb
left.gif                        25 Aug 00 13:52         0.1Kb
m0a.gif                         25 Aug 00 13:52         0.1Kb
m1a.gif                         25 Aug 00 13:52         0.1Kb
m2a.gif                         25 Aug 00 13:52         0.1Kb
m3a.gif                         25 Aug 00 13:52         0.1Kb
m4a.gif                         25 Aug 00 13:52         0.1Kb
m5a.gif                         25 Aug 00 13:52         0.1Kb
m6a.gif                         25 Aug 00 13:52         0.1Kb
m7a.gif                         25 Aug 00 13:52         0.1Kb
m8a.gif                         25 Aug 00 13:52         0.1Kb
m0d.gif                         25 Aug 00 13:52         0.1Kb
m1d.gif                         25 Aug 00 13:52         0.1Kb
m2d.gif                         25 Aug 00 13:52         0.1Kb
m3d.gif                         25 Aug 00 13:52         0.1Kb
m4d.gif                         25 Aug 00 13:52         0.1Kb
m5d.gif                         25 Aug 00 13:52         0.1Kb
m6d.gif                         25 Aug 00 13:52         0.1Kb
m7d.gif                         25 Aug 00 13:52         0.1Kb
m8d.gif                         25 Aug 00 13:52         0.1Kb
master4.gif                      1 Jan 01 19:33         0.5Kb
master1.gif                      1 Jan 01 19:33         1.3Kb
master3.gif                      1 Jan 01 19:33         1.8Kb
master2.gif                      1 Jan 01 19:33         2.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/master/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
master2.gif                      1 Jan 01 19:33         2.5Kb
master3.gif                      1 Jan 01 19:33         1.8Kb
master1.gif                      1 Jan 01 19:33         1.3Kb
master4.gif                      1 Jan 01 19:33         0.5Kb
m8d.gif                         25 Aug 00 13:52         0.1Kb
m7d.gif                         25 Aug 00 13:52         0.1Kb
m6d.gif                         25 Aug 00 13:52         0.1Kb
m5d.gif                         25 Aug 00 13:52         0.1Kb
m4d.gif                         25 Aug 00 13:52         0.1Kb
m3d.gif                         25 Aug 00 13:52         0.1Kb
m2d.gif                         25 Aug 00 13:52         0.1Kb
m1d.gif                         25 Aug 00 13:52         0.1Kb
m0d.gif                         25 Aug 00 13:52         0.1Kb
m8a.gif                         25 Aug 00 13:52         0.1Kb
m7a.gif                         25 Aug 00 13:52         0.1Kb
m6a.gif                         25 Aug 00 13:52         0.1Kb
m5a.gif                         25 Aug 00 13:52         0.1Kb
m4a.gif                         25 Aug 00 13:52         0.1Kb
m3a.gif                         25 Aug 00 13:52         0.1Kb
m2a.gif                         25 Aug 00 13:52         0.1Kb
m1a.gif                         25 Aug 00 13:52         0.1Kb
m0a.gif                         25 Aug 00 13:52         0.1Kb
left.gif                        25 Aug 00 13:52         0.1Kb
right.gif                       25 Aug 00 13:52         0.1Kb
m8b.gif                         25 Aug 00 13:52         0.1Kb
m7b.gif                         25 Aug 00 13:52         0.1Kb
m6b.gif                         25 Aug 00 13:52         0.1Kb
m5b.gif                         25 Aug 00 13:52         0.1Kb
m4b.gif                         25 Aug 00 13:52         0.1Kb
m3b.gif                         25 Aug 00 13:52         0.1Kb
m2b.gif                         25 Aug 00 13:52         0.1Kb
m1b.gif                         25 Aug 00 13:52         0.1Kb
m0b.gif                         25 Aug 00 13:52         0.1Kb
turnr.gif                       25 Aug 00 13:52         0.1Kb
turnl.gif                       25 Aug 00 13:52         0.1Kb
m8c.gif                         25 Aug 00 13:52         0.1Kb
m7c.gif                         25 Aug 00 13:52         0.1Kb
m6c.gif                         25 Aug 00 13:52         0.1Kb
m5c.gif                         25 Aug 00 13:52         0.1Kb
m4c.gif                         25 Aug 00 13:52         0.1Kb
m3c.gif                         25 Aug 00 13:52         0.1Kb
m2c.gif                         25 Aug 00 13:52         0.1Kb
m1c.gif                         25 Aug 00 13:52         0.1Kb
m0c.gif                         25 Aug 00 13:52         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/master/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
left.gif                        25 Aug 00 13:52         0.1Kb
m0a.gif                         25 Aug 00 13:52         0.1Kb
m0b.gif                         25 Aug 00 13:52         0.1Kb
m0c.gif                         25 Aug 00 13:52         0.1Kb
m0d.gif                         25 Aug 00 13:52         0.1Kb
m1a.gif                         25 Aug 00 13:52         0.1Kb
m1b.gif                         25 Aug 00 13:52         0.1Kb
m1c.gif                         25 Aug 00 13:52         0.1Kb
m1d.gif                         25 Aug 00 13:52         0.1Kb
m2a.gif                         25 Aug 00 13:52         0.1Kb
m2b.gif                         25 Aug 00 13:52         0.1Kb
m2c.gif                         25 Aug 00 13:52         0.1Kb
m2d.gif                         25 Aug 00 13:52         0.1Kb
m3a.gif                         25 Aug 00 13:52         0.1Kb
m3b.gif                         25 Aug 00 13:52         0.1Kb
m3c.gif                         25 Aug 00 13:52         0.1Kb
m3d.gif                         25 Aug 00 13:52         0.1Kb
m4a.gif                         25 Aug 00 13:52         0.1Kb
m4b.gif                         25 Aug 00 13:52         0.1Kb
m4c.gif                         25 Aug 00 13:52         0.1Kb
m4d.gif                         25 Aug 00 13:52         0.1Kb
m5a.gif                         25 Aug 00 13:52         0.1Kb
m5b.gif                         25 Aug 00 13:52         0.1Kb
m5c.gif                         25 Aug 00 13:52         0.1Kb
m5d.gif                         25 Aug 00 13:52         0.1Kb
m6a.gif                         25 Aug 00 13:52         0.1Kb
m6b.gif                         25 Aug 00 13:52         0.1Kb
m6c.gif                         25 Aug 00 13:52         0.1Kb
m6d.gif                         25 Aug 00 13:52         0.1Kb
m7a.gif                         25 Aug 00 13:52         0.1Kb
m7b.gif                         25 Aug 00 13:52         0.1Kb
m7c.gif                         25 Aug 00 13:52         0.1Kb
m7d.gif                         25 Aug 00 13:52         0.1Kb
m8a.gif                         25 Aug 00 13:52         0.1Kb
m8b.gif                         25 Aug 00 13:52         0.1Kb
m8c.gif                         25 Aug 00 13:52         0.1Kb
m8d.gif                         25 Aug 00 13:52         0.1Kb
right.gif                       25 Aug 00 13:52         0.1Kb
turnl.gif                       25 Aug 00 13:52         0.1Kb
turnr.gif                       25 Aug 00 13:52         0.1Kb
master1.gif                      1 Jan 01 19:33         1.3Kb
master2.gif                      1 Jan 01 19:33         2.5Kb
master3.gif                      1 Jan 01 19:33         1.8Kb
master4.gif                      1 Jan 01 19:33         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/master/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
master4.gif                      1 Jan 01 19:33         0.5Kb
master3.gif                      1 Jan 01 19:33         1.8Kb
master2.gif                      1 Jan 01 19:33         2.5Kb
master1.gif                      1 Jan 01 19:33         1.3Kb
turnr.gif                       25 Aug 00 13:52         0.1Kb
turnl.gif                       25 Aug 00 13:52         0.1Kb
right.gif                       25 Aug 00 13:52         0.1Kb
m8d.gif                         25 Aug 00 13:52         0.1Kb
m8c.gif                         25 Aug 00 13:52         0.1Kb
m8b.gif                         25 Aug 00 13:52         0.1Kb
m8a.gif                         25 Aug 00 13:52         0.1Kb
m7d.gif                         25 Aug 00 13:52         0.1Kb
m7c.gif                         25 Aug 00 13:52         0.1Kb
m7b.gif                         25 Aug 00 13:52         0.1Kb
m7a.gif                         25 Aug 00 13:52         0.1Kb
m6d.gif                         25 Aug 00 13:52         0.1Kb
m6c.gif                         25 Aug 00 13:52         0.1Kb
m6b.gif                         25 Aug 00 13:52         0.1Kb
m6a.gif                         25 Aug 00 13:52         0.1Kb
m5d.gif                         25 Aug 00 13:52         0.1Kb
m5c.gif                         25 Aug 00 13:52         0.1Kb
m5b.gif                         25 Aug 00 13:52         0.1Kb
m5a.gif                         25 Aug 00 13:52         0.1Kb
m4d.gif                         25 Aug 00 13:52         0.1Kb
m4c.gif                         25 Aug 00 13:52         0.1Kb
m4b.gif                         25 Aug 00 13:52         0.1Kb
m4a.gif                         25 Aug 00 13:52         0.1Kb
m3d.gif                         25 Aug 00 13:52         0.1Kb
m3c.gif                         25 Aug 00 13:52         0.1Kb
m3b.gif                         25 Aug 00 13:52         0.1Kb
m3a.gif                         25 Aug 00 13:52         0.1Kb
m2d.gif                         25 Aug 00 13:52         0.1Kb
m2c.gif                         25 Aug 00 13:52         0.1Kb
m2b.gif                         25 Aug 00 13:52         0.1Kb
m2a.gif                         25 Aug 00 13:52         0.1Kb
m1d.gif                         25 Aug 00 13:52         0.1Kb
m1c.gif                         25 Aug 00 13:52         0.1Kb
m1b.gif                         25 Aug 00 13:52         0.1Kb
m1a.gif                         25 Aug 00 13:52         0.1Kb
m0d.gif                         25 Aug 00 13:52         0.1Kb
m0c.gif                         25 Aug 00 13:52         0.1Kb
m0b.gif                         25 Aug 00 13:52         0.1Kb
m0a.gif                         25 Aug 00 13:52         0.1Kb
left.gif                        25 Aug 00 13:52         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/missing/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
mlb1.gif                        11 Jun 00 18:19         0.2Kb
mlb2.gif                        11 Jun 00 18:19         0.2Kb
mlb3.gif                        11 Jun 00 18:19         0.2Kb
mlb4.gif                        11 Jun 00 18:19         0.2Kb
mlblnk.gif                      11 Jun 00 18:21         0.2Kb
mlleft.gif                      11 Jun 00 18:19         0.1Kb
mlm1.gif                        11 Jun 00 18:19         0.2Kb
mlm2.gif                        11 Jun 00 18:19         0.2Kb
mlm3.gif                        11 Jun 00 18:19         0.2Kb
mlm4.gif                        11 Jun 00 18:19         0.2Kb
mlright.gif                     11 Jun 00 18:19         0.1Kb
mlt1.gif                        11 Jun 00 18:19         0.2Kb
mlt2.gif                        11 Jun 00 18:19         0.2Kb
mlt3.gif                        11 Jun 00 18:19         0.2Kb
mlt4.gif                        11 Jun 00 18:19         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/missing/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
mlt4.gif                        11 Jun 00 18:19         0.2Kb
mlt3.gif                        11 Jun 00 18:19         0.2Kb
mlt2.gif                        11 Jun 00 18:19         0.2Kb
mlt1.gif                        11 Jun 00 18:19         0.2Kb
mlright.gif                     11 Jun 00 18:19         0.1Kb
mlm4.gif                        11 Jun 00 18:19         0.2Kb
mlm3.gif                        11 Jun 00 18:19         0.2Kb
mlm2.gif                        11 Jun 00 18:19         0.2Kb
mlm1.gif                        11 Jun 00 18:19         0.2Kb
mlleft.gif                      11 Jun 00 18:19         0.1Kb
mlblnk.gif                      11 Jun 00 18:21         0.2Kb
mlb4.gif                        11 Jun 00 18:19         0.2Kb
mlb3.gif                        11 Jun 00 18:19         0.2Kb
mlb2.gif                        11 Jun 00 18:19         0.2Kb
mlb1.gif                        11 Jun 00 18:19         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/missing/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
mlleft.gif                      11 Jun 00 18:19         0.1Kb
mlright.gif                     11 Jun 00 18:19         0.1Kb
mlblnk.gif                      11 Jun 00 18:21         0.2Kb
mlt1.gif                        11 Jun 00 18:19         0.2Kb
mlt2.gif                        11 Jun 00 18:19         0.2Kb
mlt3.gif                        11 Jun 00 18:19         0.2Kb
mlt4.gif                        11 Jun 00 18:19         0.2Kb
mlb1.gif                        11 Jun 00 18:19         0.2Kb
mlb2.gif                        11 Jun 00 18:19         0.2Kb
mlb3.gif                        11 Jun 00 18:19         0.2Kb
mlb4.gif                        11 Jun 00 18:19         0.2Kb
mlm1.gif                        11 Jun 00 18:19         0.2Kb
mlm2.gif                        11 Jun 00 18:19         0.2Kb
mlm3.gif                        11 Jun 00 18:19         0.2Kb
mlm4.gif                        11 Jun 00 18:19         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/missing/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
mlm4.gif                        11 Jun 00 18:19         0.2Kb
mlm3.gif                        11 Jun 00 18:19         0.2Kb
mlm2.gif                        11 Jun 00 18:19         0.2Kb
mlm1.gif                        11 Jun 00 18:19         0.2Kb
mlb4.gif                        11 Jun 00 18:19         0.2Kb
mlb3.gif                        11 Jun 00 18:19         0.2Kb
mlb2.gif                        11 Jun 00 18:19         0.2Kb
mlb1.gif                        11 Jun 00 18:19         0.2Kb
mlt4.gif                        11 Jun 00 18:19         0.2Kb
mlt3.gif                        11 Jun 00 18:19         0.2Kb
mlt2.gif                        11 Jun 00 18:19         0.2Kb
mlt1.gif                        11 Jun 00 18:19         0.2Kb
mlblnk.gif                      11 Jun 00 18:21         0.2Kb
mlright.gif                     11 Jun 00 18:19         0.1Kb
mlleft.gif                      11 Jun 00 18:19         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/missing/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
mlb1.gif                        11 Jun 00 18:19         0.2Kb
mlb2.gif                        11 Jun 00 18:19         0.2Kb
mlb3.gif                        11 Jun 00 18:19         0.2Kb
mlb4.gif                        11 Jun 00 18:19         0.2Kb
mlleft.gif                      11 Jun 00 18:19         0.1Kb
mlm1.gif                        11 Jun 00 18:19         0.2Kb
mlm2.gif                        11 Jun 00 18:19         0.2Kb
mlm3.gif                        11 Jun 00 18:19         0.2Kb
mlm4.gif                        11 Jun 00 18:19         0.2Kb
mlright.gif                     11 Jun 00 18:19         0.1Kb
mlt1.gif                        11 Jun 00 18:19         0.2Kb
mlt2.gif                        11 Jun 00 18:19         0.2Kb
mlt3.gif                        11 Jun 00 18:19         0.2Kb
mlt4.gif                        11 Jun 00 18:19         0.2Kb
mlblnk.gif                      11 Jun 00 18:21         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/missing/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
mlblnk.gif                      11 Jun 00 18:21         0.2Kb
mlt4.gif                        11 Jun 00 18:19         0.2Kb
mlt3.gif                        11 Jun 00 18:19         0.2Kb
mlt2.gif                        11 Jun 00 18:19         0.2Kb
mlt1.gif                        11 Jun 00 18:19         0.2Kb
mlright.gif                     11 Jun 00 18:19         0.1Kb
mlm4.gif                        11 Jun 00 18:19         0.2Kb
mlm3.gif                        11 Jun 00 18:19         0.2Kb
mlm2.gif                        11 Jun 00 18:19         0.2Kb
mlm1.gif                        11 Jun 00 18:19         0.2Kb
mlleft.gif                      11 Jun 00 18:19         0.1Kb
mlb4.gif                        11 Jun 00 18:19         0.2Kb
mlb3.gif                        11 Jun 00 18:19         0.2Kb
mlb2.gif                        11 Jun 00 18:19         0.2Kb
mlb1.gif                        11 Jun 00 18:19         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nineball/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
empty.gif                        1 Jan 01 19:24         0.0Kb
nb0.gif                          1 Jan 01 19:24         0.2Kb
nb1.gif                          1 Jan 01 19:24         0.3Kb
nb2.gif                          1 Jan 01 19:24         0.3Kb
nb3.gif                          1 Jan 01 19:24         0.3Kb
nb4.gif                          1 Jan 01 19:24         0.3Kb
nb5.gif                          1 Jan 01 19:24         0.3Kb
nb6.gif                          1 Jan 01 19:24         0.3Kb
nb7.gif                          1 Jan 01 19:24         0.3Kb
nb8.gif                          1 Jan 01 19:25         0.3Kb
nb9.gif                          1 Jan 01 19:25         0.3Kb
nbback.gif                       1 Jan 01 19:25         2.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nineball/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
nbback.gif                       1 Jan 01 19:25         2.1Kb
nb9.gif                          1 Jan 01 19:25         0.3Kb
nb8.gif                          1 Jan 01 19:25         0.3Kb
nb7.gif                          1 Jan 01 19:24         0.3Kb
nb6.gif                          1 Jan 01 19:24         0.3Kb
nb5.gif                          1 Jan 01 19:24         0.3Kb
nb4.gif                          1 Jan 01 19:24         0.3Kb
nb3.gif                          1 Jan 01 19:24         0.3Kb
nb2.gif                          1 Jan 01 19:24         0.3Kb
nb1.gif                          1 Jan 01 19:24         0.3Kb
nb0.gif                          1 Jan 01 19:24         0.2Kb
empty.gif                        1 Jan 01 19:24         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nineball/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
empty.gif                        1 Jan 01 19:24         0.0Kb
nb0.gif                          1 Jan 01 19:24         0.2Kb
nb8.gif                          1 Jan 01 19:25         0.3Kb
nb1.gif                          1 Jan 01 19:24         0.3Kb
nb4.gif                          1 Jan 01 19:24         0.3Kb
nb2.gif                          1 Jan 01 19:24         0.3Kb
nb7.gif                          1 Jan 01 19:24         0.3Kb
nb5.gif                          1 Jan 01 19:24         0.3Kb
nb6.gif                          1 Jan 01 19:24         0.3Kb
nb3.gif                          1 Jan 01 19:24         0.3Kb
nb9.gif                          1 Jan 01 19:25         0.3Kb
nbback.gif                       1 Jan 01 19:25         2.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nineball/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
nbback.gif                       1 Jan 01 19:25         2.1Kb
nb9.gif                          1 Jan 01 19:25         0.3Kb
nb3.gif                          1 Jan 01 19:24         0.3Kb
nb6.gif                          1 Jan 01 19:24         0.3Kb
nb5.gif                          1 Jan 01 19:24         0.3Kb
nb7.gif                          1 Jan 01 19:24         0.3Kb
nb2.gif                          1 Jan 01 19:24         0.3Kb
nb4.gif                          1 Jan 01 19:24         0.3Kb
nb1.gif                          1 Jan 01 19:24         0.3Kb
nb8.gif                          1 Jan 01 19:25         0.3Kb
nb0.gif                          1 Jan 01 19:24         0.2Kb
empty.gif                        1 Jan 01 19:24         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nineball/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
empty.gif                        1 Jan 01 19:24         0.0Kb
nb0.gif                          1 Jan 01 19:24         0.2Kb
nb1.gif                          1 Jan 01 19:24         0.3Kb
nb2.gif                          1 Jan 01 19:24         0.3Kb
nb3.gif                          1 Jan 01 19:24         0.3Kb
nb4.gif                          1 Jan 01 19:24         0.3Kb
nb5.gif                          1 Jan 01 19:24         0.3Kb
nb6.gif                          1 Jan 01 19:24         0.3Kb
nb7.gif                          1 Jan 01 19:24         0.3Kb
nb8.gif                          1 Jan 01 19:25         0.3Kb
nb9.gif                          1 Jan 01 19:25         0.3Kb
nbback.gif                       1 Jan 01 19:25         2.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nineball/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
nbback.gif                       1 Jan 01 19:25         2.1Kb
nb9.gif                          1 Jan 01 19:25         0.3Kb
nb8.gif                          1 Jan 01 19:25         0.3Kb
nb7.gif                          1 Jan 01 19:24         0.3Kb
nb6.gif                          1 Jan 01 19:24         0.3Kb
nb5.gif                          1 Jan 01 19:24         0.3Kb
nb4.gif                          1 Jan 01 19:24         0.3Kb
nb3.gif                          1 Jan 01 19:24         0.3Kb
nb2.gif                          1 Jan 01 19:24         0.3Kb
nb1.gif                          1 Jan 01 19:24         0.3Kb
nb0.gif                          1 Jan 01 19:24         0.2Kb
empty.gif                        1 Jan 01 19:24         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nintendo/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
ninbck0.gif                     13 Nov 00 21:24         0.1Kb
ninbck1.gif                     13 Nov 00 21:24         0.1Kb
ninbck2.gif                     13 Nov 00 21:24         0.1Kb
ninbck3.gif                     13 Nov 00 21:24         0.1Kb
ninblack.gif                    13 Nov 00 21:24         0.1Kb
ninblank.gif                    13 Nov 00 21:24         0.1Kb
ninblue.gif                     13 Nov 00 21:24         0.1Kb
ninbotd.gif                     13 Nov 00 21:24         0.3Kb
ninbotu.gif                     13 Nov 00 21:24         0.2Kb
ningreen.gif                    13 Nov 00 21:24         0.1Kb
ninlay0.gif                     13 Nov 00 21:24         0.1Kb
ninlay0l.gif                    13 Nov 00 21:24         0.1Kb
ninlay0r.gif                    13 Nov 00 21:24         0.1Kb
ninlay1.gif                     13 Nov 00 21:24         0.1Kb
ninlay1l.gif                    13 Nov 00 21:24         0.1Kb
ninlay1r.gif                    13 Nov 00 21:24         0.1Kb
ninlay2.gif                     13 Nov 00 21:24         0.1Kb
ninlay2l.gif                    13 Nov 00 21:24         0.1Kb
ninlay2r.gif                    13 Nov 00 21:24         0.1Kb
ninlay3.gif                     13 Nov 00 21:25         0.1Kb
ninlay3l.gif                    13 Nov 00 21:25         0.1Kb
ninlay3r.gif                    13 Nov 00 21:25         0.1Kb
ninorang.gif                    13 Nov 00 21:25         0.1Kb
ninpegb.gif                     13 Nov 00 21:25         0.1Kb
ninpegt.gif                     13 Nov 00 21:25         0.1Kb
ninred.gif                      13 Nov 00 21:25         0.1Kb
nintopd.gif                     13 Nov 00 21:25         0.2Kb
nintopu.gif                     13 Nov 00 21:25         0.3Kb
ninyello.gif                    13 Nov 00 21:25         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nintendo/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
ninyello.gif                    13 Nov 00 21:25         0.1Kb
nintopu.gif                     13 Nov 00 21:25         0.3Kb
nintopd.gif                     13 Nov 00 21:25         0.2Kb
ninred.gif                      13 Nov 00 21:25         0.1Kb
ninpegt.gif                     13 Nov 00 21:25         0.1Kb
ninpegb.gif                     13 Nov 00 21:25         0.1Kb
ninorang.gif                    13 Nov 00 21:25         0.1Kb
ninlay3r.gif                    13 Nov 00 21:25         0.1Kb
ninlay3l.gif                    13 Nov 00 21:25         0.1Kb
ninlay3.gif                     13 Nov 00 21:25         0.1Kb
ninlay2r.gif                    13 Nov 00 21:24         0.1Kb
ninlay2l.gif                    13 Nov 00 21:24         0.1Kb
ninlay2.gif                     13 Nov 00 21:24         0.1Kb
ninlay1r.gif                    13 Nov 00 21:24         0.1Kb
ninlay1l.gif                    13 Nov 00 21:24         0.1Kb
ninlay1.gif                     13 Nov 00 21:24         0.1Kb
ninlay0r.gif                    13 Nov 00 21:24         0.1Kb
ninlay0l.gif                    13 Nov 00 21:24         0.1Kb
ninlay0.gif                     13 Nov 00 21:24         0.1Kb
ningreen.gif                    13 Nov 00 21:24         0.1Kb
ninbotu.gif                     13 Nov 00 21:24         0.2Kb
ninbotd.gif                     13 Nov 00 21:24         0.3Kb
ninblue.gif                     13 Nov 00 21:24         0.1Kb
ninblank.gif                    13 Nov 00 21:24         0.1Kb
ninblack.gif                    13 Nov 00 21:24         0.1Kb
ninbck3.gif                     13 Nov 00 21:24         0.1Kb
ninbck2.gif                     13 Nov 00 21:24         0.1Kb
ninbck1.gif                     13 Nov 00 21:24         0.1Kb
ninbck0.gif                     13 Nov 00 21:24         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nintendo/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
ninbck1.gif                     13 Nov 00 21:24         0.1Kb
ninbck2.gif                     13 Nov 00 21:24         0.1Kb
ninbck0.gif                     13 Nov 00 21:24         0.1Kb
ninbck3.gif                     13 Nov 00 21:24         0.1Kb
ninlay1.gif                     13 Nov 00 21:24         0.1Kb
ninlay2.gif                     13 Nov 00 21:24         0.1Kb
ninlay0.gif                     13 Nov 00 21:24         0.1Kb
ninlay3.gif                     13 Nov 00 21:25         0.1Kb
ninlay2l.gif                    13 Nov 00 21:24         0.1Kb
ninlay2r.gif                    13 Nov 00 21:24         0.1Kb
ninlay1l.gif                    13 Nov 00 21:24         0.1Kb
ninlay1r.gif                    13 Nov 00 21:24         0.1Kb
ninlay3l.gif                    13 Nov 00 21:25         0.1Kb
ninlay0l.gif                    13 Nov 00 21:24         0.1Kb
ninlay3r.gif                    13 Nov 00 21:25         0.1Kb
ninlay0r.gif                    13 Nov 00 21:24         0.1Kb
ninblack.gif                    13 Nov 00 21:24         0.1Kb
ninblank.gif                    13 Nov 00 21:24         0.1Kb
ninblue.gif                     13 Nov 00 21:24         0.1Kb
ningreen.gif                    13 Nov 00 21:24         0.1Kb
ninorang.gif                    13 Nov 00 21:25         0.1Kb
ninred.gif                      13 Nov 00 21:25         0.1Kb
ninpegb.gif                     13 Nov 00 21:25         0.1Kb
ninpegt.gif                     13 Nov 00 21:25         0.1Kb
ninyello.gif                    13 Nov 00 21:25         0.1Kb
ninbotu.gif                     13 Nov 00 21:24         0.2Kb
nintopd.gif                     13 Nov 00 21:25         0.2Kb
ninbotd.gif                     13 Nov 00 21:24         0.3Kb
nintopu.gif                     13 Nov 00 21:25         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nintendo/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
nintopu.gif                     13 Nov 00 21:25         0.3Kb
ninbotd.gif                     13 Nov 00 21:24         0.3Kb
nintopd.gif                     13 Nov 00 21:25         0.2Kb
ninbotu.gif                     13 Nov 00 21:24         0.2Kb
ninyello.gif                    13 Nov 00 21:25         0.1Kb
ninpegt.gif                     13 Nov 00 21:25         0.1Kb
ninpegb.gif                     13 Nov 00 21:25         0.1Kb
ninred.gif                      13 Nov 00 21:25         0.1Kb
ninorang.gif                    13 Nov 00 21:25         0.1Kb
ningreen.gif                    13 Nov 00 21:24         0.1Kb
ninblue.gif                     13 Nov 00 21:24         0.1Kb
ninblank.gif                    13 Nov 00 21:24         0.1Kb
ninblack.gif                    13 Nov 00 21:24         0.1Kb
ninlay0r.gif                    13 Nov 00 21:24         0.1Kb
ninlay3r.gif                    13 Nov 00 21:25         0.1Kb
ninlay0l.gif                    13 Nov 00 21:24         0.1Kb
ninlay3l.gif                    13 Nov 00 21:25         0.1Kb
ninlay1r.gif                    13 Nov 00 21:24         0.1Kb
ninlay1l.gif                    13 Nov 00 21:24         0.1Kb
ninlay2r.gif                    13 Nov 00 21:24         0.1Kb
ninlay2l.gif                    13 Nov 00 21:24         0.1Kb
ninlay3.gif                     13 Nov 00 21:25         0.1Kb
ninlay0.gif                     13 Nov 00 21:24         0.1Kb
ninlay2.gif                     13 Nov 00 21:24         0.1Kb
ninlay1.gif                     13 Nov 00 21:24         0.1Kb
ninbck3.gif                     13 Nov 00 21:24         0.1Kb
ninbck0.gif                     13 Nov 00 21:24         0.1Kb
ninbck2.gif                     13 Nov 00 21:24         0.1Kb
ninbck1.gif                     13 Nov 00 21:24         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nintendo/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
ninbck0.gif                     13 Nov 00 21:24         0.1Kb
ninbck1.gif                     13 Nov 00 21:24         0.1Kb
ninbck2.gif                     13 Nov 00 21:24         0.1Kb
ninbck3.gif                     13 Nov 00 21:24         0.1Kb
ninblack.gif                    13 Nov 00 21:24         0.1Kb
ninblank.gif                    13 Nov 00 21:24         0.1Kb
ninblue.gif                     13 Nov 00 21:24         0.1Kb
ninbotd.gif                     13 Nov 00 21:24         0.3Kb
ninbotu.gif                     13 Nov 00 21:24         0.2Kb
ningreen.gif                    13 Nov 00 21:24         0.1Kb
ninlay0.gif                     13 Nov 00 21:24         0.1Kb
ninlay0l.gif                    13 Nov 00 21:24         0.1Kb
ninlay0r.gif                    13 Nov 00 21:24         0.1Kb
ninlay1.gif                     13 Nov 00 21:24         0.1Kb
ninlay1l.gif                    13 Nov 00 21:24         0.1Kb
ninlay1r.gif                    13 Nov 00 21:24         0.1Kb
ninlay2.gif                     13 Nov 00 21:24         0.1Kb
ninlay2l.gif                    13 Nov 00 21:24         0.1Kb
ninlay2r.gif                    13 Nov 00 21:24         0.1Kb
ninlay3.gif                     13 Nov 00 21:25         0.1Kb
ninlay3l.gif                    13 Nov 00 21:25         0.1Kb
ninlay3r.gif                    13 Nov 00 21:25         0.1Kb
ninorang.gif                    13 Nov 00 21:25         0.1Kb
ninpegb.gif                     13 Nov 00 21:25         0.1Kb
ninpegt.gif                     13 Nov 00 21:25         0.1Kb
ninred.gif                      13 Nov 00 21:25         0.1Kb
nintopd.gif                     13 Nov 00 21:25         0.2Kb
nintopu.gif                     13 Nov 00 21:25         0.3Kb
ninyello.gif                    13 Nov 00 21:25         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/nintendo/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
ninyello.gif                    13 Nov 00 21:25         0.1Kb
nintopu.gif                     13 Nov 00 21:25         0.3Kb
nintopd.gif                     13 Nov 00 21:25         0.2Kb
ninred.gif                      13 Nov 00 21:25         0.1Kb
ninpegt.gif                     13 Nov 00 21:25         0.1Kb
ninpegb.gif                     13 Nov 00 21:25         0.1Kb
ninorang.gif                    13 Nov 00 21:25         0.1Kb
ninlay3r.gif                    13 Nov 00 21:25         0.1Kb
ninlay3l.gif                    13 Nov 00 21:25         0.1Kb
ninlay3.gif                     13 Nov 00 21:25         0.1Kb
ninlay2r.gif                    13 Nov 00 21:24         0.1Kb
ninlay2l.gif                    13 Nov 00 21:24         0.1Kb
ninlay2.gif                     13 Nov 00 21:24         0.1Kb
ninlay1r.gif                    13 Nov 00 21:24         0.1Kb
ninlay1l.gif                    13 Nov 00 21:24         0.1Kb
ninlay1.gif                     13 Nov 00 21:24         0.1Kb
ninlay0r.gif                    13 Nov 00 21:24         0.1Kb
ninlay0l.gif                    13 Nov 00 21:24         0.1Kb
ninlay0.gif                     13 Nov 00 21:24         0.1Kb
ningreen.gif                    13 Nov 00 21:24         0.1Kb
ninbotu.gif                     13 Nov 00 21:24         0.2Kb
ninbotd.gif                     13 Nov 00 21:24         0.3Kb
ninblue.gif                     13 Nov 00 21:24         0.1Kb
ninblank.gif                    13 Nov 00 21:24         0.1Kb
ninblack.gif                    13 Nov 00 21:24         0.1Kb
ninbck3.gif                     13 Nov 00 21:24         0.1Kb
ninbck2.gif                     13 Nov 00 21:24         0.1Kb
ninbck1.gif                     13 Nov 00 21:24         0.1Kb
ninbck0.gif                     13 Nov 00 21:24         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/orbix/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
orbixa0.gif                      4 Nov 01 19:37         0.4Kb
orbixa0m.gif                     4 Nov 01 19:37         0.5Kb
orbixa1.gif                      4 Nov 01 19:37         0.4Kb
orbixa1m.gif                     4 Nov 01 19:37         0.5Kb
orbixb0.gif                      4 Nov 01 19:37         0.2Kb
orbixb0m.gif                     4 Nov 01 19:37         0.2Kb
orbixb1.gif                      4 Nov 01 19:37         0.2Kb
orbixb1m.gif                     4 Nov 01 19:37         0.2Kb
orbixbck.gif                     4 Nov 01 19:37         0.7Kb
orbixc0.gif                      4 Nov 01 19:37         0.2Kb
orbixc0m.gif                     4 Nov 01 19:37         0.2Kb
orbixc1.gif                      4 Nov 01 19:37         0.2Kb
orbixc1m.gif                     4 Nov 01 19:37         0.2Kb
orbixd0.gif                      4 Nov 01 19:37         0.3Kb
orbixd0m.gif                     4 Nov 01 19:37         0.4Kb
orbixd1.gif                      4 Nov 01 19:37         0.3Kb
orbixd1m.gif                     4 Nov 01 19:37         0.4Kb
orbixe0.gif                      4 Nov 01 19:37         0.3Kb
orbixe0m.gif                     4 Nov 01 19:37         0.4Kb
orbixe1.gif                      4 Nov 01 19:37         0.3Kb
orbixe1m.gif                     4 Nov 01 19:37         0.4Kb
orbixf0.gif                      4 Nov 01 19:37         0.3Kb
orbixf0m.gif                     4 Nov 01 19:37         0.3Kb
orbixf1.gif                      4 Nov 01 19:37         0.3Kb
orbixf1m.gif                     4 Nov 01 19:37         0.3Kb
orbixg0.gif                      4 Nov 01 19:37         0.3Kb
orbixg0m.gif                     4 Nov 01 19:37         0.3Kb
orbixg1.gif                      4 Nov 01 19:37         0.3Kb
orbixg1m.gif                     4 Nov 01 19:37         0.3Kb
orbixh0.gif                      4 Nov 01 19:37         0.3Kb
orbixh0m.gif                     4 Nov 01 19:37         0.4Kb
orbixh1.gif                      4 Nov 01 19:37         0.3Kb
orbixh1m.gif                     4 Nov 01 19:37         0.4Kb
orbixi0.gif                      4 Nov 01 19:37         0.3Kb
orbixi0m.gif                     4 Nov 01 19:37         0.4Kb
orbixi1.gif                      4 Nov 01 19:37         0.3Kb
orbixi1m.gif                     4 Nov 01 19:37         0.4Kb
orbixj0.gif                      4 Nov 01 19:37         0.3Kb
orbixj0m.gif                     4 Nov 01 19:37         0.4Kb
orbixj1.gif                      4 Nov 01 19:37         0.3Kb
orbixj1m.gif                     4 Nov 01 19:37         0.4Kb
orbixk0.gif                      4 Nov 01 19:37         0.3Kb
orbixk0m.gif                     4 Nov 01 19:37         0.4Kb
orbixk1.gif                      4 Nov 01 19:38         0.3Kb
orbixk1m.gif                     4 Nov 01 19:38         0.4Kb
orbixl0.gif                      4 Nov 01 19:38         0.4Kb
orbixl0m.gif                     4 Nov 01 19:38         1.3Kb
orbixl1.gif                      4 Nov 01 19:38         0.4Kb
orbixl1m.gif                     4 Nov 01 19:38         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/orbix/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
orbixl1m.gif                     4 Nov 01 19:38         0.5Kb
orbixl1.gif                      4 Nov 01 19:38         0.4Kb
orbixl0m.gif                     4 Nov 01 19:38         1.3Kb
orbixl0.gif                      4 Nov 01 19:38         0.4Kb
orbixk1m.gif                     4 Nov 01 19:38         0.4Kb
orbixk1.gif                      4 Nov 01 19:38         0.3Kb
orbixk0m.gif                     4 Nov 01 19:37         0.4Kb
orbixk0.gif                      4 Nov 01 19:37         0.3Kb
orbixj1m.gif                     4 Nov 01 19:37         0.4Kb
orbixj1.gif                      4 Nov 01 19:37         0.3Kb
orbixj0m.gif                     4 Nov 01 19:37         0.4Kb
orbixj0.gif                      4 Nov 01 19:37         0.3Kb
orbixi1m.gif                     4 Nov 01 19:37         0.4Kb
orbixi1.gif                      4 Nov 01 19:37         0.3Kb
orbixi0m.gif                     4 Nov 01 19:37         0.4Kb
orbixi0.gif                      4 Nov 01 19:37         0.3Kb
orbixh1m.gif                     4 Nov 01 19:37         0.4Kb
orbixh1.gif                      4 Nov 01 19:37         0.3Kb
orbixh0m.gif                     4 Nov 01 19:37         0.4Kb
orbixh0.gif                      4 Nov 01 19:37         0.3Kb
orbixg1m.gif                     4 Nov 01 19:37         0.3Kb
orbixg1.gif                      4 Nov 01 19:37         0.3Kb
orbixg0m.gif                     4 Nov 01 19:37         0.3Kb
orbixg0.gif                      4 Nov 01 19:37         0.3Kb
orbixf1m.gif                     4 Nov 01 19:37         0.3Kb
orbixf1.gif                      4 Nov 01 19:37         0.3Kb
orbixf0m.gif                     4 Nov 01 19:37         0.3Kb
orbixf0.gif                      4 Nov 01 19:37         0.3Kb
orbixe1m.gif                     4 Nov 01 19:37         0.4Kb
orbixe1.gif                      4 Nov 01 19:37         0.3Kb
orbixe0m.gif                     4 Nov 01 19:37         0.4Kb
orbixe0.gif                      4 Nov 01 19:37         0.3Kb
orbixd1m.gif                     4 Nov 01 19:37         0.4Kb
orbixd1.gif                      4 Nov 01 19:37         0.3Kb
orbixd0m.gif                     4 Nov 01 19:37         0.4Kb
orbixd0.gif                      4 Nov 01 19:37         0.3Kb
orbixc1m.gif                     4 Nov 01 19:37         0.2Kb
orbixc1.gif                      4 Nov 01 19:37         0.2Kb
orbixc0m.gif                     4 Nov 01 19:37         0.2Kb
orbixc0.gif                      4 Nov 01 19:37         0.2Kb
orbixbck.gif                     4 Nov 01 19:37         0.7Kb
orbixb1m.gif                     4 Nov 01 19:37         0.2Kb
orbixb1.gif                      4 Nov 01 19:37         0.2Kb
orbixb0m.gif                     4 Nov 01 19:37         0.2Kb
orbixb0.gif                      4 Nov 01 19:37         0.2Kb
orbixa1m.gif                     4 Nov 01 19:37         0.5Kb
orbixa1.gif                      4 Nov 01 19:37         0.4Kb
orbixa0m.gif                     4 Nov 01 19:37         0.5Kb
orbixa0.gif                      4 Nov 01 19:37         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/orbix/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
orbixb0.gif                      4 Nov 01 19:37         0.2Kb
orbixb1.gif                      4 Nov 01 19:37         0.2Kb
orbixc0.gif                      4 Nov 01 19:37         0.2Kb
orbixc1.gif                      4 Nov 01 19:37         0.2Kb
orbixb0m.gif                     4 Nov 01 19:37         0.2Kb
orbixb1m.gif                     4 Nov 01 19:37         0.2Kb
orbixc0m.gif                     4 Nov 01 19:37         0.2Kb
orbixc1m.gif                     4 Nov 01 19:37         0.2Kb
orbixf0.gif                      4 Nov 01 19:37         0.3Kb
orbixf1.gif                      4 Nov 01 19:37         0.3Kb
orbixg0.gif                      4 Nov 01 19:37         0.3Kb
orbixg1.gif                      4 Nov 01 19:37         0.3Kb
orbixe0.gif                      4 Nov 01 19:37         0.3Kb
orbixe1.gif                      4 Nov 01 19:37         0.3Kb
orbixd0.gif                      4 Nov 01 19:37         0.3Kb
orbixd1.gif                      4 Nov 01 19:37         0.3Kb
orbixi0.gif                      4 Nov 01 19:37         0.3Kb
orbixi1.gif                      4 Nov 01 19:37         0.3Kb
orbixj0.gif                      4 Nov 01 19:37         0.3Kb
orbixj1.gif                      4 Nov 01 19:37         0.3Kb
orbixh0.gif                      4 Nov 01 19:37         0.3Kb
orbixh1.gif                      4 Nov 01 19:37         0.3Kb
orbixk0.gif                      4 Nov 01 19:37         0.3Kb
orbixk1.gif                      4 Nov 01 19:38         0.3Kb
orbixg0m.gif                     4 Nov 01 19:37         0.3Kb
orbixg1m.gif                     4 Nov 01 19:37         0.3Kb
orbixf0m.gif                     4 Nov 01 19:37         0.3Kb
orbixf1m.gif                     4 Nov 01 19:37         0.3Kb
orbixe0m.gif                     4 Nov 01 19:37         0.4Kb
orbixe1m.gif                     4 Nov 01 19:37         0.4Kb
orbixd0m.gif                     4 Nov 01 19:37         0.4Kb
orbixd1m.gif                     4 Nov 01 19:37         0.4Kb
orbixa0.gif                      4 Nov 01 19:37         0.4Kb
orbixa1.gif                      4 Nov 01 19:37         0.4Kb
orbixh0m.gif                     4 Nov 01 19:37         0.4Kb
orbixh1m.gif                     4 Nov 01 19:37         0.4Kb
orbixl0.gif                      4 Nov 01 19:38         0.4Kb
orbixl1.gif                      4 Nov 01 19:38         0.4Kb
orbixk0m.gif                     4 Nov 01 19:37         0.4Kb
orbixk1m.gif                     4 Nov 01 19:38         0.4Kb
orbixj0m.gif                     4 Nov 01 19:37         0.4Kb
orbixj1m.gif                     4 Nov 01 19:37         0.4Kb
orbixi0m.gif                     4 Nov 01 19:37         0.4Kb
orbixi1m.gif                     4 Nov 01 19:37         0.4Kb
orbixa0m.gif                     4 Nov 01 19:37         0.5Kb
orbixa1m.gif                     4 Nov 01 19:37         0.5Kb
orbixl1m.gif                     4 Nov 01 19:38         0.5Kb
orbixbck.gif                     4 Nov 01 19:37         0.7Kb
orbixl0m.gif                     4 Nov 01 19:38         1.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/orbix/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
orbixl0m.gif                     4 Nov 01 19:38         1.3Kb
orbixbck.gif                     4 Nov 01 19:37         0.7Kb
orbixl1m.gif                     4 Nov 01 19:38         0.5Kb
orbixa1m.gif                     4 Nov 01 19:37         0.5Kb
orbixa0m.gif                     4 Nov 01 19:37         0.5Kb
orbixi1m.gif                     4 Nov 01 19:37         0.4Kb
orbixi0m.gif                     4 Nov 01 19:37         0.4Kb
orbixj1m.gif                     4 Nov 01 19:37         0.4Kb
orbixj0m.gif                     4 Nov 01 19:37         0.4Kb
orbixk1m.gif                     4 Nov 01 19:38         0.4Kb
orbixk0m.gif                     4 Nov 01 19:37         0.4Kb
orbixl1.gif                      4 Nov 01 19:38         0.4Kb
orbixl0.gif                      4 Nov 01 19:38         0.4Kb
orbixh1m.gif                     4 Nov 01 19:37         0.4Kb
orbixh0m.gif                     4 Nov 01 19:37         0.4Kb
orbixa1.gif                      4 Nov 01 19:37         0.4Kb
orbixa0.gif                      4 Nov 01 19:37         0.4Kb
orbixd1m.gif                     4 Nov 01 19:37         0.4Kb
orbixd0m.gif                     4 Nov 01 19:37         0.4Kb
orbixe1m.gif                     4 Nov 01 19:37         0.4Kb
orbixe0m.gif                     4 Nov 01 19:37         0.4Kb
orbixf1m.gif                     4 Nov 01 19:37         0.3Kb
orbixf0m.gif                     4 Nov 01 19:37         0.3Kb
orbixg1m.gif                     4 Nov 01 19:37         0.3Kb
orbixg0m.gif                     4 Nov 01 19:37         0.3Kb
orbixk1.gif                      4 Nov 01 19:38         0.3Kb
orbixk0.gif                      4 Nov 01 19:37         0.3Kb
orbixh1.gif                      4 Nov 01 19:37         0.3Kb
orbixh0.gif                      4 Nov 01 19:37         0.3Kb
orbixj1.gif                      4 Nov 01 19:37         0.3Kb
orbixj0.gif                      4 Nov 01 19:37         0.3Kb
orbixi1.gif                      4 Nov 01 19:37         0.3Kb
orbixi0.gif                      4 Nov 01 19:37         0.3Kb
orbixd1.gif                      4 Nov 01 19:37         0.3Kb
orbixd0.gif                      4 Nov 01 19:37         0.3Kb
orbixe1.gif                      4 Nov 01 19:37         0.3Kb
orbixe0.gif                      4 Nov 01 19:37         0.3Kb
orbixg1.gif                      4 Nov 01 19:37         0.3Kb
orbixg0.gif                      4 Nov 01 19:37         0.3Kb
orbixf1.gif                      4 Nov 01 19:37         0.3Kb
orbixf0.gif                      4 Nov 01 19:37         0.3Kb
orbixc1m.gif                     4 Nov 01 19:37         0.2Kb
orbixc0m.gif                     4 Nov 01 19:37         0.2Kb
orbixb1m.gif                     4 Nov 01 19:37         0.2Kb
orbixb0m.gif                     4 Nov 01 19:37         0.2Kb
orbixc1.gif                      4 Nov 01 19:37         0.2Kb
orbixc0.gif                      4 Nov 01 19:37         0.2Kb
orbixb1.gif                      4 Nov 01 19:37         0.2Kb
orbixb0.gif                      4 Nov 01 19:37         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/orbix/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
orbixa0.gif                      4 Nov 01 19:37         0.4Kb
orbixa0m.gif                     4 Nov 01 19:37         0.5Kb
orbixa1.gif                      4 Nov 01 19:37         0.4Kb
orbixa1m.gif                     4 Nov 01 19:37         0.5Kb
orbixb0.gif                      4 Nov 01 19:37         0.2Kb
orbixb0m.gif                     4 Nov 01 19:37         0.2Kb
orbixb1.gif                      4 Nov 01 19:37         0.2Kb
orbixb1m.gif                     4 Nov 01 19:37         0.2Kb
orbixbck.gif                     4 Nov 01 19:37         0.7Kb
orbixc0.gif                      4 Nov 01 19:37         0.2Kb
orbixc0m.gif                     4 Nov 01 19:37         0.2Kb
orbixc1.gif                      4 Nov 01 19:37         0.2Kb
orbixc1m.gif                     4 Nov 01 19:37         0.2Kb
orbixd0.gif                      4 Nov 01 19:37         0.3Kb
orbixd0m.gif                     4 Nov 01 19:37         0.4Kb
orbixd1.gif                      4 Nov 01 19:37         0.3Kb
orbixd1m.gif                     4 Nov 01 19:37         0.4Kb
orbixe0.gif                      4 Nov 01 19:37         0.3Kb
orbixe0m.gif                     4 Nov 01 19:37         0.4Kb
orbixe1.gif                      4 Nov 01 19:37         0.3Kb
orbixe1m.gif                     4 Nov 01 19:37         0.4Kb
orbixf0.gif                      4 Nov 01 19:37         0.3Kb
orbixf0m.gif                     4 Nov 01 19:37         0.3Kb
orbixf1.gif                      4 Nov 01 19:37         0.3Kb
orbixf1m.gif                     4 Nov 01 19:37         0.3Kb
orbixg0.gif                      4 Nov 01 19:37         0.3Kb
orbixg0m.gif                     4 Nov 01 19:37         0.3Kb
orbixg1.gif                      4 Nov 01 19:37         0.3Kb
orbixg1m.gif                     4 Nov 01 19:37         0.3Kb
orbixh0.gif                      4 Nov 01 19:37         0.3Kb
orbixh0m.gif                     4 Nov 01 19:37         0.4Kb
orbixh1.gif                      4 Nov 01 19:37         0.3Kb
orbixh1m.gif                     4 Nov 01 19:37         0.4Kb
orbixi0.gif                      4 Nov 01 19:37         0.3Kb
orbixi0m.gif                     4 Nov 01 19:37         0.4Kb
orbixi1.gif                      4 Nov 01 19:37         0.3Kb
orbixi1m.gif                     4 Nov 01 19:37         0.4Kb
orbixj0.gif                      4 Nov 01 19:37         0.3Kb
orbixj0m.gif                     4 Nov 01 19:37         0.4Kb
orbixj1.gif                      4 Nov 01 19:37         0.3Kb
orbixj1m.gif                     4 Nov 01 19:37         0.4Kb
orbixk0.gif                      4 Nov 01 19:37         0.3Kb
orbixk0m.gif                     4 Nov 01 19:37         0.4Kb
orbixk1.gif                      4 Nov 01 19:38         0.3Kb
orbixk1m.gif                     4 Nov 01 19:38         0.4Kb
orbixl0.gif                      4 Nov 01 19:38         0.4Kb
orbixl0m.gif                     4 Nov 01 19:38         1.3Kb
orbixl1.gif                      4 Nov 01 19:38         0.4Kb
orbixl1m.gif                     4 Nov 01 19:38         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/orbix/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
orbixl1m.gif                     4 Nov 01 19:38         0.5Kb
orbixl1.gif                      4 Nov 01 19:38         0.4Kb
orbixl0m.gif                     4 Nov 01 19:38         1.3Kb
orbixl0.gif                      4 Nov 01 19:38         0.4Kb
orbixk1m.gif                     4 Nov 01 19:38         0.4Kb
orbixk1.gif                      4 Nov 01 19:38         0.3Kb
orbixk0m.gif                     4 Nov 01 19:37         0.4Kb
orbixk0.gif                      4 Nov 01 19:37         0.3Kb
orbixj1m.gif                     4 Nov 01 19:37         0.4Kb
orbixj1.gif                      4 Nov 01 19:37         0.3Kb
orbixj0m.gif                     4 Nov 01 19:37         0.4Kb
orbixj0.gif                      4 Nov 01 19:37         0.3Kb
orbixi1m.gif                     4 Nov 01 19:37         0.4Kb
orbixi1.gif                      4 Nov 01 19:37         0.3Kb
orbixi0m.gif                     4 Nov 01 19:37         0.4Kb
orbixi0.gif                      4 Nov 01 19:37         0.3Kb
orbixh1m.gif                     4 Nov 01 19:37         0.4Kb
orbixh1.gif                      4 Nov 01 19:37         0.3Kb
orbixh0m.gif                     4 Nov 01 19:37         0.4Kb
orbixh0.gif                      4 Nov 01 19:37         0.3Kb
orbixg1m.gif                     4 Nov 01 19:37         0.3Kb
orbixg1.gif                      4 Nov 01 19:37         0.3Kb
orbixg0m.gif                     4 Nov 01 19:37         0.3Kb
orbixg0.gif                      4 Nov 01 19:37         0.3Kb
orbixf1m.gif                     4 Nov 01 19:37         0.3Kb
orbixf1.gif                      4 Nov 01 19:37         0.3Kb
orbixf0m.gif                     4 Nov 01 19:37         0.3Kb
orbixf0.gif                      4 Nov 01 19:37         0.3Kb
orbixe1m.gif                     4 Nov 01 19:37         0.4Kb
orbixe1.gif                      4 Nov 01 19:37         0.3Kb
orbixe0m.gif                     4 Nov 01 19:37         0.4Kb
orbixe0.gif                      4 Nov 01 19:37         0.3Kb
orbixd1m.gif                     4 Nov 01 19:37         0.4Kb
orbixd1.gif                      4 Nov 01 19:37         0.3Kb
orbixd0m.gif                     4 Nov 01 19:37         0.4Kb
orbixd0.gif                      4 Nov 01 19:37         0.3Kb
orbixc1m.gif                     4 Nov 01 19:37         0.2Kb
orbixc1.gif                      4 Nov 01 19:37         0.2Kb
orbixc0m.gif                     4 Nov 01 19:37         0.2Kb
orbixc0.gif                      4 Nov 01 19:37         0.2Kb
orbixbck.gif                     4 Nov 01 19:37         0.7Kb
orbixb1m.gif                     4 Nov 01 19:37         0.2Kb
orbixb1.gif                      4 Nov 01 19:37         0.2Kb
orbixb0m.gif                     4 Nov 01 19:37         0.2Kb
orbixb0.gif                      4 Nov 01 19:37         0.2Kb
orbixa1m.gif                     4 Nov 01 19:37         0.5Kb
orbixa1.gif                      4 Nov 01 19:37         0.4Kb
orbixa0m.gif                     4 Nov 01 19:37         0.5Kb
orbixa0.gif                      4 Nov 01 19:37         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/pento/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
pattern.gif                      6 May 01 12:26         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/pento/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
pattern.gif                      6 May 01 12:26         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/pento/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
pattern.gif                      6 May 01 12:26         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/pento/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
pattern.gif                      6 May 01 12:26         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/port/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
portldd.gif                      4 Nov 01 19:38         0.4Kb
portldu.gif                      4 Nov 01 19:38         0.4Kb
portlud.gif                      4 Nov 01 19:38         0.4Kb
portluu.gif                      4 Nov 01 19:38         0.4Kb
portrdd.gif                      4 Nov 01 19:38         0.4Kb
portrdu.gif                      4 Nov 01 19:38         0.4Kb
portrud.gif                      4 Nov 01 19:38         0.4Kb
portruu.gif                      4 Nov 01 19:38         0.4Kb
portseq1.gif                     4 Nov 01 19:38         0.7Kb
portseq2.gif                     4 Nov 01 19:38         0.7Kb
prtback.gif                      4 Nov 01 19:38         1.9Kb
prtblnk.gif                      4 Nov 01 19:38         0.1Kb
prtboat1.gif                     4 Nov 01 19:38         0.3Kb
prtboat2.gif                     4 Nov 01 19:38         0.3Kb
prtboat3.gif                     4 Nov 01 19:38         0.2Kb
prtboat4.gif                     4 Nov 01 19:38         0.2Kb
prtlogo1.gif                     4 Nov 01 19:38         0.2Kb
prtlogo2.gif                     4 Nov 01 19:38         0.2Kb
prtplng1.gif                     4 Nov 01 19:38         0.5Kb
prtplng2.gif                     4 Nov 01 19:38         0.5Kb
prtplng3.gif                     4 Nov 01 19:38         0.2Kb
prtplng4.gif                     4 Nov 01 19:38         0.2Kb
prtshp1.gif                      4 Nov 01 19:38         0.2Kb
prtshp2.gif                      4 Nov 01 19:38         0.2Kb
prtshp3.gif                      4 Nov 01 19:38         0.2Kb
tcback.gif                       4 Nov 01 19:38         1.9Kb
tcblnk.gif                       4 Nov 01 19:38         0.1Kb
tccrcdl.gif                      4 Nov 01 19:38         0.2Kb
tccrcdr.gif                      4 Nov 01 19:38         0.2Kb
tccrcul.gif                      4 Nov 01 19:38         0.2Kb
tccrcur.gif                      4 Nov 01 19:38         0.2Kb
tcline.gif                       4 Nov 01 19:38         0.2Kb
tclogo1.gif                      4 Nov 01 19:38         0.2Kb
tclogo2.gif                      4 Nov 01 19:38         0.2Kb
tcplng1.gif                      4 Nov 01 19:38         0.3Kb
tcplng2.gif                      4 Nov 01 19:39         0.3Kb
tcplng3.gif                      4 Nov 01 19:39         0.2Kb
tcplng4.gif                      4 Nov 01 19:39         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/port/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
tcplng4.gif                      4 Nov 01 19:39         0.2Kb
tcplng3.gif                      4 Nov 01 19:39         0.2Kb
tcplng2.gif                      4 Nov 01 19:39         0.3Kb
tcplng1.gif                      4 Nov 01 19:38         0.3Kb
tclogo2.gif                      4 Nov 01 19:38         0.2Kb
tclogo1.gif                      4 Nov 01 19:38         0.2Kb
tcline.gif                       4 Nov 01 19:38         0.2Kb
tccrcur.gif                      4 Nov 01 19:38         0.2Kb
tccrcul.gif                      4 Nov 01 19:38         0.2Kb
tccrcdr.gif                      4 Nov 01 19:38         0.2Kb
tccrcdl.gif                      4 Nov 01 19:38         0.2Kb
tcblnk.gif                       4 Nov 01 19:38         0.1Kb
tcback.gif                       4 Nov 01 19:38         1.9Kb
prtshp3.gif                      4 Nov 01 19:38         0.2Kb
prtshp2.gif                      4 Nov 01 19:38         0.2Kb
prtshp1.gif                      4 Nov 01 19:38         0.2Kb
prtplng4.gif                     4 Nov 01 19:38         0.2Kb
prtplng3.gif                     4 Nov 01 19:38         0.2Kb
prtplng2.gif                     4 Nov 01 19:38         0.5Kb
prtplng1.gif                     4 Nov 01 19:38         0.5Kb
prtlogo2.gif                     4 Nov 01 19:38         0.2Kb
prtlogo1.gif                     4 Nov 01 19:38         0.2Kb
prtboat4.gif                     4 Nov 01 19:38         0.2Kb
prtboat3.gif                     4 Nov 01 19:38         0.2Kb
prtboat2.gif                     4 Nov 01 19:38         0.3Kb
prtboat1.gif                     4 Nov 01 19:38         0.3Kb
prtblnk.gif                      4 Nov 01 19:38         0.1Kb
prtback.gif                      4 Nov 01 19:38         1.9Kb
portseq2.gif                     4 Nov 01 19:38         0.7Kb
portseq1.gif                     4 Nov 01 19:38         0.7Kb
portruu.gif                      4 Nov 01 19:38         0.4Kb
portrud.gif                      4 Nov 01 19:38         0.4Kb
portrdu.gif                      4 Nov 01 19:38         0.4Kb
portrdd.gif                      4 Nov 01 19:38         0.4Kb
portluu.gif                      4 Nov 01 19:38         0.4Kb
portlud.gif                      4 Nov 01 19:38         0.4Kb
portldu.gif                      4 Nov 01 19:38         0.4Kb
portldd.gif                      4 Nov 01 19:38         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/port/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
prtblnk.gif                      4 Nov 01 19:38         0.1Kb
tcblnk.gif                       4 Nov 01 19:38         0.1Kb
prtlogo2.gif                     4 Nov 01 19:38         0.2Kb
tclogo2.gif                      4 Nov 01 19:38         0.2Kb
tccrcdr.gif                      4 Nov 01 19:38         0.2Kb
tccrcul.gif                      4 Nov 01 19:38         0.2Kb
tccrcdl.gif                      4 Nov 01 19:38         0.2Kb
tcline.gif                       4 Nov 01 19:38         0.2Kb
tccrcur.gif                      4 Nov 01 19:38         0.2Kb
prtlogo1.gif                     4 Nov 01 19:38         0.2Kb
tclogo1.gif                      4 Nov 01 19:38         0.2Kb
prtplng3.gif                     4 Nov 01 19:38         0.2Kb
prtplng4.gif                     4 Nov 01 19:38         0.2Kb
tcplng3.gif                      4 Nov 01 19:39         0.2Kb
tcplng4.gif                      4 Nov 01 19:39         0.2Kb
prtboat3.gif                     4 Nov 01 19:38         0.2Kb
prtboat4.gif                     4 Nov 01 19:38         0.2Kb
prtshp2.gif                      4 Nov 01 19:38         0.2Kb
prtshp3.gif                      4 Nov 01 19:38         0.2Kb
prtshp1.gif                      4 Nov 01 19:38         0.2Kb
prtboat1.gif                     4 Nov 01 19:38         0.3Kb
prtboat2.gif                     4 Nov 01 19:38         0.3Kb
tcplng1.gif                      4 Nov 01 19:38         0.3Kb
tcplng2.gif                      4 Nov 01 19:39         0.3Kb
portrdd.gif                      4 Nov 01 19:38         0.4Kb
portrdu.gif                      4 Nov 01 19:38         0.4Kb
portruu.gif                      4 Nov 01 19:38         0.4Kb
portrud.gif                      4 Nov 01 19:38         0.4Kb
portldd.gif                      4 Nov 01 19:38         0.4Kb
portldu.gif                      4 Nov 01 19:38         0.4Kb
portlud.gif                      4 Nov 01 19:38         0.4Kb
portluu.gif                      4 Nov 01 19:38         0.4Kb
prtplng1.gif                     4 Nov 01 19:38         0.5Kb
prtplng2.gif                     4 Nov 01 19:38         0.5Kb
portseq1.gif                     4 Nov 01 19:38         0.7Kb
portseq2.gif                     4 Nov 01 19:38         0.7Kb
tcback.gif                       4 Nov 01 19:38         1.9Kb
prtback.gif                      4 Nov 01 19:38         1.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/port/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
portldd.gif                      4 Nov 01 19:38         0.4Kb
portldu.gif                      4 Nov 01 19:38         0.4Kb
portlud.gif                      4 Nov 01 19:38         0.4Kb
portluu.gif                      4 Nov 01 19:38         0.4Kb
portrdd.gif                      4 Nov 01 19:38         0.4Kb
portrdu.gif                      4 Nov 01 19:38         0.4Kb
portrud.gif                      4 Nov 01 19:38         0.4Kb
portruu.gif                      4 Nov 01 19:38         0.4Kb
portseq1.gif                     4 Nov 01 19:38         0.7Kb
portseq2.gif                     4 Nov 01 19:38         0.7Kb
prtback.gif                      4 Nov 01 19:38         1.9Kb
prtblnk.gif                      4 Nov 01 19:38         0.1Kb
prtboat1.gif                     4 Nov 01 19:38         0.3Kb
prtboat2.gif                     4 Nov 01 19:38         0.3Kb
prtboat3.gif                     4 Nov 01 19:38         0.2Kb
prtboat4.gif                     4 Nov 01 19:38         0.2Kb
prtlogo1.gif                     4 Nov 01 19:38         0.2Kb
prtlogo2.gif                     4 Nov 01 19:38         0.2Kb
prtplng1.gif                     4 Nov 01 19:38         0.5Kb
prtplng2.gif                     4 Nov 01 19:38         0.5Kb
prtplng3.gif                     4 Nov 01 19:38         0.2Kb
prtplng4.gif                     4 Nov 01 19:38         0.2Kb
prtshp1.gif                      4 Nov 01 19:38         0.2Kb
prtshp2.gif                      4 Nov 01 19:38         0.2Kb
prtshp3.gif                      4 Nov 01 19:38         0.2Kb
tcback.gif                       4 Nov 01 19:38         1.9Kb
tcblnk.gif                       4 Nov 01 19:38         0.1Kb
tccrcdl.gif                      4 Nov 01 19:38         0.2Kb
tccrcdr.gif                      4 Nov 01 19:38         0.2Kb
tccrcul.gif                      4 Nov 01 19:38         0.2Kb
tccrcur.gif                      4 Nov 01 19:38         0.2Kb
tcline.gif                       4 Nov 01 19:38         0.2Kb
tclogo1.gif                      4 Nov 01 19:38         0.2Kb
tclogo2.gif                      4 Nov 01 19:38         0.2Kb
tcplng1.gif                      4 Nov 01 19:38         0.3Kb
tcplng2.gif                      4 Nov 01 19:39         0.3Kb
tcplng3.gif                      4 Nov 01 19:39         0.2Kb
tcplng4.gif                      4 Nov 01 19:39         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/preview/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
alexstar.gif                     1 Jan 01 19:25         2.7Kb
backspin.gif                     6 May 01 12:27         3.7Kb
bandpyra.gif                     1 Jan 01 19:25         1.3Kb
beachbll.gif                     1 Jan 01 19:25         3.4Kb
bicube.gif                       1 Jan 01 19:25         1.9Kb
brain.gif                        1 Jan 01 19:26         2.4Kb
brainbll.gif                     1 Jan 01 19:26         1.7Kb
chinring.gif                     1 Jan 01 19:26         1.9Kb
cube2.gif                        1 Jan 01 19:26         2.4Kb
cube3.gif                        1 Jan 01 19:26         2.2Kb
cube5.gif                        1 Jan 01 19:26         1.7Kb
diamond.gif                      1 Jan 01 19:26         2.4Kb
disky.gif                        1 Jan 01 19:26         2.9Kb
dogic.gif                        1 Jan 01 19:26         2.9Kb
empty.gif                        1 Jan 01 19:26         0.0Kb
equator.gif                     30 Jul 01 21:46         3.8Kb
equator2.gif                     1 Jan 01 19:26         2.1Kb
fifteen.gif                      1 Jan 01 19:26         0.5Kb
gripple.gif                      4 Nov 01 19:39         3.8Kb
halpern.gif                      1 Jan 01 19:26         2.3Kb
hanoi.gif                        1 Jan 01 19:26         0.5Kb
impossib.gif                     1 Jan 01 19:26         2.2Kb
insanity.gif                    30 Jul 01 21:46         3.1Kb
it.gif                           1 Jan 01 19:26         2.4Kb
ivory.gif                        1 Jan 01 19:26         2.8Kb
lo2000b.gif                      1 Jan 01 19:26         2.3Kb
magiccrf.gif                     1 Jan 01 19:26         1.8Kb
massage.gif                      1 Jan 01 19:26         3.3Kb
master.gif                       1 Jan 01 19:26         2.9Kb
megaminx.gif                     1 Jan 01 19:26         2.5Kb
misslink.gif                     1 Jan 01 19:27         1.8Kb
mozaika.gif                      1 Jan 01 19:27         2.7Kb
nineball.gif                     1 Jan 01 19:27         3.2Kb
nintendo.gif                     1 Jan 01 19:27         2.7Kb
octagon.gif                      1 Jan 01 19:27         2.0Kb
octahedr.gif                     1 Jan 01 19:27         3.2Kb
orb.gif                          1 Jan 01 19:27         3.4Kb
orbix.gif                        1 Jan 01 19:27         2.0Kb
port.gif                         1 Jan 01 19:27         1.4Kb
puck.gif                         1 Jan 01 19:27         2.0Kb
pyraminx.gif                     1 Jan 01 19:27         2.3Kb
pyramorf.gif                     1 Jan 01 19:27         2.5Kb
revenge.gif                      1 Jan 01 19:27         2.4Kb
roundy.gif                       1 Jan 01 19:27         2.4Kb
rubclock.gif                     1 Jan 01 19:27         2.6Kb
rubdice.gif                      1 Jan 01 19:27         1.7Kb
rubdom.gif                       1 Jan 01 19:27         2.7Kb
rubfift.gif                      1 Jan 01 19:27         1.8Kb
rubmag1.gif                      1 Jan 01 19:28         3.4Kb
rubmag2.gif                      1 Jan 01 19:28         3.4Kb
rubmaze.gif                      1 Jan 01 19:28         1.3Kb
rubring.gif                      1 Jan 01 19:28         3.4Kb
saturn.gif                       4 Nov 01 19:40         2.4Kb
siamese.gif                      1 Jan 01 19:28         2.7Kb
skewb.gif                        1 Jan 01 19:28         2.1Kb
spinout.gif                      1 Jan 01 19:28         1.9Kb
square1.gif                      1 Jan 01 19:28         2.4Kb
tantrix.gif                      1 Jan 01 19:28         0.6Kb
tetramin.gif                     1 Jan 01 19:28         3.5Kb
topspin.gif                      1 Jan 01 19:29         2.9Kb
tower.gif                        1 Jan 01 19:29         3.1Kb
triamid2.gif                     1 Jan 01 19:29         2.3Kb
triple.gif                       1 Jan 01 19:29         1.7Kb
turnpush.gif                     1 Jan 01 19:29         1.8Kb
turnstil.gif                     1 Jan 01 19:29         3.0Kb
ufo.gif                          4 Nov 01 19:41         2.5Kb
ultimat2.gif                     1 Jan 01 19:29         2.2Kb
whippit.gif                      1 Jan 01 19:29         1.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/preview/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
whippit.gif                      1 Jan 01 19:29         1.2Kb
ultimat2.gif                     1 Jan 01 19:29         2.2Kb
ufo.gif                          4 Nov 01 19:41         2.5Kb
turnstil.gif                     1 Jan 01 19:29         3.0Kb
turnpush.gif                     1 Jan 01 19:29         1.8Kb
triple.gif                       1 Jan 01 19:29         1.7Kb
triamid2.gif                     1 Jan 01 19:29         2.3Kb
tower.gif                        1 Jan 01 19:29         3.1Kb
topspin.gif                      1 Jan 01 19:29         2.9Kb
tetramin.gif                     1 Jan 01 19:28         3.5Kb
tantrix.gif                      1 Jan 01 19:28         0.6Kb
square1.gif                      1 Jan 01 19:28         2.4Kb
spinout.gif                      1 Jan 01 19:28         1.9Kb
skewb.gif                        1 Jan 01 19:28         2.1Kb
siamese.gif                      1 Jan 01 19:28         2.7Kb
saturn.gif                       4 Nov 01 19:40         2.4Kb
rubring.gif                      1 Jan 01 19:28         3.4Kb
rubmaze.gif                      1 Jan 01 19:28         1.3Kb
rubmag2.gif                      1 Jan 01 19:28         3.4Kb
rubmag1.gif                      1 Jan 01 19:28         3.4Kb
rubfift.gif                      1 Jan 01 19:27         1.8Kb
rubdom.gif                       1 Jan 01 19:27         2.7Kb
rubdice.gif                      1 Jan 01 19:27         1.7Kb
rubclock.gif                     1 Jan 01 19:27         2.6Kb
roundy.gif                       1 Jan 01 19:27         2.4Kb
revenge.gif                      1 Jan 01 19:27         2.4Kb
pyramorf.gif                     1 Jan 01 19:27         2.5Kb
pyraminx.gif                     1 Jan 01 19:27         2.3Kb
puck.gif                         1 Jan 01 19:27         2.0Kb
port.gif                         1 Jan 01 19:27         1.4Kb
orbix.gif                        1 Jan 01 19:27         2.0Kb
orb.gif                          1 Jan 01 19:27         3.4Kb
octahedr.gif                     1 Jan 01 19:27         3.2Kb
octagon.gif                      1 Jan 01 19:27         2.0Kb
nintendo.gif                     1 Jan 01 19:27         2.7Kb
nineball.gif                     1 Jan 01 19:27         3.2Kb
mozaika.gif                      1 Jan 01 19:27         2.7Kb
misslink.gif                     1 Jan 01 19:27         1.8Kb
megaminx.gif                     1 Jan 01 19:26         2.5Kb
master.gif                       1 Jan 01 19:26         2.9Kb
massage.gif                      1 Jan 01 19:26         3.3Kb
magiccrf.gif                     1 Jan 01 19:26         1.8Kb
lo2000b.gif                      1 Jan 01 19:26         2.3Kb
ivory.gif                        1 Jan 01 19:26         2.8Kb
it.gif                           1 Jan 01 19:26         2.4Kb
insanity.gif                    30 Jul 01 21:46         3.1Kb
impossib.gif                     1 Jan 01 19:26         2.2Kb
hanoi.gif                        1 Jan 01 19:26         0.5Kb
halpern.gif                      1 Jan 01 19:26         2.3Kb
gripple.gif                      4 Nov 01 19:39         3.8Kb
fifteen.gif                      1 Jan 01 19:26         0.5Kb
equator2.gif                     1 Jan 01 19:26         2.1Kb
equator.gif                     30 Jul 01 21:46         3.8Kb
empty.gif                        1 Jan 01 19:26         0.0Kb
dogic.gif                        1 Jan 01 19:26         2.9Kb
disky.gif                        1 Jan 01 19:26         2.9Kb
diamond.gif                      1 Jan 01 19:26         2.4Kb
cube5.gif                        1 Jan 01 19:26         1.7Kb
cube3.gif                        1 Jan 01 19:26         2.2Kb
cube2.gif                        1 Jan 01 19:26         2.4Kb
chinring.gif                     1 Jan 01 19:26         1.9Kb
brainbll.gif                     1 Jan 01 19:26         1.7Kb
brain.gif                        1 Jan 01 19:26         2.4Kb
bicube.gif                       1 Jan 01 19:25         1.9Kb
beachbll.gif                     1 Jan 01 19:25         3.4Kb
bandpyra.gif                     1 Jan 01 19:25         1.3Kb
backspin.gif                     6 May 01 12:27         3.7Kb
alexstar.gif                     1 Jan 01 19:25         2.7Kb
_____________________________________________________________


Index of /jaap/puzzles/images/preview/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
empty.gif                        1 Jan 01 19:26         0.0Kb
hanoi.gif                        1 Jan 01 19:26         0.5Kb
fifteen.gif                      1 Jan 01 19:26         0.5Kb
tantrix.gif                      1 Jan 01 19:28         0.6Kb
whippit.gif                      1 Jan 01 19:29         1.2Kb
rubmaze.gif                      1 Jan 01 19:28         1.3Kb
bandpyra.gif                     1 Jan 01 19:25         1.3Kb
port.gif                         1 Jan 01 19:27         1.4Kb
brainbll.gif                     1 Jan 01 19:26         1.7Kb
triple.gif                       1 Jan 01 19:29         1.7Kb
rubdice.gif                      1 Jan 01 19:27         1.7Kb
cube5.gif                        1 Jan 01 19:26         1.7Kb
turnpush.gif                     1 Jan 01 19:29         1.8Kb
misslink.gif                     1 Jan 01 19:27         1.8Kb
magiccrf.gif                     1 Jan 01 19:26         1.8Kb
rubfift.gif                      1 Jan 01 19:27         1.8Kb
spinout.gif                      1 Jan 01 19:28         1.9Kb
bicube.gif                       1 Jan 01 19:25         1.9Kb
chinring.gif                     1 Jan 01 19:26         1.9Kb
orbix.gif                        1 Jan 01 19:27         2.0Kb
puck.gif                         1 Jan 01 19:27         2.0Kb
octagon.gif                      1 Jan 01 19:27         2.0Kb
equator2.gif                     1 Jan 01 19:26         2.1Kb
skewb.gif                        1 Jan 01 19:28         2.1Kb
impossib.gif                     1 Jan 01 19:26         2.2Kb
cube3.gif                        1 Jan 01 19:26         2.2Kb
ultimat2.gif                     1 Jan 01 19:29         2.2Kb
lo2000b.gif                      1 Jan 01 19:26         2.3Kb
triamid2.gif                     1 Jan 01 19:29         2.3Kb
pyraminx.gif                     1 Jan 01 19:27         2.3Kb
halpern.gif                      1 Jan 01 19:26         2.3Kb
diamond.gif                      1 Jan 01 19:26         2.4Kb
it.gif                           1 Jan 01 19:26         2.4Kb
cube2.gif                        1 Jan 01 19:26         2.4Kb
revenge.gif                      1 Jan 01 19:27         2.4Kb
brain.gif                        1 Jan 01 19:26         2.4Kb
square1.gif                      1 Jan 01 19:28         2.4Kb
roundy.gif                       1 Jan 01 19:27         2.4Kb
saturn.gif                       4 Nov 01 19:40         2.4Kb
pyramorf.gif                     1 Jan 01 19:27         2.5Kb
megaminx.gif                     1 Jan 01 19:26         2.5Kb
ufo.gif                          4 Nov 01 19:41         2.5Kb
rubclock.gif                     1 Jan 01 19:27         2.6Kb
rubdom.gif                       1 Jan 01 19:27         2.7Kb
siamese.gif                      1 Jan 01 19:28         2.7Kb
mozaika.gif                      1 Jan 01 19:27         2.7Kb
nintendo.gif                     1 Jan 01 19:27         2.7Kb
alexstar.gif                     1 Jan 01 19:25         2.7Kb
ivory.gif                        1 Jan 01 19:26         2.8Kb
master.gif                       1 Jan 01 19:26         2.9Kb
disky.gif                        1 Jan 01 19:26         2.9Kb
topspin.gif                      1 Jan 01 19:29         2.9Kb
dogic.gif                        1 Jan 01 19:26         2.9Kb
turnstil.gif                     1 Jan 01 19:29         3.0Kb
insanity.gif                    30 Jul 01 21:46         3.1Kb
tower.gif                        1 Jan 01 19:29         3.1Kb
nineball.gif                     1 Jan 01 19:27         3.2Kb
octahedr.gif                     1 Jan 01 19:27         3.2Kb
massage.gif                      1 Jan 01 19:26         3.3Kb
orb.gif                          1 Jan 01 19:27         3.4Kb
rubmag2.gif                      1 Jan 01 19:28         3.4Kb
beachbll.gif                     1 Jan 01 19:25         3.4Kb
rubmag1.gif                      1 Jan 01 19:28         3.4Kb
rubring.gif                      1 Jan 01 19:28         3.4Kb
tetramin.gif                     1 Jan 01 19:28         3.5Kb
backspin.gif                     6 May 01 12:27         3.7Kb
gripple.gif                      4 Nov 01 19:39         3.8Kb
equator.gif                     30 Jul 01 21:46         3.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/preview/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
equator.gif                     30 Jul 01 21:46         3.8Kb
gripple.gif                      4 Nov 01 19:39         3.8Kb
backspin.gif                     6 May 01 12:27         3.7Kb
tetramin.gif                     1 Jan 01 19:28         3.5Kb
rubring.gif                      1 Jan 01 19:28         3.4Kb
rubmag1.gif                      1 Jan 01 19:28         3.4Kb
beachbll.gif                     1 Jan 01 19:25         3.4Kb
rubmag2.gif                      1 Jan 01 19:28         3.4Kb
orb.gif                          1 Jan 01 19:27         3.4Kb
massage.gif                      1 Jan 01 19:26         3.3Kb
octahedr.gif                     1 Jan 01 19:27         3.2Kb
nineball.gif                     1 Jan 01 19:27         3.2Kb
tower.gif                        1 Jan 01 19:29         3.1Kb
insanity.gif                    30 Jul 01 21:46         3.1Kb
turnstil.gif                     1 Jan 01 19:29         3.0Kb
dogic.gif                        1 Jan 01 19:26         2.9Kb
topspin.gif                      1 Jan 01 19:29         2.9Kb
disky.gif                        1 Jan 01 19:26         2.9Kb
master.gif                       1 Jan 01 19:26         2.9Kb
ivory.gif                        1 Jan 01 19:26         2.8Kb
alexstar.gif                     1 Jan 01 19:25         2.7Kb
nintendo.gif                     1 Jan 01 19:27         2.7Kb
mozaika.gif                      1 Jan 01 19:27         2.7Kb
siamese.gif                      1 Jan 01 19:28         2.7Kb
rubdom.gif                       1 Jan 01 19:27         2.7Kb
rubclock.gif                     1 Jan 01 19:27         2.6Kb
ufo.gif                          4 Nov 01 19:41         2.5Kb
megaminx.gif                     1 Jan 01 19:26         2.5Kb
pyramorf.gif                     1 Jan 01 19:27         2.5Kb
saturn.gif                       4 Nov 01 19:40         2.4Kb
roundy.gif                       1 Jan 01 19:27         2.4Kb
square1.gif                      1 Jan 01 19:28         2.4Kb
brain.gif                        1 Jan 01 19:26         2.4Kb
revenge.gif                      1 Jan 01 19:27         2.4Kb
cube2.gif                        1 Jan 01 19:26         2.4Kb
it.gif                           1 Jan 01 19:26         2.4Kb
diamond.gif                      1 Jan 01 19:26         2.4Kb
halpern.gif                      1 Jan 01 19:26         2.3Kb
pyraminx.gif                     1 Jan 01 19:27         2.3Kb
triamid2.gif                     1 Jan 01 19:29         2.3Kb
lo2000b.gif                      1 Jan 01 19:26         2.3Kb
ultimat2.gif                     1 Jan 01 19:29         2.2Kb
cube3.gif                        1 Jan 01 19:26         2.2Kb
impossib.gif                     1 Jan 01 19:26         2.2Kb
skewb.gif                        1 Jan 01 19:28         2.1Kb
equator2.gif                     1 Jan 01 19:26         2.1Kb
octagon.gif                      1 Jan 01 19:27         2.0Kb
puck.gif                         1 Jan 01 19:27         2.0Kb
orbix.gif                        1 Jan 01 19:27         2.0Kb
chinring.gif                     1 Jan 01 19:26         1.9Kb
bicube.gif                       1 Jan 01 19:25         1.9Kb
spinout.gif                      1 Jan 01 19:28         1.9Kb
rubfift.gif                      1 Jan 01 19:27         1.8Kb
magiccrf.gif                     1 Jan 01 19:26         1.8Kb
misslink.gif                     1 Jan 01 19:27         1.8Kb
turnpush.gif                     1 Jan 01 19:29         1.8Kb
cube5.gif                        1 Jan 01 19:26         1.7Kb
rubdice.gif                      1 Jan 01 19:27         1.7Kb
triple.gif                       1 Jan 01 19:29         1.7Kb
brainbll.gif                     1 Jan 01 19:26         1.7Kb
port.gif                         1 Jan 01 19:27         1.4Kb
bandpyra.gif                     1 Jan 01 19:25         1.3Kb
rubmaze.gif                      1 Jan 01 19:28         1.3Kb
whippit.gif                      1 Jan 01 19:29         1.2Kb
tantrix.gif                      1 Jan 01 19:28         0.6Kb
fifteen.gif                      1 Jan 01 19:26         0.5Kb
hanoi.gif                        1 Jan 01 19:26         0.5Kb
empty.gif                        1 Jan 01 19:26         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/preview/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
alexstar.gif                     1 Jan 01 19:25         2.7Kb
bandpyra.gif                     1 Jan 01 19:25         1.3Kb
beachbll.gif                     1 Jan 01 19:25         3.4Kb
bicube.gif                       1 Jan 01 19:25         1.9Kb
brain.gif                        1 Jan 01 19:26         2.4Kb
brainbll.gif                     1 Jan 01 19:26         1.7Kb
chinring.gif                     1 Jan 01 19:26         1.9Kb
cube2.gif                        1 Jan 01 19:26         2.4Kb
cube3.gif                        1 Jan 01 19:26         2.2Kb
cube5.gif                        1 Jan 01 19:26         1.7Kb
diamond.gif                      1 Jan 01 19:26         2.4Kb
disky.gif                        1 Jan 01 19:26         2.9Kb
dogic.gif                        1 Jan 01 19:26         2.9Kb
empty.gif                        1 Jan 01 19:26         0.0Kb
equator2.gif                     1 Jan 01 19:26         2.1Kb
fifteen.gif                      1 Jan 01 19:26         0.5Kb
halpern.gif                      1 Jan 01 19:26         2.3Kb
hanoi.gif                        1 Jan 01 19:26         0.5Kb
impossib.gif                     1 Jan 01 19:26         2.2Kb
it.gif                           1 Jan 01 19:26         2.4Kb
ivory.gif                        1 Jan 01 19:26         2.8Kb
lo2000b.gif                      1 Jan 01 19:26         2.3Kb
magiccrf.gif                     1 Jan 01 19:26         1.8Kb
massage.gif                      1 Jan 01 19:26         3.3Kb
master.gif                       1 Jan 01 19:26         2.9Kb
megaminx.gif                     1 Jan 01 19:26         2.5Kb
misslink.gif                     1 Jan 01 19:27         1.8Kb
mozaika.gif                      1 Jan 01 19:27         2.7Kb
nineball.gif                     1 Jan 01 19:27         3.2Kb
nintendo.gif                     1 Jan 01 19:27         2.7Kb
octagon.gif                      1 Jan 01 19:27         2.0Kb
octahedr.gif                     1 Jan 01 19:27         3.2Kb
orb.gif                          1 Jan 01 19:27         3.4Kb
orbix.gif                        1 Jan 01 19:27         2.0Kb
port.gif                         1 Jan 01 19:27         1.4Kb
puck.gif                         1 Jan 01 19:27         2.0Kb
pyraminx.gif                     1 Jan 01 19:27         2.3Kb
pyramorf.gif                     1 Jan 01 19:27         2.5Kb
revenge.gif                      1 Jan 01 19:27         2.4Kb
roundy.gif                       1 Jan 01 19:27         2.4Kb
rubclock.gif                     1 Jan 01 19:27         2.6Kb
rubdice.gif                      1 Jan 01 19:27         1.7Kb
rubdom.gif                       1 Jan 01 19:27         2.7Kb
rubfift.gif                      1 Jan 01 19:27         1.8Kb
rubmag1.gif                      1 Jan 01 19:28         3.4Kb
rubmag2.gif                      1 Jan 01 19:28         3.4Kb
rubmaze.gif                      1 Jan 01 19:28         1.3Kb
rubring.gif                      1 Jan 01 19:28         3.4Kb
siamese.gif                      1 Jan 01 19:28         2.7Kb
skewb.gif                        1 Jan 01 19:28         2.1Kb
spinout.gif                      1 Jan 01 19:28         1.9Kb
square1.gif                      1 Jan 01 19:28         2.4Kb
tantrix.gif                      1 Jan 01 19:28         0.6Kb
tetramin.gif                     1 Jan 01 19:28         3.5Kb
topspin.gif                      1 Jan 01 19:29         2.9Kb
tower.gif                        1 Jan 01 19:29         3.1Kb
triamid2.gif                     1 Jan 01 19:29         2.3Kb
triple.gif                       1 Jan 01 19:29         1.7Kb
turnpush.gif                     1 Jan 01 19:29         1.8Kb
turnstil.gif                     1 Jan 01 19:29         3.0Kb
ultimat2.gif                     1 Jan 01 19:29         2.2Kb
whippit.gif                      1 Jan 01 19:29         1.2Kb
backspin.gif                     6 May 01 12:27         3.7Kb
equator.gif                     30 Jul 01 21:46         3.8Kb
insanity.gif                    30 Jul 01 21:46         3.1Kb
gripple.gif                      4 Nov 01 19:39         3.8Kb
saturn.gif                       4 Nov 01 19:40         2.4Kb
ufo.gif                          4 Nov 01 19:41         2.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/preview/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
ufo.gif                          4 Nov 01 19:41         2.5Kb
saturn.gif                       4 Nov 01 19:40         2.4Kb
gripple.gif                      4 Nov 01 19:39         3.8Kb
insanity.gif                    30 Jul 01 21:46         3.1Kb
equator.gif                     30 Jul 01 21:46         3.8Kb
backspin.gif                     6 May 01 12:27         3.7Kb
whippit.gif                      1 Jan 01 19:29         1.2Kb
ultimat2.gif                     1 Jan 01 19:29         2.2Kb
turnstil.gif                     1 Jan 01 19:29         3.0Kb
turnpush.gif                     1 Jan 01 19:29         1.8Kb
triple.gif                       1 Jan 01 19:29         1.7Kb
triamid2.gif                     1 Jan 01 19:29         2.3Kb
tower.gif                        1 Jan 01 19:29         3.1Kb
topspin.gif                      1 Jan 01 19:29         2.9Kb
tetramin.gif                     1 Jan 01 19:28         3.5Kb
tantrix.gif                      1 Jan 01 19:28         0.6Kb
square1.gif                      1 Jan 01 19:28         2.4Kb
spinout.gif                      1 Jan 01 19:28         1.9Kb
skewb.gif                        1 Jan 01 19:28         2.1Kb
siamese.gif                      1 Jan 01 19:28         2.7Kb
rubring.gif                      1 Jan 01 19:28         3.4Kb
rubmaze.gif                      1 Jan 01 19:28         1.3Kb
rubmag2.gif                      1 Jan 01 19:28         3.4Kb
rubmag1.gif                      1 Jan 01 19:28         3.4Kb
rubfift.gif                      1 Jan 01 19:27         1.8Kb
rubdom.gif                       1 Jan 01 19:27         2.7Kb
rubdice.gif                      1 Jan 01 19:27         1.7Kb
rubclock.gif                     1 Jan 01 19:27         2.6Kb
roundy.gif                       1 Jan 01 19:27         2.4Kb
revenge.gif                      1 Jan 01 19:27         2.4Kb
pyramorf.gif                     1 Jan 01 19:27         2.5Kb
pyraminx.gif                     1 Jan 01 19:27         2.3Kb
puck.gif                         1 Jan 01 19:27         2.0Kb
port.gif                         1 Jan 01 19:27         1.4Kb
orbix.gif                        1 Jan 01 19:27         2.0Kb
orb.gif                          1 Jan 01 19:27         3.4Kb
octahedr.gif                     1 Jan 01 19:27         3.2Kb
octagon.gif                      1 Jan 01 19:27         2.0Kb
nintendo.gif                     1 Jan 01 19:27         2.7Kb
nineball.gif                     1 Jan 01 19:27         3.2Kb
mozaika.gif                      1 Jan 01 19:27         2.7Kb
misslink.gif                     1 Jan 01 19:27         1.8Kb
megaminx.gif                     1 Jan 01 19:26         2.5Kb
master.gif                       1 Jan 01 19:26         2.9Kb
massage.gif                      1 Jan 01 19:26         3.3Kb
magiccrf.gif                     1 Jan 01 19:26         1.8Kb
lo2000b.gif                      1 Jan 01 19:26         2.3Kb
ivory.gif                        1 Jan 01 19:26         2.8Kb
it.gif                           1 Jan 01 19:26         2.4Kb
impossib.gif                     1 Jan 01 19:26         2.2Kb
hanoi.gif                        1 Jan 01 19:26         0.5Kb
halpern.gif                      1 Jan 01 19:26         2.3Kb
fifteen.gif                      1 Jan 01 19:26         0.5Kb
equator2.gif                     1 Jan 01 19:26         2.1Kb
empty.gif                        1 Jan 01 19:26         0.0Kb
dogic.gif                        1 Jan 01 19:26         2.9Kb
disky.gif                        1 Jan 01 19:26         2.9Kb
diamond.gif                      1 Jan 01 19:26         2.4Kb
cube5.gif                        1 Jan 01 19:26         1.7Kb
cube3.gif                        1 Jan 01 19:26         2.2Kb
cube2.gif                        1 Jan 01 19:26         2.4Kb
chinring.gif                     1 Jan 01 19:26         1.9Kb
brainbll.gif                     1 Jan 01 19:26         1.7Kb
brain.gif                        1 Jan 01 19:26         2.4Kb
bicube.gif                       1 Jan 01 19:25         1.9Kb
beachbll.gif                     1 Jan 01 19:25         3.4Kb
bandpyra.gif                     1 Jan 01 19:25         1.3Kb
alexstar.gif                     1 Jan 01 19:25         2.7Kb
_____________________________________________________________


Index of /jaap/puzzles/images/rubring/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
back.gif                         6 May 01 12:27         1.8Kb
blank.gif                        6 May 01 12:27         0.1Kb
blue.gif                         6 May 01 12:27         0.1Kb
red.gif                          6 May 01 12:27         0.1Kb
yellow.gif                       6 May 01 12:27         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/rubring/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
yellow.gif                       6 May 01 12:27         0.1Kb
red.gif                          6 May 01 12:27         0.1Kb
blue.gif                         6 May 01 12:27         0.1Kb
blank.gif                        6 May 01 12:27         0.1Kb
back.gif                         6 May 01 12:27         1.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/rubring/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
blank.gif                        6 May 01 12:27         0.1Kb
blue.gif                         6 May 01 12:27         0.1Kb
red.gif                          6 May 01 12:27         0.1Kb
yellow.gif                       6 May 01 12:27         0.1Kb
back.gif                         6 May 01 12:27         1.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/rubring/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
back.gif                         6 May 01 12:27         1.8Kb
blank.gif                        6 May 01 12:27         0.1Kb
blue.gif                         6 May 01 12:27         0.1Kb
red.gif                          6 May 01 12:27         0.1Kb
yellow.gif                       6 May 01 12:27         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/saturn/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
sat1.gif                         4 Nov 01 19:41         0.1Kb
sat2.gif                         4 Nov 01 19:41         0.1Kb
sat3.gif                         4 Nov 01 19:41         0.1Kb
sat4.gif                         4 Nov 01 19:41         0.1Kb
sat5.gif                         4 Nov 01 19:41         0.1Kb
sat6.gif                         4 Nov 01 19:41         0.1Kb
sat7.gif                         4 Nov 01 19:41         0.1Kb
sat8.gif                         4 Nov 01 19:41         0.2Kb
satback.gif                      4 Nov 01 19:41         2.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/saturn/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
satback.gif                      4 Nov 01 19:41         2.8Kb
sat8.gif                         4 Nov 01 19:41         0.2Kb
sat7.gif                         4 Nov 01 19:41         0.1Kb
sat6.gif                         4 Nov 01 19:41         0.1Kb
sat5.gif                         4 Nov 01 19:41         0.1Kb
sat4.gif                         4 Nov 01 19:41         0.1Kb
sat3.gif                         4 Nov 01 19:41         0.1Kb
sat2.gif                         4 Nov 01 19:41         0.1Kb
sat1.gif                         4 Nov 01 19:41         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/saturn/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
sat1.gif                         4 Nov 01 19:41         0.1Kb
sat7.gif                         4 Nov 01 19:41         0.1Kb
sat5.gif                         4 Nov 01 19:41         0.1Kb
sat2.gif                         4 Nov 01 19:41         0.1Kb
sat4.gif                         4 Nov 01 19:41         0.1Kb
sat3.gif                         4 Nov 01 19:41         0.1Kb
sat6.gif                         4 Nov 01 19:41         0.1Kb
sat8.gif                         4 Nov 01 19:41         0.2Kb
satback.gif                      4 Nov 01 19:41         2.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/saturn/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
satback.gif                      4 Nov 01 19:41         2.8Kb
sat8.gif                         4 Nov 01 19:41         0.2Kb
sat6.gif                         4 Nov 01 19:41         0.1Kb
sat3.gif                         4 Nov 01 19:41         0.1Kb
sat4.gif                         4 Nov 01 19:41         0.1Kb
sat2.gif                         4 Nov 01 19:41         0.1Kb
sat5.gif                         4 Nov 01 19:41         0.1Kb
sat7.gif                         4 Nov 01 19:41         0.1Kb
sat1.gif                         4 Nov 01 19:41         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/saturn/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
sat1.gif                         4 Nov 01 19:41         0.1Kb
sat2.gif                         4 Nov 01 19:41         0.1Kb
sat3.gif                         4 Nov 01 19:41         0.1Kb
sat4.gif                         4 Nov 01 19:41         0.1Kb
sat5.gif                         4 Nov 01 19:41         0.1Kb
sat6.gif                         4 Nov 01 19:41         0.1Kb
sat7.gif                         4 Nov 01 19:41         0.1Kb
sat8.gif                         4 Nov 01 19:41         0.2Kb
satback.gif                      4 Nov 01 19:41         2.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/saturn/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
satback.gif                      4 Nov 01 19:41         2.8Kb
sat8.gif                         4 Nov 01 19:41         0.2Kb
sat7.gif                         4 Nov 01 19:41         0.1Kb
sat6.gif                         4 Nov 01 19:41         0.1Kb
sat5.gif                         4 Nov 01 19:41         0.1Kb
sat4.gif                         4 Nov 01 19:41         0.1Kb
sat3.gif                         4 Nov 01 19:41         0.1Kb
sat2.gif                         4 Nov 01 19:41         0.1Kb
sat1.gif                         4 Nov 01 19:41         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/skewb/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
skewb1.gif                      10 Mar 00 16:43         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/skewb/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
skewb1.gif                      10 Mar 00 16:43         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/skewb/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
skewb1.gif                      10 Mar 00 16:43         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/skewb/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
skewb1.gif                      10 Mar 00 16:43         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/spinout/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
back.gif                         7 Aug 00 17:20         0.3Kb
front.gif                        7 Aug 00 17:20         0.4Kb
knoba0.gif                       7 Aug 00 17:20         0.2Kb
knoba1.gif                       7 Aug 00 17:20         0.2Kb
knoba2.gif                       7 Aug 00 17:20         0.2Kb
knoba3.gif                       7 Aug 00 17:20         0.2Kb
knoba4.gif                       7 Aug 00 17:20         0.2Kb
knoba5.gif                       7 Aug 00 17:20         0.2Kb
knobb0.gif                       7 Aug 00 17:20         0.2Kb
knobb1.gif                       7 Aug 00 17:20         0.2Kb
knobb2.gif                       7 Aug 00 17:21         0.2Kb
knobb3.gif                       7 Aug 00 17:21         0.2Kb
knobb4.gif                       7 Aug 00 17:21         0.2Kb
knobb5.gif                       7 Aug 00 17:21         0.2Kb
slide.gif                        7 Aug 00 17:21         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/spinout/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
slide.gif                        7 Aug 00 17:21         0.3Kb
knobb5.gif                       7 Aug 00 17:21         0.2Kb
knobb4.gif                       7 Aug 00 17:21         0.2Kb
knobb3.gif                       7 Aug 00 17:21         0.2Kb
knobb2.gif                       7 Aug 00 17:21         0.2Kb
knobb1.gif                       7 Aug 00 17:20         0.2Kb
knobb0.gif                       7 Aug 00 17:20         0.2Kb
knoba5.gif                       7 Aug 00 17:20         0.2Kb
knoba4.gif                       7 Aug 00 17:20         0.2Kb
knoba3.gif                       7 Aug 00 17:20         0.2Kb
knoba2.gif                       7 Aug 00 17:20         0.2Kb
knoba1.gif                       7 Aug 00 17:20         0.2Kb
knoba0.gif                       7 Aug 00 17:20         0.2Kb
front.gif                        7 Aug 00 17:20         0.4Kb
back.gif                         7 Aug 00 17:20         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/spinout/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
knobb5.gif                       7 Aug 00 17:21         0.2Kb
knoba5.gif                       7 Aug 00 17:20         0.2Kb
knoba4.gif                       7 Aug 00 17:20         0.2Kb
knobb4.gif                       7 Aug 00 17:21         0.2Kb
knoba3.gif                       7 Aug 00 17:20         0.2Kb
knobb3.gif                       7 Aug 00 17:21         0.2Kb
knoba0.gif                       7 Aug 00 17:20         0.2Kb
knoba2.gif                       7 Aug 00 17:20         0.2Kb
knobb0.gif                       7 Aug 00 17:20         0.2Kb
knoba1.gif                       7 Aug 00 17:20         0.2Kb
knobb2.gif                       7 Aug 00 17:21         0.2Kb
knobb1.gif                       7 Aug 00 17:20         0.2Kb
slide.gif                        7 Aug 00 17:21         0.3Kb
back.gif                         7 Aug 00 17:20         0.3Kb
front.gif                        7 Aug 00 17:20         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/spinout/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
back.gif                         7 Aug 00 17:20         0.3Kb
front.gif                        7 Aug 00 17:20         0.4Kb
knoba0.gif                       7 Aug 00 17:20         0.2Kb
knoba1.gif                       7 Aug 00 17:20         0.2Kb
knoba2.gif                       7 Aug 00 17:20         0.2Kb
knoba3.gif                       7 Aug 00 17:20         0.2Kb
knoba4.gif                       7 Aug 00 17:20         0.2Kb
knoba5.gif                       7 Aug 00 17:20         0.2Kb
knobb0.gif                       7 Aug 00 17:20         0.2Kb
knobb1.gif                       7 Aug 00 17:20         0.2Kb
knobb2.gif                       7 Aug 00 17:21         0.2Kb
knobb3.gif                       7 Aug 00 17:21         0.2Kb
knobb4.gif                       7 Aug 00 17:21         0.2Kb
knobb5.gif                       7 Aug 00 17:21         0.2Kb
slide.gif                        7 Aug 00 17:21         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/square1/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
ambig.gif                        6 Apr 00 11:40         0.7Kb
convert.gif                      4 Apr 00 18:25         1.2Kb
deg150.gif                       4 Apr 00 21:22         0.4Kb
sq1-3-01.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-02.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-03.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-04.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-05.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-06.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-07.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-08.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-09.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-10.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-11.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-12.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-13.gif                    30 Mar 00 18:39         0.2Kb
sq1-4-a1.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a2.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a3.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a4.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a5.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a6.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a7.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-b1.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b2.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b3.gif                    30 Mar 00 18:47         0.3Kb
sq1-4-b4.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b5.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b6.gif                    30 Mar 00 18:47         0.3Kb
sq1barr.gif                     30 Mar 00 18:52         0.3Kb
sq1kite.gif                     30 Mar 00 18:52         0.3Kb
sq1lfst.gif                     30 Mar 00 18:52         0.3Kb
sq1lpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1mush.gif                     30 Mar 00 18:52         0.3Kb
sq1rfst.gif                     30 Mar 00 18:52         0.3Kb
sq1rpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1scall.gif                    30 Mar 00 18:52         0.3Kb
sq1shld.gif                     30 Mar 00 18:52         0.3Kb
sq1sq.gif                       30 Mar 00 18:29         0.2Kb
tocube.gif                       4 Apr 00 18:54         2.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/square1/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
tocube.gif                       4 Apr 00 18:54         2.8Kb
sq1sq.gif                       30 Mar 00 18:29         0.2Kb
sq1shld.gif                     30 Mar 00 18:52         0.3Kb
sq1scall.gif                    30 Mar 00 18:52         0.3Kb
sq1rpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1rfst.gif                     30 Mar 00 18:52         0.3Kb
sq1mush.gif                     30 Mar 00 18:52         0.3Kb
sq1lpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1lfst.gif                     30 Mar 00 18:52         0.3Kb
sq1kite.gif                     30 Mar 00 18:52         0.3Kb
sq1barr.gif                     30 Mar 00 18:52         0.3Kb
sq1-4-b6.gif                    30 Mar 00 18:47         0.3Kb
sq1-4-b5.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b4.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b3.gif                    30 Mar 00 18:47         0.3Kb
sq1-4-b2.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b1.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-a7.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a6.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a5.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a4.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a3.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a2.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a1.gif                    30 Mar 00 18:43         0.3Kb
sq1-3-13.gif                    30 Mar 00 18:39         0.2Kb
sq1-3-12.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-11.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-10.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-09.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-08.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-07.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-06.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-05.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-04.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-03.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-02.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-01.gif                    30 Mar 00 18:34         0.3Kb
deg150.gif                       4 Apr 00 21:22         0.4Kb
convert.gif                      4 Apr 00 18:25         1.2Kb
ambig.gif                        6 Apr 00 11:40         0.7Kb
_____________________________________________________________


Index of /jaap/puzzles/images/square1/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
sq1sq.gif                       30 Mar 00 18:29         0.2Kb
sq1-4-b4.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-a5.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-b5.gif                    30 Mar 00 18:47         0.2Kb
sq1-3-13.gif                    30 Mar 00 18:39         0.2Kb
sq1-4-a4.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a6.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-b1.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b2.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b6.gif                    30 Mar 00 18:47         0.3Kb
sq1-4-a7.gif                    30 Mar 00 18:43         0.3Kb
sq1rfst.gif                     30 Mar 00 18:52         0.3Kb
sq1lfst.gif                     30 Mar 00 18:52         0.3Kb
sq1-4-b3.gif                    30 Mar 00 18:47         0.3Kb
sq1barr.gif                     30 Mar 00 18:52         0.3Kb
sq1-4-a2.gif                    30 Mar 00 18:43         0.3Kb
sq1mush.gif                     30 Mar 00 18:52         0.3Kb
sq1-4-a3.gif                    30 Mar 00 18:43         0.3Kb
sq1kite.gif                     30 Mar 00 18:52         0.3Kb
sq1-4-a1.gif                    30 Mar 00 18:43         0.3Kb
sq1-3-02.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-08.gif                    30 Mar 00 18:37         0.3Kb
sq1shld.gif                     30 Mar 00 18:52         0.3Kb
sq1-3-06.gif                    30 Mar 00 18:34         0.3Kb
sq1rpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1scall.gif                    30 Mar 00 18:52         0.3Kb
sq1lpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1-3-10.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-09.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-11.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-04.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-07.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-03.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-05.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-12.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-01.gif                    30 Mar 00 18:34         0.3Kb
deg150.gif                       4 Apr 00 21:22         0.4Kb
ambig.gif                        6 Apr 00 11:40         0.7Kb
convert.gif                      4 Apr 00 18:25         1.2Kb
tocube.gif                       4 Apr 00 18:54         2.8Kb
_____________________________________________________________


Index of /jaap/puzzles/images/square1/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
sq1sq.gif                       30 Mar 00 18:29         0.2Kb
sq1-3-01.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-02.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-03.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-04.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-05.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-06.gif                    30 Mar 00 18:34         0.3Kb
sq1-3-07.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-08.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-09.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-10.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-11.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-12.gif                    30 Mar 00 18:37         0.3Kb
sq1-3-13.gif                    30 Mar 00 18:39         0.2Kb
sq1-4-a1.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a2.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a3.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-a4.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a5.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a6.gif                    30 Mar 00 18:43         0.2Kb
sq1-4-a7.gif                    30 Mar 00 18:43         0.3Kb
sq1-4-b1.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b2.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b3.gif                    30 Mar 00 18:47         0.3Kb
sq1-4-b4.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b5.gif                    30 Mar 00 18:47         0.2Kb
sq1-4-b6.gif                    30 Mar 00 18:47         0.3Kb
sq1barr.gif                     30 Mar 00 18:52         0.3Kb
sq1kite.gif                     30 Mar 00 18:52         0.3Kb
sq1lfst.gif                     30 Mar 00 18:52         0.3Kb
sq1lpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1mush.gif                     30 Mar 00 18:52         0.3Kb
sq1rfst.gif                     30 Mar 00 18:52         0.3Kb
sq1rpaw.gif                     30 Mar 00 18:52         0.3Kb
sq1scall.gif                    30 Mar 00 18:52         0.3Kb
sq1shld.gif                     30 Mar 00 18:52         0.3Kb
convert.gif                      4 Apr 00 18:25         1.2Kb
tocube.gif                       4 Apr 00 18:54         2.8Kb
deg150.gif                       4 Apr 00 21:22         0.4Kb
ambig.gif                        6 Apr 00 11:40         0.7Kb
_____________________________________________________________


Index of /jaap/puzzles/images/symmetry/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
i.gif                           10 Aug 00 18:28         0.4Kb
m4.gif                          10 Aug 00 18:28         0.4Kb
mc.gif                          10 Aug 00 18:28         0.4Kb
mcr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mcr2f.gif                       10 Aug 00 18:28         0.5Kb
mcr3.gif                        10 Aug 00 18:28         0.4Kb
mcr3r2.gif                      22 Oct 00 13:36         0.6Kb
mcr4.gif                        10 Aug 00 18:28         0.5Kb
me.gif                          10 Aug 00 18:28         0.4Kb
mer2e.gif                       10 Aug 00 18:28         0.4Kb
mer2f.gif                       10 Aug 00 18:28         0.4Kb
mer2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mer3.gif                        10 Aug 00 18:28         0.4Kb
mer3r2r2.gif                    10 Aug 00 18:28         0.5Kb
mer4.gif                        10 Aug 00 18:28         0.5Kb
mf.gif                          10 Aug 00 18:28         0.4Kb
mfr2e.gif                       10 Aug 00 18:28         0.4Kb
mfr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mfr2f.gif                       10 Aug 00 18:28         0.5Kb
mfr2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mfr3r2r2.gif                    10 Aug 00 18:28         0.6Kb
mr3r2.gif                       10 Aug 00 18:28         0.5Kb
mr4r2.gif                       10 Aug 00 18:28         0.6Kb
mr4r3r2.gif                     10 Aug 00 18:28         0.7Kb
r2e.gif                         10 Aug 00 18:28         0.4Kb
r2er2e.gif                      10 Aug 00 18:28         0.4Kb
r2f.gif                         10 Aug 00 18:28         0.4Kb
r2fr2f.gif                      10 Aug 00 18:28         0.4Kb
r3.gif                          10 Aug 00 18:28         0.4Kb
r3r2.gif                        10 Aug 00 18:28         0.4Kb
r3r2r2.gif                      10 Aug 00 18:28         0.5Kb
r4.gif                          10 Aug 00 18:28         0.4Kb
r4r2.gif                        10 Aug 00 18:28         0.4Kb
r4r3r2.gif                      10 Aug 00 18:28         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/symmetry/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
r4r3r2.gif                      10 Aug 00 18:28         0.5Kb
r4r2.gif                        10 Aug 00 18:28         0.4Kb
r4.gif                          10 Aug 00 18:28         0.4Kb
r3r2r2.gif                      10 Aug 00 18:28         0.5Kb
r3r2.gif                        10 Aug 00 18:28         0.4Kb
r3.gif                          10 Aug 00 18:28         0.4Kb
r2fr2f.gif                      10 Aug 00 18:28         0.4Kb
r2f.gif                         10 Aug 00 18:28         0.4Kb
r2er2e.gif                      10 Aug 00 18:28         0.4Kb
r2e.gif                         10 Aug 00 18:28         0.4Kb
mr4r3r2.gif                     10 Aug 00 18:28         0.7Kb
mr4r2.gif                       10 Aug 00 18:28         0.6Kb
mr3r2.gif                       10 Aug 00 18:28         0.5Kb
mfr3r2r2.gif                    10 Aug 00 18:28         0.6Kb
mfr2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mfr2f.gif                       10 Aug 00 18:28         0.5Kb
mfr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mfr2e.gif                       10 Aug 00 18:28         0.4Kb
mf.gif                          10 Aug 00 18:28         0.4Kb
mer4.gif                        10 Aug 00 18:28         0.5Kb
mer3r2r2.gif                    10 Aug 00 18:28         0.5Kb
mer3.gif                        10 Aug 00 18:28         0.4Kb
mer2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mer2f.gif                       10 Aug 00 18:28         0.4Kb
mer2e.gif                       10 Aug 00 18:28         0.4Kb
me.gif                          10 Aug 00 18:28         0.4Kb
mcr4.gif                        10 Aug 00 18:28         0.5Kb
mcr3r2.gif                      22 Oct 00 13:36         0.6Kb
mcr3.gif                        10 Aug 00 18:28         0.4Kb
mcr2f.gif                       10 Aug 00 18:28         0.5Kb
mcr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mc.gif                          10 Aug 00 18:28         0.4Kb
m4.gif                          10 Aug 00 18:28         0.4Kb
i.gif                           10 Aug 00 18:28         0.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/symmetry/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
i.gif                           10 Aug 00 18:28         0.4Kb
r2e.gif                         10 Aug 00 18:28         0.4Kb
r3.gif                          10 Aug 00 18:28         0.4Kb
mc.gif                          10 Aug 00 18:28         0.4Kb
me.gif                          10 Aug 00 18:28         0.4Kb
r2f.gif                         10 Aug 00 18:28         0.4Kb
r4.gif                          10 Aug 00 18:28         0.4Kb
mer2e.gif                       10 Aug 00 18:28         0.4Kb
mcr3.gif                        10 Aug 00 18:28         0.4Kb
r2er2e.gif                      10 Aug 00 18:28         0.4Kb
mf.gif                          10 Aug 00 18:28         0.4Kb
r3r2.gif                        10 Aug 00 18:28         0.4Kb
mfr2e.gif                       10 Aug 00 18:28         0.4Kb
m4.gif                          10 Aug 00 18:28         0.4Kb
r2fr2f.gif                      10 Aug 00 18:28         0.4Kb
mer2f.gif                       10 Aug 00 18:28         0.4Kb
mer3.gif                        10 Aug 00 18:28         0.4Kb
r4r2.gif                        10 Aug 00 18:28         0.4Kb
mcr2f.gif                       10 Aug 00 18:28         0.5Kb
r3r2r2.gif                      10 Aug 00 18:28         0.5Kb
mfr2f.gif                       10 Aug 00 18:28         0.5Kb
mcr4.gif                        10 Aug 00 18:28         0.5Kb
mer2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mfr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mcr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mr3r2.gif                       10 Aug 00 18:28         0.5Kb
r4r3r2.gif                      10 Aug 00 18:28         0.5Kb
mer4.gif                        10 Aug 00 18:28         0.5Kb
mfr2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mer3r2r2.gif                    10 Aug 00 18:28         0.5Kb
mcr3r2.gif                      22 Oct 00 13:36         0.6Kb
mfr3r2r2.gif                    10 Aug 00 18:28         0.6Kb
mr4r2.gif                       10 Aug 00 18:28         0.6Kb
mr4r3r2.gif                     10 Aug 00 18:28         0.7Kb
_____________________________________________________________


Index of /jaap/puzzles/images/symmetry/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
i.gif                           10 Aug 00 18:28         0.4Kb
m4.gif                          10 Aug 00 18:28         0.4Kb
mc.gif                          10 Aug 00 18:28         0.4Kb
mcr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mcr2f.gif                       10 Aug 00 18:28         0.5Kb
mcr3.gif                        10 Aug 00 18:28         0.4Kb
mcr4.gif                        10 Aug 00 18:28         0.5Kb
me.gif                          10 Aug 00 18:28         0.4Kb
mer2e.gif                       10 Aug 00 18:28         0.4Kb
mer2f.gif                       10 Aug 00 18:28         0.4Kb
mer2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mer3.gif                        10 Aug 00 18:28         0.4Kb
mer3r2r2.gif                    10 Aug 00 18:28         0.5Kb
mer4.gif                        10 Aug 00 18:28         0.5Kb
mf.gif                          10 Aug 00 18:28         0.4Kb
mfr2e.gif                       10 Aug 00 18:28         0.4Kb
mfr2er2e.gif                    10 Aug 00 18:28         0.5Kb
mfr2f.gif                       10 Aug 00 18:28         0.5Kb
mfr2fr2f.gif                    10 Aug 00 18:28         0.5Kb
mfr3r2r2.gif                    10 Aug 00 18:28         0.6Kb
mr3r2.gif                       10 Aug 00 18:28         0.5Kb
mr4r2.gif                       10 Aug 00 18:28         0.6Kb
mr4r3r2.gif                     10 Aug 00 18:28         0.7Kb
r2e.gif                         10 Aug 00 18:28         0.4Kb
r2er2e.gif                      10 Aug 00 18:28         0.4Kb
r2f.gif                         10 Aug 00 18:28         0.4Kb
r2fr2f.gif                      10 Aug 00 18:28         0.4Kb
r3.gif                          10 Aug 00 18:28         0.4Kb
r3r2.gif                        10 Aug 00 18:28         0.4Kb
r3r2r2.gif                      10 Aug 00 18:28         0.5Kb
r4.gif                          10 Aug 00 18:28         0.4Kb
r4r2.gif                        10 Aug 00 18:28         0.4Kb
r4r3r2.gif                      10 Aug 00 18:28         0.5Kb
mcr3r2.gif                      22 Oct 00 13:36         0.6Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tantrix/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
bbryyr.gif                       3 Feb 00 23:56         0.3Kb
bbyrry.gif                       3 Feb 00 23:56         0.3Kb
bluesoln.gif                     3 Feb 00 23:56         2.3Kb
brryyb.gif                       3 Feb 00 23:56         0.3Kb
bryrby.gif                       3 Feb 00 23:56         0.3Kb
bryryb.gif                       3 Feb 00 23:56         0.3Kb
byrybr.gif                       3 Feb 00 23:56         0.3Kb
byryrb.gif                       3 Feb 00 23:56         0.3Kb
dblsoln.gif                      3 Feb 00 23:56         4.4Kb
fivering.gif                    17 Apr 00 13:04         2.0Kb
geniusrb.gif                    30 Mar 00 17:54         2.7Kb
geniusry.gif                     3 Feb 00 23:56         2.8Kb
junior.gif                      30 Mar 00 17:58         2.2Kb
lines14.gif                     30 Mar 00 17:58         3.0Kb
lines14b.gif                     1 Apr 00 12:31         3.1Kb
master.gif                      30 Mar 00 18:09         2.7Kb
master2.gif                     30 Mar 00 18:11         2.7Kb
profess.gif                      3 Feb 00 23:56         2.8Kb
pyramid1.gif                    30 Mar 00 18:13         3.4Kb
pyramid2.gif                    30 Mar 00 18:14         3.4Kb
pyramid3.gif                    30 Mar 00 18:18         3.5Kb
redsoln.gif                      3 Feb 00 23:57         2.3Kb
rock1.gif                       11 Apr 00 14:49         2.7Kb
rock2.gif                       11 Apr 00 14:49         2.7Kb
rock3.gif                       11 Apr 00 14:49         2.6Kb
rock4.gif                       11 Apr 00 14:49         2.5Kb
rock5.gif                       11 Apr 00 14:49         2.6Kb
rybyrb.gif                       3 Feb 00 23:57         0.3Kb
shape12.gif                     17 Apr 00 13:04         0.3Kb
student.gif                      3 Feb 00 23:57         2.4Kb
tilelin0.gif                    30 Mar 00 18:20         2.2Kb
tileline.gif                    30 Mar 00 18:22        30.2Kb
tileloo0.gif                    30 Mar 00 18:24         2.1Kb
tileloop.gif                    30 Mar 00 18:26        28.9Kb
xxyzzy12.gif                    17 Apr 00 13:04         2.7Kb
xyxzyz12.gif                    17 Apr 00 13:04         3.0Kb
ybrbry.gif                       3 Feb 00 23:57         0.3Kb
yelsoln.gif                      3 Feb 00 23:57         2.2Kb
yrbrby.gif                       3 Feb 00 23:57         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tantrix/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
yrbrby.gif                       3 Feb 00 23:57         0.3Kb
yelsoln.gif                      3 Feb 00 23:57         2.2Kb
ybrbry.gif                       3 Feb 00 23:57         0.3Kb
xyxzyz12.gif                    17 Apr 00 13:04         3.0Kb
xxyzzy12.gif                    17 Apr 00 13:04         2.7Kb
tileloop.gif                    30 Mar 00 18:26        28.9Kb
tileloo0.gif                    30 Mar 00 18:24         2.1Kb
tileline.gif                    30 Mar 00 18:22        30.2Kb
tilelin0.gif                    30 Mar 00 18:20         2.2Kb
student.gif                      3 Feb 00 23:57         2.4Kb
shape12.gif                     17 Apr 00 13:04         0.3Kb
rybyrb.gif                       3 Feb 00 23:57         0.3Kb
rock5.gif                       11 Apr 00 14:49         2.6Kb
rock4.gif                       11 Apr 00 14:49         2.5Kb
rock3.gif                       11 Apr 00 14:49         2.6Kb
rock2.gif                       11 Apr 00 14:49         2.7Kb
rock1.gif                       11 Apr 00 14:49         2.7Kb
redsoln.gif                      3 Feb 00 23:57         2.3Kb
pyramid3.gif                    30 Mar 00 18:18         3.5Kb
pyramid2.gif                    30 Mar 00 18:14         3.4Kb
pyramid1.gif                    30 Mar 00 18:13         3.4Kb
profess.gif                      3 Feb 00 23:56         2.8Kb
master2.gif                     30 Mar 00 18:11         2.7Kb
master.gif                      30 Mar 00 18:09         2.7Kb
lines14b.gif                     1 Apr 00 12:31         3.1Kb
lines14.gif                     30 Mar 00 17:58         3.0Kb
junior.gif                      30 Mar 00 17:58         2.2Kb
geniusry.gif                     3 Feb 00 23:56         2.8Kb
geniusrb.gif                    30 Mar 00 17:54         2.7Kb
fivering.gif                    17 Apr 00 13:04         2.0Kb
dblsoln.gif                      3 Feb 00 23:56         4.4Kb
byryrb.gif                       3 Feb 00 23:56         0.3Kb
byrybr.gif                       3 Feb 00 23:56         0.3Kb
bryryb.gif                       3 Feb 00 23:56         0.3Kb
bryrby.gif                       3 Feb 00 23:56         0.3Kb
brryyb.gif                       3 Feb 00 23:56         0.3Kb
bluesoln.gif                     3 Feb 00 23:56         2.3Kb
bbyrry.gif                       3 Feb 00 23:56         0.3Kb
bbryyr.gif                       3 Feb 00 23:56         0.3Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tantrix/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
brryyb.gif                       3 Feb 00 23:56         0.3Kb
bryrby.gif                       3 Feb 00 23:56         0.3Kb
byrybr.gif                       3 Feb 00 23:56         0.3Kb
rybyrb.gif                       3 Feb 00 23:57         0.3Kb
shape12.gif                     17 Apr 00 13:04         0.3Kb
bryryb.gif                       3 Feb 00 23:56         0.3Kb
byryrb.gif                       3 Feb 00 23:56         0.3Kb
ybrbry.gif                       3 Feb 00 23:57         0.3Kb
yrbrby.gif                       3 Feb 00 23:57         0.3Kb
bbryyr.gif                       3 Feb 00 23:56         0.3Kb
bbyrry.gif                       3 Feb 00 23:56         0.3Kb
fivering.gif                    17 Apr 00 13:04         2.0Kb
tileloo0.gif                    30 Mar 00 18:24         2.1Kb
yelsoln.gif                      3 Feb 00 23:57         2.2Kb
tilelin0.gif                    30 Mar 00 18:20         2.2Kb
junior.gif                      30 Mar 00 17:58         2.2Kb
bluesoln.gif                     3 Feb 00 23:56         2.3Kb
redsoln.gif                      3 Feb 00 23:57         2.3Kb
student.gif                      3 Feb 00 23:57         2.4Kb
rock4.gif                       11 Apr 00 14:49         2.5Kb
rock5.gif                       11 Apr 00 14:49         2.6Kb
rock3.gif                       11 Apr 00 14:49         2.6Kb
rock2.gif                       11 Apr 00 14:49         2.7Kb
master.gif                      30 Mar 00 18:09         2.7Kb
rock1.gif                       11 Apr 00 14:49         2.7Kb
geniusrb.gif                    30 Mar 00 17:54         2.7Kb
xxyzzy12.gif                    17 Apr 00 13:04         2.7Kb
master2.gif                     30 Mar 00 18:11         2.7Kb
geniusry.gif                     3 Feb 00 23:56         2.8Kb
profess.gif                      3 Feb 00 23:56         2.8Kb
xyxzyz12.gif                    17 Apr 00 13:04         3.0Kb
lines14.gif                     30 Mar 00 17:58         3.0Kb
lines14b.gif                     1 Apr 00 12:31         3.1Kb
pyramid2.gif                    30 Mar 00 18:14         3.4Kb
pyramid1.gif                    30 Mar 00 18:13         3.4Kb
pyramid3.gif                    30 Mar 00 18:18         3.5Kb
dblsoln.gif                      3 Feb 00 23:56         4.4Kb
tileloop.gif                    30 Mar 00 18:26        28.9Kb
tileline.gif                    30 Mar 00 18:22        30.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tantrix/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
bbryyr.gif                       3 Feb 00 23:56         0.3Kb
bbyrry.gif                       3 Feb 00 23:56         0.3Kb
bluesoln.gif                     3 Feb 00 23:56         2.3Kb
brryyb.gif                       3 Feb 00 23:56         0.3Kb
bryrby.gif                       3 Feb 00 23:56         0.3Kb
bryryb.gif                       3 Feb 00 23:56         0.3Kb
byrybr.gif                       3 Feb 00 23:56         0.3Kb
byryrb.gif                       3 Feb 00 23:56         0.3Kb
dblsoln.gif                      3 Feb 00 23:56         4.4Kb
geniusry.gif                     3 Feb 00 23:56         2.8Kb
profess.gif                      3 Feb 00 23:56         2.8Kb
redsoln.gif                      3 Feb 00 23:57         2.3Kb
rybyrb.gif                       3 Feb 00 23:57         0.3Kb
student.gif                      3 Feb 00 23:57         2.4Kb
ybrbry.gif                       3 Feb 00 23:57         0.3Kb
yelsoln.gif                      3 Feb 00 23:57         2.2Kb
yrbrby.gif                       3 Feb 00 23:57         0.3Kb
geniusrb.gif                    30 Mar 00 17:54         2.7Kb
junior.gif                      30 Mar 00 17:58         2.2Kb
lines14.gif                     30 Mar 00 17:58         3.0Kb
master.gif                      30 Mar 00 18:09         2.7Kb
master2.gif                     30 Mar 00 18:11         2.7Kb
pyramid1.gif                    30 Mar 00 18:13         3.4Kb
pyramid2.gif                    30 Mar 00 18:14         3.4Kb
pyramid3.gif                    30 Mar 00 18:18         3.5Kb
tilelin0.gif                    30 Mar 00 18:20         2.2Kb
tileline.gif                    30 Mar 00 18:22        30.2Kb
tileloo0.gif                    30 Mar 00 18:24         2.1Kb
tileloop.gif                    30 Mar 00 18:26        28.9Kb
lines14b.gif                     1 Apr 00 12:31         3.1Kb
rock1.gif                       11 Apr 00 14:49         2.7Kb
rock2.gif                       11 Apr 00 14:49         2.7Kb
rock3.gif                       11 Apr 00 14:49         2.6Kb
rock4.gif                       11 Apr 00 14:49         2.5Kb
rock5.gif                       11 Apr 00 14:49         2.6Kb
fivering.gif                    17 Apr 00 13:04         2.0Kb
shape12.gif                     17 Apr 00 13:04         0.3Kb
xxyzzy12.gif                    17 Apr 00 13:04         2.7Kb
xyxzyz12.gif                    17 Apr 00 13:04         3.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/theory/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
perm1.gif                       22 May 00 15:45         0.9Kb
perm2.gif                       22 May 00 15:46         0.9Kb
perm3a.gif                      22 May 00 15:46         1.4Kb
perm3b.gif                      22 May 00 15:46         0.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/theory/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
perm3b.gif                      22 May 00 15:46         0.9Kb
perm3a.gif                      22 May 00 15:46         1.4Kb
perm2.gif                       22 May 00 15:46         0.9Kb
perm1.gif                       22 May 00 15:45         0.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/theory/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
perm1.gif                       22 May 00 15:45         0.9Kb
perm3b.gif                      22 May 00 15:46         0.9Kb
perm2.gif                       22 May 00 15:46         0.9Kb
perm3a.gif                      22 May 00 15:46         1.4Kb
_____________________________________________________________


Index of /jaap/puzzles/images/theory/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
perm1.gif                       22 May 00 15:45         0.9Kb
perm2.gif                       22 May 00 15:46         0.9Kb
perm3a.gif                      22 May 00 15:46         1.4Kb
perm3b.gif                      22 May 00 15:46         0.9Kb
_____________________________________________________________


Index of /jaap/puzzles/images/topspin/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
ts01.gif                        29 Feb 00 03:19         0.1Kb
ts02.gif                        29 Feb 00 03:19         0.1Kb
ts03.gif                        29 Feb 00 03:19         0.1Kb
ts04.gif                        29 Feb 00 03:19         0.1Kb
ts05.gif                        29 Feb 00 03:19         0.2Kb
ts06.gif                        29 Feb 00 03:19         0.2Kb
ts07.gif                        29 Feb 00 03:19         0.1Kb
ts08.gif                        29 Feb 00 03:19         0.2Kb
ts09.gif                        29 Feb 00 03:19         0.2Kb
ts10.gif                        29 Feb 00 03:19         0.2Kb
ts11.gif                        29 Feb 00 03:19         0.2Kb
ts12.gif                        29 Feb 00 03:19         0.2Kb
ts13.gif                        29 Feb 00 03:19         0.2Kb
ts14.gif                        29 Feb 00 03:19         0.2Kb
ts15.gif                        29 Feb 00 03:19         0.2Kb
ts16.gif                        29 Feb 00 03:19         0.2Kb
ts17.gif                        29 Feb 00 03:19         0.2Kb
ts18.gif                        29 Feb 00 03:19         0.2Kb
ts19.gif                        29 Feb 00 03:19         0.2Kb
ts20.gif                        29 Feb 00 03:19         0.2Kb
tsblank.gif                     29 Feb 00 03:19         0.1Kb
tsd.gif                         29 Feb 00 03:21         0.1Kb
tsdl.gif                        29 Feb 00 03:21         0.1Kb
tsdr.gif                        29 Feb 00 03:21         0.1Kb
tsfill.gif                      29 Feb 00 03:21         0.0Kb
tsl.gif                         29 Feb 00 03:21         0.1Kb
tsld.gif                        29 Feb 00 03:21         0.1Kb
tsleft.gif                      29 Feb 00 03:21         0.1Kb
tslu.gif                        29 Feb 00 03:21         0.1Kb
tsr.gif                         29 Feb 00 03:21         0.1Kb
tsrd.gif                        29 Feb 00 03:21         0.1Kb
tsright.gif                     29 Feb 00 03:21         0.1Kb
tsru.gif                        29 Feb 00 03:21         0.1Kb
tstd1.gif                       29 Feb 00 03:23         0.4Kb
tstd2.gif                       29 Feb 00 03:23         0.3Kb
tstu1.gif                        6 Mar 00 14:06         0.6Kb
tstu2.gif                        6 Mar 00 15:02         0.5Kb
tsul.gif                        29 Feb 00 03:23         0.1Kb
tsur.gif                        29 Feb 00 03:23         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/topspin/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
tsur.gif                        29 Feb 00 03:23         0.1Kb
tsul.gif                        29 Feb 00 03:23         0.1Kb
tstu2.gif                        6 Mar 00 15:02         0.5Kb
tstu1.gif                        6 Mar 00 14:06         0.6Kb
tstd2.gif                       29 Feb 00 03:23         0.3Kb
tstd1.gif                       29 Feb 00 03:23         0.4Kb
tsru.gif                        29 Feb 00 03:21         0.1Kb
tsright.gif                     29 Feb 00 03:21         0.1Kb
tsrd.gif                        29 Feb 00 03:21         0.1Kb
tsr.gif                         29 Feb 00 03:21         0.1Kb
tslu.gif                        29 Feb 00 03:21         0.1Kb
tsleft.gif                      29 Feb 00 03:21         0.1Kb
tsld.gif                        29 Feb 00 03:21         0.1Kb
tsl.gif                         29 Feb 00 03:21         0.1Kb
tsfill.gif                      29 Feb 00 03:21         0.0Kb
tsdr.gif                        29 Feb 00 03:21         0.1Kb
tsdl.gif                        29 Feb 00 03:21         0.1Kb
tsd.gif                         29 Feb 00 03:21         0.1Kb
tsblank.gif                     29 Feb 00 03:19         0.1Kb
ts20.gif                        29 Feb 00 03:19         0.2Kb
ts19.gif                        29 Feb 00 03:19         0.2Kb
ts18.gif                        29 Feb 00 03:19         0.2Kb
ts17.gif                        29 Feb 00 03:19         0.2Kb
ts16.gif                        29 Feb 00 03:19         0.2Kb
ts15.gif                        29 Feb 00 03:19         0.2Kb
ts14.gif                        29 Feb 00 03:19         0.2Kb
ts13.gif                        29 Feb 00 03:19         0.2Kb
ts12.gif                        29 Feb 00 03:19         0.2Kb
ts11.gif                        29 Feb 00 03:19         0.2Kb
ts10.gif                        29 Feb 00 03:19         0.2Kb
ts09.gif                        29 Feb 00 03:19         0.2Kb
ts08.gif                        29 Feb 00 03:19         0.2Kb
ts07.gif                        29 Feb 00 03:19         0.1Kb
ts06.gif                        29 Feb 00 03:19         0.2Kb
ts05.gif                        29 Feb 00 03:19         0.2Kb
ts04.gif                        29 Feb 00 03:19         0.1Kb
ts03.gif                        29 Feb 00 03:19         0.1Kb
ts02.gif                        29 Feb 00 03:19         0.1Kb
ts01.gif                        29 Feb 00 03:19         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/topspin/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
tsfill.gif                      29 Feb 00 03:21         0.0Kb
tsur.gif                        29 Feb 00 03:23         0.1Kb
tsdl.gif                        29 Feb 00 03:21         0.1Kb
tsld.gif                        29 Feb 00 03:21         0.1Kb
tsdr.gif                        29 Feb 00 03:21         0.1Kb
tsru.gif                        29 Feb 00 03:21         0.1Kb
tsul.gif                        29 Feb 00 03:23         0.1Kb
tslu.gif                        29 Feb 00 03:21         0.1Kb
tsrd.gif                        29 Feb 00 03:21         0.1Kb
tsright.gif                     29 Feb 00 03:21         0.1Kb
tsleft.gif                      29 Feb 00 03:21         0.1Kb
tsblank.gif                     29 Feb 00 03:19         0.1Kb
ts01.gif                        29 Feb 00 03:19         0.1Kb
tsd.gif                         29 Feb 00 03:21         0.1Kb
tsl.gif                         29 Feb 00 03:21         0.1Kb
tsr.gif                         29 Feb 00 03:21         0.1Kb
ts02.gif                        29 Feb 00 03:19         0.1Kb
ts03.gif                        29 Feb 00 03:19         0.1Kb
ts07.gif                        29 Feb 00 03:19         0.1Kb
ts04.gif                        29 Feb 00 03:19         0.1Kb
ts05.gif                        29 Feb 00 03:19         0.2Kb
ts06.gif                        29 Feb 00 03:19         0.2Kb
ts08.gif                        29 Feb 00 03:19         0.2Kb
ts09.gif                        29 Feb 00 03:19         0.2Kb
ts11.gif                        29 Feb 00 03:19         0.2Kb
ts13.gif                        29 Feb 00 03:19         0.2Kb
ts16.gif                        29 Feb 00 03:19         0.2Kb
ts17.gif                        29 Feb 00 03:19         0.2Kb
ts10.gif                        29 Feb 00 03:19         0.2Kb
ts12.gif                        29 Feb 00 03:19         0.2Kb
ts19.gif                        29 Feb 00 03:19         0.2Kb
ts14.gif                        29 Feb 00 03:19         0.2Kb
ts15.gif                        29 Feb 00 03:19         0.2Kb
ts18.gif                        29 Feb 00 03:19         0.2Kb
ts20.gif                        29 Feb 00 03:19         0.2Kb
tstd2.gif                       29 Feb 00 03:23         0.3Kb
tstd1.gif                       29 Feb 00 03:23         0.4Kb
tstu2.gif                        6 Mar 00 15:02         0.5Kb
tstu1.gif                        6 Mar 00 14:06         0.6Kb
_____________________________________________________________


Index of /jaap/puzzles/images/topspin/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
tstu1.gif                        6 Mar 00 14:06         0.6Kb
tstu2.gif                        6 Mar 00 15:02         0.5Kb
tstd1.gif                       29 Feb 00 03:23         0.4Kb
tstd2.gif                       29 Feb 00 03:23         0.3Kb
ts20.gif                        29 Feb 00 03:19         0.2Kb
ts18.gif                        29 Feb 00 03:19         0.2Kb
ts15.gif                        29 Feb 00 03:19         0.2Kb
ts14.gif                        29 Feb 00 03:19         0.2Kb
ts19.gif                        29 Feb 00 03:19         0.2Kb
ts12.gif                        29 Feb 00 03:19         0.2Kb
ts10.gif                        29 Feb 00 03:19         0.2Kb
ts17.gif                        29 Feb 00 03:19         0.2Kb
ts16.gif                        29 Feb 00 03:19         0.2Kb
ts13.gif                        29 Feb 00 03:19         0.2Kb
ts11.gif                        29 Feb 00 03:19         0.2Kb
ts09.gif                        29 Feb 00 03:19         0.2Kb
ts08.gif                        29 Feb 00 03:19         0.2Kb
ts06.gif                        29 Feb 00 03:19         0.2Kb
ts05.gif                        29 Feb 00 03:19         0.2Kb
ts04.gif                        29 Feb 00 03:19         0.1Kb
ts07.gif                        29 Feb 00 03:19         0.1Kb
ts03.gif                        29 Feb 00 03:19         0.1Kb
ts02.gif                        29 Feb 00 03:19         0.1Kb
tsr.gif                         29 Feb 00 03:21         0.1Kb
tsl.gif                         29 Feb 00 03:21         0.1Kb
tsd.gif                         29 Feb 00 03:21         0.1Kb
ts01.gif                        29 Feb 00 03:19         0.1Kb
tsblank.gif                     29 Feb 00 03:19         0.1Kb
tsleft.gif                      29 Feb 00 03:21         0.1Kb
tsright.gif                     29 Feb 00 03:21         0.1Kb
tsrd.gif                        29 Feb 00 03:21         0.1Kb
tslu.gif                        29 Feb 00 03:21         0.1Kb
tsul.gif                        29 Feb 00 03:23         0.1Kb
tsru.gif                        29 Feb 00 03:21         0.1Kb
tsdr.gif                        29 Feb 00 03:21         0.1Kb
tsld.gif                        29 Feb 00 03:21         0.1Kb
tsdl.gif                        29 Feb 00 03:21         0.1Kb
tsur.gif                        29 Feb 00 03:23         0.1Kb
tsfill.gif                      29 Feb 00 03:21         0.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/topspin/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
ts01.gif                        29 Feb 00 03:19         0.1Kb
ts02.gif                        29 Feb 00 03:19         0.1Kb
ts03.gif                        29 Feb 00 03:19         0.1Kb
ts04.gif                        29 Feb 00 03:19         0.1Kb
ts05.gif                        29 Feb 00 03:19         0.2Kb
ts06.gif                        29 Feb 00 03:19         0.2Kb
ts07.gif                        29 Feb 00 03:19         0.1Kb
ts08.gif                        29 Feb 00 03:19         0.2Kb
ts09.gif                        29 Feb 00 03:19         0.2Kb
ts10.gif                        29 Feb 00 03:19         0.2Kb
ts11.gif                        29 Feb 00 03:19         0.2Kb
ts12.gif                        29 Feb 00 03:19         0.2Kb
ts13.gif                        29 Feb 00 03:19         0.2Kb
ts14.gif                        29 Feb 00 03:19         0.2Kb
ts15.gif                        29 Feb 00 03:19         0.2Kb
ts16.gif                        29 Feb 00 03:19         0.2Kb
ts17.gif                        29 Feb 00 03:19         0.2Kb
ts18.gif                        29 Feb 00 03:19         0.2Kb
ts19.gif                        29 Feb 00 03:19         0.2Kb
ts20.gif                        29 Feb 00 03:19         0.2Kb
tsblank.gif                     29 Feb 00 03:19         0.1Kb
tsd.gif                         29 Feb 00 03:21         0.1Kb
tsdl.gif                        29 Feb 00 03:21         0.1Kb
tsdr.gif                        29 Feb 00 03:21         0.1Kb
tsfill.gif                      29 Feb 00 03:21         0.0Kb
tsl.gif                         29 Feb 00 03:21         0.1Kb
tsld.gif                        29 Feb 00 03:21         0.1Kb
tsleft.gif                      29 Feb 00 03:21         0.1Kb
tslu.gif                        29 Feb 00 03:21         0.1Kb
tsr.gif                         29 Feb 00 03:21         0.1Kb
tsrd.gif                        29 Feb 00 03:21         0.1Kb
tsright.gif                     29 Feb 00 03:21         0.1Kb
tsru.gif                        29 Feb 00 03:21         0.1Kb
tstd1.gif                       29 Feb 00 03:23         0.4Kb
tstd2.gif                       29 Feb 00 03:23         0.3Kb
tsul.gif                        29 Feb 00 03:23         0.1Kb
tsur.gif                        29 Feb 00 03:23         0.1Kb
tstu1.gif                        6 Mar 00 14:06         0.6Kb
tstu2.gif                        6 Mar 00 15:02         0.5Kb
_____________________________________________________________


Index of /jaap/puzzles/images/topspin/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
tstu2.gif                        6 Mar 00 15:02         0.5Kb
tstu1.gif                        6 Mar 00 14:06         0.6Kb
tsur.gif                        29 Feb 00 03:23         0.1Kb
tsul.gif                        29 Feb 00 03:23         0.1Kb
tstd2.gif                       29 Feb 00 03:23         0.3Kb
tstd1.gif                       29 Feb 00 03:23         0.4Kb
tsru.gif                        29 Feb 00 03:21         0.1Kb
tsright.gif                     29 Feb 00 03:21         0.1Kb
tsrd.gif                        29 Feb 00 03:21         0.1Kb
tsr.gif                         29 Feb 00 03:21         0.1Kb
tslu.gif                        29 Feb 00 03:21         0.1Kb
tsleft.gif                      29 Feb 00 03:21         0.1Kb
tsld.gif                        29 Feb 00 03:21         0.1Kb
tsl.gif                         29 Feb 00 03:21         0.1Kb
tsfill.gif                      29 Feb 00 03:21         0.0Kb
tsdr.gif                        29 Feb 00 03:21         0.1Kb
tsdl.gif                        29 Feb 00 03:21         0.1Kb
tsd.gif                         29 Feb 00 03:21         0.1Kb
tsblank.gif                     29 Feb 00 03:19         0.1Kb
ts20.gif                        29 Feb 00 03:19         0.2Kb
ts19.gif                        29 Feb 00 03:19         0.2Kb
ts18.gif                        29 Feb 00 03:19         0.2Kb
ts17.gif                        29 Feb 00 03:19         0.2Kb
ts16.gif                        29 Feb 00 03:19         0.2Kb
ts15.gif                        29 Feb 00 03:19         0.2Kb
ts14.gif                        29 Feb 00 03:19         0.2Kb
ts13.gif                        29 Feb 00 03:19         0.2Kb
ts12.gif                        29 Feb 00 03:19         0.2Kb
ts11.gif                        29 Feb 00 03:19         0.2Kb
ts10.gif                        29 Feb 00 03:19         0.2Kb
ts09.gif                        29 Feb 00 03:19         0.2Kb
ts08.gif                        29 Feb 00 03:19         0.2Kb
ts07.gif                        29 Feb 00 03:19         0.1Kb
ts06.gif                        29 Feb 00 03:19         0.2Kb
ts05.gif                        29 Feb 00 03:19         0.2Kb
ts04.gif                        29 Feb 00 03:19         0.1Kb
ts03.gif                        29 Feb 00 03:19         0.1Kb
ts02.gif                        29 Feb 00 03:19         0.1Kb
ts01.gif                        29 Feb 00 03:19         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tower/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
twblank.gif                     30 Mar 00 20:30         0.1Kb
twblue.gif                      30 Mar 00 20:30         0.1Kb
twgreen.gif                     30 Mar 00 20:30         0.1Kb
twleft.gif                      30 Mar 00 20:30         0.1Kb
twpurple.gif                    30 Mar 00 20:30         0.1Kb
twred.gif                       30 Mar 00 20:30         0.1Kb
twright.gif                     30 Mar 00 20:30         0.1Kb
twwhite.gif                     30 Mar 00 20:30         0.1Kb
twyellow.gif                    30 Mar 00 20:30         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tower/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
twyellow.gif                    30 Mar 00 20:30         0.1Kb
twwhite.gif                     30 Mar 00 20:30         0.1Kb
twright.gif                     30 Mar 00 20:30         0.1Kb
twred.gif                       30 Mar 00 20:30         0.1Kb
twpurple.gif                    30 Mar 00 20:30         0.1Kb
twleft.gif                      30 Mar 00 20:30         0.1Kb
twgreen.gif                     30 Mar 00 20:30         0.1Kb
twblue.gif                      30 Mar 00 20:30         0.1Kb
twblank.gif                     30 Mar 00 20:30         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tower/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
twleft.gif                      30 Mar 00 20:30         0.1Kb
twright.gif                     30 Mar 00 20:30         0.1Kb
twblank.gif                     30 Mar 00 20:30         0.1Kb
twblue.gif                      30 Mar 00 20:30         0.1Kb
twgreen.gif                     30 Mar 00 20:30         0.1Kb
twpurple.gif                    30 Mar 00 20:30         0.1Kb
twred.gif                       30 Mar 00 20:30         0.1Kb
twwhite.gif                     30 Mar 00 20:30         0.1Kb
twyellow.gif                    30 Mar 00 20:30         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tower/

Name                          Last Modified            ^ Size
_____________________________________________________________

Parent directory
twyellow.gif                    30 Mar 00 20:30         0.1Kb
twwhite.gif                     30 Mar 00 20:30         0.1Kb
twred.gif                       30 Mar 00 20:30         0.1Kb
twpurple.gif                    30 Mar 00 20:30         0.1Kb
twgreen.gif                     30 Mar 00 20:30         0.1Kb
twblue.gif                      30 Mar 00 20:30         0.1Kb
twblank.gif                     30 Mar 00 20:30         0.1Kb
twright.gif                     30 Mar 00 20:30         0.1Kb
twleft.gif                      30 Mar 00 20:30         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tower/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
twblank.gif                     30 Mar 00 20:30         0.1Kb
twblue.gif                      30 Mar 00 20:30         0.1Kb
twgreen.gif                     30 Mar 00 20:30         0.1Kb
twleft.gif                      30 Mar 00 20:30         0.1Kb
twpurple.gif                    30 Mar 00 20:30         0.1Kb
twred.gif                       30 Mar 00 20:30         0.1Kb
twright.gif                     30 Mar 00 20:30         0.1Kb
twwhite.gif                     30 Mar 00 20:30         0.1Kb
twyellow.gif                    30 Mar 00 20:30         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/tower/

Name                          ^ Last Modified            Size
_____________________________________________________________

Parent directory
twyellow.gif                    30 Mar 00 20:30         0.1Kb
twwhite.gif                     30 Mar 00 20:30         0.1Kb
twright.gif                     30 Mar 00 20:30         0.1Kb
twred.gif                       30 Mar 00 20:30         0.1Kb
twpurple.gif                    30 Mar 00 20:30         0.1Kb
twleft.gif                      30 Mar 00 20:30         0.1Kb
twgreen.gif                     30 Mar 00 20:30         0.1Kb
twblue.gif                      30 Mar 00 20:30         0.1Kb
twblank.gif                     30 Mar 00 20:30         0.1Kb
_____________________________________________________________


Index of /jaap/puzzles/images/turnstile/

v Name                          Last Modified            Size
_____________________________________________________________

Parent directory
back.gif                         1 Jan 01 20:14         3.0Kb
c1blue.gif                       1 Jan 01 20:14         0.3Kb
c1green.gif                      1 Jan 01 20:14         0.3Kb
c1grey.gif                       1 Jan 01 20:14         0.3Kb
c1purp.gif                       1 Jan 01 20:14         0.3Kb
c1red.gif                        1 Jan 01 20:14         0.3Kb
c1yell.gif                       1 Jan 01 20:14         0.3Kb
c2blue.gif                       1 Jan 01 20:14         0.3Kb
c2green.gif                      1 Jan 01 20:14         0.3Kb
c2grey.gif                       1 Jan 01 20:14         0.3Kb
c2purp.gif                       1 Jan 01 20:14         0.3Kb
c2red.gif                        1 Jan 01 20:14         0.3Kb
c2yell.gif                       1 Jan 01 20:14         0.3Kb
e1blue.gif                       1 Jan 01 20:14         0.3Kb
e1green.gif                      1 Jan 01 20:14         0.3Kb
e1grey.gif                       1 Jan 01 20:14         0.3Kb
e1purp.gif                       1 Jan 01 20:14         0.3Kb
e1red.gif                        1 Jan 01 20:14         0.3Kb
e1yell.gif                       1 Jan 01 20:14         0.3Kb
e2blue.gif                       1 Jan 01 20:14         0.3Kb
e2green.gif                      1 Jan 01 20:15         0.3Kb
e2grey.gif                       1 Jan 01 20:15         0.3Kb
e2purp.gif                       1 Jan 01 20:15         0.3Kb
e2red.gif                        1 Jan 01 20:15         0.3Kb
e2yell.gif                       1 Jan 01 20:15         0.3Kb
e3blue.gif                       1 Jan 01 20:15         0.2Kb
e3green.gif                      1 Jan 01 20:15         0.2Kb
e3grey.gif                       1 Jan 01 20:15         0.2Kb
e3purp.gif                       1 Jan 01 20:15         0.2Kb
e3red.gif                        1 Jan 01 20:15         0.2Kb
e3yell.gif                       1 Jan 01 20:15         0.2Kb
_____________________________________________________________


Index of /jaap/puzzles/images/turnstile/

^ Name                          Last Modified            Size
_____________________________________________________________

Parent directory
e3yell.gif                       1 Jan 01 20:15         0.2Kb
e3red.gif                        1 Jan 01 20:15         0.2Kb
e3purp.gif                       1 Jan 01 20:15         0.2Kb
e3grey.gif                       1 Jan 01 20:15         0.2Kb
e3green.gif                      1 Jan 01 20:15         0.2Kb
e3blue.gif                       1 Jan 01 20:15         0.2Kb
e2yell.gif                       1 Jan 01 20:15         0.3Kb
e2red.gif                        1 Jan 01 20:15         0.3Kb
e2purp.gif                       1 Jan 01 20:15         0.3Kb
e2grey.gif                       1 Jan 01 20:15         0.3Kb
e2green.gif                      1 Jan 01 20:15         0.3Kb
e2blue.gif                       1 Jan 01 20:14         0.3Kb
e1yell.gif                       1 Jan 01 20:14         0.3Kb
e1red.gif                        1 Jan 01 20:14         0.3Kb
e1purp.gif                       1 Jan 01 20:14         0.3Kb
e1grey.gif                       1 Jan 01 20:14         0.3Kb
e1green.gif                      1 Jan 01 20:14         0.3Kb
e1blue.gif                       1 Jan 01 20:14         0.3Kb
c2yell.gif                       1 Jan 01 20:14         0.3Kb
c2red.gif                        1 Jan 01 20:14         0.3Kb
c2purp.gif                       1 Jan 01 20:14         0.3Kb
c2grey.gif                       1 Jan 01 20:14         0.3Kb
c2green.gif                      1 Jan 01 20:14         0.3Kb
c2blue.gif                       1 Jan 01 20:14         0.3Kb
c1yell.gif                       1 Jan 01 20:14         0.3Kb
c1red.gif                        1 Jan 01 20:14         0.3Kb
c1purp.gif                       1 Jan 01 20:14         0.3Kb
c1grey.gif                       1 Jan 01 20:14         0.3Kb
c1green.gif                      1 Jan 01 20:14         0.3Kb
c1blue.gif                       1 Jan 01 20:14         0.3Kb
back.gif                         1 Jan 01 20:14         3.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/turnstile/

Name                          Last Modified            v Size
_____________________________________________________________

Parent directory
e3blue.gif                       1 Jan 01 20:15         0.2Kb
e3green.gif                      1 Jan 01 20:15         0.2Kb
e3grey.gif                       1 Jan 01 20:15         0.2Kb
e3purp.gif                       1 Jan 01 20:15         0.2Kb
e3red.gif                        1 Jan 01 20:15         0.2Kb
e3yell.gif                       1 Jan 01 20:15         0.2Kb
c2blue.gif                       1 Jan 01 20:14         0.3Kb
c2green.gif                      1 Jan 01 20:14         0.3Kb
c2grey.gif                       1 Jan 01 20:14         0.3Kb
c2purp.gif                       1 Jan 01 20:14         0.3Kb
c2red.gif                        1 Jan 01 20:14         0.3Kb
c2yell.gif                       1 Jan 01 20:14         0.3Kb
c1blue.gif                       1 Jan 01 20:14         0.3Kb
c1green.gif                      1 Jan 01 20:14         0.3Kb
c1grey.gif                       1 Jan 01 20:14         0.3Kb
c1purp.gif                       1 Jan 01 20:14         0.3Kb
c1red.gif                        1 Jan 01 20:14         0.3Kb
c1yell.gif                       1 Jan 01 20:14         0.3Kb
e1blue.gif                       1 Jan 01 20:14         0.3Kb
e1green.gif                      1 Jan 01 20:14         0.3Kb
e1grey.gif                       1 Jan 01 20:14         0.3Kb
e1purp.gif                       1 Jan 01 20:14         0.3Kb
e1red.gif                        1 Jan 01 20:14         0.3Kb
e1yell.gif                       1 Jan 01 20:14         0.3Kb
e2blue.gif                       1 Jan 01 20:14         0.3Kb
e2green.gif                      1 Jan 01 20:15         0.3Kb
e2grey.gif                       1 Jan 01 20:15         0.3Kb
e2purp.gif                       1 Jan 01 20:15         0.3Kb
e2red.gif                        1 Jan 01 20:15         0.3Kb
e2yell.gif                       1 Jan 01 20:15         0.3Kb
back.gif                         1 Jan 01 20:14         3.0Kb
_____________________________________________________________


Index of /jaap/puzzles/images/turnstile/

Name                          v Last Modified            Size
_____________________________________________________________

Parent directory
back.gif                         1 Jan 01 20:14         3.0Kb
c1blue.gif                       1 Jan 01 20:14         0.3Kb
c1green.gif                      1 Jan 01 20:14         0.3Kb
c1grey.gif                       1 Jan 01 20:14         0.3Kb
c1purp.gif                       1 Jan 01 20:14         0.3Kb
c1red.gif                        1 Jan 01 20:14         0.3Kb
c1yell.gif                       1 Jan 01 20:14         0.3Kb
c2blue.gif                       1 Jan 01 20:14         0.3Kb
c2green.gif                      1 Jan 01 20:14         0.3Kb
c2grey.gif                       1 Jan 01 20:14         0.3Kb
c2purp.gif                       1 Jan 01 20:14         0.3Kb
c2red.gif                        1 Jan 01 20:14         0.3Kb
c2yell.gif                       1 Jan 01 20:14         0.3Kb
e1blue.gif                       1 Jan 01 20:14         0.3Kb
e1green.gif                      1 Jan 01 20:14         0.3Kb
e1grey.gif                       1 Jan 01 20:14         0.3Kb
e1purp.gif                       1 Jan 01 20:14         0.3Kb
e1red.gif                        1 Jan 01 20:14         0.3Kb
e1yell.gif                       1 Jan 01 20:14         0.3Kb
e2blue.gif                       1 Jan 01 20:14         0.3Kb
e2green.gif                      1 Jan 01 20:15         0.3Kb
e2grey.gif                       1 Jan 01 20:15         0.3Kb
e2purp.gif                       1 Jan 01 20:15         0.3Kb
e2red.gif                        1 Jan 01 20:15         0.3Kb
e2yell.gif                       1 Jan 01 20:15         0.3Kb
e3blue.gif                       1 Jan 01 20:15         0.2Kb
e3green.gif                      1 Jan 01 20:15         0.2Kb
e3grey.gif                       1 Jan 01 20:15         0.2Kb
e3purp.gif                       1 Jan 01 20:15         0.2Kb
e3red.gif                        1 Jan 01 20:15         0.2Kb
e3yell.gif                       1 Jan 01 20:15         0.2Kb
_____________________________________________________________