Team LiB

Game Design Foundations

Roger E. Pedersen

Wordware Publishing, Inc.

Library of Congress Cataloging-in-Publication Data

Pedersen, Roger E.
Game design foundations / by Roger E. Pedersen.
p. cm.
Includes index.
ISBN 1-55622-973-9 (paperback; CD-ROM)

1. Computer games--Programming. I. Title.
QA76.76.C672P43 2002

794.8'151--dc21 2002154127

CIP

© 2003, Wordware Publishing, Inc.
All Rights Reserved

2320 Los Rios Boulevard
Plano, Texas 75074

No part of this book may be reproduced in any form or by any means without permission in writing from Wordware Publishing, Inc.

Printed in the United States of America

ISBN 1-55622-973-9

10 9 8 7 6 5 4 3 2 1

0301

All brand names and product names mentioned in this book are trademarks or service marks of their respective companies. Any omission or misuse (of any kind) of service marks or trademarks should not be regarded as intent to infringe on the property of others. The publisher recognizes and respects all marks used by companies, manufacturers, and developers as a means to distinguish their products.

All inquiries for volume purchases of this book should be addressed to Wordware Publishing, Inc., at the above address. Telephone inquiries may be made by calling:

(972) 423-0090

I dedicate this book to my four beautiful daughters, Michele Leslie, Brooke Laurel, Megan Leigh, and Meredith Marlowe Pedersen.

Acknowledgments

Special thanks to Wes Beckwith, John Neidhart, Benjamin Foley, Ruth Pedersen, Megan Pedersen, Michael R. Hausman, Bessalel Yarjovski, Dorothy Cimo, Dr. Eugelio “Joe” Gonzalez, The Montvale, NJ Library, The Waterloo, and IA Library

Professional thanks to (in alphabetical order):

Acclaim Entertainment—Alan B. Lewis
Alias|Wavefront Maya—Lei Lei Sun and H. Kernahan
Cakewalk—Steve Thomas
Chris Crawford
Corel Corporation—Monica Fergusson
Criterion Software RenderWare—Chad Barron and Tim Page
Discreet 3D Studio Max—Kevin G. Clark
Egerter Software Power Render—Chris Egerter
Electronic Arts (EA)—Jennifer Gonzalez, Ben Brickman and Steve Groll
Epic Megagames Unreal Engine—Mark Rein and Tim Sweeney
FMJSoft—Markus Jonsson
GarageGames Inc.—Jeff Tunnell
Hollywood Edge—John Moran
Interplay—Kathryne Wahl
JASC Products—Kristin McDuffee and Sandi Scott
Lithtech Monolith Engine—Paige Young
NewTek, Inc.—Chuck Baker and William Vaughan
Novalogic—Lee Milligan and Georgina Petrie
Numerical Design Ltd.
The NetImmerse 3D Game Engine
Phantom EFX—Jim Thompson
Sonic Foundry—Christopher C Cain and Trish Monone
Sound Ideas—Mike Bell
Terminal Reality Nocturne Engine—Brett Evan Russell and Jeff Mills
The Art Institute of Chicago (Georges Seurat)—Hsiu-ling Huang
The Neanderthal Museum, Germany—Petra Schiller
Ubi Soft—Clint H.
Walker Boy Studio—Eric and Chad Walker
Wild Tangent—Alex St. John and Kelly Enstrom

About the CD

The companion CD includes source code for the tic-tac-toe game discussed in the book, several audio and image applications, and a chapter on game ideas.

These are organized in the following folders:

  • FMJSoft—The applications in this folder are Awave Studio v8.5, Image Eye v6.0, AnyImage v2.5, and Awave Audio v7.6. These audio and image tools are helpful in converting and viewing files of various types. For more information about these tools, see Appendix D.

  • PhantomEFX—The Reel Deal Poker Demo is located in this folder. Simply double-click on the setup.exe file to install. For more information about the Reel Deal Poker Demo, see Appendix D.

  • Wordware—This folder includes the code and other files needed for the tic-tac-toe game presented in Chapter 11, along with an expanded version of Chapter 6, “Game Ideas,” in PDF format. You will need Adobe Acrobat Reader, which is available for download at http://www.adobe.com/products/acrobat/readermain.html, to read this file.

The CD contents can be accessed using Windows Explorer.

Caution

By opening the CD package, you accept the terms and conditions of the CD/Source Code Usage License Agreement.
Additionally, opening the CD package makes this book nonreturnable.
Team LiB


Table of Contents

Team LiB
Next Section
Game Design Foundations
Game Design Foundations
by Roger E. Pedersen ISBN:1556229739
Wordware Publishing ?2003 (378 pages)

Provides an easy-to-follow process for game designers to express their concepts and begin the development process.

Table of Contents
 | Game Design Foundations
 | Chapter 1 | - | The Game Designer
 | Chapter 2 | - | Pedersen’s Principles on Game Design
 | Chapter 3 | - | War Stories
 | Chapter 4 | - | Game Concepts
 | Chapter 5 | - | Game Genres
 | Chapter 6 | - | Game Ideas
 | Chapter 7 | - | Research
 | Chapter 8 | - | The “One Pager” Concept Document
 | Chapter 9 | - | Game Art and Animation
 | Chapter 10 | - | The User Interface
 | Chapter 11 | - | The Basics of Programming
 | Chapter 12 | - | 3D Game Engines
 | Chapter 13 | - | Artificial Intelligence (AI)
 | Chapter 14 | - | The Basics of Scriptwriting
 | Chapter 15 | - | Audio: Sound and Music
 | Chapter 16 | - | Testing
 | Chapter 17 | - | The Executive Summary (“The Five Pager”)
 | Chapter 18 | - | The Design Document
 | Appendix A | - | Contact Information
 | Appendix B | - | An Interview with Roger E. Pedersen
 | Appendix C | - | SFX (Sound Effects) Library
 | Appendix D | - | CD-ROM Contents
 | Index
 | CD Content
Team LiB
Next Section


BackCover

Team LiB
Back Cover

Game Design Foundations provides an easy-to-follow process for game designers to express their concepts and begin the development process. Game designer Roger E. Pedersen explores the various game genres, discusses the research process, and explains the basics needed to understand programming, artwork, sound and audio, testing, and scriptwriting (both linear and non-linear). The book provides extensive examples to illustrate the game development process and includes more than 1,200 game ideas. Learn the tools and secrets of a game designer with 20 years of experience and more than 50 gaming titles to his credit.

  • Learn how to thoroughly research your concept.
  • Find out about the tools needed for sound, music, and 2D and 3D art animation.
  • Discover the variety of 3D engines that are available for game development.
  • Understand the basics of programming, scriptwriting, artificial intelligence, testing, and the user interface.
  • Learn how to design and write important documents including the one pager, executive summary, and design document.
  • Analyze the numerous examples provided for ways to get your game idea and vision documented and ready to be developed.

About the Author

Roger E. Pedersen has been designing, producing, and programming games since the early 1980s for companies such as CBS Software, Gametek, Hi-Tech Expressions, Villa Crespo Software, Acclaim Entertainment, Phantom EFX, Walker Boy Studio, 3D Open Motion, Hypnotics, and Merit Industries. His cumulative title sales have surpassed 10 million copies on over 50 titles for multiple platforms including the personal computer, video consoles, location-based, Internet, arcade, and hand-held. He is also the author of award-winning articles for Gamasutra.com, GameDev.net, and Gignews.com.


Chapter 1: The Game Designer

Overview

For the past two decades, I’ve met people in the streets who proudly state it to me.

For over twenty years, I’ve chatted with people on planes, trains, buses, and in automobiles who have chatted about it with me.

In every computer superstore and every computer outlet, gaming fans have argued and bragged about it.

For numerous years at computer gaming conferences and conventions, game programmers, graphic artists, and even producers have secretly whispered it to me.

Even now, you the reader are thinking the exact same thoughts:

“I have a concept for the most amazing and revolutionary game.”

“This game of mine will blow away every game that has ever been published.”

“I played the ‘hot game’ and with a few of my additions and real ‘cool’ puzzles or tricks, it could be so much better.”

We all have great gaming concepts that would have millions of gaming fanatics praising our genius and creativity.

Then why aren’t there millions of game designers?

What transpires from concept to a product on the shelf?

Let’s get started and understand the initial tools we need to begin designing this great game that exists in our minds.


Game Designers Are NOT Programmers

You are a designer, a creator of a game concept.

You need to be able to convey your ideas for others to carry out.

You do not need to be an expert in programming, programming languages, operating systems, or what 3D card is best for your game.

Your job is to tell the programmers in a document to design for you a “temple.” It is the programmers’ job to create your temple by using any material they wish, like marble, brick, wood, and even straw. They must be able to make the structure stable and functionally designed.


Game Designers Are NOT Artists

You are the designer and not the artistic talent.

You do not need to be an expert in graphic packages, various graphics file formats, or graphics libraries.

Your job is to tell the graphic artists in a document that your “temple” needs to be decorated. It is the artists’ job to decide how to set the environment by creating marble statues, elaborate tapestries, ornate wooden wall carvings, and exquisite stained glass creations. Objects and characters will be needed in your design, but the artists will be given a freedom to create them (see Pedersen Principle 3 in Chapter 2).

The designer must supply the artist with samples of environments, layouts of the UI (user interface or what the player sees), and maps of the terrain or world. Later we talk about research that you, as the designer, must provide the staff regarding your game (see Chapter 7, “Research”).


Game Designers Are NOT Audio Engineers or Musicians

You are the designer and not a songwriter, composer, or sound effects person.

Your job is to tell the audio engineer and music people the places where there is to be music and sound effects in your game or world.

Through research you will be able to describe your thoughts and possible audio examples of music style (jazz, classical, or rock), music moods (excited, calming, or scary), characters’ desired voices (famous voices or dialects like British, Southern American, Spanish), and sound effects (based on player’s input or gameplay reactions).


Game Designers Are Visionaries

You are the Creator, the life giver, and “God” of your game.

The game is a dream running inside your head that needs to be expressed to others. Publishers, developers (producers, programmers, graphic artists, and audio specialists), and even yourself need to see written documentation describing your fantastic vision, your concept. You need to map out the playing field, describe the rules and features that make your concept unique and special, and resolve the potential unknown and empty areas (an area of unforeseen paths).

No one else can make these “God-like” judgements and additions to your vision. Your decisions should be free from technology, free from any limitations of the developer’s ability, and able to go outside the boundaries of today’s thinking. This is your innovation, your vision, your genius.


Chapter 2: Pedersen’s Principles on Game Design

Since 1983 I have worked in the computer and video gaming industry in various roles including executive producer, producer, game designer, technical director, and programmer. Throughout the years I have learned many principles from my years of industry experience. In keeping with my philosophy that game developers should share and exchange information relevant to our industry, I present ten principles of game design and production that everyone in the industry should be acquainted with.

Principle 1: Understand the Role of the Designer and Producer

It’s vital to know what lines of responsibility are drawn within game development organizations. This knowledge gives you an understanding of which people are responsible for which game components, who makes design and production decisions, and so on.

The game designer. The game designer is the visionary, somewhat like a book’s author. This person has outlined the scope and description of the product with sufficient detail so that others can understand and develop the product. Just as a book author sees his creation develop differently when made into a film, the game designer needs to accept and solicit modifications from the team members, the publisher, and the public during the development process. Often one of the game designer’s tasks is to create the project bible—the game’s lengthy design specification. This document details the gameplay, describes characters and settings (possibly including diagrams or drawings), includes level descriptions and possibly maps of areas to explore, positions and actions for each character or class of character, and so on.

The producer. The producer is the project’s manager, its champion.

The producer must keep the entire team productive and the lines of communication open. This person is a diplomat, a politician, a troubleshooter, a force needed to produce the product. The producer must keep marketing, advertising, and public relations teams up to date with the progress of the game and be honest about its features, performance, and other claims that will be made to consumers. These teams must understand the gameplay, its features, and the story line to generate great ads, media hype, magazine previews, and so on. In return, these nontechnical team members, by virtue of their continuous contact with the public, provide the game developers with feedback from the public, magazines, and retail channels about what features are currently hot in games.

The producer needs to facilitate communication between the whole team and provide timely support for each developer, which includes ensuring that:

  • Artists and animators provide artwork, animations, and temporary placeholders to the programmers on time, until the final artwork is available

  • Programmers provide the artists with current versions of the game so they can see their artwork in a real-time gameplay mode. The producer must also make sure that the programmers provide a current version of the game to the sales, public relations, and marketing teams, along with various reports about the latest version of the game. These reports describe gameplay, special features, hardware requirements and supported hardware and peripherals, and contain screen shots that best portray the product for ads, promotional sheets, previews, and reviews for magazines. The producer also needs to make sure that programmers work with the quality assurance (QA) testers and provide them with the play instructions, special key combinations, hints, and undocumented features and actions.

  • Audio and sound engineers provide voice, background, and atmosphere sounds and music. These engineers also need to view and play the current version to check and validate the timing, usage, and clarity of their work.

  • The designer (if not a member of the day-to-day team) sees the current version to confirm that the product is in line with the design specifications and the concept originally set forth

  • The QA testers report problems to the producer. The problems must be categorized as major (crash, function or action not working), minor (text misspelling, character movement too fast or slow, response time feels wrong), glitches (sound or graphic problems), improvements (add a new feature, improve the character’s interaction or behavior, clarify a confusing aspect of the design or gameplay), a videogame standards issue (the triangle button does not perform as the standard function definition), and multiplatform inconsistency (PC version vs. video game version).

Whether one person assumes the role of both producer and designer or several people handle these tasks, there must only be one producer whose word is final, whose decisions are followed, and whose leadership is trusted and motivating.


Principle 2: No Designer or Producer Is an Island

Gathering information throughout the product development cycle and knowing what to do with it is the trait of a great designer and producer.

Designers should research their subject matter and evaluate outside suggestions and opinions. The audience demands and expects films and books to seem realistic and accurate. The computer and video game audience should accept nothing less.

When undertaking the development of a sports game (e.g., baseball), a designer may feel that he knows the sport from playing it and viewing it on TV. However, much more research must be undertaken to create an immersive experience for consumers. Whether the game genre is sports, RPG, adventure, or simulation, the first step is to research similar titles in that game’s genre. You can do this by surfing the Internet, visiting the local store and purchasing competitive games, reading reviews of similar genre titles, collecting marketing materials and advertisements from other publishers’ web sites, and so on. This information is invaluable when you are designing a new product.

If you are the producer of an upcoming baseball game, you ought to know the common elements found in other baseball titles, as well as special features that differentiate each product from its competitors. You should read reviews of similar titles and the competing titles’ list of features. From this freely collected information, a designer can understand the features and gameplay customers expect, special features that the competition offers, and the criteria upon which the reviewers will base their critiques.

As the designer and/or producer, you must ask yourself:

  • Does your game suffer the same poor or awkward design flaw as a previously released title or similar genre titles? The design of the game needs to address how to be better than its competitors. The design must be able to handle flaws, difficulties, and problems that reviewers and customers have complained about in previous versions of this product or in other similar genre titles. As the decision maker, you must listen to your development team, your marketing and sales team, retailers, and your game-playing audience.

  • Do the ideas of the game designer and team outweigh those of the reviewer(s)? The ideas that are formed must have a good foundation. All reviewers try to accurately explain and criticize the product to the public. There’s a real difference between discarding a reviewer’s opinion and listing the problems and how your design addresses each one.

  • Does the design consideration include comments from previous or potential customers? Customers enjoy great products. My experience (in producing sports, gambling, and trivia/puzzle titles) indicates that customers (fans) will buy any product in the genre they enjoy. Their expectations are that your product will teach them something new about the activity, they will gain experience and be able to brag to their friends and associates, and/or they’ll be able to someday beat the game. I’ve received a great deal of fan mail in which consumers have cited the aspects of my games that they enjoyed. These letters also tell me what additions to the game they would like to see in future releases. Magazines publish readers’ letters that praise and criticize the products. Market research and beta test groups of potential and previous customers can be worthwhile in the final design stages to tweak the product before its release.

  • Are the team’s ideas and opinions seriously evaluated in the design of the product? See Principle #3 for more information about this.

  • Can the addition of a feature expand the customer base and get more publicity? In Villa Crespo Software’s Flicks, a product that reviewed 30,000 films, a field for “close-caption” was added during the development, instantly adding four million members of the hearing-impaired and non-English speaking audiences to the product’s customer base. Newsletters reaching this consumer sector gave the product free, positive reviews because the product included information vital to their readership.

The producer should collect information from team members about improvements that can be made to the product and relay this information to the designer. The producer must be able to recognize a good idea when he hears it and implement that idea in the game to make it a better product.

Designers should be adaptable and open-minded to ideas that can make their games better. Producers need to be managers, leaders, and diplomats who are able to take information from others and incorporate good suggestions in the final product. These new ideas must then be communicated by the producer and understood by all involved.


Principle 3: Let Professionals Do Their Jobs

Most projects have a team of talented professionals made up of designers, programmers, graphic artists, audio technicians, testers, marketing coordinators, and so on. Each of these team members brings his own unique, important talents to bear on the project. A producer and designer must rely on these professionals and their particular points of view to improve and facilitate the development process. Regardless of the product’s genre, each member can make a product better.

For instance, the quality assurance (QA) and testing people can suggest gameplay improvements before the product is shipped. No member of the team plays the game for hours at a time like a QA person does; therefore their suggestions are similar to that of the potential customer. In fact, members of the QA team have probably played more games in a particular genre than the rest of the team combined.

The producer must not only trust the team members but also rely on them for input to create the best product.


Principle 4: KISS (Keep It Simple, Stupid)

Every aspect of a product should be obvious and easy to understand.

For instance, allowing players to access every option within two button clicks may be simpler than having 37 unique keys to press. Forcing a player to press Alt+Ctrl+Shift A to get his character to kick an opponent would be ridiculous. Likewise, having to press “A,” “B,” “C,” and “D” to control the movements of an airplane in a flight simulator would drive the average player crazy. If a player has to repeatedly press four keys to perform a task, the game design should include a superkey or a one-key macro to simplify the operation.

Keep design interfaces simple. I once designed games for an arcade manufacturer, and the president of this company taught me a valuable lesson about design. He said if a player doesn’t grasp the interface of a computer game or video game, that player will read the manual since $50 (or so) was invested in the game. With arcade games, however, the player has only invested a quarter or two, so if the game isn’t understandable, addictive, and compelling, the player moves on to the next machine. Who cares about wasting pocket change? While this is especially critical for arcade games, I think it’s important to remember when designing games for any platform.


Principle 5: Schedules Are Like Laws

Schedules are like laws; they are created by legislative bodies and meant to be obeyed, but they are also designed to allow exceptions if evidence warrants special circumstances.

Likewise, milestones created at the beginning of the project may need to be changed based on problems that occur during development. For instance, the decision to change the original game specification (e.g., to support a new computer, a new 3D card, alter preplanned artwork or audio clips) in order to make a better product is a situation that may warrant “breaking the law” of the schedule.

If another month of development time would greatly improve the gameplay, remove non-show-stopping bugs, or allow for better visuals or audio effects, then circumstances justify deviating from the schedule. To ship a game on a target day, month, or year, regardless of the state of the product at that time, can spell disaster for that product (not to mention the harm it does to the publisher’s reputation). Missing seasonal dates like Christmas is bad, but shipping a buggy or poorly made product is worse.

You should only modify a project schedule if there are valid reasons. The team and publisher must agree that the additional time will substantially benefit the product.


Principle 6: The Yardstick: One Day’s Pay for a Week’s Worth of Fun

If a customer pays $50 (plus tax) for a game that I’ve worked on, that amounts to the average person’s one-day net pay. (A person earning $21K a year brings home around $14K, which is $54 a day.) If the player reports enjoying the game that I worked on for at least one week, then I am happy. If the player feels ripped off due to poor game design, numerous bugs, obstacles in playing the game (e.g., multi-CD swaps, memorizing numerous keystrokes, and so on), poor audio, or some other problem, then the game designer and any team members who knew of these problems beforehand are to blame.

Every member of the team should be proud of their product. They should consider the praise from consumers, reviewers, and the industry as their reward for the time and work they spent on the game.


Principle 7: I Never Met a Genre I Didn’t Like

A student who doesn’t enjoy math can study hard and still earn an “A” in class. Similarly, a designer or producer does not have to have experience working on a particular genre. The producer can educate himself to create a good game within that genre. In fact, a designer or producer doesn’t have to even be an enthusiast of that genre in order to get good results. Putting together a team in which at least one member enjoys the genre (or studying competing products of the genre) is the critical part.

Often just one enthusiastic team member can show similar games that he has enjoyed and thereby turn every team member into a knowledgeable player of the genre. Combining fanatical genre loyalists along with non-genre players on the development team can result in benefits you may not have considered. For instance, a non-genre player can suggest modifications to a game’s design by pointing out aspects of the genre he finds unappealing, whereas a fanatic of the genre can lend his expertise and advice to keep a game faithful to the genre.

A knowledgeable developer or producer may ask the entire team to play similar games in that genre and ask each team member to critique the products. This technique can help the development of your product, and it’s time well spent.


Principle 8: Be True to Your License

Games based on licensed products often cause players to make certain assumptions about those titles. There are preconceptions about the gameplay, content, and target audience. In stores, it’s the licensed titles that get noticed first, regardless of their marketing and advertising. Game designers must understand this customer mentality. The designer must understand everything about that license in order to provide the kind of entertainment that the target consumers have anticipated.

For instance, a baseball game that uses a particular baseball team’s manager in its title suggests a strategy sports game. Players would probably assume that they would be responsible for making decisions about the players and batting order. On the other hand, a licensed product linked to a professional baseball player would suggest an emphasis on sports action, such as pitching and batting.

There’s one reason why licenses cost big bucks. Designers and producers must use the license and the game’s characters to leverage consumer preconceptions to the title’s benefit.


Principle 9: Share Your Toys!

Throughout the years, many game developers have bounced ideas off me, asked me questions, and so on. I have, and will always, welcome these inquiries because I believe it’s for the greater good of the industry. Since I have always been interested in creating and exploring ideas, I’ll gladly help when someone wants information. Three occasions in particular are worth relating:

  • In 1985 an auto mechanic who owned an Atari 520ST called me to pick my brain about game design and various game projects that he was working on. For several months we talked, and he often sent me samples of his artwork as well as demos of the concepts we’d discussed. Sometime around 1987 he had an interview with a major publisher and discussed taking the demos and artwork with him. I encouraged him and wished him success. A few weeks later he announced that he was hired as a “platform level” designer. Within months he became the top “platform level” game designer for this company, and he worked on the most well known titles in the industry. He eventually left this publisher to join another equally large publisher as the head of game design. He appeared in several magazines displaying his platform level designs. To this day, I’ve never met him and have only seen him in the magazine articles that he sent me, but I feel happy that I was a small influence in his life and in the industry.

    Today he writes a column for gaming sites like Gignews.com helping other “wanna-be” game designers.

  • When I was working on All Dogs Go To Heaven, a game for the PC and Amiga based on the Don Bluth film, I met a young man who worked at an arcade. On several occasions I gave him $10 in tokens to show me the latest video games. As he played, I observed him and asked questions like, “How did you know to do that?” After we got to know each other better, he showed me several comic book sketches that he had drawn, which were great. When I was contracted to produce and develop All Dogs Go To Heaven, I asked him to do all the artwork. Since he was new to computer graphics and animation, I taught him the mechanics of using a Summagraphics tablet and the functions and features of various graphics packages. He learned quickly and produced some of the finest artwork that CGA (four-color palette) and EGA (16-color palette) would allow. After the release of this title, he went to work for a Florida publisher as a computer and video game graphic artist. When the company moved to California, he moved with them. The last I heard, he was moving on to one of the big publishers as a senior graphics person.

  • A high school student sent me a concept for a game show. The description read well, but the demo he sent me was terrible. Over several months on the phone, we fixed many of the game’s rules and aspects of the gameplay, which greatly improved the game show. I programmed the game and hired an artist to provide the graphics. When I went to Villa Crespo Software outside of Chicago, we published this game show, which we called Combination Lock. The game was fun to play, and it was the first product to feature on-screen players of all races. The high school student and I shared in the profits for several years.

The reason I relate these stories is that I want to emphasize the benefit to those who help budding game developers. When the opportunity to help someone comes knocking on the door, offer that person hospitality and kindness. The results will benefit the “seeker of knowledge,” honor you, “the master,” and benefit the industry as more creative thinkers join in.


Principle 10: There’s No Magic Formula for Success

Keep in mind that no one individual or company of any size has discovered the formula for what makes a successful product. Like film, art, and music, games appeal to a variety of consumer tastes, and of course taste is subjective.

Some developers of past hits have credited their success to the underlying technology that their game used. Other developers claim that their game transports the player into a surreal and immersive universe. Yet others feel their game’s success is due to the way it engrosses the player in a realistic simulation and challenges them with its compelling design. Behind each successful title is a unique list of traits that made it popular with consumers.

The bottom line is simple. A well-designed product based on a team effort with a simple, user-friendly interface developed within a reasonable time frame will be successful.


Chapter 3: War Stories

The following stories are passed down to you as game industry folklore. The truths they reveal to future game designers are more important than their accuracy.

Lesson One

Click To expand

In the late 1990s Acclaim Entertainment licensed the movie Batman Forever to be developed as a video game. The movie was to be a major hit with hot stars like Michael Keaton as Batman, Jim Carrey as the Riddler, and Tommy Lee Jones as Two Face. At the time, Acclaim was among the top video game publishers in the world.

When I was hired at Acclaim as producer and then executive producer, many staff members including producers, assistant producers, and QA (quality assurance testers) had protested the release of Batman Forever due to extremely poor gameplay.

Management wanted the game released to coincide with the movie’s opening. They felt that the reputation of Acclaim and the anticipated success of the movie would be the selling point and that gameplay was least important.

The Batman Forever video game almost destroyed Acclaim Entertainment. Their stock plummeted, they lost millions of dollars, and a large percentage of employees (including the author) were laid off.

Lesson: Nothing is more important than gameplay.


Lesson Two

In March 1997 an experienced game designer, John Romero, from the team that created the first-person shooter Doom, and his staff (equally famous and talented) began Daikatana (a Japanese word for “big sword”).

Like Doom, Daikatana was touted as the next super game. Its designer, John Romero, was quoted as saying “Daikatana is a super-fast, Doom-style blast-a-thon. If people don’t like it, they don’t need to buy it.”

Daikatana was an FPS time-traveling game that was marketed early on by publisher Eidos Interactive. The ads that ran in magazines stated, “John Romero’s about to make you his bitch. Suck it down.” With delay after delay and two years late, reports of staff conflict and mass exodus of team members didn’t help, and the public’s anticipation turned sour. Romero’s attitude of “Damn the lot of you” was not the way to turn the situation around.

A release in March 1997 of Daikatana would have had the game ahead of the pack in gameplay and technology (using the Quake 2 engine). Being released two years later with the Quake 3 engine available, the game seemed simple and not what one would expect from the hype and its famous designer from id Software.

Lesson: The Dream Team can easily turn into a dictatorship nightmare. (See Pedersen Principle 2: No Designer or Producer Is an Island.) A designer must respect the team and the audience. “Hard work and great gameplay, not hype” should be written on the designer’s wall.


Lesson Three

First Row Software’s The Honeymooners game took a great license and produced a game with poor gameplay. The game was designed with several mini-games featuring Ralph and Ed. One game had Ralph driving the streets of New York in his bus picking up various passengers throughout the city. For some reason, the designers had Groucho Marx as one of the random passengers. This gimmick not only added nothing to the game, but the publisher was in violation of copyright and trademark infringements since they had not received permission to use Groucho.

Research and double-check your sources for story lines, artwork, and sound (especially sound bites).

Lesson: Research is critical and must be accurate. Don’t take anything for granted.


Lesson Four

In Capstone/Intercorp’s Search for the Titanic, the player reenacts the discovery of the Titanic.

One of the gimmick features of the game was that the first player to solve the adventure would win a valuable prize. Obviously, the designer didn’t want players winning too soon, so the game was made with one extremely difficult level of play.

Just before the game’s release, the licensor, upon learning of the “prize” gimmick, demanded that it be removed. The game was released as a tough, almost impossible adventure to solve.

Reaction: Think of designing a Titanic game with multiple levels from novice (easy) to championship (prize-worthy tough). Perhaps the player can master the controls and map out the underwater terrain in the easier levels. In the harder levels, new areas of exploration open up and there are new objects to discover.

This multilevel design approach would work whether the “prize” gimmick was offered or not. For a player to purchase and spend time playing an extremely tough game is just frustrating and wrong. Players who have conquered lower levels of play and then are elevated to an extremely tough level feel they have earned the right to be frustrated.

Design multiple levels and options of play in your game. When heading toward an iceberg, avail yourself of multiple options well in advance. Having only one option, just a straight path through the iceberg, may leave you with a “sink or swim” result.

Lesson: Design multiple scenarios for playing and winning the game. Don’t let gimmicks sell the game, let good gameplay sell it.


Lesson Five

Patton from Broderbund was designed by legendary game designer Chris Crawford. He reasoned that war games are fun, yet only a small percentage of game players are buying them.

Perhaps that would change if there were a new type of war game designed for the non-wargaming audience. If the game were easier to use, different from the standard hex-based war games, it would reach a larger base of players.

This seemed reasonable; in fact testers seemed to confirm these thoughts. So what could possibly go awry? Well, first, the sales and marketing people failed to express this new type of “war game for the rest of us” concept. Next, the magazines assigned their “war game” experts to review Patton. These experts were not the intended audience, so they knocked the game for lacking the standard controls, not having hexes, and lacking the NATO markings. Then, the expert war gamers warned the novice players away from Patton.

Lesson: Sometimes the obvious isn’t worth anything.


Lesson Six

In the late 1990s Southpeak Entertainment showed me a licensed game design involving the cartoon The Jetsons.

The Jetsons game was a standard space racing game using the characters as drivers. My response was “What a waste of a great license and a real disappointment for Jetsons’ fans.”

I suggested a Jetsons space road rally game where each player as either George Jetson, his wife Jane, his daughter Judy, his son Elroy, the dog Astro, or Rosie the robot housekeeper would navigate their space car throughout the Jetsons’ world, looking for clues leading to various objects to collect.

Licenses attract an audience who know the property, its characters, venues, storylines, and interactions. Licenses are valuable assets that need to be exploited as an advantage in your game.

Lesson: Use to your advantage your license and its fans.


Chapter 4: Game Concepts

Games Are NOT Linear

Books and movies are linear forms of storytelling. They have a straight path from the beginning to the end.

There have been numerous attempts in both mediums to allow the reader or viewer to select the next path leading to one of several endings, but I would say these attempts are trying to be more “gamelike” (nonlinear).


Games Have a Goal

The goal in chess is for one player to force a winning situation by “checkmate” or having the opponent resign (quit).

The goal in many sports games is to outscore the opponent.

The goal in Othello is to occupy the most spaces on the board.

The goal in a game where you oversee a city or a planet may be to restore balance to a chaotic environment.

Other noteworthy goals for future games might be based on “losing for a greater good.” Like in the film Brewster’s Millions, Richard Pryor must become penniless to inherit the family fortune. Each turn the player receives a set amount of money to invest unwisely, and after a set number of turns, the player must be broke.

Other altruistic goals could be the game’s goal, like “self sacrifice,” “helping the less fortunate,” or “giving up all worldly possessions for a cause.”


Games Must Be Winnable

Only a fool would agree to play the “Heads I win, tails you lose” game.

Almost as bad would be a game where you need to roll dice three times and get a twelve (two sixes) each time to win. Winnable? Yes. Worth playing this game? No (winning odds are 1 in 46,656).

Design the game to be winnable or winnable through multiple paths (easy to hard).

In a multiplayer game, give each player equal strengths and weaknesses at the start. A good game lets each player have an equal chance and ability to win. You should spend time and pay attention to designing balance in your game.

Let random events and the player’s decisions and actions determine the new game situation (player’s current position).


Start of the Game

All games have the players in some initial position or setup. In chess, it’s the opening position of the 16 white and 16 black pieces. In a world domination or strategy game, it’s each player’s currently occupied terrain. In a role-playing game (RPG), it’s the adventuring party consisting of various races, skills (magic, fighting, learned skills like locksmithing), and occupations (soldier, priest, blacksmith) preparing to start a quest.

In a sports game, it’s the team’s or player’s starting formation or position. In an adventure game, it might be a puzzle to solve or deciding which direction to initially explore. In a puzzle game, it’s the initial setup of the puzzle’s challenge.

Perhaps the game could be designed to have a random start position. Some games can be unbalanced, allowing the more skillful player to have a handicap in the initial position.


Middle/Ending of the Game

Whatever the game type, there should be numerous paths for the player(s) to take or random events to occur to move the player(s) along and finally determine the winner(s).

Many games (for example, “adventure” games), give the player(s) a score at the end of the game. The game’s main goal is to finish the assigned quest. The game’s secondary goal is to better your previous score(s) and eventually earn the perfect score.

Puzzle games could reward the player with a password that would allow them access to higher levels.

In games, the goal is to win, but in many games tying (drawing) or losing a well-played game against a much stronger and skillful opponent is a rewarding and satisfactory outcome.

When designing your game, think about your audience, the challenges and hoops you’ve put them through to reach the final plateau, where they now stand awaiting their reward. Design an ending worthy of a winner and acceptable to the non-winner who has just finished your game.

Fireworks. A ticker-tape parade. The cheers of millions. These may seem overboard and silly, but to a traveler who has spent time journeying across the game you’ve designed, the spectacular ending is a marvelous reward and justly warranted.

Think of your gamer as the conquering hero who is entering the city to pay homage to you, the designer, or the parade for the sports team that has won the national championship, or the audience’s excitement and atmosphere before an encore at a concert.


Chapter 5: Game Genres

When describing a game to others, you must express its genre or type. Genres can fall into categories like action, adventure, casual, educational, RPGs, simulations, sports (including fighting games), strategy, and other (puzzle games and toys). Many games cross genre boundaries (“hybrids”) or are truly several genres in one.

Some games, like RPGs or adventure games, have been labeled by the game’s point of view (POV). A “first-person” POV is viewing your environment through the lens of a video camera. A “third-person” POV has the player’s character or persona in view as though a video camera is following the character’s movements. In the third-person POV, the video camera may be stationary (like on a tripod) or free moving, showing various angles of the player. First-person shooter (FPS) is another way to describe the POV for combat/shooter games like Doom or Quake.

Action Games

Action games are nonstop, finger flying (“twitch”) games.

In the early games, arcade-style action games involved shooting vector spaceships to dot-munching balls. Later came “platform,” “rail,” or “side scrollers,” which dominated the action game genre. Now, FPSs are the current trend in action gaming.

Action games have always been move, attack, move, react, and move again type games. They revolve around the gamer who is always central to the play and in control. During an action game, action is the emphasis, not storytelling. Action games will use pre-game “splash” screens and animation as well as interlevel screens to tell their story. Even in an FPS, the main emphasis is action by fighting, gathering weapons and ammunition, shields, and objects like health and experience points.

The next genre for the multiplayer masses will be MMFPS (massively multiplayer FPS) where millions of Internet weapon-toting, truck-driving fans will swarm planet-sized terrain hunting huge alien monsters the size of dinosaurs.

Top-Selling Action Games:

PC: | Aliens vs. Predator 2, Clive Barker’s Undying, Max Payne, Operation Flashpoint: Cold War Crisis, Red Faction, Return to Castle Wolfenstein, Serious Sam: The First Encounter, Soul Reaver 2, Tribes 2, Zax: The Alien Hunter
Console: | Conker’s Bad Fur Day, Devil May Cry, Grand Theft Auto 3, Halo, Jet Grind Radio, Klonoa 2: Lunatea’s Veil, Max Payne, Metal Gear Solid 2, Phantasy Star Online v 2, Red Faction, Resident Evil Code: Veronica X, Return to Castle Wolfenstein, Spy Hunter, Zone of the Enders

Look for

PC: | Global Operations, Medal of Honor: Allied Assault, Planetside, Soldier of Fortune 2: Double Helix, Unreal 2
Console: | Spiderman


Adventure Games

Adventure games are quests where puzzles are presented along the journey.

In the early days of interactive gaming, adventure games ruled. They were easily ported from the mainframe computer paper output days to the low-resolution monitors of the 1980s microcomputers.

Gamers (in those days, computer “geeks” and “nerds”) loved Tolkien (author of The Hobbit and Lord of the Rings trilogy) and Star Trek, which were a prominent part of the first text adventure games from the mainframe era.

Soon many companies were formed and products hit the shelves based on text adventure games (no graphics, just text and your imagination). The stories were compelling and addictive.

As the computers advanced with more memory and better graphics, graphic adventure games appeared and became popular.

Computer gaming fanatics loved solving the designers’ tricky puzzles. But eventually the other genres began to win the consumers’ popularity contest. In the late 1990s publishers and distributors had an “adventure games is dead” attitude.

Hybrid adventure games soon appeared, and out of the ashes several successful “adventure” games entered the realm of major hits and mega-sellers.

In an adventure game, you (the player) start with a limited inventory of supplies, weapons, and food. You are sent on a quest (to save the princess, free the slaves being held captive by an evil emperor, or find and return the Golden Fleece). Along the journey you are presented with puzzles to solve. The designer can make it an obvious puzzle or hide the puzzle within the story (but nevertheless it’s still a puzzle to solve). Usually all gameplay, storytelling, or advancement is paused until the puzzle is solved. A puzzle can be a physical puzzle (maneuver objects in a precise order, move an object, acquire an object, or build an object), a verbal puzzle (solve a riddle, discover the secret password, learn a phrase to say), a timing puzzle (perform tasks in a precise order or within a time duration), a labyrinth (maze) traversing, or a cavern exploration.

Most puzzles have one correct solution. I prefer to design puzzles with three solutions that I call “physical,” “intellectual,” and “reasonable” solutions. In Homer’s Odyssey, Ulysses is confronted by a Cyclops (one-eyed giant).

The physical solution is to fight the Cyclops. The two outcomes would be to either cause the Cyclops to submit and let Ulysses pass by or have the Cyclops defeat Ulysses, cause severe physical damage, and/or capture and imprison him, which would set up an escape puzzle.

The intellectual solution is to challenge the Cyclops to a game where the loser must drink an entire flask of ale. Eventually, one of the contestants would get drunk and pass out. If the Cyclops passes out (after drinking an enormous amount), Ulysses may pass by. If Ulysses passes out, he’ll awake inside the Cyclops’ prison with an awful hangover.

The reasonable solution is to walk through the miles of treacherous mountains free of Cyclops and monsters. This solution wastes valuable time but causes little physical damage.

Top-Selling Adventure Games:

PC: | Beyond Atlantis 2, Grim Fandango, In Cold Blood, Myst 3: Exile, Odyssey: The Search for Ulysses, Project Eden, Riddle of the Sphinx: An Egyptian Adventure, Road to India: Between Hell and Nirvana, Schizm, The Sting, American McGee’s Alice
Console: | Baldur’s Gate: Dark Alliance, Escape From Monkey Island, Ico, Oddworld: Munch’s Oddysee, Onimusha Warlords, Silent Hill 2, Soul Reaver 2


Casual Games

Casual games include games like board games, card games (gambling games included), and game shows.

Board games can include classic games like chess, checkers, Othello, and Go, as well as versions of retail board games. Board games are popular and addictive, as well as commonly known by a wide (mass market) audience. For instance, gamers may buy a chess program even if they don’t play chess just because they’d like to own a chess program (especially one that everyone is talking about). For the chess enthusiast, they may buy several chess programs because of the varied playing strengths, game features (Internet, various time controls and analysis features), or game gimmicks (a Civil War set where the pieces shoot and combat each other).

In the 1980s I developed several computer versions of popular children and young adult board games. The executives at these companies worried that the computer versions of their games would cannibalize (take sales away from) the retail toy sales.

In a phone conversation, I stated several key factors comparing the retail toy board game version with the computer version of their games.

  • The retail toy board game has sold in stores for many years and will continue to sell as predicted.

  • The computer version of their game:

    • will add additional revenue for them, a new market of customers owning computers, who most likely own the toy board game version.

    • will ensure that the gameboard and pieces will not get lost, which often happens to the retail toy version.

    • will ensure that players must follow the rules and cheating cannot happen.

    • will address each player by name and reward the player for successful interactions and through animation and sounds get/train the player to successfully complete his/her turn.

    • can be saved and continued at any time without setting up the board and pieces.

    • can be played by a solo player, perhaps an ill child home from school.

Game shows are addictive and popular. Everyone wants to be a contestant on his or her favorite show! Gamers can feel through sound and animation the thrill of being on a game show without leaving their office or home. They can play against “real” opponents (via networks or the Internet) or against the program’s AI (artificial intelligence). Intelligent gamers can feel successful by doing well and winning the game show’s prizes, cash, or whatever. Other gamers can practice and perform better without the embarrassment of performing poorly in the real world.

Licensing game shows is financially costly (all publishers are willing to pay for the rights of a successful show). The success of the game’s sales and market’s desire often depends on the success of the TV show and not how well the game’s designed.

Card games include trading card games, solitaire, cribbage, hearts, rummy, Old Maid, bridge, and all gambling games (poker, blackjack, keno, slot machines, roulette, craps, and baccarat). Card games are similar to classic board games in that gamers want to own good versions (good skill level or interesting features) of these games.

Gambling games have a unique attribute in that gambling gamers are always seeking an edge against the casinos and their poker night buddies. They believe that if one gambling game teaches you one expert strategy, then buying another isn’t repetitive but may teach you another much needed lesson.

Besides entertaining gamers, casual games can train, educate, and improve the gamer’s knowledge and skill level.

Casual games have a mass-market audience that knows and understands the product based on its name and package graphics. They have a longer shelf life than this month’s popular game. Publishers and developers can easily understand the game’s concept and concentrate on the game’s features and graphics.

Top-Selling Casual Games:

PC:

Chessmaster 9000, Hoyle Board Games, Lego Creator: Harry Potter, Monopoly City, Reel Deal Poker Challenge, Survivor Outlast: The Interactive Game, Weakest Link, Who Wants to Be a Millionaire Platinum, You Don’t Know Jack 2001


Educational Games

Educational games emphasize learning. They are designed to teach or reinforce a learned concept. Educational games look like games of other genres, but they are their own genre because they emphasize education.

The most basic (and to me, boring) educationally designed game would be text exercises like fill-in-the-blank, multiple choice, or essay. With a little imagination, you could turn the multiple-choice game into a fun gameshow where the host asks the student an educational-oriented question and correct answers earn points or virtual cash.

History games could be turned into adventure games or RPGs, where the student plays the key character and must answer relevant historical questions or resolve a historical situation properly.

English games could be graphic stories with relevant questions that when answered correctly proceed to the next chapter.

Throughout my career I have developed many educational games.

Educational Game as an Adventure Game

In 1983 a major book publisher had me design and program several games that were to accompany their new school textbooks. World-Wide Reporter was a game where the player, as a top-notch reporter, was sent around the world to get the scoop on headline stories. Based on 50 cities covered in the accompanying textbook, over 20 facts about each city were saved as clues. The student would receive one to two clues about a city and a clue about the story to cover. At the airport, the student would see five cities to fly to and had to select a city. If they understood the clue(s) and flew to the right city, they’d get another clue for the next city. If a mistake was made, additional clues were given directing them to the right city. After the student had traveled to five cities, he would receive one of several citations and make front-page news (student’s name in huge, bold letters).

Let’s say you’re interested in chemistry and would like to create a fun and educational chemistry game. In your travels adventuring throughout the human body, you need to find “nitrogen.” In your inventory you have a container of carbon dioxide. The player would have to figure out or know that the carbon dioxide is comprised of carbon (atomic weight 6) and two oxygen (each atomic weight 8) and the sought-after nitrogen has an atomic weight of 7. The player would examine each element found and weigh it against the carbon and the oxygen. Nitrogen is the only element heavier than carbon and lighter than oxygen. This design could make learning chemistry (the atomic weights and names) interesting and fun.

Educational Game as a Sports Game

In 1984 I designed and copyrighted two math titles, Mathathon and Geomnastics. In Mathathon, the student was a marathon runner and competing with a dozen computer opponents in a race. The goal was to finish in first place by quickly and correctly answering algebraic math questions (addition, subtraction, multiplication, division, and quadratic equations). Every quarter mile of the 26.2-mile distance, the student was presented with an algebraic question as the player’s runner ran in place or drank some water. The student was given ten seconds to answer the problem. If the correct answer was typed in, the runner would continue to race. Otherwise, the problem would be partially solved and the student would have ten seconds to answer it. This would continue until the correct answer was entered by the student or solved by the game. When the race ended, the winner was placed on a pedestal with the player’s name prominently featured as music played. A list of missed problems could be reviewed or printed.

In Geomnastics, the student was to choreograph a balance beam routine by selecting beam maneuvers and answering geometry questions. Each balance beam maneuver had a difficulty level and a geometry question of equal difficulty. After an entire routine was created and the geometry questions answered, the student would see his choreographed routine performed. After the routine, the five judges would give the gymnast a score from zero to ten based on the correctness of the student’s answers, the difficulty of the problems, and the time duration it took to answer the questions. The student could replay his routine, checking each problem with the correct answer. If the student received high marks from the five judges (45 points or better), he would receive a gold medal. Silver and bronze medals were awarded to lesser scores.

Educational games have become more interactive over the last few years. They now have graphics, sound, and gameplay on par with the other genres. Many educational titles have linked themselves to licensed properties like TV shows, cartoons, and films.

Top-Selling Educational Games:

PC:

Barbie Secret Agent, Blue’s Clues Learning Time, Cosmopolitan Virtual Makeover 2002 Deluxe, Oregon Trail 4th Edition, Shrek Gameland Activity Center, Tonka Dig n Rigs Playset


Role-Playing Games (RPGs)

Role-playing games (RPGs) are vast worlds to explore where parties of players roam the terrain seeking treasures, objects of desire, and ways to increase their experience and health status and destroy monsters and obstacles that get in their way.

RPGs started as dungeon crawls through paper labyrinths created by “masters” (dungeon designers). A master would create an elaborate labyrinth filled with traps, monsters, and evil magic. The party would enter the maze armed with individual skills, magical abilities, and weapons. On each turn the party would try to outwit, outspell with magic, and outfight the master’s creation.

The world of the Internet has enabled millions of RPG fans to explore larger terrain and more exotic quests. The acronym MMRPG stands for massively multiplayer RPG, a game in which parties of friends or groups from around the world form to explore, collect, and fight other parties and monsters. MMRPGs have numerous parties, each on various quests and with their own goals.

An RPG has a specific goal, and after many hours of play, there is an ending. MMRPGs may have no specific ending and can be played until you’ve completed all the quests or until another MMRPG or Internet game requires your time and attention.

RPGs are not limited to Tolkien-type storylines. Space stations, the Ice Age, 15th-century European exploration, the discovery of the Americas, and futuristic scenarios can all be viable venues for an RPG. Even life today could be used, such as life in a foreign country, life on an Indian reservation, or life in an Amish community.

Top-Selling Role-Playing Games:

PC: | Anachronox, Anarchy Online, Arcanum: Of Steamworks and Magic Obsura, Asheron’s Call Dark Majesty, Baldur’s Gate 2: Throne of Bhaal, Dark Age of Camelot, Deus Ex, Diablo 2 Expansion Set: Lord of Destruction, EverQuest: The Shadows of Luclin, Summoner, Wizardry 8
Console: | Dark Cloud, Dragon Warrior 7, Dungeon Siege, Final Fantasy Chronicles, Final Fantasy X, Neverwinter Nights, Paper Mario, Pokemon Crystal, Tales of Destiny 2
Look for |
PC: | Dungeon Siege, The Elder Scrolls 3: Morrowind, Neverwinter Nights


Simulation Games

Simulation games (or sims) let gamers experience real-world situations from a safe, practice area. Since the 1950s, the Department of Defense has trained the military with computerized simulators like flight sims, tank sims, and wargaming sims (missiles launching and combat).

Simulations are exciting and have a real world feeling to them. Most of the real-world applications we are trying to simulate would be extremely dangerous and very expensive outside of the computer. Navigating and reproducing practice scenarios are more practical and easier to set up inside a simulator.

Simulations can be classified as either a “vehicle simulation” or a “managing simulation.” Vehicle sims are trucks, cars (stock, Formula-1, high-performance), airplanes, helicopters, boats, submarines, spaceships, space stations, motorcycles, and so on. Managing sims include managing a nuclear power plant, a brokerage company trying to predict the stock market, being mayor of a city or president of the United States, being owner of a golf club, being manager of the city zoo, being Emperor of the Roman Empire, being owner of an amusement park (rollercoasters and rides), and even managing the lives of families or ant colonies.

Many gamers dream of sitting in a Formula-1 racecar with the engine purring as the green light signals the start of the race, and then driving at high speeds of 200 mph around the track until the checkered flag waves them in as the winner.

What about the car crashes that we often see or the high-speed turns that sometimes slam cars into the wall? How can a driver safely practice against these obstacles? Drivers can’t really practice driving expensive Formula-1s at various tracks in various weather conditions. This is where a good simulation becomes valuable. Even the novice drivers can access racing simulations and live out their dream. Scenarios can be set up for various weather conditions like rain, fog, snow, or hot, dry heat. Various car situations can be set up like various tire, radiator, or engine conditions. The drivers can practice turns and curves at various speeds without the fear of injury to the car or themselves.

The key to vehicle simulation is realism, quick and accurate responses to the gamer’s input and the situation being simulated.

There’s an old, comical story that goes…

Aboard a commercial flight from New York to Miami, the pilot passes out. The flight attendant enters the passenger cabin and announces, “The captain has passed out. Is there any passenger on board who has experience flying a jet? Possibly someone who flew jets in the Air Force?”

No one answers.

The flight attendant again pleads to the passengers, “Does anyone have a pilot’s license, either commercial or private?”

Still no one answers.

Hopelessly, the flight attendant again pleads, “Has any passenger scored above 300 points in Microsoft’s Flight Simulator?”

Yes, simulators have gotten that good. In fact, many flight simulators running on PCs can be used to log flight hours for private licenses. Gamers can learn how to use the airplane’s controls and instruments, lift off and land an airplane, and navigate it in the simulation. They can make mistakes and test normally dangerous situations like stalling, flying upside down, or spiraling downward without the fear of injury and costly damage. Scenarios can be safely tried and retried. Reading from a manual about the “how-tos” and “whys” is fine, but trying an action and failing is a better reinforcement of the concepts. Simulator pilots can crash and live to tell about it.

In a simulation, we can fly anything from a Cessna to an F-18 jet. The first PC F-18 jet simulation was so accurate and realistic that (the story goes) the military advisors forced the developers to reverse the controls.

The Apollo 13 astronauts practiced their procedures using a simulator weeks before the launch. When Apollo 13 experienced trouble, it was the backup team and the onground simulator that solved the problems and advised the crew in space how to get back to Earth.

Managing simulations have gamers acting as the U.S. president, making executive decisions that affect the entire country, reviewing Congressional bills, meeting with senators to vote for bills, interviewing with the press, and chatting with voters.

Some of the recent, most popular sims have the gamer acting as the mayor of a large city. As mayor you decide on issues like building and road construction and public safety like police and fire personnel.

Other sims are more concerned with overseeing a neighborhood and dealing with the daily activities of families and neighbors.

Regardless of the type of simulation you want to design, accurate research, realism, and fun gameplay are the critical issues to address.

Top-Selling Simulation Games:

PC: | Comanche 4, Echelon, Flight Simulator 2002, IL-2 Sturmovik, Independence War 2: Edge of Chaos, Jumpgate: The Reconstruction Initiative, NASCAR Racing 4, Operation Flashpoint: Cold War Crisis, Rally Trophy, Rowan’s Battle of Britain, Stronghold: Castle Sim, Sub Command, Train Simulator
Console: | MechWarrior 4, Freelancer

Look for

PC:

Age of Mythology, Earth and Beyond, Star Trek Bridge Commander


Sports (Including Fighting Games)

Sport games typically fall into two varieties: the player POV, also called “twitch games,” and the manager POV (strategy game). Usually the player POV version is designed for a younger audience (under 20 years old) where quick finger dexterity is more critical to gameplay. The manager POV audience is more concerned with planning, realism, statistics, and strategy.

Let’s look at several sports to design for using these POVs in each case.

In golf, the player’s POV game would have the gamer controlling the club selection, the club’s swing arc and velocity, and the contact with the ball. Various gamer interactions would be used to compute the outcome of the golfer’s swing or putt. The manager’s POV game would allow the gamer to select a proper club, have the ability to check the wind condition and terrain (banks and obstacles like sand traps, water, and tree areas), suggest the proper swing and velocity from a list of common settings, and determine the outcome of the golfer’s swing based on the selected criteria and real-world statistics.

In a baseball game, the player’s POV would allow the gamer to decide on several conditions. While in the field, the gamer would select a pitch type (curve ball, slider, or fast ball), interact to set the pitch speed, and aim the ball at a specific location in the batter’s strike zone. On a hit pitch, the gamer would have to maneuver the outfielders and decide who to throw the ball to as the play is in action. While at bat, the gamer would select the intended hit (desired power from a long high drive, hard hit grounder, or bunt) and through interaction respond to an incoming pitch. The gamer would also interact to force players to run to a base after a ball is hit and steal a base when desired. The manager’s POV game would be more concerned with setting up the starting lineup, determining substitutions and pinch hitters when needed, instructing batters when to hit away, play it smart, or bunt, and acting as a base coach and advise on leading, stealing, or advancing to the next base when the ball has been hit. The manager would select a starting pitcher based on his pitching cycles (a season view not a one-game view), select closing pitchers, and determine when to retire a pitcher. The manager gamer makes strategic decisions and lets the game handle the individual ballplayer’s responses based on these decisions.

In football, the player’s POV game would have the gamer maneuvering each of his team’s players on offense and defense. A play’s outcome would be the result of the player’s interaction. The manager POV game would have the gamer deciding on the offensive plays from a playbook and the defensive formations selected from a list. The play’s outcome would be decided by calculating the two sides statistically based on the offensive play, the defensive formation, and each team’s current lineup of players.

Fighting games are usually from the fighter’s POV (eye of the fighter) or third-person POV. Fighting games would include martial arts, boxing, wrestling, and weapons combat.

Top-Selling Sports Games:

PC: | Baseball Mogul 2002, FIFA Soccer 2002, Front Office Football 2001, Front Office Football: The College Years, High Heat Major League Baseball 2002, Mat Hoffman’s Pro BMX, NBA Live 2001, NHL 2002, Tony Hawk’s Pro Skater 2 and 3
Console: | Capcom vs. SNK 2, Dave Mirra Freestyle BMX 2, Dead or Alive 3, Fatal Fury Mark of the Wolves, Gran Turismo 2000, Gran Turismo 3, Guilty Gear X, Madden NFL 2002, Mat Hoffman’s Pro BMX, NBA Street, Need for Speed Motor City, NFL QB Club 2002, NHL Hitz 20-02, SSX Tricky, Tekken Tag Tournament, Tony Hawk’s Pro Skater 3, Ultimate Fighting Championship, Waverace Blue Storm


Strategy Games

Strategy games are games that require “thought” and “planning.” The game’s winner is determined through a “battle of the minds.”

Strategy games differ from other genres because the designer creates rules and goals, but it is the gamer who decides what strategy to use to achieve those goals and outwit the opponent(s).

War games are strategy games although they are simulations of actual or fictitious events.

Strategy games can be played as real-time or turn-based games. In real time, all players including the computer-controlled (AI) players are competing nonstop, simultaneously. In turn based, each player completes his turn before the next player begins.

A typical POV or perspective of strategy games is an overhead view to allow all players to see the entire playing area.

Top-Selling Strategy Games:

PC: | Battle Realms, Black & White, Capitalism 2, Civilization 3, Command & Conquer Yuri’s Revenge, Commandos 2: Men of Courage, Europa Universalis 2, Kohan: Immortal Sovereigns, The Sims, The Sims: Hot Date Expansion Pack, Tropico, Vietnam Squad Battles
Console: | Advance Wars, Hoshigami: Ruining Blue Earth, Kessen 2, Pikmin, Star Wars Rogue Squadron 2: Rogue Leader, Twisted Metal: Black

Look for

PC:

Republic: The Revolution, Warcraft 3: Reign of Chaos


Other Games (Puzzles and Toys)

Puzzle games have a simple goal, which is “solve the puzzle.” Gamers may have to unscramble a picture, keep dropping blocks until time runs out, complete a level, or maneuver pieces until they are placed into their correct location.

Toy games let the gamer construct objects such as building a virtual robot that you can command or building a remote control car to drive or an airplane to fly. Other toy games can be like a Rube Goldberg contraption where you construct an activity structure that uses an energy to start the flow and ends with a static state. Think of an enormous layout of dominoes standing upright. When the gamer knocks over the first domino, they all fall down in sequence until the entire array of blocks are laying static.

Gamers enjoy puzzle and toy games. Historically they are difficult to market since they are usually unique and publishers aren’t used to pitching them correctly.

Top-Selling Puzzle Games:

PC: | Bejeweled, The Incredible Machine: Even More Contraptions, MS Pandora’s Box, Ripley’s Believe It or Not!, The Typing of the Dead, Williams’ Pinball Classics, Ultimate Ride
Console: | ChuChu Rocket, Dr. Mario 64, One Piece Mansion, Samba de Amigo, Space Channel 5


Chapter 6: Game Ideas

Overview

At this stage, you understand the gaming genres and have an eagerness to become a game designer. You may now think that you still don’t have a clear vision of a game concept.

Well, you can always “creatively borrow” ideas from other sources and tailor them to your liking. Sources that are great to “borrow” from are books, movies, science, history, sports, art, and everyday life itself.

If ideas are truly worth a dime a dozen, there’s over $10 worth (1,200 plus ideas) for you to use as the basis for a game design concept in an expanded version of this chapter on the companion CD. Here is a sampling.


Sports

1 Archery

2 Arm wrestling

3 Badminton

4 Baseball

5 Basketball

6 Biathlon

7 BMX biking

8 Bobsled (and Skeleton)

9 Boogie boarding or bodyboarding

10 Bowling

11 Boxing

12 Cricket

13 Croquet

14 Cross-country skiing

15 Curling

16 Cycling

17 Darts

18 Demolition derby

19 Diving

20 Dog racing

21 Dog sledding

22 Equestrian

23 Extreme fighting

24 Fencing

25 Field hockey

26 Fishing

27 Football

28 Formula-1 racing

29 Golf

30 Gymnastics

31 Hockey (ice or roller)

32 Horse racing

33 Horseshoe pitching

34 Hunting

35 Ice skating

36 Jai alai

37 Jet skiing

38 Jousting

39 Judo

40 Karate

41 Kayaking

42 Kendo

43 Kung fu

44 Lacrosse

45 Luge

46 Miniature golf

47 Monster truck rally

48 Motorcycling

49 NASCAR racing

50 Paintball

51 Pentathlon

52 Polo (horse)

53 Pool

54 Quoits

55 Racquetball

56 Rodeo

57 Roller derby

58 Roller skating

59 Rowing

60 Rugby

61 Sailing

62 Shuffleboard

63 Skateboarding

64 Skeet shooting

65 Skiing

66 Snowboarding

67 Snowmobiling

68 Soccer

69 Softball

70 Speed skating

71 Squash

72 Sumo wrestling

73 Surfing

74 Swimming

75 Table tennis

76 Tennis

77 Tobogganing

78 Track and field

79 Trapshooting

80 Triathlon

81 Volleyball

82 Wakeboarding

83 Water polo

84 Water skiing

85 Wrestling


Board Games

1 Backgammon | 5 Go
2 Checkers | 6 Hangman (like Wheel of Fortune)
3 Chess | 7 Mahjong
4 Dominoes | 8 Othello


Card and Gambling Games

1 Baccarat

2 Blackjack

3 Bridge

4 Caribbean Stud Poker

5 Craps

6 Cribbage

7 Gin Rummy

8 Go Fish

9 Hearts

10 Keno

11 Old Maid

12 Paigow Poker

13 Poker: Draw Poker, Five Card Stud, Seven Card Stud, Texas Hold ’Em, Omaha

14 Red Dog

15 Roulette

16 Sic Bo

17 Slots

18 Solitaire

19 Spades

20 Video Poker

21 War


Simulations

1 Become a rock star | 21 Pilot an airplane: Cessna, 727, 747, F-16, F-18
2 Be a train engineer | 22 Be a brain surgeon
3 Pilot a helicopter | 23 Be a doctor: diagnose patients
4 Be an automotive technician | 24 Run a car rental company
5 Be a dentist | 25 Manage a cinema chain
6 Race a 4x4 truck | 26 Manage a cruise line
7 Build and operate a casino | 27 Operate a golf resort
8 Run a corporation | 28 Manage a major newspaper
9 Manage a gaming company | 29 Manage a pizza delivery restaurant
10 Manage a hospital | 30 Manage a resort island
11 Manage a movie studio | 31 Manage a zoo
12 Manage a railroad | 32 Manage an overnight delivery carrier
13 Manage a restaurant chain | 33 Run for president
14 Manage an amusement park | 34 Simulate a human internal disease
15 Manage a university | 35 Simulate an ant colony
16 Run for senator | 36 Operate a brokerage company
17 Operate a nuclear power plant |
18 Simulate the stock market |
19 Operate a semi-truck for cross-country delivery |
20 Drive a motorcycle across the country |


Science

Ecology

Biology

Chemistry

Chemistry topics

Earth science

Physics

Astronomy


History

People

Time periods

Wars

Exploration


Literature

The Bible

Classics

Mythology

Heroes

Mythological creatures

Irish mythology

Norse mythology


Authors

Hans Christian Andersen | Earl Derr Biggers
Albert Camus | Anton P. Chekhov
Michael Crichton | Charles Dickens
Arthur Conan Doyle | Euripides (plays)
Gilbert and Sullivan (musicals) | Brothers Grimm (fairy tales)
John Grisham | Victor Hugo
Henrik Ibsen (plays) | Jack London
Christopher Marlowe | Arthur Miller (plays)
Robert Ludlum | Edgar Allan Poe
Alexander S. Pushkin | Jean Paul Sarte (plays)
William Shakespeare | Oscar Wilde
George Bernard Shaw | Sophocles (plays)
John Steinbeck | August Strindberg
Mark Twain | Tennessee Williams


Art

How can artwork be made into a game?

A Pulitzer Prize-Winning Play Based on a Painting

Sunday in the Park With George was inspired by the art of Georges Seurat’s painting entitled “A Sunday Afternoon on the Island of La Grande Jatte.”

Georges Seurat was the founder of the 19th-century French school of Neo-Impressionism whose technique for portraying the play of light using tiny brushstrokes of contrasting colors became known as “Pointillism.”

Director and book writer James Lapine collaborated with Stephen Sondheim on Sunday in the Park with George, the winner of the 1985 Pulitzer Prize for Drama based on Georges Seurat’s masterpiece.

Click To expand
Georges Seurat, French 1859-1891, A Sunday Afternoon on La Grande Jatte - 18841884-86, oil on canvas, 207.6 x 308 cm,Helen Birch Bartlett Memorial Collection, 1926.224Image used with permission Copyright © 2001, The Art Institute of Chicago.


Music

How can music be made into a game?

We could go back in time and aid each composer in creating his or her masterpiece. We could use the music as the basis for our game design as in Tchaikovsky’s “Peter and the Wolf” or Rossini’s “William Tell Overture” (also known as the “Lone Ranger Theme”). We could educate ourselves about the different types of music, and in an RPG where we have several towns and cities, we could have a different type or style of music being played in each town.

The Tom Hanks film That Thing You Do was based entirely on a band that really only played that one song for the entire film.

Music topics to research include composers and music styles.


Dance and Instruments

Dancing and playing various instruments are educational but can also be fun if designed that way. Learning to play an instrument while adventuring through a fantasy land or playing chords or notes to interact with the world or competing in a sport are interesting and fun ways to learn. Some of these instruments can be merged together in a game, like learning the piano and organ at the same time in one well-designed game concept.


Movies and Film

When obtaining game ideas from a film (or movie), we want to utilize the film’s premise (plot, theme, and action) and not its character names, costumes, creature design and look, and names of places and objects.

The film Alien has a unique character (the alien), a specific spaceship design, a famous cast, and particular character names. If we want to mimic Alien in our game design, first we would call our game something interesting and descriptive like Space Predator or Space Cannibal to get the audience, publishers, and stores interested and to give a preconceived notion about our game.

If we decided that our alien creature was to look like a carnivorous dinosaur, we might title the game Space Raptor to bring in the Jurassic Park audience. We would design our own alien, perhaps describing it or using an artist to sketch our scary alien vision. We may use the crew dynamics of the film Alien like each member’s rank, sex, age, and race and then change the character’s name and face design to differ from the film.

In our pitch to publishers and in future sales and marketing material, we would utilize the Alien basis to correlate potential sales, audience interest, and a marketing strategy. We would obviously claim that our game is scarier and better than the film that spawned two sequels, Aliens and Alien 3, as well as several lesser rip-off films. Our pitch would include the facts that in 1979 Alien was the top-grossing film and in 1997 Alien 3 was that year’s top-grossing film. Also based on the film data, we could list the demographics of our audience like age, sex, income level, and international appeal.

As in life and in books, films, and games, “there is nothing new under the sun.”

1 | The Abyss: An underwater oil-drilling team enters an alien-inhabited nuclear submarine.
2 | Ace Ventura, Pet Detective: A detective specializing in missing animals uses his unique methods to achieve his mission to find a kidnapped dolphin.
3 | The Adventures of Baron Munchausen: Fantasy and adventure transport the Baron from a playhouse to the moon to visit the king and queen and to the sea to be eaten by a whale.
4 | The Adventures of Buckaroo Banzai Across the Eighth Dimension: A space craft made from a jet-propelled Ford Fiesta has a commander who is knowledgeable in medicine, science, music, racing, and diplomacy and battles aliens from Planet Ten.
5 | The Adventures of Priscilla, Queen of the Desert: A pink bus named Priscilla adventures across the Australian Outback with two drag queens and a transvestite.
6 | Air Force One: Terrorists take over Air Force One and kidnap the president and his family.
7 | Alien: On a research spaceship deep in space, an alien hunts the crew.
8 | Alien Nation: Aliens with bald heads who get drunk on sour milk come peacefully to Earth and try to co-exist with humans.
9 | Alive: The true story of the 1975 Uruguayan rugby team whose plane crashes in the Andes and must struggle to survive for ten weeks.
10 | Allan Quartermain and the Lost City of Gold: An American adventurer and his sexy blonde partner travel into the jungles in search of his brother and the legendary City of Gold.
11 | Along Came a Spider: A detective must solve a case involving a serial killer and the missing daughter of a U.S. Senator.
12 | American Samurai: A Japanese adopted American boy learns the ways of the Samurai and fights gangsters who compete in live-blade competitions.
13 | American Yakuza: An FBI agent infiltrates the dangerous Japanese criminal underworld of the Yakuza.
14 | The Amphibian Man: A scientist creates a man with gills.
15 | Anaconda: A documentary film crew in the Amazon River encounter snakes, even a 40-foot-long anaconda.
16 | Angel Heart: In 1955 New Orleans, a New York City detective investigates a murder in a climate of voodoo and eroticism.
17 | The Animal: A scientist surgically fixes a car accident victim using organs and parts from animals to replace the injured and destroyed ones.
18 | Arachnophobia: Deadly South American spiders invade a town.
19 | The Arena: Ancient Romans capture the world’s most beautiful women to compete in deadly games.
20 | Armageddon: An asteroid coming to destroy Earth must be intercepted and blown up by a deep-sea oil rigging crew.
21 | The Arrival: A radio astronomer discovers an alien base in Mexico and their plans for an upcoming alien invasion.
22 | Assassins: Two competing assassins (a mentor and his student) try to beat each other to the target and eventually must face each other.
23 | Baby Geniuses: Intelligent babies in a scientific lab run by evil owners must telepathically outsmart everyone.
24 | Back to the Future: A time machine De Lorean transports a teen back to visit his parents as teenagers who haven’t fallen in love yet.
25 | Barb Wire: A voluptuous sex goddess who owns a sleazy bar in a neutral zone after the second American Civil War helps the resistance in a dangerous mission.
26 | Barbarella: A space nymphet fights fantastic creatures and super beings.
27 | Basic Instinct: A downtrodden detective gets very involved with a gorgeous murder suspect with psychological and erotic intentions.
28 | Beastmaster: In a primitive world, a jungle man can telepathically communicate with animals.
29 | Bedazzled: A Faustus tale of a young man in love with an uninterested woman; he agrees to sell his soul to the devil for seven wishes.
30 | Beetlejuice: Two friendly ghosts befriend an obnoxious couple’s daughter who is obsessed with death and gets tricked into freeing Beetlejuice, a maniacal prankster ghost who stirs up the world of the living and the dead.
31 | Beginning of the End: Giant grasshoppers created by radiation attack Chicago.
32 | Big Trouble in Little China: In San Francisco, a trucker becomes involved with Chinatown’s magical martial arts army who seek to kidnap a green-eyed Asian woman.
33 | Bill & Ted’s Excellent Adventure: Two California airhead rockers use a time-traveling telephone booth to travel into the past in search of homework answers.
34 | The Birds: A tale of man versus nature where birds infest a town and become extremely violent and too numerous to count.
35 | Blade: A day walker (half human and half vampire) and his weapon-inventing mentor fight an evil, ambitious vampire leader and his vampire army in a fast-paced techno music world.
36 | Blade Runner: Los Angeles in the 21st century is dismal, and human-looking robots (“replicants”) that are destined to terminate soon are eager to live forever, as a tired cop is commanded to terminate them all.
37 | Blast From the Past: After living in an underground bomb shelter for 35 years (since birth) with his parents, a man emerges into modern day California seeking supplies and a non-mutant wife.
38 | The Blob: Slimy black tar alien feeds on a small town.
39 | Bloodsport: The Kumite is an outlawed martial arts competition in Hong Kong where anything is allowed to win, including murder.
40 | Blown Away: A bomb squad expert must stop an Irish radical bomb-making genius in Boston.
41 | The Bone Collector: A New York City quadriplegic forensics expert must solve a serial killer case using high-tech equipment from his bed and the talents of an upcoming, eager policewoman.
42 | Bonnie and Clyde: Bonnie Parker and Clyde Barrow rob Southwest banks during the Depression era.
43 | The Boy Who Could Fly: After a plane crash kills a boy’s parents, he escapes into a fantasy where he can fly.
44 | Brainsmasher: A Love Story: A super model and a bouncer fight an army of Ninjas.
45 | Brainstorm: Dreams and fantasies can be recorded and played back as a scientist desiring better results must evade interested government parties.
46 | Braveheart: William Wallace, a 13th-century Scottish patriot fights British tyranny and weak Scottish nobles.
47 | Brewster’s Millions: A poor ex-ballplayer must spend $30 million and end up penniless after 30 days in order to inherit $300 million.
48 | Bring It On: A perky blonde, newly appointed “head cheerleader,” discovers that her national cheerleading championship squad has been performing stolen routines. She must choreograph a new, exciting routine for the upcoming championship and compete against the squad from which their winning routines were stolen.
49 | Brink’s Job: The crime of the century where Tony Pino heists $2.7 million from a Brink’s truck.
50 | Broadcast News: The inner workings and public persona of the TV network news reporting business and its people (the anchormen, the reporters, and the producers).
51 | Buffy the Vampire Slayer: A Los Angeles high school cheerleader is proclaimed a vampire slayer. After training with her mentor, she must terminate an emerging onslaught of vampires.
52 | Cat People: A beautiful woman by day transforms into a deadly panther that kills by night.
53 | The Cell: A psychotherapist who can enter her patients’ minds helps the FBI by probing into a serial killer.
54 | Chameleon: A genetically engineered assassin can blend into any background unnoticed.
55 | Charlie’s Angels: A trio of gorgeous agents solve unusual cases with the help of their manager.
56 | Class of Nuke ’Em High: A nuclear spill creates an outbreak of mutants and maniacs in a New Jersey high school.
57 | Cliffhanger: Expert professional climbers get unknowingly involved with a murderous group of thieves on a treacherous, snowy mountain.
58 | Con Air: A paroled ex-Army Ranger heading home to his awaiting wife and child is on a plane with a group of America’s most wanted that take over the aircraft.
59 | Cool World: A cartoonist enters into his own adult cartoon world.
60 | The Crazies: A poisoned water supply turns citizens of a small town into murderous psychos.
61 | Cube: Six people awake to find themselves chained together in a hidden booby-trapped room and must cooperate to escape unharmed.
62 | Dark City: A dark, gothic world where as people sleep, long-coated aliens switch each person’s life nightly in an effort to examine human behavior.
63 | The Dark Crystal: Two Gelflings (like elves) must recapture a stolen dark crystal shard from an evil castle and its guardians.
64 | Dave: When the U.S. president suffers from a stroke, a man who could be his twin is recruited to impersonate the married president.
65 | Day of the Triffids: A meteor shower brings carnivorous plants that grow and mutate.
66 | Daylight: An explosion in New York’s Holland Tunnel traps a band of travelers trying to escape and survive the pending deluge of the Hudson River.
67 | Death Race 2000: A national championship cross-country car race where winning depends on time and points earned by killing pedestrians.
68 | Death Takes a Holiday: Death disguised as a prince wants to discover why humans fear him. When Death falls in love, nothing in existence dies.
69 | Defending Your Life: A look at examining your life and fears in the afterlife where existence is perfect, one can fall in love, and you can eat everything without gaining any weight.
70 | Die Hard: A New York City vacationing police officer visits his ex-wife in Los Angeles at Christmas when terrorists take over the large Japanese corporation building he is in.
71 | Die Hard 2: Die Harder: A New York City vacationing police officer awaiting his ex-wife’s arrival at the airport at Christmas confronts terrorists who have control of the airport.
72 | Dirty Rotten Scoundrels: Two con men: one is a wealthy, elderly European gentleman who is partners with the local chief of police, and the other is a younger American hustler thought to be “the Jackal,” a legendary con artist. After joining forces as mentor and student, they decide to challenge each other in a winner-take-all contest where a wealthy American soap queen is the target of the con (she turns out to be the real “Jackal”).
73 | D.O.A.: A college professor is given poison and has 24 hours to find his killer as police suspect him of murder.
74 | Edward Scissorhands: A scientist creates a boy-creature with scissors instead of hands. He unexpectedly dies, leaving the boy to deal with suburbia and an overly friendly Avon saleslady.
75 | Eight Heads in a Duffel Bag: A mobster is hired to kill eight mob lowlifes, and as proof he must return their heads to get payment. At the airport, a Mexico-bound college student and his girlfriend’s neurotic family accidentally receive the mobster’s bag, which looks like his bag. An adventure begins when the mobster seeks to recover his bag and the college student deals with his new discovery and lack of clothes.
76 | Eight Millimeter: A detective is hired by a wealthy widow who desires to know the truth about her deceased husband and his involvement in illegal “snuff” films.
77 | Empire Records: An independent record store’s last day before it joins an uncaring chain. The store’s crazy staff (suicidal, sex-starved, and kleptos) keep the manager on his toes as he tries to keep business going and acquire the needed cash to buy the store for himself.
78 | The End: A terminally ill man decides to end his suffering and attempts various methods of committing suicide.
79 | End of Days: Satan must have an heir, and an alcoholic ex-cop is the only hero who can save a young woman from this fate.
80 | Enemy Mine: Two warring planets’ pilots (a human and a reptile man) crash onto a planet where they are captured as slaves, and they must unite to survive and escape.
81 | Eraser: A federal marshal fakes elaborate deaths for people entering the Witness Protection Program.
82 | Erin Brockovich: An unemployed mother bullies her way into a law office where she uncovers and investigates a public utility company’s act of dumping toxic waste into a local water supply.
83 | Escape From LA: In Los Angeles circa 2013, the hero, who has been poisoned and has ten hours to live, is sent in to deal with the kidnapped daughter of the President and a “doomsday” device.
84 | Escape From New York: Futuristic Manhattan, now a pile of rubble, becomes the federal prison housing the worst elements. When the president’s plane crashes in New York, he becomes a hostage, forcing an unwilling war hero to begin a rescue mission.
85 | Eyes of Laura Mars: A female photographer can foresee murders in her pictures, and she becomes the focus of the killer.
86 | F/X: A Hollywood special effects expert is hired to fake a mobster’s assassination, and he becomes a loose end that must be terminated. He must use his skills to survive and rectify this life.
87 | Face/Off: A federal agent surgically exchanges his face for that of the terrorist who killed his son. The unaware agent soon discovers that the terrorist is not only alive but wearing his face.
88 | Falling Down: An average law-abiding citizen snaps and goes on a rampage, and a retiring detective on his last day must stop him.
89 | Family Man: A single, wealthy investment banker finds out the answer to the question “what if I married my college love?” with the help of his guardian angel.
90 | Fantasy Island: Vacationers get to live out their most desired fantasies.
91 | Fatal Attraction: A married New York lawyer has an affair with a beautiful associate, and when he tries to end the relationship, she threatens his family, his home, and his life.
92 | The Fifth Element: To save the Earth from a maniac arms dealer’s destructive plan, a New York City taxi driver must help an alien woman and a priest to save the day.
93 | 54: Running New York City’s most popular disco, Studio 54, requires a unique staff who desire wealth and stardom and an owner who will do anything for pleasure.
94 | The Final Terror: A group of campers in a remote wooded area are stalked by a crazed killer.
95 | Fire Down Below: A rich, evil industrialist is illegally dumping toxic waste, which upsets the undercover EPA agent who has martial art skills.
96 | Fletch: An undercover newspaper journalist trying to get a scoop on illegal drug trafficking gets involved with a corrupt police chief and a wealthy businessman whose treachery could put the reporter in the obituaries.
97 | The Fly: A scientist experimenting with teleporting accidentally gets genetically intermixed with a housefly.
98 | Footloose: In a Midwest town controlled by a minister, dancing is forbidden, and a teen newcomer from the city tries to change public views on rock music and dancing.
99 | Freejack: It’s a futuristic time when the super rich can buy young, healthy bodies from the past to prolong their longevity. A racecar driver assumed dead is transported into the future where he decides to run away as a “freejack.”
100 | Frequency: A modern day New York police officer discovers that he can communicate with the past by operating his father’s old ham radio. He can talk to his father who is living in 1969 to prevent the father’s accidental death in a warehouse fire, his mother’s murder, and other events, which drastically alters the future.
101 | From Dusk Till Dawn: Two vicious escaped criminals pick up a minister and his two teens and rendezvous at a sleazy biker bar that is unknowingly operated by vampires.
102 | The Game: An investment banker receives an unusual birthday present from his distant brother, a real life role-playing game that taps into your life, business, and finances and blurs the line between reality, terror, and the game.
103 | Ghost: An investment consultant deeply in love is murdered. Through a fake psychic, he is able to communicate and must solve his murder and protect his lover.
104 | Ghostbusters: When college grants are terminated, three “paranormal” investigators go into business as New York City gets plagued by the spirit world.
105 | Gone in 60 Seconds: In order to save his brother’s life, a retired legendary car thief must steal 50 specific modeled cars in one night by recruiting his old associates.
106 | Gotcha: A campus paintball assassination gameplayer on vacation in Europe winds up getting involved with an exotic female international spy.
107 | Grosse Point Blank: A hitman returns to attend his tenth year high school reunion only to discover that his current target is the father of his high school sweetheart and an interest to his number one rival.
108 | Groundhog Day: An obnoxious weatherman covering the groundhog shadow story in Punxatawney, PA is trapped in a bizarre space-time continuum of repeating the same day and events until he finds love, happiness, and the meaning of life.
109 | Hackers: Teenage cyber geeks get outhacked by a super hacker who frames them for industrial conspiracy. The teens must use their techno skills to resolve the problem as police, federal security, and the superhacker all want to delete them.
110 | Heaven Can Wait (Here Comes Mr. Jordan): A second string football player (or a boxer) is taken too early by his guardian angel and is sent back to Earth assuming the body of a millionaire with athletic aspirations.
111 | Highlander: Aliens on Earth are immortal and can’t be terminated unless they’re decapitated and must never fight on sacred, holy ground. In the end, “there can be only one.”
112 | The Hills Have Eyes: Inbred mountain cannibals invite lost guests to (be) dinner.
113 | House: A horror novelist moves into his deceased aunt’s haunted house where rooms transform into nightmares and monsters are no longer closet bound.
114 | Idolmaker: A hot talent agent can turn teens into superstars. He creates one rock star who gets replaced by a younger upcoming talent.
115 | The In-Laws: An importer’s son and a dentist’s daughter are to be married. The “importer,” a CIA agent, entangles the dentist in a counterfeiting and robbery scheme that has the two men avoiding federal agents and traveling to South America to meet with a lunatic dictator.
116 | Invasion of the Body Snatchers: Alien pods take over a town and its citizens.
117 | Island of the Dead: A business tycoon, a policewoman, a prison warden, and three convicts are stuck on a “burial ground” island as the disturbed dead resurrect.
118 | It’s a Wonderful Life: An angel shows a suicidal man what life would be like if he was never born.
119 | Jerry Maguire: A sports agent gets a conscience and is fired for it, forcing him and a co-worker girlfriend to start their own company that encounters a rocky road in business and romance.
120 | Johnny Mnemonic: A data courier gets an overload of critical data downloaded into his head that contains extremely confidential information that a rich corporate head wants to remain a secret. An assassin seeks his head, a female enhanced bodyguard needs his protection money, rebel hackers need him to transport the data unharmed, and an ex-doctor tries to keep his head from exploding so the battle against a technology-induced epidemic can be stopped.
121 | Joyride: Three friends steal a car that belongs to a revengeful, beautiful blonde assassin.
122 | Jumanji: A board game that turns each move into reality transports a man back, who as a boy got stuck in the game world 26 years ago.
123 | Junior: Two scientists researching an anti-miscarriage drug decide that one of them is to get pregnant by implanting a female researcher’s egg inside them.
124 | James Bond (any): World-threatening missions and scantily clad women are standard issue for this licensed to kill British agent.
125 | Killer Klowns From Outer Space: Aliens resembling psycho clowns trap Earthlings by setting up circus tents and getting them inside.
126 | Labyrinth: A teen girl wishes for the Goblin King to take her baby brother. Then, regretting her plea, she must enter the ever-changing labyrinth and reach the castle before her brother becomes a goblin forever.
127 | Ladyhawke: In medieval times, a young thief escapes a fortress prison and is saved by a knight, an ex-commander of the guards. The thief must then protect the knight’s hawk, which turns into his lover each night, while the knight becomes a wolf. Through adventures and a repenting priest’s dream, the cursed couple must travel to the fortress and face their destiny, their enslaver.
128 | Last Action Hero: A youngster who idolizes a comic book character (a movie, police action hero) gets a golden ticket to enter his favorite movie world. The boy becomes his idol’s newfound friend and accidentally frees the evil villains from the movie world into the real world. This forces his idol to come back to the real world to track down and stop the villains. In the real world, their counterparts, the real actors, interact with them at their latest movie’s premiere.
129 | The Last Starfighter: A trailer park teen loner becomes an expert at a newly arrived video game that unknowingly trains intergalactic pilots in a real-life space war. The teen is recruited in an adventure that he thought was only a game.
130 | Lifeforce: A beautiful female space vampire in London drains human life, not blood, and creates disappearing zombies.
131 | Little Shop of Horrors: A strange plant attracts huge sales to a flower shop, but its timid owner soon learns that his rapidly growing, popular plant needs warm human blood to survive.
132 | Logan’s Run: In a futuristic domed world, pleasure-seeking people exist for only 30 years, until a young officer is forced to either die in the Coliseum or run away to find sanctuary. He gets hunted by his best friend and fellow officer who eagerly wants him dead.
133 | The Long Kiss Goodnight: A quiet engaged schoolteacher hires a black private investigator to discover her past, which amnesia has wiped out. As the search for truth continues, her nightmares about her past and the CIA begin to evolve the brown-haired teacher into her former self, a blonde, highly trained CIA assassin.
134 | Lord of Illusions: A New York private investigator gets involved with the widow of the magician he is investigating. A demonic cult with a resurrecting demon and his psycho followers and the world of magicians unveil the secrets behind the seemingly obvious.
135 | Made in Heaven: To remain eternal lovers, two heavenly souls are reborn on Earth and must find each other or lose each other forever.
136 | The Man Who Knew Too Little: A video store clerk from Iowa visits his successful brother in London as his own birthday surprise. His brother is having a very important business party with clients and decides to send the naive American birthday boy on a “special night out,” participating in a real-life role-playing theatre experience. He mistakenly gets involved with a hit man and an international plot to initiate a global war. He truly believes that he is playing a well-rehearsed game and is totally oblivious to the real danger he is part of.
137 | Mannequin: An ancient Egyptian woman is brought to life as a mannequin by a department store clerk who falls in love with her, despite his successful fiancée who works for a competing store. The mannequin only comes to life for him as he climbs the company ladder and is the target of the store’s security and idol of the store’s flamboyant window designer.
138 | The Mask: A quiet bank clerk discovers an ancient mask with supernatural powers that animates him. He falls in love with a mobster’s sexy singing lady.
139 | Memento: In Los Angeles, a man searches for his wife’s killer while unable to remember current events due to an accident that destroyed his short-term memory (every 15 minutes he forgets everything). Polaroids, Post-its, and tattoos remind him of vital clues and suspects.
140 | Men In Black: Two top-secret government agents dressed in black and wearing sunglasses keep track and maintain the order of alien visitors on Earth, mainly in New York City. When an assassination of a diplomat occurs and a galaxy is threatened, alien destruction of Earth must be dealt with.
141 | Michael: The archangel’s last visit to Earth is filled with wine, women, and dancing as reporters from a Chicago tabloid newspaper want his story.
142 | Midnight Run: An ex-bounty hunter must bring the mob’s ex-accountant and embezzler from New York to California by car (since he refuses to fly), but the mob, the FBI, and an eager, meaner competing bounty hunter are also interested in the accountant.
143 | Moon Over Parador: When a Latin American dictator suddenly dies, an actor who resembles him is hired for the role of a lifetime while an ambitious political rival seeks eventual control of the country and a desirable woman needs his help.
144 | Most Wanted: A Marine sergeant guarding the first lady’s press conference is framed for her assassination and must evade the CIA, FBI, LAPD, and team he was assigned to and its leaders until he can solve his dilemma.
145 | Never Been Kissed: A young female Chicago newspaper copy editor gets her first undercover assignment to go back to high school as a student and write a front page story.
146 | Nick of Time: An evil psycho kidnaps an accountant’s young daughter and forces the accountant (a conservative widower) to assassinate the female governor of California in 90 minutes. This film is shot in real time where all events happen within the 90-minute window.
147 | Night of the Living Dead: Space radiation creates flesh-eating zombies from the recently deceased as a group of scared humans occupy an isolated farmhouse.
148 | The Ninth Gate: An unscrupulous rare-book dealer gets hired by a wealthy publishing mogul to search and authenticate three copies of a 17th-century book, which has secret writings that can forcefully enslave the devil.
149 | Not Without My Daughter: An American woman married to an Arab medical doctor travels to Iran only to find out that she has no rights, doesn’t speak the language, and since her husband has taken her passport she can’t leave the country.
150 | Ocean’s Eleven: A gang of eleven friends decide to rob five Las Vegas casinos at the same time.
151 | The Omen: An American diplomat adopts the son of Satan who has special powers. Sequels follow Damien (son of Satan) throughout his life.
152 | Other People’s Money: A corporate raider’s computer indicates top profitable companies that are ready for a takeover like the New England Wire and Cable, a family owned company that is worth more sold than to leave it operating. What’s a raider to do when a prime target is worth more to his pocket, but the owner’s beautiful lawyer daughter has stolen his heart?
153 | Out of Towners: A naive Ohio couple’s misadventures in New York City, where everything goes awry.
154 | Planet of the Apes: A member of a space team accidentally lands on a planet where apes rule and humans are their slaves.
155 | Poseidon Adventure: A cruise ship capsizes and the surviving passengers must roam the leaking upside-down ship and survive until help arrives.
156 | Predator: A space-hunting alien visits Earth seeking humans as trophies.
157 | Proof of Life: When an American engineer is kidnapped by South American anti-government guerrillas, a professional hostage negotiator is hired and begins to have an interest in his assignment’s wife.
158 | Pure Luck (or La Chevre): An accident-prone heiress with extremely bad luck disappears in Mexico, and a hard-nosed detective and a clumsy accountant (himself a bad luck magnet) travel south to find and rescue her.
159 | Ringmaster: A trash TV show host must interview perverts, misfits, and psychos to keep his ratings high and his addicted audience tuned in.
160 | The Rock: At the impenetrable prison on Alcatraz Island, a general with a deep interest in settling a military benefit issue holds hostages and has a deadly gas bomb that will be unleashed upon San Francisco. A biochemical weapons specialist and an ex-prisoner, the only man to escape Alcatraz, are sent in to remedy the threatening situation.
161 | The Running Man: A futuristic TV show where convicted criminals must evade a labyrinth of unique costumed assassins to receive a pardon.
162 | Scavenger Hunt: A millionaire wills his entire fortune to one person in a selected group of 15 people who are involved in searching and collecting a list of items in a scavenger hunt where the winner earns the inheritance.
163 | Seven: Detectives hunt down a serial killer whose crimes relate to the seven deadly sins.
164 | Seven Chances: After his girlfriend dumps him, a bachelor must get married by a strict deadline in order to inherit seven million dollars. Pandemonium occurs after he advertises for a wife to make him a wealthy married man.
165 | Shattered: A serious automobile accident disfigures a married architect and leaves him with no memory of his past. Plastic surgery restores his physical problems while a private investigator searches for his past to find out the truth about him.
166 | Silence of the Lambs: A female FBI cadet specializing in psychology must stop a serial killer on the rampage by interviewing a clever psychiatrist who is a famous imprisoned serial killer himself.
167 | The Sixth Day: A family man thought dead after his company-owned helicopter explodes is illegally replaced by his clone. When the evil corporation learns that he has survived, numerous undying assassin clones keep hunting him down.
168 | Speed: An LA SWAT cop plays a dangerous game of “cat and mouse” with an expert bomber who desires a huge ransom for a grudge he has with the government, and a public bus must remain above 55 mph or explode in heavy LA traffic.
169 | Star Wars: A young man whose family is killed learns secret jedi skills from a master and ventures out into space seeking revenge.
170 | Stay Tuned: A twist on the “devil wants your soul” theme as an unhappily married couple gets mistakenly sucked into their Hellivision set and must use their remote control to surf devilish channels and survive 24 hours of sadistic versions of popular TV shows.
171 | Terminator: A futuristic robot returns to Earth seeking to kill the young man who will one day lead the resistance against technology.
172 | They Live: Aliens are secretly living among humans and can only be spotted when the human is wearing special sunglasses that ignore color and show the real world, which is in black and white.
173 | Thrill Seekers: A tabloid reporter researching great catastrophes of the past notices in photos the same person in events that span centuries. He along with another female reporter discovers that a future travel agency offers its clients a vacation to historic disasters.
174 | Total Recall: With nightly dreams of visiting Mars, a married construction worker buys an implanted vacation where he is a secret agent in search of alien artifacts and interacts with the mutant underground while evading government assassins. When he awakes, his co-workers, his wife, and government agents want him dead, forcing him to try to discover whether it’s all a dream or reality.
175 | Wages of Fear: Four eager citizens who desperately want to leave a Central American poor, desolate town volunteer for a suicide mission to transport trucks of nitroglycerine to extinguish a raging well fire 300 treacherous miles away. Each person will receive $2,000, enough money to happily leave town.
177 | The Warriors: At a New York City street gang rally, the leader of New York’s toughest and largest gang is assassinated. The Warriors, a Brooklyn-Coney Island gang, are mistakenly blamed for the murder, and they must safely return home as the word is spread through the radio to destroy the Warriors.
178 | West World: An adult resort island where human-like robots in a western fantasy town interact with human vacationers until an electric malfunction turns friendly robots into terrorizing ones.
179 | White Man’s Burden: A reverse of life concept where blacks have all the wealth and power and the white race struggles. A bigoted black CEO fires the white main character who kidnaps his black boss and shows him how the other half lives.
180 | Wishmaster: An evil genie grants wishes to his victims in a destructive and evil version of their desires.


Chapter 7: Research

Overview

As game designers, we first get a great idea, our vision. Then we play a sample game in our head and have a very basic concept of our “fantastic” game.

Now begins the hard part, the reality of “game design.” We need to thoroughly understand the game’s subject matter as though we are professionals at it. This is done in the phase called “research.” This is the first mountain that we must cross. Many “wannabe” game designers start the climb upward and eventually lose interest and quit. To the professional game designer, this is the “fun” phase, where the dream first hits the paper and the vision becomes real.

Over the years I’ve helped many “newbie” game designers iron out their ideas and concepts (Pedersen Principle 9: Share Your Toys!). One of their first concerns is “If I tell you my great game concept, how do I know you won’t steal it?” My answer has always been, “You are the one with a burning desire to create this vision, and I’m not. There’s a lot of hard work ahead, several months of painstaking decision-making work, and you have that determination to make your vision a reality. I have a lot of my own visions that to me are important to design. I don’t have enough time to design my own visions, so why would I want to steal yours?”

Would I rather have the original visionary design the game and get rewarded later financially and credited, or steal the idea and work extremely hard for free? That’s why I enjoy mentoring. Let others do their work and hopefully we’ll all get rewarded at some point.

The best way to protect your game design is to spend $30 or so to register a copyright of your document(s). To copyright a document, you need to get a form from the U.S. Copyright Office in Washington, D.C., fill it out, and mail it along with your document(s) and filing fee. The Library of Congress’ web site (http://lcweb.loc.gov/copyright/circs/circ1.html) has information of copyright basics. To copyright a design document or a computer program, you must fill out Form TX, which is available in Adobe Acrobat Reader PDF format (www.copyright.gov/forms/formtxi.pdf).

On all of your documents place the copyright notice on the first page. I like to place this notice on the top of every page, so if copies are made the notice is included. The notice should look something like “© 2002 Roger E. Pedersen” where either the symbol © or the word “Copyright” precedes the copyright year and the copyright’s owner.

The titles of films and books cannot be trademarked, but computer and video game titles can be. If the name of your game is unique and “catchy,” you should spend the couple of hundred dollars and get a lawyer to perform a trademark search and then file a trademark for your game’s name. It will help that your title is trademarked later when talking to publishers. I worked for a game company that had a future game title on their web site for several years, and then another company advertised their game by the same name. We contacted a lawyer and found that the other company had filed that name for a trademark. We decided not to fight the costly and most likely un-winnable fight to challenge the trademark. Therefore, we lost that title.

Remember, ideas are truly a dime a dozen. Concepts are worthless in gaming until the designer commits the idea to paper, a design document. To prove that ideas without supporting documentation is meaningless, look on the companion CD-ROM or in Chapter 6, “Game Ideas,” where hundreds of ideas for free gaming concepts from other mediums such as books, film, and history are listed.

When I begin researching a gaming concept that I’m developing, I make a list of similar and competing games. Then I ask, “What current and past games are close to the game I’m developing?” and “What games in my game’s genre are currently selling?”

Even if you think your game is unique and there’s nothing close to its concept, you’ll need to explain your vision to publishers and convince them that other games like yours have been successful.

One of the first places I look is magazines. I want to see what current products are reviewed in my game’s genre and perhaps competitors to my game. Even more insightful are the advertisements by gaming mail order stores. They list many games under genre headings and their prices. This is useful information you will later need, such as competitive selling titles, their platform (PC, PlayStation, GameCube, or Xbox), and their selling price (retail price).

The next place I look is the magazines’ and gaming web sites’ lists of top games in each genre for the current and previous year. People associate future success with the current winners. You’ll want to associate your game with the top-awarded games in your game’s genre when you’re selling your concept to a publisher.

Then I look at the similar and competing game publishers’ web sites to view how they are marketing their product so I can get an idea how to market my game. Let their highly paid marketing and sales departments benefit you and get ideas to use for free. Read their descriptions and features and copy them down so your game will have the same features and gameplay. Look at any screen shots they display to see what the gamers are familiar with and how your screen should look. Some sites will include favorable reviews of their game, so print them and highlight the reviewers’ comments.

You will also search other sources (magazines and web sites) for reviews of similar and competing games. When I look at a review, I make a list with two columns marked “Good” and “Bad.” Under “Good,” I write down the reviewer’s favorable comments and the standard features that the game must have plus any extras that the designer is being praised for. Under “Bad,” I list the reviewer’s unfavorable comments, like problems with the game or features designed that didn’t work or weren’t as good as they should have been. I pay special attention to graphic and sound issues. Features that were missing or not handled correctly are noted, and later I address these so I don’t fall victim to the same criticism by other reviewers and gamers.

The important issues are the game’s interface (what does the gamer view and how does the gamer interact with the game?), the POV of the game (first or third person), the game’s options, the computer requirements (RAM, hard disk minimum space required, Windows version needed, CD speed required), and special devices required (driving wheel, force-feedback joystick or mouse, 3D accelerator card).

As a designer, I also value buying the top-selling games’ hint books or strategy guides. These books discuss the games’ basic strategy and the game’s design in depth. Hint books reveal each side’s or character’s strengths and weaknesses. Many times gamers favor one side or character above the others without fully understanding or realizing the strengths and weaknesses they are dealt. Likewise, many gamers don’t understand or realize the strengths and weaknesses of their opponents in the game. Hint books and strategy guides discuss these issues in detail. Many gamers and designers don’t have the time it would take to play all variations and situations for one side or one character, let alone all sides and all characters. This problem of not understanding the strengths and weaknesses of their characters and sides becomes more of an issue in online (web-based) games where the gamer’s time and money (cost of playing, connection costs, and so on) are needed to play.

As designers, we need to understand the top successful games’ intricate design details and balanced play as references to follow. Playing games is a great start to understanding the gamer’s POV, but we, as designers, need to understand the game designer’s POV. This viewpoint requires us to research and study these games as well as play them.

Hint books and strategy guides may also tell us the “why” behind the decisions that were made. Internet games may suffer from latency (a slow down) when the server(s) get(s) too populated. To solve this technical dilemma, the game must move players from the current server to another less-populated server. To the gamer, they might experience a magical cloud that overshadows the terrain and teleports all of the players currently in that area into another area (one controlled by a less-populated server). The key is to make the gamers unaware of the “why” and still have a fun and meaningful experience.

Another interesting area is the designer’s notes written on many sites (see Appendix A) where the development team, after the product has shipped, tells about the project, especially where things went wrong or what they would do differently.

If our desire is to become a game designer, we must master our trade by first learning from other masters as their apprentice (study existing games, research our game’s subject matter, and play games from the best to the near best) and then become masters ourselves by designing our vision through research, documentation, and play testing.

An important concept in both researching and documenting your game is to assume that the player and audience know nothing about the subject matter and gameplay issues. Document your concept and research findings as though the player and audience are not technical and totally new to the game concepts and ideas. Think of explaining these issues to a willing-to-learn and eager-to-be-taught child-like audience.

Let’s examine how to document a simple game I call Two Heads. The player flips a coin twice. If both tosses result in “heads,” the player wins.

This simple game should be more accurately described with more details that explain the concepts and issues in greater detail:

The player freely tosses a coin so that it randomly spins in the air (also called a “toss”). The coin is a metal, two-sided, flat circle in which one side is called “heads” and the opposite side is called “tails.” Commonly, a coin has a person’s head on one side (the head of a president or monarch), which is known as the “head’s side.” The opposite side of the coin often has a bird, such as an eagle, on it so it is often known as the “tail’s side.” If the first toss results in the “head’s side” appearing on top, the player continues. If the “tail’s side” appears on top, the player loses. If play continues (the first toss resulted in “heads”), the player tosses the coin for a second time. If the result is another “head’s side” on top, the player wins. Otherwise, the player loses.

This description clearly expresses the game’s rules in simple, understandable terms. The game’s object (the coin) is described with its identifying features. The game’s process is described in detail with the common lingo explained for future references. The winning and losing conditions are identified so the player(s) can easily understand the goals.

At this point, we understand the market and have an idea of what our competitors have done and what our customers expect from our game. Now we need to fully understand our game’s subject matter. We need to find free, unlimited information that can help us.

Let’s think…

Libraries have books, magazines, and encyclopedias for us to use and take notes from. Also, the Internet will supply information that we can use. The Internet’s information may be more recent than books, and there are pictures and sounds that we can access and save for samples of what our game may need. Many of the libraries I have visited have computers available with word processing capabilities and Internet access.

A wannabe game designer wanted my mentoring. He had three game design concepts that he thought would earn him millions and have the major publishers begging to sell his games. His background was working as an international contract lawyer, and he had a graduate degree in international business law and an undergraduate degree in paleontology (dinosaur scientist). He’d played a lot of recent games, especially sims, RPGs, and FPS. He played on his PC alone as well as multiplayer versions on the Internet. He had never designed a game, let alone worked on a game in any capacity.

Let’s look at and critique his three concepts.

Intergalactic Council is a space diplomacy, strategy simulation game where up to ten players are members of the council. Each of the ten players are diplomats representing their galaxy. Each diplomat presents the council treaties, trade agreements, and his galaxy’s requests (bills). If negotiations fail, the diplomats can declare war or boycott the council meetings. Each galaxy has its own inhabited planets, a galactic space armada (ships), and tradeable resources. The laws and treaties follow the international laws established for venues outside the Earth as far as format and regulations. The goal of the game is for each diplomat to successfully create and get his bills, treaties, and trade agreements passed or, by intergalactic warfare, force the acts to be accepted by the council.

How does this concept sound to you? Would it make for an interesting game? What issues need to be researched in order to get a better understanding of the rules and gamer’s play options?

I thought the concept sounded interesting but wanted to see more of it developed through research. The designer’s education and work gave him the expertise to design such a game. My concern was simpler: “Is this a game that a newbie game designer should start with?” My thoughts were that even to a seasoned game designer with some international business law background, this design was a Herculean task. I suspected that trying to research and properly design this concept would take six to twelve months to complete, and the new designer would most likely quit in the research phase.

I advised him to put this design on hold and start his design career off with an easier, less complex concept. After having a few titles finished (not necessarily published), he’d feel more confident in tackling a major research and design project, and a publisher might be willing to be financially involved. It is equally important that the team (in this case, the designer) doing the project have credentials (proof that they can finish a started task).

The second concept was The Lost Kingdoms.

The Lost Kingdoms is a fantasy simulation where the player(s) represent the kingdoms of humans, elves, dwarves, centaurs, trolls, orcs, or giants. The kingdoms have co-existed in peace for hundreds of years where the human, elf, and dwarf kingdoms were allies, the centaurs were neutral, and the troll, orc, and giant kingdoms were evil. As the game begins, the evil kingdoms of trolls, orcs, and giants are expanding, looking for more land and food (they eat humans, elves, dwarves, and centaurs). The kingdoms must sign peaceful treaties or go to war.”

How does this concept sound to you? Would it make for an interesting game? What issues need to be researched in order to get a better understanding of the rules and gamer’s play options?

At first I felt that The Lost Kingdoms was somewhat similar to the Intergalactic Council game. Just like the first concept, this one is an enormous undertaking for a first game design. The concept is good and similar to the popular Lord of the Rings books. The races in this game are familiar to RPG and fantasy RPG players. Research is critical to show good judgment and an educated concern for the fans who know and understand these races.

While researching each race, you must be able to answer the following questions and do so through the eyes of an avid fan. (Substitute the specific race involved where elves appear.)

What do elves look like (male and female)?
What do elves wear (daily dress and war clothing)?
How do elves talk (common elf phrases)?
What weapons and fighting styles do elves favor?
What do elves do each day?
What do elves cherish and care about?
What do elves believe in (family, gold, customs, and ideology)?

These are just a few starting issues to research in this game. Your job is to understand like the avid fan does the characteristics and thoughts (social, political, and economical) of your game’s kingdoms and individual heroes.

Again, as in Intergalactic Council I thought The Lost Kingdoms was another good concept that would take at least six months to document and not an ideal first game to design.

The third concept was The Survival of the Fittest.

The Survival of the Fittest is a prehistoric simulation where mankind must survive from the Neanderthal man era to the Cro-Magnon man era. In solo and multiplayer versions, each player controls the destiny and daily activities of a clan. Hunting, fishing, and making clothes and shelter are necessities for survival. The goal is to survive through several generations and keep mankind from becoming extinct.

This third design is the most feasible and within the realm of a first-time game designer, especially one who has a degree in paleontology. The Survival of the Fittest is a nice twist from all those hunting FPS games that flooded the stores after Deer Hunter.

Let’s do some research for our game, The Survival of the Fittest.


Simulation Game: The Survival of the Fittest

The time period for this simulation game is the Ice Age. Homo erectus, or the “upright man,” lived around one million years ago (1.5 million B.C.). Then 200,000 to 250,000 years ago, the Neanderthal (or Neandertal) appeared. Around 25,000 B.C. the Cro-Magnon man became the fittest species. In my research, I decided to include Homo erectus in the design for the initial migration from Africa to Europe and Asia and for their primitive lifestyle.

Similar successful products would be the Deer Hunter series and the hundreds of products that mimicked it, as well as The Sims, since in this game you’ll be monitoring and making decisions for tribe or clan members for several generations.

Neanderthal man, reconstructed from a skull found in Amud, Israel. Used with permission from the Neanderthal Museum, Mettmann, Germany (www.neanderthal.de.)

Comments on competing hunting games are:

Good: Actual animal sounds, realistic 3D animations and graphics, true-to-life animal behavior and weather conditions. The game captures the essence of the outdoors. Accurate AI, and the animals react to the hunter’s sounds and scents. The ability to customize the input keys and option settings. The game ran well on an average computer.

Bad: Difficult to see the animals’ tracks. Sounds were repetitious and did not have much variety.

Homo Erectus

Homo erectus appeared 1.5 million years B.C. and traveled from Africa to Europe and Asia. They were the first hunters and gatherers with primitive weapons like stone axes and knives. They lived in the midst of the Ice Age, so traveling across bodies of water was as simple as crossing a vast terrain of frozen, natural ice bridges. Homo erectus traveled in search of food in the frozen desert after the animals in Africa either headed north or became extinct. They had the skills to make fire. Fire was an important key to life since it protected them against wild, hungry animals that feared fire, gave the tribe heat when traveling through cold regions, and allowed them to cook their food, killing possible diseases and softening their meat. The elders could share stories around the fire.

Homo erectus had a large face, a thick skull, a large, powerful lower jaw, and a receding forehead. They could grow to 5'9" and often lived in caves. They traveled over 8,500 miles from Africa to Europe or China (8,700 miles) in over a million years, following the herds that moved northward seasonally.

Neanderthals

Neanderthals, or Homo sapiens (“wise man”), lived 200,000 to 250,000 years ago. They lived in Europe (Germany, Italy, Switzerland, France, and Portugal), Asia (Siberia, Poland), and the Near East (Turkey, Syria, Lebanon, and Israel).

A clan was comprised of 6 to 25 members. Males lived to ages 40 to 45, while females, many dying in childbirth, lived to 30. Clans often stole women from neighboring clans. Neanderthals were cave dwellers. The men hunted within their 30-mile territory. Since they lacked in-depth planning, they hunted in zigzag paths after their prey. Neanderthals cared for their wounded and disabled members and buried their dead in a ceremony where they painted the deceased body.

Neanderthals had brawny, short bodies, short arms, and broad trunks and were large brained (low, sloping forehead). They walked with bent knees, heads leaning forward, and were very strong. They were well adapted for cold, harsh climates.

Neanderthals made elaborate use of stone tools. They had hand axes for skinning and cutting game into pieces and choppers for breaking bones to eat the marrow, pound meat, and chop wood. Deniculates could shape and remove bark from wood. Scrapers could clean hides. Curved-back knives could cut flesh easily. Spears were cut with pointy ends, or stone points were placed at the end of the spear. Neanderthals made wooden clubs. They used bones for needles and fishhooks. They could craft warm boots and make a fire by spinning a pointed stick with kindling.

They were hunters and used spears to kill animals as well as force herds off cliffs. They hunted reindeer, red deer, horses, wild cattle, gazelle, rabbit, sheep, and goats. They fished and speared salmon. Neanderthals were also preyed upon by saber-tooth tigers, ten-foot-tall cave bears, foxes, cave lions, woolly mammoths, hyenas, and dogs with huge teeth.

Cro-Magnon Man

Cro-Magnon man, or “Homo sapiens sapiens,” lived around 25,000 B.C. and followed their food throughout the seasons. In winter they returned to their shelters while in summer they traveled, following the herds. Like their ancestors, they ate seeds, berries, roots, nuts, and salmon. They sweetened their foods with honey.

Cro-Magnon man could grow to six feet tall and could live into their 50s. They had a huge frontal lobe and could plan ahead. They hunted in groups or individually. They had stone axes, knives, spears, harpoons, wooden bows, and sharp stone-tipped arrows. They used traps and fished with woven nets. They built rafts and canoes to catch larger fish in the deeper waters.

Click To expand
Neanderthal male hunter and female gatherer, reconstructed from skulls found in La Chapelle-aux-Saints, France and Forbes’ Quarry, Gibraltar. Used with permission from the Neanderthal Museum, Mettmann, Germany (www.neanderthal.de)

Cro-Magnon man learned how to soften leather and use animal gut as thread and bones as needles. In summer they wore woven grass and bark clothes. In winter they wore animal skin clothing and moccasins. Their homes were portable and made like teepees. The teepees were made with branches or mammoth bones and covered with animal skins. Often the large home had a central hearth for a fire. Cro-Magnon painted and tattooed their bodies, perhaps as a sign of social position. They had flint blades and oil lamps.

They created statues out of ivory, bone, and antlers. They made colored cave paintings that depicted hunts and animals (stick figures), and they often had outlines of the artist’s hands. They made necklaces and pendants from shells, teeth, feathers, flowers, and bone.

They ate and were hunted by the same animals as the Neanderthals, except the woolly mammoth and saber-tooth tiger were then extinct. Cro-Magnon man could store and cure food.

Final Thoughts

From this information, gameplay starts to run through your mind. Thousands of Homo erectus tribes leave Africa in search of food (herds) and travel over 8,500 miles into Europe and Asia (think both solo and multiplayer versions). During the journey, they must hunt with their primitive weapons and seek shelter (ideally a cave). Gamers will have the Homo erectus tribe perform daily duties (hunting, cooking, and seeking and making shelter and clothing) through 10 to 15 generations (depending on skill level). The Homo erectus tribe must not become extinct.

Upon successfully arriving at the tribe’s final destination, Europe or Asia, Neanderthal clans of six members will emerge as the gamer’s new tribe, and gameplay will continue through six to eight generations (depending on skill level) with the clan’s membership reaching 25 members. Then Cro-Magnon man dominates the Earth and, through a more advanced intelligence and tool skill, is able to hunt better, survive the environmental conditions, and create art.

Gameplay in The Survival of the Fittest will have the clan or tribes hunting for food and skins with their era’s primitive weapons. As the group is hunting, predators will be hunting them. Another possible scenario is a saber-tooth tiger or a ten-foot-tall cave bear will enter the cave when the clan is sleeping and attack them (another variation of being hunted). This aspect of the hunters being hunted adds to the simulation’s realism and has the gamer using a carefully planned, cautious strategy throughout the game to keep the clan alive and healthy.


Classic Game: Poker

Poker is played by using a single deck of 52 cards. The deck has four suits: clubs §, diamonds ¨, hearts ©, and spades ª. Each suit has 13 cards ranked two through ten, jack, queen, king, and ace (the ace can be the highest or lowest card).

Poker games always begin with a shuffle to randomly sort the deck. A brand new deck always has the 52 cards in suit and rank order.

The Shuffle

Most computer languages have a random function, which is critical to most games. A good idea is to set the initial randomizer to a truly unique number like the current time in military format—a 24-hour clock including hour (0 to 23), minute (0 to 59), second (0 to 59), and millisecond (0 to 999).

When the poker game is first entered and a poker variation is selected, the initial deck of suits and ranks in order should be initialized. Using two random numbers (called “A” and “B”) from 1 to 52 (positions of the cards in the deck), you can exchange the two cards so that card in position “A” is relocated to position “B” and card in position “B” is relocated to position “A.” The shuffle can repeat this exchange many times. Some designers like to make this number a prime or an odd number of exchanges. For the most part, a shuffle of 1,000 exchanges is fine.

After the first shuffle of the initialized deck, the remaining shuffles throughout the game start the next shuffle process with the current shuffled deck.

Hand Rankings

The following examples are in ranking order, meaning the best hand has a ranking of one and the worst hand is of rank ten.

Rank | Hand Name | Description of Hand
1 | Royal Flush | A, K, Q, J, 10 of same suit 10ª, Jª, Qª, Kª, Aª
2 | Straight Flush | Five same-suit consecutive cards 4¨, 5¨, 6¨, 7¨, 8¨
3 | Four of a Kind | Four cards of the same rank 7ª, 7§, 7¨, 7©, 6©
4 | Full House | Three of a kind plus a pair 3¨, 3ª, 3§, Kª, K©
5 | Flush | Five cards of the same suit 3©, 7©, 10©, Q©, A©
6 | Straight | Five cards in sequence 5§, 6¨, 7§, 8©, 9ª
7 | Three of a Kind | Three cards of the same rank J©, Jª, J¨, 8©, 9ª
8 | Two Pair | Two pairs of different rank 5©, 5ª, 9§, 9ª, 8©
9 | One Pair | Two cards of the same rank Aª, A¨, 2©, 4¨, 8ª
10 | High Card | None of the other rankings Kª, 2¨, 4ª, 6©, 8¨

Poker Variations

Poker has many variations with each variation having its own rules. The more popular poker variations are Draw Poker, Five Card Stud, Seven Card Stud, Chicago Hi, Chicago Lo, Texas Hold ’Em, and Omaha. Most poker variations can be played with two to eight players. The cards are shuffled and distributed by a player called the “dealer.” In all variations, the first card is given to the player to the left of the dealer. A round of betting consists of each player deciding whether he should bet (or raise after the first bet was made) an amount from the group’s agreed-to minimum to maximum, fold (quit this round of play), or check (agree to cover the current amount due to the pot). When three raises to the original bet have been made or all players have checked, the betting round is completed.

In Draw Poker, all players make a small blind bet or ante before receiving any cards. Then players, starting with the player to the left of the dealer, receive cards until each player has five cards. Players carefully look at their cards and determine which cards to keep and which cards to discard. Players can discard up to three cards, four cards if they are keeping an ace. Before discarding, each player may bet or raise, fold (quit this round of play), or accept the current bet amount (check). Then the remaining players discard their cards. Another round of betting occurs where each player can bet, fold, or check. After all players have checked or three raises have occurred, the players must show their cards and the player with the highest hand wins the pot (all bets made). If only one player remains (no showdown), he wins and his cards can remain unexposed.

One variation of Draw Poker commonly played is Draw Poker Jacks or Better, where to open the first round of betting, the player needs a pair of jacks or better (a better ranking like three of a kind) to bet. This lets the other players know that he has a hand containing a pair of jacks or better. If no player can bet (no hand has at least a pair of jacks), the cards are reshuffled and a new round begins (ante and all). This variation can build the pot quite large with antes, and players with bad hands can fold earlier.

Five Card Stud is a variation where each player receives his first card face down (called the “hole”), the next three cards are dealt face up, and the last card is dealt face down. The player to the left of the dealer receives the first card. The player with the lowest first card must bet the minimum. Some variations have all players at the start ante up (a small bet). After all players have received their up card (cards two through four), a round of betting occurs. Then after the fifth card (a down card) has been received by all players, the last round of betting occurs. In each betting round after the first, the player with the highest ranking hand showing (only the up cards) starts the betting process. If only one player remains, he wins the pot and his cards can remain unexposed. Otherwise, the remaining players show all five cards, and the player with the highest ranking hand wins the pot.

Seven Card Stud is a variation where the first two cards are dealt face down (the “hole”) and the third card is dealt face up. On the first card up, the player with the lowest card must make the minimum bet. Each player must either bet (raise), fold, or check. After the first round of betting, the player with the highest ranking hand of shown cards opens the betting round. Cards four through six are dealt face up, and after all players have received that round’s card, betting occurs. The last card (the seventh card) is dealt face down unless in an eight-player game all eight players remain; then the last card is dealt as a community card (shared by all players). If only one player remains, he wins (no showdown) and his cards may be left unexposed. Otherwise, all remaining players must show their cards, and the player with the highest ranking hand wins the pot. If more than one player has the highest ranking hand, they split the pot or the player with the highest suit wins. The suit order is usually spades (the highest), hearts, diamonds, and clubs (the lowest).

Chicago Hi plays exactly like Seven Card Stud, except the player with the highest spade in the “hole” splits the pot. The ace of spades is the highest card. If the last card (seventh card) is a community card, it cannot be used as a “hole” card.

Chicago Lo plays exactly like Seven Card Stud, except the player with the lowest spade in the “hole” splits the pot. Players must decide whether the ace of spaces is the lowest card or the two (deuce) of spades is the lowest. If the last card (seventh card) is a community card, it cannot be used as the “hole” card.

Over the last few years, Texas Hold ’Em and Omaha have become popular variations. Texas Hold ’Em is a seven card poker game where each player receives two down cards and the remaining five cards are called “community cards,” which are shared by all of the players. Each player must make his best five-card poker hand using five out of the seven cards (his two cards plus the five community cards). After the two down cards have been dealt to all of the players, the player to the left of the dealer must make a small blind bet. Then a round of betting occurs where each player must bet (raise), fold, or check. Then five cards are placed face down in the center as community cards.

The middle three community cards are turned over (face up) and another round of betting occurs. Then the first community card is flipped over (face up) and another betting round occurs. Finally, the fifth community card is turned over (face up) and the final round of betting occurs. If more than one player remains, the player with the highest ranking hand wins the pot. Any combination of the player’s own two down cards and the five community cards can be used to make the best five-card poker hand. The pot is split if a tie occurs.

Omaha is a form of Texas Hold ’Em that is popular in casinos and on “poker night.” Omaha is a nine-card poker variation where each player is dealt four down cards and the remaining five cards are dealt face down as community cards (for all players to use). Each player must create the best ranking poker hand by using two of their four cards plus three of the five community cards. Just as in Texas Hold ’Em, after the first four cards are dealt, the player to the left of the dealer must make a small blind bet. Then players must bet (raise), fold, or check. The middle three community cards are turned face up and another round of betting occurs. The first community card is flipped and another round of betting occurs. The last (fifth) community card is turned over and the last round of betting occurs. The players remaining show their cards, and the player with the best ranking poker hand wins the pot.

Special Considerations

A deck of cards contains 52 cards. If there are eight players playing Seven Card Stud, the number of cards needed is 56. If all eight players are still in the game, the seventh card dealt is dealt as a “community card,” where all players must use the same card as their seventh (or down) card.

The same scenario can occur in Five Card Draw poker where there are eight players with five initially dealt cards and each player discards three cards, thereby totaling 64 cards needed. If additional cards are needed in Five Card Draw poker, then before a player’s discarded cards are added to the pile of discarded cards, the pile of discarded cards are shuffled and the discarding player receives his replacement cards. Then the discarded cards are added to the pile of discarded cards. This way no player can receive his discarded cards, and each player will receive replacement cards.

A player’s hand is defined as nine cards, where the first seven cards are used to analyze the player’s hand value (ranking). A hand can hold five cards (Five Card Draw and Five Card Stud), seven cards (Seven Card Stud, Chicago, and Hold ’Em), or nine cards (Omaha), so the maximum would be nine.


Strategy Game: The Navy SEALs

In 1998 a major publisher asked me to write up a one pager on a Navy SEALS strategy-action game. This type of game began with titles like “Spec Ops” and “Navy SEALS” and was catapulted into the megahits like Tom Clancy’s Rainbow Six and its subsequent titles like Ghost Recon and Rogue Spear.

Let’s first research the subject Navy SEALs and analyze the current titles that have already preceded us.

History and Facts

In 1962 President John F. Kennedy shared his vision of a special forces military that would combat unconventional warfare, counter-guerilla warfare, and clandestine operations in maritime and riverine environments.

SEAL stands for SEa-Air-Land. SEAL teams receive the SEAL mission and carry out their orders through amphibious support. SEALs must be U.S. male citizens, 28 years or younger. SEALs must have good eyesight with no color blindness.

The physical test screening consists of swimming 500 yards using a breast or sidestroke in under 12.5 minutes, 42 push-ups in two minutes, 50 sit-ups in two minutes, six pull-ups, and a 1.5-mile run wearing boots and long pants in under 11.5 minutes.

SEAL Platoon

A SEAL platoon consists of 8 to 16 members, including two officers, one chief, and 5 to 13 enlisted men such as a point man, a patrol leader, a radioman, 60 gunners, and a rear security man.

The West Coast SEAL teams are responsible for the Pacific Rim, Far East, and Africa/Middle East. The East Coast SEAL teams are responsible for South and Central America, Europe, Russia, and the Mediterranean/Eastern Block territories.

The commander is of rank lieutenant or higher and is in communication with the Task Unit Headquarters with his PRC 117, which his radioman is equipped with, and an MX-300 UHF to instruct his snipers and shooters. The commander patrols as the leader and trails the initial chaos of entry to better control the platoon.

The assault force commander wears a helmet/radio headset, a SPIE rig harness hookup, Nomex gloves, a UDT life jacket, a sit harness, and a Nomex flight suit. He also carries an MP-5 (primary weapon), a secondary weapon (a pistol), flash crashes in a pouch, tie ties for prisoner handling, an UHF MX300-R hand-held radio, medical IV, a one-quart water bottle, a gunshot kit, a gas mask, and grenade inside the grenade pouch.

The breacher is responsible for forced entry into a closed area by utilizing explosives (“breaching charges”) that accurately blast objects forward, away from the assault team. He can also use his sledgehammer to break down doors and walls and is an expert at picking locks if a stealth entry is needed. They train in specialized courses like applied explosive technology and SEAL weapons systems. The breacher wears a helmet, body armor, a Nomex flight suit, Nomex gloves, SPIE rig hookup, a UDT life jacket, and a sit harness. He carries a Remington 870 12-gauge shotgun (primary weapon), spare magazines of ammo, a secondary weapon, a crow bar, a mag light, a sledgehammer, SPIE rigging, a one-quart water bottle, flash crash grenades, a gas mask, MK-13 flares, and a gunshot medical kit and IV.

The sniper is a skilled assassin utilizing deadly skills and camouflage outfits. Snipers rely on real-time intelligence data from the commander. Some missions have the snipers precede the assault team by several days and perform special reconnaissance for the team from a hidden position. When instructed by their commander, the snipers will initiate the assault by removing any guards or terrorists and cover the assault team’s entry into the target area. The snipers are a valuable asset of the assault team. The assault force sniper wears a helmet/radio headset, SPIE rig hookup, body armor, a sit harness, and a Nomex flight suit. He carries an M-16 (primary weapon) with an Aimpoint 3000 optical sight, a .45-caliber handgun (secondary weapon), 40mm grenade vest fully loaded, a UHF MX300-R hand-held radio, and a gunshot kit.

Platoon Loadout (Uniforms)

The standard desert operator loadout is for the members to adapt to the world’s most cruel environment, the desert. Each member wears desert camouflage fatigues, and has a long range M-14 (primary weapon), tinted eye protection, dust goggles, sat-com radio (UHF MX300-R radio), GPS (global positioning system), a radio headset, night vision devices, desert camo bush cap, precision timepiece, two-quart canteen, K-Bar survival knife, an ammo pouch filled, a secondary weapon (a pistol), and a camelback hydration system with an access tube.

The winter warfare loadout consists of their normal loadout plus three lines of gear. The first line of gear includes survival gear such as a compass, flashlight, map, signaling device, emergency rations, spare parts, E & E kit (Evasion and Escape), and a side arm (pistol). The second line of gear includes equipment such as the primary weapon, ammo, grenades, water, medical kit, smokes, flares, and caribiners. The third line of gear includes the equipment stored in the rucksack, such as the sleeping bag, ground pad, tent, mission’s food, gas stove, utensils, dry socks, extra layers of clothing, and a water container. If needed, mountain gear such as an ice pick and snowshoes will also be added to the rucksack.

SEAL Weapons

A Colt .45 is a handgun with an immense amount of power for its size. The Colt .45 large caliber has a force that will stop any aggressive assailant (a huge advantage, especially in trenches). Many SEALs still prefer the Colt .45 over the new P226.

Another SEAL handgun, the P9, is a 9mm automatic that utilizes the H7K roller-delayed blowback technology. The P9 is an inch shorter than the Colt .45 and half a pound lighter.

The M16 and M203 assault rifles have 40mm grenade launchers. The M203 can be attached to the barrel and foregrip of the M14, M16, and Colt 727.

The MP5 compact submachine gun can shoot 9mm rounds at 800 rounds per minute. The gun uses the unique roller-delayed blowback technology, which allows the gun to fire in a fully locked breach position. The MP5 chamber is sealed off by a series of locks and cams, which gives the shooter accuracy when the first round is fired and can mean the difference between success and failure. The MP5 can fire a single shot, a three-round burst, or a full automatic at 800 rounds per minute.

The M60 is a tripod-mounted weapon weighing 23 pounds and using 7.62mm caliber ammunition. Normally, the M60 is a three-person operating weapon, but SEALs operate it as a one-man weapon. A SEAL platoon may have two to three members carrying an M60 so opposing forces may think the SEAL platoon has more members than it really has.

SEAL Vehicles

A desert HumVee is a new SEAL workhorse desert terrain vehicle.

A desert patrol vehicle (fast attack vehicle) is good for long-range reconnaissance and rescue missions. It has no armament and is vulnerable to attack. The DPV can travel fast, is very agile, and can traverse any terrain.

A rigid inflatable boat (RIB) is an extremely fast inflatable boat with a solid hull. The RIB comes in two sizes: the 24-foot and the 30-foot high buoyancy extreme weather craft. The 30-foot craft can get close to the beach if the SEAL platoon is under fire due to its water jet propulsion system.

The Mark V is an 82-foot craft propelled by two 2,285 horsepower HP MTU 12V386 TE94 engines with two KaMeWa K505 water jets. The craft holds 2,600 gallons of fuel and can cruise at speeds between 25 and 45 knots (with a top speed of 50 knots). It can hold a payload of 6,400 pounds and has a range of over 500 nautical miles.

SEAL Training

Land warfare training begins with small tactical unit basics to full mission profiles training in a simulated combat scenario. The platoon will practice shooting for hours on end using .556, .762, and 9mm rounds. Immediate action drills (IADs) are fire and maneuver drills through live fire, day and evening practices, with pop-up flares, smoke bombs, “practice” drop-off charges, and incoming rounds of ammo. This training is followed by a week of field training exercises where the platoon is semi-isolated in a simulated combat scenario. During this week, they will practice special reconnaissance, standoff weapons direct action raid, body snatch, point ambush, and combat search and rescue. The training may include a desert patrol vehicle or a helicopter assist.

In Puerto Rico, hydrographic (water) reconnaissance includes underwater demolition of submerged obstacles, a combat swimming course, and three weeks of diving. A full mission profile consists of being dropped off by a sea vessel or an aircraft for a 30-mile “over the horizon” swim, followed by a turtleback (full dive gear surface kicking toward a dive point), a four-hour, multi-leg dive into an enemy harbor to set limpet mines on the hulls of the target ships, and then evading the anti-swimmer measures designed by the training staff.

Puerto Rico also hosts the jungle warfare training along with Panama. Missions through the dense jungle are practiced using a pump shotgun to clear the dense foliage. Thousand-yard patrols are done, which can take several hours as the path is cleared and the extreme humidity has sweat dripping down your back. Setting up jungle hammocks is required and practiced. The jungle training simulates the SEAL teams in a Vietnam scenario as well as SEAL Team Four’s territories in South and Central America fighting the drug war.

SEAL Teams Two and Five operate in cold, snowy regions. In Alaska, Montana, Upstate New York, and Norway the extreme cold weather/winter training is conducted. This training includes cross-country skiing, snowshoeing, winter and mountain warfare tactics, survival, escape, and evasion techniques. Drills using the combat rubber raiding craft (CRRC) are conducted over 60 miles of open ocean.

Entering and exiting a moving submarine is practiced (also called submarine lock out/lock in). Exiting and entering the submarine through a dry dock shelter is also practiced (DDS MSLO/LI or dry dock shelter mass swimmer lock out/lock in).

Close quarter battle (CQB) requires extensive training, fast recognition, and good reflexes. Some CQB situations include taking down a house one room at a time, hostage rescue in a bus, train, or airplane, and securing a ship after boarding it by air or sea. Advanced courses in explosive entry methods (like blowing open a door without injuring the platoon), room entry techniques (firing your CAR-15 or MP-5 submachine gun), and blinding techniques (using flash bangs) are part of the SEAL training. The ability to properly identify the hostages and the terrorists in a split second in a terrorist/hostage situation is practiced for many hours.

Special missions called VBSS (visit, board, search, and seizure) are critical skills since these missions have the entire platoon securing and controlling a ship.

Special mission training includes unconventional warfare (UW) simulated behind the guerrilla lines scenario, foreign internal defense (FID) training foreigners during peacetime, direct action (DA) where a potential use of force is warranted (ambushes, hostage rescue, target assaults), counter terrorist (CT), and special reconnaissance (SR) where information gathering is done.

SEALs train in parachute rigging, sniper school, emergency medical technician, weapon’s repair, target analysis, intelligence photography, stinger weapon school, hand to hand combat fighting course, NSW communications school, applied explosive techniques, and freefall school and jumpmaster training.

Break Time

At this point we have learned a lot about the Navy SEAL team and platoon responsibilities.

Lots of gaming ideas and concepts should be circling your brain. One idea is a SEAL team game with several missions, such as a hostage rescue in a Middle East town like Beirut, Lebanon, a VBSS mission to seize and control a ship, and a mission to neutralize a South American drug operation.

Perhaps SEAL training is the design you want to begin with, which could lead to several choice missions utilizing the skills learned. There are so many different design concepts that can arise from just a few pages of information about Navy SEALs that a day ago you might not have known. Research helps solidify your initial vision and puts real life situations and facts into your design. Players require a believable storyline and realistic gameplay.

Multiplayer games of this nature have several types of play: deathmatch, capture the flag (CTF), cooperative, and king of the hill (KOTH).

In deathmatch, all players compete against each other to eliminate the most opponents. In capture the flag, players must seek out and capture the opposing side’s team flag and return the flag to their own home base to win. In cooperative play, all players control one of the single player’s squad mates. In king of the hill, the player who occupies a specific marked area for the longest cumulative time wins the game.

Navy SEAL Games

Let’s look at several existing games that are based on the Navy SEAL concept. I have chosen several top games including Electronic Arts’ SEAL Team, Zombie Interactive’s Spec Ops, Yosemite Entertainment’s Navy SEALs, Novalogic’s Delta Force, Delta Force 2, Delta Force Land Warrior and their sequels, and Red Storm’s Rainbow Six, Rogue Spear, and Ghost Recon and their sequels.

Electronic Arts’ SEAL Team, 1993 IBM PC-DOS

This is a 3D tactical combat simulator of the Navy Special Operations in the Mae Khong Delta, Vietnam. Missions include espionage, rescue, recon, and demolition scenarios. Players can choose their team from dozens of commandos who each have their own statistics and specialty. An important gameplay concept is to select many new commandos for each mission, giving them all vital experience. The key to winning SEAL Team is patience and good observation skills.

Good: Team coordination and authentic hand signals used for tactical operations is well done.

Bad: Underwhelming graphics and long pauses waiting for realistic action to occur really hurt this game.

Zombie Interactive’s SPEC OPS, 1998 IBM PC

Spec Ops had a few versions, such as SPEC OPS: Rangers Lead the Way, SPEC OPS: Ranger Team Bravo, SPEC OPS: Stealth Patrol, SPEC OPS 2, SPEC OPS: Omega Squad, and SPEC OPS: Ranger Elite.

SPEC OPS: Ranger

SPEC OPS: Ranger was one of the first games of this genre. Ranger was a first-person shooter with a slower tempo, simulating real world objectives. The team used standard issue weapons for missions based on modern day political hot spots.

Good: A sound AI system.

SPEC OPS: Ranger Team Bravo

SPEC OPS: Ranger Team Bravo had several new missions. The first mission was in Pale, Bosnia, where the team had to track down a Serbian war criminal. Rough terrain and snow made the task slow. The mission was difficult: wipe out an entire small, Serbian mountain base and capture the Serbian war criminal alive and return him to the UN base.

The second mission takes the team to 1968 Thon An Thai, Vietnam, where the dense jungle must be traversed in order to save a downed B-52 pilot as hard rain and the dark night skies impair vision.

The third mission is to Rayat, Iraq, where your team must search and destroy a biochemical facility (five targeted buildings) without causing a toxic cloud explosion. The team must return the evidence though enemy fire by truck to the UN base.

Good: Team Bravo had multiplayer capabilities via LAN or TCP/IP connections, which allowed six players to control two rangers each. The host player could set time limits, number of lives, level, and mode of play (deathmatch, cooperative play, or team vs. team). Single and multiplayer modes contained the 15 original single-player levels, 9 new single-player levels, and 7 special deathmatch levels. The graphics had crisper textures and enhanced lighting effects.

Ranger and enemy skins were more defined and cleaner. Special effects like muzzle flashes were more realistic. Weather conditions functioned better, which included snow, lightning, thunder, and hard rain.

Bad: The snow effect, while functional, was not well done graphically. Each mission had a set of criteria that had to be met for a successful mission. Any unsuccessful mission had to start again.

The game contained poor AI (the first version). Enemies were stationary and easy to kill, and the computer-controlled team members had weak path finding.

Algorithms had enemies often getting stuck behind trees, bushes, and objects. The team members also wouldn’t move when fired upon. Many 2D sprites were used to simulate a 3D object so trees, bushes, and objects looked repetitive and fake. Special effects like smoke, explosions, and weather were obvious 2D sprites, and the human characters had a low polygon (poly) count.

SPEC OPS: Rangers Lead the Way

Rangers Lead the Way is a realistic, action oriented, real-time 3D-person game based on the elite warfare units. The goal is to control your team of rangers and eliminate the opponent’s targets in a timely manner while completing your mission’s subtasks.

Click To expand

Good: Extraordinary visuals like fancy fireworks and light sourcing. Realistic team movements and terrain features, full mouse support, and the annoying timer was removed (time allotted to complete a mission).

Yosemite Entertainment’s Navy SEALs, PS2, and IBM PC

Navy SEALs is a squad-based action game where players select a team of highly trained commandos by recruiting each team member, equipping them, and setting their exact path for the mission. During the mission, the player controls one team member, and the computer (AI) controls the remaining team members. Navy SEALs has a unique helmet interface that lets the player switch between the team members that they control. To successfully complete a mission, understanding each team member’s special abilities (such as technical specialist, explosive expert, sniper, and weapons specialist) is required. Navy SEALs’ missions include invading a small island and infiltrating corporate buildings. Each mission has three squads of four team members each.

Good: Great graphics

Novalogic’s Delta Force

Delta Force had competition with Rainbow Six’s huge advertising budget and the household name recognition of Tom Clancy. Delta Force was well reviewed and hailed by fans but lost to Rainbow Six in sales.

Novalogic’s high quality demo available weeks before the game’s release had a devoted fan base awaiting its October arrival. Delta Force made PC Data’s Top 50 Games list.

Free Internet support through NovaWorld Server with support for up to 32 players per game really helped Delta Force in its marketing and selling.

Delta Force has more than 40 exciting missions dealing with global issues like a Central Asian airfield takedown, nuclear terrorism in Northern Russia, and drug cartel raids in South America. Gameplay occurs in either first- or third-person POV with realistic sound effects using 3D positional sounds.

Click To expand
Click To expand
Click To expand

The weapons used in Delta Force are: Barret .50 “light fifty” model 82A1 is a long-range, high powered rifle perfect for snipers. M249 SAW (squad automatic weapon) is a hand-held, portable machine gun that can fire 200 rounds of 5.56mm ammo. M4 5.56mm carbine assault rifle is a lightweight and accurate, gas powered rifle used extensively for close quarter combat. M40A1 sniper rifle is a hand-made rifle based on the Remington 700 and made by gunsmiths at the rifle team equipment shop at Quantico, Va. for superior accuracy. Heckler & Koch 9mm MP5 SD submachine gun is a silent and accurate submachine gun capable of single-shot, burst, and automatic firing. Cot M 1911A1 .45 is a superior handgun that is handmade by gunsmiths at the rifle team equipment shop at Quantico, Va. High standard .22 pistol is a silent and super accurate handgun. M-72 LAW (light antitank weapon) launches a single 66mm explosive round that can penetrate a target with up to 350mm of armor. M18 claymore is an anti-personnel mine combining a sheet of C4 plastic explosive and 700 ball bearings inside a curved plate. An M57 remote firing device (called a “clacker”) has the exploding ball bearings propelled in 60-degree arcs traveling at a high speed up to 50 meters. Satchel charges are packed with high explosives for demolishing buildings and walls.

Good: Free Internet support

Bad: Lack of control over the computer controlled teammates and squads

Novalogic’s Delta Force 2

Delta Force 2 has over 40 day and night missions in weather conditions like snow, rain, and fog. The multiplayer mode has new games like Attack and Defend, Search and Destroy, and Flag Ball.

Click To expand

New weapons include a silenced Heckler & Koch .45 USSOCOM (United States Special Operations Command), the Heckler & Koch P11 (an underwater pistol), a Russian-made underwater rifle, time-delay grenades, a laser designator, and tracer rounds. A LAR V rebreather for extended underwater submersion is also available as well as a field-surveillance video camera.

Click To expand
Click To expand

A lot of veteran fans requested a mid-mission site to change and fix weapons. So an “armory” building was created to allow players to change gear and fix machine guns and grenade launchers.

Weapons: Heckler & Koch 9mm MP5 SD 3 submachine gun, M249 SAW (squad automatic weapon), M-72 LAW (light antitank weapon), M40A1 sniper rifle, Barret .50 “light fifty” model 82A1. These five are the same as in Delta Force.

Other weapons: 5.66mm APS underwater assault rifle shoots penetrating 150mm long darts. The “master key” (a M4 combined with a shotgun) is a gas-operated rifle and an attached shotgun that can easily remove any door. Heckler & Koch P11 underwater pistol is a silent, electrically charged pistol. Heckler & Koch USSOCOM semiautomatic .45 pistol. M4 5.56 carbine assault rifle and M203 grenade launcher fires 40mm explosive ammunition. Fragmentation grenades will explode on impact or have a four- to seven-second time delay. Ka-Bar knife for silent, close-range attacks. LAR V rebreather for extended underwater submersion. Ghilke suit is a camouflage sniper suit. Kevlar vest is a body armor that protects against small arms fire.

Good: Delta Force 2 has smoother animations and more detailed graphics. The missions have a connecting storyline and new weapons are available. In single player, you can set waypoints and orders for your teammates and have the ability to revise those orders during the mission. Multiplayer has a new commander’s screen that allows easier attack coordination and lists needed multiplayer data like the player list, team list, and game settings (length of match, winning conditions, and mission briefing describing the goals and objectives).

Team member movements (animations) were added for swimming and climbing (ladders and sides of a building). Character “death” animations were made more realistic and varied. The enemy has a better AI algorithm using new, effective tactics.

An “in-game” save feature and a built-in mission editor were added. Better enhanced graphics supporting 32-bit color were added, making the terrain and weather effects (fog, rain, snow, and wind) realistic.

Realistic physics and ballistics (bullets penetrating various objects like a tent, a wall, or a concrete barrier) were implemented taking into account gravity, wind direction, and velocity. When a character fires, the shot is affected by gravity and wind. When a character falls or jumps, gravity determines the character’s injury or death.

NovaWorld server now supports up to 50 players and four teams, not just two. A “no-respawn” option forces dead players to leave the game.

Uniforms can be customized to give squads their own, unique look. Medals and awards are given to the best players.

Communicating with other players over a full-duplex sound card is handled entirely by the NovaWorld server (VON, or voice-over net technology).

Novalogic’s Delta Force Land Warrior

Delta Force Land Warrior has stunning and intense action. The ability to snipe someone from half a mile away while descending from a parachute is a great feature. In Delta Force Land Warrior, you are in control of an advanced strike team. Missions deal with terrorists and hostiles throughout the world. There are huge terrains to play on with tunnels and indoor scenarios.

Click To expand

The multiplayer mode has capture the flag, king of the hill, and cooperative modes, and up to 50 players can play at a time. Players can choose their teams from sniper, demolition, close quarter battle specialists, aquatic experts, and heavy gunners.

Weapon loadouts have increased from four (primary weapon, sidearm, grenades, and ammo or a LAW) to five (primary, secondary, sidearm, explosives, and auxiliary gear). The newest weapon of the future is the Alliant Techsystems’ OICW assault rifle. Additional weapons include the Steyr AUG light assault rifle, MM-1 grenade launcher, the Pancor jackhammer shotgun, the PSG-1, the FN mag light machine gun, the Heckler & Koch G11 assault rifle, Calico submachine gun, the Heckler & Koch .45 SOCOM, the Glock 18 submachine gun pistol, the AT-4 light anti-armor weapon, and a medic pack for multiplayer medics.

Another feature is picking up weapons from dead opponents. They use the same weapons to which you have access.

Good: Sharper, more detailed graphics

Basic System Requirements:

Video Card: Direct 3D compatible video card required. 3dfx Voodoo 3 or NVIDIA TNT2 recommended. Supported 3D cards include: 3DFX Voodoo 2, 3, 5, NVIDIA TNT, TNT2, GeForce, GeForce2, ATI Rage Fury Max, Matrox G400

Operating System: PC, CD-ROM, Windows 95, 98, Me, 2000 (DirectX 7.0 or greater)

CPU Type and Speed: Minimum Pentium II, Celeron 400, or equivalent required, Pentium II 400 MHz or equivalent recommended

Hard Drive Space: 200 MB available

System Memory: 64 MB required (with AGP video card: 128 MB recommended)

CD-ROM Speed: 4x CD-ROM drive

DirectX: DirectX 7.0 or greater required (included on CD)

Sound Cards: Windows compatible. Voice-over net (VON) requires full duplex sound card

Supported Controllers: Windows compatible mouse

Internet Play: Up to 50 simultaneous players via NovaWorld servers (Internet service provider required)

LAN Play: IPX LAN Support

Novalogic’s Delta Force: Task Force Dagger

Delta Force: Task Force Dagger is based on missions from Operation Enduring Freedom where the player controls up to ten different Special Forces soldiers in over 25 missions set in Afghanistan. Each team represents members of the 2/75th Ranger, SEAL Team 6, CIA Spec Ops, the UK SAS 22 Regiment, SFOD-SF Viper Team (Green Berets), Australian SASR, Canadian JTF-2, Marine Force Recon, USAF CSAR (Air Force Pararescue), and SFOD-DELTA.

Missions range from Kandahar to Mazar-i-Sharif to Tora Bora, each in deep enemy territories. Delta Force operatives’ missions include raids on rebel headquarters, taking control of a local airport, ambushing enemy convoys, and destroying key SAM and SCUD missile sites.

Delta Force: Task Force Dagger uses NovaLogic’s updated Land Warrior engine and is designed as a stand-alone mission pack with new characters, weapons, and single and multiplayer levels.

Delta Force: Task Force Dagger includes 25 all new missions designed to test the team’s reactions and bravery while operating under fire. This version is the first Delta Force game where the player represents different Special Forces soldiers with unique abilities and has over 30 weapons to select from, including 17 brand new weapons. Each mission is realistic and includes a strategic recon and objective, such as locate and neutralize, infiltrate and secure, and escort and protect civilians. UAVs (unmanned aerial vehicles) can be used for spying and calling in devastating air strikes. Missions include a takeover of the Kandahar airport, a raid of rebel headquarters in Mazar-i-Sharif, an ambush to a convoy near the Pakistani border, the elimination of a command and control compound in Kandahar, the demolition of bunkers in the foothills of Kabul, destroying a SAM site, escorting a journalist through hostile territory, and raiding the Abu Khabab chemical weapons facility.

The 17 new weapons in Delta Force include primary and secondary weapons, sidearm weapons, grenades, and explosives. The primary weapons are the Diemaco C8 carbine with ELCAN scope, M16A2 with M203, M4 SOPMOD with ACOG scope and Knight Rail accessory system, SA80 individual weapon, M60 assault rifle, M60E3 assault rifle, M24 sniper rifle, M40A3 sniper rifle, and AW sniper rifle. M4 SOPMOD has a telescopic butt-stock with ACOG scope and KRAS, which is a 5.56mm assault weapon produced for the U.S. Army, and Knight Rail accessory system. The AW sniper rifle is a 7.62mm sniper rifle, a second-generation sniper rifle developed for Artic warfare functioning in temperatures below –30.

The secondary weapon includes the F89 Austeyr. The sidearm weapons are the Browning HP, Sig P226, FN Fortynine, and F97 (Glock 19). The Browning HP is a 9mm side arm that was designed in 1935 by John M. Browning. The Browning HP is in active service all over the world.

The grenades include the US Mk3A2 concussion grenade, and the explosives include the Alliant SLAM (selectable lightweight attack munition) and the M72 LAW (light anti-tank weapon). Mk3A2 concussion grenade is an offensive hand grenade, commonly referred to as the concussion grenade, designed to produce casualties.

The tactics include scenarios like spying on the enemy and calling in air strikes, controlling the cameras on unmanned aerial vehicles to gather visual intelligence and plan your attack with the element of surprise, and calling in devastating air strikes to take out key SAM and SCUD missile sites.

Multiplayer mode NovaWorld or LANs have ten new multiplayer maps, deathmatch, capture-the-flag, and co-op modes. Players can create infinite game types and maps with the mission editor.

Novalogic’s Delta Force Urban Warfare

The Delta Force franchise set the standard in first-person military action shooters when it was released and has a customer base of 2.6 million PC gamers globally. Now Delta Force Urban Warfare is designed for the PlayStation game console in an all-new Delta Force experience by Rebellion.

Click To expand

Diverse, intense gameplay includes wild shoot-outs combined with stealth tactics, close quarters combat (CQC) with strategic infiltration, time-sensitive ops, sniping, and demolition. An advanced enemy AI lets players engage and defeat enemies that react to gunfire, dive for cover, employ tactical maneuvers, and pursue using a player’s blood trail.

The new firepower and hi-tech gear includes assault and sniper rifles, grenade and rocket launchers, plus remote explosives, night vision and thermal goggles, combat radar, and a security camera scrambler.

There are 12 challenging missions, such as intercept communications, capture prisoners, and conceal enemy bodies. Blast your way out of a bank robbery, rescue and protect hostages, defuse explosives, and attack an oilrig.

Urban Warfare has an intriguing storyline (presented in cut-scenes and in-game radio messages) that propels you through each mission.

Novalogic’s Delta Force: Black Hawk Down

Click To expand

NovaLogic’s Delta Force: Black Hawk Down is set in Somalia in 1993 and based on the real-life events of Operation Restore Hope and Task Force Ranger campaigns by the U.S. Army and Delta Force against the oppressive Somali warlords in and around Mogadishu. The latest NovaLogic game engine is utilized for the PC CD-ROM version and the Xbox and PlayStation 2 versions. The gameplay includes missions such as firing from vehicle mounted weapons, including the .50-caliber fixed machine gun, close quarters battle engagements and Delta Force’s signature long-range engagements, authentic weapons used during the actual Operation Restore Hope campaign by the U.S. Special Forces, a new AI system allowing enemies to intelligently track the player, large-scale multiplayer action via NovaWorld or a LAN, stunning graphics, and a realistic, gripping storyline.

Red Storm’s Rainbow Six

Rainbow Six is from legendary author Tom Clancy and has the player leading an elite multinational task force to battle international terrorism in a series of realistic missions and mission training sessions. Rainbow Six is designed in two parts: mission planning and mission execution (action).

Click To expand

The training mission is comprised of various shooting ranges, obstacle courses, and single-team and multiteam hostage rescues. The main campaign has various multiplayer modes, such as cooperative mission, deathmatch, and team deathmatch.

There are three levels of difficulty for the campaigns where each level has more objectives and less team casualty tolerance. To advance to the next mission, you must successfully complete the previous mission. If you accidentally kill a civilian or yourself (even if you injure yourself), the mission must be repeated. Even one bullet can injure or kill you, so wearing body armor will protect the team and perhaps make a mission successful.

Rainbow Six can be played in first- or third-person POV. The team is selected before each mission from 20 possible characters. The first mission plan is provided, and the remaining missions are up to the player to plan. Each mission requires the mission’s plot objectives (such as rescuing hostages, stealing vital information, disarming a bomb, or covert actions) to be successful.

Players can switch between teams but not team members, and waypoints can be set for team members to follow.

Weapons: Benelli M1 tactical 12-guage, M-16A2, Beretta 9mm 92FS, Heckler & Koch .40 USP, Heckler & Koch .45 MARK 23, flashbangs, explosive flares, grenades, door charges, disarm bomb kit, disable alarm systems kit, heartbeat sensor

Good: Simple Quake-like interface with an immersive, realistic feel. Better graphics, especially in human motion and movement and lighting. Realistic audio, background sounds, character voices, and special effect noises (realistic gun sounds). Solid storyline and a good manual.

Bad: Poor AI when engaging enemies, especially in CQB situations (patch available). Teammates will wait for the next waypoint “go code” instead of moving. Grenade explosion zone is too limited. It’s around two feet from explosion point. A lot of time is spent defining and redefining the mission layout (average mission planning takes 20 to 40 minutes). Multiplayer deathmatches can be one shot and you’re out (dead). Single-player missions are short and easy to solve.

Red Storm’s Rogue Spear

Terrorist activities require the Rainbow Six team’s special abilities. Initially, the terrorist attacks seem random, but the team soon uncovers the truth behind this cleverly planned strike.

Rogue Spear has 18 missions, such as (fourth mission) hostage rescuing in Djakovica, Kosovo, where a NATO helicopter has been shot down and the pilot and passenger need to be rescued. In the sixth mission, the team must enter an enemy base, disable the security system, plant a phone bug and a surveillance camera in a key area, and leave unnoticed.

After a mission is successfully completed, two new modes are available: lone wolf and terrorist hunt. In lone wolf the player traverses the map alone with thirty randomly played enemies on alert. In terrorist hunt the player wanders the map and must kill all enemy characters.

Rogue Spear still has the practice mission and branch campaign options as in Rainbow Six. There are new orders that can be given, which are cover, defend, and snipe.

Rogue Spear has weather conditions like snow and rain. The characters can now crouch, limp, die in realistic manners, and peek around corners. Rogue Spear has three new sniper rifles and new assault rifles.

The “watch mode” allows players to see the mission as it is carried out and enter it at any point.

Good: Better graphics with greater levels of detail, larger mission terrain, and better character animations. Highly decorated buildings with nice-looking interiors including randomly wandering civilians. The textured planning map looks great. Graphics support now includes 1024x768 resolution. The snipers are much better to control. Multiplayer has great options like the ability to play Rogue Spear on Mplayer and MSN Gaming Zone. Also, the assassination mode in multiplayer (to defend an NPC, a building, or a base) is great.

Bad: Graphics have polygonal clipping problems. First- to third-person switching has misaligned texture and clipping problems. The AI was fine-tuned (enemies now act more realistic) but perhaps too much since enemies rarely miss. Computer-controlled team members move and react worse than in Rainbow Six. Team members still get stuck in doorways, stuck on ladders, and fall off elevated walkways. The new planning interface is cluttered and hard to understand. The team members still can’t jump, crawl, or swim, which would make the game better.

The first three missions are rather boring to play.

Rogue Spear: Black Thorn

Team Rainbow has a new deadly enemy that knows how Rainbow thinks, how Rainbow acts, and how to stay one step ahead.

Black Thorn features new multiplayer mode (lone wolf), up to 16 players in multiplayer mode, six new training/multiplayer maps, more than ten new weapons for single and multiplayer modes, and a bonus CD (The Making of Tom Clancy’s Ghost Recon) containing developer interviews, gameplay video, hints and tips, weapon previews, and more.

Minimum system requirements include a CPU with 266 MHz Pentium II processor or better, an operating system with Windows 95/98/2000, 64 MB RAM (128 MB recommended), a video card with DirectX 8 or higher, compatible 2D video card capable of 16-bit color, 3D hardware support with DirectX 8 compatible video card with 4 MB VRAM (DirectX 8 compatible 3D accelerator with 16 MB VRAM recommended), CD-ROM with 4X or better, sound with DirectX 8 or higher compatible sound card required, and 550 MB free hard drive space required (1 GB recommended).

Rogue Spear: Urban Operations

A barrage of cold-blooded, grenade-throwing terrorists challenge your skills and training. The game features famous cities in real-world locations, five fantastic new levels with four game types for each, more than five new multiplayer levels playable as single-player terrorist hunt or lone wolf, five classic levels from the original Tom Clancy’s Rainbow Six, and terrorists with new skills.

Red Storm’s Ghost Recon

Ghost Recon was IGN’s Game of the Year. Ghost Recon has missions in forest terrain, murky swamps, and urban combat terrain. Players can choose six teammates, not just three, to be distributed among the three mission squads. The mission’s possible team can be chosen from six rifleman, two support specialists, two snipers, and two demolition experts. A new device called a “threat indicator” alerts you to the enemy’s location.

Good: Great graphics with superb trees and shrubbery. Better AI for the enemy and team members. Enemy AI fire will display tracers. The enemy will cover, flank, and go prone. Teammate AI is improved, especially in backing you up. The in-game planning interface has improved and represents the future implementation of the U.S. Military’s land warrior system.

Ghost Recon: Desert Siege

Red Storm’s Ghost Recon continues with Desert Siege, which takes place in East Africa, 2009. A 60-year conflict boils over as Ethiopia invades its smaller neighbor Eritrea, threatening the world’s most vital shipping lanes in the Red Sea. An elite team of U.S. Army Green Berets, known as the Ghosts, moves in to safeguard the seas and free Eritrea. As the war rages on, the Ghosts are drawn from Eritrea’s shores to the heart of Ethiopia in their deadliest battles yet.

Rainbow Six: Eagle Watch

Rainbow Six: Eagle Watch is an expansion pack that requires the full version of Rainbow Six to operate. This time terrorists threaten the world’s most famous sites such as the Taj Mahal, Big Ben, the Forbidden City, the Senate wing of the U.S. Capitol Building, and a classified Russian shuttle.

The new multiplayer modes (two to eight players) include assassin, scatter assassination, scatter, team terrorist hunt, team scatter terrorist hunt, and save the base.

Assassin mode is when teams at one insertion point kill the other team’s general. Scatter assassination mode is when teams are at scattered positions from the start and must kill the other team’s general. Scatter mode is when the team’s individuals are placed initially at scattered positions. Team terrorist hunt mode is when teams start at one base and attempt to kill terrorists. The team that kills at least half of the terrorists first wins. Team scatter terrorist hunt mode is when teams starting at scattered positions attempt to kill terrorists. The team that kills at least half of the terrorists first wins. Save the base mode is when each team attempts to defuse a bomb located in the other team’s base.

The new weapons include the Desert Eagle .50-caliber (a very powerful handgun capable of piercing body armor with its six-round magazine), Heckler & Koch G36K assault rifle (a compact rifle useful in CQB with a 5.56mm round capable of piercing most body armor), and the Heckler & Koch G3A3 assault rifle (most accurate rifle firing a powerful 7.62mm NATO round).

There are also four new operatives added to the Rainbow Six team.

Rainbow Six: Eagle Watch is available for the PC, Macintosh, PlayStation 2, and N64.

Good: Beautiful graphics of the world’s most famous sites. Full watch option where players perform the planning and let the computer execute it as they watch each step executed, which turns Eagle Watch into a strategy game. The new multiplayer modes are well done, especially the new training modes and maps. The available options are a great feature. This expansion pack is worth the cost and is better than some of the new top sellers.

Bad: Using the “default plans” for each mission, the experienced player can finish Eagle Watch (all five missions) quickly. The new weapons add nothing to the gameplay. The four new operatives are not significant. The manual is still Red Storm’s worst feature. The enemy AI is still lacking, especially when they idle in place and stand around looking as if they are unaware that an attack is about to occur.

Rainbow Six: Covert Operations Essentials (aka Covert Ops)

Rainbow Six: Covert Ops gives the player an insight into the real world of counter-terrorism from 1970 to today. The first of two CDs is a stand-alone (no previous version of Rainbow Six or Rogue Spear is needed to play) mission pack containing nine new missions ranging from a simple covert training mission to a complex jungle search and rescue mission through enemy terrain. The second CD contains a complete Rainbow Six team kit including real-life documentation and tactical training based on the most accurate real-world sources. The player, using these actual military documents, executive-level briefings, and interviews with field experts, advances through a series of tests where success earns the player achievement ribbons for the character. A wide selection of interactive tests are provided from simple document-based questions to complex photo and video-based questions.

Red Storm’s Rainbow Six: Raven Shield

The latest addition to the Rainbow Six action-packed, realistic series is Rainbow Six: Raven Shield in which the Rainbow Six team, as told by legendary author Tom Clancy, is commissioned to utilize its advanced technology throughout the world. The latest Unreal engine is being used in this 15-mission, single-player mode that has the gameplay in first-player perspective. The Unreal Warfare engine gives Raven Shield detailed textures, realistic animations, real-time lighting effects, and shadows. The Unreal Warfare engine has features such as skeletal meshes that allow for movement through the program and now through scripting or canned animations. The sound effects in Raven Shield are very realistic, and the ambience is heard throughout the player’s environment.

The next change from previous versions is in the planning screens or pregame menu system, which is now much easier to understand and faster to manipulate (the same options are still available, just easier and more user-friendly). A quick order interface allows for real-time insertion of orders. From a single screen, a team can be selected, put in uniform, and sent out on a mission. The old way of planning the operation in a detailed method is still available. Raven Shield allows each weapon to be modified with one additional attachment, such as a sound suppressor, thermal sniper scope, high-capacity magazine, or a mini-scope. Even if a weapon has a built-in attachment such as the MP5SD5, which comes with a sound suppressor, it can have an attachment added to it. Think of the combinations of adding one of four attachments to the 57 weapons included in Raven Shield, and you have a lot of high-tech weaponry that matches real-world available weapons.

Some of the new weapons in Raven Shield are the MTAR-21 9mm submachine gun, the Mac-11/9 9mm submachine gun, the Micro-Uzi 9mm submachine gun, the SR-2 9mm submachine gun, the USAS-12 12-gauge shotgun, the TAR-21 5.56mm assault rifle, the Type 95 5.56mm assault rifle, the VSS Vintorez 9x39mm sniper rifle, and the 23E 5.56mm machine gun. Also at your disposal are claymore mines, tear gas grenades, gas masks, smoke grenades, and frag impact grenades.


Sports Game: Baseball

I have often stated that games have pushed the envelope and technology of computers. Word processors and spreadsheets have not required faster CPU speed like 800 MHz or 2 GHz computers, nor have they demanded 32-bit color palettes or massive storage devices like CDs and DVDs. The players’ desire for faster, prettier, and more realistic games has created today’s environment. Games have created the markets for quality sound cards and speakers as well as 3D accelerator cards.

Sports games, in order to satisfy their fans’ needs, have pushed the realism of gaming in terms of the graphics (3D polygons and skins or “textures”), the game’s physics (from the movements of the players and the motion of the ball to the natural effects of gravity, weather, and bouncing off surfaces), and real-world statistics. Some sports games like football have options to link into the U.S. Weather Bureau site to download the current weather and wind conditions for all stadium venues.

Baseball Basics

A baseball team consists of nine main players, which include the pitcher, catcher, infielders (first baseman, second baseman, third baseman, and shortstop), and the outfielders (left fielder, center fielder, and right fielder).

The baseball game lasts nine innings, unless a tie exists; then it continues until one side has outscored its opponent. An inning consists of each team playing until they have three outs by a strikeout, pop-out, or tag out. If a batter has been thrown four pitches outside the strike zone, that player advances or walks to first base (called a “BB” or “base on balls”). A strike occurs when a pitch is swung at and missed, hit in foul territory on the first two strike counts, or called a strike by the umpire. Three strikes and the player is out (called a strikeout or “SO”). Three outs retires the side (half of an inning). A “fielder’s choice” is when a batter pops the ball into the infield, which becomes an automatic out regardless of whether the ball is caught or not. A “double play” is when two outs occur in one play. A “triple play” is when three outs occur in one play. A doubleheader is two baseball games with the same teams back to back.

The infield, or diamond, has a home plate and three bases that are 90 feet apart with 15-square-inch bases. The pitcher’s mound is 60.5 feet from home plate and is raised ten inches above the field.

The pitcher’s arsenal consists of the fast ball (an up-spin pitch), a curve ball (a down-spin pitch), a change-up (slower to fast curve ball), a slider (a side spinner), or the breaking ball (change of direction ball). The pitches can fly over the plate from 50 to 100 mph.

A “foul ball” is a ball batted that lands in foul territory, an area behind home plate, the area left of the left foul line, or the area right of the right foul line. A foul ball cannot be the third strike. A “fair ball” is a ball batted that lands in the outfield or anywhere between the first base foul line and the third base foul line (including over the outfield wall). On either side of home plate is the “batter’s box,” which is six feet long by four feet wide. A “run” is when a player advances around the bases and safely touches home plate. A “steal” occurs when a player advances to the next base without the ball being hit. Stealing usually occurs when the ball is being pitched.

Umpires judge pitches that the batter hasn’t swung at and determines if they are within the strike zone or not (they are ruled as a “strike” or a “ball”). A swung-at ball is always a strike or a hit. A tap (usually light) of the ball is called a “bunt.”

A baseball is 9 to 9.25 inches in circumference. The bat (wood or metal) can be up to 42 inches long and 2.75 inches in diameter. Fielders (all nine of them) wear padded leather gloves on their non-throwing hand. The catcher and first baseman wear special gloves. The catcher also wears a face mask, shin guards, and a chest-protecting pad.

In Major League baseball there are two leagues, the American and National League. The baseball season starts in April and ends in October. The best teams win their conference championship (two divisions in each league) and play the World Series. The All-Star game is played by players who are voted on by fans to play on their league’s team, either the National League or American League team. The All-Star managers are the previous year’s championship team’s managers who select their All-Star team’s pitchers.

Baseball Data

The first and oldest rule in research is “check and recheck your facts.” Never assume that the data given to you by a reputable source is accurate and complete. Check other reliable statistics sources like CBS sports or ESPN web sites.

When I received the data for General Mills’ All-Star Baseball, the data was missing important statistic fields and individual player statistics, had inaccurate or jumbled statistics (like 367 was 376), and needed significant checking to verify the given data and supply the missing data needed.

Baseball data was divided into two major groups: team data and player data. Team data included the team name, team graphics (logo, 3D stadium, team uniform for home and away games, and so on), stadium location, franchise facts, ticket prices, and club owner. The player data was categorized by player bio, graphics, all batting information, fielding information, and pitching info (if the player is a pitcher).

Player bio information included the player’s birthday, hometown, position (manager, coach, pitcher, catcher, infielder, or outfielder), salary, height, weight, and so on. The graphics included the player’s face texture or skin file name, the player’s uniform (including the number and special patches worn), and so on. The player’s batting information included batting statistics, batting side right, left, or switch hitter, special batting stance, batting swing and running to base animations, and so on. The fielding information included catches right- or left-handed, fielding statistics, special running and catching animations, and so on. The pitching information included the pitch type thrown, pitching statistics, pitching specialty (like relief pitcher or starting pitcher), and so on.

I wanted the player’s personal data (like birth date) to tell gamers interesting facts when they played the game, like “Today is the following player’s birthday.” This feature becomes an easy one by reading the computer’s internal clock (date and time) and reading all of the players’ birthdays from the database that you’ve created and modified. Like baseball trading cards, I wanted to supply the players’ height, weight, and hometown for announcers to add to their colorful commentary or as a statistic used along with the players’ thumbnail photo as they’re coming to bat. The player’s hitting statistics are needed to properly compute the results of the game’s hitting “eye and hand” twitch skills used in sports games. A home run hitter would more often strike out or hit triples and home runs over hitting singles and doubles. Pitchers, on the other hand, generally strike out or hit singles. Given the exact same swing data (the same pitch type and strike zone location, the same hit type like a “power swing,” and the same connection timing of the bat with the ball), you would expect the real world results to vary greatly if the batter was a home run hitter rather than a pitcher.

One rule I decided early on in the data gathering process was to be consistent and able to explain my decisions to a hardcore fan. One such example of this was with American League pitchers who do not bat, except in certain games in the World Series. The first data I used was the last year the pitcher had a valid batting statistic. Then I would use that pitcher’s lifetime statistics for batting. Lastly I used any minor league or previous (to becoming a professional pitcher) batting statistic I could find. Generally, I found most of the statistics I needed.

One hard-to-find statistic was running and throwing speeds for all players to accurately calculate base running and field throwing to tag a runner out. I tried to find a 100-yard dash timing statistic to grade players into several speed categories (for both running, stealing, and throwing).

Let’s examine the real world of baseball versus the computer, statistic-based AI we need to design. The situation to examine is a runner on first base when the batter hits the ball into center field. The experienced center fielder picks up the ball and throws it to the second baseman. This is an every-game, real-life situation. How can the computer accurately recreate this scenario?

Based on the twitch indicators and that batter’s real-world batting statistics, the resulting hit or strike can be calculated. The twitch indicators include the type of pitch, the selected “aimed at” strike zone location, the type of batting power, and the “bat-to-ball” connection timing. The batter’s real-world batting statistics are percentages for a strike, a single, a double, a triple, a homerun, and a pop out. The ball’s trajectory and speed can be accurately computed, including weather, wind, and gravity factors.

Now that the ball’s flight and expected landing position are known (through calculations), each player in the field calculates, based on his present location and running speed, who can get to the ball the fastest (in this case, the answer is probably the center fielder). The center fielder runs toward the ball’s final location, which was already calculated. Upon picking up the ball (our calculations determined that a catch couldn’t be made in time), he looks at the runner on first base. The first calculation needed is the distance from the first base runner’s current position (he might have been leading off the base) to second base multiplied by his standard base running time (remember that 100-yard dash statistic!). Then the same calculation is made for the batter running from home plate to first base. A calculation is made for the center fielder, knowing the distance from his position to first base and his position to second base and his throwing speed statistic. Each calculated scenario is compared: (1) the center fielder’s throw to first base time versus the batter’s running to first base time and (2) the center fielder’s throwing time to second base versus the first base runner’s time to second base.

Obviously, whichever scenario is quicker for the center fielder to execute is the outcome of this play. In this case, the center fielder will throw to the second base player who (calculated as being closest to the goal of stopping or tagging out the runner who was on first base) is closest to that position. This is a simple description of simulating in AI the real-world thinking and spontaneous actions that we see every day.

Baseball Games

The current selection of top baseball games are published by the majors including Interplay (recently halted a new version of baseball), Microsoft, Acclaim, and 3DO and Electronic Arts.

Interplay published VR Baseball, which was last published as Interplay Sports Baseball 2000. Microsoft’s offering is MS Baseball 2001 for Windows. EA Sports, which proclaimed “We are Sports,” has their studio 3DO and its head, Trip Hawkins, publishing High Heat Baseball 2002 for Windows, the PlayStation 2 (High Heat Baseball 2003 for PSX 2 E), and Gameboy Advance (both in 2002 and 2003 versions). EA’s predecessor baseball offering was Triple Play Baseball. Acclaim has their All Star Baseball for 2002 and 2003 for the Game Cube, PSX 2, and Microsoft’s Xbox.

  • Interplay Sports Baseball 2000

    Interplay VR Baseball 2000 Windows CD $9.95

    Interplay Sports Baseball 2000 Windows $29.95

  • Microsoft’s Baseball 2001

    MS Baseball 2000 CD Sports $18.95

    MS Baseball Slugfest XBOX Sports $49.95

  • EA Triple Play Baseball

    Triple Play Baseball CD Sports $24.95

  • EA/3DO High Heat Baseball 2002 and 2003

    High Heat Baseball 2002 W95 CD Sports $24.95

    High Heat Baseball 2002 PSX 2 T Sports $29.95

    High Heat Baseball 2002 PSX 2 E Sports $29.95

    High Heat Baseball 2002 Gameboy Advance E Sports $39.95

    High Heat Baseball 2003 PSX 2 E Sports $49.95

    High Heat Baseball 2003 Gameboy Advance Sports $39.95

  • Acclaim All Star Baseball 2002 and 2003

    All Star Baseball 2002 Game Cube E Sports $49.95

    All Star Baseball 2002 PSX 2 E Sports $48.95

    All Star Baseball 2003 Game Cube Sports $49.95

    All Star Baseball 2003 PSX 2 Sports $49.95

    All Star Baseball 2003 Xbox Sports $49.95

Interplay Sports Baseball 2000

Let’s examine Interplay’s Baseball 2000 in terms of its good aspects, bad aspects, and suggested improvements.

Good: Baseball 2000 has good AI that focuses on pitches that the batter will want to hit and will intentionally walk a batter. The fielding option is very good, and the program controls the fielder until the camera has the fielder in full view and then the player takes control. The game player has no need for exactness when fielding a ball or throwing to a base. Fielding a ball requires a general area click on a player, and the ball jumps into the glove. The pitching and batting interface is easy to use and has an optional strike zone and an option after the throw to display where the ball was pitched.

This version has better graphics than last year (not as good as Triple Play and MLB 2000), including numerous batting animations, real-time shadows when players move/stand, detailed jerseys with patches and correct team logos, and player numbers (including the correct number font). With good collision detection and display when fielders and runners collide, the AI makes Baseball 2000 a better game than the previous version, VR Baseball 99.

The pitching interface is great. When a pitch is selected, a strike zone region is determined and slightly adjusted as the ball is pitched (same interface in Triple Play). In Interplay Baseball 2000, pitch speed can also be selected, which will determine the energy used by the pitcher. Pitchers must be warmed up before they enter the game. Another good feature is that auto base running and slides can be head first or feet first. There are many new features, like different replay camera angles and camera zooms, including “ball cam,” and all 30 stadiums are detailed in 3D; 700 new fully animated scenes were added including feet-first sliding, diving catches, jumping throws, kneeling throws, over-the-shoulder catches, outfield fence climb catches, numerous first baseman catches, and team rosters complete from the 1999 season with the ability to trade and create players.

Bad: The graphics issues include seams in the field, players whose facial hair is inconsistent, the same blank stare on faces, no home run celebration, and slow frame rate. The stadiums are only half filled by fans. The baseball is represented by a white dot and not a rotating, seamed ball. Sound issues include no umpire shouting and animating called balls and strikes (play-by-play announcer calls them), the play-by-play announcer gets redundant quickly, and the previous version had better crowd noises, better sound effects like hecklers and vendors, and the crowd’s roar was better. Also, the sound options are not saved.

Other issues include no user records, no career mode, incorrect 1999 schedule, all fielders run at the same rate, throwing to a player has one rate (should have player-defined throwing rates and rates for normal or aggressive throws), and loading the season (and saving it) is slow. Also there are no selectable camera angles (although replay has them all available).

Improvements: Pitching improvements include adding passed balls and wild pitches, and the pitcher is less accurate as he tires. Adding options for automating base running, pitching, hitting, throwing, and fielding. Modifying the color commentary and having better play-by-play variations.

Animation improvements include adding umpire animations and involvement (motioning and speaking), having working and animated base coaches, filling the stadium with a variety of fans, having various home run celebrations, coming to bat rituals, and on-deck animations, having pitches without a long canned animation, and after a strikeout or a first base out, optionally throwing the ball around the infield. Improving the AI to compete with High Heat Baseball (intentional walks), having optional hitting and pitching cursors, and forcing base runners to go on a two outs and a full count.

Microsoft’s Baseball 2001

Microsoft’s Baseball 2001 has a major addition—the Baseball Mogul’s technology as the brains “under its hood.” Players can build and develop a team just like a Major League baseball general manager, simulate a schedule over days, weeks, months, and seasons and team and player statistics over seasons, and develop minor league players and teams. Game players can trade players with computer sophisticated AI that can accept a trade or reject one with a counter-offer.

Baseball 2001 is a full baseball simulation, including franchise factors like tracking players’ salaries, farm system and scouting budgets, and other bottom line decisions. The general manager mode has features like career mode, where the player can have control over the managers and coaches, manage finances, sign and release free agents, and make trades. Winning the World Series is important for revenue success (filling the stadium and paying for a winning team). The commissioner mode has the ability to create new players as well as manage the entire league (all teams). The financial aspects include base revenue, winning percentages, fan attendance and support, good team decisions, scouting costs, and farm system operation.

Baseball 2001 is licensed by Major League baseball and the Major League Baseball Players Association with all 30 teams and over 1,200 players and 35 stadiums, including Milwaukee, Houston, San Francisco, and Detroit.

The game includes commentary by Arizona Diamondbacks announcer Thom Brennaman and is endorsed by the Boston Red Sox All-Star shortstop and American League Rookie of the Year, Nomar Garciaparra.

Microsoft’s sports is a worthy challenge to Electronic Arts (sports champion “We are Sports”). The game features a floating indicator (cursor) that is used for pitching and batting, which differs from the twitch timing method utilized by Triple Play and EA/3DO’s High Heat.

The 1999 season’s actual statistics are used as well as tracking statistics, such as longest home run and pitcher’s statistics, like number of pitches versus number of outs. Based on the batter’s statistics, he can attempt one of three swings: a power, contact, or normal swing. A normal swing provides a large indicator for a larger swing radius but with less hitting power. The power swing provides a smaller indicator defining a smaller swing radius but more power in his hit. Pitchers utilize the same indicator method as hitters, where the pitching statistics are correlated to the desired pitch type and speed.

Good: Great detailed player movements from extensive motion captured actor sessions, 3D realistic stadiums, high resolution, and multi-polygonal player models. Players animate and move more fluidly with high-resolution digital imaging of player’s faces and individual player posturing and trademark movements. Comprehensive statistics tabulate individual player and team game and season statistics with analysis.

System requirements are the Pentium 166, 32 MB RAM, Win 95/98, DirectX 7, 3D accelerator card with 4 MB RAM.

Electronic Arts Triple Play Baseball

EA’s Triple Play 2000 is an “arcade-style” or “offensive” baseball game, and fans and critics prefer a more realistic simulation experience in sports games. For the PC Windows market and the PlayStation, Triple Play was the best-selling baseball game.

Triple Play features stadium flyovers, was the first game with the now common two-man announcing team, and has on-the-fly commentary based on the player’s season. Smooth, well-animated graphics are apparent in Triple Play 2000 in the player’s movements, like swinging, pitching, or sliding, which all look sharp and detailed. The realistic polygonal models look natural, and the days of blocky and stiff 3D models are long gone. The stadiums are graphically impressive from Kansas City’s waterfalls and Boston Fenway’s “green monster” outfield to Baltimore Camden Yards’ right field brick building. Shadows based on the time of day as well as weather are just one of the realistic details present in Triple Play 2000.

The “Jumbotron” screen depicts batting and running players as a screen within a screen action. Other detailed graphic features include dust clouds when a player slides into a base or off the player’s cleats when the bat taps the footwear before entering the batter’s box. Even the clouds across the sky or the orange-red sunset shows the graphic detail achievements. Players have facial animations and realistic expressions. The ball in motion has a slight comet-tail visual showing a fast moving ball. Broadcast-quality camera angles and perspectives with zooming and panning are so seamless you begin to think that a cameraman is controlling the viewing. Numerous home run animations depict visuals like a swing from four different angles, instant replay montages, and animations where the ball flies out of the stadium while another one shows the ball’s flight from its POV.

Triple Play 2000’s audio continues its predecessor’s features by having a real-time game announcer commenting play information in seamless speech, including the team and its players’ names (the speech sounds even, rather than strung or patched together).

In 1998 Triple Play introduced the two-man announcing team, where the duo not only describe the action but chat during idle moments and tell stories of players and specific places. Even information about the current season being played is mentioned. The crowd sounds and reaction to the game are improved, from the vendors selling beverages like lemonade or food to the crack of the bat, the stadium announcer paging people, and music to get the fans yelling.

The menus in Triple Play 2000 have been streamlined for ease of use and faster gameplay. The batting interface allows for the traditional timing-based bat-to-ball hitting system to a “zone cursor” that makes you target the strike zone. Batting allows for a normal swing, a power swing, a check swing, and a bunt.

The pitching interface (although still awkward) allows for a pitch type and a pitch area (strike zone or just outside the strike zone), and after the ball leaves the pitcher’s hand, an adjustment control can be used to more accurately move the ball along its intended path (called the “aftertouch”). An arrow indicates the location of the ball (as a help feature).

Triple Play 2000 has a rookie level for extremely easy play, a pro level, and an “All-Star level.” The player can customize each setting to a particular level.

Electronic Arts/3DO High Heat Baseball

High Heat Baseball previously predicted that the New York Yankees would win the 1998 World Series (Correct—New York Yankees sweep the San Diego Padres) and the 1999 World Series (Correct—Yankees’ 4-1 victory over the Braves) and then announced that after an 82-year drought the Boston Red Sox would win the 2000 World Series (Incorrect—New York Yankees beat New York Mets for third straight World Series).

The High Heat Baseball development team is headed by 3DO CEO Trip Hawkins, who leads a group of die-hard baseball fans. Hawkins was the visionary behind High Heat’s predecessor, Earl Weaver Baseball, the legendary award-winning sports title considered the best baseball simulation ever.

High Heat was thoroughly researched for over four years through seeing games as a spectator in every ballpark and analyzing the other baseball games and evaluating new innovative concepts.

Good: High Heat has the most accurate and realistic pitcher-against-batter statistics, true-to-life base running, fielding, managing, and pitching (wild pitches, pick-off base runners, manager visits to the mound, dropped third strikes, and passed balls). There are multiple camera POVs and an action-cam for close-ups in the action POV. All 30 MLB stadiums for 2001, including PNC Park and Miller Park (over 10,000 polygons per stadium), and historic ballparks like Baker Bowl and Shibe Park. Realistic texturing includes high resolution, high color, alpha blending and mip-mapped technology, and real-time shadowing based on the current sun position or night game lights.

An intelligent crowd features more responsiveness in graphics, sound, and animated vendors. Players have realistic motions on their 6,000 polygon plus models with detailed uniforms (team logos, decals, striping, and piping), actual face maps of over 120 players, true-to-life player motions, and over 1,300 animations and 300 signature animations of pitchers and batters. There are TV-style graphics and menus. In-game animations include arguing with an umpire, base coaches that interact with the base runners, manager visits to the mound, managers able to signal to the bullpen for a new pitcher, and Jumbotron instant replay.

Other features include multiple team rosters for current and all previous seasons with over 750 players, All-Star team selections from current year and previous year, tremendous statistics including historical statistics per player for each year, and batting practice mode with a training mode. There is Internet/LAN play of exhibition, season, and playoff games. Also included is the ability to customize leagues where you define the teams, the schedule, and playoffs.

There are modes to perform multiplayer trades, free-agent pools, aging curves, a three-tiered minor league system, scouting profiles, full-featured draft setup, complete news, updates, and detailed career information tracking. Special modes include manage-only mode and one-pitch mode, batting practice mode, exhibition mode, season mode, career mode, home run derby mode, and playoffs mode.

Game commentary is by San Francisco Giants announcer Ted Robinson.

System Requirements:

Without a 3D Card | With a 3D Card
Windows 95/98 | Windows 95/98
DirectX 7 | DirectX 7
Pentium 166 | Pentium 200 MMX
32 MB RAM | 32 MB RAM
4x CD-ROM | 4x CD-ROM
110 MB disk drive | 250 MB disk space
2 MB SVGA video card | 4 MB Direct3D accelerator with a 800x600, 16 bit
DirectX7.0 sound card, 16-bit | 3D sound card, 8-bit DirectSound
Multiplayer: | Multiplayer:
28.8 or greater modem TCP/IP | 28.8 or greater modem TCP/IP
or IPX (network play) | or IPX (network play)

Computer Gaming World’s Top Ten Games of All Time. Gamepen’s Best PC Sports Game of 2000.

Electronic Arts Triple Play 2002

Electronic Arts decided to hire a new developer (Pandemic) to design and produce Triple Play 2002. The new version features numerous new motion capture animations, photo-realistic player head scans, and a TV-style look. The game has 500 animations with 40 signature animations and 160 star player face scans with each player consisting of 4,800 polygons. The commentators are Bob Costas and Harold Reynolds. Triple Play offers the 2002 schedule and previous year statistics tracking over 50 items. Fantasy draft, “End of Season” awards, and create a player (over 30 traits to modify) are also included.

3DO High Heat Baseball 2003

On the consoles, 3DO High Heat Baseball competes with EA’s Triple Play 2002. High Heat has new fielding animations and smooth batting animations. They’ve added the ability to draft and create a player. For the batter, there are now hot and cold batting zones. For the pitcher, fatigue is now calculated.

The game has 1,500 animations with 200 signature animations and 350 star player face scans with each player consisting of 6,000 polygons. The commentators are Dave O’Brien and Chuck Valencia. High Heat offers the 2002 schedule and previous year statistics tracking 78 (splits to 150) items. Franchise mode, fantasy draft, “End of Season” awards, and create a player (33 traits to modify) are also included. The game features wild pitches and passed balls, dropped third strikes, injuries, on-field managers and coaches, and home plate collisions.

Acclaim All-Star Baseball

Four-time World Series Champion and 2000 All-Star Game MVP Yankee shortstop Derek Jeter endorsed and is featured in this game. All 30 Major League teams and over 700 players with realistic face textures. Players can select the Cooperstown Hall of Fame team with roster including Reggie Jackson, Mike Schmidt, and Nolan Ryan. Game commentary is by Arizona Diamondbacks announcers Bob Brenly and Thom Brennaman. All 30 MBL stadiums with active dugouts (with real, recognizable players sitting in them), bullpens, real outfield advertisements, real-time scoreboards and Jumbotron (that show each player as he approaches the plate), and stadium features like the Kauffman Stadium (Kansas City, MO) waterfalls, 2001 All-Star Safeco Field, Puerto Rico Stadium, PNC Park, Miller Park, and Oakland Coliseum.

The game has animated team mascots, 130 varying player batting stances, 50 pitching animations, and over 1,500 player animations based on motion capture sessions. There are classic uniforms from historic teams. There are seven camera angle views based on television broadcast positions. Season awards like the MVP, Cy Young, Rookie of the Year, and Golden Glove.

General manager mode for trading players, signing free agents, and drafting players, setting lineups, defining the pitching staffs, and viewing statistics for hitting and pitching in 44 categories. Each pitcher has six different pitch types, including circle change-up, two-seam fastball, knuckle curveball, and spit ball.

Game modes include quick play, exhibition, season (162 games), World Series, All-Star Game, home run derby, and batting practice. Options include disabling interleague play, balanced play (play teams with same record), unbalanced play (play within your division) for half a season, full season, three-game round robin, and user-defined number of games.

Also customizable are options like game time (day, night, twilight), weather (rain, snow, clear), and game level (rookie, veteran, and All-Star). Players can create up to 25 players, defining their abilities and appearance. Fielding can be automatic (computer controls everything including throwing) or manual (throwing to a base can be selected before the ball is obtained). Designed for fans of the arcade-style baseball game as well as the simulation-style game.

This game has received the following awards:

IGN Editor’s Choice Award: All-Star Baseball 2001 and 2002, EGM Editor’s Choice Award: All-Star Baseball 2000 and 2001, GamePro Baseball Game of the Year: All-Star Baseball 1999

Acclaim All-Star Baseball 2003

Since the previous versions are of high quality, this game expanded its features and options. The fielding mechanics are improved, giving a much smoother look. TV-style presentation in high detail, team mascots cheering on the dugout, on-screen Donruss trading cards, and a trivia minigame are all included in this new version. They’ve even added broken bats, erratic throws, and wild pitches, as well as a completely redesigned career mode, allowing up to 20 continuous seasons (3,000 games). All-Star has added an expansion mode to create a new team and over 50 Hall of Fame players to select.

The game has 1,900 animations with 200 signature animations and 400 star player face scans with each player consisting of 5,000 polygons. The three commentators (yes, there are three) are Thom Brennaman, Steve Lyons, and Bob Brenly. All-Star offers the 2002 schedule and previous year statistics tracking 67 items. Historic players (52), classic team uniforms (two per team), franchise mode, fantasy draft, “End of Season” awards, create a team, and create a player (over 30 traits to modify) are also included. The game features wild pitches and passed balls, dropped third strikes, injuries, on-field managers and coaches, and home plate collisions.


Chapter 8: The “One Pager” Concept Document

Overview

The first document that a game designer creates is called a one pager. The one pager explains and sells your game’s concept to publishers and developers and puts your ideas and vision into a concise document. A one pager can be one or two pages (double spaced preferred but single spaced in lieu of a partial third page).

The one pager always begins with your game’s title. You are selling the game’s name as well as its design. The first sentence is the most important and often the hardest one to write. In one sentence you must describe your game concept. Let me repeat this rule: You must explain the entire game in ONE SENTENCE. Usually, the sentence repeats the game’s title and includes the game’s genre and a basic description or overview of the concept.

Some examples are:

  • Gangster is an FPS where the player is a gangster like Jesse James, Clyde Parker, or John Dillinger, and the player is placed in the gangster scenarios and must successfully complete each mission.

  • P-Man is an action game where you maneuver a dot-munching, animated circle through a labyrinth trying to destroy flashing bases, as six enemy squares eagerly roam the maze seeking to capture you.

  • Couch Potato Baseball is a 3D sports game (baseball) where the player selects his All-Star team and manages the team through a season of play to the World Series by selecting his All-Star team players, assigning each game’s line-up, selecting the pitchers, trading players, and bringing up triple A players to play.

The one pager also includes other gaming issues. You need to list your game’s features (cover the basic, standard features as well as special features that make your concept different or better than the current, competing games), the hardware and software requirements needed (required) and suggested (recommended) to properly play your game, and similar and competing games (their title, publisher, platforms like Windows, PlayStation 2, Nintendo Game Cube, or Microsoft’s Xbox, and retail price). You may also include any marketing and sales issues that will help sell your concept and get an interest in your game, like a license, anticipated audience (sex, age ranges of players), and pertinent data (sports game number of players and world-wide audience numbers). After you write the one pager to your liking, show it to avid game players and fans as well as non-players. The one pager is important and should be understandable to everyone from business people to hardcore gamers.


Example 1

Note that in the following example the name in parentheses is a placeholder.

(Megan Pedersen)’s International Wakeboarding Open

(Megan Pedersen)’s International Wakeboarding Open is a 3D, third-person wakeboarding sports competition that lets the player(s) (single and multiplayer) compete in seven international venues and choreograph their acrobatic maneuvers through each course’s obstacles and wakes. (Megan Pedersen)’s International Wakeboarding Open will appeal to all extreme sports enthusiasts and features the top women’s wakeboarding champion (Megan Pedersen). Wakeboarding has been featured on ESPN, ESPN2, and OLN, reaching over 70 million households. (Megan Pedersen) has won numerous wakeboarding championships, including the Van Triple Crown of Wakeboarding Championship, the Wakeboarding National Championship, the World Championship, and the X Games Championship.

Wakeboarding is the fastest-growing water sport in the world, increasing over 100 percent in participation over the past three years. Wakeboarding is a combination of surfing, skateboarding, snowboarding, and water skiing. A wakeboard looks like a snowboard with a pair of bindings attached to it. The wakeboarder carves turns with body leans and by rocking the board.

(Megan Pedersen)’s International Wakeboarding Open has each player competing in one to all seven countries in the circuit. The participating countries will be the U.S.A. (Orlando, Florida); Sydney, Australia; South Africa, Africa; Tokyo, Japan; Paris, France; Venice, Italy; and Buenos Aires, Argentina. In the single-player mode, the player will practice his maneuvers and learn new ones. Based on the player’s learned skill level, he will be able to compete for the championships. Players need to master the basic skills before attempting the expert tricks and maneuvers. In the multiplayer mode (via the Internet or network), players will take turns competing in one or more countries for individual championships or the Grand Prix of (Megan Pedersen)’s International Wakeboarding Open Circuit Championship.

The intended audience will be males between the ages of 8 and 20 who enjoy extreme sports. Also, since the presence of famed female wakeboarder (Megan Pedersen) is featured, an anticipated female audience of those 8 to 17 is projected. The platform for this game will be the Windows XP as the first release (Windows 2000, 98, Me, and XP compatible) with Microsoft’s Xbox, PlayStation 2, and the Nintendo Game Cube to follow. Similar, successful games have been Tony Hawks’ Pro Skater 2 and 3 (IBM Windows CD version is $29.95 and Xbox version is $49.95), MTV Sports Snowboarding, Konami’s 1080 Snowboarding and X Games Pro Boarder, and EA’s Snowboard Super X (PlayStation 2 version is $49.95 and Nintendo Game Cube version is $52.95). Activision plans to release Shaun Palmer’s Pro Snowboarder, Mat Hoffman’s Pro BMX, Kelly Slater’s Pro Surfer, and Darin Shapiro’s Pro Wakeboarder.

(Megan Pedersen)’s International Wakeboarding Open is a 3D behind the wakeboarder POV where the player controls the boarder’s lateral movement, speed, or forward movement (by signaling to the virtual motorboat), acrobatic maneuvers, and obstacle jumps (the slider, a kicker, and a jump ramp). The game will contain realistic physics, animation, and sound effects. Commentators, including (Megan Pedersen), will describe and evaluate the wakeboarder’s performance. After each performance or routine, the player can use the video replay feature to observe and improve his tricks. Each of the seven unique country locations will have an obstacle course that can be modified by the player before the competition begins. Players will be judged based on the 100-point system for their technical difficulty (“execution,” worth 33.3 points), the “in-air” acrobats (“intensity,” worth 33.4 points), and the seamless flow of the routine (“composition,” worth 33.3 points). Like the real world of competition, each wakeboarder has a two-fall limit.

In the single-player mode, the player can practice his tricks on various obstacles and courses. In order to become a Pro Wakeboarder, the player must successfully show an understanding of the beginner, intermediate, and advanced tricks, grabs, spins, and inverts. (Megan Pedersen) will coach and evaluate the player as he progresses from novice to Pro Wakeboarder status. The beginner wakeboarder can learn simple air maneuvers and grabs like the Butterslide 180, the Surf Carve, and the Ollie Blind 180. Then the player can practice the intermediate tricks like the Indy Blind 180, the Scarecrow, and the Back Roll and finally advance to the difficult inverts, spins, and grabs like the Whirlybird, the Elephant, and the Wrapped KGB.

(Megan Pedersen)’s International Wakeboarding Open will be a highly anticipated arrival into the extreme sports gaming world with its fast-paced, turbo-charged acrobatic maneuvers, realistic sound effects, orchestrated ambient sound track, and commentators describing the wakeboarder’s tricks, as well as having the (Megan Pedersen) name, a dominant female competitor in the world of extreme sports.


Example 2

Here is another one pager example.

Years ago I met a student studying to become a medical doctor who was addicted to Mortal Kombat. He wanted to design a game where the player would be inside the human body combating real life diseases like cancer. The cancer cells would invade the body and the player would gather his super force of red and white blood cells, the Chemo Team, and Radiation Sensations, using their martial art techniques to fight and destroy the disease. This game would not only be fun for the fighting genre fans but would also teach people about diseases (what the disease does, where it attacks the human body, symptoms, and what to look for as it progresses) and their treatments (the latest cures, various treatment options, and length of time needed to destroy a disease or put it in remission).

We worked together to expand this concept by including the entire human life (from infant to old age). We called this game Medical Kombat and felt that it would appeal to all ages, especially children 13 to 18 as well as medical students like my co-designer.

Several films have been made on this subject, such as Fantastic Voyage and Osmosis Jones.

Medical Kombat

Medical Kombat is a third-person POV martial arts/first-person shooter that takes place in a real human body from birth to death as the good side combats disease and viruses. The player or players in multiplayer mode, as the good side, will learn all about many diseases and their symptoms and causes, as well as the past and latest medical treatments.

The player will select an age range to play from, such as an infant, young child, or young adult to adulthood. The infant diseases will include jaundice, convulsions, seizures, asthma, hernia, and so on. The young children diseases will include viruses and ailments like mumps, measles (rubeola and rubella or German measles), chicken pox, polio, allergies, acne, bee stings, hiccups, splinters, epilepsy, broken arms and legs, and so on. Other diseases will include bacterial diseases (like scarlet fever, whooping cough, typhoid fever, diphtheria, gangrene, cholera, conjunctivitis, and tuberculosis), viruses (like smallpox, influenza, anthrax, pneumonia, herpes, hepatitis, trachoma, and yellow fever), fungal diseases (like thrush and athlete’s foot), nutritional diseases (like beriberi, rickets, and scurvy) and parasitic diseases (like malaria and bubonic plague). The adult diseases will include leukemia, cancer (lung, skin, breast, and bone), tumors, gallstones, kidney stones, AIDs, heart problems, diabetes, Alzheimer’s, arthritis, osteoporosis, ALS, muscular dystrophy, and emphysema.

Besides the aforementioned good guy teams, there will be vaccine and drug-injected super heroes like penicillin, insulin, and other medications. Some super heroes can fight an enemy one on one, some spin medicated webs trying to capture and destroy the unsuspecting enemies, and others shoot medication into the human body, blocking the pathways or locking the enemy inside a region. The super team uses the human body’s blood transit system to travel through arteries away from the heart and veins and back to their headquarters (the heart). The object of each mission is to survive, and the player(s) will have several medical gauges and monitors that will give up-to-date tracking of the patient’s progress.

Medical Kombat has unique cross-genre appeal since it is a martial arts fighting game, an FPS, and an educational game all in one. Parents will appreciate its educational benefit, and the males and females 8 to 16 will be enthusiastic about the realistic and intense fighting and destruction of their enemies. Each year 15,000 to 19,000 high school students apply to medical colleges throughout the U.S.

The platform for this game will be the Windows XP as the first release (Windows 2000, 98, Me, and XP compatible) with Microsoft’s Xbox, PlayStation 2, and the Nintendo Game Cube to follow. Similar fighting games like Crouching Tiger Hidden Dragon sell for $49.95 on the Nintendo Game Cube, PSX 2, and Xbox and $32.95 for the Gameboy Advance. Mortal Combat Deadly Alliance sells for $49.95 on the Nintendo Game Cube, PSX 2, and Xbox and $39.95 for the Gameboy Advance.

Medical Kombat simulates the first war that man ever fought, the first war you have ever fought, and the last war you will someday lose. The players will enjoy the thrill of real-life search and destroy as they battle their way through each mission and learn about life and death in the process.


Chapter 9: Game Art and Animation

Overview

Artists and level designers create characters, environment (worlds), and our concept’s visuals. To turn our vision into a real game, as designers we need to understand the roles and talents of our 2D and 3D artists, level designers, and animators. Game designers need to understand the artist’s tools and the tools’ capabilities as well as game engines and project and asset management software for tracking and organizing the game’s artwork, audio, and programming code.

2D artists work on concept sketches, textures, skins, and background 2D artists use software like Adobe Photoshop, Jasc Paint Shop Pro, CorelDRAW, Microsoft’s Paint, and Equilibrium DeBabelizer.

3D artists create 3D worlds and models like characters, vehicles, and props. They use software like Alias|Wavefront Maya, Discreet’s 3D Studio Max, Softimage, and LightWave, as well as animation and tools like Character Studio, Poser 4.0, and predesigned 3D models.

Level designers create the environment and architecture using a level editor that can make a 2D layout into a 3D building or environments using software engines like LithTech, Quake, and Unreal.

Project and asset management software such as NXN alienbrain, PVCS Merant, Rational Software ClearCase, Starbase StarTeam, and Telelogic CM Synergy are needed to organize and make asset access easier and more convenient.


Adobe Photoshop

Team LiB

Adobe Photoshop
(www.adobe.com)

Adobe Photoshop 7.0 is a graphics editing application that has tremendous tools, features, and plug-ins. The interface has basic components, such as the menu bar, toolbox, the options bar, and palettes.

The toolbox includes Adobe Online and functions like Marquee, Move, Lasso, Magic Wand, Crop, Slice, Airbrush, Paintbrush, Clone Stamp, History Brush, Eraser, Gradient, Blur, Path Component Selection, Type (enter text), Pen, Rectangle, Notes, Eye Dropper, Hand, Zoom, Change Foreground or Background Color, Edit in Standard Mode, Edit in Quick Mask Mode, Full Screen Mode, Full Screen Mode with Menu Bar, Standard Screen Mode, and Jump to ImageReady (for web graphics by Adobe). The menu bar includes functions under categories such as File, Edit, Image, Layer, Select, Filter, Window, and Help.

Adobe Photoshop 7.0 in April 2002 retailed for $609 for the Mac (Mac OS 9 and Mac OS X) and Windows XP. This new version features the “healing brush,” which easily retouches digital photos (removes dust, scratches, blemishes, and wrinkles while preserving shading, lighting, and textures). It also has a file browser to organize images, rotate, sort, rank, and batch rename images, scripting support for JavaScript, AppleScript, and Microsoft Visual BASIC. An enhanced distorting or liquify tool is available to allow viewing of other layers and to zoom, pan, and undo multiple steps. There is a pattern maker to create realistic or abstract patterns like grass, rocks, and sand and a search and replace text feature that supports multiple languages and a spell checker.


Jasc Paint Shop Pro

Team LiB

Jasc Paint Shop Pro
(www.JASC.com)

Twenty million users know that Paint Shop Pro offers the easiest, most affordable way to achieve professional results with complete graphics and photo editor for home and business.

Jasc Paint Shop Pro 7 Anniversary Edition offers the ability to retouch, repair, and edit photos with easy-to-use, high-quality, automatic photo enhancement features, the ease of creating and optimizing web graphics with built-in web tools and artistic drawing and text tools. It also offers the ability to design cool animations with Animation Shop 3 (included free), use productivity tools such as grids, guides, alignment, and grouping, and expand your creativity with over 75 special effects. JASC Paint Shop Pro can be downloaded for $99 or ordered boxed for $109. A free 30-day trial version is available to download.


CorelDRAW Graphics Suite 11 (www3.corel.com)

CorelDRAW Graphics Suite has been a powerful software package for over ten years in vector illustration, layout, bitmap creation, image editing, painting, and animating. This new version has an enhanced interface and improved customization features, is capable of professional output, and supports multiple language text.

Animation can be created and edited using Corel R.A.V.E. (Real Animated Vector Effects), which is one of the three CorelDRAW suite components (along with CorelDRAW and Corel PHOTO-PAINT). The CorelDRAW suite is Windows XP compatible. CorelDRAW has an updated interface with easier to access and use functions, dockers (detachable palettes), more high zoom level dragging of a drawing, and PerfectShapes (a la WordPerfect Suite), which enables easy creation of various standard shapes. PHOTO-PAINT allows for controlling text for resizing and skewing, photo correction (like red-eye removal), creating drop shadows, and previewing various file formatted pictures. Corel R.A.V.E. is Macromedia Flash-compatible as well as other formats that allow for live-effects creation over time, editing your work through a timeline function, and creating roll-over graphics.

The CorelDRAW V11.0 Graphics Suite retails for $529 and Corel DRAW V11.0 Upgrade for $249.


Equilibrium DeBabelizer (

Team LiB

Equilibrium DeBabelizer (www.Equilibrium.com)

Equilibrium’s DeBabelizer Pro 5 by Equilibrium is an automating media production tool that allows you to automatically acquire, edit, optimize, and convert countless images of various formats. Version 5 has embedded Digimarc digital watermarks or a composite logo to right-protect your images, scripting to batch multiple commands, compress, and convert QuickTime, AVI, and RealVideo, and enhanced GIF and JPEG compression.

The DeBabelizer Pro 5.0 includes “hot folder processing,” which enables numerous files to be placed in designated folders, “watch me” scripting, which mimics your execution and scripts the operation for you, a “global log” of all executed and error operations, the ability to sort and reorder batch lists, conditional scripting, inline scripting to click on a command and instantly edit a script or modify the settings, and the ability to manipulate an image in high quality scale. It also includes the ability to flip, rotate, trim, resize canvas, plus change the intensity, contrast, gamma, hue, saturation, and brightness in full preview. Channels control allows for quick viewing of the RGB and alpha (invisible color) channels. The Ultimate Palette Optimization feature allows for generating the best palette for an image, series of images, or frames; it also has the ability to set pixel depth, reduce colors, and control dithering, merge multiple palettes, equalize palettes (better distribution of color and saturation), set palette and remap to any of the 28 built-in palettes, remove unused or duplicate colors; plus it has the ability to remove the Ultramat (blue screen hue range), shave or outline an image, field interpolation to clean up video and rendered animations on a scan line level, and NTSC and PAL Hot Pixel Fixer (guarantees all colors conform to video display limitation standards).

Windows system requirements are a 486 or better (Pentium recommended), Windows 95, 98, Me, NT (Service Pack 6), 2000 (Service Pack 2), 64 MB RAM available, 20 MB free disk space, 256 color monitor, and a CD-ROM.

Mac system requirements are a Power Macintosh Processor 3 or higher, System 9.1 or above, 64 MB RAM available, 100 MB available disk space, 1024x768 monitor, a CD-ROM, QuickTime 5.0, and CarbonLib 1.4.

Equilibrium DeBabelizer Pro 5, which also runs on the Windows 95, 98, 2000, Windows Millennium Edition, and Windows NT operating systems, has a price of $469.


Alias|Wavefront Maya (

Team LiB

Alias|Wavefront Maya (www.AliasWavefront.com)

The Alias|Wavefront logo is a registered trademark and Alias|Wavefront is a trademark of Alias|Wavefront, a division of Silicon Graphics Limited in the United States and/or other countries. Maya is a registered trademark of Silicon Graphics, Inc., exclusively used by Alias|Wavefront, a division of Silicon Graphics Limited. The Maya logo, Maya Personal Learning Edition, Maya Complete, Maya Unlimited, Maya Paint Effects, Maya Artisan, Maya Fur, Maya Cloth, Maya Embedded Language and Maya Shockwave 3D Exporter are trademarks of Alias|Wavefront, a division of Silicon Graphics Limited. IRIX is a registered trademark and SGI is a trademark of Silicon Graphics, Inc.

Alias|Wavefront’s Maya is a comprehensive production solution for 3D artists in animation and visual effects, starting with the initial concept to the final rendered image.

Maya Complete by Alias|Wavefront for the Mac OS X (fully Mac compliant using OpenGL), Windows, and Unix sold for $7,500, now (1/2003) at $1,999. Maya Unlimited was selling at $16,000, now (1/2003) at $6,999. A free, noncommercial version of Maya Complete is available as Maya Personal Learning Edition. Also available are Maya Real-Time Author and Maya Shockwave 3D Exporter.

Maya Personal Learning Edition is a free noncommercial use version of Maya Complete’s main toolset, including NURBS (Non-Uniform Rational B-Spline, one of the primitives in 3D), modeling, animation, inverse kinetics (IK), Maya Artisan, Maya Paint Effects, particles, dynamics, and Maya advanced rendering capabilities.

What’s the Catch?

Maya Personal Learning Edition restricts users (3D graphics and animation students and industry professionals learning Maya) through the displayed watermark (a moving text image that is placed on created images) and a special file format readable only through this system. Maya Personal Learning Edition will run on Windows NT 4.0, Windows 2000 Professional, and Windows XP but not on Windows 95, 98, Me, Linux, or IRIX (buy the Maya Complete version). Maya Personal Learning Edition requires 695 MB to install and 270 MB to run (the installer is deleted). The complete set of user documentation is included.

Maya Complete and Maya Unlimited

Maya Complete 4.0 includes modeling, rendering, animation, dynamics, Artisan, Paint Effects, Maya Embedded Language (MEL), open interface for programming and scripting, Maya Fur, Maya Cloth, and advanced modeling features.

Maya Unlimited (for IRIX, Linux, and Windows platforms) includes Maya Cloth, Maya Fur, and Maya Live, reads and writes Maya software files, all MEL commands (like system, fopen, popen, fwrite, fprint, and cmdpipe), and API, and supports exporting skin weight maps and character maps.

Maya is a node-based program where each node can represent a surface, a texture, or an animation curve with attributes like the object’s position or size. There are two user views: hypergraph or outliner panel view.

Maya’s three primitives are NURBS, polygons, and subdivisions (in the Windows version only). Layers separate objects for editing and viewing, which can be shown, hidden, templated, or referenced.

Light has several variations, including ambient (uniform light), area (rectangular emitted light), directional (parallel light rays), point (radiates out from a center), or spotlight (cone-shaped lighted area). Light creates shadows.


3D: Softimage|XSI

Team LiB

3D: Softimage|XSI
(www.Softimage.com)

Softimage|XSI 2.0 is Avid technology’s next generation 3D software application based on their Softimage|3D, which was the leading 3D character animation software. Softimage|3D was utilized by many films, such as Jurassic Park, The Mask, Godzilla, and The Matrix.

Softimage|XSI has the same toolset and layout as Softimage|3D. There are now three main modules called Model, Animate, and Render. Animate lets you store actions (poses and animation segments). There is an animation editor and an animation mixer, which have many nonlinear animation tools for blending and sequencing stored actions. The Render module has basic materials and textures defined and can separate a single render into separate passes. A Render Tree allows combining materials, textures, and procedural surface properties as a graphical flowchart, connecting nodes of different surface properties to other nodes as a tree structure.

SOFTIMAGE|XSI 2.0

SOFTIMAGE|3D

Softimage|XSI version 2.0 has a completely customizable user interface, layouts, toolbars, menus, and shortcut keys; for all geometry and data views a drag and drop is implemented, and all view ports are resizable and configurable. The user interface is fully customizable for the layouts, toolbars, menus, and shortcut keys.

Modeling is specifically designed for creating and editing environments and seamless animated characters. Components include polygon, edge, point, knot, curve, isoline, surface curve, boundary, and subsurface. Primitives include arc, circle, spiral, square, cone, cube, cylinder, disc, grid, sphere, torus, dodecahedron, icosahedron, octahedron, tetrahedron, rhombicosidodecahedron, soccer ball, and NURBS surface cones, cylinders, and cubes. Male and female body primitives and complete skeleton primitives are provided. To interactively manipulate complex characters fast, subdivision surfaces are provided, such as tools for blending, filtering, merging, lofting, extruding, fitting, snipping, adding and removing knots, and picking commands. Interactive Polygonal Modeling includes tools for beveling, duplicating, extruding, merging, and blending.

Text primitives allow for text creation, using TrueType fonts and international fonts, the import of EPS files, and producing curves and planar and solid meshes. Textures and materials include plastic, glass, wood, stone, marble, clouds, fabric, and gradients. Advanced materials include ambient, diffuse, specular, reflective, transparent, and static blur. Material connections include surface, volume, environment, contour, displacement, shadow, photon, and photon volume. Supported texture import formats include AVI, Softimage (.pic), Targa (.tga), YUV, SGI (.sgi, .rgb), Wavefront (.rla), PICT (.pct, .pict), PCX, BMP, PGM, GIF, Alias (.als), JPEG (.jpg, .jpeg, .jfif), Photoshop (.psd), Cineon (.fido), Script (.scr), MAP, QuickTime (.mov, .qt), and TIFF (.tif, .tiff).

Softimage|XSI has hair/fur simulation with the advanced ability to groom, render, and interact with the environment dynamically. An optional cloth realistic simulation is provided. The Particle System creates real-world effects, such as snow, sparks, fireworks, explosions, flames, smoke, and fog. There is also multiple camera support with telephoto and wide angle lens presets and numerous light presets, such as infinite, point, spot, box, and neon.


Softimage|XSI 3.0

Nonlinear animation (NLA) is at the heart of the XSI architecture. This scalable and completely customizable environment gives you all of the tools and genuine flexibility to quickly and creatively respond to any request. An array of new performance, data management, and workflow enhancing features are built into the core of version 3.0, including the ability to deal with even larger, more complex scenes with ease using such tools as the revolutionary new XSI Explorer. Artists can also take advantage of unique new innovations, such as the interactive camera manipulation and navigation tools, to interactively view their work during the creative process.

Softimage continues to drive the character animation market with new cutting-edge additions to character skeleton construction, such as options for generating fully customizable, film-quality biped and quadruped rigs. Version 3.0 provides additional flexibility, higher levels of interactivity, and simplifies the creation of complex rigging tasks. These new tools are also perfect for smaller shops that previously could not afford the investment necessary to develop such high quality character setups and rigging.

XSI v.3.0 is the perfect tool for creating realistic armies of characters or clones. XSI now offers a new production-proven, high-performance and interactive crowd simulation pipeline to automate the creation of complex and heavy crowd scenes. With these new features, you can master the creation of thousands of characters or objects directly within XSI while maintaining the ability to tweak and perfect the results post-simulation.

Interactive rendering in Softimage|XSI has taken another leap forward with the integration of mental ray v.3.1 technology. Dramatic improvements in quality and speed, combined with the overall quality and integration of the rendering toolset, maintain XSI rendering as the market leader for the intuitive, interactive creation of images of unsurpassed realism.

XSI v.3.0 offers a powerhouse of new tools and productivity enhancements to digital artists working on interactive media projects. These new tools include unique support for programmable DirectX real-time shading effects, new PDKs for Microsoft’s Xbox and Sony’s PlayStation 2, updated mesh-modeling tools offering a more intuitive working environment, better performance with more complex models, and state-of-the-art UV texturing tools.

XSI v.3.0 includes new versions of the XSI Viewer, the dotXSI File Tool Kit (FTK), dotXSI file format, and a new C++ API for the XSI SDK. Built ahead of the curve with a dramatically accelerated development cycle, Softimage|XSI v.3.0 offers a suite of unmatched productivity-enhancing tools without creative compromise.


3D: NewTek LightWave 7.5 (

Team LiB

3D: NewTek LightWave 7.5 (www.Newtek.com)

NewTek’s LightWave is a complete and flexible 3D graphics and animation application proven for years in the film, television, and gaming industries. LightWave includes tools that other packages offer separately, such as soft-body dynamics, particles, hair and fur, and unlimited render nodes.

Hollywood has used LightWave for such films as AI: Artificial Intelligence, Armageddon, Behind Enemy Lines, Black Knight, Blade, Charlie’s Angels, Contact, Deep Impact, Devil’s Advocate, Driven, Dungeons and Dragons, Final Fantasy, Flubber, Goldeneye, How the Grinch Stole Christmas, Jimmy Neutron: Boy Genius, Jurassic Park, Jurassic Park 3, Kung Pow! Enter the Fist, Lost in Space, Pitch Black, Rollerball, Scary Movie, Scary Movie 2, The One, The Sixth Day, The Time Machine, Titanic, Waterworld, and X-Men.

Many computer and video games have utilized LightWave, such as Anachronox, Asheron’s Call, Baldur’s Gate, Civilization 3, Daikatana, Deus Ex (2000 Game of the Year), Duke Nukem’, Everquest: The Ruins of Kunark, Halo, Homeworld (1999 Game of the Year), Icewind Dale, Kiss Psycho Circus, Quake III Team Arena, Resident Evil: Code Veronica X, Rollercoaster Tycoon, Serious Sam First Encounter (2001 Game of the Year), Serious Sam Second Encounter, Star Trek Elite Force, Star Trek: Klingon Academy, Ultima Online, and Unreal Championship.

NewTek’s LightWave 3D supports Windows 98, Me, 2000, NT 4 with 128 MB of RAM, and the Macintosh systems like the Power Macintosh Processor (G3 or higher), Mac OS 9 (with 384 MB of RAM), and Mac OS X (with 128 MB of RAM).

NewTek LightWave 3D for the Mac OS 9 and X native and Windows 98, 2000, Me, and NT 4.0 was $2,495 and is now (1/2003) $1,595. LightWave 3D includes soft-body dynamics, particles, and Sasquatch lite for hair and fur. An upgrade to LightWave 7.5 sells for (1/2003) $795.

NewTek has released LightWave 3D 7.5, an upgrade from version 7, which supports Macintosh and Windows platforms with features such as sliders that control animation settings, customizable to help animate characters, lighting rigs, and more. Forget about memorizing a long list of commands with Expression Builder (expression creator). Use Dynamic Parenting and Simple Constraints to make complex interactions between objects easier to animate. Motion blur and depth-of-field effects can be previewed. The Motion Mixer has been improved with new motion weighting and blending features.

Click To expand
Click To expand

NewTek LightWave’s Modeler has long held the title as the world’s best polygonal modeler. Game developers will find it to be a major weapon in creating efficient, yet great-looking models for fast, exciting gameplay. LightWave’s advanced UV mapping, weight maps, gradient controls, and motion and texture baking all contribute to a powerful arsenal for the game developer.

A few of NewTek LightWave’s new feature highlights include subdivision surfaces, inverse kinematics, and nonlinear animation.

  • Subdivision surfaces—With the press of the Tab key, your model changes from a 30-polygon faceted rough to an organically rounded, smooth, flowing sculpture (a head or a body, human, animal, or alien; a cool sports car; or a techno-organic spaceship perhaps). Subdivision surfaces provide modeling as complex as you need with great economy of effort and time. You model with simple polygons at only a fraction of the number the final model will need. You have complete control of your model but with a simplicity and ease you would never have expected when creating complex natural or engineered objects.

  • Inverse kinematics (IK)—LightWave lets you use virtual bones to quickly and easily make a skeleton for your character and use FK (forward kinematics) and IK to move the character. Forward kinematics: Rotate the upper arm, and the forearm, hand, and fingers must follow. Inverse kinematics: Put a “goal” just at the end of the fingers, and then if you want your character to reach for that M&M on the table, just move the goal toward the M&M and the character’s arm will move in proper fashion. These can be combined for realistic movement in any situation. And LightWave’s “Faster Bones” option makes animating a complex character quick and responsive.

  • Nonlinear animation—LightWave also includes a nonlinear animation tool, Motion Mixer. Previously saved motion cycles such as walking, running, jumping, etc. can be mixed and matched, stretched, and shortened as needed to produce just the movement and timing you need for your project. Animate once, customize endlessly.

    LightWave 7.5 has a suggested retail price of $1,595.

Softimage 3D base retails for $1,495 and includes network licensing (server-based floating), floating operating system capacity (server-based cross-operating system floating license for Windows, Linux, and IRIX), unlimited instances of SOFTIMAGE|3D in interactive and command-line mode on same workstation with same license, unlimited command-line rendering on multiple workstations (Softimage renderer only), launch distributed rendering (with additional mental ray 2.1 stand-alone licenses) from the interactive application or from the command line, and SOFTIMAGE|SDK ClothExtreme (purchased separately).

Softimage 3D extreme retails for $2,495 and includes ParticleSuite, MetaClay, SoftBody, mental ray 2.1 renderer (single processor—mental ray license enables tools such as Render Map (for lightmaps), Photon Wizard (for radiosity and caustic effects), and more), Softimage renderer, network licensing (server-based floating), floating operating system capacity (server-based cross-operating system floating license for Windows, Linux, and IRIX), unlimited instances of SOFTIMAGE|3D in interactive and command line mode on same workstation with same license, unlimited command-line rendering on multiple workstations (Softimage renderer only), launch distributed rendering (with additional mental ray 2.1 stand-alone licenses) from the interactive application or from the command line, and SOFTIMAGE|SDK ClothExtreme (purchased separately).

SOFTIMAGE ClothExtreme provides SOFTIMAGE|XSI users with unmatched cloth realism, including collisions with geometric objects and self-collision. Fully integrated within the SOFTIMAGE|XSI workflow, it retails for $595.


3D: Discreet 3D Studio Max 5.0 (

Team LiB

3D: Discreet 3D Studio Max 5.0 (www.Discreet.com/
products/3dsmax5/)

Discreet’s 3D Studio Max (or 3DS Max) is the world’s best-selling professional 3D modeling animation and rendering application. 3DS Max delivers a unified object-oriented platform for the artists designing visual effects, character animation, and state-of-the-art games.

3DS Max has won over 65 industry awards since its first publication in 1996 and has sold over 140,000 copies on the Windows platform. Now Microsoft’s Xbox and PlayStation 2 artists can utilize 3DS Max.

System requirements for Windows include the Windows 2000 or 98 operating systems with a 300 MHz processor minimum (dual Pentium 3 system recommended), 128 MB RAM and 300 MB swap space minimum, graphics card supporting 1024x768x16-bit color (OpenGL and Direct3D hardware acceleration supported, 24-bit color, 3D graphics accelerator is preferred), mouse (optimized for Microsoft’s Intellimouse), CD-ROM drive, optional sound card, and speakers. Network rendering supported for Windows 2000 only.

Click To expand

3DS Max supports numerous image file formats, such as AVI, BMP, CIN, EPS, FLC, GIF (import only), JPG, PNG, RGB, RLA, RPF, TGA, TIF, YUV (import only), Photoshop PDS (import only), and QuickTime MOV. The geometry file support includes IGES (import only), PRJ, SHP, VRML, 3DS, 3D ASCII SCENE, Adobe Illustrator AI, AutoCAD DWG and DXF, Adobe Type 1 (import only), and TrueType fonts (import only).

Some interesting new features of 3DS Max version 4.0 are flexible IK independent shaded bones system for more accurate skeletal setups, previews, and skinning, and IK support of branching hierarchies, pinned objects, and six degrees of freedom (6DOF) constraints.

Character deformations include new angle deformers and soft body characteristics. Other features include game development support for Direct3D, multi textures per face, opacity mapping, true transparency, and pixel/vertex shaders like reflection maps and bump maps. An “animate” button makes everything clicked on virtually animated. Shaders provided include isotropic, Blinn, Oren-Nayar-Blinn, Phong, metal, multilayer, and Strauss with independent sampler options.

NURBS can be projected onto mesh surfaces. NURBS surfaces include point and CV, u-loft, uv-loft, blend, n-sided blend, offset, extrude, fillet, lathe, ruled, cap, one rail, two rail, trim, and multi-curve trim. NURBS curves include point and CV, fit, offset, chamfer, fillet, surface-surface intersection, surface edge, ISO, curve on surface, and projected with trimming control.

The particle system has behavioral control, such as inter-particle collision, meta-particles, snow, spray, bubbles, explosions, spawning, and trails that support dynamic reactions with forces and object collisions. Interchangeable light types include omni, free and target spot, free and target directional that support plug-in shadows, shadow color and density, projected images, contrast, edge softness, attenuation, and decay.

Discreet’s 3DS Max 5.0 includes new bone tools, character node function, set-key animation, skin pose, morphing, spline IK, function curve and dope sheet editors, integrated dynamics, and weighted controllers. Other new features include a redesigned UV interface and new polygonal modeling tools.

3DS Max 5 is available for Windows 2000 and XP and retails for $3,195 with an option to upgrade from Max 4 for $795 or from Max 3 for $995.


Poser 4 by Curious Labs

Team LiB

Poser 4 by Curious Labs
(www.CuriousLabs.com)

Poser 4 is a 3D-character animation and design tool for artists and animators for creating images, movies, and posed 3D figures from a large selection of detailed 3D human and animal models. The library includes pose settings, facial expressions, hand gestures, and numerous exchangeable clothing wardrobes.

The Poser 4 Sketch Designer is a rendering option that allows an artist using a series of brushstrokes to create a scene to define backgrounds, edges of scene elements, and individual elements and figures.

Each piece of clothing was designed as though it were a Poser figure, defined as a conforming figure to be attached to other clothing or body parts. Poser 4 comes with an extensive library of brand-new, predesigned wardrobe elements.

The animated deformers include magnet (bending, stretching, or pinching), wave (animates ripples on surfaces), and turbulence (splash or explosive blast effects). Poser’s advanced texture controls allow a whole figure or individual body part to incorporate transparency and reflections into textures.

Unlimited light can be placed into a scene, including the new fixed set of three global lights, which can be spotlights that cast very realistic shadows and varying cones and intensity settings. A “point at” light function can track a prop or figure’s motion.

Poser has hierarchical selection tools, polygonal picking and grouping, and its figures have IK.

Poser 4’s libraries have over 60 fully textured 3D figures, including nude human male and female models, babies (generic with or without a diaper), three robot models, and new animal models. The hair models include styles such as an afro, curly, pigtails, and facial hair. Facial models include round face, long face, ovoid, heart, and square, plus lips, nose, chin, cheeks, brow, and ethnic morphs.

Some clothes in the library include full human body outfits (cat suit or superhero costume for a female, a halter type dress and a spaghetti strap dress for a female, a formal gown for a female, a male and female overcoat, and a man’s tuxedo), various hats, upper body (female halter, male and female long sleeve, male muscle shirt, male necktie, male and female short sleeve with collar, male and female t-shirt, male and female turtleneck, male and female unitard, and male and female vest), lower body (male and female bikini, jeans, shorts, slacks, and female above knee skirt), footwear (female boots, cowboy boots, female high heels, male and female running shoes, sandals, socks, and work shoes). Also included in the library are animation sets, characters, faces, hands, pose sets, and walk collections.

Poser 4 can import 3D files such as AIFF, AVI (Windows), BMP, BVH motion, DXF, JPEG, OBJ, PICT, QuickTime (Mac), TIFF, WAV, 3DMF, 3DS, and export AVI (Windows), BMP, BVH motion, DXF, H-Anim, JPEG, MetaStream 2, OBJ, PICT, QuickTime (Mac), RIB, TIFF, VRML 2, 3DMF, and 3DS.

System requirements for Windows are a Pentium PC running Windows 95, 98, Me, or NT (Service Pack 3 or later), 32 MB RAM (64 MB recommended), color display (24-bit recommended), CD-ROM drive, and 240 MB free hard disk space. For a Pentium PC running Windows 2000 or XP the requirements are 64 MB RAM (128 MB recommended), color display (24-bit recommended), CD-ROM drive, and 240 MB free hard disk space. For a Macintosh such as a Power Macintosh the requirements are System 8.x through 9.x with 32 MB RAM (64 MB recommended), color display (24-bit recommended), CD-ROM drive, 240 MB free hard disk space.

Poser 5 full version retails for $319, while the Upgrade retails for $169.

LIPSinc Mimic

LIPSinc Mimic from Curious Labs is a stand-alone Windows application that works with Poser 4 (not included) and automates lip-synching and facial animation. Mimic analyzes speech (import a sound file or use a microphone and enter the sounds) and automatically outputs the correct corresponding mouth, jaw, and lip position data and speech gestures, such as head nods, and eye blinks), for Poser version 3 and version 4 figures.

LIPFX Mimic is the application for timing and lip-position data, and SpeechFX Mimic generates realistic head, eye (including eye blinks), and eyebrow movements. LIPSinc Mimic’s system requirements are a Pentium 2 or higher, 32 MB RAM running under Windows 95, 98, or NT with Curious Labs Poser version 3.01 or version 4.

LIPSinc Mimic retails for $139.


NXN Software’s alienbrain (

Team LiB

NXN Software’s alienbrain (www.Alienbrain.com)

Click To expand

NXN Software’s alienbrain 5.0 is a digital production management software application for enhanced project management of gaming assets, studio management, and bug tracking. PMX, or Project Management Extension, allows the manager to plan the project, schedule it, and track it efficiently by allowing maintenance of multiple project plans per team, associated media assets on a task basis, and task distribution, with progress and completion monitored in real time.

BMX, or Bug Management Extension, enables development teams to log, store, assign, track, and resolve bugs, feature requests, and development tasks, as well as produce summary reports. SMX, or Studio Management Extension, provides current status reports and content reports for production and asset (artwork, audio files, and so on) management. Reports can be based on an individual user or team based on content and modifications.

NXN alienbrain Starter Pack is a configuration system for smaller teams ($9,990 for a team of up to ten users that contains one team productivity server, one PowerClient, five BaseClients, and four CodeClients with one year maintenance). Just like NXN alienbrain’s other applications, the Starter Pack includes version control for media assets and source code, project management, and workflow functionality. The Starter Pack integrates with Discreet’s 3D Studio Max, Alias|Wavefront’s Maya, and Softimage|XSI. The package is designed for ten users and can be extended to 20 users if needed.

NXN Software’s alienbrain VFX is an asset management solution specifically designed for the production of large-scale visual effects projects. NXN alienbrain VFX is based on the technology behind NXN alienbrain and has key features, such as asset management support for scanned and rendered film frames; handling of large, binary files such as 3D models and film frames; graphical clients for Linux, Mac OS X, and Windows; scalability to tens of terabytes of production data and millions of objects; optimized high performance file transfers in NFS (Network File System) environments; and integration with common visual effects and animation tools, such as Maya, 3D Studio Max, and Softimage|XSI.

NXN Software’s alienbrain 6.0 offers over 50 new features and improvements, most of which focus on the product’s new software configuration management (SCM) capabilities for programming teams like full branching, branch merging, sharing, structural history, atomic get, and pinning features—and these new features apply to the asset management aspects of alienbrain as well.

Other features designed for programmers include command-line tools for automated processes and shell scripting, event scripting to allow teams to modify the behavior of existing functionality to suit specific development processes (e.g., create a script that aborts an import if a file does not conform to a certain pixel depth or size), the ability to change reporting tools, a customizable defect and request tracking module, and integration with Microsoft Visual Studio and Metrowerks’ CodeWarrior. A new dedicated alienbrain “Developer Client” complements the pre-existing “Designer Client” and “Manager Client” used by development teams. Developer, Designer, and Manager clients are available for $690, $990, and $1,990, respectively. A Japanese version is scheduled for the fourth quarter of 2003.


PVCS Merant

Team LiB

PVCS Merant
(www.Merant.com/pvcs)

Click To expand

Merant creates software for managing digital assets, enhancing team collaboration, and business decision support. They focus on protecting and tracking multiple uses of software, content, and intellectual property. PVCS lets you manage software changes across all platforms from one repository with one tool and offers end-to-end change management across the broadest range of digital assets—applications, code, and content.

PVCS Professional combines PVCS Version Manager, PVCS Tracker, and PVCS Configuration Builder into a single suite for software configuration management (SCM). PVCS Professional enables teams of any size to protect software assets, automate development tasks, and manage the many changes and issues involved in team development.

PVCS Version Manager is the industry standard for version control in team development environments. It organizes, manages, and protects software assets during revision and promotes team collaboration. PVCS Version Manager is integrated with numerous development environments and tools.

PVCS Tracker captures, manages, and communicates changes, issues, and tasks, providing basic process control to ensure coordination and communication within and across development and content teams at every step.

PVCS Configuration Builder ensures that applications can be reliably built in a reproducible manner, ensuring components from the same version are used.

PVCS Dimensions tightly integrates SCM (software configuration management) functions under process definition and enforcement to automatically manage workflow and change implementation.


Rational Software ClearCase (

Team LiB

Rational Software ClearCase (www.Rational.com/
products/clearcase/)

Rational Software ClearCase is a robust software artifact managing tool. Rational’s software configuration management (SCM) solution contains the essential functions of transparent code sharing, version control, and advanced workspace and build management.


Starbase StarTeam

Team LiB

Starbase StarTeam
(www.Starbase.com/)

Starbase offers a complete family of advanced team development, software configuration management (SCM) solutions such as StarTeam, an easy-to-use SCM that allows development teams to collaborate and communicate through an intuitive, award-winning interface (for Windows 95 and NT).

StarTeam is a true Client/Server architecture system supporting clients over the Internet and other networks with full data encryption and compression in multiple views, such as change requests, parallel and concurrent development, charting and reporting with a set of standard charts, user-defined specifications and customizable HTML-based report generation, and grouped or sorted criteria for reports and charts.

The security includes group or individual access rights. Other tools include e-mail notification of changes and change requests and state transitions of workflow.


Telelogic CM Synergy

Team LiB

Telelogic CM Synergy
(www.Telelogic.com)

Telelogic CM Synergy provides life cycle control of software development assets enabling improved software quality and faster delivery by maintaining the integrated, central repository database of software assets and all project-related information, including tasks, processes, and team members associated with each aspect.

CM Synergy is a task-based change management software offering a flexible and powerful distributed repository and a team-oriented workflow approach to development teams of varying sizes. Other modules of Synergy include Change Synergy, a web-based change request tracking and reporting system; CM Synergy (DCM), distributed change management for remote and geographically distributed teams; CM Synergy ObjectMake, which controls your build process, improving productivity and quality among the team; and ProjectSynergy for Microsoft Project, to get a greater understanding of project activity and schedules.


Chapter 10: The User Interface

Overview

The user interface (the current expression for GUI or graphical user interface) is how the player or user sees the displayed graphics and presentation of the game and communicates with the game through various commands, such as game controls, input devices (joysticks, mouse, steering wheels), on-screen interface (icons, buttons, gauges, score areas), timing mechanics (speed indicators or pressure gauges for hitting a ball or accelerating a vehicle), and text and messages to verbal commands through a speaker for game sounds or verbal responses.

The user interface is the most important aspect of a game since it is how the player sees and interacts with the product. A realistic sports game or an RPG with hard to remember or understand controls and screen buttons frustrates and often turns the players off from what could be a really great game. If players in the middle of a deeply involved and immersed experience have to stop to read a manual to figure out how to access the needed weapon or what command exits the room, they will be irritated and angry.

Cars operate and have similar features to all other cars, yet no two car models are exactly alike. People feel good about loading a game and feeling that the controls and screens look familiar and are easy to understand. A number of discussions at gaming conferences have been about how many levels a player should go in depth to perform a needed action. The designer should be thinking, “How can I make getting to this action command easy and logical.” If there are common game activities that are done on a more frequent basis than others, those commands should be placed in a convenient location where they can be accessed quickly and easily.

You might say, “Where’s the room for innovation?” There’s a lot of room and desire for innovation in gaming and user interface design, but the issue to debate is “innovation at whose expense?” If you decide to be innovative at the player’s expense and your design seems harder to the player, then it should be reworked or thrown away. If it seems hard to the player at first but over time becomes easier and players enjoy the innovation, then that’s a great thing. The thought of being innovative should include a default method, “following the rest of the crowd,” and your innovation as a bonus “better” method. Eventually, players will try your innovation, and if it truly is a better method, players, reviewers, and your competitors will emulate your innovation.

The user interface should provide easy-to-recognize icons, buttons, and menus. Placing “tool tips”—or little descriptions of the item when the mouse is over that location a second or so—helps the player understand the input control. Designing a mouse over and an on-click state of a button or icon, along with an audible sound, would also reinforce the input control. Placing pop-up menus or pull-down menus so they don’t interfere with critical screen elements is important. If you are in a strategy game where several of your units are about to attack your enemy’s stronghold and a menu blocks that section of the screen, you as the designer either didn’t understand your game from the player’s POV or the implementation of your design wasn’t clear enough in your design document.

In the design of your user interface, research is a crucial area. Read the reviews of similar products. What are the reviews and feedback from players saying? What mistakes are being made and could be repeated by your design? Then look at the competing products and understand why they have developed their UI in the format that they present to the players. Read Chapter 7, “Research” (again) and notice the evolution of the baseball games and military strategy FPS from their simple, first endeavors to today’s complex and highly competitive versions. If your game design is a baseball game, read about what you’re competing with. Notice their features, UI, team size, and budgets. Your UI design may be perfect, but it might require expensive technology and a budget or time frame that is unrealistic. Remember in Chapter 7 the two games that I dismissed as first-time endeavors entitled Intergalactic Council and The Lost Kingdoms? These two concepts could become a user interface nightmare if not planned out and tested properly.

In 2002, I was involved with a Civil War 3D strategy game developed by Walker Boy Studio entitled War Between the States. Here is an excerpt from the Walker Boy Studio web site (used with permission) on designing their user interface.


War Between the States User Interface (UI)

The user interface for our purpose was conceived with the intention to provide first and foremost a straightforward and meaningful set of tools to be used continuously throughout War Between the States. To give you an insight into the reason behind our chosen idea for the UI, let us first show an example of a screen from War Between the States’ user interface.

Click To expand
Figure 1: War Between the States UI

As you can see, our layout has a unique and smooth flow to it. The idea behind creating a flawless interface begins with understanding how the game will play out and how the user will “read” the screen. For War Between the States, the game plays out with the user’s vantage point (being one from above at a slight angle). The view can be rotated along a Z-axis, moved directionally along the X- and Y-axis, and zoomed in and out. With these settings, our major “Play/Motion” of the viewing screen will be one that consists mostly of scrolling throughout the world. In order for us to take advantage of this motion and use its flow consistently with that of our user interface, we decided to divide it with a top bar and a lower bar. A distinct difference in size is noticeable, and for our purpose the larger of the two was placed at the bottom of the screen to give the impression of a strong and solid foundation from which to display the “Game Screen.” These two bars section off the screen in an even and calm fashion providing an almost “framed” impression. With the smaller top bar that supports the more important and most-used information and the lower bar containing the broader sets of information, the UI bars divide themselves appropriately pertaining to how we “read” the screen.

To continue with this thought, the layout also added a strong visual effect for the “read” of the screen. The most common way of viewing a screen is as we read from left to right and top to bottom. Therefore the UI bars’ horizontal construction subtly moves the user across and throughout the screen. Remember as a designer and artist, we must realize that it is our job to subconsciously direct and lead the users where we want them to go for the sole purpose of providing them the greatest experience possible.

There are multiple UI bars to choose from in War Between the States and each with its own distinct look and feel. When approaching the base set of colors and tones used for the UI bars, it is best to create an image that will stand out when it is looked at and gently fade into the background when it is not being looked at. There are several things that can affect how a UI bar is viewed, one being if the UI bar is too detailed and “busy” it tends to distract the user from the game as well as make it difficult to quickly access the information needed throughout the game. Dead space, unused space, and “bad negative space” on a UI bar also creates eyesores that distract the user, and it would be best to avoid such cases.

Aside from the color and other artistic renderings applied to a UI bar, the entire shape of the UI bar also dictates how well the user will react. For our game, we have chosen a clean-cut look with solid color schemes and layouts. The UI bars that border our gaming screens have been created with a straight bar across. This was chosen so that we could keep the UI bars from becoming too complex looking as well as to aide us in not creating a feeling of parts of the scene appearing hidden behind a cut up user interface. Now these things are very subtle, but they are what make the difference between a UI that works well and one that does not for this game. This does not mean that other UI screens cannot work, but for ours, this type of layout is by far the most comprehensive and complimentary to our game type and idea.

For a visual demonstration of what I have been talking about I have prepared a few examples that compare other user interfaces.

Click To expand

As you can see, each is quite different and unique. Starting with Figure 3, the major difference is the addition of a right side bar. This is an excellent example of how the flow of the eye can be immediately stopped and the fluid motion from point to point on the screen is disrupted. It does allow for more options on the screen, which means more buttons but also more distractions. If a right side bar is to be added, the best advice artistically speaking is to frame in the entire screen. What that will produce is a much more evenly balanced and visually pleasing layout. Examining Figure 4, it allows the eye to find and better focus in on what the designer wants them to focus on. What happens without the left UI bar, simply put, is a process where the eye will overfocus on either the game screen or the UI and not create the smooth flow between the two, or it will cause the eye to slip to the left of the viewing screen subconsciously because of the open area at the edge of the screen. One other thing we avoided was breaking the UI screen in to several pieces along its horizontal line. As you can see from Figure 5, when a UI is broken up such as this, it again does not allow for even flow across. It creates a definite stop and restart. This slows the process and adds more time getting the information needed.

Click To expand

With Figure 5, we see a segmented UI that needs some help. Cutting up a UI can work, but not like this. If a UI is going to be cut up, it needs to have a good reason for being cut into separate pieces. One reason that comes to mind is that the information in each box is very different and need not be placed next to any other UI information. Another is that there may be so little information needed that to artistically create a well-balanced layout, the UI bars and buttons are separated across the gaming screen. See Figure 6.

As designers and artists, we are trying to create works of art with every frame of motion in a game. As any artist will tell you, no matter how beautiful the painting, if its frame is bad it will only lessen the impact of the image.


Last UI Thoughts

So as a game designer, think about your initial impression to your audience. How do you want them to view your design? What comments should your design inspire in your audience?

When I designed a product entitled Flicks! Film Review Library, which was a film database containing information about 30,000 films (the director, the actors, synopsis of plot), I had to decide to either design a database program that would be functional but boring or a highly colorful, fun, and easy-to-use product. I chose the latter, letting the user access all the controls from the main screen.

Click To expand

The reviews really praised the product, calling Flicks! “an indispensable tool for every VCR sold,” “easy to use,” “attractive,” “mouse or key based,” and “the only program you’ll ever need.” These are the comments that a good UI program should expect, along with a solid design behind it.

Click To expand

I designed Flicks! from a fanatical user POV and as though it would be used by a novice computer person like your grandmother or young child. The searching power of multiple fields “and” and “or-ed,” combined with simple a click on an actor’s name to see all of his films, made the product enjoyable and sought after by film, video, and computer enthusiasts.


Chapter 11: The Basics of Programming

Overview

Programming is like being a general in the military and giving absolute commands to your troops. You say “march” and 100 soldiers begin to move forward. You say “halt!” and they all stop immediately. This is programming. You tell a dumb machine it can only do a few things, such as add “one plus one” and answer the question “does one equal one?” Simplistic? Yes. Realistic? Yes.

Commands (or let’s call them “instructions”) are processed in order. Life is processed in order.

At 7:00 A.M.: You get up out of bed.
At 7:15 A.M.: You walk into the bathroom.
At 7:16 A.M.: You turn on the water in the shower.
At 7:17 A.M.: You get into the shower.
At 7:18 A.M.: You soap yourself.
At 7:19 A.M.: You rinse off.

Repeat three more times.

At 7:20 A.M.: You soap yourself.
At 7:21 A.M.: You rinse off.
At 7:22 A.M.: You soap yourself.
At 7:23 A.M.: You rinse off.
At 7:24 A.M.: You soap yourself.
At 7:25 A.M.: You rinse off.

(end of the loop or repeated commands)

At 7:26 A.M.: You exit the shower and dry off.

This is life, but it can also be looked at as a set of instructions (or programming).


A Look at Programming

Architects design plans, builders create blueprints, and engineers draw schematics. Computer engineers (including programmers) draw flowcharts to visually explain the system’s or module’s flow that they wish to design.

Let’s start with a few common computer programming terms.

Character or Char is an 8-bit (numbers from 0 to 127) storage location that is used for alphanumerics (numbers, letters A-Z, and symbols).

Boolean or Bool is an 8-bit storage location that is TRUE (non-zero) or FALSE (a zero value).

Integer or Int is a 16-bit storage location that is used for numbers –32767 to 32767.

Unsigned integer is a 16-bit storage location that is for positive-only integers or numbers 0 to 65,535.

Long is a 32-bit storage location that is used for numbers –2.1 billion to 2.1 billion.

Unsigned long is a 32-bit storage location that is for positive-only longs or numbers 0 to 4.2 billion.

Float is a 16-bit real number (decimal or fractions).

String is a group of characters (Char format) that are referenced by a common name and have a NULL (or zero)-ending delimiter.

Array is a group of common elements as an array of integers, an array of longs, or an array of strings.

Structure is a group of elements of various types. A structure wraps these elements together under one heading. A sample of a structure called “Employee” may contain the employee’s name (a string), the employee’s address (a string), the employee’s salary (a float), or the employee’s age (an integer).

Class is similar to a structure where various types of elements and functions related to these elements are combined. Similar to the “Employee” structure, we could have a class “Employee” that includes the employee’s name (a string), the employee’s address (a string), the employee’s salary (a float), the employee’s start date (a date structure, three integers defining the month, day, and year), and employee’s birth date (a date structure). The class “Employee” can also contain the function for the employee’s age (no longer an integer but a function based on today’s date and the employee’s birth date), a yearly salary review based on the employee’s start date, and a birthday e-mail function to send the employee an “E-card” on his birthday (based on the birthday variables).

ASCII stands for American Standard Code for Information Interchange.


Operating Systems

There are several operating systems and system graphic libraries, such as Windows, Windows DirectX, OpenGL, and Linux.

Windows NT is a Microsoft Windows personal computer operating system designed for users and businesses needing advanced capability. NT’s technology is the base for the Microsoft successor operating system, Windows 2000. Windows NT (which unofficially may have originally stood for “New Technology”) is actually Microsoft NT Workstation and Microsoft NT Server combined. The Workstation is designed for business users who need a more reliable and faster performance system than Windows 95 and Windows 98.

Windows CE (which unofficially may have originally stood for “Consumer Electronics”) is based on the Microsoft Windows operating system but is designed for including or embedding in hand-held computers and as part of cable TV set-top boxes.

Windows 2000 (W2K) is a version of Microsoft’s evolving Windows operating system that was called Windows NT 5.0. Microsoft emphasizes that Windows 2000 is evolutionary and “built on NT technology.”

Windows XP is the latest version of the Windows desktop operating system for the PC. Windows XP is touted as the most important version of Windows since Windows 95. Windows XP is built on the Windows 2000 kernel and comes in a Professional version and a Home Edition version.

DirectX is an application program interface (API) for creating and managing graphic images and multimedia effects under Microsoft’s Windows. DirectX includes DirectDraw (an interface for two-dimensional images), Direct3D (an interface for creating three-dimensional images), DirectSound (an interface for sound), DirectPlay (a plug-in for Internet and multiplayer applications), and DirectInput (an interface for input from I/O devices).

OpenGL (Open Graphics Library) is the computer industry’s standard application program interface (API) for defining 2D and 3D graphic images across numerous platforms and operating systems. OpenGL is similar to DirectX’s DirectDraw and Direct3D.

Linux is a Unix-like operating system including a graphical user interface, an X Window system, TCP/IP (file transfer, electronic mail, remote logon), and the Emacs (customizable open source text editor and application development system) with a reputation as a very efficient and fast-performing system. Unlike Windows, Linux is publicly open, and because it conforms to the Portable Operating System Interface standard user and programming interfaces, developers can write programs that can be ported to other operating systems. There are approximately 18 million Linux users worldwide.


Programming Commands

Let’s look at the basics of programming commands or statements through three styles: flowcharting, BASIC (Beginner’s All-purpose Symbolic Instruction Code) language, and C (or C++) language.


Conditional Statements (Also Called “if” Statements or Decision Blocks)

Click To expand


Compound “if” Statements (Multiple Conditions)

Click To expand


Mathematical Statements

Click To expand

A “loop” statement: Set an array “Q” with ten indexed storage spaces where each index is multiplied by 2.

Click To expand

BASIC program for the “loop” flowchart (“'” indicates a comment):

FOR INDEX = 1 TO 10    'INDEX will start at 1 and end after its
                       'increments to 10
 Q(INDEX)= INDEX * 2   'Store in index of Q, INDEX multiplied by 2
NEXT INDEX             'Increment INDEX and loop back to FOR

C or C++ program for the “loop” flowchart (“//” indicates a comment):

for(INDEX=1; INDEX <= 10; INDEX++) // INDEX will start at 1, check
                                   // to see if it’s still less than
                                   // or equal to 10 and then
                                   // increment INDEX by 1
 Q[INDEX] = INDEX * 2;             // Store in index of Q, INDEX
                                   // multiplied by 2

This process can also be initialized as:

// C starts with index of zero
        int Q[11] = { 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20};


Computer Concepts

The first concept we will examine is called a “stack” or a “queue.” A checkout line in a grocery store opens up, and there is no one in the line. A customer enters the line, and the cashier begins to ring him up. Another customer enters the line behind the first customer, and then another customer enters the end of the line behind the second customer. The first customer pays for his groceries and leaves. The second customer is rung up as another customer enters the end of the line.

This everyday occurrence is known as a queue or a stack, where the first person in line is the first person processed. We call this FIFO or First In, First Out.

FIFO’s cousin is FILO, or First In, Last Out, which occurs in situations like cooking pancakes. The first pancake is nice and brown and is tossed onto a plate. The next pancake is finished and tossed on top of the first pancake. Another pancake is cooked and tossed on top of the second pancake. Then you sit down at the kitchen table ready to eat the fruits (or pancakes) of your labor. The first pancake you begin to eat is the last pancake you cooked (the pancake on top). The next pancake you eat is the second one cooked, and the last pancake eaten is the first one cooked. This method is an example of FILO; the first pancake cooked is the last one eaten.


Min-Max Gaming Theory (with Alpha-Beta Pruning)

Let’s pretend that we are playing a game, and it is our turn. On our turn we have two choices, “A” and “B.” By selecting choice “A” we will lose the game, and by selecting choice “B” we will win the game. The obvious choice would be “B” for the win. If we have ten choices that we can choose from and the first choice gives us a win, the remaining nine choices can be ignored since any other choice will not produce a result better than the first choice, which results in a win. This is the theory called “Min-Max with Alpha-Beta pruning.” You seek to find the best result, and your opponent seeks to find your worst result (or his best result). If choice “A” for your opponent leads to you winning and choice “B” for your opponent leads to you losing, your opponent will choose “B,” leading to your loss (or their win). As you evaluate each level or turn to be made, you seek a positive, winning result while your opponent seeks a negative (losing for you) result.

Once the maximum or a preset cutoff (threshold) result has been found, all remaining decisions (or paths) are unnecessary to examine. Many “n-player” games like chess, Othello, and checkers utilize these gaming theories to quickly evaluate and determine the non-human player’s strategy (also called AI, or artificial intelligence, since we are simulating intelligent thinking).

In Chapter 13, we discuss artificial intelligence in more depth.

Before we look at instructing a machine to process our commands (or programming), let’s look at a simple gaming process on paper and replicate it through a flowchart (a diagram explaining our process) and then various methods of writing our instructions (also known as “coding” or “programming”).


Tic-Tac-Toe

Let’s look at a simple game that we all know and have played called Tic-Tac-Toe. The three-by-three board is filled by two players (“X” and “O”), and the winner is the player who successfully connects three of his Xs or Os in a row (horizontal, vertical, or diagonal).

In Tic-Tac-Toe, the player who goes first (say, “X”) can choose one of nine spaces to mark with an “X” (as in the above diagram spaces one to nine). Then “O” has a turn and can mark any of the remaining eight empty spaces. This gameplay continues until either player has won (three connecting marks) or all of the spaces are filled (no player wins). In mathematics, we call this process “factorial,” and in Tic-Tac-Toe it is 9! or nine factorial (9 * 8 * 7 * 6 * 5 * 4 *3* 2 * 1).

This means that the full tree structure or game path would have 9! ending states (or “nodes”), which is 362,880 win, lose, or draw (tie) states.

When playing Tic-Tac-Toe, there are two methods of selecting a space to mark with your X or O: randomly marking an empty space or logically examining each empty space through an iterative process and selecting the space that leads to a non-losing result (a winning or tying result). All games use one of these methods, but obviously the second, non-random method gives us a better game and stronger competition.

The following sample game will indicate the “side to play” (X or O) and the next available space to mark.

Click To expand

X wins (3, 5, 7 diagonal connection).

The “Min-Max” search would return a result of 1 for X and –1 for O, meaning a win for the player X worth 1 point and a loss to player O and worth –1 points. The process would terminate or prune lower branches, since the game is over at step (G). The result of –1 in step (F) would trigger a more favorable result for O to find elsewhere.

O evaluates the next empty space, which is space 7 in step (F), in lieu of the losing choice step (F) marking space 6.

Click To expand

X wins (1, 5, 9 diagonal connection).

Again the “Min-Max” search would return a result of 1 for X and –1 for O, meaning a win for the player X worth 1 point and a loss to player O worth –1 points. The process would terminate or prune lower branches since the game is over at step (G). The result of –1 in step (F) would trigger a more favorable result for O to find elsewhere.

O evaluates the next empty space, which is space 8 in step (F), in lieu of the losing choice step (F) marking space 7.

Click To expand

Finally O evaluates the next empty space, which is space 9 in step (F), in lieu of the losing choice step (F) marking space 8.

Click To expand

After looking at the various paths, O will evaluate step (D), O mark 4, as the critical mistake and evaluate (D), O mark 5.

Click To expand

In step (E), X must stop O from winning by marking space 8 (forced move).

In step (F) below, O finds the next free space and marks space 4.

Click To expand

In step (G), X must once again stop O from winning by marking space 6 (forced move).

In step (H), O must stop X from winning by marking space 9 (forced move).

Finally, X marks space 7, the only remaining space, and a tie or draw occurs.

Let’s examine the following Tic-Tac-Toe scenario:

This scenario has player O select and mark an empty space. The iterating method would require that each empty space (spaces 3, 4, 6, 7, 8, and 9) be examined and evaluated. After spending time and effort evaluating the empty spaces, the process would recognize that player O is forced to mark space 9 to stop player X from winning. The best method of handling the selection and marking our next space would be to first check to see if any empty space would give us the immediate win and then if we can’t win, check if any empty space would give our opponent the immediate win before examining each empty space in order.

Forced Move

Our thinking would lead us to the following thought process:

TOP:

Set current Tic-Tac-Toe board to current scenario.

Is there an empty space to mark so that I win?

If YES, select and mark this space and

set result to WIN.

If NO, continue.

Is there an empty space to mark so that I won’t lose?

If YES, select and mark this space and

set result to Forced Mark.

If NO, continue.

Are there any empty spaces left?

If YES, continue.

If NO, set the result to the game is over

(a tie).

Place your mark on the next empty space.

Set side to play to the other player.

Go back to label TOP.

To properly design the function “Forced Move,” we need to know which player is to mark X (marked as +1) or O (marked as –1). This function “Forced Move” will return a +100 value if we win, a –100 value if our opponent could win (we are forced to block them), and a zero if no winning situation is found. We know that to win at Tic-Tac-Toe, we must have three connecting spaces marked with matching Xs or Os.

Click To expand

Forced Move Revised

The flowchart describing a “Forced Move” looks (obviously) like a process that can be better defined and easier to express. We can define an array called wp (win path), which has two dimensions—paths and linked spaces.

Click To expand

Let’s look at how we can use the knowledge we just learned to program Tic-Tac-Toe in Visual Basic and Visual C++.


Visual Basic Tic-Tac-Toe

Click To expand

Our user interface (above) lets the player start a new game, choosing whether he would like to go first or second as either X or O, and lists the moves (spaces marked). The larger “big” board is where the current game is played and the player marks his desired space. The smaller board displays the computer thinking as calculated by the Min-Max with Alpha-Beta pruning search algorithm.

FORM1

Private Sub Form_Load()

Dim i As Integer

Form1.BorderStyle = 0

Text1.Text = " " + "Moves" + " "
Frame1.Visible = False

InitVariables
playerMark = -1
End Sub

Private Sub Option1_Click(index As Integer)

 Picture1.Enabled = True
 Picture1.PaintPicture BigBoard, 0, 0
 Picture2.PaintPicture SmBoard, 0, 0

 InitVariables
 showBigBoard
 showSmallBoard

 playerMark = (2 * (index Mod 2)) - 1 '-1 is "O", 1 is "X"

 playerDONE = 1                   ' Computer goes first
 Option1(index).value = False     ' reset Selected value
 Frame1.Visible = False
 Option2.Enabled = True
 Option2.value = False
 Option2.Visible = False

 If index < 2 Then         ' Player’s turn
 Text5.Text = "Your turn, please mark a space"
 Picture1.Enabled = True   ' Player goes first
 playerDONE = 0
 Else                      ' Computer’s turn
 opening
 End If
End Sub

Private Sub Option2_Click()

 Frame1.Visible = True
 Text1.Text = " " + "Moves" + " "
 Option2.Enabled = False
End Sub

Private Sub Picture1_Click()

Dim i As Integer
Dim flag As Integer

 If playerDONE = 1 Then Exit Sub
 flag = -1

'check the area the player has selected to mark
 For i = 0 To 8
 If PmouseX >= (15 * BigBoxXY(i, 0)) And PmouseX <= (15 *
                    (BigBoxXY(i, 0) + 120))
 Then
 If PmouseY >= (15 * BigBoxXY(i, 1)) And PmouseY <= (15 *
                    (BigBoxXY(i, 1) + 95))
 Then
 If ttt(0, i) = 0 Then
 ttt(0, i) = playerMark
 Text1.Text = Text1.Text + "You marked space " + Str(i + 1) + " "
 Text4.Text = "Marked " + Str(i + 1)
 showSmallBoard ' display current path scenario of board
 playerDONE = 1
 showBigBoard
 opening
 Exit Sub
 End If
 End If
 End If
 Next i
End Sub

Private Sub Picture1_MouseMove(Button As Integer, Shift As Integer,
  X As Single, Y As Single)
 PmouseX = X
 PmouseY = Y
End Sub

Private Sub Picture1_Paint()
 showBigBoard
End Sub
Private Sub Picture2_Paint()
 showSmallBoard
End Sub

Public Sub showBigBoard()

Dim i As Integer

For i = 0 To 8
 If ttt(0, i) = 1 Then
 Picture1.PaintPicture markX, 15 * BigBoxXY(i, 0), 15 *
                  BigBoxXY(i, 1)
 End If
 If ttt(0, i) = -1 Then
 Picture1.PaintPicture markO, 15 * BigBoxXY(i, 0), 15 *
                  BigBoxXY(i, 1)
 End If
Next i

Clevel = 0
showSmallBoard
End Sub

Public Sub showSmallBoard()

Dim i As Integer

For i = 0 To 8
 If ttt(Clevel, i) = 1 Then
 Picture2.PaintPicture smarkX, 15 * SmBoxXY(i, 0), 15 * SmBoxXY(i, 1)
 End If
 If ttt(Clevel, i) = -1 Then
 Picture2.PaintPicture smarkO, 15 * SmBoxXY(i, 0), 15 * SmBoxXY(i, 1)
 End If
Next i
End Sub
Click To expand
MODULE1
'since C++ start arrays at index Zero we will too
'Set the Global variables

Public ttt(0 To 9, 0 To 8) As Integer
Public wp(0 To 7, 0 To 2) As Integer
Public BigBoxXY(0 To 8, 0 To 2) As Integer
Public SmBoxXY(0 To 8, 0 To 2) As Integer
Public playerMark As Integer
Public Path As String
Public playerDONE As Integer
Public PmouseX As Integer
Public PmouseY As Integer
Public markX As Picture
Public markO As Picture
Public smarkX As Picture
Public smarkO As Picture
Public BigBoard As Picture
Public SmBoard As Picture
Public caption1 As String
Public Clevel As Integer
Public L1nextspace As Integer
Public Level1Data(0 To 9) As Integer

Sub InitVariables()

Dim i As Integer
Dim j As Integer

' Change the path according to your Directory

 Path = "C://Wordware//VBTicTacToe//"
 Set BigBoard = LoadPicture(Path + "TicTacToeBigBoard.bmp")
 Set SmBoard = LoadPicture(Path + "TicTacToeSmBoard.bmp")
 Set markX = LoadPicture(Path + "BigX.bmp")
 Set markO = LoadPicture(Path + "BigO.bmp")
 Set smarkX = LoadPicture(Path + "SmallX.bmp")
 Set smarkO = LoadPicture(Path + "SmallO.bmp")

 Clevel = 0

 Form1.Picture1.Enabled = False

'Initialize the Tic-Tac-Toe boards (all levels) to Zeor
 For i = 0 To 9
   For j = 0 To 8
     ttt(i, j) = 0
   Next j
 Next i

'We start the arrays at Zero to match our C-code

' Rows
  wp(0, 0) = 0: wp(0, 1) = 1: wp(0, 2) = 2
  wp(1, 0) = 3: wp(1, 1) = 4: wp(1, 2) = 5
  wp(2, 0) = 6: wp(2, 1) = 7: wp(2, 2) = 8
' Columns
  wp(3, 0) = 0: wp(3, 1) = 3: wp(3, 2) = 6
  wp(4, 0) = 1: wp(4, 1) = 4: wp(4, 2) = 7
  wp(5, 0) = 2: wp(5, 1) = 5: wp(5, 2) = 8
' Diagonals
  wp(6, 0) = 0: wp(6, 1) = 4: wp(6, 2) = 8
  wp(7, 0) = 2: wp(7, 1) = 4: wp(7, 2) = 6
' Define our two Tic-Tac-Toe boards

  BigBoxXY(0, 0) = 0: BigBoxXY(0, 1) = 0
  BigBoxXY(1, 0) = 125: BigBoxXY(1, 1) = 0
  BigBoxXY(2, 0) = 243: BigBoxXY(2, 1) = 0
  BigBoxXY(3, 0) = 0: BigBoxXY(3, 1) = 101
  BigBoxXY(4, 0) = 125: BigBoxXY(4, 1) = 101
  BigBoxXY(5, 0) = 243: BigBoxXY(5, 1) = 101
  BigBoxXY(6, 0) = 0: BigBoxXY(6, 1) = 196
  BigBoxXY(7, 0) = 125: BigBoxXY(7, 1) = 196
  BigBoxXY(8, 0) = 243: BigBoxXY(8, 1) = 196

  SmBoxXY(0, 0) = 0: SmBoxXY(0, 1) = 0
  SmBoxXY(1, 0) = 22: SmBoxXY(1, 1) = 0
  SmBoxXY(2, 0) = 44: SmBoxXY(2, 1) = 0
  SmBoxXY(3, 0) = 0: SmBoxXY(3, 1) = 22
  SmBoxXY(4, 0) = 22: SmBoxXY(4, 1) = 22
  SmBoxXY(5, 0) = 44: SmBoxXY(5, 1) = 22
  SmBoxXY(6, 0) = 0: SmBoxXY(6, 1) = 44
  SmBoxXY(7, 0) = 22: SmBoxXY(7, 1) = 44
  SmBoxXY(8, 0) = 44: SmBoxXY(8, 1) = 44

  Randomize (Timer) ' initialize the Random number function

End Sub

'Copy a new Tic-Tac-Toe board starting with the previous board

Sub Copy_ttt(level As Integer)

Dim index As Integer

If level < 1 Then Exit Sub
If level > 8 Then Exit Sub

Clevel = level ' for small tic-tac-toe board

 For index = 0 To 8
   ttt(level, index) = ttt(level - 1, index)
 Next index
 Form1.showSmallBoard
End Sub

' Let's verify if there's an empty space to fill

Function SpaceEmpty(level As Integer) As Integer

Dim index As Integer

 For index = 0 To 8
   If ttt(level, index) = 0 Then
     SpaceEmpty = index + 1
     Exit Function
   End If
 Next index
 SpaceEmpty = 0 'no empty space was found
End Function
' A function to check if the current board position is a winning
' one for either player

Function IsThereaWin(level As Integer, MySide As Integer) As Integer

Dim ttWin As Integer
Dim OppWin As Integer
Dim MyWin As Integer
Dim wpindex As Integer
Dim i As Integer

 OppWin = -3 * MySide
 MyWin  =  3 * MySide

 For wpindex = 0 To 7 ' for each win (3 rows, 3 columns and
          2 diagonals)
  ttWin = 0
  For i = 0 To 2 ' add the 3 spaces as per direction to check
    ttWin = ttWin + ttt(level, wp(wpindex, i))
  Next i

  If ttWin = MyWin Then ' I have 3 connecting marks
    IsThereaWin = 100 'I win plus space to move to
    Exit Function
  End If

  If ttWin = OppWin Then ' Opponent can get 3 connecting marks
    IsThereaWin = -100 'Forced plus space to block
    Exit Function
  End If
 Next wpindex

 IsThereaWin = 0
End Function

' Let's check to see if there's a forced move to make
' A forced move is a winning space or a blocking space to stop a loss

Function Forced_Move(level As Integer, MySide As Integer) As Integer

Dim index As Integer
Dim trys As Integer
Dim ttWin As Integer
Dim OppWin As Integer
Dim MyWin As Integer
Dim wpindex As Integer
Dim i As Integer
Dim FMove As Integer
Dim sgn1 As Integer

 OppWin = -3 * MySide
 MyWin  =  3 * MySide

 For trys = 0 To 1
   For index = 0 To 8

     If level > 0 Then Copy_ttt (level)

     If ttt(level, index) = 0 Then ' empty space
       If trys = 0 Then ' Can we win on this turn
         ttt(level, index) = MySide
       Else ' Can our opponent win if we don't block on this turn
         ttt(level, index) = -MySide 'opponent
       End If

       FMove = IsThereaWin(level, MySide)

       If FMove <> 0 Then

         sgn1 = 1
         If FMove < 0 Then sgn1 = -1

         Forced_Move = sgn1 * (Abs(FMove) + index + 1)
         If level > 0 Then Copy_ttt (level)
         Exit Function
       End If

     End If
   Next index
 Next trys

 If level > 0 Then Copy_ttt (level)
 Forced_Move = 0 'No forced move
End Function
Click To expand
Sub Tic_Tac_Toe()

Dim X As Integer
Dim MySide As Integer
Dim spaceon As Integer
Dim FMove As Integer
Dim i As Integer
Dim value As Integer

  X = 0: MySide = -playerMark

  If SpaceEmpty(0) Then 'Game still on

' A forced move to win or to block a win is the best mark move

    X = Forced_Move(1, MySide)
    spaceon = Abs(X) Mod 100

    If X <> 0 Then ' A forced move has been calculated
      ttt(0, spaceon - 1) = MySide ' either a '1' or a '-1'
      Form1.Text1.Text = Form1.Text1.Text + " I marked space " +
              Str(spaceon) + " "
    End If

'find a space that's not forced

    If X = 0 Then

' Initialize the level 1 available mark spaces to an extremely low
  value
      For i = 0 To 9
      Level1Data(i) = -999
    Next i

' Call the Min-Max Function where Alpha is very low and Beta is very
  high

    X = MinMaxValue(1, MySide, -999, 999) ' find the best move

' find the best space to mark from the level 1 list of valid spaces
  to mark

    spaceon = SpaceEmpty(0) - 1
    X = -999

    For i = 1 To 9
      if Level1Data(i) > X Then
        spaceon = i
        X= Level1Data(i)
      End If
    Next i

    ttt(0, spaceon - 1) = MySide '  Mark the best space

    Form1.Text1.Text = Form1.Text1.Text + " I marked space " +
         Str(spaceon) + " "
  End If

  Form1.Text4.Text = "Marked " + Str(spaceon)
  Form1.showSmallBoard ' display current path scenario of board
End If

Form1.showBigBoard
playerDONE = 0

FMove = IsThereaWin(0, playerMark)

  If FMove <= -100 Then ' Be prepared to see this message often
    Form1.Text1.Text = Form1.Text1.Text + " " + "HURRAY! I WON!"
                  + " "
    Form1.Text1.Text = Form1.Text1.Text + " Play me again?"
    Form1.Text5.Text = "Would you like to play me again?"
    playerDONE = 100
    Form1.Option2.Visible = True
    Exit Sub
  End If
  If FMove >= 100 Then ' You may never see this message
    Form1.Text1.Text = Form1.Text1.Text + " " + "WOW! YOU'VE WON!"
                   + "  "
    Form1.Text1.Text = Form1.Text1.Text + " Play me again?"
    Form1.Text5.Text = "Would you like to play me again?"
    playerDONE = 100
    Form1.Option2.Visible = True
    Exit Sub
  End If

  If FMove = 0 Then ' No win found and all spaces marked

    playerDONE = 0
    Form1.Text5.Text = "Your turn, please mark a space"

    If SpaceEmpty(0) = 0 Then ' no more empty spaces to mark
      Form1.Text1.Text = Form1.Text1.Text + " " + "DRAW!" + " "
      Form1.Text1.Text = Form1.Text1.Text + " Play me again?"
      Form1.Text5.Text = "Would you like to play me again?"
      Form1.Option2.Visible = True
      Exit Sub
    End If
  End If
End Sub

' Just like a chess opening database, here are standard
' Tic-Tac-Toe opening marks

Sub opening()

Dim i As Integer
Dim j As Integer
Dim k As Integer

  Form1.Text5.Text = "" ' clear message

' Check to see if we go first and second
  j = 0

  For i = 0 To 8
    If ttt(0, i) <> 0 Then
      j = j + 1
      k = i
    End If
  Next i

  If j > 1 Then

    Form1.Text5.Text = ""
    Tic_Tac_Toe ' find a space to mark
    Exit Sub
  End If

  If j = 0 Then      ' we go first
    i = Int(Rnd * 5) ' valid first marks are spaces 1,3,5,7 and 9
    i = i * 2  ' we have a random number 0 through 4 so we double it
    ttt(0, i) = -playerMark
    Form1.Text4.Text = "Marked " + Str(i + 1)
    Form1.Text1.Text = Form1.Text1.Text + " I marked space " +
                     Str(i + 1) + " "
    playerDONE = 0
    Form1.showBigBoard
    Form1.Text5.Text = "Your turn, please mark a space"
    Form1.Picture1.Enabled = True ' Player goes
    Exit Sub
  End If

  If j = 1 Then ' we go second

' valid moves are center and the opposite corner if the opponent
' marked a corner space

  i = -1 ' a flag

  If k = 4 And i = -1 Then ' center space marked
  AAA: i = Int(Rnd * 4)    ' valid first marks are spaces 1,3,7 and 9
    If i = 4 Then GoTo AAA ' can't mark the center space
    i = i * 2 ' we have a random number 0 through 4 so we double it
  End If

  If i = -1 Then           ' center space was not marked
    i = 4                  ' mark center space (space 5)
  End If

  ttt(0, i) = -playerMark
  Form1.Text4.Text = "Marked " + Str(i + 1)
  Form1.Text1.Text = Form1.Text1.Text + " I marked space " + '
                   Str(i + 1) + " "
  playerDONE = 0
  Form1.showBigBoard
  Form1.Text5.Text = "Your turn, please mark a space"
  Form1.Picture1.Enabled = True ' Player goes
  Exit Sub
 End If
End Sub
Click To expand
Function MinMaxValue(level As Integer, MySide As Integer, alpha As
     Integer, beta As Integer) As Integer
Dim WIN       As Integer
Dim index     As Integer
Dim MTlist    As Long
Dim nextspace As Integer
Dim X         As Integer
Dim succval   As Integer
' reset current level board

  Copy_ttt (level)

  If SpaceEmpty(level) = 0 Then
    MinMaxValue = 0
    Exit Function
  End If

'find a space that's not forced
'list all open spaces

  MTlist = 0 ' List all the open (unmarked) spaces on this level

  X = Forced_Move(level, MySide) ' Is there a forced move (a win or a
                                 ' block of a win)

  If X <> 0 Then                 ' a forced move has been flagged
    MTlist = Abs(X Mod 100)      ' space is 1 to 9
  Else
    For index = 0 To 8
      If ttt(level, 8 - index) = 0 Then ' subtract from 8 for
           ascending order
        MTlist = MTlist * 10 + (9 - index)
      End If
    Next index
  End If

  While MTlist > 0
    nextspace = MTlist Mod 10          ' next space to mark
    MTlist = (MTlist - nextspace) / 10 ' remainder of possible spaces
                                       ' to mark

    Copy_ttt (level)
    ttt(level, nextspace - 1) = MySide

    Form1.Text4.Text = "Marked " + Str(nextspace)
    Form1.showSmallBoard ' display current path scenario of board

    WIN = IsThereaWin(level, MySide)

    If WIN >= 100 Then
      succval = WIN
    Else
      succval = -MinMaxValue(level + 1, -MySide, -beta, -alpha)
    Endif

    If level = 1 Then       ' Save this space's value
      Level1Data(nextspace) = succval
      If succval = 100 Then ' Winning line found
        MinMaxValue = succval
        Exit Function
      End If
    End If

'The Alpha-Beta pruning code

    If succval >= beta Then
      MinMaxValue = beta
      Exit Function
    End If

    If succval > alpha Then alpha = succval

    Wend

    MinMaxValue = alpha ' return a draw

End Function
Click To expand
//since C++ start arrays at index Zero we will too
int ttt[8][8]={ {0,0,0,0,0,0,0,0},{0,0,0,0,0,0,0,0},
                {0,0,0,0,0,0,0,0},{0,0,0,0,0,0,0,0},
                {0,0,0,0,0,0,0,0},{0,0,0,0,0,0,0,0},
                {0,0,0,0,0,0,0,0},{0,0,0,0,0,0,0,0}};

int wp[8][3]={{0,1,2},{3,4,5},{6,7,8}, // Rows
              {0,3,6},{1,4,7},{2,5,8}, // Columns
              {0,4,8},{2,4,6}};        // Diagonals

// Copy a new Tic-Tac-Toe board starting with the previous board
void Copy_ttt(int level)
{
     int index;

     if(level<1) return;              // invalid parameter
     for(index=0; index<9; index++)
          ttt[level][index]= ttt[level-1][index]
}

// Let's verify if there's an empty space to fill
int SpaceEmpty(int level)
{
     int index;

     for(index=0; index<9; index++)
          if(ttt[level][index]==0)return(index+1);
     return 0;    // no empty space was found
}

// Let's check to see if there's a forced move to make
// A forced move is a winning space or a blocking space to stop
// a loss
int Forced_Move(int level, int MySide)
{
     int index, trys, ttWin;
     int OppWin= -3 * MySide;
     int MyWin= 3 * MySide;

     for(index=0; index<9;index++)
          for(trys=0; trys<2; trys++){
               if(level>0) Copy_ttt(level);

               if(ttt[level][index] == 0){ // empty space
                    if(trys ==0)ttt[level][index]= MySide;
                    else ttt[level][index]=-MySide; // opponent

               ttWin= ttt[level][wp[index][0] +
                    ttt[level][wp[index][1] +
                    ttt[level][wp[index][2];

               if(ttWin == MyWin)return(100 + index); // I win plus
                                                   space to move to
               else
               if(ttWin == OppWin)return(-(100 + index)); // Forced
                                                plus space to block
          }

     return 0; // No forced move
}
void Tic_Tac_Toe()
{
int x=0, MySide= 1, spaceon;

     while(SpaceEmpty(0) && x < 100){ // Game still on
          x= Forced_Move(1, MySide);
          spaceon= abs(x)%100;
          if(x != 0)ttt[0][spaceon]= x/100; // either a '1' or a '-1'
          else{          // find a space that's not forced
               BestMove(1);    // find the best move
          }

          x= 0; // reset 'x'
     }
}

(This code can be found on the book’s companion CD.)


Visual C++ Language: Code for the AI Logic of Tic-Tac-Toe

#include "stdafx.h"
#include "TicTacToeLogic.h"
#include <time.h>
#include <mmsystem.h>
#define IDB_SMBOARD    140
#define IDB_BIGO         141
#define IDB_BIGX         142
#define IDB_SMALLO       143
#define IDB_SMALLX       144
#define IDB_BOARD        145
// extern(al) variables or variables that are defined in another file
extern CString           m_msg1,m_msg2,m_moves;
extern HINSTANCE         m_hInstance;
extern int               Setbuttons;
extern HDC               my_hDC;

// Set the Global variables
char                     Path[100];
int                      ttt[10][9], wp[8][3], BigBoxXY[9][3],
                           SmBoxXY[9][3];
int                      playerMark, playerDONE, PmouseX, PmouseY;
char                     squote[2]={(char)39,(char)0}; // ' single
                          quote

HBITMAP                  markX, markO, smarkx, smarko;
HBITMAP                  BigBoard, SmBoard;
int                      Clevel, L1nextspace, Level1Data[10];
unsigned int             randseed;

/////////////////////////////////////////////////////////////////////
void LoadBMPs()
{
  markX = ::LoadBitmap(m_hInstance,MAKEINTRESOURCE(IDB_BIGX));
  markO = ::LoadBitmap(m_hInstance,MAKEINTRESOURCE(IDB_BIGO));
  smarkx = ::LoadBitmap(m_hInstance,MAKEINTRESOURCE(IDB_SMALLX));
  smarko = ::LoadBitmap(m_hInstance,MAKEINTRESOURCE(IDB_SMALLO));
  BigBoard = ::LoadBitmap(m_hInstance,MAKEINTRESOURCE(IDB_BOARD));
  SmBoard = ::LoadBitmap(m_hInstance,MAKEINTRESOURCE(IDB_SMBOARD));
}
/////////////////////////////////////////////////////////////////////
void InitVariables()
{
int     i, j;

  Clevel = 0;

// Initialize the Tic-Tac-Toe boards (all levels) to Zeor
  for(i = 0; i <= 9; i++)
    for(j = 0; j <= 8; j++)
      ttt[ i ][ j ] = 0;

// We start the arrays at Zero to match our C-code
// Rows
  wp[ 0 ][ 0 ] = 0; wp[ 0 ][ 1 ] = 1; wp[ 0 ][ 2 ] = 2;
  wp[ 1 ][ 0 ] = 3; wp[ 1 ][ 1 ] = 4; wp[ 1 ][ 2 ] = 5;
  wp[ 2 ][ 0 ] = 6; wp[ 2 ][ 1 ] = 7; wp[ 2 ][ 2 ] = 8;

// Columns
  wp[ 3 ][ 0 ] = 0; wp[ 3 ][ 1 ] = 3; wp[ 3 ][ 2 ] = 6;
  wp[ 4 ][ 0 ] = 1; wp[ 4 ][ 1 ] = 4; wp[ 4 ][ 2 ] = 7;
  wp[ 5 ][ 0 ] = 2; wp[ 5 ][ 1 ] = 5; wp[ 5 ][ 2 ] = 8;

// Diagonals
  wp[ 6 ][ 0 ] = 0; wp[ 6 ][ 1 ] = 4; wp[ 6 ][ 2 ] = 8;
  wp[ 7 ][ 0 ] = 2; wp[ 7 ][ 1 ] = 4; wp[ 7 ][ 2 ] = 6;

// Define our two Tic-Tac-Toe boards
  int xoff1= 260,xoff2=40,yoff1=6,yoff2=210;
  BigBoxXY[ 0 ][ 0 ] = xoff1 + 0; BigBoxXY[ 0 ][ 1 ] = yoff1 + 0;
  BigBoxXY[ 1 ][ 0 ] = xoff1 + 125; BigBoxXY[ 1 ][ 1 ] = yoff1 + 0;
  BigBoxXY[ 2 ][ 0 ] = xoff1 + 243; BigBoxXY[ 2 ][ 1 ] = yoff1 + 0;
  BigBoxXY[ 3 ][ 0 ] = xoff1 + 0; BigBoxXY[ 3 ][ 1 ] = yoff1 + 101;
  BigBoxXY[ 4 ][ 0 ] = xoff1 + 125; BigBoxXY[ 4 ][ 1 ] = yoff1 + 101;
  BigBoxXY[ 5 ][ 0 ] = xoff1 + 243; BigBoxXY[ 5 ][ 1 ] = yoff1 + 101;
  BigBoxXY[ 6 ][ 0 ] = xoff1 + 0; BigBoxXY[ 6 ][ 1 ] = yoff1 + 196;
  BigBoxXY[ 7 ][ 0 ] = xoff1 + 125; BigBoxXY[ 7 ][ 1 ] = yoff1 + 196;
  BigBoxXY[ 8 ][ 0 ] = xoff1 + 243; BigBoxXY[ 8 ][ 1 ] = yoff1 + 196;

  SmBoxXY[ 0 ][ 0 ] = xoff2 + 0; SmBoxXY[ 0 ][ 1 ] = yoff2 + 0;
  SmBoxXY[ 1 ][ 0 ] = xoff2 + 22; SmBoxXY[ 1 ][ 1 ] = yoff2 + 0;
  SmBoxXY[ 2 ][ 0 ] = xoff2 + 44; SmBoxXY[ 2 ][ 1 ] = yoff2 + 0;
  SmBoxXY[ 3 ][ 0 ] = xoff2 + 0; SmBoxXY[ 3 ][ 1 ] = yoff2 + 22;
  SmBoxXY[ 4 ][ 0 ] = xoff2 + 22; SmBoxXY[ 4 ][ 1 ] = yoff2 + 22;
  SmBoxXY[ 5 ][ 0 ] = xoff2 + 44; SmBoxXY[ 5 ][ 1 ] = yoff2 + 22;
  SmBoxXY[ 6 ][ 0 ] = xoff2 + 0; SmBoxXY[ 6 ][ 1 ] = yoff2 + 44;
  SmBoxXY[ 7 ][ 0 ] = xoff2 + 22; SmBoxXY[ 7 ][ 1 ] = yoff2 + 44;
  SmBoxXY[ 8 ][ 0 ] = xoff2 + 44; SmBoxXY[ 8 ][ 1 ] = yoff2 + 44;

  setRandom(); // initialize the Random number function
}
/////////////////////////////////////////////////////////////////////
// Copy a new Tic-Tac-Toe board starting with the previous board

void Copy_ttt(int level)
{
int index;

if( level < 1)return;
if( level > 8)return;

Clevel = level; // for small tic-tac-toe board

  for( index = 0; index <= 8;index++)
    ttt[ level ][ index ] = ttt[ level – 1 ][ index ];
}
/////////////////////////////////////////////////////////////////////
// Let's verify if there's an empty space to fill

int SpaceEmpty(int level)
{
int index;

  for(index = 0; index <= 8; index++)
    if( ttt[level][index] == 0)
      return( index + 1 );

  return(0); //no empty space was found
}
/////////////////////////////////////////////////////////////////////
// A function to check if the current board position is a winning
// one for either player

int IsThereaWin(int level, int MySide)
{

int ttWin, OppWin, MyWin, wpindex, i;

  OppWin = -3 * MySide;
  MyWin = 3 * MySide;

  for(wpindex = 0; wpindex <= 7; wpindex++){ // for each win
                          (3 rows, 3 columns and 2 diagonals)
    ttWin = 0;
    for(i = 0; i<= 2; i++) // add the 3 spaces as per direction
                              to check
      ttWin = ttWin + ttt[level][wp[wpindex][i]];

    if( ttWin == MyWin)    // I have 3 connecting marks
      return(100);         // I win plus space to move to

    if( ttWin == OppWin) // Opponent can get 3 connecting marks
      return(-100); // forced plus space to block
  }

  return(0);
}
/////////////////////////////////////////////////////////////////////
// Let's check to see if there's a forced move to make
// A forced move is a winning space or a blocking space to stop
// a loss

int forced_Move(int level, int MySide)
{
int index, trys, OppWin, MyWin, FMove, sgn1;

  OppWin = -3 * MySide;
  MyWin = 3 * MySide;

  for( trys = 0; trys<= 1; trys++)
    for( index = 0; index <= 8; index++){

    if( level > 0 )Copy_ttt (level);

      if( ttt[level][index] == 0 ){ // empty space

    if( trys == 0 )                 // Can we win on this turn
      ttt[level][index] = MySide;
    else                  // Can our opponent win if we don’t block
      ttt[level][index] = -MySide;  // opponent

    FMove = IsThereaWin(level, MySide);

    if( FMove != 0 ){
      sgn1 = 1;
      if( FMove < 0 ) sgn1 = -1;

      if( level > 0 ) Copy_ttt (level);
      return (sgn1 * (abs(FMove) + index + 1));
      }
    }
  }

  if( level > 0 ) Copy_ttt (level);

  return(0);                        //No forced move
}
/////////////////////////////////////////////////////////////////////
void Tic_Tac_Toe()
{
int X, MySide, spaceon, FMove, i;

  X = 0;
  MySide = -playerMark;

  if( SpaceEmpty(0) > 0 ){         // Game still on

// A forced move to win or to block a win is the best mark move

    X = forced_Move(1, MySide);
    spaceon = abs(X) % 100;         // -100 or +100 plus space to mark

    if( X != 0 ){        // A forced move has been calculated
      ttt[0][spaceon - 1] = MySide;       // either a '1' or a '-1'
      m_moves=_T(" I marked space ");
      m_moves+=REPitoa(spaceon,2);
    } // X != 0

//find a space that’s not forced

    if( X == 0 ){

// Initialize the level 1 available mark spaces to an extremely
// low value
      for( i = 0; i <= 9; i++)
        Level1Data[i] = -999;

// Call the Min-Max Function where Alpha is very low and Beta is
// very high

      X = MinMaxValue(1, MySide, -999, 999); // find the best move

// find the best space to mark from the level 1 list of valid spaces
// to mark

        spaceon = SpaceEmpty(0) - 1;
        X = -999;

        for( i = 1; i <= 9; i++)
        if( Level1Data[i] > X ){
          spaceon = i;
          X = Level1Data[i];
        }

        ttt[ 0 ][ spaceon – 1 ] = MySide;   // Mark the best space

        m_moves+=_T(" I marked space ");
        m_moves+=REPitoa(spaceon,2);
    } // X == 0

      m_msg2=_T("Marked ");
      m_moves+=REPitoa(spaceon,2);
      show_boards();     // display current path scenario of board
  } // SpaceEmpty(0) > 0

  show_boards();
  playerDONE = 0;
  FMove = IsThereaWin(0, playerMark);

  if( FMove <= -100 ){ // Be prepared to see this message often
    m_moves+=_T(" HURRAY! I WON!");
    m_moves+=_T(" Play me again?");
    m_moves+=_T("Would you like to play me again?");
    playerDONE = 100;
    Setbuttons= -2;    // Reset_Buttons
    return;
  } // FMove <= -100

  if( FMove >= 100 ){  // You may never see this message
    m_moves+=_T(" WOW! YOU");
    m_moves+=squote;   // Place a ' within " "
    m_moves+=_T("VE WON!");
    m_moves+=_T(" Play me again?");
    m_moves+=_T("Would you like to play me again?");
    playerDONE = 100;
    Setbuttons= -2;    // Reset_Buttons
    return;
  }                    // FMove >= 100

  if( FMove == 0 ){    // No win found and all spaces marked

    playerDONE = 0;
    m_msg1=_T("Your turn, please mark a space");

    if( SpaceEmpty(0) == 0 ){ // no more empty spaces to mark
      m_moves=_T(" DRAW!");
      m_moves=_T(" Play me again?");
      m_moves=_T("Would you like to play me again?");
      Setbuttons= -2; // Reset_Buttons
      return;
    } // SpaceEmpty
  } // FMove == 0
}
/////////////////////////////////////////////////////////////////////
// Just like a chess opening database, here are standard
// Tic-Tac-Toe opening marks

void opening()
{
int   i, j, k;

  m_moves=_T("");

// Check to see if we go first and second
  j = 0;

  for (i = 0; i <= 8; i++ )
    if( ttt[0, i] != 0 ){
      j++;
      k = i;
    } // ttt[0, i] != 0

  if( j > 1 ){

    m_msg1=_T("");
    Tic_Tac_Toe();       // find a space to mark
    return;
  }

  if( j == 0 ){           // we go first
    i = (int)(Random(5)); // valid first marks are spaces 1,3,5,7
                          // and 9
    i = i * 2;            // we have a random number 0 through 4
                          // so we double it
    ttt[0][i] = -playerMark;
    m_msg2=_T("Marked ");
    m_moves+=REPitoa(i + 1,2);
    m_msg1=_T("I marked space ");
    m_moves+=REPitoa(i + 1,2);
    playerDONE = 0;
    show_boards();
    m_msg1=_T("Your turn, please mark a space");     // Player goes
    return;
  } // j == 0

  if( j == 1 ){               // we go second

// valid moves are center and the opposite corner if the opponent
// marked a corner space

    i = -1;                   // a flag

    if( k == 4 && i == -1 ){  // center space marked

      i=4 ;                   // can't mark the center space
      while (i ==4)
        i = (int)(Random(4)); // valid first marks are spaces 1,3,7
                              // and 9

        i = i * 2;            // we have a random number 0 through 4
                              // so we double it
    }                         // k == 4 && i == -1

    if( i == -1 )             // center space was not marked
      i = 4;                  // mark center space (space 5)

    ttt[0][i] = -playerMark;
    m_msg2=_T("Marked ");
    m_msg2=REPitoa(i + 1,2);
    m_moves=_T(" I marked space ");
    m_moves+=REPitoa(i + 1,2);
    playerDONE = 0;
    show_boards();
    m_msg1=_T("Your turn, please mark a space"); // Player goes
    return;
  }
}
/////////////////////////////////////////////////////////////////////
int MinMaxValue(int level, int MySide, int alpha, int beta)
{
int WIN, index, nextspace, X, succval;
long MTlist;

// reset current level board
  Copy_ttt (level);

  if( SpaceEmpty(level) == 0 ) return( 0 );

// find a space that’s not forced
// list all open spaces

  MTlist = 0;  // List all the open (unmarked) spaces on this level

  X = forced_Move(level, MySide); // Is there a forced move (a win
                                  // or a block of a win)

  if( X != 0 )                    // a forced move has been flagged
    MTlist = abs(X % 100);        // space is 1 to 9
 else{
    for( index = 0; index <= 8; index++)
      if( ttt[level][8 - index] == 0 ) // subtract from 8 for
                                       // ascending order
        MTlist = MTlist * 10 + (9 - index);
    }                             // else

  while (MTlist > 0){
    nextspace = MTlist % 10;            // next space to mark
    MTlist = (MTlist - nextspace) / 10; // remainder of possible
                                        // spaces to mark

    Copy_ttt (level);
    ttt[level][nextspace - 1] = MySide;

    m_msg2=_T("Marked ");
    m_moves+=REPitoa(nextspace,2);
    show_boards();

    WIN = IsThereaWin(level, MySide);

    if( WIN >= 100 )
      succval = WIN;
    else
      succval = -MinMaxValue(level + 1, -MySide, -beta, -alpha);

    if( level == 1 ){                     // Save this space’s value
      Level1Data[ nextspace ] = succval;
      if( succval == 100) return succval; // Winning line found
    }                                     // level == 1

// The Alpha-Beta pruning code

    if( succval >= beta ) return( beta );

    if( succval > alpha ) alpha = succval;

  }                                       // While

  return( alpha );                        // return a draw
}
/////////////////////////////////////////////////////////////////////
// Convert as number to a character array with a length of lval1
// (may have preceding zeroes)
char *REPitoa(long val1, int lval1)
{
long x;
int sgn=1, i, j, k, zeroflag=0;
static char strx[10];

  x= val1;
  if((val1 == 0) && (lval1 == 99)) return("");
  if(lval1 == 99) lval1= 0;
  if(val1 < 0){sgn= -1; x= -val1;}  // flag and set to positive
  if(lval1 < 0){
    zeroflag= 1;                    // preceding zero
    lval1= -lval1;
  }
  if(lval1 == 0){
    while(x > 0){
      lval1++;
      x= x / 10L;                   // divide by 10 as a long
    }
    x= val1;
  }
  if((val1 == 0) && (lval1 == 0)) lval1=1;
  if(lval1 > 9)lval1= 9;                // max length
  for(i=0; i<10; i++) strx[i]= (char)0; // end string
  if(x == 0){
    for(i= 0; I < lval1; i++) strx[i]= '0';
    return(&strx[0]);
  }
  j= 0;
  for(i= 0; i < lval1; i++){
    k= x % 10;
      if(k > 0 && j == 0) j=1;
      strx[lval1 - (1 + i)] = (char)((int)'0' + k);
      if((zeroflag == 0) && (x == 0) && (j == 1))
        strx[lval1 - (1 + i)]= (char)32; // blank left zeroes
      x=x / 10;                          // must be after the "if"
  }
  return &strx[0];
}
/////////////////////////////////////////////////////////////////////
// Button 0        Play first as 'O'
// Button 1        Play first as 'X'
// Button 3        Play second as 'O'
// Button 4    Play second as 'X'
void buttontoplay(int buttonid)
{
  show_boards();

  playerMark = (2 * (buttonid % 2)) - 1; // -1 is "O", 1 is "X"

  playerDONE = 1;                        // Computer goes first

  if( buttonid < 2){                     // Player’s turn
    m_msg1=_T("Your turn, please mark a space");
    playerDONE = 0;
  }
  else                                   // Computer’s turn
    opening();
}
/////////////////////////////////////////////////////////////////////
void Get_Mark()
{
  int i, flag;

  if (playerDONE == 1)return;
  flag = -1;

// check the area the player has selected to mark
  for (i = 0; i < 9; i++)
    if ((PmouseX >= (BigBoxXY[i][0])) && (PmouseX <= (BigBoxXY[i][0]
                  + 120)))
      if ((PmouseY >= (BigBoxXY[i][1])) && (PmouseY <=
                   (BigBoxXY[i][1] + 95)))
        if( ttt[0][i] == 0){
          ttt[0][i] = playerMark;
          m_moves=_T("You marked space ");
          m_moves+=REPitoa(i + 1,2);
          m_msg2=_T( "Marked ");
          m_msg2+=REPitoa(i + 1,2);
          playerDONE = 1;
          show_boards();
          opening();
          return;
    }
}
/////////////////////////////////////////////////////////////////////
void setRandom()
{
// Seed the random-number generator with current time so that
// the numbers will be different every time we run.
  if(randseed == 0){
    randseed= (unsigned int) timeGetTime();
    srand( randseed );
  }
}
/////////////////////////////////////////////////////////////////////
int Random(int num)
{
  int r;
  DWORD r1;

  if(num == 0) num=1;
  r1= rand();
  r= (int)r1 % num;

  return r;
}
/////////////////////////////////////////////////////////////////////
void show_boards()
{
    showSmallBoard();
    showBigBoard();
}
/////////////////////////////////////////////////////////////////////
void showBigBoard()
{
    int i, x, y;
    HDC hMemDCO= ::CreateCompatibleDC(NULL);
    HDC hMemDCX= ::CreateCompatibleDC(NULL);
    HDC hMemDC = ::CreateCompatibleDC(NULL);

  SelectObject(hMemDCO, markO);
  SelectObject(hMemDCX, markX);
  SelectObject(hMemDC, BigBoard);

  ::StretchBlt(my_hDC, 260, 6, 367, 293, hMemDC, 0, 0, 367, 293,
                  SRCCOPY);

    for (i = 0; i<9; i++){
      x= BigBoxXY[i][0];       y= BigBoxXY[i][1];
      if (ttt[ 0 ][ I ] == 1)              // markX
        ::StretchBlt(my_hDC, x, y, 113, 90, hMemDCX, 0, 0, 114, 90,
                   SRCCOPY);
      else
        if (ttt[ 0 ][ I ] == -1)           // markO
          ::StretchBlt(my_hDC, x, y, 114, 90, hMemDCO, 0, 0, 114, 90,
                   SRCCOPY);
    }
    Clevel = 0;

    DeleteDC(hMemDCO);
    DeleteDC(hMemDCX);
    DeleteDC(hMemDC);
}
/////////////////////////////////////////////////////////////////////
void showSmallBoard()
{
    int i,x,y;
    HDC hMemDCo= ::CreateCompatibleDC(NULL);
    HDC hMemDCx= ::CreateCompatibleDC(NULL);
    HDC hMemDC = ::CreateCompatibleDC(NULL);

  SelectObject(hMemDCo, smarko);
  SelectObject(hMemDCx, smarkx);
  SelectObject(hMemDC,  SmBoard);

  ::StretchBlt(my_hDC, 40, 210, 64, 64, hMemDC, 0, 0, 64, 64,
                  SRCCOPY);

    for (i = 0; i<9; i++){
      x= SmBoxXY[ i ][ 0 ];     y= SmBoxXY[ i ][ 1 ];
      if (ttt[ Clevel ][ i ] == 1)      // smarkX
        ::StretchBlt(my_hDC, x, y, 114, 90, hMemDCx, 0, 0, 114, 90,
                   SRCCOPY);
      else
      if (ttt[ Clevel ][ i ] == -1)     // smarkO
        ::StretchBlt(my_hDC, x, y, 18, 20, hMemDCo, 0, 0, 18, 20,
                   SRCCOPY);
    }

    DeleteDC(hMemDCo);
    DeleteDC(hMemDCx);
    DeleteDC(hMemDC);
}


Chapter 12: 3D Game Engines

Overview

The current trend in gaming is 3D games from a first-person or third-person POV.

Designing and programming a state-of-the-art 3D game engine could take a team of programmers a year or more to develop, and during this game development process, some tweaking and bug fixes would occur. A successful game experience validates and makes other developers and publishers interested in licensing that game’s 3D engine. Some development teams don’t have the time and talent necessary to create their own 3D game engine, so finding one that suits their needs and budget is more desirable.

The current 3D game engines fall into three categories, which I call “economy,” “midsize,” and “luxury.” The less expensive the engine, the older the technology and less features there are available. Likewise, the more expensive the 3D game engine, the newer the technology and more powerful and plentiful its features.


New Definitions

BSP (Binary Space Partition): In drawing 3D scenes, a tree structure is created and accessed where the objects are stationary and the player’s view direction changes.

LOD (Level of Detail): The number of needed polygons based on that object’s distance from the camera. The closer the object is to the camera, the more polygons it needs to look real. As it moves away from the camera, its details are less desired (removing the extra polygons speeds up the rendering process).

Texture: A 2D image that can be mapped onto a 3D image or polygon

MipMap: “Miltum in Parvo” or many things in a small place is Direct3D’s method of aliasing by limiting the ratio of pixel size to texel size (texture coordinate).

Bump Map: The process of using white and black to make a surface look bumpy. White or light will make a surface look tall or raised, while black or dark will make the surface look flat (no bumps).

Mesh: A mesh or wireframe is a polygonal skeleton, a line-based and nonshaded, nontextured object displayed with linear edges and subdivisions.

PVS (Potentially Visible Set): Precalculated set of visible cells in the process called Precalculated Portal Rendering where each cell has data called PVS


Economy 3D Engines

Genesis3D from Eclipse
(www.Genesis3d.com)

The Genesis3D game engine (1997) is free to use for commercial and noncommercial games and is an Open Source 3D game development engine, which means that any code modifications to the Genesis3D engine that your game makes will be freely distributed to the world. Also, the Genesis3D logo must be the first logo displayed in your game without modification.

If you want to keep your engine modification code a secret (private) and/or not display the Genesis3D logo, this engine becomes a “midsize” engine costing you $10,000 for a special Eclipse license.

The Genesis3D engine requires programmers and artists to create an entire game using the Genesis3D engine; a Windows programming language like Visual C++ 6 (or higher), Borland C++, Delphi, or Visual Basic; a 3D modeling art package like Animation: Master v8 (or higher), Milkshape3D, 3D Studio Max 3 (or higher), or Truespace; and a BSP (binary space partition) level editor like the included GEdit. DirectX 6 (or higher) is needed to run Genesis3D on Windows 95, 98, Me, and XP.

Please note that your game design and code will not be distributed—just the modifications that you make to the Genesis3D code (the engine’s DLL, LIB, or tools).

In 1999 Wild Tangent (www.wildtangent.com) and Eclipse Entertainment negotiated a deal where Wild Tangent purchased most of the Genesis3D assets to create their web driver.

Mark O’Hara began the task of cleaning up the Genesis3D code, adding new features and fixing some well-known bugs. He and his team realized they were rewriting a lot of code and decided to use their newly acquired knowledge and start from scratch, calling their endeavor Destiny3D (www.destiny3d.com/pages/engine.html).

Although Genesis3D is free, there seems to be a history of tweaking involved with using it as a viable 3D game engine. You basically get what you paid for.

For more information, please check out their web site (www.Genesis3d.com), as well as Wild Tangent’s web site (www.wildtangent.com) and Destiny3D’s web site (www.destiny3d.com).

Quake Engine GLP’d by id Software (1996) (www.idSoftware.com/
Business/Home/Technology/)

In 1999 id Software released the original Quake source code under the GNU general public license. If your development team has skillful talent but little cash or a small budget and can abide by the GPL terms, then this engine should be looked at. There are no restrictions on distributing a game using the GPL Quake engine, the engine that released such games as Half-Life, Hexen, Gunman Chronicles, Laser Arena, and Quake.

If you wish to avoid the GPL terms, the “non-GPL” Quake license can be purchased for a flat fee of $10,000 per title with no royalty.

This version includes networking code (some of the best mid- to high-latency network code ever designed) and the fast code and rendering you found in Valve’s “Half-Life.” An especially great 3D game engine for budget titles (under $20 retail software).

Torque Engine by GarageGames (www.GarageGames.com)

Click To expand

The Torque Engine (sometimes referred to as the Tribes 2 engine) supports reflections, environment mapping, detail texturing, static or dynamic LOD (Level of Detail), skeletal animation, and animation blending. Soon it will have bump mapping and vertex and pixel shading. Facial animation and lip-synching are being discussed, but since this engine is built for action and strategy games, these features are relatively low priority.

The Torque 3D game engine from GarageGames is ideal for independent game developers with huge dreams but less cash. The Torque game engine sells for $100 per programmer (an incredibly low price considering this is the Tribes 2 engine developed by Dynamix), which includes the source code and has some of the best networking in the industry, including that of the Unreal and Quake 3 engines.

TGE has been used by several triple “A” titles and includes the latest in scripting, geometry, particle effects, animation, texturing, and award-winning multiplayer networking code.

The documents and a nice demo are provided to run in Win32 (OpenGL and DirectX) and Macintosh OS 9/X server and client with OpenGL and Linux.

The Torque Engine comes with a scripting engine, a GUI engine, a mission engine, a 3D engine, a mesh engine, a particle engine, a terrain engine, an interior building engine, a water engine, and networking, sound (3D sound support with panning, volume, Doppler, and cones), spatial database, collision testing, vehicle physics, and tools (3DS Max plug-ins, exporter, WorldCraft converter, and lighting).

Torque technology games include Starsiege, Tribes, Front Page Sports: Skiing, and Trophy Hunting IV.

What’s the reason for such an inexpensive and extremely powerful 3D engine? In 1998 Dynamix employees started GarageGames, and Sierra (Dynamix’s parent company) partnered with them for the development and licensing of the Torque Engine. After paying the minimal $100 per programmer upfront fee, the source code to the Torque Engine, a demo application, and access to the CVS server is provided. Simple games are put on the server as “free games.” Higher quality games are put in a “pay bin” where revenue is split 50-50 between GarageGames and the developer. Extremely good games are published and distributed down the retail box chain through one of GarageGames’ publisher affiliates where they receive 20 percent and the developer gets 80 percent of the royalties received. Developers can look for their own publishing deal, but GarageGames must be involved in the negotiations once they’re underway.

Unlimited products can be developed using one Torque license. Products that are placed in the pay bin are priced by the developer and bought by the educated public. Developers who contribute to the official source code and technology base can trade off back-end royalty points for the code.

The Torque Engine in its “stock state” supports up to 128 players in a single game.

As of September 2002, the licensing agreement for the Torque Game Engine (TGE) will no longer require TGE licensees to publish on the GarageGames site. GarageGames will absolutely stand by their guarantee to publish games under their current license agreement and offers current licensees the option to move to the new agreement. The new license agreement requires indies (independents) to qualify based on having current annual revenues that do not exceed $500,000 in order to license the software for the $100-per-programmer price. Specifically, the EULA will state under Grant of License: “GarageGames grants you the right to use the Software in accordance with the terms of this Agreement. If the annual revenue of your company is less than $500,000 U.S. annually, you may publicly sell, distribute, release, publish, and/or transmit any games created with the Software. You may distribute free demos of the Games through third-party distribution channels. Free games may be distributed from your own web site.”

You can get the engine for $100 per programmer, create a demo or a game, and know that you only have to pay $10,000, no royalties, for the technology once you sign your deal. Or, the other scenario is that you use the low-price engine to create your game and start your own company. The engine is nearly free as you are getting started and money is tight. Then, if you succeed, you kick the $10,000 back to GarageGames (i.e., if you are successful, they are successful).

Power Render 4 Engine by Egerter Software (www.PowerRender.com)

Power Render is a set of tools for creating interactive 3D applications like games. A world editor used by level designers can build entire worlds from individual elements, such as terrain, BSP objects, and characters.

Since 1994 the flexible engine Power Render has been used for 3D applications that specialize in libraries for character animation, sound effects, and music. Power Render tools include support for geometry import, a level editor, character and particle effect editor, object preview and material editor, TrueType font to texture converter, archive manager, and Quake 3 BSP converter with model application support including 3D Studio Max versions 3 and 4, Character Studio versions 2 and 3, and LightWave 6.5 or higher or applications that create .3ds, .lwo, or .md2 files. Exporters for regular geometry, key framing, skinning using bipeds, and morph targets are provided.

Power Render 4 is a general purpose SDK for creating 3D multimedia applications and games. A high-level engine/editor is capable of mixing outdoor terrain and indoor BSP levels seamlessly. Features include full DirectX 8 support, 3D hardware (HAL) driver, C or C++ code using static libraries (requires Microsoft’s Visual C/C++ version 5 or 6), 16- or 32-bit color, full-screen and windowed rendering, Z buffering and stencil buffering with shadow volumes, dynamic lighting with directional, omni, spotlight, and lightmaps, automatic mipmap generation, vertex fogging, environment mapping, environmental and DOT3 bump mapping, cube mapping, procedural textures, compressed textures, real-time dynamic shadows using projection, shadow volume, Quake 3 BSP support with lightmaps, shaders, curves, PVS, and collisions, TrueType font support, 3D sound, and CD and MP3 playback.

It has the ability to store pixel and vertex shader code and constraints. Other features are radiosity lighting, textures each with a base map, bump map, detail map, light map, and cubic environment map, real-time shadowing, projected textures on rooms and objects, octree-based collision detection, and environmental reflections on all surfaces.

Coding can be done using Code Warrior 7, Delphi, Visual Basic, and Visual C++.

Landscape Studio Editor builds worlds entirely from scratch using any polygon mesh. Sliding (player movement) and bouncing (projectile movement) is supported. Entity generation quickly generates a random forest and other objects defined by parameters that the designer sets that include vegetation maps, random rotation and scale (for trees of varying sizes), height, range, and more.

Power Render supports three main types of animation: keyframing (rigid bodies), morphing (vertex interpolation), and skinning (skinned mesh over keyframed bones). A terrain can have a maximum height field of 512x512—a little higher if texture quality is sacrificed.

Power Render has three types of licenses where a license can be upgraded for the difference between the two prices. The shareware or freeware Power Render version is free to download (with a recommended $289 shareware price). This version includes a single-user unlimited shareware and freeware product (not for commercial products but great to demo to a publisher and upgrade after the product gets a signed contract or green flag to go retail). The tools and libraries can be used in their binary form, 12-month technical support and library updates (pay the shareware fee), and access to the FTP site for downloads and beta versions. The product must display the Power Render logo and copyright somewhere in the product.

Power Render’s commercial single-user product license (a $1,500 price tag) allows one person to develop and commercially sell his game (one game per license). The tools and library are in binary form with 12 months of technical support and library updates, access to the FTP site for downloads and beta versions. This license allows for commercial distribution royalty free for unlimited products for one person. The products must display the Power Render logo and copyright somewhere in the product.

Power Render commercial site license with source (a $5,500 price tag) allows for multiple users at multiple locations for developing a single title (per license). The tools and libraries are included as binary with full source code, technical support, and library updates available for 18 months, access to FTP site for downloading updates and beta versions. This is a royalty-free commercial distribution version for one game with modification to and distribution of tools and editor to end users for creating custom mods.

Quake 2 Engine by id Software (1997) (www.idSoftware.com/
Business/Home/Technology/)

In December 2001 id released Quake 2 source code under the GNU general public license. If you have a development team that has skillful talent but little cash or a small budget and can abide by the GPL terms, then this engine should be considered. There are no restrictions on distributing a game using the GPL Quake engine, the engine that released such games as Hexen 2, Daikatana, Heretic 2, Kingpin: Life of Crime, Sin, Soldier of Fortune, and Quake 2. The Quake 2 engine has more advanced hardware and software rendering and updated network code that launched successful titles such as Soldier of Fortune and Anachronox. The tools can be licensed separately for $5,000 per project with numerous third-party tools available.

If you wish to avoid the GPL terms, the “non-GPL” Quake 2 license can be purchased for a flat fee of $10,000 per title with no royalty.


Midsize 3D Game Engines

WildTangent Web Driver (Internet 3D Engine) (www.WildTangent.com)

The Web Driver is a platform for the development of high quality, high performance, compact 2D and 3D content for the Internet. It consists of a high-level API for Java, JavaScript, and other COM-enabled languages, such as C, C++, and Visual Basic, and has a powerful graphical engine underneath. The API provides both 2D and 3D support, allowing the creation of everything from simple 2D or 3D content, such as product visualizations for e-commerce, to full-fledged 3D games. All of these can run within a web page simply by visiting a web site.

Triple A console companies such as Activision and EA (Electronic Arts) are using Web Driver to allow players to play via the Internet.

The Web Driver consists of a downloadable component of about 1 MB and includes an updater mechanism to provide an easy way to distribute new versions with additional functionality and maintenance fixes. The user only has to install the Web Driver once, and after that the updater will automatically update the Web Driver when the computer is connected to the Internet (via a background process that uses idle or unused bandwidth), preventing the need for further delays and downloads at the time the content is viewed. The updater also provides information to WildTangent about error conditions on the user’s machine, as well as relevant hardware information necessary to reproduce and fix the issue. With the updater, we can be extremely proactive about fixing issues and implementing new features so that we can ensure that the user experience remains a positive one.

The plug-in includes Java and JavaScript interface layers for use by Java/JavaScript-enabled Internet Explorer and Netscape browsers. While the Web Driver was designed for the Internet, it also has a COM interface that can be used in stand-alone applications using languages such as Visual Basic, C, and C++.

The Web Driver is designed to connect the ease of distribution of the Internet with the power of the latest video hardware. The Web Driver is built upon DirectX, the current standard in 3D technology. This enables the use of hardware acceleration from just about every video card on the market. The Web Driver also includes a fast software renderer that emulates video features if they aren’t present on a user’s system.

The Web Driver’s modular architecture also allows it to be easily extended. New features can be added to the engine without requiring major changes to the way the Web Driver is built.

The Web Driver will run on any Windows-based operating system from Windows 98 on and offers support for Internet Explorer, Netscape Navigator, AOL, and Opera.

The Web Driver API and tools were designed with rapid development in mind for a fast developer learning curve, smooth art path, short product development cycle, and stable application deployment.

The Web Driver API is seamlessly integrated into Java and JavaScript. It does not have a proprietary scripting environment but is used directly as a part of the Java or JavaScript language. This allows developers to produce Web Driver content that leverages the full power of Java/JavaScript as well as the Web Driver API. The API can be used in JavaScript to produce simple content, such as e-commerce product visualizations, or produce high-performance games and applications in the more powerful Java environment.

The API is designed to remove as much low-level code development as possible from the content developer, allowing the rapid development of high-performance applications. Difficult procedures such as scene initialization, hardware detection and implementation, and setting of video modes is done by the Web Driver internally with just a few lines of code needed from the developer.

User input via keyboard, mouse, and joystick is easily exposed through event callbacks. The event interface also exposes the time of the event’s firing so that the content developer doesn’t need to use the system clock directly for measuring event times.

WYSIWYG scene design is made possible with WTStudio, a powerful and easy-to-use scene editor. You can view the scene as you build it with real-time lighting and display of 3D objects and animations. No compile step is necessary! Scenes can also be quickly displayed in a browser through WTStudio’s HTML exporter.

The Internet experience is enhanced via a smart download of resources. Resources are downloaded asynchronously, and the developer has control over which resources to download first, how many resources can download at once, and at what point enough resources are downloaded to start the application. Other resources can continue to download as the application is being used so that the user is presented with a minimal load time before viewing the content. Level lightmaps and binary trees can be set to be either included in the level file (for optimizing processor time) or generated by the client (for optimizing download time).

Resource files used by the Web Driver may be compressed and encrypted with WildCompress, not only providing for shorter download times but also protecting your art assets from being modified or appropriated for other applications.

Objects in the scene are arranged in a frame of reference hierarchy through the Web Driver’s scene graph. Objects can inherit position, rotation, scale, visibility, and collision properties of their parent objects, allowing easy construction and management of elaborate scenes.

The Web Driver uses hardware acceleration by default if it’s available. If it’s not, a powerful software renderer is used. Hardware is accessed through DirectX’s hardware abstraction layer, so your application will support the latest DirectX compatible video cards. If necessary, information about the user’s system can be explicitly obtained (with the user’s permission) through the WTSysInfo object.

Features of the rendering window include easy access to full-screen video modes, support for multiple cameras and viewports, distance fog, mouse and viewport picking, and automatic conversion between 2D and 3D space through worldToScreenPoint and screenToWorldPoint functions.

Collision detection is exposed through the API, giving access to bounding-box or polygon-level interaction between scene objects. The returned collision information object contains information about the collision normal (angle of face hit), position of object at point of collision, and a reference to the object hit. Collisions can be optimized through the use of 32-bit collision masks, giving a fine level of detail for collision filtering.

WTStudio provides your scenes with access to very flashy visual effects, such as skyboxes, mirrors, 3D text, particle systems, AVIs, dynamic shadows, specular highlights, environment mapping, particle systems, and procedural textures.

The performance of scenes created in WTStudio is optimized through binary space partitioning (BSP), improving efficiency of collision detection and visibility culling. Visibility can be further optimized through explicit use of visibility portals.

Smooth-skinned skeletal animation effects are achievable through the Actor object. Actor geometry and motions can be exported from 3D Studio Max and Maya, with other exporters on the way for other modeling packages. Access to the actor’s bone hierarchy is available in script for the purpose of attaching objects to actor bones.

WildTangent Multiplayer

Like the Web Driver, the multiplayer toolset is an abstraction layer that provides access to underlying services (in this case, multiplayer networking functionality). The multiplayer API gives access to multiplayer functionality, which is provided by a range of possible multiplayer modules. By supporting an extensible modular approach, the system can make use of a variety of network transports, communications systems, and lobby systems and implement additional multiplayer functionality in the future.

The API supports basic network messaging, lobby/matchmaking, and framework functionality. Basic network messaging functions can be accessed via a generic API (which has similarities to DirectPlay). This may be supplied by one of a number of plug-in communications modules. Lobby/matchmaking functionality brings together players without the need to explicitly enter user-unfriendly network addresses. The lobby functionality is also modular, enabling the use of a range of different lobby services.

The framework functionality allows other modules to be selected and plugged in to the architecture. In Multiplayer 2.0, a DirectPlay communications module provides access to DirectPlay functionality on machines with DirectX 5 and up. Lobby functionality is provided to connect games or other content via DirectPlay lobbying. This makes use of the large installed base of DirectPlay-capable machines. Later releases will include other modules to support additional communications and lobbying providers (including third-party systems) as appropriate. In this release, the API is available in Java within the MS IE browser. Future releases will expand this language support to include COM-enabled languages (such as C/C++, VB, and VBScript) as well as Javascript.

Licensing the Web Driver

  • Personal Use: Use of the Web Driver is always free and can start immediately upon downloading the SDK without any other contact with WildTangent. However, when posting or publishing the developed content, securing a technology license is required regardless of the intended use. If the ultimate plan is to post or publish your Web Driver-developed content on a personal (noncommercial) web site, the license will be free of charge.

  • Commercial Use: Use of the Web Driver is always free, however we require a technology license and adherence to the appropriate terms prior to posting or publishing. If the ultimate plan is to post or publish your Web Driver-developed content on a commercial web site, you must secure a commercial technology license.

  • Affiliate Program: If you’re interested in learning about participating in WildTangent’s Affiliate Program, eliminating tech licensing fees, and having WildTangent distribute your content through the Broadcast Games Network, please e-mail your name, your company’s name (if any), the URL where your Web Driver game is currently located, and a game design document to affiliate@wildtangent.com.

WildTangent’s technology is currently available to content and application developers for free. SDKs, white papers, forum access, FAQs, and documentation are all available at no cost. Developers may build content and applications without being subject to technology licensing fees. However, a developer that publishes its WildTangent-developed content will then be subject to the terms noted in the appropriate technology licenses as mentioned above. All licensing terms are subject to change, so contact WildTangent to lock in for the current version of the Web Driver.

LithTech Game Engine by Monolith (1998) (www.LithTech.com)

Click To expand

The LithTech engine supports environment mapping and detail texturing, skeletal animation, weight deformation, animation blending, specular maps, dynamic bump mapping, and programmable vertex and pixel shaders. Lip-synching is a feature of the usability of the engine and not the engine itself. The LithTech engine allows programmers using modeling and animation to access the models and modify the lighting properties, texture maps, and texture properties in real time (on the fly). Using the 3D Studio Max and Maya tools, the export features are expanding. Artists can control the LOD (level of detail) and the lighting effect on a model.

The current version of the engine is called the Jupiter system and is being used to power the sequel to No One Lives Forever. Being explored in future releases is FFD (free form deformation) and IK (inverse kinetics) for animation and parametric and subdivision surfaces for geometry. Also coming is hardware lighting, including the full Blinn lighting models. Also, new networking and server architecture, especially for gaming the high performance networking that is modular, is being added in future releases.

Games utilizing the LithTech Engine include Aliens vs. Predator 2, Blood 2: The Chosen, Kiss Psycho Circus: The Nightmare Child, Legends of Might & Magic, No One Lives Forever, Shogo: Mobile Armor Division, Atlantis, Die Hard: Nakatomi Plaza, and Global Operations. Future games to be released are TRON 2.0, No One Lives Forever 2: A Spy in H.A.R.M.’s Way, and the Matrix MMP.

Nocturne Engine by Terminal Reality (www.TerminalReality.com)

Click To expand

The Nocturne Engine includes bump mapping, dynamic LOD, reflections, and real-time shadow mapping. The seamless transitions from outdoor to indoor levels were considered early on in the engine’s design since the outside considerations were addressed first.

In project Blair Witch, vertex weighting, lip-synching, and facial expressions were used. Future releases will address the higher polygon counts and more detailed characters. An AI algorithm feature called “Cram Tex” optimizes the textures, making every pixel in the map used and visible on characters and objects.

Nocturne’s chief advantage is portability, since it has been used on the PC, the Mac, Dreamcast, PlayStation 2 and 3, the Xbox and Xbox 2, the Nintendo Cube, and Hypercube.

The Nocturne Engine supports 16-bit or 32-bit color rendering (supporting one billion visible colors), real-time lights and shadows, and great reflections including ones made as characters walk past a mirror. The Nocturne Cloth Engine makes long trench coats flow as the wearer walks confidently down the street and turns the corner swiftly—a strong wind can generate a realistic cloth response, taking into account the cloth’s material and weight. The Nocturne Sound Engine is state of the art with 3D positional audio attached to moving objects, full surround sound support, and legacy support for stereo.

Serious Engine by CroTeam (2000) (www.CroTeam.com)

Click To expand

The Serious Engine supports bump mapping, “true” reflection and environment mapping, detail texturing, and dynamic level of architectural detail to create a rich and eye-pleasing game. The engine supports large open-space terrain, and through a custom visibility algorithm combined with an extensive LOD for model and the world, enables games to have both indoor and outdoor aspects on the same level. A fast LOD algorithm, an advanced Serious Engine feature, allows for a high number of models to be visible on the screen at one time.

Level editors have tools that can create realistic open-space environments utilizing both directional and subtle ambient lighting with flexible and detailed backgrounds. To prevent texture repetition (or tiling), multilayered texturing is used.

The CroTeam has utilized their engine on Serious Sam: First Encounter and Serious Sam: Second Encounter.

The Serious Engine by CroTeam is a 3D game engine and has a graphics editor for creating models called Serious Editor, which includes full engine and tools source code, Serious Demo and Serious full-game source code, direct technical support via e-mail with the engine’s creators, and online manuals for the Serious Editor and Serious Modeler.

The Serious Engine includes intuitive tools, rendering and 6DOF (degrees of freedom) physics, and exceptional technical support from the CroTeam.

Unreal Engine by Epic Games (2002) (www.epicgames.com)

Click To expand

The Unreal Engine is a complete, evolving game framework that has powered such games as Epic’s Unreal Tournament, Ion Storm Austin’s Deus Ex, Electronic Arts’ Harry Potter, and the U.S. Army’s America’s Army game. It features a suite of authoring tools, physics, AI, collision detection, multiplayer networking, high-polygon object rendering, a surface shader system, skeletal animation, and terrain rendering. It interfaces to 3D Studio Max and Maya through provided data-export plug-ins.

The authoring tools include UnrealEd, a real-time level design tool based on constructive solid geometry that is optimized for building real-time 3D environments and fully integrates with the Unreal Engine, providing actual camera views, all lighting, placement of textures, and geometry operations that immediately work, giving the level designers extremely fast feedback.

The Unreal Engine is fully supported on Windows, Xbox, PlayStation 2, and GameCube, and ports are available for Macintosh and Linux.

Unreal’s AI has intelligent “bots” that know how to move using all player movement options, weapons and inventory, and switches and navigate on platforms and open doors.

The path AI navigation system has complex evaluation, alarm points, and static states algorithms.

The Unreal development system provides licensors with the complete source code, the editing tools including UnrealEd and the 3D Studio Max and Maya plug-ins, and access to the support web site and mailing lists. The complete source to Epic’s latest game, currently Unreal Tournament 2003, is included for reference. Updates with new features are provided every two to four months.

Click To expand


Luxury 3D Game Engines

Criterion Software’s
RenderWare
(www.renderware.com)

About RenderWare

Criterion has two RenderWare products, RenderWare Platform and RenderWare Studio.

RenderWare Platform is a suite of truly multiplatform game production technologies. Platform provides a tailored set of open and extensible tools, allowing developers to focus on content and gameplay rather than reinventing the wheel. The API offers an open framework that aligns all the essential components of game production (graphics, audio, physics, and AI) into one single, powerful toolkit.

RenderWare Studio is the only complete game production system. It streamlines the entire development process by integrating all the essential tools and technologies (graphics, physics, audio, asset management, exporters, viewers) into a single unified production environment. By parsing the source code and generating an intuitive UI that controls all game attributes immediately, the entire development team is provided with a real-time link to all target platforms, ensuring that a live build of the game is immediately available. Geographically dispersed teams are able to share assets and collaborate on gameplay, engineering, and production in real time.

RenderWare is used extensively by the majority of developers and publishers within the game development community, such as Activision, Acclaim, Capcom, Rockstar, EA, Empire Interactive, Infogrames, Interplay, Konami, Lucas Learning, Midway, Sierra-Online, Eidos, Namco, Sony Computer Entertainment America, Sony Online, THQ, Titus, and Ubisoft. RenderWare is used in more that 250 titles and over 400 SKUs (multiplatforms) with released titles having generated over $1 billion in revenue for the publisher community to date.

More About RenderWare Platform

RenderWare Platform provides developers with the following modules for PlayStation 2, Xbox, Nintendo GameCube, and PC and is behind chart toppers including Grand Theft Auto III, Tony Hawk’s Pro Skater 3, Burnout, Mortal Kombat 5: Deadly Alliance, and Pro Evolution Soccer.

RenderWare Graphics

RenderWare Graphics is the world’s leading high-performance, open and extensible, truly multiplatform 2D/3D graphics engine. RenderWare Graphics’ optional extras include RenderWare dynamic PVS (possible visible set) powered by Hybrid Graphics’ technology, plus the new FX Pack, which includes CrowdFX, TeamFX, and ToonFX.

Features of RenderWare Graphics 3.4 include multiplatform, portable API, powerful exporter framework, comprehensive art path tool chain, a comprehensive range of fast graphics capabilities, advanced multitexturing capability, optimized skinning, hardware-optimized point sprites, full scene anti-aliasing, configurable pixel format descriptor, new build manager, a component-based approach, and native geometry support.

RenderWare Graphics multiplatform, portable API allows high-level functionality to be the same for PlayStation 2, Xbox, GameCube, and PC, with platform-specific optimizations to get the best from the hardware pipelines using PowerPipe.

RenderWare Graphics 3.4 has the Exporter Framework that allows you to make a whole range of modifications, additions, and replacements to the full feature art asset export process from 3D Studio Max 4.x and Maya 4. Consisting of a series of modular libraries and custom code hooks, you can introduce new common classes to the modeler, changing behaviors or creating new object handlers under our plug-in architecture.

Comprehensive Art Path Tool Chain includes a powerful, enhanced asset Visualizer, high performance light mapper, and PVS sector-editing tool. New for 3.4 are a pre-instancer tool for optimizing art assets to all platforms, a generic animation toolkit for both hierarchical and nonhierarchical animations, and a skin splitter toolkit that allows increasing the maximum bone limit to 256.

The comprehensive range of fast graphics capabilities include improved tri-stripping and Bezier geometry, lightmaps, polygon rejection, and scene management on all platforms. There are also platform-specific features, such as VU (Virtual Universe) code, pixel and vertex shaders, and TEV for maximum performance.

RenderWare Graphics’ advanced multitexturing capability exploits indirection on GameCube and Xbox. An offline tool also provides the creation/editing of multitexture effects for the fully integrated, advanced pipelines, including skinning and morphing.

Optimized skinning consists of a hand-optimized platform assembler supporting four-weight (points of influence) skinning on appropriate models (triangle and patch primitive).

Hardware-optimized point sprites give high-performance rendering of particle systems for console and PC when supporting hardware is available.

Full scene anti-aliasing allows for the softening of the jagged edges of polygons on screen and is enabled via support for multisampling.

Configurable pixel format descriptor allows the user to define the type of rendering environment to meet the needs of each application (e.g., the resolution of the Z-buffer depth).

New GUI-driven build manager simplifies SDK and application building on all platforms.

RenderWare Graphics’ architecture uses a component-based approach based around a thin-layer, core library supplemented by a number of plug-ins and toolkits. Plug-ins are the key to RenderWare Graphics’ power; they can extend existing objects and add new objects of their own that can also be further extended.

Support for all the native geometry formats reduces upload time and the memory needed for rendering.

RenderWare Graphics features and benefits:

  • Rigid body dynamics provides dynamic interactions between in-game objects, realistically resolved with appropriate Karma behaviors. You can achieve all the accurate and spectacular physics events you need for your development.

  • Flexible primitive and terrain collisions allows robust interactions between smooth or rugged landscapes and irregular objects within the game world to attain the best physics accuracy and immersion levels.

  • Rag-doll provides amazingly realistic character physics and is available for reactionary in-game behaviors. Impressive human impact responses to being “hit” by projectiles, and uniquely complex events like falling down stairs are now available to developers of all genre of game.

  • Comprehensive Joint and Constraint Library provides for natural laws that can be applied to “limbed” entities for believable movement of human and exotic characters alike. Restriction for hard and soft joints can be set to dampen and cap movements across all degrees of freedom in the simulation of muscle-driven movement. The possibility of animation-driven physics is also opened up with customizable joint attributes, such as velocity and position being exposed.

  • Time-slicing provides complex physics calculations that are broken down across several frames of processing to ensure that they don’t hit the frame rate.

  • Flexible architecture allows RenderWare Physics to either be quickly integrated or comprehensively extended, depending on the developers needs, thanks to the flexibility of its architecture.

  • Multiplatform solvers provides fast and stable physics solvers that are optimized to each platform’s processing capabilities. The user is given the ability to find the balance accuracy and fidelity of the simulation. In addition, we offer a small memory footprint and non-spiking performance. Solvers can also be switched between each other on a frame-by-frame basis.

RenderWare Physics

RenderWare Physics is a portfolio of game/genre-specific physics effects built on a common underlying math library. It provides fast and stable physics modeling suitable for use in every genre of game and other interactive 3D applications. It provides the ability to add real-time dynamic behavior to your game objects. Now characters can roll down a set of stairs, vehicles smash into each other and into pieces, and structures collapse. RenderWare Physics adds realism to environments and introduces a new dimension of exciting gameplay opportunities. Everyday objects can move, fall, and even break in reaction to the player; furniture can be pushed over, and doors can be blown off their hinges!

RenderWare AI

RenderWare AI, powered by Kynogon, enables developers to have direct, customizable access to the most innovative AI tools to help them populate game worlds and deliver extremely high levels of life-like behavior and intelligent interaction between characters and game environments.

RenderWare AI uses a four-layered solution for the API, consisting of Architecture (the foundation layer), Services (the management layer), Agents (the actions layer), and the Brains (the thinking layer).

RenderWare AI features and benefits:

  • Powerful, multigenre core capabilities have several core service managers available within RenderWare AI: 3D Path-finding, Entities, Dynamic Avoidance, 3D Perception, Dynamic Objects, Racetrack, and Sound Sources.

  • Time-slicing is provided by the service managers that run optimally via clever use of time slicing in the AI core.

  • Core agents available in RenderWare AI are Go to, Follow, Flee, Hide (close and distant), Combat (close and distant), Speeder, Overtake, Fish-tailing, and Player cloning.

  • Custom agent and brain scripting allows developers to also script their own Agents and Brains to produce additional specialized behaviors.

  • Architecture configuration mechanism allows developers to configure the run-time parameters, such as memory allocation, average CPU consumption, NPC (non-player character) attributes, Agents, and Brains within an XML file.

  • Path and racetrack data calculation tools are provided in the service managers that rely on automatically precalculated path data and racetrack data, generated by two provided tools that model the static environments. These provide non-player characters and vehicles with the data they require to move intelligently, identify hiding points, and access paths after analyzing the topology of level environments and racetracks.

  • Player cloning tool allows a developer or a game designer to develop a behavioral agent without coding it. The developer or the game designer simulates the behavior that he wants, and the tool generates a clone reproducing his behavior.

RenderWare Audio

RenderWare Audio is an extensible, data-driven, multiplatform, interactive audio engine with a light external API used to control the data-driven architecture.

RenderWare Audio 2.0 has a completely new streaming system with greatly increased performance, such as (1) support for interleaved substreams to enable instant switching between streams, (2) regions allowing a single file to be segmented into many separate streams, (3) quick stream (stream caching) allowing instantaneous seeking and playback, and (4) command queuing allowing beat matched switching between streams or interactive music applications.

Enhanced Wave Dictionary Editor with extended compatibility, functionality, and increased performance includes (1) the ability to edit parameters (bit-rate, frequency, target format, etc.) for each wave, (2) reduced wave import time, saving file links to waves and only building the wave dictionary on export, (3) wave data conversions to optimize audio data for your target platform, (4) wave conversions that can be implemented within the run-time RenderWare Audio API, (5) wave conversion that supports PCM and VAG (Sony ADPCM) for PlayStation 2, and (6) data contained within wave dictionaries that can now be converted to any supported format when a wave dictionary is either loaded or saved.

RenderWare Audio 2.0 also has analog and digital Dolby Surround Sound support dependent on the hardware, memory management extended enabling multiple management strategies, significantly reduced memory requirements, and platform-specific enhancements. RenderWare Audio for PlayStation 2’s new streaming system makes better use of the IOP processor, avoiding SIF DMA transfers between EE and IOP; the new DMA manager greatly increases the IOP <-> SPU2 transfer throughput, support for Dolby Pro Logic II and Dolby Digital 5.1 Playback, and Analogues and digital output (for Dolby and Stereo).

More About RenderWare Studio

RenderWare Studio enables the faster development of new concepts and full working levels, validating game designs at a much earlier stage in the game’s life cycle. There is no need to invest man-years developing tailored tools and technology for each game or platform, as RenderWare Studio provides the full data-driven framework, so developers can hit the ground running and get straight on to developing critical gameplay and features from the outset.

RenderWare Studio is a major risk reducer for a number of reasons. Not only is it a proven, integrated AAA game delivery system, but the greater visibility that the team has across the entire game’s production cycle means that should new team members be added or replaced, it can be done so without causing disruption to the workflow. More importantly, this visibility enables both developer and publisher to manage the games’ production at a more commercial level, being able to share and forecast progress and creative direction earlier in the cycle.

Unlike conventional games development methods, RenderWare Studio empowers all team members to import and modify their own work independently, without relying on the activity and progress of the other elements of game production, resulting in faster progress and ensuring heightened development efficiency. The final phase of the development life cycle is also less problematic, with tuning and testing being dispersed throughout the entire development cycle. Bandwidth and productivity therefore become easier to control, resulting in more efficient resource management across the entire studio.

As a result of the faster development capabilities of RenderWare Studio, developers can improve the quality and reduce the cost of their playable game concept. With a game demonstrator immediately available on all game platforms, developers are able to maximize the product pitching, reviewing, and focus testing processes.

By improving the overall efficiency of the team and catalyzing significantly reduced development times, RenderWare Studio gives the team greater confidence and more valuable time to focus on delivering truly innovative and unique gameplay ideas to make the game stand out from the crowd.

RenderWare Studio has a real-time communications link to PlayStation 2, Xbox, GameCube, and PC, with regular updates for immediate, continuous play testing.

Developers can look forward to fast, easy integration of RenderWare Studio into their current working environment, and the high scalability of the RenderWare architecture means that developers can effect a seamless integration of their existing tool chains and assets. Asset importer plug-ins link RenderWare Studio with your preferred art package, and developers can extend the coverage of any import path, as all are open and well documented.

With the latest build of the game available to both developer and publisher, concepts and ideas can be easily shared throughout the duration of the project. Progress updates can be facilitated quickly and easily, and mutually agreeable and realistic milestones can be set.

RenderWare Support

RenderWare’s mission is to help developers and their teams deliver your game project to market on schedule by minimizing the technical challenges that can accompany the development of games. By licensing RenderWare, customers not only buy the best tools and technologies, but they unlock the door to a developer relations operation that puts you on a traffic-free route to a finished game, giving peace of mind throughout the game production cycle and guaranteeing the timely delivery of the game.

RenderWare Developer Relations is comprised of three disciplines: support, consulting, and training. It is purely focused on meeting the needs of the developer community and helping tackle the challenges developers face on a day-to-day basis.

Licensing and Costs

RenderWare’s APIs can be purchased separately or as a group (“platform”). The APIs are royalty-free, distributable to the entire team (TCP/IP designed), and licensed per title having multiple platforms (RenderWare Graphics must be purchased for each platform being developed on). There are free educational licenses and preproduction licenses and various methods of breaking up the purchasing fees.

RenderWare has several methods of support, including fully web-managed support where developers report their needs and are given a ticket for the response. RenderWare guarantees an answer within 24 hours (their technical support is 24 hours, seven days a week) but often responds within an hour. Second is their phone support, and they frequently visit developers on site and give on-site training and tutorials. RenderWare has extensive documentation and free weekly builds (updates). Most developers will be up to speed within a week (the learning curve).

NetImmerse 3D Game Engine by Numeric Design Ltd. (www.NDL.com)

NetImmerse is an object-oriented C++ software toolkit, a comprehensive set of tools, plug-ins, and run-time libraries that saves 3D game and application developers time and money, while delivering the features and effects that 3D game developers require. The generality of NetImmerse’s 3D game development solutions has led to the development of successful games in a wide range of genres.

NetImmerse provides end-to-end support for Windows (98/Me/NT/2000/XP), Xbox, PlayStation 2, and GameCube platforms, and it enables developers to start, from day one, to develop real-time games and other interactive 3D content specifically optimized for each platform’s power and unique capabilities.

NetImmerse consists of three main components that are typically used in sequence: a set of plug-ins that easily move content from a modeling package into the engine, a set of tools that make it easy to optimize and use that content, and the C++ run-time API that constitutes the core real-time graphics engine. NetImmerse also includes readable source code for the engine and tools, sample code, and complete documentation for the engine, tools, and samples. Finally, NDL offers full support for the engine via e-mail, telephone, and its developers’ web site.

The NetImmerse toolkit includes plug-ins for all of the popular content creation packages. These plug-ins allow the user to easily view content in real-time and export content to the NetImmerse Engine. Plug-ins are available for Discreet 3D Studio Max and Alias-Wavefront Maya. Licensees receive full source code for all plugins as well.

NetImmerse is a cross-platform 3D game engine for the PC, PlayStation 2, Xbox, and GameCube that allows developers to begin creating content immediately, saving more than six months of development time and years of engineering costs. NetImmerse provides plug-ins that integrate seamlessly with Discreet 3D Studio Max and Alias-Wavefront Maya, the most popular modeling packages for game developers. The plug-ins directly export whatever geometry, textures, texture effects, animations, particles, and skin/bones information that the specific modeling package can create to the NetImmerse native file format (known as NIF files).

NetImmerse Core Technologies includes components such as scene graph, culling and sorting, portals, rendering, lighting, textures and transparency, level of detail, animation, particle systems, skinned character, dynamic collision detection, 3D sound, physics using the Havok physics engine and special effects like fog (modes include range-based, Z-based, and texture-based volumetric), lens flare, and dynamic shadows.

The NetImmerse hierarchical scene graph is optimized for high performance real-time applications, particularly 3D games. Multiple types of geometric primitives are supported, including lines, particles, indexed triangle sets, and indexed triangle strips.

NetImmerse automatically culls any geometry that will not appear on the screen using standard view frustum culling, leaving more CPU cycles for drawing visible objects.

The NetImmerse Portals module or “room-to-room visibility system” is designed to enable applications to render and manage large interior datasets.

A fully general camera model is supported so that the view frustum need not be symmetric (this is useful for oblique cameras, mirrors, and other effects). Multiple, simultaneous, independent cameras are supported, which may be used for split-screen rendering, inset windows, or offscreen texture rendering.

NetImmerse supports dynamic RGB lighting. These dynamic lights can be any color and may be point, infinite, or spotlights. Specular highlights and prelit vertices are also supported.

NetImmerse supports a wide range of texture effects, including (1) multitextures, such as light maps, dark maps, gloss maps, decals; (2) projected textures, including projected lights and shadows (for interesting lighting effects); (3) animated textures, for effects such as fog, fire, smoke, and explosions; (4) environment maps (spherical environment maps are supported on all platforms, with cubic environment maps supported on DX8 and Xbox); (5) rendered textures, which may be used for television screens in the scene, dynamic shadows, mirrors, and other advanced effects.

NetImmerse supports multiple levels of detail for any object in a scene, including direct import of 3D Studio Max and Maya levels of detail. NetImmerse incorporates full support for almost all animation methods that are produced from 3D Studio Max and Maya.

NetImmerse supports an efficient system for implementation of particle systems.

Skinning, a deformable mesh of “skin” and “bones,” enables moving characters to have superior visual quality at reduced computational cost.

NetImmerse provides a powerful collision-detection system.

Documentation and Support

NetImmerse eliminates the need for both building and maintaining a 3D game engine. It’s like having an in-house development team that stays up-to-date on all the latest graphics algorithms, techniques, and hardware. The NetImmerse team is committed to applying the latest leading-edge technologies to help developers create high performance, visually compelling AAA games.

NDL offers e-mail/phone support as well as regular software updates. The NetImmerse team also maintains a public online forum for the NetImmerse customer community, which focuses on developer issues and news on a platform-specific basis. In addition, the NetImmerse toolkit ships with over 500 pages of comprehensive manuals on programming and content creation to help developers and artists ramp up quickly on the product. Customized training is also available, although most NetImmerse customers discover that, with the quality of the NetImmerse source code and documentation, they don’t need it. NetImmerse has over 40 up-to-date source code tutorials, and samples are included for each of the significant NetImmerse features and programming concepts.

All licenses include full source code and are royalty free.

Here are the license fees as of January 2003:

NetImmerse SDK
Description | Single Use | Unlimited Use
NetImmerse for one platform | $50,000 | $150,000
NetImmerse for two platforms | $75,000 | $200,000
NetImmerse for three platforms | $100,000 | $250,000
NetImmerse for four platforms | $125,000 | $300,000
All licenses include complete source code to all NetImmerse libraries, modules, and plug-ins for the platform licensed.
Annual Support
Description | Single Use | Unlimited Use
One platform | $25,000 | $40,000
Two platforms | $30,000 | $50,000
Three platforms | $40,000 | $60,000
Four platforms | $50,000 | $70,000
Support includes e-mail access to NDL technical staff and two enhancements/updates per year. Unlimited use support fees assume support for no more than three simultaneous projects per year; support for additional projects in the same year incur an additional support fee.

More than 30 titles have shipped using the NetImmerse 3D Game Engine, such as MMRPG Dark Age of Camelot, Freedom Force, The Elder Scrolls III: Morrowind, Project Entropia, and Star Trek: Bridge Commander.

Quake 3 Arena Engine by id Software (1999) (www.idSoftware.com/
Business/Home/Technology/)

The Quake 3 Arena Engine is the current top engine from id Software available for the PC (Windows), the Macintosh, and Linux operating systems. The Dreamcast port of Quake 3 Arena is also available.

The Quake 3 Arena license includes a one-time, full-day question and answer session with John Carmack on the engine and level design and shader construction issues with id’s artists and level designers. Additional time can be arranged with id’s expert programming staff to address particular needs.

The world editor, Q3Radiant, and shader guide are also included with the Quake 3 Arena license. Current best-selling games using the Quake 3 Arena Engine are Star Trek: Elite Force, Return to Castle Wolfenstein, and Quake 3 Arena.

For a single title license, id Software charges a $250,000 guarantee against a 5 percent royalty of the wholesale price.


Chapter 13: Artificial Intelligence (AI)

Overview

Artificial intelligence is a scientific term that gives nonhuman entities algorithmic and mathematical solutions for problem solving and simulating human thought and decision making. In films, this is often depicted as a mechanical robot trying to act human. In computer or videogames, it is the heart and soul of the nonplayer characters (NPCs) controlling our enemies and allies.

Typically, we think of games such as chess, checkers, and backgammon as intellectual and sophisticated games, therefore a machine that can simulate being an adversary (especially a masterful one) has been a way for researchers to validate their AI techniques. Since computers can process mathematical instructions and perform iterations (repetitive processes) very fast, researchers in AI use these skills to simulate human thought.

As game designers, we must not only plan our vision but try to conceptualize each idea and how it can be expressed through a mathematical expression or logically arrived at through a database search or script. You will discover that simple, everyday activities are in fact very complicated and complex concepts.

In a baseball game, the pitcher throws the ball at the catcher as the batter from the opposing team tries to hit the ball and safely get to a base. Most of us have seen this scenario many times on television or at the ballpark. There are many complex issues being processed in this simple example of a sports game. The batter’s box is empty so the team at bat sends out their next batter (based on the roster and batting order) to the plate. The pitcher holding the ball may first check the runner on first base based on the following conditions: (1) There is a runner at first base, and (2) the first base runner is leading or positioned off the base by a few feet or more. The pitcher, who still has the ball even after the ball has been thrown to the first baseman, knows that a batter is “in” the batter’s box ready to receive a pitch. The ball is thrown based on a preset speed, type of pitch (curve ball, fast ball, slider, and so on), target position “in the strike zone,” and factors based on real-world factors like typical pitches and number of strikes, balls, and wild pitches this pitcher throws. The batter responds by swinging at the ball or not.

A pitch will be judged as a strike or a ball (if the batter doesn’t swing) based on the pitcher’s real-world factors previously mentioned. A swung-at pitch will use the batter’s real-world factors like number of strikeouts, singles, doubles, triples, home runs, type of preset hit (bunt, grounder, short hit in the air in the outfield just outside the infield), power hit (deep outfield or a possible “over the wall” home run), and point of contact with the ball (late swing, early swing, or perfectly timed swing).

The batter’s real-world factors and player factors, such as options selected and timing triggers, are combined, and a logical result should be determined. For example, a selected option to bunt would not result in an “over the wall” home run nor would a batting pitcher typically hit a home run or even a triple. The algorithm should include for a batting pitcher an extremely small (one in 10,000) chance of hitting a home run, a little better chance (one in 5,000) of hitting a triple even if the real-world factors indicate this is unlikely to occur. As the batter hits the ball into “fair” territory, the players in the field must follow the hit ball and respond if they are currently the closest field player to the ball. A ball hit to left field may have the shortstop initially moving, but as it passes by or over his head, he stops moving and the already moving left fielder continues moving until he acquires the ball. There are certain logical (predetermined) movements, such as the pitcher backing up the catcher on certain plays or the shortstop backing up the third baseman or second baseman, especially if they are the players moving after the ball.

Let’s look at a situation where the center fielder has just acquired the ball after it has hit the ground (so a caught fly out is not possible). There are runners at second base and first base, and the batter who just hit the ball is advancing to first base. The center fielder can throw the ball to the third baseman—outing the runner from second base, throw the ball to the second baseman—outing the runner from first base, or throw the ball to the first baseman—outing the batter advancing to first base.

What decisions does the experienced center fielder make in the real world? If the situation occurred when the team at bat had two outs, it would be vastly different than if the team at bat had no outs. (Remember, three outs retires the side, and the inning is over.)

I handled this situation in my baseball endeavor by remembering that each base is 90 feet from the other. The database had a factor for each player’s 100-yard dash speed (300 feet) and a factor for each player’s throwing speed and accuracy. Before acquiring the ball, the computer calculated the distance from the point of acquisition of the ball to each base (first base, second base, and third base) and factored in the center fielder’s throwing speed and accuracy to each of these bases against the runner’s speed and his distance to the next base or his current position (remember the runner could be leading off the base when the ball was hit) to the next base. The action that would result in a guaranteed out would be selected first. If no out situation was possible, then throwing the ball to the most advanced base or third base to stop further advancement would be the default selected.

Let’s assume that this scenario would have the center fielder throwing the ball to the second baseman. The second baseman would out the runner from first base. If this would be the third out, the action would terminate and the at-bat team would be finished; possibly the sides would exchange places (batting side taking the field and vice versa). If the outing at second base was not the third out, the second baseman would have to evaluate the current situation, just like the center fielder had done (second base runner is running to third base, is on third base, or is running home; batter is running to first base, is on first base, or is running to second base). These factors would result in another throw by the second baseman to the first baseman, to the third baseman, to the catcher, or possibly held until all action is halted and the runners are safe (stationary, not advancing) on first and third base. Then the second baseman would throw the ball to the pitcher. The batter’s box would again be empty and the cycle continues.

This seems like a lot of calculating and planning, but as designers, we must express our vision to the other team members, like the programmers who must translate our vision into concrete instructions, the artists who must provide models and artwork needed for each of these scenarios and actions, and the sound engineers who provide realistic sound effects to add life into this realistic and intelligent creation.

In our design, we must be consistent and fair. If a pitcher has no batting statistics (this is possible nowadays), then have some planned criteria such as minor league or college statistics followed by an average division, league, or professional statistics for pitchers.

When designing a game like chess or poker, design the best or championship skill level first and then lessen its strength. Lower strength levels can have threshold criteria placed on the player, shorter search path depths, or time limits to determine the best move found. In chess, you may exhaust all paths of analysis for the expert, set a limit to the depth of each path or a threshold value (such as “situation is valued at half a pawn or better” end analysis) for a club player, and select one of several random “non-losing” moves for a novice player.


Pathfinding

Pathfinding is probably the single most popular and frustrating game AI problem in the industry. Games like role-playing games (RPGs) and real-time strategy games (RTS) often have characters sent on missions from their current location to a predetermined, player determined, or menu-selected waypoint (destination). The perfect situation of a movement would be a no-collision or obstacle path.

Click To expand

The typical path from a character’s current position to the destination (waypoint) usually passes directly through one or more obstacles.

Click To expand

The first solution in avoiding these obstacles is to “ride the rail” or walk around the object’s surface until you’re free to continue toward the destination.

Click To expand

Although the “riding the rail” algorithm solves the problem of avoiding obstacles, it looks silly and unrealistic, sort of a blind person’s path solution.

Click To expand

The next solution is to make the path less blocky by connecting points of the hypotenuse of the triangles.

The last issue to make the path to our waypoint truly realistic is to curve the path.

Click To expand

The way to simulate a realistic character movement in 3D is to plot a straightforward path from the character’s current position to its destination and record all of the obstacles from a world table that lie on this straight line. For each obstacle, calculate the original collision point and the two tangent points on either side of the obstacle. The point closest in distance is the one selected to be connected as the hypotenuse of the triangle.

There are several techniques to achieve this pathfinding problem, such as algorithmic (equations) or methods such as “flood fill” and “A*” (pronounced “A star”) solutions. A flood fill is similar to a graphics application’s “paint” tool, which will completely color a given area.

Click To expand

If we were to flood fill the white area with black, it would continue filling until it hit a non-white spot.

Click To expand

If we were to start on location “A,” the fill would traverse in all directions until the new space was non-white.

Click To expand

Each space or “node” would check its neighbors in the four directions, and if the neighbor is white, it would be changed to black. This recursive (repeating) process would repeat until all four directions starting with node “A” return a “false” or no non-white connecting nodes are left.

The A* algorithm is similar. A node is placed on an “open” list, and if a shorter node path is found, the new path replaces the current path (which gets placed on a “closed” list). The shortest path from a start node to a destination node is the final path left when all paths have been searched.

The objects that are on the map as collision areas should include the static objects like buildings, water, fences, and so on, as well as dynamic, moveable objects like vehicles, people, and floating bridges. The game design may include the ability to destroy objects like buildings and bridges, thereby modifying the original list of static objects. Another game design might require that characters avoid areas due to hazardous conditions that may be in effect under certain conditions or for a certain time period or avoid specific tribes and clans. These avoidance issues greatly change the terrain path created. One solution would be to dynamically (on the fly) set these areas when needed as an obstacle block or zone and let the path-finding function handle this as though it were a large building to walk around.

The solutions discussed thus far don’t take into account various terrain elevations. Nature has rivers running downhill, and our characters would probably prefer a downhill path to town rather than a Mount Everest climbing shortcut. The distance over Everest may be the shortest, but its elevation and treachery makes it less desirable. If each node had an elevation factor, the path created would be the shortest path within reason. Otherwise, the character’s morale and fatigue factors would be greatly increased, causing negative results later. The elevation factor could also be used in the character’s “line of sight” functionality. If a character were standing in a ditch, that character probably wouldn’t see the massive horde of enemy troops heading toward him in the distance. On the other hand, a fort on top of a mountain would have its residents’ “line of sight” able to see quite a distance and its cannons able to fire a long distance. If a character is standing on one side of a building, the enemy approaching from the other side would be unnoticed since the character’s “line of sight” would be blocked by the building. These factors add to the realism of the game, and that’s what players demand. That’s what your game design should include.

Other pathfinding issues would include formations (groups of moving objects) and the turn radius and ramping up or down speed to initialize a movement and terminate a movement. A formation is a group of characters all moving independently but as a group. Soldiers in two columns march behind their leader. As the leader turns, so does the entire troop. They all must maintain their relative distance from the row in front of them, march at the same speed (pace), and turn their bodies relative to their path line. The leader may be marching north as the last soldier in the line is still marching east 50 feet behind the leader. Formations also must not collide and bounce off each other like billiard balls. These are complex structures that must be in your game design and algorithmically understood by the team developing your vision.

Humans are bipeds and, if they are moving the wrong direction, can turn on a dime and reverse their movement toward the goal. Vehicles and horses need more space to create a turn radius. Your car needs to circle or turn around when reversing from the road south to the road north. We have fancy terms like the “U-turn” and the “K-turn” when a car is reversing its direction. People can perform this maneuver with an “about face” motion. These factors must be incorporated into the game design for a realistic look and feel in your game. People, horses, and vehicles don’t jump into a quick speed and just stop on a dime at will. Moving objects need to increase their speed (velocity) and decrease it before coming to a complete stop. These factors are not easy to implement but should be addressed in the design document and discussed as the game is being developed. Often, ideas, concepts, and features that are in the design document hit the cutting room floor (do not make it to the final product). These design document items should be frequently discussed and addressed to determine their status as to whether they are “in,” “out,” or “on hold” for the final product. Most items, given enough development time and money, can be implemented. In reality, developers don’t have this luxury of unlimited time and available finances.

AI is an important consideration in the success of your game. Often, I read on Internet gaming sites that the development team planned to do AI last and within a week or two. This inexperienced and ignorant decision severely delayed the project, and the AI was quickly finished without a real solid solution. The teams have often said in the aftermath of a major project that they wished they had started the AI earlier and had longer to work on the best AI possible (not the best AI as soon as possible).


Chapter 14: The Basics of Scriptwriting

Overview

In 1995 I decided to learn all about the movie-making business. The film industry is a well-established medium similar to game design and production with its own rules and theories. I have said for some time that if a movie were made like a video game, the audience would walk out after five minutes.

In game design and implementation, we often lack solid and interesting storylines. (That’s why I recommend “borrowing” masterpieces from other disciplines like classic stories, movies, and history in Chapter 6 and on the companion CD.)

The gaming business blames technology for our shortcomings like “slow computer speed,” “not enough memory or RAM,” “terrible storage space available on CD or DVD,” and “lag time or slow Internet transmission rates.” We pay little attention to important visual issues like lighting, camera POVs, actor position and the verbal impact on their delivery, and sound effects. I’ve heard this said and agree that technology is a tool and not the basis for designing a great game. Stories, character development, interesting puzzles, and interaction make great games.

The film business is just that—a business—and many game publishers and developers fail to understand and operate like a profitable business. I have seen and been paid by companies that ran their business haphazardly and without plans, documentation, or any goals except to finish the current game at some point.

The film business has several phases like preproduction, where the script is written, the shooting schedule is prepared and documented, the entire film’s budget is documented, the in-front and behind the camera crews are hired, and the filming locations are scouted out and selected. After six to eighteen months of extensive planning that has been researched, documented, and communicated to all personnel involved, two to eight weeks of expensive filming begins. Then postproduction begins with first dailies (each day’s or previous day’s shooting reviewed) to ensure that the filming is useable. If we’re satisfied with the currently shot footage, we are ready to continue. Otherwise, we must reshoot scenes or make cutting room floor decisions. Postproduction also includes editing (which takes to use, which POV or shooting angle looks best) and voice audio (the shooting dialogue is only a place holder as actors and actresses rerecord all of their lines in a soundproof room for the final merging with the film).

When the film is shot, the film itself contains no audio, which is recorded on another medium like audio or digital tape and later merged together with the film in the editing room. Obviously, video contains both audio and video, but almost always the audio is redone in postproduction. Also in the postproduction phase is ADR (Automated Dialogue Replacement, also known as “looping”) and Foley, which is where sound effects and clean, audio dialogue are added to the film.

It is in post that a film may go through several staff and audience viewing tests to see how people react to various versions of the film.

As a film producer, you would be expected to understand the filming process like lights, camera angles, and filming techniques as well as dealing with your crew, actors, writers, and studios. Similarly, as a game producer you should be equally skilled.

This book is about game design and not filmmaking. These skills, although they may be interesting to learn, fall more into the realm of the game producer. The skills that the designer needs to understand are the preproduction skills mentioned earlier, which include script writing, scheduling, budgeting, characters needed, and stage direction (how you envision the screen to depict a scene like “CLOSE-UP on George as he enters the room seeing his wife dead for the first time”).

A brief introduction to these skills is discussed in this chapter, and through your research in the library or a favorite bookstore you can learn additional insights about the film business, preproduction, and postproduction.

Film is a linear (one beginning, one middle, and one ending) type of medium where the audience is passive (only watches the presentation). Later, we look at a suggested nonlinear, game-oriented standard that has worked in my endeavors.

In writing a script for actors to follow, there are certain standards in formatting your masterpiece. Standard items in your script would be a slag line or scene identification, the action in this scene (a description of any action), the character who is speaking, the dialogue or line spoken by this character, any action being performed as the character is speaking (he lights a candle as he walks toward the hallway), the camera and stage directions (information to the cameraperson like CLOSE-UP, CUT TO, FADE-IN), and scene notes that the writer wants to briefly convey. Typical information in a slag line are location (the courthouse steps, in the evil doctor’s laboratory, outside in front of John’s house), the time of day and weather conditions (nighttime, around 10 P.M. as the rain is pouring down), stage instructions (dark room lit by a flickering candle, blindingly shiny room with an open window), cues and special effects (lightning, explosions, ringing telephone), and background music.

Slag lines include “INT.” for interior shot and “EXT.” for exterior shot, along with the time of day.

EXT. PEDERSEN HOUSE - NIGHT

INT. BEDROOM - MOMENTS LATER

EXT. THE PARKING LOT - DAY

Camera POV information may include (CU) or CLOSE-UP, PULL BACK, TIGHTEN - ADAM AND EVE, ANGLE - ON THE BOOK, (MS) or MEDIUM SHOT - MICHELE AND BROOKE, and CAMERA PANS RIGHT.

Column 60 (or pica) is where you put the camera start of scene or end of scene instructions like CUT TO:, DISSOLVE TO:, and FADE IN/ OUT:. When a character is speaking but not shown on the screen, we call this a “voice-over” or (VO). After the character’s name, we place the (VO) indicator as in ROGER (VO), meaning that Roger is speaking off-camera. Stage directions are always in parentheses, like “(crying),” “(laughing),” and “(looking at the book).”

The cover page should begin with the script’s name one-third to halfway down the page and centered followed by (on the next line) the word “by” or “written by” (again centered) and then the author’s name centered. Then, on the bottom right side of the cover page should be the author’s or his representative’s name (on the first line) and address (on the second line), their city, state, and zip code (next line), followed by a line with their phone number and another line with their fax number. On the left side of the cover page at the bottom should be the copyright notice (example “Copyright 2002 Roger E. Pedersen”).

The entire script should be typed on white paper that is 8.5 inches by 11 inches (20 pound weight) with 1-inch margins all around. You begin the first page of your script (using Courier 12 type) with the film’s (or game’s) title placed seven lines down from the top of the page and typed in all capitals, underlined, and centered on the line. Then five lines below the title (on line 12 from the top of the page) type “FADE IN:.” Then two lines down from that (on line 14) write your first scene.

Remember to always check your spelling and punctuation (especially since today’s word processors have spell-checking features). A script should be bound in a plain card stock cover secured by two or three brass brads.

0000000001111111111222222222233333333334444444444555555555566666666667
1234567890123456789012345678901234567890123456789012345678901234567890
--------------------------------TOP OF PAGE----------------------
1
2
3
4
5
6
7                     GAME DESIGN FOUNDATIONS
8
9
10
11
12                                                    FADE IN:
13
14                            SCENE 1:

The script has several important items that are used, such as the name of the character, the character’s dialogue, the dialogue directions, and the page number.

The CHARACTER NAME is always in all capitals and starts on the 40th space or pica. The dialogue starts on the 30th space or pica and ends on the 60th space or pica. The dialogue directions begin on the 35th space or pica. The page number begins on the 75th space or pica and is two lines from the top. All SOUND EFFECTS are in all capitals.

000000000111111111122222222223333333333444444444455555555556
123456789012345678901234567890123456789012345678901234567890

                                 (Roger walks in the room tired.)

                                       ROGER
                             What a busy and tiring day!
                             Let's see what I received in
                             the mail today.


Linear vs. Nonlinear or Games vs. Films and Books

In a linear format like a book or a film, the author (or scriptwriter) is in control, leading the reader or viewer on a journey from the beginning to a single conclusion.

In a nonlinear format like gaming, the player decides on the journey from the author’s presented beginning or how the player has arrived at his current situation. The multiple paths from this starting point vary depending on the player’s decisions, and the ending will depend on how the player satisfies the author’s view of success or failure. The author can use NPC (nonplayer characters) to influence the player, assist the player, or compete against the player.

Linear format mediums control the entire world and can be represented as an event or chapter leading into another event or chapter where the order and connection is extremely important. All events and characters in chapter four must happen and be known before chapter five occurs.

Nonlinear format mediums are represented by numerous covered boxes where the player can open up any one of the boxes and discover the events and characters independent from previous information that he has acquired. The order in which the player opens the box is part of the game; perhaps in one game the order is not important, and in another game the order that a box is opened greatly changes the entire story being revealed.

Unlike linear formats, the boxes can be opened more than once, and each time the events and characters can remain constant or change entirely. The first time you open the box, you might be greeted by a simple “Hello,” whereas the second time you open the box you may be greeted by “I’m glad to see you again.”


Alice in Wonderland

Click To expand
Alice in Wonderland statue in Central Park, NY. Pictured are Alice, the Mad Hatter, the March Hare, the Dormouse, and the Cheshire Cat

Let’s look at one of my favorite stories by Lewis Carroll, Alice in Wonderland. For those who have not read or seen on film this exciting adventure story, I’ll briefly explain it in linear mode (there are many Internet sites where you can download the entire book, including the original drawings).

A worthy game about Alice in Wonderland is Electronic Arts’ American McGee’s Alice where upon Alice’s return to Wonderland she learns of its chaotic and demented state and must return the world to its proper happy state. This theme is similar to the film Journey Back to Oz, which was based on Baum’s Ozma of Oz and a few characters and situations from The Marvelous Land of Oz.

An Overview of Lewis Carroll’s Alice in Wonderland

Chapter 1, | A: Alice, a young girl who owns a cat, Dinah, sees a White Rabbit with a waistcoat and a pocket watch run across her lawn exclaiming “Oh, dear! Oh, dear! I shall be late!”
Chapter 1, | B: Alice follows the rabbit down the large rabbit hole under the hedge.
Click To expand
Alice and the Cheshire Cat
Chapter 1, | C: Alice falls down the hole slowly. She sees cupboards, bookshelves, maps, and pictures upon pegs as she falls.
Chapter 1, | D: Alice touches down and follows the White Rabbit down a long corridor lit by a row of hanging lamps.
Chapter 1, | E: Alice ends up alone in a hall filled with locked doors. A three-legged glass table appears with a tiny golden key on top of the table. Alice finds a small 15-inch door behind a curtain that the little golden key fits. A liquid in a “Drink Me” bottle is swallowed by Alice who begins to shrink to ten inches. Alice leaves the golden key on top of the glass table. An “Eat Me” cake is eaten and Alice grows nine feet high.
Chapter 2: | White Rabbit appears, dropping his white kid gloves and a large fan after seeing large, giant Alice. Giant Alice cries, creating a pool of tears. Using the White Rabbit’s fan, Alice begins to shrink.
Chapter 3: | Alice is swimming with several animals and birds that assemble on a bank. To dry off, the group, consisting of Alice, a lory, a dodo, an eaglet, a duck, a magpie, a canary, and two crabs (a mother and her daughter), run in a circle or “caucus-race.” Alice gives everyone candy and presents herself with a thimble.
Chapter 4, | A: The White Rabbit commands Alice to go to his house and return with a pair of gloves and a fan. Alice travels to the White Rabbit’s house and collects a pair of gloves and a fan. Alice finds and drinks from an unlabeled bottle and begins to grow, filling up the entire house. The White Rabbit, a lizard named Bill, and two guinea pigs begin to throw pebbles that turn into little cakes when they hit the floor near Alice. Alice eats one of the cakes and begins to shrink.
Chapter 4, | B: Alice runs into the woods. She sees an enormous puppy who playfully wants to fetch after a stick. Alice escapes into a flowered, grassy area where on top of a large, growing mushroom sits a hookah-smoking large caterpillar.
Chapter 5: | The Caterpillar tells Alice that eating one side of the mushroom will make her grow and the other side will make her shrink. Alice eats the right side and begins to shrink. Alice manages to eat the left side and grows enormously. A pigeon flying overhead sees Alice’s head and long neck and assumes that Alice is a serpent. Alice tries pieces of the mushroom: left-hand pieces to grow, right-hand pieces to shrink, until she is back to a normal size.
Chapter 6: | A Fish Footman and a Frog Footman are chatting as the door shuts. The door opens and Alice enters a large kitchen filled with smoke where a Duchess sits nursing her baby on a three legged-stool with her cook stirring a cauldron of peppered soup. Sitting on the hearth is a wide grinning Cheshire Cat. The cook begins to throw pans, plates, and dishes at the sneezing Duchess and her baby whom she is violently tossing in the air. Alice steals the baby, who turns into a pig, and she lets it go trotting away. Alice chats with the Cheshire Cat who tells her that traveling to the right leads to the Mad Hatter’s and traveling to the left goes to the March Hare’s.

The Mad Hatter
Chapter 7: | At a large table under a tree, the March Hare and the Mad Hatter are drinking tea with a half-sleeping and half-awake Dormouse between them.
Chapter 8: | A large rose garden of white roses is being painted red by three playing cards. Ten diamond suit card soldiers, ten heart suit card royal children, the Knave of Hearts, the Kings and Queens, the White Rabbit, and the King and Queen of Hearts attend the Royal Croquet game where hedgehogs are croquet balls, flamingos are the mallets, and the playing cards are the arches. During croquet, Alice chats with the Cheshire Cat.
Chapter 9: | The Duchess is freed and walks with Alice until the Queen of Hearts appears and the Duchess flees. Alice meets the Gryphon and they visit the Mock Turtle.
Chapter 10: | The Lobster Quadrille (a Sea Dance with Lobsters) happens.
Chapter 11: | The Knave of Hearts is accused of stealing the Queen’s tarts. In the court are the King and Queen of Hearts, a pack of cards, the Knave of Hearts in chains, the White Rabbit, the Gryphon, the guinea pigs, and Lizard Bill. The first witnesses are the Mad Hatter, the March Hare, and the Dormouse. The next witnesses are the Duchess’ cook and Alice.
Chapter 12: | In court, Alice grows large. Finally, giant Alice realizes that everything in court is nothing but a pack of cards. Alice’s sister awakens her as Wonderland disappears.
Click To expand
Get involved with your vision as the author joins Alice in Wonderland


Nonlinear, Game Interactive Format

In a “nonlinear, game interactive format,” the chapters of the linear format become self-contained boxes, allowing the player to select from the available boxes or places to explore.

The storytelling or control of the plot rests in the hands and skills of the player. The designer’s job is to give numerous paths and options for the player to operate therein. Think of this as an amusement park where the individual rides are entirely self-contained, but they are located near and have a similar theme to the other rides in that section of the park. Selecting amusements and rides in various orders may result in a variety of outcomes; for instance, eating and riding three roller coasters may produce a result much different stomach-wise than riding the roller coasters first and then eating a big meal.

The designer sets the stage, provides enough paths and possible storylines, and for each path an outcome is determined. Some areas can be entered only once, while others can be entered multiple times or in a specific order. In others, the order produces different outcomes.


Alice in Planet Wonderland

Box 1:

(enter initially only)
Alice sits at her CAT (Computer by Advanced Technologies) computer (Dinah) playing solitaire. She is about to be 33 years old on March 3. On her 13th birthday, her mother, also age 33, died unexpectedly. Divorced and lonely, she stares at her computer screen night after night. She was raised by her aunt along with her older sister. After high school she had to work instead of attending college, where she wanted to go to study medicine or law.

An e-mail pops up.

“Oh, Dear! Oh, Dear! I shall be late!
Download the Wonderland program.
signed, The White Rabbit.”

Curious, Alice downloads and executes the 3D Virtual Wonderland program and in first person POV sees 3D White Rabbit run across the screen and down a hole located under a row of hedges.

Alice touches her screen on top of the hole under the hedge and her finger disappears.

Amazed, Alice drinks her cup of tea, which has magically turned purple. She is instantly transported into the 3D virtual Wonderland world. She enters the surprisingly large rabbit hole in hope of adventure.

Box 2:

(an initial entry)
As 33-year-old Alice floats down into the abyss, she turns 28 and sees objects from her past. Soon she turns 23, and more familiar objects from those years appear around her as she continues to fall. Then she turns 18 and notices the world around her is the same as it was in those late teenage years. Finally, Alice lands on the ground as she has become 13 again. The White Rabbit is seen running down the long corridor.

Box 3:

(multi entry)
“The Rabbit Form,” a dark nightclub with pulsating music dimly lit by a row of hanging lamps owned by the White Rabbit. Cards, dominoes, and chess pieces are dancing to the music. In the back there are stairs leading to a basement.

Box 4:

(multi entry)
An empty basement with several locked doors, a sofa, two comfortable chairs, a coffee table filled with cakes and glasses of purple, green, and yellow juices, and a three-legged glass bookcase with a golden key lying on the top shelf. Each door leads to a different “box.”

If Alice partakes of the “Eat Me” cakes on the coffee table, she will turn 18 years old. Then with another bite, she’ll become 23 years old. After another mouthful, she’ll turn 28 years old and lastly become 33 years old again.

If Alice drinks from any of the glasses, she’ll lose five years from her life, so if she’s 18 years old, she’ll turn 13 again. She can never get older than 33 or younger than 13. She needs to be at least 23 to acquire the key and 13 to unlock and open any door.

The first door enters the Alice Tear Lake Island.

The second door enters the entrance to the White Rabbit’s House.

The third door enters the white rose garden leading to the King’s Castle.

Box 5:

(multi entry)
Alice Tear Lake Island is the island where the “caucus race” happens and was created by the first of Alice’s tears. This is where Alice interacts with other virtual 3D characters, such as a lory, a dodo, an eaglet, a duck, a magpie, a canary, and two crabs (a mother and her daughter).

On the first time here (or if Message One flag is not “On”) Alice learns that, after the original Alice’s first visit, the Queen of Hearts has been placed in the dungeon for beheading half the kingdom and for unjustly accusing the Knave of Hearts of stealing her tarts. The Mad Hatter now rules since he won the “caucus race” after everyone else tried to solve his “riddle of the day” that had no sensible answer.

Box 6: | (multi entry) The White Rabbit’s House where the White Rabbit, the messenger and herald for the King, lives. The White Rabbit has many employees who have cottages on his estate, such as the housemaid, Mary Ann, the butler, Pat, and the gardener and handy creature, Lizard Bill.
Box 7: | (multi entry) The Rose Garden in front of the King’s Castle where the gardeners—the Two of Hearts, the Five of Hearts, and the Seven of Hearts—paint the white roses red and prune the luxurious gardens. Often in older days croquet was played here with flamingo mallets, hedgehog balls, and playing card arches.
Box 8: | (multi entry) The woods where an enormous puppy playfully wants to fetch after a stick. The woods are located just north of the Caterpillar’s Mushroom.
Box 9: | (multi entry) The Caterpillar’s Mushroom. A flowered, grassy area where on top of a large, growing mushroom sits a hookah-smoking large caterpillar. The caterpillar explains that eating the left side of the mushroom will make one grow older and the other side will make one grow younger. A pigeon flying overhead attacks grown-ups (over 23 years old). This is located just south of the woods (beware of the giant puppy).
Click To expand
Become one with your vision; put yourself into your work.
Box 10: | (multi entry) The Duchess’ House where a Fish Footman guards the entrance and inside the large kitchen filled with smoke a Duchess sits nursing her baby on a three-legged stool with her cook stirring a cauldron of peppered soup. Occasionally, sitting on the hearth is a wide grinning Cheshire Cat who can disappear and often gives great advice. Quite often the cook throws pans, plates, and dishes at the sneezing Duchess and her baby whom the Duchess violently tosses in the air. From the Duchess’ house, traveling to the right leads to the Mad Hatter’s House and traveling to the left goes to the March Hare’s Hutch.
Box 11: | (multi entry) Mad Hatter’s Property. Located on the front lawn of the Mad Hatter’s domicile is a large table under a tree reserved for drinking tea. Currently, the Mad Hatter and his “mad as a March Hare” companion reside at the Castle where it’s always “tea time.”
Box 12: | (multi entry) The March Hare’s Hutch. In the shape of a large rabbit, the March Hare’s house is cluttered with piles of carrots and bags of tea.
Box 13: | (multi entry) The Castle where the Mad Hatter rules in riddles and drinks tea with his companions, the March Hare and the forever sleepy Dormouse. The Hatter gets very few things done but at least he’s not running around chopping everyone’s head off like the imprisoned Queen of Hearts did. In a nice room inside the castle resides the King of Hearts. The Frog Footman runs errands for the Hatter and the Hare but not very often. The Mad Hatter enjoys watching the Knave of Hearts carry the royal crown, especially in the Castle’s dungeon where the raving and angry Queen of Hearts sits. (Remember, she accused the Knave of stealing her tarts at one time.)
Box 14: | (multi entry) The Castle’s Dungeon is a large room where one side has a metal-barred prison (room) with a bed, and on the adjacent side is a foyer for visitors and guards to sit at the table or move the chairs toward the prisoner. Currently, the Queen of Hearts resides here and is visited daily by the Knave of Hearts, who delivers a fresh tart each morning and leaves it on a chair in front of the barred prison just out of reach of the Queen. The King, who lives in his lofty room upstairs in the castle, has long forgotten his wife and her annoying, belittling behavior toward him.
Box 15: | (multi entry) Gryphon. The mountain cave of the Gryphon (half lion and half eagle). Just a short trip from here to visit the Mock Turtle.
Box 16: | (multi entry) Mock Turtle. The sandy beach area by the sea where the Mock Turtle lays on a rock sobbing and tells marvelous stories and puns.
Possible endings: |
 | Alice stays in Wonderland forever. Alice returns home in time for her 33rd birthday. Alice returns home as a 13-year-old and her mother lives past 33. Alice returns home as an 18-year-old and goes to college. Alice returns home as a 23-year-old and meets a handsome doctor. Alice joins the Queen of Hearts in the dungeon. Alice becomes the new Queen of Wonderland. Alice goes mad and becomes a wicked witch who gets visited by a girl named Dorothy and her dog Toto (but that’s another story).


Nonlinear Game-Oriented Scripting Standard

Since nonlinear or “game”-oriented scripts can jump from scene to scene as the player (now in charge) commands, there must be a way to connect dialog with the dynamically created story. By labeling each section of dialog and allowing “condition” comments, we can design our vision using the same scenario with varying responses based on preexisting conditions.

Label: ALICE-06-001 (Chapter 6, first time)
Condition: Alice enters the Duchess’ kitchen (first time)

ALICE

Hello. I’m Alice.

What a nice baby you have.

Label: ALICE-06-002 (Chapter 6, after first time)
Condition: Alice enters the Duchess’ kitchen (after first time)

ALICE
Hello. Nice to see you again, Duchess.
My has the pig, eh...baby grown.

Label: ALICE-06-005 (Chapter 6, after first time)
Condition: Alice enters the Duchess’ kitchen (after first time)

ALICE
Hello, again.
Boy, I sure come here often.
May I hold the baby?

The dialog does not follow a linear story; therefore the scripting should follow the game flow and the actors’ dialogue should look exactly like their standard script format. This technique assures us that the game will have all of the script conditions and voice-over parts to shoot, and the talent (which we will be working with from outside the gaming industry) will view us as professional and understand the work we need them to perform. By providing our needs in this format, we can get the talent to read their lines based on our game’s conditions, price out the costs for their efforts, and have many verbal variations so our gameplayers won’t be bored or frazzled by hearing the same repeated dialog every time they enter the Duchess’ kitchen.


Scheduling a Shoot or Voice-Over Session

Scheduling a shoot session is an important and often under-appreciated skill that when correctly planned, can save a lot of time and money (think budget!).

A good method to start the process is to list all of the actors’ (real names if selected) or characters’ names in the first column followed by each scene and act (by venue/location) in the following columns.

A scheduling example:

Actor Name | 1 | 2 | 3 | Scene 4 | 5 | 6
Mary | X | - | X | X | X | -
John | - | X | X | X | - | X
Michele | - | X | X | X | - | -
Roger | X | - | - | X | X | -
Brooke | - | - | X | X | X | X
Megan | - | X | X | X | X | -

Now the shoot scheduler must analyze this table of actors or characters versus their scenes. In the analysis phase of the scheduling using the example, let’s examine the scenario where the actor “Roger” is a famous, award-winning thespian who will enhance the sales and marketing of our game. Roger’s time is both valuable and expensive compared to the other actors in our shoot.

Ideally, we’d want to shoot his (Roger’s) scenes first and work around his schedule. In the example, Roger appears in scenes 1, 4, and 5. Let’s look at a shooting schedule that begins on a Monday, and Roger’s agent tells us that he is only available for one scene a day and free on Tuesday, Wednesday, and Friday.

In this scenario, we’d shoot the scenes in the following order:

Monday is for shooting Scene 3 (Roger is not available).
Tuesday is for shooting Scene 4 (Roger is available).
Wednesday is for shooting Scene 5 (Roger is available).
Thursday is for shooting Scene 2 (Roger is not available).
Friday is for shooting Scene 1 (Roger is available and finished).
Saturday (last shooting day) is for shooting Scene 6.

This analysis for the schedule would have the following effect:

Mary works on days 1, 2, 3, and 5.
John works on days 1, 2, 4, and 6.
Michele works on days 1, 2, and 4.
Brooke works on days 1, 2, 3, and 6.
Megan works on days 1, 2, 3, and 4.

This schedule accommodates the specific schedule of superstar Roger and tries to minimize the other actors’ schedules that may require costly overnight lodging, meals, and transportation. Try to maximize the “act and leave” process and minimize the nonworking (“off”) days.

Another criterion to examine is location-dependent situations, such as renting an authentic World War II fighter airplane. Renting such a vehicle might be less expensive in the off season or midweek (Tuesday through Thursday), since air shows occur on weekends and transporting to and from the air shows probably occurs on Friday to travel to the show and Monday to return back to the “home base.”

If a scene needs to be shot with an authentic World War II fighter airplane, this scene with all of the actors involved would have priority for a scheduled midweek shoot. The earlier the better (like on Tuesday rather than Thursday), since the shoot scene might have to be reshot (a botched Tuesday shoot could be reshot on Wednesday when a Thursday bad shoot would have to be reshot the following Tuesday, costing time and money).

If a venue or location is rented for the day, all scenes and acts that take place in that venue must be scheduled for that day’s shoot. The venue’s shoot day is more important than the actor’s schedule, and the production scheduler must weigh all of the scenarios and costs involved to properly construct the entire production schedule that may include costly actors’ time, venues, and prop rental.

During a location shoot, the costly actor’s scenes are shot first, followed by the scenes that would dismiss the most actors, so as the day progresses fewer actors remain (“act and leave”).

When developing a script for cut scenes, in-game character voices, or cinematics, scheduling included in the design document not only helps the producer and development team but is needed for budgetary considerations, such as the number of shoot days, number of actors and crew, location setups (needed actors, crew, and props and equipment), a fallback or contingency plan due to bad weather (such as rain or snow), and absent personnel (such as sick or accidentally detained).

The schedule helps in set building (when needed, transporting the sets), props needed, scheduling rehearsals, and actor stand-ins for camera adjusting and lighting the scene.


Chapter 15: Audio: Sound and Music

Overview

Sound adds a special dimension to the gaming experience. Game designers must document needed sounds for background (ambient sound) and sound effects for the gamer’s selection, as well as the in-gameplay sound effects and character voices. The game designer needs to know and understand the basic audio software and sound effects libraries that the audio specialist, sound engineer, and composers will use to make the game sound great.

The game designer needs to provide the audio staff with a complete list of sounds envisioned in the game. From this list, the audio people will estimate their completion time, milestones (deliverables in segments), and budget (what they will charge to make your game sound great). If the game designer can provide samples of music (the style, the mood to create, and the instruments involved) and samples of sound effects (even if they are borrowed from other mediums like film, video, or television), the sound creation process will be quicker and easier to complete since the audio specialists involved with new, original compositions and sound effects will be closely in line with the designer’s original vision.

SFX libraries (for a detailed listing see Appendix C) include collections from Sound Ideas, Warner Brothers, Hanna Barbara, Disney, Universal Studios, LucasFilm, 20th Century Fox, and Hollywood Edge (used by many famous filmmakers and their Academy Award-winning films). Audio software includes Cakewalk’s SONAR, Cakewalk’s SONAR XL, Cakewalk’s Metro 5, Sonic Foundry’s Sound Forge 6.0, Sonic Foundry’s ACID PRO 4.0, Sonic Foundry’s Vegas Video 3.0, and FMJ Soft’s Awave Studio.

The game designer must address sound issues and questions that will be asked by a knowledgeable audio or sound specialist or composer.

How much music, sound effects, and character voices are needed? Number of tracks? Length of each music and sound effect sample? Composition style that the designer envisions? Where in the game are the sound effects needed? Is there critical timing for animation or AVIs?

How soon do you need sound (timeframe)? Quicker means more money. More advance scheduling and better documentation of needed sounds could produce a better result or a selection of several varying choices to use.

What is to be the delivery method—CD or DAT (Digital Audio Tape)? Explain the theme of game or the mood the designer wishes to create. What are the storage considerations (space reserved or allocated specifically for audio)? Are there any samples of prerecorded music to emulate?

A general rule of thumb for sound is that 30 seconds of music requires four hours to compose from scratch, record tracks, and mix down.

In regard to licensed properties, must the character voices be that of the property’s actors, or can approved voice-over impersonators perform in their place? Using the Hollywood actors may have additional, expensive costs attached to the endeavor as well as difficulties scheduling the actor’s precious time to rehearse and record the audio script.

If the property is a sitcom, do the sitcom’s writers and/or producers get to approve the game’s script and gameplay? (This was a true situation for a game based on a sitcom having characters like Elaine, George, and Kramer.)

Research books on music, or listen to music from all genres such as baroque, blue grass, blues, classical, country, disco, jazz, Latin, new age, opera, punk rock, R&B (rhythm and blues), rap, reggae, rock and roll, and techno sounds.

Be familiar with the Game Ideas list of music composers and their work found on the companion CD. Music creates a mood and an atmosphere and can transport the player into your world. The next time you watch your favorite movie or go to the theater, pay attention to the sounds you hear. Listen to the movie and mentally record its sound effects, its ambience, and the actors’ technique for delivering their lines.

Researching audio Internet sites like Game Audio Pro (groups.yahoo.com/group/gameaudiopro/) can be a valuable endeavor. Game Audio Pro is an open forum for audio professionals who work in the computer and video game industry, as well as hobbyists, semi-pros, and game music fans.

Here’s a handy chart showing you the various file sizes depending on your sample rate (sound quality) and size of each sample (8- or 16-bit).


Sound Quality vs. File Size

Resolution | Encoded or Stereo 8-bit | Dolby Surround or Stereo 16-bit
44.1 kHz | 5,292 K | 10,584 K
27.05 kHz | 2,646 K | 5,292 K
11.025 kHz | 1,323 K | 2,646 K
8 kHz (Java or Flash) | 960 K | 1,920 K


Cakewalk (

Team LiB

Cakewalk (www.Cakewalk.com)

Cakewalk offers a variety of award-winning multitrack recording products both for the professional and the beginner, such as SONAR, SONAR XL, Home Studio, Home Studio XL, and Metro 5 (Mac).

SONAR

Click To expand

The SONAR multitrack digital recording system is a new generation of professional audio technology for recording, editing, mixing, and delivering music and sound projects for CDs, film and video scores, the Internet, or any multimedia project (available for Windows 98/Me/2000). SONAR has multiport drum editing with grid and pattern-based enhancements and custom drum mapping. It has advanced project management like easy-to-use file management tools, per-project audio folders, intelligent file naming, and more. SONAR’s Track view allows for recording, editing, sequencing, and mixing the project from within one global view. Tracks, auxiliary buses, and main outputs are all displayed in the Track view.

Click To expand

Cakewalk is developing support for OMFI (Open Media Framework Interchange) technology into its flagship SONAR 2.0 digital multitrack recording system. OMFI support for SONAR 2.0 is now in the alpha-testing phase at the company.

OMFI is the film, video, and audio industry’s standard for saving and transferring digital postproduction projects between different production studios and workstation platforms. SONAR 2.0 will both import and export OMFI format files and should be available by fall 2002 at no charge to all registered SONAR 2.0 owners.

The company also recently joined the Advanced Authoring Format (AAF) Association—the organization responsible for the continuing development of OMFI-based technology. Cakewalk is the first Windows audio software company to join this influential trade association.

The AAF is a broadly based trade association created to promote the development and adoption of AAF technology. AAF technology allows content creators, editors, and rich media authors to exchange video, audio, images, text, and metadata between applications and builds on existing OMFI technology.

In addition, Cakewalk plans to support Broadcast Wave files in SONAR 2.0 at the same time that it releases support for OMFI files. The Broadcast Wave Format (EBU Standard N22) allows audio material to be interchanged between different computer platforms and broadcast environments. It extends conventional RIFF WAV files by adding metadata, such as creation date and time, material identifier, and time position (SMPTE).

The SONAR 2.0 digital multitrack recording system provides unlimited digital audio and MIDI recording; real-time, fully automatable DirectX 8 audio effects and low-latency DXi software synths; support for Reason and other ReWire-compatible synths; comprehensive audio loop construction and editing tools; support for importing and exporting ACID-format WAV files; flexible project file management; and other professional music production capabilities.

As of January 2003, the prices of SONAR software were:

SONAR Software | Price
SONAR 2.1 | $479
SONAR 2.1 XL | $599
SONAR 2.1—upgrade for registered Cakewalk customers | $199
SONAR 2.1 XL—upgrade for registered Cakewalk customers | $249

SONAR XL

SONAR XL provides all of the capabilities of SONAR, plus two additional 64-bit, fully automatable DirectX 8 mastering effects, an advanced DXi soft synth drum sampler, audio loop libraries, and a SoundFont library (available for Windows 98/Me/2000).

SONAR 2.0 XL provides a fully automatable 64-bit EQ, 30-band spectrum analyzer, and phase meter—perfect for mastering. It features clean and vintage EQ algorithms, high and low cut filters with resonant filter controls, low and high shelf filters, six bands of bell filters, sweepable filter points, and adjustable Q sizes.

Click To expand

SONAR 2.0 XL’s 64-bit, fully automatable audio effect features hard- or soft-knee compression, no-clip brick wall limiting, and ultra-fast attack/release times, as well as analog-style metering.

Cakewalk Home Studio

Record your own music on your PC with Cakewalk Home Studio. There is no better Windows software available for musicians taking the step into the world of digital recording. Home Studio provides you with everything you need to turn your PC into a powerful multitrack recording studio.

Home Studio has support for real-time DirectX effects, DXi software synths, MIDI FX plug-ins, and ACID-format audio loop technology that allows you to record unlimited audio and MIDI tracks, mix with real-time audio and MIDI effects, plug and play DXi soft synths, create loops fast, and support ACID-format, MP3, WAV, WMA, and MIDI files. Also included for free are Pyro MP3 and CD Maker (trial version), Virtual Sound Canvas DXi soft synth, DreamStation DXi soft synth, and ACID-format audio loop library.

As of January 2003, Cakewalk Home Studio 2002 retailed for $129.

Click To expand

Home Studio XL

For the musician, project studio producer, or dance/remix artist who’s looking for more value, Home Studio XL provides all the capabilities of Home Studio 2002, plus a series of essential plug-ins for mixing and mastering, such as (1) Compressor/Gate—tighten up your mix, bring out the vocals, add punch to tracks, and smooth out performances with a wide dynamic range, (2) Limiter—avoid distortion by keeping audio signals from exceeding a set threshold, (3) Expander/Gate—increase the dynamic range of your recordings (makes loud parts louder and quiet parts quieter), (4) Dynamics Processor—an all-in-one effect that combines all three above effects for more control over your mix, and (5) DR-008 SE Drum Sampler/Synthesizer.

The Cakewalk Loops CD includes a full CD of ACID-format audio loops by leading producers, including Power FX, Smart Loops, and X-MiX and contains many styles such as rock, pop, hip hop, and dance.

As of January 2003, Cakewalk Home Studio XL retailed for $219.

Click To expand

Metro 5

Metro 5 is the complete digital audio and MIDI studio for the Mac. You can record tracks using any musical instrument or sound source, arrange your music with flexible pattern-based sequencing, explore new ideas with creative songwriting tools, mix in real time using automated audio effects, edit and print notation, and even produce scores for film, video, games, and QuickTime movies.

Cakewalk’s Metro 5 has an improved user interface for increased musical productivity, supports ASIO-compatible audio cards, and has automated real-time effects processing, up to eight stereo auxiliary buses for routing real-time effects, improved drag-and-drop editing of audio, audio file compression for improved disk storage, VU meters for accurate level monitoring of audio and MIDI, audio scrubbing for quick auditioning of tracks, crossfades with linear and exponential curves, and context-sensitive, searchable online help and online tutorials.

With Cakewalk’s Metro 5 you can record up to 64 tracks of digital audio at variable sampling rates from 11.025 kHz to 48 kHz and edit and process with sample accuracy and off-line edits. Cakewalk’s Metro 5 multitrack MIDI allows up to 99 tracks of MIDI per section with up to 32 sections per song file where you can edit notes, controllers, tempo, pitch bend, and drum patterns within a single window. Composers can pitch, bend, and transpose notes and edit the drum grid, perform criteria-based editing, velocity editing, and print notation. You can turn MIDI tracks into notation or transcribe a MIDI performance or enter notes with a mouse. Scores can be printed with titles, expression text, dynamic markings, and scalable staves.

Click To expand

Metro 5’s system requirements for recording MIDI only include PowerPC/iMac with 8 MB of RAM or more, Mac-compatible MIDI interface, OMS and QuickTime musical instruments for internal playback, Mac OS System 7.0 or later, and MIDI Timepiece, OMS, Galaxy, SampleCell, and Unisyn v1.0 supported but not required.

Metro 5’s system requirements for recording MIDI and audio include PowerPC/iMac capable of 16-bit input, 5 MB RAM free per audio track (real-time effects require additional memory), Sound Manager 3.2 or greater for audio input/output, and QuickTime 2.5 or better required for importing/exporting audio and displaying QuickTime movies.

Metro 5’s audio hardware support has, in addition to Apple Sound Manager, support for ASIO-compatible audio devices, including MOTU 2408, AudioMedia III, Event Layla, Yamaha SW1000 XG, Korg 1212 I/0, Sonorus Stud/O, Alesis PRC, and Lucid PCI 24.

As of January 2003 the prices of Metro software were:

Metro Software | Price
Cakewalk Metro 5 | $249
Cakewalk Metro 5—for registered customers | $ 49
Cakewalk Metro 5—upgrade from Metro 4.X | $ 49
Cakewalk Metro 5—upgrade from 1.X, 2.X, SE, DECK II, beyond | $ 49
Cakewalk Metro 5—upgrade from Metro 3.X | $ 49


Sonic Foundry (

Team LiB

Sonic Foundry (www.sonicfoundry.com)

Click To expand

Sonic Foundry develops sophisticated technology for creating, editing, managing, delivering, and accessing rich media.

Sound Forge 6.0

Sound Forge is Sonic Foundry’s award-winning, two-track digital audio editor. Sound Forge includes a powerful set of audio processes, tools, and effects for manipulating audio. This one-of-a-kind application is perfect for audio editing, audio recording, effects processing, and media encoding. Combine Sound Forge with any Windows-compatible sound card to create, record, and edit audio files. The clean and familiar Windows interface makes editing a breeze. It also has built-in support for video and CD burning and can save to a number of audio and video file formats, including WAV, WMA, RM, AVI, and MP3.

Click To expand

Sound Forge’s editing features provide a combination of over 35 audio effects and processes with more than 200 presets. It includes dozens of editing features, such as cut, paste, move, delete, mute, reverse, crossfade, trim, normalize, fade, pan, resample, enhance, insert silence, and more.

Sound Forge’s effects includes 20 DirectX Audio plug-ins, including XFX1, XFX2, XFX3, and Acoustic Mirror, which can be used for acoustic simulation and microphone modeling. The entire arsenal of effects includes amplitude modulation, chorus, delay/echo, distortion, dynamics, flange, gapper, noise gate, pitch bend, reverb, vibrato, time compression, Wave Hammer (compressor and volume maximizer), and more. Sound Forge also includes three EQs—graphic, parametric, and paragraphic—and supports DirectX plug-ins from third-party applications.

Sound Forge supports a wide range of audio formats, including 15 import formats—Windows Media Audio (WMA), OggVorbis (OGG), Perfect Clarity Audio (PCA)—and 17 export formats, such as WAV, Windows Media Audio, RealAudio, and MP3.

Sound Forge provides simple drag-and-drop operations and a customizable interface, allowing you to build projects the way you want. Sound Forge also supports standard Windows keyboard commands and mouse shortcuts.

Sound Forge includes auto crash recovery, which allows you to recover lost work after a power failure or system crash. Sound Forge also includes a powerful undo/redo history feature, which allows you to see your entire work history at a glance and undo unwanted edits.

New features for Sound Forge 6.0 include multitask background rendering, which allows you to work on one file while Sound Forge processes another; increased editing accuracy, which permits editing down to the sample level; and new video render options, including fast video resizing, source video resampling, and video stretching.

Platform: Windows 98SE, Me, 2000, or XP

List price: $499.95, packaged: $399.96, download: $349.97

Click To expand

ACID PRO 4.0

ACID PRO 4.0 is an award-winning, loop-based music creation tool that allows you to produce original, royalty-free music. ACID PRO can create songs, remix tracks, develop music beds, score videos, and develop music. It is intuitive and easy to use, works with hundreds of loops in multiple genres, uses unlimited tracks of audio, and imports complete songs, even MP3s. It has built-in support for MIDI, video scoring, and can save to a number of audio and video file formats, including MP3 (MP3), Perfect Clarity Audio (PCA), Video for Windows (AVI), QuickTime (MOV), OGG Vorbis (OGG), and new export formats such as RealVideo 8 (RM) and RealAudio 8.

With ACID PRO, you can adjust the volume and panning for each track, alter effects over time using volume and track envelopes, apply fades and transitions, create amazing drum fills, combine music loops with existing songs, and even apply effects on tracks, buses, or in assignable effects chains.

ACID PRO includes 20 DirectX audio plug-ins from Sonic Foundry’s XFX 1, XFX 2, and XFX 3. It also includes effects such as amplitude modulation, chorus, delay, distortion, flange, noise gate, reverb, and more. ACID PRO also includes three EQs—graphic, parametric, and paragraphic—and supports third-party DirectX plug-ins.

ACID PRO includes a music content CD containing more than 350 multi-genre music loops and dozens of projects from Sonic Foundry’s Loops for ACID collection, including genres such as dance, hip-hop, techno, industrial, pop, rock, jazz, ambient, orchestral, and more.

ACID PRO supports MIDI and DLS (downloadable sounds) files. MIDI files can be played using external or internal MIDI sound sources, including DLS files, through the DirectX Soft Synth. MIDI tracks time stretch perfectly to any tempo and can be rendered with effects just like audio tracks.

Click To expand
Click To expand
ACID PRO Beatmapper remixing tool and Chopper editing tool

ACID PRO includes features such as the Beatmapper remixing tool, Video scoring track, and Chopper editing tool. It has a powerful new effects model, 32 effects per track, 32 effect chains/26 buses, sample rates up to 192 kHz, 12 new DirectX audio plug-ins from XFX2 and XFX3, MIDI record and playback, MIDI file support, DLS sound file support, CD ripping/CD extraction, master, track, and assignable audio effects, attack, sustain, and release (ASR) envelopes, track envelopes to lock to events, Vegas Audio LE multitrack editing software, and user interface enhancements.

Platform: Windows 98SE, Me, 2000, or XP

List price: $499.95, packaged: $399.96, download: $349.97

Vegas Video 3.0

Vegas Video 3.0 is a digital video editing system that provides all the integrated tools and high-quality output options that you demand for your production environment. Vegas Video 3.0 offers support for all OHCI-compatible IEEE 1394 DV devices, from consumer to professional, whether the final project is DV, MPEG-2 for DVD, streaming media for the web, uncompressed D1 for broadcast, NTSC or PAL, or a Red Book CD master.

Click To expand

Platform: Windows 98SE, Me, 2000, or XP

List price: $599.95, packaged: $479.96, download: $419.97


Awave Studio (

Team LiB

Awave Studio (www.fmjsoft.com)

Click To expand

Awave Studio is a multipurpose audio tool that reads a variety of audio file formats from different platforms, synthesizers, and trackers. It can be used as an audio file format converter, an audio editor, an audio and MIDI player, and a wave table synthesizer instrument editor and converter. Awave Studio converts from the 190 audio-related file formats that it can read into any of the 190 audio file formats that it can write.

Awave Studio does quality conversions between the instruments format’s most common PC synthesizer sound cards, like SB AWE32, SB Live!, all Vortex II-based cards, TB Pinnacle, TB Maui, AVM Apex, Gravis UltraSound, and UltraSound PnP.

Awave Studio converts MIDI song data between several formats. You can package MIDI songs together with custom instruments in a single file. You can even convert MOD-tracker modules into MIDI format accompanied by custom instruments.

Awave Studio also supports reading, and in many cases also writing, and several commercial synthesizer file formats, including formats from Ensoniq, Akai, Kurzweil, Roland, and Yamaha. It can also send or receive waveforms to professional synthesizers using standard SDS transfers over MIDI or really fast SMDI transfers over SCSI.

A Batch Conversion Wizard makes converting large numbers of audio files easy.

The Audio Processing Wizard lets you accomplish many common editing tasks like resampling, fading, cutting and pasting, merging and combining waveforms, and much more. An example of a use for the Audio Processing Wizard is the cross-fade loop function; using this, you no longer have to search in vain for that elusive optimal loop point. Just select a likely portion of the waveform and cross-fade it, and you have a good sounding loop.

The Instrument Processing Wizard helps you avoid having to manually do repetitive editing tasks on instruments. It is a fully featured DLS level 1, DLS level 2, and SoundFont 2.1 wavetable instrument editor, which can also be used as an editor for many other instrument formats.

You can play sampled audio files using the Audio Player on a real-time oscilloscope or frequency analyzer display, which is also integrated into the Windows shell so that you can play files with a click of the right mouse button.

The MIDI Player uses Microsoft DirectMusic technology and DLS synthesis (DX 8 required for DLS level 2). It guarantees that MIDI songs sound exactly the same on all computers.

Record your MIDI songs (with or without custom instruments) to a WAV file on disk using the software synthesizer for later MP3 format conversion.

Audition your instruments directly using any of the several natively supported synthesizers (including DirectMusic and the Microsoft software synthesizer or the simpler internal sound mixer). Use the PC keyboard or an external MIDI keyboard to play. Record new waveforms using the Waveform Recording Wizard.

It does not convert WAV to MIDI—it isn’t a MIDI editor/sequencer. It does not handle really huge audio files (those that are too large to fit in memory), and 16-bit PCM mono/stereo is the internal precision used.

Click To expand

Awave Studio is shareware; it is not free. This means that if you like the program and decide to use it past the 30-day trial period, you must register (i.e., buy it—the price is $99.95). There are also a number of incentives for registering it such as:

  • Removes nag screens and other annoying reminders

  • Removes save limit

  • Enables some locked features (copy/paste, saving bank files, and batch convert)

When you purchase Awave Studio, you get a one person-one computer license—valid for the current program version. You are sent a personal registration code that unlocks the shareware version, turning it into the full registered version.


Sound Ideas (

Team LiB

Sound Ideas (www.sound-ideas.com)

Click To expand

Sound Ideas is an online resource for sound effects and production music. Its collection includes:

General Sound Effects Collection

The General Series 6000 Extension I | The General Series 6000 Extension II
The General Series 6000 Extension III | Series 1000 General Sound Effects Library
Series 2000 General Sound Effects Library | XV Series Multi-Platform SFX Library
BBC Sound Effects Library 1-40 | BBC Sound Effects Library 41-60
The International Sound Effects Library | De Wolfe Sound Effects Library
De Wolfe Classic Sound Effects Library | Renaissance SFX Library—Dolby Surround
Platinum Sounds for the 21st Century | Audio Pro European Sound Effects Library
Digiffects Sound Effects Library |

Feature Film Sound Effects Collection

Amadeus SFX Library | 20th Century Fox SFX Library
Lucasfilm SFX Library | Universal Studios SFX Library
Turner Entertainment Co. SFX Library | Disney Ideas

Comedy and Cartoon Sound Effects Library

Hanna-Barbera SoundFX Library | Hanna-Barbera Lost Treasures
Warner Bros. Sound Effects Library | The Sound Effects of Rocky & Bullwinkle & Friends

Science Fiction Sound Effects Library

Metropolis Sci Fi Toolkit 1 | Metropolis Sci Fi Toolkit 2
Jurassic Dinosaurs | Drone Archeology
The Big Drone |

Extreme Sound Effects Collections

Crash & Burn | PowerSurge 1
PowerSurge 2 | Larger Than Life
Impact Effects | Power Pack from Digiffects
The Dark Side of Sound | Specialty Sound Effects Collections
Thunder | The Art of Foley
Foley Footsteps | Series 9,000 Open & Close
Series 11,000 Sports | Series 4,000 Hollywood
Emergency | Click Shop from Digiffects
Dynamic Range | The Works
Blow Tools |

Land and Water Sound Effects Collections

Series 5,000 Wheels | Series 5,000 Wheels 2nd Gear
Speed | Series 12,000 Anchors Away
Series 13,000 Ship Shape |

Birds and Animals Sound Effects Collections

Just Birds & Animals

Wild World of Animals

Audience Reactions Sound Effects Collections

Audience Reactions I

Audience Reactions II

Ambience Collections

Series 3,000 Ambience I | Series 7,000 Ambience II
Series 10,000 Ambience III |

Speech and Voice Collections

Nightingale Voice Box 1 & 2 | Nightingale Voice Box 3—Just Kids & Babies
Great Speeches of the 20th Century | Historic Presidential Speeches

Can I use Sound Ideas sound effects in my computer game?

Yes you can, provided that the sounds are embedded in the code of your game and are not available for an end user to access or download. If your application allows the end user to access or download unsynchronized sounds, you should contact Sound Ideas to arrange supplemental authorization for the use of the sound effects.

I am making a video game for release in retail stores. Can I use your sound effects in it?

Yes you can. Synchronization of our sound effects in this manner is permitted under the terms and conditions of the Sound Ideas End User License Agreement.


The Hollywood Edge

Team LiB

The Hollywood Edge
(www.Hollywood
Edge.com)

Click To expand

The Hollywood Edge, a division of Todd/Soundelux Studios, is one of the largest publishers and distributors of high-quality sound effects, production music, and specialty audio hardware. With over 30 multiple disc collections, including hard-to-find sound effects and special field recordings, The Hollywood Edge productions are the most usable effects library available. Oliver Stone, Martin Scorsese, and John Hughes are among the filmmakers who highly recommend the vast collection produced and compiled by the award-winning sound designers and editors from Soundelux.

Soundelux is the only company in the industry that is also a postproduction facility and offers its Foley sound collection from Academy Award-winning films in its new Foley series.

The Hollywood Edge SFX Collection

3DSFX Series | The Car Chase Scene Set | Futurity’s Metropolis
Alan Howarth Signature Series | Cartoon Trax | Hi Tech & Top Secret Effects
American Zoetrope | Citi Trax | Historical Series
Vehicles | Dynamic Range | HPX Digital Effects
Animal Trax | The Edge Edition | Laughs, Cheers, and Applause
Animation Collection | The Eerie Edition | Lon Bender’s Wacky World of Widgets
Apocalypse Now | European Edition |
Background Trax | Explosions Signature Series | Martial Arts & Human Impacts
Burtis Bill’s American West | File Effects | Metropolis II
Busted Effects & Most Wanted | Foley Sound Library Foley Steps | Paradise
Peter Sullivan Signature Series | Premiere Edition 4(Volumes 41 to 50) | Sports With Balls Surround Crowds
Premiere Edition 1 (Volumes 1 to 20) | Sci-Fi Set | Star Trax
 | Sound Designer Tool Kit | Super Single I
Premiere Edition 2 (Volumes 21 to 30) | Sounds of a Different Realm | Super Single II The Works
Premiere Edition 3 (Volumes 31 to 40) | Sounds of Speed Sports With Balls | Worldwide Sports Edition


Chapter 16: Testing

Overview

Through the entire development phase, testing is performed by a variety of skilled team members. Programmers are constantly checking and testing their code for accuracy, for speed, for efficiency, and against the designer’s specifications. QA (quality assurance) testers perform various tests throughout the development process that varies as the game development cycle progresses.

In the beginning of a game’s development, the testing should check basic design issues such as: Are the graphic images displayed correctly? Are they in the correct location on the screen? Do the buttons work in various modes like mouse-over, clicked-on, and normal mode? Are the correct sounds and sound effects being played? Are the sounds audible? Does the volume need adjusting?

The next phase should test the user interface, the input and user decision paths (the numerous possible actions a player may take), and the basic gameplay.

As the game becomes more playable and stable (fewer glitches and bugs), various hardware configurations should be tested, such as numerous PC brands, CPU speeds, operating systems (Windows 3.1, 98, 2000, Me, and XP are examples), 3D cards, graphic cards (various supported graphic modes), and printers. Actual gameplay from an expert’s POV (knowledgeable, genre fanatic) to a complete idiot’s POV (beginner or novice player) should be tested, and problems that were previously reported and now labeled as “fixed” (problem was resolved) should also be verified. If the game supports multiplayer or Internet options, these components should be tested throughout the day and night for the throughput “test” play speed (latency) and to verify the aspects in the game that should work in multiplayer mode.

A good practice is to have the programmers include in the game an “audit trail” that writes the algorithms that determine all gameplay (a list of each algorithm’s variables and conditions set). This way, when a tester finds an unexpected response or action, the programmer can check the equations and conditions that caused this event. Also, many gaming companies have the QA testers videotape their sessions. Since most developers can never find the problems that QA has uncovered, the tape is a good source for proof and a record of current bugs and problems that need to be addressed. This is especially needed if the testers and developers do not work in the same area.

Testers need to create a common database (records) of a product’s ongoing testing problems and bugs. This “bug report” can be as simple as a text document or a spreadsheet. Better still are databases like Microsoft’s Works, Microsoft’s Access, and Oracle. The report should be in a common area that all testers have access to and provide the producer (the person who is responsible for the project) a uniform report in which to communicate with the developers.

Here is an example of a bug report that a tester could use (feel free to expand upon this):

Click To expand

*Video SMPTE is the Society of Motion Picture and Television Engineers. There is an SMPTE time code standard (hr:min:sec:frame) used to identify video frames.

In the bug report, we want to know everything about the problem (what the tester saw and thinks is a problem). There can be multiple pages based on the same problem if the developers have not resolved it to the tester’s satisfaction. The producer’s report should be listed in “severity” order and status, flagging the number of times this problem has been submitted to the developers.

Upon the bug being fixed, the tester and the senior tester must sign off on the report, and the producer must give the testers a Producer ID number to validate that everyone is in agreement that the bug has been fixed (the testers, the producer, and the development team).

Why does testing matter to the game designer?

The design document should have everything needed to program and create the artwork and audio that the team needs to implement your vision. Missing graphics, empty areas with no ambient sounds or sound effects, and programmers guessing how to code are the result of poor and incomplete design instructions (the design document).

The testers should be able to read your design document and lay out a testing plan from the basic question “does the game follow the design?” (graphics, sound effects, audio ambience, player control, and NPC AI) to all paths that a player can select from the start to termination of the game (successfully completing the game and the numerous ways to end the game early or unsuccessfully). The testers should be able to plan the testing from single player to multiplayer via a network or the Internet.

Once a test plan has been developed, the producer and the testers should have a conference that includes the game designer to discuss the testing plan, to modify any areas not included in the plan, and to sign off on the plan (agree to the strategy of testing the game).


Chapter 17: The Executive Summary (“The Five Pager”)

The Executive Summary (aka Five Pager or Design Treatment) is a basic summary of the game’s concept and a description of the game, including the basic plot, the gameplay, the demographics (player’s or target audience’s gender, age), the flow of the game from the starting scenario to several typical endings (successful and unsuccessful), and the game’s features (like graphics, audio presentation, hardware controls, licensed properties). The Executive Summary is a short, concise information and promotion document, ideally five pages, for the executives to grasp your game’s concept, gameplay, and features.

Candide 2517 Design Treatment

Candide 2517 is a space adventure game in third person containing major battles in space, land, and sea, one-on-one fighting, and games of chance. The settings range from beautiful and glamorous to seedy desolate towns through natural disasters such as earthquakes, meteor storms, deluges, and snowy blizzards.

Candide 2517 is based on Candide, Voltaire’s 1759 novelette. It is the adventure of a young man who is pummeled and whipped in every direction by fate, while he desperately clings to the belief that we live in the “best of all possible worlds.” Candide has become Voltaire’s most celebrated work and has been read by millions throughout the years. Candide and the Land of El Dorado have the power of name recognition, which attracts players just like the license of a film, television show, or book would provide without the expensive fees. Since 1956, playhouses from Broadway to London have performed Voltaire’s Candide with original music by Leonard Bernstein.

Candide 2517 will have stunning venues like Myst and space battles as good as the Star Wars games. In several venues, games of chance will be necessary to earn valuables and range from street venues to galley ships to elaborate casinos a la Las Vegas.

The target audience is vast, from teenagers to adults, and includes both sexes. The battles can be played as “twitch” games where quickness and timing win or as strategy versions where the player acts as the general of the space armada.

The first platform will be the IBM PC and Windows 98, 2000, Me, XP using a 3D engine that supports vast planet-size outdoor terrains, as well as the indoor venues such as palaces, casinos, castles, small inns, and single-unit dwellings. Then the Internet version would be next, allowing players on a PC, PlayStation 2, GameCube, or Xbox to play each other in the various battles or adventure independently from planet to planet.


Candide 2517: The Storyline (a Futuristic Version of Voltaire’s Classic Novel)

On the planet of Westphalia, in the kingdom of the most noble Baron of Thunder-ten-tronckh, lives the Baron, one of the most powerful lords; the Lady Baroness, who weighs 350 pounds; Cunégonde, the 17-year-old daughter who is fresh, comely, plump, and desirable; the Baron’s son who is young and in every respect worthy of the father from which he sprang; and Candide, the illegitimate nephew of a baron.

The children are under the tutelage of the scholar Pangloss, who teaches “metaphysico-theologo-cosmolonigology,” or that this world is “the best of all possible worlds.”

Candide falls in love with the Baron’s young daughter, Cunégonde. The Baron catches the two embraced and expels Candide from his terrestrial paradise.

The snow falls in great flakes and through the blizzard, Candide (almost frozen to death) crawls 100 miles in waist-high snow to the next town, called Wald-berghoff-trarbkdikdorff.

On his own for the first time, Candide meets two soldiers who offer him food and warmth. They draft him into the army of the Bulgars and fly him to their planet. Candide is given a small scout ship, which he accidentally launches into the atmosphere and crash lands.

Candide is court-martialed as a defector and sentenced to death or to run the gauntlet, a maze of torturous mechanical devices, and be chased by the whole regiment. After running through the maze and receiving a few bumps and bruises, Candide begs to be killed. Blindfolded and in front of a firing squad, Candide kneels down just as the Bulgarian Majesty, receiving information about Candide’s crime, decides to pardon him.

The next day, the king of Planet Bulgaria orders the army to prepare their ships for an intergalactic battle with the king of Planet Abares.

Over 20,000 Bulgarian space battle cruisers, destroyers, and gunners attack Planet Abares, which was already on alert and had many space vessels prepared for the invasion. (The player may twitch through this battle, play the Bulgarian or Abares King and command the battle, or skip the battle as Candide did.)

After witnessing a horrific battle, Candide manages to escape and travels to Planet Holland. On Planet Holland, a kindly merchant named James takes Candide in. One day Candide runs into a deformed beggar who is “covered with scabs, his eyes sunk in his head, the end of his nose eaten off, his mouth drawn on one side, his teeth as black as a cloak, snuffling and coughing most violently, and every time he attempted to spit out dropped a tooth.” This deformed beggar turns out to be Master Pangloss.

Pangloss explains that Cunégonde and her family have all been brutally murdered by the Bulgar army after they battled the Abares. Cunégonde’s body was ripped open by Bulgarian soldiers after raping her. They knocked the Baron, her father, on the head for attempting to defend her, and the Baroness was cut in pieces. Their son was killed in the same manner as his sister. As for the castle, they have not left a single stone. Pacquette, the pretty wench who waited on the noble Baroness, was exiled earlier after laying with Pangloss. Pacquette was infected and became a carrier of a sex disease that violently killed off 20 billion people. Pangloss explains that he has contracted the deadly sex disease known as the “Phallic Plague.” Nonetheless, he maintains his optimistic outlook. James takes Pangloss in as well.

The merchant makes Pangloss his bookkeeper. After two months, James has some mercantile affairs on Planet Lisbon and takes the two philosophers with him on the transportation ship.

The three travel to Planet Lisbon together, but before they arrive their ship runs into a meteor storm and James is cast into space by a brutish flight attendant. Candide, trying to help his benefactor, is prevented by the philosopher Pangloss, who demonstrates to him that the flight to Planet Lisbon has been made on purpose for the merchant’s death.

The meteor damage to the ship forces a crash landing where the whole crew perishes, except Pangloss, Candide, and the brutish flight attendant. As they walk toward the capital city of Planet Lisbon, the earth trembles under their feet, and the purple sea swallows up the land, causing 30 million inhabitants of all three sexes, young and old, to die beneath the ruins and waters. Candide and Pangloss wander the city in search of food and supplies since theirs were destroyed in the crash and explosion of their meteor-damaged ship.

The masses of survivors begin to follow the Grand Reverend, who believes that burning a few people alive over a slow fire with a great ceremony is an infallible prevention of earthquakes and floods. Pangloss is soon hanged as a heretic, and Candide is flogged for listening with approval to Pangloss’s philosophy. Others are burned. The same day there is another earthquake and flood.

After his beating, an old woman accosts and dresses Candide’s wounds. After a night’s rest, breakfast, and another day’s recuperation, the old woman escorts feeble Candide into the country about a mile from her room. Candide sits on a magnificent sofa as the old woman leaves. The old woman soon returns supporting, with great difficulty, a young lady, who appears scarcely able to stand. Cunégonde faints upon the sofa.

Cunégonde explains that though the Bulgars killed the rest of her family, she was merely raped and captured by a captain. In three months, having gambled away all his money and having grown tired of her, the captain sold her to a Jew named Don Issachar. After the Grand Reverend saw her in church, he forced the Jew to share her with him as a jointly owned sex slave.

To intimidate Don Issachar, the Grand Reverend invited Cunégonde to the ceremony, giving her a very good seat where she saw Master Pangloss hanged and Candide flogged. Cunégonde ordered the old woman to acquire and restore Candide to health.

The two childhood lovers, Cunégonde and Candide, embrace each other passionately just as Senor Don Issachar unexpectedly enters the dwelling. The Senor draws a sword as Candide, finding a knife, lunges at him and kills the Israelite dead on the floor.

As Candide begins to move the dead body, knife in hand, the Grand Reverend suddenly enters the dwelling and sees the evidence before him. Candide lunges forward and puts another dead on the floor.

Candide, Cunégonde, and the old woman ride three Andalusian horses to the little town of Avacena, in the midst of the mountains of Sierra Morena, and enter an inn. The sell their fine horses to a Benedictine friar for transport fares to Planet Buenos Ayres.

On board the ship bound for Planet Buenos Ayres, the old woman relates her own story. She was born the daughter of Pope Urban X and the Princess of Palestrina but has suffered numerous misfortunes that include rape, enslavement, and cannibalism.

Candide and Cunégonde plan to marry and he gives her a promissory locket to seal the engagement.

As they arrive on Planet Buenos Ayres, the governor, Don Fernando d’Ibaraa y Figueora y Mascarenes y Lampourdos y Souza, the greatest noblemen on the planet with an exceedingly fine mustache, proposes to Cunégonde.

In their flight from Planet Lisbon to Buenos Ayres, Cunégonde’s money and jewels are stolen, including some well-known items known to be the property of the Grand Reverend. The Franciscan who stole them is captured and immediately hanged. Word soon spreads throughout the galaxy that the stolen jewels of the Grand Reverend were discovered on Planet Buenos Ayres. The dozens of intergalactic bounty hunters searching for the Grand Reverend’s murderer head toward the planet.

The old woman convinces Cunégonde to marry Don Fernando for her own financial welfare and safety.

Candide and his newly acquired valet named Cacambo flee to a neighboring planet colonized by people who rebelled against Planet Lisbon and relocated to their own planet. After landing, Candide and Cacambo are captured by soldiers. After Candide claims to be from the planet of Westphalia and not Planet Lisbon, he is brought before the High Commander. Candide and Cacambo are escorted by horses through acres of a vast garden and animal habitat over plush, orange hills and bridges that cross green rivers to finally arrive at a beautiful pavilion adorned with a colonnade of green marble.

The High Commander turns out to be the reportedly “dead” brother of the beautiful Cunégonde and the true son of the Baron. After discussing that the Baron’s son had survived the inflicted wounds and rose up in ranks to rule this planet, he learns of Candide’s promise to marry his sister. As Candide is far beneath her status, this makes the High Commander angry. The High Commander strikes him across the face with the flat side of his sword. Candide in an instant draws his rapier and plunges it up to the hilt in the High Commander’s body.

After laying the High Commander behind the shrubs, Cacambo removes the Baron’s clothes and puts them on Candide, gives him the dead man’s three-cornered cap, and makes him mount on horseback. Once back where they landed their ship earlier, they escape to a neighboring planet.

Upon landing, they see two large, green monsters attacking voluptuous blonde-haired women. Candide figures that saving two beautiful women from this vicious attack would make up in some small way for all of his recent killings. Candide strikes down the monsters, who happen to be the mates of the two women. This act was a ritual, an erotic lovemaking session that Candide mistook for violence. Fifty naked Oreillons (cannibals) capture Candide and Cacambo and invite them to be dinner. Somehow Cacambo convinces them to let them go.

They leave, heading for Planet Cayenne, but a meteor shower forces them to land on an uncharted planet with steep terrain and active volcanoes. After carefully piloting the ship through the erupting volcanoes, they safely land. Upon finding a canoe on this desolate planet, they paddle up the yellow river until they see purple children playing catch with round yellow, red, and green things, which upon careful examination are large pieces of gold, rubies, and emeralds.

After collecting several fine gems, Candide and Cacambo, hungry, enter a restaurant where the waitstaff are dressed in clothes made of gold. Upon finishing their fine meal of soup, they offer to pay with the gems. The owner of the establishment, laughing with his staff, exclaims that they are not accustomed to charging and the joke is that they offered to pay with the common pebbles found scattered throughout the town and roadways. An old local townsman tells them that the inaccessible rocks and precipices and volcanoes had secured them from the rapacious fury of the people of other planets who have an unaccountable fondness for the pebbles and dirt of their land.

Candide and Cacambo get into the coach, the six swift pack sheep fly, and in less than a quarter of an hour, they arrive at the King’s palace. At the entrance is a portal 220 feet high and 100 wide where 20 beautiful young virgins in waiting receive Candide and Cacambo on their alighting from the coach, conduct them to the bath, and clothe them in robes woven of the down of hummingbirds.

They spend a whole month in this hospitable place until they plan to return to their own world with only a dozen of the El Dorado sheep loaded with the pebbles of this country to be as rich as any monarch on their planet.

The mountains of El Dorado on all sides are over 10,000 feet high and perfectly perpendicular. The king gives orders to his engineers to make a lifting machine to hoist these two extraordinary men out of the kingdom. In 15 days the 3,000 good machinists finish it and Candide and Cacambo are high above El Dorado and ready to journey back to their ship.

After traveling about 100 days, they have only two sheep left of the original 202 they brought with them from El Dorado. They finally reach their ship and pack the gems and remaining food and water supply. Candide decides to travel to Planet Surinam where he plans to send Cacambo to Planet Buenos Ayres with instructions to use part of the fortune to purchase Cunégonde from Don Fernando and then meet him on Planet Venice.

As they land on Planet Surinam, the ship transporting them is in need of major repairs. Being so rich with gems of El Dorado, Candide abandons the ship for someone else to claim and repair. Cacambo leaves on a freighter headed for Buenos Ayres.

Candide continues some days longer at Surinam, waiting for any captain to carry him and his two remaining sheep to Planet Venice. A space pirate named Mynheer Vanderdendur, who pilots a large vessel, comes and offers his service first for a decent sum of money and then repeatedly for double the previous sum. Naïve and newly rich Candide pays the sum each time and upon departure finds his valuable sheep, prepaid moneys, and Vanderdendur’s ship already launched.

Upon lodging an official complaint with the Planet’s magistrate, Candide gets fined 10,000 credits for his petulance and ordered to pay 10,000 more credits for the fees of the court. Frustrated, Candide sails in the opposite direction from Planet Venice to Planet Bordeaux. An old philosopher, Martin, is specially chosen to be Candide’s traveling companion to Planet Bordeaux since he is a scholar—a pessimistic scholar at least.

On the trip to Bordeaux, a military patrol ship wanting to perform a routine boarding is ignored, and the patrol ship fires upon and destroys the ship piloted by Vanderdendur. Candide takes this as proof that there is justice in the world, but Martin staunchly disagrees.

Candide stays no longer on Planet Bordeaux than is necessary to dispose of a few of the pebbles he brought from El Dorado. Candide’s disorder becomes very serious, and during his rest a little spruce Abbey of Perigord comes to visit him.

When Candide feels better, the Abbey takes Candide to the planet’s gigantic and elaborate casino where Candide falls in love with the actress and entertainer Miss Clarion. Throughout each night he gambles and afterwards waits for her to come by and chat with him. (Here is where the player would play intergalactic games of chance as he watches the extremely sexy and entertaining Miss Clairon. The player has to win the big jackpot to earn the favors of Miss Clairon from a kiss to getting into her private suite in the Casino.)

Upon winning a night with Miss Clairon, she, having cast her eye on two very large diamonds that are on Candide’s finger, praises them in so earnest a manner that they are in an instant transferred from his finger to hers.

The next day after feeling a little guilty about cheating on Cunégonde, Candide receives a love transmission from Cunégonde. Eager to get to Planet Venice, Candide boards a transport to Planet Portsmouth. When they arrive, a revolt breaks out among the masses and Candide bargains with the vessel’s skipper to transport him directly to Planet Venice.

After two days in Portsmouth, the skipper takes Candide and Martin to Planet Venice, passing Planet Lisbon along the way at which Candide trembles. Upon their arrival at Planet Venice, Candide goes in search of Cacambo at every inn and coffeehouse and among all the ladies of pleasure.

Candide perceives a young Theatin friar, Friar Giroflee, in the Piazza San Marco, with a girl under his arm and invites them to join him. The girl is Paquette, the chambermaid-turned-prostitute who gave Pangloss his deadly sex disease. Paquette tells Candide that a priest, her confessor, easily seduced her, giving her the deadly sex disease and obliging her to leave the castle some time after the Baron had kicked Candide out.

Candide and his friend Martin travel down the watery streets by gondola and arrive at the palace of the noble Pococurante where two pretty girls, neatly dressed, bring them chocolates. Candide walks into a large gallery, where he is struck with the sight of a fine collection of paintings and a library of rare books. After a fabulous dinner, Pococurante orders a concert.

Days turn into weeks at the palace and Candide and Martin enjoy being spoiled and pampered by virgins and soon-to-be ex-virgins, as no news of Cacambo’s arrival comes from the messengers.

One evening Candide and his attendant Martin go into their inn and sit down to have supper with some foreigners. A dark servant approaches the unsuspecting Candide, who realizes the man is Cacambo. Cacambo tells him that Cunégonde is on Planet Constantinople. The foreigners had come to spend the Carnival in Planet Venice and were in fact six dethroned Kings: Achmet III the Grand Sultan, Ivan the Emperor of all the Russians, Charles Edward the King of England, two Kings of Poland, and Theodore the elected King of Corsica.

Aboard a king’s ship, Candide and Martin head for Planet Constantinople in search of Cunégonde and the old woman. On a fuel stop on a moon of Planet Bosphorus, Candide pays a high ransom for Cacambo’s freedom.

There are two slaves among the ship’s crew who seem very ill and to whose bare backs the master of the vessel frequently applies the electronic lash. Candide looks at these two slaves more attentively than at any of the rest, and their features, though greatly disfigured, appear to him to bear a strong resemblance to those of Pangloss and the unhappy Baron High Commander, Miss Cunégonde’s brother. He is correct and buys their freedom immediately.

The Baron of Thunder-ten-tronckh says that after Candide’s attack, he was attacked and carried off by a party of Spanish troops, who clapped him in prison on Planet Buenos Ayres. Master Pangloss claims that it rained extremely hard when they were to burn him. Since it became impossible to light the fire, they hung him because they could do no better. The executioner knew how to burn people very well, but as for hanging, he was a novice at it. A surgeon purchased his body, carried it home, and prepared to dissect it when he awoke.

Candide, the Baron, Pangloss, Martin, and Cacambo arrive on Planet Constantinople at the house of the Transylvanian prince on the shores of the Propontis. There they see Miss Cunégonde and the old woman, who are hanging some tablecloths on a line to dry. The fair Cunégonde is all sunburned, with bleary eyes, a withered neck, wrinkled face and arms, all covered with a red scarf. Candide advances toward her out of good manners. She embraces Candide and her brother. They embrace the old woman, and Candide ransoms them both.

Cunégonde, not knowing that she has grown ugly, as no one has informed her of it, reminds Candide of his promise and that she still wears his locket in so peremptory a manner that the simple lad dares not refuse her; he then informs the Baron that he is going to marry his sister.

The Baron becomes furious again so Martin decides to throw the Baron into the sea. Cacambo concludes that the Baron must be delivered in chains back to the Turkish captain and sent to the galleys.

Candide and the six dethroned kings raise an armada and travel to the planet of Westphalia to reclaim the throne and castle rightfully belonging to Cunégonde and her heirs. (Another huge battle between the Bulgarians and Candide’s forces. All of the Bulgarians on Planet Westphalia must be destroyed.)

Upon winning the battle and establishing territories for the six dethroned kings, Candide marries his mistress Cunégonde. Their children are taught the philosophies of Master Pangloss—that this world is “the best of all possible worlds.”

Living in the rebuilt palace with their own wing is the philosopher Martin, the prudent Cacambo, and the old woman.

One day two old acquaintances, Pacquette and Brother Giroflee, arrive and are in the utmost distress. The couple had parted, been reconciled, quarreled again, been thrown into prison, had made their escape, and at last Brother Giroflee had turned atheist. Candide hires them as servants, and Pacquette continues to follow her trade; but she gets little or nothing for it.

Candide spends his days with Cacambo and finds the pleasures of cultivating his gardens.

Candide 2517 contains the essential elements that players enjoy and desire in a game. Candide 2517 has adventure, lost treasures and planets, intergalactic fighting in “twitch” and strategy modes, and numerous paths to journey to get to the final victory. Thanks to Voltaire, Candide 2517 has a rich and colorful storyline with exciting and interesting characters. The psuedo-license of Candide and the Land of El Dorado as seen in the hit Disney film The Road to El Dorado will attract the mass market.

On September 11, 2001, America was shocked out of its blind optimism by the attacks. Voltaire and Candide is more in the public eye because of these terror attacks. Voltaire’s Candide asks audiences to question why the world is like it is and makes people think how we can make it a better place for everyone.


Chapter 18: The Design Document

The Design Document is the designer’s entire vision spelled out in detail, which includes all of the storyline, character dialog, world maps, city views, and room specifications with sample wallpaper, artwork, and rug designs, audio content for background or ambient sounds, sound effects and character dialog (with accents and speech patterns), programming, and AI considerations. This document is often called the “Design Bible,” since it is the document written by the designer for the entire team to follow, including the programmers (game and engine, technical programmers), the artists (both scenery and character artists), audio specialists (composer, special effects, background sound engineers, ADR and Foley specialists), and game testers. The concept is “if something exists in the game, it must appear and be described in the Design Document.” It is the common point of reference that the entire team understands and follows to create the designer’s vision. It is from this document that programmers (usually the lead programmer or technical director) and the artist (usually the head artist) refer to when documenting the technical spec (or specification), which explains in detail the in-depth technical issues of all the game code, the engine code, and the artwork and audio files (describing the file’s name, size, and description).

Background

In late May 2001 I met with Phantom EFX in Iowa to discuss a follow-up game to Reel Deal Slots. My previous “casino” games included products from Villa Crespo Software, such as video poker (Stanford Wong Video Poker and Dr. Wongs Jacks+), black jack (Dr. Thorp’s Black Jack), craps, roulette, and poker (Amarillo Slim’s Dealer’s Choice, 7 Card Stud, and Ruckus Poker). The meeting determined that the product was to be a poker game, and some basic game design issues were discussed and written down.

In June 2001 the project was underway as design, programming, and artwork progressed concurrently. The distributors wanted a Christmas product, and that meant a mid- to late-August deadline (a gold master reproduced and boxed by the end of August). That was a 12-week project life cycle. My friends in the industry laughed when I chatted with them about the project, claiming that the time needed to complete a game of this size was six to twelve months.

This case is not (I repeat not) the usual project life cycle. Several important issues had to be done to meet these critical deadlines, such as numerous daily meetings in the beginning to flesh out the game design, total control of the project by the programmer (me), and working six to seven days a week, ten to sixteen hours a day. Needless to say, the official design document was never written. The design discussed daily was written down, and artwork submitted to programming had to be documented (filename, screen positions, file format).

The project shipped on time with a few items dropped from the design document and the Internet component placed in the first patch (downloadable update). In the design document of Reel Deal Poker Challenge in this chapter, I note the design originally planned, and in brackets (“[this was dropped from the game because…]”) I discuss issues and reasons for changes, later implementations, or dropping the issue from the game.

I have often read articles and books on game design that discuss game design documents in theory. In this chapter I show you in detail what goes into a game design document. This document is provided as a tutorial so you can start with this template and create your own, much better design documents for your visions—the games of the future.

Click To expand


Reel Deal Poker Challenge Design Document

PUBLISHER: | PHANTOM EFX
GENRE: | CASUAL GAME WITH ADVENTURE ELEMENTS
PLATFORM: | WINDOWS 98/2K/Me/XP WITH DIRECT X 8.0
DESIGNERS: | (Alphabetic order)
 | Roger E. Pedersen
 | Aaron Schurman
 | Danny Stokes
 | Marty VanZee

Table of Contents

Overview

Rules of Poker

  • Hand Rankings

  • Poker Variations

Start of the Game (or After the Game Icon Is Clicked on)

  • The Cashier’s Cage

  • VIP Register

The Lobbies

Prize Vault

Audio

Artwork

  • Lobbies

    • General

  • Poker Rooms for Four and Eight Players

    • First and Second Floor Card Icons

    • Third Floor Card Icons

    • Tournament

      • Tournament Information

      • Tournament Place Finished

    • First Floor

      • Lobby

      • Poker Room

        • Four Player

        • Eight Player

      • Tournament Room

        • Four Player

    • Second Floor

      • Lobby

      • Poker Room

        • Four Player

        • Eight Player

      • Tournament Room

        • Four Player

    • Third Floor

      • Lobby

      • Poker Room

        • Four Player

        • Eight Player

      • Tournament Room

        • Four Player

    • Special Floor

  • Poker Four Player

    • First Floor: Roman Motif

      • Yvette

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

    • Sven

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

    • Hoyt

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

  • Second Floor: Oriental Motif

    • Melvis

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

    • Jacqueline

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

    • Mortimer

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

  • Third Floor: Egyptian Motif

    • Lizzie

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

    • Qiangsheng (aka “Q”)

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

    • Lou

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

  • Special Floor: World Championship Poker Room

    • Trevor

      • Profile

      • Poses

      • Mouth Animations

      • Animated Eyes

    • Trevor has been beaten (Red Dress Dance)

    • Eight Player Characters

    • Cards

      • Whole Cards

      • Discarded Cards

      • No Alpha Round Cards

      • Fake Drop Round Cards

      • Fake Drop Shadow Cards

Cashier’s Cage

VIP Casino Card

VIP Clipboard

Cashier’s Cage

Credit Screen

Statistics Screen

The Prize Vault

Chips

Tournament First Prizes

Floor 1 $5,000 Tournament Prizes

Floor 1 $25,000 Tournament Prizes

Floor 2 $25,000 Tournament Prizes

Floor 2 $100,000 Tournament Prizes

Floor 3 $100,000 Tournament Prizes

Floor 3 $500,000 Tournament Prizes

Special Floor $2,500,000 World Championship

Exit Game

Betting/Raising

Scriptwriting

Yvette

Sven

Hoyt

Melvis

Jacqueline

Mortimer

Lou

Q

Lizzie

Trevor

Cashier, Bouncer, and Manager

Programming

Basic Poker AI

The AI to Determine the Best Poker Hand Using Five to Seven Cards

Draw Poker (No Openers and Jacks or Better to Open)

Five Card Stud

Seven Card Stud, Chicago Lo, and Chicago Hi

Texas Hold ’Em and Omaha

Game Variations: Order of Play

Draw Poker No Openers and Jacks or Better to Open

Five Card Stud

Seven Card Stud, Chicago Lo, and Chicago Hi

Texas Hold ’Em

Omaha


Overview

Reel Deal Poker Challenge takes place in the Poker Palace where players from each level’s lobby enter the cashier cage, the slot room, the poker room, or the poker tournament room.

The goal of Reel Deal Poker Challenge is to advance through each of the three levels by winning tournaments and finally beating the World Champion in a winner-takes-all showdown.

Poker game variations available are Draw Poker, Draw Poker with Jacks or Better, Five Card Stud, Seven Card Stud, Chicago High, Chicago Lo, Omaha, and Hold ’Em. (Omaha, a variation of Texas Hold ’Em, was added due to its Internet and casino popularity.)

Based on the successful features from Reel Deal Slots and Video Poker, Reel Deal Poker Challenge will incorporate two addictive features, such as the Prize Vault and “VIP” player areas.

Players enjoy guessing what prizes they can win and gaining prizes in their “prize vault,” as well as earning the right to have access to upper levels where there are better players and higher stakes. The Internet play through the Game Spy site will allow players (up to eight) to play a selected poker variation and increase their chip inventory against other human players.

Each room and lobby will have its own unique theme from “Oriental” to “Roman” to “Egyptian” accompanied by ambient (background) music in the lobby and in each room.

The slot room will be an extension to the Poker Palace to show off (and gain sales for the slot game) and increase the player’s chip inventory.

(Although the players could enter the slot room and play several slot games, the money lost or won in the slot room is not added to the player’s chip inventory. The prior product written in Linux and Windows under a different compiler using a special library for graphics and sound combined with the extremely short development cycle made this feature a low priority. Finally, it was implemented as a separate room with an “order this great product” screen before returning to the Poker Palace lobby. These are the realities that separate a design document and your vision versus getting the product on the shelf in the time required—usually beyond most of the team’s control.)


Rules of Poker

Poker is played by using a single deck of 52 cards. The deck has four suits: clubs §, diamonds ¨, hearts ©, and spades ª. Each suit has 13 cards ranked two through ten, jack, queen, king, and ace (the ace can be the highest or lowest card).

Poker games always begin with a shuffle to randomly sort the deck. A brand new deck always has the 52 cards in suit and rank order.

Hand Rankings

The following examples are in ranking order, meaning the best hand has a ranking of one and the worst hand is of rank ten.

Rank | Hand Name | Description of Hand | Example
1 | Royal Flush | A, K, Q, J, 10 of same suit | 10ª, Jª, Qª, Kª, Aª
2 | Straight Flush | Five same-suit consecutive cards | 4¨, 5¨, 6¨, 7¨, 8¨
3 | Four of a Kind | Four cards of the same rank | 7ª, 7§, 7¨, 7©, 6©
4 | Full House | Three of a kind plus a pair | 3¨, 3ª, 3§, Kª, K©
5 | Flush | Five cards of the same suit | 3©, 7©, 10©, Q©, A©
6 | Straight | Five cards in sequence | 5§, 6¨, 7§, 8©, 9ª
7 | Three of a Kind | Three cards of the same rank | J©, Jª, J¨, 8©, 9ª
8 | Two Pair | Two pairs of different rank | 5©, 5ª, 9§, 9ª, 8©
9 | One Pair | Two cards of the same rank | Aª, A¨, 2©, 4¨, 8ª
10 | High Card | None of the other rankings | Kª, 2¨, 4ª, 6©, 8¨

Poker Variations

Poker has many variations with each variation having its own rules. The more popular poker variations are Draw Poker, Five Card Stud, Seven Card Stud, Chicago Hi, Chicago Lo, Texas Hold ’Em, and Omaha. Most poker variations can be played with two to eight players. The cards are shuffled and distributed by a player called the dealer. In all variations, the first card is given to the player to the left of the dealer. A round of betting consists of each player deciding whether he should bet (or raise after the first bet was made) an amount from the group’s agreed-to minimum to maximum, fold (quit this round of play), or check (agree to cover the current amount due to the pot). When three raises to the original bet have been made or all players have checked, the betting round is completed.

In Draw Poker, all players make a small blind bet or ante before receiving any cards. Then the players, starting with the player left of the dealer, receive cards until each player has five cards. Players carefully look at their cards and determine which cards to keep and which cards to discard. Players can discard up to three cards (or four cards if they are keeping an ace). Before discarding, each player may bet or raise, fold (quit this round of play), or accept the current bet amount (check). Then the remaining players discard their cards. Another round of betting occurs where each player can bet, fold, or check. After all players have checked or three raises have occurred, the players must show their cards; the player with the highest hand wins the pot (all bets made). If only one player remains (no showdown), he wins and his cards can remain unexposed.

One variation of Draw Poker that is commonly played is Draw Poker Jacks or Better, where to open the first round of betting the player needs a pair of jacks or better (a better ranking like three of a kind) to bet. This lets the other players know the player has a hand with a pair of jacks or better. If no player can bet (no hand has at least a pair of jacks), the cards are reshuffled and a new round begins (ante and all). This variation can make the pot quite large with antes and the bets of players with bad hands who fold earlier.

Five Card Stud is a variation where each player receives their first card face down (called the “hole”), the next three cards are dealt face up, and the last card is dealt face down. The player to the left of the dealer receives the first card. The player with the lowest first card must bet the minimum. Some variations have all players at the start ante up (a small bet). After all players have received their up cards (cards three and four), a round of betting occurs. Then after the fifth card (a down card) has been received by all players, the last round of betting occurs. In each betting round after the first, the player with the highest-ranking hand showing (only the up cards) starts the betting process. If only one player remains, he wins the pot and his cards can remain unexposed. Otherwise, the remaining players show all five cards and the player with the highest ranking hand wins the pot.

Seven Card Stud is a variation where the first two cards are dealt face down (the “hole”) and the third card is dealt face up. On the first card up, the player with the lowest up card must make the minimum bet. Each player must either bet (raise), fold, or check. After the first round of betting, the player with the highest ranking hand of shown cards opens the betting round. The cards four through six are dealt face up, and after all players have received that round’s card, betting occurs. The last card (the seventh card) is dealt face down unless in an eight-player game all eight players remain, and then the last card is dealt as a community card (shared by all players). If only one player remains, he wins (no showdown) and his cards may be left unexposed. Otherwise, all remaining players must show their cards, and the player with the highest-ranking hand wins the pot. If more than one player has the highest-ranking hand, they split the pot or the player with the highest suit wins. The suit order is usually spades (the highest), hearts, diamonds, and clubs (the lowest).

Chicago Hi plays exactly like Seven Card Stud, except the player with the highest spade in the “hole” splits the pot. The ace of spades is the highest card. If the last card (seventh card) is a community card, it cannot be used as a “hole” card.

Chicago Lo plays exactly like Seven Card Stud, except the player with the lowest spade in the “hole” splits the pot. Players must decide whether the ace of spaces is the lowest card or the two (deuce) of spades is the lowest. If the last card (seventh card) is a community card, it cannot be used as the “hole” card.

Over the last few years, Texas Hold ’Em and Omaha have become popular variations.

Many of the top poker players consider Texas Hold ’Em to be the most challenging and sublime of all the poker games. Texas Hold ’Em is the game played to determine the undisputed champion at the World Series of Poker at Binion’s Horseshoe in downtown Las Vegas.

Texas Hold ’Em is a seven-card poker game where each player receives two down cards and the remaining five cards are called “community cards,” which are shared by all of the players. Each player must make his best five-card poker hand using five out of the seven cards (his two cards plus the five community cards). After the two down cards have been dealt to all of the players, the player to the left of the dealer must make a small blind bet. Then a round of betting occurs where each player must bet (raise), fold, or check. Then five cards are placed face down in the center as community cards. The middle three community cards (the “flop”) are turned over (face up) and another round of betting occurs. Then the first community card (the “turn” card) is flipped over (face up) and another betting round occurs. Finally, the fifth community card (the “river”) is turned over (face up) and the final round of betting occurs.

If more than one player remains, the player with the highest ranking hand wins the pot. Any combination of the player’s own two down cards and the five community cards can be used to make the best five-card poker hand. The pot is split if a tie occurs.

Omaha is a form of Texas Hold ’Em that is very popular in casinos and on “poker night.” Omaha is a nine-card poker variation where each player is dealt four down cards and the remaining five cards are dealt face down as community cards (for all players to use). Each player must create the best ranking poker hand by using two of his four cards plus three of the five community cards (Omaha players often say “Two from the hand, three from the board”). Just like in Texas Hold ’Em, after the first four cards are dealt, the player to the left of the dealer must make a small blind bet. Then the players must bet (raise), fold, or check. The middle three community cards are turned face up, and another round of betting occurs. The first community card is flipped, and another round of betting occurs. The last, fifth, community card is turned over, and the last round of betting occurs. The players remaining show their cards, and the player with the best ranking poker hand wins the pot.


Start of the Game (or After the Game Icon Is Clicked on)

The Cashier’s Cage

Players start their first game in the cashier cage, where they must register to proceed into the lobby. In the cashier’s cage, players can turn on or off the four-player poker room’s character comments, turn on or off ambient sound (background music), look at their statistics for each poker variation (should I call if I’m only holding a pair of aces in Draw Poker?), register as a player and get their name and unique ID number on their VIP Casino Card, or see the credits (the people who worked night and day to provide you with this fine entertainment).

The cashier’s cage

VIP registration

VIP Register

The VIP registration screen has several required fields that must be entered before proceeding to play the game, such as the player’s title (Mr., Mrs., or Ms.), the player’s first and last name (two separate entered fields), and the player’s birthday (month and day as two digits). Optional fields are the player’s address, city, state, and zip code (allow up to ten digits). “CANCEL” will clear all fields, and “DONE” will check the required fields for completeness and validity (the birth date check will validate the day based on the month—i.e., making 04/31 an invalid date). This screen matches the previous product’s screen where there is a method for customers to register their product, sending the publisher their mailing information contained on this screen. [This feature of downloading the registration was not implemented by the publisher.]

The entry of “Mr.” and “Mrs.” or “Ms.” flags the return “Welcome” verbal greeting of “Nice to have you back, (Sir or Miss)” and “Play well, (Sir or Miss),” which adds a nice touch to the game (How did it know?).

The last player to play the game is the player that the game assumes is playing. If not, the new or returning player must indicate so.

In the cashier’s cage players can request additional funds when they are below the highest floor allowed or minimum tournament entry fee.

If the player is only allowed on the first floor and his current chip inventory is below $250, he can receive an additional credit of $2,500. The credit is added to his current chip inventory and the credit is noted in his casino record (see the “Statistics Screen” section).

If the player is only allowed on the first or second floors and his current chip inventory is below $1,250, he can receive an additional credit of $5,000. The credit is added to his current chip inventory and noted in his casino record (see “Statistics Screen”).

If the player is allowed on all three floors and his current chip inventory is below $5,000, he can receive an additional credit of $25,000. The credit is added to his current chip inventory and the credit is noted in his casino record (see “Statistics Screen”). Otherwise, the player is given a sound bite of “Your account balance is not low enough to receive additional funds.”

The “cash” area displays the player’s current chip inventory in dollars and reputation points earned by participating in poker tournaments.

Player has registered

Prize vault birthday celebration
Click To expand

The birthday in this game will be utilized on the Prize Vault by giving the birthday player a present (a birthday cake plus a $100 chip).


The Lobbies

There are three lobbies and a special level to play the World Champion in a winner-takes-all poker battle.

The first floor’s motif is based on the Roman era with Roman Doric columns, wooden carved doors, and a mirrored ceiling reflecting the plush Corinthian rug.

Click To expand

The second floor sends the player into the Orient where Ming vases shoot out spirals of flames, lighting up the walls of famous works of art from the Han dynasty. The floor is cushioned by a rare Oriental rug under a simplistic wooden ceiling.

Click To expand

The third floor transports the player to the edge of the Nile, where pharaohs once ruled and the players enjoy visions of authentic Egyptian hieroglyphics, rare Egyptian doors from the throne of King Tutankamen, and an exotic rug from the temple of Cleopatra. The symbol of Ra, god of the sun appears as the wall torches flicker, adding to the illumination of the magnificent array of constellations that shine through the high glass ceiling.

If a player hasn’t earned enough reputation points to enter the elevator to the next floor, a security guard blocks the entrance to the elevator.

Click To expand


The Prize Vault

The Prize Vault (or the trophy room) is where players store their first place tournament prizes. There are 15 prizes to be placed in the Prize Vault. Winning them and discovering what they are is an addictive part of the fun (as experienced from the previous product Reel Deal Slots and Video Poker). There is only one of each type of prize to win (prizes once earned cannot be removed). If a prize is clicked on, its description and a larger picture of that prize appears on the screen.

If the date is between seven days before the player’s birthday and seven days after that date, the happy birthday cake and message will appear. Only the first time will a $100 chip be given as a birthday present (mark “Chip Given” and Year).


Audio

  • All voice-over audio recorded

  • Floor 1 (Roman) Ambience (Background Music): Several to be intermixed and not repetitive

  • Floor 2 (Oriental) Ambience (Background Music): Several to be intermixed and not repetitive

  • Floor 3 (Egyptian) Ambience (Background Music): Several to be intermixed and not repetitive

  • Special Floor Ambience (Background Music): Several to be intermixed and not repetitive

  • Player input sound effects for actions such as a button press or a mouse click

  • Ambience (Background Music) for the other rooms on each floor such as the Cashier’s Cage, the Elevator (arriving and exiting sounds), the Poker Room, the Tournament Room, the Prize Vault, and entering the Slot Room

  • In-game sounds for card flipping, chip click when thrown on the table, chip rake when gathering your winnings, and a shuffle sound

  • Music for winning a tournament and credits screen


Artwork

As a designer, your job (to the best of your knowledge) is to list all the needed artwork and the vision you have of your game to the artists. But they have to see the same vision you do. Since this is an internal design document and not a product for sale, provide detailed photographs and pictures of your world from any source. Borrow from the Internet, scan photos from books and magazines, and get on paper the closest visual to what you are envisioning as possible.

Lobbies

General

Multiplayer button and Multiplayer Mouse Over

Next Level Congratulations

Poker Rooms for Four and Eight Players

Bet indicator | Marks the player who initially started the betting
Deal indicator | Marks the player who is dealer

First and Second Floor Card Icons

IconG5carddraw | Icon on green table for Five Card Draw Poker
IconG5carddrawjb | Icon on green table for Five Card Draw Poker Jacks or Better
IconG5cardstud | Icon on green table for Five Card Stud Poker
IconG7cardstud | Icon on green table for Seven Card Stud Poker
IconGChicagoHi | Icon on green table for Chicago Hi Poker
IconGChicagoLow | Icon on green table for Chicago Lo Poker
IconGOmaha | Icon on green table for Omaha Poker
IconGTexasholdEm | Icon on green table for Texas Hold ’Em Poker

Third Floor Card Icons

IconB5carddraw | Icon on blue table for Five Card Draw Poker
IconB5carddrawjb | Icon on blue table for Five Card Draw Poker Jacks or Better
IconB5cardstud | Icon on blue table for Five Card Stud Poker
IconB7cardstud | Icon on blue table for Seven Card Stud Poker
IconBChicagoHi | Icon on blue table for Chicago Hi Poker
IconBChicagoLow | Icon on blue table for Chicago Lo Poker
IconBOmaha | Icon on blue table for Omaha Poker
IconBTexasholdEm | Icon on blue table for Texas Hold ’Em Poker

Tournament

Click To expand

A tournament is a four-player game for a preset “entry fee” where the winner gets an additional money prize and in some rooms a “prize” to be added to their Prize Vault (or trophy room). All players keep their winnings. Early exiting from the room forfeits the “entry fee.” Reputation points needed to advance to the other floors are gained by participating in tournaments. The player with the most money after 20 hands of poker (any variation but only one per tournament) wins.

Tournament Information

Floor | Level | Next Floor Points | Ante Min | Ante Max | Entry Fee | VIP Points (1st-4th)
1 | 1 | 100 | $20 | $50 | $1,000 | 15, 10, 5, 3
 | 2 | 100 | $50 | $200 | $5,000 | 25, 20, 10, 5
 | 3 | 100 | $250 | $1,000 | $25,000 | 35, 25, 15, 10
2 | 1 | 1100 | $50 | $200 | $5,000 | 150, 100, 50, 30
 | 2 | 1100 | $250 | $1,000 | $25,000 | 250, 200, 100, 50
 | 3 | 1100 | $1,000 | $5,000 | $100,000 | 350, 250, 150, 100
3 | 1 | 1100 | $250 | $1,000 | $25,000 | 1500,1000, 500, 300
 | 2 | 1100 | $1,000 | $5,000 | $100,000 | 2500, 2000, 1000, 500
 | 3 | 1100 | $5,000 | $20,000 | $500,000 | 3500, 2500, 1500, 1000
4 | 1 | 0 | $20,000 | $50,000 | $2,500,000 |

Tournament Place Finished

Click To expand
Click To expand

First Floor
Lobby

RomanLobby | The first floor’s lobby
RomanBouncer | The bouncer in front of the elevator
RomanBouncerText | The bouncer’s text when accessing the elevator
RomanCashMO | Enter the cashier’s cage mouse over
RomanElevUpMO | Access the elevator up mouse over (first floor)
RomanExitMO | Exit the game (and save) mouse over
RomanGrandMaster | Enter the Grandmaster button (play Trevor) Only displayed when player has enough reputation points to access the “Special Floor” and has not played Trevor yet
RomanGrandMasterMO | Enter the Grandmaster button mouse over
RomanPokMO | Play the non-tournament Poker Room mouse over
RomanPrizeMO | Enter the Prize Vault mouse over
RomanSlotsMO | Enter the Slot Machine Room mouse over
RomanTournMO | Play in a poker tournament mouse over

Poker Room

Click To expand
Four Player

Roman Table

Roman Deal normal, mouse over, on click buttons

Roman Lobby normal, mouse over, on click buttons

Roman Stats Screen normal, mouse over, on click buttons

Profiles Turn On and Turn Off buttons

Profile Exit normal and mouse over button

Eight Player

Roman Table

Roman Deal normal, mouse over, on click buttons

Roman Lobby normal, mouse over, on click buttons

Roman Stats Screen normal, mouse over, on click buttons

Tournament Room

Four Player

Roman Table

Roman Deal normal, mouse over, on click buttons

Roman Lobby normal, mouse over, on click buttons

Roman Stats Screen normal, mouse over, on click buttons

Profiles Turn On and Turn Off buttons

Profile Exit normal and mouse over button

Second Floor
Lobby

OrientalLobby | The second floor’s lobby
OrientalBouncer | The bouncer in front of the elevator
OrientalBouncerText | The bouncer’s text when accessing the elevator
OrientalCashMO | Enter the cashier’s cage mouse over
OrientalElevUpMO | Elevator up mouse over (to third floor, if able)
OrientalElevDownMO | Elevator down mouse over (to first floor)
OrientalExitMO | Exit the game (and save) mouse over
OrientalGrandMaster | Enter the Grandmaster button (play Trevor)
OrientalGrandMasterMO | Enter the Grandmaster button mouse over
OrientalPokMO | Play the non-tournament Poker Room mouse over
OrientalPrizeMO | Enter the Prize Vault mouse over
OrientalSlotsMO | Enter the Slot Machine Room mouse over
OrientalTournMO | Play in a poker tournament mouse over
LeftPot | Animation of fire spiraling out of the left pot
RightPot | Animation of fire spiraling out of the right pot

(Programming note: Offset the two pots’ spiraling fire so they look more natural.)

Poker Room

Click To expand
Four Player

Oriental Table

Oriental Deal normal, mouse over, on click buttons

Oriental Lobby normal, mouse over, on click buttons

Oriental Stats Screen normal, mouse over, on click buttons

Profiles Turn On and Turn Off buttons

Profile Exit normal and mouse over button

Eight Player

Oriental Table

Oriental Deal normal, mouse over, on click buttons

Oriental Lobby normal, mouse over, on click buttons

Oriental Stats Screen normal, mouse over, on click buttons

Tournament Room

Four Player

Oriental Table

Oriental Deal normal, mouse over, on click buttons

Oriental Lobby normal, mouse over, on click buttons

Oriental Stats Screen normal, mouse over, on click buttons

Profiles Turn On and Turn Off buttons

Profile Exit normal and mouse over button

Third Floor
Lobby

EgyptianLobby | The third floor’s lobby
EgyptianBouncer | The bouncer in front of the elevator
EgyptianBouncerText | The bouncer’s text when accessing the elevator
EgyptianCashMO | Enter the cashier’s cage mouse over
EgyptianElevUpMO | Elevator up mouse over (to third floor, if able)
EgyptianElevDownMO | Elevator down mouse over (to first floor)
EgyptianExitMO | Exit the game (and save) mouse over
EgyptianGrandMaster | Enter the Grandmaster button (play Trevor)
EgyptianGrandMasterMO | Enter the Grandmaster button mouse over
EgyptianPokMO | Play the non-tournament Poker Room mouse over
EgyptianPrizeMO | Enter the Prize Vault mouse over
EgyptianSlotsMO | Enter the Slot Machine Room mouse over
EgyptianTournMO | Play in a poker tournament mouse over
LeftTorch | Animation of fire flickering from the left torch
RightTorch | Animation of fire flickering from the right torch

(Programming note: Offset the two torches’ flickering fire so they look more natural.)

Poker Room

Click To expand
Four Player

Egyptian Table

Egyptian Deal normal, mouse over, on click buttons

Egyptian Lobby normal, mouse over, on click buttons

Egyptian Stats Screen normal, mouse over, on click buttons

Profiles Turn On and Turn Off buttons

Profile Exit normal and mouse over button

Eight Player

Egyptian Table

Egyptian Deal normal, mouse over, on click buttons

Egyptian Lobby normal, mouse over, on click buttons

Egyptian Stats Screen normal, mouse over, on click buttons

Tournament Room

Four Player

Egyptian Table

Egyptian Deal normal, mouse over, on click buttons

Egyptian Lobby normal, mouse over, on click buttons

Egyptian Stats Screen normal, mouse over, on click buttons

Profiles Turn On and Turn Off buttons

Profile Exit normal and mouse over button

Special Floor

Click To expand

Boiler Room Table

Boiler Room Deal normal, mouse over, on click buttons

Boiler Room Lobby normal, mouse over, on click buttons

Boiler Room Stats Screen normal, mouse over, on click buttons

Profiles Turn On and Turn Off buttons

Profile Exit normal and mouse over button

Four-Player Poker Characters

First Floor: Roman Motif Four

Yvette
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Yvette’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” “uh,” and a smile)

Click To expand
Animated Eyes

For each of Yvette’s poses, the eyes should blink, look mad, smile, and open wide.

Sven
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Sven’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” and “uh”)

Click To expand
Animated Eyes

For each of Sven’s poses, the eyes should blink, look mad, and open wide.

Hoyt
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Hoyt’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” “uh,” and a smile)

Click To expand
Animated Eyes

For each of Hoyt’s poses, the eyes should blink, look mad, half-open, and open wide.

Second Floor: Oriental Motif

Melvis
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Melvis’ poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” “uh,” a smile, and a sneer—of course!)

Click To expand
Animated Eyes

For each of Melvis’ poses, the eyes should blink, look mad, brow up, left brow up, and right brow up.

Jacqueline
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Jacqueline’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” “uh,” and a smile)

Animated Eyes

For each of Jacqueline’s poses, the eyes should blink, look mad, smile, and open wide.

Mortimer
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Mortimer’s poses (“ah,” “ee,” “eh,” “mm,” “oh,” “oo,” “sah,” “seh,” “smm,” “soh,” and a smile)

Click To expand
Animated Eyes

For each of Mortimer’s poses, the eyes should blink, look mad, smile, and open wide.

Third Floor: Egyptian Motif

Lizzie
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Lizzie’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” “uh,” and a smile)

Animated Eyes

For each of Lizzie’s poses, the eyes should blink, look mad, and open wide.

Qiangsheng (aka “Q”)
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Qiangsheng’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” “uh,” and a smile)

Animated Eyes

For each of Qiangsheng’s poses, the eyes should blink, look mad, and open wide.

Lou
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Lou’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” “pb,” and “uh”)

Animated Eyes

For each of Lou’s poses, the eyes should blink and look mad.

Special Floor: World Championship Poker Room

Trevor
Click To expand
Profile
Click To expand
Poses
Click To expand
Mouth Animations

Phonemes for each of Trevor’s poses (“ah,” “ee,” “eh,” “fv,” “mm,” “oh,” “oo,” and “uh”)—the World’s Best Poker Player doesn’t smile!

Animated Eyes

For each of Trevor’s poses, the eyes should blink, look mad, and look up.

Trevor has been beaten (Red Dress Dance)
TrevorEnd | Trevor dancing in a red dress animation (loops until Exit clicked)
Ending Background | Boiler Room Background

Close Ending Scene on click and mouse over

Click To expand
Click To expand

Eight-Player Poker Characters

Click To expand

Players (static 2D images)

Normal | Eye Open/Closed | Mouth Open/Closed | Extra Animation
Beth | BethEC | BethMO |
Carol | CarolEC | CarolMO | CarolWink
Carver | CarverEC | CarverMO |
Cathy | CathyEC | CathyMO |
Curly | CurlyEC | CurlyMO | CurlyTiltHead
Gerald | GeraldEC | GeraldMC |
Harry | HarryEC | HarryMO |
Hazel | HazelEC | HazelMO |
Lakisha | LakishaEC | LakishaMO |
Mark | MarkEC | MarkMO |
Meredith | MeredithEC | MeredithMO |
Mitch | MitchEC | MitchMC |
Thomas | ThomasEC | ThomasMO |

Cards

There are 52 cards (or one deck) in poker. There are four suits named clubs, diamonds, hearts, and spades (“alpha” order) with rankings from a two or deuce (low) to the ace (high). In a low game like Chicago Lo, the ace can be the lowest card or the highest card or both.

Click To expand

All cards are placed in racks for the four- and eight-player poker games.

Most casinos use the “reverse alpha” order to break ties, meaning that the best suit is a spade, followed by the hearts, diamonds, and clubs.

Click To expand

Whole Cards

The 52 card faces and the decorated back of the card are used as the “community cards,” cards shown in the middle of the table and used by all of the players such as center cards in Texas Hold ’Em, Omaha, and other variations if there are not enough cards left to play (Seven Card Stud with eight players needs 56 cards so the last card must be a “community card”).

Discarded Cards

Click To expand

In Draw Poker, the player may discard his unwanted cards in order to receive new replacement cards. The player clicks on the card (as a toggle On/Off) to turn the clicked-on card “gray,” meaning “to discard.” Since the game places the cards in a rack, the cards (all 52) need to be only half drawn.

No Alpha Round Cards

All 52 cards plus the back of the card, drawn half size since the cards are placed in a rack, are mainly used as the top-right card without a shadow.

Click To expand

Fake Drop Round Cards

All 52 cards plus the back of the card, drawn half size since the cards are placed in a rack, are mainly used as the “discarded” cards beneath another card.

Click To expand

Fake Drop Shadow Cards

All 52 cards plus the back of the card, drawn half size since the cards are placed in a rack, are mainly used as the cards beneath another card (not a discarded card).

Click To expand


Cashier Cage

VIP Casino Card

Fonta numbers 0 through 9

Fonta letters capital A through Z and lowercase a through z

VIP Clipboard

VIP Clipboard (see Registration screen)

Numbers 0 through 9

Letters capital A through Z and lowercase a through z

Symbols dash and slash

Back of first name, Back of last name, Back of address, Back of city, Back of state, Back of zip code, Back of birthday, Back of birth month

Cancel and Done on click buttons

Cashier Cage

Cashier Screen | The cashier cage screen
Player Name Area | Up to 20 previous players who registered
Cash Prestige Font | Numbers 0 through 9 for Cash and Reputation area
Lobby | To return to the Lobby (must be a registered player)
Credits | To honor those who have worked hard on this game
Register | To register to play in the casino
Additional Funds | An ATM in the casino, like calling your parents for money
Statistics | To view the playing statistics for each poker variation
Ambient Sound | To turn on or off the ambient music
Character Comments | To turn on or off the four-player verbal comments


Credit Screen

Credits

The staff that will produce the vision


Statistics Screen

Click To expand

Note: On chart, the Straight Flush (including a Royal Flush) and Flush will mark the high card in the winning hand. The flush winning hands will be indicated in the columns marked spades, hearts, diamonds, and clubs (“reverse alpha” order). The chart numbers reflect the winning hands from the currently registered player’s games (not just their winning hands) from all play in either the Poker Room or the Tournament Room.

  • Bookman Demi10 font numbers 0 through 9 (for chart)

  • Bookman Demi14 font numbers 0 through 9 plus the $ and “,” (for upper section)

  • Bookman Demi24 font letters capital A through Z and lowercase a through z (for player’s name)

    The statistics are saved and can be cycled through for each of the poker variations, such as Chicago Hi, Chicago Lo, Five Card Draw, Five Card Draw Jacks or Better, Five Card Stud, Texas Hold ’Em, Omaha, and Seven Card Stud.

  • Close normal, mouse over, and on click buttons

  • Left arrow normal and mouse over to scroll back through the poker variations

  • Right arrow normal and mouse over to scroll forward through the poker variations.


The Prize Vault

Click To expand

Lobby on click and Lobby mouse over to exit back to the Lobby.

Stat Screen on click and Stat Screen mouse to view the Statistics screen.


Chips

Chips are to be displayed for betting (click on a chip to bet that amount) and placed on the table in three varying positions to look randomly thrown.

Betting chips are to be valued from $1 to $5 million.

Click To expand

Table chips are to be valued from $1 to $5 million in three varying positions (one or two positions for the $50K to $5M chips).

Click To expand


Tournament First Prizes

Floor 1: $5,000 Tournament Prizes

Click To expand
Click To expand

Floor 1: $25,000 Tournament Prizes

Click To expand
Click To expand
Click To expand

Floor 2: $25,000 Tournament Prizes

Click To expand
Click To expand

Floor 2: $100,000 Tournament Prizes

Click To expand
Click To expand
Click To expand

Floor 3: $100,000 Tournament Prizes

Click To expand
Click To expand

Floor 3: $500,000 Tournament Prizes

Click To expand
Click To expand
Click To expand

Special Floor: $2,500,000 World Championship

Click To expand


Exit Game

  • “Yes” mouse over and on click buttons (save player’s game settings)

  • “No” mouse over and on click buttons


Betting/Raising

Click To expand

Clicking the left box for Open or Raise brings up the right box to enter the amount.

Check | On click and mouse over buttons
Fold | On click and mouse over buttons
Open | On click and mouse over buttons
Call | On click and mouse over buttons
Raise | On click and mouse over buttons
Cancel | On click and mouse over buttons
LED Font | Numbers 0 through 9
Right Arrow | On click and mouse over buttons
Left Arrow | On click and mouse over buttons
Chips | See Artwork: Chips to set Amount of Open or Raise Chipsvalues displayed are determined by the Min and Max betting amount set by the poker game amounts selected before entering the poker room.


Scriptwriting

For standard scripting format rules, see Chapter 14, “The Basics of Scriptwriting.”

[

3

4

6

]

[1234567890123456789012345678901234567890123456789012345678901234567890]

YVETTE

Wow! Good hand.

YVETTE

Oh, I like that.

YVETTE

Nice try.

YVETTE

Call.

YVETTE

I can’t lose.

YVETTE

Check.

YVETTE

Now, that’s a cute little card.

YVETTE

Did that feel good?

YVETTE

Fold.

YVETTE

I’m in, way in.

YVETTE

That’s the card I’m looking for.

YVETTE

Not good for me.

YVETTE

Oh, baby.

YVETTE

Pass.

YVETTE

Where did you pull that out of?

YVETTE

Show me yours and “huh” I’ll show you mine.

YVETTE

I suppose.

YVETTE

Sweet!

YVETTE

That was too close for comfort.

YVETTE

I wouldn’t pass this up for anything.

SVEN

(German stuff)

SVEN

I’ll be back.

SVEN

I can’t believe you don’t play now.

SVEN

Better luck next time.

SVEN

Call.

SVEN

I can’t believe it’s not better.

SVEN

Check.

SVEN

My day will come.

SVEN

Fold!

SVEN

I fold now.

SVEN

(German stuff) I’m in.

SVEN

Look at you, little girlie cards.

SVEN

Ha! Ha! Ha! (German stuff)

SVEN

I am triumphant!

SVEN

I’m in.

SVEN

I’m out.

SVEN

I’m liking these cards.

SVEN

Your money will be mine now.

SVEN

I must raise now.

SVEN

Nice cards there.

SVEN

Pass.

SVEN

Raise.

SVEN

Oh, (German stuff “Menee Guta”)

SVEN

(German stuff)

SVEN

Sure, why not.

HOYT

Bah.

HOYT

Call.

HOYT

Check.

HOYT

Doh!

HOYT

Fold.

HOYT

You gotta know when to fold ’em.

HOYT

Good job, buddy!

HOYT

Hmmm!

HOYT

I’m in the money! I’m in the money!

HOYT

I’m in.

HOYT

I’m there.

HOYT

Later tator.

HOYT

Not me.

HOYT

On to you, pal.

HOYT

Shazam!

HOYT

Doh, I knew I should have run.

HOYT

Well, spank my ass and call me Shirley!

HOYT

You stayed in with that?

HOYT

This must be my lucky day.

HOYT

This pot’s mine!

HOYT

Well, why not.

MELVIS

Ahhh...Yah

MELVIS

Baby!

MELVIS

Can’t love these cards.

MELVIS

Ah... You can’t treat the King like that.

MELVIS

Ah...Check baby!

MELVIS

Ah... That’s a hell of a clambake!

MELVIS

Foldin’.

MELVIS

I’m gonna call.

MELVIS

Ain’t nothin’ but a hound dog, baby.

MELVIS

Melvis has left the building!

MELVIS

Baby needs some blue suede shoes.

MELVIS

Ohh... nice hand there.

MELVIS

Oh mama!

MELVIS

Ouch, man!

MELVIS

Uh! huh huh!

MELVIS

Uh thank ya. Thank ya very much!

MELVIS

Oooh, ya baby!

MELVIS

You betcha!

JACQUELINE

Oh, you’ll do better next time.

JACQUELINE

Check!

JACQUELINE

That pot was only chump change anyway.

JACQUELINE

Can we play yet?

JACQUELINE

My daddy told me I can’t lose.

JACQUELINE

Daddy always said I could do it.

JACQUELINE

Hmmmmp!

JACQUELINE

I did it! I did it!

JACQUELINE

Sure, I have plenty.

JACQUELINE

Impressive!

JACQUELINE

Why won’t you let me win?

JACQUELINE

Hmm...Pass.

JACQUELINE

Daddy, I need more money.

JACQUELINE

I must fold now.

JACQUELINE

Never too rich for my blood.

JACQUELINE

Oooo!

JACQUELINE

I’ll see that and raise you.

JACQUELINE

You know what they say, the rich get richer.

JACQUELINE

Simply divine.

JACQUELINE

Sure, why not.

JACQUELINE

I want to win.

MORTIMER

Hee! Hee! Ain’t missing this opportunity.

Hee! Hee!

MORTIMER

(Chuckle)

MORTIMER

Eh...that’s what Daddy’s talking about.

MORTIMER

Don’t feel bad, it’s only money.

MORTIMER

In my day we ran from cards like this.

MORTIMER

But I’m feelin’ frisky.

MORTIMER

Now that’s a good return on investment.

MORTIMER

Yeah…Sure. What have I got to lose?

MORTIMER

Horse hockey!

MORTIMER

This isn’t worth a hill of beans.

MORTIMER

I’m in.

MORTIMER

I should’ve invested less.

MORTIMER

There goes my kids’ inheritance.

MORTIMER

I’m in for the long haul.

MORTIMER

Nice hand.

MORTIMER

In my day, we played with nickels.

And we were thankful for it.

MORTIMER

In my day, we never saw cards like these.

MORTIMER

Whoopee!

MORTIMER

Call.

MORTIMER

Check.

MORTIMER

Fold.

MORTIMER

Raise.

LOU

I was actually nervous.

LOU

Call.

LOU

Hey, I can’t win your money if we don’t play.

LOU

Fold.

LOU

Get out while you still can.

LOU

Oh, give it a shot.

LOU

Good cards, pal-ie.

LOU

Have fun spending my money.

LOU

Hell yeah!

LOU

I’m in.

LOU

Bet on.

LOU

No more for me.

LOU

Not me.

LOU

I’m out-ie.

LOU

Pass.

LOU

I can’t possibly lose.

LOU

Raise.

LOU

I’ll raise ya.

LOU

See ya!

LOU

Suckers!

LOU

Let’s sweeten the pot.

LOU

You talkin’ to me?

LOU

What were you thinkin’?

LOU

Check.

Q

Ha! Ha! Ha! I always win.

Q

I cannot beat that hand!

I could beat a weaker hand.

Q

Beginner’s luck.

Q

I do not believe in your bluff.

Q

Call.

Q

Ha ha ha! You cannot defeat me.

Q

Check.

Q

A cherry blossom knows when to fall.

I know when to get out.

Q

I do not want it.

Q

I will live to fight another day.

Q

Fold.

Q

Only a fool fights in a burning house.

Q

This pot is only half full.

Q

I’m in.

Q

Your cards are like sand, no substance.

Q

Observe the lotus blossom, it needs no

timekeeping.

Q

Our money must experience more togetherness.

Q

Pass.

Q

How long does it take one to learn patience?

Q

Raise.

Q

For everything there is a season.

This is not mine.

Q

I will see what happens.

Q

This hand cannot help but spill gold.

Q

Victory belongs to the honorable.

LIZZIE

Bingo! Wait, wrong game.

LIZZIE

How do you feel, taking my bus fare?

LIZZIE

Guess I’ll take the bus home.

LIZZIE

Check.

LIZZIE

That’s OK, sweetie, you deserve it.

LIZZIE

Fold.

LIZZIE

(Hiccup)

LIZZIE

See if you can keep up, sweetie.

LIZZIE

I’m kicking butt and taking names.

LIZZIE

How did you like that?

LIZZIE

Macy’s, here I come!

LIZZIE

This is sweeter than a Mai Tai.

LIZZIE

Maybe next time.

LIZZIE

Nice win.

LIZZIE

Oh, well.

LIZZIE

Okay.

LIZZIE

I’ll stay for one more card.

LIZZIE

Pass.

LIZZIE

Raise.

LIZZIE

Shame on you for pushing an old lady out.

LIZZIE

Wow! Squeaked that one out.

LIZZIE

How do you like that can of whup-ass?

LIZZIE

Too rich for my blood.

LIZZIE

Very nice.

LIZZIE

There goes my Wayne Newton ticket money.

LIZZIE

Yah! Why not?

TREVOR

Ahhh!

TREVOR

Hey, we don’t have all day.

TREVOR

Bad luck.

TREVOR

Check.

TREVOR

Count me in.

TREVOR

That didn’t turn out for me.

TREVOR

Fold.

TREVOR

Good deal.

TREVOR

You gotta pay to play.

TREVOR

Can you hang with me?

TREVOR

Hmm.

TREVOR

How did I miss that?

TREVOR

Sometimes, you need to know when to hold ’em.

TREVOR

Let’s see what happens.

TREVOR

Ah, maybe next time.

TREVOR

Nice job.

TREVOR

Nice play.

TREVOR

Winning this hand is not my destiny.

TREVOR

Pass.

TREVOR

Raise.

TREVOR

Today is a good day.

TREVOR

Nice hand!

But if you actually beat me,

I’ll put on a dress.

CASHIER

Your account balance is not low enough

to receive additional funds.

BOUNCER

Uhhhm, excuse me.

MANAGER

Welcome to Reel Deal Poker.

Please click the register button to continue.

MANAGER

Nice to have you back, sir!

MANAGER

Nice to have you back, miss!

MANAGER

Play well, sir!

MANAGER

Play well, miss!


Programming

An animation for each character in four-player mode is a combination of the character’s pose, the eye position, and the mouth position. A 0 (zero) for an eye or mouth animation means that the pose eye or mouth default is used; in other words, “don’t draw over the original eye or mouth if it’s a zero.”

YVETTE saying “Wow, good hand.”

{{pose 1, eye 3, mouth 0},{1, 7, 0},{1, 7, 5},{1, 1, 5},{1, 1, 5},
{1, 1, 5},{1, 1, 5},{1, 1, 5},{1, 1, 5},{1, 6, 5},{1, 7, 5},{1, 7, 5},
{1, 7, 0},{1, 3, 0},{1, 3, 0},{1, 3, 0},{2, 10, 0},{2, 6, 5},{2, 6, 5},
{2, 10, 5},{2, 3, 5},{2, 10, 5},{2, 1, 5},{2, 1, 5},{2, 1, 5},{2, 1, 5},
{2, 3, 5},{2, 9, 4},{2, 9, 4},{2, 9, 4},{2, 9, 4},{2, 9, 4},{2, 9, 4},
{2, 9, 4},{2, 9, 4},{2, 9, 4},{2, 9, 4},{2, 9, 4},{1, 5, 0}, {1, 5, 0},
{1, 5, 0},{1, 5, 0},{1, 5, 0},{1, 5, 0}}

For each character map (or associate), there are one to three phrases for actions such as “checking,” “raising,” “folding,” “calling,” “when they win a pot,” “when they lose a pot (randomly select a character),” “when they are bluffing (betting on an average hand),” and “taunting the player when a minute has gone by without any input.”


Basic Poker AI

The hand ranking is defined by a hand rank value, plus the highest card value. The hand rank values are for a royal flush 180, a straight flush is 160, four of a kind is 140, a full house is 120, a flush is 100, a straight is 80, three of a kind is 60, two pair is 40, a pair is 20, and a high card is 0.

All players are categorized as “conservative” or “not conservative” and “strong,” “average,” and “weak.”

The AI to Determine the Best Poker Hand Using Five to Seven Cards

  1. Flush—check to see if at least five cards are in the same suit.

  2. Straight—put cards in ascending order and check if there are five consecutive cards. (Reminder: Place the ace in the lowest and highest positions.)

  3. If flush and straight came out positive, we have a straight flush; check for ace high for royal flush.

  4. If we have found a straight or a flush hand, set its value and return.

  5. If nothing found so far, put the cards in rank order.

  6. Check each rank from the ace (high) to the deuce (two, low card).

  7. If one rank has four cards found, we have four of a kind; set its value and return.

  8. If one rank has three cards found, we have at least found the highest three of a kind hand (set value to trip.) Remember we could be examining seven cards.

    If another rank has at least two cards found, we have a full house (set value to a full house).

    On three cards of same rank found, set value to trip or full house and return.

  9. If one rank has a pair (two of the same rank), then we have at least found the highest pair (set value to a pair).

    If another rank has a pair, then we have a two pair hand (set value to two pair).

    On a pair found, value a two pair or pair value and return.

  10. We have only a high card, so set the value to the highest card and return.

Draw Poker (No Openers and Jacks or Better)

All analysis assumes an eight-player game, and the logic works for any amount of players.

  1. For strong players, don’t open betting in position one through four without a pair of aces or two pair with queens or better.

A pair of kings can open in positions five and six, while position seven can open with a pair of queens or jacks with ace kicker. The dealer who goes last needs a pair of jacks or better to open betting.

  1. In a high ante game, position one through three needs a pair of kings, position four through six needs a pair of queens, and the remaining positions need a pair of jacks to open betting.

  2. Against strong players, don’t “call” with less than two pair headed by at least a king. In last positions, seven or dealer, you can call with two pair.

  3. Against weak to average players, you can “raise” with a pair of aces or kings if you are alone with the opener and last in position.

  4. Don’t “raise” with opened straights or four flush cards, and only call if the pot yields four times your bet.

  5. “Raise” with trips (three of a kind) that are ten and below. “Call” with jacks or better before the draw to force players out or keep them in for the kill with the higher hands. Against strong players, you need strong cards to raise when they open. Against weak players (i.e., players who open with jacks or queens under the gun), you can raise aggressively when holding aces or kings.

    Any player who checks during the first bet round can only call bets thereafter in the first round.

In Draw Poker Jacks or Better, the computer will check each hand to see if the hand passes the Jacks or Better test. If no player has this requirement, each player must “check” and the hand is redealt (the ante up will increase). If the player folds or tries to “open” and the requirement has not been met by any player, the computer assumes a “check.” If the player (non NPC), has a pair of kings and “checks” and no other player has met the requirements, a new hand is dealt (the computer must not force the player to make an opening bet). In Draw Poker, a minimum starting bet or “ante” is made by each player before the first card is dealt. All cards are dealt face down, starting with the player to the left of the dealer. A player may discard up to three cards or four cards if they hold an ace (computer checks this situation) and receive replacement cards. Discarded cards are immediately reshuffled into the remaining deck after that player has received cards so that a player will never get his discarded cards back. If a player opens by betting or raises a bet, he cannot raise again, unless another player has raised. In all poker games, a maximum of three raises is allowed per betting session.

Five Card Stud

  1. If hand value is a royal flush, straight flush, or four of a kind, “bet” or “raise” the maximum amount and return.

  2. If hand value is a full house, flush, straight, or three of a kind (trip), “bet” or “raise” medium.

  3. If the hand value is only a high card and seeing the others up cards shows that you have the highest single card (no one has a pair or better showing)...

    • If asked to “check,” then check.

    • If you are to bet first and if it’s the first round of betting and you have an ace (conservative) or a ten (nonconservative), “bet” medium.

    • If after betting round one you have the highest card of at least a queen, “bet” medium (conservative) or maximum (nonconservative).

    • If you are not the first bettor (a bet has been made) and you have an ace (conservative) or a queen (nonconservative), “bet” maximum.

    • Otherwise, “call.”

    If a raise has been made, conservative players always “fold.”

    • Strong players “call” on betting round one and afterward; if they have the highest card showing or better, they “call;” otherwise, they “fold.”

  4. If you have no pair and not the highest hand showing and you are the first bettor...

    Conservative “folds.”

    Nonconservative...

    • If betting round is three, then “fold.”

    • If betting round is one or two, then...

      • With ace “bet” maximum.

      • With a queen or king “bet” medium.

    • Otherwise, “check.”

  5. If you have any pair on the opening bet round (first two cards) or any round a hand better than three of a kind...

    If the highest hand showing is better than your hand, on the last betting round “fold.”

    If first to “bet” and pair is...

    • Less than a pair of queens, “check.”

    • A pair of aces, “bet” maximum.

    • A pair of kings or queens, “bet” medium.

    • Two pair (remember the first pair may signal this code, so check to see if there’s a two pair hand) then “bet” maximum.

    Another player has bet and you have (a pair or better)...

    • A pair of aces or a better than a pair hand, then “bet” maximum.

    • Otherwise “check.”

    Another player has raised and your pair is...

    • Less than the highest hand showing and you are a strong player...

    • With queens or better then “call.”

    • Otherwise, “fold.”

  6. If you have a full house or better and raises made are less than three, then “raise” maximum.

    Otherwise, “call.”

Seven Card Stud, Chicago Lo, and Chicago High

Special Case for Chicago High

One of your first two cards is a spade.

  • You have the ace of spades; therefore you can’t lose, so “bet” maximum.

  • You have the highest spade since any higher ones are shown, so “bet” maximum.

  • You have the king of spades, so “bet” medium.

  • You have the next highest spade since any next higher ones are shown, so “bet” medium.

  • If the spade you have is within three ranks of the highest spade not showing then...

    • If no raises, then “call.”

    • If raise was made, then “check.”

  • If you are to bet and...

    • If the spade you have is within four ranks of the highest spade not showing, then “bet” minimum.

    • If the spade you have is within nine ranks of the highest spade not showing, then “check.”

Otherwise, follow steps one through six.

Special case for Chicago Lo

  • One of your first two cards is a spade.

    • You have the ace of spades; therefore you can’t lose, so “bet” maximum.

    • You have the lowest spade since any lower ones are shown, so “bet” maximum.

  • You have the two (deuce) of spades, so “bet” medium.

  • You have the next lowest spade since any next lower ones are shown, so “bet” medium.

  • If the spade you have is within three ranks of the lowest spade not showing then...

    • If no raises, then “call”

    • If raise was made, then “check.”

  • If you are to bet and...

    • If the spade you have is within four ranks of the lowest spade not showing, then “bet” minimum.

  • Otherwise, follow steps one through six.

  1. Hand value is better than three of a kind.

    Your hand beats any hand showing.

    • You are the first to bet, “bet” medium.

    • Another player is the first to bet...

      • Round of betting is...

      • Conservative: Round one through three and then “check.”

      • Rounds four through six and then “bet” maximum.

    • Nonconservative: Round one and then “check.”

      • After round one, “bet” maximum.

    Your hand is not better than anything showing...

    • Stay with it until the last (seventh) card and “call.”

    • If a raise is on the table, don’t stay with a loser (“fold”).

  2. Hand value is at least a high pair.

    If hand is better than a pair or a pair of queens or better for conservative or eights or better for nonconservative, then...

    • Your hand is better than anything showing...

      • You are the first to bet, so “bet” maximum.

      • You are not the first to bet, so “raise” maximum.

    • Your hand is not the highest (a better one is showing)...

      • You are the first to bet, so “check.”

      • “Call” bets until the fourth card is dealt and “fold” if no improvement.

      • A “raise” is on the table; don’t stay with a loser.

    On the last card, your hand has not improved, so “fold.”

  3. Hand is at least a medium pair, which is a ten or higher for a conservative player and a six or higher for a nonconservative player.

    Your hand is better than anything showing...

    You have a king or an ace in hand with the pair...

    • Betting rounds one to six...

      • You are the first to bet...

        • Betting rounds one to five and then “bet” medium.

        • Betting round six and then “check.”

      • You are not the first to bet...

        • Betting round six and then “call.”

        • Otherwise, “raise” maximum (if you can).

    • Last betting round (sixth)...

      • You are the first to bet so “check.”

      • Otherwise, “fold.”

    • Your hand is not the highest (a better one is showing)...

      • You are the first to bet so “check.”

      • “Call” bets until the fourth card is dealt, and then “fold” if no improvement.

  4. Hand is at least a low pair.

    Your hand is better than anything showing...

    • Betting rounds...

      • One and two for conservative and one through four for nonconservative...

        • Your hand is highest one showing...

          • You are the first to bet so “bet” medium.

          • You are not the first to bet...

            • No player has raised so “raise” medium.

            • Otherwise, “call.”

    • Your hand is not the highest one showing...

      • You are the first to bet so “check.”

      • A bet has been made by another player...

        • Betting round two for conservative or betting round four for nonconservative, and then “fold.”

        • Otherwise, “call.”

      • Three to six for conservative and five to six for nonconservative...

        • You are the first to bet so “check.”

        • Your hand is the highest one showing so “call.”

        • Your hand is not the highest one showing...

          • Betting round six and then “fold.”

          • Betting round six...

          • If lucky, then “call.”

          • If unlucky, then “fold.”

        • Other betting rounds...

          • If no raises yet, then “check.”

          • If raise, then “fold.”

    Your hand is not better than anything showing...

    • Betting round six or conservative and then “fold.”

    • Otherwise...

      • If lucky, then “call.”

      • If unlucky, then “fold.”

  5. Hand possibly a flush or a straight....

    If your cards are of the same suit or rank within straight range....

    • First bet round...

      • You are first to bet, so “check.”

      • You are not first to bet, so “call.”

    • Second bet round...

      • You are first to bet, so “bet” medium.

      • You are not first to bet, so “call.”

    • Five and six betting rounds...

      • If fifth betting round...

        • King or better in hand...

          • You are first to bet so “check.”

          • Otherwise, “call.”

      • If sixth betting round...

        • You are first to bet, so “check.”

        • You are not first to bet...

          • Flush or straight and then “call.”

          • Otherwise, “fold.”

    Three and four betting rounds...

    • You are first to bet so “check.”

    • You are not first to bet so “call.”

  6. If there’s a raise and you have nothing in steps one through five, then “fold.”

Texas Hold ’Em and Omaha

  1. The player to the left of the dealer is forced to make a “blind bet” (“bet” minimum).

  2. Determine if you should stay with the first two cards (for Texas Hold ’Em) or first four cards (for Omaha) in your hand.

    You have a pair (remember in Texas Hold ’Em you can use one, two, or none of your first two cards and in Omaha you must use two cards of your first four cards.

    • If your pair for conservative is aces or for nonconservative is tens or better, then “bet” or “raise” maximum.

    • If your pair for conservative is queens or kings for nonconservative is sixes or better, then “bet” or “raise” medium.

    • If you have any pair, then bet “minimum.”

    • Otherwise, “call” or “check.”

  3. For all remaining betting rounds, get the value of your hand.

    Your hand is only a high card...

    • You are the first to bet so “check.”

    • You are not the first to bet...

      • Conservative players “fold.”

      • Nonconservative player “call” for the second and third betting rounds and “fold” after the last “community card” is turned over.

    Your hand is a pair...

    • You are the first to bet so “check.”

    • You are not the first to bet...

      • A player has raised then...

        • If you have won the last two hands, then “call.”

        • Conservative players “fold.”

        • Nonconservative player “call” for the second and third betting rounds and “fold” after the last “community card” is turned over.

      • A player has bet...

        • For the second and third betting rounds so “call.”

        • “Fold” after the last “community card” is turned over.

      • Players so far have checked and then you “check.”

    Your hand is two pair...

    • You are the first to bet...

      • Conservative players “check.”

      • Nonconservative players “bet” medium.

    • You are not the first to bet...

      • No one has raised so “call.”

      • A raise has been made...

        • You are in the first three players from the dealer so “fold.”

        • Otherwise, “call.”

      • Only a call so far, so you then “call.”

    Your hand is three of a kind (a trip) or better...

    • You are the first to bet so “bet” maximum.

    • You are not the first to bet...

      • Your hand is a straight or better so “raise” maximum.

      • There are no raises yet, so “raise” maximum.

    • Another player has raised...

      • You are in the first three players from the dealer so “call.”

      • You are the fourth player from the dealer so “raise” medium.

      • You are more than four players from the dealer so “raise” maximum.


Game Variation’s Order of Play

Draw Poker No Openers and Jacks or Better to Open

Players “ante” or place the minimum bet into the pot.

Five cards are dealt face down to each player.

Betting session or round.

Player to the left of the dealer bets first.

A player cannot bet and raise himself consecutively.

Only three raises per betting session are allowed.

(In Draw Poker Jacks or Better, only a player meeting these requirements of a hand of at least a pair of jacks may bet. If a player doesn’t select “check” and they don’t have the requirements, then a “check” is the default option. If all players “check,” then the deck is reshuffled and another ante is made by all players. If a player “folds” before any bet is made, the default of a “check” is done instead. The computer never looks at anyone’s hand to process the NPC’s AI, except in this case of checking for the requirements of a hand of at least a pair of jacks.)

Players starting with the player left of the dealer may discard up to three cards (four cards if they hold on to an ace—computer checks for the ace).

(Immediately, the discarded cards are replaced and the discarded cards are shuffled into the end of the deck behind the original 52 cards so that the game doesn’t run out of cards and a player will not receive his own discarded cards or someone else’s discarded cards before the original deck has been dealt.)

Betting session or round.

Player to the left of the dealer bets first.

A player cannot bet and raise himself consecutively.

Only three raises per betting session allowed.

Show all remaining players’ cards.

Find the winning hand or hands if tied.

Pay the winner(s) from the pot.

Update statistics.

Five Card Stud

Deal one card face down to each player (card one).

Deal one card face up to each player (card two).

Betting session or round.

  • Lowest hand showing bets first.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

If more than one player left....

  • Deal one card face up to each player (card three).

  • Betting session or round...

    • Best hand showing bets first.

    • A player cannot bet and raise himself consecutively.

    • Only three raises per betting session allowed.

If more than one player left....

  • Deal one card face up to each player (card four).

  • Betting session or round...

    • Best hand showing bets first.

    • A player cannot bet and raise himself consecutively.

    • Only three raises per betting session allowed.

If more than one player left....

Deal one card face down to each player (card five).

Betting session or round...

Best hand showing bets first.

A player cannot bet and raise himself consecutively.

Only three raises per betting session allowed.

Show all remaining players’ cards.

Find the winning hand or hands if tied.

Pay the winner(s) from the pot.

Update statistics.

Seven Card Stud, Chicago Lo, and Chicago High

Deal two cards face down to each player (card one and two, aka “the hole”).

Deal one card face up to each player (card two, aka “door card”).

Betting session or round.

  • The first round of betting starts with a forced bet by the lowest up card by suit in alpha order (clubs is the lowest suit and spades is the highest suit).

  • A player cannot bet and raise themselves consecutively.

  • Only three raises per betting session allowed.

If more than one player left....

  • Deal one card face up to each player (card four, aka “fourth street”).

  • Betting session or round...

    • Best hand showing bets first.

    • A player cannot bet and raise himself consecutively.

    • Only three raises per betting session allowed.

If more than one player left....

  • Deal one card face up to each player (card five, aka “fifth street”).

  • Betting session or round...

    • Best hand showing bets first.

    • A player cannot bet and raise himself consecutively.

    • Only three raises per betting session allowed.

If more than one player left....

  • Deal one card face up to each player (card six, aka “sixth street”).

  • Betting session or round...

    • Best hand showing bets first.

    • A player cannot bet and raise himself consecutively.

    • Only three raises per betting session allowed.

If more than one player left....

  • Deal one card face down to each player (card seven, aka “the river” also a “hole” card).

  • If there are more cards needed than 52 as when eight players need seven cards each or 56 cards, the last card is a community card used by all players.

  • Betting session or round...

    • Best hand showing bets first.

    • A player cannot bet and raise himself consecutively.

    • Only three raises per betting session allowed.

Show all remaining players’ cards starting with the last bettor.

(For Chicago Hi, the best hand and the highest spade in the hole shares the pot. For Chicago Lo, the best hand and the lowest spade in the hole shares the pot. An ace may be used for high or low. If the seventh card is a “community” card, then it isn’t a “hole” card. The winning “hole” card doesn’t have to be part of the winning hand.)

Using five of the seven cards, find the winning hand, or hands if tied.

Pay the winner(s) from the pot.

Update statistics.

Texas Hold ’Em

Deal two cards face down to each player (card one and two, aka “the hole”).

Betting session or round...

  • A “blind bet” is made by the player left of the dealer.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Community cards two, three, and four (the “flop”) are dealt center table face up.

Betting session or round...

  • Player to the left of the dealer bets first.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Community card one (the “turn” card) is dealt center table face up.

Betting session or round...

  • Player to the left of the dealer bets first.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Community card five (the “river”) is dealt center table face up.

Betting session or round...

  • Player to the left of the dealer bets first.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Find the winning hand or hands if tied using any combination of the player’s own two down cards and the five community cards.

Pay the winner(s) from the pot.

Update statistics.

Omaha

Deal four cards face down to each player (the first four cards, aka “the hole”).

Betting session or round.

  • A “blind bet” is made by the player left of the dealer.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Community cards two, three, and four (the “flop”) are dealt center table face up.

Betting session or round.

  • Player to the left of the dealer bets first.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Community card one (the “turn” card) is dealt center table face up.

Betting session or round.

  • Player to the left of the dealer bets first.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Community card five (the “river”) is dealt center table face up.

Betting session or round.

  • Player to the left of the dealer bets first.

  • A player cannot bet and raise himself consecutively.

  • Only three raises per betting session allowed.

Find the winning hand, or hands if tied, using any combination of two of the player’s own down cards and the three community cards. Remember, “two from the hand, three from the board.”

Pay the winner(s) from the pot.

Update statistics.


Appendix A: Contact Information

Gaming News and Jobs

www.Gamasutra.com

www.GameDev.net

www.GigNews.com

www.Next-Generation.com

www.GDMag.com

www.FGOnline.com

www.Avault.com

www.ZDNet.com/Gamespot

www.Pcign.com

www.BluesNews.com


Gaming Conferences

Game Developers Conference | www.GDConf.com
Extreme Game Developer’s Conference | www.Xgames3D.com
E3 a.k.a. Electronic Entertainment Expo | www.e3expo.com


Game Job Sites

www.GameJobs.com

www.GameProducer.com


Game Job Agencies

Interact | www.Interact.com
Smackjobs | www.Smackjobs.com
Virtual Search | www.Vsearch.com
Premier Search | (800) 571-0832
Networking People | www.np-usa.com
iTrac | www.iTracrecruiting.com
GameQuest | www.GameQuest.org
Hall Kinion | (831) 462-9800
Mary-Margaret | www.mary-margaret.com
TAC Entertainment | www.TACentertainment.com
TSC Management Serv | www.TSCsearch.com
Aardvark Swift Consulting | www.aardvarkswift.com


Gaming Schools

www.DigiPen.edu

www.FullSail.com

www.GameInstitute.com


3D Engines

Genesis 3D from Eclipse | www.Genesis3d.com
Destiny3D | www.destiny3d.com/pages/engine.html
Quake Engines id Software | www.idSoftware.com/Business/Home/Technology/
Torque Engine | www.GarageGames.com
Power Render 4 Engine | www.PowerRender.com
Wild Tangent Web Driver | www.WildTangent.com
LithTech Game Engine | www.LithTech.com
Nocturne Engine | www.TerminalReality.com
Serious Engine | www.CroTeam.com
NetImmerse 3D Game Engine | www.NDL.com
Unreal Engine | http://unreal.epicgames.com/


Art Packages

Adobe PhotoShop | www.adobe.com/products/photoshop/main.html
JASC Paint Shop Pro | www.JASC.com
Equilibrium De Babelizer | www.Equilibrium.com
Alias|Wavefront Maya | www.AliasWavefront.com
Softimage XSI | www.Softimage.com/products/xsi/v2/default.asp
NewTek Lightwave 7.5 | www.Newtek.com
Discreet 3D Studio Max 5.0 | www.Discreet.com/products/3dsmax5/
Poser 4.0 by Curious Labs | www.CuriousLabs.com


Asset Management Tools

NXN Software’s alienbrain | www.Alienbrain.com
PVCS Merant | www.Merant.com/pvcs
Rational Software ClearCase | www.Rational.com/Products/Clearcase/
Starbase StarTeam | www.Starbase.com
Telelogic CM Synergy | www.Telelogic.com


Audio Tools

Cakewalk | www.Cakewalk.com
Sonic Foundry | www.sonicfoundry.com
Awave Audio | www.fmjsoft.com
Sound Ideas | www.Sound-ideas.com
Hollywood Edge | www.HollywoodEdge.com


Appendix B: An Interview with Roger E. Pedersen

How did you get interested in computers and gaming?

In the 6th grade we played Avalon Hill games and Diplomacy for history. I became addicted to war games and started subscribing to Strategy and Tactics and military magazines. I designed several war games (Global Conquest, LunarCity, and The PentaLegions), and I correspondeded with other game designers like Gary Gygax (who developed D&D) and a fellow who had me game test Conquest, a chess-like 2-4 player game played on a board or through the mail. I also started to become an avid chess player (now ranked a USCF Chess Master).

The high school hooked up to a Texas Instruments mini-computer and started a computer class. I was too young to take the classes (you had to be in 10th grade), so I hung out in the computer room and taught myself BASIC. A man (David Ahl, editor of Creative Computing, the nation’s #1 PC magazine in the 1970s) in Westchester County (one county over) started having computer lectures and fairs once a month, which I attended and prepared simulations and easy single-player games for that ran via a yellow paper terminal (no monitors back then).

The interest in computers led me to teach the high school computer course. The computer teacher was also a math teacher and taught computers through math solving so the principal asked me to teach real-world computing (searching, sorting, simulations, games like Tic-Tac-Toe).

Throughout college I studied AI, game theory, database theory, and worked for a mini (Nova Computers) company and was given a TI Silent 700 (terminal paper terminal connected to the Novas) in my dorm room. Other students had 1-4K PCs that they assembled from Heathkit.

What made you decide to work in the game industry, especially from its beginning?

In 1981 I bought myself an Apple 2 and Pascal and wrote a few simple graphic games in 48K with eight colors. In 1983 I moved back to the New York City area looking for a job. A headhunter (job recruiter or agent) called me and asked if I wanted to work at home (part-time) programming games for book publishers who wanted adventure games for the Apple as a selling device (“buy 40 books and get a game that relates to the subject matter.”) I did several games for Laidlaw, a division of Doubleday, where the student could travel throughout the U.S. visiting state capitals, throughout the world visiting famous cities and capitals, and visiting Indian reservations and learning their customs.

Then I got a contract with CBS to rewrite the series “Success with Math” which included “Addition,” “Subtraction,” “Multiplication,” “Division,” and “Long Division” on a Commodore Vic-20 and 64. CBS bought me a Vic-20 and a Commodore 64 and gave me the Apple disks (no code).

In 1985 I met with a Florida game/toy company, Gametek, who wanted to get into the computer game business. They had several hot TV show and board game licenses. I formed Pedersen Systems Inc. and designed, produced, co-programmed, and did the artwork, sound (music), and database for two games (three SKUs such as Apple 2, Commodore 64/128, and IBM PC) a month. Candyland took four days to design and program a finished version for the three computers.

My co-partner Michael Hausman developed a toolbox (code routines and a graphics converter for each machine), allowing us to make games in IBM PC DOS, and upon finishing the code in Manx/Aztec C, the Commodore 64 and Apple versions only required a new compile into their assembler code and running the graphics from the IBM PC through Michael’s converter. Go To the Head of the Class took us five days for three versions (I had to type and update the 1,000 questions used in the game). From there we put on the store shelves Press Your Luck, a TV show, Chutes and Ladders, another Milton Bradley board game, from Parker Brothers’ board game to the computer Sorry. Fisher Price games Perfect Fit, I Can Remember, and Fun Flyer, which never shipped. Also developed and never shipped were board games Trouble and Big Boggle.

In 1988 Michael and I ported Swimwear, a swimsuit calendar program where you could customize calendars and select swimsuit-clad women to represent each month for Hi-Tech Expressions from the IBM PC to the Apple. The port and redesign of the printer graphics were done in four weeks.

In 1989 we designed, programmed, did the sound and artwork for PolarWare (Steve Green), and then bought out by Merit Software on the Don Bluth film All Dogs Go To Heaven. The original (unfinished, part color and part black and white) film was provided, and we created a storybook with ten games that related to the film and its characters. The soundtrack was digitized and played back through the PC speaker and the Sound Blaster (this was the first game digital sound was used through these devices). Both Michael and I programmed this title, and the magnificent artwork was done by an upcoming computer graphics artist, Juan Sanchez (his first title). The design, artwork, and programming took ten weeks for the IBM version. The IBM PC code and graphics were easily ported to the Amiga.

After making millions for Gametek, I published several games (Cyber Cop, Zombies: Undead or Alive!, Crazy Cola, and Dome of Champions) that won CES awards but sold poorly (proving that the creative techies should stay away from the business end of accounting, marketing, and sales).

After developing for Gametek, Hi-Tech Expressions, and Merit Software, all of which became huge publishers during and after your association with them, what did you do?

In 1992 at the CES show (pre-E3 days), I contracted with Dan Sejzer of Villa Crespo Software to do design, programming, artwork, and sound for a video poker game. Within four weeks, a prototype was finished and Dan showed it to several distributors who wanted it ASAP. I moved to Chicago to become director of development of Villa Crespo Software, initially a three-person company. Within a year VCS had over 30 titles on the store shelves and over a dozen employees. Developers in Europe and throughout the U.S. were working with us to sell their titles. My job was to work with these developers, create internal projects, head up the QA group, and work with marketing and manual writers. Titles that I developed and programmed were Stanford Wong’s Video Poker and Flicks! Film Review Library (both CES Innovations award winners), Dr. Wong Jacks+ (IBM DOS, Windows), Combination Lock (IBM DOS), Casino Girls Video Poker (IBM DOS), and Real Mother Goose (IBM DOS).

Titles that I managed were Amarillo Slim’s Dealer’s Choice, Rosemary West’s House of Fortunes, Gold Sheet Pro Football Analyst, Games Magazine: Word Games, and the Coffee Break Series.

Titles that I managed and produced were The Coffee Break CD, Amarillo Slim 7 Card Stud (IBM DOS), Flicks! (IBM DOS), Hearts (IBM DOS), and Casino Craps (IBM DOS).

I designed the gameplay for Rosemary West’s House of Fortunes and Games Magazine: Word Games and created the concept of The Coffee Break Series (all titles), which had great software (abridged versions of VCS premium software and upgraded shareware titles) at budget prices ($13). VCS was the first publisher to enter this budget market with brand-new titles.

I designed the packaging for Failsafe (a police officer) and Flicks! (a large in-home TV).

From 1994 to 1995 I joined Merit Industries as manager of product development for their videogame/arcade machine MegaTouch. I designed and programmed numerous touch screen games on the IBM PC for the Atari Jaguar (to be the brains and engine inside the arcade box). I redesigned the previous MegaTouch system and games written in a 16-color mode to a 16-24-bit color system with stereo sound. I developed new touch screen games and tested the games with nontechnical players for addictiveness, ease of play, and understanding. At Merit Industries, I learned that in the arcade market if the product isn’t fun or addictive, the player has only invested a quarter.

From August 1996 to May 1997, I became senior producer for Acclaim Entertainment, later earning the role of executive producer and game designer developing numerous titles on the PC and video game platforms.

As executive producer, I worked on titles with Ocean of America, such as Cheesy (PSX), Break Point, Tennis (Saturn), Tunnel B1 (PSX, Saturn, IBM DOS, WIN 95), and Project X2 (PSX, Saturn). I worked on the Fox Interactive title Die Hard Trilogy (IBM DOS, Saturn). I worked on titles with Taito such as Psychic Force (PSX) and Puzzle Bobble/Bust-A-Move 3 (PSX). I also worked on titles with Acclaim such as JLA (Justice League of America) licensing liaison with Warner Brothers and DC Comics, Bloodshot (PSX, IBM DOS). I designed an original script based on the Acclaim Comic character Bloodshot and his many enemies.

As senior producer, I worked on the original Shadowman (PSX, IBM Win 95, N64). I managed over a dozen producers and associate producers each with four to six titles (each title had several SKUs, such as N(intendo)64, Win95, PSX, Sega, etc.) as well as produced numerous titles as senior producer for the Sony PlayStation (PSX), the Sega Saturn, Nintendo 64, and Windows 95. (Each title had a budget of $1-5 million.)

For Bloodshot and JLA, I documented and designed products preparing an executive treatment, a design specification, and technical specifications.

For Psychic Force, I localized the storyline for the U.S market, directed voice-over talent and edited the VO DATs from a digital editor to Mac audio format, directed in the motion capture studio for sample data for JLA and Shadowman, reviewed potential products for Acclaim distribution from outside developers and tested numerous products before turnover (Turok, Forsaken, Space Jam, WWF Wrestling, and Magic: The Gathering), selected QA staff to head and work on various projects, and met with licensors Warner Brothers, DC Comics, and Acclaim Comics to discuss game design and licensing matters such as character descriptions, storylines, arch-enemies, three view artwork, acceptable design issues (death or injury to a super hero). I mentored and gave suggestions to producers and game analysts in their design efforts and met as a technical expert with various “hot” development teams/groups (like id off-shoots, makers of Doom and Quake) for title/concept negotiations.

From 1994 to 2000 my pet project has been as PSI Productions (modern version of Pedersen Systems, Inc.) as a director, producer, designer, and programmer of The Six Stones of Serena, an interactive fantasy adventure. I wrote an interactive adventure/role-playing game (500 pages with over 300 parts). Using a SONY BetaCam and Hi-8 Cameras, I shot script (100 actors) during a four-week period. Using video editors (Toaster, Grass Valley, AVID) and software, I edited and placed video on a CD. I used various 3D art packages (Animated World Builder) for virtual world. I designed and programmed an interactive scripting system(language) to create interactive characters and a storyline. An author can easily design, play, and debug interactive stories.

In 1997 I contracted with Sports Simulation to design and program in IBM PC Windows ’95 Pro Soccer, a location-based simulation where a human player kicks a soccer ball at a virtual goalie. Designed as an “all-sports” system linking any sports module to a ball trajectory DLL (library) and a sensor DLL, the Pro Soccer module used actual kicked soccer ball trajectory data to move a virtual ball toward a virtual goalie (St. John’s University soccer team filmed).

As producer, I filmed various soccer players (male, female, teen, college, pro) against an ultramat background and placed the “virtual” players in a 3D soccer world (goal and field) for varying soccer options: direct penalty kick, indirect penalty kick, and corner kick.

In 1998 Michael and I again teamed up in contracting with Hypnotix as game designer, producer, and programmer for General Mills Big G All-Stars vs. Major League Baseball (IBM PC Windows ’95, 3.1). The ad appeared April to July 1998 on 60 million boxes of General Mills cereal, and the CD sold over 1 million copies. The GM trademarked characters the Trix Rabbit, Count Chocula, the Lucky Charms Leprechaun vs. the MLB players (nine players on 30 teams).

What role do you typically play in the development of a game?

Ideally, the game designer and producer. Then I oversee the programming and artwork. Usually the basic game design is provided and I help with redesigning the game, documenting, and programming. It’s important to understand the original game design so when you discard it, the money people and original designers agree with your improvements and ideas. Many people think they can design a great game even though they’ve never done it. Even designers in one genre think they can easily create great concepts without research in other areas, like an adventure game designer trying to make a sports game.

What advice can you offer to people who want to get started with game development, perhaps to turn it into a career?

Study. Learn to do. I studied film making so I could understand an art that has had a successful life. Games will eventually become interactive (where users can chat with their virtual world citizens). Actors (on-screen, voice-over, and motion capture) work better with knowledgeable and experienced directors and producers. Lighting, camera angles, and cut scenes are proven methods in film that video/PC/interactive designers, directors, and producers need to understand. In designing The Six Stones of Serena, I had several binders full of Internet and book research of mythology, ancient architecture, geographical topography, and sci-fi lore, just to justify ideas and gameplay. In baseball, you must understand the statistical data and its relevance and how they relate to the player and the other data. If the user is shown believable scenarios, then the game and the experience is more enjoyable.

What in your opinion makes a good game?

I look at games from the user’s point of view, often asking myself “Is this game worth $60?” “What features would help the user?” “My goal is X, how can I get there easier, faster?” For adventure games, the story must be good. Sports games must be realistic. Puzzle games should be addictive with the ability to play unlimited variations. As CPUs get faster and memory and storage becomes cheaper and more abundant, the stories can be more elaborate. There should be more polygons, more actors on the CD, better sound, and perhaps orchestrated soundtracks.

Why do you enjoy making games?

I enjoy the creation process, making something that’s never existed that is addictive, challenging, and fun to play. I enjoy watching someone play my games. I enjoy hearing someone say they loved a game I worked on. I enjoy reading reviews (all of them favorable so far... knock on wood or silicon) of games that I was a part of.

Lastly, with so many titles released each year, do you have any advice for designers or programmers about distinguishing themselves from others to get a job in the industry? Or will demand be too low?

Unless I work for a company full-time (and I’m always looking) I contract one to two titles per year (contact me at GameProducer@aol.com). When I started, a developer could be a “lone wolf.” Fortunately, I have been teamed up with talented programmers, artists, and coworkers. Now a game needs a dozen people to create it, which is fine as long as one person has the clear vision. “Newbies” should join a game company at any salary, design a game themselves or by using a standard development system to show potential employers that they can really program or design a game to completion. The Internet has opened up a venue for virtual gaming companies. You could design a game and get on Gamasutra.com (under “Contractors”) to look for programmers and artists to help on a back-end deal (work for free now and hopefully get a royalty later when the game is selling). Or if you have programming talent and need artwork, you could get on 3Dcafe.com and find help.

At a conference in 2000, I heard that in 1998 the film industry had revenues way above the gaming industry. Then in 1999 the two industries were close in revenues, and in 2000 the gaming industry out-revenued both the film and music industry combined.

Wow! That’s the place to be, and now’s the time to be there!

Like film, books, and art, computer gaming is an art obtainable through talent and hard work, as well as education.


Appendix C: SFX (Sound Effects) Library

Sound Ideas (www.Sound-Ideas.com)

Click To expand

E-mail: Info@Sound-Ideas.com

Phone U.S.: (800) 387-3030

Phone Int.: (905) 886-5000

Fax: (905) 886-6800

Can I use Sound Ideas sound effects in my computer game?

Yes you can, provided that the sounds are embedded in the code of your game and not available for an end-user to access or download. If your application allows the end-user to access or download unsynchronized sounds, you should contact Sound Ideas to arrange supplemental authorization for the use of the sound effects.

I am making a video game for release in retail stores. Can I use your sound effects in it?

Yes you can. Synchronization of our sound effects in this manner is permitted under the terms and conditions of the Sound Ideas End User License Agreement.


Sound Ideas SFX Collection

The General Series 6000

The Series 6000 ($1,495) contains general sound effects libraries on 40 CDs with more than 7,500 sound effects (more than 50 hours of recorded sound), including sound effects of animals and birds, construction, crowds, fire, household, industry, military, office, sports, transportation, and weather.

The General Series 6000 Extension I

The Series 6000 Extension I ($795) contains more general sound effects libraries on 20 CDs with more than 3,200 sound effects.

The General Series 6000 Extension II

The Series 6000 Extension II ($495) contains more general sound effects libraries on ten CDs with sound effects including popular and practical items and ambiences, plus a comprehensive set of snowmobiles and contemporary telephone sounds—cellular, cordless, electronic, and pagers.

6061 | Air Conditioners, Air Releases, Aircraft Carriers, Airplanes, Alarms, Autos, Axes, Balloons, Barns
6062 | Bees, Bells, Boats, Bone Breaks, Can Punctures, City Ambiences, Clocks, Computers, Crashes, Crowds
6063 | Crowds, Crunches, Doors, Drops, Electricity, Elevators, Explosions, Film Clappers, Fire, Fireworks, Flame Throwers, Forest Ambiences
6064 | Glass Sounds, Golf Carts, Guns, Ricochets, Shotguns and Silencers, Helicopters, Horses, Hospital Monitors, Human Hits, Ice Picks, Industrial Sounds
6065 | Industrial Sounds, Lawn Tractors, Marsh Ambiences, Metal Sounds, Motors, Motorcycles, Music
6066 | Parades, Plastic Sounds, Plumbing, Police Scooters, Projectors, Radar, Radios, Rain, Ratchets, Refrigerators, Rips, Rock Sounds, Rockets, Roller Coasters, Room Tones, Scrapes, Shovels, Sirens, Snowballs
6067 | A full CD of Snowmobile Sounds—Singles, Groups, Polaris, Vintage, and Yamaha
6068 | Squishes, Steam, Strobe Flashes, Subways, Suction, Swishes, Telemetry, Cellular Telephones, Novelty Phones, Cordless Telephones, Electronic Telephone Rings and Internal Signals, Teleconference Phones, Pagers
6069 | Toboggans, Trains, Trucks, Wagons, Water Sounds
6070 | Water Sounds, Weather, Werewolves, Western Ambiences, Whooshes, Wind, Wood Sounds

The General Series 6000 Extension III

The Series 6000 Extension III ($495) contains more general sound effects libraries on ten CDs with sound effects, including all-terrain vehicles, automobiles and guns, plus a spectacular selection of weapons, battles, horror, crashes, smashes, crowds, doors, explosions, hits, vehicles, swishes, and whooshes.

Series 1000 General Sound Effects Library

The Series 1000 SFX ($595) is on 28 CDs that contain over 3,000 sound effects in a wide variety of categories.

1001 | Airplanes
1002 | Animals
1003 | Airports, Archery, Applause, Automobiles
1004 | Automobiles
1005 | Baseball, Bells, Bicycles, Cameras, Clocks
1006 | Birds, Boxing, Buzzers
1007 | Children, Computers
1008 | Construction
1009 | Construction, Crashes, Crowds, Doors, Drawbridges
1010 | Crowds
1011 | Electronics, Earthquakes, Electricity, Elevators, Exercise
1012 | Explosions, Fairs, Farms, Football, Fire, Guns
1013 | Footsteps, Foreign Sounds, Gambling, Golf
1014 | Helicopters, Horns, Hockey, Glass Sounds
1015 | Household Sounds
1016 | Human Sounds, Jungles, Laboratory, Laughter, Logging
1017 | Indians, Industry
1018 | Naval Boats, Ships, Motorcycles
1019 | Military Battles, Guns, Harps
1020 | Musical and Percussion Instruments
1021 | Musical and Percussion Instruments
1022 | Office, Country Sounds, Parades
1023 | Pinball, Post Offices, Projectors, Pumps, Rodeos, Restaurants, Roller Coasters
1024 | Service Stations, Sirens, Snowmobiles, Space Sounds
1025 | Stores, Swimming, Subways, Telephones
1026 | Rain, Thunder, Tennis, Taxis, Trains, Umbrellas, Vacuum Cleaners, Vendors
1027 | Traffic, Trucks, Buses
1028 | Water, Whistles, Wind, Zippers

Series 2000 General Sound Effects Library

The Series 2000 SFX ($695) is on 22 CDs that contain stereo sound effects in a wide variety of categories.

2001 | European FX: Ambiences, Crowds, Automobiles
2002 | Fire Engine and Police Sirens, Hand Guns, Police Station Ambiences, Rain, Swimming Pools, Traffic
2003 | Traffic, European Telephones, Horses, Trains, Restaurants, Fairs, Crowds
2004 | Airplanes, Animals, Automobiles
2005 | Applause, Crowds, Laughter
2006 | Automobiles
2007 | Residential Ambiences, Door Bells, Broadcast News, Sports and Weather, Birds, Buses, Cameras, Automobile Skids, Squeals and Crashes, Demolition Sounds
2008 | Children, Clocks
2009 | Chainsaws, Construction
2010 | Dentist Sounds, Doors, Explosions, Fire and Fireworks, Guns, Arcades, Fairs and Roller Coasters
2011 | Footsteps—Stone, Concrete, Pavement, Dirt, Grass, Hardwood, Leaves, Linoleum, Metal, Sand
2012 | Footsteps—Sand, Snow, Water, Wood, Metal and Garbage, Farm and Tractor Sounds, Babies, Punches
2013 | Helicopters, Hospitals, Squeaks, Sirens, Alarms
2014 | Household and Industrial Sounds
2015 | Motorcycles, Dune Buggies, Lawn Trimmers and Mowers
2016 | Boats, Marine Sounds, Newsroom and Office Sounds
2017 | Musical and Percussion Instruments, Whistles, Noisemakers
2018 | Rain, Thunder, Bar and Restaurant Ambiences, Soda Fountains
2019 | Space Sounds, Shopping Malls, Stores
2020 | Sports, Military Tanks, Cannons and Battles
2021 | Traffic, Trucks
2022 | Water, Zippers

XV Series Multi-Platform SFX Library

XV Series Multi-Platform SFX Library ($795) has more that 3,000 sound effects in over 60 major categories, each of the 15 volumes in red book CD audio format, as well as CD-ROM format containing WAV and MP3 files for both PC and Macintosh systems on 30 CDs.

XV-01 | Air and Air Valves, Airplanes, Airport Ambiences, Animals
XV-02 | Animals, Arrows, Automobiles, Axes, Balloons, Bells, Bicycles, Birds, Boats
XV-03 | Boats, Bodyfalls and Bone Breaks, Boxes, Buses, Cameras, Canoes, Cards, Cartoon Sounds, Cases, Cash Registers and Casino Sounds
XV-04 | Chainsaws, City Ambiences, Clocks, Coins, Construction, Plastic and Styrofoam Containers, Country Ambiences, Ceiling and Wood Cracks, Crashes, Wooden Crates
XV-05 | Crowd Sounds, Debris, Dentist Sounds, Deposit Boxes, Doors
XV-06 | Doors, Drops, Earthquakes, Electrical Panels and Electricity, Elevators, Exercise Equipment, Explosions, Fair Ambiences, Farm Tractors, Fire Sounds and Equipment, Fireworks, Flags, Flame Throwers, Footsteps
XV-07 | Footsteps, Forest Ambiences, Burning Fuses, Gas Station Sounds, Gavels, Geiger Counters, Glass Sounds, Golf Carts, Gun Sounds, Handcuffs, Heartbeats
XV-08 | Helicopters, Horror and Vampires, Hospital Sounds, Household Sounds
XV-09 | Household Sounds, Human Sounds, Ice, Impacts, Industry Sounds, Insects
XV-10 | Jet Packs, Jet Skis, Jukeboxes, Jungle Ambiences, Kayaks, Ladders, Lighters, Lipstick Tubes, Locks, Manhole Covers, Marsh Ambiences, Matches, Microphones, Military Sounds, Morse Code, Motors
XV-11 | Motorcycles, Mountain Ambiences, Music, Newspaper Boxes, Office Sounds
XV-12 | Office Sounds, Parades, Pinball, Police Station Sounds, Popcorn Makers, Film and Slide Projectors, Radar Sweeps, Radio Sounds, Restaurant Ambiences, Robot Motors, Rock Falls, Roller Coasters, Room Tones, Safes and Vaults, School Ambiences, Sci-Fi Sounds, Sculls, Servo Movements
XV-13 | Sirens, Snowmobiles, Sports, Stereo Equipment, Stock Exchange Ambiences, Street Sweepers, Suits of Armour, Swimming, Swishes, Swords and Sword Fights, Tape Cueing, Telemetry, Telephones
XV-14 | Teletype Machines, Toboggans, Tombstones, Toys, Traffic Ambiences, Trains, Tree Falls, Trucks, Turnstiles
XV-15 | Velcro, Vending Machines, Video Cassette Recorders, Volcanoes, Wagons, Walkie Talkies, Water Sounds, Weather, Wheelchairs, Whips, Whistles, Whooshes, Zippers

BBC Sound Effects Library 1-40

The BBC Sound Effects Library ($595) is on 40 CDs containing sound effects like exterior atmospheres, household, interior backgrounds, comedy, fantasy, humor, communications, water, industry, cars, hospitals, equestrian events, livestock, agricultural machinery, horses, dogs, schools, and crowds.

BBC 01 | BBC Sound Effects
BBC 02 | Exterior Atmospheres
BBC 03 | Household
BBC 04 | Interior Backgrounds
BBC 05 | Transport
BBC 06 | Animals and Birds
BBC 07 | Human Crowds, Children, and Footsteps
BBC 08 | Comedy, Fantasy, and Humor
BBC 09 | International
BBC 10 | Communications
BBC 11 | Water
BBC 12 | British Birds
BBC 13 | Industry
BBC 14 | Cities
BBC 15 | Natural Atmospheres
BBC 16 | Cars
BBC 17 | Sport and Leisure
BBC 18 | Bang!
BBC 19 | Electronically Generated Sounds
BBC 20 | Weather I
BBC 21 | Weather II
BBC 22 | Ships and Boats I
BBC 23 | Ships and Boats II
BBC 24 | America
BBC 25 | Aircraft
BBC 26 | China
BBC 27 | Babies
BBC 28 | Hospitals
BBC 29 | Africa: The Human World
BBC 30 | Africa: The Natural World
BBC 31 | Equestrian Events
BBC 32 | Greece
BBC 33 | Adventure Sports
BBC 34 | Livestock I
BBC 35 | Livestock II
BBC 36 | Farm Machinery
BBC 37 | Horses I
BBC 38 | Horses II and Dogs
BBC 39 | Schools and Crowds
BBC 40 | Spain

BBC Sound Effects Library 41-60

The BBC Sound Effects Library, second edition ($395), consists of sound effects and ambiences from around the world on 20 CDs with sound effects like trains, steam transport and steam engines, “do it yourself” handyman and construction sounds, domestic cats and more British birds, emergency services—burglar alarms, police, fire and ambulance sounds, crowd ambiences, everyday sounds from the surburbs, two CDs of footsteps, and nine new CDs of international sounds and ambiences from countries in Europe, Asia, and South America.

BBC 41 | Trains
BBC 42 | The Age of Steam
BBC 43 | D.I.Y. and Building
BBC 44 | Cats
BBC 45 | “Dial 999”
BBC 46 | Istanbul
BBC 47 | British Birds II
BBC 48 | Crowds
BBC 49 | Suburbia
BBC 50 | France—Paris
BBC 51 | London
BBC 52 | Exterior Atmospheres II: British Rural BG
BBC 53 | India and Nepal: City Life
BBC 54 | India, Pakistan, and Nepal: Countryside
BBC 55 | Footsteps I
BBC 56 | Footsteps II
BBC 57 | Urban South America
BBC 58 | Rural South America
BBC 59 | Hungary
BBC 60 | The Czech Republic and Slovakia

The International Sound Effects Library

The International Sound Effects Library ($595) has more than 2,500 sound effects on 28 CDs, more than 35 hours of recorded sound including Animals (three CDs), Business (two CDs), Civic (one CD), Domestic (one CD), Entertainment (one CD), Gimmicks (one CD), Humans (five CDs), Machinery (two CDs), Nature (one CD), Ranch (one CD), Sport (three CDs), Transportation (six CDs), and War (one CD).

De Wolfe Sound Effects Library

The De Wolfe Sound Effects Library ($795) is a digital sound library with over 2000 effects on 23 CDs. Along with a wide selection of ambiences, transportation, domestic, and comedy sounds are unique sounds like sailing an 18th-century clipper ship, the inside ambience of a Zeppelin, and Harrier jets on the attack.

DW 01 | Communications
DW 02 | Electronic
DW 03 | Water
DW 04 | Comedy 1
DW 05 | Comedy 2
DW 06 | American
DW 07 | Domestic 1
DW 08 | Domestic 2
DW 09 | Interior Atmospheres
DW 10 | Warfare
DW 11 | Industry
DW 12 | Cars
DW 13 | Farmyard
DW 14 | Exterior Atmospheres
DW 15 | Period Transport
DW 16 | Interior Crowds
DW 17 | Period Warfare
DW 18 | Human Sounds
DW 19 | Horror
DW 20 | Construction
DW 21 | D.I.Y. 1
DW 22 | D.I.Y. 2
DW 23 | Wild Animals and Tropical Atmospheres

De Wolfe Classic Sound Effects Library

The De Wolfe Classic Sound Effects Library ($395) has over 1,000 effects on six CDs.

De Wolfe Classic FX CD #1:

Metal Workshop | Vice, Hammer, File, Hacksaw, Gas Torches, Lathe, Brazing Brass
Woodwork | Screwdrivers, Drills, Gauges, Coping Saws, Handsaw, Tenon Saw, Electric Saw, Electric Jigsaw, Electric Drill, Wood and Jack Planes, Sandpapering, Hammering Nails, Wood Lathe

De Wolfe Classic FX CD #2:

Comedy | Music Jingles and Instrument Accents, Whistles, Stings and Musical Transitions, Comedy Effects and Accents, Bounces, Crashes and Smashes, Pops, Whizzes and Whooshes, Squelches and Splats, Cartoon Effects
Toys and Amusements | Train, Tank, Submarine, Space Ship, Robot and Mechanical Toys, Pogo Stick, Slot Machines, Roulette Wheels
Percussive Sounds | Wooden, Metal, Glass, China and Paper Sounds, Lighter Flicks, Money, Scissors, Zippers, Balloons

De Wolfe Classic FX CD #3:

Aircraft

Boeing 707, V.C. 10, Boeing 747 Jumbo Jet, Boeing 727, Tristar, Hawker Harrier Vertical Take-Off Jet, Hunterfighter, Formation Flying, Tiger Moth, Beaver, Pioneer, Cessna 175, Westland Scout Helicopter

De Wolfe Classic FX CD #4:

Rally Cars | Multiple Engine and Driving FX for 11 different vehicles, ranging from 1000 cc 4 cylinder to 4,000 cc 6 cylinder, Multiple Car and Hot Rod Pass Bys for Brands Hatch and Silverstone Races
American FX | Crowds, Gambling Ambiences, Games, Pistol and Rifle Ricochets, Indian Attacks, Telephone Sounds, Bar, Restaurant and Party Atmospheres, Rocket Launch and Communications, Vehicles and Traffic, Police Sirens and Cars, Fire Engines and Stations, Niagara Falls

De Wolfe Classic FX CD #5:

The Elements | Weather and Natural Reactions, Thunder Claps, Rain, Volcanos, Fires, Wind, Rough Seas, Streams, Rivers and Floods
Wild Animal FX | Lion, Tiger, Leopard, Panther, Cheetah, Grey Gibbons, Monkey House and Chimpanzees, Orangutans, Gorilla, Deer, Camels, Sea Lions, Crocodiles, Hippos, Flamingos, Elephants, Huskies and Dogs, Bull, Rhinos, Stampede, Jungle, Swamp and Forest Atmospheres

De Wolfe Classic FX CD #6:

Domestic | Electric Plugs and Appliances, Cleaning Sounds, Family Pets, Household Sounds, Water and Fixture Sounds, TV Sets and Radios, Light Switches and Doors, Food Preparation
Industry | Fabrication, Factory and Assembly Shop Atmospheres, Machines, Annealing Furnace, Machine Shop Sounds and Atmosphere

Renaissance SFX Library

Renaissance SFX Library ($1,195) has Dolby Surround to deliver all four channels of sound on 11 CDs that have sound effects of ambiences, isolated sounds, voices, and musical instruments.

CD #1: | World Ambiences
CD #2: | Sounds From Nature
CD #3: | Special Environments
CD #4: | Impact FX
CD #5: | Voice FX
CD #6: | Emotional Voices
CD #7: | Music Tools
CD #8: | Subwoofer FX. Incredible low frequency effects, specifically designed by Renaissance Sound Technologies or the LFE channel in 5.1 production
CD #9: | Rhythmical Tools. Perfectly loopable electronic FX and acoustic rhythmical sounds—the loops include dramatic rhythm textures and are all recorded in a deep moving surround motion.
CD #10: | Dramatic String Textures. A full acoustical production—real immersive acoustic string performances, recorded with Renaissance proprietary miking techniques for a real natural “being there” sensation
CD #11: | Strings and Chords. Use this acoustic string and chord set to create your surround sound tracks—all tracks have been recorded in natural RCE surround technique for maximum compatibility with drama strings textures.

Platinum Sounds for the 21st Century

Platinum Sounds for the 21st Century ($995) is on ten CDs that have sound effects of animals, electricity and static, industrial (double disc), metal, science fiction (double disc), supernatural, transportation, and water.

1 | Animals
2 | Electricity and Static
3 | Industrial #1
4 | Industrial #2
5 | Metal
6 | Science Fiction #1
7 | Science Fiction #2
8 | Supernatural
9 | Transportation
10 | Water

Audio Pro European Sound Effects Library

The Audio Pro Sound Effects ($795) has 18 CDs of sound effects like nature, animals, airplanes and airports, trains and stations, transportation, traffic, crowds and industry, leisure and entertainment, tools, offices, communications, cameras, household, clocks, room tones, bells, sports, war, human solo, human groups, music samples, science fiction, cartoons, and footsteps.

AP1 Sounds of Nature

AP2 | Animals
AP3 | Airplanes, Airport
AP4 | Trains, Station
AP5 | Transportation #1
AP6 | Transportation #2
AP7 | Traffic
AP8 | Crowds, Industry
AP9 | Leisure, Entertainment
AP10 | Tools, Office, Communications
AP11 | Household
AP12 | Household, Clocks, Tools
AP13 | Room Tones
AP14 | Bells, Sports, War
AP15 | Human: Solo
AP16 | Human: Groups, Solo, Crowds
AP17 | Music Samples, Science Fiction
AP18 | Cartoon, Footsteps

Digiffects Sound Effects Library

Digiffects offers 17 distinct collections of more than 13,000 effects for a total of 118 unique and fully digital CDs ($50 per CD). This wide-ranging collection offers American and European alternatives on things like sirens, crowds, and telephones.

Amadeus Sound Effects Library

Amadeus Sound Effects Library ($495) is on five CDs with sound effects like applause, audience walla, horse and carriage effects, human voices, theatrical effects, and a host of other sound effects that re-create the 18th-century world of Wolfgang Amadeus Mozart.

20th Century Fox SFX Library

The 20th Century Fox Corporation SFX Library ($595) has ten CDs with over 1,350 sound effects.

TCF 1 | Antique Autos, Auto Crashes, Ferraris, Hot Rods, Model Ts, Stock Car Races, Auto Skids
TCF 2 | Airplanes, Animals, Arrows, Archery, Crowds, Baseball, Battles
TCF 3 | Bells, Bodyfalls, Cartoon Boings, Boxing Crowds, Cameras, Carnivals, Catapults, Crashes, Crowds
TCF 4 | Drawbridge, Earthquakes, Electronics, Explosions, Fight Scenes, Bar Fights, Fires and Fire Trucks, Flame Throwers, Professional Football
TCF 5 | Glass Smashes, Cannons, Firearms, Handcuffs, Naval Horns, Horses and Stagecoaches
TCF 6 | Human Hits, Jail Doors, Jungles, Knife Stabs, Knife Throws, Metal Hits
TCF 7 | Motorcycle Gangs, Vintage Motorcycles, Office Ambiences, Parachutes, Police Radios, Ratchets, Record Scratches, Rockets, Sand Storms, Ship Signals, Ship SONAR, Space Shuttles
TCF 8 | Air Raid Sirens, Ship Sirens, Snowmobiles, Artillery Soldiers, Cavalry Soldiers, Soldiers Marching, Roman Soldiers, Green Hornet Stings, Submarines, Submarine Control Rooms, Submarine Torpedoes, Sword Fights
TCF 9 | Military Tanks, Telegraphs, Telephones, Thunder, Period Traffic, Trains
TCF 10 | Steam Trains, Trolleys, Military Trucks, Underwater Sounds, Western Streets, Police Whistles

Lucasfilm SFX Library

The Lucasfilm SFX Library ($495) is a six-CD set.

Produced By Lucasfilm: | Produced By Sound Ideas:
LF01 Animal Sounds | LF04 Aircraft Carrier
LF02 Elements (Wind, Rain, Fire) | LF05 Helicopter & Private Jet
LF03 Industry Sounds | LF06 Porsche 911 & Corvette

Universal Studios SFX Library

Universal Studios SFX Library ($495) has over 1,000 sound effects on five CDs.

US01 | Single Prop Airplanes, Biplanes, Triplanes, Twin Prop Airplanes, Four Engine Airplanes, Eight Engine Airplanes, Airport Ambience
US02 | Aviation, Animals, Avalanches, Human Bodyfalls, Boxing, Comedy, Crashes
US03 | Doors, Electricity, Explosions, Fires, Human Hits, Horns, Knife Throws, Metal Hits, Face Punches, Space Doors, Space Gun Shots, Spaceships, Swords, Telegraphs, Underwater Sounds, Volcanoes, Werewolves, Whips
US04 | Grenades, Military Cannons, Rockets, Whistle Bombs, Explosions, Depth Charges, Torpedoes, Submarines, Tanks, Swords, Sword Fights, Marching, Hand Guns, Muskets, Rifles, Ricochets, Machine Guns, Military Battles
US05 | Steam Trains, Indians, Western Battles, Stagecoaches, Horses Walking, Horses Trotting, Horses Cantering, Horses Galloping, Cavalry Horses

Turner Entertainment Co. SFX Library

Turner Entertainment Co. SFX Library ($395) has three CDs and contains over 500 sound effects.

TE01 | Airplanes, Ambulances, Animals, Cartoon Sounds, Creatures, Monsters, Archery, Auto Crashes, Auto Races, Civil War Battles, Revolutionary Battles, Sci-Fi Battles, Western Battles, World War II Battles
TE02 | Crowds, Doors, Earthquakes, Electronics, Explosions, Karate, Sci-Fi Fights, Handguns, Machine Guns, Sci-Fi Guns, Gun Silencers, Western Guns, Human Hits, Horror
TE03 | Parachutes, Sci-Fi Sounds, Ships, Spaceships, Storms, Air Raid Sirens, Sword Fights, Military Tanks, Steam Trains, Time Machine, Volcanoes, Weather, Winds

Disney Ideas

The Disney Ideas ($99) single CD contains over 150 sound effects like ambiences, animals, sports, transportation, machinery, cartoon sounds, and special effects.

Hanna-Barbera SoundFX Library

The Hanna-Barbera SoundFX Library ($495) has more than 2,200 effects on four CDs.

HB01 | Arrows, Military Battles, Bites, Bloods, Beings, Blinks, Bounces, Branch Breaks, Bubbles, Crashes, Glass Crashes, Metal Crashes, Tree Crashes, Wood Crashes, Metal Doors, Drums, Explosions, Body Falls, Falls, Debris Falls, Ski Falls, Fishing Reels, Flops, Gazobs, Handguns, Machine Guns, Rifles, Rifle Fogey, Hammers, Head Shakes, Hits, Metal Hits, Human Hits, Wood Hits, Hops, Horns, Pianos, Plungers, Poof, Pops, Ratchets, Rattles, Rasbora, Ricochets, Roller Skates, Runs, Rock Scrapes, Shakes, Skis, Auto Skids, Slides, Glass Smashes, Spins, Splats, Sputters
HB02 | Squeaks, Squirts, Steam Sounds, Stretches, Rope Stretches, Swishes, Swooshes, Swords, Teeth, Thuds, Thumps, Tip Toes, Trumpets, Twangs, Twirls, Water Splashes, Underwater Sounds, Wobbles, Zips, Zonks, Zooms, Animals and Birds
HB03 | Magic, Electricity, Electronic Sounds, Jetsons’ Doorbell, Sci-Fi Sounds, Titan Rocket Blast Off, Spaceship Sounds, Flying Saucer Sounds, Jetsons’ Space Capsule Sounds, Jet Pack Sounds, Tube Sounds, Spacey Swooshes, Avalanches, Earthquakes, Fires, Rockslides, Thunder, Water Sounds, Wind
HB04 | Airplanes, Jet Airplanes, Prop Airplanes, Autos, Tire Squeals, Jet Boats, Helicopters, Jeeps, Motorcycles, Steam Trains, Computers, Impact Wrenches, Machines, Motors, Presses, Pumps, Crowds, Kisses, Screams

Hanna-Barbera Lost Treasures

The Hanna-Barbera Lost Treasures collection ($99) has more than 350 effects on one CD.

HB05

Basketball, Bites, Cameras, Crashes, Crowds, Explosions, Flame Throwers, Footsteps, Growls, Hits, Bulb Horns, Laughter, Magic, Pops, Rattles, Sci-Fi Sounds, Splats, Squeaks, Cockpit Switches, Voices

Warner Bros. Sound Effects Library

Warner Bros. Sound Effects Library ($495) is on five CDs containing over 1,400 sound effects.

WB01 | Airplanes, Bees, Birds, Cats, Chickens, Dogs, Donkeys, Ducks, Elephants, Farm Sounds, Horses, Monsters, Pigs, Pigeons, Sheep, Archery, Autos, Bells, Boings, Bonks, Bounces, Bubbles, Chatter, Crackles, Crashes, Creaks, Cymbals, Doors, Drums
WB02 | Electricity, Falls, Footsteps, Gongs, Hits, Hops, Horns, Howls, Knocks, Lightning, Morse Code, Motors, Accordions, Fantasies, Pianos, Vibraphones, Violins, Xylophones, Panting, Pile Drivers, Plops, Plunger, Pops, Pumps, Punctures, Radios, Ratchets, Rattles, Saws, Sci-Fi Sounds, Scrapes, Sirens, Skids, Slides, Smashes, Snaps, Splats, Spray, Sputs, Swallows
WB03 | Squeaks, Squirts, Stretches, Swimming, Swishes, Suction, Tears, Teeth, Telephones, Tightropes, Trains, Twangs, Vacuums, Washboards, Water Sounds, Whips, Whistles, Whizzes, Windows, Wipes, Wobbles, Woodpeckers, Zips, Blows, Breathing, Crowds, Cries, Gargles, Growls, Grunts, Gulps, Hiccups, Kisses, Laughter, Razzberries, Screams, Sighs, Sneezes, Sniffles, Snores, Spits, Throat Cuts, Whistles, Yawns, Yells
WB04 | Airplanes, Bears, Fantasy Bees, Fantasy Birds, Creatures, Ducks, Balloons, Bells, Boings, Glass Bottles, Bounces, Bone Breaks, Burp Bubbles, Gag Bubbles, Lava Bubbles, Buzzes, Caverns, Coin Drops, Crackles, Crashes, Door Creaks, Crunches, Debris Falls, Drawbridges, Eating, Electricity, Electronic Sounds, Eruptions, Explosions, Body Falls, Thin Bubbles, Fireworks, Flicks, Footsteps, Ghosts, Heartbeats, Cardboard Hits, Metal Hits, Human Hits, Water Hits, Whap Hits, Wood Hits, Bulb Horns, Laboratory Sounds, Money Bags
WB05 | Motors, Cartoon Peels, Pile Drivers, Pings, Poofs, Pouring from a Jug, Paper Punctures, Metal Rattles, Plastic Rattles, Wood Rattles, Cardboard Rips, Rockslides, Metal Rolls, Rumbles and Groans, Train Rumbles, Tube Rumbles, Saws, Sci-Fi Sounds, Metal Scrapes, Scratches, Shakes, Slides, Balloon Spins, Tube Spins, Winding Spins, Spooges, Glass Squeaks, Spin Squeaks, Water Squirts, Squishes, Plastic Stretches, Tube Stretches, Air Suction, Swishes, Swords, Water Cannons, Water Gurgles, Wind, Zips

The Sound Effects of Rocky and Bullwinkle and Friends

The Sound Effects of Rocky and Bullwinkle and Friends ($395) are on three CDs containing 787 sound effects, featuring the well-known sounds of Rocky and Bullwinkle, Boris and Natasha, Sherman and Peabody, Dudley Do-Right, Fractured Fairy Tales, and George of the Jungle.

RB01 Cartoon Sounds | Accents, Airplanes, Alarms, Animals, Automobiles, Battles, Bells, Birds, Boats, Boings, Boinks, Bonks, Bounces, Clocks, Crackles, Crashes, Creaks
RB02 Cartoon Sounds | Crowds, Crunches, Dishes, Doors, Drills, Drops, Drums, Electricity, Explosions, Fights, Flaps, Footsteps, Guns, Hits, Horns, Human Sounds, Jungle Ambiences
RB03 Cartoon Sounds | Machines, Motors, Music, Pops, Radar, Radio, Ratchets, Rattles, Rockets, Rumbles, Sci-Fi Sounds, Scrapes, Sirens, Skids, Slaps, Splats, Sprongs, Squeaks, Stretches, Swishes, Telephones, Trains, Twangs, Water Sounds, Whips, Whistles, Zips

Series 8000 Sci-Fi

Series 8000 Sci-Fi ($395) is on four CDs with more than 500 contemporary space and futuristic fantasy sound effects and ambiences, including alarms, spaceships, alien creatures, hatches and air locks, robotics, rockets, telemetry, weapons, and Challenger space shuttle launches.

8001 | Air Bursts, Alarms, Ambiences
8002 | Ambiences, Animals and Creatures, Avalanches, Battles, Communications, Computers, Docking Thrusters, Doors, Drains, Drones
8003 | Earthquake, Electricity, Energy Bursts, Explosions, Fires, Flybys, Footsteps, Freezer Chambers, Laser Guns and Beams, Phasers, Ray and Stun Guns, Dry Ice, Robotics, Scanners, Servos, Space Rockets and Shuttles
8004 | Spaceships, Simulators and Stations, Splats, Squeals, Telemetry, Torpedoes, Vortexes, Weapon Dischargers, Whooshes, Wind, Zips

Series 8000 Sci Fi Warp 2

Series 8000 Sci-Fi Warp 2 ($395) continues on three CDs with sound effects.

8005 | Air Blasts, Air Locks, Alarms, Ambiences, Animals and Creatures, Battles, Bells, Black Holes, Communications, Computers, Control Rooms, Crowds
8006 | Doors, Shields and Hydraulics, Dopplers, Drones, Electricity, Electronic Pulses, Scrambles and Hits, Energy Bursts and Transformers, Explosions, Flybys, Force Fields, Laser Guns and Beams, Stun Guns, Electronic and Metal Hits, Laboratory Sounds
8007 | Photon Bursts, Plasma Capsules, Power Sources, Robotics, Rockets, Satellites, Scanners, Sensors, Servos, Space Pods, Ships and Stations, Switches, Telemetry, Time Warps, Transporters, Vortexes, Weapons, Whooshes, Zips

Designer Sound Library

The Designer Sound Library ($295) is on three CDs containing almost 700 sound effects like Fantasy, Science Fiction, Telemetry, Guns, Explosions, Hits, Thunder, Drones, Whooshes, Swishes, Glisses, Pulses, Zips, and Sparkles.

Radioactive

Radioactive ($250) is on two CDs that contain 200 eerie wave forms, pans, sweeps, phasers, communications, shimmers, bubbles, beeps, static, and monsters and apparitions like Space Monster Screams, Phaser Morph, Shimmering Space Bells, Ringing Soundscape, Space Ribbon with Whine, Time Travel Reverb, Shuttle Craft Engine Room, Steady Bubble Gyro Delay, Alien Tractor Beam Sequence, Evil Diablo Wave, Vortex Entry, Single Ray Gun Blast, Rumbling Wind Whoosh, Solar Wind and Waves, Predatory Black Hole, Phaser Wave Boomerang, Electric Tubescape, Distorted Space Guitar, Fading Bubble Chirp, and Galactic Spacescape Hum.

Science Fiction Sound Effects Library

The Science Fiction Sound Effects Library ($295) is on three CDs that contain a broad range of futuristic, space, alien, and creature sound effects and ambiences.

Spacefighter Duel and Selected Elements:

Flights and Attacks, Launches, Blastoffs, Flybys and Circling, Explosions, Battle, and a Roasted Toasted Alien

Ambience Effects and Action Effects and Scenes:

Space Hangar Ambiences, Spacefighter Strafing Runs and Flybys, Squadron Formations, Moon Landing Sequence, Starship Bridge and Warp Drive Sequence, Space and Blaster Battles, Lift-Off to Orbit Countdown, Re-Entry Sequence, Computer Room, Mad Scientist’s Laboratory, Laser Cannon Blasts, Alien Weather and Lightning Bolts, Horror Heartbeat, and Engine Room Ambience

Electronic Effects:

Bells, Bubble Up Effects, Communications and Telemetry, Beeps, Radio Bursts, Intercom Static and Space Radio Interference, Space Beacon, Warnings, Hand-Held Computers, Sine Waves, Warble, Electromagnetics, and Space Radio Tuning

Mechanical Effects:

Laser Bursts, Pneumatic Sliding Doors, Sinister Pulsating Machines, Vacuum Pump, Mechanical Computers, and Various Machine, Switch, and Motor Sounds

Weapons Effects:

Vindicator and Scavenger Weapons Fire, Spaceship Weapons Fire, Turbo Laser, Proton Torpedoes, Death Star Explosions, Hand Blasters, Hand Phasers, and other Weapons

Fantastic Creatures:

Alien Creature Mumbling, Cute Droid, Mean Little Creature, Alien Intelligence and Computer Speech, The Id Monster, Cantina Creatures, Robot, Gargle and Growl Monsters, Weird Thing, Mad Martian Mouse, White Fang, and other Robots and Alien Radio Drop Ins

Miscellaneous Effects:

Ominous Flying Saucer, Vibrations, Laser Tunnel Resonance, Radioactive Emanations, Disintegrator-Integrator Units, Launch and Catapult Effects, Meteor Showers, Personal Extra-Vehicular Thruster Units, Rumbles, Wails, Sirens and Sputters, Garbled or Coded Radio Communications, Phaser and Other Space Sounds

Soundscapes and Music:

Solar and Cosmic Storms, Flying Saucer Landings and Take-Offs, Close Encounter with Mothership, Glass Tones, Mental Projection, Dark Swells, Interdimensional Madness, Nightmare Terror and Radioactive Crying, Humourous Zombies, Kaleidoscope, and other Musical Compositions

Metropolis Sci-Fi Toolkit 1

This Science Fiction Toolkit ($129) on one CD contains a vast collection of whooshes, sweeps, releases, scans, accents, alerts, blasts, prompts, bleeps, whirls, flutters, synths, washes, impacts, lasers, sirens, pulses and buzzes, science fiction ambiences, and other electronic tools.

Metropolis Sci-Fi Toolkit 2

The Metropolis Science Fiction Toolkit II ($129) is on one CD that contains over 200 new sound effects never heard anywhere before, including great mechanical, ethereal, whoosh, metallic, static, and ambience effects, plus squeaks, scans, and scrapes.

Jurassic Dinosaurs

Jurassic Dinosaurs ($99) is a single CD.

Organic Creatures, Small to Large:

Mouse, Bird-Like, Chipmunk-Like, Mouse-Like, Dinosaur Hatchling, Small Animals, Classic Jungle Birds, Laughing Creature, Sheep or Goat-Like, Weird and Humorous Creature, Cat-Like Growls, Roars, Hisses and Snarls, Strange Jungle Animals, Complex Cries, Fluttering, Mournful and Haunted Wails, Heavy Breaths, Elephant-Like Trumpeting, Pig-Like Grunts, Nasal Trumpeting, Complex Dinosaur Battle Screams, Grunting Cries, Hoarse Growls, Alien Cries and Calls, Sneezes and Coughs, Cow-Like Moos, T-Rex Attack and Challenge Cries, Groans and Grunts, Honking Cries, Guttural Rumblings and Roars, Angry Dinosaur Growls and Grumbles

Organic Body and Environment:

Creature Footsteps on Various Surfaces, Impact Tremors, Thundering Stampede, Eating Cracks, Crunches and Snaps, Wing Flapping on Flying Creatures, Flying Insects, Plant Monster FX, Broken Foliage FX

Alien, Robotic, and Supernatural Creatures:

Android, Cyborg Language, Help Droidbot, Robot Footsteps and Servo Motor, Robot Start-Up, Overload, Electric Discharges, Radio Control Frequency and Squeaking Joints, Alien Creatures, Dragons, Werewolves, Shape Shifters, Ghost Vortexes, Classic Tinkerbell Winged Fairy

Drone Archeology

Drone Archeology ($129) is on one CD that contains 99 stereo drones, ranging from 32 to 64 seconds in length and has a 114-page accompanying booklet.

The Big Drone

The Big Drone ($129) is on two CDs and contains both simple and complex drones that have been designed to enhance many different kinds of scoring applications.

Crash and Burn

Crash and Burn ($250) is on two CDs containing over 400 sound effects like Wood, Junk, Metal, Plastic and Rock, Bombs and Timers, Dynamite, Gas Explosions and Grenades, Fireballs, Chemical and Petroleum Fires, Firestorms and Fire Extinguishers, Forest and Building Fires, Guns, Bullets and Missiles, Torches and Ignitions, Window Breaks and Glass Smashes, Molotov Cocktails, Rumbles, Blasts, Debris, Building, Ceiling and Elevator Falls, Bodyfalls and Body Hits and Twisters.

PowerSurge 1

PowerSurge 1 ($250) is on two CDs containing electrical sparks, arcs and zaps, crashes, smashes, hits and punches, large impacts, guns and helicopters, electronic beeps and buttons, telemetry and computers, a full range of explosions, weather and natural disasters, and an entire galaxy of potent sci-fi FX, ambiences, and alternate realities.

PowerSurge 2

PowerSurge 2 ($250) is on two CDs and has more of the sound effects that PowerSurge 1 started.

Larger Than Life

The Larger Than Life SFX Library ($495) is on five CDs containing sound effects of explosions, gunfire, thunder, horror, crashes, and bangs.

LTL 1 | Air Releases, Airplanes, Airport Control Towers, Archery, Augers
LTL 2 | Automobiles, Auto Crashes and Skids, Boats, Bodyfalls, Bone Breaks, Crashes, Electricity, Explosions, Feedback, Fire Bursts, Flame Throwers, Glass Smashes, Hand Guns, Rifles
LTL 3 | Body and Face Hits, Squishes, Horses, Industrial Machines, Metal Sounds
LTL 4 | Radio Static, Rockets, Sci-Fi Sounds, Submarines, Sword Battles and Hits, Light Sabres
LTL 5 | Tanks, Telemetry, Torpedoes, Trains, Volcanoes, Water Geysers, Weather, Whooshes, Wood Hits

Impact Effects

The Impact Effects ($129) CD contains 605 tracks with sound effects like Arrow Impacts into Bodies and Wood, Auto Crashes and Explosions, Ball Falls and Hits, Body Falls and Bone Breaks, Building Crashes and Ceiling Cracks, Bullet Impacts into Bodies, Glass, Metal and Wood, Cabinet, Drawer and Cardboard Crashes, Crashes and Auto Crash Test Dummies, Debris Falls, Earthquakes, Soft Falls, Garbage Drops and Hits, Gas and House Explosions, Glass Falls, Hits and Smashes, Dull, Heavy, Low and Soft Hits, Human Hits, Junk Crashes, Knife Impacts into Bodies and Wood, Mass Destruction, Metal Crashes, Falls and Hits, Meteor Crashes, Plastic Crashes, Crumples, Falls, Hits and Spins, Rock Falls, Hits and Smashes, Sack Drops and Hits, Subway Crashes, Sword Impacts, Wood Breaks and Crashes, Falls and Hits

Power Pack from Digiffects

Power Pack from Digiffects ($250) is on five CDs with more than 1,000 pre-boosted effects.

CD #1 Synthetic Media FX: Tailor-made for commercial use

CD #2 Synthetic Media FX: Longer and machine sounds

CD #3 Processed Sound FX: Stronger, tougher, and louder

CD #4 Processed Sound FX: Machine sounds and impacts

CD #5 Cartoon Sound FX: Comedy and corny sounds

The Dark Side of Sound

The Dark Side of Sound ($250) is on two CDs containing drama and horror and suspense ambiences, plus a full selection of creatures, monsters, ghosts, vampires, zombies, haunted houses, and many other creepy effects: Encounters With Evil, Dripping Blood, Ripping Flesh, Graveyards, Coffins, Dungeons, Guillotines, Secret Passageways, Demonic Languages, and Eerie Whispers.

Thunder

Thunder ($250) is on two CDs of more than 100 thunder and rain effects. CD #1 contains single claps, cracks, rumbles, rolling thunder, and lightning strikes. CD #2 offers a sky full of three-minute storm ambience tracks, ranging from gentle rain showers to exploding thunder and fierce hurricanes.

The Art of Foley

The Art of Foley ($495) is on ten CDs containing a warehouse full of simulated sounds like Applaud, Break, Bubble, Click, Creak, Crumple, Crush, Drop, Fall, Grind, Hammer, Hit, Impact, Jingle, Kick, Pry, Punch, Rattle, Rip, Rustle, Scrape, Shake, Shriek, Smash, Splash, Squelch, Squish, and Step and Swish.

FS-01: | Applause, Archery, Automobiles, Bags, Basketball, Bells, Belts, Birds, Bone Breaks, Books, Bottles, Brushes, Buckets, Buses
FS-02: | File Cabinets, Cans, Carts, Briefcases and Luggage, Ceramic Smashes, Chains, Chairs, Clicks, Cloth Movements, Clothes, Coins, Computer Keyboards, Construction Ambiences, Crashes, Creaks, Desks, Dishes, Dog Movements, Doors, Drapes and Curtains, Drawers, Drills, Drops, Electricity Sparks, Equipment Rattles, Eyeglasses
FS-03: | Body Falls, Fax Machines, Footsteps
FS-04: | Footsteps
FS-05: | Golf, Glass Sounds, Guns, Hammers, Handcuffs, Hits, Human Horror Sounds
FS-06: | Horses, Stagecoaches and Wagons, Everyday Human Sounds, Insects, Kicks, Knives, Ladders, Latches, Leaves, Levers, Lighters, Liquids, Locks, Machines, Matches, Metal Sounds
FS-07: | Metal Sounds
FS-08: | Motors, Nails, Paper Sounds, Pens, Pencils, Ping Pong, Punches, Rattles
FS-09: | Cloth Rips, Rocks, Ropes, Safes and Vaults, Sand, Saws, Scissors, Scrapes and Screeches, Shakers, Shovels, Spins and Twirls, Rubber Squeaks, Flesh Stabs, Swimming and Diving, Swishes, Swords, Tables, Telephones, Turrets, Typewriters, Ventilators
FS-10: | Water Sounds, Whistles, Whooshes, Wood Sounds

Foley Footsteps

The Foley Footsteps CD ($99) is a comprehensive all-digital collection of male and female footsteps, recorded on a variety of different surfaces and at different walking speeds. Surfaces available include cement, wood, grass, gravel, metal, and snow. Sounds of individual steps, paced steps, shuffles, running, jumping, and climbing stairs are also included.

Series 9000 Open and Close

Series 9000 Open and Close SFX Library ($595) is on 12 CDs containing more than 6,200 sound effects from out-of-this-world space doors to down-to-earth household cupboards.

Series 11000 Sports

The Series 11000 Sports collection ($495) is on five CDs containing extreme close-ups of individual hits, impacts and catches, full competitive game action recorded at the sidelines, and the sounds of spectators, crowds, and stadiums in a wide selection of sports activities. Recorded with professional, semi-pro, and advanced collegiate athletes, it features both indoor and outdoor stadium crowd sounds of up to and more than 100,000 spectators.

S11-01: | Badminton, Baseball, Softball, Basketball, Mountain Bike
S11-02: | Mountain and Road Bicycles, Billiards, Bowling, Boxing, Croquet, Curling
S11-03: | Curling, Exercise Equipment, Football, Golf, Gymnastics, Ice Hockey
S11-04: | Inline Hockey, Martial Arts, Paintball, Ping Pong, Racquetball, Skateboarding, Ice Skating
S11-05: | Cross-Country and Downhill Skiing, Snowboarding, Snowshoeing, Soccer, Swimming Dives and Races, Tennis, Volleyball, Wrestling

Series 4000 Hollywood

Series 4000 Hollywood ($495) is on five CDs containing 2,200 digitally recorded effects like recorded cartoon boinks, zips, and pops.

4001 Cartoon | Boinks, Bongs, Dits, Bings, Boings, Bounces, Warbles, Impacts, Cymbals, Gongs, Falls, Squishes, Splats, Drips, Pops, Bubbles, Rattles, Grinds, Squeaks, Bells, Horns, Whistles, Zips, Whizzes, Twangs, Space Sounds, Accents, Crashes
4002 Cartoon | Accents, Drums, Percussion, Cars, Airplanes, Trains, Boats, Motors, Drills, Guns, Birds, Cats, Chickens, Chipmunks, Cows, Dogs, Donkeys, Ducks, Elephants, Frogs, Horses, Monkeys, Pigs, Sheep, Growls
Firearms | Airguns, Handguns, Rifles, Shot Guns, 9mm Uzis, Mini Uzis, M-16s, AK-47s, Machine Guns, Holsters
4003 Cartoon | Laughter, Cries, Yells, Groans, Head Shakes, Vocals, Sneezes, Wheezes, Nose Blows, Gargles, Yawns, Snores, Kisses, Babies, Footsteps, Swishes, Body Punches, Face Punches, Face Slaps, Human Hits, Human Stabs, Whips, Human Bodyfalls, Glass Smashes, Auto Crashes, Metal Crashes, Horror Sounds, Explosions
4004 Music | Great Selection of Cartoon, Circus, and Classical Music
4005 Music | Wide Variety of Fanfares, Jazz, Marches, Rock, Horror, and Space Music

Emergency

Emergency ($250) is on two CDs containing more than 500 sound effects like accident scenes, radio dispatches, alarms, sirens, crowds, and equipment sounds, Accidents and Rescues, Fires and Explosions, Ambulances, Fire Engines and Life Saving Equipment, Police Chases and Hostage Scenes, Police Cars, Equipment and Guns, Riot Scenes and Tear Gas, SWAT Teams, and Forensic Crime Investigations.

ClickShop from Digiffects

ClickShop from Digiffects ($200) is on four CDs containing 2,300 sound effects like switches, buttons, beeps, hits, rips, scrapes, clicks, hums, motors and machines, a variety of mechanical and other industrial sound effects, and backgrounds.

Dynamic Range

Dynamic Range ($395) is on two CDs containing over 1,000 sound effects like gun sounds and related effects, including interior and exterior shots, bullet hits, ricochets, silencers and gun handling sounds. Interior shots include revolvers, pistols, rifle, automatic weapons, and random fire. Exterior shots include revolvers, pistols, shotgun, assault rifles, automatic weapons, random fire, and special weapons. Foley/Handling include revolvers, pistols, rifles, shotguns, auto rifles, assault rifles, by effect silencers, ricochets, bulletbys, and bullet hits.

The Works

The Works ($495) is on ten CDs containing 2,870 sound effects like pneumatics, buttons, switches, signals, levers, ratchets, gears, friction, stress, servo motors, small motors, small mechanisms, electrical effects, compartments, doors, machines, motors and engines, a diverse collection of backgrounds like interior work and manufacturing, packing, shipping, conveyors, exterior work, labor, industry, and constant tone environments.

WORKS 1 | Pneumatics, Buttons, Switches
WORKS 2 | Signals, Levers, Ratchets, Gears
WORKS 3 | Friction, Stress, Servo Motors
WORKS 4 | Small Motors, Small Mechanisms, Electrical Effects
WORKS 5 | Compartments, Doors, Tape Machines
WORKS 6 | Machines, Motors, Engines
WORKS 7 | Backgrounds: Interior Work and Manufacturing
WORKS 8 | Backgrounds: Packing, Shipping, Conveyors
WORKS 9 | Backgrounds: Exterior Work, Labor, Industry
WORKS 10 | Constant Tone Environments

Blow Tools

Blow Tools ($565) is on 12 CDs containing over 700 sound effects like rushing, wailing, blustering, buffeting, groaning, rustling, droning, growling, shrieking and moaning, whistling, rumbling, whispering, sweeping and swooshing, breezing, blowing, howling, gusting, and whooshing.

Series 5000 Wheels

Series 5000 Wheels ($595) is on 24 CDs containing 25 vehicles digitally recorded with over 3,000 sounds, including long recorded passbys with no premature fadeouts, 140 interior and exterior sounds per vehicle.

5001 | Dodge Omni
5002 | Ford Tempo
5003 | Chrysler Le Baron
5004 | Buick LaSabre
5005 | Cadillac-Sedan de Ville
5006 | Mercedes Benz
5007 | Toyota Corolla
5008 | Ford Mustang GT
5009 | Porsche 930 Turbo
5010 | Hot Rod
5011 | Alfa Romeo Spider
5012 | Jeep 4X4
5013 | Ford 3/4 Ton Pickup
5014 | Ford Van-Cargo Type
5015 | 14' Box Truck-Ford
5016 | Mack, 18 Wheel (Cab and Wagon)
5017 | Greyhound Bus-MCI
5018 | 1923 Ford Model “T”
5019 | 1938 Chevrolet Coupe
5020 | 1956 Chevy Belair
5021 | Jalopy
5022 | Various Surfaces and Miscellaneous Effects
5023 | Harley Davidson/Yamaha 250 Mini-Bike
5024 | Honda 750/Yamaha 80 Mini Bike

Series 5000 Wheels 2nd Gear

The Sound Ideas Wheels 2nd Gear Sound Effects Library ($595) is on 21 CDs containing a full range of effects for 20 different cars, trucks, recreational vehicles, and a selection of vintage and performance automobiles, plus one full CD of off-road effects.

CD #5025 | Dodge Neon-Manual Transmission
CD #5026 | Chevy Caprice Police Edition
CD #5027 | Ford Crown Victoria Police Edition
CD #5028 | BMW 328I
CD #5029 | BMW 540I
CD #5030 | Mercedes Benz 500 SEC
CD #5031 | Nissan Pathfinder-Manual Transmission (4WD)
CD #5032 | Chevy Blazer (4WD)
CD #5033 | Chevy Suburban
CD #5034 | Jeep Grand Cherokee (4WD)
CD #5035 | Chevy S 10 Small Pickup-Manual Transmission
CD #5036 | Chevy Silverado Full Size Pickup
CD #5037 | Nissan 240 SX SE-Manual Transmission
CD #5038 | Pontiac GTO-Manual Transmission
CD #5039 | Porsche Turbo S-Manual Transmission
CD #5040 | Ferrari Testarossa-Manual Transmission
CD #5041 | 1975 Cobra RS 427-Manual Transmission
CD #5042 | 1963 Rolls Royce
CD #5043 | Lincoln Town Car Stretch Limo
CD #5044 | 1955 Packard
CD #5045 | Off Road-Various Vehicles

Speed

Speed ($250) is two CDs containing more than 165 sound effects like idles, engine revs and shifting gears, single car passbys, passbys and races between two or more cars, straightaways, curves, hairpin turns, dragster burn outs, race, announcement and crowd ambiences, pit crew ambiences, tire garage ambiences, and starting and finish line sounds. The vehicles recorded are CART Indy Cars, Indy Lights Series Cars, Formula Atlantic Series Cars, Vintage Formula One Cars, Offroad Desert Racers, Go Carts, Dragsters, Funny Cars, Monster Trucks, NASCAR Stock Cars, World Sports Car Series, GTS Series Cars, FIA GT Series, and Motorcycles (several types).

Series 12000 Anchors Away

Series 12000 Anchors Away ($595) is on five CDs containing more than 1,200 sound effects like 40 different small boats, personal watercraft, racing, and fishing and excursion vessels such as Canoes, Kayaks, Row Boats, Pedal Boats, Jet Skis, Jet Boats, Hydroplanes, Everglade Air Boats, Fishing Boats, Trawlers, Pontoon Boats, Ski Boats, Scullers, Powerboats, Hovercraft, Zodiac Rescue Boats, Ferries, Tourist, Paddlewheel River Boats, Steam Boats, Cabin Cruisers, Vintage Boats, Schooners, and Speed Boats. A full range of exterior and on sounds include Starts, Idles, Engine Revs, and Shut Offs, Approaches, Reverses, and Turns From Different Perspectives, Pull Aways and Passbys At Different Speeds, Launching, Beaching, Paddling, Rowing and Docking Maneuvers, Engines, Motors, Generators and Throttles, Deck, Cabin, Engine Room, Race Ambiences, Horns, Signal Bells, Steam Whistles and Foghorns, Sails and Rigging and Winches. Other practical and related sounds included are Anchors, Buoys, Dock Hits, Paddles, Pumps, Water Bailing and Splashing, Sounds, Lake and Ocean Waves, and Wake Splashes

Series 13000 Ship Shape

Series 13000 Ship Shape ($395) is on six CDs containing more than 300 effects of a full fleet of freighters, luxury ocean liners, and other large vessels, cargo ships, barges, tug boats, an ice breaker, state-of-the-art naval frigates, a World War II PT boat, hydrofoils, large fishing vessels, trawlers, and cruise ships. Also included are a wide variety of engine room, anchor, and equipment sounds and backgrounds, plus a full selection of ocean wave and harbor ambiences.

Just Birds and Animals

Just Birds and Animals ($250) is on two CDs containing individual bird and animal species, plus a variety of key ambiences and backgrounds.

JBA 01: | Alligators, Barn Ambiences, Bats, Bears, Bees, Bird Ambiences, Blackbirds, Budgies, Chachalacas, Chickadees, Chickens, Cockatoos, Crows, Doves, Ducks, Eagles, Falcons, Flamingoes, Geese, Hawks, Hummingbirds, Killdeers, Loons, Macaws, Mockingbirds, Owls, Parrots, Peacocks, Pigeons, Roosters, Seagulls, Sparrows, Starlings, Sun Conures, Turkeys, Vultures, Warblers, Whippoorwills, Woodpeckers, Wrens, Yellowthroats, Domestic Cats
JBA 02: | Country Ambiences, Crickets, Dolphins, Donkeys, Elephants, Piranhas, Flies, Frogs, Goats, Gorillas, Horses, Insects, Katydids, Jaguars, Jungle Ambiences, Leopards, Lions, Marsh Ambiences, Monkeys, Penguins, Pigs, Prairie Dogs, Sea Lions, Sea Otters, Seals, Rattlesnakes, Squirrels, Tigers, Walruses, Whales

Wild World of Animals

Wild World of Animals ($495) is on ten CDs that contain over 850 sound effects like aquatic animals (sharks, whales, dolphins, walruses), wild animals (buffalo, alligators, elephants, snakes, tigers, pandas), birds and insects, and domestic animals (cattle, goats, dogs, cats), plus an entire CD of horses.

WWA01 | Wild Animals | Buffalo, Camel, Elephant, Elk, Giraffe, Impala, Moose, Panda, Rhino, Wildebeest, Zebra
WWA02 | Wild Animals II | Bear, Bobcat, Cougar, Leopard, Lion, Ocelot, Panther, Tiger, Wildcat, Jackal, Wolf
WWA03 | Wild Animals III | Chimp, Gorilla, Monkey, Orangutan, Bat, Rabbit, Agouti, Rat, Frog, Alligator, Crocodile, Snake, Locust, Bee, Fly, Mosquito
WWA04 | Aquatic Animals I | Dolphin, Sea Lion, Seal, Walrus, Shark, Whale
WWA05 | Aquatic Animals II | Whales
WWA06 | Birds I | Birds in Many Environments: Amazon, Belize, North America
WWA07 | Birds and Insects I | Birds in Many Environments: Residential, Rural, Africa; Crickets, Cicadas
WWA08 | Birds and Insects II | Marsh and Jungle Ambiences from Around the World
WWA09 | Domestic Animals I | Cattle, Donkey, Goat, Pig, Sheep, Dog, Cat
WWA10 | Horses I | Horses: Many Gaits on Various Surfaces

Audience Reactions I

Audience Reactions I ($250) is on two CDs containing more than 500 audience reactions in larger arena and sports stadium crowds and children’s reactions.

AR-01: | Small- and Medium-Sized Studio Audiences, Large Stadium Crowds, Applause, Standing Ovations, Cheers and Whistles, Male and Female Applause, Rhythmic Clapping in Unison, Stomping and Clapping, Applause and Cheers, Surges of Applause, Whistling and Foot Stomping, “Bravo!,” “Encore!,” and “Yea!,” and Rowdy Cheering
AR-02: | Small- and Medium-Sized Studio Audiences, Large Stadium Crowds, Studio Audience of Children, Booing and Hissing, Angry Yelling, Cheers, Laughter, Laughter and Applause, Sympathetic Reactions, Male and Female Laughter and Applause, Amazed Reactions, Thoughtful and Surprised Reactions, Gasps, Relief and Disappointed Reactions, Disgusted Reactions, Hecklers and Shushes, Positive and Negative Reactions, Reactions of Disbelief, Shocked and Surprised Reactions, Trumpet Fanfare and Charge!, Happy New Year Countdown, Screams: Fear, Panic, and Adoration, and Children’s Reactions

Audience Reactions II

Audience Reactions II ($250) is on two CDs containing more than 500 sound effects like applause, cheering, anger and booing, laughter, screams, and a full palette of vocal and emotional reactions from many different sets of voices.

AR-03: | Medium-Sized Studio Audiences, Applause, Standing Ovation and Re-Seating, Cheers and Whistles, Male and Female Applause, Rhythmic Clapping in Unison, Applause and Cheers, Surges of Applause, Rowdy Cheering, “Surprise!,” “Hip, Hip, Hooray!,” “Charge!,” “Go Team Go!,” Sympathetic and Disappointed Reactions, Excited and Disbelief Reactions, Frightened, Panic and Horror Screams, Chanting “Hell No, We Won’t Go,” Laughter and Applause, Booing and Hissing and Angry Yelling, Disgruntled and Riotous
AR-04: | Small-Sized Studio Audiences, Male Only and Female Only Reactions, Studio Audience of Children, Booing and Hissing, Angry Yelling, Cheers, Laughter, Laughter and Applause, Sympathetic Reactions, Male and Female Laughter and Applause, Surprised Reactions, Shocked Gasps, Relief and Disappointed Reactions, Disgusted Reactions, Hecklers and Shushes, Positive and Negative Reactions, Shocked and Surprised Reactions, Happy New Year Countdown, Screams: Fear, Panic, and Adoration, Children’s Reactions, Chant “Go Team Go” and “De-Fence” and “Hip Hip Hooray”

Series 3,000 Ambience I

Series 3000 Ambience I ($495) is on 12 CDs containing over 200 stereo sound effects.

3001 | City Atmospheres
3002 | Parks, Construction, Harbors
3003 | Jungles, Swamps, Mountains, Deserts, Forests
3004 | Country and Residential
3005 | Highways and Airports
3006 | Outdoor Crowds
3007 | Outdoor Crowds
3008 | Indoor Crowds
3009 | Indoor Crowds
3010 | Restaurants, Bars, Offices
3011 | European Ambiences
3012 | Room Tones

Series 7,000 Ambience II

Series 7,000 Ambience II ($495) is on 15 CDs containing more than 350 contemporary ambiences.

7001 | Barns, Countrysides, Forests, Jungles, Marshes, Mountains, Oceans, Storms, Winds
7002 | Airports, Arcades, Ballrooms, Banks, Bars, Basketball, Beaches, Billiard Halls, Boardrooms, Bowling, Fairs
7003 | Bus Stations, Casinos, Cities, Construction, Conventions
7004 | Indoor Crowds (Small, Medium, and Large), Outdoor Crowds (Medium and Large)
7005 | Harbors, Hockey, Hospitals, Household, Industries, Libraries, Lobbies, Markets, Office Foyers, Parades
7006 | Parks, Parking Lots, Parties, Playgrounds, Residential, Restaurants, Room Tones
7007 | Room Tones, Schools, Service Stations, Ice Skating, Stadiums
7008 | Stock Exchanges, Stores, Subways, Swimming Pools, Symphonies, Theatres, Train Stations
7009 | Scenes: Barns, Battles, Caves, Christmas, Cities, Courtrooms, Dinosaur Parks, Earthquakes, Fight Scenes, Forest Fires, House Fires, Horror, Police Accidents, Steam Train Stations, Western Streets
7010 | Foreign Ambiences From: Australia, Austria, Belgium, China, Czech Republic
7011 | Foreign Ambiences From: Czech Republic, Denmark, Egypt, England, France
7012 | Foreign Ambiences From: Germany, Hong Kong, Hungary, Iceland, India
7013 | Foreign Ambiences From: India, Italy, Japan, Korea, Luxembourg, Malaysia
7014 | Foreign Ambiences From: Mexico, Nepal, Netherlands, Poland, Russia, Scotland
7015 | Foreign Ambiences From: Scotland, Spain, Switzerland, Taiwan, Thailand, Uruguay

Series 10,000 Ambience III

The Series 10,000 Ambience III ($495) is on 14 CDs containing sound effects from 28 different countries and national regions, with five of New York City, and the remaining CDs are sounds of forest, water, rural, rain, residential, city, construction, industry, traffic, crowd, room tone, office, and other backgrounds.

S10-01: | Barns
 | Foreign Ambiences From: Australia, Belgium, Bolivia, Brazil
S10-02: | Cities, Construction, Countrysides
 | Foreign Ambiences From: Brazil, China
S10-03: | Indoor and Outdoor Crowds, Forests
 | Foreign Ambiences From: Czech Republic, England
S10-04: | Harbors
 | Foreign Ambiences From: France, Germany, Guatemala, Hawaii, Hungary
S10-05: | Industries and Foreign Ambiences From: India
S10-06: | Foreign Ambiences From: Italy, Luxembourg, Mexico, Netherlands
S10-07: | New York Ambiences—Airport, Bank, Bar, Boat, Bus Terminal, Chinatown, City
S10-08: | New York Ambiences—City, Construction, Crowds
S10-09: | New York Ambiences—Horse, Hotel, Library, Market, Office, Park
S10-10: | New York Ambiences—Park, Restaurant, Store, Subway, Traffic
S10-11: | New York Ambiences—Traffic, Train Station
S10-12: | Post Offices, Rain
 | Foreign Ambiences From: New Zealand, Pakistan, Philippines, Poland
S10-13: | Residential, Restaurants, Room Tones, Schools, Traffic
 | Foreign Ambiences From: Russia, Switzerland, Thailand, Turkey
S10-14: | Water Ambiences: Falls, Oceans, Rivers, Streams
 | Foreign Ambiences From: Turkey, Venezuela

Nightingale Voice Box 1 and 2

Nightingale Voice Box 1 and 2 ($250) is on two CDs containing over 1,500 sound effects like laughing, crying, screaming, eating, breathing, coughing, sneezing, pain and ecstasy, and broadcast and P.A. section. It also includes news, weather and sports, yodeling, auctioneers, nursery rhymes, telephone operators, cheering, lots of kids’ stuff, stereo location ambience, many multilingual tracks, and more than 50 tracks of words, phrases, and sayings.

Nightingale Voice Box 3—Just Kids and Babies

Nightingale Voice Box 3—Just Kids and Babies ($129) is on one CD that contains 99 great tracks of children, toddlers, and babies eating, screaming, crying, whining, singing, and playing.

Great Speeches of the 20th Century

Great Speeches of the 20th Century ($75) is on four CDs that contain some of the most well-known speeches of the 20th century, spanning the years 1908-1991. Each speech has been edited to include the most memorable and noteworthy segments, and every attempt has been made to include a variety of speakers in the political, historical, inspirational, and topical categories.

Historic Presidential Speeches

Historic Presidential Speeches ($95) is on six CDs featuring 85 years of presidential oratory in their own voices: 17 of America’s chief executives variously sharing their visions, coaxing a nation to support their political programs, and appealing for votes.


Hollywood Edge (

Team LiB

Hollywood Edge (www.HollywoodEdge.com)

Click To expand

E-mail: Jmoran@SoundLux.com
Phone: (323) 603-3253
Fax: (323) 603-3298

The Hollywood Edge, a division of Livewire Studios Soundelux is one of the largest publishers and distributors of high-quality sound effects, production music, and specialty audio hardware. With over 70 multiple-disc collections, which include hard-to-find sound effects and special field recordings, The Hollywood Edge productions are the most usable effects library available. Oliver Stone, Martin Scorsese, and John Hughes are among the filmmakers who highly recommend the vast collection produced and compiled by the award-winning sound designers and editors from Soundelux.

3DSFX Series

The 3DSFX Series ($295) is a six-CD set.

CD 1: | Contains modern train sound effects (foreign and domestic), including train station ambiences, clean and unique.
CD 2: | Vintage train effects—steam engine trains, diesel trains, idles, and couplings
CD 3: | Nautical vessels like submarines, sailing ships, rowboats, hovercrafts, fans, horns, engine rooms, and more
CD 4: | Nautical atmospheres like water laps and waves of every known variety
CD 5: | Rivers and waterfalls natural water sound
CD 6: | English and foreign crowds from boxing and barbecue crowds to Afghan and German crowds

Signature Series: Alan Howarth

Signature Series: Alan Howarth ($395) is a five-CD set.

CD 1: | Sound effects like aircraft, aerospace sounds, metallic devices, and trains
CD 2: | Sound effects for building earthquake, fire, ice, and wind tracks
CD 3: | Sound effects of automobile racing and crowd effects from Israel
CD 4: | Sound effects like the horror and medieval genre, with the addition of a unique collection of horse effects
CD5: | Nature sound effects from Israel and an excellent variety of water and underwater sounds

American Zeotrope

American Zeotrope ($495) is on seven CDs that contain hundreds of original vehicle and moving machine sounds, including Mustangs, Buicks, Lincolns, Pontiacs, Impalas, Corvairs, Falcons, and the limited-production Tucker car types such as limos, taxis, ambulances, emergency vehicles, hot-rods, and muscle cars. Vehicle sounds were recorded on road surfaces ranging from gravel, dirt, city streets, highway, and wet pavement at varying speeds: racing, slow driving, stalled, and steady. Isolated car sounds are included such as wipers, doors, trunks, horns, tire peel-outs and blow-outs. Other moving vehicle sounds include motorcycles, trucks, trains, tugboats, ferries, subway cars, and related ambiences.

Animal Trax

Animal Trax ($495) is on ten CDs containing over 1,200 animal sounds like lions, tigers, bears, leopard growls, hyena laughs, snake strikes, gorilla grunts, baboon screams, and whale and dolphin calls. There are also sounds from birds, snakes (rattlesnakes, vipers, python, boa, cobra), lizards, alligators, a toad, a frog, cats, dogs, a goat, a horse, a pig, a sheep, primates (monkeys, gorilla, chimpanzee, baboon), an elk, cattle, bobcats, a lynx, boars, ocelots, pumas, wild cats, pandas, raccoons, camels, coyotes, wolves, bats, a hippopotamus, rhinos, sea lions, and a walrus.

The Animation Collection

The Animation Collection ($395) is on five CDs containing 1,600 completely individualized sound effects including whistles (sport, train), whoopee, squeaks (a gate, glass, rubber, wheels), swishes, twangs, warbles, horns, telephone ring, bells, squishes, bubbles, raspberries, Jew’s harp, rubberband, baby (coos, laughs), moans, hiccups, snoring, chewing, kisses, fighting grunts, door (open, knocks, slam, and closes), footsteps, grinds, sawing, rips (cloth, paper), anvil hit, wood drop, match lights, can hit, dish and glass breaks, metal hit, trash can band and rattles, alarm, explosions, sword play, Sci-Fi, animal sounds (cat, dog, horse, chicken, rooster, chimp, cow, donkey, pig, elephant, duck, and seal) and music instruments (violin, trumpet, French horn, drum, cymbal, and electric guitar).

Apocalypse Now

Apocalypse Now ($395) is on five CDs containing sound effects like aircrafts, including Hueys, Loaches, and Phantoms. Vehicles: tanks, APCS, Amtracs, PBR. Weaponry; M-16, M-60s, Russian SKS, Howitzers, mortars, napalm. Troop activity, backgrounds, walla, and foley.

Background Trax

Background Trax ($295) is on five CDs containing ambience sounds from areas such as a computer room, a department store, a hallway, a police station, a restaurant, a school, a super market, Africa, a jungle, the wind, an airport, from exteriors of cars, trains, trucks, on an elevator, at night, in traffic, listening to the rain, a flowing river, a busy sink, waterfalls, and waves.

Burtis Bill’s Sounds of the American West

Burtis Bill’s Sounds of the American West ($249) is a three-CD set.

Disc 1: | Capture the feeling of sleeping out on the open range with the sounds of a campfire being built after a hard day’s work. Climb on your horse, take a ride in a stagecoach, pan for gold in the great California rush, and hear the echo of the bugle call as you arrive in the Old West.
Disc 2: | Experience the transition from frontier to factory with machinery from the Industrial Revolution. Hear the rumblings of a diesel drill and wheat grinder, the gears of hand-operated factory machinery, and factory backgrounds dating back to the turn of the century.
Disc 3: | Pull into the station with the sounds of a stream train, whistles, and blowdowns, bys and steadies, onboard ambiences, and unparalleled air and steam releases. Also included are the sounds of a Model T, from start up to drive away, with interior steady and multiple bys. Disc two also contains weapons, from quickdraws and pistol shots to revolver cocks and chamber spins—everything you need to sweeten an Old West shootout.
Disc 4: | Hear the sounds of what are now ghost towns, with music, dancing, saloon doors, cork pops, spittoon “impacts,” and card game trouble. Make your own bar brawl, buy some staples at the old general store, lock up your favorite outlaw, or hear a sweet tune on your own Victrola. Create a picture in your mind with the sounds of an entire western town.

Busted Effects and Most Wanted

Busted Effects and Most Wanted ($249) is on three CDs containing sound effects such as mangled cars trying to start, a 747 taking off ten feet away from you, broken exhaust fans, large animal traps, earthquake rattles, elephant gunshots, dead batteries, aircraft, alarms, animals, high school cheerleaders, old and broken clocks, computers, slamming doors, electrical explosions and zaps, broken machines and miscellaneous noises, train horns and engines, busted vehicles, and much more.

Chase Scene Elements

Chase Scene Elements ($395) is on five CDs containing sound effects like cars crashing, tires skidding and peeling, an automobile leaving the pavement and bounding back down, and sometimes a cliff drop, roll, and fiery crash below, real impacts, crashes, and cliff and water drops staged exclusively for this set. Cars were dropped from over 100 feet and crashed onto different surfaces. Others were rolled off of 250 cliffs, and special ramps were constructed for jumps and crash maneuvers, crashes (stationary and moving impacts), skids, peels, 180 degree spin-outs, surface changes (paved road and off-road), cliff drops, water drops, cornering, other high-speed maneuvers including driving at various speeds, hard ins, and jumps/hills/bumps. The types of vehicles featured include a compact automobile, full size automobile, sports utility vehicle/truck, and a sports car.

Cartoon Trax

The Cartoon Trax ($395) is on five CDs with an optional (which can be purchased separately for under $500) fully cross-referenced and indexed guidebook for sound effects, like bees swarming, flies buzzing, bird caws, animal sounds (bat, chicken, ducks, pigs, lamb, wolf, elephant, goat, horse, donkey, dog, cat, frog, gopher, and squirrel), cow bells, fire bells, alarm clocks, gong, Jew’s harp (boing), bubbles, twang, crashes and impacts, explosions, water sounds, musical instruments (timpani drum, cymbal, trumpet, sax, trombone, oboe, xylophone, guitar, accordion, and cello), footsteps, nose blowing and sneezing, car horn, laughing, crying, kisses, raspberries, grunts, knocking, pan hits, and motor sounds.

CityTrax

CitiTrax ($495) is on ten CDs containing hundreds of hours of full spectral stereo recordings made on location, on DAT, that were pared down to the finest ten hours of environment ever made. From the first disk, the sound of the city jumps into your face with busy sidewalks. Two tracks later there is a different version with the added dimension of footsteps. You can almost tell the pedestrian is wearing a pair of Bass loafers from the clicking heels as he moves into perspective and then passes by on a track that’s almost three minutes long. The traffic roars by as horns honk. The sound of jackhammers and a passing police car add to the full stereo spectrum, completing the aural illusion. The camera passes into the doorway of a department store and the sound crossfades from urban noise to a shopping mall interior.

Dynamic Range

Dynamic Range ($395) is on two CDs containing over 1,000 gun and ammo sounds like gun blasts, ricochets, whistling bullets, hits on multiple surfaces, silencers, interior and exterior shots, handling sounds, and more. It features 30 different weapons, including pistols, shotguns, rifles, automatic fire, machine guns—the works.

The Edge Edition

The Edge Edition ($295) is on four CDs containing over 800 newly created sound effects, like motorcycles, cars, trucks, 747 jets, airports, amusement park rides, impacts, office sounds, slamming doors, buzzers, telephones, clocks, 16mm video camera, crashes, toilets, alarms, animal sounds (birds, horses, wolf, cat, dog, pig, monkey, dolphin, elephant, bee swarm), large crowds, avalanche, wind, rain, river, bubbles, party sounds, baseball, golf, explosions, telephone, cash register, sound of material such as metal, wood, and glass, dentist drill, footsteps, door sounds (open, close, and slam) and human sounds such as laughing, crying, screaming, heart beating, whispering, farting, and belches.

Eerie Edition 1

The Eerie Edition 1 ($295) is on three CDs containing spooky sounds like human moans, heavy breathing, laughing, crying, chanting, pig squeals, animal growls, scratching sounds, heartbeats, footsteps, wind, dry ice, metal gates and chains, and wood creaking.

European Edition

Pinewood Studios, London, has always been regarded as the MGM of Europe. European Edition ($595) is a 20-CD set.

Sound effects of rare European vehicles are available, spanning from the turn of the century to the present day, from a horse-drawn carriage on a cobblestone street to supersonic jets. The Hollywood Edge European Edition contains unique British and European atmospheres and wallas—
hotels, restaurants, airports, city streets, and even the sounds of the countryside, British-style telephones, door buzzers, sirens, horns, European racing cars and motorcycles, and sound effects like the jungle, the forest, kitchen appliances, construction site sounds, computer room sounds, International market sounds, International airport sounds, wind, dry ice, and footsteps.

Explosions for the 21st Century

Explosions for the 21st Century ($195) is on two CDs containing sound effects like bombs (150 pounds of explosives), a car blown up, concrete structures blown up, an explosion with debris made of glass, metal, rock, and wood, as well as water splashes. The Hollywood Edge is pleased to present Patricio Libenson’s signature explosion sound effects series, recorded on an MTR-90 II Otari 24/16 track recorder using a 4TDFä multi-microphone arrangement and Class A mic pre-amps to obtain the best possible sound.

File Effects

File Effects ($495) is on ten CDs containing over 250 sounds, most of which are in the three-minute duration range. Ambience sound effects range from modern computer offices and train stations to footsteps and squeaky wooden floors, Hong Kong harbor hooters, traffic, moaning wind, and as you would expect, wonderful interior ambiences. The collection categories include Skylines, Interiors and Exteriors, the Elements, Travel, Transportation, and Industry. An airplane flying over at the wrong time, or a car passing by when you’ve captured the perfect quiet spot for recording bird calls can create a totally unusable end.

Foley Sound Effect Library

Foley Sound Effect Library ($395) is on five CDs containing over 1,600 Foley sound effects like whizzes, swooshes, clunks, squishes, crashes, clashes, bumps, binks, sizzles, creaks, rattles, clinks, cracks, and impacts. Foley recordists at Soundelux Studios in Hollywood have captured each glass smash, metal wronk, meaty punch, wood crash, and sword clash. The CD set will feature the Foley sounds of blunt and edged weapons, fight kicks and punches, metal, glass, and wood impacts, casino effects, paper movement, and much more.

Disc 1: | Hear the bangs and clangs of metal impacts in the Foley series. From big ronks to small impacts, experience the eerie metal scrapes and strains, drops and warbles, and ricochets and groans of metallic foley.
Disc 2: | Listen for the thumps and splinters of wood along with the crashes and shatters of glass in this wood and glass impact disc. From wood falls, splits and bat hits, to glass smashing, window breaking, and bulb shattering, this Foley disc will allow you to sweeten everything from bar fights to huge explosions.
Disc 3: | Experience the sounds of a medieval battle in the third of this five CD set. From knife draws, sword clanks, wooshes, shield impacts, and axe clashes to arrow whistles and flame sizzles, shape your conflict with this extensive battle collection.
Disc 4: | Fight to the finish with the fourth disc in the Foley collection. Find the meatiest punch, the best body blow, the heaviest kick, and the most gruesome cracks, crunches, stabs, breaks, and falls to sweeten any conflict, from big brawl to minor scuffle.
Disc 5: | Round out your Foley effects collection with a catch-all disc direct from the Soundelux stages. From card games and coin jingles, soft kisses and hard hugs, soda fizzles and beer gulps, flag flaps and animal traps to leaves rustling, chains clanking, jewelry jingling, and hand shaking, this potpourri of sounds will surely round out your personal Foley library.

Foley Footsteps (Sonic Boom)

Sonic Science Foley Footsteps ($75) is on one CD containing over 700 sound effects of male and female footsteps recorded on a range of surfaces at a variety of walking speeds. Some surfaces include cement, wood, grass, gravel, metal, and snow. There are sounds of individual steps, paced steps, shuffles, running, jumping, and climbing stairs.

Futurity’s Metropolis

Futurity’s Metropolis ($99.95) is on one CD and contains various sci-fi sound effects.

Hi-Tech and Top Secrets Effects

Hi-Tech and Top Secrets Effects ($395) is on five CDs containing entirely new sounding machines, rumbles, room tones, and start-ups recorded from classified and restricted experiments. Other sound effects include telemetry, human voices, short wave radio tuning and static, air release and blasts, electric zaps, tool sounds, mechanism, alarms, computer sounds, medical office equipment sounds, propeller, and heart simulator sounds.

Historical Series

The Historical Series ($349) is on six CDs that include many of the sounds that helped Soundelux (our parent company) win the Academy Award for sound on the film Braveheart, directed by and starring Mel Gibson. Many of these sounds are directly from Braveheart.

Disc 1: | War: Horses, Armies, and Weapons. This CD includes Infantry, Cavalry, Armies, and Horses that include up to 150 walking and charging.
Disc 2: | Churches, Bells, and Clocks. This disc includes clocks from the 17th century up to the 19th century and bells that include everything from Monastery to Cathedral.
Disc 3: | Horses, Carriages, and Traps. This CD includes horse-drawn carriages on different surfaces, including onboard, and different types of horse movements like shaking bridle, etc. Also included are different types of early doors.
Disc 4: | Castles, Palaces, and Monasteries. This disc includes many different types of doors and windows, wooden main gates, bolts and knockers, confessional box open and close, wooden vestry doors, and more.
Disc 5: | Traffic-Free Backgrounds, including cities, towns, villages, farmyards, courtyards, and more.
Disc 6: | European Myths and Legends. Included on this CD are dragons, potion explosive puffs, sea serpents, witches’ caves, trap door levers, beheading with swords, and more.

HPX Digital

HPX Digital ($795) is on ten CDs containing sound effects like ocean, seagulls, crickets, wind, rain, thunder, hurricane, large crowds cheering at basketball and football games, busy intersection and highway, airplanes, steamship, sci-fi, fishing, kitchen, bathroom, horror, train, building equipment and tools, shipping, office, war vehicles such as planes and tanks, and weapons.

Laughs, Cheers, and Applause

Laughs, Cheers, and Applause ($199) is on two CDs featuring reactions of crowds from 15 to 50,000 people (actual variations include crowds of 15, 20, 50, 100, 20,000, 30,000, and 50,000 people). The professionals at The Hollywood Edge have gone to live performances, set up the mics in various parts of the audience, and have digitally recorded extensive LIVE vocal and crowd reactions. The spectral stereo separation places you in the very center of the crowds. The effects are all real, not an assembled gathering of actors in a set-up environment.

Lon Bender’s Wacky World Of Widgets

Lon Bender’s Wacky World Of Widgets ($195.99) is on one CD containing some of the best and most bizarre effects in the realm of robots and gizmos, presented as both individual effects and elaborate designs of multilayer effects. Lon Bender, the award-winning designer of the set, has personally gone through hundreds of sounds and picked over 450 of the best gadgets to be included.

Martial Arts and Human Impacts

Martial Arts and Human Impacts ($60) is on one CD, the most realistic karate kicks, punches, blocks, and body blows available to the public. Recorded in part on the sight of Ken Nagayama’s School of Martial Arts, this collection contains some of the most realistic bone-breaking punches, quick kicks, body slams, board breaks, weapon impacts, mid-air flips, and blood curdling yells ever recorded.

Metropolis II

Metropolis II ($129) is a single dynamic sound effects CD full of fresh and original production elements, it features 99 tracks of audio wizardry ranging from the electronic whoosh to the giant cavern ambiance and everything in between.

T.H.E. Music Library

T.H.E. Music Library ($4497.95) is a 45-CD set that comes delivered in commercial length, containing over 550 themes :60, :30, :10, as well as extended lengths, alternative/lighter mixes, and is feature film quality music.

Paradise (Sonic Boom)

Paradise ($395) is a five CD library that brings the sounds of nature together. From the lost jungles of Montserrat to the thundering waterfalls of Trinidad, Paradise transports the magic of distant lands home. Primarily recorded on the island of Montserrat only weeks before the devastating volcanic eruption, this collection captures for eternity the beauty and mystique of this tiny oasis in the South Caribbean. Listen to the language of island commerce in the markets, a church choir, birds in the rainforest, volcanic vents, the sizzling sounds of the surf, the clicking of coral, SCUBA, waterfalls, thunder and rain, and the unique sound of bamboo stalks creaking in the wind. It includes 105 full-length ambience tracks. CD titles include Cultural, Rainforest, Residential, Waves, and Waterfalls.

Peter Sullivan Signature Series

Peter Michael Sullivan has traveled around the world to bring into your studio the absolute finest environmental textures and effects. His Signature Series ($150) two-CD set was recorded entirely on location and edited over several years, there is no other library like it! Sound effects include thunder, rain, and wind. The Asian Jungle Dawn spans well over two minutes and captures both the ambient beauty and terror that accompanies the squawk of tropical birds.

The Premiere Edition (Volumes 1 to 20)

The Premiere Edition (Volumes 1 to 20) ($895) is on 20 CDs containing the best sound effects. Some of the sound effects run a full four minutes with these variations of rainstorms and ambient nature sounds.

The Premiere Edition 2 (Volumes 21 to 30)

The Premiere Edition 2 (Volumes 21 to 30) ($495) is on ten CDs containing never-before heard, completely original sound effects from the Hollywood Edge.

The Premiere Edition 3 (Volumes 31 to 40)

Premiere Edition 3 (Volumes 31 to 40) ($495) is on ten CDs meeting and surpassing the expectations for high quality sound effects.

The Premiere Edition 4 (Volumes 41 to 50)

Premiere Edition 4 (Volumes 41 to 50) ($595) is on ten CDs featuring the latest addition to its signature sound effects collection with more than ten hours of audio and 1,200 effects. The set contains many hard-to-find effects such as great room tones, cloth movement, new computers, hi-tech sounds, real and Foley rain, and wood and metal scrapes of every kind. There are effects from Academy Award-winning sound designers and field recordings from the new Los Angeles subway, downtown Los Angeles, and the Los Angeles International Airport.

Sound Designer’s Toolkit

Sound Designer’s Toolkit ($495) is a five-disc set of production elements and includes three discs of various stingers, rumbles, booms, whooshes, and hits, plus two additional discs of musical effects, hits, accents, and music beds.

Sounds of a Different Realm

Sounds of a Different Realm ($295) is on three CDs where the first two CDs, “Unusual Presences,” contain a unique collection of ethereal presences, deep bass textures, ambient hums, swirling winds, steamy atmospheres, whirling tones, gaseous presences, industrial pulsing, and much, much more. The third CD, “Common Sounds Heard in Uncommon Ways,” is a curious world of sound lurking beneath the surface of household items.

Sounds Of Speed

Sounds Of Speed ($695) is a 20-CD set that is far and away the most comprehensive collection of racing sound effects ever put together with constants from the driver’s perspective using microphones mounted on actual boats, bikes, and cars, as well as NASCAR, CART Indy, Indy Lights, Toyota Atlantic Racing, Formula 1, FIA GT Cars, World Sports GT Cars, Off-Road, Motorcycle Road Course, Motocross, Vintage Race Cars, Dragsters, Monster Trucks, Go Karts, Demolition Derby, Off-Shore Power Boat, Inboard and Outboard Boat Racing, Unlimited and Limited Hydroplane Racing, Victory Ceremonies, Pit, Paddock, Garage, Crowd, and General Racing Ambiences.

Sports With Balls

Sports With Balls ($495) is a three-CD set designed by Hollywood’s top sound designers and editors and produced by Lon Bender, Wylie Stateman, and Tod A. Maitland. This huge, hard-hitting, “in your face” sound collection of sports effects and surround crowds contains every sports effect imaginable from baseball, football, basketball, ice hockey, and more. The sounds of heavy body hits, line crunches, baseball bat cracks, and football flying spirals are all a part of this “game-day” collection. The Hollywood Edge has assembled the first complete surround crowds library, including huge arena crowd reactions.

Star Trax

Star Trax consists of sound effects like trains, helicopters, ships, airports, street, pedestrian, country road, motorcycles (Suzuki GS 1100 G and Honda CX 500), diesel car, a Trabant 601 (an East German car), restaurant, escalator, German chatting, theater, hall, disco club, fish market, Oktoberfest, German amusement park, road work, steel and wood doors, steel gate, police car, and telephone rings.

Super Single I and II

The Super Single I ($60) and II ($60) provide a wide variety of effects for a producer on a tight budget. The very same exacting precision of the Premiere Edition is undertaken for the Super Single. The Hollywood Edge has taken to heart the most requested sound effects and created an all new Super Single series. There are military sounds, all kinds of crashes, car doors, horns from cars and trains, cartoons, animals, and loads of footsteps.

The Works

The Works ($495) is on ten CDs containing 2,870 sound effects which include the sounds of motion, action, and force like appliances, buttons, switches, levers, ratchets, gears, pneumatics, friction, stress, servo-motors, tiny mechanisms, compartments, doors, tape machines, engines, and so much more. It also features work environments such as manufacturing plants, industrial machines, conveyors, shipping, packaging, and construction work (interior and exterior).

Worldwide Sports Edition

Worldwide Sports Edition ($495) is on ten CDs containing a huge collection of sporting sounds from around the world, from the crack of a homerun bat to the punch of a heavyweight boxer. Other sports sounds range from Football, Baseball, Hockey, Soccer, Boxing, Golf, Diving, Swimming, Tennis, Ping-Pong, Billiards, Track and Field, Martial Arts, Roller Blading, Ice Skating, Gymnastics, Biking, and Racquetball, including crowd noises.


Appendix D: CD-ROM Contents

Reel Deal Poker Challenge

Click To expand

Poker has never been so much fun on the PC. In Reel Deal Poker Challenge, you will be able to actually sit across the table from your opponents. For the first time in gaming history, you have the chance to watch for bluffs, watch highly animated character reactions to how you play, and be able to better your skill and reputation as a poker player.

When you create a new player in Reel Deal Poker Challenge, you will have no reputation and very little cash. As you play intense tournaments, you have the chance to earn prize money and increase your reputation. As your reputation increases, you will be invited to more prestigious poker games in the Poker Palace.

As you advance to other floors in the palace, watch your characters advance in skill and poker ability. As the stakes increase, you can win incredible virtual prizes and trophies, kept in your own customizable prize vault.

Do you have what it takes to make it to the top? Can you hang with the intense tournament games? Can you win the grandest of prizes? Only your own skill and intuition can decide.

Slots are also available in Reel Deal Poker Challenge. Order from www.PhantomEFX.com.

Click To expand


Awave Studio v8.5

What Can Awave Studio Do?

Click To expand

Awave Studio is a multipurpose audio tool that reads a veritable host of audio carrying file formats from different platforms, synthesizers, and trackers. It can be used in a variety of ways: as an audio file format converter, an audio editor, an audio and MIDI player, and, last but not least, a wavetable synthesizer instrument editor and converter.

Here are just a few examples of possible uses:

  • Do you have a strange audio file that you want to use but can’t figure out how to convert it into any sensible format that can be used by the programs you need? Maybe you even have a large number of files that you need to convert or process in some way. Chances are good that Awave Studio can help you.

  • Are you a composer? Have you ever wanted to take advantage of all those free instruments floating around the web but found it impossible to get them in a format suitable for your synthesizer? Awave Studio reads the instrument formats of most (if not all) commercial synthesizers and sound cards and can also write a fair number of them. It also supports both SDS and SMDI, so you can send samples over MIDI or (really fast) over SCSI using these standard protocols.

  • Have you ever wanted to play a standard MIDI file song that comes with an “instrument bank” that was created for another wavetable sound card than yours? Awave Studio can make not only high quality conversions between most of the major sound cards; it can also load both the MIDI song and the instruments and play it directly for you.

    And that’s not the end of it—it can even write the song to a WAV file on disk for you (which you could later convert to MP3 format and distribute on the web).

  • Do you need a simple audio editor? You can do such things as resampling, fading in and out, maximizing amplitude, applying effects, and more.

  • Do you need an instrument editor for your wavetable sound card? Or are you not satisfied with the one you have? It provides full support for all of the features (in fact, a superset) of both the new DownLoadable Sounds level 2 standard and the SoundFont 2.0 standard. You can also customize it for use as an editor for many other formats as well.

File Formats Galore

Awave Studio can read almost any imaginable audio or instrument file format—over 200 of them in fact. It can also write to about 100 of them.

Features

This program does so many different things.

  • It can do conversions from about 200 audio-related file formats that it can read (no kidding—you read that right—200 formats) into any of the 100 or so audio file formats that it can write. No other software even comes close to such a wide format support.

  • It can do quality conversion between the instruments formats most common to PC synthesizer sound cards. Some examples: SB AWE32, SB Live!, all Vortex II-based cards, TB Pinnacle, TB Maui, AVM Apex, Gravis UltraSound, and UltraSound PnP.

  • It can convert MIDI (and similar) song data between several formats and package MIDI songs together with custom instruments in a single file (e.g., you can convert MOD-tracker modules into MIDI-format accompanied by custom instruments). Or why not convert melodies between different mobile phone ring signal formats?

  • It can read and write instrument formats for many commercial synthesizers and hardware modules, as well as many popular software synths, including formats from Ensoniq, Akai, Korg, Kurzweil, Roland, Yamaha, Native Instruments, Creamware, and many more.

  • It can send or receive waveforms to professional synthesizers using standard SDS transfers over MIDI or really fast SMDI transfers over SCSI.

  • A Batch Conversion Wizard makes converting large numbers of audio files extremely simple (and with optional effects processing).

  • The Audio Processing Wizard lets you accomplish many common editing tasks, like resampling, fading, cutting and pasting, merging and combining waveforms, and more. DirectShow audio effect filters (aka DirectX plug-ins) are also supported, opening up a whole world of third-party effect processing modules. It can work on multiple waveforms at once just as easily as on a single.

  • A nice example of a use for the Audio Processing Wizard is the “cross-fade loop” function. Using this, you no longer have to search in vain for that elusive optimal loop point. Just select a likely portion of the waveform and cross-fade it and voilá—you have a good-sounding loop.

  • The Instrument Processing Wizard helps you in many ways to avoid having to manually do repetitive editing tasks on multiple instruments. The MIDI Processing Wizard gives you tools for doing things like transposing notes or changing the tick rate.

  • It is a fully featured DLS level 1, DLS level 2, and SoundFont 2.1 wavetable instrument editor. But you can also use it as an editor for many other instrument formats. For some, it is the only PC editor. You can customize the editing user interface for your particular soundcard by using the parameter set feature. Predefined sets for common synthesizer soundcards are available.

  • It has an easy to use and understand two “panes” layout: a hierarchical instrument “tree” to the left and waveforms to the right.

  • Graphical editors are available for instrument parameters (e.g., the much applauded loop editor lets you easily find the best loops—refined to perfection based on feedback from our users).

  • Play MIDI files with custom instruments using the MIDI Player. Works on any computer with a basic sound card and DirectX 7 or later; you don’t have to have a sound card with a fancy MIDI synth. And MIDI songs are guaranteed to sound exactly the same on all computers since it uses Microsoft DirectMusic technology and DLS synthesis (DX 8 required for DLS level 2).

  • Record your MIDI songs (with or without custom instruments) to a WAV file on disk using the software synthesizer, an all-digital process. This is great if you later want to convert it to MP3 format.

  • Audition your instruments directly using any of the several natively supported synthesizers (including DirectMusic and the Microsoft software synthesizer or the simpler internal sound mixer). Use the PC keyboard or an external MIDI keyboard to play. Or use the Audio Player (with real-time oscilloscope or frequency analyzer display) to play back audio files; it’s even integrated into the Windows shell so that you can play files with a click of the right mouse button.

  • Record new waveforms using the Waveform Recording Wizard.

OK, that was a long list, so what doesn’t it do? Well, just to clear up a few common questions: It does not convert WAV to MIDI, it isn’t a MIDI editor/sequencer either, and it won’t perform any acts of black magic. Also, it does not handle really huge audio files (those that are too large to fit in memory), and 16-bit PCM mono/stereo is the internal precision used. But check out our Awave software if you need something to convert stuff (e.g., huge 24-bit multichannel recordings). If you are still unsure that it will do what you want, why not download and try the free 30-day trial shareware version?

So, finally, how does it stack up against competing products?

Awave Studio has now been close to ten years in the making. If you do a point-by-point comparison with other conversion software, you will find that:

  • It is more versatile (e.g., it not only converts files, but it also has editing features, it can do batch conversions, it can play songs, etc.).

  • It supports a lot more file formats.

  • It usually does a better job by converting more paramaters and translating them more accurately.

  • It has a competitive price.

Of course, all other programs are not bad, but the amount of parameters supported and converted do vary somewhat from file format to file format. So if you are unsure, download the 30-day free trial version from the web site and compare for yourself. With this you can try almost all functionality. But there are certain limitations; as an example, you can try out SMDI transfers by sending from a synth to the program but not the other way around. You can save to all supported file formats, but you can only save once before having to restart the program. While you can save individual instruments, you can’t save a whole loaded bank of instruments. Limiting and frustrating when doing some real work for sure, it should be enough to try the quality of conversions fully. It is, after all, a trial version and 30 days of free full use.

Why You Should Buy It

Awave Studio is shareware; it is not free. This means that if you like the program and decide to use it past the 30-day trial period, you must register (i.e., buy it). There are also a number of incentives for registering it:

  • Removes nag screens and other annoying reminders

  • Removes save limit

  • Enables some locked features—copy/paste, saving “bank files,” and “batch convert”

  • You will receive word about updates and new releases (requires e-mail).

The price is $119.95

What you get:

  • You get a One Person—One Computer license, valid for the current program version.

  • You are sent a personal registration code that unlocks the shareware version, turning it into the full registered version.

Note that the license is personal and may not be transferred to another person or institution, and it allows you to have it installed on no more than one computer at a time.

Awave Studio support can be reached at awave@fmjsoft.com.

Import Formats

Awave Studio can Read (R) and/or Write (W) the following file formats:

Ext. | R/W | Format
669 | R | 669 tracker module
AIFC | R | Compressed audio interchange file format
AIFF | R+W | Audio interchange file format
AIS | R | Velvet Studio Instruments
AKP | R+W | Akai S5000/S6000 program file
ALAW | R+W | European telephony format audio
AMS | R | Extreme’s Tracker module format
AMS | R | Velvet Studio Module
APEX | R+W | AVM Sample Studio bank file
ARL | R+W | Aureal sound bank format
ASE | R | Velvet Studio Sample
AU | R+W | Sun/NeXT/DEC audio file
AVI | R | MS audio video interleave file
AVR | R | Audio Visual Research sound file
C01 | R | Typhoon wave files
CDR | R | Raw Audio-CD data
DCM | R | DCM module format
DEWF | R | Macintosh SoundCap/SoundEdit recorded instrument format
DIG | R | Digilink format
DIG | R | Sound Designer I audio file
DLP | R | DirectMusic Producer DLS file
DLS | R+W | DownLoadable Sounds level 1
DLS | R+W | DownLoadable Sounds level 2
DMF | R | Delusion/XTracker digital music file format
DSF | R | Delusion/XTracker digital sample file format
DSM | R | Digital Sound Module tracker format
DSS | R @ | Olympus DSS file
DTM | R | DigiTrekker module
DWD | R+W | DiamondWare digitized file
EDA | R | Ensoniq ASR disk image
EDE | R | Ensoniq EPS disk image
EDK | R | Ensoniq KT disk image
EDQ | R | Ensoniq SQ1/SQ2/KS32 disk image
EDS | R | Ensoniq SQ80 disk image
EDV | R | Ensoniq VFX-SD disk image
EFA | R | Ensoniq ASR file
EFE | R+W | Ensoniq EPS file—should work with all EPS-family!
EFK | R | Ensoniq KT file
EFQ | R | Ensoniq SQ1/SQ2/KS32 file
EFS | R | Ensoniq SQ80 file
EFV | R | Ensoniq VFX-SD file
EMB | R | Everest embedded bank file
EMD | R | ABT extended module
EMY | R+W | EMelody Ericsson mobile phone ring-tone format
ESPS | R | ESPS audio files
EUI | R | Ensoniq EPS family compact disk image
F2R | R | Farandoyle linear module format
F3R | R | Farandoyle blocked linear module format
F32 | R | Raw 32bit IEEE floating point values
F64 | R | Raw 64bit IEEE floating point values
FAR | R | Farandoyle tracker module
FFF | R+W | GUS PnP bank file format
FNK | R | FunkTracker module format
FSM | R | Farandoyle sample format
FZB | R+W | Casio FZ-1 bank dump
FZF | R+W | Casio FZ-1 full dump
FZV | R+W | Casio FZ-1 voice dump
G721 | R+W | Raw CCITT G.721 4-bit ADPCM format data
G723 | R+W | Raw CCITT G.723 3- or 5-bit ADPCM format data
G726 | R+W | Raw CCITT G.726 2-, 3-, 4- or 5-bit ADPCM format data
GDM | R | Bells, whistles, and sound boards module format
GI! | R | GigaStudio/GigaSampler split files
GIG | R+W | GigaStudio/GigaSampler files
GKH | R | Ensoniq EPS family disk image file
GSM | R+W | Raw GSM 6.10 audio stream
GSM | R+W | Raw “byte aligned” GSM 6.10 audio stream
GSM | R+W | US Robotics voice modems GSM w.o. header/VoiceGuide/RapidComm
GSM | R+W | US Robotics voice modems GSM w. header/ QuickLink
HCOM | R | Sound Tools HCOM format
IFF | R+W | Interchange file format
IMY | R+W | iMelody mobile phone ring-tone format
INI | R | MWave DSP synth’s mwsynth.ini GM-setup
INI | R+W | Gravis UltraSound bank setup
INRS | R | INRS-Telecommunications audio
INS | W | Cakewalk Instrument definition file
INS | R | Ensoniq EPS family instrument
INS | R+W | Sample Cell/II Mac instrument
INS | R+W | Sample Cell/II PC instrument
IST | R | Digitrakker instrument file
IT | R | Impulse Tracker module
ITI | R+W | Impulse Tracker instrument
ITS | R+W | Impulse Tracker sample
K25 | R | Kurzweil K2500 file (Note: KRZ is W also)
K26 | R | Kurzweil K2600 file (Note: KRZ is W also)
KIT | R+W | Native Instruments Battery drum kit file
KFT | R | Kort T-series image file
KMP | R+W | Korg Triton keymap file
KMP | R+W | Korg Trinity keymap file
KR1 | R | Kurzweil K2000/K2500/K2600 split file
KRZ | R+W | Kurzweil K2000 file (Note: Also works with K2500/K2600)
KSC | R+W | Korg Triton script file
KSC | R+W | Korg Trinity script file
KSF | R+W | Korg Triton sample file
KSF | R+W | Korg Trinity sample file
MAP | R+W | Native Instruments Reaktor format
MAT | R+W | Matlab variables binary file
MAUD | R | MAUD sample format
MDL | R | Digitrakker module
MED | R | OctaMED tracker module
MID | R+W | Standard MIDI file
MLD | R | MFi/MFi2—melody format for i-Mode (aka i-Melody)
MLS | R | Miles Sound Tools “compressed DLS”
MMF | R | SMAF songs—synthetic music mobile application format
MOD | R | Amiga and PC tracker module
MOV | R | Apple QuickTime audio
MP1 | R | MPEG audio stream, layer I
MP2 | R+W % | MPEG audio stream, layer II
MP3 | R+W * | MPEG audio stream, layer III
MPA | R | MPEG audio stream, layer I, II, or III
MPEG | R | MPEG 1 system stream
MPG | R | MPEG 1 system stream
MSS | R+W | Miles Sound System DLS 1 + XMI file
MTM | R | MultiTracker module
MUS | R | Doom/Heretic music file
MUS10 | R | Mus10 audio
MWS | W | MWave DSP synth’s instrument extract
NIST | R | NIST Sphere audio
NVF | R+W | Creative Nomand voice file
O01 | R | Typhoon voice file
OGG | R+W ! | Vorbis Ogg stream
OKT | R | Oktalyzer tracker module
P | R+W | Akai S1000/S1100/S01 program
P | R+W | Akai S3000/S3200/S2000/S2800 program
PAC | R | SB Studio II package
PAF | R+W | Ensoniq PARIS audio file
PAT | R+W | Advanced Gravis Ultrasound/Forte tech. Patch
PBF | R+W | Turtle Beach Pinnacle bank file
PCG | R+W | Korg Triton bank file
PCG | R+W | Korg Trinity bank file
PCM | R | OKI MSM6376 synth chip PCM format
PGM | R+W | AKAI MPC-2000/2000XL drum set file
PGM | R+W | AKAI MPC-3000 drum set file
PLM | R | DisorderTracker2 module
PLS | R | DisorderTracker2 sample
PRG | R+W | WAVmaker program
PSB | R | Pinnacle sound bank
PSION | R | PSION a-law audio
PSM | R | Protracker studio module format
PTM | R | Poly Tracker module
RA | W # | RealAudio audio file
RAW | R | Raw signed PCM data
RIF | R | Rapidcom Voice/Quicklink Rockwell ADPCM files
RMI | R+W | RIFF-MIDI file (with or without embedded DLS)
Rockwell | R+W | Rockwell 2-, 3-, 4-bit ADPCM format
S | R+W | Akai S1000/S1100 sample
S | R+W | Akai S3000/S3200/S2000/S2800/S01 sample
S3I | R+W | Scream tracker v3 instrument
S3M | R | Scream tracker v3 module
SAM | R | Signed 8-bit sample data
SB | R+W | Raw signed byte (8-bit) data
SBK | R+W | Emu SoundFont v1.x file
SD | R+W | Sound Designer I audio
SC2 | R | Sample Cell/II PC instrument (also W as .INS)
SD2 | R+W | Sound Designer II flattened file
SD2 | R+W | Sound Designer II data fork
SDK | R | Roland S-series floppy disk image
SDS | R+W | Raw MIDI sample dump standard file
SDW | R | Raw signed DWord (32-bit) data
SDX | R | MIDI sample dump standard files as compacted by SDX
SEQ | R+W | Sony PlayStation MIDI sequence
SF | R+W | MTU/IRCAM SoundFile format
SF2 | R+W | Emu SoundFont v2.1 file
SFARK | R | Melody Machine compressed soundfont
SFD | R | SoundStage sound file data
SFI | R | SoundStage sound file info
SFR | R | Sonic Foundry sample resource
SMD | R | SmdEd/J-Phone mobile songs
SMP | R | Avalon sample file
SMP | R | Ad Lib gold sample
SMP | R+W | Samplevision format
SND | R | Raw unsigned PCM data (Also W as .UB)
SND | R+W | AKAI MPC-60/2000/2000XL/3000 series samples
SNDR | R | Sounder sound file
SNDT | R | Sndtool sound file
SOU | R | SB Studio II sound
SPD | R | Speach data file
SPL | R | Digitrakker sample
SPPACK | R+W | SPPack sound sample
STM | R | Scream tracker v2 module
STS | R+W | Creamware STS-series sampler program
SVX | R | Interchange file format, 8SVX/16SV
SW | R+W | Raw signed word (16-bit) data
SYW | R+W | Yamaha SY-series wave files (really named W??)
TXT | W | ASCII text parameter description
TXT | R+W | ASCII text formatted audio data
TXT | R+W | RTTTL/NokRing mobile phone ring-tone format
TXW | R+W | Yamaha TX16W wave files (really named .W??)
UB | R+W | Raw unsigned byte (8-bit) data
UDW | R | Raw unsigned DWord (32-bit) data
ULAW | R+W | US telephony format (CCITT G.711) audio
ULT | R | UltraTracker modules
UNI | R | MikMod “UniMod” format
UW | R+W | Raw unsigned word (16-bit) data
UWF | R | UltraTracker wave file
V8 | R | Covox 8-bit audio (also W as .UB)
VAB | R+W | Sony PlayStation/PS2 bank file
VAG | R+W | Sony PlayStation/PS2 wave file
VAP | R+W | Annotated speech file
VOC | R+W | Creative Labs sound
VOX | R+W | Dialogic 4-bit ADPCM
VOX | R | Talking Technology Incorporated file
VSB | R+W | Virtual sampler bank file
W?? | R+W | Yamaha TX16W waveform (also see TXW)
W?? | R+W | Yamaha SY-series waveform (also see SYW)
W64 | R+W | Sonic Foundry Wave-64 format
WAV | R+W | MS Windows PCM wave
WA! | R+W | GigaSampler/GigaStudio compressed wave file
WFB | R+W | Turtle Beach WaveFront bank (Maui/Rio/Monterey)
WFD | R+W | Turtle Beach WaveFront drum set (Maui/Rio/
Monterey) |  |
WFP | R+W | Turtle Beach WaveFront program (Maui/Rio/
Monterey) |  |
WMA | R+W = | Windows media audio
XI | R+W | Fast Tracker 2 instrument
XM | R | Fast Tracker 2 extended module
XMI | R+W | Miles Sound System extended MIDI file

* R Unrecognized formats prompts user to supply basic info

@ DSS decoding requires Olympus DSS Player v3.x.

% MP2 encoding requires a free third-party DLL (TooLame.dll).

* MP3 encoding requires a free third-party DLL (Lame_enc.dll).

! OGG encoding and decoding requires free external DLLs.

# RA encoding requires free external DLLs from RealNetworks.

= WMA encoding and decoding requires free external DLL

(wmaudsdk.dll).


Image Eye v6.0

Image Eye is a specialized image viewer for the sole purpose of viewing images as quickly and as practically as possible and nothing else. You don’t get any menus, tool bars, or other fancy but sometimes annoying things cluttering up the window where you want to see a picture and nothing else. In fact, you can even have the window title bar disappear when you don’t need it, leaving just the image itself. There are many handy and practical user interface tricks—pressing Ctrl+Alt+X to close all image windows, just to mention one.

Features

  • The only image viewer you should need for browsing images

  • Small, very fast, highly tuned code with MMX support

  • Optimized display in all video modes—no compromises in image quality

  • A very sparse but powerful and helpful user interface

  • Nothing unnecessarily taking up space on your desktop

  • Supports all of the more common image file formats

  • Rotate, mirror, zoom, pan, and adjust contrast, brightness, sharpness, hue, saturation, and more

  • Full screen display when the window is maximized

  • Index feature with fast image thumbnail creation (disk caching optional)

  • Does not attempt to be any half-baked semi-editor or file format converter

  • Integrates well with Any Image software for advanced conversion capabilities

  • Smart background preloading and caching of images

  • Includes a simple slide show scripting language—roll your own presentations

  • “Run maximized,” “auto shrink,” “auto size,” “close all,” and other unique options

  • Image Eye can read many image file formats.

Image Eye support can be reached at support@fmjsoft.com.

File Formats

Image Eye can read all of these file formats:

BMP, DIB, RLE | Microsoft Windows/IBM OS/2 (device independent) bitmap
CAL, CALS, RAS | Computer aided acquisition and logistics support format
ICO, CUR | Microsoft Windows icon/cursor
IFF, LBM, BBM | Electronic Arts interchange file format
FIF | Iterated Systems fractal image file format
FIT, FITS NOST | Flexible image transport system
GIF | CompuServe graphics interchange format v87a, v89a
JPG, JPEG, JIF | Joint Photographic Experts Group, JPEG—JFIF
MAC | MacPaint image
NEO | Atari Neochrome image
PCX | ZSoft image—PC Paintbrush
PIC | Pictor/PC Paint
PNG | Portable network graphics
PSD | Adobe PhotoShop format
RAS, SUN | Sun raster format
RAW | Raw image file
PBM, PGM, PPM | PBMPLUS portable bitmap, graymap, pixelmap
TGA | Truevision TARGA image
TIF, TIFF Tag | Image file format


Any Image v2.5

Any Image is not an image editor or an image viewer. It is a tool that helps you quickly and easily do high quality conversions between common image file formats. Converting a single image is as easy as converting a huge number of images.

Click To expand

Features

  • Convert one file or many files—same quick three-step procedure.

  • No-compromises code optimized for both conversion quality and speed

  • Supports all of the more common image file formats

  • Image processing operations: Image resizing (by factor or to fit inside rectangle), framing options, undithering, sharpness control, color saturation, brightness, contrast and bias control, rotation and mirroring

  • Highest quality color depth reduction: Write images with 2, 4, 8, 16, 32, 64, 128, 256, 32 K, or 16 M optimized colors

  • Alpha plane, transparency color, and text fields converted for several formats

  • Automatically creates HTML image tables for image galleries or thumbnail indexes

  • Integrates well with our Image Eye viewer

  • Very affordable price

Any Image support can be reached at support@fmjsoft.com.

File Formats

Any Image can read (R) and/or write (W) the following graphics file formats:

BMP, DIB, RLE | R + W | Microsoft Windows/IBM OS/2 bitmap
CAL, CALS, RAS | R | Computer aided acquisition and logistics support format
ICO, CUR | R | Microsoft Windows icon/cursor
IFF, LBM, BBM | R | Electronic Arts interchange file format
FIF | R | Iterated Systems fractal image file format
FIT, FITS | R + W | NOST flexible image transport system
GIF | R + W | CompuServe Graphics interchange format v87a, v89a
JPG, JPEG, JIF | R + W | Joint Photographic Experts Group, JPEG—JFIF
MAC | R | MacPaint image
NEO | R | Atari Neochrome image
PCX | R + W | ZSoft image—PC Paintbrush
PIC | R | Pictor/PC Paint
PNG | R + W | Portable network graphics
PSD | R + W | Adobe PhotoShop format
PXR | R | Pixar format
RAS, SUN | R + W | Sun raster format
RAW | R + W | Raw image file data
PBM, PGM, PPM | R | PBMPLUS portable bitmap, graymap, pixelmap
TGA | R + W | Truevision TARGA image
TIF, TIFF | R + W | Tag image file format


Awave Audio v7.6

Click To expand

Features

Awave Audio is a dedicated audio file format batch converter.

  • Do conversions from about 60 audio file formats that it can read into any of the 30 or so audio file formats that it writes.

  • A three-step procedure makes converting large numbers of audio files both fast and simple.

  • Handle very large files without using up your memory. *

  • Handle audiophile-quality audio formats and 24-bit 192KHz multi-channel audio. Internal sample precision is 32-bit floating point. For improved sound quality, noise dithering is used when decreasing sample bit-depths (e.g., when going from 24- to 16-bit). [*]

  • You can do optional effects processing using up to four DirectShow effect filters (aka DirectX plug-ins, also used by many other professional audio software), as well as built-in functions such as resampling and silence removal.

  • Bonus feature: The Audio Recording Wizard easily lets you make new recordings.

  • Bonus feature: Read audio CD tracks (requirements: MMC2-compatible CD/DVD-ROM + ASPI32 drivers). *

Awave Audio support is reachable at awave@fmjsoft.com.

File Formats

Awave Audio can read (R) and write (W) many formats.

Ext | R/W | Type
AIFC | R | Compressed audio interchange file format
AIFF | R+W | Audio interchange file format
ALAW | R+W | Raw CCITT/ITU G.711 A-law format audio
AU | RW | Sun/NeXT/DEC audio file
AVI | R | MS audio video interleave file
AVR | R | Audio Visual Research sound file
CDA | R | Audio CD track
CDR | R | Raw audio-CD data
DIG | R | Digilink format
DIG | R | Sound Designer I audio file
DSS | R | Olympus DSS file %
DWD | R+W | DiamondWare digitized file
ESPS | R | ESPS audio files
F32 | R+W | Raw 32-bit IEEE floating point values
F64 | R+W | Raw 64-bit IEEE floating point values
G721 | R+W | Raw CCITT/ITU G.721 4-bit ADPCM format data
G723 | R+W | Raw CCITT/ITU G.723 3- or 5-bit ADPCM format data
G726 | R+W | Raw CCITT/ITU G.726 2-, 3-, 4-, or 5-bit ADPCM format data
GSM | R+W | Raw GSM 6.10 audio stream
GSM | R+W | Raw “byte aligned” GSM 6.10 audio stream
GSM | R+W | US Robotics voice modems GSM w.o. header/VoiceGuide/RapidComm
GSM | R+W | US Robotics voice modems GSM w. header/ QuickLink
IFF | R+W | Interchange file format
INRS | R | INRS-Telecommunications audio
MAT | R+W | Matlab variables binary file
MOV | R | Apple QuickTime audio
MP1 | R | MPEG audio stream, layer I
MP2 | R+W ¤ | MPEG audio stream, layer II ¤
MP3 | R+W * | MPEG audio stream, layer III *
MPA | R | MPEG audio stream, layer I, II or III
MPEG | R | MPEG 1 system stream
MPG | R | MPEG 1 system stream
NIST | R | NIST Sphere audio
NVF | R+W | Creative nomand voice file
OGG | R+W | Vorbis Ogg file
PAF | R+W | Ensoniq PARIS audio file
PSION | R | PSION a-law audio
RA | W # | RealAudio audio file #
RAW | R+W | Raw signed PCM data
RIF | R+W | Rapidcom Voice/Quicklink Rockwell ADPCM files
SAM | R | Signed 8-bit sample data
SB | R+W | Raw signed byte (8-bit) data
SD | R+W | Sound Designer I audio
SD2 | R+W | Sound Designer II flattened file
SD2 | R+W | Sound Designer II data fork
SDW | R+W | Raw signed DWord (32-bit) data
SF | R | IRCAM SoundFile format
SFR | R | Sonic Foundry sample resource
SMP | R | Samplevision format
SND | R | Raw unsigned PCM data
SNDR | R | Sounder sound file
SNDT | R | Sndtool sound file
SPD | R | Speech data file
SPPACK | R+W | SPPack sound sample
SVX | R | Interchange file format, 8SVX/16SV
SW | R+W | Raw signed word (16-bit) data
TXT | R+W | ASCII text formatted audio data
TXT | W | ASCII text parameter description
UB | R+W | Raw unsigned byte (8-bit) data
UDW | R+W | Raw unsigned DWord (32-bit) data
ULAW | R+W | Raw CCITT/ITU G.711 mu-law format data
UW | R+W | Raw unsigned word (16-bit) data
V8 | R | Covox 8-bit audio
VAG | R+W | Sony PlayStation/PS2 compressed sound files
VAP | R+W | Annotated speech file
VOC | R+W | Creative Labs sound file (older format)
VOC | R+W | Creative Labs sound file (newer format)
VOX | R+W | Dialogic adpcm
WAV | R+W | MS Windows PCM wave
WAV | R+W | “Extensible format” Microsoft waveform file
WMA | R+W = | Windows media audio (require wmaudsdk.dll) =

* MP3 encoding requires a free third-party DLL (Lame_enc.dll or

BladeEnc.dll).

¤ MP2 encoding requires a free third-party DLL (TooLame.dll).

= WMA encoding and decoding requires free external DLL

(wmaudsdk.dll).

# RA encoding requires free external DLLs from RealNetworks.

% DSS reading requires that the Olympus DSS Player v3.x is installed.

[*]* These are features that are not available with “big brother” Awave Studio, which does do a great many things (e.g., handling synthesizer instruments, collections, midi, editing, etc.) that Awave Audio won’t do.


Team LiB

Index

Numbers

20th Century Fox, 215, 230, 327
3DO, 86-87, 91-93
3DS Max, 113-114


Team LiB

Index

A

A * (A-star) pathfinding, 193-197
Acclaim Entertainment, 11, 86-87, 94-96
ACID PRO, 225-226
action game, 19-20, 70
Adobe Photoshop, 103-104, 108, 113, 369
ADR (Automated Dialogue Replacement), 200, 247
adventure game, 5, 16, 19, 20-21, 23-24
Alias|Wavefront Maya, 103, 106-108, 117, 174, 176, 179, 181, 187-188
Alice in Wonderland, 203-205
Alice in Planet Wonderland, 206-211
alienbrain, 116-118
All Dogs Go To Heaven, 9
Amiga, 9
Any Image, 369-370
Apollo 13, 27
AppleScript, 104
arcade game, 7
artificial intelligence (AI), 22, 29, 70, 110, 133, 154-157, 183, 191-197, 235, 247, 251, 294-302, 311
artist, 2, 4, 6
Atari 520ST, 9
audio engineer, 2, 4, 6
authors, 35
Avid Technology, 107-109
Awave Audio, 371-373
Awave Studio, 227-229, 359-367


Team LiB

Index

B

baseball, 5, 28, 83-96
BASIC, 104, 130-132, 311
Batman Forever, 11
Binary Space Partition (BSP), 165, 168-169, 174
Bluth, Don, 9
Broderbund, 13
bug report, 234
bump map, 114, 165


Team LiB

Index

C

Cakewalk, 217-223
Capstone, 13
Carrey, Jim, 11
Carroll, Lewis, 203
casual games, 21-23
chess, 16, 21
Clancy, Tom, 64, 71, 77, 82
ClearCase, 118-119
close quarter battle (CQB), 67, 76, 78, 81
CM Synergy, 119
Code Warrior, 117, 170
Combination Lock, 10
copyright, 51-52
CorelDRAW, 104-105
Crawford, Chris, 13
Criterion Software, 180-186
Cro-Magnon man, 57-59
CroTeam, 178
Curious Labs, 114-116


Team LiB

Index

D

dance, 36
DAT (Digital Audio Tape), 216, 314, 349
Debabelizer, 105-106
Deer Hunter, 56-57
Delphi, 166, 170
design bible, 3, 247
design specification, 3
digital recording, 216, 336, 361
DirectX, 129, 174
Discreet, 113-114
Disney, 215, 328
Doom, 12, 19, 314
Dynamix, 167-168


Team LiB

Index

E

Eclipse Entertainment, 166
educational games, 19, 23-24
Egerter Software, 169-171
Eidos Interactive, 12
Electronic Arts (EA) Sports, 86-87, 89-93
Epic Games, 178-179


Team LiB

Index

F

first-person shooter (FPS), 12, 19, 55-56, 69, 97, 122
First Row Software, 12
FIFO, 133
film, 5, 9, 11, 15, 37-49, 100
film script format,
linear, 200-202
non-linear, 210-211
Flicks: Film Review Library, 6, 126, 313
fog effect, 26, 72-73, 108, 169, 174, 187-188
Foley, 200, 230, 247, 335-336, 338, 347, 350-351, 354
football, 28, 32, 83


Team LiB

Index

G

gambling game, 5, 21-22, 33
game engines, 165
GarageGames, 167-169
General Mills, 84-85
Genesis 3D, 166-167
Geomnastics, 24
golf, 26, 28, 32


Team LiB

Index

H

Hanks, Tom, 36
Hanna Barbera, 215, 230
Hawkins, Trip, 86, 91
history, 34
Hollywood Edge, 231-232
Home Studio, 220
Home Studio XL, 221
Homo erectus, 57-59
Honeymooners, The, 12
Hughes, John, 231
hybrids, 19, 20


Team LiB

Index

I

id Software, 12, 171, 189
Image Eye, 368-369
instrument, 36
Intercorp, 13
Intergalactic Council, 55
Internet, 25, 53-54, 55, 75, 171-173, 233, 252
Interplay, 87-88
inverse kinetics (IK), 112


Team LiB

Index

J

JavaScript, 104, 171-173, 175, 216
Jetsons, The, 14
Jones, Tommy Lee, 11


Team LiB

Index

K

Keaton, Michael, 11
Kennedy, John F., 64


Team LiB

Index

L

Lapine, James, 35
Level of Detail (LOD), 165, 167, 175, 177-178, 188
licensed property, 8-9, 11-12, 14, 22, 24, 89, 98, 216, 237, 245, 312
LIFO, 133
LightWave, 110-112
Linux, 107, 112, 129, 168, 179, 189, 252
LIPFX Mimic, 116
LIPSinc Mimic, 116
literature, 35
LithTech, 176-177
looping, 200
Lost Kingdoms, 55-56
LucasFilm, 215, 230, 327


Team LiB

Index

M

MacIntosh, 106, 110, 115, 117, 168, 177, 179, 189, 217, 221-223, 314, 320
Marx, Groucho, 12
Mathathon, 24
Maya Complete, 106-107
Maya Personal Learning Edition, 106-107
Maya Unlimited, 106-107
Medical Kombat, 100-101
Merant, 118
mesh, 82, 108, 109, 114, 166
Metro 5, 221-223
Microsoft, 86, 87, 89-90, 103, 104, 113, 117, 119, 169, 228, 234, 361, 369, 370, 373
Microsoft Flight Simulator, 27
Microsoft Visual BASIC, 130-132, 141, 142-154, 166, 170, 171, 172
Microsoft Visual C++, 109, 130-132, 141, 154-164, 166, 169, 170, 171, 172, 175, 186, 187
Microsoft Xbox, 52, 77, 86-87, 97, 99, 101, 109, 113, 177, 179, 180, 181, 185, 186, 187, 188, 238
MIDI, 222, 225, 229
Min-Max gaming theory, 133-141
mipmap, 165, 169, 181, 188
Monolith, 176-177
multiplayer, 16, 19, 25, 68-69, 174-175, 233
assassin mode, 81
capture the flag, 68
cooperative, 68
deathmatch, 68
king of the hill, 68
music, 4, 10, 24, 36, 91, 169, 184, 200, 207, 215-232, 237, 252, 256, 259-260, 278, 312, 316, 317-356
musicians, 2


Team LiB

Index

N

Navy SEAL
games, 68-83
history and background, 64-68
Neanderthal, 57-59
NetImmerse 3D, 186-189
NewTek, 110-112
Nintendo Gameboy, 86-87, 101
Nintendo GameCube, 52, 86-87, 97, 99, 101, 179, 180, 181, 186, 187, 238
Nocturne Engine, 177
non-player character (NPC), 79, 183, 191, 202, 235, 295, 302
Non-Uniform Rational B-Spline (NURB), 106-108, 114
Numeric Design, 186-189
NXN Software, 116-118


Team LiB

Index

O

O’Hara, Mark, 166
one pager, 97-98
examples, 98-101
OpenGL, 106, 113, 129, 168
Othello, 15, 21, 33, 133


Team LiB

Index

P

Paint Shop Pro, 104
pathfinding, 193-197
Patton Strikes Back, 13
Pedersen, Megan, 98-99
Pedersen, Roger E., 2, 3-10, 12, 51, 52, 201, 205, 208, 248, 311-316
PC (personal computer), 9, 52, 129
pixel shading, 167, 169, 176, 181
platform games, 19
pointillism, 35
poker, 22-23, 33-34, 60-63, 193, 247-306, 313, 357-358
Poser, 114-116
Potentially Visible Set (PVS), 166, 169, 181, 186
POV (point of view), 19, 28-29, 53, 71, 78, 90, 92, 99-100, 122, 126, 165
Power Render 4, 169-171
producer, 3-8
programmer, 1, 2, 4, 6
Pryor, Richard, 15
puzzle, 1, 5, 16, 19, 20-21, 30, 199, 314, 316
PVCS, 118


Team LiB

Index

Q

Q3Radiant, 189
QA (Quality Assurance) tester, 4, 6, 11, 233, 313-314
Quake, 19, 78, 103, 167, 314
Quake 2 Engine, 12, 171
Quake 3 Engine, 12, 110, 167, 189
queue, 132


Team LiB

Index

R

rail games, 19
Rational Software, 118-119
RenderWare, 180-186
role-playing game (RPG), 5, 16, 19, 23, 25, 36, 55, 56, 121, 189, 193
Romero, John, 12


Team LiB

Index

S

scheduling, 7, 211-213
science, 34
Scorsese, Martin, 231
script cover page, 201-202
SEAL, see Navy SEAL
Search for the Titanic, 13
Serious Engine, 178
Seurat, Georges, 35-36
SFX Libraries, 229-232, 317-356
side scroller game, 19
simulation game, 5, 19, 26-27, 29, 34, 55, 56, 57-59, 68
SoftImage, 103, 107-109, 112, 117
SONAR, 217-219
SONAR XL, 219-220
Sondheim, Stephen, 35
Sonic Foundry, 223-227
SONY Playstation, 184
Sound Forge, 223-225
Sound Ideas, 229-231
Southpeak Entertainment, 14
SpeechFX Mimic, 116
sports game, 5, 15-16, 19, 24, 28, 31-33, 36, 52, 83-96
stack, 132
Star Trek, 20
Starbase, 119
StarTeam, 119
Stone, Oliver, 231
strategy games, 16, 19, 29, 64-83
subdivision surfaces, 108
Summagraphics tablet, 10
Sunday in the Park with George, 35-36
Survival of the Fittest, 56-59
system requirements, 74, 79, 92-93, 106, 113, 115, 116, 222


Team LiB

Index

T

Telelogic, 119
Terminal Reality, 177
texture, 165, 181, 188
Tic-Tac-Toe, 134-164
Todd/Soundelux Studios, 231
Tolkien, 20
Torque Engine, 167-169
twitch games, 19, 238, 245
Two Heads game, 54


Team LiB

Index

U

Universal Studios, 215, 230, 327-328
UnrealEd, 179
Unreal Engine, 82, 103, 110, 167, 178-179


Team LiB

Index

V

Vegas Video, 227
vertex shading, 114, 169, 176, 181
Villa Crespo Software, 6, 10, 247, 313
Voltaire, 237, 238


Team LiB

Index

W

Walker Boy Studio, 122
War Between the States, 122-125
Warner Brothers, 215, 230, 314, 329
WAV files, 218, 220, 229
Web Driver, 171-175
WildTangent, 166-167, 171-175
Windows 2000, 129
Windows 95, 74, 106, 115
Windows 98, 129
Windows CE, 129
Windows NT, 129
Windows XP, 129
World-Wide Reporter, 23


Team LiB
Previous Section

CD Content CD Content

Following are select files from this book's Companion CD-ROM. These files are for your personal use, are governed by the Books24x7 Membership Agreement, and are copyright protected by the publisher, author, and/or other third parties. Unauthorized use, reproduction, or distribution is strictly prohibited.

Click on the link(s) below to download the files to your computer:

File | Description | Size
All CD Content | Game Design Foundations | 349,574
Vbtictactoe |  | 33,243
Other Content |  | 298,113
Team LiB
Previous Section